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vi  Preface

Included with Your Textbook Purchase
Depending on your purchase option, some or all of the following are included with your textbook:

Interactive ebook: A dynamic, engaging, and truly interactive textbook that includes elements such as 
videos, self-assessments, slide shows, GIFs, and other interactive features. Highlighting, taking notes, 
and searching for content is easy. 

eLab Course Management System: A robust tool for accurate assessment, tracking of learner activity, 
and automated grading that includes a comprehensive set of instructor resources. eLab can be fully 
integrated with your LMS, making course management even easier.

Instructor resources: This course is also supported on the Labyrinth website with a comprehensive 
instructor support package that includes detailed lesson plans, lecture notes, PowerPoint presenta-
tions, a course syllabus, test banks, additional exercises, and more.

Student Resource Center: The exercise files that accompany this textbook can be found within eLab 
and in the Student Resource Center, which may be accessed from the ebook or online at:  
labyrinthelab.com/office19

We’re excited to share this innovative, new approach with you, and we’d love you to share your 
experience with us at: lablearning.com/share

Visual Conventions
This book uses visual and typographic cues to guide students through the lessons. Some of these cues 
are described below:

Cue Name What It Does

Type this text Text you type at the keyboard is printed in this 
typeface.

Action words The important action words in exercise steps are 
presented in boldface.

Ribbon Glossary terms are highlighted with a yellow 
background.

Note!  Tip!  Warning! Tips, notes, and warnings are called out with  
special icons.

 
Videos, WebSims, and other ebook or online 
content are indicated by this icon.

Command→Command→ 
Command→Command

Commands to execute from the Ribbon are 
presented like this: Ribbon Tab→Command  
Group→Command→Subcommand.

Í Design→Themes→Themes These notes present shortcut steps for executing 
certain tasks.

Display Settings
Multiple factors, including screen resolution, monitor size, and window size, can affect the appearance 
of the Microsoft Ribbon and its buttons. In this textbook, screen captures were taken at the native 
(recommended) screen resolutions in Office 2019 running Windows 10, with ClearType enabled. 
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L E A R N I N G  O B J E C T I V E S

Ý Create and modify relationships

Ý Format a table datasheet layout

Ý Modify table structures

Ý Set field properties

Ý Use the Lookup Wizard

5 Refining Table Design

ACCESS

I
t’s important to understand 

what makes Access a relational 

database management system 

and why properly designed databases 

perform better. Well-designed databases 

reduce redundant data and create critical 

connections between the objects that help 

make them more efficient. In this chapter, 

you will develop important database table 

relationships and use tools to help speed 

data entry and ensure data accuracy.
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132 Access Chapter 5: Refining Table Design

Project: Maintaining and Formatting Databases
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You are tasked with maintaining the company’s database. After 
reviewing the objects in the database, you decide to make some changes that will make the 
database more efficient and improve data entry. You will create a lookup field to streamline 
data entry. In the process, you will add formatting to make the tables more colorful. You will 
then examine the relationships between tables to ensure they accurately define the database.

Creating and Modifying Relationships
As you build tables and other objects in a relational database, Access creates some of the relation-
ships between tables based on each table’s field structure. It’s a good idea to examine and edit these 
relationships manually. For example, you may choose to cascade updated or deleted records, that is, 
to automatically update or delete all affected records as part of a single operation.

Cascade options can be invaluable in cases in which a store pulls a product off its shelf and therefore 
needs to remove that product from its merchandise list, order list, inventory list, and advertising list. 
In most cases, you also must enforce referential integrity to ensure relationships between records in 
related tables are valid. Finally, it may be wise to create and display those relationships in a report to 
add to the database documentation.

Relationship Types
Database relationships connect data in one table to data stored in other tables. Access supports 
three different types of relationships:

 Ý A one-to-one relationship means each record in Table A can have only one matching record in 
Table B, and each record in Table B can have only one matching record in Table A. This is the least 
common relationship.

Example: A main Customers table linked to a CustPassword table (one customer has one 
password)

 Ý A one-to-many relationship means each record in Table A can have multiple matching records 
in Table B, but a record in Table B can have only one matching record in Table A. This is the most 
common relationship.

Example: One employee will have many sales, and a product will be sold many times

 Ý A many-to-many relationship occurs when two tables may each have many matches in the 
other table but they do not share key fields, so they use a third junction table to connect the two 
tables, completing the relationship. The junction table has a one-to-many relationship to each table.

Example: A Vendors table and a Products table, where one vendor provides many different products 
and one product is available from many vendors

Adding and Modifying Relationships
There are times when a database designer must add or edit a relationship. You can examine, create, 
edit, and delete relationships between tables in the Relationships window. The Show Table command 
in the Relationships window displays the Show Table window containing a list of tables and their fields. 
Tables are added to the Relationships window with a click of the Add button. Fields from one table 


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Creating and Modifying Relationships 133

added to the Relationships window can be dragged and dropped onto a field in another table to begin 
creating a relationship between those fields. Conversely, relationships can be edited by selecting the 
join line between the relational fields and using the Edit Relationships command on the Ribbon.

Í Database Tools→Relationships→Relationships 

Í Relationship Tools→Design→Tools→Edit Relationships 

The Edit Relationships Box
The Edit Relationships dialog box displays the tables and fields involved in the relationship along with 
options for establishing referential integrity, cascade protocols, and the relationship type being created. 

Table fields to be joined

Relationship options

Type of relationship to be created

One-to-many join line

A
C
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Creating and Modifying Relationships 135

DEVELOP YOUR SKILLS: A5-D1

In this exercise, you will open the Relationships window, add a table, and create a relationship between 
tables with referential integrity enforced.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

 1.  Open A5-D1-WinDesign from your Access Chapter 5 folder and save it as: 
A5-D1-WinDesignRev

When completing exercises, always choose to Enable Content.

 2.  Choose Database Tools→Relationships→Relationships .

 3.  Choose Relationship Tools→Design→Relationships→Show Table .

 4.  Double-click the EmpSpouses and All_Customers tables to add them to the Relationships 
window and then close the Show Table box.

Typically, all tables will be in the Relationships window, but sometimes tables are added later.

 5.  Rearrange the tables in the Relationships window by dragging their title bars so they are 
arranged as shown.

Arranging the tables this way helps you see all the relationships, as the relationship lines are not 
overlapping.

A
C
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Creating and Modifying Relationships 137

Deleting Relationships
To modify tables after relationships have been set, you must temporarily delete existing relationships 
so Access is free to make the revisions without violating integrity rules. For example, say you have an 
existing Short Text data type field, such as State, and you want to change it to a Lookup data type. If 
you attempt to change its data type, Access will warn you that you must first delete its relationships 
to any other tables. After you delete the relationship and change the field’s data type, you may have 
to reestablish the relationship and edit those relationship properties.

DEVELOP YOUR SKILLS: A5-D2

In this exercise, you will edit the relationship between the Employees and Invoices tables so if you change 
the Employee ID in the primary table (Employees), Access will update the Employee ID in the related 
foreign table (Invoices).

 1.  Right-click the join line between the Employees table and the Invoices table and choose Edit 
Relationships.

The mouse pointer must be right on the join line or you won’t see the Edit Relationships option on the 
right-click menu.

 2.  Check the Cascade Update Related Fields checkbox and click OK.

 3.  Right-click the join line linking the ProdID fields in the Products and InvoiceDetails tables.

Your mouse pointer must be directly on the line for the menu to appear.

 4.  Choose Delete and then click Yes to confirm the deletion.

 5.  Choose File→Save or click the Save button to save the relationship changes.

Documenting and Printing Relationships
After you have inspected the relationships, you may want to create a report to view a printable 
version of them. You can also display the database objects that make use of, or are used by, other 
objects in the database. This is done through the Object Dependencies panel.

Í Database Tools→Relationships→Relationships→Relationship Report 

Í Database Tools→Relationships→Object Dependencies 

DEVELOP YOUR SKILLS: A5-D3

In this exercise, you will create a relationship report and examine object dependencies for the Employees 
table.

 1.  Choose Relationship Tools→Design→Tools→Relationship Report .

 2.  Choose Print Preview→Page Layout→Landscape  so all tables and relationships are 
shown.

 3.  Save the report as: Relationships

The report is added to the Report group in the Navigation pane.

 4.  Close the report and then close the Relationships window.

A
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138 Access Chapter 5: Refining Table Design

Display Object Dependencies
 5.  Select the Employees table in the Navigation pane 

without opening it.

 6.  Choose Database Tools→Relationships→Object 
Dependencies .

 7.  Ensure the Objects That Depend on Me option is 
selected in the Object Dependencies panel.

The objects listed below each type are dependent on the 
Employees table.

 8.  Choose the Objects That I Depend On option.

The Employees table has relationships with, or depends on, 
the EmpSpouses, Invoices, and States tables.

 9.  Close the Object Dependencies panel.

Modifying Table Structures
Database integrity and data validity are important aspects of database maintenance. Access features 
that enable you to modify table fields, control the data entered, and format the data to ensure 
consistent reporting include but are not limited to:

 Ý Renaming tables, forms, and other database objects

 Ý Adding and removing fields from tables

 Ý Changing data types

Renaming Tables and Adding, Deleting, and Editing Table 
Fields
As you create tables, you define each field by setting the data type and entering the field name. 
Access works behind the scenes and sets default properties for the field that limit the number of 
characters in a field, as well as the format and data type of characters valid for the field. You can 
accept the default properties Access sets or modify the properties. Properties available depend on 
the data type selected for the field. Take care when adding, deleting, or editing fields because of the 
impact such actions might have on the table data.

Renaming Tables
When you save a table, give it a name that describes the data it contains. You can change the name 
later without affecting its data, but note that table names are often included in other database 
objects that use the table’s data, which means renaming a table can impact other database objects. 
Access should automatically update the name of the table used in other database objects. However, 
if you rename a table, you should make sure that every form, query, or report that uses that table 
still functions the same.
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Modifying Table Structures 139

A good database design principle is to name all your tables in a similar fashion, for example, using 
the underscore between words in all tables named with more than one word (Invoice_Details). 
Traditionally, spaces are not used in table names because referencing the table in a query or 
entering the table name in an expression could be confusing. For instance, is Invoice Details two 
objects or one object? Fortunately, Access will enclose a table name like Invoice Details in [square 
brackets] when it uses it in an expression.

Adding Fields to Existing Tables
Periodically you will need to create new fields in existing database tables and then add data to these 
fields. You can add a field either in Datasheet View or in Table Design View and then move it where 
you want it to be in the layout.

Deleting Fields
When you delete a field that contains data, Access displays a warning that deleting the field will 
remove all its data. If you delete a field in Design View and have not saved the table, you can recover 
the deleted field using Undo. If, however, you save the table after deleting the field, the data is lost, 
and you have to add the field name to the Table Design and then reenter all field data in the table to 
restore the data. Fields are deleted in Design View by clicking the field header and tapping [Delete].

Editing Field Data Types
Many Access data types start with a different letter, which means you can type a letter, and the data 
type that begins with that letter will display. For example, if you want to change the data type of a 
field from Short Text to Number, you click in the field’s Data Type and type N.

Any time you change the data type of a field that contains values that fail to conform to the new 
data type, Access deletes any nonconforming data. For example, if you change a field’s data type 
from Short Text to a Number data type and someone has accidentally entered 1O (using a capital 
O) instead of 10 (using a zero), Access will warn you that you are about to delete data that did not 
conform, thus the entry made using the capital O will be removed after the change is confirmed. 
The great thing about this is that Access will allow only valid field data, which results in more 
accurate data.

The Yes/No Data Type
The Yes/No data type sets the field so only two entries are possible: Yes/No, True/False, or On/Off. 
When you set the Yes/No data type for a field, Access places a checkbox for the field in the datasheet 
and on forms where the data appears. Checking the checkbox indicates a value of Yes, True, On, etc.; 
clearing the checkbox indicates a value of No, False, or Off.

DEVELOP YOUR SKILLS: A5-D4

In this exercise, you will rename a table, delete a table field, add a table field, and modify the data type of 
a field.

 1.  Right-click the All_Customers table in the Navigation pane and choose Rename.

 2.  Type Customers and tap [Enter].

 3.  Open the Customers table and switch to Design View.
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140 Access Chapter 5: Refining Table Design

 4.  Click the field selection box on the left edge of the Notes field to select the field.

 5.  Tap [Delete] and choose Yes to confirm.

The field and any data within it have been permanently removed from the database. However, before 
continuing, you could use Undo to restore the field and data because you made the deletion while 
working in Design View.

Add New Fields
Now you will add a Yes/No field to the Customers table.

 6.  Right-click the CustStreetAddress field selection box and choose Insert Rows.

A new row opens above the CustStreetAddress row.

 7.  Click in the empty Field Name box of your new field and type: Business

 8.  Tap [Tab] and set the data type to Yes/No.

 9.  Save the table and then switch to Datasheet View.

Your new Yes/No Business field has all boxes unchecked, which means it is set to No.

 10.  Check the Business field boxes for the records with these CustIDs: DavisP, HassanA, and 
KleinJ.

These records are now identified as having a business.

 11.  Close the Customers table.

Formatting a Table Datasheet Layout
If field values are longer than anticipated, Access displays only the portion of the data that fits within 
the column width, hiding some of the data. Or the opposite scenario may occur, in which one or two 
fields were added and you need to display all the fields on one screen, which means you may have to 
modify the width of each column to fit the screen. Alternatively, you can maximize the Access window 
or close the Navigation pane to provide more room without having to modify the width of each 
column.

Changing the Width of Columns
Access offers some useful techniques to adjust the width of each column in a datasheet to display all 
data in the column:

 Ý Drag a column border: Drag a column border to make the column on the left of the border 
wider or narrower.

 Ý Double-click a column heading border: Double-click the right border of a column to change 
the width of the column on the left to fit either the longest data entry in the column or column 
heading, whichever is wider.

 Ý Right-click a field heading and choose Field Width: Select the Field Width command from 
the context menu to open the Column Width dialog box and type the width, reset the standard 
width, or select Best Fit to automatically size the field width to the longest entry.
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Formatting a Table Datasheet Layout 141

Moving and Hiding Data Columns
There will be times when you want to reposition a column of data in a table layout—perhaps to display 
the email address before the telephone number. When you rearrange the columns in a datasheet, 
the table layout remains the same but the fields display in a different order in the datasheet. You may 
also want to hide some columns so you can better view other field columns. When you hide columns, 
Access temporarily removes them from display, but the data remains in the table—it’s not deleted. If 
you want to view data in hidden columns later, unhide the column.

Saving a Table Layout
Changing the layout of a table datasheet has no real effect on table data or structure; however, 
when you make changes to a table datasheet, Access recognizes the differences between the  
structure of the table and its layout and prompts you to save the changes to the layout when 
you close the table. If you abandon the changes, the next time you open the table datasheet, the 
column widths will return to their original size and any columns that were hidden will show. If you 
save the changes, the next time you open the table datasheet, Access recalls the layout and displays 
the formatting changes.

DEVELOP YOUR SKILLS: A5-D5

In this exercise, you will adjust the column width to allow for the best display of data in a datasheet. You 
will also rearrange columns and hide a column.

 1.  Display the Customers table in Datasheet View.

 2.  Position the mouse pointer over the border between the Street Address and City column headings 
so the adjust pointer appears as a double-headed arrow.

 3.  Double-click and notice that the Street Address column width adjusts to fit the widest entry in 
the column.

 4.  Position the mouse pointer on the CustID column heading and then drag 
right to select both the CustID and Last Name columns.

 5.  Position the mouse pointer between the column headings and double-click 
when the adjust pointer appears.

Both columns will be Best Fit.

 6.  Click the First Name column heading to select the column. Do not release your mouse button.

 7.  Drag the First Name column to the left of the Last Name column, releasing the mouse button 
when the black vertical bar is between the CustID and Last Name columns.

The First Name column should now be before the Last Name column.
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142 Access Chapter 5: Refining Table Design

 8.  Click the table selection button to select all data.

 9.  Double-click the border between any of the selected column headings to Best Fit all columns.

 10.  Save the layout changes.

Enhancing a Datasheet
Changing the datasheet layout enables you to make necessary adjustments, such as widening a field 
so a longer value can be fully displayed. Enhancing the datasheet layout enables you to improve its 
readability. Some of the features you can apply to enhance a datasheet include gridlines, font size and 
color, and background color.

As you apply enhancements to the datasheet, Access formats all data and gridlines to match the 
format you choose. The Text Formatting group on the Home tab displays tools for enhancing the 
most commonly formatted features on a datasheet such as fonts, colors, fills, and alignments. It 
also contains tools for formatting alternate rows and gridlines. Finally, you can find more formatting 
options in the Datasheet Formatting dialog box (launched from the Text Formatting group).

Gridline formatting
Alternate row formatting

Dialog box launcher opens the Datasheet Formatting box

Í Home→Text Formatting

DEVELOP YOUR SKILLS: A5-D6

In this exercise, you will use the Text Formatting tools to set datasheet enhancement options for the 
Customers table.

 1.  Choose Home→Text Formatting→Alternate Row Color  menu button �.

 2.  Choose Blue, Accent 1 (the fifth color on the top row under Theme Colors).

Alternate rows in the datasheet should now be blue.

 3.  Choose Home→Text Formatting→Font menu button � and choose Arial from the list.

All table data should now be formatted with the Arial font.

 4.  Choose Home→Text Formatting→Gridlines  menu button � and choose Gridlines: 
Horizontal.

The datasheet will display only horizontal gridlines now.
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Setting Field Properties 143

 5.  Click the dialog box launcher at Home→Text Formatting to open the Datasheet Formatting 
dialog box.

 6.  Click the Gridline Color menu button � and choose Black, Text 1 (second color on the top 
row of Theme Colors).

 7.  Click OK to apply the black gridlines.

 8.  Save the changes to the Customers table.

Setting Field Properties
Use field property settings to further define the properties of each field. The Field Properties pane 
appears in the lower portion of the Table Design View or on the Fields tab in Datasheet View. 

COMMON FIELD PROPERTIES

Field Property Description
Field Size Sets a field length for the number of characters each field can hold

Format Sets a predefined display layout for fields (that is, currency or percent)

Input Mask Identifies the format of values entered—with hyphens or without, 
alphabetic or numeric, uppercase or lowercase, etc.

Caption Sets a column heading title to describe the data content better than the 
actual field name and includes spaces where appropriate

Default Value Adds a default value for a specific field in each record, such as FL for the 
State field, abbreviated as “ST”

Validation Rule Controls actual values entered into a field, such as less than 100 or greater 
than 01/01/2017

Validation Text Provides a tip that identifies valid data entries, such as “All dates must be 
after 01/01/2017”

Required Sets the field as required to ensure a value is entered in the field

Why Set Field Properties?
Different people add data to databases—and they often enter the data using varying formats. 
For example, some people type parentheses around the area code when entering phone numbers. 
Others may separate the area code from the number using a hyphen. Both formats are accurate, but 
displaying mismatched data can be distracting. Entering parentheses or hyphens can also be time-
consuming. Setting field properties to control how data appears helps maintain data consistency 
throughout a database.

Set Field Sizes, Captions, and Default Values
Maintaining database integrity, data validity, and data format are important considerations when 
building a database. You should make every effort to ensure that data is entered consistently, 
contains the required number of characters, and falls within valid data ranges.
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144 Access Chapter 5: Refining Table Design

Setting Field Size
Rather than using a default field size, you can set the Field Size property to limit the number of 
characters that can be entered into the field for each record. For example, you can limit data entry of 
state names to the two-character state abbreviation.

Sometimes, when you reduce an existing field size to limit data entry, Access warns that data may be 
lost due to the reduced field size. In most cases, you are familiar with the data, so you can choose Yes 
to continue. For instance, truncating Florida to FL would not create invalid data. However, if you are 
uncertain, you should choose No, check the data to ensure that it fits the new limit, and then set the 
field size.

Identifying Field Size for Number Fields
Number fields are identified by special formats in the Properties panel. In general, number fields 
should be set to define the largest value anticipated for the field. Setting the proper field size controls 
for number fields helps optimize database performance.

NUMBER FIELD FORMATS

Field Size Property Description
Byte Stores whole numbers between 0 and 255 using 1 byte and allows 

no fractions or decimal points; uses the minimal amount of memory, 
allowing for the fastest processing

Integer Stores whole numbers between –32,768 and 32,767 using 2 bytes rather 
than the standard 7 bytes normally used for high values

Long Integer Stores whole numbers between –2,147,483,648 and 2,147,483,647 using 
4 bytes rather than the standard 14 bytes normally used for high values

Single Stores positive and negative numbers to exactly seven decimal places 
using 4 bytes

Double Stores positive and negative numbers to exactly 15 decimal places 
using 8 bytes

Replication ID Identifies replication of tables, records, and other objects in Access 
2003 or earlier databases using 16 bytes

Decimal Stores positive and negative numbers to exactly 28 decimal places 
using 12 bytes

Setting Text to Uppercase or Lowercase Format
Text fields have unique field properties available for formatting data. Access provides a Format field 
that enables you to force a specific format to all characters in the field. The most common format 
characters are used to force uppercase (>) and lowercase (<). Using the Text Format property elimi-
nates the need to spend valuable time entering multiple characters in the Input Mask property.

Setting Captions
As you may have noticed, many field names contain no spaces or include an underscore, such as  
LastName or Last_Name. The Caption field property enables you to type a more descriptive name for 
a field that is more suitable for display on forms, in datasheets, and on reports—such as Last Name.
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Setting Default Field Values
Validation rules control the data you enter in table fields. Setting a default value for a field automatically 
enters the most common data value and can save time and help reduce the number of errors made 
during data entry.

For instance, all the employees at Winchester Web Design live in Florida. Consequently, it saves time 
and reduces inconsistency when the default value for the State field is set to FL. The default value 
appears whenever a new record is added. If you need to enter a different state, you simply type in the 
new state’s two-character abbreviation to replace the default value.

Making a Field Required
Whenever you create a primary key field, its properties are automatically set to be required and 
indexed, allowing no duplicates. A database index is a structure whose main function is to speed up 
database operations. An index that is set on key fields enables faster searches and retrieval of data.

A key field must have a value; by default, every other field does not require that a value be entered. 
There are times, however, when non-key fields must have values. For instance, you must include an 
employee last name and first name when entering a new record into your Employees table. The 
Required field property helps to easily accomplish this.

DEVELOP YOUR SKILLS: A5-D7

In this exercise, you will set field sizes, captions, and default values in the Customers table.

 1.  If necessary, open the Customers table and switch to Design View.

 2.  Click anywhere in the CustState field and set these field properties:
• Field Size: 2
• Format: >
• Caption: ST
• Default Value: FL

Entering > for the Format property converts entries to uppercase. Access places quotation marks 
around the Default Value field property when you click in another field property or save the table. 
Setting field sizes consistent with the data they hold helps the data display properly when it’s included 
in forms and reports.

 3.  Click anywhere in the CustLastName field and change the field size to 25 and the required 
property to Yes.
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146 Access Chapter 5: Refining Table Design

 4.  Click anywhere in the CustPhone field and change the field size to 15 and the required property 
to Yes.

 5.  Choose File→Save. For both the Some Data May Be Lost message and the Data Integrity Rules 
Have Been Changed message, choose Yes.

 6.  Switch to Datasheet View and enter this data in a new record:

Field Data to Enter

CustID JonesK

First Name Ken

Last Name Leave this field blank.

Business Check the box to set it to Yes.

Street Address 2300 Maple Ave.

City Palmetto

ST This field already shows FL because you set FL as the default value.

ZIP 34628

Telephone Leave this field blank.

Email KJones@email.com

 7.  Tap [Tab] after entering the email address.

You are prompted to enter a value for the Customers.CustLastName field because you made it a 
required field.

 8.  Click OK, select the Last Name field, and type: Jones

 9.  Tap [Tab] through the remaining record fields. 

You are prompted to enter a value for the Customers.CustPhone field, since it is also a required field.

 10.  Click OK and then tap the left arrow [¢] to select the Telephone field; type 9415553232 and 
tap [Tab].

Access automatically applies parentheses, ( ), to the area code and a hyphen, -, after 555.
 

Custom Text and Memo Field Formats
Standard field formats in Access cannot meet the needs of every text or memo field contained in 
every database. That’s why Access provides tools for creating custom formats. Custom formats for 
Text and Memo fields can contain two sections:

 Ý Section 1 contains a symbol and is followed by a semicolon when a second section is entered.

 Ý Section 2 contains the value of the alternate value when no value is entered. This alternate is a 
null value and is enclosed in quotation marks with no space between: “”.

An example of a two-section format for a text field would look like this: @; “N/A”

The @ symbol tells Access to display the field data if a value is entered, and N/A tells Access to 
display N/A (Not Applicable) if no value is entered. The @ symbol displays all characters that will fit 
the Field Size property, and if there are fewer characters than the Field Size value, Access pads the 
rest of the field with blank spaces.
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Short Text and Long Text Field Unique Properties
Text and Memo fields are formatted to hold text characters (abc), symbols (#$%), and numbers (123) 
on which no mathematical calculations will be performed, such as FirstName, LastName, City, and 
also ZIPCode, PhoneNumber, and SocSecNumber. Because of the broad scope of data that these 
data types can contain, Access provides several field properties for controlling and formatting data 
entry in the field.

SHORT TEXT AND LONG TEXT FIELD UNIQUE PROPERTIES

Property Description
Allow Zero Length This allows data entry of zero length in a field. Data is entered as open 

and close parentheses with no character between: (). This entry shows 
that there is no value to enter. For example, if you have a field in a 
Customers table that requires a land phone number and the customer 
has no landline, enter () in the field.

Text Format This property sets the text in a Long Text field as Plain Text or Rich Text. 
Rich text fields can be formatted with different font types, sizes, and 
colors.

Text Align This positions the text on the left, center, or right side of the field box or 
column. The Distribute setting spreads out the text to fill the column or 
text box size.

Append Only This adds a series of date-stamped comments to a single Long Text field, 
making it easy to create a history log of comments added to the fields. 
These comments are stored in a separate table and accessed through 
the Append Only Long Text field.

Entering Field Properties
Access provides three basic techniques for setting field properties:

 Ý Type the value into the property box.

 Ý Choose the value from the property list. (For example, click the drop-down menu button to select a 
valid entry from the list.)

 Ý Click the Build button at the right side of a field property to open the Wizard associated with that 
property and choose the desired settings. For example, click the Build button to open the Input 
Mask Wizard to format the display of text and field dates.

DEVELOP YOUR SKILLS: A5-D8

In this exercise, you will set additional properties to require the entry of a customer’s first name.

 1.  Display the Customers table in Design View.

 2.  Click anywhere in the CustFirstName field and type @ for the Format field property.

Using the @ symbol will display all characters that fit within the field size and pad any remaining 
positions with spaces.
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 3.  Choose Yes in the Required field property and No in the Allow Zero Length field property to 
prohibit a null value from being entered.

These settings will require a CustFirstName to always be entered.

 4.  Choose File→Save and choose Yes when advised that the data integrity rules have been 
changed.

 5.  Switch to Datasheet View.

 6.  Click in the CustID field of the new, blank record at the bottom of the table and type: SmithA

 7.  Type Smith in the Last Name field and then close the Customers table.

A message informs you that you must enter a value in the CustFirstName field. This is because you set 
the Allow Zero Length property to No, which requires an entry of at least one character to be made.

 8.  Click OK to dismiss the message and then click Yes to close the database object (Customers 
table) now.

The table will close and the new record you started to enter will not be saved.
 

Formatting Data Using Input Masks
Consistency of data format is important for visual aesthetics; it also helps ensure accuracy in 
searches, queries, and sorts. You can control data formats using the field property input mask. Using 
input masks, you can set the characters you want displayed in fields, such as the parentheses in an 
area code, and Access requires the user to enter the data within that format. 

The Input Mask Wizard
The Input Mask Wizard is a valuable tool for setting the most common formats used in databases. 
You can also set input masks to require a specific number of characters in a field or to convert 
characters to capital or lowercase.

Setting input masks ensures that the data format in tables is consistent. Because the table data is 
consistent, data displayed in forms and reports will also be consistent.

Input masks can automatically format unformatted data.

The Build  button that appears at the right end of the Input Mask box when you click the box 
starts the Input Mask Wizard, which helps you build the mask.
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Input Mask Symbols
When you use the Input Mask Wizard, Access places the necessary coding into the Field Properties 
pane. Access uses several symbols to control the appearance of data.

INPUT MASK SYMBOLS

Symbol Description Example
0 Requires a numeric digit (000) 000-0000 requires an area code as 

part of the phone number.

9 Data is optional but must be a digit (999) 000-0000 requires a seven-digit 
phone number with an optional three-digit 
area code.

# Restricts data to a digit, +, -, or space #99.99 permits + or – in the position of the #.

L Requires an alphabetic character (that is, a 
letter)

LL requires the entry of two alphabetic 
characters in the State field.

? Restricts, but does not require, data to 
alphabetic characters

L????L requires two alphabetic characters, 
one on each end of the data, but permits 
four additional alphabetic characters 
between.

A Requires an alphabetic or numeric 
character

000-AAAA permits a phone number to be 
entered either as 555-1234 or 555-HOME.

a Allows, but does not require, alphabetic or 
numeric characters

(aaa) AAA-AAAA requires a seven-digit 
phone number but not the area code.

& Requires any alphanumeric character (letter 
or number) or a space

&&&& permits data entry such as a four-
character ID along the lines of 01HP, 1 HP, 
or 1234.

C Allows, but does not require, any character 
or space

CCCC could contain an entry such as 01HP, 
1 HP, HP, etc.

.,:;-/ Characters used to separate parts of 
numeric, date, time, and currency values

#,###.## permits numeric data.

99/99/00 permits date data.

99:00:00 permits time data.

< Converts characters to lowercase <aaa permits entry of three characters such 
as ABC and converts data to lowercase abc.

> Converts characters to uppercase >aa permits entry of two characters such as 
fl and converts the data to FL.

! Displays input mask characters from right 
to left

!(#) 000-0000 right-aligns the phone 
number so if only seven numbers are 
entered, the area code is left blank. This 
affects fields defined with the Number data 
type.

\ Causes characters that follow the \ to 
display as literal characters

(\A) appears as (A).

“Literal Text” Places text between the quotation marks 
into the field value at the identified position

“ID-”0000 places ID- before the numbers 
entered. A space may be enclosed in quotes 
to ensure it appears in the value.

Password Creates a password entry text box; any 
character typed in the text box is stored as 
a character but displays as an asterisk (*)

When passWord1! is typed, Access shows 
**********.
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Storing Input Mask Characters
Access provides two methods for storing the input mask with the table data—with or without the 
symbols. Storing the symbols with the data increases the size of the database file. Therefore, companies 
that store extremely large volumes of data often prefer storing the data without the input mask symbols. 
You can choose one of these methods while running the Input Mask Wizard.

Using Smart Tags
As you work in Access, you will periodically see smart tags, such as the Paste Options smart tag, 
which you may have seen in Word and other Microsoft applications. Smart tags allow you to apply 
formatting changes you make to a field in one table to the same field anywhere else it occurs in the 
database. For example, if you modify the field format properties in a table, the Property Options 
smart tag lets you apply the same format changes to the field when it appears in other forms, 
queries, and reports. This helps ensure data consistency throughout the database.

DEVELOP YOUR SKILLS: A5-D9

In this exercise, you will set the primary key, change a field size, and apply a custom input mask to a field in 
the Products table. Then you will apply a standard telephone input mask to a field in the Employees table.

 1.  Open the Products table in Datasheet View.

The ProdID field consists of two numeric characters and two alphabetic characters.

 2.  Switch to Design View and click the Primary Key  button to make ProdID the primary key field.

 3.  Click in the Input Mask field properties box and type “PROD-”00AA (use zeros and not the 
letter O for 00).

This input mask formats the ProdID field to automatically begin with PROD- followed by two 
numbers and then two letters.

 4.  Choose File→Save and the Property Update Options smart tag will appear next to the input 
mask you just entered.

 5.  Click the smart tag  and choose Update Input Mask Everywhere ProdID Is Used.

Access displays the Update Properties dialog box, which contains a list of all objects using the field. 
For this field, only one object is listed.

 6.  Click Yes to update the Products Report object and then switch to Datasheet View.

The ProdID field now has PROD- preceding each product ID.

 7.  Close the Products table.

Use the Input Mask Wizard
Now you will apply a standard input mask format to a field.

 8.  Open the Employees table in Datasheet View.

The Telephone field contains numbers without any other symbols.

 9.  Switch to Design View and click anywhere in the EmpPhone field.

 10.  Click in the Input Mask field property box and then click the Build  button on the right side 
of the box.

 11.  Choose Phone Number as the input mask and click Finish.
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 12.  Save the table and then switch to Datasheet View.

Notice the phone numbers are now formatted with parentheses and a hyphen because of the input mask.

 13.  Switch back to Design View.

Create Additional Settings
 14.  Change field properties to set the field sizes, input masks, and captions as indicated.

For the EmpLastName and EmpFirstName input masks, you’re using 24 question marks; you’re using 
14 question marks for the EmpCity input mask. These input masks use >L< to specify that the first 
character should automatically be capitalized and the next 24 or 14 question marks specify that up to 
24 or 14 alphabetic characters may be entered.

Field Field Size Input Mask Caption

EmpID 3 >LLL ID

EmpLastName 25 >L<???????????????????????? Last Name

EmpFirstName 25 >L<???????????????????????? First Name

EmpStreetAddress 30 Street Address

EmpCity 15 >L<?????????????? City

EmpST 2 >LL State

EmpZIP ZIP

EmpEmail Email

HireDate Hire Date

WebCert Web Cert

 15.  Choose File→Save and choose Yes when advised that some data may be lost.

 16.  Switch to Datasheet View.

The column headings now show captions rather than field names. The Caption property lets you use 
descriptive headings for fields, as field names cannot contain spaces.

 17.  Enter these records, using (Tab) to move between fields and only lowercase letters in the ID, Last 
Name, and First Name fields:

Field Name Field Data

ID Fdr

Last Name Roberts

First name Fred

Street Address 362 Lakeview Ave.

City Sarasota

State FL

Zip 34234

Phone 9415553981

Email FredRoberts@email.com

Hire Date 9/26/2018

Web Cert Yes (check)

Notice as you enter the data into the fields that some letters are automatically converted to uppercase 
due to the input mask rules you set.

 18.  Close the Employees table.
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Setting Validation Rules
A validation rule is a field property that enables you to limit the values entered in the field to reduce 
inaccurate data entry. You could, for example, set a validation rule to limit the value typed into an 
HoursWorked field to 50 or fewer, or the value of Pay Rate to less than $60.

Setting Appropriate Data Types for Validation Rules
For validation rules to be effective, the field for which you are setting the rule must be formatted 
appropriately for the data type to be entered. For example, if you set a validation rule requiring a 
four-digit number, the data type for the field should be set to Number. If you are requiring dates that 
occur before a specific date, the data type for the field should be Date/Time.

Validation Text Messages
When you set a validation rule for a field, it’s a good idea to set validation text, which contains 
instructions or valid data values to help guide data entry. Access displays the text as a message each 
time an invalid value is entered in the field.

Setting Different Types of Validation Rules
Validation rules are used to examine data entered into tables and forms. You can set comparison 
rules. Samples of comparison rules you can set to determine whether the value is within a valid range 
are shown in the following table:

VALIDATION RULES

Comparison Validation Rule Example Validation Text Example
Greater than >100 Enter a value greater than 100.

Less than <100 Enter a value less than 100.

Equal to =1 Or =2 Enter a value of 1 or 2.

Date after a date >#1/1/2017# Enter a date after January 1, 2017.

Greater than or equal to >=100 Enter a value of 100 or more.

Less than or equal to <=100 Enter a value of 100 or less.

Like Like “ID-0000” Enter a four-digit value starting 
with ID-.

Between Between 1 and 8 Enter a value from 1 to 8.

The same wildcards used to enter input masks are used in validation rules. For example, the question 
mark is substituted for each character that is required, such as in ID-????. The asterisk (*) can substitute 
for a group of characters that may vary, such as in ID-*.

DEVELOP YOUR SKILLS: A5-D10

In this exercise, you will set validation rules for data entered into fields in the Products table.

 1.  Display the Products table in Design View.

 2.  Click anywhere in the Price field and then click in the Validation Rule field property box.

 3.  Type >=25 as the validation rule.

 4.  Click in the Validation Text box and type: All prices must be at least $25

 5.  Choose File→Save and choose Yes to acknowledge that the date integrity rules have been 
changed.
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Test the New Validation Rules
 6.  Switch to Datasheet View.

All ProdID entries begin with PROD- because of the input mask you set earlier.

 7.  Click in the ProdID field for the new, blank record and type: 07SW

 8.  Tap [Tab], type Switchboard Page as the description, and tap [Tab] again to move to the 
Price field.

 9.  Type 20 in the Price field and tap [Tab].

The warning appears because of the validation rule you just set for the Price field. Notice the All prices 
must be at least $25 validation message you set is displayed in the alert.

 10.  Click OK to acknowledge the error message, type 30 for the price, and tap [Tab].

 11.  Close the Products table.

Setting Lookup Fields with the Lookup Wizard
All tables in a relational database are related in some way to each other, as well as to other objects 
in the database. Data from one table is often used in another table. A lookup field enables you to 
select a field value in one table by looking up values from another table; or you could select from a 
list of values entered by the database designer. The list of valid entries appears in a drop-down menu 
in the table accessing the values. 

A lookup field displays a menu arrow at the 
right end of the field during data entry.

This example shows the Products 
list displaying selectable values.

Using a lookup value also enables you to look up values from one field and return a value from a 
different field in the connected table. For example, you can look up a product number by typing the 
common product name. When a lookup field is created using values in another table, a relationship is 
also created between the lookup field and the field that contains the values.

Benefits of Lookup Tables
Adding a lookup field to a table serves three primary purposes:

 Ý It reduces the time required to enter the data repeatedly.

 Ý It reduces errors associated with data entry.

 Ý It restricts data to valid entries.
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Setting Lookup Fields with the Lookup Wizard 155

 8.  Click in the ProdID Data Type box and then click the drop-down menu button �.

 9.  Choose Lookup Wizard from the menu.

 10.  Click Next to accept the current setting, I Want the Lookup Field to Get the Values from Another 
Table or Query.

 11.  Choose Table: Products in the next Wizard screen and then click Next.

The Products table will contain the values to be looked up.

 12.  Move all three available fields to the Selected Fields list and click Next.

 13.  Choose ProdID as the sort field, leave the sort order as Ascending, and click Next.

The next Wizard screen lets you adjust the width of the lookup field columns, which determines how 
the columns appear when the lookup field is used.

 14.  Uncheck the Hide Key Column checkbox and then double-click the right borders of all three 
column headings to best fit the columns; click Next.

 15.  Click Next again to choose ProdID as the field that uniquely identifies the row.

 16.  In the next screen, leave the label set to ProdID, check the Enable Data Integrity box, and 
choose the Cascade Delete option.

 17.  Click Finish and then choose Yes in the two warning boxes.

Test the Lookup Field
 18.  Switch to Datasheet View.

 19.  Click in the ProdID field for the 02SP record (second record in the table).

 20.  Click the drop-down menu button � and choose the 07SW product.

This product ID replaces the 02SP for that record, so invoice 1 still has three products listed on it, but 
one of them has changed. This lookup field makes it easy for you to view a listing of products when 
adding them to invoices.

 21.  Close the InvoiceDetails table.
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Creating Lookup Fields for Multiple Values
You have already created a lookup field that enabled you to select a single item from a list. You can 
also set up lists that allow you to select multiple values to enter for each lookup field. If, for example, 
an inventory item is available from more than one supplier, you can set up the field to allow you to 
select all suppliers for an item. To create a selection list, simply check the Multiple Items option as 
you move through the Lookup Wizard screens.

DEVELOP YOUR SKILLS: A5-D12

In this exercise, you will create a lookup field in the Invoices table that allows you to assign two or more 
employees to an inventory item.

 1.  Display the Invoices table in Design View.

 2.  Click in the EmpID Data Type box, click the menu button �, and choose Lookup Wizard.

 3.  Click Next to accept the current setting, I Want the Lookup Field to Get the Values from Another 
Table or Query.

If you choose the I Will Type the Values in That I Want option, you can create your own list of items.

 4.  Choose Table: Employees and click Next.

The Employees table will contain the values to be looked up.

 5.  Move the EmpID, EmpLastName, and EmpFirstName fields to the Selected Fields list and click 
Next.

 6.  Choose EmpID as the sort field, leave the sort order as Ascending, and click Next.

 7.  Click Next to accept the default width settings for the columns.

 8.  In the final Wizard screen, check the Allow Multiple Values box, leave the label set to EmpID, 
and click Finish.

 9.  Choose Yes in the message box to confirm you want to store multiple values.

 10.  Choose Yes to save the table and choose Yes one last time to confirm that some data may be 
lost.

Test the Multiple Values Lookup Field
 11.  Switch to Datasheet View.

 12.  Click in the Emp ID field for the third record (invoice 3).

Tip!
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L E A R N I N G  O B J E C T I V E S

Ý Create a form that contains a subform

Ý Add a calculated control to a form

Ý Add a total row to a form

Ý Disable form fields

Ý Lock form fields

Ý Add ScreenTips to forms

Ý Create pop-up forms

6 Customizing Input 
Forms

ACCESS

R
elational database design often 

requires data from more than 

one table or query to appear 

on the same form. Customizing forms and 

their controls while applying other form 

settings gives designers more control while 

simultaneously making forms more efficient 

and easier to use. In this chapter, you will 

add a subform to a main form, which is a 

handy technique used to include data from a 

different source. You will also explore Access 

features to create calculated fields, add tips 

to form controls, and set control properties 

to protect and limit data entry.
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178 Access Chapter 6: Customizing Input Forms

Project: Formatting Functional Forms
Winchester Web Design has seen sales increase over recent months and wants to simplify 
data entry as a result. You’ve been asked to design advanced forms to make data entry easier 
for all team members and less prone to errors. You will create an invoice form that contains a 
subform containing invoice details. Your form will also contain a calculated field for creating 
totals, and you will use form features to enhance data entry. The database relationships will be 
critical for setting up these forms.

Subforms
Although many forms are designed to enter data into a single table, there are times when you 
may need forms that perform actions such as processing customer invoices, calculating totals, and 
locating data from multiple tables. One of the best ways to accomplish this is through a subform, 
which is a secondary form placed on a main form. Subforms work well when one-to-many relation-
ships are set, allowing the user to work with multiple tables on a single form. Subforms are simply 
subsets of data linked by parent fields on the main form to child fields on the subform.

The detail data from related tables appears in a subform.

A main form displaying customer and employee information


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Creating Subforms
The easiest way to create a subform is to use the Form Wizard, which creates a new form with an 
option to add a subform. Subforms can also be added to existing forms by placing a Subform control 
on the existing form, where you can specify the subform’s position and size. When the Subform 
control is added to the form, the Subform Wizard launches, allowing you to set subform properties.

View the Video “Creating Subforms with the Form Wizard.”

Í Create→Forms→Form Wizard 

Í Design→Controls→Subform 

DEVELOP YOUR SKILLS: A6-D1

In this exercise, you will use the Form Wizard to create an invoice form that contains an invoice details 
subform.

 1.  Open A6-D1-WinDesign from your Access Chapter 6 folder and save it as: 
A6-D1-WinDesignRev

 2.  Choose Create→Forms→Form Wizard .

 3.  Choose Table: Invoices from the Tables/Queries list and then add the InvNum and CustID 
fields to the Selected Fields list.

 4.  Add the fields indicated to the Selected Fields list, making sure to add them in the order shown:

Customers Invoices Employees InvoiceDetails Products InvoiceDetails
CustLastName InvDate EmpID ProdID ProdDescription Qty

CustFirstName EmpLastName Price

CustStreetAddress EmpFirstName

CustCity

CustState

CustZIP

CustPhone

CustEmail

 5.  Click Next and notice that the data is arranged by invoice number and the Form with 
Subform(s) option is already chosen.

The subform preview in the Wizard includes the ProdID, ProdDescription, Price, and Qty fields.

 6.  Click Next to accept the settings; click Next again to accept the Datasheet subform layout.
A
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180 Access Chapter 6: Customizing Input Forms

 7.  In the final Wizard screen, name the form Customer Invoices and the subform 
Customer InvoiceDetails Subform and then click Finish.

The new form and subform display in Form View.

 8.  Double-click the right border of each subform column heading to autofit the columns.

 9.  Click the empty ProdID cell in the new row at the bottom of the subform.

 10.  Click the drop-down menu button � and choose 03BL.

It’s easy to populate the first three fields of the new subform record.

 11.  Enter 1 in the Qty column and tap [Tab] to complete the record.
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Modifying Subforms
When you use the Form Wizard to create a subform, Access creates the subform and a main form 
with the subform embedded within it. Both are displayed in the Navigation pane. You can then open 
and modify the subform by itself in Layout View or Design View, or you can open the main form and 
modify it and the embedded subform together.

The Customer InvoiceDetails Subform and the Customer Invoices 
main form are displayed in the Navigation pane.

Subforms and their controls have their own Property Sheets that allow you to precisely control the 
subform layout and design. And you can use the same keystroke and mouse techniques to arrange 
and size subform controls that you use with main forms.

DEVELOP YOUR SKILLS: A6-D2

In this exercise, you will modify the Customer Invoices form and subform by deleting, moving, and sizing 
controls, and adding a graphic to the form.

 1.  Switch to Layout View.

You will begin by modifying the layout and controls on the main form.

 2.  Click the ST label in the main form to select it and then click inside the label and change it to: 
State

 3.  Change the ZIP label to: Zip

 4.  Locate the EmpID label and notice the Last Name and First Name labels below it.

 5.  Change the employee Last Name label to Emp Last Name and the employee First Name 
label to: Emp First Name

 6.  If necessary, display the Property Sheet by choosing Form Layout Tools→Design→Tools→ 
Property Sheet .

As you select and move controls in the following steps, you may need to drag the Property Sheet out 
of the way or close and reopen it as needed.

You can also tap [F4] to toggle the Property Sheet open and closed.Tip!
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 11.  With the subform frame still selected, use the left arrow [¢] key to nudge the subform to the left 
to align it with the main form labels.

Modify the Form Header
In the next few steps, you will modify the form title and add color and a logo to the header.

 12.  Use these guidelines to modify the form:
• Click the title box control to select it and then click just in front of Invoices and press 
[Shift]+[Enter] to move Invoices to a new line.

• Set the Width property to: 3
• Replace Customer with: Winchester Web Design
• Select both lines and choose Home→Text Formatting→Center  to center the title in  

the box.

 13.  Click to the right of the title box in an empty part of the form header.

The title box will become deselected when you select the form header.

 14.  If necessary, display the Property Sheet and click in the Back Color property box.

 15.  Click the Build  button and choose a light blue color or whatever color you feel looks best in 
the form header.

 16.  Choose Form Layout Tools→Design→Header/Footer→Logo .

 17.  Navigate to your Access Chapter 6 folder, choose WWD-Logo.bmp, and click OK.

 18.  Set the Width and Height properties to 0.8 and the Left property to: 4
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184 Access Chapter 6: Customizing Input Forms

 19.  Review your completed form and then close it, saving the changes to both the form and subform.

 

Adding Calculations to Forms
There are several ways to add calculations to forms, and the easiest way is to build a form based on a 
query that already has a calculated field. If your form is based on one or more tables or is based on 
a query without a calculated field, you will need to create a calculated control by adding an unbound 
control to the form and placing a formula within the control source property.

Applying Totals to Forms in Datasheet Layout
The Form Wizard has an option for creating a form in Datasheet Layout View. A form in Datasheet 
Layout View looks just like a table in Datasheet View. The Totals feature is available for tables in 
Datasheet View and for forms in Datasheet Layout View. The Totals feature lets you easily use 
an aggregate function such as count, sum, or average to create totals for numeric fields in the 
datasheet.

Í Home→Records→Totals 
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DEVELOP YOUR SKILLS: A6-D3

In this exercise, you will create a form that uses the Totals feature to count the number of individual line 
items on customer invoices and to total the amounts of all invoices.

 1.  Choose Invoices Query in the Navigation pane and then choose Create→Forms→ 
Form Wizard .

 2.  Move all fields to the Selected Fields list and click Next.

 3.  Choose Datasheet as the layout and click Next.

 4.  Name the new form Invoices Query Form and click Finish.

The form looks like a table when displayed in Datasheet View.

 5.  Choose Home→Records→Totals .

A Total line appears at the bottom of the datasheet layout.

 6.  Click in the Qty cell on the Total row.

A menu button appears at the left end of the cell.

 7.  Click the menu button � and choose Count, then click in the LineTotal cell and choose Sum 
from the menu.

The Count function simply counts the number of rows containing a quantity while the Sum function 
adds all line totals in the column.

 8.  Scroll through the datasheet’s 125 rows and notice that the Total row remains fixed at the 
bottom of the window.

The Totals feature is an easy way to use aggregate functions and is available in forms and in tables 
and queries.

 9.  Close the Invoices Query Form, saving the changes if prompted.

Creating Calculated Controls in Forms
The Totals feature is useful when you want to create totals for all records in a datasheet. But some-
times it’s necessary to display calculations in Form View, which displays just a single record at a time. 
You can do this by inserting a calculated control. A calculated control is an unbound text box control 
placed on the form with a formula inserted in the Control Source property. Usually, the formula 
references other controls on the form that are bound to underlying database fields. For example, you 
would use the formula =Price*Qty to display the total amount of a transaction, with both the Price 
and Qty fields shown on the form. Calculated controls can also contain aggregate functions or an 
array of built-in functions and expressions made available by using the Expression Builder.
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 4.  Click just below the Qty control text box to insert a new control.

 5.  Use the arrow keys as needed to nudge the control so it is aligned with the Qty control.

Create Formulas
 6.  If necessary, choose Format Design Tools→Design→Tools→Property Sheet to display the 

Property Sheet.

 7.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Tax

Control Source =(Price*Qty)*.07

Format Currency

Decimal Places 2

Notice that the text for Price and Qty are now surrounded by brackets, which indicates that these are 
fields.

 8.  Click the Text8 label on the subform and set these properties:

Property Value

Caption Tax

Width 0.25

Left 0.25

 9.  Choose Format Design Tools→Design→Controls→Text Box .

 10.  Click just below the Tax control text box to insert a new control.

 11.  Use the arrow keys as needed to align the control with the Tax and Qty controls above it.

 12.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Line Total

Format Currency

Decimal Places 2

 13.  Click the Control Source property and then click the Build  button to the far right.

The Expression Builder dialog box appears.
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Setting Properties to Assist and Control Data Entry  189

Setting Properties to Assist and Control  
Data Entry

Some properties are meant to assist with data entry, while others help control or limit it. These 
properties are easily set using the Property Sheet.

Disabling Form Fields
Sometimes a form may include data that users should not enter themselves or even access, for 
example, setting up passwords or entering Social Security numbers. Many forms also contain settings 
that enter default values, such as states, or values that correspond to data contained in another field, 
such as city and ZIP code fields. To protect a field on a form from being edited during data entry, 
you can disable the field in the Property Sheet. Disabled fields are unavailable for data entry; they’re 
still visible, but they appear grayed out and are not accessible to the user. During data entry, Access 
automatically skips a disabled field and moves directly to the next enabled and accessible field. To 
disable a field, just set the Enabled property to No.

Locking Form Fields
Another way to protect fields from being edited is to lock them. Locked fields remain available on the 
form and appear as normal; this allows users to click in the field, but they cannot change the data. 
Locked fields improve readability when a form is printed versus disabled fields, which appear grayed 
out and print faintly. To lock a field, set the Locked property to Yes.

DEVELOP YOUR SKILLS: A6-D5

In this exercise, you will disable the InvNum field in the Customer Invoices form and the LineTotal field in 
the Customer InvoiceDetails subform. In addition, you will lock the Price field in the subform so it cannot 
be edited.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box on the main form and then click the Data tab on the Property Sheet.

 3.  Disable the text box by changing the Enabled property to No.

 4.  Click anywhere on the subform to make it active and then click the ProdID text box.

 5.  Disable the ProdID text box.

 6.  Click the Price text box in the subform and set the Locked property to Yes.
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190 Access Chapter 6: Customizing Input Forms

Test the Property Settings
 7.  Switch to Form View and try clicking in the disabled InvNum field.

The field is grayed out, and you can’t click in it.

 8.  Try clicking in any of the cells of the disabled ProdID field in the subform.

In the subform, only the data appears grayed out, but you still cannot click in the field.

 9.  Click in any Price field in the subform and try changing the number.

Locking allows users to select a field, but the data cannot be changed.
 

Adding Control Tips
When you create a table and define fields, you can enter field details in the Description column. 
These field descriptions appear in the status bar when the fields are active during data entry. They 
also appear in the status bar when a field appears on a form. Although forms identify most fields 
with control labels, sometimes labels for specific fields, such as State and ZIP, are removed from a 
form when the controls are grouped under a more general label such as Address.

To help data entry personnel determine what data to type in a field, you can add descriptive messages 
to display onscreen by setting the ControlTip Text property for a control. ControlTips appear when 
the user points to the control. Setting control tips helps to provide explanations for controls.

DEVELOP YOUR SKILLS: A6-D6

In this exercise, you will create control tips for the disabled and locked fields on the Customer Invoices 
form to explain why they are inaccessible.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box and then click the Other tab on the Property Sheet.

 3.  Click in the ControlTip Text property text box and type: Invoice numbers are 
assigned automatically and cannot be changed.

 4.  Enter these control tips for the subform controls:

ProdID text box Product IDs are assigned by supervisors and cannot 
be edited.

Price text box Product prices cannot be changed.

 5.  Save the changes to the form.

 6.  Switch to Form View and point to the InvNum field to display the control tip.

 7.  Point to the ProdID and Price fields in the subform and notice the control tips do not appear.

Control tips display only in Form View. The subform is currently displayed in Datasheet View, so the 
tips don’t show.

 8.  Open the Customer InvoiceDetails Subform in Form View and point to the ProdID and Price 
controls to display the control tips.

 9.  Close the Customer InvoiceDetails Subform.

Leave the Customer Invoices form open.
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Creating a Pop-Up Form
Forms and reports can be set to open in pop-up windows that stay on top of other open database 
objects. Pop-up forms can prompt a user for information or display a window containing supple-
mental data. Such forms and reports can help data entry personnel look up values while processing 
orders or looking up item prices. You can apply different formats to pop-up forms.

POP-UP WINDOW MODES

Mode Description
Modal Pop Up Displays a custom dialog box that prevents access to other database 

objects until the dialog box is closed or its required actions are taken

Example: If you choose to print a report and have the Print dialog box 
open, you cannot make changes to the report until you click OK or Cancel 
in the dialog box.

Modeless Pop Up Creates a pop-up window that sits on top of other open windows in such a 
way that users cannot work in the database while it is open

Example: When processing orders, you could set the Inventory List to 
open as a modeless pop-up form to ensure you have the correct inventory 
number.

DEVELOP YOUR SKILLS: A6-D7

In this exercise, you will create and test a pop-up form using the Winchester Web Design Products table.

 1.  Select the Pop Up Products table from the Navigation pane.

 2.  Choose Create→Forms→Form Wizard .

 3.  Add all three fields to the Selected Fields list, choose Datasheet Layout, and name the form: 
Pop Up Products List

 4.  Switch to Design View and choose Form Design Tools→Design→Tools→Property Sheet .

 5.  If necessary, choose Form from the Selection Type list and 
then click the Other tab and set the Pop Up property to Yes.

 6.  Switch to Datasheet View and double-click the right border 
of each column heading to autofit the columns.

 7.  Resize the window using the sizing handle until it just encloses 
the datasheet.

You may need to reposition the form first by dragging the title bar 
until you can see the frame borders.
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200 Access Chapter 6: Customizing Input Forms

 9.  Switch to Form View and display the Venue Events form in Form View.

 10.  Move the pop-up form so you can view the data in the Venue Events form and subform.

You can see what each Event ID on the Venue Events subform means by looking on the Events Pop Up 
form.

 11.  Close the database, saving the changes to the form.
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L E A R N I N G  O B J E C T I V E S

Ý Create a crosstab query

Ý Create a find unmatched query

Ý Create a find duplicates query

Ý Create and run parameter queries

Ý Create and run action queries

7 Creating Complex 
Queries

ACCESS

A
s your database grows, so will 

the need to quickly retrieve and 

modify exact data. Complex 

queries help with this because they allow 

you to further refine search results and 

perform actions that modify records. In this 

chapter, you will explore queries designed 

to enhance the timeliness and accuracy of 

large relational databases. You will create 

crosstab queries and use parameter queries 

that prompt you to enter values to generate 

or modify records. You will also create 

action queries to update databases and 

automate database tasks.

Microsoft Access 2019: Level 2 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



208 Access Chapter 7: Creating Complex Queries

Project: Handling Growing Databases
You are responsible for analyzing the data-retrieval processes for the growing Winchester 
Web Design database. You decide to develop queries to increase the efficiency of both data 
entry and updates, as well as to better analyze data. The tools you will use include crosstab 
queries for data analysis, parameter queries that will prompt the user for input, and action 
queries to update and maintain the database.

Crosstab Queries
Crosstab queries allow you to easily analyze data. A crosstab query lists the fields to be grouped 
on the left side (rows) of the datasheet, and it arranges the fields to be summarized across the top 
(columns) so you can calculate sums, averages, counts, or totals by both group and subgroup. For 
example, if you have a database that contains sales records for your employees, the description of 
each product they sell, and their total sales for each product, you could create a crosstab query to 
display the total sales by product for each employee.

The original data format is arranged by record.

Using a crosstab query, you can display the data grouped by employee with totals for the various 
products.


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Crosstab Queries 209

Both tables and queries can be used as the basis of crosstab queries. You can create a crosstab query 
while working with an existing query in Design View using the Crosstab option; alternatively, use the 
Query Wizard.

Í Design→Query Type→Crosstab 

Watch the video “Creating Crosstab Queries.”

DEVELOP YOUR SKILLS: A7-D1

In this exercise, you will create a crosstab query that lists every employee and their total invoice amount 
generated by product.

 1.  Open A7-D1-WinDesign from your Access Chapter 7 folder and save it as: 
A7-D1-WinDesignRev

 2.  Double-click the Employee Sales query to run it and display the resulting datasheet.

The query contains line item sales data. Each employee has multiple transactions, and each 
transaction contains the product description, price, and quantity. The LineTotal field is a calculated 
field that multiplies price by quantity. You will use this query as the basis for your crosstab query.

 3.  Close the Employee Sales query.

 4.  Choose Create→Queries→Query Wizard .

 5.  Choose Crosstab Query Wizard and click OK.

 6.  Choose the Queries view option and then choose Query: Employee Sales from the query list.

 7.  Click Next to accept the Employees Sales query as the basis of your crosstab query.

 8.  Choose EmpLastName from the Available fields list and add it to the Selected Fields list.

Your crosstab query will display employee last names as row headings in the query results datasheet. 
Each employee will have a single row, with their last name displayed in the first cell of the row and 
their sales information displayed in the other row cells.

 9.  Click Next and choose ProdDescription for the column headings.

The various product descriptions (Blog, Home Page, Web Page) will appear as column headings.

The sample query at the bottom of the Wizard can be a useful guide for deciding which fields to use as 
the row and column headings.

Tip!
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210 Access Chapter 7: Creating Complex Queries

 10.  Click Next, choose LineTotal from the Fields list, and then choose Sum from the Functions list.

The crosstab query will examine all transactions in the underlying Employee Sales query and sum the 
line totals for each product description. For example, a grand total of all line totals will be created 
where the product description is Blog and the employee is Kramer.

 11.  Leave the Yes, Include Row Sums option checked and click Next.

This option creates one additional column in the datasheet to hold a total for each employee. The 
total will be the sum of all cells in the crosstab query datasheet for that employee.

 12.  Leave the default query name as Employee Sales_Crosstab and click Finish.

 13.  Take a moment to examine the query results.

Complete the Query Wizard steps again, if necessary, so you fully understand how the query options 
produce the resulting datasheet.

 14.  Close the query.

Find Queries
Database tables often contain common fields that link, or relate, the tables. For example, the 
Product ID field from a Products table also appears in an Invoices table, so invoices can show only 
existing products. Thus, it’s important that records entered in one table have a matching record in the 
related table. That is, an invoice should never show a product that is not in the Products table.

Sometimes databases are poorly designed and incorrect data is allowed. For example, a user may 
enter a product that does not exist into a new invoice. Data is also sometimes imported from other 
data sources, which might result in incorrect or duplicate data. Fortunately, Access provides two 
additional Query Wizard options to help resolve these types of data conflicts.
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Find Unmatched Query
The find unmatched query locates records in one table that have no matching records in another 
table. For example, you could create a find unmatched query to ensure each record in an Invoice 
table has a corresponding record in a Customers or Products table.

Find Duplicates Query
A find duplicates query locates records containing duplicate field values in a single table or query 
datasheet. For example, you could create a find duplicates query to locate all customers with the 
same last name in a Customers table or to find all customers located in a particular state or ZIP code.

DEVELOP YOUR SKILLS: A7-D2

In this exercise, you will create a query to locate records in the Customers table that do not have a 
matching customer ID in the Invoices table. Then you will create a query to identify records with duplicate 
customer last names.

 1.  Choose Create→Queries→Query Wizard , choose Find Unmatched Query Wizard, and 
click OK.

 2.  Click Next to choose the Customers table.

When the query is created, records from the Customers table will appear in the query results.

 3.  Choose the Invoices table and click Next.

You will set up the query to find records in the Invoices table that do not have a matching customer 
record in the Customers table. Notice that the CustID fields are chosen as the matching fields in the 
Wizard screen. They’re automatically chosen because a one-to-many relationship is already set up 
between these fields in the Customers and Invoices tables.

 4.  Click Next to accept CustID as the matching field.

 5.  Add CustLastName, CustFirstName, CustPhone, and CustEmail to the Selected Fields list.

These are the fields from the Customers table that will be displayed in the query results, creating a 
contact list of customers who don’t have invoices in the system. In other words, these are customers 
who haven’t purchased anything in a while, making them potential prospects for new sales.

 6.  Click Next and then click Finish to accept the default query name Customers Without Matching 
Invoices.

Your query should produce a data set of three records only.

 7.  Close the datasheet after reviewing it.

Create a Find Duplicates Query
 8.  Choose Create→Queries→Query Wizard , choose Find Duplicates Query Wizard, and 

click OK.
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212 Access Chapter 7: Creating Complex Queries

 9.  Click Next to choose the Customers table as the query to search for duplicate field values.

 10.  Add CustLastName to the Duplicate Value Fields list and click Next.

You are looking only for the records of customers who have the same last name.

 11.  Add CustFirstName and CustPhone to the Additional Query Fields list and click Next.

These fields will appear in the resulting datasheet but aren’t used in the duplicate values test. Only 
CustLastName is being checked for duplicates.

 12.  Name the query Customers with the Same Last Name and click Finish.

The query results show just two customers with the same last name (Roberts).

 13.  Close the query after reviewing the results.

Parameter Queries
A parameter query is a select query that prompts users to enter new criteria values each time the 
query is run. The query then generates results based on the value(s) entered. For example, a param-
eter query that searches for customers with a specific last name might prompt the user to enter the 
desired last name when the query is run. The query then returns only records containing the last 
name entered by the user. Parameter queries are created by enclosing the desired prompt text with 
square brackets, [ ], in the query Criteria row.

Surround the parameter 
query prompt text in 
square brackets in a 
Criteria cell.

The prompt text appears 
here when the query is run.

The user enters the desired 
parameter value here.

In this example, only records in which the customer last name is Smith are returned.
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Complex Parameter Queries
Suppose you want to see all items purchased by a particular customer and those equal to or greater 
than a particular price; for example, all items purchased by Smith with a price greater than or equal 
to $300. You can do this by creating an AND condition using parameters in the CustLastName and 
Price fields.

You can also create expressions with prompts for multiple values in the same query field or include 
logical criteria such as greater than (>), less than (<), and equal to (=). 

EXAMPLES OF PARAMETER QUERY CRITERIA FOR  
A SINGLE FIELD

Parameter Criteria Result
Between [What is the start date?] 
And [What is the end date?]

These criteria prompt the user to enter start and 
end dates. Access recognizes the Between and And 
expressions and returns dates within the range entered.

>=[Enter minimum price] This displays the prompt Enter minimum price and returns 
only records greater than or equal to the price entered.

DEVELOP YOUR SKILLS: A7-D3

In this exercise, you will use parameters to return customer records based on user input.

 1.  Display the Customer Invoice Parameter query in Design View.

 2.  Click in the CustLastName criteria field and enter the criterion: [Enter Customer Last 
Name]

 3.  Run the query, type Roberts in the parameter box that appears, and click OK.

All line items from invoices 34 and 7, where the customer last name is Roberts, are returned.

Create an AND Parameter Condition
 4.  Switch to Design View and enter this parameter in the Price criteria box: >=[Enter Minimum 

Price]
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214 Access Chapter 7: Creating Complex Queries

 5.  Run the query and enter Roberts in the first parameter box and 300 in the second.

Now the record set has records only with Roberts in the Last Name field in which the price is greater 
than or equal to 300.

 6.  Close the query, saving the changes.

Action Queries
An action query performs an action that modifies a database table or a group of records in a table. 
They can modify, move, update, or delete groups of records with a single action. You can even use an 
action query to create a new table by adding various fields and data from other tables. 

An action query is run whenever it is opened, so if you create an update query designed to increase 
prices by 10% on all items in a table, Access will increase those prices every time you run the query. 
Action queries do this without opening the underlying tables being modified by the query. For this 
reason, an action query may accidentally be run more than once, inadvertently changing the under-
lying table data multiple times. It’s good practice to not save action queries after running them or to 
delete action queries if they are saved. This will help maintain the validity of the database as changes 
to the underlying data cannot easily be undone.

Action queries require that content within a database be enabled. As a result, if you did not click the 
Enable Content button found at the top of the Access window when you first opened the database, 
Access will display an error message advising you to enable content before you can create or run 
action queries.

Make Table Queries
A make table query is an action query that can create a new table using data from multiple database 
tables. It’s also a great way to move data produced from a calculated query field into a table. When 
you create a new table using a make table query, Access prompts you for a table name and even 
allows you to save the data in another database. A reason to move records to another database, 
for example, would be to archive them when they become obsolete, such as when a product is no 
longer available. When you rerun a make table query, Access will replace the table created with the 
previous running of the query. To retain the previously created table, you must first rename it; this 
way it won’t be replaced.

Í Design→Query Type→Make Table 
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DEVELOP YOUR SKILLS: A7-D4

In this exercise, you will create a make table action query to save all of the 2017 invoice records in a new 
table.

 1.  Open Invoices Query in Design View.

 2.  Enter Between 1/1/2017 And 12/31/2017 as the criterion for the InvDate field.

This criterion will produce a datasheet with old invoices no longer needed in the database. You’ll then 
use the make table query feature to move the records to a new table.

 3.  Choose Query Tools→Design→Query Type→Make Table .

 4.  Enter 2017 Invoices as the table name and click OK.

 5.  Run  the query and choose Yes to paste 61 rows into a new table.

The new table named 2017 Invoices appears at the top of the Tables section in the Navigation pane.

 6.  Open the new 2017 Invoices table in Datasheet View.

Notice that all of the line items listed have a 2017 invoice date.

 7.  Close the 2017 Invoices table and then close the invoices query without saving the changes.

It’s important not to save the query because it’s used for other purposes and because you want to 
preserve the new table without risking an overwrite of it.

 8.  Open the Invoices table in Datasheet View.

The Invoices table still contains the 2017 records.

Make table queries don’t remove data from underlying tables; they simply copy the data to new tables. 

 9.  Close the Invoices table.

Append Queries
An append query adds a group of records from one or more tables to the end of one or more tables 
in the same or in another database. For example, if you want to offer a new set of products, you could 
use an append action query to add the new items from a new products table to the existing products 
table. Or you might use an append query to automatically add new customers to the Customers 
table the first time a customer places an order.

Formatting the Source and Destination Tables
In an append query, the table that records are drawn from is called the source table. The table 
receiving the records is the destination table. To successfully run an append query, the structures, 
field names, data types, and field order for both tables should be the same.

Note!
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216 Access Chapter 7: Creating Complex Queries

Identifying the Source and Destination Tables
Append queries are created in the database that contains the source table. When the query is run, 
the Append dialog box prompts you to identify the destination database and table. Access identifies 
the destination table in the Append To row of the query grid.

Í Design→Query Type→Append 

DEVELOP YOUR SKILLS: A7-D5

In this exercise, you will create an action query to append records from the New Products table to the 
existing Products table.

 1.  Open the Products table and notice that it contains six records.

 2.  Open the NewProducts table to see the five records that will be appended to the Products 
table.

The tables have the same field structure, which includes field order and matching field names and field 
data types.

 3.  Close both tables and then choose Create→Queries→Query Design  to create a new 
query.

 4.  Add the New Products table to the query window and then close the Show Table dialog box.

 5.  Add all fields from the New Products table to the query grid in the same order they appear in the 
New Products list.

 6.  Choose Query Tools→Design→Query Type→Append .

 7.  Click the Table Name menu button �, choose Products, and click OK.

An Append To row is added to the query. When you run the query, it will copy all records from the 
underlying New Products table to the Products table. The tables have identical field structures, so the 
data will drop right into the existing table.

 8.  Run  the query and choose Yes to append the five rows to the Products table.

Nothing appears to happen when you run the query—but don’t run it again! You will see the changes 
only after you open the destination table to which the records were appended. If you do run the query 
again, Access will add the same records to the destination table again, creating duplicate data.

 9.  Display the Products table in Datasheet View to verify that the new records were appended.

The Products table should now contain 11 records.

 10.  Close the Products table and then close the new append query, saving it as: Append 
Products
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Update Queries
An update query is an action query that makes global changes to a group of records in one or more 
tables. For example, you can use an update query to increase the prices for every product in a specific 
category or to update the area code for phone numbers that change when the phone company adds 
or changes an area code. To ensure the corresponding fields in related tables are updated consis-
tently, check the Cascade Update Related Fields checkbox in the Edit Relationships window.

Identifying the Query Grid Update Row
Append, update, crosstab, and delete queries all add a query-specific row to the query grid. The 
update query places an Update To row in the query grid so that you can tell Access how to update 
the desired field(s). In most cases, this will be changing one value to another by substitution, 
mathematical operation, formula, or comparison.

Í Design→Query Type→Update 

DEVELOP YOUR SKILLS: A7-D6

In this exercise, you will create an update action query that increases the prices of every item in the 
Products table by 10%.

 1.  Open the Products table in Datasheet View and notice the Home Page price is $400.

The update query will increase this and all other prices by 10%.

 2.  Close the Products table and then choose Create→Queries→Query Design .

 3.  Add the Products table to the query window and then close the Show Table dialog box.

 4.  Add all fields from the Products table to the query grid in the same order they appear in the 
Products list.

 5.  Choose Query Tools→Design→Query Type→Update .

An Update To row is added to the query grid.

 6.  Click in the Update To cell for the Price field and enter: [Price]*1.1

Be sure to include the square brackets, [ ], when entering this formula so Access will recognize Price as 
a field. Multiplying by 1.1 increases the price by 10%.

 7.  Run  the query and choose Yes when the warning prompt appears to update 11 rows.

 8.  Close the query without saving it.

Once again, it’s good practice not to save action queries, such as update queries. Running a query by 
accident can corrupt data and recovering corrupted data is often difficult or impossible to do.

 9.  Open the Products table in Datasheet View and notice the Home Page price went from $400 
to $440 (an increase of 10%).

 10.  Close the Products table.
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Delete Queries
A delete query removes a group of records from one or more tables. For example, you could create 
a delete query to remove records for a discontinued line of products or to delete records you have 
appended to another table to prevent inadvertently running an append query multiple times.

Preparing for Delete Queries
To ensure corresponding records in related tables will be deleted concurrently, check the Cascade 
Delete Related Records checkbox in the Edit Relationships window. When you set up a delete query, 
Access replaces the Sort row of the query grid with a Delete row. You can set criteria for specific 
fields in a table to identify the conditions that must be met in order to delete records, or you can set 
no criteria to remove all records from a table.

Í Design→Query Type→Delete 

DEVELOP YOUR SKILLS: A7-D7

In this exercise, you will create a delete query to remove the 2017 invoices from the Invoices table.

 1.  Open the Invoices table in Datasheet View.

The table still has invoices dated from 2017. These invoices were copied to the 2017 Invoices table 
using a make table query in a previous exercise. Because make table queries do not delete records, 
you’ll take care of this using a delete query.

 2.  Close the Invoices table and then choose Create→Queries→Query Design .

 3.  Add the Invoices table to the query window and then close the Show Table dialog box.

 4.  Add only the InvDate field to the query grid.

 5.  Enter Between 1/1/2017 And 12/31/2017 as the criterion for the InvDate field.

Access may view typing 2017 as an attempt to insert the 2017 Invoices table. To avoid adding this 
table to the criteria, tap (Spacebar) at the end of the criteria and then press (Enter).

 6.  Choose Query Tools→Design→Query Type→Delete .

A Delete row is added to the query grid.

 7.  Run  the query and choose Yes when the prompt to delete 19 rows appears.

A second warning appears, notifying you that the records cannot be deleted because there is a key 
violation. This is because the Cascade Deleted Records option is not activated for a relationship 
between the Invoices and Invoice Details table. This option must be activated for you to run delete 
queries.

 8.  Choose No in the warning message box and then choose Database Tools→Relationships→ 
Relationships .
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226 Access Chapter 7: Creating Complex Queries

Create an Update Query
 11.  Create a new query using the SalaryGrades table and adding only SalaryAmt to the query 

grid.

 12.  Use the Update query type to add an Update row to the query.

 13.  Use an update criterion that multiplies the SalaryAmt field by: 1.07

This will produce a 7% increase to the numbers in the SalaryAmt field.

 14.  Run the query, choosing Yes to update 21 records.

 15.  Close the query, saving it as: Salary Updates

 16.  Close the SalaryGrades table.

Create a Delete Query
 17.  Create a new query using only the EventDate field from the Schedules table.

 18.  Use the criterion <1/1/2019 in the EventDate field.

 19.  Use the Delete query type and then run the query, choosing Yes to delete six records.

 20.  Close the new query without saving it.

 21.  Open the Schedules table to verify all records with an event date prior to 1/1/2019 have been 
deleted and then close the database.
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L E A R N I N G  O B J E C T I V E S

Ý Import a report into a database

Ý Add a subreport to a main report

Ý Create a report from a subreport

Ý Create calculated controls on a subreport

Ý Set page breaks in reports

Ý Add a chart to a report

8 Customizing Reports

ACCESS

D
atabase reports summarize 

the data contained in tables 

or displayed in query results 

and enable you to provide information in a 

page layout suitable for printing. Although 

forms and reports serve different purposes 

within the context of a relational database, 

the techniques used to customize them 

are similar. In this chapter, you will import 

reports from other databases and use 

features to create custom reports.
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232 Access Chapter 8: Customizing Reports

Project: Billing Customers
The company manager of Winchester Web Design, a small web page design company, wants 
you to improve its invoice report for customer billing. After reviewing invoices from several 
companies, the company manager has sketched out a design for the new invoice report layout. 
Your job is to create a sample of the new invoice report for the company’s executive team.

Importing a Report into a Database
Access offers a variety of ways to create reports. In addition to using the Report Wizard or starting 
from scratch in Design View, you can import reports from another database. Because most compa-
nies require some type of invoice to send with customer orders, locating a sample invoice report to 
import is not difficult.

Sometimes you have the report you want, but during its design it may have become corrupted, either 
due to inadvertent changes to the report itself or because of changes to an underlying query. That’s 
when backups are invaluable. If a report becomes corrupted, you can restore it by importing data-
base objects from a backup copy of a database. The record source should already match, and there 
should be no need to edit the properties or the field names.

Identifying Report Record Sources
Reports you import retain two connections to their original database. The first is the source database 
table or query name, shown in the Record Source property, and the second are the field names, which 
appear in report text boxes. As a result, when you import a report from another database, you often 
must establish new control sources to the destination database. You can accomplish this by:

 Ý Editing the imported report’s Record Source property to link to a table or query in the destination 
database.

 Ý Editing, if necessary, the field names in the imported report’s text boxes to match those in the new 
record source table or query.

Í External Data→Import & Link→New Data Source→From Database→Access 

DEVELOP YOUR SKILLS: A8-D1

In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

 1.  Open A8-D1-WinDesign from your Access Chapter 8 folder and save it as: 
A8-D1-WinDesignRev

 2.  Look in the Reports section in the Navigation pane and notice the database contains three 
reports.

 3.  Choose External Data→Import & Link→New Data Source→From Database→Access .

The Get External Data – Access Database dialog box appears.

 4.  Click the Browse button and navigate to your Access Chapter 8 folder.


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Adding a Subreport to a Main Report 233

 5.  Choose the file A8-D1-WinDesign-Backup and click Open.

This database is a backup copy of the WinDesign database.

 6.  Leave the Import tables, queries, forms, reports storage setting selected and click OK.

Access opens the Import Objects dialog box and displays object names contained in the backup 
database in tabbed groups.

 7.  Click the Reports tab, choose Customer Invoices, and click OK.

 8.  Leave the Save Import Steps box unchecked and click Close.

The Customer Invoices report is added to the Reports section of the Navigation pane.

 9.  Double-click the Customer Invoices report to open it in Report View.

 10.  Scroll down as necessary to see the empty space between the customer information and  
signature blocks.

This is a great spot to insert a subform/subreport that includes the invoice detail lines.
 

Adding a Subreport to a Main Report
Subreports display subsets of data in reports and are derived from related database tables, similar 
to subforms on forms. However, a subreport can display table data by using a table, query, form, or 
another report as its source object. Forms are frequently created before reports and often already 
display the required report data. To streamline the report design and layout, it’s best to use a 
subform as the basis of a subreport.
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234 Access Chapter 8: Customizing Reports

This invoice report uses a subform to display invoice details.

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add  
a subform to a form. You can create the subreport using the Report Wizard or add an unbound 
subreport control to the report. Then you identify the database object containing the fields you  
want to display as a subreport.

View the video “Adding a Subreport Using the Wizard.”

Í Report Design Tools→Design→Controls→Subform/Subreport 

DEVELOP YOUR SKILLS: A8-D2

In this exercise, you will add a subreport to the Customer Invoices report. You will use the InvoiceDetails 
subform as the source for the subreport.

 1.  Display the Customer Invoices report in Design View.

 2.  Choose Report Design Tools→Design→Controls→Subform/Subreport  (at the bottom 
of the controls list).
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236 Access Chapter 8: Customizing Reports

 11.  Switch to Report View to see your completed report.

 12.  Use the Navigation bar and the scroll bar to review the database records.

The information in both the report and the subform changes each time a new record is displayed.

 13.  Close the report, saving the changes.

Creating a Report from a Subreport
Using a subform as the record source for a subreport is convenient because the subform already 
includes the needed data. However, when a subreport uses a form as the record source, any changes 
made to the subreport layout are reflected in the source form. If you don’t want the source form 
to be changed, you can save the subreport as a separate report in the database, change the main 
report’s Record Source property to the new report object, and then edit the subreport.

Access allows you to save an existing form as a new form and an existing report as a new report. 
When a subform is used as the record source for a subreport, you can open the subreport in a sepa-
rate window and save it as a separate report.

Í File→Save As→Save Object As→Save As

DEVELOP YOUR SKILLS: A8-D3

In this exercise, you will create and save a new report based on the subreport from the Customer Invoices 
report. You will then edit the source object property in the main report to display the new subreport.

 1.  Open InvoiceDetails Subform from the Forms section of the Navigation pane.

 2.  Choose File→Save As, choose Save Object As from the File Types list, and then click the Save 
As button in the right pane.

 3.  Type WWD Customer Invoices Subreport as the name, choose Report from the As 
drop-down list, and click OK.

A new report is added to the Reports section of the Navigation pane.

 4.  Close the InvoiceDetails Subform.

 5.  Open the new WWD Customer Invoices Subreport in Design View.

 6.  Display the Property Sheet, if necessary, and then click the All tab and type Customer 
Invoices Subreport as the caption.

Create a Title for the Subreport
 7.  Choose Report Design Tools→Design→Header/Footer→Title.

Access places a title and empty placeholder controls in the Report Header.

 8.  Type Winchester Web Design Invoice Details in the title control and tap [Enter].
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 9.  Set these property values for the new title control:

Property Setting

Width 3

Height 0.25

Left 1

Font Name Arial

Font Size 12

Text Align Center

 10.  Click the Report Header section bar and set the Height 
property to: 0.3069

Inserting the title in the header widens the subreport, so you 
will now reset the width.

 11.  Click the report selector button and set the Width prop-
erty to: 5.6

 12.  Close the subreport, saving the changes, and then open the Customer Invoices report in 
Design View.

 13.  If necessary, display the Property Sheet and click the Data tab.

 14.  Click the subreport to select it.

 15.  Click in the Source Object property box.

A drop-down menu button appears at the far 
right of the property box.

 16.  Choose Report.WWD Customer Invoices 
Subreport from the drop-down menu.

 17.  Switch to Report View to see how the new 
subreport looks.

Notice the change in appearance compared to 
the subform used previously.

 18.  Scroll through the report, seeing how the subreport always shows the correct invoice details.

 19.  Close the Customer Invoices report, saving the changes.
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240 Access Chapter 8: Customizing Reports

 17.  Click the new text box control and set these property values using the All tab in the Property 
Sheet:

Property Setting

Name txtCount

Width 0.3

Top 0.1

Left 0.1

Back Style Transparent

Border Style Transparent

Set Control Properties to Sum
 18.  Click the Data tab and set the Control Source property to =1 and the Running Sum property to 

Over Group.

 19.  Switch to Report View and scroll through the report.

Notice that the numbering continues sequentially throughout the report.

 20.  Close the WWD Customer Invoices Subreport, saving the changes.

 21.  Display the Customer Invoices report in Design View.

 22.  Click the InvoiceDetails Subform and set the Width property to: 6

 23.  Switch to Print Preview and use the navigation bar to review the various report pages.

Each invoice begins on a new page and the invoice detail line items begin at number 1 for each invoice.

 24.  Close Print Preview and then close the Customer Invoices report, saving the changes.

Creating Calculated Controls on a Subreport
Reports summarize data in tables and queries to present useful, organized information. This means 
that a report would typically show subtotals, grand totals, and averages to summarize a specified 
group of data. You can do this by adding calculated controls.

Positioning Calculated Controls
Calculated controls are built-in reports using the Control Source property of an unbound text box 
control to which you add a formula. The section or group where a calculated control is placed deter-
mines how Access performs the calculation.
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Creating Calculated Controls on a Subreport 241

A calculated control in a Detail section 
performs a calculation for each detail line.

A calculated control in a Group Footer 
section calculates the total for the group.

A calculated control in a Page Footer 
section calculates the total for the page.

A calculated control in a Report Footer 
section calculates the total for the entire report.

DEVELOP YOUR SKILLS: A8-D5

In this exercise, you will add a calculated control to the report footer section in the WWD Customer 
Invoices Subreport.

 1.  Display the WWD Customer Invoices Subreport in Design View.

 2.  Click the Report Footer section bar and set the Height property to: 0.3

 3.  Choose Report Design Tools→Design→Controls→Text Box 

 4.  Click anywhere in the Report Footer section.

 5.  Switch to the All tab in the Property Sheet and set these properties for the new text box control:

Property Setting

Name CustomerTotal

Control Source =Sum([Price]*[Qty])

Format Currency

Height 0.25

Top 0

Left 4.75

 6.  Click the new label control and set these property values:

Property Setting

Caption Invoice Total

Width 1.2

Height 0.25

Top 0

Left 3

Fore Color Text Dark
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242 Access Chapter 8: Customizing Reports

 7.  Close the subreport, saving the changes.

 8.  Display the Customer Invoices report in Report View.

 

Growing and Shrinking a Subreport
When the number of records or amount of data displayed in a subreport varies, you can set the Can 
Grow and Can Shrink properties to allow the subreport space to expand or shrink so more data 
displays vertically. You can also change the orientation of the print layout to allow more horizontal 
space on each report page.

The subform without the Can Grow property enabled 
displays less vertical data, requiring a scroll bar.

The subform with the Can Grow property enabled 
is expanded to display more vertical data.

DEVELOP YOUR SKILLS: A8-D6

In this exercise, you will adjust the margins of the Customer Invoices report and set the Can Grow and Can 
Shrink properties. These properties will adjust the size of the subreport to fit the contents.

 1.  Display the Customer Invoices report in Design View.
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Setting Page Breaks and Customizing Controls 243

 2.  Choose Report Design Tools→Page Setup→Page Size→Margins→Narrow.

 3.  Click the InvoiceDetails Subreport.

 4. If necessary, display the Property Sheet; on the Format tab, set the Can Grow property to No.

 5.  Switch to Report View and scroll through the report.

The subform now displays a vertical scroll bar in order to view additional records.

 6.  Switch to Design View and click the InvoiceDetails Subreport.

 7.  Click the Format tab on the Property Sheet and, if necessary, set the Can Grow and Can Shrink 
properties to Yes.

 8.  Switch to Report View and scroll through the report.

The subreport grows and shrinks to best fit the contents.

 9.  Save the report.

Setting Page Breaks and Customizing Controls
As you view the Winchester Web Design Customer Invoices report in Report View, you may notice 
that the number of invoice records displayed on each screen varies depending on the number of items 
ordered. To ensure each customer invoice starts on a new page, you can add a page break control. 
By default, when you view a report in Print Preview, data for each customer/record automatically 
appears on a separate page; however, multiple records appear on the same page when the report is 
displayed in Report View.

To add a title or general company information to an invoice, place title controls in the Page Header 
rather than the Report Header, which prints only on the first page.

Add the page break at the end of the Detail section so Access knows to start a new page before printing 
the next page header.

Í Report Design Tools→Design→Controls→Insert Page Break 

DEVELOP YOUR SKILLS: A8-D7

In this exercise, you will modify the Customer Invoices report by adding a title and the current date as well 
as setting up page breaks to print each invoice on a separate page.

 1.  Display the Customer Invoices report in Design View.

To begin, you will modify the report title.

 2.  Click the Customer Invoice title control in the Page Header section and then click just in front 
of Customer to position the insertion point there.

 3.  Type Winchester Web Design and then press [Shift]+[Enter] to force Customer Invoice to a 
second line.

 4.  Click an empty area in the Page Header section and then click the title control once more to 
select it.

 5.  Set the Width property to 4 and the Left property to 2.

Tip!
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244 Access Chapter 8: Customizing Reports

Add a Date Control
In the next few steps, you will insert a date that will display in the report header.

 6.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 7.  Choose the third date option MM/DD/YYYY format, remove the check from the Include Time 
box, and click OK.

Access places the new date control in the Report Header section. Next, you will move the date to the 
Page Header section so it appears on every page rather than just the first page of the report.

 8.  Select the date control and press [Ctrl]+[X] to cut it from the report header.

 9.  Click the Page Header section bar and press [Ctrl]+[V] to paste the date into the page header.

 10.  Set these properties for the date control:

Property Setting

Width 2

Height 0.2

Top 0.4

Left 5.8

Add a Page Break Control
 11.  Scroll to the bottom of the Detail section.

 12.  Choose Report Design Tools→Design→Controls→Insert Page Break .

 13.  Place the page break in the Detail section just above the Page Footer section bar.

 14.  Switch to Print Preview and use the navigation bar to browse the pages.

The date appears on each invoice because you added it in the Page Header section. Each invoice 
begins on a new page. Sometimes it’s not necessary to add a page break to a report and doing so may 
add an unneeded page. If this occurs in your report, remove the page break.

 15.  Close Print Preview and then close the report, saving the changes.

Adding Charts
Summarized and numerical data is often displayed visually using a chart. By adding a chart to a 
report, the information and relationships between report data is more easily interpreted. While you 
can add charts to reports and forms, they’re more commonly used in reports. Access offers multiple 
chart types, including column, bar, line, and pie, among others.

You can insert charts using the Chart control or the Insert Chart command.

Í Report Design Tools→Design→Controls→Insert Chart 

Before After
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Adding Charts 245

Formatting Modern Charts
You can format and modify common settings using either the Property Sheet or the Chart Settings 
task pane, which means formatting charts in Access is similar to formatting charts in other Microsoft 
Office applications, like Excel and PowerPoint.

View the video “Adding Modern Charts.”

Í Report Design Tools→Design→Tools→Chart Settings 

Refreshing Chart Data
Like many other Access objects, charts use the contents in a table or query as the data source. When 
the data source of a chart is changed, the chart may not automatically reflect those changes. The 
Refresh All command manually updates a chart to match record source data.

Home→Records→Refresh All 

DEVELOP YOUR SKILLS: A8-D8

In this exercise, you will modify Winchester’s Employee Sales report by adding a chart. You will then 
format the chart and manually update it after making changes to the record source.

 1.  Display the Employee Sales report in Design View.

 2.  Choose Report Design Tools→Design→Controls→Insert Chart .

A menu appears allowing you to select the chart type.

 3.  Choose Column→Clustered Column.

Your mouse pointer changes to a chart icon with a plus sign.

 4.  Click in the upper-left corner of the Page Footer section to insert the chart control.

 5.  Close the Property Sheet and the Chart Settings pane, if necessary.

 6.  Hover your mouse pointer over the bottom right of the new 
chart control until a diagonal double-pointed arrow appears.

 7.  Resize the control by dragging to the bottom right until your 
chart is as tall as the Page Footer section and as wide as all 
text box controls in the Detail section.
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268 Glossary

parameter query Query that filters records and 
returns only a subset that matches the value entered, 
delivering on-the-fly results

referential integrity Relationship protocol that 
maintains the validity of related data; requires that the 
data types of related primary and foreign key fields are 
the same or compatible

smart tags Indicate common actions that may be taken 
if certain conditions are encountered or if a control has 
a problem; clicking a smart tag displays a list of possible 
actions

subform A secondary (child) form placed on a main 
(parent) form, allowing the user to view and complete 
data entries for multiple tables through one form 

subreports Display subsets of data derived from 
related database tables, similar to subforms

update query Query that makes global changes to a 
group of records in one or more tables

validation rule Field property that enables you to limit 
values entered in the field to reduce errors associated 
with data entry (e.g., limit the value typed into an Hours 
Worked field to less than 60)

validation text Contains instructions or valid data 
values to help guide the data entry personnel
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270 Index

L
less than or equal to (validation rule), 152
less than (validation rule), 152
like (validation rule), 152
L (input mask symbol), 149
locking form fields, 190
Long Integer format, 144
Long Text field, 147
lookup fields tables, 153–157

benefits of, 153–154
creating for multiple values, 156–157
performing lookups, 154–155
testing, 155

M
make table queries, 214–215
many-to-many relationships, 132
memo fields, 146
Modal Pop Up, 191
Modeless Pop Up, 191
moving columns, in tables, 141
Multiple Items option, 156

N
naming tables, 138–139
non-key fields, 145
numbering items reports, 238–240

setting properties for, 238
subreports, numbering separately, 

238–240

O
one-to-one relationships, 132

P
page breaks reports, 244
parameter queries, 212–214
Password (input mask symbol), 149
pop-up forms, creating, 191–192
printing, relationships, 137–138
Print Preview feature, 243
Property Options smart tag, 150
Property Sheets, for subforms, 181

Q
queries

action queries, 214–219
append queries, 215–216
crosstab queries, 208
delete queries, 218–219
find duplicates queries, 211
find queries, 210–212
find unmatched queries, 211
make table queries, 214–215
parameter queries, 212–214
update queries, 217

R
referential integrity requirements, 134
relationships

adding and modifying, 132–136
deleting, 137
Edit Relationships dialog box, 133
referential integrity requirements, 134
relationship cascade options, 134–136
reviewing, 136
types of, 132

Relationships window, 132
renaming

tables, 138–139
Replication ID format, 144
reports

adding subreports to, 233–236
charts in, adding, 244–246
creating from subreports, 236–237
date control, adding, 244
importing into database, 233
numbering items in, 238–240
page breaks in, setting, 243–244
setting properties for, 238
subreports, numbering separately, 

238–240
Required field property, 145
Required property, 143
Rich text field, 147
Running Sum property, 238, 240

S
saving table layout, 141–142
Show Table command, Relationships 

window, 132
smart tags, 150
subforms, 178–184

creating, 179–180
modifying, 181–184

subreports
creating reports from, 236–237
growing and shrinking, 242–243
numbering separately, 238–240
title for, creating, 236–237

symbols for input masks, 149–150

T
tables. See also queries

adding to, 139
benefits of lookup fields in, 153–154
captions, field property settings, 144
changing layout of, 142–143
creating for multiple values, lookup 

fields in, 156–157
default values, field property  

settings, 145
entering, field property settings, 147–148

tables (continued)
field property settings, 143–153
field size for number fields, field property 

settings, 144
formatting data using input masks, field 

property settings, 148–151
lookup fields in, 153–157
memo fields, field property settings, 146
moving and hiding, columns in, 141
performing lookups, lookup fields in, 

154–155
reasons for setting, field property 

settings, 143
required fields, making, field property 

settings, 145–146
saving layout of, 141–142
size of fields, field property settings, 144
testing lookup fields in, 155
text fields, custom, field property 

settings, 146
text fields, uppercase vs. lowercase, field 

property settings, 144
validation rules, field property  

settings, 152–153
width of, columns in, 140

Text Align property, 147
text boxes reports

adding and formatting, 239–240
moving and resizing controls for, 239

text fields, custom, 146
Text Format property, 144, 147
Text Formatting group, 142
Totals feature, 184–185

U
umatched queries, finding, 211
underscores, in table names in Access, 139
update queries, 217
Update To row, 217

V
Validation Rule property, 143
validation rules tables, 152–153
Validation Text property, 143

Y
Yes/No data type, 139–140
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