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Preface

T
his textbook is part of our new approach to learning for introductory computer 

courses. We’ve kept the best elements of our proven, easy-to-use instructional 

design and added interactive elements and assessments that offer enormous 

potential to engage learners in a new way. 

Why Did We Write This Content?
In today’s digital world, knowing how to use the most common software applications is critical, and 
those who don’t are left behind. Our goal is to simplify the entire learning experience and help every 
student develop the practical, real-world skills needed to be successful at work and in school. Using 
a combination of text, videos, interactive elements, and assessments, we begin with fundamental 
concepts and take learners through a systematic progression of exercises to achieve mastery.

What Key Themes Did We Follow?
We had conversations with dozens of educators at community colleges, vocational schools, and other 
learning environments in preparation for this textbook. We listened and adapted our learning solu-
tion to match the needs of a rapidly changing world, keeping the following common themes in mind:

Keep it about skills. Our content focus is on critical, job-ready topics and tasks, with a relentless focus 
on practical, real-world skills and common sense. We use step-by-step instructional design to ensure 
that learners stay engaged from the first chapter forward. We’ve retained our proven method of 
progressively moving learners through increasingly independent exercises to ensure mastery—an 
approach that has successfully developed skills for more than 25 years.

Keep it simple. Our integrated solutions create a seamless experience built on a dynamic instructional 
design that brings clarity to even the most challenging topics. We focus our content on the things 
that matter most and present it in the easiest way possible. Concise chunks of text are combined with 
visually engaging and interactive elements to increase understanding for all types of learners.

Keep it relevant. Fresh, original, and constantly evolving content helps educators keep pace with 
today’s student and work environments. We reviewed every topic for relevancy and updated it where 
needed to offer realistic examples and projects for learners.

How Do I Use This Book?
Our comprehensive learning solution consists of a print textbook, a groundbreaking interactive 
ebook, and our easy-to-use eLab course management tool featuring additional learning content, 
such as overviews and video tutorials, and assessment content. Our interactive ebook contains 
learning content delivered in ways that will engage learners.
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vi  Preface

Included with Your Textbook Purchase
Depending on your purchase option, some or all of the following are included with your textbook:

Interactive ebook: A dynamic, engaging, and truly interactive textbook that includes elements such as 
videos, self-assessments, slide shows, GIFs, and other interactive features. Highlighting, taking notes, 
and searching for content is easy. 

eLab Course Management System: A robust tool for accurate assessment, tracking of learner activity, 
and automated grading that includes a comprehensive set of instructor resources. eLab can be fully 
integrated with your LMS, making course management even easier.

Instructor resources: This course is also supported on the Labyrinth website with a comprehensive 
instructor support package that includes detailed lesson plans, lecture notes, PowerPoint presenta-
tions, a course syllabus, test banks, additional exercises, and more.

Student Resource Center: The exercise files that accompany this textbook can be found within eLab 
and in the Student Resource Center, which may be accessed from the ebook or online at:  
labyrinthelab.com/office19

We’re excited to share this innovative, new approach with you, and we’d love you to share your 
experience with us at: lablearning.com/share

Visual Conventions
This book uses visual and typographic cues to guide students through the lessons. Some of these cues 
are described below:

Cue Name What It Does

Type this text Text you type at the keyboard is printed in this 
typeface.

Action words The important action words in exercise steps are 
presented in boldface.

Ribbon Glossary terms are highlighted with a yellow 
background.

Note!  Tip!  Warning! Tips, notes, and warnings are called out with  
special icons.

 
Videos, WebSims, and other ebook or online 
content are indicated by this icon.

Command→Command→ 
Command→Command

Commands to execute from the Ribbon are 
presented like this: Ribbon Tab→Command  
Group→Command→Subcommand.

ÍÍ Design→Themes→Themes These notes present shortcut steps for executing 
certain tasks.

Display Settings
Multiple factors, including screen resolution, monitor size, and window size, can affect the appearance 
of the Microsoft Ribbon and its buttons. In this textbook, screen captures were taken at the native 
(recommended) screen resolutions in Office 2019 running Windows 10, with ClearType enabled. 
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L E A R N I N G  O B J E C T I V E S

ÝÝ Set Access options

ÝÝ Split a database

ÝÝ Explore switchboards and create a navigation 
form

ÝÝ Set and modify startup options

9 Customizing the 
Database Interface 
and Startup Options

ACCESS

S
hared databases can experience 

a growing number of issues that 

accompany the unpredictable 

actions of multiple users. To limit these issues, 

designers can modify interface and startup 

options to help reinforce consistent data 

entry and protect vital data. In this chapter, 

you will create a navigation form, which is an 

attractive, user-friendly interface that allows 

for quick and accurate data entry. You will 

also split a database to protect the database 

tables and their data while still allowing users 

to create and modify their own personal 

queries, forms, and reports. Finally, you will 

set and modify various Access options.
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268 Access Chapter 9: Customizing the Database Interface and Startup Options

Ý Project: Customizing—As You Like It
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You are building the company’s database, which is almost 
complete. The owner is concerned about its ease of use and future maintenance and would 
like to allow individuals to make their own customized queries and reports while maintaining a 
standard company interface and ensuring data validity and database security.

Setting Access Options
Each Microsoft Office application provides options to control the way the application performs. 
Access options can control the color of datasheets, set default fonts, create sections on the Naviga-
tion pane, add a title to the application window, customize the Quick Access toolbar, set a default 
startup form, and so on. Some options control settings for the active database, while others control 
default settings for all databases used on a particular device.

Displaying Access Options
The Access Options dialog box groups features by type. It lists the categories in a panel on the left 
side and their associated options in the panel on the right side. Some options are used frequently 
while others are rarely used.

Option sections for the selected General category show current settings.

Option 
categories


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Setting Access Options 269

Datasheet Effects
Users may prefer a specific font or cell style and don’t want to apply the desired changes each time 
they enter data. Options to customize how a datasheet will appear by default can be found in the 
Datasheet category of the Access Options dialog box. Examples of datasheet options that can be set 
include gridlines, cell effects, column widths, and font properties.

ÝÍ File→Options→Datasheet

DEVELOP YOUR SKILLS: A9-D1

In this exercise, you will display and explore options in the Access Options dialog box.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

 1.  Open A9-D1-WinDesign from your Access Chapter 9 folder and save it as: 
A9-D1-WinDesignRev

 2.  Choose File→Options and click the Datasheet category.

 3.  Explore the options for the current database but don’t change any.

These settings apply to any database opened using your installation of Access. Changing these settings 
will affect any database opened on this device from here out.

 4.  Click Cancel when you have finished.

Unless otherwise directed, keep Access and any databases or database objects being used open at the end 
of each exercise.
 

Setting Personal Information and Database Properties
The Access Options dialog box includes a General category that allows you to set the format in which 
databases are created and to set personal information for your copy of Microsoft Office.

Database properties are similar to other object properties, except they identify or describe an entire 
database, such as the database title and author, names of objects contained in the database, or the 
date and time it was created or last updated.

ÝÍ File→Options→General

ÝÍ File→Info

Note!

A
C

C
E

S
S
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270 Access Chapter 9: Customizing the Database Interface and Startup Options

DEVELOP YOUR SKILLS: A9-D2

In this exercise, you will you will personalize your copy of Microsoft Office and change database properties.

 1.  Choose File→Options.

The Access Options window opens with the Datasheet category selected.

 2.  Explore the general options for the database but don’t change them.

 3.  Click Cancel to close the Access Options dialog box.

Now you will set database properties.

 4.  Choose File→Info and follow these steps to set the database properties:

A

D

C

B

A Click the View and Edit Database Properties link.

B If necessary, click the Summary tab on the Properties dialog box.

C Type Jay Winchester in the Manager line.

D Type Winchester Website Design in the Company line.

 5.  Click OK.

Customizing the Navigation Pane
The Navigation pane is your tool for selecting database objects and identifying objects associated 
with each object type. You use the Navigation pane to display objects in different views. You can also 
customize it to contain additional sections to make the pane even more useful.

Navigation Pane Categories and Groups
The Navigation Options dialog box shows two list boxes: one that identifies the categories of 
objects displayed on the Navigation pane and one that shows the groups available for display  
on the pane.
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Setting Access Options 271

Categories 
available 
by default

Buttons for 
adding, deleting, 

and renaming 
items

Groups available 
for the selected 
category

Buttons for 
adding, deleting, 
and renaming 
groups

Working with Groups
Access prevents you from changing, deleting, or adding additional object type groups to the essential 
Tables and Related Views and Object Type categories. However, the Custom category allows you to 
rename, delete, and add groups to a category. When you add or rename groups in the Navigation 
pane, you must reassign objects to the groups so Access knows where to place them.

Customizing the Navigation pane applies the control settings to the active database only. You must 
customize the Navigation pane for any other databases. 

DEVELOP YOUR SKILLS: A9-D3

In this exercise, you will customize the Navigation pane and assign objects to new Navigation pane groups.

 1.  Choose File→Options and follow these steps to customize the Navigation pane:

A

B

C

A Choose Current Database.

B Scroll, if necessary, to the Navigation section.

C Click the Navigation Options… button.

Access displays the Navigation Options dialog box.

Note!

A
C

C
E

S
S
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272 Access Chapter 9: Customizing the Database Interface and Startup Options

 2.  Follow these steps to create a new item:

A

B

A Click Add Item.

B Type Winchester Web Design in the Custom Category 1 box and tap (Enter).

A new item named Winchester Web Design appears in the Categories list. 

 3.  Click Add Group.

A new item named Custom Group 1 appears in the Groups list.

 4.  Type Customers in the Custom Group 1 box and tap [Enter].

 5.  Click Add Group and then type Invoices and tap [Enter].

Microsoft Access 2019: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Setting Access Options 273

 6.  Click OK to close the Navigation Options dialog box. Click OK to close the Access Options 
dialog box.

 7.  Follow these steps to display the new Winchester Web Design category:

A

B

A Click the Navigation Pane Options button.

B Choose Winchester Web Design.

All objects for the Winchester Web Design category are in the Unassigned Objects group.

 8.  In the Unassigned Objects group on the Navigation pane, right-click the Customers table 
object and choose Add to Group→Customers.

 9.  One at a time, right-click the Customers Form, the Customer Invoice Report, and the 
Customer Invoice Subreport to add them to the Customers group.

 10.  Assign these objects to the Invoice group:
• InvoiceDetails
• Invoices
• Invoice Details Query
• Invoices Query

• Invoice Form
• Invoice Details Subform
• Invoice Details Report

 11.  Click the Navigation Pane Options button and choose Object Type.

The Navigation pane returns to the more traditional view, which groups objects by type (Tables, 
Queries, Forms, and Reports).

 

Setting Up Current Database Formats
Current database settings enable you to change the way Access displays and works with the active 
database. You can, for example, change the text Access displays in the title bar when the database is 
open, show or hide the Navigation pane, enable views, or change the way Access displays open objects.

Changing Title Text in the Application Bar
Sometimes, the actual filename assigned to a database may be different from the text you want 
users to see when they open the database. You can change the text that appears in the title bar using 
the Current Database options window.

Type the text you want displayed in the 
title bar into the Application Title text box.

A
C

C
E

S
S
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274 Access Chapter 9: Customizing the Database Interface and Startup Options

Setting Object Window Format
Open database objects are set to format as tabs within the database work area. You have to click the 
tab of the object you want to see in the work area.

Tabs for opened documents are 
aligned at the top of the work area.

You can change the format so objects display as overlapping windows in the work area, or you can 
move and resize the objects for easier comparison of styles, layout, and contents.

Overlapping windows 
have individual title 
bars that “float” in 
the work area.

After changing the document window options, close and then reopen the database to view the new 
settings.

ÝÍ File→Options

Tip!
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Setting Access Options 275

DEVELOP YOUR SKILLS: A9-D4

In this exercise, you will change settings for the current database, editing the title and changing the 
window options.

 1.  Choose File→Options and follow these steps to change the application title text and window 
display:

A
B

C

A Choose Current Database.

B Type Winchester Web Design as the application title.

C Choose Overlapping Windows.

 2.  Explore the other options for the current database and then click OK.

You must close and then reopen the database for the settings to take effect.

 3.  Choose OK in the message dialog box and then close and reopen the database.

 4.  Display the Customers and Products tables in separate windows.

 5.  Drag the title bar of the Products table window down slightly to view the Customers table.

Move and resize the open objects so you can see both at the same time.

 6.  Choose File→Options→Current Database, set the document window preference back to 
Tabbed Documents, and click OK. Then click OK in the message box.

 7.  Close the tables and then close the database.

A
C

C
E

S
S
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276 Access Chapter 9: Customizing the Database Interface and Startup Options

Splitting a Database
Sometimes users want to edit the design and layout of queries, forms, and reports or even develop 
their own objects to meet their particular needs. If the database is shared with other users, this may 
cause problems. 

Record Locking
Multiple users can simultaneously use an Access database to add, edit, and delete data. Whenever 
an Access database is opened, Access creates a small temporary file by the same name but with the 
extension .laccdb. This file manages record locking. The initial file extension character, l, stands for 
locked, which means whenever one user edits a record, no other user can edit it until the first user 
moves to another record—essentially “unlocking” it. Record locking helps maintain consistent data 
and protects the integrity of record updates.

Reasons for Splitting Databases
Allowing users to create their own objects in a shared database can create confusion and increase 
the chance of data corruption or broken database relationships. To protect company data, many 
businesses prohibit users from creating and saving new objects. One way to protect table data when 
allowing users to create and customize objects to meet their personal needs is to split the database.

The Database Splitter
The database splitter converts a database into two files: one that contains the tables holding the 
data that support all other database objects and one that contains the database reports, forms, 
queries, and other objects that use the data. After a database is split, multiple users in a networked 
environment can access the database at the same time. As a result, each user can access, design, and 
modify their own database objects and update data from the database tables without interrupting 
other users or increasing the number of objects contained in the central database.

Split Database Terminology
Two terms are often associated with split databases:

 Ý Front end refers to the up-front portion of a split database with which users interact—the queries, 
forms, and reports they use or may create and customize. Access places a blue arrow beside each 
table name in a split database to identify objects users can view but not change.

 Ý Back end refers to the underlying database tables that support the front end. These tables are 
protected so users cannot modify their structure. Access adds _be to the end of the back-end 
portion of the database filename.
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Splitting a Database 277

This temporary 
file indicates 

record locking.

Blue arrows 
identify tables 

with objects 
users cannot 

change.

The filename of 
the split database’s 
back end includes _be.

When you split a database, Access links the front and back ends of the database so users can work 
with controls on forms, queries, and reports.

Backing Up a Database Prior to Splitting
Access recommends you back up a database before you split it to preserve the database in case an 
error occurs during the splitting process. One quick way to do this is to select and copy the database 
in Windows Explorer and then paste a backup copy in the desired folder.

ÝÍ Database Tools→Move Data→Access Database→Split Database

DEVELOP YOUR SKILLS: A9-D5

In this exercise, you will split the Winchester Web Design database.

 1.  Open A9-D1-WinDesignRev from your Access Chapter 9 folder.

Do not open any database objects.

 2.  Choose File→Save As→Save Database As→Save As.

 3.  Navigate to your Access Chapter 9 folder; then change the filename to  
A9-D6-WinDesign-Backup and click Save.

You back up the database so you have a copy in case errors occur when the database is split.

 4.  Close the new backup database and then reopen A9-D1-WinDesignRev but don’t open any objects.

 5.  Choose Database Tools→Move Data→Access Database .

 6.  Review the information in the Database Splitter dialog box and then click Split Database.

Access opens the Create Back-End Database dialog box and displays the same filename with _be at 
the end to identify it as the back-end file.

A
C

C
E

S
S
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278 Access Chapter 9: Customizing the Database Interface and Startup Options

 7.  Navigate to your Access Chapter 9 folder and click Split.

 8.  Click OK in the message box.

All the table names now have a blue arrow in front of them.

 9.  Right-click the Customers table in the Navigation pane and choose Design View.

Access warns you that Customers is a linked table that can’t be modified; it’s linked to the back-end 
database. You can open the table in Design View, but you can’t modify the structure or data types. To 
add, change, and delete records, you’d open the table in Datasheet View. Any changes to data in the 
front-end database are reflected in the table in the back-end database.

 10.  Read the warning message and then click No.

 11.  Right-click the Customers Form in the Navigation pane and choose Design View.

The front-end form displays in Design View.

 12.  Select the Notes label and Notes text box and tap [Delete].

 13.  Save the form and close A9-D1-WinDesignRev.

 14.  Choose File→Open and navigate to your Access Chapter 9 folder; rename A9-D1-WinDesignRev 
to A9-D6-WinDesign-Split and then open A9-D1-WinDesignRev_be.

The Winchester Web Design tables are the only objects in the back-end database.

 15.  Close the back-end database.

Customizing the Database Interface
Access offers multiple options for customizing the user interface. Switchboards and navigation forms 
can be set to automatically open when a database is opened. They provide buttons and tabs to 
perform an array of functions from displaying forms and reports to printing, saving, and even closing 
the database and exiting Access.

Database Switchboards
A switchboard is an easy-to-use interface with menus and buttons for opening database objects and 
performing common tasks such as adding records and printing reports. 

Underlying Switchboard Items table

A sample switchboard form
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Customizing the Database Interface 279

The Switchboard Manager
Switchboards were common in older versions of Access. To create a switchboard, the Switchboard 
Manager command button must be on the Ribbon, which you can do via the Customize Ribbon 
group in Access Options. The Switchboard Manager button might be on the Database Tools tab if 
you open a database created in a previous version of Access or one that already contains a database 
switchboard.

Navigation Forms
An alternative to the switchboard is a navigation form, a special interface that allows you to quickly 
access forms and reports in your database. Microsoft introduced navigation forms to accommodate 
online databases published to the web because the Access Navigation pane will not display in a 
browser.

Navigation Form Features
A navigation form usually has tabs across the top to group common elements with subnavigation 
links along the left side or directly below. The navigation form opens like a regular form in the Access 
window.

Tabs can group forms and reports by subject.

Individual objects can be accessed via controls listed on the side of an active tab.

When you create a tab that matches the name of a form or report in the database, Access automatically 
assigns the form or report to the tab in the navigation form.

Navigation Form Layouts
The Winchester Web Design database includes the Employees Form, the EmployeeSpouses Form, 
and the Employee Report that you can place on the same Employees tab on a navigation form. You 
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280 Access Chapter 9: Customizing the Database Interface and Startup Options

can also add other forms and reports. Access offers six different navigation form layouts from which 
you can choose. You can also change the fonts, colors, and themes.

DEVELOP YOUR SKILLS: A9-D6

In this exercise, you will create a navigation form with tabs for the categories in the Winchester Web 
Design database. Then you will add subnavigation links for forms and reports within each tab’s category.

 1.  Choose File→Open and navigate to your Access Chapter 9 folder; rename  
A9-D6-WinDesign-Backup as A9-D7-WinDesignRev and then open that file.

 2.  Follow these steps to create a new navigation form:

C

A

B

A Click the Create tab.

B Choose Forms→Navigation.

C Choose Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View, which is the recommended view for editing.
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Customizing the Database Interface 281

 3.  Follow these steps to review the new navigation form:

A

B D

C

A Notice the form icon and title in the Form Header section.

B Click to select the Vertical Navigation control.

C Click to select the Horizontal Navigation control.

D Click to select the Navigation Subform.

 4.  Double-click the Add New tab in the 
Horizontal Navigation control and then 
type Employees and tap [Enter] to 
display another Add New tab.

You can point to the right border of a tab 
until the mouse appears as a two-headed 
pointer and drag the border to the left or 
right until the tab title is best displayed.

 5.  Create additional tabs for: Customers, Invoices, and Products

Add Items to Tabs
 6.  Follow these steps to add an item to a tab:

A

C

B

A Click the Employees tab.

B Drag the Employees Form into the Vertical Navigation control.

C When the pink bar appears just above the Add New tab, drop the form.
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282 Access Chapter 9: Customizing the Database Interface and Startup Options

 7.  Drag the forms and reports to the tab indicated:

Tab Form or Report

Employees EmployeeSpouses Form

Employees Employee Report

Customers Customers Form

Customers Customer Invoice Report

Invoices Invoice Form

Invoices Invoice Details Report

Products Product Form

Products Products Report

 8.  Save the form as WWD Navigation Form and then switch to Design View.

Add a Title and Logo and Apply Formatting
 9.  Delete the Title and Logo controls in the Form Header section.

 10.  Choose Form Design Tools→Design→Controls→Label and draw a label in the Form Header 
section.

 11.  Type Welcome to Winchester Web Design as the label, tap [Enter], and then set these 
properties on the Property Sheet:

Property Value

Width 5.5

Height 0.45

Top 0.1875

Left 1.5

Font Name Georgia

Font Size 22

Text Align Center

Font Weight Semi-bold

Fore Color Blue, Accent 1, Darker 50%

 12.  Click the Form Header section bar; type 0.8 for the Height property and choose Blue, Accent 
1, Lighter 80% for the Back Color property.

 13.  Choose Form Design Tools→Design→Controls→Insert Image , navigate to your Access 
Chapter 9 folder, and choose WWD-Logo.

If the WWD-Logo is displayed in the Image Gallery, you can just click it.

 14.  Draw the new logo image in the Form Header section to the left of the title.

 15.  In the Property Sheet, make these settings:

Setting Value

Width 0.7

Height 0.7

Top 0.05

Left 0.5
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Customizing the Database Interface 283

 16.  Click the Detail section bar and type Accent 1, Lighter 90% for the Back Color and 
Alternate Back Color properties.

 17.  Click the left column of the navigation form (NavigationControl5) in the Selection Type list and 
choose Transparent for the Back Style property.

 18.  Select the top navigation control row (NavigationControl0) and choose Transparent for the 
Back Style property.

 19.  Switch to Form View and click the Employees tab.

The form includes three objects listed for the Employees tab and the selected object displayed in the 
Navigation Subform.

 20.  Save the WWD Navigation Form.

Adding Custom Command Buttons
Now that you have a navigation form that opens each of the forms and reports in the database, you 
can use Design View to add command buttons that will perform functions. Then you can size and 
position the buttons and add the text that will be displayed on each button.

A button is added to the form to exit Access when work is completed.

When you use the Command Button control from the Ribbon to create an action command button 
on a form, the Command Button Wizard opens and walks you through the process. Placing command 
buttons in the Detail section will replicate the button for each entry in the form.

ÝÍ Form Design Tools→Design→Controls→Button

DEVELOP YOUR SKILLS: A9-D7

In this exercise, you will create a command button on the WWD Navigation Form. You will then add text 
and attach a command to the button.

 1.  Display the WWD Navigation Form in Design View.

 2.  Expand the Form Footer section by dragging the bottom of the form down.

 3.  Click the Form Footer section bar and type  Accent 1, Lighter 90% for the Back Color of 
the Form Footer section.
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284 Access Chapter 9: Customizing the Database Interface and Startup Options

 4.  Choose Form Design Tools→Design→Controls→Button   and draw a button in the main 
Form Footer section.

Access launches the Command Button Wizard after you draw the command button.

 5.  Follow these steps to complete the first button:

A

C

B

A Choose Application.

B Choose Quit Application.

C Click Next.
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Customizing the Database Interface 285

 6.  Follow these steps to complete the button:

A B

C

A Choose the Text option.

B Type Exit Access as the text to appear on the button.

C Click Finish.

 7.  Save changes to the form and then switch to Form View.

 8.  Click the Exit Access command button on the form.

The database and Access close.
 

Setting Startup Options to Open a Form
Switchboards and navigation forms provide an interface between the user and the forms, queries, 
and reports contained in the database. In many cases, data entry personnel have no need to create 
objects or see the Navigation pane.

As a result, many businesses set startup options that display either the most commonly used form, 
such as the Invoice Form, or the database interface so it is the first thing users see when they open the 
database. Setting these startup options is also a way to protect the database from unauthorized access.

Overriding Startup Options
After you set startup options for a database, the Navigation pane and many of the underlying objects 
and database tools may be hidden. To override the startup settings, press and hold the [Shift] key as 
you open the database in Access.

ÝÍ File→Options→Current Database
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DEVELOP YOUR SKILLS: A9-D8

In this exercise, you will set the WWD Navigation Form to open automatically each time you open the 
database.

 1.  Open A9-D7-WinDesignRev from your Access Chapter 9 folder.

 2.  Choose File→Options→Current Database and follow these steps to apply startup options:

B
C

A

A Click the Display Form list button and choose WWD Navigation Form.

B Uncheck the box to Display Navigation Pane located in the Navigation section.

C Click OK.

 3.  Click OK to acknowledge the message box.

 4.  Close the database and open it again.

Access opens the database with the navigation form hidden and the WWD Navigation Form 
displayed.

 5.  Click the Exit Access command button.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A9-R1

Set Options and Properties
You have been promoted to lead designer and are now responsible for all security aspects of the Kids for 
Change database. In this exercise, you will personalize Access, modify navigation options, and display 
multiple objects in an overlapping format.

 1.  Start Access, open A9-R1-K4C from your Access Chapter 9 folder, and save it as: 
A9-R1-K4CRev

Don’t forget to enable content.

 2.  Choose File→Options. In the General category, modify the username and/or initials as you feel 
necessary.

 3.  Choose Current Database, scroll to the Navigation section, and click the Navigation 
Options… button.

 4.  Click Add Item.

A new item appears in the Categories list named Custom Category 1. 

 5.  Type Kids for Change in the Custom Category 1 box and tap [Enter].

 6.  Click Add Group and type Activities for the new item that appears in the Groups List.

 7.  Add two more groups, using Children as the first name and Volunteers as the second.

 8.  Click OK twice.

 9.  Click the Navigation Pane Options button and choose Kids for Change.

Access places all objects for the Kids for Change category into the Unassigned Objects group. 

 10.  In the Unassigned Objects group on the Navigation pane, right-click the Activities table object 
and choose Add to Group→Activities.



A
C

C
E

S
S

Microsoft Access 2019: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



288 Access Chapter 9: Customizing the Database Interface and Startup Options

 11.  Right-click the Activities List query and add it to the Activities group and then add the 
Activities Form and Activity Costs Report.

 12.  Assign the Children table, Children List, Children Form, and Children Report to the Children 
group.

 13.  Assign the Volunteers table, Volunteers Subform, Volunteers Form, and Volunteers Report 
to the Volunteers group.

 14.  Click the Navigation Pane Options menu button � and choose Object Type.

The Navigation pane groups objects by type (Tables, Queries, Forms, and Reports).

Set Database Properties
 15.  Open the Access Options dialog box and choose Current Database.

 16.  Click the Application Title text box and type: Kids for Change

 17.  Choose the Overlapping Windows option and click OK.

You must close and then reopen the database for the settings to take effect.

 18.  Choose OK in the message dialog box; then close and reopen the database.

 19.  Open the Activities and Children tables to display the objects in separate overlapping windows.

You can move and resize the open objects so you can see both at the same time.

 20.  Close the database.

REINFORCE YOUR SKILLS: A9-R2

Create a Navigation Form and Set Startup Options
Kids for Change has asked you to provide a more efficient way for its data entry personnel to access forms 
and reports. In this exercise, you will create a navigation form that displays when the Kids for Change 
database is opened. 

 1.  Open A9-R2-K4C from your Access Chapter 9 folder and save it as: A9-R2-K4CRev

 2.  Choose Create→Forms→Navigation→Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View.

 3.  Double-click the Add New tab in the 
horizontal navigation control; type 
Activities as the tab name and tap 
[Enter].

 4.  Create four more tabs:

• Children

• Donors

• PaidStaff

• Volunteers
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 5.  Click the Activities tab and then drag the Activities form from the Navigation pane into the 
vertical navigation link area, placing it above the Add New tab.

 When the pink bar appears just above the Add New tab, drop the form.

 6.  Add the forms and reports to the tab indicated:

Tab Form or Report Tab Form or Report

Activities • Activity Costs Report PaidStaff • Staff Form

• Activity Staffing

• Activity Costs Report

Children • Children Form

• Children Report

Volunteers • Volunteers Form

• Volunteers Report

Donors • Donors Form

• Donations Report

• Monthly Donations Report

 7.  Save the form as K4C Navigation Form and then switch to Design View.

 8.  Delete all the controls in the Form Header section.

 9.  Choose Form Design Tools→Design→Controls→Label, draw a title label named  
Kids for Change in the Form Header section, and tap [Enter].

 10.  Enter these properties for the new title label:

Property Value

Width 4

Height 0.4

Top 0.2

Left 2

Font Name Cambria

Font Size 23

Text Align Center

Fore Color Blue, Accent 1, Darker 50%

 11.  Click the Form Header section bar; type 0.8 for the Height property and choose Dark Blue, 
Text 2, Lighter 80% for the Back Color property.

Tip!
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290 Access Chapter 9: Customizing the Database Interface and Startup Options

 12.  Choose Form Design Tools→Design→Controls→Insert Image , navigate to the Access 
Chapter 9 folder, and choose K4C-logo.bmp.

If the K4C-Logo is in the Image Gallery, you can click it there.

 13.  Draw the logo image in the Form Header section to the left of the title.

 14.  With the K4C-Logo selected, type 0.7 for the Width and Height properties, 0.05 for the Top 
property, and 0.5 for the Left property.

 15.  Switch to Form View and click each tab to verify that the objects display in the navigation 
subform; save your changes to the form.

Add a Command Button
 16.  Switch to Design View and expand the Form Footer section downward.

 17.  Choose Form Design Tools→Design→Controls→Button  and draw a button in the Form 
Footer section.

 18.  Choose Application and Quit Application, and then click Next.

 19.  Choose the Text option; type Exit Access and click Next.

 20.  Name the command button cmdExitAccess and click Finish.

 21.  Save your changes to the form.

Set Access Startup Options
 22.  Choose File→Options→Current Database.

 23.  Type Kids for Change for the application title.

 24.  Click the Display Form menu button � and choose K4C Navigation Form.

 25.  Click OK twice and then close and reopen the database.

The K4C Navigation Form opens when the database is opened and includes Kids for Change in the 
title bar and the Exit Access command button in the Form Footer.

 26.  Click the Exit Access command button to close the database and exit Access.

REINFORCE YOUR SKILLS: A9-R3

Split a Database and Hide the Navigation Pane
Kids for Change would like its table data to be protected. In this exercise, you will split the database and 
hide the Navigation pane to protect the table data from unauthorized users.

 1.  Open A9-R3-K4C from your Access Chapter 9 folder and save it as: A9-R3-K4C-Backup

 2.  Close the new backup database and reopen A9-R3-K4C, but don’t open any objects.

 3.  Choose Database Tools→Move Data→Access Database .
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 4.  Click the Split Database button and then navigate to your Access Chapter 9 folder and click 
Split.

 5.  Click OK in the message box.

Table names now have a blue arrow in front of them.

 6.  Right-click the Activities table in the Navigation pane and choose Design View.

Access informs you that Activities can’t be modified because it is linked to the back-end database. 

 7.  Click No in the message box.

 8.  Right-click the Volunteers Form in the Navigation pane and choose Design View.

 9.  Select the Available Day label and the ActID text box at the bottom of the Detail section and 
tap [Delete].

 10.  Save the form and then save the database as: A9-R3-K4CRev

Hide the Navigation Pane
 11.  Choose File→Options→Current Database.

 12.  In the Navigation section, uncheck the box next to Display Navigation Pane and then click OK.

 13.  Close and then reopen the database.

Access opens the database but does not display the Navigation pane.

 14.  Close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A9-A1

Set Options and Properties
As head of technology for Universal Corporate Events you have been tasked with fine-tuning the 
company’s database. In this exercise, you will personalize Windows settings, modify the object navigation 
options, and alter the way open objects appear on the screen.

 1.  Start Access, open A9-A1-UCE from your Access Chapter 9 folder, and save it as: 
A9-A1-UCERev

 2.  Choose File→Options. In the General category, modify the personal settings as you feel 
necessary.

 3.  Choose Current Database and open the Navigation Options dialog box.

 4.  Create a new item named: Universal Corporate Events

 5.  Create a new group named: Events

 6.  Add two more groups: Menus and Venues

 7.  Close the Navigation Options dialog box and the Access Options dialog box.

 8.  Click the Navigation Pane Options button and choose Universal Corporate Events.

Access places all objects for Universal Corporate Events into the Unassigned Objects group. 

 9.  In the Unassigned Objects group, right-click the Events table object and choose Add to 
Group→Events.

 10.  Assign these objects to their appropriate groups:

Group Object Group Object

Events • Event Revenue

• Event Pricing Entry

• Event Schedules

• EventCosts Subform

• Events Form

Venues • VenueLiaisons table

• Venues table

• Venue Events

• Venue Events Subform

• Venues Form

• Venues Report

Menus • Menus table

• Menus Form

• Event Menus Report

 11.  Click the Navigation Pane Options button and choose Object Type.

Set Database Properties
 12.  Open the Access Options dialog box and choose Current Database, if necessary.

 13.  Click the Application Title text box and type: Universal Corporate Events

 14.  Choose the Overlapping Windows option and click OK.

 15.  Choose OK in the message dialog box; then close and reopen the database. 


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 16.  Open the Personnel and Venues tables in separate overlapping windows.

You can move and resize the open objects so you can see both at the same time.

 17.  Choose File→Options→Current Database and reset the Document Window option to 
Tabbed Documents.

 18.  Close the database.

APPLY YOUR SKILLS: A9-A2

Create a Navigation Form and Set Startup Options
The president of Universal Corporate Events wants a custom navigation form. In this exercise, you will 
create a navigation form with links that open associated forms and reports as well as a command button 
that closes the database and exits Access. You will also modify the startup options.

 1.  Open A9-A2-UCE from your Access Chapter 9 folder and save it as: A9-A2-UCERev

 2.  Choose Create→Forms→Navigation→Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View.

 3.  Double-click the Add New tab in the horizontal navigation control and then type Events and 
tap [Enter].

 4.  Create two more tabs, naming the first Menus and the second Venues.

 5.  Click the Events tab and then drag the Event Costs form from the Navigation pane into the 
vertical navigation link area.

 6.  Add these forms and reports to the tab indicated:

Tab Form or Report Tab Form or Report

Events • Events Form

• Event Pricing Entry

• Event Schedules

• Event Revenue 
Report

Venues • Venues Form

• Venue Events Form

• Venues Report

Menus • Menus Form

• Event Menus Report

 7.  Save the form as: UCE Navigation Form

 8.  Switch to Design View and delete all controls in the Form Header section.

 9.  Display the Personnel Form in Design View.
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 10.  Copy the logo and title from the Personnel Form and paste them into the Form Header of the 
UCE Navigation Form. Then close the Personnel Form.

 11.  Click the Form Header section bar; on the Property Sheet, enter 0.8 for the Height property 
and choose Blue, Accent 5, Lighter 80% for the Back Color property.

 12.  Select the pasted title control and replace Personnel Form with: Navigation Form

 13.  Type 2 for the Left property.

 14.  Select the logo and type 0.5 for the Left property.

 15.  Switch to Form View and verify that each object displays in the navigation subform.

 16.  Save your changes to the form.

Add a Command Button
 17.  Switch to Design View.

 18.  Expand the Form Footer section of the main form by dragging the bottom of the form down.

 19.  In the main Form Footer section, create a command button with the text Exit Access that 
will close the application.

Hint: Choose the Application category with the Quit Application action.

 20.  Name the command button: cmdExitAccess

 21.  Save the form. Switch to Form View and click the new command button to close the database 
and Access.

APPLY YOUR SKILLS: A9-A3

Display the Navigation Form on Startup and Split the Database
The president of Universal Corporate Events wants the navigation form to be displayed on startup. She 
also wants to protect the table data from unauthorized use. In this exercise, you will set the newly created 
navigation form to display each time someone opens the database. You will then split the database.

 1.  Open A9-A3-UCE from your Access Chapter 9 folder and save it as: A9-A3-UCERev

 2.  Choose File→Options→Current Database.

 3.  Type Universal Corporate Events for the application title.

 4.  Click the Display Form list button and choose UCE Navigation Form.

 5.  Click OK twice.

 6.  Close and then reopen the database.

Access opens the database and displays the UCE Navigation Form.

The UCE Navigation Form automatically opens in Form View when the database is opened. The form 
includes Universal Corporate Events in the title bar and the Exit Access command button in the Form 
Footer.
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Split a Database
 7.  Close any open database objects and then choose File→Save As→Save Database As→Save As.

 8.  Navigate to your Access Chapter 9 folder, change the filename to A9-A3-UCERev-Backup 
and click Save to create a backup copy, and then close the database.

 9.  Open A9-A3-UCERev, choose Database Tools→Move Data→Access Database, and click 
Split Database.

 10.  Navigate to your Access Chapter 9 folder and click Split; click OK in the message box.

All the table names now have a blue arrow in front of them.

 11.  Right-click the Personnel table in the Navigation pane and choose Design View.

Personnel is linked to the back-end database and can’t be modified.

 12.  Click No in the message dialog box.

 13.  Right-click the Personnel Form in the Navigation pane and choose Design View.

 14.  Delete the word Grade from the Salary Grade label.

 15.  Close the Personnel Form, saving the changes.

 16.  Navigate to your Access Chapter 9 folder and open A9-A3-UCERev_be.

Tables are the only objects in the back-end database.

 17.  Close the database.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A9-E1 That’s the Way I See It
You would like to create a navigation form in the Blue Jean Landscaping database. Open A9-E1-BJL 
and save it as: A9-E1-BJLRev

Use these guidelines to create horizontal tabs and a vertical left navigation form: 

 Ý Create five tabs: Customers, Equipment, Manufacturers, Merchandise, and Sales

 Ý Add all related forms and reports to the corresponding tabs.

 Ý Add a title control with the name BlueJean Landscaping Navigation Form and then 
add a logo using BLJ-Logo.bmp.

 Ý Add a command button labeled Exit Database that exits the application.

 Ý Name the form: BlueJean Landscaping Navigation Form

Enhance the appearance of the forms and add any features you feel will help facilitate effective data 
entry.

A9-E2 Be Your Own Boss
As the owner of Blue Jean Landscaping, you would like to set startup options and apply database 
properties to help streamline user performance and security in the company database. Open 
A9-E2-BJL and save it as: A9-E2-BJLRev

Set an application title using the company name. Display the Blue Jean Landscaping Navigation 
Form on startup and apply overlapping windows. Then, hide the Navigation pane. Apply any other 
Access options you feel will help facilitate effective data entry or security.

A9-E3 Demonstrate Proficiency
Stormy BBQ is concerned about lower-level staff accessing database tables and inadvertently 
introducing errors and would like the database split to ensure data accuracy. It would also like to set 
navigation options. Open A9-E3-SBQ and save it as: A9-E3-SBQRev

Create a new navigation item labeled with the company name. Add the indicated 
groups. Add as many related objects as you can to the corresponding group and then 
split the database. Finally, apply any other Access options you feel will help facilitate 
effective data entry.



Groups

Daily

Menu

Merch

Staff

Restaurants
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ÝÝ Convert Access 2019 files to previous Access 
formats

ÝÝ Host Access files in SharePoint

ÝÝ Attach files to database records

ÝÝ Integrate Access data with Word and Excel

ÝÝ Display Access data on the web

10 Importing and 
Exporting Data Using 
Word, Excel, and HTML

ACCESS

D
ata can be stored on all types 

of computer systems and in 

many formats. Maintaining files 

and other data so they’re easy to share 

with others can be challenging; fortunately, 

Access tools make it relatively easy to 

import, export, format, and upload files 

for sharing. In this chapter, you will share 

Access data with other Microsoft Office 

programs, as well format data for other 

systems and the web.
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Ý Project: Capturing More Data
The Winchester Web Design database stores all data related to customers, employees, 
products, and invoices. Having all the data stored in one electronic file makes it very 
convenient for sharing it within the company. Sometimes, however, data must be exported so 
it can be used offsite by someone who may not have Access on their computer. You have been 
assigned the task to experiment with file formats to make both non-sensitive and sensitive 
data available to others.

Converting Access 2019 Databases to Earlier 
Formats

Access 2019 databases carry a unique format that is incompatible with versions of Access older than 
2007. The obvious difference is the filename extension. Versions of Access prior to 2007 created files 
with an .mdb extension. Access 2007–2019 versions create files with an .accdb extension (for Access 
database). To share a database made in a more current version of Access with someone who has an 
Access version prior to 2007, you must save the database in a format that the older version recognizes.

When you try to convert some newer databases to an earlier version of Access, you may get an error 
message.

Older versions of Access do not support some of the features and formats supported in more current 
versions, such as the Long Text data type that has replaced the Memo field, the Attachment data 
type that has replaced the OLE object field, and the Custom Web App and Web App Action Bar.

Identifying the Format of an Access Database
When you open a database, Access identifies the version of the file in the title bar.

When you open a database created in Access 2007–2019, the title 
bar will reference the Access 2007–2016 file format.

When you open a file created in an older version of Access, the title 
bar will reference the Access 2002–2003 file format.

ÝÍ File→Save As→Save Database As→Access 2002–2003 Database


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DEVELOP YOUR SKILLS: A10-D1

In this exercise, you will save an Access 2019 database in the Access 2003 file format.

 1.  Open A10-D1-WinDesign from your Access Chapter 10 folder and save it as: 
A10-D1-WinDesign2019

Remember to enable content, if necessary.

 2.  Choose File→Save As→Save Database As→Access 2002–2003 Database and then click 
Save As.

The Save As dialog box opens.

 3.  Change the filename to A10-D1-WinDesign2003 and click OK.

The filename and file format information display in the title bar, indicating that the database is now 
in Access 2002–2003 file format. The filename and path might be too long to show the file format, 
however. If you click the File tab, more of the path is visible.

 4.  Close all open databases.

Attaching Files to Database Records
Older versions of Access used fields with the OLE Object data type to add images to records. For 
example, a company might want to include employee photos in their employee table. However, adding 
a single uncropped, high-resolution image taken from one of today’s smartphones or adding long and 
wordy comments to records with long text fields can significantly increase the size of the database.

A database’s size affects its speed and efficiency. Attaching files—rather than embedding the data—
can significantly reduce the size of the database.

Using the Attachment Data Type
The Attachment data type allows you to attach one or more pictures, spreadsheet files, documents, 
charts, and other file types to a specific field in the table. You can use an Attachment field to store 
multiple files of varying file types without increasing the size of the actual database file.

Attachment Limitations and Notes
• After assigning the Attachment data type to a field, you cannot change it.

• A maximum of 2 gigabytes of data can be attached to a database.

• The file size for individual attachments is limited to 256 megabytes.

• You cannot attach files to a record in Access 2003 or earlier.

Managing Attachments
Access identifies fields that contain attachments 
with a paperclip icon in the field name. A paperclip 
icon followed by a number indicates the number of 
attachments for each individual record. For instance, 
you might have a products database where you have 
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one photo of the product front and another of the product back. Or perhaps you want to store both a 
casual and a publicity dress photo for your employees.

Adding an attachment is as simple as double-clicking the paperclip icon for the record to which you 
want to attach the file. Then you navigate to the image or file you want to attach.

DEVELOP YOUR SKILLS: A10-D2

In this exercise, you will add an Attachment field to the Winchester Web Design Employees table in Design 
View and attach two photos to a table record.

 1.  Open A10-D2-WinDesign from your Access Chapter 10 folder and save it as: 
A10-D2-WinDesignRev

 2.  Display the Employees table in Design View.

 3.  Follow these steps to add a new field to the table:

A B C

A Type EmpPhoto in the first available row in the Field Name column.

B Choose Attachment from the Data Type list.

C Type Office ID Photo in the Description column.

 4.  Save the changes to the table and then switch to Datasheet View.

 5.  Follow these steps to add an attachment to the first table record:

A

B

A Scroll to the new attachment field and double-click the paperclip icon for the first record.

B Click Add.
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 6.  Navigate to your Access Chapter 10 folder, double-click JayWinchester.jpg, and click OK.

Access places the number 1 in parentheses following the attachment icon for the first record.

 7.  Double-click the paperclip icon for record 1 to open the Attachments dialog box.

 8.  Click Add and then double-click JayAndJulie.jpg; click OK to close the Attachments  
dialog box.

Now a 2 follows the paperclip icon for the first record.

 9.  Double-click the paperclip icon again, select JayWinchester.jpg, and click Open.

The photo displays in your default program used to view images.

 10.  Switch to Access and close the Attachments box; save and close the Employees table.

Integrating Access with Word
There are several ways to share data between Access and Word—the easiest being to use Copy and 
Paste. For instance, you can select all or part of an Access table or query, copy it, and then open a 
Word document and paste the copied Access selection as an unlinked object.

A variation of this is to select the desired rows or columns in an Access table or query and export 
the data as a linked source to a Word document. A linked file allows source data to be placed into 
a destination file that is automatically updated when changes are made to the source file, so if you 
were to link an Access table to a Word document on Monday and then change the Access data on 
Tuesday, those changes would be reflected in the Word document the next time the Word file is 
opened (as long as the Access file hasn’t been deleted or moved).

Another process is Mail Merge, which allows you to merge selected data fields (such as names and 
addresses) with a Word document, producing personalized letters that can be mailed to thousands of 
potential customers. You can also publish Access data into a Word document for inclusion in a report.

There are additional Export tools on 
the External Data tab of the Ribbon 
that let you connect to other Micro-
soft Office applications using various 
file formats. One is a text file, or a 
plain alphanumeric text file without 
any formatting or font information. A variation of a text file is a rich text file (RTF), which contains 
minimal formatting, such as color or bold. Both text files and rich text files are very small in size, 
relative to normal Word documents, and are compatible across virtually all hardware and software 
platforms.

Copying Data from Access to Word
You can use copy-and-paste and drag-and-drop techniques to copy Access data into a Word  
document. Note that pasted data is not linked, so editing data that has been inserted into Word  
has no effect on the data stored in Access and vice versa.
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DEVELOP YOUR SKILLS: A10-D3

In this exercise, you will copy data from an Access table into a new Word document using copy-and-paste 
and drag-and-drop techniques.

 1.  Display the Products table in Datasheet View.

 2.  Follow these steps to make a copy of all the records in the Products table:

A

B

A Click the table selector button to select all product records.

B Choose Home→Clipboard→Copy.

 3.  Start Word, choose Open Other Documents, navigate to your Access Chapter 10 folder, and 
double-click A10-D3-WWD-ProdLetter.docx.

The document, a letter to the company’s customers, opens in Microsoft Word.

 4.  Position the insertion point under the line that reads …and consider adding one of these product 
features to your current website.
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 5.  Choose Home→Clipboard→Paste menu button �→Keep Source Formatting.

 6.  Close the Products table in Access.

 7.  Arrange your Word and Access windows side by side so you can view both programs 
simultaneously.

 8.  In Access, open the Employee Contact Info query.

 9.  Follow these steps to drag the Employee Contact Info query records into Word:

A

B

C

A Click the table selector button.

B Hover the mouse pointer over the left side of a field in the first column so it becomes a white 
arrow.

C Drag the records into the Word document and drop them where the insertion point is 
located.

The mouse pointer becomes a black circle with a line through it  as you drag records over the 
Access work area. When you cross onto the Word document, it becomes a white move arrow with a 
plus sign. When you copy and paste or drag data to a Word document, the name of the Access object 
(Employee Contact Info) is displayed as a title at the top of the object.

The drag-and-drop process can be challenging. You must precisely position the mouse pointer over the left 
side of a field in the first column. If you can’t get it to work, use Copy and Paste.

Note!
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 10.  Compare your Word document to this example.

If the report extends to a second page, delete any unnecessary blank lines.

 11.  Close the Employee Contact Info query.

 12.  Save the Word document as A10-D3-WWD-ProdLetterRev and then close it and exit Word. 
Maximize Access.

Publishing Data to Word
The most commonly used tools for integrating Access data with other applications appear in the Export 
group on the External Data tab, and other tools appear on the More list. These tools enable you to 
send data from a database object to Word and other applications. When you export a database object 
to Word, Access formats it in rich text format, launches Word, and opens the data in a new document. 
You can then edit and save the document in Word without affecting the data in the database.

You can use these same techniques to drag Access table data into Excel and PowerPoint.

ÝÍ External Data→Export→More→Word 

Tip!
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DEVELOP YOUR SKILLS: A10-D4

In this exercise, you will export a list of the Winchester Web Design employees to a Word document.

 1.  Open the Employees table in Datasheet View.

 2.  Choose the External Data→Export→More menu button �→Word .

The Export – RTF File dialog box opens.

 3.  Follow these steps to export the table to Word as a small, cross-platform rich text file:

B

C

A

A Click Browse, open your Access Chapter 10 folder, and save the file as: A10-D4-WWDEmp.rtf

B Click the Open the destination file after export… checkbox.

C Click OK.

Access exports the table and opens it in Word. When you export data to a Word document, there is 
no title added as there is when you copy data into Word.

 4.  Close the Export – RTF File dialog box and switch to Word.

 5.  Choose Layout→Page Setup→Margins and then choose Narrow to fit more of the data on 
the page.

 6.  Choose Layout→Page Setup→Orientation→Landscape.

 7.  Resize the columns to fit as much of the data on the page as possible.

 8.  Close the Word file, saving changes, if prompted.

 9.  Switch to Access and close the Employees table.

Merging Access Data with Word Documents
Access databases often contain valuable data that can be used in letters, mailings, and other  
documents. Retyping such data can be time-consuming and may result in inaccurate data entry.  
The Export tool is useful for merging data with Word.
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When merging data with Word, Access gives you two options:

 1.  Link to an existing Word document: This option creates a link to an existing document so 
Word can locate the database and pull the most up-to-date data into the merge document. The 
link between the Word document and the database includes a path used to locate the data each 
time you open the merge document. If the database file is moved to a different folder, Word will 
be unable to locate it and cannot complete the merge.

 2.  Create a new Word document: This option creates a new Word document and merges it 
with the data linked to an Access database table. The next time you open the Word document, 
Word automatically looks for the database containing the merge data.

ÝÍ External Data→Export→Word Merge 

DEVELOP YOUR SKILLS: A10-D5

In this exercise, you will export Access data containing customer addresses and link it to the Word 
customer letter.

 1.  Open the Customers table and choose External Data→Export→Word Merge .

The Microsoft Word Mail Merge Wizard opens.

 2.  Choose the Link Your Data to an Existing Microsoft Word Document option and click OK.

Access opens the Select Microsoft Word Document dialog box.

 3.  Navigate to your Access Chapter 10 folder and open A10-D3-WWD-ProdLetter.

Word opens your document along with the Mail Merge task pane.

 4.  Follow these steps in Word to add fields to the merge document:

A

C

B

A Click in the blank line between the phone number and the date.

B Choose Mailings→Write & Insert Fields→Insert Merge Field menu button �.

C Choose CustFirstName.
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 5.  Tap [Spacebar] to insert a space after «CustFirstName».

 6.  Choose Mailings→Write & Insert Fields→Insert Merge Field→CustLastName.

 7.  Tap [Enter] and choose CustStreetAddress from the Insert Merge Field list.

 8.  Tap [Enter] and choose CustCity from the Insert Merge Field list.

 9.  Type a comma, tap [Spacebar], and choose CustState from the Insert Merge Field list.

 10.  Tap [Spacebar] and choose CustZIP from the Insert Merge Field list.

If the field names were FirstName, LastName, City, etc., instead of CustFirstName, CustLastName, 
CustCity, you could click the Address Block icon to insert the address fields in one step.

 11.  Choose Mailings→Preview Results→Preview Results to verify the customer name and 
address display properly.

 12.  Save and close the Word document; exit Word.

 13.  Switch to Access and close the Customers table.

Integrating Access with Excel
Many people find using formulas in Excel more user-friendly and sophisticated than the calculated 
fields in Access. Luckily, you can send Access data to Excel to perform calculations. The process of 
sending data to other files or applications is called exporting data. The process of retrieving data 
from other files or applications is called importing data.
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Importing Data from Excel Files
When you import data from Excel, Access uses the Import Spreadsheet Wizard to guide you through 
the process. Imported data becomes part of the database file. Because the data is imported and not 
linked, any changes made to the Excel file after the import have no impact on the table data in Access. 

Tools on the External Data tab can be used to import and to export data.

The tool for importing from Excel 
is in the Import & Link group.

The tool for exporting to 
Excel is in the Export group.

ÝÍ External Data→Import & Link→New Data Source→From File→Excel .

DEVELOP YOUR SKILLS: A10-D6

In this exercise, you will import an Excel worksheet into your database.

 1.  Close all Access database objects and choose External Data→Import & Link→ 
New Data Source  to open the menu.

 2.  Choose From File→Excel .

Access launches the Get External Data – Excel Spreadsheet dialog box.

 3.  Choose the Import the Source Data into a New Table in the Current Database option,  
click Browse and navigate to your Access Chapter 10 folder, and double-click  
A10-D6-WebContacts.xlsx.

 4.  Click OK to launch the Import Spreadsheet Wizard.

 5.  Choose the Show Worksheets option and click Next.

 6.  Check the First Row Contains Column Headings box and click Next.

 7.  Click Next to import all worksheet fields to the new table, without changes.

 8.  Click Next to let Access create a primary key.

 9.  Type Web Contacts in the Import to Table Name box and click Finish.

 10.  Close the Get External Data window.
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View Imported Table Data
 11.  Open the new Web Contacts table.

The data imported is not linked to the Excel spreadsheet. If you update the data in Excel, it will not 
be updated in the Access file. Once this data is imported, there is no longer a connection between the 
two files.

 12.  Adjust column widths as needed and then save and close the Web Contacts table.

 13.  Close the WinWebDesign database.

 14.  Start Excel and open A10-D6-WebContacts.xlsx from your Access Chapter 10 folder.

 15.  Change the street address in cell C2 to: 888 Import Lane

 16.  Save and then close the A10-D6-WebContacts.xlsx file.

 17.  In Access, open A10-D2-WinWebDesignRev, close any open objects, and open the  
Web Contacts table.

Notice the address has not changed because the Excel worksheet was imported into Access but not 
linked to an Access table. 

 18.  Close the Web Contacts table.

Linking an Excel Worksheet to an Access Database
When you want the data in the Access database to reflect the 
most current data contained in an Excel spreadsheet, you can 
import and link the Excel spreadsheet to the Access data-
base table. When you link a spreadsheet to a database, any 
change to the spreadsheet data is reflected in Access when 
you open the linked table in Access. Access uses an Excel icon, 
with a small arrow to the left, to identify a table linked to a 
spreadsheet. 

No edits can be made to linked spreadsheets from within the 
Access table. You must open the source Excel spreadsheet to 
make changes to the data or structure.

DEVELOP YOUR SKILLS: A10-D7

In this exercise, instead of importing, you will link the WebContacts spreadsheet to the Winchester Web 
Design database.

 1.  Choose External Data→Import & Link→New Data Source→From File→Excel .

 2.  Choose the Link to the Data Source by Creating a Linked Table option, click Browse,  
navigate to your Access Chapter 10 folder, and open A10-D6-WebContacts.xlsx.

 3.  Click OK to launch the Link Spreadsheet Wizard.
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 4.  Click Next to accept Sheet1.

 5.  Check the First Row Contains Column Headings checkbox and click Next.

 6.  Type Web Contacts Linked in the Linked Table Name box and click Finish.

 7.  Click OK in the Link Spreadsheet Wizard message and locate the linked item, identified by the 
Excel icon and arrow in the Navigation pane Tables group.

 8.  Open the Web Contacts Linked table in Access and try to edit the data.

The object icon indicates that the table is linked. Access prevents data editing when the linked file is 
open in Access. 

 9.  Close the Web Contacts Linked table.

 10.  Switch to Excel and open A10-D6-WebContacts.xlsx.

 11.  Change the street address in cell C2 to: 222 Link Lane

 12.  Save and then close A10-D6-WebContacts.

 13.  Switch to Access and open the Web Contacts Linked table.

The street address for the first record is now 222 Link Lane because the table is linked to the updated 
Excel worksheet.

 14.  Close the Web Contacts Linked table.

Fixing Broken Links
When you link an Excel spreadsheet to an Access database, Access identifies the drive and folder in 
which the Excel file was located at the time you created the link. Access searches for the Excel file 
each time you open the database. If the original Excel file was moved and the path is no longer valid, 
Access is unable to connect to the linked file. 

As a result, Access contains a feature called the Linked Table Manager that aids in locating and redi-
recting the database to the correct file so you can view the data. A list of linked files along with the 
external location in which it is stored are displayed in the Linked Table Manager dialog box. Linked 
files can then be selected along with an option to tell Access you want to redirect the link to a new 
location where the file has been moved. 

ÝÍ External Data→Import & Link→Linked Table Manager 
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DEVELOP YOUR SKILLS: A10-D8

In this exercise, you will open the Linked Table Manager and update the linked table location.

 1.  Choose External Data→Import & Link→Linked Table Manager .

 2.  Follow these steps to review the information contained in the dialog box:

A

C
B

A Click the checkbox beside the linked filename and review the linked file identified.

B Check the Always Prompt for New Location checkbox.

C Click OK.

The Always Prompt for New Location option enables you to navigate to the folder containing the 
linked file if the file has been moved.

 3.  Locate the Excel file A10-D6-WebContacts.xlsx and click Open.

 4.  Click OK to acknowledge that the linked tables were successfully refreshed.

 5.  Click Close in the Linked Table Manager dialog box.

 6.  Close the A10-D2-WinDesignRev database.

Exporting Access Data to Excel
If you want to use the Excel calculations on Access data, you can export the data to create a new 
Excel file. Some fields, such as ZIP codes, which are defined as the Short Text data type, or a Yes/No 
data type, which displays values of True/False, may require additional formatting or manipulation in 
Excel. Overall, though, the steps are similar to those used to export Access data to merge with Word.

ÝÍ External Data→Export→Excel 
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DEVELOP YOUR SKILLS: A10-D9

In this exercise, you will export data from an older Winchester Web Design Invoices table to create a new 
Excel workbook.

 1.  Open A10-D9-Invoices from your Access Chapter 10 folder and save it as: 
A10-D9-InvoicesRev

 2.  Click the Invoices table in the Navigation pane to select it (but don’t open it).

 3.  Choose External Data→Export→Excel .

 4.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the first two available 
checkboxes under Specify Export Options.

 5.  Click Browse, navigate to your Access Chapter 10 folder, and save the file as:  
A10-D9-Invoices.xlsx

 6.  Click Save and then click OK in the Export – Excel Spreadsheet dialog box.

Excel opens the new workbook containing the invoice data. Resize columns as necessary.

 7.  Close the workbook, saving if prompted. Exit Excel and switch back to Access.

The Save Export Steps dialog box is displayed and indicates that Invoices was successfully exported.

 8.  Close the Export dialog box, without saving the export steps, and close the database. 

Displaying Access Data on the Web
In addition to sharing data from Access with other Microsoft Office applications, Access allows data 
to be stored on the web, either by hosting data on a SharePoint site, saving the database file directly 
to online storage, or exporting database objects in an HTML format universally available to anyone 
in the world. Additionally, there may be times when you want to add web page access to database 
objects.

Storing Data on Microsoft SharePoint
A database file can be hosted on Microsoft SharePoint. This allows any SharePoint user to access 
the data from a SharePoint list at any location with an Internet connection using a web browser. You 
can assign permission levels for each user, restricting or allowing them to complete specified actions 
such as only reading data, making changes to data, or having full control over the design. A database 
synchronized to a SharePoint site can be modified in Access offline and any changes will appear to 
the SharePoint site when reconnected.
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Alternately, you can save a database file directly to SharePoint, allowing users to access the database 
at any location with an Internet connection. Doing so requires an active SharePoint site with user 
authentication for accessing and editing the database file.

Exporting Access Objects as Web Pages
Hypertext Markup Language (HTML), the code or language in which web pages are written, allows 
files to be formatted and viewed in any web browser, anywhere in the world. Access allows you to 
save each database object separately as an HTML file and display that data online.

Updating HTML Data
When data in the database changes, HTML files do not automatically update. Consequently, many 
companies update their HTML files regularly and display a date and time to indicate when data was 
published. To create a web-based file for Access data, you use the External Data tab to export the 
object as an HTML file.

Saving HTML-Formatted Objects
When you export a database object as an HTML file, you can preserve the formatting and layout 
of what you have already designed in Access. When you click OK, Access displays the HTML Output 
Options dialog box, which enables you to choose the default or other encoding to apply to the file.

ÝÍ External Data→Export→More→HTML Document 

DEVELOP YOUR SKILLS: A10-D10

In this exercise, you will export a table in HTML format and view it in a web browser.

 1.  Open A10-D2-WinWebDesignRev and close any open objects.

 2.  Click the Products table in the Navigation pane to select it.

 3.  Choose External Data→Export→More→HTML Document .

The Export-HTML Document window appears.

 4.  Click Browse, navigate to your Access Chapter 10 folder, and click Save.

 5.  Check the first two checkboxes under Specify Export Options and click OK.

The HTML Output Options dialog box appears.
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 6.  Click OK to create the file with the default encoding.

Access creates the HTML file and opens it as a web page in your default web browser. You can now 
upload it to your website or to your network.

 7.  Close your web browser window.

 8.  Switch back to Access and close the dialog box.

Importing HTML Files
When data you want to use is in an HTML file, you can import that data to create a new table, 
append it to an existing table, or link the HTML file to the database. The steps for importing HTML 
data are similar to those used to import Excel and other types of data.

ÝÍ External Data→Import & Link→New Data Source→From File→HTML Document 

DEVELOP YOUR SKILLS: A10-D11

In this exercise, you will import a list of web resources contained in an HTML file into Access as a new table.

 1.  Close any open objects in the A10-D2-WinDesignRev database.

 2.  Choose External Data→Import & Link→New Data Source→From File→HTML Document .

 3.  Click Browse and navigate to the Access Chapter 10 folder.

 4.  Double-click A10-D11-WebResources.html and select the Import the Source Data into a 
New Table in the Current Database option.

 5.  Click OK to launch the Import HTML Wizard.

 6.  Check the First Row Contains Column Headings checkbox and click Next.

 7.  Click Next again, this time to keep the existing field names and data types and to import all 
fields into the table.

 8.  Choose the No Primary Key option and click Next.

Because the HTML document is just a short list of website addresses, there is no need to set a primary 
key to uniquely identify each site.

 9.  Type Resources for the Import to Table name and click Finish.
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 10.  Close the dialog box. Open the Resources table and resize the columns as necessary.

 11.  Review the data and then save and close the Resources table.

Adding Hyperlinks to Database Objects
Hyperlinks attached to database forms and reports are a convenient way to access other database 
objects, external files associated with the database, or websites. You can create a hyperlink to:

 Ý Open an external website.

 Ý Launch another application and open a specific file.

 Ý Add a new table field for a customer’s email address.

The Insert Hyperlink dialog box enables you to select an existing file or web page, an object in the 
active database, or an email address. Although the hyperlink text generally identifies the action of 
the hyperlink, you can also add a ScreenTip to display more descriptive text when the user points to 
the hyperlink. Typically, hyperlinks are underlined and formatted a light blue text color. When you 
point to a hyperlink, the mouse pointer appears as a pointing hand. Clicking (rather than double-
clicking) performs the action associated with the hyperlink.

Text to display for the link

Buttons to 
display the 

type of 
hyperlink

Button to set a 
descriptive ScreenTip

HTML file in the current folder

ÝÍ Form Design Tools→Design→Controls→Link 

DEVELOP YOUR SKILLS: A10-D12

In this exercise, you will add a hyperlink to Winchester’s About Us Page form.

 1.  Display the About Us Page form in Design View.
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 2.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link  to 
open the Insert Hyperlink dialog box.

 3.  Follow these steps to add a hyperlink to the company web address: 

A

C

B

D

A Choose Existing File or Web Page.

B Type Microsoft.com for the text to display.

C Type http://microsoft.com for the address.

D Click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 4.  Switch to Form View and click the hyperlink.

The Microsoft website opens in your web browser.

 5.  Close your browser window. Close all database objects, saving changes if necessary, and then 
exit Access.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A10-R1

Format Fields and Integrate with Word
As lead designer for Kids for Change, you are in charge of database maintenance. Kids for Change has 
asked you to store staff photos in the database and export data to a Word document. In this exercise, you 
will add an attachment field for staff photos, copy Access data to Word, and export a table to Word in 
rich text format.

 1.  Open A10-R1-K4C from the Access Chapter 10 folder and save it as A10-R1-K4C-Rev, 
choosing Yes when asked to close all open objects.

To begin, you will create an Attachment field.

 2.  Display the PaidStaff table in Design View.

 3.  Scroll down to the first empty row and complete the field using these guidelines: 

• Type StaffPhoto in the Field Name column.

• Choose Attachment from the Data Type list.

• Type Staff ID Photo in the Description column.

 4.  Save the PaidStaff table and switch to Datasheet View.

 5.  Double-click the paperclip icon for the first record (Matthew Bryant).

The Attachments dialog box opens.

 6.  Click Add, navigate to your Access Chapter 10 folder, and double-click MathewBryant.jpg.

Access adds the filename of the photo to the Attachments dialog box.

 7.  Click OK to close the Attachments dialog box and then close and save the PaidStaff table.

Copy Access Data to Word 
 8.  Display the K4CActivityList table in Datasheet View.

 9.  Click the table selector button and then choose Home→Clipboard→Copy .

 10.  Start Word and open A10-R1-K4C-Welcome.docx from your Access Chapter 10 folder.

 11.  Position the insertion point under the line Below are just a few of the activities we are offering this 
year and choose Home→Clipboard→Paste.

 12.  Save the Word document in your Access Chapter 10 folder as: A10-R1-K4C-WelcomeRev 

 13.  Switch back to Access and close K4CActivityList.

 14.  Position the Word and Access windows side by side and make sure the We hope that you... para-
graph is visible in the Word document.

 15.  Open the Welcome Staffers query in Access and click the table selector button to select all 
staffer records.


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 16.  Hover the pointer over the left side of the first column so it becomes a white arrow and then drag 
and drop the records below We hope that you... in the Word document.

 17.  Save and close the Word document.

Export Access Data to Word
 18.  Switch to Access and maximize the window.

 19.  Close the Welcome Staffers query and then click the Venues table to select it.

 20.  Choose External Data→Export→More→Word .

 21.  Click the Browse button, navigate to your Access Chapter 10 folder, and save the file as: 
A10-R1-K4C-Venues

 22.  Click the Open the Destination File After the Export Operation Is Complete checkbox and 
click OK.

 23.  Close the Word document, saving the changes if prompted, and then close the Export – RTF File 
dialog box in Access.

Merge Access Data into a Word Document
 24.  Open the Volunteers table and choose External Data→Export→Word Merge.

The Microsoft Word Mail Merge Wizard opens.

 25.  Choose Link Your Data to an Existing Microsoft Word Document and click OK.

 26.  Open A10-R1-K4C-WelcomeRev from your Access Chapter 10 folder; maximize the Word 
window.

 27.  Position the insertion point under the K4C logo and above Dear K4C Volunteer, and then choose 
Mailings→Write & Insert Fields→Insert Merge Field menu button �→VolFirstName.

Access inserts the table field between chevrons on the document.

 28.  Tap [Spacebar] and enter the VolLastName field.

 29.  On the next line, enter the VolStreet field.
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 30.  On the next line, enter the VolCity field, then the VolST field, and then the VolZIP field, taking 
care to include spaces between fields and a comma after the city.

 31.  Choose Mailings→Preview Results  to verify the customer name and address display properly.

 32.  Save and close the Word document and exit Word. Save and close the database.

REINFORCE YOUR SKILLS: A10-R2

Integrate Access with Excel
Kids for Change would like you to share some of the data in its database with Excel. In this exercise, you 
will add a table that is linked to an Excel spreadsheet and export a table to Excel.

 1.  Open A10-R2-K4C from your Access Chapter 10 folder and save it as: A10-R2-K4CRev

To begin, you will import unlinked Excel data into Access.

 2.  Choose External Data→Import & Link→New Data Source →From File→Excel.

Access launches the Get External Data – Excel Spreadsheet dialog box.

 3.  Choose Import the Source Data into a New Table in the Current Database, click Browse, 
and open A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder.

 4.  Click OK to launch the Import Spreadsheet Wizard and import the data using these guidelines:

• First Row Contains Column Headings.

• Import all worksheet fields to the new table, without changes.

• Let Access add the primary key.

• Type Venue Contacts for the Import to Table name.

 5.  Close the Get External Data window without saving the import steps.

 6.  Open the new Venue Contacts table and resize the columns as desired.

The table lists four fields and nineteen records. The data is not linked to the source table in Excel, so if 
you update the data in Excel, the Access file will not update.

 7.  Save and close the Venue Contacts table.

Link an Excel Spreadsheet to an Access Database
 8.  Choose External Data→Import & Link→New Data Source→From File→Excel .

 9.  Choose Link to the Data Source by Creating a Linked Table, click Browse and open  
A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder, and click OK.
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 10.  Check the First Row Contains Column Headings checkbox and click Next.

 11.  Type Venue Contacts Linked for the Linked Table name and click Finish; click OK in the 
message box.

The imported table has a different icon than the other tables in the Navigation pane. The icon has an 
arrow pointing toward the Excel icon instead of the Access table icon.

 12.  Open A10-R2-K4C-Contacts in Excel and change the contact for All Angels Church from Kevin 
Gregory to: Dina McMullen

 13.  Save and close Excel and then switch to Access and open the Venue Contacts Linked table.

The name is also changed in the table.

 14.  Close the Venue Contacts Linked table.

Use the Linked Table Manager
 15.  Choose External Data→Import & Link→Linked Table Manager .

 16.  Click the checkbox beside the linked filename and review the linked file identified.

 17.  Check the Always Prompt for New Location checkbox and click OK.

Access opens the Select New Location dialog box so you can navigate to the folder containing the 
linked file—in the event the file has been moved.

 18.  Open A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder.

 19.  Click OK in the dialog box and then close the Linked Table Manager dialog box.

Export Access Data to Create a New Excel Workbook
 20.  Click Donations Query in the Navigation pane and then choose External Data→Export→ 

Excel .

 21.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the Export Data with 
Formatting and Layout and Open the Destination File After the Export Operation Is 
Complete checkboxes.

 22.  Save the export in your Access Chapter 10 folder as: A10-R2-K4C-Donations.xlsx 

 23.  Click OK in the dialog box. Close Excel and then close the Export – Excel Spreadsheet box.

REINFORCE YOUR SKILLS: A10-R3

Integrate Access with the Web
Kids for Change would like you to share some of the data in its database for display on the web. In this 
exercise, you will import an HTML file as a new database table, export a table to view on the web, and add 
a hyperlink from the Activities Form to the Activity Costs Report.

 1.  Open A10-R3-K4C from your Access Chapter 10 folder and save it as: A10-R3-K4CRev

You will begin by exporting an object in HTML format.

 2.  Close the navigation form and then select the Activities Query in the Navigation pane.

 3.  Choose External Data→Export→More→HTML Document .

 4.  Click Browse, navigate to your Access Chapter 10 folder, and save the file as:  
A10-R3-K4C-Activities.html

 5.  Check the Export Data with Formatting and Layout and Open the Destination File After 
the Export Operation Is Complete checkboxes.
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 6.  Click OK twice to create the file with the default encoding.

Access creates the HTML file and opens it as web page in your default web browser. You can now 
upload it to your website or to your network.

 7.  Close your web browser window; switch back to Access and close the Export – HTML Document 
dialog box.

Import an HTML File as a Database Object
 8.  Close any open objects and then choose External Data→Import & Link→New Data Source→ 

From File→HTML Document .

 9.  Click Browse and open A10-R3-K4C-Partners.html from your Access Chapter 10 folder; 
select Import the Source Data into a New Table in the Current Database and click OK.

 10.  Check the First Row Contains Column Headings checkbox and click Next.

 11.  Click Next to accept the default field names and data types, choose No Primary Key on the 
next screen, and click Next.

 12.  Type NonProfits for the Import to Table name and click Finish.

 13.  Close the Get External Data dialog box. Open the NonProfits table and size the columns so you 
can view the data.

 14.  Review the data and then save and close the NonProfits table.

Add a Hyperlink to a Form
 15.  Display the Activities Form in Design View.

 16.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link .

 17.  Choose Object in This Database, expand the Reports section, choose Activity Costs Report, 
and click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 18.  Drag the new hyperlink control to the right of the Telephone controls.

 19.  Save the changes to Activities Form, switch to Form View, and click the hyperlink.

The Activity Costs Report opens. 

 20.  Close Access, saving any changes.
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 Apply Your Skills
APPLY YOUR SKILLS: A10-A1

Change the Database Format, Create Attachments, and Integrate 
Access with Word
Universal Corporate Events needs your help adding employee photos and merging data with Word. In this 
exercise, you will add an attachment field to a table for employee photos. Then you will copy Access data 
into Word, export a table to Word, and merge Access data into a Word document.

 1.  Start Access, open A10-A1-UCE from your Access Chapter 10 folder, and save it as: 
A10-A1-UCERev

 2.  Open the Personnel table in Design View. Type PerPhoto in the first available Field Name 
record, choose the Attachment data type, and enter the description: Personnel ID Photo

 3.  Save the Personnel table and switch to Datasheet View.

 4.  Add the ReneeAllison.jpg photo from your Access Chapter 10 folder to the Renee Allison 
record.

 5.  Close the Attachments dialog box; save and close the Personnel table.

Copy and Export Access Data to Word 
 6.  Start Word and open A10-A1-UCE-Promotions.docx from your Access Chapter 10 folder.

 7.  Run the Event Organizers query in Access and then select all records in the query datasheet.

 8.  Position the Word and Access windows side by side and then drag and drop the Access query 
records into the Word document on the empty line below the paragraph that ends ...contact one 
of our Event Organizers first!

 9.  Close the Event Organizers query and then maximize the Word window.

The bottom portion of the letter includes the Event Organizers query. The name of the Access object is 
displayed as a title at the top of the object.

 10.  Save the Word document in your Access Chapter 10 folder as: 
A10-A1-UCE-PromotionsRevised

 11.  Select the Menus table and choose External Data→Export→More→Word.

 12.  Click Browse and save the file in your Access Chapter 10 folder as: A10-A1-Menus.rtf

 13.  Check the Open the Destination File After the Export Operation Is Complete checkbox 
and click OK.

 14.  Close the Word document; switch to Access, close the dialog box, and then maximize the Access 
window.

Merge Access Data into a Word Document
 15.  Open the BusinessOwners table in Datasheet View and choose External Data→Export→ 

Word Merge.

 16.  Link your data to the Word document A10-A1-UCE-PromotionsRevised in your Access 
Chapter 10 folder.


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 17.  Position the insertion point under the UCE URL and above the date and then create an address 
block as described:

• On the first line, choose First_Name from the merge fields list, tap [Spacebar), and choose 
Last_Name.

• On the second line, choose Address.

• On the third line, choose City, ST, and ZIP and add a comma and space between each field.

 18.  Choose Mailings→Preview Results→Preview Results.

 19.  Close the files in Word and Access, saving changes when prompted.

APPLY YOUR SKILLS: A10-A2

Integrate Access Data with Excel and Link Spreadsheets
The president of Universal Corporate Events wants you to integrate some of the company’s data with 
Excel. In this exercise, you will add a table that links to an Excel spreadsheet and export a table to Excel.

 1.  Open A10-A2-UCE from your Access Chapter 10 folder and save it as: A10-A2-UCERev

 2.  Choose External Data→Import & Link→New Data Source→From File→Excel.

 3.  Choose to link your data by creating a linked table and then browse to your Access Chapter 10 
folder and open A10-A2-UCE-Customers.xlsx.

 4.  Check the First Row Contains Column Headings checkbox and click Next.

 5.  Type BestCustomers-Linked for the Import to Table name and click Finish.

 6.  Click OK in the message box and then open the new BestCustomers-Linked table.

In the next few steps you will change the last name Fran to Francesca in the second record of the Excel 
spreadsheet. This change will be reflected in the Access table because they are linked. 

 7.  Close the table, saving it if prompted, and then open A10-A2-UCE-Customers.xlsx in Excel 
and change the first name in the second record from Fran to: Francesca
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 8.  Save and close the Excel workbook and then open the BestCustomers-Linked table in Access.

The first name is also changed to Francesca in the table.

 9.  Close the BestCustomers-Linked table.

 10.  Choose External Data→Import & Link→Linked Table Manager.

 11.  Mark the checkbox beside the linked filename, check the Always Prompt for New Location 
checkbox, and click OK.

 12.  Locate the A10-A2-UCE-Customers file and click Open.

 13.  Click OK in the dialog box and then close the Linked Table Manager.

Export Access Data to Create a New Excel Workbook
 14.  Select the Menus table in the Navigation pane and choose External Data→Export→Excel.

 15.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the two available  
checkboxes under Specify Export Options.

 16.  Click Browse, save the file as A10-A2-UCE-Menus in your Access Chapter 10 folder, and click OK.

Excel opens and displays the workbook containing the Menus data. 

 17.  Close the Excel workbook and then switch to Access and close the Export - Excel Spreadsheet box.

 18.  Close the database, saving any changes.

APPLY YOUR SKILLS: A10-A3

Export and Import to the Web and Add Hyperlinks
In this exercise, you will export a table to make it available for viewing on the web, import an HTML file as 
a table, and add a hyperlink from the Venues Form to the Venue Revenue Report.

 1.  Open A10-A3-UCE from your Access Chapter 10 folder and save it as: A10-A3-UCERev

 2.  With the Menus table selected, choose External Data→Export→More→HTML Document.

 3.  Click Browse and save the file in your Access Chapter 10 folder as: A10-A3-UCE-Menus.html

 4.  Check the boxes for Export Data with Formatting and Layout and Open the Destination 
File After the Export Operation Is Complete; click OK.

 5.  In the HTML Output Options Dialog box, leave the option for Default Encoding selected and 
click OK.

Access creates the HTML file and opens it as a web page in your default web browser.

 6.  Close your web browser window. Switch back to Access and close the Export – HTML Document 
dialog box.

Import an HTML File as a Database Object
 7.  Close any open objects and then choose External Data→Import & Link→New Data 

Source→From File→HTML Document.

 8.  Click Browse, open A10-A3-UCE-Events.html from your Access Chapter 10 folder, and click OK.

 9.  Check the First Row Contains Column Headings checkbox and click Next.

 10.  Click Next again to accept the default field options, choose No Primary Key on the next screen, 
and click Next.
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 11.  Type AdditionalEvents for the Import to Table name and click Finish.

 12.  Close the Get External Data dialog box and then open the AdditionalEvents table and widen 
the columns as necessary.

 13.  Review the data and then save and close the AdditionalEvents table.

Add a Hyperlink to a Form
 14.  Display the Venues Form in Design View.

 15.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link.

 16.  Type Open Venue Revenue Report for the Text to Display.

 17.  Choose Object in This Database in the Insert Hyperlink dialog box.

 18.  Expand the Reports section, click Venue Revenue Report, and click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 19.  Drag the hyperlink control to the right of the Venue ID.

 20.  Save changes to the Venues Form and then switch to Form View.

When you point to the hyperlink, a ScreenTip displays the hyperlink’s destination.

 21.  Click the hyperlink to open the Venue Revenue Report in Report View.

 22.  Close all open database objects and then close the database.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A10-E1 That’s the Way I See It
To streamline customer outreach, you want to export data from the Blue Jean Landscaping database 
to Word. Open A10-E1-BJL and save it as A10-E1-BJLRev

Use the Customers table and the Mail Merge function to export the indicated 
fields into the A10-E1-BJL-Promotion document in the empty area between the 
date and body of the letter.

Open the Services table and copy the Services column header and field data, 
pasting it into empty space between the two body paragraphs. Enhance the 
appearance of the Word document using any techniques you feel will help 
improve customer outreach.

A10-E2 Be Your Own Boss
You want to export data in the Blue Jean Landscaping database to a spreadsheet so you can perform 
quick calculations. You also need to link new merchandise data from Excel. Open A10-E2-BJL and 
save it as: A10-E2-BJLRev 

Export the Merch Sales Query as an Excel spreadsheet named Merch Sales.xlsx and preserve 
the data with formatting and layout. Use A10-E2-BJL-NewMerchandise.xlsx to create a linked 
table named New Merch that contains the column headings from the sheet’s first row. Apply any 
changes to the table you feel will help improve data entry or visual appearance.

A10-E3 Demonstrate Proficiency
Stormy BBQ is concerned that sales employees cannot access merchandise data while they are 
on the road. They would like you to publish it to the web for easy access and to add a hyperlink to 
the MerchSales form. Lastly, they’ve asked you to begin adding photos of the current staff. Open 
A10-E3-SBQ and save it as: A10-E3-SBQRev 

Export the MerchSales table as an HTML document named MerchSales.html (preserve the data 
with formatting and layout). Add a hyperlink to the Merchandise table at the bottom-left corner of 
the MerchSales form using Available Merchandise as the text to display. Add an Attachment 
field to the Staff table and attach the HankGore.jpg file to the Hank Gore record. Apply any other 
changes you feel will help improve the database.



Fields to Add:

First Name

Last Name

Street Address

City

ST

ZIP
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L E A R N I N G  O B J E C T I V E S

ÝÝ Add command buttons to forms

ÝÝ Manage database objects and create macros

ÝÝ Back up, restore, analyze, compact, and repair a 
database

ÝÝ Set database security using encryption and 
passwords

11 Maintaining a 
Database

ACCESS

A
s you prepare your database for 

distribution, you will make your 

last design tweaks and confirm 

it is optimized for speed and ease of use. At 

this stage, security should be a main priority, 

as protecting a database from data loss 

and unauthorized access is critical. In this 

chapter, you will customize Access settings 

and add easy-to-use command buttons to 

a form. You will also create macros; explore 

database security features; set a database 

password; and then analyze, compact, and 

repair a database.
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Ý Project: Improving and Maintaining a Database
The prototype of the Winchester Web Design database is almost complete. After reviewing 
the database, the company’s owner is pleased with the overall design. He now wants to add 
some command buttons and macros to improve navigation and to ensure the database runs as 
efficiently as possible. A major concern is the security of the database and the data it contains. 
The owner would like to institute both security protocols and a regular backup policy.

Using Command Buttons to Improve Navigation
In addition to adding labels, text boxes, images, and other controls to database forms, you can add 
command buttons to use for record navigation, such as finding a record or going to the previous/next 
record, and report operations, such as printing a specific report or even exiting Access. To create a 
button, you draw a button shape in the desired location on the form and use the Command Button 
Wizard to walk you through the process.

ÝÍ Form Design Tools→Design→Controls→Button 

DEVELOP YOUR SKILLS: A11-D1

In this exercise, you will add command buttons to the Form Footer section of the Invoice Form to make 
navigation easier and to quickly view an invoice report.

 1.  Open A11-D1-WinDesign from your Access Chapter 11 folder and save it as: 
A11-D1-WinDesignRev

 2.  Enable content and then close the Winchester Web Design Navigation Form.

Many of the activities in this chapter require you to enable content to function properly. Enable content 
when the option appears.

 3.  Open the Invoice Form in Design View.

 4.  Click the Form Footer section bar and type 0.75 for the Height property on the Property Sheet. 
(Hint: Tap [F4] to open the Property Sheet.)

 5.  Choose Form Design Tools→Design→Controls→Button .

 6.  Draw a button in the Form Footer under the left end of the subform.

If the Command Button Wizard doesn’t open, delete the button and then choose Form Design 
Tools→Design→Controls→Use Control Wizards and draw the button again.



Note!
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 7.  Follow these steps to add a command button:

Your command button may show a different number than 33.

A

C

B

A  Choose the Record Navigation category.

B  Choose the Go To First Record action.

C  Click Next.

 8.  Click the Picture option, choose Go To First, and click Next.

 9.  Enter cmdFirst as the meaningful name and click Finish.

The command button shows the Go To First picture in the Form Footer section and is programmed to 
go to the first record when in Form View.

 10.  Repeat steps 5–9 to add commands in the order shown:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

 11.  Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action; click Next.
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 12.  Select the Invoice Details Report as the report to preview and click Next.

 13.  Choose the MS Access Report picture, if necessary, and click Next.

 14.  Enter the name cmdPreviewInvoices and click Finish.

 15.  Select the new buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

 16.  With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

 17.  Switch to Form View and test each button.

 18.  If necessary, close the Invoice Details Report and then save and close the Invoice Form.

Creating Macros to Improve Efficiency
A macro is an object that combines a series of steps into a single step so a more detailed task can be 
automated. For example, if you regularly export your data to another database, instead of choosing 
External Data→Export→Text File and then entering the filename and selecting export options, you 
could create a macro to perform all the steps with one double-click of the mouse. 

The ExportCustomers macro exports the Customers table to the default My Documents folder as 
a text file (bottom figure). If needed, a specific file path could be entered for the output file.

ÝÍ Create→Macros & Code→Macro 
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DEVELOP YOUR SKILLS: A11-D2

In this exercise, you will create a macro that will display a message box to provide basic directions on when 
and where to back up the Winchester Web Design database.

 1.  Choose Create→Macros & Code→Macro .

 2.  Choose MessageBox from the Add New Action drop-down menu.

 3.  Enter the following into the MessageBox text boxes:

Property Setting

Message Be sure to back up every Friday

Beep Yes

Type Information

Title Back-Up Policy

 4.  Save the macro as: Back-Up Policy

 5.  Choose Macro Tools→Design→Tools→Run  to test the macro.

A message box should appear with the title, message, and icon you entered.

 6.  Click OK to close the message box.

 7.  Close the Back-Up Policy macro.

Back-Up Policy is now listed in the Navigation pane under the Macros group heading.
 

Using Macros to Display Adaptable Reports
Now that you have created a simple macro to display a reminder message, you can add a command 
button to a form that will run a macro to display a report. By adding a “where” condition, you can 
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332 Access Chapter 11: Maintaining a Database

not only open the report of your choosing, you can also specify the macro to display a specific record 
within the report based on matching the criteria for a field in the current object. For example, if you 
would like to print the invoice that corresponds to the record displayed in your Orders form, you can 
set the macro to display only the record that matches the Order ID field in both the Orders form and 
the Invoices report.

DEVELOP YOUR SKILLS: A11-D3

In this exercise, you will create a macro button that will be placed on the Employees Form to display a 
report of all the sales for the specific employee selected.

 1.  Choose Create→Macros & Code→Macro .

 2.  Open the Add New Action drop-down menu, scroll the list downward, and choose 
OpenReport.

 3.  Open the Report Name drop-down menu and choose Invoice Details Report.

 4.  Complete the OpenReport text boxes as indicated:

As you start to enter in the Where Condition text box, Access will suggest field names from a  
drop-down menu, allowing you to quickly and more accurately select from the list.

Property Setting

Report Name Invoice Details Report

View Report

Where Condition [EmpID]=[Forms]![Employees Form]![EmpID]

Window Mode Normal

 5.  Save the macro as: Invoice Details Report by Employee

 6.  Display the Employees Form in Design View.

 7.  Choose Design→Controls→Button  and draw a button in the top-right corner of the 
Details section of the Employees Form.

The Command Button Wizard starts.

 8.  Choose the Miscellaneous category and the Run Macro action; click Next.

 9.  Choose Invoice Details Report by Employee and click Next.

 10.  Accept the default macro picture and click Next again.

 11.  Name the button cmdRptByEmployees and click Finish.
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 12.  Switch to Form View and navigate to Mike Waters (EmpID MJW).

 13.  Click the new Run Macro button to display all records in which the EmpID is MJW.

 14.  Close the report and form, saving the changes to the form.

Managing Database Objects
Protecting databases and the quality of data they contain is vital to the reliability and performance 
of any database. At the same time, learning efficient ways to manage database objects helps to save 
a great deal of time as you build a database. The general cleanup and maintenance of a database 
can be accomplished in a number of ways. You can create new objects from existing objects, rename 
database objects, and delete unneeded or duplicate database objects.

Creating New Objects from Existing Objects
Often, databases contain separate objects that are similar in structure and in the data they hold. 
For example, the Employees table in the Winchester Web Design database contains fields similar to 
those found in the Customers table. When you build a database that contains similar objects, you can 
copy the original object, save it using a new name, and then modify the new object to fit its specific 
needs. There are two basic ways to copy objects:

 Ý Use the Save Object As command and rename the object to create another instance of it.

 Ý Use the contextual menu Copy and Paste commands.

Renaming Database Objects
You might create a table, query, form, or report and save it with the first name that comes to mind 
and then, after working with the object for a while, you might want to change the name. When an 
object is renamed, Access automatically renames all the relationships and record sources that use 
the renamed object. For instance, if you update the Invoices table to Orders, the record source for 
the queries, forms, and reports based on the table will be updated to reflect the new name.

Deleting Database Objects
During the development of a database, there are times when it is wise to create a temporary table, 
query, form, or report for testing purposes. Once the database is completed, you should remove 
these objects so they don’t clutter the Navigation pane or confuse users. 

DEVELOP YOUR SKILLS: A11-D4

In this exercise, you will copy, rename, and delete a report. You will also save a table in the Winchester 
Web Design database as a new table and edit the field names for the new table.

 1.  Right-click the Products Report in the Navigation pane and choose Copy.

 2.  Right-click again and choose Paste, keep Copy Of Products Report as the report name, and click OK.

 3.  Right-click Copy Of Products Report and choose Rename; type Delete This Report and 
tap [Enter].
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334 Access Chapter 11: Maintaining a Database

 4.  Select the Delete This Report report in the Navigation pane.

 5.  Tap [Delete] and click Yes to confirm the deletion.

You can also right-click an object and choose Delete from the menu.

 6.  Open the Employees table and choose File→Save As→Save Object As→Save As.

 7.  Type Business Contacts in the Save ‘Employees’ To text box and click OK.

 8.  Switch to Design View.

 9.  Select and edit the Business Contacts field names, replacing each Emp prefix with a Bus prefix 
(so EmpID is BusID, EmpLastName is BusLastName, and so on).

 10.  Right-click the HireDate field, choose Delete Rows, and then click Yes to confirm.

 11.  Delete the WebCert field and then save the changes to the Business Contacts table.

 12.  Switch to Datasheet View to confirm your changes and then close the Business Contacts table.

Backing Up a Database
All databases should be safeguarded to protect their data. Most organizations have a scheduled 
procedure to back up all files on their network, including the databases.

When you back up a database using the built-in Access tools, Access automatically places the date 
of the backup in the filename so you can easily identify and retrieve each backup file. You choose 
the drive and folder in which you want to save the backup. To restore the database, simply open the 
backup.

ÝÍ File→Save As→Save Database As→Back Up Database 

DEVELOP YOUR SKILLS: A11-D5

In this exercise, you will back up your Winchester Web Design database.

 1.  Close any open objects in the Winchester Web Design database.

 2.  Choose File→Save As→Save Database As→Back Up Database  and then click Save As.

Access opens the Save As dialog box and adds the current date to the end of the filename.

 3.  Save the file in your Access Chapter 11 folder.

Access saves the backup file to the desired location, adding the date the backup occurred to the 
filename. However, the open database file is still the original Winchester Web Design database.

 4.  Close the database, navigate to your Access Chapter 11 folder, and open the backup database.

A backup is only as current as the time the backup was created. It’s important to have a policy that 
schedules and mandates a daily or weekly backup.

 5.  Close the backup database and reopen A11-D1-WinDesignRev.

Tip!
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Analyzing and Documenting Databases
Each time you change the design or content of a database, the chance that the database will become 
corrupted increases. Access includes several tools that help you protect, document, analyze, and 
even repair databases. The main tools found in the Analyze group on the Database Tools tab are:

 Ý Performance Analyzer: This tool analyzes the performance of a database to locate and identify 
potential trouble spots that affect how the database functions.

 Ý Database Documenter: This tool documents objects in the database so you can track changes 
to design and relationships. It builds an Object Definition document that provides a detailed 
description of each database object.

Reviewing and Analyzing Performance
When you run the Performance Analyzer, Access reviews each selected object in the database, looks 
at all the relationships, and identifies any problems that might affect database performance. Access 
often makes recommendations for improvements to optimize database efficiency. In some cases, 
Access identifies tables in which no primary key is set. In other cases, Access will suggest a more 
efficient data type or that you use fewer controls on a form.

Some changes recommended by the Performance Analyzer may not be necessary. For example, 
Access frequently recommends that phone numbers be formatted using the Number data type. Not 
only is this unnecessary, it may even cause problems for extensions that are commonly preceded 
by an X, such as X209. As you review the recommended changes, you will begin to identify those 
requiring your attention and those you can ignore.

There are two options for analyzing database performance. The Analyze Performance tool enables 
you to choose the database objects you want to analyze. The Analyze Table tool analyzes a table 
using the Table Analyzer Wizard.

ÝÍ Database Tools→Analyze→Analyze Performance 

Documenting a Database
As you plan a new database, you must analyze the needs of the business and the requirements of the 
database. In the process, you create a list of fields required and then organize and group those fields 
into the tables that will provide the data for forms, queries, and reports. The list identifies and defines 
each field and the tables and objects in which the fields are used within the database. When the 
database is finished, you may choose to document the database so it can be efficiently updated and 
maintained in the future.

Documentation provides insight into the structure of the entire database as well as the structure 
of each object within the database. Maintaining a database can be very time-consuming. Without 
proper documentation to identify potential impacts of changing field properties, object structures, 
and so forth, you can potentially corrupt one database object that, in turn, wreaks havoc on the entire 
database. Each time you change the structure of any database object, remove an object from, or add 
an object to the database, you should run the Database Documenter to provide up-to-date documen-
tation about the database. Such information will prove invaluable to database administration.

ÝÍ Database Tools→Analyze→Database Documenter 
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DEVELOP YOUR SKILLS: A11-D6

In this exercise, you will analyze and document your Winchester Web Design database.

 1.  Choose Database Tools→Analyze→Analyze Performance .

The Performance Analyzer opens.

 2.  Click the Tables tab and click Select All to check all the tables listed.

 3.  Click OK and view the suggestions under Analysis Notes.

The data types have been set properly, so you can ignore the suggested ideas.

 4.  Click Close.

 5.  Choose Database Tools→Analyze→Database Documenter .

The Documenter opens.

 6.  Click the Tables tab, check the InvoiceDetails, Invoices, and Products tables, and click OK.

Access produces a report about a dozen pages long that documents the tables, fields, and 
relationships of the selected tables.

 7.  Scroll through the report and examine the documentation provided.

 8.  Choose Print Preview→Data→Excel  to open the Export Excel Spreadsheet Wizard.

 9.  Check the Open the Destination File After the Export Operation Is Complete box, if 
necessary.

 10.  Click Browse, navigate to your Access Chapter 11 folder, type A11-D6-Objects as the  
filename, click Save, and then click OK.

 11.  Browse through the Excel spreadsheet and close it when finished.

 12.  Close the wizard without saving the export steps and then close the print preview.
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Compacting and Repairing a Database
When you delete a record in Access, the record is not really deleted—it’s marked for deletion. 
The process of marking a record as deleted is quicker than completely deleting and reordering or 
rewriting all the records in a table. A similar process is used when you shorten the contents of a 
record—the space that was used for the longer data is not released.

As you work with databases, they can become sluggish and the data stored in the databases can 
become fragmented. Fragmentation occurs when parts of your database file become separated by 
incidental data that has been added to the disk you are using. For example, if you saved a 10-mega-
byte database file to your hard drive and saved an Excel spreadsheet to the same hard drive shortly 
afterward, it would be written next to the 10-megabyte database file. 

Then, if a large group of new records were added to the database file, they would have to be stored 
after the Excel file and not after the original database file because the adjacent space is now occu-
pied by the spreadsheet. As you add more records and save other files, both your files and storage 
drive become fragmented and less efficient.

Consequently, over time databases can become bulky and inefficient. This issue can be resolved by 
compacting, or compressing, your database to remove wasted and unused space left from deleted 
and edited records. 

To ensure optimal performance, Access enables you to compact and repair databases as often as you 
want. Sometimes Access recognizes a problem when a database is opened and attempts to repair 
the file before you work with it. Even if there is no file corruption, the normal maintenance tasks of 
adding, deleting, and editing records, creating and running queries, and so forth, may reduce data-
base performance. You may want to compact and repair the database manually on a regular basis or 
set an option to automatically compact the database whenever you close Access.

ÝÍ Database Tools→Tools→Compact and Repair Database 

DEVELOP YOUR SKILLS: A11-D7

In this exercise, you will compact and repair your Winchester Web Design database.

 1.  Close any open database objects.

 2.  Choose Database Tools→Tools→Compact and Repair Database .

Access compacts and repairs the file. Because the database is relatively small, the compact and repair 
process takes only a moment. For larger databases, the process will take longer. 

 3.  Close A11-D1-WinDesignRev and exit Access.

Setting Database Security
Imagine your doctor stores all your medical records in a large database that could be accessed by hospi-
tals, clinics, and medical insurance companies who want to know more about the medications you take, 
conditions you might have, and doctor’s visits. Databases, by nature, often hold confidential information. 
As a result, security is imperative. Companies that maintain large database files often restrict access to 
databases at the login or server level. Splitting a database can protect the data contained in databases, 
and Access offers tools that enable you to secure a database by assigning a password.
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Opening a Database Exclusively
Most large business databases are designed to provide access to multiple users at the same time. 
As a result, the default setting for a database is as a shared file. Before you can set security for a 
database, you must ensure no one else is currently using the database. You do this by opening the file 
exclusively so Access locks the database and prevents others from accessing it at that time.

The Open dialog box contains numerous commands for opening databases after a file has been 
selected.

COMMANDS FOR OPENING DATABASES

Command Description
Open Provides full and typical access to the database and its objects 

and menus so you can create and edit

Open Read Only Opens the database so you can view and print data but does not 
allow design changes; however, you can save the database as a 
new file and edit that one 

Open Exclusive Opens the database and locks it to prevent other users in a 
shared environment from accessing it

Open Exclusive Read-Only Opens the database and locks it so other users cannot access it 
and prevents edits to data and database objects

Encrypting a Database Using a Password
Regardless of whether a backup routine is in place, valuable time can be lost reconstructing data if 
unauthorized users damage the database. Database passwords are intended to protect the database 
just as the passwords you use to access bank accounts or email accounts protect your financial and 
personal information.

Limits of Passwords
Database passwords provide limited security for databases by preventing unauthorized users from 
opening the database. You can set a password for any database you have on your personal computer, 
just as systems administrators set a password for shared databases on a network. 

Access passwords are case-sensitive, or capable of distinguishing between upper- and lowercase 
characters.

Strong Passwords
Access passwords can use a combination of upper- and lowercase characters, symbols, and numbers. 
Access allows you to use any combination of characters in passwords except “ \ [ ] : | <> + = ; , . ? and *. 
Strong passwords are at least thirteen characters long and contain at least one of each of the char-
acter types indicated. Passwords cannot start with a space.

Weak Password: webdesign

Strong Password: TooHard2Cr@ck

Setting Up Databases for Assigning Passwords
To assign a database password, the database must initially be closed. The default access setting for 
databases that appear on a network is as a shared database, accessible to anyone who has access to 
its file location. To set a password, you must open the database exclusively using the Open Exclusive 

Tip!
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command in the Open dialog box. This ensures that no one else is currently using the database and 
that, once you open it, other users are prohibited from opening it until you close it. If the file is not 
opened exclusively, you will get a warning message.

The Encrypt with Password command is a toggle. When a database has a password, the command button 
shows Decrypt Database.

ÝÍ File→Info→Encrypt with Password 

DEVELOP YOUR SKILLS: A11-D8

In this exercise, you will open the Winchester Web Design database exclusively and set a database 
password to protect the database.

 1.  Start Access, choose Open Other Files from the menu, and click Browse.

 2.  Navigate to your Access Chapter 11 folder; click A11-D1-WinDesignRev but do not open the 
database.

 3.  Click the Open menu   button and choose Open Exclusive.

 4.  Enable content and then close the WWD Navigation Form.

 5.  Choose File→Info→Encrypt with Password .

 6.  Type Labyrinth123! in the Password text box and again in the Verify text box and then click 
OK.

 7.  Click OK to acknowledge that row level locking will be ignored.

 8.  Close A11-D1-WinDesignRev and then open it again.

 If you forget your password, you won’t be able to open the database.

 9.  Type Labyrinth123! in the Enter Database Password text box and click OK.

You must open the database exclusively again if you want to change or remove the password.

 10.  Close A11-D1-WinDesignRev.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Note!

Warning!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A11-R1

Enhance and Clean Up a Database
Kids for Change would like to improve its forms by adding navigation and accessibility to other objects 
using buttons. It would also like to clean up database objects. In this exercise, you will add command 
buttons; create a macro that opens a report; and do some cleanup tasks by copying, renaming, and 
deleting objects.

 1.  Start Access; open A11-R1-K4C from your Access Chapter 11 folder, and save it as: 
A11-R1-K4CRev

Remember to enable content if the option appears. You will begin by adding command buttons to a form. 

 2.  Open the Activities Form in Design View.

 3.  Click the Form Footer section bar and set the Height property to: 0.75

 4.  Choose Form Design Tools→Design→Controls→Button  and draw a button in the form 
footer under the Telephone label.

The Command Button Wizard opens.

 5.  Choose Record Navigation as the category and Go To First Record as the action; click Next.

The wizard displays a sample button picture for each action.

 6.  Leave the options for pictures as selected, click Next, enter cmdFirst as the meaningful name, 
and click Finish.

The command button shows the Go To First image in the Form Footer section and is programmed to 
go to the first record when in Form View.

 7.  Add these buttons in the order listed:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

 8.  Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action.

 9.  Select the Activity Costs Report as the report to preview and click Next.

 10.  Choose the Preview picture and click Next; enter the name cmdPreviewCosts and click Finish.

 11.  Select the new command buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

All of the command buttons are aligned to the top.


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 12.  With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

 13.  Switch to Form View and test each of the new buttons; close the Activity Costs Report.

Create a Macro to Display Adaptable Reports
 14.  Choose Create→Macros & Code→Macro .

 15.  Choose OpenReport from the Add New Action menu.

 16.  Use this table to create the macro:

Report Name Volunteers Report

View Report

Where Condition [ActID]=[Forms]![Activity Staffing]![ActID]

 17.  Save the macro as Available Volunteers and then close it.

 18.  Display the Activity Staffing form in Design View and then choose Form Design Tools→ 
Design→Controls→Button .

 19.  Draw the new button to the right of the Meet Time controls.

 20.  Choose the Miscellaneous category and the Run Macro action, click Next, choose Available 
Volunteers, and click Next again.

 21.  Accept the default macro picture and click Next; name the button VolunteersMacro and 
click Finish.

 22.  Switch to Form View and click the new VolunteersMacro button.

The macro button displays the Volunteers Report record for the activity on the form. 

To display the Volunteers Report for another activity, close the report, navigate to the desired activity, 
and click the macro command button.

 23.  Close the Volunteers Report and then save and close the Activity Staffing form.

Rename, Delete, and Save Object as a New Object
 24.  Right-click Donations Report in the Navigation pane and choose Copy.

 25.  Right-click again, choose Paste, type Delete This Report as the report name, and click OK.

 26.  Select Delete This Report in the Navigation pane and tap [Delete]; click Yes to confirm the 
deletion.

 27.  Open the PaidStaff table and choose File→Save As→Save Object As→Save As.

 28.  Type Professional Contacts in the Save ‘PaidStaff’ To text box and click OK.

 29.  Display the new Professional Contacts table in Design View and rename the StaffID field to: 
ProfID

 30.  Right-click the Parent field and choose Delete Field; confirm the deletion.

 31.  Delete the Masters, HrlySal, and ActID fields. Click Yes to permanently delete the fields and 
to delete the ActID indexes.

 32.  Rename the Email Address field as: ProfEmail

 33.  Save and close the Professional Contacts table and then close the database.
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REINFORCE YOUR SKILLS: A11-R2

Perform Database Maintenance and Set a Password
Kids for Change would like a backup of its database. It would also like it to be optimized for speed and 
secured with a password. In this exercise, you will perform some maintenance procedures on the Kids for 
Change database, including backing up and analyzing objects. You will also add a password to protect the 
data from unauthorized users.

 1.  Start Access; open A11-R2-K4C from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-R2-K4CRev

 2.  Choose File→Save As→Save Database As→Back Up Database .

 3.  Click the Save As button, navigate to your Access Chapter 11 folder, and click Save.

Analyze and Document a Database
 4.  Choose Database Tools→Analyze→Analyze Performance .

 5.  Click the Tables tab and click Select All to check all the tables listed.

 6.  Click OK and view the Analysis Results.

Because the data types have already been set properly, you can ignore the suggested ideas.

 7.  Click Close and then choose Database Tools→Analyze→Database Documenter .

 8.  Click the Tables tab, check the Activities and PaidStaff tables, and click OK.

The report documents the tables, fields, and relationships of the selected tables.

 9.  Choose Print Preview→Data→More→Word  to export the report to a Word RTF.

RTF files contain minimal formatting, are small, and are compatible across virtually all hardware and 
software platforms. Exporting to RTF ensures wider compatibility for various users.

 10.  Browse to your Access Chapter 11 folder, type A11-R2-Tables as the filename, and click Save.

 11.  Check the Open the Destination File After the Export Operation Is Complete box and click OK.

Access creates and opens the Word document.

 12.  Page through the Word document and then close it and exit Word.

 13.  Close the dialog box without saving the export steps and then close the print preview.

Compact and Repair a Database
 14.  Choose File→Info→Compact & Repair Database .

Access has compacted and repaired the file. The K4C Navigation Form might open, depending on your 
system.

 15.  Close A11-R2-K4CRev.

Protect a Database
 16.  Choose File→Open→Browse, navigate to your Access Chapter 11 folder and click  

A11-R2-K4CRev, and then click the Open menu button  and choose Open Exclusive.

No one else will be able to use the database until you exit Access.

Because you opened the database exclusively, you can set a password to open the database.

 17.  Choose File→Info→Encrypt with Password.
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 18.  Type Labyrinth123! as the password, verify it by typing it again, and click OK.

 19.  Click OK to acknowledge the message about row-level locking.

 20.  Close A11-R2-K4CRev and then open it again.

Access displays the Password Required dialog box. 

 21.  Type Labyrinth123! in the text box and click OK.

 22.  Close the database.

REINFORCE YOUR SKILLS: A11-R3

Perform Maintenance and Back Up a Database
Kids for Change would like a reminder to back up the database regularly. It would also like to rename a 
form and save a volunteer list as a query. In this exercise, you will create a macro that reminds users to 
back up the database. You will also rename, delete, and save objects.

 1.  Open A11-R3-K4C from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-R3-K4CRev

Remember to enable content if the option appears.

Create a New Macro
 2.  Choose Create→Macros & Code→Macro .

 3.  Choose MessageBox from the Add New Action drop-down menu and use this information to 
create the macro:

Message Back up the database to SharePoint 
at the end of each day!

Beep Yes

Type Information

Title Back-up Routine

 4.  Save the macro as: Back-up Routine

 5.  Choose Macro Tools→Tools→Run .

The Back Up Routine Information message box opens.

 6.  Click OK to close the message box and then close the Back-up Routine macro.

Back-up Routine is now listed under Macros in the Navigation pane.

Manage Database Objects
 7.  Right-click Staff Form in the Navigation pane and choose Copy.

 8.  Right-click again and choose Paste; rename the pasted object to PaidStaff Form and click OK.

 9.  Select the Staff Form in the Navigation pane and tap [Delete]; click Yes to confirm the deletion.

 10.  Open the Volunteers table and choose File→Save As→Save Object As→Save As.

 11.  Type Volunteers List in the Save ‘Volunteers’ To text box.

 12.  Choose Query from the As drop-down menu and click OK.

 13.  Close the Volunteers List Query and then close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A11-A1

Enhance a Database
Universal Corporate Events has asked you to improve forms by adding navigation and accessibility to other 
objects using macros and buttons. In this exercise, you will add command buttons to the Wage and Salary 
Form and create macros to increase efficiency.

 1.  Start Access; open A11-A1-UCE from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-A1-UCERev

Remember to enable content if the option appears.

 2.  Open Wage and Salary Form in Design View.

 3.  Set the Height property for the Form Footer section to: 0.75

 4.  Draw a button in the Form Footer under the Detail section labels.

 5.  Create a Go To First Record button that uses the Go To First picture option and name it: 
cmdFirst

 6.  Add these command buttons, in the order listed, using the default picture options:

• Go To Previous Record named: cmdPrevious

• Go To Next Record named: cmdNext

• Go To Last Record named: cmdLast

• Find Record named: cmdFind

 7.  Draw a button to the right of the Find Record button using these specs:

• Category: Report Operations

• Action: Preview Report

• Report to preview: Wage and Salary Report

• Picture: Preview

• Name: cmdPreviewReport

 8.  Select all new command buttons and then top-align them and set equal horizontal space 
between them.

Hint: Go to Form Design Tools→Arrange→Sizing & Ordering.

 9.  Switch to Form View, test the buttons, and then close the Wage and Salary Report.

 10.  Save and close the Wage and Salary Form.

Create a Macro
 11.  Choose Create→Macros & Code→Macro.

You will create a macro that opens the Event Revenue Report for the Event ID shown on the form.


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 12.  Create an OpenReport macro using these guidelines:

Report Name Event Revenue Report

View Report

Where Condition [Forms]![Event Costs]![EventID]=[Event 
Revenue]![EventID]

Macro Name Event Revenue by Name

 13.  Close the macro.

 14.  Display the Event Costs form in Design View.

 15.  Create a new button under the Cost Details label using these specs:

• Category: Miscellaneous

• Action: Run Macro

• Macro: Event Revenue by Name

• Picture: default option

• Name: cmdEventRevenue

 16.  Switch to Form View and navigate to the first record with an Event ID of BUSMTG.

 17.  Click the new macro button.

The revenue report for this event type is displayed. You can display the report for other Event IDs by 
navigating to the event and running the macro.

 18.  Close the Event Revenue Report; save and close the Event Costs form.

 19.  Close the database.

APPLY YOUR SKILLS: A11-A2

Perform Database Maintenance and Set a Password
Universal Corporate Events would like a backup of its database. It would also like to fine-tune the objects 
and secure the database. In this exercise, you will perform maintenance procedures to reduce wasted 
space, defragment objects, and improve efficiency. You will also back up the database and add a password 
to protect data from unauthorized users.

 1.  Open A11-A2-UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A2-UCERev

 2.  Choose File→Save As→Save Database As→Back Up Database→Save As.

The current date is added to the end of the database filename.

 3.  Save the file in your Access Chapter 11 folder.

Analyze and Document a Database
 4.  Choose Database Tools→Analyze→Analyze Performance.

 5.  On the Tables tab, click Select All to check all the tables listed and click OK.
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 6.  Review the information presented and then close the dialog box.

 7.  Choose Database Tools→Analyze→Database Documenter.

The Documenter opens.

 8.  On the Tables tab, check Menus and Schedules, and then click OK.

Access generates a report for the tables, fields, and relationships of the selected tables.

 9.  Choose Print Preview→Data→More→Word.

 10.  Browse to your Access Chapter 11 folder, use A11-A2-MenuSched as the filename, and click 
Save.

 11.  Check the Open the Destination File After the Export Operation Is Complete box and 
click OK.

 12.  Exit Word. In Access, close the Export – RTF File dialog box without saving the export steps, 
close the preview, and close any open database objects.

Secure a Database
 13.  Choose File→Open and then navigate to your Access Chapter 11 folder and open  

A11-A2-UCERev in Exclusive mode.

 14.  Encrypt the file with the password: Labyrinth123!

 15.  Click OK to acknowledge the encrypting message.

 16.  Close and reopen A11-A2-UCERev, entering the password when prompted.

 17.  Close the database.

APPLY YOUR SKILLS: A11-A3

Maintain Database Objects and Create a Macro
Universal Corporate Events would like you to add a message to remind employees to export reports every 
Friday and to clean up database objects to ensure the database runs smoothly. In this exercise, you will 
create a macro to display a message, create a new Products table based on data in the Menus table, and 
compact and repair the database.

 1.  Open A11-A3UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A3-UCERev

 2.  Close the UCE Navigation Form.

 3.  Create a MessageBox macro, using Export all new reports on Friday! as the 
message, no beep, Information as the type, and Report Policy for the title.

 4.  Save the macro as Report Policy and then run it.

 5.  Close the information box and then close the Report Policy macro.

Maintain Database Objects
 6.  In the Navigation pane, copy and paste the Personnel Report, resulting in a new object named 

Copy of Personnel Report.

 7.  Rename the pasted object as: Staff Report
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 8.  Delete the Staff Report, confirming the deletion when prompted.

 9.  Open the Menus table, choose File→Save As→Save Object As, and click Save As.

 10.  Save the object as a new table named Products and then display the table in Design View.

 11.  Rename the table fields as indicated:

Field Rename

MenuCode ProdCode

MenuPlan ProdPlan

ChgPP Cost

CostPP Price

 12.  Save and close the new Products table.

Last, you will compact and repair the database.

 13.  Choose Database Tools→Tools→Compact and Repair Database.

 14.  Close the database, choosing Yes to empty the Clipboard.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A11-E1 That’s the Way I See It
You would like to modify a database form to provide buttons for navigation as well as opening a 
closely related report for the Blue Jean Landscaping database. Open A11-E1-BJL and save it as: 
A11-E1-BJLRev

Create a macro named Service Invoices that opens 
the Service Invoices Report in Report View for the last 
name shown on the form. In the Service Invoices form 
footer, create command buttons using the default picture 
options as indicated in the table. Then create a Run Macro 
button named cmdServiceInvoicesReport that 
opens the Service Invoices macro. Top-align the buttons 
and set equal space horizontally between all buttons. Make any other changes to the form you feel 
would improve its look and feel.

A11-E2 Be Your Own Boss
As the owner of Blue Jean Landscaping, you would like to improve performance and security. Open 
A11-E2-BJL and save it as: A11-E2-BJLRev 

Analyze the performance of all database tables. Use the Database Documenter to generate a 
report for the Services, ServiceInvoices, and ServiceInvDetails tables. Export the report to an Excel 
file (name it ServicesTables). Back up the database and then close and open A11-E2-BJLRev 
exclusively. Encrypt the file with a password of your choosing. Write the password down for your 
instructor or for future reference.

A11-E3 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant has asked you clean up unnecessary objects in its 
database and to save a table as a query for easy filtering and sorting of restaurants. Also, it would 
like the database compacted and repaired in case renaming and removing objects has affected 
efficiency. Open A11-E3-SBQ and save it as: A11-E3-SBQRev

Complete these actions:

 Ý Delete the KeyWest Staff Query.

 Ý Rename any form with the name of your choosing.

 Ý Save the Restaurants table as a query named: Restaurant List

 Ý Compact and repair the database.



Go To First Record cmdFirst

Go To Previous Record cmdPrevious

Go To Next Record cmdNext

Go To Last Record cmdLast

Find Record cmdFind
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Glossary

back end Refers to the underlying database tables that 
support the front end 

command buttons Controls used to create action 
buttons that can be placed on a form to perform such 
actions as opening a report, moving to the next record, 
or even exiting Access

compacting Removes wasted and unused space left 
from deleted and edited records 

database splitter Converts a database into two files—
one that contains the tables holding the data and one 
that contains the objects that use the data 

exporting Process of sending data to other files or 
applications

fragmentation When parts of your database file 
become separated by incidental data that has been 
added to the storage location

front end Refers to the up-front portion of a split 
database with which users interact

Hypertext Markup Language (HTML) Code or 
language in which web pages are written 

importing Process of retrieving data from other files or 
applications

linked file Allows source data to be placed in a destina-
tion file that automatically updates when changes are 
made to the source file

Linked Table Manager Aids in redirecting a database 
to the correct linked file if the file was moved, as in a 
removed thumb drive or a file moved to a different folder

macro Object that combines a series of steps into a 
single step so a more detailed task can be automated

Mail Merge Word feature used to personalize standard 
letters, envelopes, mailing labels, and other documents 
by combining a main document with a data source

navigation form Form-like interface with tabs across 
the top to group common elements and sub-navigation 
links along the left side or directly below, allowing quick 
access to database forms and reports

Performance Analyzer Analyzes database perfor-
mance to locate and identify potential trouble spots that 
affect how the database functions

record locking Helps maintain consistent data and 
protects the integrity of record updates by creating a 
small temporary file that locks a record being edited by 
another user

rich text file (RTF) Variation of a text file that contains 
minimal formatting, such as bold and color

SharePoint Secure online location used to store, orga-
nize, collaborate, and share information from any device 
using a web browser

switchboard Easy-to-use interface containing 
menus and buttons for opening database objects and 
performing common tasks such as adding records or 
printing reports

text file Small alphanumeric text file that lacks 
formatting and font information; compatible across 
virtually all hardware and software platforms
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Index

A
.accdb file extension, 298
Access Options dialog box, 268

Datasheet category, 269
General category, 269–270

analyizing databases, 335–336
Attachment data type, 299–301

B
back end, 276
backing up, before splitting databases, 

277–278

C
Command Button control, 283
command buttons

customizing, 283–285
navigation improvement using, 328–330

compacting databases, 337
Current Database options window, 273
current database settings, 273–275

D
Database Documenter tool, 335
database properties, 269–270
datasheet effects, 269
deleting database objects, 333–334
documenting databases, 335–336

E
encrypting database, using passwords, 

338–339
Excel

exporting data to Excel, 311–312
fixing broken links, 310–311
importing data from Excel files, 308–309
integrating Access with, 307–312
linking Excel worksheet to Access 

database, 309–310
exporting objects as web pages, 313

F
fragmentation, of databases, 337
front end, 276

G
groups, on Navigation pane, 270–273

H
HTML

importing HTML files, 314–315
saving HTML-formatted objects, 

313–314
updating HTML data, 313

hyperlinks, adding to database object, 
315–316

I
Insert Hyperlink dialog box, 315
interface options, 278–286

custom command buttons, 283–285
navigation form, 279–283
startup options to open forms, 285–286
switchboard, 278–279

L
linked files, 301, 306
Linked Table Manager, 310–311
locking records, 276

M
.mdb file extension, 298
macros, creating for improving efficiency, 

330–333
Mail Merge, 301
merging database objects, 333–334

N
navigation form, customizing, 279–283
navigation improvement, using command 

buttons, 328–330
Navigation pane, customizing, 270–273

O
OLE Object data type, 299
Open command, 338
Open Exclusive command, 338
Open Exclusive Read-Only command, 338
Open Read Only command, 338
options

current database settings, 273–275
custom command buttons, 283–285
database properties, 269–270
datasheet effects, 269
interface, 278–286
navigation form, 279–283
Navigation pane, 270–273

options (continued)
personal information, 269–270
startup options to open forms, 285–286
switchboard, 278–279

P
passwords, encrypting database using, 

338–339
Performance Analyzer tool, 335
personal information, 269–270

R
record locking, 276
records, attaching files to, 299–301
renaming database objects, 333
repairing databases, 337
reports, adaptable, using macros to  

display, 331–333
rich text files (RTFs), 301

S
security of databases, 337–339

encrypting database using passwords, 
338–339

opening database exclusively, 338
SharePoint, displaying Access data on, 

312–313
splitting databases, 276–278

backing up before, 277–278
database splitter, 276
reasons for, 276
terminology, 276–277

startup options
overriding, 285–286
to open forms, 285–286

switchboard, customizing, 278–279
Switchboard Manager command button, 279

T
text files, 301
title bar, 273

W
Web

adding hyperlinks to database object, 
315–316

displaying Access data on, 312–316
exporting objects as web pages, 313
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Web (continued)
importing HTML files, 314–315
saving HTML-formatted objects, 

313–314
updating HTML data, 313
using SharePoint, 312–313

Word
copying data from Access to Word, 

301–304
integrating Access with, 301–307
merging data with Word documents, 

305–307
overview, 301
publishing data to Word, 304–305
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