
In this chapter, you will be introduced to 

database concepts and work with Access 

tables, the starting point of all databases. 

Have you ever wondered how sportscasters 

come up with fun and interesting facts about 

teams and players in a flash? Have you been 

taken by surprise when a customer service 

agent suddenly begins to recite your name, 

address, and a detailed purchase history? 

In most cases, these people have access to a 

powerful database from which they obtain the 

information.

LEARNING OBJECTIVES

■■ Identify database objects and the 
functions they perform

■■ Identify table features

■■ Create database tables

■■ Identify and choose data types

■■ Print a datasheet

C H A P T E R  8 :  A C C E S S 

Introducing Databases
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196 Chapter 8  |  Introducing Databases

	 Project: Creating a Database
Winchester Web Design is a small website development company. The company 

specializes in building websites for small businesses. You have been asked to build 

a database to help the company manage its employee, customer, and sales data. 

You’ll get started by exploring objects in an existing database. Then you’ll create a 

database and work with tables.

What Is Access?
It is likely that you routinely interact with databases. If you make an online purchase, 
your order information goes into a database. The database might be used to track 
your order status, product likes and reviews, past orders, or future promotions. If you 
post or like something on your Facebook account, that information is maintained in a 
database. If you search for or store a telephone number, that information is likely kept 
in a database. It is quite possible you have been using databases without even knowing 
it! Here, you will be introduced to what a database is and gain a better understanding of 
related terms, explore a sample database, and finally, create your own!

While there are many definitions of a database, you can think of a database as an 
organized collection of related data files or tables. For example, a company might 
organize its information by both customers (external to the business) and employees 
(internal to the business). While the data relate to the same business, the types of data 
provided for customers and employees will likely differ. 

Databases are the epicenter of our digital world.
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Types of Databases
Large organizations typically use large custom-designed databases specifically for that 
company or industry. When you make travel plans, you are using a database that is 
specific to the airline industry. It contains real-time data, meaning that if there is only 
one seat left on a plane, whoever selects and pays for the seat first gets the reservation. 
If you are a small business owner, you may use a database like Microsoft Access to track 
information about your customers, products, and employees. Access provides the tools 
needed to let small organizations create, use, and maintain databases.

Open and Save an Access Database
Each time you start Access, the Backstage view displays options for opening an 
existing file, creating a new blank database, or selecting from a number of pre-built 
templates. If you’re creating a new database, Access will immediately prompt you to 
save the file in your desired storage location. You must save your file first because the 
database needs to constantly make updates to data as it is entered or edited.

hands-on 8.1  Start Access and Open a Database
In this exercise, you will start the Access program and open an existing database. 

	1.	 If necessary, start your computer.

	2.	 Click the Start  button in the bottom-left corner of the screen.

	3.	 Scroll down the alphabetical list and click Access 2016.
The Access program loads and Backstage view is displayed. Recently used databases 
appear on the left, and you can create new databases from the list of templates.

	4.	 Maximize  the Access window if it isn’t already maximized. 

	5.	 Choose Open Other Files near the lower-left side of the window.

	6.	 Click the Browse button, navigate to your Chapter 08 folder, and open the 
Win Web Design database file.

	 7.	 Click Enable Content if the Security Warning bar displays.
The Security Warning appears whenever a database file is opened for the first time. You 
should never open files unless you know and trust the file sender. The database objects 
are shown in the Navigation pane on the left.

	8.	 Keep Access open, as you will continue to use the database to explore the Access 
environment. 
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198 Chapter 8  |  Introducing Databases

Database Objects and the Access Window
The Access window includes the Ribbon, Navigation pane, and work area. A database 
object is a structure used to store, retrieve, or display data. The four Access objects 
are tables, queries, forms, and reports. The database objects are displayed in the 
Navigation pane on the left side of the window. The work area is where you create, 
modify, or work with database objects.

DATABASE  OBJECT  TYPES

Access Object What It Does

Table Tables contain the database’s data, and they let you enter, 
edit, delete, or view records in a row and column layout that is 
similar to that used in an Excel worksheet. A record contains 
information about an individual person, place, or item.

Form Forms are used to view, edit, and add data one table record at a 
time.

Query Queries are used to search for specific table records using 
criteria and to sort and perform calculations on the results.

Report Reports are printable database objects that can display, group, 
and summarize data from tables and/or queries.

hands-on 8.2  Use Database Objects and Enter and Edit Data
In this exercise, you will open and view the four Access object types.

	1.	� Take a moment to explore the Access window noticing the various tables, 
queries, forms, and reports in the Navigation pane.

Explore a Table
	2.	� Double-click the Customers table in the Objects list of the Navigation pane to 

open it in the work area within Datasheet View.
Notice that the table, which is in Datasheet View, looks like a worksheet with columns 
and rows. Datasheet View lets you view, add, and edit table records. One benefit of 
Datasheet View is it lets you see more than one record at a time.

	3.	� Click in the first empty Cust ID cell at the bottom of the CustID column.
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What Is Access? 199

	4.	� Type AdamsA and tap [Tab] to complete the entry and move the insertion 
point to the next field.
Notice the pencil icon highlighted in yellow. This indicates the current record is active 
and being created or edited.

Cust ID is known as a primary key field in this table, so each Cust ID must be unique.

	5.	� Type Adams in the Last Name field and tap [Tab].

	6.	� Enter Anthony as the First Name, 23 Pine St as the street address, and 
Bradenton as the city.

	 7.	� Click the drop-down menu button  in the ST field and choose FL from the list 
of states.
ST is an example of a field with properties that make data entry easy and accurate.

	8.	� Complete the record as follows, making sure you tap [Tab] after entering the 
information in each cell.
Tapping [Tab] after entering a full row of data completes the record, saving it in 
the database. As you enter the telephone number, just type the digits; Access will 
automatically format the entry for you.

■	 ZIP: 34210

■	 Telephone: (941) 555-3648

■	 Email: AAdams @ email . com

■	 Notes: Call for delivery.

	9.	� Choose Home→Views→View menu button  and then choose 
Design View .
Fields contain pieces of data in records such as zip codes, telephone numbers, email 
addresses, or notes. Each object type can be created or edited using Design View. Tables 
Design View is where fields can be added, removed, or edited and field properties can be 
set.

	10.	� Click the View menu button  and choose Datasheet View .
Notice the Anthony Adams record is now the second record in the table. It moved up 
because the records are sorted in ascending order using the Cust ID field.
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200 Chapter 8  |  Introducing Databases

Explore a Form
Now you will explore a form that is based on the Customers table. Forms help 
facilitate effective data entry by displaying one record at a time.

	11.	� Double-click Customers Form in the Forms section of the Navigation pane.
Notice the form displays all fields from the Customers table but only one record is 
visible.

	12.	� Locate the Record bar at the bottom of the form.

	13.	� Click the Next Record  button to view the Anthony Adams record you just 
entered.

	14.	� Click in the Notes box and type after 10:00 at the end of the note (that is, 
“Call for Delivery after 10:00”).

	15.	� Click the Next Record  button again to complete the edit.
This edit has now been saved in the Customers table.

Explore a Query
Now you will explore a query that is based on the Customers table. Queries choose 
specific database records using criteria that you specify.

	16.	� Double-click Customers Query in the Queries section of the Navigation pane.
The query results look like a table displayed in Datasheet View, but the query only 
displays some of the fields from the underlying Customers table and records where the 
City is equal to Bradenton.

	17.	� Click the View menu button  on the Ribbon and choose Design View .
The query has fields from the Customers table and the criterion (a single criteria) 
bradenton. This is an example of a simple query based on a single table. Queries can 
draw data from multiple tables and can include more sophisticated criteria.

	18.	� Choose Design→Results→Run  to run the query and display only the 
Bradenton results.

Explore a Report
Now you will explore a report that uses multiple tables, including the Customers 
table.

	19.	� Double-click Invoice Details Report in the Reports section.
Take a moment to scroll through and observe the report.
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Introducing Tables 201

	20.	� Click the View menu button  on the Ribbon and choose Design View .
The Report design grid may look complicated, but it’s easy to create a robust report 
using the Access Report Wizard. The design grid can then be used to make modifications 
once the foundation has been set with the Wizard.

	21.	�� Click the View menu button  on the Ribbon and choose Report View , 
which is great for viewing reports.

	22.	� Follow these steps to explore the object tabs and to close an object:

BA

A	�Switch between open objects using the tabs.
B	�Click the Close Object button to close the objects one at a time.

	23.	� Choose File→Close to close the database.
The data you entered and edited is automatically saved by the database.

Introducing Tables
A table is the starting point for entering, finding, and reporting useful information 
located in your database. A database can have separate tables, each tracking different 
types of data. A business might use a table to keep track of customer billing or 
employee contact information.

Table Features
Data are meaningful units of information such as names, numbers, dates, and 
descriptions organized for reference or analysis. The data stored in the Winchester 
Web Design Group database might include customer first and last names, business 
names, telephone numbers, and other important information.

A field is the smallest meaningful unit of information about a person, place, or 
item. Individually, each field represents a piece of data. Together the fields provide 
information. In most databases, fields are displayed in columns.
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202 Chapter 8  |  Introducing Databases

A record is a collection of related fields about a person, place, or item, such as a single 
customer or employee. A collection of related records makes up a table. In most 
databases, records are displayed in rows.

First Name field and JeffriesD record in Customers table

Field Data Types
If you have ever filled out an online form, you might have seen instant formatting of 
some fields. When typing in currency values, the dollar sign and decimal point may 
appear automatically, and when entering a date, the slashes between month, day, 
and year spontaneously appear. This can be accomplished by assigning a data type to 
the field. A data type sets the characteristics of a particular field, identifying the type 
of values it may hold, such as alphanumeric text, or numbers, or dates, yes/no values, 
or even a hyperlink.

Primary Key Fields
Almost every database table should have a primary key field. A primary key is a 
unique identifier for each record in the table. Examples of fields that would make 
good primary keys are Social Security numbers, student IDs, or email addresses. 
Using a student ID as a primary key ensures that each student is uniquely identified 
in a student database table. Two students may have identical names, but they will 
never have identical student ID numbers.

Creating a Table in a New Database
Instead of using a database that someone else has prepared, you can design your own 
using a blank database template in Access. Tables are the starting point for databases 
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and this shows up when a new blank database is first created. The new table has a 
single primary key field as a starting point for the database.

The starting point in a blank database

hands-on 8.3  Create a Blank Database and Add a Table
In this exercise, you will create a new blank database and add an Invoices table in 
Datasheet View.

	1.	 If necessary, start Access and choose Blank Desktop Database.

	2.	� Click Browse Folders  and save the database in your Chapter 08 folder as: 
Datasheet

Access is the only Office application that requires you to save a new file (the database) 
before you can begin working.

	3.	� Click the Create button, and a new table will appear.

	4.	� Follow these steps to change the name of the ID field and set the data type for a 
second field:

A

C

B

A	�Double-click the ID field name and type InvNum as the new name. This will 
be the primary key field.

B	�Tap [Tab] to go to the second column and, if necessary, choose Click to Add 
to display the data type list.

C	�Choose Date & Time.
Once the data type is selected, the heading for the new field becomes Field1.

	5.	� Replace Field1 with the name InvDate and tap [Tab] to move to a new field.
Your table currently has a primary key field and one Date/Time field.
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204 Chapter 8  |  Introducing Databases

	6.	� Choose Short Text as the data type for the third field and change the field name 
to: EmpID

	 7.	� Tap [Tab], choose Short Text for the fourth field data type, and change the field 
name to: CustID
Your simple table with four fields is now set up and ready for data to be entered.

	8.	� Click in the empty InvDate field (you might have to click twice) and type 
12/15/2016.

	9.	� Tap [Tab] and type JFW as the EmpID.

	10.	� Tap [Tab], type SmithW as the CustID and then tap [Tab] again to begin a new 
record.

	11.	� Enter the data for these three additional records:
The InvNum primary key field is automatically numbered because it has an 
AutoNumber property set.

	12.	� Choose File→Save or click the Save button on the Quick Access toolbar and 
save the table as: Invoices
You will print the table in the next exercise.

Printing Data and Closing a Database
Previewing and printing table datasheets and other Access objects, such as reports, 
is easily done using the File→Print command. Sometimes paper printouts are 
necessary, and you may also find they are an effective way to check a database for 
accuracy. When you close a database using the File→Close command, Access will 
prompt you to save changes to any unsaved open objects, such as tables, forms, 
reports, and queries. 
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hands-on 8.4  Print a Datasheet and Close the Database
In this exercise, you will preview and print a database table and then close it. 

	1.	 Make sure the Datasheet database is open and the Invoices table is displayed in 
Datasheet View.
Tables are displayed in Datasheet View by double-clicking them in the Navigation pane 
on the left side of the Access window.

	2.	 Choose File→Print and then choose Print Preview.

	3.	 Notice the preview of how the datasheet will look when printed and then take a 
moment to explore the Print Preview toolbar options.

	4.	 Choose Print Preview→Print and then click OK if you want to actually print 
the datasheet; otherwise, choose Print Preview→Close Print Preview.

	5.	 Choose File→Close to close the database, choosing Yes if you are prompted to 
save changes to your table.
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	Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the 
Self-Assessment. 

Page number

	1.	 Zara should use a form if she wants to display one record at a 
time on her screen.

true false

	2.	 A primary key uniquely identifies each record in a table. true false

	3.	 Which database object is used for storing 
data? 

A.	Form

B.	 Query

C.	Report 

D.	Table

Page number: 

	5.	 Which table feature is shown within the 
rectangle? 

A.	Field

B.	 Record

C.	Relationship

D.	Primary key

Page number: 

	 7.	 Which database object is best for viewing 
and editing one record at a time?

A.	Table

B.	 Form

C.	Query

D.	Report

Page number: 

	4.	 Short text, hyperlink, and numeric are 
examples of?

A.	Primary keys

B.	 Records

C.	Queries

D.	Data types

Page number: 

	6.	 Which database object should be used 
to locate all customers who live in 
Springfield, Illinois, and to then sort the 
results in order by zip code?

A.	Form

B.	 Query

C.	Report

D.	Table

Page number: 

	8.	 The names, addresses, and phone numbers 
for 5,000 customers are stored in a 
database as which of the following?

A.	5,000 fields

B.	 5,000 records

C.	5,000 tables

D.	A single object

Page number: 
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	Skill Builders
skill builder 8.1  Enter and Edit Database Records

First Perk is a coffee shop that tracks sales using an Access database. In this exercise, 
you will update pricing and add several new items.

	1.	 Start Access and choose Open Other Files. (Or, if Access is already open, choose 
File→Open.)

	2.	 Click the Browse button, navigate to your Chapter 08 folder, and double-click 
the First Perk database file. 

	3.	 Open the Items table in Datasheet View by double-clicking it in the Navigation 
pane. 

	4.	 Click in the Price field for the Coffee item and change the price from 1.50 to 
2.00.
Note that dollar signs $ are automatically displayed in the Price field because the field is 
formatted with a Currency number format.

	5.	 Change the price of Coffee-Decaf to 2.00 and change the price of Espresso Shot  
to 2.50.

	6.	 Now add the following items to the database:

ItemName Price

Latte 3.25

Cappuccino 3.25

Mocha 3.50

Green Tea 2.50

Earl Grey 2.50

Note that Access automatically numbers the ItemNumber field for you because it is set 
up as an AutoNumber field type.

	 7.	 Feel free to print a copy of the datasheet.

	8.	 Close the table and then choose File→Close to close the database.
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skill builder 8.2  Create a Table in Datasheet View
In this exercise, you will create a new database and a table using Datasheet View.

	1.	 Start Access. Or, if Access is already open, choose File.

	2.	 Choose Blank Desktop Database and then click the Browse Folders  button 
and save the database in your Chapter 08 folder as K4C.

	3.	 Click the Create button to start a new database.

	4.	 Double-click the ID heading and change the text to StID.
This will be the primary key field with autonumbering, so your records will 
automatically get numbered.

	5.	 Tap [Tab], choose Short Text as the data type, and change the heading from 
Field1 to StLName.

	6.	 Add StFName, StAdd, StCity, StST, StZIP, StPhone, and StAvail as fields 
with the Short Text data type.

	 7.	 Choose File→Save or click the Save  button on the Quick Access toolbar and 
save your table as Staff.

	8.	 Click the first empty cell in the StLName field and enter the following records 
using these guidelines:
■	 Tap the [Tab] key to complete your entries.

■	 Enter hyphens in the phone field, as the field is not set up to automatically 
enter them for you.

■	 Widen the columns as necessary by double-clicking the right borders of the 
column headings you want to widen.

■	 Strive for 100% accuracy when entering data, which requires including spaces 
between characters when called for and verifying the capitalization of upper- 
and lowercase letters.

	9.	 Close the Staff table, saving the changes, and then choose File→Close to close 
the database.

	10.	 Exit Access.
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