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L E S S O N  2
Using an Access 
Database
ost databases are 
designed and set up 

by professionals who are 
database experts. As a result, 
most company employees are 
simply required to maintain 
databases—a task that most 
people are already accustomed 
to doing. Consider, for 
example, the address book you 
use to store addresses of 
friends and relatives. Each 
time someone listed in the 
address book moves or 
changes phone numbers, you 
edit the information in your 
address book.

M
 The same concept is true of 
electronic databases. 
Employees come and go, 
customers relocate to new 
addresses, phone numbers 
change, and websites come 
online. Updating database data 
to reflect these changes helps 
maintain the usefulness of the 
data. In this lesson, you will 
learn how to adjust the layout 
of a database table, add data 
using database input tools, 
edit data, delete records, and 
print database data.
L E S S O N  O B J E C T I V E S
After studying this lesson, you 
will be able to:

■ Add records to a database 
using both tables and forms

■ Change the layout of a table 
by adjusting column width, 
hiding columns, and 
rearranging column layout

■ Locate and update records 
by sorting, filtering, and 
using Find and Replace 

■ Preview and print 
database data

■ Save a database as a new file
Additional learning resources are available at labpub.com/learn/oe7r/

Optional Lessons
NOTE! These optional Access lessons are numbered Lessons 1-3. Your instructor may choose to use these lessons instead of the printed Access lessons in your book, which are Lessons 21-24. Only complete these online lessons if directed by your instructor.
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Case Study: Learning to Use Access
Andrew Johnson has just been hired in the data processing department of Labyrinth Exports. 
Andrew has little experience working with an Access database, but is a proficient typist and a 
quick learner. He will be updating the Customers table in the database his first day on the job. 
As he works, he will add new records to the table, adjust the layout of tables, locate and 
update records, delete records, and print data. 

Andrew adjusts the column widths and positions of columns shown in the top image so that they 
appear as shown in the bottom image.

Before adjusting the 
layout of the table, 
some columns are so 
narrow that numbers 
are hidden and only a 
portion of some data 
displays. In addition, 
some of the empty 
columns should be 
moved.

After changing the layout, 
all numbers appear, all data 
in all columns displays, and 
the empty E-mail Address 
column is repositioned.
33
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Adding Records and Formatting 
Datasheet Layout

Two tasks frequently associated with databases include adding records to database tables and 
formatting the layout of the datasheet to display field data. In many cases, these are two 
primary tasks of data entry personnel.

Adding Records Using a Table
Many of you will already be acquainted with adding rows to Microsoft Word tables and 
Microsoft Excel worksheets. Each time you enter text or figures into a new row, the table or 
worksheet grows to accommodate the new text. The same concept is true of database tables.

The Primacy of Tables
Recall that tables in Access databases hold the raw data. All reports, queries, and forms use 
table data in different ways. As a result, you must first input—add data to—a table. Access 
provides two basic input tools for adding data to database tables: 

■ Typing the data into the datasheet view of the appropriate table. 

■ Typing data into a form associated with the appropriate table.

Access automatically saves each record as you complete it when you tab after entering the data into the 
last field.

AutoNumbered Fields
Many Access tables contain fields that 
automatically number records as you 
add them to a table. As a result, it is 
unnecessary to type a number in these 
fields and the numbers 
are uneditable—the number is 
assigned to the specific record. In addition, if you delete a record from a table, Access never 
assigns the number to any new records. 

QUICK REFERENCE: ADDING A NEW RECORD TO A TABLE 

Task Procedure

Add a new record to 
a datasheet 

■ Open the table in the database to which you want to add a new record.

■ Click the New Record  button to create a new record.

■ Type data into each field in the row, pressing [Tab] to move to the 
next field.

Add a new record 
using a form

■ Open the form associated with the table in the database to which you want 
to add a new record.

■ Click the New Record  button to create a new record.

■ Type data into each field in the form, pressing [Tab] to move to the 
next field.

In this example, the 
company ID column 
is AutoNumbered.
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Relaunching Access
As you discovered in Lesson 1, Exploring Access 2007, the first time you launch 
Access, you often have to navigate through several levels of program menus to 
launch the program. In addition, the first time you open a database, you use the 
Open command on the File menu to display the Open dialog box and 
then navigate to the drive and folder containing the database. After you launch 
Access the first time, the program appears on the Start menu so that it is much 
easier to launch. The last nine databases, by default, appear on the Open Recent Database list 
to make them easier to open.

Hands-On 2.1 Add a Record to a Database Table
In this exercise, you will launch Access, open a database that you have previously not opened, open a table, 
and add a record to the table using the datasheet.

1. Launch Access and open the Labyrinth Exports database from the Lesson 02 folder in your 
file storage location.

2. Enable content in the database, and log in as Steven Thorpe.

There is no particular reason to log in as Steven Thorpe except to ensure that your screens match those 
shown in this lesson.

3. Close  the Home form, open the Navigation Pane, and expand the Tables list.

4. Open the Customers table and follow these steps to create a new record:

FROM THE KEYBOARD

[Ctrl]+[End] to move 
to the last field in the 
last record and then 
press [Tab] to create 
a new record

A Click the New Record  button 
to create a new record.

B Ensure that 
you are 
creating 
record 30.

C Notice that an asterisk (*) appears in the row 
frame for the new record until you start typing.
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5. Type the following data into table columns, pressing [Tab] or [Enter] to move to the 
next column:

The data you type may appear all misaligned and run together. That’s okay for now. You will eventually 
learn how to format the data so that it appears correctly.

6. Complete the record for Company DD by typing your data or made-up data into the 
remaining field columns, as shown.

After you press (Tab) or (Enter) from the Notes column, Access automatically moves to another new 
record. As long as you leave fields in this record blank, Access will not number the record.

Formatting a Table Datasheet Layout
Several of the columns in the Customers table are so narrow that the data in the columns 
appears to be cut off. The data in narrow columns is still there—Access displays only the 
portion of the data that fits within the column width and truncates (stores without displaying) 
the additional data. You can maximize the Access window to provide more space for the table 
and close the Navigation Pane to provide even more space for objects you have open. These 
actions simply allow more columns of data to appear onscreen without affecting the width of 
each column. 

C Notice, as you start typing the 
company name, another new 
record row appears in the table.

D Press the [Tab] key after 
you fill in this field, and 
then continue with step 6.

A As you add or edit a record, 
notice the pencil icon that 
appears in the row frame.

B Type the data in 
the columns as 
shown here.
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Changing the Width of Columns
You can adjust the width of each column in a datasheet to display all data in the column. 
Access gives you some useful techniques for changing column width. 

■ Drag a column border: Dragging a column border enables you to make the column on 
the left of the border wider or narrower.

■ Double-click a column heading border: Double-clicking a border changes the width of 
the column on the left to fit the longest data entry in the column or the column heading, 
whichever is wider.

Moving and Hiding Data Columns
In addition, there will be times when you want to reposition a column of data in a table layout 
or hide some columns so that you can view other field columns. Access contains tools that 
enable you to rearrange columns and hide columns. When you hide columns, Access 
temporarily removes them from display. The data, however, remains in the table—it is NOT 
deleted. When you want to view data in hidden columns, you can unhide the column.

Saving a Table Layout
Changing the layout of a table datasheet has no real effect on table data or table 
structure; however, when you make changes to a table datasheet, Access 
recognizes the differences between the layout and the structure of the table and 
prompts you to save the changes to the layout when you close the table. If you 
abandon the changes you make to the layout, the next time you open the table datasheet, the 
column widths will return to their original size, the hidden columns will show, and the 
repositioned columns will occupy their original place in the layout. If you save the changes, 
the next time you open the table datasheet, Access recalls the layout and displays the 
datasheet as you formatted it.

The shape and color of the mouse pointer is important when you are adjusting column width 
and repositioning columns in a table or datasheet layout. Be sure to pay attention to the mouse pointer 
shape as you work.

The data in these columns is truncated because 
the column widths are too narrow.

Widening the column widths 
prevents truncation.

Before and after hiding the E-mail Address column.

FROM THE KEYBOARD

[Ctrl]+[S] to save 
changes to the table 
layout
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Hands-On 2.2 Format a Table Datasheet Layout
In this exercise, you will adjust the column widths of table datasheet columns, hide columns, and 
reposition columns.

1. Open the Customers table in the Labyrinth Exports database if it is closed.

2. Follow these steps to change the width of the first table column:

3. Follow these steps to change the width of two columns at the same time:

4. Follow these steps to reposition the empty E-mail Address column:

A Point to the border of the column heading between the first column and 
the Company column until you see a two-headed black mouse pointer.

B Double-click the border between the columns to widen the first column.

A Point to the column heading First Name, ensuring that you 
see a black down-pointing arrow, click and drag the pointer 
to the right toward Last Name to select both columns.

B Double-click the right border of the Last 
Name column, ensuring that your mouse 
pointer appears as a two-headed black 
arrow as it did in step 2.

A Click the E-mail Address 
column heading to 
select the column.

B Scroll to the right until the 
Business Phone and Fax Number 
columns appear onscreen.

C Point to the selected E-mail Address 
column heading, ensuring that the 
mouse pointer appears as a white arrow.

D Drag the E-mail column heading to a position to the right of the Fax Number column. As you drag 
the column, a black vertical bar indicates the active position of the column. If you drop the column 
before it is properly placed, point to the column heading and drag it to the proper position.
38 Lesson 2: Using an Access Database
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5. Follow these steps to hide the Country/Region column:

6. Click the Save  button to save changes to the table layout.

7. Close  the table.

Adding Records Using a Form
As you know, forms are objects that display data onscreen one record at a time and are used to 
input data into a database. Because of the field layout on most forms, all data contained in a 
record is normally visible, so it is easier to review all data associated with a record than it is in 
table datasheet layout. Most forms are also formatted to be more aesthetically pleasing 
than tables.

Saving the New Record
After you type data into the last field on a form and press the [Tab] key, Access automatically 
saves the record into the table.

Hands-On 2.3 Add a Record to a Database Using a Form
In this exercise, you will use a form to add a new employee to the Employees table.

1. Expand the Forms list in the Navigation Pane and double-click the Employee Details form 
to open it.

2. Click the New Record  navigation button to create a new 
blank record.
Access displays a new blank form. 

A Scroll to the right until the Country/Region 
column appears onscreen.

B Right-click the Country/Region column 
heading to display the shortcut menu.

C Choose Hide Columns to hide the column.
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3. Follow these steps to enter data for a new employee using the form:

4. Close  the form, open the Employees table to ensure that data for the new record 
appears, and then close the table.

Retrieving Data
The primary purpose of any database is to be able to locate and retrieve data quickly 
and efficiently. Whether you’re processing an order, announcing statistics, or updating records, 
being able to find the data is important. Access provides three main tools and features for 
helping locate and retrieve data:

■ Sorting features

■ Filtering tools

■ Find and Replace

Sorting Records
Access automatically sorts records according to the field set up when a table is created and 
fields are set up. Many times tables are sorted by record number so that as you enter records, 
Access assigns a number to the record and the records sort in the order in which you enter 
them. The database sort feature enables you to rearrange table records on the basis of data 
found in other table columns. Two main sort orders are available:

■ Sort Ascending: Arranges data in alphabetical order from A to Z, in numeric order from 
lowest to highest, or in chronological order from first to last.

■ Sort Descending: Arranges data in reverse alphabetical order from Z to A, in numeric 
order from highest to lowest, or in reverse chronological order from last to first.

C Continue using 
the [Tab] key to 
move from 
field to field 
and enter your 
personal (or 
fictional) data 
for the instruction text pictured. Entering 
fictional data keeps your personal data private.

A Click the First 
Name text box, 
and then type 
your first 
name.

B Press [Tab] to 
move to the 
Last Name 
field, and then 
enter your last 
name.

D Enter more information on 
the right side of the form.

E Press [Tab] one more time after 
you enter data in the Notes field.
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Sorting Records Using Tables and Forms
Regardless of whether you are working with a table or a form, the primary procedures for 
sorting records are the same. 

Hands-On 2.4 Sort Records in a Table
In this exercise, you will sort records in both tables and forms and clear all sorts set.

1. Open the Employees table and follow these steps to sort records by last name:

2. Follow these steps to set a descending sort order and clear all sorts:

3. Close  the table. 
Access displays a prompt asking if you wish to save changes to the table. Because you have changed the 
sort order a couple of times and then cleared the sorts, Access recognizes that you have changed the 
layout of the table while it was open. As a result, it prompts you to save changes. If you were to click Yes, 
the changes would become part of the table design. Instead, choose No and discard the changes. 

A Position the 
cursor on 
any record in 
the Last 
Name field.

B Choose Home→ 
Sort & Filter→
Ascending on 
the Ribbon.

A Click any 
record in the 
Job Title 
column.

B Choose Home→Sort & Filter→Descending on the Ribbon to sort records 
by job title. Notice, too, that the last names arrange alphabetically for 
each job title because you already sorted the table on that column.

C Click the Clear All Sorts button. 
Notice that records are rearranged 
in ID order—the default sort order.
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4. Choose No in response to the prompt to save the changes.

5. Open the Customer Details form and follow these steps to sort the customers:

6. Close  the form.

Sorting Records Using Multiple Fields
Data in Access can be sorted on more than one table field at the same time. This can be useful 
when sorting fields where the value in the first field of more than one record is the same so 
you want to select a second field on which to organize the records. 

Example
Take, for example, personal names. Many records in a table might contain the same last name 
value. When this happens, selecting the first name field as a second sort field is often 
appropriate. Using this example, the last name field would be considered the primary sort field, 
and the first name field is called the secondary sort field. The secondary sort field is only 
considered when multiple records contain the same data in the primary sort field.

A Click the 
Company value 
text box to 
make it the 
active field.

B Click the 
Ascending 
button to sort 
the table by 
company name. 
Company A 
becomes the 
first record.

C Clear All Sorts to 
restore the table 
to its default sort 
order.

These records are sorted first by Last 
Name column and then by First Name.
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How Multiple Column Sorts Work
Access sorts data on multiple fields from left to right. As a result, the columns in a table must 
appear side by side in the datasheet and the column on the left must be the one you want 
sorted first (primary sort field). Access will then consider the second column (secondary sort 
field) only when it finds identical values in the primary sort field. You can perform more 
complex sorts on multiple fields using the Advanced Filter/Sort options, which you will learn 
more about in future lessons, or sort multiple columns by rearranging them in the datasheet 
so that they appear side by side. 

QUICK REFERENCE: SORTING RECORDS 

Task Procedure

Sort Ascending ■ Position the cursor in the field on which you want to sort records.

■ Choose Home→Sort & Filter→Ascending  on the Ribbon.

Sort Descending ■ Position the cursor in the field on which you want to sort records.

■ Choose Home→Sort & Filter→Descending  on the Ribbon.

Clear Sorts ■ Choose Home→Sort & Filter→Clear All Sorts  on the Ribbon.

Sort on Multiple 
Fields

■ Arrange the fields you want to sort next to each other with the primary 
field to the left of the secondary field.

■ Select both field column headings and click the sort button for the sort 
order in which you want to sort the records.

In order to sort the Last Name field 
first, it had to be moved to the left 
of the First Name field. 
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Hands-On 2.5 Sort Records Using Multiple Fields
In this exercise, you will sort data in a table on the basis of the values found in two columns.

1. Open the Purchase Orders table in the Labyrinth Exports database. 

2. Follow these steps to sort table records on the basis of values contained in multiple fields:

3. Review the record sort results.

4. Clear all sort orders and click any value in the Purchase Order ID column to deselect 
both columns.

A Click the Supplier 
ID column heading 
and drag the 
mouse to select the 
Created By column 
heading so that 
both columns are 
selected.

B Choose Home→Sort & 
Filter→Ascending on 
the Ribbon.

All records 
containing 
Supplier A 
appear at 
the top of 
the table.

Values in the Created By column are 
arranged alphabetically for each supplier.
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5. Follow these steps to sort on the same two columns and obtain different results:

Notice that the arrangement of all records created by one person with suppliers arranged alphabetically 
for each person before the next person’s records appear.

6. Close  the table. Choose No when prompted to save the changes.

Locating and Deleting Records Using Table Datasheets
The navigation buttons found at the bottom of tables and forms provide an efficient way to 
move among records when the number of records in a database is relatively few. When a data-
base contains large volumes of data, finding a more efficient way to locate records becomes 
important. Both tables and forms are the primary objects used to locate records for updating 
and deleting.

Using Find and Replace
The Find and Replace tool in Access improves the efficiency of maintaining a database that 
constantly changes. Using the tool, you can locate records easily and then delete them or 
edit them.

The Find feature in Access enables you to locate records containing data that you 
need to edit or to locate records that you want to delete. The Find page of the 
Find and Replace dialog box contains a few features similar to those found in 
other Microsoft applications. Because data stored in a database is somewhat 
different from the text and data stored in other files, you will find some unique 
fields as you work in Access.

QUICK REFERENCE: DELETING RECORDS 

Task Procedure

Delete a 
record

Use one of the following procedures to delete a record:

■ Click the record selector button at the left end of the record and press [Delete] on the 
keyboard to remove the record. Then choose Yes when warned that you are about to 
delete a record.

■ Choose Home→Records→Records  on the Ribbon and choose Delete.

A Drag the 
Created By 
column so 
that it 
appears to 
the left of the 
Supplier ID 
column.

B Select both columns and choose 
Home→Sort & Filter→Ascending 
on the Ribbon.

FROM THE KEYBOARD

[Ctrl]+[F] to open 
the Find page of the 
Find and Replace 
dialog box
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QUICK REFERENCE: USING FIND AND REPLACE 

Item Feature Description

A Find What Contains the text, numbers, dates, and other values you want to locate.

B Look In Tells Access where in the data to search for the text. The data in the field 
that was active when the Find command is issued appears in the Look In 
box. You can change the location by clicking the down arrow and selecting 
the table name from the Look In list.

C Match Allows you to locate records where the search text appears as the only data 
in the field (whole field), anywhere in the field value, or at the beginning 
of the field.

D Search Tells Access which direction to search from the active cursor—forward to 
the end of the table, backward to the beginning of the table, or the whole 
table.

E Match Case Locates data that matches the exact capitalization pattern you type.

F Search Fields 
As Formatted

Searches for data as it is displayed in the datasheet rather than as you 
typed it. For example, if you check the box, you would search for data, such 
as March 5, 2007, as it appears in the datasheet even though you might 
have entered the data as 3/5/2007.

A 

B 

C 

D 

E F 
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Hands-On 2.6 Locate and Delete Records in a Table
In this exercise, you will use Find to locate a record in a table and delete it.

1. Open the Customers table in the Labyrinth Exports database.

2. Follow these steps to find the record to delete:

Access finds the record for Company X.

3. Click Cancel to close the Find and Replace dialog box, and then follow these steps to delete 
the Company X record:

Leave the table open. 

A Choose Home→Find→Find on the Ribbon to display the Find and Replace dialog box.

B Enter the 
values shown 
in each textbox 
of the Find 
page of the 
dialog box and 
then click Find 
Next to start 
the search.

A Point to the record selector button at 
the left end of the record to select the 
record for Company X and right-click 
to display the shortcut menu.

B Select Delete Record and then click 
Yes when Access warns you that 
you are about to delete a record.
Retrieving Data 47



ac7-qc1_book.book  Page 48  Wednesday, March 7, 2007  4:10 PM
Using Forms to Locate and Edit Records
Tables are one type of object you can use to update or delete records from a database. You can 
also use forms to edit and delete records. The basic procedures required to locate records using 
a form are the same as those used to locate records in a table.

Hands-On 2.7 Locate and Edit Records in a Form
In this exercise, you will locate a record using a form and update the data contained in the record.

1. Open the Customer Details form in the Labyrinth Exports database.

2. Choose Home→Find→Find  on the Ribbon and follow these steps to locate the record 
to edit:

3. Click Cancel to close the Find and Replace dialog box and then type the following new 
values in the First Name and Last Name fields to replace the current contact name: 
Viktor Alonzo.

4. Close  the form.

Using Find and Replace to Update Records
When you have specific edits to make to individual records, locating the records and making 
the edits works well. There are times when you need to update the data in one table field for 
multiple records with the identical replacement data. For example, when the area code for a 
city changes, multiple records would need to be updated with the same value. The Replace 
command enables you to update records in cases such as this by replacing existing data with 
new data. Because you are already familiar with the options on the Find page of the Find and 
Replace dialog box, you’ll find the Replace page of the dialog box very familiar. The Replace 
action buttons are used to:

■ Replace: Replace text for each occurrence of the search text one at a time.

■ Replace All: Replace all occurrences of the search text with the new text at the same time.

In general, the Replace All command should be used with great caution to avoid unexpected results. For 
example, if you search for a string of characters such as the and replace those letters with the 
single character a using Replace All, you may find that Access will replace the characters in their so that it 
becomes air. Both are valid words.

A Type 
Company N in 
the Find What 
text box.

C Click Find Next.

B Notice that 
other settings 
match those 
you last used.

FROM THE KEYBOARD

[Ctrl]+[H] for Find 
and Replace
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Hands-On 2.8 Update Multiple Records Using Find and Replace
In this exercise, you will use the Find and Replace dialog box to update multiple records with the same data.

1. Open the Employees table in the Labyrinth Exports database.

2. Follow these steps to locate and replace text with new values:

Access presents a warning message advising you that you will not be able to undo this action.

3. Choose Yes in response to the warning prompt, click Cancel to close the dialog box, and 
then scroll to the right to ensure that the value in the City field for all records (except your 
record) shows Seattle.

4. Close  the table.

Filtering Records 
So far, you have sorted records to place them in an order that they are more easily reviewed, 
and have used the Find and Replace features to delete and update records. In both cases, you 
worked with all records contained in the table. When you work with large volumes of table 
data, there will be times when you want to locate a group of records that contain specific 
values in specific fields. Filtering enables you to select a subset of records contained in the 
table to make working with the records more efficient. 

Using the Filter Tools
The Filter tool enables you to identify a value in any table field and tell Access to select only 
those records in the datasheet that contain the same value in the selected field. This process 
applies a filter to the table that hides records when the data in the active field contains 
different data. For example, if you work with a database that contains thousands of records for 
consumers across the country, you could apply a filter to identify all the people who live in a 
specific state.

A Choose Home→Find→Replace on the Ribbon to open 
the Replace page of the Find and Replace dialog box.

C Click Replace All to 
replace all occur-
rences of the search 
text at one time.

B Type Any City in 
the Find What text 
box and set other 
options as shown.
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Access provides two types of methods for filtering records: Filter by Selection and Filter 
by Form. 

■ Filter by Selection: Selects records on the basis of the value contained in the active field 
for the active record. 

■ Filter by Form: Selects records on the basis of values or conditions (criteria) that you type 
in one or more form fields. Again, Access searches only the fields you specify to find 
the match.

You will explore both techniques in this section.

Filtering Records by Selection
When you filter database records by selection, you have two options. You can instruct Access to 
select all records containing data that matches the value or selected text in the active field of 
the selected record. You can also instruct Access to select all records containing any value other 
than the one selected. Access searches only the active field to find the matches.

Removing a Filter
When you filter records in a table, Access recognizes the change to the display. As a result, if 
you close the table without removing the filter, Access prompts you to save changes to the 
table. Many times, you do want to save changes—such as when you widen or hide columns. 
Normally, filtering data in a table is temporary while you work with the data, so you do not 
want to save a filtered table. You remove a filter using the Toggle Filter tool.

Using the Toggle Filter Tool
The Toggle Filter  tool in the Sort & Filter section of the Ribbon serves two purposes:

■ After you apply a filter, clicking the Toggle Filter  button removes the filter and displays 
all records.

■ After removing a filter, clicking the Toggle Filter  button reapplies the last filter applied.

In addition, when you point to the Toggle Filter button, a ToolTip displays to let you know 
what action you are performing. For example, when you point to the Toggle Filter button after 
applying a filter, the ToolTip shows Remove Filter. When you point to the Toggle Filter button 
after removing a filter, the ToolTip shows Apply Filter.
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Hands-On 2.9 Filter Records by Selection
In this exercise, you will use tables to filter records and review the results before clearing the filter.

1. Open the Products table in the Labyrinth Exports database.

2. Follow these steps to set a filter:

Access applies the filter immediately and displays three records that contain 
the value.

3. Click the Toggle Filter  button to remove the filter and display 
all table records.

4. Follow these steps to display all records in the table that contain 
values other than Supplier D:

Access applies the filter immediately and displays 42 records that contain the value.

5. Close  the table. Choose No when prompted to save changes.

A Locate the 
Supplier IDs 
field column 
and select a 
record that 
contains the 
value 
Supplier D.

B Choose Home→Sort & 
Filter→Selection on the 
Ribbon.

C Select Contains Supplier D 
from the Selection menu.

A Locate the 
Supplier IDs 
field column 
and select a 
record that 
contains the 
value 
Supplier D.

B Choose Home→Sort & 
Filter→Selection on the 
Ribbon.

C Select Does Not Contain 
Supplier D from the 
Selection menu.
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Filtering Records by Form
Filtering records by form enables you to set criteria in fields of a blank form. Access then filters 
the database to select only the records that contain values set in fields on the form. 
One advantage to using the Filter By Form feature is that you can select records on the basis of 
values in multiple fields without rearranging the layout of table fields. Another advantage is 
that you can use comparison indicators to locate records that fit within a range of values. 
When you filter by form, Access remembers the sort criteria. As a result, it is important to clear 
all filters after you apply this filter.

Identifying Logical Operators
When you use the Filter By Form feature in Access, you will often apply comparison operators 
so that Access can locate records that contain the data you want to find. These operators are 
identified and described in the following table.

The format of the Filter By Form entry palette depends on whether you are filtering from a 
table or from a form. If you are filtering from a table, a datasheet palette opens.

QUICK REFERENCE: DEFINING COMPARISON INDICATORS AND SYMBOLS 

Comparison 
Symbol Description

= ■ Records in the table must contain a value that matches exactly the value you enter 
in the form for the field set.

< ■ Records in the table must contain a value less than the value you enter in the form 
for the field set.

> ■ Records in the table must contain a value greater than the value you enter in the 
form for the field set.

<> ■ Records in the table must contain a value different from the value you enter in the 
form for the field set.

<= ■ Records in the table must contain a value less than or equal to the value you set for 
the field.

>= ■ Records in the table must contain a value greater than or equal to the value you set 
for the field.

When you filter from a table datasheet, 
a blank datasheet for the table opens.

Notice that 
the table 
name appears 
in the Filter by 
Form tab.

Down arrows on active fields enable you to select values on the basis of 
valid table values.
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If you are filtering from a form, a blank form opens.

Using Wildcards
Because database users often want to locate records that contain data in a specific field but 
may also contain additional text or data, Access accepts the use of wildcards, such as the 
asterisk, for setting criteria. Valid wildcards and how Access uses them are identified in the 
following table.

Wildcard Example Description

* Appears in a position where any number of additional characters may 
appear in a search string.

*Graham* Locates all records with the string of text graham somewhere in the 
field value. The asterisk allows text and other data characters to appear 
before the search string as well as after the search text, regardless of 
how many characters appear.

Graham* Locates all records with the string of text graham at the beginning of 
the field value regardless of how many characters follow it.

*Graham Locates all records with the string of text graham at the end of the field 
value regardless of how many characters precede it.

Gra*ham Locates all records with the string of text beginning gra and ending 
ham regardless of how many characters appear between the search 
strings.

? Each question mark represents a character and limits the search to a 
specified number of characters on the basis of the number of question 
marks that appear.

Gra?am Locates all records with the string of text gra at the beginning of the 
field value and am at the end of the field value with only one letter 
between the instances of the letter a in the search string.

Gra??? Locates all records with the string of text gra at the beginning of the 
field value followed by three additional characters. 

Notice that 
the form 
name appears 
in the Filter 
by Form tab.

Down arrows 
on fields 
enable you to 
select values 
from a list of 
valid table 
values.
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Hands-On 2.10 Filter Records by Form
In this exercise, you will use both tables and forms to filter records by form.

1. Open the Orders table in the Labyrinth Exports database.

2. Follow these steps to open Filter by Form:

3. Follow these steps to filter and select all records in the Orders table that locate orders for 
one sales rep for a specific company:

Access locates two records that meet the criteria set and places a filter icon beside each field name for the 
filter values set.

4. Choose Home→Sort & Filter→Advanced Filter Options  on the Ribbon and select 
Clear All Filters to display all records and remove criteria from the Filter By Form window.

5. Close  the Orders table. Choose No when prompted to save the changes.

6. Open the Product Details form.

B Select Filter By 
Form to open a 
blank table record. 

A Click the 
Advanced Filter 
Options button.

A Press [Tab] to 
position the 
cursor in the 
Employee field.

B Click the down 
arrow at the 
right side of the 
Employee field and select 
Anne Hellung-Larsen. C Press [Tab] to move to 

the Customer field and 
select Company BB from 
the Customer list.

D Click the Apply Filter  
button to filter the records.
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7. Follow these steps to apply a filter by form to select products from a supplier that cost less 
than a specified value:

Access locates six records that match the criteria set. 

8. Click the Remove Filter  button to remove the filter, and then close  the form.

Previewing and Printing Data
Reports are considered a primary output format for Access databases because they summarize 
data and display it as meaningful information. There may be times when you want to print 
raw data contained in a table or query results datasheet, or data contained in specific fields in a 
database table. You may also want to print a single record within a database in form layout. 
Access provides tools for printing all of these objects. 

Setting Up Data to Print
Earlier in this lesson you learned how to adjust the column layout on a datasheet, how to 
search for records containing specific data, and how to filter out records that contain data 
different from the values you want to display. Each of these activities changes the display of 
data in a datasheet. When you print from a table datasheet, Access prints the data 
that actually appears in the datasheet when you issue the print command. You can hide 
columns to prevent them from printing, change the page layout settings to print the datasheet 
in landscape layout, and change the margins to fit a datasheet on a single sheet of paper. 

A Click the Advanced Filter Options button and select Filter By Form.

C Click the Supplier field down 
arrow and select “Supplier A.”

D Click the Apply 
Filter button.

E Use the navigation buttons at the bottom 
of the form to display each record found.

B Click the 
Standard Cost 
field and type 
<10 in the 
field.
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Examining the Preview Window
Previewing data before you print helps determine adjustments that need to be made to ensure 
that the datasheet prints on the page as you want it to. You can view multiple pages in print 
preview to see how columns line up, what columns appear on separate pages, and so forth, so 
that you can make the necessary adjustments to the datasheet.

Because the layout of database objects differs, options available in the Print dialog box vary 
depending on what you are printing. However, the basic procedures used to preview and print 
database objects are the same and are similar to the procedures used to print files in other 
applications. When you preview an object, the Print Preview tools appear on the Ribbon. These 
tools are used to change the layout of the page on which you print. 

The Print Preview 
Ribbon contains 
tools for changing 
the layout of the 
printed document.

Navigation buttons 
enable you to 
review all pages as 
they will print.

Preview settings 
enable you to 
change the number 
of pages displayed 
onscreen at one 
time.

Close Print Preview 
restores the access 
object window.
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Previewing and Printing Data 57

Hands-On 2.11 Preview and Print Data
In this exercise, you will preview and print a database table.

1. Open the Customers table and follow these steps to preview the datasheet:

2. Follow these steps to view pages that will print:

3. Choose Print Preview→Close Preview→Close Print Preview button on the 
Ribbon as shown to close the preview window.

4. Follow these steps to hide seven fields of data:

B Point (don’t 
click) on the 
Print menu  
button. If you 
click the Print 
command on 
the Office list, 
Access prints 
without 
previewing.

▼

C Choose Print Preview. 

A Click the 
Office button.

B Click the middle of the 
preview document to 
zoom in on the page.

A Click the Next 
Page naviga-
tion button and 
review all 
pages of the 
document. As 
long as the 
Next Page 
button is active, 
another page is 
required to 
print the 
datasheet.

A Click the Fax Number 
field column heading.

B Hold down the [Shift] key and click the Notes field column 
heading to select the two fields and those in between.
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5. Right-click one of the selected field column headings and select Hide Columns from the 
shortcut menu.

6. Adjust the column widths of the remaining columns.

7. Choose Office →Print menu →Print Preview, and then follow these steps to display 
multiple pages in the preview window:

The appearance of buttons and features on the Ribbon varies depending on screen resolution and size as 
well as the size of the application window. 

8. Choose Print Preview→Page Layout→Landscape  on the Ribbon to display the 
complete datasheet on one page.

▼

A Click this 
button to 
display two 
pages of the 
printout 
together 
onscreen.

B Click the 
column of the 
datasheet that 
appears on the 
second page to 
zoom in on it.

Landscape layout displays all 
columns together on a sheet.
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9. Choose Print Preview→Print→Print  on the Ribbon to open the Print dialog box.

10. Select options in the Print dialog box to print one copy of all pages.

11. Close  the table. Choose No when prompted to save changes. 

12. Close any other database objects that are open and close the Navigation Pane.

Saving a Database as a New File
Anytime you change a file, you need to save it to prevent unwanted loss of data. Access 
automatically saves each database record as you enter it and also prompts you to save each 
object as you modify or change it in any way. As a result, the data stored in a database saves 
regularly as you work. Existing files often make good files on which to create new files. 

Using the Save As Command
You can use the Office →Save As menu  command to save an existing database as a new 
database using a different filename just as you would with any other Microsoft Office application. 
Saving a database as a new file is not only a good way to quickly create a new database for a 
different purpose, but it is also a good way to create a backup of your data to protect it. Because 
many databases contain numerous objects, the Access Save As command also contains options for 
saving each of the database objects as new objects within the existing database. 

The Print dialog box you see may be 
different from the one shown here 
because of the difference in the 
printer that is active.

new!

▼
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Hands-On 2.12 Save a Database as a New File
In this exercise, you will save the Labyrinth Exports database as a new database file.

1. Close all database objects, if you have objects open.

2. Follow these steps to save the file as a new database file:

Access opens the Save As dialog box.

The Office →Save As commands.

Commands for saving the active 
or selected database object as a 
new object in the active database.

Commands for saving the database 
as a new file using various Access 
formats.

A Click the 
Office button. 

B Point to the 
Save As menu 

 button to 
display the 
Save As 
cascading 
menu.

▼

C Choose the Access 2007 
Database command.
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Saving a Database as a New File 61

3. Follow these steps to save your file as a new database file:

4. Close the database and exit Access.

A Navigate to and open the 
folder in which you are 
storing your class files.

B Choose the File Name text 
box and type the name of 
the new file shown.

C Click Save.
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Concepts Review

True/False Questions

Multiple Choice Questions

1. To locate records containing data for a specific field by selecting a value from a list of 
data entries, you must use the Filter By Form feature.

TRUE FALSE

2. When you rearrange columns in a datasheet and then print the datasheet, the 
printed document shows the columns in their original order.

TRUE FALSE

3. In the Find and Replace dialog box, you could change the Search setting to tell 
Access to search the entire table.

TRUE FALSE

4. The Replace button appears only on the Find tab page of the Find and Replace 
dialog box. 

TRUE FALSE

5. After you hide a column in a datasheet, there is no way to redisplay the column. TRUE FALSE

6. You can use both tables and forms to add records to database tables. TRUE FALSE

7. One of the main purposes of a database is to be able to retrieve data quickly 
and efficiently.

TRUE FALSE

8. Access contains two tools for locating data in a database: Find and Replace. TRUE FALSE

9. Only one column of data can be sorted at a time. TRUE FALSE

10. Filtering helps you narrow down a search for data by displaying only the records 
that contain values you want to consider.

TRUE FALSE

1. Which Access feature would you use to 
locate a record containing specific data 
without hiding any of the records?
a. Find

b. Find and Replace

c. Sort

d. Filter

2. What happens to a table design (or structure) 
when you reposition a field in the datasheet?

a. The field is repositioned in the table 
design.

b. Access displays a warning message.

c. Access deletes the field that originally 
appeared in the column.

d. Nothing

3. Which sort order arranges 
records alphabetically from A to Z? 

a. Sort numerically

b. Sort alphabetically

c. Sort ascending

d. Sort descending

4. What happens to a datasheet when you save it 
after sorting it?

a. Nothing

b. Access resorts it.

c. The new sort order is saved as part of the 
datasheet format.

d. Both b and c
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Skill Builders

Skill Builder 2.1 Adjust Datasheet Layout
The sb-Valley Hospital database has been updated to contain additional data in each table. In this exercise, 
you will adjust the widths of columns in each table to display data appropriately, reposition fields displayed 
on the datasheet, and hide other fields to obtain a printout of specific data. After you make the changes 
required, you can print the datasheets.

1. Start Access, and then open the sb-Valley Hospital database from the Lesson 02 folder in 
your file storage location. 

2. Enable content, and choose Office →Save As→Access 2007 Database.

3. Save the file using the filename sb-Valley Hospital-end in the Lesson 02 folder.

Adjust the Datasheet Column Width
4. Open the Patients table and press (Ctrl)+(A) to select all fields and data in the datasheet.

5. Point to the border between two of the column headings so the mouse pointer appears as a 
double-arrow, and then double-click the right column headings border between the 
column headings to widen all the columns to fit the data. 

6. Click the Save  button to save changes to the table layout.

Enter Data into the Datasheet
7. Click the New Record  button to create a new blank record and enter the following data 

to create two additional records:

Now you will hide one of the columns.

8. Right-click the Telephone column heading to display the shortcut menu and select 
Hide Columns.

Preview and Print the Table
9. Choose Office →Print menu  button→Print Preview to view the datasheet as it would 

print and then print the document (optional). 

10. Click the Close Print Preview button to close the preview, and then close the 
table, saving changes if prompted.

First Name Last Name Street City State ZIP Telephone DOB

Alex KELLY Olson Avenue COLUMBUS OH 43221 6145551024 9/14/1975

Bryan SANDERS Quaker Ridge Lane CHARLESTON WV 25301 11/22/1946

▼
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Skill Builder 2.2 Locate, Filter, and Print Records
A new record needs to be added to the Employees table in the sb-Valley Hospital—end database. In 
this exercise—after entering the new record using the Employee Personnel File form—you will locate all 
records for employees in the department and preview and print a copy of the two forms.

1. Open the sb-Valley Hospital-end database created in Skill Builder 2.1, if necessary, and 
expand the Forms list in the Navigation Pane.

Create a New Record
2. Open the Employee Personnel File form and click the New (Blank) Record  to create a 

new blank form.

3. Type the data shown in the following table to create a new record seven in the database, 
substituting your name and fictional data in fields indicated.

Find and Filter Records
4. Choose Home→Find→Find  on the Ribbon and type Office Adm in the Find What 

text box, select Employees Personnel File from the Look In drop-down list, and then 
choose Find Next.

5. Click Cancel to close the Find and Replace dialog box.

6. Choose Home→Sort & Filter→Selection  on the Ribbon and select the Equals “Office 
Adm.” command to filter the records.
Access locates only two records that contain the value.

Preview and Print Records
7. Choose Office →Print menu →Print Preview to preview the form print page.

8. Choose Print Preview→Print→Print  on the Ribbon to print the forms.

9. Choose the Pages option in the Print dialog box, enter From 1 to 1 and click OK to print 
the two records.

10. Close the print preview window and the form.

ID #
First
Name

Middle
Initial

Last 
Name

Street 
Address City State ZIP Department

Salary
Level

EX490 Yours Yours Yours Fictional Yours Yours Yours Office Adm. O3

▼
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Skill Builder 2.3 Sort and Print Datasheets and Reports
One of the benefits of storing data in a database is the ease with which you can sort the data. The US Postal 
Service requires that bulk mail be sorted and arranged by ZIP code before it will be accepted. Businesses, of 
course, often send letters to their customers and clients. Valley Hospital wants to use the database to organize 
records by ZIP code before using it to print envelope labels. In this exercise, you will sort the records by ZIP 
code and save changes to the table settings so that the records will remain organized in this sort order. In 
addition, because you have added a new employee to the database, you need to print a copy of the Employee 
Phone List report.

1. Open the sb-Valley Hospital-end database, if necessary, and open the Patients table (not 
the Patient Information form).

2. Hide the Street column in the datasheet.

Sort Records
3. Place the cursor in the ZIP field for any record. 

4. Choose Home→Sort & Filter→Ascending  on the Ribbon to sort the records.
Access sorts records so that all records with no data in the ZIP field appear at the top of the datasheet. 

5. Press (Ctrl)+(S) to save changes to the table and close it.

6. Open the Patients table again to ensure that the sort order was saved, and then print a 
copy of the datasheet.

Preview and Print a Report
7. Close the table and open the Employee Phone List report; preview and print the report.

8. Close all open database objects and then close the database.
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Assessments

Assessment 2.1 Edit Records and Save as a New File
Sales from the Rich Homestead have been doing well; therefore, in this exercise, you will need to update 
the database to remove records. By first filtering the records by form, you can narrow the list of records 
displayed to make the update process easier. As you work, you will need to adjust datasheet column widths 
to fit column contents. You will notice that the data is just raw data; for example, dollar signs have not 
been added.

1. Launch Access and open the as-Rich Homestead database from the Lesson 02 folder in 
your file storage location.

2. Enable content, and save the database to the Lesson 02 folder as a new file named 
as-Rich Homestead-end using the current file format.

Format Table Layout and Sort Data
3. Open the Records table, and adjust the column widths of all fields in the table to fit 

the contents.

4. Scroll to the right side of the table until you see both the Selling Price and Date End field 
columns, and then move the Date End column and place it just to the left of the Selling 
Price column.

5. Save changes to the table, and then sort the records alphabetically by the Item Title field.

Filter Records by Form
6. Click the Advanced Filter Options  button and choose Filter By Form to open a blank 

records form.

7. Type Decca* in the Item Title field and >8/30/07 in the Date End field.

8. Choose Home→Sort & Filter→Apply Filter  on the Ribbon.
Access locates two records.

Select and Delete Records
9. Click the record selector button for the first record and then press [Shift] and click the 

second record selector button to select both records.

10. Press (Delete) to delete both records. 
Access prompts you to confirm the deletion.

11. Choose Yes to delete both records.

12. Clear the filter criteria using the Advanced Filter Options shortcut menu.

13. Close the Records table. Choose Yes when prompted to save the table.
66 Lesson 2: Using an Access Database



ac7-qc1_book.book  Page 67  Wednesday, March 7, 2007  4:10 PM
Assessment 2.2 Locate and Update Data, and Print Datasheets
New items have been located that need to be added to the Rich Homestead store. They fit into two separate 
categories, Comics and Collectibles. In addition, the item descriptions of some of the comics and books 
contain extraneous characters that need to be removed. In this exercise, you will be able to print datasheets 
that display more uniform data.

1. Open the as-Rich Homestead-end database from the Lesson 02 folder in your file storage 
location and then open the Comics table.

2. Adjust the field column widths of fields containing truncated data and save changes to 
the layout.

Add Records
3. Add a new record to the table and type the following data into appropriate fields of the 

new record. Note that not all fields contain data:

Format A

Title Marvel—Spider-Man

Category 4542

Store Category 2961949

Quantity 1

Start Price 5

Duration 7

Selling Price

Gallery Type Gallery

Shipping Type Flat

Shipping Service 9

Shipping Service 5

Dispatch Time Max 2
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4. Open the List Collectibles form, create a new blank record in the form, and enter the 
following data for a new item:

5. Close the List Collectibles form, saving changes if prompted.

Locate and Update Records
6. Open the Comics table, sort the table data alphabetically on the Title field, and locate the 

records at the top of the table that contain multiple asterisks.

7. Select the Title field of each record containing multiple asterisks and remove the asterisks.

If you accidentally delete text other than the asterisks as you update the records, you can reverse the 
deletion using the Undo command. Simply press [Ctrl]+[Z] to reverse the deletion.

8. Repeat the instructions outlined in steps 6 and 7 to sort and remove the asterisks from 
records in the Books table.

9. Print copies of the datasheets for the following tables: Collectibles, Records, Books, 
and Comics.

Selling Format S

Accept Offer Y

Item Title Masonic Ceremonial Sword

Starting Price 25

Selling Price

Postage 15

Insurance 10

Date Listed 07/28/2007

Duration 30

Date End 08/27/2007
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Critical Thinking

Critical Thinking 2.1 Sorting, Filtering, and Locating Records
In this lesson, you learned how to use a database to sort, filter, and locate records. The 
ct-Potters League database contains a list of members stored in a table in the database. They 
want to print a number of lists using data stored in the table. In this activity, you adjust the 
layout of the table datasheet view and then sort and filter data before printing numerous 
datasheets. As you work, make the necessary adjustments to show all data contained in each 
field column and hide those columns that are empty. Save changes you make after adjusting 
column widths and after hiding the empty columns. 

Use the required feature to display and print the datasheet that shows the required data for 
each of the following list requests:

■ A list of all members arranged alphabetically by last name

■ A list of all members arranged by ZIP code

■ A list of all members who have paid their dues

■ A list of all members whose status is active

■ A list of all members whose status is supportive

■ A list of all members who live in Texas, the location for the event this year

Critical Thinking 2.2 Sorting and Filtering Data on the Internet
As you have most likely already discovered, databases are everywhere. As a result, you have 
many opportunities to sort data contained in databases you find—in online stores, 
information pools, and other sites. When a website has a Search tool included, you are actually 
applying a filter to the items or data stored in the online database.

In this exercise, you locate three sites on the Internet and print copies of the original page to 
show the arrangement of records, and then you use the sort and filter tools available to 
generate additional printouts.

■ Locate at least three sites on the Internet that you believe display data stored in a database. 
Print a copy of the site page as it appears before you change the arrangement.

■ Sort the data alphabetically on the field you believe provides a good description of the items 
in the database and print a copy of the sorted page.

■ Filter each site’s database to show all records in the database for only one type of listing 
and print a copy of the filtered page.
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Critical Thinking 2.3 Getting Help on Sorting and Filtering
The Help system in Access provides extensive information about sorting and filtering database 
data. Review the information provided about both topics to find out how Access handles each 
of the following:

■ Using queries with sorting and filtering

■ What to consider when sorting linked tables

■ The difference between a simple and a complex sort

■ The differences between select queries and filters

■ How to use the Advanced Filter/Sort features
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