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Oeports summarize data into 

meaningful information for printing. 

As a result, reports serve as output 

objects for Access databases. Although 

reports often summarize data from a single 

database table, they can display data from 

multiple tables and queries. Whether you are 

customizing forms or reports, you can use 

many of the same techniques to position 

fields, group date, and add pictures and titles. 

One important feature of customized reports 

includes the capability of adding calculated 

controls to generate report subtotals and 

totals. In this lesson, you will create a report 

in Design view, modify the report, format the 

report, and create calculated and total 

controls on the report. 
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L E S S O N  O U T L I N E

8.1 Using Report Design View

8.2 Creating a Report in Design View

8.3 Modifying a Report in Design View

8.4 Performing Report Calculations

8.5 Creating Labels Using the Label Wizard

8.6 Printing Reports

8.7 Concepts Review

Reinforce Your Skills

Apply Your Skills

Critical Thinking & Work-Readiness Skills

L E A R N I N G  O B J E C T I V E S

After studying this lesson, you will be able to:

■ Create a report using Report Design View

■ Modify reports

■ Add report sorting and grouping levels

■ Add graphics and other design elements to 

reports

■ Add calculated controls to a report and 

calculate totals

■ Create a labels report using the Labels Wizard
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Reporting Data

Customized input forms are great database objects for entering data, 

displaying data, and printing raw data for records contained in data-

base tables. Most businesses, however, want to summarize data, filter 

it, or sort it using one of the fields contained in a database table. Green 

Clean is no exception—the company wants a new report that summa-

rizes the sales for each employee and prints the data with sales totals. 

Allen Sedgwick, manager of Computer Information Systems, has 

agreed to create a custom report to meet these needs. The first draft of 

the report design is shown here. After the CEO reviews the design, he 

completes a sample report for review by other executives.
Fo
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Video Lesson labyrinthelab.com/videos

Report Design View displays the sections of each report, identifies each control contained in 

the report, and holds the basic layout and design elements for the report. If you have explored 

Form Design View, you know that it enabled you to view different form sections such as Form 

Header, Detail, and Form Footer. Report Design View displays numerous sections as well, and 

each is identified by a section bar. In addition to the Detail section, the report sections used 

most frequently include the Report Header/Footer sections and Page Header/Footer sections. 

Identifying Report Design View Elements
The design elements you will see as you work with Report Design View resemble those that 

were available for designing forms. If you have customized forms, many of these elements will 

be familiar to you.

8.1 Using Report Design View

Report Header section contains information that 
appears only at the top of the first report page.

Page Header section contains information that 
appears at the top of every report page.

Detail section contains data and summary 
information.

Page Footer section contains information that 
appears at the bottom of every report page.

Report Footer section contains information that 
appears at the bottom of the last report page.
286 Lesson 8: Creating Custom Reports
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IDENTIFYING REPORT DESIGN ELEMENTS 

Report Element Description

Sections The major parts of the report, such as the Report Header, the Report Footer, the 

Detail, the Page Header, and the Page Footer. Section bars divide report sections.

Controls Items on a form or report that display data, perform actions, and decorate the object. 

Access uses three main types of controls on reports—bound controls, unbound 

controls, and calculated controls. Each control consists of two parts—control label 

and control text box—that are tied to a field in a database table.

Bound control A control that ties, or binds, data displayed on a report to a field in a database table 

so that the field value appears on the report. Bound controls normally appear in the 

Detail section of a report.

Unbound control An item on a report that is independent of data and fields in a database table. 

Unbound controls can be lines, rectangles, pictures, and so forth. Unbound controls 

can appear in any report section.

Section bars identify 
the report sections.

The Report Header section holds the report 
title, date, and time the report was compiled.

Label controls identify 
the data in the Page 
Header section.

Control text boxes display 
data from the associated 
table in the Detail section.

Tools in the Controls group of the Report Design tab on the 
Ribbon enable you to add graphics and other types of controls.

Four tabs appear in the Report 
Design Tools area of the Ribbon.

The Field List panel displays fields available from 
the table or query on which the form is based.

The Report Footer section 
shows a function control 
that counts the entries.

Page Footer contains a 
control that includes 
the page number.

Scroll buttons display 
additional control tools.

QUICK REFERENCE
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Displaying Report Views
As you design reports, you will find that there are three views available—Report View, Layout 

View, and Design View. Working with these views is similar to working with views in Form 

design. Each view has its own distinct purpose:

Switching Between Views
It is a simple matter to switch between Layout View and Design View when required tools are 

available only in Design View. The Home and Design tabs on the Ribbon both contain controls 

that allow you to switch the View. 

Calculated control A control that is tied to an expression created for the report or to a calculated field 

constructed in a query. Calculated controls normally appear in the Detail or Report 

Footer section of the report. 

Control label The part of a control that contains text to identify the data displayed on the report. 

Normally, the control label text is the field name or caption set for the field. For 

example, Employee Number is a label that identifies the Employee# field.

Control text box The part of a control that displays data from a field in an Access table. For example, 

ToliP01 is the data contained in the Employee# field.

Report Header/

Footer

The sections of a report that contain text, pictures, and other items that are repeated 

at the top (header) or bottom (footer) of the report. 

Detail section The main section of a report, which normally displays data from database tables that 

varies from record to record.

Page Header/

Footer

The sections of a report that contain text and other items that are repeated at the top 

(header) or bottom (footer) of every page of the report.

Group Header/

Footer

The sections that identify a field on which data in the report is grouped (Group 

Header) and enables you to report summary data for the group (Group Footer). The 

name of the grouped field appears in the Group Header and Footer bars.

USING REPORT VIEWS 

View Description Use this view to . . .

Report Displays when you open a report. Report View 

does not permit modification of formatting or 

data. Report View presents the report as it will 

print. 

■ Preview a report layout before printing. 

■ View summarized data.

Layout Displays a “run” of a report layout with sample 

data displayed so that you can size and 

position controls appropriately. You can 

modify formatting in this view as well as use 

many of the same design tools that are 

available in Design View. 

■ Preview a report with data.

■ Size and position controls and ensure that 

all data contained in a field displays 

properly on a report.

■ Add a limited number of controls to 

a report.

Design Displays the design palette containing 

sections and section bars, controls, labels, 

design elements, and other report features. In 

addition, tools for adding many additional 

controls are available in Design View.

■ Format and design a report.

■ Add summary data and controls.

■ Add design elements.

IDENTIFYING REPORT DESIGN ELEMENTS (continued)

Report Element Description

QUICK REFERENCE

QUICK REFERENCE
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Display Report Views 8.1.1

In this exercise, you will open an existing report and display it in all three report views.

1. Open the Green Clean database from your Lesson 08 folder and save the file using the 

filename Green Clean Reports.

2. Open the Employees report to display the report in Report View.

3. Choose Home→Views→View menu  on the Ribbon and choose Design View.

4. Follow these steps to locate associated controls:

5. Choose Home→Views→View menu  on the Ribbon and choose Layout View.

From this point forward, the instructions for switching views will simply instruct you to switch 
to the appropriate view. For example, switch to Design View or switch to Layout View. 

SWITCHING AMONG REPORT VIEWS

Task Procedure

Display Report View ■ Open a report.

■ From Layout View, choose Design→Views→View menu  and choose Report 

View.

or 

■ From any view, choose Home→Views→View menu  and choose Report View. 

Display Design 

View

■ Right-click a report name in the Navigation Pane and choose Design View.

or

■ From Layout View, choose Design→Views→View menu  and choose Design 

View.

or

■ Open a report and choose Home→Views→View menu  and choose 

Design View.

Display Layout View ■ Right-click a report name in the Navigation Pane and choose Layout View.

or

■ From Design View, choose Format→Views→View menu  and choose Layout 

View.

or

■ Open a report and choose Home→Views→View menu  and choose 

Layout View.

DEVELOP YOUR SKILLS 8.1.1

QUICK REFERENCE

▼

▼

▼

▼

▼

▼

▼

A Click the ID control 
text box in the 
Detail section.

B Locate the connected control 
label in the Page Header section.

▼

NOTE
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6. Follow these steps to identify features in Layout View:

7. Close the report without saving changes.

The appearance of buttons on the Ribbon may be different from those shown here due to 
screen resolution and monitor size.

Video Lesson labyrinthelab.com/videos

Now that you are familiar with many of the features found in reports and Report Design View, 

you may find building a report from scratch using Design View more efficient—especially 

when you want to include only a few fields from a table in the report. When you create a new 

report in Design View, you select the table that contains the fields you want to include in the 

report, drag fields to report sections, and insert group sections. When the basic structure of the 

report is complete, you can add controls to create titles, add graphics, and insert footer 

controls. Many of the tools you use to build a report in Design View appear on the Design tab 

of the Ribbon.

Working with Report Controls
The controls you selected on the report when it was displayed in both Layout View and Design 

View are bound controls that display data contained in database tables. Access has three basic 

types of controls that you can add to reports—and these controls parallel those you can add to 

forms. 

■ Bound controls—Controls that tie, or bind, data displayed on a report to a field in a 

database table so that the field value (data) appears on the report. Bound controls normally 

appear in the Detail section of a report.

■ Unbound controls—Lines and other drawn objects, text for titles, graphics, and so 

forth—independent items you can add to a report to enhance the appearance of the report. 

8.2 Creating a Report in Design View

A Click EmployeeID 
value GSE-001.

B Locate the associated column 
heading that displays a dotted border.

C Review the tools on the 
Design tab of the Ribbon.

NOTE
290 Lesson 8: Creating Custom Reports

Labyrinth Learning  http://www.lablearning.com



Microsoft Access 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
Fo
r E

va
lu

at
io

n 
O
nl

y

■ Calculated controls—Controls that are tied to an expression, aggregate function, or 

calculated field constructed in a query or built directly on the report. Calculated controls 

normally appear in the Detail or report Footer section of the report.

Adding Controls from Field Lists
The Field List contains a list of all tables that appear in the database. You can expand a table to 

display all fields contained in the table. In addition, when you add a field from one table to the 

list, a section of the Field List panel shows tables that are related to the selected table. As a 

result, you can expand related tables and use fields from related tables in the report. 

Dragging Controls from the Field List
Adding bound controls from the available field list to a section of a report is as 

simple as dragging the control and dropping it into the appropriate report 

section. When you add a field from the field list to the report page, Access places 

both the control label and control text box for a bound control on the report. 

Because most reports display the control label in the Page Header section, you 

can cut it from the Detail section and paste it into the Page Header section or delete it from the 

Detail section and add a new label control to the Page Header section. If you try to drag the 

field to the Page Header section and then move the control text box to the Detail section, 

Access moves both parts of the control to the Detail section.

Bound control pulls data 
from the ID field.

Unbound control provides 
a title for the report.

Calculated control counts the 
number of entries using an 
aggregate function.

The additional 
table relates to 
the table 
currently used.

Fields from this table 
appear in the report.

FROM THE KEYBOARD

[Ctrl]+[X] to cut an 
object
[Ctrl]+[V] to past an 
object
Creating a Report in Design View 291
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Adding Controls from the Ribbon
When you display a report in Design View, Access displays control tools on the Ribbon used to 

add unbound controls to reports. Tools used to change font and add color to reports are also 

available in Layout View. As a result, working in Design View as you design and set controls on 

reports is essential.

A limited number of controls is available in Layout View. As a result, most people use Design 
View to add controls to reports because more controls are available when Design View is 
displayed. 

Create a Report in Design View 8.2.1

In this exercise, you will create a report in Design View, add bound controls to the report, and position 
control labels in the Page Header.

1. Choose Create→Reports→Report Design  on the Ribbon.

Access creates a new blank report and displays it in Design view. The Field List should also be displayed.

If the Field List is closed, choose Design→Tools→Add Existing Fields  on the Ribbon to 
open it.

2. Follow these steps to add a field to the report:

ADDING CONTROLS TO A REPORT

Task Procedure

Drag controls ■ Display the report in Layout or Design View.

■ Choose Design→Tools→Add Existing Fields  to open the Field List.

■ Expand the table containing the field you want to add.

■ Drag the field onto the report and position it where you want it.

Add controls from 

a Ribbon

■ Display the report in Design View.

■ Choose Design→Controls and click the control type button you want to add to the 

report.

■ Click or drag a control in the position and size you want on the report.

DEVELOP YOUR SKILLS 8.2.1

QUICK REFERENCE

NOTE

TIP

A Expand the Orders table 
to display the fields 
contained in the table.

B Drag the Order ID field to 
about the 1" position on 
the horizontal ruler in 
the report Detail section.
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3. Follow these steps to move the Order ID control label to the Page Header section:

Access places the label at the left edge of the Page Header section.

4. Drag the Order ID control text box to the left and position it below the Order ID label.

5. Repeat the procedures outlined in steps 2–4 to add fields, position labels, and move text 

boxes to the positions shown in the following figure.

6. Save the report using the Report name Sales Report and leave it open.

After saving the report, Access places the name of the table from which each control text box came before 
the field name and separates the table name from the field name using a period (.). For example, you 
will notice Orders. OrderID in the first control text box in the Detail section of the report after saving it.

A Right-click the 
Order ID control 
label and 
choose Cut.

B Right-click the 
Page Header 
section bar and 
choose Paste.

Field from the Inventory field list

Fields from the 
Orders field list

Field from the Employees field list
Fo
r E
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Video Lesson labyrinthelab.com/videos

As you work in Report Design View, you can use many of the techniques and features used to 

customize forms to format and enhance data controls on the report and set background colors, 

etc. One important difference between customizing forms and reports is the general layout of 

the object. Reports normally display control labels in the Report Header section so that they 

serve as column headings. Control text boxes appear in the Detail section. In addition, when 

you group summary data in a report, Access displays Group sections that hold group titles, 

group field control labels, and group summary data. 

Adding Report Sorting and Grouping Levels
The report you have created is relatively sparse—it currently contains only five fields and 

column headings. If you printed the report now, it would resemble a table datasheet. However, 

by grouping the data using the Employee field, you create a report that provides information 

that is easier to locate. A group is a collection of records that has at least one data element in 

common. For example, if you want to display all vendors with offices in the same state, you 

could group on the State field. A group consists of a Group Header, records, and a Group 

Footer. Grouping records enables you to separate records visually on a report and display 

introductory and summary data for each group.

8.3 Modifying a Report in Design View

Data records are grouped for each employee.
294 Lesson 8: Creating Custom Reports
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Using the Group, Sort, and Total Panel
To view the grouping and sorting settings, you display the Group, Sort, and Total panel at the 

bottom of the Access window. You can then use the panel to add groups and sorting settings or 

review them after you set them. You can also set up groups using commands on the shortcut 

menus and then study the effect in the Group, Sort, and Total panel. You can set properties in 

the Group, Sort, and Total panel to display or hide group headers and footers. Additional 

properties enable you to tell Access how to group data, set a grouping interval, and set group 

properties for keeping items in a group together on a page.

Working with Group Sections
Setting a group and sort order does not automatically place the column heading or field 

control text box on the report. It simply sets the grouping and sorting order and creates a 

section on the report to hold the controls. After you set up the groups, it is important to either 

move the group field from the Detail section to the Group section or add it to the Group 

section. By placing the field text box control in the Group Header section, Access groups all 

entries by the field you choose and each item in the Group Header section prints only one 

time—at the start of a new group value.

Creating Multi-Level Groupings
Access provides multi-level grouping for records on a report. If, for example, you want to print 

invoices that group items ordered by type or category for each customer, you would use two-

level grouping. You can set multiple groups using the Sort, Group, and Total panel or by 

choosing the command from the shortcut menu. 

The Group, Sort, and Total 
panel displays at the 
bottom of the window.

The field on which Access 
will group the data.

The Group Header 
identifies the field but 
contains no field controls.

The LastName control 
will be moved to the 
group header.
Modifying a Report in Design View 295
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The command you see when you right-click a field name to group or sort depends on the 
data type of the field.

Add a Group and Sort Level to a Report 8.3.1

In this exercise, you will add a group and sort level to the Sales Report in your Green Clean Reports 
database that groups records by sales person.

1. Display the Sales Report in Design View.

2. Right-click the Employees.LastName text box control in the Detail section of the report 

and choose Group On.

Access displays a group header for the new group.

3. Choose Design→Grouping & Totals→Group & Sort on the Ribbon to open the Group, 

Sort, and Total panel.

4. Right-click the LastName text box control in the Detail section again and choose Cut.

5. Right-click the Employee.LastName Header section bar and choose Paste to place the 

text box control in the group header section.

6. Follow these steps to set a sort order using the Group, Sort, and Total panel:

ADDING SORT AND GROUP LEVELS

Task Procedure

Display the panel using the 

Ribbon in Layout or Design 

View

■ Display the report is Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

Add group level ■ Right-click the field on which you want to group data records.

■ Choose Group On Field Name.

Add sort order ■ Right-click the field on which you want to sort data or groups.

■ Choose Sort A to Z or Smallest to Largest  

or 

■ Choose Sort Z to A or Largest to Smallest .

DEVELOP YOUR SKILLS 8.3.1

QUICK REFERENCE

NOTE

A Click the Add a Sort 
button on the Group, 
Sort, and Total panel.

B Choose 
Employees.LastName.
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7. Right-click each of the following controls in the sections identified and choose Delete to 

remove them:

8. Scroll down to the bottom of the report palette and follow these steps to size the 

Detail section:

9. Switch to Report View and compare your report to the one shown here:

10. Save  changes to the report, and then close  it.

Section Control

Page Header ID label and Last Name label

Detail Orders.ID ID

A Drag the Page Footer 
section bar up.

B Drop the section bar 
just below the Detail 
section controls.

All orders for 
Adams display first.

Orders for Bouras start.

Notice that the column 
headings need to be fixed.
Modifying a Report in Design View 297
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Adding Date and Time Data to a Report
Video Lesson labyrinthelab.com/videos

When reports change frequently and are printed regularly, keeping track of the most current 

report can be a challenge. You can add a date and/or time to the footer section of a report to 

help you track the reports. When you add the date and time controls, Access places the 

controls in the Report Header section by default. You can move them to the section in which 

you want them to appear or leave them in the Report Header section.

Add Date and Time to the Page Footer Section 8.3.2

In this exercise, you will add the date and time to the Page Footer section of your report.

1. Display the Sales Report in Design View.

2. Choose Design→Header/Footer→Date & Time  on the Ribbon to open the Date and 

Time dialog box.

3. Follow these steps to add date and time controls to the section:

ADDING DATE AND TIME FIELDS TO A REPORT

Task Procedure

Add a date field to a 

report

■ Choose Design→Header/Footer→Date & Time  on the Ribbon.

■ Check the Include Date checkbox, select the format option, and click OK.

Add a time field to a 

report

■ Choose Design→Header/Footer→Date & Time  on the Ribbon.

■ Check the Include Time checkbox, select the format option and click OK.

DEVELOP YOUR SKILLS 8.3.2

The Date and Time controls in the Report Footer section.

QUICK REFERENCE

A Check the Include Date 
checkbox.

B Choose the mm/dd/yyyy 
format option.

D Choose the hh:mm time 
option and then press [Enter].

C Check the Include Time 
checkbox.
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4. Click the =Date() control and press (Shift) and click =Time() control to select both 

controls in the Report Header section.

5. Right-click one selected control and choose Cut; then right-click the Page Footer section 

and choose Paste. 

6. Drag the controls to the right side of the Page Footer section.

7. Save  changes to the report and then close  it.

Adding Graphics to Reports 
Video Lesson labyrinthelab.com/videos

Adding a graphic to a report that identifies the business can be an effective way to associate 

a corporate logo with a company. Graphics also dress up a report to make it more interesting 

to those who use the report. Access contains two basic tools for adding a graphic to a report 

or form:

■ The Image or Insert Image control: Enables you to position a graphic on any report or form 

section

■ The Logo control: Places a logo in the Report Header section of a report and the Form 

Header section of a form

Applying Themes
When you build the report in Design View, you add design elements to the report manually. 

Formatting a report using the Themes feature enables you to create a report using color 

schemes available in Access. Themes contain design elements such as background color, font 

and font size, and so forth that quickly dress up a report without the tedious formatting of 

controls and background manually and individually. Applying a Theme improves the read-

ability of the report and can make it look more professional. However, caution should be used 

when applying a Theme to a report because applying Access Themes reformats all objects in 

the active database with the color scheme defined in the Theme. Because reports are designed 

for printing, the formatting Themes apply is much more subtle for reports than it is for forms. 

As a result, you may wish to apply additional formatting controls after you apply the Theme.

ADDING A GRAPHIC TO A REPORT OR FORM

Task Procedure

Add a logo to a 

report or form

■ Display the form or report in Design View.

■ Choose Design→Header/Footer→Logo  on the Ribbon.

Add a picture to a 

report or form: 

■ Display the report or form in Design View.

■ Choose Design→Controls→Insert Image

or 

■ Choose Design→Controls→Image.

QUICK REFERENCE
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Add a Logo and Apply Themes to a Report 8.3.3

In this exercise, you will add a logo to the Report Header section and apply a Theme to the report.

1. Display the Sales Report in Design View.

2. Choose Design→Header/Footer→Logo  on the Ribbon to open the Insert Picture 

dialog box.

3. Open the Lesson 08 folder and double-click the GC Logo.jpg filename.

Access places the logo in the upper left corner of the Report Header section, as shown. Notice, too, that 
there is a long narrow box immediately to the right and attached to the logo. This box is used to type a 
title on the report. You can delete the title box or use it to add a title to the report.

4. Choose Design→Themes→Themes  on the Ribbon and choose the Trek Theme 

from the palette.

Although you have selected a different format, you may see no difference in the report until you display 
the report in Layout or Report View.

5. Save  changes to the report and then close  it.

Formatting Controls
Video Lesson labyrinthelab.com/videos

Now that you have the elements you want to include on the report set, you can format the 

controls to make them visually effective. Aligning controls to ensure that the column headings 

appear where you want them, adding a title, and formatting the text and sizes of each control 

are just a few of the edits you can make. The procedures you use to format, align, size, and 

position the controls are the same procedures you used to format controls on forms.

Selecting Controls
Each control, as you are aware, contains two parts: the control label and the control text box. 

When you add a field control to a report, Access places both parts of the control on the report 

APPLYING THEMES TO FORMS AND REPORTS

Task Procedure

Apply a Theme ■ Prepare the report or form to which you want to apply the Theme.

■ Display the report or form in Design View or Layout View. 

■ Choose Design→Themes→Themes  on the Ribbon.

■ Select the Theme to apply.

DEVELOP YOUR SKILLS 8.3.3

QUICK REFERENCE

The logo
Box for 
the title
300 Lesson 8: Creating Custom Reports

Labyrinth Learning  http://www.lablearning.com



Microsoft Access 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
Fo
r E

va
lu

at
io

n 
O
nl

y

and you can reposition the label as you did earlier in this lesson. To select multiple controls at 

the same time, you have several options: Clicking each control individually, selecting all 

controls along a horizontal or vertical line, or outlining an area of the report to select all 

controls within the area.

Sizing Controls
An important part of any report is reporting and summarizing accurate data. Another part of 

reporting data is ensuring that the data is fully displayed in the report. To accomplish that, you 

need to size controls on the report so that they are large enough to display the longest data 

value for each field. Sizing controls is often more efficient in Layout View because the report is 

running and data displays as you size the control. As a result, you can be certain that data for 

all records has adequate space.

As you work in Layout View, you will find that active controls display a heavier border than 

inactive controls. Use the borders to size the control just as you used handles on active controls 

while working in Design View—drag the border. As you drag the border for the active record, 

the controls for that field on all records also resize, just as they would if you resized the control 

in Design View. The main difference is that in Design View, you only see one control—not 

multiple controls that represent multiple records.

Identifying Mouse Shapes
 The mouse pointer shape is important as you work with Design as well as Layout View. 

You’ve already seen how the mouse pointer appears when you are sizing a control. In addition 

to the sizing mouse shape, you will see the white pointer arrow accompanied by a four-headed 

black arrow that you use to move a control.

Set, Size, and Align Report Controls 8.3.4

In this exercise, you will use Layout View to reposition controls on the Sales Report, align the controls, and 
size the controls to fit the data. 

1. Display the Sales Report in Layout View and follow these steps to size the control:

DEVELOP YOUR SKILLS 8.3.4

As you drag a border, 
notice that the mouse 
pointer appears as a 
two-headed arrow.

The borders of additional 
records also resize.

The active control 
displays a broader border.

A Click the GC-24 control to make it active.

B Point to the left border of the control until 
the mouse shape appears as shown here. C Drag the border to a position 

close to the 2 in the value.
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2. Follow these steps to position and align the column headings:

3. Save  changes to the report and then close  it.

Adding a Title to the Report Header
Video Lesson labyrinthelab.com/videos

Titles identify the purpose of forms and reports and often contain only the name of the 

company. You can use Design View to add a Label control containing the title to the report or 

use the Title tool that is designed to specifically add and format a title. Both tools are available 

in both Design and Layout Views. When you use the Title tool to create a title for a form or 

report, Access places the report name as the title, positions it in the appropriate section of the 

form or report, and formats the text using the default settings. You can then change the text 

format if desired, using tools on the Ribbon and the Property Sheet. Because you have already 

applied a Theme to the report in this lesson, Access will format the title using settings that are 

active in the Theme.

Using the Property Sheet
The Property Sheet contains property settings that control the way many elements of database 

objects function and look. You have already used the Property Sheet to set data format in 

tables and form properties. Many of the same properties are available for controlling data 

display in reports. 

Add a Report Title and Format Text 8.3.5

In this exercise, you will use Layout View to add a report title and format text using the Property Sheet 
and Ribbon.

1. Display the Sales Report in Layout View.

2. Choose Design→Header/Footer→Title  on the Ribbon.

Access places a title with the text Sales Report beside the logo at the top of the report.

3. Click the Sales Report title and choose Design→Tools→Property Sheet  on the 

Ribbon.

DEVELOP YOUR SKILLS 8.3.5

B Center the Number 
Ordered and Price labels 
above their columns.

A Click the Order ID 
control label and drag 
it to the right so that it 
appears centered 
above the column.
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4. Change the following property settings to format the title control:

5. Drag the lower-right corner of the logo and size it to the height of the title.

6. Save  changes and display the report in Design View.

Format Label Controls

7. Click the vertical ruler on the left in the Page Header section to select all column head-

ings and choose Format→Font→Bold and set the size to 14.

8. Size each column heading so that all text displays and then adjust the positions of the 

column headings appropriately.

9. Select the Employees.LastName text box in the Group Header section and set the 

following properties in the Property Sheet:

10. Adjust the size of the Employees.LastName control and the height of each report 

section.

11. Save  changes to the report, view the report in Layout View and make additional 

adjustments, and then close it.

Property Setting

Special Effect Raised

Font Size 36

Width 3.5"

Text Align Center

Font Weight Semi-bold

Property Value

Back Color Brown, Accent 2

Special Effect Sunken

Fore Color White

Font Size 16

Text Align Center
Fo

Modifying a Report in Design View 303
Labyrinth Learning  http://www.lablearning.com



Microsoft Access 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
Fo
r E

va
lu

at
io

n 
O
nl

y
Video Lesson labyrinthelab.com/videos

By now, you have most likely learned how to create a calculated field in a query grid. You can 

also create calculated controls in reports that calculate values for each record based on data 

contained in table or query fields. When you position the calculated control in the Detail 

section, Access calculates the value for each record in the report each time you open and print 

the report. As a result, each time you update a value used in a calculated control, Access 

updates the report the next time you open and print it. The Text Box control is one tool you can 

use to create a control on the report to hold the calculated expression.

Using the Expression Builder
You can create a calculated control by typing control field names and operators (multiply, 

divide, add, subtract, etc.), symbols such as square brackets, and so forth, directly in the 

Control Source property in the Properties dialog box. However, many people find it easier to 

use the Expression Builder dialog box to build the expression. The Expression Builder dialog 

box contains features that enable you to paste field names and operators required for the 

expression right into the dialog box so that you can review the expression. You can use the 

Expression Builder to create expressions in queries, on forms, or on reports.

8.4 Performing Report Calculations

Fields and controls are 
available in the active object.

These properties can be set.

The calculated expression appears in 
the box at the top of the dialog box.

All objects in the database are grouped 
by type in this list. The active object is 
highlighted and appears open.
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Add a Calculated Control Using the 
Expression Builder 8.4.1

In this exercise, you will add a bound calculated control to the report that calculates the total sales for each 
record. You will use the Expression Builder and Design View.

1. Display the Sales Report in Design View and display the right side of the Detail section.

2. Choose Design→Controls→Text Box  on the Ribbon and follow these steps to 

create the control to hold the calculation:

Access places a unbound control text box on the report along with a control label.

3. Press [F4] to display the Property Sheet and follow these steps to open the 

Expression Builder:

Access opens the Expression Builder dialog box.

USING THE EXPRESSION BUILDER

Task Procedure

Create a calculated 

control using the 

Expression Builder

■ Display the form or report in Design View.

■ Choose Design→Controls→Text Box  on the Ribbon. 

■ Click or draw the control on the form or report palette where you want it to appear.

■ Press [F4] to display the Property Sheet and click the Data tab.

■ Click the Control Source property and then click the Build  button.

■ Add fields, operators, and other elements to the expression and then click OK.

DEVELOP YOUR SKILLS 8.4.1

QUICK REFERENCE

A Drag the crosshair mouse 
in the Detail section from 
about the 4.25" mark on 
the horizontal ruler.

B Release the mouse button 
when the mouse pointer 
appears about the 5.25" mark.

A Click the Data tab, and then 
click the Control Source box.

B Click the Build button 
at the right end of the 
Control Source box.
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4. Follow these steps to create the calculated expression:

5. Follow these steps to add the operator to the expression:

6. Follow these steps to complete the expression:

Access adds the field to the box at the top of the Expression Builder.

7. Click OK to place the expression in the Control Source property box. 

8. Click the Property Sheet Format tab and set the Format property to Currency and the 

Text Align property to Right.

9. Right-click the control label on the report and choose Cut; then right-click the Page 

Header section bar and choose Paste to place the control as a column heading.

10. Position the label above the calculated control text box and then double-click the label 

text and type Item Total.

11. Click the Price column heading (label). 

12. Choose Home→Clipboard→Format Painter  on the Ribbon to pick up the format of 

the column heading.

13. Click the Item Total column heading to paint the format onto it and size the control to 

display all text.

14. Switch to Report View to display the report with totals and then save  it.

A Click Sales 
Report in the 
Expression 
Elements list.

B Double-click Quantity in the 
Expression Categories list to 
add it to the expression.

A Click Operators 
in the 
Expression 
Elements list. B Double-click the asterisk (*) 

in the Expression Values list 
to add it to the expression.

A Click Sales 
Report in the 
Expression 
Elements list.

B Double-click Price in the 
Expression Categories list 
to add it to the expression.
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Creating Controls to Calculate Totals
Video Lesson labyrinthelab.com/videos

The calculated control you added to the report calculated a total for each item in the report. 

The calculated control appeared in the Detail section of the report. You can add calculated 

controls to other sections of the report so that the control performs a calculation on groups of 

records. For example, when you have a report that is grouped by sales person, such as the one 

you are creating, you can add the calculated control to the Group Footer section so that Access 

calculates a value for each group. And if you want a simple total at the end of a report, you 

would add the calculated control to the Report Footer section. You can even create a control 

that calculates sub-totals and then create a control that calculates a grand total at the end of 

the report. 

Displaying the Group Footer Section
You may have noticed, when you set the report to group records by employee last name, that 

Access displayed the header but left the footer hidden. In most cases, the group footer is used 

only to display group summary data such as totals and calculations. As a result, before you can 

add a group total, you must first display the Group Footer section. You display the Group 

Footer section using the Group, Sort, and Total panel or by setting a function for a field in the 

Detail section.

Creating Aggregate Fields
In addition to creating calculated totals in the Group Footer section, you can total values, find 

averages, and set other aggregate functions directly from the Group bar in the Group, Sort, 

and Total panel. When you select a field control in the detail section of the report, you can also 

use the totals button on the Ribbon to set aggregate functions for the field.

The Group bar expands to display additional options. Feature options appear on drop-down menus.

Click the With No Totals 
list button to open the 
Totals options.

Set the field and position you want 
to display the totals and functions.
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Create Calculated Totals and Set Functions 
in Group Footers 8.4.2

In this exercise, you will create a calculated total for each sales person and also set a function to calculate the 
total and average of other columns in the report.

1. Display the Sales Report in Design View and select the Orders.Quantity control in the 

Detail section.

2. Choose Design→Grouping & Totals→Totals  on the Ribbon and choose Sum.

Access opens the EmployeeLastName Footer section and places the function in the footer.

3. Repeat the procedures outlined in steps 1 and 2 to set an Average function for the 

Inventory.Price field in the Detail section. 

4. Choose Design→Controls→Text Box  on the Ribbon and create a new text box at 

about the 5.5" mark in the Employees.LastName Footer section.

5. Select the calculated control in the Detail section and copy and paste it into the 

Employees.LastName Footer section, positioning it at about the 5.5" mark.

6. Open the Property Sheet Data tab and follow these steps to revise the expression to 

calculate total sales for each salesperson:

USING GROUP, SORT, AND TOTAL FEATURES

Task Procedure

Display the Group 

Footer section

■ Display the report in Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

■ Click More on the Group bar for the group for which you want to display a footer.

■ Click the Without a Footer Section list button and choose With a Footer Section.

Set aggregate 

function totals from 

the Group bar

■ Display the report in Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

■ Click More on the Group bar for the group for which you want to display aggregate 

functions.

■ Click the with no totals list button and set the field, type, and position of the 

function you want to set.

Set aggregate 

function totals from 

the Ribbon

■ Display the report in Design View and click the field control in the Detail section 

for which you want to set a function.

■ Choose Design→Grouping & Totals→Totals  on the Ribbon.

■ Choose the function you want to apply to the field.

DEVELOP YOUR SKILLS 8.4.2

QUICK REFERENCE

A Click the Control 
Source property. C Type ) at the end of the expression 

to close the parentheses.

B Type Sum(immediately after the = sign—be sure to include the 
open parentheses—and type the rest of the formula as shown.
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Creating Labels Using the Label Wizard 309

7. Add a label using the Label tool  to the Page Header section above the control text 

box, add the text Sales Totals to the label, and format the label using the Format Painter 

to appear as the other column headings.

8. Switch to Layout View and review the report , adjusting the width of any field that 

displays #####. Pound symbols in a field indicate that the field is not wide enough to 

display the value.

9. Save  changes to the report and close it.

Video Lesson labyrinthelab.com/videos

One common request people have of databases is the capability to print address labels using 

data contained in a database table. As a result, Access 2007 introduced a new wizard designed 

specifically for creating labels—it’s called the Label Wizard. The Label Wizard steps you 

through screens from which you can make choices to set up labels using the data from specific 

tables or queries. 

Setting Up the Labels
The procedures for using the Label Wizard are similar to those you have used to create other 

objects using wizards. The Label Wizard provides options for setting standard labels as well as 

for creating custom labels. The database object that is active when you start the wizard is the 

object Access assumes you want to use to create the labels. As a result, it is important to select 

or open the object before you start.

Adding Fields to the Labels
Adding fields to the labels is similar to adding fields to a Word document when you plan to use 

the document as a mail merge main document. As a result, it is necessary to add required 

spacing and punctuation to the label as you insert the fields. In addition, Access places curly 

braces { } around field names on the labels just as Word does.

8.5 Creating Labels Using the Label 
Wizard

A typical 
label design

Field names 
appear in braces.

Spacing and punctuation 
are added by the user.
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Create Labels Using the Label Wizard 8.5.1

In this exercise, you will create mailing labels for addressing envelopes for a mass mailing to all customers 
in the Green Clean Reports database.

1. Click the Customers table in the Navigation Pane to make it active.

2. Choose Create→Reports→Labels  on the Ribbon to launch the Label Wizard.

3. Follow these steps to set the label type and size:

4. Click Next and set the Font Size to 10.

CREATING LABELS

Task Procedure

Launch the Label 

wizard

■ Select the table containing the data you want to use for the labels.

■ Choose Create→Reports→Labels .

Work through 

wizard screens

■ Select the label type, format, and unit of measure you want to use for the labels 

and click Next.

■ Set the font, size, and color, and then click Next.

Add fields to a label ■ Double-click the field names in the Available Fields list in the order you want them 

to appear on the label.

■ Add spacing, punctuation, and hard returns as needed to position the 

fields properly.

■ Click Next.

■ Select the field on which you want to sort the labels and click Next.

■ Type a label report name and click Finish.

DEVELOP YOUR SKILLS 8.5.1

QUICK REFERENCE

A Choose 8463 from the 
Product number list.

B Choose the English 
Unit of Measure.

C Choose Sheet feed 
as the Label Type.
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Printing Reports 311

5. Click Next and follow these steps to set up the prototype label:

6. Click Finish to complete the labels; click OK if Access displays a message about label size.

Access saves the report using the default report name and displays the labels in Print Preview.

7. Close  the report.

Video Lesson labyrinthelab.com/videos

Reports in Access provide the main output source for disseminating 

information from the database. As a result, creating meaningful reports is 

important to the success of the database. After you create and format reports, set 

grouping and sorting levels, and add summary controls, you are ready to test the 

report by printing it. 

Procedures for printing reports are basically the same procedures you would use to print files 

in other programs, such as Word, Excel, and PowerPoint. As with each different program, print 

options in Access vary with different objects. For example, you can print individual pages, all 

pages, or a set range of pages. 

Setting Report Print Layout
Commands on the Page Setup tab of the Ribbon enable you to set up the basic page layout for 

a report. Using these commands, you can change the paper size and orientation, set margins 

and columns, and instruct Access to print the data only—leaving the design elements off.

Controlling Page Breaks
If you have used Word to create long documents, you know that controlling page breaks is 

important to prevent an individual line of a paragraph (often called a widow or orphan) from 

appearing on a page by itself. The same is true for printing reports. You want to adjust settings 

so that a group header section stays with at least the first record in the report and also to 

prevent an individual record or line of a report section from appearing alone. Access contains 

features that you can set to contain report sections and produce a better organized report.

8.6 Printing Reports

A Double-click the FirstName field to 
add it to the label and then press 
the [Spacebar] to add a space.

B Double-click the LastName field and 
then press [Enter] to move to a new line.

C Double-click additional fields in the Available Fields list to complete 
this label layout, adding spaces and punctuation you see here.

FROM THE KEYBOARD

[Ctrl]+[P] to open the 
Print dialog box

Page Layout tools on 
the Page Setup tab.
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Setting Page Breaks
Setting a page break on a report is different from setting a hard page break in a Word 

document or Excel worksheet. Because your report design contains controls for defining the 

report layout, it can be challenging to determine how many records will appear for each group, 

and the number of records shown in each group usually varies for each group heading. As a 

result, setting a page break is an uncertain way to try to control page printouts. 

Setting Group Controls
Instead of setting page breaks for printing reports, Access enables you to control how you want 

to keep groups together on report pages. Setting these controls prevents lone headers on report 

pages and enables you to keep each group on a single page. Setting these controls also reduces 

excessive page printouts.

Set Print Options 8.6.1

In this exercise, you will set up the report for printing and print the report.

1. Display the Sales Report in Design View and display the Group, Sort, and Total panel.

2. Follow these steps to set page controls:

PRINTING REPORTS

Task Procedure

Display Print 

Preview

■ Display Report View.

or

■ Choose File→Print→Print Preview.

Print specific pages ■ Choose File→Print→Print to display the Print dialog box.

■ Select the Pages option and enter the page numbers you want to print.

Print all report 

pages

■ Choose File→Print→Quick Print.

or

■ Choose File→Print→Print to display the Print dialog box.

■ Click OK.

or

■ Press (Ctrl)+(P) to display the Print dialog box.

■ Click OK.

DEVELOP YOUR SKILLS 8.6.1

QUICK REFERENCE

A Click More on the Group bar in the Group, Sort, and Total panel.

B Click the Do Not Keep Group 
Together On One Page list button.

C Choose Keep 
Header and First 
Record Together 
On One Page.
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3. Save  the report and display it in Print Preview, navigating to multiple pages. 

4. Choose Print Preview→Print→Print  on the Ribbon to print the report and then 

close it, close the database, and exit Access.

Concepts Review labyrinthelab.com/acc10

To check your knowledge of the key concepts introduced in this lesson, complete the Concepts Review quiz by 
going to the URL listed above. If your classroom is using Labyrinth eLab, you may complete the Concepts 
Review quiz from within your eLab course.

8.7 Concepts Review
Concepts Review 313
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Reinforce Your Skills

Create a Report in Design View
Lagniappe Cruises is preparing to publish a brochure that describes its cruises for next year. In preparation 
for this brochure, they would like to have a report that tallies the total cost of each room type based on 
occupancy. In this exercise, you will create the shell of the report and add fields to the report.

1. Open the rs-Lagniappe Cruises database from the Lesson 08 folder and save the file using 

the filename rs-Lagniappe Reports.

2. Choose Create→Reports→Report Design  on the Ribbon to create the report.

3. Choose Design→Tools→Add Existing Fields  on the Ribbon to open the Field List.

4. Expand (+) the Cruises table to display the field list for the table.

5. Drag the following fields to the report Detail section in the order listed: SailDate, 

Destination, Ship, InsideCabin, OutsideCabin, Verandah.

6. Right-click the SailDate label and choose Cut; then right-click the Page Header and 

choose Paste. 

7. Repeat the procedures outlined in step 6 to cut and paste the Destination and ShipName 

labels in the Page Header, dragging the labels to appropriate positions above the field text 

box control.

8. Drag additional fields into the following positions on the report:

9. Print a copy of the report design.

10. Save  the report using the report name Cruise Costs and leave it open.

REINFORCE YOUR SKILLS 8.1
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Add Group Levels, Time, and Date to the Report
Before formatting and enhancing the report you created, you need to better organize the report so that it 
shows data grouped by date and subgrouped by destination. In this exercise, you will add two group levels to 
the report and also add time and date controls.

1. Display your Cruise Costs report in Design View.

Set Grouping

2. Right-click the Destination control in the Detail section and choose Group On.

3. Right-click the Destination control in the Detail section again and choose Cut; then 

right-click the Destination Header section and choose Paste.

4. Repeat the procedures outlined in steps 2 and 3 to create another group using the Sail-

Date control in the Detail section.

Align Controls

5. Click the vertical ruler even with the first cabin controls and drag the mouse down to 

select all six cabin controls.

6. Choose Arrange→Sizing & Ordering→Size/Space→To Widest  to size the controls 

evenly.

7. Choose Arrange→Sizing & Ordering→Size/Space→Equal Vertical  to distribute 

the controls evenly.

8. Select the three cabin labels and choose Arrange→Sizing & Ordering→ Align→ 
Left.

9. Repeat the procedures outlined in step 8 to align the cabin text boxes on the left.

REINFORCE YOUR SKILLS 8.2
Fo
r E
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Add Date & Time Controls

10. Drag the Page Footer section bar up and position it just below the Verandah controls. 

11. Choose Design→Header/Footer→Date & Time  and set options to add the date and 

time to the report using a format you prefer.

12. Adjust the positions of additional controls to appear as follows and delete the Destination 

and SailDate control labels in the Page Header:

When you group on the Destination and SailDate fields, the labels for the controls no longer appear in 
the Page Header section of the report.

13. Switch to Layout View, review the report, and adjust the size of the destination control to 

display all text.

14. Save  changes to the report and print a copy of the report.

Format and Enhance the Report
You have now established the skeleton of the report. Adding a title and graphics as well as graphic elements 
to the report will enhance its appearance. In this exercise, you will add a title and logo to the report header 
section, format text controls, and format the report. 

1. Display the Cruise Costs report in Design View and drag the border of the Report Footer 

section down to make the section larger.

2. Select both the Date and Time controls that appear in the Report Header section.

3. Right-click the selected controls and choose Cut; then right-click the Report Footer 

section and choose Paste to move the controls to the footer.

REINFORCE YOUR SKILLS 8.3
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Add and Format a Logo

4. Choose Design→Header/Footer→Logo  and double-click the rs-Lagniappe Cruises 

Logo.gif file in the Lesson 08 folder to add the logo to the report.

5. Close the Field List panel and press [F4] to open the Property Sheet.

6. Click the Border Color property and choose White from the color palette.

Add and Format a Title

7. Choose Design→Header/Footer→Title  and then set the following properties:

8. Size the title control to display all text on one line and position the title appropriately.

9. Size the logo control appropriately.

Format Detail Section Controls

10. Select all label controls in the Detail section, apply the following properties, and drag the 

left border of the controls to size them appropriately:

11. Select the Cabin text box controls, set the following properties, and then drag the right 

border of the controls to size them appropriately:

Property Setting

Font Size 72

Fore Color Orange, Accent 6

Property Setting

Fore Color Orange, Accent 6

Font Size 14

Font Weight Bold

Property Setting

Fore Color Accent 6, Darker 25%

Font Size 14

Font Weight Extra Bold
Fo
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Format Group Controls

12. Select the Destination and SailDate controls in the group headers, apply formatting to 

the controls appropriately, and then size the controls appropriately.

13. Delete the Ship Name label in the Page Header section; then select the Ship control in the 

Detail section, set formatting properties of your choice, and size the control appropriately.

14. Display the report in Layout View and size the Destination group header so that the 

right edge appears close to the right margin border as shown.

15. Make additional adjustments as necessary to the report, save  changes to the report, 

and then print a copy of it.

Create Calculated Controls
The report you are building is shaping up nicely. Each cabin on the all ships is designed to hold two people. 
Connecting cabins are designed for families who take a cruise. To report the total cost of each cabin for each 
cruise, you need to add some calculated controls to the report. In this exercise, you will use the Expression 
Builder to add the calculated controls to the report.

1. Display the Cruise Costs report in Design View and press [F4] to open the Property Sheet.

2. Choose Design→Controls→Text Box  on the Ribbon and then click the Detail 
section beside the Inside Cabin text box.

3. In the Property Sheet, click the Data tab, choose the Control Source property and click 

the Build button to launch the Expression Builder.

4. Click the Cruise Costs report in the Expression Elements list and double-click the 

InsideCabin field from the Expression Categories list to add it to the Expression Builder; 

then type *2 to complete the expression and click OK.

REINFORCE YOUR SKILLS 8.4
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5. In the Property Sheet, click the Format tab and set the Format property to Currency.

6. Repeat the procedures outlined in steps 2–5 to create calculated controls for the Outside 

Cabin control and the Verandah control, substituting the appropriate field name in the 

expression and setting both to Currency format.

7. Delete the labels for each control you added.

Add a Label Control

8. Choose Design→Controls→Label  and place a label control containing the text 

Total Cost beside the Ship control in the Detail section.

Format the New Controls

9. Click the Ship control in the Detail section and choose Design→Font→Format Painter 

to pick up the format applied to the control and then click the Total Cost label to apply the 

format to the label.

10. Repeat step 9 to pick up the format of the cabin text boxes and apply it to the calculated 

controls.

11. Align controls appropriately and then save  changes to the report. 

Your report should appear similar to:
Fo
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Create Count Totals
The number of cruises to each destination is a value that is also required for this report. In this exercise, you 
will create a total count of cruises for each destination.

1. Display the Cruise Costs report in Design View and click the Destination control in the 

Destination Header section.

2. Choose Design→Grouping & Totals→Group & Sort  and click More on the Group 

on Destination bar.

3. Follow these steps to show a count of each destination in the footer section:

Access creates the count function in the Destination Footer section of the report.

4. Drag the Page Footer section bar down to make the Destination Footer section larger; 

then click the Count control and choose Format→Font→Align Text Right on the 

Ribbon.

5. Display the report in Report View and compare the listings for Australia/New Zealand on 

your report to the one shown here:

6. Save  the report, print a copy, and then close it.

REINFORCE YOUR SKILLS 8.5

A Click the With No Totals 
list button.

B Choose Destination 
from the Total On list.

C Check the Show Subtotal 
In Group Footer checkbox.

Total cruises to 
the first listed 
destination 
is 2.
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Create Labels
Mailing labels is only one type of label you can create using the Label Wizard. You can also create file folder 
labels and many other types. In this exercise, you will create a simple file folder label to use for creating 
labels for Lagniappe Cruise destinations.

1. Select the Cruises table and choose Create→Reports→Labels  to launch the Label 

Wizard.

2. Take the following actions on the Wizard screen indicated, clicking Next to advance to the 

next screen:

3. Print a copy of the report and then close the report, close the database, and exit Access.

REINFORCE YOUR SKILLS 8.6

Screen Action

1 Choose Label #8257

2 Choose Font Size 10

3 Move Destination to the Prototype Label

4 No changes

5 Type Destination File Labels as the report title.
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Apply Your Skills

Create a Report in Design View
Raritan Clinic East continues to work on their database. They have finalized forms and have moved on to 
creating reports. In this excercise, you will create a report using data from the Resources table.

1. Open the as-Raritan Clinic database in your Lesson 08 folder and save the database as a 

new file named as-Raritan Clinic Reports.

2. Create a new report in Design View that is based on the Resources table.

3. Drag controls for the following fields to the Detail section and place them side by side in 

the order shown: ResourceTypeID, ResourceFirstName, ResourceLastName.

4. Delete the label control for the ResourceTypeID field and move the labels for the name 

controls to the Page Header section.

5. Save  the report using the report name Resources and print a copy of the report. 

Leave the report open.

Group Data in the Report
Grouping the resources by type helps locate resources when substitutes are needed. In this exercise, you will 
create a grouping level for the report you started in Apply Your Skills 8.1 and add a date control to the 
Report Footer section.

1. Display the Resources report in Design View.

2. Choose the ResourceTypeID control in the Detail section and set it as the Group On 

field.

3. Move the ResourceTypeID control to the ResourceTypeID Header section of the 

report.

4. Add the Date control without the Time control to the report and move it to the Page 
Footer section.

5. Adjust the size of the Detail Section.

6. Save  changes to the report and leave it open.

APPLY YOUR SKILLS 8.1

APPLY YOUR SKILLS 8.2
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Format the Report
The plain report you have created so far is a nice basic structure of a report. Formatting the report so that 
text appears more vivid and sections are more appropriately sized to report the data will improve the 
appearance of the report. In this exercise, you will apply a Theme to the report, format report controls, and 
size the report sections. 

1. Display the Resources report in Design View and size the Detail section so that it is just 

tall enough to accommodate the controls.

2. Format the report by applying the Opulent Theme to the report.

3. Set control properties for the controls to improve their appearance.

4. Align the controls in the Detail section at the top.

5. Size the Detail and ResourceTypeID Header sections so that they are large enough for 

the controls they contain.

6. Switch to Layout View and adjust the sizes of the controls to display data appropriately 

on the report.

7. Save  changes to the report, print a copy, and then close the report.

Add a Logo and Title to the Report
The Raritan Clinic East report now contains the data and format you want to display. In this exercise, you 
will add a title and logo to the report.

1. Display the Resources report in Design View and make the Report Header section 

active.

2. Add the as-Raritan Clinic Logo.jpg graphic to the Report Header section of the report and 

position it on the right side of the section.

3. Add a title to the report and position it on the left side of the Report Header section. 

4. Type Resources by Type in the new title box and format the title by setting the font 

size to 40.

5. Size and position the logo and title appropriately.

6. Save  changes to the report and leave it open for the next exercise. 

APPLY YOUR SKILLS 8.3

APPLY YOUR SKILLS 8.4
Fo
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Add a Control and Edit the Control Source
The group header identifies the coded resource type ID. Unless those who view the report know what each 
type of resource represents, they will have no idea how many nurses, staff, etc., are listed. In this exercise, 
you will add a new control to the report and edit the control source property to select the appropriate table.

1. Display the Resources report in Design View and display the Field List panel.

2. Expand the field list for the Resource Types table and drag the ResourceType field to 

the ResourceTypeID Header section, positioning it beside the existing control in the 

section.

3. Copy the format from the ResourcesID control to the ResourceTypeID control in the 

group header section, align the controls appropriately, and delete unnecessary control 

labels.

4. Display the report in Layout View and size the controls in the group header section 

appropriately to display all data.

5. Save  the report and leave it open for the next exercise.

Add Totals to Count the Entries in Report Groups
The report for the clinic database is almost complete. In this exercise, you will add totals that count the 
number of records for each group.

1. Display the Resources report in Design View and display the Group, Sort, and Total 
panel.

2. Create a total that counts the resource records for each resource type and displays the 

total in the group footer section.

3. Display the report in Report View and compare your report to the one shown here:

4. Save  the report, print a copy, and then close the report, close the database, and 

exit Access.

APPLY YOUR SKILLS 8.5

APPLY YOUR SKILLS 8.6

Each group total 
appears before 
the next group 
heading.
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Critical Thinking & 
Work-Readiness Skills

In the course of working through the following Microsoft Office-based Critical 
Thinking exercises, you will also be utilizing various work-readiness skills, 
some of which are listed next to each exercise. Go to labyrinthelab.com/

workreadiness to learn more about the work-readiness skills.

8.1 Create a Report that Prints Labels 
Green Clean is preparing to set up files for all customers in the database. They 

would like you to prepare a report for the database that they can use to create file 

folder labels. Follow these guidelines to prepare the report: 

■ Use the ct-Green Clean Reports (Lesson 08 folder). 

■ Format the labels so they print file folder label format from the Green Clean 

Customers table. 

■ Sort the labels on the Last Name field. 

■ Print a copy of the labels on plain paper. 

8.2 Create, Format, and Total a Custom Report
Green Clean’s corporate offices have just contracted with First Perk, an onsite 

coffee shop, to provide beverage service. First Perk has its own database for 

which they want to add custom reports. The manager explains that they would 

like a report that groups orders by sales person, totals each order, and totals all 

orders for each sales person. 

Create a report that meets the manager’s criteria using a query as a record 

source. Format the report using appropriate design elements, and save the report 

with the title Sales Summary. The logo for First Perk can be found in the Lesson 08 folder. 

Print the report.

8.3 Use Teamwork to Design a Custom Report Layout
Green Clean’s management team, none of them database experts, challenges 

your team of consultants to produce reports from their database that provide 

“higher value” information, though they are not specific in their requests. 

Collaborate with your team to identify the types of reports you believe Green 

Clean could effectively add to the database. Then, design a report layout that can 

be applied to the reports and create at least two new reports for Green Clean. 

Add the reports to the Green Clean Reports database you have used throughout 

this lesson. Customize the reports using your collaborative creative imaginations.

WORK-READINESS 

SKILLS APPLIED

■ Applying technology 
to a task

■ Improving or 
designing systems

■ Thinking creatively

WORK-READINESS 

SKILLS APPLIED

■ Thinking creatively

■ Making decisions

■ Organizing and 
maintaining 
information

WORK-READINESS 

SKILLS APPLIED

■ Seeing things in the 
mind’s eye

■ Thinking creatively

■ Solving problems
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