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Oatabase reports summarize data 

contained in tables or displayed in 

query results datasheets and enable 

you to provide meaningful information in a 

layout that is suitable for printing. Although 

forms and reports serve two distinctly 

different purposes within the context of a 

relational database, the techniques used to 

customize reports and forms are very similar. 

By now, you have most likely created reports 

using both the Report Wizard and Design 

View and have customized elements of a 

report. In this lesson, you will import reports 

from other databases and use additional 

features to create custom reports.
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L E S S O N  O U T L I N E

10.1 Importing a Report into a Database

10.2 Adding a Subreport to a Main Report

10.3 Creating a Report from a Subreport

10.4 Numbering Items in a Report

10.5 Creating Calculated Controls on a 
Subreport

10.6 Setting Page Breaks and Customizing 
Controls

10.7 Analyzing Report Performance

10.8 Concepts Review

Reinforce Your Skills

Apply Your Skills

Critical Thinking & Work-Readiness Skills

L E A R N I N G  O B J E C T I V E S

After studying this lesson, you will be able to:

■ Import a report into a database

■ Add a subreport to a main report

■ Create a report from a subreport 

■ Number items in a report

■ Create calculated controls on a subreport

■ Set page breaks and customize controls

■ Analyze report performance
Student Resources labyrinthelab.com/acc10
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Billing Customers

iJams, the online music distribution company, is now working with 

customer orders and wants to devise an invoice report that it can include 

with customer orders. After reviewing invoices from several different 

companies, Brett Schneider, fulfillment manager, has sketched out a design 

for a sample iJams invoice. He is now ready for it to be added to the iJams 

test database so that he can print a sample copy and circulate it among other 

administrators in the company. The report he wants created appears similar 

to the one shown here.

Data from the subdatasheet appears in a 
subform on the customer invoice report.
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Video Lesson labyrinthelab.com/videos

Access offers a variety of ways to create new reports. By now, you have already created a simple 

report, made reports using the Reports Wizard, and modified the layout of reports using 

Design View. Another way to get commonly used reports into a database is to import them 

from another database. Reports such as invoices, sales summaries, and other commonly used 

business reports normally contain the same basic data—often arranged in the same basic 

layout. When you locate a report that contains the fields you need, you can import it into an 

existing database and edit it to create the report you need. Because most companies require 

some type of invoice to send with customer orders, locating an invoice report that you can 

import is relatively easy.

Identifying Report Record Sources
Reports that you import retain two connections to their original database: the source database 

table or query name, which appears in the Record Source property, and field names, which are 

contained in the source database tables and appear in report control text boxes. As a result, 

when you import a report from another database, you must break the ties with the source 

database and establish ties to the new database. You can accomplish this by:

■ Editing the Record Source property in the properties box to tie a table or query in the new 

database to the report. 

■ Comparing the field names referenced in report control text boxes to those in your database 

to determine which field names may need to be changed so that Access can locate data 

to display. 

■ Editing the field names in the report control text boxes to match those shown in the record 

source table or query, or renaming fields in the database table to match those shown in 

the report. 

Using SmartTags
Many times, when Access identifies a conflict between an available data or control source and 

the one identified in the Record Source control, you will see SmartTags onscreen attached to 

the fields affected. SmartTags appear as small triangles in the upper-left corner of affected 

controls. You can use the SmartTag to access the Control Source property or the Report Record 

Source property for the data Access should use for the report control.

10.1 Importing a Report into a Database

Small triangles identify the controls 
for which Access can find no data.

Selecting a control displays handles.

SmartTags enable 
you to change the 
source for the data 
if appropriate.
364 Lesson 10: Creating Complex Reports
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Import a Report and Edit the Record Source 10.1.1

In this exercise, you will import a basic report into a database, rename the report, edit the record source 
for the report, and view data from a table in your database using the imported report.

1. Launch Access, open the database named iJams Test in the Lesson 10 folder, and save 

the database as a new database named iJams Reports.

2. Choose External Data→Import→Access  on the Ribbon to open the Get External 

Data dialog box.

3. Click Browse, open the Lesson 10 folder, and double-click the Invoice database.

4. Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database option, and then click OK. 

Access opens the Import Objects dialog box and displays object names contained in the Invoice database.

5. Follow these steps to select the Report to import:

6. Close the Get External Data dialog box and open the Navigation Pane.

Rename the Report

7. Right-click the Invoice report name and choose Rename.

8. Type iJams Customer Invoice and press [Enter].

Access may present a message advising you that the table specified in the report does not exist in this 
database. You will fix that when you modify the Record Source property.

9. Right-click the iJams Customer Invoice report and choose Design View to open the 

report in Design View.

Change the Report Record Source

10. Follow these steps to change the Report Record Source property:

Access opens the Property Sheet dialog box.

DEVELOP YOUR SKILLS 10.1.1

A Display the Reports tab.

B Choose the Invoice report.

C Click OK.

A Choose the CustomerID control text box.

B Click the SmartTag 
list button.

C Choose Edit the 
Report’s Record 
Source Property.
Importing a Report into a Database 365
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11. Click the Record Source property box and choose iJams Customers from the list.

Access clears all conflicts in the reports.

12. Save  and close  the report.

Video Lesson labyrinthelab.com/videos

Subreports display subsets of data from related database tables in reports just as subforms do on 

forms. However, a subreport can display table data by naming a table, query, form, or another 

report as the source object. Because forms are frequently created before reports, when they 

already display table data from multiple tables, using the form to create the subreport 

streamlines report design and often displays data in a better format. 

Examining the iJams Database Objects
The invoice report you imported contains only the fields required to report customer 

information from the iJams Customers table. Invoices normally display the list of items 

ordered in addition to the customer data. You currently have three tables in the database that 

contain the data required for the complete invoice—the iJams Customers table, the 

iJams Inventory table, and the iJams Orders table. Fields from all three tables appear in the 

iJams Order Processing form—but the fields you want to add to the report appear only in the 

subform. Using the form, then, makes creating the subreport more efficient.

10.2 Adding a Subreport to a Main Report

This subform contains the 
data you want to include 
on the invoice report.
366 Lesson 10: Creating Complex Reports
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Identifying Procedures for Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add 

a subform to a form. You can create the report using the Report Wizard or add an unbound 

subreport control to the report. Then you identify the database object containing the fields you 

want to display as a subreport. 

Add a Subreport to a Report 10.2.1

In this exercise, you will add a subreport to the iJams Customer Invoice report and identify the iJams Order 
Subform form as the Source Object for the subreport.

1. Display the iJams Customer Invoice report in Design View.

2. Choose Design→Controls→Subform/Subreport  on the Ribbon and then click the 

Detail section just below the shipping information control label.

Access opens the Subreport Wizard.

3. Follow these steps to create the subreport control:

4. Click Next, click Next again to accept the default links, and then click Finish.

5. Press [F4] to display the Property Sheet and then click the Data tab.

6. In the Source Object property box, ensure that Form.iJams Order Subform (the top 

item in the list) is active. 

7. Click the subform label control for the subreport control and press [Delete] to remove it.

8. Display the report in Layout View and adjust the width of each column in the subreport.

9. Drag the right border of the subreport to the 6.5" mark on the horizontal ruler.

10. Choose Design→Views→View→Print Preview  on the Ribbon to switch 

to Print Preview.

11. Click the navigation buttons at the bottom of the window to display several pages 

of the report, noting pages of the report that contain data in the subreport.

12. Save  the changes and close  the report.

DEVELOP YOUR SKILLS 10.2.1

A Choose Use an Existing 
Report or Form.

B Click the iJams Order 
Subform.
Adding a Subreport to a Main Report 367
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Video Lesson labyrinthelab.com/videos

The subreport you added to the main report displays table data by using a form as the record 

source. Changes you make to the layout of the subreport are reflected in the form. To eliminate 

this problem, you can save the subreport as a separate report in the database, change the 

Record Source property to the new report object, and then edit the subreport. 

As you know, Access allows you to save an existing form as a new form, an existing report as a 

new report, and so forth. When the form is used as the record source for a subreport, you can 

display the subreport in a separate window and then save it as a separate report.

Create a New Report Using a Subreport 10.3.1

In this exercise, you will create and save a new report using the subreport in the iJams Customer Invoice 
report and edit the source object in the iJams Customer Invoice report to display the new report.

1. Display the iJams Customer Invoice report in Design View.

2. Right-click the subreport control text box and choose Subreport in New Window.

Access opens the subreport (the iJams Order Subform, in this case) in a separate tabbed window.

If you do not see the Subreport in New Window command on the shortcut menu, click an 
area of the main report and then right-click the subreport control again.

3. Choose File→Save Object As, and then follow these steps to save the form as a report:

4. Add a title containing the word Orders to the new report and then save  the report.

10.3 Creating a Report from a Subreport

SAVING A SUBREPORT AS A REPORT 

Task Procedure

Open a subreport in 

a separate window

■ Right-click the subreport on the report in Design View.

■ Choose Subreport in New Window from the shortcut menu.

Save the subreport 

as a new report

■ Open the subreport in a new window.

■ Choose File→Save Object As to open the Save As dialog box.

■ Type the name of the new report.

■ Select Report from the As list, and then click OK.

DEVELOP YOUR SKILLS 10.3.1

QUICK REFERENCE

TIP

A Type iJams Customer Order Subreport 
in the Save…To box.

B Click the As list button and choose Report.

C Click OK.
368 Lesson 10: Creating Complex Reports
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5. Close  the new report and then display the iJams Customer Invoice report in Design 
View again.

6. Display the Property Sheet and then display the Data tab.

7. Select the subreport control and change the Source Object property to Report.iJams 
Customer Order Subreport.

8. Switch to Print Preview and review the report.

9. Save  and close  the report.

Video Lesson labyrinthelab.com/videos

As the number of records contained in a table grows, the length and number of records 

displayed in a report or subreport also grows. You can number the records in a report to help 

track items listed. If a report is grouped, you can set the count to restart numbering at the 

beginning of each group. These numbers serve as an easy reference when you are discussing a 

report over the telephone or identifying an item in an invoice that you are returning.

Setting Properties to Number Items
By setting the Control Source property for a control, you can add numbering automatically to 

items in a report. In addition, you can set the Running Sum property to identify the portion of 

a report for which you want to count items. For example, suppose you have a products report 

that groups products by category. You can set the Running Sum property to count the items in 

each group and then start counting again with the next group. 

Numbering Subreports Separately
A significant limitation to setting a numbering control is that Access does not permit 

numbering items in a subreport control on a main report. Because you saved the subreport as a 

separate report, however, you can add the numbering controls directly to the subreport by 

displaying it in a separate window. Edits you make to the subreport when it is open as a 

separate item are reflected in the main report the next time you open it.

10.4 Numbering Items in a Report

Items are numbered sequentially 
throughout the report.
Numbering Items in a Report 369
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Number Items in a Report and Subreport 10.4.1

In this exercise, you will edit the iJams Customer Order Subreport by repositioning controls in the Page 
Header section and then add an unbound control to the report to count the number of items ordered. 

1. Display the iJams Customer Order Subreport in Design View.

2. Follow these steps to remove anchor formatting from the Detail Section:

3. Right-click the Detail section bar and select Page Header/Footer to display the Page 

Header section of the report.

4. Follow these steps to reposition controls on the subreport:

REMOVING CONTROL TIES AND NUMBERING REPORT ITEMS 

Task Procedure

Remove control ties ■ Choose Arrange→Table→Remove Layout  on the Ribbon.

Add a control to 

number report items

■ Display the report or subreport in Design View.

■ Choose Design→Controls→Text Box  on the Ribbon.

■ Click the position on the report or subreport to place the control.

■ Display the Property Sheet Data tab.

■ Set the Control Source property to = 1.

■ Set the Running Sum property to Over All.

DEVELOP YOUR SKILLS 10.4.1

QUICK REFERENCE

A Click the table selection 
button to select 
connected controls.

B Choose Arrange Table→
Remove Layout on the Ribbon.

AMove the control labels to the Page Header section, size 
them appropriately, and align them at the top as shown.

BMove control text boxes in 
the Detail section, size them 
appropriately, and align 
them at the top as shown.

C Drag the Page Footer 
section bar up to reduce the 
size of the Detail section.
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5. Choose Design→Controls→Text Box  on the Ribbon and then follow these steps to 

place the control in the Detail section of the report:

Set Control Properties to Sum

6. Display the Properties Sheet panel for the new unbound control.

7. Follow these steps to set the data properties for the control:

8. Switch to Report View and review the report.

Access displays the number in the new control and counts 35 records in the report.

9. Save  and close  the report.

10. Open the iJams Customer Invoice report, display page 14 of the report, and compare 

your report to the one shown in the following illustration.

11. Close the report.

A Click to the left of the OrderID text box. Notice that the label appears 
behind the text box control.

C Size the control as shown here.

B Click the control label and delete it.

A Display the 
Data tab.

B Enter =1 in the 
Control Source property.

C Set the Running Sum 
property to Over All.
Numbering Items in a Report 371
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Video Lesson labyrinthelab.com/videos

Reports summarize data contained in tables and queries to create valuable information. 

Calculated fields and controls that appear in queries, on forms, and on reports perform 

calculations using values from fields contained in tables or displayed on query results 

datasheets. Adding a calculated field to a report that totals or averages data for a group or 

subreport often provides valuable information to report reviewers. 

Positioning Calculated Controls
Calculated controls are constructed on reports using an unbound control to which you add the 

formula for the calculation. The position of the calculated control determines how Access 

performs the calculation. 

■ When you have a grouped report, add a calculated control to the group footer to sum values 

for the group and each subordinate subgroup. 

■ Place a calculated control in a page footer to calculate items on each page.

■ Place a calculated control in a report footer to calculate a total for the entire report.

10.5 Creating Calculated Controls on a 
Subreport

Sample of calculated 
controls in all three sections

Calculated control in a Detail section.

Calculated control in a page footer 
calculates the total for the page.

Calculated control in a report footer 
calculates totals for the entire report.
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Create Calculated Controls 10.5.1

In this exercise, you will add three calculated controls to the Report Footer section of the iJams Customer 
Order Subreport.

1. Display the iJams Customer Order Subreport in Design View and display the Property 
Sheet All tab.

2. Follow these steps to create a calculated field in the Detail section:

3. Drag the bottom border of the Report Footer section down to about the 1" mark on the 

vertical ruler to enlarge the Report Footer section.

4. Choose Design→Controls→Text Box  on the Ribbon and click the Report Footer 

section at about the 5" mark on the horizontal ruler.

5. Display the Property Sheet and click the Data tab.

6. Click the Control Source property and type the following formula into the property box: 

=.07*(Sum([Sales Price]*[Quantity])).

This formula tells Access to add (Sum) all the individual item prices and then multiply the total by 
7 percent—the sales tax rate.

7. Display the Property Sheet Format tab and choose Currency as the format.

8. Click the new control label and type Tax: in the Caption property box.

9. Switch to Report View and scroll to the bottom of the report to display the total.

Access shows the total value of tax is $705.12.

10. Repeat the procedures outlined in steps 4–9 to:

■ Create another new text box control below the Tax control.

■ Type the following formula in the Control Source property box:

=1.07*(Sum([Sales Price]*[Quantity]))

This formula tells Access that the total amount of the order is 107 percent (100 percent plus the 
7 percent tax) of the total price of all items ordered.

■ Format the control as Currency.

■ Type the following control label in the Caption property box: Order Total.

DEVELOP YOUR SKILLS 10.5.1

A Choose 
Design→
Controls→
Text Box on the 
Ribbon, and 
then click the 
Detail section 
at about the 5" 
mark on the 
horizontal 
ruler.

B Cut the label and position it in the Page Header 
section, changing the text to read Total.

C Type 
=[SalesPrice]*[Quantity] in 

D Select Currency from 
the Format list.
Creating Calculated Controls on a Subreport 373
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374 Lesson 10: Creating Complex Reports

11. Preview the last page of the report and compare the last few lines of your report to the 

one shown in the following illustration.

12. Close  the subreport, saving changes when prompted.

Growing a Subreport
Video Lesson labyrinthelab.com/videos

When the number of records or amount of data displayed in a subreport varies, as it does for 

customer invoices, you can set the Can Grow property setting to allow the space allotted to the 

subreport on a main report to expand so that more data appears vertically in the subreport. 

You can also change the orientation of the print layout to allow more horizontal space on each 

report page. 

SETTING MARGINS, ORIENTATION, CAN GROW, AND CAN 

SHRINK PROPERTIES 

Task Procedure

Set report 

margins

■ From Design or Layout View, choose Page Layout→Page Size→Margins on the 

Ribbon.

■ Choose the margin form to apply.

or 

■ From Print Preview, choose Print Preview→Page Size→Margins on the Ribbon.

■ Choose the margin form to apply.

Set orientation ■ From Design or Layout View, choose Page Layout→Page Layout on the Ribbon.

■ Choose the Portrait or Landscape orientation to apply.

or 

■ From Print Preview, choose Print Preview→Page Layout on the Ribbon.

■ Choose the Portrait or Landscape orientation to apply.

Set Can Grow 

property

■ Display the Property Sheet and click the Format tab.

■ Click the subreport control.

■ Set the Can Grow property to Yes.

Set Can Shrink 

property

■ Display the Property Sheet and click the Format tab.

■ Click the subreport control.

■ Set the Can Shrink property to Yes.

QUICK REFERENCE
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Set the Can Grow Property and Report Layout 10.5.2

In this exercise, you will adjust the layout and margins of the main iJams Customer Invoice report and set 
the Can Grow property.

Before You Begin: Your iJams Reports database should be open.

1. Open the iJams Customer Invoice report in Design View and display page 4.

2. Change the following settings:

■ Choose Page Setup→Page Layout→Landscape  on the Ribbon.

■ Choose Page Setup→Page Size→Margins  on the Ribbon and choose Narrow.

3. Save  changes to the report.

4. Display the Property Sheet and then display the Format tab.

5. Click the subreport control and set the following properties:

■ Set the Can Grow property to Yes if it is set differently.

■ Set the Can Shrink property to Yes.

6. Adjust the horizontal width of the subreport control to display all data.

7. Save  changes and display page 4 of the report in Print Preview.

Notice the enlarged subreport area in the following illustration. Now the tax and total 
calculations appear.

DEVELOP YOUR SKILLS 10.5.2
Creating Calculated Controls on a Subreport 375
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Video Lesson labyrinthelab.com/videos

As you reviewed pages of the iJams Customer Invoice report in Report View, you most likely 

noticed that the number of records displayed on each page varied, depending on whether or 

not data appeared in the subreport as well as on the number of items the customer ordered. By 

default, when you view the report in Print Preview, data for each customer/record automati-

cally appears on a separate page even though multiple records appear when the report is 

displayed in Report View. 

When you import a report from another source, you frequently need to customize the report so 

that it meets the needs of the new database. Many businesses customize reports to display a 

company name and logo, for instance. Depending on the information you are reporting, it may 

also be necessary to adjust the page layout or change the margins or orientation, as you did in 

the last exercise, so that the report fits more attractively on a page. It is also sometimes wise to 

add a page break control to ensure that the invoice for each customer starts on a new page.

Positioning the Page Break Control
When each page of a report such as an invoice is to be sent to different people, it is also 

important that each invoice in the report prints on a separate sheet of paper. You can set page 

breaks to ensure that each customer invoice prints on a separate page. It is important to 

position the page break at the end of the detail section so that Access knows to start a new 

page before printing the next page header.

10.6 Setting Page Breaks and 
Customizing Controls

ADDING PAGE BREAK CONTROLS

Task Procedure

Add a page 

break control

■ Choose Design→Controls→Insert Page Break  on the Ribbon.

■ Drag the Page Footer section bar down to provide space at the bottom of 

the Detail section.

■ Click the Detail section at the position on the Detail section where you want 

the page to break.

QUICK REFERENCE
Fo
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376 Lesson 10: Creating Complex Reports

Labyrinth Learning  http://www.lablearning.com



Microsoft Access 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
or
 E

va
lu

at
io

n 
O
nl

y
Add Logo, Title, Date, and Page Break Controls 
to a Report 10.6.1

In this exercise, you will “clean up” the iJams Customer Invoice report by customizing the imported report. 
You will edit control text to add iJams to the title, insert a picture of a logo, and set page breaks to print each 
invoice on a separate page.

Before You Begin: Your iJams Reports database should be open.

1. Display the iJams Customer Invoice report in Design View.

2. Click the Customer Invoice title control in the Page Header section, and then follow 

these steps to edit the Title:

Add a Logo to the Page Header

3. Choose Design→Header/Footer→Logo  on the Ribbon and double-click the 

iJams.bmp file in the Lesson 10 folder. 

Access adds the logo to the Report Header section. You want the logo to appear on each report page, 
so you need to move it.

4. Drag the logo to the Page Header section and position it on the left side of the title.

5. Size the control to enlarge it and then set the Size Mode property for the control to 

Stretch.

Add a Date Control to the Report
Now you will remove the existing Order Date field control and replace it with a Date control.

6. Delete the Order Date label control from the Detail section.

7. Choose Design→Header/Footer→Date & Time  on the Ribbon to add just the Date 

(not the time) to the Report Header section.

8. Cut the control from the Report Header section and paste it into the Detail section, 

positioning it at the right side of the report even with the Customer ID control. 

DEVELOP YOUR SKILLS 10.6.1

A Click the selected control again to position 
the insertion point before the existing text.

B Type iJams to appear 
before Customer Invoice.

C Adjust the size of the 
title control so that the 
text appears on one line, 
if necessary.
F
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Add a Page Break Control

9. Follow these steps to position the page break:

10. Preview the report and navigate to additional report pages.

For this report, the page break causes an extra page to appear for each record. As a result, you should 
delete the page break control.

11. Display Design View, select the Page Break control, and press [Delete] to remove it.

12. Save  and close  the report.

Video Lesson labyrinthelab.com/videos

Access tracks each database object and identifies how tables, queries, forms, and reports are 

related. In addition, Access tracks how you use each object within the database. The changes 

you have made to the database by importing a report, editing the report structure, creating a 

subreport based on a form, saving the form as a report, and then changing the record source 

for the subreport are a bit more complex than creating a simple report and adding a subreport 

that is based on another table or query. You have also made other changes since you last 

checked the performance of the database. 

What the Performance Analyzer Analyzes
To ensure that all objects in a database work together in an efficient manner, you can run the 

Performance Analyzer. The Performance Analyzer:

■ Analyzes database performance by reviewing each database object, identifying potential 

errors, and recommending modifications to objects and fields within each object to 

maintain optimum efficiency in the database 

■ Compares relationships between database tables and identifies data redundancy 

10.7 Analyzing Report Performance

A Drag the Page 
Footer section bar 
down to provide 
space at the bottom 
of the Detail section.

B Choose Design→
Controls→
Insert Page Break 
on the Ribbon.

C Click the Detail 
section just 
below the 
subreport control.
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■ Identifies items such as mismatched field definitions and displays a list of these instances 

so that you can consider editing object definitions 

■ Locates errors that could result in inaccurate data analysis and any disconnects between 

forms/subforms and reports/subreports 

■ Identifies fields and property settings that can slow down the running of filters and queries 

as well as the generation of reports 

You can use the Performance Analyzer to analyze all objects in a database or selected objects. You 

can even change settings to instruct the analyzer to make the necessary corrections for you. 

Analyze Report Performance 10.7.1

In this exercise, you will run the Performance Analyzer on the iJams Customer Invoice report and review 
suggested performance analysis.

Before You Begin: Your iJams Reports database should be open.

1. Click (but do not open) the iJams Customer Invoice report in the Navigation Pane.

2. Choose Database Tools→Analyze→Analyze Performance  on the Ribbon to start 

the Performance Analyzer.

Because you selected the report before starting the performance analyzer, Access displays the active object 
page in the Performance Analyzer window.

DEVELOP YOUR SKILLS 10.7.1

A sample Performance 
Analyzer report
Fo
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3. Click Select All to select all reports, and then click OK.

Access analyzes the reports in the database and presents the following report.

4. Close the dialog box, close the database, and exit Access.

Concepts Review labyrinthelab.com/acc10

To check your knowledge of the key concepts introduced in this lesson, complete the Concepts Review quiz by 
going to the URL listed above. If your classroom is using Labyrinth eLab, you may complete the Concepts 
Review quiz from within your eLab course.

10.8 Concepts Review

All these ideas affect fields containing numbers that will not be used 
in calculations. Therefore, it’s OK for them to be text data types.
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Reinforce Your Skills

Import a Report and Edit a Record 
Source
The state licensing bureau is continuing its work to develop a database that they plan to implement and 
then market to states so that each state can maintain accurate records for licensed drivers. One of the 
database developers identified a report layout from a database submitted as an example by the state of 
Louisiana. The report is similar to the one they want to include in their database. In this exercise, you will 
import the report and then customize it to meet the needs of the national database.

1. Launch Access, open the rs-Oklahoma Drivers database from the Lesson 10 folder, and 

create a new database named rs-Driver Reports.

2. Choose External Data→Import & Link→Access  on the Ribbon to open the Get 

External Data dialog box.

3. Click the Browse button, locate, and double-click the rs-Sample Driver Report database 

in the Lesson 10 folder. 

4. Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules Into the 
Current Database option and click OK.

5. Click the Reports tab, click the Sample Drivers Report report, and then click OK to 

import the report.

6. Close the Get External Data dialog box and display the new report in Design View.

Edit the Record Source
Notice the triangles in the upper-left corner of each control in the Detail section that identify errors finding 
the data. You need to change the record source to correct this.

7. Press [F4] to open the Property Sheet and click the Data tab.

8. Click the Record Source property and select Oklahoma Drivers from the Record Source 

list.

9. Switch to Report View and review the report data. 

10. Save  and close  the report.

REINFORCE YOUR SKILLS 10.1
Fo
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Add Fields to a Report and Arrange Report Controls
The sample drivers report is designed to list some driver data in a tabular layout. To prepare the layout of the 
report to accommodate the subreport, you need to rearrange the controls on the report. In this exercise, you 
will add fields to a report, change the layout of the report, and arrange controls. Feel free to use your own 
report design.

Before You Begin: Your rs-Driver Reports database should be open.

1. Display the Sample Drivers Report in Design View.

2. Drag the top of the Page Footer section bar down to expand the Detail section. 

Arrange Controls

3. Drag controls in the Detail section to appear as shown in the following illustration.

4. Follow these steps to select multiple controls and change the font color:

5. Click a blank area of the report to deselect all controls.

6. Drag each of the following control labels from the Page Header section to the Detail 

section, positioning them beside the corresponding control text box: Gender, Donor, Class, 

Name, and Street.

7. Repeat the procedures outlined in step 4 to select all remaining controls in the Page 

Header section and then press [Delete] to remove them.

REINFORCE YOUR SKILLS 10.2

A Click in the vertical ruler 
even with the controls in 
the Page Header section. B Choose Home→Font→

Font Color menu on 
the Ribbon and 
choose Automatic.
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Format and Edit Controls

8. Select the State text box control in the Detail section and then format the control using 

these guidelines:

■ Set the font size to 48.

■ Size the State control to show Sta in the control box.

■ Change to a font other than Georgia.

■ Set the font color to a shade of maroon.

9. Change the name of the Street label to Address.

10. Choose Design→Tools→Add Existing Fields  on the Ribbon to open the Field List.

Add Controls

11. Drag the following fields from the field list and position them along the bottom of the 

Detail section: Height, Weight, HairColor, EyeColor.

Arrange and Edit the Title

12. Drag the Test Drivers control from the Report Header section to the Page Header section 

and then double-click the word Test and type Oklahoma.

13. Save  changes to the report and then display the report in Report View to preview it.

14. Print a copy of one report page and then close  the report.

Add a Subreport to a Report 
Insurance information on file for each driver is an important part of a driver’s record and should be 
included for each driver in the report. In this exercise, you will add the insurance data to the Sample Drivers 
Reports report.

Before You Begin: Your rs-Driver Reports database should be open.

1. Display the Sample Drivers Reports report in Design View.

2. Drag the Page Footer section bar down to make room for the subreport control.

3. Choose Design→Controls→Subform/Subreport  on the Ribbon and click the 

Detail section of the report just below the Height control label.

4. Choose Cancel to close the wizard and then press [F4] to open the Property Sheet.

5. Click the Source Object property and choose Form.Insurance from the source object 

list.

6. Drag the right side of the report to about the 9" mark on the horizontal ruler.

7. Display Layout View and choose Page Setup→Page Layout→Landscape to change 

the layout of the report.

8. Adjust the size of the subreport control to display all columns and delete the subreport 
control label.

9. Save  changes to the report, print a copy of page 1, and then close the report.

REINFORCE YOUR SKILLS 10.3
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Save a Subreport as a New Report 
and Adjust Margins
The subreport you added to the report using a form can be saved as a stand-alone report so that changes 
made to the form cause no problems with the report. In this exercise, you will save the subreport as a 
separate report and adjust the margins so that the control fits on the report page.

Before You Begin: Your rs-Driver Reports database should be open.

1. Display the Sample Drivers Report in Design View.

2. Right-click the subreport control and select Subreport in New Window on the 

shortcut menu.

3. Choose File→Save Object As to open the Save As dialog box.

4. Type Insurance Proof Subreport in the Save Form To box.

5. Choose Report from the As drop-down list and click OK.

6. Close  all objects and then display the Sample Drivers report in Design View.

7. Display the Property Sheet.

8. Click the Source Object property and choose Report.Insurance Proof Subreport from 

the property list.

9. Close the Property Sheet and then size the subreport control to fit the size of the subre-

port page displayed.

10. Drag the right page edge of the report back to the 9" mark on the horizontal ruler.

11. Choose Page Setup→Page Size→Margins  on the Ribbon and then choose Narrow.

12. Save  changes to the report, preview it and compare your report to the one shown, 

and then close the report.

REINFORCE YOUR SKILLS 10.4
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Edit a Subreport and Number Records
The field arrangement on the subreport displays multiple records that are difficult to discern. In addition, 
some drivers have multiple cars for which they have registered insurance. It would be helpful to number 
the insurance listings. In this exercise, you will modify the subreport and add a number control to the 
subreport.

Before You Begin: Your rs-Driver Reports database should be open.

1. Display the Insurance Proof Subreport in Design View.

2. Choose Design→Controls→Text Box  on the Ribbon and click the report Detail 
section just below the Agent Last Name label.

3. Delete the new Unbound control label and press [F4] to display the Property Sheet.

4. Format the new control by sizing it similarly to the State field on the main form.

The State field on the main form was formatted using 48 point font size, maroon font color, and a font 
type other than Georgia.

5. Type =1 in the Control Source property and set the Running Sum property to Over All.

6. Close the Property Sheet and adjust the size and position of controls on the subreport to 

display all values and label text.

7. Save  changes to the subreport, and then preview it.

8. Close  the subreport and open the Sample Drivers Report. 

9. Review pages of the report, and then switch back to Design View to make necessary 

adjustments to control and report size.

10. Save  changes to the report and print a copy of page 7.

11. Close  the report.

REINFORCE YOUR SKILLS 10.5
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Insert Page Breaks and Analyze Reports
You have added a variety of different objects to the sb-Driver Reports database. Before continuing with 
additional projects, it would be a good idea to analyze the performance of database objects. In this exercise, 
you will insert page breaks in the report design and then analyze the performance of reports in the database.

Before You Begin: Your rs-Driver Reports database should be open.

1. Display the Sample Drivers Reports report in Design View.

2. Choose Design→Controls→Insert Page Break  on the Ribbon and click the Detail 
section of the report just below the subreport control on the left side of the report.

3. Switch to Print Preview  and navigate each report page.

4. Save  and close  the report.

5. Select the Sample Drivers Report in the Reports list, but do not open it.

6. Choose Database Tools→Analyze→Analyze Performance  on the Ribbon to open 

the Performance Analyzer dialog box.

7. Check both the Sample Drivers Report and Insurance Proof Subreport checkboxes in 

the Reports list.

8. Click OK. 

Access displays a list of three ideas—all related to changing the Text data types for fields containing 
numeric data to Number data types.

9. Close the dialog box and choose Database Tools→Analyze→Analyze 
Performance on the Ribbon to open the Performance Analyzer dialog box again.

10. Click the All Object Types tab, click the Select All button to select all objects, and then 

click OK to run the Analyzer.

11. Review ideas presented, close the dialog box, and close the database.

REINFORCE YOUR SKILLS 10.6
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Apply Your Skills

Create a Report from a Form
The Homestead Properties database currently has three tables—one showing current listings, one showing 
property details for listings, and one showing sold properties. When clients who want to buy properties 
come into the office, office personnel want to be able to print a report that shows not only the property 
data—location, cost, and so forth—but would also like to show data from the property details table. Because 
the main part of the report you want to build exists in a form, you can use the form to create the report. In 
this exercise, you will create the main report using an existing form. 

1. Open the as-Homestead Properties database contained in the Lesson 10 folder and save it 

as a new file named as-Homestead Reports.

2. Open the Properties form and review the form details.

3. Save the form as a report named Active Listings. Open the report.

4. Display the report in Print Preview and navigate pages of the report.

5. Save  the report, print a copy of page 1, and then close  the report. 

Add a Subreport and Page Break to a Report
The Active Listings report contained in the as-Homestead Reports database shows the basic information 
required for each property. It does not, however, show the details about the home that appear in the Property 
Details table. In this exercise, you will add the details data as a subreport on the main report and add a sort 
order so that records display by listing number.

Before You Begin: Your as-Homestead Reports database should be open.

1. Display the Active Listings report in Design View.

2. Add a subreport to the Detail section of the report, placing it just below the existing 

report data.

3. Set the Source Object property to show the Property Details table data and delete the 

control label.

4. Choose Design→Grouping & Totals→Group & Sort  to open the Group, Sort, and 

Total panel.

5. Click the Add a Sort button in the Group, Sort, and Total panel and select Listing# as the 

field to sort on.

6. Switch to Layout View and size columns in the subreport to fit the data contained in 

the columns.

7. Size the subreport control to display all seven columns and save  changes to the 

report.

APPLY YOUR SKILLS 10.1

APPLY YOUR SKILLS 10.2
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8. Preview the report, switch back to Design View, and make any necessary adjustments to 

the size and position of the subreport control.

9. Add a page break below the subreport. 

10. Display the Page Header/Footer for the report and move the title from the Report Header 

section to the Page Header section.

11. Hide the Report Header section and save  changes to the report.

12. Print a copy of one page of the report and then close  it.

Create a Simple Report and Number Items
Homestead Properties likes to maintain a running count of sold properties that they print and distribute to 
all realtors each week. They would like to create a report that they can use to generate the report each week. 
In this exercise, you will create a new simple report and add a numbering control to the report.

Before You Begin: Your as-Homestead Reports database should be open.

1. Create a new Simple Report based on the Sold Properties table and review the report.

2. Save the report as Sold Homestead Properties.

3. Display the new report in Design View and remove automatic layout ties from all controls 

in each report section.

4. Change the margins to Narrow and adjust the position and size of the controls to fit the 

data and label text using Layout View.

5. Delete the Sold controls, format the Price control text box to show currency, and add an 

appropriate title to the report.

6. Increase the size of the Page Header section and move the title to the Page Header 

section.

7. Hide the Report Header/Footer sections. Choose Yes if warned that hiding the sections 

will remove controls from the sections.

8. Add an unbound control to the Detail section of the report, delete the control label, and 

set the control properties to number items over the complete report.

9. Set the orientation of the report to Landscape and drag the right edge of the report page 

to about the 10" mark on the horizontal ruler.

10. Save  the report as Sold Homestead Properties, preview the report, and print a 

copy of the last page of the report.

11. Close  the report. 

APPLY YOUR SKILLS 10.3
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Create a Calculated Control and Analyze 
the Database
As realtors review the Sold Properties report, they would like to know the total value of real estate sold. Each 
property listed by the company nets 3 percent of the sales price. Because all properties on the sold list were 
listed by agents from Homestead Properties, they would also like to see the value of their portion of the sales 
price. In this exercise, you will create calculated controls to show the commission earned by the company for 
each property and a total amount earned for all sold properties. You will also analyze the database.

Before You Begin: Your as-Homestead Reports database should be open.

1. Display the Sold Homestead Properties report in Design View.

2. Create a new unbound control and position it at the right side of the Detail section 

of the report.

3. Set the formula in the Control Source property: =.03*[Price].

4. Add a label containing the text Listing Profits to the Page Header section for the new 

calculated control. 

5. Display the Report Footer section and create an unbound control in the Report Footer 

section below the Price column, label the control Total Sales, and add the formula 

=Sum([Price]).

6. Format both controls to display the values as currency.

7. Use the Format Painter to copy the format from one standard column heading to the 

labels of both new controls, if necessary to make them uniform in appearance.

8. Preview the report and print a copy of the last report page.

9. Save  changes to the report and run the Performance Analyzer to analyze all 

database reports.

10. Close  the report, and then close the database.

APPLY YOUR SKILLS 10.4
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Critical Thinking & 
Work-Readiness Skills

In the course of working through the following Microsoft Office-based Critical 
Thinking exercises, you will also be utilizing various work-readiness skills, 
some of which are listed next to each exercise. Go to labyrinthelab.com/

workreadiness to learn more about the work-readiness skills.

10.1 Create, Format, and Enhance a Report
Foxy’s gym, the exercise facility for iJams personnel, has contracted you to create a report to 

distribute with employee paychecks that shows employee data and hours worked. A sample of 

the report administrators want was located in the ct-Easy Up Sports database (Lesson 10 

folder) that Foxy’s recently acquired. Your task is to import that report and use it to create the 

new report. Use the ct-Foxy’s database (Lesson 10 folder) to create a new database named 

ct-Foxy’s Reports. Import the ct-Easy Up Sports database Personnel report to create the 

new report named Foxy’s Paystub. Formulas required for calculated fields appear in a 

tabbed page on the report you import and can be removed from the report after you add the 

fields to the new report. Save and print a copy of page 5 of the report.

10.2 Add a Logo and Analyze Reports
Foxy’s gym wants to add the logo to each database object so people begin to associate exercise 

and health with Foxy’s. Add the Foxy’s Logo (Lesson 10 folder) to the Foxy’s Paystub report 

you created in the previous exercise. When both reports are complete, run an analysis on the 

reports to determine ways to optimize performance. 

How many suggestions does Access make? Why? How many critical errors does Access find? 

How can you correct them? Record your answers in a Word document named ct-Questions 

saved to your Lesson 10 folder.

10.3 Train On Reports
Though this class, with its textbook and associated materials, may be the best way initially 

to learn Access skills for most learners, the Microsoft website is a great source for learning 

as well. 

Explore the available online training sessions for reports. Review at least two sessions to learn 

more about grouped reports and report summarization. Identify at least two report features 

that you want to learn more about. Experiment with the two features using the ct-Foxy’s 

Reports database you created in Critical Thinking 10.1.

Create a Word document named ct-Online Learning in your Lesson 10 folder that 

identifies the features that you have learned more about and how or why these features are 

important to you. Print the report. 

WORK-READINESS 

SKILLS APPLIED

■ Solving problems

■ Serving clients/
customers

■ Improving or 
designing systems

WORK-READINESS 

SKILLS APPLIED

■ Acquiring and 
evaluating 
information

■ Interpreting and 
communication 
information

■ Solving problems

WORK-READINESS 

SKILLS APPLIED

■ Knowing how to 
learn

■ Acquiring and 
evaluating 
information

■ Reading
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