
Whether you are creating a new 
database to organize a soccer team 
or run a small business, it is 

essential to begin with careful planning. 
Successful projects often begin by examining 
existing business procedures and compiling a 
list of tasks to accomplish, designing an 
outline of how to accomplish those tasks, and 
making preparations to develop the final 
product. In short—analyze, design, and 
develop.

In this lesson, you will plan and design a 
database. You will gather information as 
needed to make a complete list of the required 
tables, records, and fields. You will define the 
data type for each field and assign ID fields so 
you can create relationships to link your 
tables. You will create several tables and enter 
records. Then, you will apply record sorts and 
filters.

L E S S O N  O U T L I N E
Designing a Relational Database
Normalizing Databases
Linking Tables with Primary and Foreign Keys
Creating Access Tables in a New Database
Retrieving Data
Concepts Review
Reinforce Your Skills

Apply Your Skills

Extend Your Skills

Transfer Your Skills

L E A R N I N G  O B J E C T I V E S
After studying this lesson, you will be able to:

■■ Plan, design, and create a relational database 
and associated tables

■■ Define and implement database normalization

■■ Define data relationships and primary and 
foreign keys

■■ Define and create an Entity Relationship 
Diagram

■■ Sort and filter records

2Designing a Database and 
Creating Tables

A C C E S S  2 0 1 3
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C A S E  S T U D Y

Creating a Database
Winchester Web Design is a small website development company. The 
company specializes in websites for small businesses. The main deliverables 
are homepages (site navigation, overall website design, and cascading styles), 
secondary pages, blogs, and small business shopping carts.

Website designers must analyze a client’s needs and desires before creating a 
website that includes the site homepage layout, navigation structure, and site 
styles. Once the homepage layout is determined, secondary pages can be 
developed. You have been asked to build a database for Winchester Web Design. As you begin your work, 
notice how the web design and development process has many similarities to designing a useful and 
efficient database: analyze, design, and develop.

The Winchester Web Design database will contain tables from which forms, reports, and queries will be created.
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Designing a Relational Database
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0201

Early database programs stored data in one large, flat file similar to a spreadsheet. If a company 
sold merchandise and the same product was sold many times, these databases required a person 
to enter and store the same product description and product price for each transaction. Such 
repetitive data entry is time consuming and requires voluminous storage space.

Flat files also increase the chance of typos and are prone to inconsistent data. For example, just 
think of how many ways one might enter William into various tables: Will, Bill, Willy, Billy, or 
William. If you searched for all sales records for William Smith, you probably would not find the 
listing for Bill Smith.

Flat file databases repeat data for each record. Smith is physically entered and stored three times in this table; the 
description and price are manually entered for each record.

Well-designed relational databases separate data into linked tables to reduce storage space, data repetition, 
and potential errors.

The Employees 
table is related 
to the Invoices 
table via the 
EmpID field.

The Customers 
table is related 
to the Invoices 
table via the 
CustID field.

What Is a Relational Database?
A relational database contains two or more tables that are linked (related) to each other by 
unique and identifying key fields, such as ProductID or Invoice Number. For instance, if you are 
adding a record to the Invoice table, you could select the ProductID from the linked Products 
table and also display the product description and product price. The product information is 
only stored once in the Products table, but it is available to all the tables, queries, forms, and 
reports that are linked in the database.
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AC02.4  Access 2013  Lesson 2: Designing a Database and Creating Tables

The Invoice Details table 
includes a drop-down list 
of product information.

The Invoice Details 
table is linked to the 
Products table by the 
key field ProdID.

The drop-down menu 
lists the linked data 
stored in the Products 
table.

You can select the key field ProdID to access the Product Description and 
Product Price from the Products table, without storing those two fields in 
the Invoice Details table. 

Gathering Data
Before you create a database, you must analyze the needs of the business and the requirements 
of the database. You will need sample copies of employee records, customer records, product or 
service records, and any other pertinent documents or forms. You will need copies of every 
existing report, ranging from individual invoices to yearly sales summaries. You will also need a 
sketch, or mockup, of the complete layout for any new forms and reports that the business 
desires to add.

Samples of forms and reports collected at the start of a project. There may be handwritten 
forms as well.

This data gathering process must take place before you begin to design the objects in a database.

Lessons from Microsoft Office 2013  FOR EVALUATION ONLY (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Designing a Relational Database  AC02.5

Ac
ce

ss
 2

01
3

DEVELOP YOUR SKILLS AC02-D01

Collect Information for a New Database
In this exercise, you will use Microsoft Excel to create a list of the reports and forms needed to fully 
analyze the needs of your database. Of course, as a student, you will not have real documents; this is a 
brainstorming exercise. With this in mind, you will create a worksheet that represents the typical design 
process.

1.	 Start Microsoft Excel 2013 and click Blank workbook in the Backstage view.

If you do not have Excel 2013, you can use an older version of Excel.

2.	 Follow these steps to create a list of Winchester Web Design reports, records, forms, and 
relevant documents:

	Type DOCUMENTS 
in cell A1 (increase 
the column width, 
if necessary).

	Type FIELDS in 
cell B1.

	List the individual 
fields to be included 
in each document 
in column B, 
under FIELDS.

	List the tables, 
reports, 
records, and 
forms shown 
in column 
A, under 
DOCUMENTS.

This figure shows only part of the data gathering process. Some fields may be included on more than 
one document, such as ProdID, ProdDescription, and Price.

3.	 Following the template above, after the last field in the Customer List, add a table named 
Employees that contains Name and Address, Telephone, Email, and Hire Date 
fields, and a Yes/No Web Certification field.
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AC02.6  Access 2013  Lesson 2: Designing a Database and Creating Tables

4.	 Click Save , navigate to your AC2013 Lesson 02 folder, and save the workbook as 
AC02-D01-WinWebDesign-[FirstInitialLastName].

Replace the bracketed text with your first initial and last name. For example, if your name is Bethany 
Smith, your filename would look like this: AC02-D01-WinWebDesign-BSmith.

5.	 Keep the workbook open for the next exercise.

Unless directed otherwise, always keep your working file open at the end of each exercise.

Importance of Good Database Design
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0202

There are a few basic principles to guide you through the database design process. Follow the 
steps outlined here to create a database that will perform efficiently.

PRINCIPLES FOR GOOD DATABASE DESIGN

Objective Description

Separate Tables Organize and separate data fields into tables with specific subjects (e.g., person, 
place, or product) so you can easily locate records and reduce redundant data and 
inconsistencies.
Example: A small business may have an Employees table, a Products table, and an 
Invoices table.

Assign Keys Set a unique key field for each main table to link to data in other tables. This is done 
so data are only entered and stored one time, saving time and disk space, and 
reducing data entry errors.
Example: If the ProductID key field is entered into the Invoices table, the 
ProductDescription and ProductPrice can be linked from the Products table and 
displayed in an invoice.

Atomize Fields Break fields into the smallest single values, called atomization.
Example: Instead of a Name field that contains the value of Jay Winchester, create 
two fields—FirstName (Jay) and LastName (Winchester). This allows you to sort/
search by LastName and, if desired, print a report without including FirstName.

Normalizing Databases
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0203

Organizing tables and fields into their smallest distinct parts, and then efficiently linking the 
data together through the relationships of key fields, is called normalization. Normalization 
eliminates data duplication, decreases data entry errors and inconsistencies, reduces file size, 
and streamlines the search for necessary information. 

As you add table fields, be aware that Access has reserved words, which have special meanings 
and cannot be used as field names. Examples of reserved words are Name and Date. If you need 
to use such fields, name them FirstName, LastName and BirthDate or HireDate, which are more 
descriptive.
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When assigning field names, it is common practice to avoid using spaces, which you have no 
doubt noticed already. This is especially helpful when performing calculations on a field. For 
instance, a field named Hours Worked, almost looks like two fields (one named Hours and one 
named Worked). Consequently, most professionals would use the field name HoursWorked or 
Hours_Worked. Space can be easily added for readability when designing your forms and 
reports.

As you work through the activities in this lesson, you will begin to shape the relationships 
among database objects toward normalization.

DEVELOP YOUR SKILLS AC02-D02

Separate Data into Tables and Assign Key Fields
In this exercise, you will divide your gathered document data into tables, each of which describes a single 
category. You will break down each field into its smallest components, then name each field and assign 
them to the most appropriate table. Finally, you will add a unique identifying key field to each table.

1.	 In the WinWebDesign workbook, click the New Sheet  button.

2.	 Follow these steps to create a list of database tables and the fields that each table will 
contain:

A	Type TABLES in 
cell A1.

C	Type the name of each 
table in column A, as 
shown.

D	Type each field name in 
column B, as shown.

B	Type FIELDS in 
cell B1.

This figure shows only part of the normalization and data assigning process. With the exception of key 
ID fields, no field is listed more than once.
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AC02.8  Access 2013  Lesson 2: Designing a Database and Creating Tables

3.	 Enter the following fields for the Employees table:

■■ EmpID ■■ EmpZIP
■■ EmpLastName ■■ EmpPhone
■■ EmpFirstName ■■ EmpEmail
■■ EmpAddr ■■ EmpHireDate
■■ EmpCity ■■ EmpWebCert
■■ EmpST

4.	 Save  the workbook.

Planning Related Tables 
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0204

In most cases, determining the tables required for a database and identifying the data or fields 
each table should contain is relatively simple. After analyzing the business reports and forms for 
Winchester Web Design, you have determined that you will need an Employees table and a 
Customers table, in addition to a Products and an Invoices table. You have also identified which 
fields are required for each table. At this point you should examine each table and confirm that 
any unassociated data has been moved into a different but appropriate table.

Now you will link the tables with key ID fields so you don’t have to enter the same names and 
products over and over. By establishing relationships between database tables, you prevent 
repeated data and redundant fields (except those key identifying fields that establish 
relationships between tables).

Linking Tables with Primary 
and Foreign Keys

Almost every database table should have a primary key field with a unique ID that will not be 
the same for any two database records. Your social security number and a student ID are 
examples of unique primary keys. 

Primary Keys
Not everyone has a spouse or an email address, so some fields may remain null or empty. 
However, if a table contains a primary key, then a value must be entered for that key field every 
time a new record is added. Without a value, that record cannot be linked to any other table in 
the database. All taxpayers have a social security number; all students have a student ID.

Each time you create a new table in Datasheet View, Access automatically creates an ID field and 
marks it as the primary key field. When you manually create a table in Design View and do not 
assign a primary key field, Access asks if you want to create one before you save the table. By 
default, this primary key is the first field listed in a table and is assigned the AutoNumber data 
type. AutoNumber values start at 1 and are automatically increased by 1 for each subsequent 
record. You can also rename this field, change its data type, remove the primary key designation 
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from the field, or assign the key to another field. The primary key field must contain data; the 
field cannot be empty.

Foreign Keys
As you review your Excel workbook, notice that most key fields (ProdID, EmpID, and CustID) 
are used in more than one table. In the Customers table, the CustID field is its unique primary 
key. However, individual customers will also need to be displayed in the Invoice table to show 
their purchases. A foreign key is a field in a secondary table that corresponds and links to the 
primary key field in the main table, where the specific information for a particular item is stored. 
The foreign key must be the same data type as the primary key, except in the case of 
AutoNumber. If the primary key is set to AutoNumber then the foreign key should be set to a 
Number data type with its Field Size property set to Long Integer.

Here, the CustID field in the Invoices table is a foreign key that links to the primary key in the 
Customers table to obtain the customer name, address, and customer contact information 
stored in the main table.

If the primary key is a number, then the foreign key must also be a number; if the primary key is 
text, then the foreign key must also be text.

DEVELOP YOUR SKILLS AC02-D03

Assign Key Types to Key Fields
In this exercise, you will assign primary and foreign keys in the Winchester Web Design workbook.

1.	 Follow these steps to label the keys as primary or foreign:

	Type Primary and Foreign as shown to 
identify keys in each table.

	Type KEY in cell C1.

	Type Primary in cell C2 to identify the 
primary key.
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AC02.10  Access 2013  Lesson 2: Designing a Database and Creating Tables

2.	 Assign the primary key designation to the EmpID field in the Employees table.

3.	 Save  the workbook.

Identifying Relationship Types
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0205

Individuals and teams within organizations establish relationships to effectively interact and 
cooperate with other teams. The same is true of tables within an Access database—relationships 
must exist. Relationships in databases connect data in one table to data stored in other tables. 
Access supports three different types of relationships: 

■■ One-to-one

■■ One-to-many

■■ Many-to-many 

One-to-One Relationships
A one-to-one relationship means that each record in Table A can have only one matching record 
in Table B, and each record in Table B can have only one matching record in Table A. This is the 
least frequently used relationship. A one-to-one relationship requires both of the related fields 
to be primary keys. This relationship is generally used for storing information that applies only 
to one small portion of the main table, such as to isolate part of the table for security purposes. 
A good example of this is a main Customers table linked to a CustPassword table.

A join line connects one key field to 
another key field. The 1s identify the 
relationship type.

Primary key fields.

In this one-to-one relationship, each employee customer is only 
linked to one password. 
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One-to-Many Relationships
A one-to-many relationship means that each record in Table A can have multiple matching 
records in Table B, but a record in Table B can have only one matching record in Table A. For 
instance, one employee will have many sales, and a product will be sold many times. This is the 
most common type of relationship.

One employee may have many sales or 
invoices. The 1 on the join line for EmpID 
indicates one employee; the infinity (∞) 
symbol indicates many sales.

Many-to-Many Relationships
A many-to-many relationship occurs when two tables each have many matching records in the 
other table, but they do not share key fields, so they use a third junction table to tie other tables 
and complete the relationship. The junction table generally has a one-to-many relationship to 
each table. An example is a vendors table and a products table, where one vendor provides many 
different products and one product is available from many vendors.

In this many-to-many relationship, items in 
the Products and Vendors tables each have a 
one-to-many relationship with the Product-
Junction table. As a result, the business 
could buy the same products from multiple 
suppliers.
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Developing an Entity Relationship Diagram
An Entity Relationship Diagram (ERD) helps to model and display relationships between 
entities, specifically the relationship between tables and fields, as established by key fields. 
There are a variety of tools that can be used to develop this diagram, ranging from Microsoft’s 
Visio to the open source and free MySQLTM Workbench. And there are different techniques 
that may be used to display this relationship diagram. Microsoft Access’s Relationships tool 
provides an excellent way to both set and view these relationships.

A relationship diagram generated by Microsoft Access displays each table, each field, and how 
the tables are linked by their key fields.

Defining Data Types
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0206

If you have ever filled out an online form, you might have seen instant formatting of some 
fields. When typing in currency values, the dollar sign and decimal point may appear 
automatically, and when entering a date, the slashes between month, day, and year 
spontaneously appear. This can be accomplished by assigning a data type to the field. A data 
type sets the characteristics of a particular field, identifying the type of values it may hold, such 
as alphanumeric text, or numbers, or dates, yes/no values, or even a hyperlink.

Identifying Field Data Types
You have identified and named your fields and assigned them to a table. You also made sure you 
did not assign any field to more than one table—with the exception of a foreign key. Now you 
will assign each field a data type. As you define each field in a new table datasheet, Access 
displays a drop-down list from which you can choose the type of data you plan to enter in 
the field.

FROM THE RIBBON

Database Tools→ 
Relationships 
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By defining the type of data each field will contain, you can reduce both the time and the 
amount of formatting you must apply as you enter the data. Defining a data type also reduces 
the potential for errors. For example, if you set a field’s data type to a number, a user will not be 
able to enter values such as the letter l for the number 1 (one) or the letter O for the number 0 
(zero). Defining data types can also decrease the storage space needed. A description of data 
types available in Access 2013 databases is shown in the following table.

ACCESS DATA TYPES

Data Type Description

Short Text Default data type that contains up to 255 characters (any combination of alphabetic 
and numeric characters, such as names, addresses, and phone numbers); text fields 
may contain numbers but are not used in calculations

Long Text Text entries that contain between 1 and 63,999 characters

Number Numeric data to be used in mathematical calculations

Date & Time Fields that hold date and time values

Currency Numeric values representing dollars and cents or fields in which you want to prevent 
rounding off during calculations

AutoNumber A field for which Access automatically assigns a unique identifying number to records 
as they are added to a table; cannot be modified; cannot be reused in a table, so 
deleted records result in gaps

Yes/No Single-character entries in a Yes/No checkbox format used to enter data that can be 
only one of two possible values (true/false, yes/no, or on/off)
Use the Yes/No data type for a checkbox that indicates whether an employee has web 
certification or a college degree

OLE Object Embedded or linked objects (e.g., Excel spreadsheets, Word documents, images, 
audio, video, etc.) with a storage limit of 1 gigabyte

Hyperlink Links to web pages or other files when clicked

Attachment Data type that identifies a file, such as a document or an image, that will be included 
in the database as an attachment

Calculated Field created by doing math on values in other fields within the table

Lookup Wizard Field that displays a drop-down list of values from another table or from a list of values 
you type; a common lookup field is a drop-down list of State abbreviations
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DEVELOP YOUR SKILLS AC02-D04

Define Data Types
In this exercise, you will assign data types and sizes to the fields in your Winchester Web Design workbook.

1.	 In your workbook, enter the data type of each field in column D as shown. Then, specify 
field sizes in column E (on the right).

The Notes field is a Long Text memo/comment field and has no entered size limit.

2.	 Assign the Short Text data type to these fields in the Employees table: EmpID, 
EmpLastName, EmpFirstName, EmpAddr, EmpCity, EmpST, EmpZIP, and EmpPhone.

3.	 Assign the Hyperlink data type to EmpEmail.

4.	 Assign the Date & Time data type to EmpHireDate.

5.	 Assign the Yes/No data type to EmpWebCert.

NOTE

	 When in Datasheet View, tap [Spacebar] to check or uncheck a checkbox.

6.	 Assign the same field sizes you assigned to similar fields in the Customers table.

7.	 Save the workbook.
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Creating Access Tables in a New Database
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0207

Now that you have analyzed the needs of your new database and designed the structure for the 
tables, fields, and primary keys, you are now ready to create your database in Microsoft Access.

Creating a New Database
An Access database serves as a container that holds all the tools, data, and various database 
objects that help users enter and organize data and obtain meaningful information from that 
data. As a result, you must name and save the database when you create it. After you create a 
new database, Access automatically creates and opens an empty table, named Table1, in 
Datasheet View. When a table is created in Datasheet View, the first field, by default, is the 
AutoNumber data type.

DEVELOP YOUR SKILLS AC02-D05

Create a New Table in Datasheet View
In this exercise, you will create a new blank database and add an Invoices table in Datasheet View.

1.	 Start Access 2013.

2.	 Follow these steps to create and name the new database:

	Click Blank Desktop 
Database.

	Type AC02-D05-
WinWebDesign-
[FirstInitialLastName]
for the File Name.

	Click the Browse Folders 
button and navigate to your 
AC2013 Lesson 02 folder.

	Click Create.

In step c, remember to replace the bracketed text with your first initial and last name. 

Access creates the new database, shows the database name in the application title bar, and creates a 
new table named Table1 in the Access window.
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3.	 Follow these steps to add field names and set data type:

	Double-click the ID field column 
heading and type InvNum as the 
key field for column one.

	Tap [Tab] to go to the second 
column and choose Date & 
Time from the data type list. 

Once the data type is selected, the heading Click to Add a new field is automatically named Field1.

4.	 Type InvDate as the new name for Field1 in the second column and tap [Tab] to complete 
the name and move to a new field in the third column.

5.	 Choose the data type Short Text for the third field and change the field name to EmpID.

6.	 Tap [Tab], choose Short Text for the fourth field and change the field name to CustID.

Full field names/column headings may not appear if the columns are narrower than the field name. 
Drag the right edge of the column heading to adjust column size.

7.	 Follow these steps to enter data in your new table:

	Tap [Tab] and 
type JFW.

	Tap [Tab] and type 
SmithW under the 
CustID heading.

	Use [Tab](forward) or [Shift]+[Tab](backward) to 
navigate among cells and enter the remaining data.

	Click in the first row under InvDate 
and type 12/15/2013.

NOTE

	 When you create a table in Datasheet View, Access sets the first field as the Primary Key 
with an AutoNumber data type. Because InvNum uses the AutoNumber data type, Access 
fills in consecutive numbers automatically.
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8.	 Follow these steps to save the table using a new table name:

	Click Save.

	Type 
Invoices 
in the Table 
Name box. 

	Click OK.

The name in the object tab changes from Table1 to Invoices.

9.	 Click Close  to close the table. Leave the database open.

Creating Tables in Design View
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0208

Many people believe that it’s easier to create a new table in Design View because it offers a 
straightforward layout and provides intuitive options for entering field descriptions, setting 
field properties, and easily setting or removing primary keys.

Entering Optional Descriptions
In Design View, descriptions may be added to each field in a table to help identify special 
information about a field. For example, in the Customers table, the customer ID consists of the 
customer last name plus the customer first initial. So you might enter the following description 
for the CustID field: ID = Last name and customer first initial.

Setting Field Properties
Once you assign a data type, you can modify the field’s properties further. As you define each 
field in a database table, Access sets properties for the field that control the number of 
characters the field can contain as well as the format of the data and the type of characters that 
are valid for the field. You can accept Access default properties or modify the properties. 
Properties available depend on the data type selected for the field. 
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Requiring Data in Key Fields
The field identified as the primary key field must contain data—it cannot be empty. When 
Access creates the primary key field, by default it sets the key field to automatically number the 
records. This ensures that each record has a unique number. Businesses often create their own 
coding system to identify customers and accounts, and use this identifying code for the 
key field.

If a column in the table is too long or too short for the data it contains, you can adjust its width. 
Access provides some useful tools for changing column width. 

■■ Drag a column border: Dragging a column border enables you to make the column on the 
left of the border wider or narrower.

■■ Double-click a column heading border: Double-clicking the right border of a column 
changes the width of the column on the left to fit the longest data entry in the column or 
column heading, whichever is wider.

■■ Right-click a field heading and choose Field Width: Selecting the Field Width 
command in the context menu opens the Column Width dialog box so you can type the 
desired column width, reset the standard column width, or select Best Fit to automatically 
size the field width to the longest entry.

DEVELOP YOUR SKILLS AC02-D06

Create a New Table in Design View
In this exercise, you will create a new table using Table Design View. Then, you will adjust the width of the 
columns in the table.

1.	 Choose Create→Table Design.

Access opens an empty table in Design View.

2.	 Follow these steps to create the first table field, which will be the primary key:

	Click Primary 
Key.

	Type CustID 
in the first 
row of the 
Field Name 
column and 
tap [Tab].

	Note that 
Short Text is 
selected as the 
default Data 
Type.

	Tap [Tab] and type Customer 
Last Name and First Initial.
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3.	 Tap [Tab] and repeat step 2 to add the additional fields and field information shown here.

4.	 Click the CustLastName field and enter the values shown:

	Change the Field Size 
value in the Field 
Properties section to 
25 characters.

	In the Caption text box 
type Last Name.

5.	 Repeat the procedure shown in step 4 to change the caption properties of the following 
fields:

Field Size Caption

CustLastName 25 Last Name

CustFirstName 25 First Name

CustStreetAddress 25 Street Address

CustCity 15 City

CustState 2 ST

CustZIP 5 ZIP Code

CustPhone 15 Telephone

CustEmail Email

6.	 Save  the table as Customers.

If you forget to save, Access will prompt you to save when you close the table.
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7.	 Click the View drop-down arrow and choose Datasheet View.

8.	 Enter these records:

Notice that the street address for DavisP is slightly cut off (the “y” in “Way” is difficult to make out). 
You will adjust column width next.

Change the Column Width 

9.	 Follow these steps to change the width of two columns:

	Click between the ST and ZIP header. The mouse 
pointer changes into a double-headed arrow. Drag the 
ST column header to the left to manually resize it. 

	Double-click the column header between 
Street Address and City to auto size it.

10.	 Close the Access table and database. Save  and close the Excel workbook. 

Retrieving Data
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0209

Whether you’re processing an order, announcing statistics, or updating records, the primary 
purpose of any database is to be able to locate and retrieve data quickly and efficiently. Access 
provides three main tools and features for helping to locate and retrieve data.

■■ Sorting features

■■ Filtering tools

■■ Find and Replace commands

Sorting Records
Access automatically sorts records according to the primary key field identified when a table is 
created and fields are set up. You can also automatically sort tables by an AutoNumber as you 
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enter records. The database sort feature enables you to rearrange table records based on data 
found in other table columns as well. Two main sort orders are available in Access.

■■ Sort Ascending: Arranges data in alphabetical order from A to Z, in numeric order from 
lowest to highest, or in chronological order from first to last.

■■ Sort Descending: Arranges data in reverse alphabetical order from Z to A, in numeric order 
from highest to lowest, or in reverse chronological order from last to first.

Sorting Records Using Tables and Forms
Regardless of whether you are working with a table or a form, the primary procedures for 
sorting records are the same. 

Because the Winchester Web Design company is a small business with only a few employees, 
customers, and products, in the remainder of this lesson we will use the Raritan Clinic East 
database to get a better feel for the power of databases.

NOTE

	 For the rest of this exercise, you will work with a Raritan Clinic East database.

DEVELOP YOUR SKILLS AC02-D07

Sort Records in a Table
In this exercise, you will sort records in the Raritan Clinic East database. 

1.	 Open AC02-D07-RCE from the AC2013 Lesson 02 folder and save it as AC02-D07-RCE-
[FirstInitialLastName].

2.	 Double-click the Patients table in the Navigation Pane to open it in Datasheet View.

3.	 Follow these steps to sort records alphabetically by last name:

	Position the 
insertion 
point and 
click any 
record in the 
Last Name 
field.

	Choose Home→Sort & Filter→Ascending.
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4.	 Follow these steps to set a descending sort order and then remove the sort:

	Click Remove 
Sort.

	Click any record in the Doctor column.

	Choose Home→ 
Sort & Filter→ 
Descending.

Records are rearranged in Patient ID order again—the default sort order.

Sorting Records Using Multiple Fields
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0210

Data can be sorted in more than one table field at the same time. This can be useful, say, when 
more than one person in a family visits the same medical clinic. When this happens, selecting 
the first name field as a second sort field within a last name sort is appropriate. The last name 
field is the primary sort field and the first name field is the secondary sort field. The secondary 
sort field is only considered when multiple records contain the same data in the primary 
sort field.

How Multiple Column Sorts Work
Access sorts data in multiple fields from left to right. Consequently, the left column must be the 
one you want sorted first (primary sort field). Access then considers the second column 
(secondary sort field) only when it finds identical values in the primary sort field. You can 
perform more complex sorts on multiple fields using the Advanced Filter/Sort options, or sort 
multiple columns by rearranging them in the datasheet so that they appear side by side. 
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QUICK REFERENCE SORTING RECORDS

Task Procedure

Sort ascending Click in the desired field and choose Home→Sort & Filter→Ascending.

Sort descending Click in the desired field and choose Home→Sort & Filter→Descending.

Clear sorts Choose Home→Sort & Filter→Remove Sort.

Sort in multiple 
fields

Arrange the desired fields with the primary field left of the secondary field then 
select both field column headings and click the desired sort button.

DEVELOP YOUR SKILLS AC02-D08

Sort Records Using Multiple Fields
In this exercise, you will sort data in a table based on the values found in two columns.

1.	 Follow these steps to sort table records based on the values in multiple fields:

	Choose Home→Sort & Filter→Ascending.

	Click the Last Name column heading and drag the 
mouse to select the First Name column heading. Notice 
the downward pointing arrow as you drag the mouse.
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2.	 Review the record sort results to see the effect of sorting on two columns.

There are two patients named Cook and two named Frost. The patients with the same last names are 
also sorted alphabetically by first name.

3.	 Choose Home→Sort & Filter→Remove Sort. Click any value in the Street Address 
column to deselect both name columns.

4.	 Follow these steps to sort on the same two columns and obtain different results:

	Select both name columns and choose 
Home→Sort & Filter→Ascending.

	Click the First Name column heading to select the column; then click and drag 
the column. left so that it appears to the left of the Last Name column. Click any 
other field to clear the selected column.

The records appear in alphabetical order by first name—the Barrys are together and the Marys are 
together.
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5.	 Click Close  to close the Patients table.

Because you have changed the sort order a couple of times and then cleared the sorts, Access recognizes 
that you have changed the layout of the table and prompts you to save. If you click Yes, the changes 
will become part of the table design. You want to discard the changes. 

6.	 Choose No in response to the prompt to save changes.

Filtering Records
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0211

So far, you have sorted all the records contained in a table. When you work with large volumes 
of table data, there will be times when you want to locate a group of records that contain specific 
values in specific fields. Filtering enables you to select and work with a subset of records 
contained in a table. 

Using the Filter Tools
The Filter tool lets you identify a value in a table field and tell Access to select only those records 
in the datasheet that contain the same value in the selected field. This process applies a filter to 
the table that hides (filters out) records whose active field contains data that does not match. 
For example, if you work with a database that contains thousands of records for consumers 
across the country, you could apply a filter to identify people who live in a specific state.

Access provides two types of methods for filtering records: Filter by Selection and Filter 
by Form. 

■■ Filter by Selection: Selects records based on the value contained in the active field in the 
table. 

■■ Filter by Form: Selects records based on values or conditions (criteria) you type into form 
fields. Access searches only the fields you specify.

Filtering Records by Selection
There are two basic ways to filter by selection. You can tell Access to select all records containing 
data that matches the value or selected text in the active field of the selected record. Or you can 
select all records containing any value other than the one selected. Access searches only the 
selected field to find matches.

Removing a Filter
If you close the table after you have applied a filter, Access prompts you to save changes to the 
table. You will often want to save changes, especially in cases where you widen or hide columns. 
However, filtering data in a table is typically a temporary view while you work with the data, so 
you do not want to save a filtered table. To remove a filter, choose Home, and in the Sort & Filter 
section, click the Advanced menu drop-down, then choose Clear All Filters.
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Using the Toggle Filter Tool
The Toggle Filter tool in the Sort & Filter section of the Ribbon serves two purposes:

■■ After you apply a filter, clicking the Toggle Filter button removes the filter and displays all 
records.

■■ After removing a filter, clicking the Toggle Filter button reapplies the last filter applied.

In addition, when you point to the Toggle Filter button, a ToolTip displays to let you know what 
action you are performing. For example, when you point to the Toggle Filter button after 
applying a filter, the ToolTip displays Remove Filter. When you point to the Toggle Filter button 
after removing a filter, the ToolTip displays Apply Filter.

DEVELOP YOUR SKILLS AC02-D09

Filter Records by Selection
Two records in the Raritan Clinic East Doctors table contain an invalid zip code. In this exercise, you will 
filter table records, correct the zip code, and then remove the filter.

1.	 Open the Raritan Clinic East Doctors table.

2.	 Follow these steps to set a filter:

	Click Toggle 
Filter to 
switch 
between the 
filtered records 
and the entire 
table.

	Locate a record 
with a Zip field 
value equal 
to 34205 and 
double-click to 
highlight the 
Zip value.

	Choose Home 
→Sort & 
Filter→ 
Selection.

	Select Equals 
“34205” from 
the Selection 
menu.

	Two records 
contain the 
invalid Zip 
code.

Access applies the filter immediately and displays two records that contain the value. The navigation 
bar indicates that the results are filtered.
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3.	 Click the Zip field for each of the errant records and type 34207.

4.	 Choose Home→Sort & Filter→Advanced→Clear All Filters  to remove the filter and 
display all table records.

Filtering Records by Form
Video Library	 http://labyrinthelab.com/videos  Video Number: AC13-V0212

Filter by Form allows you to select records based on values in multiple fields without rearranging 
the layout of table fields. When you filter by form, Access remembers the sort criteria. As a 
result, it is important to clear all filters after you apply this filter.

Identifying Comparison Operators
When you use the Filter by Form feature, you will often apply comparison operators so Access 
can locate the exact records or the range of records that contain the data you want to find.

COMPARISON INDICATORS AND SYMBOLS

Comparison Symbol Description

= Equal: Records in the table must contain a value that equals the value you set for 
the field.

< Less than: Records in the table must contain a value less than the value you set for 
the field.

> Greater than: Records in the table must contain a value greater than the value you 
set for the field.

<> Unequal: Records in the table must contain a value different from the value you set 
for the field.

<= Less than or equal: Records in the table must contain a value less than or equal to 
the value you set for the field.

>= Greater than or equal: Records in the table must contain a value greater than or 
equal to the value you set for the field.

The format of the Filter by Form entry palette depends on whether you are filtering from a table 
or from a form. If you are filtering from a table, a datasheet palette opens. If you are filtering 
from a form, a blank form opens.

Using Wildcards
Database users often want to locate records that contain data in a specific field which may 
contain additional text or data. To accommodate this, Access accepts the use of wildcards, such 
as the asterisk (*), which can be used to represent multiple characters, or the question mark (?), 
where each question mark represents a single character. 
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USING WILDCARDS TO LOCATE DATA

Example Description

Will* Finds all records with the search string text will at the beginning of the field value 
regardless of how many other characters follow it. This search string will find Will, Willy, 
and William.

*ill Finds all records with the search string text ill at the end of the field value regardless of 
how many characters precede it. This search string will find Will, Bill, and Jill, but not Willy 
or William.

*ill* Finds all records with the search string text ill anywhere in the field value, whether or not 
other characters appear before or after the search text. This search string will find Bill, Jill, 
Will, Willy, and William.

Will? Finds all records with the search string text will at the beginning of the field value and with 
only one character after. This search string will find Willy but not Willie.

Will?? Finds all records with the search string text will at the beginning of the field value followed 
by exactly two additional characters. This search string will find Willie but not Willy or 
William.

DEVELOP YOUR SKILLS AC02-D10

Filter Records by Form
In this exercise, you will use a table to filter records by form.

1.	 If necessary, open the Raritan Clinic East Doctors table in Datasheet View.

2.	 Follow these steps to open the Filter by Form tool:

	Choose 
Filter by 
Form. 

	Choose 
Home→ 
Sort & 
Filter→ 
Advanced.

A blank record opens.
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3.	 Follow these steps to filter and select records in which the City value is Sarasota:

	Click in the City field.

	Click the menu  
button at the right 
side of the City field 
and choose Sarasota.

	Click Toggle Filter 
to filter the records.

Access finds the records that meet the criteria and places a filter icon beside the field name.

Only records with the City field value of Sarasota are displayed. Notice the Filter icon in the City 
heading to indicate that it is a filtered field.

4.	 Review the results then choose Home→Sort & Filter→Advanced→Clear All Filters .

WARNING

	 Toggling the filter off does not remove the filter from the table; it just toggles between 
showing all the records and the filtered records. To remove a filter, choose Clear All Filters 
from the Advanced menu.

5.	 Click Close  to close the table. Choose No when prompted to save.
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Update Records with Find and Replace
Access’ Find and Replace tool improves the efficiency of maintaining a database that constantly 
changes. Using this tool, you can easily locate, delete, and edit records.

When you have specific edits to make to individual records, finding the records and making the 
edits works well. There are also times when you need to update the data in one field for multiple 
records with the identical replacement data. For example, if the area code for a city changed, 
multiple records would need to be updated with the same value. The Replace command allows 
you to update these records by replacing existing data with new data. Use the Replace 
command to:

■■ Replace: Replace text for each occurrence of the search text, one at a time.

■■ Replace All: Replace all occurrences of the search text with the new text, all at the 
same time.

TIP

	 Use Replace All with caution to avoid unexpected results. For example, if you wanted to 
replace the area code 813 with 941, Replace All would also change the phone number 555-
6813 to 555-6941.

The Find and Replace dialog box is probably already familiar to you. However, 
because data stored in a database is somewhat different from the text stored in 
other files, you will find some fields that are unique to the Access application.

FROM THE KEYBOARD
[Ctrl]+[F] to open the 
Find command page of 
Find and Replace 

[Ctrl]+[H] to open the 
Find and Replace dialog 
box
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FIND AND REPLACE COMMANDS

Feature Description

Find What Enter the text, numbers, dates, and other values to locate.

Replace With Finds a value and replaces it with a value you specify.

Look In Search only in the active field or in the entire document.

Match Search for only data matching the whole field, any part of the field, or at the start of the 
field.

Search Search up or down from the active cursor (to the end of the table or to the beginning of 
the table) or the whole table.

Match Case Matches the exact capitalization pattern you type.

Search Fields As 
Formatted

Search for data as it is displayed in the datasheet rather than as you type it. If you 
uncheck the box, you would find March 5, 2013, even if it is formatted in the datasheet 
as 3/5/2013.

DEVELOP YOUR SKILLS AC02-D11

Update Records Using Find and Replace
After a long career, Dr. Bonifay (DocID 223) is retiring. In this exercise, you will use Find and Replace to 
transfer her patients to Dr. Lawrence (DocID 209).

1.	 Open the Patients table.

2.	 Click the Doctor column heading to select the field to search.

You must select the field to search first.

3.	 Choose Home→Find→

4.	 Follow these steps to locate and replace text with new values:

	Click Replace All.

	Type 223 in the 
Find What box.

	Type 209 in the 
Replace With 
box.
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Access’ warning states that you will not be able to undo this action.

5.	 Choose Yes to replace all the values.

6.	 Click Cancel to close the Find and Replace dialog box then scroll to confirm that the 223 
doctors values have indeed changed to 209.

7.	 Close the table, saving if prompted.

8.	 Press [Alt]+[F4] to exit Access.

Concepts Review
To check your knowledge of the key concepts introduced in this lesson, complete the Concepts 
Review quiz by choosing the appropriate access option below.

If you are… Then access the quiz by…

Using the Labyrinth Video Library Going to http://labyrinthelab.com/videos

Using eLab Logging in, choosing Content, and navigating to the 
Concepts Review quiz for this lesson

Not using the Labyrinth Video Library or eLab Going to the student resource center for this book
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Reinforce Your Skills
REINFORCE YOUR SKILLS AC02-R01

Design a New Database
Kids for Change is a non-profit organization that helps young adults organize social/community service. 
They recently received an influx of funds to invest in computerizing the organization. In this exercise, you 
will gather and organize the information to determine the tables and fields needed for the new Kids for 
Change database. 

Design a Database

1.	 Think about what pieces of information should be included in the database. Consider the 
kinds of forms and reports they might want to generate.

2.	 Start Excel and add the following headings for the columns in the first row:

■■ Column A: Table ■■ Column D: Table
■■ Column B: Field ■■ Column E: Field
■■ Column C: Key ■■ Column F: Key

3.	 Type a list of data that should be included in the database. Resize the columns as necessary.

Normalize the Database

4.	 As you examine the data, break down each piece of information into its basic parts.

5.	 Divide the data into tables based on the following categories: Activities, Staff, 
Sites, Volunteers, and Children. List the table names in columns A and D.

6.	 With the exception of key fields used to link tables, make sure no field appears in more than 
one table. List the corresponding fields for each table in columns B and E.

Relate Tables with Keys

7.	 Enter a key ID field for each table to show the relationships that should exist between 
tables. Indicate which fields are primary or foreign keys in column C.

8.	 Save the Excel spreadsheet to your AC2013 Lesson 02 folder as AC02-R01-K4C-
[FirstInitialLastName].

9.	 Submit your final file based on the guidelines provided by your instructor.

To view examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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REINFORCE YOUR SKILLS AC02-R02

Create a New Database and Add Tables
In this exercise, you will create a new database and add tables.

Before You Begin: You must complete Reinforce Your Skills AC02-R01 before beginning this exercise. If 
necessary, open your AC02-R01-K4C-[FirstInitialLastName] file in Excel.

Create a Database and a Table in Datasheet View

1.	 Start Access. Start a Blank Desktop Database, saving it as AC02-R02-K4C-
[FirstInitialLastName] in your AC2013 Lesson 02 folder.

The new database opens and a new empty table named Table1 is open in Datasheet View.

2.	 Double-click ID in the first field heading of Table1 and type StaffID.

3.	 Press [Tab], keep the default data type Short Text in the next field and change the Field1 
heading to StaffLastName.

4.	 Press [Tab] and repeat the above steps to enter the remaining fields from the Staff table you 
created in your AC02-R01-K4C spreadsheet. (Possible field names that you might choose 
are shown below in step 6.)

All the remaining fields in this table are the Short Text data type.

TIP

	 Remember to tap [Tab] after each field entry.

5.	 Save  the table as Staff.

6.	 Add the following records to the Staff table:

Because StaffID is an AutoNumber data type, Access fills in consecutive numbers automatically. The 
StaffPhone field has not been formatted, so you must add the hyphens.

7.	 If necessary, double-click the line between the column headings to automatically resize the 
columns to display all the data.

8.	 Save and close  the Staff table.
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Create a Table in Design View

9.	 Choose Create→Table Design.

10.	 Enter ChildID in the first row of the Field Name column.

11.	 Tap [Tab] and leave the Data Type for ChildID as Short Text.

12.	 Tap [Tab] and in the Description field, type ID = Last Name and First Initial.

13.	 Click Primary Key to designate ChildID as the primary key field.

14.	 Enter the remaining fields, data types, and descriptions shown, choosing the Date/Time 
data type for ChildBirthday.

15.	 Click Save  and name the table Children.

16.	 Open the Children table in Datasheet View.

17.	 Enter these field values.

The ChildPhone and ChildBirthday fields have not been formatted, so you must add the hyphens and 
slashes.

18.	 Click Close  to close the Children table. Exit both Excel and Access.

19.	 Submit your final file based on the guidelines provided by your instructor.

To view examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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REINFORCE YOUR SKILLS AC02-R03

Create New Tables and Enter Data
The staff director of Kids for Change would like you to add two new tables to the database, one that stores 
various community activities and one that stores parent volunteers. In this exercise, you will collect and 
organize the data needed for the lists, break down the data to its basic fields, and divide the fields into 
related tables. Then, you will create the tables.

Design and Normalize Database Tables

1.	 Start Excel. In a new blank worksheet, type a list of information to be included in a new 
Volunteers and a new Activities table. Break each piece of information into its smallest 
parts.

2.	 Type the Volunteers and Activities table names in column A.

3.	 Enter fields for each of the tables in column B. With the exception of key fields used to link 
tables, make sure no field appears in more than one table.

Relate Tables with Keys

4.	 Enter a key ID field for each table to show the relationships that should exist between 
tables. Indicate which fields are primary or foreign keys in column C.

5.	 Save the spreadsheet to your AC2013 Lesson 02 folder as AC02-R03-K4C-Excel-
[FirstInitialLastName].

Your Excel worksheet should look similar to the figure above, though you may have different names.
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Create a Table in Datasheet View

6.	 Start Access. Open AC02-R03-K4C from your AC2013 Lesson 02 folder and save it as 
AC02-R03-K4C-[FirstInitialLastName].

7.	 Choose Create→Tables→Table to create a new table in Datasheet View.

8.	 Double-click ID in the first field heading and type VolID.

9.	 Press [Tab], choose the Short Text data type, and change the Field1 heading to 
VolLastName.

10.	 Press [Tab] and repeat enter the remaining fields from the Volunteers table that you 
entered in Excel.

11.	 Save the table as Volunteers.

12.	 Add these records to the Volunteers table.

The VolPhone field has not been formatted, so you must add the hyphens.

13.	 Close the Volunteers table.

Create a Table in Design View

14.	 Choose Create→Tables→Table Design to create a new table in Design View.

15.	 Enter ActivityID in the first row of the Field Name column.

16.	 Tap [Tab] and leave the Data Type as Short Text.

17.	 Tap [Tab]. In the Description field, type Activity Initials + Activity Day.

18.	 Set ActID as the primary key.
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19.	 Enter the remaining Short Text fields from your Excel worksheet.

20.	 Choose Date/Time from the drop-down menu for ActTime.

21.	 Save the table as Activities.

22.	 Open the table in Datasheet View and enter these records.

23.	 Close the table, saving changes if prompted. Then, exit Excel and Access.

24.	 Submit your final file based on the guidelines provided by your instructor.
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Apply Your Skills
APPLY YOUR SKILLS AC02-A01

Plan and Design a Database
Universal Corporate Events is a corporate meeting and event planning service. 
They have hired you to build a new database to automate the company. In this exercise, you will create a 
new database and add a table that organizes the types of events that Universal Corporate Events plans.

Design and Normalize a Database

1.	 In Excel, create a list of all fields and information that you want to include in the database, 
such as event types, locations, a calendar or schedule, menu plans, and other relevant 
subjects.

2.	 Divide the data into four tables: Staff, Events, Scheduling, and Menus.

3.	 Determine the common key ID fields you will use to relate the tables to each other.

4.	 Assign a data type to each field.

5.	 Save the spreadsheet to your AC2013 Lesson 02 folder as AC02-A01-UniversalCorp-
[FirstInitialLastName].

6.	 Exit Excel.

7.	 Submit your final file based on the guidelines provided by your instructor.

To view examples of how your file or files should look at the end of this exercise, go to the student 
resource center.

APPLY YOUR SKILLS AC02-A02

Add Tables to a New Database
Now that you have collected and organized the data fields, you can create the database for Universal 
Corporate Events. In this exercise, you will create the new database, add an EventStaff table in Datasheet 
View, and then add a Menus table in Design View.

Before You Begin: You must complete Apply Your Skills AC02-A01 before beginning this exercise. If 
necessary, open yourAC02-A01-UniversalCorp-[FirstInitialLastName] file in Excel.

Create a Database and a Table in Datasheet View

1.	 Start Access. Open a Blank Desktop Database and save it as AC02-A02-
UniversalCorp-[FirstInitialLastName] in your AC2013 Lesson 02 folder.

2.	 Referring to your AC02-A01-UniversalCorp Excel workbook, enter the Staff table field 
names.

3.	 Save the table as EventStaff.
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4.	 Enter these records in the EventStaff table.

5.	 Close the EventStaff table, saving if prompted.

Create a Table in Design View

6.	 Choose Create→Tables→Table Design.

7.	 Enter the fields and data types for the Menus table from your AC02-A01-UniversalCorp 
workbook.

8.	 Designate MenuCode as the primary key field.

9.	 Save the table as Menus.

10.	 Open the table in Datasheet View and enter this data.

11.	 Close the Menus table, saving it if prompted. Then, Exit Excel and Access.

12.	 Submit your final file based on the guidelines provided by your instructor.

To view examples of how your file or files should look at the end of this exercise, go to the student 
resource center.

APPLY YOUR SKILLS AC02-A03

Create a New Database and Add Related Tables
Every university and school has a giant database that stores data for students, faculty, classes, grades, and 
so forth. In this exercise, you will identify fields needed to store student data for such a database and group 
these fields into appropriate tables.

Design and Normalize a Database

1.	 Start Excel. In a new workbook, list the reports commonly generated by schools and 
universities, such as course schedules, grades, prerequisites, degree requirements, student 
aid, etc.

2.	 List data fields that would be required to generate the reports.

3.	 Determine the common key ID fields that can be used to relate the tables to each other.

4.	 Assign a data type to each field.
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Create a Database and a Table in Datasheet View

5.	 Start Access. Create a new database named A02-A03-SunStateU-
[FirstInitialLastName] and save it to your AC2013 Lesson 02 folder.

Access creates the new database, and opens a new table in Datasheet View.

6.	 In the new table, enter these fields and data types for university classes.

Field Data Type

Department Short Text

Class Number Short Text

Section Number Short Text

Building Short Text

Room Number Short Text

Start Time Date/Time

End Time Date/Time

Credit Hours Number

7.	 Set Department as the primary key field.

8.	 Brainstorm and add at least four new records to the table.

9.	 Save the table as Classes.

10.	 Create a table in Design View containing these fields and data types, adding your own 
descriptions.

Field Name Data Type Description

ProfID Short Text

ProfLastName Short Text

ProfFirstName Short Text

ProfDept Short Text

ProfRank Short Text

11.	 Set ProfID as the primary key.

12.	 Save the table as Professors.

13.	 Close the Classes and Professors tables. Then, exit Excel and Access.

14.	 Submit your final file based on the guidelines provided by your instructor.
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Extend Your Skills
In the course of working through the Extend Your Skills exercises, you will 
think critically as you use the skills taught in the lesson to complete the assigned 
projects. To evaluate your mastery and completion of the exercises, your instructor 
may use a rubric, with which more points are allotted according to performance 
characteristics. (The more you do, the more you earn!) Ask your instructor how 
your work will be evaluated.

AC02-E01	 That’s the Way I See It
Winchester Website Design is exploring expanding the number of items they currently recycle 
(cans, bottles, Styrofoam, paper, old electronics). To determine if there are additional ways to 
recycle, the company president has asked you to do some research. Go online and 
locate information about recycling in your state (recycling locations, contact persons, etc.). Plan 
the fields to include in a recycling information database. In Excel, create a spreadsheet that 
organizes your data into tables, along with key fields and data types. Save the spreadsheet as 
AC02-E01-ExcelRecycle-[FirstInitialLastName] in your AC2013 Lesson 02 
folder.

In Access, create a new database named A02-E01-Recycling-[FirstInitialLastName]. 
Create a table that includes fields for recycling locations throughout the state and a contact 
name for the person in charge of the recycling facility. Enter data for at least three sites/
companies. Finally, add a record containing your school as a site/company and your name as the 
contact. 

You will be evaluated based on the inclusion of all elements, your ability to follow directions, 
your ability to apply newly learned skills to a real-world situation, your creativity, and your 
accuracy in creating objects and/or entering data. Submit your final files based on the guidelines 
provided by your instructor.

AC02-E02	 Be Your Own Boss
You are the owner of Blue Jean Landscaping and have decided to sponsor the Sarasota Service 
Guild, a nonprofit organization created to raise money to help adults with disabilities. The guild 
has successfully raised more than $60,000 annually through sponsoring an historic home tour. 
They would like a database that will enable them to track memberships, donations from 
businesses, ticket sales, etc. You can help them plan their database by identifying fields, such as 
donor names and tour schedules, and tables, such as Members and Tour Home Addresses. Using 
Excel, identify sample tables that need to be included in the database and the fields that you 
would place in each table, assign primary and foreign keys to relate the tables, and select data 
types for each field. Save the Excel spreadsheet as AC02-E02-BJLandscaping-
[FirstInitialLastName] in your AC2013 Lesson 02 folder. Once you have designed the 
database in Excel, start Access and create a new database named AC02-E02-
BJLandscaping-[FirstInitialLastName]. Add the tables that you included in your 
Excel spreadsheet.

You will be evaluated based on the inclusion of all elements, your ability to follow directions, 
your ability to apply newly learned skills to a real-world situation, your creativity, and your 
accuracy in creating objects and/or entering data. Submit your final files based on the guidelines 
provided by your instructor.
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Transfer Your Skills
In the course of working through the Transfer Your Skills exercises, you will use 
critical-thinking and creativity skills to complete the assigned projects using skills 
taught in the lesson. To evaluate your mastery and completion of the exercises, 
your instructor may use a rubric, with which more points are allotted according 
to performance characteristics. (The more you do, the more you earn!) Ask your 
instructor how your work will be evaluated.

AC02-T01	 Use the Web as a Learning Tool
Throughout this book, you will be provided with an opportunity to use the Internet as a learning 
tool by completing WebQuests. According to the original creators of WebQuests, as described on 
their website (WebQuest.org), a WebQuest is “an inquiry-oriented activity in which most or all 
of the information used by learners is drawn from the web.” To complete the WebQuest projects 
in this book, navigate to the student resource center and choose the WebQuest for the lesson on 
which you are currently working. The subject of each WebQuest will be relevant to the material 
found in the lesson.

WebQuest Subject: Design elements of a high-quality Access database.

Submit your final file(s) based on the guidelines provided by your instructor.

AC02-T02	 Demonstrate Proficiency
Stormy BBQ wants to modernize its business. They have hired you to design and create a 
database for their BBQ restaurant. Using Excel, plan the new database. Then, in Access, create 
three tables: one for staff/employees, one for the menu, and one for customer information. 
Brainstorm and add at least six records to each table (make it up). Relate the menu and 
customer tables using a customer favorite ID. 

Save the database to your AC2013 Lesson 02 folder as AC02-T02-StormyBBQ-
[FirstInitialLastName]. Submit your final file based on the guidelines provided by your 
instructor.
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