
Database reports summarize the data 
contained in tables or displayed in 
query results and enable you to 

provide information in a page layout 
suitable for printing. Although forms and 
reports serve two different purposes within 
the context of a relational database, the 
techniques used to customize them are 
similar. In this chapter, you will import 
reports from other databases and use 
features to create custom reports.

L E A R N I N G  O B J E C T I V E S
■■ Import a report into a database

■■ Add a subreport to a main report

■■ Create a report from a subreport

■■ Create calculated controls on a subreport

■■ Set page breaks in reports

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 15 mins

■■ Total: 2 hrs 15 mins

P R O J E C T:  B I L L I N G  C U S T O M E R S
The company manager of Winchester 
Web Design, a small web page design 
company, wants you to improve its 
invoice report for customer billing. 
After reviewing invoices from several 
companies, the company manager has 
sketched out a design for the new 
invoice report layout. Your job is to 
create a sample of the new invoice 
report for the company’s executive 
team.

4Customizing Reports
A C C E S S  2 0 1 6
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56 FastCourse Access 2016 Chapter 4: Customizing Reports

Importing a Report into a Database
Access offers a variety of ways to create reports. In addition to using the Report Wizard or 
starting from scratch in Design View, you can also import reports from another database. 
Because most companies require some type of invoice to send with customer orders, locating a 
sample invoice report to import is not difficult.

Sometimes you have the report you want, but during its design it may have become corrupted, 
either due to inadvertent changes to the report itself or because of changes to an underlying 
query. That’s when backups are invaluable. If a report becomes corrupted, you can restore it by 
importing database objects from a backup copy of a database. The record source should already 
match, and there should be no need to edit the properties or the field names.

Identifying Report Record Sources
Reports that you import retain two connections to their original database. The first is the source 
database table or query name, shown in the Record Source property and the second are the field 
names, which appear in report text boxes. As a result, when you import a report from another 
database, you often must establish new control sources to the destination database. You can 
accomplish this by:

■■ Editing the imported report’s Record Source property to link to a table or query in the 
destination database.

■■ Editing, if necessary, the field names in the imported report’s text boxes to match those 
shown in the new record source table or query.

ÍÍ External Data→Import & Link→Access 

DEVELOP YOUR SKILLS: A4-D1 

In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

 1.  Open A4-D1-WinWebDesign from your Access Chapter 4 folder and save it as 
 A4-D1-WinWebDesignRevised.

 2.  Look in the Reports section in the Navigation pane and notice the database contains just 
two reports.

 3.  Choose External Data→Import & Link→Access .

 4.  Click Browse, navigate to your Access Chapter 4 folder, choose A4-D1-WinWebDesign 
-Backup, and click Open.

 5.  Leave the storage setting as Import Tables, Queries, Forms, Reports, Macros, and Modules 
into the Current Database and click OK.

 6.  Click the Reports tab, choose Customer Invoices, and click OK.

 7.  Leave the Save Import Steps checkbox unchecked and click Close in the Get External Data 
dialog box.
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Adding a Subreport to a Main Report 57

 8.  Double-click the Customer Invoices report to open it in Report View.

 9.  If necessary, scroll down and then notice the empty space between the Customer 
Information and signature blocks.

Adding a Subreport to a Main Report
Subreports display subsets of data in reports and are derived from related database tables, 
similar to subforms on forms. However, a subreport can display table data by using a table, 
query, form, or another report as its source object. Forms are frequently created before reports 
and they often already display the desired data needed in a report. For these reasons, it is often 
best to use a subform as the basis of a subreport to streamline report design and layout.

An invoice report that uses a subform to display invoice details

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add  
a subform to a form. You can create the subreport using the Report Wizard or add an unbound 
subreport control to the report. Then you identify the database object containing the fields you  
want to display as a subreport.

ÍÍ Design→Controls→Subform/Subreport 
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58 FastCourse Access 2016 Chapter 4: Customizing Reports

DEVELOP YOUR SKILLS: A4-D2

In this exercise, you will add a subreport to the Customer Invoices report. You will use the InvoiceDetails 
subform as the source for the subreport.

 1.  Display the Customer Invoices report in Design View.

 2.  Choose Design→Controls→Subform/Subreport  (located at the bottom of the  
controls list).

 3.  Click just below the ZIP label to insert a control and launch the SubReport Wizard.

 4.  Choose InvoiceDetails Subform from the Use an Existing Report or Form option and 
click Next.

 5.  Click Next again to accept Choose from a List as the linking method.

 6.  Click Finish to accept InvoiceDetails Subform as the name.

 7.  Display the Property Sheet, if necessary, and click the Data tab.

 8.  Click the Format tab in the Property Sheet and set the following properties:

Property Setting
Width 5.6"

Height 1.5"

Top 2.9"

Left 0.5"
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Creating a Report from a Subreport 59

 9.  Click the InvoiceDetails Subform label, which should be just below the ZIP label, and set 
the following properties:

Label Property
Caption Invoice Details

Width 1.2"

Height 0.25"

Top 2.5"

Left 0.5"

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1, Darker 50%

 10.  Switch to Report View to see your completed report.

 11.  Use the record Navigation bar and the scroll bar to review the database records.

 12.  Close the report, saving the changes.

Creating a Report from a Subreport
Using a subform as the record source for a subreport is convenient because the subform already 
includes all of the needed data. However, when a subreport uses a form as the record source, any 
changes made to the subreport layout are reflected in the source form. If you don’t want the 
source form to be changed, you can save the subreport as a separate report in the database, 
change the main report’s Record Source property to the new report object, and then edit the 
subreport.

Access allows you to save an existing form as a new form, and an existing report as a new report. 
When a subform is used as the record source for a subreport, you can open the subreport in a 
separate window and save it as a separate report.

ÍÍ File→Save As→Save Object As
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60 FastCourse Access 2016 Chapter 4: Customizing Reports

DEVELOP YOUR SKILLS: A4-D3

In this exercise, you will create and save a new report based on the subreport from the Customer Invoice 
Report. You will then edit the source object property in the main report to display the new subreport.

 1.  Open InvoiceDetails Subform from the Forms section of the Navigation pane.

 2.  Choose File→Save As→Save Object As→Save As.

 3.  Type WWD Customer Invoices Subreport as the name, choose Report from the As 
drop-down list, and click OK.

 4.  Close InvoiceDetails Subform.

 5.  Open the new WWD Customer Invoices Subreport in Design View.

 6.  Display the Property Sheet, if necessary.

 7.  Click the All tab and type Customer Invoices Subreport as the caption.

 8.  Choose Design→Header/Footer→Title.

 9.  Type Winchester Web Design Invoice Details in the title control and tap [Enter].

 10.  Set the following property values for the new title control:

Property Setting
Width 3"

Height 0.25"

Left 1"

Font Name Arial

Font Size 12

Text Align Center

 11.  Click the Report Header section bar and set the Height property to 0.3".

 12.  Click the Report Selector button and set the Width property to 5.6".
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Numbering Items in a Report 61

 13.  Close the subreport, saving the changes.

 14.  Open the Customer Invoices report in Design View.

 15.  If necessary, display the Property Sheet and click the Data tab.

 16.  Click on the subreport to select it.

 17.  Click in the Source Object property box and choose Report.WWD Customer Invoices 
Subreport from the drop-down menu.

 18.  Switch to Report View to see how the new subreport looks.

 19.  Scroll through the report, seeing how the subreport always shows the correct invoice details.

 20.  Close the Customer Invoices report, saving the changes.

Numbering Items in a Report
As the number of records in a table grows, the length and number of records in a report or 
subreport also grows. You can number the records in a report to help track the items listed. If a 
report is grouped, you can set the count to restart numbering at the beginning of each group.

Setting Properties to Number Items
By adding a text box to the Detail section and setting its Control Source property to =1, you can 
automatically number items in a report. In addition, you can set the Running Sum property to 
identify the portion of a report for which you want to count items. For example, suppose you 
have an invoice report that groups services by invoice number. You can set the Running Sum 
property to count the items in each group and then start counting again with the next group.

Numbering Subreports Separately
Access does not permit numbering items in a subreport control on a main report. However, 
because you saved the subreport as a separate report, you can add the numbering controls 
directly to the subreport by opening it in a separate window. Any edits you make when it is open 
as a separate item are reflected in the main report the next time you open it.

DEVELOP YOUR SKILLS: A4-D4

In this exercise, you will reposition the controls in the Page Header of the WWD Customer Invoices 
Subreport and then add a text box control to count the number of line items.

 1.  Display the WWD Customer Invoices Subreport in Design View.

 2.  Right-click the Detail section bar and choose Page Header/Footer.

 3.  Click the Page Header section bar and change the Height property to 0.3".
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62 FastCourse Access 2016 Chapter 4: Customizing Reports

 4.  Select the ProdID label in the Detail section and use [Ctrl]+[X] to cut the control.

 5.  Click in the Page Header section and use [Ctrl]+[V] to paste the label.

 6.  With the ProdID label still selected, set both the Width and Left properties to 0.5".

 7.  Use the procedure in steps 4–6 to move the Description, Price, Qty, and LineTotal labels 
one at a time into the Page Header section, setting the Width and Left properties as follows:

Property Width Setting Left Setting
Description 2" 1.25"

Price 0.75" 3.5"

Qty 0.3" 4.5"

LineTotal 0.75" 5"

 8.  If necessary, click on the labels and use the up arrow [£] key to nudge them up until they are 
vertically aligned with the ProdID label as shown here.

 9.  Set these property values for the text boxes in the Detail section:

Text Box Control Width Top Left
ProdID 0.5" 0.1" 0.5"

ProdDescription 2" 0.1" 1.25"

Price 0.75" 0.1" 3.5"

Qty 0.3" 0.1" 4.5"

LineTotal 0.75" 0.1" 5"

 10.  Click the Detail section bar and set the Height property to 0.5".

 11.  Click the Selection Type menu button  at the top of the Property Sheet and choose 
Report.

 12.  Set the Width property to 6".

 13.  Switch to Report View.

 14.  Switch to Design View and choose Design→Controls→Text Box .

 15.  Click to the left of the ProdID text box in the Detail section to position the new box in  
that area.
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Creating Calculated Controls on a Subreport 63

 16.  Click the label of the new text box and tap [Delete] to remove it.

 17.  Click the new text box control and set these property values using the All tab in the 
Property Sheet:

Property Setting
Name txtCount

Width 0.3"

Top 0.1"

Left 0.1"

 18.  Click the Data tab and set the Control Source property to =1 and the Running Sum 
property to Over Group.

 19.  Switch to Report View and scroll through the report.

 20.  Close the WWD Customer Invoices Subreport, saving the changes.

 21.  Display the Customer Invoices report in Design View.

 22.  Click the InvoiceDetails Subform to select it and set the Width property to 6".

 23.  Switch to Print Preview and use the Navigation bar to review the various report pages. 

 24.  Close Print Preview and then close the Customer Invoices report, saving the changes.

Creating Calculated Controls on a 
Subreport

Reports summarize data contained in tables and queries to present useful, organized 
information. This typically means that calculated fields must be added to a report for subtotals, 
grand totals, and averages.

Positioning Calculated Controls
Calculated controls are built in reports by using the Control Source property of an unbound text 
box control to which you add a formula. The placement of the calculated control determines 
how Access performs the calculation.
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64 FastCourse Access 2016 Chapter 4: Customizing Reports

Calculated control in a Detail section 
performs a calculation for each detail line.

Calculated control in a Group Footer 
calculates the total for the group.

Calculated control in a Page Footer 
calculates the total for the page.

Calculated control in a Report Footer 
calculates the total for the entire report.

DEVELOP YOUR SKILLS: A4-D5 

In this exercise, you will add a calculated control to the Report Footer section of the WWD Customer 
Invoices Subreport.

 1.  Display the WWD Customer Invoices Subreport in Design View.

 2.  Click the Report Footer section bar and set the Height property to 0.3".

 3.  Choose Design→Controls→Text Box .

 4.  Click anywhere in the Report Footer section.

 5.  Click the All tab in the Property Sheet.

 6.  Set the following properties for the new control:

Property Setting
Name CustomerTotal

Control Source =Sum([Price]*[Qty])

Format Currency

Height 0.25"

Top 0"

Left 4.75"

 7.  Click the new text box label and set the following property values:

Property Setting
Caption Invoice Total

Width 1.2"

Height 0.25"

Top 0"

Left 3"

Fore Color Text Dark
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Setting Page Breaks and Customizing Controls 65

 8.  Close and save the changes to the subreport.

 9.  Display the Customer Invoices report in Report View.

Growing a Subreport
When the number of records or amount of data displayed in a subreport varies, you can set the 
Can Grow property setting to allow the subreport space to expand so more data displays 
vertically. You can also change the orientation of the print layout to allow more horizontal space 
on each report page. 

DEVELOP YOUR SKILLS: A4-D6 

In this exercise, you will adjust the margins of the Customer Invoices report and set the Can Grow and Can 
Shrink properties. These properties will adjust the size of the subreport to fit the contents.

 1.  Display the Customer Invoices report in Design View.

 2.  Choose Page Setup→Page Size→Margins→Narrow.

 3.  Click on the InvoiceDetails Subreport to select it.

 4.  Click the Format tab on the Property Sheet and, if necessary, set both the Can Grow and 
Can Shrink properties to Yes.

 5.  Choose File→Save to save the report.

 6.  Switch to Report View and scroll through the report.

Setting Page Breaks and Customizing 
Controls

As you view the Winchester Web Design Customer Invoices report in Report View, you may 
notice that the number of invoice records displayed on each screen varies depending on the 
number of items ordered. To ensure that each customer invoice starts on a new page, you can 
add a page break control. By default, when you view a report in Print Preview, data for each 
customer/record automatically appears on a separate page; however, multiple records appear on 
the same page when the report is displayed in Report View.

To add a title or general company information to an invoice, place title controls in the Page 
Header section rather than the Report Header, which only prints on the first page.

Positioning the Page Break Control
To ensure that each invoice record prints on a separate sheet of paper, you can set page breaks. 
When you set page breaks, add the break at the end of the Detail section so Access knows to 
start a new page before printing the next page header.

ÍÍ Design→Controls→Insert Page Break 
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66 FastCourse Access 2016 Chapter 4: Customizing Reports

DEVELOP YOUR SKILLS: A4-D7 

In this exercise, you will modify the Winchester Web Design Customer Invoice Report. You will add a title 
and the current date and set page breaks to print each invoice on a separate page.

 1.  Display the Customer Invoices report in Design View.

 2.  Click the Customer Invoice title in the Page Header and then click again just in front of 
Customer to position the insertion point there.

 3.  Type Winchester Web Design and then press [Shift]+[Enter] to force Customer Invoice to 
a second line.

 4.  Click in an empty part of the Page Header and then click the title box to select it.

 5.  Set the Width property to 4" and the Left property to 2".

 6.  Choose Design→Header/Footer→Date and Time .

 7.  Choose the MM/DD/YYYY date format, remove the check from the Include Time box, 
and then click OK.

 8.  Select the date control and press [Ctrl]+[X] to cut it from the Report Header.

 9.  Click the Page Header section bar and press [Ctrl]+[V] to paste the date into the Page 
Header.

 10.  Set the following properties for the date control:

Property Setting
Width 2"

Height 0.2"

Top 0.4"

Left 5.8"

 11.  Scroll down to the bottom of the Detail section.

 12.  Choose Design→Controls→Insert Page Break .

 13.  Place the page break in the Detail section just above the Page Footer section bar.

 14.  Switch to Print Preview and use the Navigation bar to browse the various pages.

 15.  Close Print Preview.

 16.  Choose File→Close to close the database and save the changes to the Customer Invoices 
report.

Before After
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Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1. Reports can be imported from other databases. True  False

2. Reports can be created from subreports. True  False

3. The Can Grow property allows a subreport to expand to accommodate a  
varying number of records. True  False

4. Page breaks are typically added to the Page Header section of a report. True  False

5. Which property is used to link an imported report to a table or query in the destination database?

A. Control Source

B. Caption

C. Record Source

D. Name

6. Which of these can a subreport display data from?

A. Table

B. Query

C. Form

D. All of these options

7. Which of these is used in the Control Source property to automatically number items in a report?

A. =1

B. =Num

C. Control Source

D. -Num

8. Which property is used to created calculated controls in reports?

A. Name

B. Control Source

C. Caption

D. Pop Up
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