
L E A R N I N G  O B J E C T I V E S

ÝÝ Add command buttons to forms

ÝÝ Manage database objects and create macros

ÝÝ Backup, restore, analyze, compact, and repair a 
database

ÝÝ Set database security using encryption and 
passwords

11 Maintaining a 
Database

ACCESS

A
s you prepare your database for 

distribution, you will make your 

last design tweaks and confirm 

that it is optimized for speed and ease of 

use. And at this stage, security should be a 

main priority. It is important to protect a 

database from data loss and unauthorized 

access. In this chapter, you will customize 

Access 2016 settings and add easy-to-use 

command buttons to a form. You will create 

macros, explore database security features, 

set a database password, and then analyze, 

compact, and repair an Access database.
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	 Project: Improving and Maintaining a Database
The prototype of the Winchester Web Design database is almost complete. After reviewing 
the database, the company’s owner is pleased with the overall design. He now wants to add 
some command buttons and macros to improve navigation and to ensure that the database 
runs as efficiently as possible.

A major concern is the security of the database and the data it contains. The owner would like 
to institute both security protocols and a regular backup policy. 

Using Command Buttons to Improve Navigation
In addition to adding labels, text boxes, images, and other controls to database forms, Access allows 
you to add command buttons that can be used for things such as record navigation and report opera-
tions. You can open a form, select the Button control from the Controls group on the Design tab, 
draw a button in the desired location on the form, and use the Command Button Wizard to add a 
custom button to find a record, go to the previous or next record, print a specific report, or even  
exit Access.

Develop Your Skills: A11-D1 

In this exercise, you will add command buttons to the Form Footer section of the Invoice Form to make 
navigation easier and to quickly view an invoice report.

1.	 Open A11-D1-WinWebDesign from your Access Chapter 11 folder and and save it as 
A11-D1-WinWebDesignRevised.

2.	 Enable content, if necessary.

3.	 Close  the Winchester Web Design Navigation Form.

4.	 Open the Invoice Form in Design View.

5.	 Click the Form Footer section bar and type 0.75" for the Height property on the Property 
Sheet.

Tap [F4] to toggle the Property Sheet open and closed.

6.	 Choose Design→Controls→Button .

7.	 Draw a button in the Form Footer under the left end of the subform.

If the Command Button Wizard doesn’t open, choose Design→Controls→Use Control Wizards.



Tip!
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8.	 Follow these steps to add a command button:

A
B

A	Choose the Record Navigation category.

B	Choose the Go to First Record action.

Your command button may show a different number (than 33).

9.	 Click Next and then click the Picture option, choose Go To First, and click Next.

10.	 Enter cmdFirst for the Meaningful Name and click Finish.

The command button shows the Go To First picture in the Form Footer section and is programmed to 
go to the first record when in Form View.

11.	 Repeat steps 6–10 to add, in the order listed, command buttons for Back (Go To Previous 
Record: cmdBack), Next (Go To Next Record: cmdNext), Last (Go To Last Record: cmdLast), 
and Find (Find Record: cmdFind).

12.	 Draw a button to the right of the Find button. When the Command Button Wizard opens, choose 
Report Operations and Preview Report and then click Next.

13.	 Select the Invoice Details Report as the Report to Preview and click Next.

14.	 Choose the MS Access Report picture, if necessary, and then click Next.
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15.	 Enter the name cmdPreviewInvoices and click Finish.

16.	 Select the new buttons and choose Arrange→Sizing & Ordering→Align→Top.

17.	 With the buttons still selected, choose Arrange→Size & Ordering→Size/Space→ 
Equal Horizontal.

18.	 Switch to Form View and test each button.

19.	 If necessary, close the Invoice Details Report and then save and close the Invoice Form.

Creating Macros to Improve Efficiency
A macro is an object that combines a series of steps into a single step so that a more detailed task 
can be automated. For example, if you regularly export your data to another database, instead of 
choosing External Data→Export→Text File and then entering the filename and selecting export 
options, you could create a macro to perform all the steps with one double-click of the mouse. 

The ExportCustomers macro exports the 
Customers table to the default My Documents 
folder as a text file. If needed, a specific file 
path could be entered for the output file.

The exported text file

Microsoft Access 2016   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Creating Macros to Improve Efficiency  267

Creating a macro starts from the same Ribbon path used to create other database objects: the 
Create tab. The next step is to select the action desired from the Add New Action drop-down menu.

ÍÍ Create→Macros & Code→Macro to create a macro

Develop Your Skills: A11-D2 

In this exercise, you will create a macro that will display a message box to provide basic directions on when 
and where to back up the Winchester Web Design database.

1.	 Choose Create→Macros & Code→Macro .

2.	 Choose MessageBox from the Add New Action drop-down menu.

3.	 Enter the following into the MessageBox text boxes:

4.	 Save the macro as Back Up Policy.

5.	 Choose Design→Tools→Run  to test the macro.

6.	 Click OK to close the message box.

7.	 Close the Back Up Policy macro.

Back Up Policy is now listed in the Navigation pane under the Macros group heading.

Using Macros to Display Adaptable Reports 
Now that you have created a simple macro to display a reminder message, you can add a command 
button to a form that will run a macro to display a report.

Develop Your Skills: A11-D3 

In this exercise, you will create a macro button that will be placed on the Employees Form to display a 
report of all the sales for the specific employee selected.

1.	 Choose Create→Macros & Code→Macro .

2.	 Choose OpenReport from the Add New Action drop-down menu.
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3.	 Click the Report Name menu  and choose Invoice Details Report.

4.	 Enter the following into the OpenReport text boxes:

As you start to enter in the Where Condition text box, Access will suggest field names from a drop-
down menu, allowing you to quickly and more accurately select from the list.

5.	 Save the macro as Invoice Details Report by Employee.

6.	 Display the Employees Form in Design View.

7.	 Choose Design→Controls→Button  and draw a button in the top-right corner of the 
Details section of the Employees Form.

The Command Button Wizard starts.

8.	 Choose the Miscellaneous category and then choose the Run Macro action.

9.	 Click Next and then choose Invoice Details Report by Employee.

10.	 Click Next, accept the default macro picture, and click Next again.

11.	 Name the button cmdRptByEmployees and click Finish.

12.	 Switch to Form View and navigate to Mike Waters (EmpID MJW).

13.	 Click the new Run Macro button to display all records in which the EmpID is MJW.

14.	 Close the report and form, saving the changes to the form.
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Managing Database Objects
Protecting databases and the quality of data they contain is vital to the reliability and performance 
of any database. At the same time, learning efficient ways to manage database objects helps to save 
a great deal of time as you build a database.

General Cleanup and Maintenance
The general cleanup and maintenance of a database can be accomplished in a number of ways. 
You can delete unneeded or duplicate database objects, rename database objects, and create new 
objects from existing objects.

Saving Database Objects As New Objects
You can use an existing file as a template for creating new files that may be similar in nature and 
format. For example, suppose you need to send each of your customers a letter that contains basi-
cally the same information. You can create the first letter, use the Save As command to save the 
original as a new file, and then edit the copy instead of having to retype all the information again. 

Creating New Objects from Existing Objects
Often, databases contain separate objects that are similar in structure and in the data they hold. 
For example, the Employees table in the Winchester Web Design database contains fields similar to 
those found in the Customers table. When you build a database that contains similar objects, you can 
copy the original object, save it using a new name, and then modify the new object to fit its specific 
needs. Access provides two basic processes for copying objects:

ÝÝ The Save Object As command opens the Save As dialog box and identifies the name of the object 
being copied along with an object type.

ÝÝ Right-click the object you want to copy and choose Copy. Then, right-click the object area in the 
Navigation pane and choose Paste.

Renaming Database Objects
There are times when you create a table, query, form, or report and save it with the first name that 
comes to mind. Then, after working with the object for a while, you might want a better name. To 
rename a database object, right-click the object and choose the Rename option. Access will auto-
matically rename all the relationships and record sources that use the renamed object. For instance, 
if you update the Invoices table to Orders, the record source for the queries, forms, and reports that 
are based on the table will be updated to reflect the new name. 

Deleting Database Objects
During the development of a database there are times when it is wise to create a temporary table, 
query, form, or report for testing purposes. Once the database is completed, you should remove 
these objects so they don’t clutter the Navigation pane or confuse users. To delete unwanted data-
base objects, either right-click an object and choose the Delete option from the pop-up menu or 
select the table, query, form, or report and simply tap the [Delete] key.
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Develop Your Skills: A11-D4 

In this exercise, you will copy a report, rename a report, and delete a report. Then, you will save a table in 
the Winchester Web Design database as a new table and edit the field names for the new table.

1.	 Right-click the Products Report in the Navigation pane and choose Copy.

2.	 Right-click again and choose Paste, keep Copy Of Products Report as the Report Name, and  
click OK.

3.	 Right-click Copy Of Products Report, choose Rename from the menu, type Delete This 
Report Later, and then tap [Enter].

4.	 Select the Delete This Report Later report in the Navigation pane.

5.	 Tap [Delete] and click Yes to confirm the deletion.

6.	 Open the Employees table.

7.	 Choose File→Save As→Save Object As→Save As.

8.	 Type Business Contacts in the Save ‘Employees’ To text box and click OK.

9.	 Switch to Design View.

10.	 Select and edit the Business Contacts field names, replacing each Emp prefix with a Bus prefix 
(so EmpID is BusID, and EmpLastName is BusLastName, and so on.).

11.	 Right-click the HireDate field, choose Delete Rows, and click Yes to confirm the decision.

12.	 Delete the WebCert field and then save the changes to the Business Contacts table.

13.	 Switch to Datasheet View to confirm your changes and then close the Business Contacts table.

Backing Up a Database
All databases should be safeguarded to protect their data. Most organizations have a scheduled 
procedure to back up all files on their network, including the databases.

When you back up a database using the built-in Access tools, Access automatically places the date 
of the backup in the filename so you can easily identify and retrieve each backup file. You choose 
the drive and folder in which you want to save the backup. To restore the database, simply open the 
backup.

Develop Your Skills: A11-D5 

In this exercise, you will back up your Winchester Web Design database.

1.	 Close any open objects in the Winchester Web Design database.

2.	 Choose File→Save As→Save Database As→Back Up Database and then click the  
Save As button.

Access opens the Save As dialog box and adds the current date to the end of the filename.
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3.	 Save the file in your Access Chapter 11 folder.

Access saves the backup file to the desired location; however, the database file in use is still the original 
Winchester Web Design database. 

4.	 Close the database, navigate to your Access Chapter 11 folder, and open the backup database. 

A backup is only as current as the time the backup was created. It’s important to have a policy that 
schedules and mandates a daily or weekly backup.

5.	 Close the backup database and reopen A11-D1-WinWebDesignRevised.

Analyzing and Documenting Databases
Each time you change the design or content of a database, the chance that the database will become 
corrupted increases. Access contains several tools that help you protect, document, analyze, and 
even repair databases. The main tools found in the Analyze group on the Database Tools tab are:

ÝÝ Performance Analyzer: Analyzes the performance of a database to locate and identify potential 
trouble spots that affect how the database functions.

ÝÝ Database Documenter: Documents objects in the database so that you can track changes to 
the design and relationships in the database; builds an Object Definition document that provides a 
detailed description of each database object. 

Reviewing and Analyzing Performance 
When you run the Performance Analyzer, Access reviews each selected object in the database, looks 
at all the relationships that exist, and identifies any problems that might affect database perfor-
mance. Access often makes recommendations for improvements to optimize the efficiency of the 
database. In some cases, Access identifies tables in which no primary key is set. In other cases, Access 
will suggest a more efficient data type or that you use fewer controls on a form.

However, some changes recommended by the Performance Analyzer may not be necessary. For 
example, Access frequently recommends that phone numbers be formatted using the Number data 
type. Not only is this unnecessary, it may even cause problems for extensions that are commonly 
preceded by an X, such as X209. As you review the recommended changes, you will begin to identify 
those requiring your attention and those you can ignore.

Two options for analyzing database performance are available. The Analyze Performance tool 
enables you to choose those objects that you want to analyze. The Analyze Table tool analyzes a 
table using the Table Analyzer Wizard.

Documenting a Database
As you plan a new database you must analyze the needs of the business and the requirements of the 
database. In the process, you create a list of fields required and then organize and group those fields 
into the tables that will provide the data for forms, queries, and reports. The list identifies and defines 
each field and the tables and objects in which the fields are used within the database. When the 
database is finished, you may choose to document the database so that it can be efficiently updated 
and maintained in the future. 
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Documentation provides insight into the structure of the entire database as well as the structure 
of each object within the database. Maintaining a database can be very time-consuming. Without 
proper documentation to identify potential impacts of changing field properties, object structures, 
and so forth, you can potentially corrupt one database object that, in turn, wreaks havoc in the entire 
database. Each time you change the structure of any database object, remove an object from, or add 
an object to the database, you should run the Database Documenter to provide up-to-date docu-
mentation about the database. Such information will prove invaluable to database administration. 

Develop Your Skills: A11-D6 

In this exercise, you will analyze and document your Winchester Web Design database.

1.	 Choose Database Tools→Analyze→Analyze Performace .

The Performance Analyzer opens.

2.	 Click the Tables tab and click Select All to check all the tables listed.

3.	 Click OK and view the suggestions under Analysis Notes.

The data types have been set properly, so you can ignore the suggested ideas.

4.	 Click Close.

5.	 Choose Database Tools→Analyze→Database Documenter .

The Documenter opens.

6.	 Click the Tables tab, check the InvoiceDetails, Invoices, and Products tables, and then  
click OK.

Access produces a report that is about a dozen pages long documenting the tables, fields, and 
relationships of the selected tables.

7.	 Scroll through the report and examine the documentation provided.

8.	 Close Print Preview and then choose Data→Excel  to export the report to an Excel 
spreadsheet.

9.	 Check the Open the Destination File After the Export Operation is Complete box, if 
necessary.

10.	 Click Browse, navigate to your Access Chapter 11 folder, type A11-D6-Objects as the file-
name, click Save, and then click OK.

11.	 Browse through the Excel spreadsheet and close it when finished.

12.	 Close the Export – Excel Spreadsheet Wizard, without saving the export steps, and then 
close the Print Preview.

Compacting and Repairing a Database
When you delete a record in Access, it is not really deleted—it is marked for deletion. The process of 
marking a record as deleted is quicker than completely deleting and reordering or rewriting all the 
records in a table. A similar process is used when you shorten the contents of a record—the space 
that was used for the longer data is not released. 

Microsoft Access 2016   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Setting Database Security  273

As you work with databases, they can also become sluggish and the data stored in the databases can 
become fragmented—that is, parts of your database file become separated by incidental data that 
has been added to the disk you are using. For example: If you saved a ten megabyte database file to 
your hard drive and saved an Excel spreadsheet to the same hard drive shortly afterwards, it would 
be written next to the ten megabyte database file. Then, if a large group of new records were added 
to the database file, they would have to be stored after the Excel file and not after the original data-
base file, because the adjacent space is now occupied by the spreadsheet. As you add more records 
and save other files, both your files and storage drive become fragmented and less efficient.

Consequently, over time databases can become bulky and inefficient. This issue can be resolved by 
compacting—or compressing—your database to remove wasted and unused space left from deleted 
and edited records. 

To ensure optimal performance, Access enables you to compact and repair databases as often as you 
want. Sometimes Access recognizes a problem when a database is opened and attempts to repair 
the file before you work with it. Even if there is no file corruption, the normal maintenance tasks of 
adding, deleting, and editing records, creating and running queries, and so forth, may reduce data-
base performance. As a result, you may want to compact and repair the database manually on a 
regular basis, or set an option to automatically compact the database whenever you close Access.

Develop Your Skills: A11-D7 

In this exercise, you will compact and repair your Winchester Web Design database.

1.	 Close any open database objects.

2.	 Choose Database Tools→Tools→Compact and Repair Database .

Access compacts and repairs the file. Because the database is relatively small, the compact and repair 
process takes only a moment. For larger databases, the process will take longer. 

3.	 Close A11-D1-WinWebDesignRevised and exit Access.

Setting Database Security
Imagine that your doctor stores all your medical records in a large database that could be accessed 
by hospitals, clinics, and medical insurance companies who want to know more about the medications 
you take, conditions you might have, and doctor’s visits. Databases, by nature, often hold confidential 
information. As a result, security is imperative. Companies that maintain large database files often 
restrict access to databases at the login or server level. Splitting a database can protect the data 
contained in databases, and Access offers tools that enable you to secure a database by assigning a 
password.

Opening a Database Exclusively
Most large business databases are designed to provide access to multiple users at the same time. As a 
result, the default setting for a database is as a shared file. Before you can set security for a database, 
you must first ensure that no one else is currently using the database. You do this by opening the file 
exclusively so that Access locks the database and prevents others from accessing it at that time.
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Opening Database Commands
The Open dialog box contains numerous commands for opening databases after a file has been 
selected. The following table identifies and describes when you should use each command on the 
Open drop-down menu.

COMMANDS FOR OPENING DATABASES

Command Description

Open Provides full and typical access to the database, its objects and menus, 
so you can create and edit.

Open Read Only Opens the database so that you can view and print data but does not 
allow design changes. However, you can save the database as a new file 
and edit the new file. 

Open Exclusive Opens the database and locks it to prevent other users in a shared 
environment from accessing the database.

Open Exclusive 
Read-Only

Opens the database and locks it so other users cannot access it and 
prevents edits to data and database objects.

Develop Your Skills: A11-D8 

In this exercise, you will open the Winchester Web Design database exclusively.

1.	 If necessary, start Access; close A11-D1-WinWebDesignRevised if it is open.

2.	 Choose File→Open, navigate to your Access Chapter 11 folder, and click  
A11-D1-WinWebDesignRevised but do not open the database. 

3.	 Click the Open menu  and choose Open Exclusive, enabling content if necessary.

Encrypting a Database Using a Password
Regardless of whether a backup routine is in place, valuable time can be lost reconstructing data if 
unauthorized users damage the database. Database passwords are intended to protect the database 
just as the passwords you use to access bank accounts or email accounts protect your financial and 
personal information. 

Limits of Passwords
Database passwords provide limited security for databases by preventing unauthorized users from 
opening the database. You can set a password for any database you have on your personal computer, 
just as systems administrators set a password for shared databases on a network. 

Access passwords are case sensitive, or capable of distinguishing between characters typed in uppercase 
and characters typed in lowercase. 

Tip!
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Strong Passwords
Access passwords can use a combination of upper- and lowercase characters, symbols, and numbers. 
Access allows you to use any combination of characters in passwords except “ \ [ ] : | <→ + = ; , . ? and *. 
Strong passwords are at least eight characters long and contain at least one of each of the character 
types listed above. Passwords cannot start with a space.

Weak Password: webdesign

Strong Password: Hard2Cr@ck

Setting Up Databases for Assigning Passwords
To assign a database password, the database must initially be closed. The default access setting for 
databases that appear on a network is as a shared database, accessible to anyone who has access to 
its file location. To set a password, you must open the database exclusively using the Open Exclusive 
command in the Open dialog box. This ensures that no one else is currently using the database and 
that, once you open it, other users are prohibited from opening it until you close it. If the file is not 
opened exclusively, you will get a warning message.

The Encrypt with Password command on the File menu is a toggle command. When a database has a 
password, the command button shows Decrypt Database. 

Develop Your Skills: A11-D9 

In this exercise, you will set a database password to protect the database.

Your Winchester Web Design database should be open in exclusive mode.

1.	 Choose File→Info→Encrypt with Password.

2.	 Type labyrinth in the Password text box and type labyrinth again in the Verify text box, 
then click OK.

3.	 Click OK to acknowledge that row level locking will be ignored.

4.	 Close A11-D1-WinWebDesignRevised and then open it again.

If you forget your password, you will not be able to open your database.

5.	 In the Password Required dialog box, type labyrinth in the Enter Database Password text 
box and then click OK.

You must open the database exclusively again if you want to change or remove the password.

6.	 Close A11-D1-WinWebDesignRevised and exit Access.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment on the 
Student Resource Center.

Note!

Warning!
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS A11-R1

Add Command Buttons, Create a Macro, and Manage Objects
In this exercise, you will wrap up some of the final tasks associated with the Kids for Change database. 
You will add command buttons to the Activities Form, create macros to increase efficiency, and do some 
cleanup tasks by copying, renaming, and deleting objects.

1.	 Start Access, open A11-R1-K4C from your Access Chapter 11 folder, close any open objects, 
and then save the file as A11-R1-K4CRevised.

Add Command Buttons to a Form
2.	 Enable content then close the K4C Navigation Form, if necessary.

3.	 Open the Activities Form in Design View and open the Property Sheet, if necessary.

4.	 Click the Form Footer section bar. Type 0.75" for the Height on the Property Sheet.

5.	 Choose Design→Controls→Button  and draw a button in the Form Footer under the 
Telephone label.

The Command Button Wizard opens.

6.	 Under Record Navigation, choose the Go To First Record action. Click Next.

The wizard displays a sample button picture for each action.

7.	 Click the Picture option, choose Go To First, and click Next.

8.	 Enter cmdFirst for the Meaningful Name and click Finish.

The command button shows the Go to First image in the Form Footer section and is programmed to 
go to the first record when in Form View.

9.	 Add, in the order listed, command buttons for Previous (Go To Previous Record: cmdPrevious), 
Next (Go To Next Record: cmdNext), Last (Go To Last Record: cmdLast), and Find (Find Record: 
cmdFind).

The command buttons should appear in the order shown.

10.	 Draw a button to the right of the Find button. When the Command Button Wizard opens, choose 
Report Operations and Preview Report. Click Next.

11.	 Select the Activity Costs Report as the Report to Preview and click Next.

12.	 Choose the Preview picture on the next screen, if necessary, and click Next.

13.	 Enter the name cmdPreviewCosts and click Finish.

14.	 Select the new command buttons and choose Arrange→Sizing & Ordering→Align Top.

All of the command buttons are aligned to the top.


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15.	 With all the buttons selected, choose Arrange→Size & Ordering→Size/Space→ 
Equal Horizontal.

16.	 Switch to Form View and test each of the new buttons.

17.	 Close the Activity Costs Report; save and close the Activities Form.

Create a New Macro
18.	 Choose Create→Macros & Code→Macro  to create a macro that displays a reminder 

message.

19.	 Choose MessageBox from the Add New Action drop-down menu.

20.	 Enter the following:

21.	 Save the macro as Back Up Routine.

22.	 Choose Tools→Run .

The Back Up Routine Information message box opens.

23.	 Click OK to close the message box. Close the Back Up Routine macro.

Back Up Routine is now listed under Macros in the Navigation pane.

Create a Macro to Display Adaptable Reports
24.	 Choose Create→Macros & Code→Macro .

25.	 Choose OpenReport from the Add New Action menu.

26.	 Choose Volunteers Report from the Report Name menu.

27.	 Choose Report for the view type.

28.	 Type [ActID]=[Forms]![Activity Staffing]![ActID] for the Where Condition.

29.	 Save the macro as Available Volunteers and close it.

30.	 Display the Activity Staffing form in Design View.

31.	 Choose Design→Controls→Button  and draw the new button to the right of the Day and 
Meet Time controls.

32.	 Choose the Miscellaneous category and the Run Macro action.

33.	 Click Next then choose Available Volunteers.

34.	 Click Next, accept the default macro picture, and click Next again.

35.	 Name the button VolunteersMacro and click Finish.

36.	 Switch to Form View.
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37.	 Click the new VolunteersMacro button.

The macro button displays the Volunteers Report record for the activity on the form. 

To display the Volunteers Report for another activity, close the report, navigate to the desired activity, 
and click the macro command button.

38.	 Close the Volunteers Report; save and close the Activity Staffing form.

Rename, Delete, and Save Object As a New Object
39.	 Right-click Venues Report in the Navigation pane and choose Copy.

40.	 Right-click again and choose Paste. Type Delete This Report as the report name and 
click OK.

41.	 Select Delete This Report in the Navigation pane.

42.	 Tap [Delete]; click Yes to confirm the deletion.

43.	 Open the PaidStaff table.

44.	 Choose File→Save As→Save Object As→Save As. 

45.	 Type Professional Contacts in the Save ‘PaidStaff’ To text box and click OK.

46.	 Display the new Professional Contacts table in Design View.

47.	 Edit the field names in the Professional Contacts table, replacing each Staff prefix with a Prof 
prefix (so that StaffID is ProfID, etc.).

48.	 Right-click the Parent field and choose Delete Rows; confirm the deletion.

49.	 Delete the Masters, ActID, and HrlySal fields. Click Yes to permanently delete the fields and 
to delete the ActID indexes.

50.	 Rename Email Address as ProfEmail.

51.	 Save and close the Professional Contacts table, close the database, and exit Access.

REINFORCE YOUR SKILLS A11-R2

Perform Database Maintenance and Set a Password
In this exercise, you will perform some maintenance procedures on the Kids for Change database. You will 
also add a password to protect the data from unauthorized users.

1.	 Start Access, open A11-R2-K4C from your Access Chapter 11 folder, close any open objects, 
and then save the file as A11-R2-K4CRevised.

Back Up a Database
2.	 Enable content and close the K4C Navigation Form.

3.	 Choose File→Save As→Save Database As→ .

4.	 Click the Save As button.

5.	 Navigate to your Access Chapter 11 folder and click Save.

6.	 Return to your Access Chapter 11 folder and open the backup database to confirm that you 
can access it. Close the backup database.
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Analyze and Document a Database
7.	 Choose Database Tools→Analyze→Analyze Performace .

8.	 Click the Tables tab and click Select All to check all the tables listed.

9.	 Click OK and view the Analysis Results.

Because the data types have already been set properly, you can ignore the suggested ideas.

10.	 Click Close.

11.	 Choose Database Tools→Analyze→Database Documenter .

12.	 Click the Tables tab, check the Activities and PaidStaff tables, and click OK.

The report documents the tables, fields, and relationships of the selected tables.

13.	 Choose Data→More→Word  to export the report to a Word RTF.

14.	 Browse to your Access Chapter 11 folder, type A11-R2-Tables.rtf as the filename, check 
the Open the Destination File After the Export Operation is Complete box, and click OK.

Access creates and opens the Word document.

15.	 Page through the Word document. Then close it and exit Word.

16.	 Close the Export – RTF File dialog box without saving the export steps and then close Print 
Preview.

Compact and Repair a Database
17.	 Close any open database objects.

18.	 Choose File→Info→Compact & Repair Database .

Access has compacted and repaired the file. The K4C Navigation Form might open, depending on 
your system.

19.	 Close A11-R2-K4CRevised and exit Access.

Open a Database for Exclusive Use
20.	 Start Access and choose Open Other Files, navigate to your Access Chapter 11 folder, and 

click A11-R2-K4CRevised—but do not open it.

21.	 Click the Open menu  and choose Open Exclusive.

22.	 Enable content, if necessary when the database opens.

No one else will be able to use the database until you exit Access.

Set a Database Password
Because you opened the database exclusively, you can set a password to open the database.

23.	 Choose File→Info→Encrypt with Password.

24.	 Type labyrinth as the password. Verify the password by typing it again and then click OK.

25.	 Click OK to acknowledge the message about row-level locking.

26.	 Close A11-R2-K4CRevised and then open it again.

Access displays the Password Required dialog box. 

27.	 Type labyrinth in the text box and click OK.

28.	 Close the database and exit Access.
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	 Apply Your Skills
Apply Your Skills A11-A1

Add Command Buttons, Create a Macro, and Manage Objects
You have to perform maintenance on the Universal Corporate Events database. In this exercise, you will 
add command buttons to the Wage and Salary Form and create macros to increase efficiency. You will 
also clean up some of the database objects to ensure that the database runs smoothly.

1.	 Start Access, open A11-A1-UCE from your Access Chapter 11 folder, close any open objects, 
and then save the file as A11-A1-UCERevised.

Add Command Buttons to a Form
2.	 Enable content and close the UCE Navigation Form, if necessary.

3.	 Open the Wage and Salary Form in Design View.

4.	 Click the Form Footer section bar and type 0.75" for the Height property on the Property 
Sheet.

5.	 Draw a button in the Form Footer under the Detail section labels.

6.	 In the Record Navigation category, choose Go To First Record and click Next.

7.	 Click the Picture option, choose Go To First, and click Next.

8.	 Enter cmdFirst for the Meaningful Name and click Finish.

The command button is programmed to go to the first record when in Form View.

9.	 Add, in the order listed, command buttons for Go To Previous Record: cmdPrevious, Go To 
Next Record: cmdNext, Go To Last Record: cmdLast, and Find Record: cmdFind.

10.	 Draw a button to the right of the Find button. In the Command Button Wizard, choose Report 
Operations and Preview Report and click Next.

11.	 Select the Wage and Salary Report as the Report to Preview, and click Next.

12.	 Choose the Preview picture, if necessary, and click Next.

13.	 Enter the name cmdPreviewReport and click Finish.

14.	 Select all new command buttons and choose Arrange→Sizing & Ordering→ Align→Top. 
Then choose Arrange→Size & Ordering→Size/Space→Equal Horizontal.

15.	 Switch to Form View and test the buttons.

16.	 Close the Wage and Salary Report.

17.	 Save and close the Wage and Salary Form.

Create Macros
18.	 To add a macro for a backup reminder, choose Create→Macros & Code→Macro .

19.	 Choose MessageBox from the Add New Action drop-down menu.

20.	 Use Back up work to the OneDrive on Friday as the message, choose 
Information for the type, and use Back Up Policy for the title.


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21.	 Save the macro as Back Up Policy and then run it.

22.	 Click OK to close the information box then close the Back Up Policy macro.

23.	 Choose Create→Macros & Code→Macro .

You will create a macro that opens the Event Revenue Report for the Event ID shown on the form.

24.	 Choose OpenReport for the Add New Action.

25.	 Choose Event Revenue Report for the Report Name and Report for the View.

26.	 Type this text for the Where Condition:[Forms]![Event Costs]![EventID]=[Event 
Revenue]![EventID]

27.	 Save the macro as Event Revenue by Name and then close it.

28.	 Display the Event Costs form in Design View.

29.	 Draw a new button under the Cost Details label.

30.	 Choose the Miscellaneous category and then choose the Run Macro action.

31.	 Click Next and choose your new Event Revenue by Name macro.

32.	 Click Next, accept the default macro picture, and click Next again.

33.	 Name the button cmdEventRevenue and click Finish.

34.	 Switch to Form View and navigate to the first record with an Event ID of BUSMTG.

35.	 Click the new Run Macro button and enter BUSMTG in the pop-up box.

The revenue report for this event is displayed. You can display the report for other Event IDs by 
navigating to the event, running the macro, and entering the Event ID in the pop-up box.

36.	 Close the Event Revenue Report; save and close the Event Costs form.

Rename, Delete, and Save an Object as a New Object
37.	 Right-click the Personnel Report in the Navigation pane and choose Copy.

38.	 Right-click Personnel Report again, choose Paste, and then click OK.

39.	 Right-click Copy Of Personnel Report, choose Rename, and change the name to Delete 
This Report.

40.	 Make sure Delete This Report is selected and then tap [Delete] and click Yes to confirm the 
deletion.

41.	 Open the Menus table.

42.	 Choose File→Save As→Save Object As and click the Save As button.

43.	 Type Products in the Save ‘Menus’ To text box and click OK.

44.	 Display the new Products table in Design View.

45.	 In the Products table, change MenuCode to ProdCode, MenuPlan to ProdPlan, change 
ChgPP to Cost, and CostPP to Price.

46.	 Save and close the new Products table.

47.	 Close the database and exit Access, choosing Yes to empty the Clipboard.
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Apply Your Skills A11-A2

Perform Database Maintenance and Set a Password
The UCE database requires regular tune-ups to run smoothly. In this exercise, you will perform some 
maintenance procedures to reduce wasted space, defragment objects, and improve efficiency. You will also 
add a password to protect data from unauthorized users. 

1.	 Start Access, open A11-A2-UCE from your Access Chapter 11 folder, close any open objects, 
and then save the file as A11-A2-UCERevised.

Back Up a Database
2.	 Enable content and close the UCE Navigation Form.

3.	 Choose File→Save As→Save Database As→Back Up Database  →Save As. 

The current date is added to the end of the database filename.

4.	 Save the file in your Access Chapter 11 folder.

5.	 Open the backup database to confirm that you can access it and then close the backup 
database.

Analyze, Document, Compact, and Repair a Database
6.	 Choose Database Tools→Analyze→Analyze Performace .

7.	 Click the Tables tab and click Select All to check all the tables listed.

8.	 Click OK to view the information presented and then click Close.

9.	 Choose Database Tools→Analyze→Database Documenter .

The Documenter opens.

10.	 Click the Tables tab, check the Menus and Schedules tables, and click OK.

Access generates a report for the tables, fields, and relationships of the selected tables.

11.	 Page through the report and examine the documentation provided.

12.	 Choose Data→More→Word  to export the documentation to Word.

13.	 Browse to your Access Chapter 11 folder, use A11-A2-MenuSched.rtf as the filename, and 
click Save.

14.	 Check the Open the Destination File After the Export Operation is Complete box and  
click OK.

15.	 Exit Word. Close the Export – RTF File dialog box without saving the export steps and close 
Print Preview. Close any open database objects.

16.	 Choose Database Tools→Tools→Compact and Repair Database .

17.	 Close the database.

Open a Database for Exclusive Use and Set a Database Password
18.	 Navigate to your Access Chapter 11 folder and click A11-A2-UCERevised—but do not open it.

19.	 Click the Open menu  and choose Open Exclusive.
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20.	 Enable content, if necessary.

21.	 To set a password for the database, choose File→Info→Encrypt with Password.

22.	 Type labyrinth as the password, verify the password, and click OK.

23.	 Click OK to acknowledge the encrypting message.

24.	 Close and reopen A11-A2-UCERevised, entering the password when prompted.

25.	 Close the database and exit Access.
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