
L E A R N I N G  O B J E C T I V E S

ÝÝ Import a report into a database

ÝÝ Add a subreport to a main report

ÝÝ Create a report from a subreport

ÝÝ Create calculated controls on a subreport

ÝÝ Set page breaks in reports

ÝÝ Add a chart to a report

8 Customizing Reports

ACCESS

D
atabase reports summarize 

the data contained in tables 

or displayed in query results 

and enable you to provide information in a 

page layout suitable for printing. Although 

forms and reports serve different purposes 

within the context of a relational database, 

the techniques used to customize them 

are similar. In this chapter, you will import 

reports from other databases and use 

features to create custom reports.
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	 Project: Billing Customers
The company manager of Winchester Web Design, a small web page design company, wants 
you to improve its invoice report for customer billing. After reviewing invoices from several 
companies, the company manager has sketched out a design for the new invoice report layout. 
Your job is to create a sample of the new invoice report for the company’s executive team.

Importing a Report into a Database
Access offers a variety of ways to create reports. In addition to using the Report Wizard or starting 
from scratch in Design View, you can import reports from another database. Because most compa-
nies require some type of invoice to send with customer orders, locating a sample invoice report to 
import is not difficult.

Sometimes you have the report you want, but during its design it may have become corrupted, either 
due to inadvertent changes to the report itself or because of changes to an underlying query. That’s 
when backups are invaluable. If a report becomes corrupted, you can restore it by importing data-
base objects from a backup copy of a database. The record source should already match, and there 
should be no need to edit the properties or the field names.

Identifying Report Record Sources
Reports you import retain two connections to their original database. The first is the source database 
table or query name, shown in the Record Source property, and the second are the field names, which 
appear in report text boxes. As a result, when you import a report from another database, you often 
must establish new control sources to the destination database. You can accomplish this by:

ÝÝ Editing the imported report’s Record Source property to link to a table or query in the destination 
database.

ÝÝ Editing, if necessary, the field names in the imported report’s text boxes to match those in the new 
record source table or query.

ÍÍ External Data→Import & Link→New Data Source→From Database→Access 

DEVELOP YOUR SKILLS: A8-D1

In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

	 1.	 �Open A8-D1-WinDesign from your Access Chapter 8 folder and save it as: 
A8-D1-WinDesignRev

	 2.	 �Look in the Reports section in the Navigation pane and notice the database contains three 
reports.

	 3.	 �Choose External Data→Import & Link→New Data Source→From Database→Access .

The Get External Data – Access Database dialog box appears.

	 4.	 �Click the Browse button and navigate to your Access Chapter 8 folder.


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	 5.	 �Choose the file A8-D1-WinDesign-Backup and click Open.

This database is a backup copy of the WinDesign database.

	 6.	 �Leave the Import tables, queries, forms, reports storage setting selected and click OK.

Access opens the Import Objects dialog box and displays object names contained in the backup 
database in tabbed groups.

	 7.	 �Click the Reports tab, choose Customer Invoices, and click OK.

	 8.	 �Leave the Save Import Steps box unchecked and click Close.

The Customer Invoices report is added to the Reports section of the Navigation pane.

	 9.	 �Double-click the Customer Invoices report to open it in Report View.

	10.	 �Scroll down as necessary to see the empty space between the customer information and  
signature blocks.

This is a great spot to insert a subform/subreport that includes the invoice detail lines.
 

Adding a Subreport to a Main Report
Subreports display subsets of data in reports and are derived from related database tables, similar 
to subforms on forms. However, a subreport can display table data by using a table, query, form, or 
another report as its source object. Forms are frequently created before reports and often already 
display the required report data. To streamline the report design and layout, it’s best to use a 
subform as the basis of a subreport.
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This invoice report uses a subform to display invoice details.

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add  
a subform to a form. You can create the subreport using the Report Wizard or add an unbound 
subreport control to the report. Then you identify the database object containing the fields you  
want to display as a subreport.

View the video “Adding a Subreport Using the Wizard.”

ÍÍ Report Design Tools→Design→Controls→Subform/Subreport 

DEVELOP YOUR SKILLS: A8-D2

In this exercise, you will add a subreport to the Customer Invoices report. You will use the InvoiceDetails 
subform as the source for the subreport.

	 1.	 �Display the Customer Invoices report in Design View.

	 2.	 �Choose Report Design Tools→Design→Controls→Subform/Subreport  (at the bottom 
of the controls list).
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	 3.	 �Click just below the ZIP label to insert a control and launch the SubReport Wizard.

	 4.	 �Choose the Use an Existing Report or Form option.

	 5.	 �Choose InvoiceDetails Subform from the list and click Next.

	 6.	 �Click Next again to accept the Choose from a list linking method.

	 7.	 �Click Finish to accept InvoiceDetails Subform as the name.

The subform is inserted in the report.

Set Properties
	 8.	 �Display the Property Sheet, if necessary, and click the Data tab.

Notice the Source Object is set to Form.InvoiceDetails Subform.

	 9.	 �Switch to the Format tab in the Property Sheet and set these properties:

Property Setting

Width 5.6

Height 1.5

Top 2.9

Left 0.5

	10.	 �Click the InvoiceDetails Subform label, which is just below the ZIP label, and set these 
properties:

Property Setting

Caption Invoice Details

Width 1.2

Height 0.30

Top 2.5

Property Setting

Left 0.5

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1, Darker 50%
A
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	11.	 �Switch to Report View to see your completed report.

	12.	 �Use the Navigation bar and the scroll bar to review the database records.

The information in both the report and the subform changes each time a new record is displayed.

	13.	 �Close the report, saving the changes.

Creating a Report from a Subreport
Using a subform as the record source for a subreport is convenient because the subform already 
includes the needed data. However, when a subreport uses a form as the record source, any changes 
made to the subreport layout are reflected in the source form. If you don’t want the source form 
to be changed, you can save the subreport as a separate report in the database, change the main 
report’s Record Source property to the new report object, and then edit the subreport.

Access allows you to save an existing form as a new form and an existing report as a new report. 
When a subform is used as the record source for a subreport, you can open the subreport in a sepa-
rate window and save it as a separate report.

ÍÍ File→Save As→Save Object As→Save As

DEVELOP YOUR SKILLS: A8-D3

In this exercise, you will create and save a new report based on the subreport from the Customer Invoices 
report. You will then edit the source object property in the main report to display the new subreport.

	 1.	 �Open InvoiceDetails Subform from the Forms section of the Navigation pane.

	 2.	 �Choose File→Save As, choose Save Object As from the File Types list, and then click the Save 
As button in the right pane.

	 3.	 �Type WWD Customer Invoices Subreport as the name, choose Report from the As 
drop-down list, and click OK.

A new report is added to the Reports section of the Navigation pane.

	 4.	 �Close the InvoiceDetails Subform.

	 5.	 �Open the new WWD Customer Invoices Subreport in Design View.

	 6.	 �Display the Property Sheet, if necessary, and then click the All tab and type Customer 
Invoices Subreport as the caption.

Create a Title for the Subreport
	 7.	 �Choose Report Design Tools→Design→Header/Footer→Title.

Access places a title and empty placeholder controls in the Report Header.

	 8.	 �Type Winchester Web Design Invoice Details in the title control and tap [Enter].
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	 9.	 �Set these property values for the new title control:

Property Setting

Width 3

Height 0.25

Left 1

Font Name Arial

Font Size 12

Text Align Center

	10.	 �Click the Report Header section bar and set the Height 
property to: 0.3069

Inserting the title in the header widens the subreport, so you 
will now reset the width.

	11.	 �Click the report selector button and set the Width prop-
erty to: 5.6

	12.	 �Close the subreport, saving the changes, and then open the Customer Invoices report in 
Design View.

	13.	 �If necessary, display the Property Sheet and click the Data tab.

	14.	 �Click the subreport to select it.

	15.	 �Click in the Source Object property box.

A drop-down menu button appears at the far 
right of the property box.

	16.	 �Choose Report.WWD Customer Invoices 
Subreport from the drop-down menu.

	17.	 �Switch to Report View to see how the new 
subreport looks.

Notice the change in appearance compared to 
the subform used previously.

	18.	 �Scroll through the report, seeing how the subreport always shows the correct invoice details.

	19.	 �Close the Customer Invoices report, saving the changes.

A
C

C
E

S
S

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



238  Access Chapter 8: Customizing Reports

Numbering Items in a Report
As the number of records in a table grows, the length and number of records in a report or subreport 
also grows. You can number the records in a report to help track the items listed. If a report is grouped, 
you can set the count to restart numbering at the beginning of each group.

Setting Properties to Number Items
By adding a text box to the Detail section and setting its Control Source property to =1, you can 
automatically number items in a report. In addition, you can set the Running Sum property to identify 
the portion of a report for which you want to count items. For example, suppose you have an invoice 
report that groups services by invoice number. You can set the Running Sum property to count the 
items in each group and then start counting again with the next group.

Numbering Subreports Separately
Access does not permit numbering items in a subreport control on a main report. However, because 
you saved the subreport as a separate report, you can add the numbering controls directly to the 
subreport by opening it in a separate window. Any edits you make when it is open as a separate item 
are reflected in the main report the next time you open it.

DEVELOP YOUR SKILLS: A8-D4

In this exercise, you will reposition the controls in the WWD Customer Invoices Subreport page header 
and add a text box control to count the number of line items.

	 1.	 �Display the WWD Customer Invoices Subreport in Design View.

	 2.	 �Right-click the Detail section bar and choose Page Header/Footer.

You will add labels to the Page Header section.

	 3.	 �Click the Page Header section bar and change the Height property to: 0.3

	 4.	 �Select the ProdID label in the Detail section and use [Ctrl]+[X] to cut the control.

	 5.	 �Click in the Page Header section bar and use [Ctrl]+[V] to paste the label.

	 6.	 �With the ProdID label still selected, set both the Width and Left properties to: 0.5

	 7.	 �Use the procedure in steps 4–6 to move the Description, Price, Qty, and LineTotal labels one 
at a time into the Page Header section, setting the Width and Left properties as follows:

Property Width Left

Description 2 1.25

Price 0.75 3.5

Qty 0.3 4.5

LineTotal 0.75 5

	 8.	 �If necessary, click the Description, Price, Qty, and LineTotal labels and use the up arrow [£] 
key to nudge them so they’re vertically aligned with the ProdID label.
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Move and Resize Report Text Box Controls
	 9.	 �Set these property values for the text boxes in the Detail section:

Text Box Control Width Top Left

ProdID 0.5 0.1 0.5

ProdDescription 2 0.1 1.25

Price 0.75 0.1 3.5

Qty 0.3 0.1 4.5

LineTotal 0.75 0.1 5

	10.	 �Click the Detail section bar and set the Height property to: 0.5

	11.	 �Click the Selection Type menu button � at the top of the Property Sheet and choose Report.

	12.	 Set the Width property to: 6

	13.	 �Switch to Report View.

There is room for a small field to the left of the ProdID field, which is where you will insert numbering.

Add and Format a Text Box
	14.	 �Switch to Design View and choose Report Design Tools→Design→Controls→Text Box .

	15.	 �Click to the left of the ProdID text box in the Detail section to position the new box in that area.

The precise location is not important, as you will set the position, using specific properties, in a 
moment.

	16.	 �Click the new label control and tap [Delete] to remove it.

You may need to move your new text box if it is obscuring the label.
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240  Access Chapter 8: Customizing Reports

	17.	 �Click the new text box control and set these property values using the All tab in the Property 
Sheet:

Property Setting

Name txtCount

Width 0.3

Top 0.1

Left 0.1

Back Style Transparent

Border Style Transparent

Set Control Properties to Sum
	18.	 �Click the Data tab and set the Control Source property to =1 and the Running Sum property to 

Over Group.

	19.	 �Switch to Report View and scroll through the report.

Notice that the numbering continues sequentially throughout the report.

	20.	 �Close the WWD Customer Invoices Subreport, saving the changes.

	21.	 �Display the Customer Invoices report in Design View.

	22.	 �Click the InvoiceDetails Subform and set the Width property to: 6

	23.	 �Switch to Print Preview and use the navigation bar to review the various report pages.

Each invoice begins on a new page and the invoice detail line items begin at number 1 for each invoice.

	24.	 �Close Print Preview and then close the Customer Invoices report, saving the changes.

Creating Calculated Controls on a Subreport
Reports summarize data in tables and queries to present useful, organized information. This means 
that a report would typically show subtotals, grand totals, and averages to summarize a specified 
group of data. You can do this by adding calculated controls.

Positioning Calculated Controls
Calculated controls are built-in reports using the Control Source property of an unbound text box 
control to which you add a formula. The section or group where a calculated control is placed deter-
mines how Access performs the calculation.
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A calculated control in a Detail section 
performs a calculation for each detail line.

A calculated control in a Group Footer 
section calculates the total for the group.

A calculated control in a Page Footer 
section calculates the total for the page.

A calculated control in a Report Footer 
section calculates the total for the entire report.

DEVELOP YOUR SKILLS: A8-D5

In this exercise, you will add a calculated control to the report footer section in the WWD Customer 
Invoices Subreport.

	 1.	 �Display the WWD Customer Invoices Subreport in Design View.

	 2.	 �Click the Report Footer section bar and set the Height property to: 0.3

	 3.	 �Choose Report Design Tools→Design→Controls→Text Box 

	 4.	 �Click anywhere in the Report Footer section.

	 5.	 �Switch to the All tab in the Property Sheet and set these properties for the new text box control:

Property Setting

Name CustomerTotal

Control Source =Sum([Price]*[Qty])

Format Currency

Height 0.25

Top 0

Left 4.75

	 6.	 �Click the new label control and set these property values:

Property Setting

Caption Invoice Total

Width 1.2

Height 0.25

Top 0

Left 3

Fore Color Text Dark
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242  Access Chapter 8: Customizing Reports

	 7.	 �Close the subreport, saving the changes.

	 8.	 �Display the Customer Invoices report in Report View.

 

Growing and Shrinking a Subreport
When the number of records or amount of data displayed in a subreport varies, you can set the Can 
Grow and Can Shrink properties to allow the subreport space to expand or shrink so more data 
displays vertically. You can also change the orientation of the print layout to allow more horizontal 
space on each report page.

The subform without the Can Grow property enabled 
displays less vertical data, requiring a scroll bar.

The subform with the Can Grow property enabled 
is expanded to display more vertical data.

DEVELOP YOUR SKILLS: A8-D6

In this exercise, you will adjust the margins of the Customer Invoices report and set the Can Grow and Can 
Shrink properties. These properties will adjust the size of the subreport to fit the contents.

	 1.	 �Display the Customer Invoices report in Design View.
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	 2.	 �Choose Report Design Tools→Page Setup→Page Size→Margins→Narrow.

	 3.	 �Click the InvoiceDetails Subreport.

	 4.	 If necessary, display the Property Sheet; on the Format tab, set the Can Grow property to No.

	 5.	 �Switch to Report View and scroll through the report.

The subform now displays a vertical scroll bar in order to view additional records.

	 6.	 �Switch to Design View and click the InvoiceDetails Subreport.

	 7.	 �Click the Format tab on the Property Sheet and, if necessary, set the Can Grow and Can Shrink 
properties to Yes.

	 8.	 �Switch to Report View and scroll through the report.

The subreport grows and shrinks to best fit the contents.

	 9.	 �Save the report.

Setting Page Breaks and Customizing Controls
As you view the Winchester Web Design Customer Invoices report in Report View, you may notice 
that the number of invoice records displayed on each screen varies depending on the number of items 
ordered. To ensure each customer invoice starts on a new page, you can add a page break control. 
By default, when you view a report in Print Preview, data for each customer/record automatically 
appears on a separate page; however, multiple records appear on the same page when the report is 
displayed in Report View.

To add a title or general company information to an invoice, place title controls in the Page Header 
rather than the Report Header, which prints only on the first page.

Add the page break at the end of the Detail section so Access knows to start a new page before printing 
the next page header.

ÍÍ Report Design Tools→Design→Controls→Insert Page Break 

DEVELOP YOUR SKILLS: A8-D7

In this exercise, you will modify the Customer Invoices report by adding a title and the current date as well 
as setting up page breaks to print each invoice on a separate page.

	 1.	 �Display the Customer Invoices report in Design View.

To begin, you will modify the report title.

	 2.	 �Click the Customer Invoice title control in the Page Header section and then click just in front 
of Customer to position the insertion point there.

	 3.	 �Type Winchester Web Design and then press [Shift]+[Enter] to force Customer Invoice to a 
second line.

	 4.	 �Click an empty area in the Page Header section and then click the title control once more to 
select it.

	 5.	 �Set the Width property to 4 and the Left property to 2.

Tip!
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Add a Date Control
In the next few steps, you will insert a date that will display in the report header.

	 6.	 �Choose Report Design Tools→Design→Header/Footer→Date and Time .

	 7.	 �Choose the third date option MM/DD/YYYY format, remove the check from the Include Time 
box, and click OK.

Access places the new date control in the Report Header section. Next, you will move the date to the 
Page Header section so it appears on every page rather than just the first page of the report.

	 8.	 �Select the date control and press [Ctrl]+[X] to cut it from the report header.

	 9.	 �Click the Page Header section bar and press [Ctrl]+[V] to paste the date into the page header.

	10.	 �Set these properties for the date control:

Property Setting

Width 2

Height 0.2

Top 0.4

Left 5.8

Add a Page Break Control
	11.	 �Scroll to the bottom of the Detail section.

	12.	 �Choose Report Design Tools→Design→Controls→Insert Page Break .

	13.	 �Place the page break in the Detail section just above the Page Footer section bar.

	14.	 �Switch to Print Preview and use the navigation bar to browse the pages.

The date appears on each invoice because you added it in the Page Header section. Each invoice 
begins on a new page. Sometimes it’s not necessary to add a page break to a report and doing so may 
add an unneeded page. If this occurs in your report, remove the page break.

	15.	 �Close Print Preview and then close the report, saving the changes.

Adding Charts
Summarized and numerical data is often displayed visually using a chart. By adding a chart to a 
report, the information and relationships between report data is more easily interpreted. While you 
can add charts to reports and forms, they’re more commonly used in reports. Access offers multiple 
chart types, including column, bar, line, and pie, among others.

You can insert charts using the Chart control or the Insert Chart command.

ÍÍ Report Design Tools→Design→Controls→Insert Chart 

Before After
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Formatting Modern Charts
You can format and modify common settings using either the Property Sheet or the Chart Settings 
task pane, which means formatting charts in Access is similar to formatting charts in other Microsoft 
Office applications, like Excel and PowerPoint.

View the video “Adding Modern Charts.”

ÍÍ Report Design Tools→Design→Tools→Chart Settings 

Refreshing Chart Data
Like many other Access objects, charts use the contents in a table or query as the data source. When 
the data source of a chart is changed, the chart may not automatically reflect those changes. The 
Refresh All command manually updates a chart to match record source data.

Home→Records→Refresh All 

DEVELOP YOUR SKILLS: A8-D8

In this exercise, you will modify Winchester’s Employee Sales report by adding a chart. You will then 
format the chart and manually update it after making changes to the record source.

	 1.	 �Display the Employee Sales report in Design View.

	 2.	 �Choose Report Design Tools→Design→Controls→Insert Chart .

A menu appears allowing you to select the chart type.

	 3.	 �Choose Column→Clustered Column.

Your mouse pointer changes to a chart icon with a plus sign.

	 4.	 �Click in the upper-left corner of the Page Footer section to insert the chart control.

	 5.	 �Close the Property Sheet and the Chart Settings pane, if necessary.

	 6.	 �Hover your mouse pointer over the bottom right of the new 
chart control until a diagonal double-pointed arrow appears.

	 7.	 �Resize the control by dragging to the bottom right until your 
chart is as tall as the Page Footer section and as wide as all 
text box controls in the Detail section.
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Format the Chart
	 8.	 �Choose Report Design Tools→Design→Tools→Chart Settings .

The Chart Settings pane appears.

	 9.	 �Choose EmployeeSales from the Data Source drop-down list.

	10.	 �Choose EmpLastName for the Axis.

	11.	 �Choose ProdDescription as the Legend.

	12.	 �Choose LineTotal (Sum) for the Values.

	13.	 �Open the Property Sheet and set these chart properties:

Property Setting

Has Legend Yes

Chart Title Total Sales

Category Axis Font Size 14

Primary Values Axis Format Currency

There are many chart properties and settings available. If you will use charts frequently, you may want 
to explore each of these settings.

	14.	 �Switch to Report View to see the newly created chart.

Refresh the Chart
	15.	 �Open the InvoiceDetails table and change the quantity for the first record to: 100

	16.	 �Switch to the Employee Sales report and choose Home→Records→Refresh All .

The Home Page column for Winchester rises dramatically.

	17.	 �Switch to the InvoiceDetails table and change the quantity for the first record back to: 1

	18.	 �Switch to the Employee Sales report and refresh the chart using the Refresh All command.

The chart data has normalized.

	19.	 �Close the Employee Sales report, saving any changes, and then close the database.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Tip!
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: A8-R1

Import a Report and Add a Subreport
In this exercise, you will import a report from the Kids for Change database and then add a subform with 
details on the activities provided by the staff.

	 1.	 �Open A8-R1-K4C from your Access Chapter 8 folder and save it as: A8-R1-K4CRev

	 2.	 �Choose External Data→Import & Link→New Data Source→From Database→Access .

	 3.	 �Click Browse and navigate to your Access Chapter 8 folder, choose A8-R1-K4C-Backup, and 
click Open.

	 4.	 �Leave the import storage setting chosen and click OK.

	 5.	 �Click the Reports tab, choose Staff Report, and click OK.

	 6.	 �Leave the Save Import Steps checkbox unchecked and click Close in the Get External Data 
dialog box.

	 7.	 �Display the newly imported Staff Report in Report View.

The empty space between the staff records is where you will insert the subreport.

Add and Format a Subreport
	 8.	 �Switch to Design View and choose Report Design Tools→Design→Controls→ 

Subform/Subreport  (scroll to the bottom of the controls list).

	 9.	 �Click just below the Activity ID label in the Detail section to insert a control and launch the 
Subreport Wizard.

	10.	 �Choose Staffing Subform from the Use an Existing Report or Form option and click Next.

	11.	 �Click Next again to accept Choose from a List as the linking method.

	12.	 �Click Finish to accept Staffing Subform as the name.

A small green triangle in the report selector indicates a possible error. Clicking the triangle displays a 
smart tag that shows the error and possible solutions. In this case, the report is wider than the page. 
You will correct this in the next few steps.


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	13.	 �Click the Staffing Subform label and tap [Delete].

	14.	 �Click the subreport and set these properties:

Property Setting

Width 7.7

Height 0.5

Top 3

Left 0

Border Style Transparent

	15.	 �Click the report selector and set the Width property to: 7.8

The green smart tag indicator should be gone.

	16.	 �Save Staff Report and then switch to Report View.

	17.	 �Scroll through the report to see that the activity details now appear under the staff information.

	18.	 �Close the database.

REINFORCE YOUR SKILLS: A8-R2

Create a Report from a Subreport and Number Report Items
In this exercise, you will save a subreport as a separate report. You will also update a report of donations 
to Kids for Change, numbering them in order to add a count of the donations per donor.

	 1.	 �Open A8-R2-K4C from your Access Chapter 8 folder and save it as: A8-R2-K4CRev

	 2.	 �Open Staff Report and switch to Design View.

	 3.	 �Right-click the subreport control and choose Subreport in New Window.

The Staffing Subform subreport opens in a separate window.
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	 4.	 �Choose File→Save As→Save Object As→Save As.

	 5.	 �Type K4C Staffing Subreport as the name, choose Report from the Save As drop-down 
list, and click OK.

	 6.	 �Close the subform and the report.

	 7.	 �Display the new K4C Staffing Subreport in Design View.

	 8.	 �Click the Detail section bar and set the Height property to: 0.3

	 9.	 �Right-click the Detail section bar and choose Report Header/Footer.

The Report Header section appears.

	10.	 �Click the Report Header section bar.

	11.	 �Set the Back Color property to Blue, Accent 1, Lighter 80%.

	12.	 �Choose Report Design Tools→Design→Controls→Label  and then click in the Report 
Header section above the ActID control and type: ID

	13.	 �Add six more labels: Activity, Day, Time, Venue, Street, and City

You don’t need to be precise with the label positions, as you will modify their properties in the 
next step.

	14.	 �Press [Ctrl] and click all seven labels to select them and then set these properties:

Property Setting

Height 0.2

Top 0

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1
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	15.	 �Click in an empty spot in the Report Header section to deselect the labels.

	16.	 �If necessary, click the individual labels and widen them so the text is fully visible and then align 
them with the text boxes in the Detail section.

	17.	 �Close and save K4C Staffing Subreport.

	18.	 �Display Staff Report in Design View and click the subreport control.

	19.	 �Set these properties on the All tab of the Property Sheet:

Property Value

Name Staffing Subreport

Source Object Report.K4C Staffing Subreport

	20.	 �Switch to Report View to see the changes and then close and save Staff Report.

Number Report Items
	21.	 �Display Donations Report in Design View.

	22.	 �Choose Report Design Tools→Design→Controls→Text Box  and click in the Detail 
section to the left of the DonorID text box.

	23.	 �Click the label control for the new text box (to the left of the text box—it may be difficult to see) 
and tap [Delete].
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	24.	 �Select the new text box control and then set these property values on the All tab of the Property Sheet:

Property Setting

Name txtCounter

Control Source =1

Width 0.3

Top 0

Property Setting

Left 0.3

Border Style Transparent

Font Name Arial

Font Weight Semi-Bold

	25.	 �Click the Data tab in the Property Sheet and set the Running Sum property to Over All.

	26.	 �Switch to Report View.

Access numbers the detail lines consecutively for each individual donation.

	27.	 �Close the database, saving the changes to the Donations Report.

REINFORCE YOUR SKILLS: A8-R3

Insert Calculated Fields and Page Breaks
Kids for Change wants to improve its donations reporting. In this exercise, you will add a field to calculate 
the total monthly donations for each donor. You will set the subreport to grow and shrink, and you will add 
custom controls and a page break. You will then add a column chart that shows total donations by donor 
with data labels.

	 1.	 �Open A8-R3-K4C from your Access Chapter 8 folder and save it as: A8-R3-K4CRev

You will begin by adding a calculated field to a report.

	 2.	 �Display K4C Donors Subreport in Design View.

	 3.	 �Choose Report Design Tools→Design→Controls→Text Box  and click in the Page Footer 
section under the Amount text box to place a new text box there.

	 4.	 �Click the text box label and tap [Delete].
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	 5.	 �Click the new text box and set these properties on the All tab of the Property Sheet:

Property Setting

Name MonthTotal

Control Source =Sum([Amount])

Format Currency

Width 1.3

Height 0.2

Property Setting

Top 0

Left 5

Font Name Arial Rounded MT Bold

Text Align Right

	 6.	 �Close and save K4C Donors Subreport.

Grow and Shrink a Subreport
	 7.	 �Display Monthly Donations Report in Design View.

	 8.	 �Click the subform to select it.

	 9.	 �Click the All tab in the Property Sheet and set the Can Grow and Can Shrink properties to Yes.

	10.	 �Switch to Report View and scroll through the report.

Notice how the number of donations per month changes and the report shrinks and grows to 
accommodate the number of donations each month.

Modify the Title
	11.	 �Switch to Design View.

	12.	 �Click the Monthly Donations Report title control in the Page Header section and then click 
just in front of Monthly to position the insertion point.

	13.	 �Type Kids for Change and press [Shift]+[Enter] to force Monthly Donations Report to a 
second line.

	14.	 �Click a blank part of the header and then click the title control again to select it.
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	15.	 �Set these properties for the title control:

Property Setting

Width 4

Left 2

Text Align Center

	16.	 �Switch to Print Preview and scroll through the first page of the report.

More than one month appears per page.

	17.	 �Use the navigation bar to navigate to page 2.

The April donations spill over from the previous page. In the next steps, you will insert a page break so 
each month begins on a new page.

Insert a Page Break
	18.	 �Close Print Preview and then switch to Design View and choose Report Design Tools→ 

Design→Controls→Insert Page Break .

	19.	 �Click in the left side of the DonationDate Footer section to place the page break.

	20.	 �Set the Top property of the page break control to: 0

	21.	 �Click the DonationDate Footer section bar and set the Height property to: 0.001

This will make the DonationDate Footer section as short as possible so the page break doesn’t push 
the DonationDate header to the next page.

	22.	 �Switch to Print Preview and use the navigation bar to scroll through the report pages.

Now the donations for each month start on new pages.

Add a Column Chart
	23.	 �Close the Monthly Donations report, saving the changes, and then display the Total Donations 

Chart report in Design View.

	24.	 �Choose Report Design Tools→Design→Controls→Insert Chart .

	25.	 �Choose Column→Clustered Column.

	26.	 �Click in the upper-left corner of the Detail section to insert the chart control.

	27.	 �Choose Donations Query from the Data Source drop-down list.

	28.	 �Choose DonorLName for the Axis, (None) as the Legend, and NetAmt (Sum) for the Values.

A
C

C
E

S
S

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



254  Access Chapter 8: Customizing Reports

	29.	 �Click the Format tab at the top of the Chart Settings pane and check the box for Display Data 
Label.

	30.	 �Resize your control by dragging to the bottom right until your chart fills the entire Detail section.

	31.	 �Open the Property Sheet and set these chart properties:

Property Setting

Has Legend No

Has Title No

Primary Values Axis Format Currency

	32.	 �Switch to Report View and view the report; close the database, saving the changes.
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	 Apply Your Skills
APPLY YOUR SKILLS: A8-A1

Work with Reports and Subreports
In this exercise, you will help Universal Corporate Events create a report that breaks down the company’s 
revenue by venue. You will add a subreport to a main report.

	 1.	 �Open A8-A1-UCE from your Access Chapter 8 folder and save it as: A8-A1-UCERev

The first step is to import the needed report.

	 2.	 �Choose External Data→Import & Link→New Data Source→From Database→Access .

	 3.	 �Choose A8-A1-UCE–Backup from your Access Chapter 8 folder.

	 4.	 �Leave the Import storage setting chosen and click OK.

	 5.	 �Click the Reports tab, choose Venue Revenue Report, and click OK.

	 6.	 �Choose to not save the import steps and click Close.

	 7.	 �Display the newly imported Venue Revenue Report in Report View.

The empty space between the locations is where you will insert the subreport.

Add a Subreport
	 8.	 �Switch to Design View and choose Report Design Tools→Design→Controls→ 

Subform/Subreport .

	 9.	 �Click in the VenueID header section below the other controls and launch the Subreport Wizard.

	10.	 �Choose VenueRevenue Subform from the Use an Existing Report or Form option and click Next.

	11.	 �Choose the second linking option (link by VenueID) and click Next again.

	12.	 �Click Finish to accept VenueRevenue Subform as the name.

	13.	 �Delete the VenueRevenue Subform label located just above the subform.


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	14.	 �Select the new subform and set these properties:

Property Setting

Width 7

Height 1.5

Top 1.3

Left 0.25

Border Style Transparent

	15.	 �Click the VenueID Header section bar and set the Height property to: 3

	16.	 �Switch to Report View and scroll through the report.

Each venue now has an event data subform associated with it that contains all the revenue data for 
the events.

	17.	 �Close the database, saving the changes to the Venue Revenue Report.

APPLY YOUR SKILLS: A8-A2

Create a Report from a Subreport and Number Report Items
In this exercise, you will continue to help Universal Corporate Events create an effective venue revenue 
report. You will create a report from a subreport and number items on a subreport.

	 1.	 �Open A8-A2-UCE from your Access Chapter 8 folder and save it as: A8-A2-UCERev

	 2.	 �Display Venue Revenue Report in Design View.

	 3.	 �Right-click the subreport and choose Subreport in New Window.

	 4.	 �Save the object as a report named: VenueRevenue Subreport

	 5.	 �Close VenueRevenue Subreport.

	 6.	 �Make sure the subform/subreport is selected and the Property Sheet is displayed.

	 7.	 �Set the Source Object property on the All tab to Report.VenueRevenue Subreport.

	 8.	 �Save the Venue Revenue Report and then switch to Print Preview.

The subreport will be displayed.

	 9.	 �Close Print Preview and close Venue Revenue Report.

Format the Report
Now you will resize the labels and move them from the Detail section to the Report Header section.

	10.	 �Display the VenueRevenue SubReport in Design View and set the Width property to: 6

This widens the subreport enough to accommodate the changes you are about to make. 
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	11.	 �Use [Ctrl] and the mouse to select all labels and text boxes in the Detail and Report Footer 
sections.

	12.	 �Click the Format tab in the Property Sheet and set the Border Style 
property to Transparent and the Fore Color property to Black, Text 1.

	13.	 �Click an empty part of the form to deselect all controls and then click 
each label individually and reduce the size to just fit the caption (label 
text).

	14.	 �Click the Report Header section bar and set the Height property to: 0.3

	15.	 �Click the VenueID label and press [Ctrl]+[X].

	16.	 �Click in the Report Header section, press [Ctrl]+[V] to paste the label, and then use the arrow 
keys to nudge it to about 0.25 in from the left edge.

	17.	 �Cut and paste the remaining labels from the Detail section into the Report Header and then use 
the arrow keys to align them approximately as shown:

	18.	 �Rearrange the Detail section text boxes by dragging them with the mouse, nudging them with 
the arrow keys, and reducing their widths to align them with the Report Header labels.

	19.	 �Click the Detail section bar and set the Height property to: 0.3

	20.	 �Use the right arrow [¡] key to right-align the calculated control in the Report Footer section 
with the Line Total label and the Detail section calculated control.
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	21.	 �Switch to Layout View and, if necessary, resize and reposition the controls so they are aligned 
nicely and all data is visible.

	22.	 �Save the subreport.

Number Report Items
	23.	 �Switch to Design View and insert a new text box in the Detail section to the left of the VenueID 

text box.

	24.	 �Delete the associated label control.

	25.	 �Click the new text box control and set these property values in the All tab of the Property Sheet:

Property Setting

Name txtCount

Control Source =1

Width 0.2

Top 0

Left 0

Border Style Transparent

	26.	 �Click the Data tab in the Property Sheet and set the Running Sum property to Over All.

	27.	 �Select all text boxes in the Detail section and set the Top property to: 0
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	28.	 �Save the VenueRevenue SubReport and then display the Venue Revenue Report in Print 
Preview.

Navigate through the report and notice that the detail lines for each venue are now numbered 
sequentially.

	29.	 �Close the database, saving changes to any reports.

APPLY YOUR SKILLS: A8-A3

Add a Calculated Field and a Page Break
Universal Corporate Events continues to refine its database reports. In this exercise, you will first add a 
field to calculate the total of all the venues’ revenues. You will also add a page break to another report to 
allow each month to begin on a new page.

	 1.	 �Open A8-A3-UCE from your Access Chapter 8 folder and save it as A8-A3-UCERev

	 2.	 �Display Venue Revenue Report in Report View.

	 3.	 �Scroll through the report and notice that each venue is associated with Line Total calculations 
and a total of all line totals per venue.

The one thing missing is a grand total at the bottom of the report that sums all totals for the venues. 
You will add a calculated control that produces a grand total.

	 4.	 �Switch to Design View.

	 5.	 �Click the Report Footer section bar and set the Height property to: 0.4

	 6.	 �Insert a text box anywhere in the Report Footer section and set these properties for the label control:

Hint: Use the Format tab on the Property Sheet.

Property Setting

Caption Grand Total for All Venues

Width 2

Top 0.1

Left 2

Font 
Weight

Semi-Bold

Fore Color Blue, Accent 1, Darker 50%
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	 7.	 �Set these property values for the new text box:

Hint: Use the All tab on the Property Sheet.

Property Setting

Name ActivityCost

Control Source =Sum([Guests]*[ChgPP])

Format Currency

Width 1.5

Top 0.1

Property Setting

Left 5

Border Style Transparent

Font Weight Semi-Bold

Fore Color Blue, Accent 1, Darker 50%

	 8.	 �Select the VenueRevenue Subform and set the Can Grow and Can Shrink properties on the 
Format tab of the Property Sheet to Yes.

This ensures that all venue detail lines will be displayed.

	 9.	 �Switch to Report View and scroll to the end of the report.

Notice the Grand Total for All Venues label and the grand total calculated control.

	10.	 �Close Venue Revenue Report, saving the changes.

Insert a Page Break
	11.	 �Display the Event Revenue Report in Print Preview.

	12.	 �Scroll through the first page and notice that several months are included.

The page break you are about to insert will position each month on a separate page.

	13.	 �Close Print Preview and then switch to Design View and insert a Page Break  control on the 
left side of the EventDate Footer section, just below the Total for label.

Be sure to position the break below the label or portions of the report will be cut off.

	14.	 �Switch to Print Preview and notice that just one month appears on the first page.

	15.	 �Use the navigation bar to go to the next page, and, once again, just one month will be displayed 
because of the page break.

	16.	 �Close the report, saving your changes.
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Insert a Pie Chart
	17.	 �Display the Revenue by Venue report in Design View.

	18.	 �Use the Insert Chart command to create a new pie chart.

	19.	 �Click in the upper-left corner of the Detail section to insert the chart control and use these chart 
settings:

•	 Data source: Event Revenue

•	 Legend: (None)

•	 Values: TotalRev (Sum)

	20.	 �On the Format tab, check the box for the Display Data Label option.

	21.	 �Resize your chart control to fill the entire Detail section.

	22.	 �On the Property Sheet, set these properties for the chart:

Property Setting

Legend Position Bottom

Has Title No

Primary Values Axis Format Currency

	23.	 �Close the database, saving the changes to the report.
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	 	Project Grader

project grader: A8-P1

Taylor Games: Updating Inventory
Taylor Games is ready to take sales orders. Before it begins, it needs to create a printable sales receipt for 
its customers. In this exercise, you will start by adding a subreport to a main report. Next, you will add 
calculated controls to provide order subtotals, taxes, and totals. You will then set page breaks for printing 
individual receipts.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download A8_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

•	 Not using eLab: Open A8_P1_Start from your Access Chapter 8 folder.

	 2.	 �Add a subreport to the Sales Receipt report using these guidelines:

•	 Position the subreport in the detail section below the text boxes.

•	 Use the OrderDetails report for the data.

•	 Leave all linked field options set to the default values.

•	 Leave the Name as OrderDetails.

	 3.	 �Delete the OrderDetails subreport label and set the following subreport properties:

Property Value

Width 6

Height 3

Top 0.45

Left 0

Border Style Transparent

Can Shrink Yes

	 4.	 �In the Detail section of the subreport, set the Border Style property for all text box controls to 
Transparent.

	 5.	 �In the Report Footer section of the subreport, insert a new text box control and set these  
properties for it:

Property Value

Name Subtotal

Control Source =Sum([Line Total])

Format Currency

Top 0.10

Left 4.2

Border Style Transparent
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	 6.	 �Set these properties for the new unbound label (contains the text Text40):

Property Value

Name Sub Total

Caption Sub Total

Width 1

Top 0.10

Left 3.5

	 7.	 �Insert a new text box control below the Subtotal text box and set these properties for it:

Property Value

Name Taxes

Control Source =[Subtotal]*.075

Format Currency

Top 0.4

Left 4.2

Border Style Transparent

	 8.	 �Set the following properties for the new unbound label (contains the text Text42):

Property Value

Name Tax

Caption Tax

Width 1

Top 0.4

Left 3.5

	 9.	 �Insert a new text box control below the Taxes text box and set these properties for it:

Property Value

Name Order Total

Control Source =[Subtotal]+[Taxes]

Format Currency

Top 0.7

Left 4.2

Border Style Transparent

Font Weight Bold

	10.	 �Set the following properties for the new unbound label (contains the text Text44):

Property Value

Name Total

Caption Total

Width 1

Top 0.7

Left 3.5

Font Weight Bold

A
C

C
E

S
S

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



264  Access Chapter 8: Customizing Reports

	11.	 �Insert a page break control below the subreport and just above the Sales Receipt form’s page 
footer.

	12.	 �Save your database.

•	 Using eLab: Save it to your Access Chapter 8 folder as A8 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Access Chapter 8 folder as: A8 _ P1 _ Submission

project grader: A8-P2

WebVision: Create a Chart and Back Up the Database
WebVision would like you to make some database improvements. In this exercise, you will create a chart 
displaying the total sales for each sales rep. You will also import an invoice report, located in a backup 
database, and make a few changes to improve visual design.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download A8_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

•	 Not using eLab: Open A8_P2_Start from your Access Chapter 8 folder.

	 2.	 �Use the Report Design tools to create a new report with the name: Annual Sales by Rep

	 3.	 �Insert a date and time control using these guidelines and properties:

•	 Use the second date option.

•	 Do not include a time.

Property Value

Width 1

Text Align Center

	 4.	 �Insert the WebVision Logo.jpg image from your Access Chapter 8 folder and set the Width 
property to: 1.25

	 5.	 �Set the ReportHeader section Back Color property to Background Form.
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	 6.	 �Add a pie chart to the Detail section using these chart settings:

Setting Value

Data Source Rep Sales by Customer query

Axis (Category) Last Name

Legend (Series) (None)

Values (Y axis) Total (Sum)

In the Format list Check the Display Data Label box 

	 7.	 �Set these chart properties:

Property Value

Top 0

Left 0

Width 6.5

Height 5

Legend Position Bottom

Legend Text Font Size 14

Chart Title Annual Sales by Rep

Chart Title Font Size 20

Primary Values Axis Format Currency

	 8.	 �Set the Report Width property to: 6.5

	 9.	 �Use these guidelines to import a report from another database:

•	 Choose the A8_P2_Backup Access database located in your Access Chapter 8 folder as the 
data source.

•	 Choose the Invoices report as the object to import.

	10.	 �Save your database.

•	 Using eLab: Save it to your Access Chapter 8 folder as A8 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Access Chapter 8 folder as: A8 _ P2 _ Submission
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A8-E1	 That’s the Way I See It
You would like to modify a database report to show sales details for the Blue Jean Landscaping 
database. Open A8-E1-BJL and save it as: A8-E1-BJLRev

Import the Customer Sales Report from A8-E1-BJL-Backup. Then add the CustomerSales Subform 
to the Detail section of the Customer Sales Report.

A8-E2	 Be Your Own Boss
As the owner of Blue Jean Landscaping, you pride yourself on creating organized and easy-to-use 
reports. You want to add more calculations to your report and to add page breaks for more orga-
nized viewing of the data. Open A8-E2-BJL and save it as: A8-E2-BJLRev

Open Customer Sales Report and create a new subreport from the CustomerSales Subform. Calcu-
late the line totals for each subreport line using the formula Price*QtySold. Insert a page break so 
each customer appears on a separate page when you view the report in Print Preview.

A8-E3	 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant is enjoying increased sales, so you must make some 
changes to the database reports to produce more useful sales results. Open A8-E3-SBQ and save it 
as: A8-E3-SBQRev

Import the Merchandise Sales Report from A8-E3-SBQ-Backup. Insert the MerchandiseSales 
Subform into the Detail section of the Merchandise Sales Report to add individual sale line items 
(choose Show each record in Merchandise using SKU). Save the subform as a report, being sure to 
close the subform, and then open the new subreport so the changes you make are not reflected 
in the subform. Calculate each line total (ListPrice*QtySold) in the Detail section of the subreport. 
Create a new report that includes a pie chart in the Detail section. Ensure the chart uses the 
MerchandiseSalesQuery as the data source and displays the total sales by Item Name.


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