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Oxcel has many features to help you 

perform sophisticated data analyses, 

including the PivotTable and the 

PivotChart. PivotTables let you summarize 

worksheet data dynamically to view them in 

various ways. In this lesson, you will arrange 

your data with simple drag-and-drop 

commands and have Excel automatically 

create summary formulas in the rows and 

columns. You also will create PivotCharts to 

achieve the same power and flexibility for 

charting data. Many Excel workbooks are 

used on a recurring basis. Examples include 

monthly expense accounts, sales forecasts, 

and lists of various types. Often, the same 

tasks are performed in these workbooks over 

and over. Excel allows you to create macros to 

automate repetitive tasks. In addition, Excel 

lets you assign macros to shortcut keys, 

buttons on the Quick Access toolbar, and 

custom buttons or other graphics in a 

worksheet. In this lesson, you will create 

macros and custom buttons in an Excel 

workbook.
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L E S S O N  O U T L I N E

12.1 Creating PivotTables

12.2 Creating PivotCharts

12.3 Changing Macro Security 

12.4 Recording Macros

12.5 Running Macros

12.6 Assigning Macros

12.7 Concepts Review

Reinforce Your Skills

Apply Your Skills

Critical Thinking & Work-Readiness Skills

L E A R N I N G  O B J E C T I V E S

After studying this lesson, you will be able to:

■ Create PivotTables and change their fields

■ Create PivotCharts from PivotTable or 

worksheet data

■ Set macro security to protect workbook data

■ Record and run macros to automate tasks

■ Add custom task buttons to worksheets
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Simplifying Repetitive Tasks

Raritan Clinic East, an incorporated medical practice that 

serves a patient community ranging in ages from 

newborn to 18 years, is planning to construct a pediatric 

oncology facility. In addition, a companion facility will 

provide temporary housing to physicians specializing in 

ground-breaking cancer treatments and long-term 

housing for family members of the children who are receiving treatments. Sandra Chavez-Hall is the 

chief development officer for the clinic’s foundation. She coordinates a fundraising campaign to solicit 

contributions from private donors, charitable organizations, industry sources, and government grants 

to build the two facilities. Sandra will use PivotTables and PivotCharts to analyze the contributions by 

various criteria.

Sandra also maintains a contributions-to-date summary report. She uses macros to record the steps 

used in sorting the data. By attaching each macro to a button on a worksheet, she can sort the report 

with one click.

Levels 3–6 are 
collapsed to 
display only 
the subtotals.

The PivotTable shows the 
contributions organized by sponsor 
categories within each pledge level. 
You can easily rearrange the design 
to view the data in other ways.

Macros were created to perform repetitive tasks; then they were assigned to buttons in row 1.

Labyrinth Learning  http://www.lablearning.com
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Video Lesson labyrinthelab.com/videos

PivotTables are powerful data analysis tools. They let you summarize data in various ways and 

instantly change the view you use. You can create normal Excel lists and tables to sort and 

filter data and produce subtotals. A PivotTable not only subtotals groups of related data, but 

also goes a step further and compares one group to another. Compared with performing 

similar data analyses on a standard worksheet, PivotTables offer tremendous speed and flexi-

bility. 

Arranging the Source Data
You create PivotTables from columns or from a table in an Excel worksheet. The data should 

contain no blank rows or columns. Converting a list to a table is recommended when records 

will be added after the PivotTable is created. The additional table data are included automati-

cally when the PivotTable is refreshed or updated. Data in a list are not included automatically. 

The following examples explain two PivotTables based on the same worksheet list.

PivotTable Example 1
You could sort the preceding table by pledge level or sponsor category; however, you could not 

easily compare totals for the various pledge levels in each sponsor category. This is where the 

PivotTable comes into use. A PivotTable can summarize some or all of the data in any number 

of ways, and it creates grand totals for you. Each column in a PivotTable is a field. Examine the 

PivotTable and notice that the Sponsor Category field from the table is used for the row labels, 

the Pledge Level field for the column labels, and the Year 2 field for the data area and grand 

totals. Each row displays the amount given by each sponsor group in the various pledge levels.

12.1 Creating PivotTables

The worksheet 
data on which the 
sample PivotTables 
are based

This PivotTable summarizes contributions from all sponsor groups.

The amount 
given by each 
sponsor group 
is displayed by 
pledge level.

Filter buttons 
allow you to 
sort and filter 
the sponsor 
groups and 
pledge levels.

PivotTables 
automatically 
total the rows 
and columns 
and calculate a 
grand total.
460 Lesson 12: Creating PivotTables and Macros
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PivotTable Example 2
Using the same table data, you may view the data differently—in this case, summarized first by 

pledge level and then by sponsor category. To create this type of view, the PivotTable layout 

shown in the following illustration contains the Pledge Level and then Sponsor Category fields 

for row labels, no column labels, and the Year 2 field for the data area and totals.

In this lesson, you will learn how to lay out both of these types of PivotTables and much more.

How PivotTables Work
Each area of the PivotTable plays a role in data organization. The PivotTable Field List task 

pane displays after you define the worksheet range to be used. The areas of the task pane are 

explained in the following illustration showing the settings for the preceding PivotTable 

Example 1.

You must select a cell in the PivotTable to display the PivotTable Field List task pane.

This PivotTable layout 
summarizes contributions 
first by pledge level and 
then by sponsor category.

Buttons allow you to 
collapse and expand 
the level of detail.

Subtotals are created 
for each pledge level.

You may choose 
some or all columns 
from the worksheet 
data to appear in 
the PivotTable.

The Row Labels area 
contains the product 
names, one sponsor 
category in each row.

The Column Labels area contains the 
pledge levels, one level in each column.

The Values area contains the Year 2 
contribution numbers from the worksheet 
to be calculated using the SUM function.

You could drag the Pledge Level field 
to the Report Filter area to filter for 
one or more pledge level groups 
rather than display data for every 
pledge level in the PivotTable.

NOTE
Creating PivotTables 461
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You design a PivotTable by choosing the columns (fields) to be included from the worksheet. 

Excel initially places all text columns that you choose into the Row Labels area and all selected 

number columns into the Values area for summing. If this is not your desired layout, you can 

drag and drop various fields into the correct areas of the task pane. Where you place fields 

determines how the PivotTable summarizes the data. By choosing different fields or dragging 

and dropping a field, you may quickly compare data in various ways. You may choose from 

several functions—such as SUM, COUNT, and AVERAGE—to calculate fields containing 

values. 

Create PivotTables 12.1.1

The best way to understand the dynamic capabilities of a PivotTable is to create one. In this exercise, you 
will create PivotTables from a worksheet range and a table. 

Review the Worksheet Data

1. Start Excel and open the Sponsors workbook from the Lesson 12 folder in your file 

storage location. 

2. Maximize  the window.

The Sponsors Sheet worksheet contains the data you will use to create two PivotTables. Look at 
the column headings and the various records in the rows. Each record contains data for a specific 
donor or government grant for the building project. Notice the dollar amounts contained in the Year 1 
and Year 2 columns. 

CREATING A PIVOTTABLE

Task Procedure

Create a PivotTable 

from a worksheet 

range or table

■ Select a cell in the worksheet range or table.

■ Choose Insert→Tables→PivotTable  from the Ribbon.

■ Verify the worksheet range or table name in the Create PivotTable dialog box 

and click OK to place the PivotTable on a new worksheet. 

■ In the PivotTable Field List task pane, place a checkmark by each worksheet 

field to be included in the design, selecting the fields in the order they should 

appear as row labels and values columns. 

■ If necessary, drag and drop a field name to the correct area: Report Filter, Row 

Labels, Column Labels, or Values.

Name a PivotTable ■ Choose Options→PivotTable, type the name in the PivotTable name text box 

(spaces are allowed), and tap [Enter].

Display the 

PivotTable Field List 

task pane 

■ Select any cell within the PivotTable. 

■ If the task pane is turned off, choose Options→Show→Field List from the 

Ribbon. 

DEVELOP YOUR SKILLS 12.1.1

QUICK REFERENCE
F
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Create a PivotTable from a Worksheet Range
You will create a PivotTable that summarizes Year 2 by pledge level with subtotals for each sponsor category 
(corporation, individual, organization, state government agency, and so on). 

3. Select cell B4. 

You should select a cell within the worksheet range or table before you create the PivotTable. The range 
should contain no blank rows or columns. 

4. Choose Insert→Tables→PivotTable  from the Ribbon. 

The Create PivotTable dialog box appears. 

5. Verify the suggested range as shown, notice that the default is to place the PivotTable on a 

new worksheet, and click OK. 

A new worksheet appears and contains an empty PivotTable placeholder. The PivotTable Field List task 
pane also displays. If the task pane is turned off, choose Options→Show→Field List from the Ribbon. 

6. Rename Sheet1 as PivotTable by Sponsor Category.

7. Select cell A1, which is outside the boundary of the PivotTable outline. 

Notice that the PivotTable Field List task pane disappears. You must select a cell within the PivotTable 
placeholder to display the task pane. 

8. Select cell A3 within the PivotTable placeholder to restore the task pane. 

Notice that the PivotTable Field List task pane contains a list of all the data fields in the worksheet 
range. You will choose only some of them. 

9. Follow these steps to define the PivotTable in the task pane:

B Drag the Pledge 
Level field to 
the Column 
Labels area.

A Place a checkmark 
next to the Pledge 
Level, Sponsor 
Category, and 
Year 2 fields.
Creating PivotTables 463
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In the resulting PivotTable, notice that the sponsor categories are displayed one per row, the six pledge 
levels are displayed one per column, and the Year 2 contributions data are summarized with totals for 
each sponsor category in column H and each pledge level in row 19. The Level 1 label is not aligned over 
its numbers in cell B4, and you will fix this in a later exercise. 

Name the PivotTable

10. Choose Options→PivotTable from the Ribbon, type BySponsorCategory in the Pivot-

Table name text box, and tap [Enter]. 

Create a PivotTable from a Worksheet Table
The steps for creating a PivotTable from a worksheet table are the same as for a worksheet range. This time 
your PivotTable will group the data by pledge level with the sponsor categories in alphabetical order within 
each pledge level. 

11. Display the Sponsors Table worksheet in the Sponsors workbook.

12. With any table cell selected, choose Insert→Tables→PivotTable  from the Ribbon. 

13. Verify that the suggested range is the Sponsors_Table and click OK. 

14. Rename the new sheet as PivotTable by Pledge Level.

15. In the PivotTable Field List task pane, place a checkmark next to field names in this order: 
Pledge Level, Sponsor Category, Year 2. 

The task pane and the PivotTable results should display as shown. The records are grouped by pledge 
level with the sponsor categories in alphabetical order within each pledge level. The Year 2 subtotal 
displays for each pledge level, and a grand total appears at the bottom of the column. With this layout, 
you did not need to create any column labels. 
464 Lesson 12: Creating PivotTables and Macros
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Name the PivotTable

16. Choose Options→PivotTable from the Ribbon, type By Pledge Level in the Pivot-

Table name text box, and tap [Enter]. 

Notice that you can type a PivotTable name with or without spaces.

17. Save  the changes to your workbook. 

Formatting a PivotTable
Video Lesson labyrinthelab.com/videos

Values and subtotals in the PivotTable do not automatically display the formatting from the 

original worksheet cells. You may set number formatting for a value field. You also may select 

and format one or more specific cells in the PivotTable. For example, you may align the column 

labels using commands on the Home tab of the Ribbon. The PivotTable Tools Design contex-

tual tab contains a large selection of PivotTable styles to apply color, shading, and gridlines 

with one mouse click. The report layout displays in Compact Form by default, or you may 

choose from two other layouts. The subtotals may be displayed at the top or bottom of each 

group or hidden. 

FORMATTING A PIVOTTABLE 

Task Procedure

Apply number 

formatting to a field 

Right-click a column cell in the PivotTable, choose Number Format from the pop-

up (context) menu, and choose options from the Format Cells dialog box. (Do not 

choose the Format Cells command from the context menu, which formats the 

selection rather than entire columns.)

Change the 

subtotals or grand 

totals display

Choose Design→Layout→Subtotals  or Grand Totals  and choose an 

option from the Ribbon. 

Apply a PivotTable 

style 

Choose Design→PivotTable Styles and choose a style from the Ribbon. 

Apply a report 

layout

Choose Design→Layout→Report Layout  and choose the Compact (default), 

Outline, or Tabular layout from the Ribbon. 

The Tabular Form report layout with 
filter buttons for each row label field

The Compact Form report layout 
with a PivotTable style applied

QUICK REFERENCE
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Format a PivotTable 12.1.2

In this exercise, you will format the PivotTables that you created in the previous exercise. You will format 
selected cells, apply number formatting to values columns, choose a PivotTable style, and explore the report 
layout choices. 

Format PivotTable Data

1. Display the PivotTable by Sponsor Category worksheet in the Sponsors workbook.

You may need to use the navigation buttons at the left of the worksheet tabs to bring the desired tab 
into view.

2. Select the range B4:H4 and right-align the labels to match the number alignment in 

their columns.

3. Choose Design→Layout→Grand Totals menu  from the Ribbon. Experiment by 

choosing each option and observe its result. Choose On for Rows and Columns when 

you are finished.

4. If necessary, select any cell in the PivotTable to redisplay the PivotTable Field List 

task pane.

5. Follow these steps to format the Year 2 contribution numbers in the PivotTable:

All number columns are displayed with the formatting that you chose because they all are part of the 
Sum of Year 2 field.

Apply a PivotTable Style

6. Display the PivotTable by Pledge Level worksheet. 

7. Choose the Design→PivotTable Styles→More  button, scroll through the available 

styles, and choose PivotStyle Medium 9. 

This style shades the subtotal rows. 

DEVELOP YOUR SKILLS 12.1.2

▼

A Right-click any number in 
the range B5:H19, and 
choose Number Format 
from the context menu.

B Choose the Number category, set 0 decimal 
places, and place a checkmark in the Use 
1000 Separator (,) box.

C Click OK.
466 Lesson 12: Creating PivotTables and Macros
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Explore Report Layouts

8. Choose Design→Layout→Report Layout→Show in Outline Form from the Ribbon. 

This layout divides the Pledge Level and Sponsor Category fields into separate columns. Both column 
headings display a filter button. 

9. Choose Design→Layout→Report Layout→Show in Tabular Form from the Ribbon. 

This layout displays a subtotal row below its detail rows. 

10. Choose Design→Layout→Report Layout→Show in Compact Form to return to the 

original layout. 

11. Save  the changes to your workbook. 

Changing PivotTable Fields
Video Lesson labyrinthelab.com/videos

You may add or remove fields on a PivotTable simply by adding or removing the checkmark 

next to the field name in the PivotTable Field List task pane. The PivotTable will automatically 

reconfigure to display the new data. You also may change the order of fields within the row 

and column areas. One of the most powerful ways of manipulating data is to move a field from 

the row area to the column area or vice versa. This is called pivoting the field (thus the name 

PivotTable). The display of the data field rotates to give you an entirely different view of your 

data, as illustrated in the two PivotTables you created in the previous exercise. There, you posi-

tioned the Region field to display as columns in the first PivotTable and as rows in the second. 

Change PivotTable Fields 12.1.3

In this exercise, you will add fields to the PivotTable and reorder the display of fields. You also will pivot 
the view.

Add a Values Field

1. Display the PivotTable by Pledge Level worksheet, if necessary. 

The PivotTable contains data only for Year 2. Now you will add Year 1. 

2. Place a checkmark next to Year 1 in the task pane to add 

this field to the PivotTable. 

The Year 1 values are summed with subtotals and a grand total. 
Notice that Excel automatically added a ∑ Values entry in the 
task pane Column Labels area because the PivotTable now 
contains two Sum columns.

3. Right-click any cell in the Sum of Year 1 column of the 

PivotTable, and choose Number Format from the context menu.

4. In the Format Cells dialog box, choose the Number category, set 0 decimal places, place a 

checkmark in the Use 1000 Separator (,) box, and click OK.

5. Repeat steps 3 and 4 to format the Sum of Year 2 column.

DEVELOP YOUR SKILLS 12.1.3
Creating PivotTables 467
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Reorder Fields

6. Drag Sum of Year 2 below Sum of Year 1 in the Values area.

The PivotTable now displays the columns for both years in the order listed in the Values area of the 
task pane.

Add and Then Remove a Labels Field

7. Place a checkmark by the Sponsor Name field in the top section of the PivotTable Field 

List task pane.

Notice the order of the fields in the Row Labels area. Now the sponsors and their contribution amounts 
are displayed within each sponsor category. Adding or deleting row labels allows you to control the level 
of detail displayed in a PivotTable.

8. Remove the checkmark by the Sponsor Category field and Sponsor Name field in the 

PivotTable Field List task pane.

9. Add a checkmark by the Team Leader field.

The team leader totals appear within each pledge level. Notice that some team leaders appear in 
multiple pledge levels. This view makes it easy to compare Year 1 and Year 2 data.
Fo
r E
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Pivot the View

10. Drag the Team Leader field from the Row Labels area to the Column Labels area below 

the ∑ Values field.

You just pivoted the team leader field to be displayed in columns rather than rows. This view allows you 
to compare each team leader’s overall performance among the various pledge levels, but comparing Year 
1 to Year 2 is more difficult than in the previous view.

11. Undo  the pivot you performed in the previous step.

12. Save  the changes to your workbook. 

Filtering a PivotTable with AutoFilter
Video Lesson labyrinthelab.com/videos

You may set the PivotTable to filter, or include, specific items in the data summaries. The totals 

and subtotals are recalculated for the selected items. The Row Labels and Column Labels head-

ings have an AutoFilter button that displays the same sorting and filtering options that are 

available on the columns of worksheet lists and tables.

This is the field to 
be filtered is 
selected in the list.

The heading contains 
an AutoFilter button.

Rows for specific pledge 
levels will be excluded 
from the PivotTable.

Totals and subtotals will 
be calculated for the 
selected pledge levels.

Additional filtering commands, 
such as Begins With and Greater 
Than, are available to filter a 
text, number, or date column.
Creating PivotTables 469
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Filtering PivotTables with Slicers
New to Excel 2010, slicers are menu frames displayed on the worksheet that contain all 

filtering choices in one field. You can choose items or clear a filter without having to drop 

down a list. Selected items are highlighted in slicers, making it easy to see which criteria have 

been applied to the PivotTable filter. Slicer frames may be resized, moved, and formatted with 

styles for a consistent appearance. Slicers also may be shared in other worksheets of the same 

workbook for use with multiple PivotTables based on the same data set. Changing the filtering 

selections in a shared slicer causes all connected PivotTables to update automatically.

CHANGING PIVOTTABLE FIELD ORDER AND FILTERING A PIVOTTABLE USING 

AUTOFILTER AND SLICERS

Task Procedure

Change the field 

order in rows or 

columns

■ Drag a field name above or below another field in an area list at the bottom of the 

PivotTable Field List task pane.

Remove a field ■ Uncheck the field name from the PivotTable Field List task pane.

Filter for specific 

items using 

AutoFilter

■ Click the AutoFilter  button next to Row Labels, Column Labels, or a specific 

column label, if available, in the PivotTable.

■ Choose a field from the fields available in the filtering list.

■ Remove the checkmark form the desired item(s), or choose Label Filters, Value 

Filters, or Date Filters, depending on the type of data in the column.

Filter for specific 

items using slicers

■ Select any cell in the PivotTable.

■ Choose Options→Sort & Filter→Insert Slicer  from the Ribbon. (Or, choose 

Design→Filter→Slicer.)

■ Place a checkmark next to the desired fields in the Insert Slicers dialog box, and 

click OK.

■ Choose one or more items in slicers, as desired. To select additional items in a 

slicer, hold down [Ctrl] while clicking each item. To remove items from a multiple 

selection, hold down [Ctrl] while clicking each item. 

Frame resizing 
handles

Slicers allow you to filter a PivotTable easily by clicking 
buttons. Here, the PivotTable by Pledge Level is filtered to 
calculate each team leader’s totals for corporate 
sponsorships and individual sponsorships in pledge level 1.

Clear Filter 
button

Highlighted items included 
in the current filter

Items available but not 
selected in the current filter

Dimmed item not available in 
the current filter (pledge level 1 
contains no corporate grants)

QUICK REFERENCE
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Filter a PivotTable with Slicers 12.1.4

In this exercise, you will display slicers on a PivotTable worksheet. You will move, resize, and format the 
slicers to fit around the PivotTable. Then, you will select items from the slicers to filter the PivotTable to look 
at the data in various ways.

Insert Slicers

1. Display the PivotTable with Slicers worksheet in the Sponsors workbook. (Scroll to the 

right in the worksheet tabs to locate the tab, if necessary.)

The PivotTable displays the Sponsor Categories field as rows and the Sum of Year 1 and Sum of Year 2 
fields as columns.

2. Select any cell in the PivotTable to display the PivotTable Tools in the Ribbon, if necessary.

3. Choose Options→Sort & Filter→Insert Slicer  from the Ribbon.

4. Place a checkmark next to the Pledge Level, Team Leader, and Sponsor Category 
fields in the Insert Slicers dialog box; click OK.

5. Select cell A1 to hide the PivotTable Field List task pane, if still displayed.

Clear a filter from a 

slicer

■ Choose the Clear Filter  button in the upper-right corner of the desired slicer. 

Move and resize a 

slicer

■ Point to a slicer’s frame or title bar and drag to the desired location on the 

worksheet.

■ Drag a corner or side handle on the slicer frame to resize the slicer.

Display slicer 

buttons in multiple 

columns

■ Select the slicer.

■ Choose Options→Buttons→Columns , and choose the number of columns 

from the Ribbon.

Apply a style to a 

slicer

■ Select the slicer.

■ Choose Options→Slicer Styles, and choose a style from the Ribbon.

Connect a slicer to 

additional 

PivotTables based 

on the same data 

set in the workbook

■ Select the slicer.

■ Choose Options→Slicer→PivotTable Connections  from the Ribbon.

■ Place a checkmark by the PivotTable name(s) to which you wish to connect the 

slicer.

DEVELOP YOUR SKILLS 12.1.4

CHANGING PIVOTTABLE FIELD ORDER AND FILTERING A PIVOTTABLE USING 

AUTOFILTER AND SLICERS

Task Procedure

QUICK REFERENCE
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Move and Resize Slicers

6. Follow these steps to move and resize the Sponsor Category slicer:

7. Drag the Pledge Level slicer and Team Leader slicer to row 20 as shown.

8. Click the Pledge Level title to display the slicer’s frame, and then hold down [Shift] and 

click on the Team Leader title.

Frames appear around the two slicers to indicate both are selected. If you click a slicer button by 
mistake, click the Clear Filter button in the upper-right corner of the slicer and repeat step 8.

9. Choose Options→Buttons→Columns  from the Ribbon, and change the number of 

columns from 1 to 2.

A Point at the Sponsor Category’s title bar until the pointer changes to a 
four-pointed arrow, and then drag the slicer to the right of the PivotTable.

B Point at the lower-right corner handle on the slicer frame until 
the pointer changes to a two-pointed arrow, and drag to the 
right and down to display all the sponsor category names.
472 Lesson 12: Creating PivotTables and Macros

Labyrinth Learning  http://www.lablearning.com



Microsoft Excel 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
Fo
r E

va
lu

at
io

n 
O
nl

y

Apply Slicer Styles

10. Click the Sponsor Category title in the slicer at the right of the PivotTable, choose 

Options→Slicer Styles, and choose any style from the Ribbon.

11. Repeat step 10 to apply styles of your choice to the Pledge Level slicer and Team Leader 

slicer.

Filter the PivotTable

12. Choose Level 1 in the Pledge Level slicer.

Four sponsor categories are displayed in the PivotTable, matching the four highlighted buttons in the 
Sponsor Category slicer. These are the only types of sponsors to contribute at level 1, the highest dollar 
level.

13. Click the Clear Filter  button on the Pledge level slicer to restore all data in the Pivot-

Table.

14. Select Corporate Sponsorship in the Sponsor Category slicer.

The Sum of Year 2 total in the PivotTable is 20,951,250. The slicers show that Pledge Levels 1–5 and 
team leader Faber are included.

15. Hold down [Ctrl] and select Individual Sponsorship.

The PivotTable and slicers reflect the additional category. You can use [Ctrl]+click to select additional 
items or deselect them in a slicer.

16. Experiment by selecting and deselecting various criteria in the slicers; clear filters 

from all slicers when you are finished.

17. Save  the changes to the workbook.

The Team Leader slicer shows that Faber, 
Lemus, and Weinstein are included in the 
PivotTable totals. The buttons are dimmed for 
the other team leaders because they did not 
solicit any contributions at pledge level 1.
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Editing PivotTable Calculations
Video Lesson labyrinthelab.com/videos

You are not limited to summing values in a PivotTable, and you may create additional 

formulas. 

Changing the Function for a Values Area Item
By default, the subtotals and grand totals in a PivotTable sum the values in a field. You may 

use the Summarize Values By command to change the SUM function to a different function, 

such as AVERAGE, MAX, or COUNT. Not all Excel functions are available by using this 

command. 

If the Values area of the PivotTable Field List task pane contains only one entry, all Sum 
columns will change to the function you selected. If multiple entries exist in the Values area, 
you may change the function for one entry at a time.

Creating a Calculated Field
Some functions not available with the Summarize Values By command described previously 

may be typed in the Insert Calculated Field dialog box. A calculated field is a column that you 

create manually in the PivotTable. This field contains a formula using values from one or more 

existing fields. For example, the formula could subtract the value in one field from another to 

find the difference, as shown in the following illustration. You enter the formula once, and 

Excel displays the formula result in every record of the PivotTable. For accuracy, you should 

select field names from the list rather than type their names in creating the formula for a 

calculated field.

NOTE

Selecting a values column based on Sum of Year 1 
and changing the function to AVERAGE changes 
all columns based on Sum of Year 1.

Sum of Year 2 retains its SUM function 
unless the function is changed separately.

You may insert existing field names and/or 
type function names, values, and symbols 
to create a formula for a calculated field.

Field names may be selected from 
this list for insertion in the formula.
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Converting Column Data to a Calculation
The Show Values As command creates formulas using preset options. For example, you can 

calculate percentages of a total, the difference between values in two columns, a running total, 

or a ranked order. If you want to display the original column data along with the converted 

data, simply drag and drop the field name from the field list to the Values area to create a 

duplicate field.

Refreshing PivotTable Data
PivotTables do not automatically update after the source data is changed.

PivotTables often are created with data from sources external to the Excel work-

book containing the PivotTables. For example, the source data may be in another 

Excel workbook or an Access database. After you change the source data—even 

if in a worksheet range or table within the same workbook—you must refresh 

the PivotTables manually. Using the Ribbon, you may refresh just the active PivotTable or all 

PivotTables in the workbook. You also may set a PivotTable option to refresh data from 

external sources when the workbook is opened. 

EDITING PIVOTTABLE CALCULATIONS AND REFRESHING DATA 

Task Procedure

Change the function used to 

calculate subtotals and grand 

total(s)

■ Select a number cell in any column of the PivotTable that contains the 

existing calculation.

■ Choose Options→Calculations-→Summarize Values By menu ▼, and 

choose a different function from the Ribbon. 

■ If desired, repeat for any other calculation listed separately in the Values 

area of the PivotTable Field List task pane. 

Create a calculated field to 

the right of existing 

PivotTable columns

■ Select any cell within the PivotTable. 

■ Choose Options→Calculations→Fields, Items, & Sets 

menu ▼→Calculated Field from the Ribbon.

■ Type a name in the Name box of the Insert Calculated Field 

dialog box.

■ Edit the formula =0 to the desired formula by double-clicking field names 

and typing other parts of the formula, including math symbols (such as + 

or *). 

Modify a formula in a 

calculated field

■ Choose Options→Calculations→Fields, Items, & Sets 

menu ▼→Calculated Field from the Ribbon.

■ Choose the calculated field name in the Name drop-down list (not the 

Field list) of the Insert Calculated Field dialog box.

■ Edit the formula and click Modify. 

WARNING

FROM THE KEYBOARD

[Ctrl]+[Alt]+[F5] to 
refresh all data sources

QUICK REFERENCE
Creating PivotTables 475
Labyrinth Learning  http://www.lablearning.com



Microsoft Excel 2010 (c) 2010 Labyrinth Learning • Not for Sale or Classroom Use
 E
va

lu
at

io
n 

O
nl

y

Change PivotTable Calculations 12.1.5

In this exercise, you will change the default SUM to a different function. You will create a calculated field to 
set a 110 percent contributions goal for each team leader. You also will change a value in the original source 
table and observe the effect upon PivotTables. 

1. Display the PivotTable by Pledge Level worksheet. 

Change a Function

2. Select a number cell in column B of the PivotTable. Then, choose Options→Calculation-
s→Summarize Values By menu ▼→Average from the Ribbon. 

The column heading changes to Average of Year 1 in the PivotTable and the Values area of the task 
pane. The subtotals and grand total now calculate averages. Notice that the Sum of  Year 2 column did 
not change. You must edit the function separately for each calculation listed in the Values area of the 
task pane. You will leave Sum of  Year 2 as is. 

Delete a calculated field ■ Choose Options→Calculations→Fields, Items, & Sets 

menu ▼→Calculated Field from the Ribbon.

■ Choose the calculated field name in the Name drop-down list (not the 

Field list) of the Insert Calculated Field dialog box.

■ Click Delete. 

Convert all data in a field to 

percentages of a total or 

calculate a difference, 

running total, or ranked order

■ If a duplicate field is desired to retain the original column data, drag and 

drop the field name from the upper part of the PivotTable Field List into 

the Values area.

■ Choose a number cell in the desired column of the PivotTable where you 

want to convert data.

■ Choose Options→Calculations→Show Values As menu , and choose 

the desired preset option from the Ribbon to convert all data in the field.

Refresh PivotTables after 

changing source data

■ Choose Options→Data→Refresh menu ▼ from the Ribbon and choose 

one of the following: 

◆ Refresh to update the active PivotTable.

◆ Refresh All (or use [Ctrl]+[Alt]+[F5]) to update all PivotTables in the 

workbook.

DEVELOP YOUR SKILLS 12.1.5

EDITING PIVOTTABLE CALCULATIONS AND REFRESHING DATA (continued)

Task Procedure

QUICK REFERENCE

▼

Fo
r
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Create a Calculated Field
Assume that you set a goal for all team leaders to increase contributions by 110 percent in Year 3. 

3. Choose Options→Calculations→Fields, Items, & Sets menu ▼→Calculated Field 

from the Ribbon.

4. Follow these steps to create a calculated field in the Insert Calculated Field dialog box:

The calculated field displays as the last column of the PivotTable. 

Change Worksheet Data
Cell C10 of the PivotTable shows that team leader Faber is responsible for $250,000 of Level 2 contributions 
in Year 2. Next, you will change a value in the table upon which the PivotTable is based.

5. Display the Sponsors Table worksheet. (Do not select the Sponsors Sheet tab.)

6. In cell F98 for Year 2, change 250,000 to 200000. 

7. Display the PivotTable by Pledge Level worksheet. 

Notice that Faber's level 2 amount in Year 2 still appears as 250,000 in cell C10. Changes to the source 
data do not automatically update in the PivotTables.

Refresh PivotTables

8. Choose Options→Data→Refresh menu ▼→Refresh All from the Ribbon. 

Faber's amount now appears as 200,000, and the goal was recalculated in cell D10. Any other 
PivotTables or PivotCharts based on the same source data would also be updated.

9. Save  the changes to your workbook. 

A Type Goal 110% Year 2 
in the Name box.

B Tap [Tab] to highlight =0 in the 
Formula box. Type an equals (=) 
sign to begin the formula.

C Double-click Year 2 and type 
*110% (make certain to type the 
asterisk) to finish the formula.

D Click Add. E Click OK.
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Video Lesson labyrinthelab.com/videos

A PivotChart presents data from a PivotTable. There are two ways to create a PivotChart.

1. You may chart an existing PivotTable by choosing a chart type from the Insert ribbon as for 

a normal Excel chart. 

2. You may use the PivotChart command to create a PivotTable and PivotChart from the 

source data at the same time. The chart builds as you choose fields in the PivotTable Field 

List task pane. 

The field(s) in the values area of the PivotTable are displayed as data series in the chart. The 

row labels in the PivotTable are used as the axis labels in the chart, and the column labels are 

the data series in the chart legend.

Filtering PivotCharts
The PivotChart may be filtered using the AutoFilter buttons on the chart, AutoFilter buttons 

on the PivotTable, or slicers added to the worksheet. (See the previous filtering topics in this 

lesson.) The filtering is applied to the related PivotTable as well.

Copy a PivotTable before creating a PivotChart. Any changes to the chart update in the 
PivotTable copy. The design in the original PivotTable will be preserved for further analysis.

12.2 Creating PivotCharts

The data may be filtered using the AutoFilter buttons. 
This chart is filtered to display only pledge level 6.

Labels in this chart area indicate any values 
fields selected in the PivotTable Field List. 
The chart columns depict those values

A PivotChart

Settings in the PivotTable Field List 
are applied to the PivotTable and any 
PivotChart based on the PivotTable.

TIP
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Formatting and Printing PivotCharts 
You format PivotCharts using the same Ribbon commands as for normal Excel charts. You 

choose from the same variety of chart styles, including column, line, and pie. You format chart 

objects just as you would on a normal Excel chart. Some chart formatting, such as data labels, 

is not preserved after a PivotChart is refreshed. When a PivotChart is selected, the Print 

command will print only the chart. By first selecting a worksheet cell, you can print both the 

PivotTable and PivotChart as displayed on the worksheet. 

Create a PivotChart 12.2.1

In this exercise, you will create a PivotChart from an existing PivotTable. 

1. Display the PivotChart worksheet of the Sponsors workbook. (Scroll to the right in the 

worksheet tabs to locate the tab, if necessary.)

Create a PivotChart

2. Select any cell within the PivotTable and choose Insert→Charts→Column. 

Below 2-D Column in the chart types menu, choose Clustered Column. 

A new column chart is created immediately from the settings in the PivotTable Field List.

Notice that while the PivotChart is selected, the Column Labels area of the PivotTable Field list task pane is 
labeled Legend Fields (Series). The Row Labels area is labeled Axis Fields (Categories).

WORKING WITH PIVOTCHARTS 

Task Procedure

Create a PivotChart 

from an existing 

PivotTable

■ Select any cell within the PivotTable. 

■ Choose Insert→Charts, and choose a chart type from the Ribbon. The chart is 

created next to the PivotTable. 

Create a PivotTable 

and PivotChart 

concurrently from 

a worksheet range or 

table

■ Select any cell in the worksheet range or table. 

■ Choose Insert→Tables→PivotTable menu ▼→PivotChart from the Ribbon.

■ Verify the worksheet range or table name in the Create PivotTable with 

PivotChart dialog box and click OK to place the PivotTable and PivotChart 

placeholders on a new worksheet. 

■ Choose options for the PivotTable in the PivotTable Field List task pane. 

These options also create a column PivotChart automatically. 

Modify PivotChart 

format

■ Select the chart and choose from the Design, Layout, and Format Ribbons as 

for a normal Excel chart. 

Filter data in a 

PivotChart

■ Choose the AutoFilter button on the PivotChart for the desired field, and 

choose filtering options from the drop-down list.

or

■ Choose Analyze→Data→Insert Slicer, choose the desired slicer(s), and 

click OK.

■ Choose the desired filtering criteria from the slicer(s). 

DEVELOP YOUR SKILLS 12.2.1

QUICK REFERENCE
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3. Point at the chart frame and drag the chart just 

below the PivotTable.

4. Place a checkmark next to Year 2 in the PivotTable 

Field List.

The Sum of Year 2 column displays in the PivotTable, and 
the PivotChart displays an additional column for the Sum of 
Year 2 series.

Filter the PivotTable and PivotChart
Notice that the PivotTable has been filtered to display pledge Levels 4–6. The PivotChart matches this 
filtering. You will use the AutoFilter button on the chart to remove pledge level 4. You could also use the Row 
Labels AutoFilter button on the PivotTable.

5. Follow these steps to filter the PivotChart:

Format the PivotChart

6. Select the chart, if necessary. 

7. Choose Design→Type→Change Chart Type→Column→Clustered Cylinder 

from the Ribbon and click OK.

The chart is reconfigured to the new chart type. You may use chart formatting commands on 
any PivotChart. 

8. Choose Layout→Labels→Chart Title→Centered Overlay Title from the Ribbon, type 

Levels 5 and 6 (your text appears in the Formula Bar), and tap [Enter]. 

9. Feel free to add other formatting to the chart. For example, the values labels on the vertical 

axis could be formatted as Currency with no decimals, as shown here. 

B Scroll down the list.

C Remove the checkmark 
next to Level 4.

D Click OK.

A Choose the Pledge Level 
AutoFilter button at the 
lower-left corner of the 
PivotChart.
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10. Save  the changes. 

11. Use [Ctrl]+[W] or the Close button shown to close the workbook but 

leave Excel open. 

Video Lesson labyrinthelab.com/videos

A macro is a recorded set of mouse and keyboard actions that can be played back at any time. 

Macros are useful for automating routine tasks, especially if those tasks are lengthy. Though 

macros are a huge timesaver for your frequently used procedures, they also are a prime way to 

pass viruses to computers. Therefore, be cautious about opening workbooks containing macros 

that you receive from others. 

Security Levels
You change macro security in the Trust Center section within Excel Options. Your setting there 

is in effect for all Excel workbooks that you open on your computer. The setting is not 

embedded in any workbooks that you save and share with others. You may choose among four 

different levels of security in Excel that control whether macros in an opened workbook are 

available or disabled:

■ Enable all macros—You are not protected from potentially unsafe macros. This option is 

not recommended for general use. 

■ Disable all macros except digitally signed macros—This option automatically disables 

unsigned macros and enables macros from publishers you previously added to the trusted 

publishers list in the Trust Center. An invisible digital signature or visible signature line 

may be added to an Excel workbook. 

■ Disable all macros with notification—This is the default option, and it displays a 

message allowing you to enable macros in the specified workbook if you wish or use the 

workbook without enabling the macros. 

■ Disable all macros without notification—Only macros in workbooks that you placed in 

a trusted location of the Trust Center are allowed to run. All other digitally signed and 

unsigned macros are disabled.

If you have antivirus software installed, the file will be scanned for viruses before it is opened 

regardless of the security level you set.

Your network system administrator may set macro security and prevent users from 
changing it.

12.3 Changing Macro Security 

CHANGING MACRO SECURITY

Task Procedure

Change macro security Choose File→Options →Trust Center→Trust Center Settings button→
Macro Settings, and choose a macro security option. 

NOTE

QUICK REFERENCE
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Verify Macro Security 12.3.1

In this exercise, you will verify the macro security setting on your computer. Then you will open a workbook 
and enable its macros.

1. Choose File→Options →Trust Center. Click the Trust Center Settings button and 

choose the Macro Settings category from the left side of the window. Choose Disable All 
Macros with Notification if not already selected. 

2. Choose the Message Bar category from the left side of the window. Verify that the 

following option is selected: Show the Message Bar in All Applications When 
Content, Such As ActiveX and Macros, Has Been Blocked. 

3. Click OK twice to exit the Excel Options window. 

4. Open the Macro Test workbook from the Lesson 12 folder in your file storage location. 

A Security Warning message displays below the Ribbon to alert you that macros are disabled. If you do 
not respond, the message will disappear after you begin working in the workbook. 

5. Click the Enable Content button next to the Security Warning. 

The macros are enabled. 

6. Click the Sort by Leader button.

The worksheet list should sort in order by team leader, indicating that the macro worked successfully. 

7. Close the workbook without saving changes. 

DEVELOP YOUR SKILLS 12.3.1
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❊

Video Lesson labyrinthelab.com/videos

Excel’s macro recording feature saves your keystrokes and the commands you issue for a task. 

For example, you may record steps to choose page layout options and print a document by 

clicking the appropriate commands in the Ribbon. You then may play back a recorded macro at 

a later time. This is similar to using a video camera. You turn it on, press the record button, and 

stop recording when finished. You may replay the recording as many times as you want. Simi-

larly, macros play back recorded keystrokes and mouse actions. 

Naming a Macro
You should name your macros. If you do not, Excel names them Macro1, Macro2, and so on. 

Name your macros following the same rules that are used for defined names for ranges. Macro 

names may not contain spaces but may include capital letters or underscores to separate 

words. For example, you may name a macro FormatTitle or Format_Title. 

Recording Macro Steps
Most actions you perform are recorded in the macro. These include mouse actions, choosing 

Ribbon commands, selecting options in dialog boxes, using cursor keys to navigate the work-

sheet, and typing text. Any mistakes and corrections you make during recording also are saved 

in the macro. You may decide not to rerecord the macro, however, if the final result is correct.

You should practice the procedure you wish to automate before you actually record the 
macro. This will help you avoid mistakes during the recording process.

Storing Macros
Macros are available only in the workbook in which you create them unless you assign them to 

the Personal Macro Workbook. 

Current Workbook
Some macros are useful only in a particular workbook. For example, you may develop a macro 

to sort worksheet rows in a specific manner. The macro is useful only in the workbook in 

which it is created, so you would choose the storage option This Workbook. 

Personal Macro Workbook
The Personal.xlsb file is a hidden file that makes its macros available in all open workbooks on 

your computer system. For example, you may create a macro to format headings with a consis-

tent style to be used in various workbooks. You will assign a macro to the Personal Macro 

Workbook and delete macros from it in a Skill Builder exercise of this lesson. 

12.4 Recording Macros

After the Record Macro button is clicked in the 
Status Bar, the Stop Recording button appears.

TIP
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Saving a Workbook Containing Macros
If you attempt to save a workbook containing macros using 

the normal Excel Workbook file format, Excel displays the 

message “The following features cannot be saved in macro-

free workbooks: VB Project.” Clicking No in the message box displays the Save As dialog box, 

where you should choose the Excel Macro-Enabled Workbook file format. The file is saved 

with the extension .xlsm in the file name to indicate that it contains a macro. 

Record a Macro 12.4.1

In this exercise, you will record a macro to sort a table first by team leader and then by the contributions to 
date. You will save the workbook in the macro-enabled file format. 

Before You Begin: Macro security should be set to Disable All Macros with Notification from Develop Your 
Skills 12.3.1.

Open the Workbook

1. Open the Contributions workbook.

Take a moment to review the worksheet. Notice that it contains a table of sponsors and that each 
sponsor has been assigned to a team leader. Also notice that the list is sorted in order by sponsor name, 
and the table's AutoFilter column heading buttons are turned off. The goal of the next few exercises is to 
sort the table and add new sponsors to the table. You will record macros to automate the sorting process.

RECORDING A MACRO

Task Procedure

Record a macro ■ Create the worksheet and prepare to record the macro. 

■ Click the Record Macro  button on the Status Bar in the lower-left 

corner of the window. 

■ Right-click the Status Bar and choose Macro Recording in the context 

menu if the button does not display. Tap [Esc] to hide the context menu.)

■ Type a descriptive name in the Macro Name box (spaces are not allowed) 

and fill in other options as desired. 

■ Click OK to begin recording.

■ Execute the commands and actions you want the macro to record. 

■ Click the Stop Recording  button on the Status Bar when you have 

finished recording. 

Delete a macro ■ Choose View→Macros→View Macros  (the top part of the button) 
from the Ribbon or use [Alt]+[F8].

■ Choose the desired macro name and click Delete. 

Save a workbook 

containing macros

■ Choose Save  and click No in the message box or choose Save As.

■ Choose Excel Macro-Enabled Workbook from the Save as Type list in the 

Save As dialog box. 

DEVELOP YOUR SKILLS 12.4.1

QUICK REFERENCE
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Record the Sort_by_Leader Macro

2. Click the Record Macro  button on the Status Bar at the bottom-left corner of the 

window. (Right-click the Status Bar and choose Macro Recording in the context menu 

if the button does not display. Tap [Esc] to hide the context menu.)

The Record Macro dialog box appears.

3. Follow these steps to name the macro and begin the recording process:

4. Click OK, and the macro will begin recording your actions.

If you make any mistakes, just correct the errors as you would normally. Major errors may be fixed 
either by stopping the recording and starting over or by editing the macro in the Visual Basic Editor 
(not covered in this lesson). 

5. Select cell B4 in the table.

This step ensures that the proper data is selected prior to sorting whenever the macro is run. 

6. Choose Data→Sort & Filter→Sort from the Ribbon. 

7. Follow these steps to set the Sort parameters and initiate the Sort:

8. Click the Stop Recording  button on the Status Bar at the bottom-left corner of the 

window. 

A Taking care to type an underscore 
using [Shift]+[-] between the 
words, type Sort_by_Leader 
to name the macro. (Spaces are 
not allowed in macro names.)

B Verify that This Workbook displays 
as the macro storage location.

C Type the description shown.

A Click the drop-
down button 
on the Sort By 
list and choose 
Team Leader.

B Click the Add 
Level button.

D Choose Largest to 
Smallest from the list.

E Verify that My Data Has Headers is on 
(the checkmark should already display).

F Click OK.

C Choose To Date 
from the list.
Recording Macros 485
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Your actions have been saved in the macro. The list is sorted as shown in the following illustration. Keep 
in mind that the macro recorded this sort sequence. 

Save the Workbook as Macro-Enabled

9. Click Save . 

A message displays as shown. The VB Project indicated is a Visual Basic Project module containing 
your macro. 

10. Click No to display the Save As dialog box. 

11. Edit the File Name to Contributions with Macros. 

12. Drop down the Save As type list, choose Excel 
Macro-Enabled Workbook, and click Save. 

The macro is saved as part of the workbook named 
Contributions with Macros.xlsm. If you were to close the workbook, the macro would be available the 
next time you opened the workbook. The Disable All Macros with Notification security setting is in 
effect, so you still can control whether macros actually are enabled in an opened workbook. 
486 Lesson 12: Creating PivotTables and Macros
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 You may run macros in a variety of ways. The method you use depends on 

how the macro was assigned. You may create a macro and assign it to a shortcut 

key, graphic, or Quick Access toolbar button. An unassigned macro must be run 

by using the Macros command on the Ribbon and selecting a macro. This proce-

dure may be used to run any macro recorded in the current workbook, even if the macro was 

assigned. The keyboard shortcut [Alt]+[F8] may be used to display the Macro dialog box. 

Run an Unassigned Macro 12.5.1

In this exercise, you will sort the contributions table manually in a different order and then run the 
Sort_by_Leader macro. 

Before You Begin: You must have completed Develop Your Skills 12.4.1, and the Contributions with Macros 
workbook should be open. Macro security should be set to Disable All Macros with Notification from 
Develop Your Skills 12.3.1. If you reopened the Contributions with Macros workbook and the Security 
Warning message appears under the Ribbon, choose Enable Macros. 

1. Select cell D4 and choose Data→Sort & Filter→Sort A to Z  from the Ribbon.

The contributions table is sorted alphabetically by sponsor name. Now you will run the macro you 
created in the previous exercise. 

2. Choose View→Macros→View Macros  from the Ribbon. 

3. Choose the Sort_by_Leader macro and click Run in the Macro dialog box. 

The list is sorted by team leader, then by the To Date amount in highest to lowest order within each 
team leader's rows. The macro saves you time because you did not need to choose the Sort command and 
set options manually. 

4. Save  the changes to the workbook.

12.5 Running Macros

RUNNING A MACRO

Task Procedure

Run an unassigned or assigned 

macro from the Ribbon 

■ Choose View→Macros→View Macros  from the Ribbon 

or use [Alt]+[F8]. 

■ Choose the desired macro name and click Run. 

Run an assigned macro ■ Use the shortcut key or click the assigned graphic, worksheet 

button, or Quick Access toolbar button. 

DEVELOP YOUR SKILLS 12.5.1

FROM THE KEYBOARD

[Alt]+[F8] to view 
macros

QUICK REFERENCE
Running Macros 487
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Video Lesson labyrinthelab.com/videos

You may run a macro from within the Macro dialog box. However, macros are more accessible 

if you assign them to shortcut keys, custom buttons or graphics on a worksheet, or buttons on 

the Quick Access toolbar. You then run the macro by issuing the shortcut key or clicking the 

object to which the macro is assigned. 

Assigning Macros to Shortcut Keys
Excel lets you assign a macro to a shortcut key as you name the macro. You may run the macro 

simply by using the shortcut key combination. You must use (Ctrl) or (Ctrl)+(Shift) as part of the 

shortcut key combination. Any shortcut you assign will override an existing Excel command 

shortcut. For example, you may assign (Ctrl)+[B] to a macro, but that combination would no 

longer choose Bold from the Ribbon.

If you are in the habit of using Microsoft’s command shortcuts, use (Ctrl)+(Shift) for your macro 
shortcuts.

Assign a Macro to a Shortcut Key 12.6.1

In this exercise, you will create a macro to add a new sponsor to the table and assign the macro to a shortcut 
key. You will run the macro to add a sponsor. Then you will assign a shortcut key to the macro you created 
in the previous exercise and use its shortcut key to sort the list. 

Before You Begin: You must have completed Develop Your Skills 12.4.1 and 12.5.1, and the Contributions 
with Macros workbook should be open. Macro security should be set to Disable All Macros with Notification 
from Develop Your Skills 12.3.1. If you reopened the Contributions with Macros workbook and the Security 
Warning message now appears under the Ribbon, choose Enable Macros. 

Assign a Shortcut Key and Record the Insert_Student Macro
You will record a new macro that automates the process of inserting a new sponsor record just below the 
table header row.

1. Click the Record Macro  button on the Status Bar. 

The Record Macro dialog box appears.

2. Follow these steps to name a new macro:

12.6 Assigning Macros

DEVELOP YOUR SKILLS 12.6.1

TIP

A Type Insert_Sponsor 
in the Macro Name box.

B Tap [Tab] to move to the 
Shortcut Key text box. Hold 
down [Shift] and tap [I] to set 
the shortcut as Ctrl+Shift+I.

C Verify that the macro will 
be stored in This Workbook.

D Leave the 
Description box 
empty. A description 
is optional.

E Click OK.
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In the next few steps, you will perform the actions to be recorded in the macro. You will insert a blank 
table row below the column headings and copy cell formatting to the blank cells. 

3. Select cell A4.

4. Taking care not to select the menu  button, choose Home→Insert from the Ribbon.

A blank row is inserted at row 4, and its cells are formatted like the column headings.

5. Select the range A5:G5, and choose Home→Clipboard→Format Painter  from the 

Ribbon.

6. Select cell A4 to apply the cell formatting from row 5 to the blank row 4.

7. Select cell A4 again to position the pointer for data entry. 

8. Click the Stop Recording  button on the status bar. 

Run the Macro to Add New Students

9. Delete the blank row 4 that you inserted while creating the macro. 

10. Use (Ctrl)+[Shift]+[I] to run the Insert_Sponsor macro. (Hold down [Ctrl], then also hold 

down [Shift], and then tap [I]. Release [Ctrl] and [Shift].) 

The pointer moves to cell A4 and blank cells are inserted. New sponsors always will be added to a new 
row below the header row. 

If your macro did not work correctly, choose View→Macros→Macros→Insert_Sponsor, and then 
click Delete. Then repeat steps 1–10, choosing Yes when asked if you wish to replace the macro.

11. Add the following sponsor to the table. Tap [Tab] after entering the Year 2 value, and the 

To Date total will be calculated automatically.

12. Run the Insert_Sponsor macro again and add this sponsor to the table:

Assign a Shortcut Key to the Sort_by_Instructor Macro

13. Choose View→Macros→View Macros  from the Ribbon. 

14. Choose the Sort_by_Leader macro and click Options in the Macro dialog box. 

15. In the Shortcut Key text box, press [Shift], and 

tap [L] to set the shortcut key to Ctrl+Shift+L. 

Click OK. 

16. Click Cancel to exit the Macro dialog box. 

17. Use [Ctrl)+[Shift]+[L] to run the macro. 

The table is sorted by team leader and then by To Date 
amount in highest to lowest order within each team 
leader group. The Raul T. Garcia record moves to row 98 in the Weinstein team leader group. The 
Wayne Zobe record moves to row 101.

18. Save  the changes to the workbook.

▼
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Assigning Macros to Custom Buttons
Video Lesson labyrinthelab.com/videos

A macro assigned to a custom button is run whenever the button is clicked. The easiest way to 

create a custom button is to add a shape, such as a rectangle, to the worksheet. You then 

assign a macro to the button. You may position custom buttons anywhere in a worksheet. To 

avoid deleting buttons in error, do not place them in rows or columns that could be deleted in 

the future. A custom button may also contain a descriptive label to help identify its function 

or the macro that is assigned to it.

You may create custom buttons using the Button (Form Control) tool on the Developer tab. 
To display this tab, choose File→Options from the Ribbon, select Customize Ribbon at the 
left of the Excel Options dialog box, and place a checkmark next to Developer in the Main 
Tabs list at the right. The Developer tab contains commands for working with macros.

Assign Macros to Custom Buttons 12.6.2

In this exercise, you will create buttons and assign the Insert_Sponsor and Sort_by_Leader macros to them. 

Before You Begin: Macro security should be set to Disable All Macros with Notification from Develop Your 
Skills 12.3.1. If you reopened the Contributions with Macros workbook and the Security Warning message 
appears under the Ribbon, choose Enable Macros. 

Create Buttons

1. Choose Insert→Illustrations→Shapes→Rectangles→Rectangle  shape tool from 

the Ribbon. 

2. Drag the mouse to draw a button on cell D1.

3. Copy and paste the button to cell E1. 

ASSIGNING A MACRO

Task Procedure

Assign a macro to a 

shortcut key as the macro 

is created 

■ Click the Record Macro  button on the Status Bar. 

■ While filling in options in the Macro dialog box, click in the Shortcut Key 

text box and key a single letter, or hold [Shift] and key the letter. 

Assign a macro to a 

shortcut key after the 

macro is created 

■ Choose View→Macros→View Macros  from the Ribbon. 

■ Choose the macro name and click Options in the Macro dialog box. 

■ In the Macro Options dialog box, click in the Shortcut Key text box and 

key a single letter, or hold [Shift] and key the letter. 

Assign a macro to a 

custom button or graphic 

on the worksheet

■ Record the macro. 

■ Insert a shape, picture, or clip art image on the worksheet. Right-click the 

object and choose Assign Macro from the context menu. Choose the 

desired macro from the Assign Macro dialog box. 

■ To display a text label in a shape used as a custom button, select the 

button in the worksheet and type the desired text in the button. 

■ If necessary, resize the button or graphic, drag it to the desired 

worksheet location, and align multiple buttons. 

DEVELOP YOUR SKILLS 12.6.2

TIP

QUICK REFERENCE
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Name Buttons

4. Select the first button and type Insert Sponsor; do not tap [Enter]. 

5. Select the second button and type Sort by Leader.

Button text may contain spaces because it is only a label. 

6. Click outside the button to deselect it. 

7. If necessary, align the buttons: Select the first button, 

use [Shift)+click to select the second button, and choose 

Format→Arrange→Align→ Align Top from the 

Ribbon. 

Formatting the buttons is easier if completed before you assign macros to the buttons. If you wish, you 
may change the colors and outline in custom buttons. 

Assign Macros to Buttons

8. Deselect the two buttons. 

9. Right-click the Insert Sponsor button and choose Assign Macro from the context menu. 

10. In the Assign Macro dialog box, choose Insert_Sponsor from the list and click OK. 

11. Use the preceding steps to assign the Sort_by_Leader macro to its button. 

Run Macros Using the Buttons

12. Deselect the button. 

13. Click the Insert Sponsor button to run the Insert_Sponsor macro. 

(Deselect the button and select again if the pointer does not display as a 

hand as you select the button.) 

A new row appears just below the header row. 

14. Add this sponsor to the new row:

15. Click the Sort by Leader button to run the Sort_by_Leader macro. 

The new row is sorted into the worksheet as row 5. 

16. Save  the changes and close the workbook. 

Now you have learned to create simple macros to automate routine tasks. You ran macros using the 
Ribbon, shortcut keys, and custom buttons on the worksheet.

Concepts Review labyrinthelab.com/excel10

To check your knowledge of the key concepts introduced in this lesson, complete the Concepts Review quiz by 
going to the URL listed above. If your classroom is using Labyrinth eLab, you may complete the Concepts 
Review quiz from within your eLab course.

12.7 Concepts Review
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Reinforce Your Skills

Create a PivotTable and a PivotChart
In this exercise, you will create a PivotTable and PivotChart simultaneously from a worksheet table. You 
will practice placing and pivoting fields to change your view of the data. 

1. Start Excel and open the rs-Jan Sales PivotTable workbook from the Lesson 12 folder. 

The January Sales worksheet displays one month’s activity at Avery Internet Auto Sales. Before you 
create a PivotTable, take a moment to look over the layout of the data fields and records. For example, 
notice that there is just one field for numeric data in this table. 

Create the PivotTable and PivotChart

2. Select cell A4. 

This tells Excel to use the table data when you create the PivotTable. 

3. Choose Insert→Tables→PivotTable  menu ▼→PivotChart from the Ribbon, verify 

JanSales as the table data to be used, and click OK to create a PivotTable and PivotChart 

in a new worksheet. 

4. Rename the Sheet1 sheet tab to PivotTable. 
The PivotTable Field List task pane is displayed. If it does not and you made certain the chart is selected, 
choose Analyze→Show/Hide→Field List. You may turn on/off the pane as needed. 

5. In the PivotTable Field List task pane, place a checkmark in the Sold By and Price 

checkboxes. 

The PivotTable displays the total sales for each salesperson using the Sum of Price field in the values 
area of the PivotTable Field List task pane. The chart is selected, so the task pane displays Axis Fields 
(Categories) and Legend Field areas. 

6. Select a cell in the PivotTable, and the same areas now are titled Row Labels and Column 

Labels to reflect those items in the PivotTable. 

REINFORCE YOUR SKILLS 12.1
Fo
r E
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Add a Field
Since you may need to know which types of cars each salesperson sold during January, you will place a new 
field in the row field’s area. 

7. Place a checkmark in the Type box on the task pane to add the field to the Row Labels 

area.

The PivotTable and PivotChart expand to display the sales of the various types of vehicles sold by each 
salesperson. It might also be interesting to summarize how the revenue at the dealership breaks down 
by vehicle type, so in the next step you will pivot the Type field from the row area to the column area. 

Arrange Items in the Window
You may not see the entire PivotTable and PivotChart as items change in the window. 

8. Follow these steps to maximize space:

A Undock the task pane by dragging 
its title bar down and to the left. The 
task pane now is smaller, and you 
may move it at any time.

B Resize the PivotTable 
Field List by dragging 
its bottom border up or 
down to keep desired 
options visible.

C To prevent the PivotChart from 
covering the PivotTable in the next 
step, move the PivotChart to the right 
by dragging the chart frame. until the 
left edge of the chart is in column G.
Reinforce Your Skills 493
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Pivot the View

9. Drag the Type field to the Column Labels area. 

The Grand Total line at the bottom of the PivotTable displays the revenue for each type of car. The chart 
displays columns for each car type. 

Add a Field and Pivot the View

10. Place a checkmark in the New/Preowned box on the task pane to add the field to the Row 

Labels area and observe the effect in the PivotTable and the PivotChart. 

11. Drag the New/Preowned field above Sold By in the Row Labels area of the task pane as 

shown. 

This view clearly shows that revenue is much greater for new cars than preowned, as might be expected.
494 Lesson 12: Creating PivotTables and Macros
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12. Move the PivotChart to below the PivotTable so both fit on one printed page.

13. Drag the PivotTable Field List task pane to the right edge of the screen, until the task pane 

is docked.

14. Select a cell in the PivotTable to deselect the PivotChart.

Only the chart would print when the chart is selected.

15. Save  the changes and close the workbook.

As you have seen, PivotTables and PivotCharts help you display and analyze data in various ways with 
a minimum of setup steps.

Filter a PivotTable
In this exercise, you will filter to exclude data items from a PivotTable. You also will use a slicer to filter by a 
field not displayed in the PivotTable. 

1. Open the rs-Feb Sales PivotTable workbook. 

Look at the table data in the February Sales worksheet. A PivotTable and a PivotChart were created 
using this data. 

2. Display the PivotTable worksheet. 

You will not use the field buttons in the PivotChart, so they were turned off in the Analyze ribbon.

3. Select a cell within the PivotTable to display the PivotTable Field List task pane, if 

necessary.

Use AutoFilter 

4. Follow these steps in the PivotTable to suppress the display of data for Walk-In sales:

Notice that no data is displayed for Walk-In sales, and the Row Headers filter button displays a filter 
icon. You may use this method to switch the display of individual data items on and off for any field in 
the Row Labels or Column Labels. 

5. Display the Row Labels filter list again and choose Clear Filter from “Source.” 

REINFORCE YOUR SKILLS 12.2

A Click the Row Labels 
AutoFilter button in cell A3.

B Remove the checkmark 
from the Walk-In box.

C Click OK.
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Delete and Add Fields in the PivotTable

6. In the PivotTable Field List task pane, remove the checkmark from the Source box. 

7. Place a checkmark in the Financing box to add the field to the PivotTable. 

The pie chart displays bank/credit union financing as 46 percent, dealer financing as 42 percent, and 
cash as 12 percent for all vehicles sold. 

Filter with a Slicer
Notice that the New/Preowned field does not have a checkmark in the PivotTable Field List, so the field does 
not appear in the PivotTable. At times, you may wish to maintain a simplified PivotTable and PivotChart 
design. You can use slicers to filter for fields that are not displayed. Next, you will filter for new and 
preowned vehicles.

8. Choose Insert→Filter→Slicer  from the Ribbon.

9. In the Insert Slicers dialog box, place a checkmark next to New/Preowned, and click OK.

The New/Preowned slicer displays on the worksheet window, and the PivotTable Filter List task pane is 
hidden. 

10. Point to the New/Preowned title in the slicer, and drag the slicer frame so it is not 

covering the PivotTable or PivotChart.

11. Choose New in the slicer.

The Sum of Price column in the PivotTable and the PivotChart percentages have changed to include 
only new vehicles. The pie chart displays Dealer financing as 46 percent but Cash financing as only 6 
percent of new vehicles sold.

12. Choose Preowned in the slicer.

The values and percentages update to include only preowned vehicles. Now you can see that dealer 
financing is only 21 percent and the majority of preowned vehicle purchases were paid in cash.

13. Select the PivotChart, choose Design→Chart Styles→More , and choose a chart 
style that displays good contrast between the colors of the text and pie slices.

14. Change the page orientation or resize the chart, if necessary, to fit the PivotTable and 

PivotChart on one printed page. 

15. Save  the changes and close the workbook.
Fo
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Create a Macro for the Personal Macro Workbook
In this exercise, you will create a macro that selects an entire worksheet, formats all cells with bold, and 
widens the columns. You will assign the macro to the personal macro workbook to make it available for use 
in other workbooks you may open.

Begin Recording the Macro

1. Start a new workbook.

2. Click the Record Macro button  on the Status Bar. 

3. Type the macro name FormatSheet in the Record Macro dialog box.

4. Set the Store Macro In option to Personal Macro Workbook.

Choose This Workbook instead if you cannot save a macro to the Personal Macro Workbook 
on your computer system.

5. Click OK (and replace the macro if it already exists) to begin the recording process. 

Set Worksheet Formats

6. Use [Ctrl]+[A] to select the entire worksheet. 

7. Use [Ctrl]+[B] to bold all cells.

8. Choose Home→Cells→Format →Column Width to display the Column Width 

dialog box, type 12, and tap [Enter] to choose OK. 

9. Select cell A1 to deselect the highlighted cells. 

10. Click the Stop Recording  button on the Run the Macro status bar. 

11. Choose File→Close  and choose not to save when Excel asks if you want to save the 

workbook. 

Run the Macro

12. Start a new workbook and choose View→Macros→View Macros  (the top part of 

the button) to display the Macro dialog box. 

Any macro with PERSONAL.XLSB! in its name has been saved to the Personal Macro Workbook and is 
available to all open workbooks. 

13. Choose the PERSONAL.XLSB!FormatSheet macro and click the Run button. (Choose 

FormatSheet rather than PERSONAL.XLSB!FormatSheet if you saved the macro to This 

Worksheet.) 

The column and text formats are set. Keep in mind that you may apply virtually any formatting to 
cells, columns, rows, text, or numbers with a macro. 

REINFORCE YOUR SKILLS 12.3

NOTE
F
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Delete the Macro from the Personal Macro Workbook
Macros stored in the Personal Macro Workbook cannot be removed with the Delete button in the Macro 
dialog box. Just read the next steps and complete step 20 if you saved the macro to This Workbook rather 
than Personal Macro Workbook. 

14. Choose View→Macros→View Macros  from the Ribbon.

15. Follow these steps to delete the FormatSheet macro from the Personal Macro Workbook: 

The macro code displays in the Microsoft Visual Basic for Applications window. 

16. In the Microsoft Visual Basic for Applications window, choose Tools→Macros.

17. In the Macros dialog box, set the Macros In option to VBA Project (PERSONAL.XLSB). 

18. Choose the FormatSheet macro, click Delete, and click OK to confirm.

19. Close  the Microsoft Visual Basic for Applications window to reveal the Excel work-

book window. 

In this exercise, you deleted the macro to keep the computer system “clean.” Normally, you would leave 
macros stored in the personal macro workbook so they could be used in all workbooks. 

20. Close the empty workbook without saving it. 

A If you don’t see the macro name, change the Macros In 
setting to All Open Workbooks.

B Click the PERSONAL.XLSB!FormatSheet macro from the 
list box (not from the first box under Macro Name).

C Click the Step Into button.
F
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Apply Your Skills

Create a PivotTable
In this exercise, you will create a PivotTable to calculate the cost of care and shelter for healthy and sick 
animals at Capital City Animal Shelter. 

1. Open the as-April Expenses workbook from the Lesson 12 folder. 

2. Examine the April Expense Report worksheet. Identify the fields you will use in the 

PivotTable. 

Create the PivotTable

3. Create a PivotTable on a new worksheet. 

4. Rename the new sheet with a descriptive name of your choice. 

5. Rename the PivotTable as April Expenses. 

6. Set up fields for the PivotTable so that the rows summarize the data by cats/dogs and then 

by age. 

7. Set up fields so that the columns compare the cost of caring for healthy and sick animals.

8. Set up fields to total the cost of care and shelter. 

Format the PivotTable

9. Apply a PivotTable style. 

10. Format all numbers with Comma Style and two decimal places. 

When you finish, your PivotTable should match the following figure, except for field labels.

Change Worksheet Data and Update the PivotTable

11. In the April Expenses worksheet, change the cost per day in cell F1 to $5.25.

12. Do whatever is necessary to update the PivotTable to reflect the change you just made. 

13. Save  the changes and close the workbook. 

APPLY YOUR SKILLS 12.1

Your PivotTable displays some additional 
labels. They were removed from this figure 
because they would display a significant 
part of the exercise solution.
Apply Your Skills 499
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Create a PivotTable and PivotChart
In this exercise, you will create a PivotTable and PivotChart that display the cost of care and shelter for sick 
and healthy animals summarized by animal type and health. The chart will be a stacked column chart. 

1. Open the as-May Expenses workbook. 

2. Examine the May Expense Report worksheet. Identify the fields you will use to create the 

PivotTable and its accompanying PivotChart. 

Create the PivotTable and PivotChart 

3. Create a PivotTable and PivotChart together on a new worksheet. 

4. Rename the new sheet with a descriptive name of your choice. 

5. Rename the PivotTable as May Expenses. 

6. Set up fields for the PivotTable and PivotChart so that the table and chart summarize the 

data by cats/dogs and then by health. 

7. Set up fields so that the shelter cost and veterinary cost are calculated separately. 

8. Format all numbers in the PivotTable with Comma Style and no decimal places. 

Format the PivotChart

9. Change the chart type to Stacked Column. 

10. Apply a PivotChart style and a chart layout of your choice. 

When you finish, your PivotTable and PivotChart should match the following figure, except for field 
labels.

11. Change the page orientation and make any other adjustments necessary to fit the Pivot-

Table and PivotChart on one printed page. 

12. Save  the changes and close the workbook. 

APPLY YOUR SKILLS 12.2

Your PivotTable displays one additional 
label. It was removed from this figure 
because it would display a significant 
part of the exercise solution.

Your PivotChart style and layout 
may differ from that shown.
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Create a Macro that Inserts the Date
In this exercise, you will create a macro that inserts the phrase Today’s Date in cell A1 and the TODAY() 
function in cell A2. The macro also will format the two cells. You will assign the macro to the current work-
book only. 

1. Start a new workbook containing three blank worksheets. 

2. Select cell A10. 

Record the Macro

3. Begin recording a new macro. 

4. Name the macro TodaysDate, assign the shortcut keystroke Ctrl+Shift+D to the 

macro, and store it in This Workbook. Your macro should record all of the actions in 

steps 5–11. 

5. Select cell A1. 

6. Type Today’s Date into cell A1. 

7. Enter the formula =TODAY()in cell B1. 

This function displays the current date in the cell. 

8. Left-align the date in cell B1. 

9. Format cells A1:B1 with size 12, bold, and a blue color for text. 

10. Set the width of column A to 20. 

11. Select cell B1. 

12. Stop the macro recording. 

13. Save  as a Macro-Enabled Workbook with the name as-Today’s Date in 

the Lesson 12 folder in your file storage location. 

Test the Macro Using the Ribbon Command

14. Display the Sheet2 worksheet. 

15. Run the macro using the Run command in the Macro dialog box. 

If your macro does not insert text, format the text, and widen column A as specified in steps 5–11, then 
delete the macro and rerecord it. 

Test the Macro Shortcut Key

16. Display the Sheet3 worksheet. 

17. Test the macro using the (Ctrl)+[Shift]+(D) keystroke combination. 

18. Have your instructor or a teaching assistant initial that you have successfully run the 

macro. __________

19. Save as as-Today’s Date again and close the workbook. 

APPLY YOUR SKILLS 12.3
Apply Your Skills 501
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Create Macros and Assign Buttons
In this exercise, you will create a defined name for a list, create two macros, assign buttons to them, and 
finally run the macros using the buttons. 

1. Open the as-Holiday Donations workbook.

2. Display the November Donations worksheet, if not already displayed.

3. Create two macros for use in this workbook only and assign them to buttons as shown in 

the following table. The table describes the button text, macro names, and macro functions 

for each button. Position the buttons above the list in rows 3:4. 

4. Save  as a Macro-Enabled Workbook in the Lesson 12 folder in your file storage 

location. 

Test the Macros

5. Manually sort the list in A to Z order by the type of donation in column C. 

6. Test the Sort_by_Patron macro. 

7. Test the Sort_by_Details macro. 

8. Have your instructor or a teaching assistant initial that you have successfully run the 

macros. __________

9. Save  again and close the workbook. 

APPLY YOUR SKILLS 12.4

Button Text Macro Name Macro Function

Sort by Patron Sort_by_Patron Sort the patron list in rows 6–16 in A to Z order based on the patron 

last names and first names in columns A:B. 

Sort by Details Sort_by_Details Sort the the patron list in rows 6–16 from largest to smallest based 

on the donation details in column D. 
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Critical Thinking & 
Work-Readiness Skills

In the course of working through the following Microsoft Office-based Critical 
Thinking exercises, you will also be utilizing various work-readiness skills, 
some of which are listed next to each exercise. Go to labyrinthelab.com/

workreadiness to learn more about the work-readiness skills.

12.1 Create a PivotTable and PivotChart
Dr. Edward Jackson, chief operating officer of Raritan Clinic East, would like a 

PivotTable and a PivotChart created from data to show a summary of patients’ 

daily drug charges in each hospital station by doctor name. Open ct-Raritan 

Clinic East Patients (Lesson 12 folder). Look at the Patients worksheet. Title the 

list appropriately and descriptively. You will adjust column widths in a later exer-

cise. Perform a two-column sort by Station then by Doctor. Insert both a Pivot-

Table and PivotChart into a new worksheet and rename the worksheet 

PivotChart. Set up the PivotTable to display daily cost totals by station and 

then by doctor name. Format the chart for appropriate size and appearance. Save 

your work as ct-Raritan Clinic East Patients [Your Last Name]. Keep the 

file open.

12.2 View Details using the PivotChart
Dr. Edward Jackson would now like to see a summary of patients. Open ct-

Raritan Clinic East Patients [Your Last Name], if necessary. Using options on the 

PivotTable Field List and the PivotChart, display the doctor specialty and doctor 

names, and then graph only Dr. Lawrence’s patients. Resize and move the chart, 

if necessary. Format the PivotChart worksheet to print on one page. Save your 

work, and keep the file open.

12.3 Create Macros
You have decided to help Dr. Edward Jackson be more productive by adding 

macros the Patients worksheet. If necessary, open ct-Raritan Clinic East Patients 

[Your Last Name]. On the Patients worksheet, create a macro to automatically 

insert today’s date in cell H1 and right align it. Create another macro to autofit 

the column widths. Test the macros by running them. Then, save as a macro-

enabled workbook. Close your file when you are finished.

WORK-READINESS 

SKILLS APPLIED

■ Organizing and 
maintaining 
information

■ Using computers to 
process information

■ Seeing things in the 
mind’s eye

WORK-READINESS 

SKILLS APPLIED

■ Seeing things in the 
mind’s eye

■ Organizing and 
maintaining 
information

■ Using computers to 
process information

WORK-READINESS 

SKILLS APPLIED

■ Showing 
responsibility

■ Making decisions

■ Selecting technology
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