
In this lesson, you will learn about Excel 
features that can help you perform 
sophisticated data analyses. These features 

include the VLOOKUP and HLOOKUP 
functions, PivotTables, and PivotCharts. With 
the VLOOKUP and HLOOKUP functions, you 
use one piece of information to obtain another 
within a list. PivotTables let you summarize 
worksheet data dynamically so it can be 
viewed in various ways. PivotCharts provide 
this same power and flexibility within charts. 
Additionally, since many Excel workbooks are 
used on a recurring basis, with the same tasks 
being performed repeatedly, you will also 
create macros that can automate repetitive 
tasks.

L E S S O N  O U T L I N E
Introducing Lookup Functions
Creating PivotTables
Creating PivotCharts
Changing Macro Security
Recording Macros
Running Macros
Assigning Macros
Concepts Review
Reinforce Your Skills

Apply Your Skills

Extend Your Skills

Transfer Your Skills

L E A R N I N G  O B J E C T I V E S
After studying this lesson, you will be able to:

■■ Create a lookup formula to locate a value or text 
in a list

■■ Create PivotTables and change their fields

■■ Create PivotCharts from PivotTable and 
worksheet data

■■ Set macro security to protect workbook data

■■ Record and run macros to automate tasks

12Using LOOKUP Functions, 
PivotTables, and Macros
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C A S E  S T U D Y

EX12.2

C A S E  S T U D Y

Analyzing Data Efficiently
Green Clean, a janitorial product supplier and cleaning service contractor, works 
in conjunction with select charitable entities to raise funds for environmental 
causes. You would like to evaluate the overall performance of the company’s 
fundraising team leaders. You would also like to examine the results of specific 
fundraising efforts that were overseen by these team leaders during the current 
year. You will use powerful data analysis tools—including the VLOOKUP 
function, PivotTables, and PivotCharts—to perform this analysis. You will also 
record macros to automate processes that will facilitate the analysis.

The VLOOKUP function 
is used to populate the 
Award Rate and Achieved 
Goal? columns.

This PivotTable illustrates 
one of many ways in 
which the data can be 
organized.

Lessons from Microsoft Office 2013 FOR EVALUATION ONLY (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Introducing Lookup Functions EX12.3

Ex
ce

l 2
01

3

Introducing Lookup Functions
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1201

The lookup functions VLOOKUP (Vertical Lookup) and HLOOKUP (Horizontal Lookup) are 
used to retrieve a piece of data from a lookup table located within the same worksheet, a 
separate worksheet, or a different workbook.

The same data arranged in a vertical lookup table (left) and a horizontal lookup table (right)

LOOKUP Function Syntax
The structure of the VLOOKUP and HLOOKUP functions is VLOOKUP or HLOOKUP(lookup 
value,table array,column (or row) index number,[range lookup]).

VLOOKUP FUNCTION ARGUMENTS

Argument Description

Lookup value The value in the worksheet to be looked up in the first column of the table array

Table array The cell range containing the lookup table, which may be expressed as absolute cell 
references or a defined name

Column index 
number

The column number in the table array that contains the corresponding data to be 
retrieved

Range lookup Optional; a logical value that specifies a search for an exact or approximate value in 
the table array (TRUE, the default) or an exact match only (FALSE)
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EX12.4 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

How the VLOOKUP Function Works
In the formula =VLOOKUP(D5,Award_Table,2), cell D5 contains the lookup value, the defined 
name Award_Table indicates the table array in which the search takes place, and the number 2 
(the column index number) indicates that the corresponding award rate will be retrieved from 
the second column of the lookup table. The search is conducted down the first column of the 
table array until the highest value not greater than the lookup value is located.

Cell E5 contains the 
VLOOKUP formula.

The Lookup Value

Excel searches the first 
column of the lookup table 
and stops at row 19 because 
the lookup value is at least 
$5,000 but not $10,000.

The award rate of 5% in the  
second column here is returned to cell E5.

When a lookup formula will be copied to other cells, the cell range of the table array should be 
expressed in the formula as a defined name or absolute cell references.

Specifying the Range Lookup Argument
In our example, Excel uses the default range lookup argument TRUE so the search is conducted 
in the first column of the table array for either an exact match of $6,810 or the closest value not 
greater than $6,810. At times, you may want to search only for an exact match of the lookup 
value. The formula =VLOOKUP(D5,Award_Table,2,FALSE) includes the FALSE range lookup 
argument. This restricts the search to an exact match. Using our example, since the first column 
of the table array ($E$16:$F$20) does not contain the exact lookup value of $6,810, Excel would 
display #N/A in the formula cell.

Sorting a Table Array
The rows in the table array must be sorted in lowest to highest (A to Z) order in the first column 
when the TRUE range lookup argument is used. This way, you can be assured that VLOOKUP 
will stop at the proper row and return the correct value. Sorting the table array is not required 
when the FALSE range lookup argument is used. 
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DEVELOP YOUR SKILLS EX12-D01

Use VLOOKUP
In this exercise, you will set up a three-column table array and use the VLOOKUP function to calculate 
award points and display messages.

1. Open EX12-D01-Awards from the EX2013 Lesson 12 folder and save it as EX12-D01-
Awards-[FirstInitialLastName].

Replace the bracketed text with your first initial and last name. For example, if your name is Bethany 
Smith, your filename would look like this: EX12-D01-Awards-BSmith.

2. Display the December worksheet. Complete the table 
array in the range E15:G20 by entering the numbers and 
text shown.

Use a minus sign to enter the negative numbers in the range 
E16:E17.

3. Follow these steps to create the range name:

 Select the range E16:G20.

 Type Award_Table 
in the Name box.

 Tap [Enter].

4. Select cell E5 and enter the formula =VLOOKUP(D5,Award_Table,2).

The 5 percent award rate is returned from the lookup table to cell E5.

5. Use AutoFill to copy the formula from cell E5 down to the range E6:E12. 

6. Select cell E7 and review the formula in the Formula Bar. 

The award rate returned from the lookup table is 0 percent. Notice that all arguments are the same for 
this function as the formula in cell E5, except that the relative cell reference instructs the VLOOKUP 
to look up the value from cell D7. 

7. Type =C5*E5 in cell F5 and use AutoFill to copy the commission formula to the range 
F6:F12.

The result in cell F5 is 1,591.
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EX12.6 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

8. Select cell G5, enter the function =VLOOKUP(D5,Award_Table,3), and use AutoFill to 
copy the quota message formula to the range G6:G12.

You used the same arguments for this function that you did in cell E5 except that the last argument is 
3 instead of 2. This instructs VLOOKUP to return the message text from column 3 of the table array. 
Rows 4–20 should match the following illustration.

9. Select cell F16 and change the rate to 1%.

The rate in cell E7 changed from 0 percent to 1 percent, and the corresponding award points in cell F7 
are now 525.

10. Click Undo  to change the entry back to 0% in cell F16.

11. Select cell G16 and change the message to Counsel.

Notice that the result in cell G7 changed to Counsel because you changed the message in the lookup 
table. 

12. Click Undo  to change the entry back to Under Achiever. 

13. Save and then close the file.
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Creating PivotTables
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1202

PivotTables are powerful data analysis tools. They let you summarize data in various ways and 
instantly change the view you use. A PivotTable not only subtotals groups of related data; it also 
compares one group to another.

Arranging the Source Data
You create PivotTables from columns or from a table in an Excel worksheet. The data should 
contain no blank rows or columns. Converting a list to a table is recommended when records 
will be added after the PivotTable is created. The additional table data are included 
automatically within the PivotTable when it is refreshed or updated. Data in a list are not 
included automatically. The following examples explain two PivotTables based on the 
worksheet list partially shown here.

The worksheet data

PivotTable Example 1
You can sort the preceding table by pledge level or sponsor category, but you cannot easily 
compare totals for the various pledge levels in each sponsor category. A PivotTable can 
summarize some or all data in any number of ways, and it creates grand totals. Each column in 
a PivotTable is a field. Examine the PivotTable and notice that the Sponsor Category field from 
the table is used for the row labels, the Pledge Level field for the column labels, and the Year 2 
field for the data area and grand totals. Each row displays the amount given by each sponsor 
group in the various pledge levels.

This PivotTable summarizes contributions by sponsor category.
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EX12.8 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

PivotTable Example 2
In this example, data is summarized first by pledge level and then by sponsor category. To create 
this type of view, the PivotTable layout shown in the following illustration contains the Pledge 
Level and then Sponsor Category fields for row labels, no column labels, and the Year 2 field for 
the data area and totals.

This PivotTable layout summarizes contributions 
first by pledge level and then by sponsor category.

How PivotTables Work
Each area of a PivotTable plays a role in data organization. The PivotTable Fields task pane 
displays after you define the worksheet range to be used. The areas of the task pane are 
explained in the following illustration, which displays the settings for PivotTable Example 1.

Here you choose columns that 
will appear in the PivotTable.

Row labels are displayed here.

You can filter fields you 
have chosen by dragging 
them here.

Column labels are 
displayed here.

This area displays 
the field on which a 
calculation is performed 
within the PivotTable.
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NOTE

 You must select a cell in the PivotTable to display the PivotTable Fields task pane.

Where you place fields within the PivotTable Fields task pane determines how the PivotTable 
summarizes the data. By choosing different fields or dragging and dropping a field, you can 
quickly compare data in various ways. You may choose from several functions—such as SUM, 
COUNT, and AVERAGE—to calculate fields containing values.

QUICK REFERENCE CREATING A PIVOTTABLE

Task Procedure

Create a PivotTable 
from a worksheet 
range or table

■■ Select a cell in the worksheet range/table and choose Insert→Tables→PivotTable.

■■ Verify the worksheet range/table name, choose the PivotTable position, and 
click OK. 

■■ In the PivotTable Fields task pane, place a checkmark by each worksheet field to 
be included in order.

■■ If necessary, drag and drop field names to the correct areas: Filters, Rows, 
 Columns, or Values.

Name a PivotTable ■■ Choose PivotTable Tools→Analyze→PivotTable.

■■ Type the name in the PivotTable Name Box (spaces are allowed) and tap [Enter].

Display the 
PivotTable Fields 
task pane

■■ Select any cell within the PivotTable.

■■ If the task pane is turned off, choose PivotTable Tools→Analyze→Show→ 
Field List.

  The Recommended PivotTables command offers various preset PivotTables. These can be 
accessed by choosing Insert→Tables→Recommended PivotTables.

DEVELOP YOUR SKILLS EX12-D02

Create PivotTables
The best way to understand the dynamic capabilities of a PivotTable is to create one. In this exercise, you 
will create PivotTables from a worksheet range and a table. 

1. Open EX12-D02-Sponsors from the EX2013 Lesson 12 folder and save it as EX12-D02-
Sponsors-[FirstInitialLastName].

You will create a PivotTable that summarizes Year 2 by pledge level with subtotals for each sponsor 
category. 

2. Select cell B4 and choose Insert→Tables→PivotTable.

2013
NEW!
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EX12.10 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

3. Verify that the table/range agrees with the one displayed here, and then click OK.

A new worksheet appears and contains an empty PivotTable placeholder. The PivotTable Fields task 
pane also displays. If the task pane is turned off, choose PivotTable Tools→Analyze→Show→Field 
List. 

4. Rename Sheet1 to PivotTable by Sponsor Category, and then select cell A1. 

The PivotTable Fields task pane disappears when you select the cell, which is outside the boundary of 
the PivotTable outline.

5. Select cell A3 to restore the task pane.

6. Follow these steps to define the PivotTable in the task pane:

 Drag the Pledge Level field to the Columns area.

 Place a checkmark 
next to Pledge Level, 
Sponsor Category, 
and Year 2.

In the PivotTable, notice that the sponsor categories are displayed one per row, the six pledge levels 
are displayed one per column, and the Year 2 contributions data are summarized with totals for each 
sponsor category in column H and each pledge level in row 19.
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7. Choose PivotTable Tools→Analyze→PivotTable→Options. 

8. Type BySponsorCategory in the PivotTable name text box and tap [Enter]. 

Create a PivotTable from a Worksheet Table
The steps for creating a PivotTable from a worksheet table are the same as for a worksheet range. This time 
your PivotTable will group data by pledge level, with the sponsor categories in alphabetical order within 
each pledge level. 

9. Display the Sponsors Table worksheet.

10. With any table cell selected, choose Insert→Tables→PivotTable, verify that the 
suggested range is the Sponsors_Table, and click OK. 

11. Rename the new sheet PivotTable by Pledge Level. In the PivotTable Fields task 
pane, place a checkmark next to field names in this order: Pledge Level, Sponsor 
Category, Year 2. 

The records are grouped by pledge level, with the sponsor categories in alphabetical order within each 
pledge level. The Year 2 subtotal displays for each pledge level, and a grand total appears at the bottom 
of the column.

12. Choose PivotTable Tools→Analyze→PivotTable→Options. 

13. Type ByPledgeLevel in the PivotTable name text box and tap [Enter]. 

14. Save the file and leave it open; you will modify it throughout this lesson.
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EX12.12 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

Formatting a PivotTable
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1203

Values and subtotals in a PivotTable do not automatically display the formatting from the 
original worksheet cells. You may select and format one or more specific cells in the PivotTable 
using standard Ribbon commands. Alternatively, the PivotTable Tools Design contextual tab 
contains a large selection of PivotTable styles that can be used to quickly apply color, shading, 
and gridlines. The report layout displays in Compact Form by default, but you may choose from 
two other layouts. The subtotals may be displayed at the top or bottom of each group, or can be 
hidden.

Compact form Tabular form

QUICK REFERENCE FORMATTING A PIVOTTABLE

Task Procedure

Apply number 
formatting to a field

Right-click a column cell in the PivotTable, choose Number Format, and choose 
options from the Format Cells dialog box. (Don’t choose Format Cells, which 
formats the selection rather than entire columns.)

Change the 
subtotals or grand 
totals display

Choose PivotTable Tools→Design→Layout→Subtotals or Grand Totals and choose 
the desired option.

Apply a PivotTable 
style

Choose PivotTable Tools→Design→PivotTable Styles→More and choose the 
desired style.

Apply a report 
layout

Choose PivotTable Tools→Design→Layout→Report Layout and choose Compact 
(default), Outline, or Tabular.
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DEVELOP YOUR SKILLS EX12-D03

Format a PivotTable
In this exercise, you will format selected cells, apply number formatting to values columns, choose a 
PivotTable style, and explore the report layout choices. 

1. Save your file as EX12-D03-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Sponsor Category worksheet, select the range B4:H4, and 
right-align the labels.

3. Choose PivotTable Tools→Design→Layout→Grand Totals. Experiment by choosing 
each option and observing its result, and then choose On for Rows and Columns.

4. Select any cell in the PivotTable.

5. Follow these steps to format the Year 2 contribution numbers:

 Choose the Number 
category.

	Set 0 in the Decimal 
Places box.

	Place a checkmark 
in the Use 1000 
Separator (,) box.

 Click OK.

 Right-click any number 
in the range B5:H19 and 
choose Number Format.

All number columns are displayed with the formatting you chose because they all are part of the Sum 
of Year 2 field.

6. Display the PivotTable by Pledge Level worksheet.

7. Click in the PivotTable, choose PivotTable Tools→Design→PivotTable Styles→More , 
and choose Pivot Style Medium 9. 

This style shades the subtotal rows. 

8. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline 
Form. 

This layout divides the Pledge Level and Sponsor Category fields into separate columns. Both column 
headings display a filter button. 

9. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Tabular 
Form. 

This layout displays a subtotal row below its detail rows.

10. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Compact 
Form to return to the original layout.

11. Save the file and leave it open.
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EX12.14 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

Changing PivotTable Fields
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1204

You may add or remove fields on a PivotTable simply by adding or removing the checkmark next 
to the field name in the PivotTable Fields task pane. The PivotTable will automatically reconfigure 
to display the new data. You may also change the order of fields within the row and column areas. 
One of the most powerful ways of manipulating data is to move a field from the row area to the 
column area or vice versa. This is called pivoting the field (hence the name PivotTable). The display 
of the data field rotates to give you an entirely different view of your data, as illustrated in the two 
PivotTables you created in the previous exercise. There, you positioned the Pledge Level field to 
display as columns in the first PivotTable and as rows in the second.

Pledge Level fields displayed as columns

Pledge Level fields displayed as rows
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DEVELOP YOUR SKILLS EX12-D04

Change PivotTable Fields
In this exercise, you will add fields to the PivotTable and reorder the field display. You will also pivot 
the view.

1. Save your file as EX12-D04-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Pledge Level worksheet.

3. Place a checkmark next to Year 1 in the task pane to add this field to the PivotTable. 

The Year 1 values are summed with subtotals and a grand total.

4. Right-click any cell in the Sum of Year 1 column of the PivotTable and choose Number 
Format.

5. In the Format Cells dialog box, choose the Number category, set 0 decimal places, check 
the Use 1000 Separator (,) option, and click OK.

6. Repeat steps 4–5 to format the Sum of Year 2 column.

7. Drag Sum of Year 2 below Sum of Year 1 in the Values area.

The PivotTable now displays the columns for both years in the order listed in the Values area of the 
task pane.

8. Place a checkmark by the Sponsor Name field in the top section of the PivotTable Fields 
task pane.

Notice the order of the fields in the Row Labels area. Now the sponsors and their contribution 
amounts are displayed within each sponsor category. Adding or deleting row labels allows you to 
control the level of detail displayed in a PivotTable.
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EX12.16 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

9. Remove the checkmark by the Sponsor Category and Sponsor Name fields in the 
PivotTable Fields task pane; add a checkmark next to Team Leader.

The team leader totals appear within each pledge level. Notice that some team leaders appear in 
multiple pledge levels. This view makes it easy to compare Year 1 and Year 2 data.

10. Drag the Team Leader field from the Rows area to the Columns area below the Values 
field.

You just pivoted the team leader field to be displayed in columns rather than rows. Now you can 
compare each team leader’s overall performance among the various pledge levels.

11. Undo  the pivot.

12. Save the file and leave it open.
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Filtering a PivotTable with AutoFilter
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1205

You may set the PivotTable to filter, or include, specific items in the data summaries. The totals 
and subtotals are recalculated for the selected items. The Row Labels and Column Labels 
headings have an AutoFilter button that displays the same sorting and filtering options that are 
available on the columns of worksheet lists and tables.

The field to be 
filtered The AutoFilter 

button

Additional filtering 
commands, such as 
Begins With and Greater 
Than, are available here.

Select specific 
pledge levels here.

Filtering PivotTables with Slicers
Slicers are menu frames displayed on worksheets that contain all filtering choices in one field. 
Selected items are highlighted in slicers, making it easy to identify currently applied criteria. 
Slicer frames may be resized, moved, and formatted with styles for a consistent appearance. 
Slicers may also be shared in other worksheets of the same workbook for use with multiple 
PivotTables based on the same data set. Changing the filtering selections in a shared slicer 
causes all connected PivotTables to update automatically.

Highlighted items are 
included in the current filter.

The Clear Filter button

Dimmed items are not available in 
the current filter (Pledge Level 1 
contains no corporate grants).

Lessons from Microsoft Office 2013 FOR EVALUATION ONLY (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY

http://labyrinthelab.com/videos


EX12.18 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

QUICK REFERENCE CHANGING PIVOTTABLE FIELD ORDER AND FILTERING PIVOTTABLE DATA

Task Procedure

Change the field 
order in rows/
columns

■■ Drag a field name above/below another field in an area list at the bottom of the 
PivotTable Fields task pane.

Remove a field ■■ Uncheck the field name from the PivotTable Fields task pane.

Filter for specific 
items using 
AutoFilter

■■ Click the AutoFilter button next to Row (or Column) Labels, choose a field in the 
filtering list, and remove the checkmark from the desired item(s); or, choose Label 
Filters, Value Filters, or Date Filters, depending on the data type.

Filter for specific 
items using slicers

■■ Select any PivotTable cell and choose PivotTable Tools→Analyze→Filter→Insert 
Slicer.

■■ Place a checkmark next to the desired fields and click OK.

■■ Choose one or more items in slicers, as desired. (To select multiple items, hold 
down [Ctrl] while clicking each item. To remove items from a multiple selection, 
hold down [Ctrl] while clicking items.)

Clear a filter from a 
slicer

■■ Click the Clear Filter  button.

Move and resize a 
slicer

■■ Point to a slicer’s frame or title bar and drag to the desired location on the 
 worksheet.

■■ Drag a corner or side handle on the slicer frame to resize the slicer.

Display slicer 
buttons in multiple 
columns

■■ Select the slicer, choose Slicer Tools→Options→Buttons→Columns, and choose 
the number of columns.

Apply a style to a 
slicer

■■ Select the slicer, choose Slicer Tools→Options→Slicer Styles→More, and 
choose a style.

Connect a slicer 
to additional 
PivotTables based 
on the same 
data set

■■ Select the slicer and choose Slicer Tools→Options→Slicer→Report Connections.

■■ Place a checkmark by the PivotTable name(s) to which you wish to connect the 
slicer and click OK.

DEVELOP YOUR SKILLS EX12-D05

Filter a PivotTable with Slicers
In this exercise, you will display slicers on a PivotTable worksheet. You will move, resize, and format the 
slicers to fit around the PivotTable. Then, you will select items from the slicers to filter the PivotTable to 
look at the data in various ways.

1. Save your file as EX12-D05-Sponsors-[FirstInitialLastName].

2. Display the PivotTable with Slicers worksheet.

The PivotTable displays the Sponsor Categories field as rows and the Sum of Year 1 and Sum of Year 2 
fields as columns.

3. Select any cell in the PivotTable and choose PivotTable Tools→Analyze→Filter→Insert 
Slicer. 

4. Place a checkmark next to Pledge Level, Team Leader, and Sponsor Category; click OK.

5. Select cell A1 to hide the PivotTable Fields task pane, if still displayed.
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6. Follow these steps to move and resize the Sponsor Category slicer:

	If necessary, drag Pledge Level 
and Team Leader slicers away 
from columns D–E.

 Point at the Sponsor 
Category’s title bar and drag 
the slicer to the right of the 
PivotTable.

 Point at the lower-right 
corner handle on the slicer 
frame and drag down and right 
to display all sponsor category 
names.

7. Drag the Pledge Level and Team Leader slicers to row 19.

8. Click the Pledge Level title to display the slicer’s frame, and then hold down [Shift] and 
click the Team Leader title.

Frames appear around the two slicers to indicate that both are selected.

9. Choose Slicer Tools→Options→Buttons→Columns  and change the number of 
columns to 2.

10. Click the Sponsor Category title in the slicer at the right of the PivotTable, choose Slicer 
Tools→Options→Slicer Styles→More, and choose any style.

11. Apply the styles of your choice to the Pledge Level and Team Leader slicers.

12. Choose Level 2 in the Pledge Level slicer.

The Team Leader slicer shows that Debowski, Faber, Lemus, Martinez, and Weinstein are included in 
the PivotTable totals. The buttons are dimmed for the other team leaders because they did not solicit 
any contributions at Pledge Level 2.

The seven sponsor categories with contributions at Level 2 are displayed in the PivotTable, matching 
the seven highlighted buttons in the Sponsor Category slicer.
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13. Click the Clear Filter  button on the Pledge Level slicer.

14. Select Corporate Sponsorship in the Sponsor Category slicer, hold down [Ctrl], and select 
Individual Sponsorship.

The PivotTable and slicers reflect the additional category.

15. Save the file and leave it open.

Editing PivotTable Calculations
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1206

You are not limited to summing values in a PivotTable, and you may create formulas within 
PivotTables when necessary.

Changing the Function for a Values Area Item
By default, the subtotals and grand totals in a PivotTable sum the values in a field. You may 
change the SUM function to a different function, such as AVERAGE, MAX, or COUNT.

If the Values area of the PivotTable Fields task pane contains only one entry, all SUM columns 
will change to the function you selected. If multiple entries exist in the Values area, you may 
change the function for one entry at a time.

Creating a Calculated Field
Some functions are not available on the Summarize Values By tab of the Value Field Settings 
dialog box. These functions may be typed in the Insert Calculated Field dialog box. A calculated 
field contains a formula using values from one or more existing fields. For example, the formula 
could subtract the value in one field from another to find the difference. 

TIP

 For accuracy, you should select field names from the list rather than type their names when 
creating the formula for a calculated field.

Here, you create 
a formula for a 
calculated field.

Field names may be 
selected from this list for 
insertion in the formula.
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Converting Column Data to a Calculation
The Show Values As tab of the Value Field Settings dialog box can be used to create formulas 
employing preset options. For example, you can calculate percentages of a total, the difference 
between values in two columns, a running total, or a ranked order. If you want to display the 
original column data along with the converted data, simply drag and drop the field name from 
the field list to the Values area to create a duplicate field.

Refreshing PivotTable Data
PivotTables are often created with data from sources external to the Excel 
workbook containing the PivotTables. After you change the source data—
even if in a worksheet range or table within the same workbook—you must 
refresh the PivotTables manually. You may refresh just the active PivotTable 
or all PivotTables in the workbook. You may also set a PivotTable option to 
refresh data from external sources when the workbook is opened. 

QUICK REFERENCE EDITING PIVOTTABLE CALCULATIONS AND REFRESHING DATA

Task Procedure

Change the 
summary function

■■ Select a number cell in any PivotTable column that contains the existing calculation.

■■ Choose PivotTable Tools→Analyze→Active Field→Field Settings, choose a different 
function, and click OK.

Create a calculated 
field to the right of 
existing PivotTable 
columns

■■ Select any PivotTable cell.

■■ Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets→ 
Calculated Field and type a name in the Name box.

■■ Edit the formula =0 by double-clicking field names and typing other parts of the 
formula, click Add, and click OK.

Modify a formula in 
a calculated field

■■ Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets→ 
Calculated Field.

■■ Choose the calculated field name in the Name drop-down list (not the Field list), 
edit the formula, and click OK.

Delete a calculated 
field

■■ Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets→ 
Calculated Field.

■■ Choose the calculated field name in the Name drop-down list (not the Field list), 
click Delete, and click OK.

Convert all data in a 
field to percentages 
or calculate a 
difference, running 
total, or ranked 
order

■■ If a duplicate field is desired to retain the original column data, drag and drop the 
field name into the Values area.

■■ Right-click a number cell in the desired column of the PivotTable and choose 
Show Values As.

■■ Choose the desired preset option, and if necessary, select the desired options; 
click OK.

Refresh PivotTables 
after changing 
source data

■■ Choose PivotTable Tools→Analyze→Data→Refresh menu  and choose 
Refresh or Refresh All.

FROM THE RIBBON

PivotTable Tools→ 
Analyze→Data→ 
Refresh →Refresh or 
Refresh All

FROM THE KEYBOARD
[Ctrl]+[Alt]+[F5] to 
refresh all data sources
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DEVELOP YOUR SKILLS EX12-D06

Change PivotTable Calculations
In this exercise, you will change the default SUM to a different function. You will also create a calculated 
field and change a value in the original source table.

1. Save your file as EX12-D06-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Pledge Level worksheet.

3. Select a number cell in column B of the PivotTable, and then choose PivotTable 
Tools→Analyze→Active Field→Field Settings.

4. Select Average on the Summarize Values By tab and click OK.

The column heading changes to Average of Year 1 in the PivotTable and the Values area of the task 
pane. The subtotals and grand total now calculate averages. The Sum of Year 2 column did not 
change.

5. Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & 
Sets→Calculated Field.

6. Follow these steps to create a calculated field:

 Type Goal 110% Year 
2 in the Name box.

 Type an equals sign to 
begin the formula.

 Double-click Year 2 
and type *110%.

 Click Add.

 Click OK.

The calculated field displays as the last column of the PivotTable.
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Change Worksheet Data
Now you will change a value in the table upon which the PivotTable is based.

7. Display the Sponsors Table worksheet.

8. In cell F98 change 250,000 to 200000, and then display the PivotTable by Pledge Level 
worksheet. 

Faber’s level 2 amount in Year 2 still appears as 250,000 in cell C10. Changes to the source data do 
not automatically update in the PivotTables.

9. Choose PivotTable Tools→Analyze→Data→Refresh menu →Refresh All.

Faber’s amount now appears as 200,000, and the goal was recalculated in cell D10. Any other 
PivotTables or PivotCharts based on the same source data would also be updated.

10. Save the file and leave it open.

Creating PivotCharts
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1207

A PivotChart presents data from a PivotTable. There are two ways to create a PivotChart.

1. Chart an existing PivotTable by choosing a chart type from the Insert tab, as you would do for 
a normal Excel chart. 

2. Use the PivotChart command to create a PivotTable and PivotChart from the source data at 
the same time. The chart builds as you choose fields in the PivotTable Fields task pane. 

The fields in the values area of the PivotTable are displayed as data series in the chart. The row 
labels in the PivotTable are used as the axis labels in the chart; the column labels are the data 
series in the chart legend.
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Filtering PivotCharts
The PivotChart may be filtered using the AutoFilter buttons on the chart, AutoFilter buttons on 
the PivotTable, or slicers added to the worksheet. The filtering is applied to the related 
PivotTable as well.

The chart columns 
depict the PivotTable 
column values.

The data may be 
filtered using the 
AutoFilter buttons.

TIP

 To retain an original PivotTable, copy it before creating a PivotChart, as any changes to the 
chart will update the PivotTable copy.

Formatting and Printing PivotCharts
You format PivotCharts using the same Ribbon commands as you do for normal Excel charts. 
Some chart formatting, such as data labels, is not preserved after a PivotChart is refreshed.

QUICK REFERENCE WORKING WITH PIVOTCHARTS

Task Procedure

Create a PivotChart 
from an existing 
PivotTable

■■ Select any cell within the PivotTable.

■■ Choose Insert→Charts and choose a chart type. The chart is created next to the 
PivotTable.

Create a PivotTable 
and PivotChart 
concurrently from  
a worksheet range 
or table

■■ Select any cell in the worksheet range/table and choose 
Insert→Charts→PivotChart menu →PivotChart & PivotTable.

■■ Select the desired options and click OK.

■■ Choose options for the PivotTable/PivotChart in the PivotTable Fields/PivotChart 
Fields task pane.

Modify a PivotChart 
format

■■ Select the chart and choose from the PivotChart Tools→Design and/or 
PivotChart Tools→Format tab commands.

Filter data in a 
PivotChart

■■ Choose the AutoFilter button on the PivotChart for the desired field, 
choose the desired filtering options, and click OK. Or, choose PivotChart 
Tools→Analyze→Filter→Insert Slicer, choose the desired slicer(s), and click OK. 
Then choose the desired filtering criteria from the slicer(s).
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DEVELOP YOUR SKILLS EX12-D07

Create a PivotChart
In this exercise, you will create a PivotChart from an existing PivotTable.

1. Save your file as EX12-D07-Sponsors-[FirstInitialLastName].

2. Display the PivotChart worksheet. 

3. Select any cell within the PivotTable, and then choose Insert→Charts→Insert Column 
Chart→2-D Column→Clustered Column.

4. Point at the chart frame and drag the chart just below the PivotTable.

5. Place a checkmark next to Year 2 in the PivotChart 
Fields list.

The Sum of Year 2 column displays in the PivotTable, 
and the PivotChart displays an additional column for the 
Sum of Year 2 series.

6. To filter the PivotChart, choose the Pledge Level 
AutoFilter button at the lower-left corner of the 
PivotChart, remove the checkmark next to Level 4, 
and click OK.

7. Select the chart, choose PivotChart Tools→Design→Type→Change Chart 
Type→Column→3-D Clustered Column, and click OK.

The chart is reconfigured to the new chart type.

8. Save and close the file.

Changing Macro Security
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1208

A macro is a recorded set of mouse and keyboard actions that can be played back at any time. 
Macros are useful for automating routine tasks, especially if those tasks are lengthy. Macros can 
contain viruses, so be cautious about opening workbooks containing macros that you receive 
from others.

Security Levels
You change macro security in the Trust Center section within Excel Options. 
Your setting there is in effect for all Excel workbooks that you open on your 
computer. The setting is not embedded in any workbooks that you save and 
share with others. You may choose among four different levels of security in 
Excel that control whether macros in an opened workbook are available or 
disabled.

FROM THE RIBBON

File→Options→Trust 
Center→Trust Center 
Settings→Macro 
Settings

Lessons from Microsoft Office 2013 FOR EVALUATION ONLY (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY

http://labyrinthelab.com/videos
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■■ Enable all macros: You are not protected from potentially unsafe macros. This option is not 
recommended for general use.

■■ Disable all macros except digitally signed macros: This option automatically disables 
unsigned macros and enables macros from publishers previously added to the trusted 
publishers list in the Trust Center.  

■■ Disable all macros with notification: This is the default option that displays a message 
allowing you to enable macros in the specified workbook or use the workbook without 
enabling macros. 

■■ Disable all macros without notification: Only macros in workbooks that you placed in a 
trusted location of the Trust Center will run. All other digitally signed and unsigned macros 
are disabled.

If you have antivirus software installed, the file will be scanned for viruses before it is opened 
regardless of the security level set. Also, note that your network system administrator may set 
macro security and prevent users from changing it.

DEVELOP YOUR SKILLS EX12-D08

Verify Macro Security
In this exercise, you will verify the macro security setting on your computer. Then you will open a 
workbook and enable its macros.

1. Choose File→Options→Trust Center. 

2. Click the Trust Center Settings button, choose the Macro Settings category, and choose 
Disable All Macros with Notification (if necessary).

3. Choose the Message Bar category from the left side of the window. Verify that the Show 
the Message Bar… option is selected.

4. Click OK twice to close both dialog boxes.

5. Open EX12-D08-MacroTest from the EX2013 Lesson 12 folder.

6. Click Enable Editing below the Ribbon if necessary. Save the file as EX12-D08-
MacroTest-[FirstInitialLastName].

A Security Warning message may display below the Ribbon to alert you that macros are disabled.

7. Click the Enable Content button , if necessary. 

The macros are enabled. 

8. Click the Sort by Leader button.

The worksheet list should sort in order by team leader, indicating that the macro worked successfully. 

9. Close the file without saving changes.
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Recording Macros
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1209

Excel’s macro recording feature is similar to a video camera. You 
turn it on, press a button to start recording, and press a button to 
stop recording when finished. You may replay the recording as 
many times as you want, during which macros play back recorded 
keystrokes and mouse actions.

Naming a Macro
You can name your macros, or use Excel’s default names (Macro1, Macro2, etc.). Macro names 
may not contain spaces but may include capital letters and underscores. 

Recording Macro Steps
Most actions you perform are recorded in a macro. These include mouse actions, choosing 
Ribbon commands, selecting options in dialog boxes, using arrow keys to navigate the 
worksheet, and typing text. Any mistakes and corrections you make during recording are also 
saved in the macro. If the final result is correct, you can choose to include mistakes and 
corrections and not bother to rerecord the macro, as there would be no benefit to doing so.

TIP

 Practice the procedure you wish to automate before recording the macro. This will help you 
avoid mistakes during the recording process.

Storing Macros
Macros are available only in the workbook in which you create them unless you assign them to 
the Personal Macro Workbook. Some macros are useful only in a particular workbook. For these 
macros, you would choose the This Workbook storage option. Other macros can benefit multiple 
workbooks. So that they will be available for all workbooks, these macros are assigned to a 
Personal Macro Workbook, which is a hidden file used to make macros available to all open 
workbooks.

Saving a Workbook Containing Macros
If you attempt to save a workbook containing macros 
using the normal Excel Workbook file format, Excel 
displays the message “The following features cannot 
be saved in macro-free workbooks: VB Project.” 
Clicking No in the message box displays the Save As 
dialog box, where you should choose the Excel Macro-Enabled Workbook file format. The file is 
saved with the extension .xlsm to indicate that it contains a macro. 

After the Record Macro 
button is clicked in the 
Status Bar, the Stop 
Recording button appears.
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QUICK REFERENCE RECORDING A MACRO

Task Procedure

Record a macro ■■ Create the worksheet and prepare to record the macro. 

■■ Click Record Macro  on the Status Bar or right-click the Status Bar and 
choose Macro Recording (tap [Esc] to hide the context menu).

■■ Type a descriptive name in the Macro Name box, fill in other options as desired, 
and click OK to begin recording.

■■ Execute the commands and actions you want the macro to record.

■■ Click Stop Recording  when finished.

Delete a macro
■■ Choose View→Macros→View Macros , choose the desired macro name, and 
click Delete.

Save a workbook 
containing macros

■■ Choose Save and select No in the message box; or, choose File→Save As, 
choose Computer→Browse, and navigate to the desired location.

■■ Choose Excel Macro-Enabled Workbook from the Save as Type list and click Save.

DEVELOP YOUR SKILLS EX12-D09

Record a Macro
In this exercise, you will record a macro to sort a table first by team leader and then by the contributions to 
date. You will save the workbook in the macro-enabled file format.

1. Open EX12-D09-Contributions from the EX2013 Lesson 12 folder and save it as EX12-
D09-Contributions-[FirstInitialLastName].

2. Click the Record Macro  button on the Status Bar at the bottom-left corner of the 
window. 

If the button does not display, right-click the Status Bar and choose Macro Recording. Tap [Esc] to 
hide the context menu.

3. Follow these steps to name the macro and begin the recording process:

 Type Sort_by_Leader to 
name the macro.

 Verify that This Workbook 
displays here.

 Type this description.

 Click OK.

If you make mistakes as you are recording the macro steps, just correct the errors as you would normally. 
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4. Select cell B4 in the table, and then choose Data→Sort & Filter→Sort. 

5. Follow these steps to set the sort parameters and initiate the sort:

 Click the Sort By menu button and 
choose Team Leader.

 Click Add Level.

 Choose To Date for 
the Then By options.

 Choose Largest 
to Smallest here.

 Click OK.

6. Click Stop Recording  on the Status Bar. 

Your actions have now been saved in the macro.

7. Click Save. Click No in the dialog box, and then choose Computer→Browse if necessary.

8. Edit the filename to EX12-D09-ContsWithMacros-[FirstInitialLastName], 
choose Excel Macro-Enabled Workbook from the Save as Type list, and click Save. Keep 
the file open.

The macro is saved as part of the workbook named ContsWithMacros.xlsm. If you were to close the 
workbook, the macro would be available the next time you opened it.

Running Macros
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1210

You may run a macro from within the Macro dialog box. However, macros are 
more accessible if you assign them to shortcut keys, custom buttons or graphics 
on a worksheet, or buttons on the Quick Access toolbar. You then run a macro 
by issuing the shortcut key or clicking the object to which it is assigned. 

DEVELOP YOUR SKILLS EX12-D10

Run an Unassigned Macro
In this exercise, you will sort the contributions table manually in a different order and then run a macro.

1. Save your file as EX12-D10-ContsWithMacros-[FirstInitialLastName].

If you reopened the Contributions with Macros workbook and the Security Warning appears, choose 
Enable Macros.

2. Select cell D4 and choose Data→Sort & Filter→Sort A to Z .

The contributions table is sorted alphabetically by sponsor name. Now you will run the macro you 
created in the previous exercise. 

FROM THE RIBBON

View→Macros→View 
Macros

FROM THE KEYBOARD
[Alt]+[F8] to view 
macros
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3. Choose View→Macros→View Macros , choose the Sort_by_Leader macro, and click 
Run.

The macro has saved you time by sorting the list by team leader, then by the To Date amount in 
highest to lowest order within each team leader’s row.

4. Save the file and leave it open.

Assigning Macros
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1211

Macros can be assigned to shortcut keys, or to either custom buttons or graphics within a 
worksheet.

Assigning Macros to Shortcut Keys
Excel lets you assign a macro to a shortcut key as you name the macro. You must use (Ctrl) or 
(Ctrl)+(Shift) as part of the shortcut key combination. Any shortcut you assign will override an 
existing Excel command shortcut. For example, if you assign (Ctrl)+[B] to a macro, that 
combination would no longer apply bold formatting.

TIP

 If you are in the habit of using Microsoft’s command shortcuts, avoid overriding them by 
using (Ctrl)+(Shift) for your macro shortcuts.

DEVELOP YOUR SKILLS EX12-D11

Assign a Macro to a Shortcut Key
In this exercise, you will create a macro, assign multiple macros to different shortcut keys, and run macros.

1. Save your file as EX12-D11-ContsWithMacros-[FirstInitialLastName].

If you reopened the Contributions with Macros workbook and the Security Warning appears, choose 
Enable Macros.

2. Click Record Macro  on the Status Bar.

3. Follow these steps to name a new macro:

 Type Insert_Sponsor in 
the Macro Name box.

 Hold down [Shift] and tap 
[I] to set the shortcut as 
[Ctrl]+[Shift]+[I].

 Verify that the macro will be 
stored in This Workbook.

 Click OK.
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Now you will perform the actions to be recorded in the macro. You will insert a blank table row below 
the column headings and copy cell formatting to the blank cells. 

4. Select cell A4, and then choose Home→Cells→Insert.

A blank row is inserted at row 4, and its cells are formatted like the column headings.

5. Select the range A5:G5, choose Home→Clipboard→Format Painter , and select 
cell A4 to apply the cell formatting from row 5 to the blank row 4.

6. Select cell A4 again to position the pointer for data entry.

7. Click Stop Recording . 

8. Delete the blank row 4 that you inserted while creating the macro, then use (Ctrl)+[Shift]+[I] 
to run the Insert_Sponsor macro. 

The pointer moves to cell A4 and blank cells are inserted. New sponsors always will be added to a new 
row below the header row. 

9. Add this sponsor to the table. Tap [Tab] after entering the Year 2 value to have the To Date 
value calculate automatically.

10. Run the Insert_Sponsor macro again and add this sponsor to the table.

Assign a Shortcut Key to the Sort_by_Leader Macro

11. Choose View→Macros→View Macros . 

12. Choose the Sort_by_Leader macro, and then click Options.

13. In the Shortcut Key text box, press [Shift], and tap [L] to set the shortcut key to 
[Ctrl]+[Shift]+[L]; click OK. 

14. Click Cancel to exit the Macro dialog box, then use [Ctrl)+[Shift]+[L] to run the macro. 

The table is sorted by team leader and then by the To Date amount in highest to lowest order within 
each team leader group. The Raul T. Garcia record moves to row 98 in the Weinstein team leader 
group. The Wayne Zobe record moves to row 101.

15. Save the file and leave it open.
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Assigning Macros to Custom Buttons
Video Library http://labyrinthelab.com/videos Video Number: EX13-V1212

A macro assigned to a custom button is run whenever the button is clicked. The easiest way to 
create a custom button is to add a shape to the worksheet. You then assign a macro to the 
button. A custom button may also contain a descriptive label to help identify its function or the 
macro that is assigned to it.

You create custom buttons using the Insert Controls tool on the Developer tab. To display this 
tab, choose File→Options, click Customize Ribbon, place a checkmark next to Developer in the 
Main Tabs list at the right, and click OK.

QUICK REFERENCE ASSIGNING A MACRO

Task Procedure

Assign a macro to a 
shortcut key as the 
macro is created

■■ Click Record Macro .

■■ While filling in options in the Macro dialog box, click in the Shortcut Key text box 
and type a single letter (or hold [Shift] and type the letter).

Assign a macro to 
a shortcut key after 
the macro is created

■■ Choose View→Macros→View Macros , choose the macro name, and click 
Options. 

■■ In the Macro Options dialog box, click in the Shortcut Key text box and type a 
single letter (or hold [Shift] and type the letter).

Assign a macro to a 
button or object on 
the worksheet

■■ Record the macro.

■■ Insert a shape, picture, or clip art image on the worksheet and right-click the 
object, or insert a button.

■■ Choose Assign Macro, choose the desired macro, and click OK. 

■■ To display a text label in a button, select the button in the worksheet and type the 
desired text. 

■■ If necessary, resize the button or graphic, drag it to the desired worksheet 
 location, and align multiple buttons.

DEVELOP YOUR SKILLS EX12-D12

Assign Macros to Shapes
In this exercise, you will create rectangles and assign the Insert_Sponsor and Sort_by_Leader macros to 
them.

1. Save your file as EX12-D12-ContsWithMacros-[FirstInitialLastName].

If you reopened the Contributions with Macros workbook and the Security Warning appears, choose 
Enable Macros.

2. Choose Insert→Illustrations→Shapes→Rectangles→Rectangle . 
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3. Drag the mouse to draw a rectangle on cell D1. Copy and paste the button to cell E1. 

4. Select the first rectangle and type Insert Sponsor (don’t tap [Enter]), select the second 
rectangle, and type Sort by Leader.

Shape text may contain spaces.

5. Click outside the rectangle to deselect it. Then, use 
[Shift] to select both rectangles and choose Drawing 
Tools→Format→Arrange→Align Objects→Align Middle.

Formatting the rectangles is easier if completed before you assign macros to them.

Assign Macros to Shapes

6. Deselect the two rectangles.

7. Right-click the Insert Sponsor rectangle, choose Assign Macro, choose Insert_Sponsor, 
and click OK. 

8. Assign the Sort_by_Leader macro to its rectangle. 

9. Deselect the rectangle.

10. Click the Insert Sponsor rectangle to run the Insert_Sponsor macro. 

A new row appears just below the header row. 

11. Add this sponsor to the new row:

12. Click the Sort by Leader rectangle to run the Sort_by_Leader macro. 

The new row is sorted into the worksheet as row 5. 

13. Save and then close the file. Exit Excel.

Concepts Review
To check your knowledge of the key concepts introduced in this lesson, complete the Concepts 
Review quiz by choosing the appropriate access option below.

If you are… Then access the quiz by…

Using the Labyrinth Video Library Going to http://labyrinthelab.com/videos

Using eLab Logging in, choosing Content, and navigating to the Concepts 
Review quiz for this lesson

Not using the Labyrinth Video Library 
or eLab

Going to the student resource center for this book 
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Reinforce Your Skills
REINFORCE YOUR SKILLS EX12-R01

Analyze Data
In this exercise, you will use an HLOOKUP function to enter data within a car donation worksheet. You 
will then create a PivotTable and PivotChart to analyze the data.

Use LOOKUP Functions

1. Start Excel. Open EX12-R01-CarDonations from the EX2013 Lesson 12 folder and save 
it as EX12-R01-CarDonations-[FirstInitialLastName].

2. Select cell F5 and click Insert Function . 

3. Choose All from the Or Select a Category list.

4. Tap [H] to jump to the functions beginning with the letter H in the Select a Function list. 

5. Continue tapping [H] until HLOOKUP is highlighted, and then tap [Enter]. 

6. Select cell E5 as the Lookup_Value. Select the range J5:L7 as the Table_Array and apply 
absolute formatting to this range. Type 2 as the Row_Index_Num and click OK.

The HLOOKUP function returns 1, which is the rounded result of the 90 percent Realized Value in the 
third column of the table array. This result must be multiplied by the value displayed in column E to 
complete the Realized Value formula.

7. Ensure that cell F5 is selected, click in the Formula Bar at the end of the current formula, 
type *E5, and confirm the formula.

The formula now returns a result of 41,301, which is 90 percent of the value in column E. The 
remaining cells in column F of the table have automatically populated.

8. In cell G5 type this formula: =HLOOKUP(E5,$J$5:$L$7,3)

The result Individual Resale (which is listed in the third column of the table array) is returned in cell 
G5, and the remaining cells in column G of the table have automatically populated.

Create PivotTables and PivotCharts

9. Select cell A4. 

This ensures that Excel will use the table data when you create the PivotTable. 

10. Choose Insert→Charts→PivotChart , verify JanSales as the Table/Range, and 
click OK. 

11. Rename the Sheet1 sheet tab as PivotTable. 

The PivotChart Fields task pane displays. If it does not and you made certain that the chart is selected, 
choose Analyze→Show/Hide→Field List.

12. In the PivotChart Fields task pane, place a checkmark in the Received By and Value 
checkboxes. 

The PivotTable displays the total donations generated by each representative using the Sum of Value 
field in the Values area of the PivotChart Fields task pane. The chart is selected, so the task pane 
displays Axis (Categories) and Legend (Series) field areas. 
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13. Select a cell in the PivotTable, and the areas referenced above are now titled Rows and 
Columns to reflect those items in the PivotTable. 

Since you may need to know which types of cars each representative received during January, you will 
place a new field in the Rows area.

14. Place a checkmark in the Type box on the task pane to add the field to the Rows area.

The PivotTable and PivotChart expand to display the vehicles received by each representative. It might 
also be interesting to summarize how the donations break down by vehicle type, so in the next step you 
will pivot the Type field from the row area to the column area. You may not see the entire PivotTable 
and PivotChart as items change in the window. 

15. To maximize space, unlock the task pane by dragging its title bar down and to the left. 
Resize the PivotTable Field List by dragging its bottom border up or down to keep desired 
options visible.
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EX12.36 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

16. To prevent the PivotChart from covering the PivotTable in the next step, 
move the PivotChart by dragging the chart frame until the left edge of 
the chart is in column G.

17. Select a cell in the PivotTable. In the PivotTable Fields task pane, drag 
the Type field to the Columns area.

The Grand Total line at the bottom of the PivotTable displays the donations from each type of car. The 
chart displays columns for each car type. 

18. Place a checkmark in the Upgraded/Base Model box on the task pane to add the field to 
the Rows area. Observe the effect in the PivotTable and the PivotChart. 
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19. Drag the Upgraded/Base Model field above Received By in the Rows area of the task pane.

This view shows that donations are much greater for upgraded cars than base models.

20. Move the PivotChart below the PivotTable so both fit on one printed page.

21. Drag the PivotChart Fields task pane beyond the right edge of the screen so it locks in place 
(is docked).

22. Select a cell in the PivotTable to deselect the PivotChart.

Only the chart will print when the chart is selected.

23. Save and close the file; exit Excel.

24. Submit your final file based on the guidelines provided by your instructor.

To view examples of how your final file or files should look at the end of this exercise, go to the student 
resource center.
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REINFORCE YOUR SKILLS EX12-R02

Create and Run a Macro
In this exercise, you will create a macro that selects an entire worksheet, formats all cells with bold, and 
widens the columns. You will assign the macro to shortcut keys and run it.

Change Macro Security

1. Start Excel and open a new workbook.

Now you will change the security settings. These may already be set by your network system 
administrator, and may be locked. If you are unable to change the settings, skip the following two 
steps.

2. Choose File→Options→Trust Center and click the Trust Center Settings button. If 
necessary, choose Macro Settings and Disable All Macros with Notification.

3. Choose the Message Bar category on the left. Verify that the Show the Message Bar… 
option is selected, and then click OK twice.

Record a Macro

4. Click Record Macro  on the Status Bar. 

5. Type the macro name FormatSheet in the Record Macro dialog box. Set the Store Macro 
In option to Personal Macro Workbook.

Choose This Workbook if you cannot save a macro to the Personal Macro Workbook on your computer 
system.

6. Click OK (and replace the macro if it already exists) to begin the recording process. 

7. Press [Ctrl]+[A] to select the entire worksheet and then press [Ctrl]+[B] to bold all cells.

8. Choose Home→Cells→Format →Column Width.

9. Type 12 and tap [Enter]. 

10. Select cell A1 to deselect the highlighted cells, and then click Stop Recording  on the 
Status Bar. 

11. Choose File→Close. Choose not to save when prompted. 

Run Macros

12. Open a new workbook and save it in the EX2013 Lesson 12 folder as EX12-R02-
PersonalMacro-[FirstInitialLastName].

13. Choose View→Macros→View Macros  (the top part of the button) to display the 
Macro dialog box. 

Any macro with PERSONAL.XLSB! in its name has been saved to the Personal Macro Workbook and 
is available to all open workbooks. 

14. Choose the PERSONAL.XLSB!FormatSheet macro and click Run. 

Choose FormatSheet if you saved the macro to This Worksheet. The column and text formats are set.

15. Type Macro in cell A1.

Because the macro was run, this text appears in bold.
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Assign Macros

16. Choose View→Macros→View Macros .

17. Click the PERSONAL→XLSB!FormatSheet macro from the list box and click Options.

18. Click in the Shortcut Key box, hold down [Shift] and tap [F] to set the shortcut as [Ctrl]+ 

[Shift]+ [F].

19. Click OK and then Cancel.

20. Save as a macro-enabled workbook and then close the workbook; do not save changes to 
the Personal Macro Workbook. Exit Excel.

21. Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.

REINFORCE YOUR SKILLS EX12-R03

Analyze and Automate an Event Donation Listing
In this exercise, you will use a VLOOKUP function to enter data and complete a PivotTable and PivotChart 
to analyze the data. You will also use a macro to automate tasks.

Use LOOKUP Functions

1. Start Excel. Open EX12-R03-EventDonations from the EX2013 Lesson 12 folder and 
save it as a macro-enabled workbook named EX12-R03-EventDonations-
[FirstInitialLastName].

2. In the February Donations worksheet, select cell G5 and type this text: 
=VLOOKUP(E5-F5, 

3. Highlight the table array in the range I5:J7.

The table array has already been named Table_Array, so this name appears in the formula when you 
highlight its range.

4. Type the following to complete the formula: ,2)

The VLOOKUP function displays Excellent Return, and the remaining cells in column G of the table 
have automatically populated.
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EX12.40 Excel 2013 Lesson 12: Using LOOKUP Functions, PivotTables, and Macros

Create PivotTables and PivotCharts

5. Select the PivotTable worksheet. Then select a cell within the PivotTable to display the 
PivotTable Fields task pane, if necessary.

6. Click the Row Labels AutoFilter button in cell A3, remove the checkmark from the 
Open Admission box, and click OK. 

Notice that no data is displayed for Open Admission events, and the Row Headers filter button displays 
a filter icon.

7. Display the Row Labels filter list again and choose Clear Filter from “Type”.

8. In the PivotTable Fields task pane, remove the checkmark from the Type box. 

9. Place a checkmark in the Location box to add the field to the PivotTable. 

The pie chart displays Outdoor as 205195, Online as 108700, and On-site as 154310 for all event 
donations. Next, you will use slicers to filter a field that is not displayed.

10. Choose Insert→Filters→Slicer . In the Insert Slicers dialog box, place a checkmark 
next to Event Manager and click OK.

The Event Manager slicer displays on the worksheet window.

11. Point to the Event Manager title in the slicer and drag the slicer frame so it is not covering 
the PivotTable or PivotChart.

12. Choose Lehman in the slicer.

The Sum of Donations column in the PivotTable and the PivotChart totals have changed to include 
only donations attributed to Lehman.

13. Choose Jones in the slicer.

The totals update to include only donations attributed to Jones. Note that Jones did not have any on-
site donations; therefore, this location type is not displayed in the PivotTable or PivotChart.

14. Select the PivotChart and choose PivotChart Tools→Design→Chart Styles→More . 

15. Choose a chart style that displays good contrast between the colors of the text and pie slices.

16. Move the PivotChart below the PivotTable so they will fit on one printed page.
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Change Macro Security
Now you will change the security settings. These may already be set by your network system administrator, 
and may be locked. If you are unable to change the settings, skip the following two steps.

17. Choose File→Options→Trust Center and click the Trust Center Settings button. If 
necessary, choose Macro Settings and Disable All Macros with Notification.

18. Choose the Message Bar category on the left. Verify that the Show the Message Bar… 
option is selected, and then click OK twice.

Record a Macro

19. Select the February Donations worksheet and click Record Macro  on the Status Bar. 

20. Type the macro name NewEvent in the Record Macro dialog box and set the Store Macro In 
option to This Workbook.

21. Click OK (and replace the macro if it already exists) to begin the recording process. 

22. Right-click the row 25 header and choose Insert.

23. Select cell H25 and type New.

24. Select cell A1 and click Stop Recording  on the Status Bar. 

Run Macros

25. Choose View→Macros→View Macros  (the top part of the button) to display the 
Macro dialog box. 

26. Choose the NewEvent macro and click Run.

A new row is inserted at the bottom of the list, and the New label is inserted in column H.

Assign Macros

27. Choose View→Macros→View Macros .

28. Click the NewEvent macro from the list box, and then click Options.

29. Click in the Shortcut Key box, hold down [Shift] and tap [N] to set the shortcut as 
[Ctrl]+[Shift]+[N].

30. Click OK and then Cancel.

31. Save as a macro-free workbook and then close the file; exit Excel.

32. Submit your final file based on the guidelines provided by your instructor.
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Apply Your Skills
APPLY YOUR SKILLS EX12-A01

Analyze Data
In this exercise, you will use VLOOKUP to calculate total expenses and to classify 
each event. You will then create a PivotTable and PivotChart that display the cost 
of events summarized by media and play mode.

Use LOOKUP Functions

1. Start Excel. Open EX12-A01-MayExpenses from the EX2013 Lesson 12 folder and save 
it as EX12-A01-MayExpenses-[FirstInitialLastName].

2. Use the VLOOKUP function in column H to determine the total cost for each event. 
The function should use the subtotal in column G as the lookup value and search the  
Misc_Costs table for the miscellaneous costs, the value of which should be added to 
the subtotal in column G to arrive at the total cost.

3. Use the VLOOKUP function in column I to determine the classification for each event. 
The function should use the subtotal in column G as the lookup value and search the 
Misc_Costs table for the proper classification.

4. AutoFill the formulas in the range H5:I5 to row 23.

Create PivotTables and PivotCharts

5. Create a PivotTable on a new worksheet based on the May expense data.

6. Rename the new sheet with a descriptive name of your choice. Rename the PivotTable to 
May Expenses. 

7. Set up fields for the PivotTable so the table summarizes the data by Media and then by Play 
Mode. 

8. Set up fields so the event costs and setup costs are calculated separately. 

9. Format all numbers in the PivotTable with Comma Style and no decimal places. 

10. Create a Stacked Column PivotChart on the new worksheet.

11. Apply a PivotChart style and a chart layout of your choice. If your layout includes titles, 
replace the placeholders with appropriate titles.

12. Change the page orientation and make any other adjustments to fit the PivotTable and 
PivotChart on one printed page.

13. Save and close the file; exit Excel.

14. Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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APPLY YOUR SKILLS EX12-A02

Create a Macro to Insert a Date
In this exercise, you will create a macro that inserts the phrase Today’s Date in cell A1 and the TODAY() 
function in cell A2. The macro will also format the two cells. You will assign the macro to the current 
workbook only.

Change Macro Security and Record Macros

1. Start Excel. Create a new macro-enabled workbook named EX12-A02-DateMacro-
[FirstInitialLastName] and saved to the EX2013 Lesson 12 folder.

2. If necessary, add or subtract worksheets so a total of three are displayed.

Now you will change the security settings. These may already be set by your network system 
administrator, and may be locked. If you are unable to change the settings, skip the following two 
steps.

3. Ensure that Disable All Macros with Notification is selected.

4. Ensure that the Show the Message Bar… option is selected.

5. On Sheet1, select cell A10. 

6. Begin recording a new macro. 

7. Name the macro TodaysDate and store it in This Workbook. Your macro should record 
all of the actions in steps 8–13 

8. Select cell A1 and type Today’s Date. 

9. Enter the formula =TODAY()in cell A2. 

This function displays the current date in the cell. 

10. Left-align the date in cell A2. 

11. Format cells A1:A2 with size 12, bold, and a blue color for text. 

12. Set the width of column A to 20. 

13. Select cell B1, and then stop recording. 

Run and Assign Macros

14. Display the Sheet2 worksheet. 

15. Run the macro using the Run command in the Macro dialog box. 

16. Assign the shortcut keystroke [Ctrl]+[Shift]+[D] to the macro.

17. Display the Sheet3 worksheet. 

18. Test the macro by pressing (Ctrl)+[Shift]+(D).

19. Save and close the file; exit Excel.

20. Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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APPLY YOUR SKILLS EX12-A03

Analyze Data and Automate Processes
In this exercise, you will analyze event costs using VLOOKUP, PivotTables, and PivotCharts. You will also 
create and run a macro to allow for the addition of events to the worksheet.

Use LOOKUP Functions

1. Start Excel. Open EX12-A03-AprilExpenses from the EX2013 Lesson 12 folder 
and save it as a macro-enabled workbook named EX12-A03-AprilExpenses-
[FirstInitialLastName].

2. Use the VLOOKUP function in column H to determine the total cost for each event. 
The function should use the subtotal in column G as the lookup value and search the  
Misc_Costs table for miscellaneous costs, the value of which should be added to 
the subtotal in column G to arrive at the total cost.

3. Use the VLOOKUP function in column I to determine the classification for each event. 
The function should use the subtotal in column G as the lookup value and search the 
Misc_Costs table for the proper classification.

Create PivotTables and PivotCharts

4. Create a PivotTable and PivotChart on a new worksheet, based on the April expense 
data.

5. Rename the new sheet with a descriptive name of your choice. Rename the PivotTable as 
April Expenses. 

6. Set up fields for the PivotTable so the table and chart summarize the data by Genre and 
then by Play Mode. 

7. Set up fields so the event costs and setup costs are calculated separately. 

8. Format all numbers in the PivotTable with Accounting format.

9. Change the chart type to Clustered Bar and apply a PivotChart style and a chart layout of 
your choice. 

10. Make any adjustments necessary to fit the PivotTable and PivotChart on one printed page.
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Change Macro Security and Record Macros
Now you will change the security settings. These may already be set by your network system administrator, 
and may be locked. If you are unable to change the settings, skip the following two steps.

11. Ensure that Disable All Macros with Notification is selected.

12. Ensure that the Show the Message Bar… option is selected.

13. On the April Expense Report worksheet, select cell G1. 

14. Begin recording a new macro. 

15. Name the macro NewField and store it in This Workbook. Your macro should record all 
of the actions in steps 16–18. 

16. Select cell A5 and choose Home→Cells→Insert.

17. Select cell K5 and type New Event.

18. Highlight the range E5:H5 and apply the Accounting format.

19. Stop the macro recording. 

Run and Assign Macros

20. Run the macro using the Run command in the Macro dialog box. 

Note that a new row is created at the top of the list when the macro is run.

21. Assign the shortcut keystroke (Ctrl)+[Shift]+(R) to the macro.

22. Test the macro using the (Ctrl)+[Shift]+(R) keystroke combination.

23. Delete the three blank rows above the worksheet data.

24. Save as a macro-enabled workbook and then close the file; exit Excel.

25. Submit your final file based on the guidelines provided by your instructor.
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Extend Your Skills
In the course of working through the Extend Your Skills exercises, you will 
think critically as you use the skills taught in the lesson to complete the assigned 
projects. To evaluate your mastery and completion of the exercises, your instructor 
may use a rubric, with which more points are allotted according to performance 
characteristics. (The more you do, the more you earn!) Ask your instructor how 
your work will be evaluated.

EX12-E01 That’s the Way I See It
You volunteer at the local animal shelter and, since everyone there knows you are studying 
Excel, they’ve asked you to create a workbook displaying information for five new shelter dogs. 
The worksheet will list the dogs’ identifying information and will contain one column that uses 
a lookup table. Start Excel and create a new workbook named EX12-E01-Lookup-
[FirstInitialLastName] that is saved to your EX2013 Lesson 12 folder. 

The dogs can be placed into four size classifications, namely Small (0–25 lbs.), Medium (26–50 
lbs.), Large (51–99 lbs.), and Extra Large (100+ lbs.). Create a worksheet that lists five dogs, the 
shelter contact’s name (use the dogs of friends or celebrities whose information can be readily 
found on the Internet), and each dog’s breed, age, and weight. Then create a table array that 
lists the four sizes and the weights for each. This table is to be used to create a final worksheet 
column, within which the appropriate classification is listed for each dog. Finally, create a macro 
that sorts the data based on one of the existing columns. Ensure that the macro inserts a label 
describing the type of sort in a logical location. 

You will be evaluated based on the inclusion of all elements specified, your ability to follow 
directions, your ability to apply newly learned skills to a real-world situation, your creativity, 
and the relevance of your topic and/or data choice(s). Submit your final file based on the 
guidelines provided by your instructor.

EX12-E02 Be Your Own Boss
In your quest to keep your Blue Jean Landscaping records organized and up to date, you are 
creating a PivotTable and PivotChart to display a summary of clients’ monthly landscaping 
service costs in each town by lead landscaper name. 

Open EX12-E02-Clients from the EX2013 Lesson 12 folder and save as EX12-E02-
Clients-[FirstInitialLastName]. Give the worksheet an appropriate title. Then, create 
a macro that performs a column sort by town and then by lead landscaper. Assign this macro to 
shortcut keys. Insert a PivotTable that displays monthly cost totals by town and then by lead 
landscaper. Create a PivotChart and format it appropriately for size and appearance. 

You will be evaluated based on the inclusion of all elements specified, your ability to follow 
directions, your ability to apply newly learned skills to a real-world situation, your creativity, 
and your demonstration of an entrepreneurial spirit. Submit your final file based on the 
guidelines provided by your instructor.
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Transfer Your Skills
In the course of working through the Transfer Your Skills exercises, you will use 
critical-thinking and creativity skills to complete the assigned projects using skills 
taught in the lesson. To evaluate your mastery and completion of the exercises, 
your instructor may use a rubric, with which more points are allotted according 
to performance characteristics. (The more you do, the more you earn!) Ask your 
instructor how your work will be evaluated.

EX12-T01 Use the Web as a Learning Tool
Throughout this book, you will be provided with an opportunity to use the Internet as a learning 
tool by completing WebQuests. According to the original creators of WebQuests, as described on 
their website (WebQuest.org), a WebQuest is “an inquiry-oriented activity in which most or all 
of the information used by learners is drawn from the web.” To complete the WebQuest projects 
in this book, navigate to the student resource center and choose the WebQuest for the lesson on 
which you are currently working. The subject of each WebQuest will be relevant to the material 
found in the lesson.

WebQuest Subject: Effective implementation of PivotTables

Submit your files based on the guidelines provided by your instructor.

EX12-T02 Demonstrate Proficiency
You have been maintaining a donation listing workbook and would like to be able to quickly sort 
the contents in different ways: 1) in A to Z order based on the patron last names and first 
names, and 2) in largest to smallest order based on donation details. 

Open EX12-T02-Donations from the EX2013 Lesson 12 folder and save it as EX12-T02-
Donations-[FirstInitialLastName]. Create macros that automate the processes 
described above, and name them Sort_by_Patron and Sort_by_Details, respectively. These 
macros should each display a description of the sort in cell A16. Be sure to test the macros after 
they have been created to ensure that they work properly. Insert buttons in an appropriate 
location on the worksheet, and assign one macro to each. 

Submit your final file based on the guidelines provided by your instructor.
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