
In this chapter, you will learn how to 
summarize data using PivotTables and 
PivotCharts and work with the 

important tools needed to create both 
PivotTables and PivotCharts.

L E A R N I N G  O B J E C T I V E S
■■ Create PivotTables

■■ Modify and format PivotTables

■■ Apply a filter to a PivotTable

■■ Insert a slicer to filter a PivotTable

■■ Create a calculated field

■■ Create PivotCharts

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 1 hr 20 mins

■■ Total: 3 hrs 20 mins

P R O J E C T:  A N A LY Z I N G  S A L E S 
D ATA
You have been given an Excel file containing all of 
the sales information for the Airspace Travel 
employees for Q3, July to September. To analyze the 
employees’ performance, you will create a variety of 
PivotTables and PivotCharts to highlight important 
details within the data.

3PivotTables and 
PivotCharts

E X C E L  2 0 1 6
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Creating PivotTables
A PivotTable is another powerful, popular, and cooperative Excel tool used to summarize 
complex information. PivotTables make it easy to understand large amounts of information by 
creating a summary report of your data. They are created by taking the existing data in a 
worksheet and organizing the various fields into columns and rows, which can then be used to 
display different results. The purpose of a PivotTable is to take large amounts of data and to help 
you determine, for example, which products are selling the best, which employees are 
performing the best, which day of the week or time of day do we need to have more staff on 
hand to reduce wait times for customers?

To create a PivotTable, you can start with a blank table and add fields, or you can use one of the 
recommended PivotTables that Excel suggests based on your data.

View the video “Making a PivotTable.”

What Is a PivotTable?
A PivotTable combines some of the features of a table and some of the features of an outline and 
includes additional unique features that make it extremely flexible. You can arrange your data 
in different ways, which is where the term pivot comes from (which means to turn or rotate), 
and you can quickly switch between the different views rather than creating a separate table 
each time. PivotTables are made up of rows and columns that contain Field labels, and the Value 
fields are then summarized within. PivotTable fields can be used to subtotal, compare, count, or 
perform other calculations on your data, as well.

The partial worksheet data being used to create a PivotTable
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The following PivotTable uses the data above to compare product and service sales  side by side 
for employees grouped by their positions.

The Row Labels include
 position and last name.

The values for product 
and service sales are shown 
in two columns.

Rows are grouped by position,
 and each group can be collapsed

 or expanded as needed.

The Row Labels field also 
includes a filter button to 
apply a Sort or Filter to the 
rows in the PivotTable.

Arranging the Source Data
To create a PivotTable, you must also understand where to get the source data and know the 
state the data has to be in. Because a PivotTable summarizes data, the source data should not be 
summarized in any way. You can also think of this as being the raw data. 

Typically, you want the source data to have fields (column headings) listed across the top, and 
then each row in the worksheet should contain a unique list entry. For example, the source 
should not have a list of employees and then list a summary of sales for each month in the same 
row. Rather, the source should be the raw sales data listing with a separate row for each month 
of data or even a separate row for each individual sale.

The source can be a list of data formatted as either a normal range or a table. The source should 
not contain any blank rows or columns or duplicate values.

Remove Duplicates
When entering data or combining data from different sources, there is a chance of having the 
same information listed twice. This duplicate information can then cause your information to 
be incorrect, which in turn causes incorrect evaluations, analysis, and perhaps important 
decisions based on the flawed data. To check for duplicates and remove them, you can use the 
Remove Duplicates command in Excel. To decide whether a record is considered a duplicate, you 
must tell Excel which columns must match. In some cases, it requires only one or two columns 
to determine that a record is a duplicate; for other data, you may want to match all columns.

ÍÍ Data→Data Tools→Remove Duplicates
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Adding PivotTable Fields
Whether you start with a blank PivotTable or use a recommended one, after it is created you 
have the option of adding and removing fields as you choose to manipulate the table data. The 
PivotTable Fields pane allows you to quickly add and remove fields by either clicking or 
dragging.

Fields added here are displayed in the 
Row Labels; note in the PivotTable on 
the right that position comes first, 
followed by last names.

Fields added here are displayed in the 
Column Labels; in this example no field 
was added to columns, so the column labels 
are the Values fields.

This area displays the Value fields added to the 
PivotTable and the function being performed.

Fields added
 here can be

 quickly filtered.

Choose from the list of field names to be 
included in the PivotTable; these are the 
column names from the source data.

ÍÍ Insert→Tables
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DEVELOP YOUR SKILLS: E3-D1	

In this exercise, you will check the source data for duplicates, insert a blank PivotTable, and add fields to 
the PivotTable to show a summary of sales for each location.

	 1.	 �Start Excel, open E3-D1-Sales from your Excel Chapter 3 folder, and save it as E3-D1-
SalesTargets.

	 2.	 �Begin by verifying the data by quickly scrolling through the rows to the end of the sheet.

	 3.	 �Choose Data→Data Tools→Remove Duplicates  to remove the duplicate values, if 
there are any.

	 4.	 �Leave all columns checked and click OK.

	 5.	 �Click OK to close the dialog box.

	 6.	 �Quickly navigate to the last row of data by pressing [Ctrl]+[¥] and notice the data stops at 
row 89.

	 7.	 �Choose Insert→Tables→PivotTable  to insert the PivotTable.

	 8.	 �Confirm the range is Sales!$A$3:$I$89 and then click OK to create the PivotTable.

	 9.	 �Click the Location and Position checkboxes in the PivotTable Fields pane to add those 
fields as row labels and then drag the Month field into the Columns box.
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	10.	 �Click the Sales checkbox (this may require scrolling down in the field list, depending on 
screen size) in the PivotTable Fields pane, which will add the Sales field to the Values.

	11.	 �Rename the Sheet to Sum of Sales by Location.

	12.	 �Save the file.

Working with PivotTables
After you have created a PivotTable, you can modify the fields at any time by adding or removing 
them or by changing the positioning and order of the fields. To add fields, you can check the box 
next to the field name or drag it into the appropriate quadrant in the lower half of the PivotTable 
Fields pane. To remove fields, you can uncheck the box or drag a field name out of a quadrant 
and off the field list altogether. Each time you make a change, the PivotTable will automatically 
reconfigure to display the new data.

Changing the order of the fields in either the row or column will create different data groupings, 
and this is done by dragging and dropping the field names into the new positioning. Or you 
might want to switch a field label from row to column or column to row, which pivots the data.
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This example shows the Sum of Product sales, organized by Position, then Last Name in the Rows, and Columns 
grouped by Region.

Now the PivotTable shows Product sales with Rows grouped by Region, then Position, then Last Name; it is the same 
data but is just organized differently.

This is perhaps the most important skill for working with PivotTables because each change in 
the data’s organization tells a new story. It is important to practice organizing your fields in a 
variety of ways to see how the information can be shaped to answer different questions.

View the video “Changing a PivotTable.”

Formatting PivotTables
Changing the PivotTable’s format can help make the information easier to read and understand. 
Similar to tables, there are a number of styles to choose from in the gallery on the Design tab. 
There are also a number of layout and style options to choose from.

Report Layout options include Compact, Outline, and Tabular. Subtotals can either be displayed 
at the top or bottom of each category or group or turned off altogether, and grand totals can also 
be turned on or off for rows and columns.
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Number formatting does not automatically transfer from the source data, but you can quickly 
change the number format for an entire value field by right-clicking one of the values in the 
PivotTable and choosing Number Format or by using the Field Settings command.

This PivotTable has a style applied and contains number formatting, and the report layout is displayed in Outline form, 
which takes up more space but makes it easier to see the row labels.

Changing Value Field Settings
For each value field, the settings can be changed to better suit the information you want to show. 
The Field Name can be customized, the Number Format can be modified, and another function 
can be chosen instead of using the SUM function to summarize values. For example, instead of 
showing the sum of sales for each region, you might want to show the average sales by region. 
Then, instead of Average of Product, you could adjust the Custom Name to Avg Product Sales.

DEVELOP YOUR SKILLS: E3-D2	

In this exercise, you will create another PivotTable and adjust the fields and value field settings to show the 
average by position for commissions, sales, and targets.

	 1.	 �Save your file as E3-D2-SalesTargets.

	 2.	 �Go to the Sales worksheet.
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	 3.	 �Choose Insert→Tables→Recommended PivotTables  to insert a new PivotTable.

	 4.	 �Select the third option on the left, Sum of Commissions, Sum of Sales and Sum of 
Target by Location, and then click OK to insert the PivotTable.

	 5.	 �Uncheck the Location box in the PivotTable Fields pane to remove the Location field from 
the PivotTable.

	 6.	 �Now check the Position box in the Field list to add that field.

	 7.	 �Next drag the Position field above the First Name field in the Field List Rows to change the 
order of the fields.

	 8.	 �Check the Month box in the list to add the Month field and remove the First Name field by 
dragging it out of the Rows section of the Field List pane and onto the worksheet (an 
alternative method is to remove the field by removing the checkmark in the Field list).

	 9.	 �Choose PivotTable Tools→Design→PivotTable Styles→Pivot Style Dark 20.
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	10.	 �In the Field List pane Values section, click the menu button  beside Sum of Commissions 
(the first field listed in Values; because of the small space the names are often cut off, but 
you can see the full name by hovering the mouse over the field) and then choose Value 
Field Settings….

	11.	 �Follow these steps to change the field settings:

A

B

C

A	Choose Average in Summarize Value Field By.

B	In the Custom Name box, type Avg Comm..

C	Click Number Format, choose Currency, and then click OK.

	12.	 �Click OK to close the Value Field Settings dialog box.

	13.	 �Repeat this process for the Sum of Sales and Sum of Target fields, so that both fields display 
the Average summary function, with the names Avg Sales and Avg Target and the 
Currency number format.
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	14.	 �Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline 
Form to change the report layout.

	15.	 �Rename the worksheet Averages by Position.

	16.	 �Save your work.

Filtering a PivotTable
PivotTables can be filtered to remove unnecessary data and focus on the data that is important. 
A filter can be added several ways: by using AutoFilter, by adding a filter field, or by adding a 
slicer. Each time a PivotTable is filtered, the totals and subtotals are instantly recalculated 
throughout the table.

Filtering a PivotTable with AutoFilter
The row labels and column labels have an AutoFilter menu button  that provides the same 
sorting and filtering options that are available in worksheet lists and tables.

This PivotTable has been filtered to show Sales Account Mgr and Senior Account Mgr positions only and to sort by 
Position A to Z; because Sales comes first alphabetically, it is listed first.
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Filtering a PivotTable with a Filter Field
Adding a field to the filter section of the PivotTable Field list simplifies the process of filtering 
the data to display one or more categories of data at a time. To turn on the option for showing 
more than one category, click the Select Multiple Items checkbox in the filter drop-down menu. 
The filtered field and the current filter setting will always display directly above the PivotTable.

By adding a field to the Filters area, that filter will remain displayed above the PivotTable as shown below.

This PivotTable has been filtered to show only the Eastern region.

Filtering a PivotTable with Slicers
Slicers are menu frames placed on a worksheet that contain all filtering choices in one field. 
Selected items are highlighted in the slicer, making it easy to identify currently applied criteria. 
To select multiple fields in a slicer, you can use the Multi-Select feature or use the [Ctrl] key on 
the keyboard.

Slicers are more appealing because they can be moved around, resized, and styled to match the 
PivotTable, but the real benefit is that slicers can be shared with other sheets in the same 
workbook for other PivotTables that use the same source data. Changing the filtered selections 
in a shared slicer automatically updates all connected PivotTables.
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The PivotTable with a slicer; displays the Central and Eastern region data

DEVELOP YOUR SKILLS: E3-D3	

In this exercise, you will add filters to the existing PivotTables using two different methods.

	 1.	 �Save your file as E3-D3-SalesTargets.

	 2.	 �Add a filter field to the PivotTable by dragging the Location field into the Filters section of 
the PivotTable Fields pane.

	 3.	 �Click the filter menu button  above the PivotTable and select New York from the list to 
display the information for New York only; click OK.
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	 4.	 �Go to the Sum of Sales by Location sheet and, if necessary, select any cell in the 
PivotTable.

	 5.	 �Click the Position field in the Rows section of the PivotTable Fields pane and choose 
Remove Field.

	 6.	 �Choose PivotTable Tools→Analyze→Filter→Insert Slicer .

	 7.	 �In the Insert Slicers dialog box click the Position checkbox and then click OK.

	 8.	 �Drag the Slicer window so that it is directly beside the PivotTable and the tops of both are 
roughly aligned.

	 9.	 �Now resize the slicer in Slicer Tools→Options→Size to exactly 1" 
high and 1.5" wide.

	10.	 �Apply the Slicer Style Dark 5 style (Slicer Tools→Options→Slicer 
Styles) to the slicer and then click Agent to display the sales data for 
Agents only.

	11.	 �Now adjust the Number Format for sales values by right-clicking cell 
E5 and choosing Number Format….

	12.	 �Choose Currency and click OK.

	13.	 �Now select Manager in the slicer to display the sales data for Managers only.

	14.	 �Save the file.
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Creating Calculated Fields
In addition to the functions that are provided, you may want to create your own calculations 
and add them to the PivotTable. A calculated field uses a formula containing values from one or 
more of the existing fields. For example, you could take Sales values and multiply by 5% or take 
the Cost field from a PivotTable and subtract the Sales field.

ÍÍ PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets

Show Values As
Another option for displaying your PivotTable values is to use comparison operations, which are 
also available from the Value Field Settings dialog box. There are options already created to 
determine calculations such as a % of the grand total, the difference between values in two 
fields, or a ranking order.

The Value Field Settings can be used to show options such as the % of Grand Total, as displayed  
in the PivotTable here.

Refreshing PivotTable Data
Whenever the source data changes, an existing PivotTable has to be refreshed to update the data 
in the PivotTable. You have the option of refreshing only the current PivotTable or all of them at 
once, and you can also set up an option to refresh the data each time the file is opened.

ÍÍ PivotTable Tools→Analyze→Data→Refresh
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DEVELOP YOUR SKILLS: E3-D4	

In this exercise, you will create a new PivotTable that will show which employees achieved their sales 
target.

	 1.	 �Save your file as E3-D4-SalesTargets.

	 2.	 �Go to the Sales sheet and insert a new blank PivotTable using the default values.

	 3.	 �Rename the new sheet % of Target.

	 4.	 �Add the Location, Position, and Last Name fields to the Rows, in that order.

	 5.	 �Add Sales and Target to the Values, in that order. Values will automatically be added to the 
Columns quadrant.

	 6.	 �Adjust the Value Field Settings for both Values to be Currency, no decimals, and the 
Custom Names to Total Sales and Total Target, respectively.

	 7.	 �Now choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets → 
Calculated Field….

	 8.	 �In the Name box, enter % of Target.

	 9.	 �Delete the number 0 in the Formula box; in the Fields list, select Sales and click Insert 
Field.
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	10.	 �Type / and then in the Fields list select Target and click Insert Field.

	11.	 �Click OK to create the calculated field, which will divide sales by the target and is displayed 
in the Values quadrant.

	12.	 �Right-click cell D4 and open the Value Field Settings for the calculated field, change the 
name to Total % of Target and the Number Format to Percentage with two decimal 
places. Click OK to close the Number Format and OK again to close the Value Field Settings 
dialog box.

	13.	 �Click the collapse buttons to collapse the Agent and Manager labels. This will display the 
Locations and Positions only.

	14.	 �Change the PivotTable style to Pivot Style Dark 20.

	15.	 �Now go to the Sales sheet and select cell H7.

	16.	 �Edit the cell and enter the correct information by typing 12900 in cell H7.

	17.	 �Return to the % of Target sheet and choose PivotTable Tools→Analyze→Data→Refresh 
 menu button →Refresh All.

	18.	 �The data in all PivotTables is now updated to reflect the correction.

	19.	 �Save the file.
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Creating PivotCharts
PivotCharts are charts based on PivotTable data. PivotCharts can be created simultaneously 
with the PivotTable or after the PivotTable has been created, but a PivotChart must have an 
associated PivotTable. The fields on the Values area of the PivotTable are displayed as data series 
on the chart. The row labels are used as the axis labels, and the column labels are used in the 
chart legend. The PivotChart Tools tab contains all of the normal options for chart formatting in 
addition to the Analyze options for PivotTables.

Filtering PivotCharts
A PivotChart also includes AutoFilter buttons directly in the chart for quick and easy access to 
filter options. Filtering the PivotChart will also filter the associated PivotTable, and vice versa. If 
a slicer has been added to the PivotTable, filtering can also be performed with the slicer for the 
PivotChart.

The PivotTable Legend values 
indicate the columns being displayed.

Filter buttons can be used to filter the data; 
in this example, the filter for position displays 
the Sales and Senior Account Mgr positions 
but hides the Sales Reps.

DEVELOP YOUR SKILLS: E3-D5	

In this exercise, you will insert a PivotChart for an existing PivotTable and then build a new PivotChart 
while creating the adjoined PivotTable at the same time.

	 1.	 �Save your file as E3-D5-SalesTargets.

	 2.	 �Go to the Sum of Sales by Location sheet.

	 3.	 �Choose PivotTable Tools→Analyze→Tools→PivotChart .

	 4.	 �In the Insert Chart dialog box, click OK to insert the clustered column chart.

	 5.	 �Drag to move the chart so it is directly below the PivotTable.
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	 6.	 �In the slicer, click the Multi-Select  button and then click Agent to display data for 
both Positions in the chart.

	 7.	 �Now go to the Sales worksheet and choose Insert→Charts→PivotChart .

	 8.	 �In the Create PivotChart dialog box, click OK.

	 9.	 �In the PivotTable Fields pane, add Location to the Axis, Month to the Legend, and 
Commissions to the Values.

	10.	 �Click the Month filter menu button , uncheck Sep, and click 
OK.

	11.	 �Rename the worksheet Commissions by Month.

	12.	 �Drag to move the chart so it is directly below the PivotTable.

	13.	 �Save your work and close the file.
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Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 PivotTable fields can be used to subtotal, compare, count, or perform other  
calculations on your data.	 True    False

2.	 You can use the PivotTable Field list to quickly add and remove fields by either  
clicking or dragging.	 True    False

3.	 You are the manager of a car dealership and want to modify a PivotTable to  
show the average inventory level instead of a sum of the inventory level; you  
could do this by changing the Value Field Settings for Inventory.	 True    False

4.	 Number formatting will automatically transfer from the source data to the PivotTable.	 True    False

5.	 The following PivotTable has been filtered by both Position and Region.	 True    False

6.	 The Value Field Settings dialog box has an option to display a value field  
as a % of the Grand Total.	 True    False

7.	 When you create a PivotChart, the fields in the Values area of the PivotTable  
are displayed as data series on the chart.	 True    False

8.	 To add a field to a PivotTable you can:

A.	Click the field checkbox.

B.	 Type the field name.

C.	 Click the Field checkbox or drag the field into the chosen Pivot area.

D.	Drag the field into the chosen Pivot area.
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9.	 The following PivotTable has the Region added to Rows and Type added to:

A.	Columns

B.	 Filters

C.	 Styles

D.	Values

10.	 If you want the ability to filter several PivotTables at once, all of which use the same source data, which 
type of filter should you use:

A.	AutoFilter

B.	 Filter Field

C.	 PivotFilter

D.	Slicer

11.	 Dayna has a PivotTable with inventory items that lists cost and markup percentages. She has asked you 
to help her add the retail price to the PivotTable (which is cost multiplied by markup). You should tell 
her to use:

A.	Value Field Settings

B.	 A calculated field

C.	 Show Values As

D.	Tell her this is not possible with PivotTables

12.	 If the following PivotTable was used to create a PivotChart, which field would display in the legend?

A.	Amount

B.	 Region

C.	 Type

D.	Grand Total




