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To start Excel, click Start and choose All Programs, Microsoft® Office, Microsoft Office Excel 2007.

Office Button
Provides access to a menu of commonly used commands, such 
as New, Open, Save As, Print, and Close. (This menu replaces the 
File menu used in previous versions of Excel.) The right side of the 
menu contains links to recently opened files.

Quick Access toolbar
Contains buttons for frequently used commands (by default, Save, Undo, and Repeat/Redo).

Add commands: Click the Quick Access toolbar button  and choose the command you 
want to add.
Move the toolbar beneath the Ribbon: Click the Quick Access toolbar button  and 
choose Show Below the Ribbon.

Ribbon
Contains tabs, which in turn contain groups of related tools, such as buttons, lists, and galleries. 
A gallery is a collection of commands or options that are represented graphically to show their 
results. If your screen is set to a low resolution, some groups on the Ribbon will display only the 
group name. To display the commands in the group, click the arrow on the group button.

Formula bar
Provides an area for entering and editing values, formulas, and text. To insert a formula, type 
it in the desired cell. Then click the Enter button  to accept the formula, or click the Cancel 
button  to delete it. To create a formula based on one of Excel’s built-in functions, click the 
Insert Function button . Use the Name box  to assign names to selected cells.

Worksheet
Consists of horizontal rows and vertical columns. The intersection of a row and a column is 
called a cell. For example, column A and row 1 meet at cell A1. An Excel file is called a workbook.
By default, a new workbook contains three worksheets.

Workbook navigation
Provides ways to access the worksheets in a workbook. To activate a worksheet, click its sheet 
tab at the bottom of the program window . If the desired tab is 
hidden, display it by using the scrolling buttons.

Status bar
Provides information and instructions for the active worksheet. Using buttons on the status 
bar, you can change the view to Normal, Page Layout, or Page Break Preview  and 
change the zoom level for the selected worksheet .
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Workbooks, Worksheets, and Sheet Elements

Create a workbook
1. Click the Office Button and choose New.

2. In the New Workbook dialog box, the “Blank and recent” 
category will be active and the Blank Workbook option will be 
selected.

3. Click Create.

Create a workbook based on a template
1. Click the Office Button  and choose New.

2. In the left pane of the New Workbook dialog box, select the 
category you want.

3. In the middle pane, select the template you want to use.

4. If the template is on your computer, click Create. Or, if the tem-
plate is online, click Download.

Open a workbook
Click the Office Button  and choose Open. Locate and select the 
workbook you want to use, and then click Open.

Save a workbook
1. Click the Office Button , point to Save As, and choose one of 

the following:

Excel Workbook: This is the default file format (.xlsx) for 
Excel 2007. This format does not support macros.

Excel Macro-Enabled Workbook: Use this file format (.xlsm) 
if your workbook contains macros. 

Excel 97-2003 Workbook: Use this format (.xls) to save a 
workbook so it’s compatible with Excel 97–2003.

2. In the Save As dialog box, select the location (drive and folder) 
where you want to save the workbook.

3. In the File name box, enter a name for your workbook.

4. Click Save.

Working with worksheets
Insert a new worksheet after existing worksheets: In the 
workbook navigation area, click the Insert Worksheet tab .

Insert a new worksheet before an existing worksheet: On the 
Home tab, in the Cells group, click the down-arrow on the Insert 
button and choose Insert Sheet.

Move a worksheet: Drag the sheet tab to the desired location.

Copy a worksheet: While holding c, drag the sheet tab to 
the location where you want the copy to be placed. (Release the 
mouse button before you release c.)

Name or rename a worksheet: Double-click its sheet tab, type 
a new name, and press e.

Change a worksheet’s tab color: Right-click the sheet tab and 
choose Tab Color. Select a color from the gallery.

Delete a worksheet: Right-click its sheet tab and choose 
Delete.

Move or copy a worksheet to another workbook
1. Open the source and target workbooks.

2. Click the sheet tab for the worksheet you want to move or copy.

3. Right-click the worksheet tab and choose 
Move or Copy.

4. From the To book list, select the target 
workbook. 

5. In the Before sheet list, specify the position 
for the moved or copied worksheet.

6. If you want to copy the sheet, check the
Create a copy box.

7. Click OK.

Workbooks and worksheets

Selecting a row, column, or range
Select a row: Click the numeric row heading .

Select a column: Click the alphabetic column heading .

Select a contiguous range: A range is a selection of multiple 
adjacent cells. To select a range, point to the first cell you want to 
select, and then drag to the last cell. (Make sure you don’t drag 
the fill handle .)

Select non-contiguous ranges: Select 
the first range. While holding c,
select each additional range by clicking 
or dragging.

Name a range
1. Select the range you want to name.

2. On the formula bar, click the Name box .

3. Type the desired name. Range names must begin with a letter or 
underscore and cannot contain spaces.

4. Press e.

Insert rows, columns, or ranges
Insert a row: Click the row heading below where you want the 
new row to be inserted. On the Home 
tab, click the down-arrow on the Insert 
button and choose Insert Sheet Rows.

Insert a column: Click the column 
heading to the right of where you want 
the new column. On the Home tab, click 
the down-arrow on the Insert button 
and choose Insert Sheet Columns.

Insert an empty range: Select the 
range where you want to insert empty cells. On the Home tab, 
click the down-arrow on the Insert button and choose Insert
Cells. Specify whether you want to shift the selected cells to the 
right or down. Click OK.

Move or copy cells by dragging
1. Select the cells you want to move or copy.

2. Point to the edge of the selection. The 
pointer will change to a four-way arrow. 

3. To move the selection, simply drag it to the 
desired location. To copy the selection, hold c (the pointer 
will change to a plus sign) and drag it to the desired location.

Delete a range
1. Select the range you want to delete.

2. On the Home tab, click the down-arrow on the 
Delete button and choose Delete Cells.

3. Specify where to shift adjacent cells and click OK.

Hide and show columns
Hide a column: Right-click the column heading and choose Hide.

Show a hidden column: Select the columns on both sides of the 
hidden column. Right-click and choose Unhide.

Rotate column labels
1. Select the column labels you want to rotate.

2. On the Home tab, in the Alignment group, click the Orientation 
button . Then, do one of the following:

Choose an orientation.

Choose Format Cell Alignment.
Under Orientation, enter the desired 
angle in degrees , and then 
click OK.

Rows, columns, and cells
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Data, Formulas, and Functions

A function is a predefined formula that performs a specific type of 
calculation.

Insert a function
1. Click the Formulas tab. Then, in the Function Library group, click 

a function category.

2. From the list of functions, select the function you want to insert. 
Then click OK to open the Function Arguments dialog box.

3. Enter the required arguments (values or references) by typing or 
by selecting cells. Then, click OK.

Functions

Use the AutoSum button (on the Home and Formulas tabs) to auto-
matically enter one of the following frequently used functions:

Sum: Adds numbers.

Average: Calculates an average.

Count Numbers: Counts the number of cells 
that contain numbers.

Max: Returns the largest value.

Min: Returns the smallest value.

 Enter a formula automatically
1. Select the cell where you want the function to go.

2. To add numbers in a range, click the AutoSum button . Or, to 
enter a different function, click the down-arrow on the AutoSum 
button and choose the function you want.

3. Excel will guess the range of values to use as the argument. Press 
e to accept this range, or enter your own range. 

AutoSum

Insert a formula
You use formulas to perform numeric calculations. Select the cell 
where you want the result to appear, and then do one of the following:

Press =. Enter the formula in the cell and press e.

On the formula bar, click the 
Formula box and press =.
Enter the formula and click .

References
There are several types of references you can use to identify a range 
on a worksheet and tell the formula where to look for the data.

Relative: The references are relative to the position of the formula 
on the worksheet. If the formula is copied to a new location, the 
references will be adjusted. To use a relative cell reference, enter its 
column letter followed by its row number—for example, A1.

Absolute: The references always refer to a specific location on 
the worksheet. If the formula is copied to a new location, the cell 
references will remain the same. To use an absolute reference, 
place a dollar sign ($) in front of both the column letter and the 
row number—for example $A$1.

Mixed: Some of the references are relative while others are 
absolute. If the formula is copied to a new location, the relative 
part of the reference will be adjusted, while the absolute part 
will remain the same. To use a mixed reference, place a dollar 
sign ($) in front of only the column letter or the row number—for 
example, $A1 or A$1.

Operators
Operators are used in formulas to indicate the type of calculation that 
the formula will perform. The table below shows some commonly 
used operators in the order in which they’re evaluated 
in expressions. To change the evaluation order, enclose
in parentheses the part of the formula to be calculated 
first—for example, =(A4-2)*6.

Operator Function Example Result using 
values above

^ Specifies an exponent. =5^3 125

* Multiplies numbers. =A1*A2 3125

/ Divides numbers. =A1/A2 5

+ Adds numbers. =A1+A2 150

- Subtracts numbers. =A1-A2 100

Formulas

Enter, edit, and organize data
Enter data in a cell: Select the cell, type the data, and press 
e (or click  on the formula bar).

Change your data: Double-click the cell, make your changes, 
and press e.

Delete data: Select the cell and press d.

Organize your data: Use labels to identify rows or columns of 
values.

Labels: Contain text only or text and 
numbers. To enter a numeric label, type 
an apostrophe (’) before the number.

Values: Include numbers, formulas, and 
functions that are used in calculations. To enter a value, either 
type a number or begin the value with +, -, =, @, #, or $.

Use AutoFill to complete a data series
1. Select the range that contains the initial value(s) of 

the series you want to complete.

2. Drag the selection’s fill handle (in the lower-right 
corner) down or to the right to fill in successive values. 
As you drag, a ScreenTip displays the last value in the series.

The following table shows the results for various types of data.

Selection AutoFill result

A series of numbers A continuation of the series

A single day of the week 
or a single month

The next day of the week or the next 
month

Multiple days of the week 
or multiple months

The next day of the week or the next 
month based on the series

Sort data
To sort data in a single column, select any cell in the column. 
On the Home tab, in the Editing group, click Sort & Filter and 
choose Sort Smallest to Largest or Sort Largest to Smallest.

Create a table (list) 
1. Select the range that contains your table items.

2. Click the Insert tab. Then, in the Tables group, click Table.

3. If the range has headers, check My table has headers.

4. Click OK. AutoFilter drop-downs are enabled for each column.

5. To filter the items, click the AutoFilter drop-down 
arrow . In the menu, clear Select All, select the 
items you want to display, and click OK.

6. To add items to your table, enter them in the last row.

Data

Label

Value

Name 
box

Function 
selector Enter

Cancel Insert Function

Formula 
box
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Formatting and Printing

Format text
1. Select the range you want to format. 

2. Use the buttons in the Font group on the 
Home tab.

NOTE: If you need formats not available on the Ribbon, click the Font 
group’s Dialog Box Launcher , specify the formatting, and click OK.

Apply a date format
1. Select the range that contains the dates you want to format. 

2. On the Home tab, in the Number group, 
click the Dialog Box Launcher .

3. From the Category list, select Date.

4. From the Type list, select a date format.

5. Click OK.

Use the Ribbon to apply number formats
1. Select the range that contains the numbers you 

want to format.

2. In the Number group on the Home tab, do one 
of the following:

Click the down-arrow on the Number For-
mat box and select a format from the list.

Click the number format (Currency, Percent, 
or Comma ) you want to use.

Change the column width
If ##### appears in a cell, the column needs to be widened to display 
a number. Here are some methods for changing column widths:

Point to the border between two column headings; the mouse 
pointer will change to this: . Drag the border to the left or 
right.

Double-click the column border. This automatically sizes the 
column to fit the widest data it contains.

Set a specific column size in characters. On the Home tab, in the 
Cells group, click Format and choose Column Width. Enter a 
column width and click OK.

NOTE: The same methods work for changing the row height.

Set alignment
Alignment refers to the placement of data within a cell.

Align the contents of a cell or range: Select the cell or range. 
In the Alignment group on the Home tab, click the alignment 
button you want: Align Left , Center , or Align Right .

Center data over a range: Select the range that contains the 
data you want to center. In the Alignment group on the Home 
tab, click .

Apply borders to a cell or range
1. Select the cell or range.

2. On the Home tab, in the Font group, click 
the down-arrow on the Borders button 
and choose the border format you want.

Add a comment to a cell
Use comments to provide additional information about a cell’s con-
tents. First, select the cell and click the Review tab. Then, click New
Comment, type your comment, and click outside the cell.

Copy formatting from one cell or range to another
1. Select the cell or range that has the formatting you want to copy.

2. In the Clipboard group on the Home tab, click the Format Painter 
button  to copy the selection’s formatting. 

3. Select the cell or range where you want to apply the formatting.

Formatting

Remove a cell’s contents, formats, or comments
1. Select the cell.

2. In the Editing group on the Home tab, click the Clear button, and 
then choose one of the following:

Clear All: Clears the contents of the cell, as well as any 
formats and comments.

Clear Formats: Clears the cell’s formats but not the contents.

Clear Contents: Clears the value, label, or formula in the cell 
but not the formats.

Clear Comments: Clears any comments but not the contents 
or formats.

Format a range as a table
You can quickly format a range as a table 
with alternate-row shading.

1. Select the range you want to format 
and click the Home tab.

2. In the Styles group, click Format as 
Table and select the table style you 
want to use.

NOTE: To preview what your table will look 
like with a style applied, point to the style.

Formatting, continued

Use Print Preview
Use Print Preview to see what a worksheet will look like when printed. 
To preview a worksheet, click the Office Button , point to Print,
and choose Print Preview. A Print Preview Ribbon tab will appear. 

Click Print to set the printing options and print the worksheet.

Click Page Setup to open the Page Setup dialog box, where you 
can select options for controlling how the sheets print.

Check Show Margins to display the margin handles, which you 
can move to change the margins.

Click Close Print Preview to return to the worksheet.

Define a print area
Select the range you want to print and click the Page Layout tab. In 
the Page Setup group, click Print Area and choose Set Print Area. A 
dotted line will appear around the area you set.

NOTE: To clear a print area, click the Page Layout tab. In the Page Setup 
group, click Print Area and choose Clear Print Area. The dotted line will 
disappear.

View or print gridlines and headings
Click the Page Layout tab. In the Sheet Options group, 
check the View or Print boxes under either Gridlines
or Headings.

Print a selection, worksheet, or workbook 
1. If you want to print a selection, select the desired range. Other-

wise, skip ahead to step 2.

2. Click the Office Button , point to Print, and choose Print to
open the Print dialog box.

3. From the Name list, select the printer you want to use.

4. Under Print range, specify a range of pages to print.

5. Under Copies, specify the number of copies.

6. Under Print what, specify whether you want to print the selected 
range, the active worksheet, or the entire workbook.

7. Click OK.

Printing



5

Worksheet Panes and Charts

Move or resize an embedded chart
Move an embedded chart: Select the chart and drag it to the 
location you want.

Resize an embedded chart: Select the chart to activate sizing 
handles along the chart’s boundary. Then, drag the sizing handles 
as needed.

Use Chart Tools tabs to modify and format a chart
Use the Chart Tools tabs (Design, Layout, and Format) to change the 
chart type and to format chart objects.

Change the chart type: Select the chart. Click the 
Design tab. In the Type group, click Change Chart 
Type. Select a new category and type, and click OK.

Change the chart layout or style: Select the chart. On the 
Design tab, in either the Chart Layouts or Chart Styles group, 
click the More button . Then select the style or layout you 
want to apply.

Transpose row and column data in the chart: On 
the Design tab, in the Data group, click Switch Row/
Column.

Move the chart to a separate chart sheet: On the Design tab, 
in the Location group, click Move Chart. Select New sheet, enter 
a name for the sheet, and click OK.

Enter titles for the chart or the x- and y-axes: Click the Layout
tab. In the Labels group, click either 
Chart Title or Axis Title and choose 
a position for the title. Click the label 
and enter your text.

Hide or reposition the legend: On the Layout tab, in the Labels 
group, click Legend and choose the desired option.

Display or hide the data table: On the Layout tab, in the Labels 
group, click Data Table and select Show Data Table.

Angle the chart title or a label: Select the text item. On the 
Layout tab, click Chart Title and choose More Title Options. (Or 
click Data Labels and choose More Data Label Options.) Click 
Alignment, specify an angle, and click Close.

Adjust the scale of a chart: Select the chart. On the 
Layout tab, click Axes. Choose Primary Horizontal Axis
or Primary Vertical Axis and then choose More … Axis 
Options. You can adjust the range of values on each axis, 
change the way the values appear on each axis, specify the inter-
vals at which the values appear, or set the point at which one axis 
crosses another. Click Close.

Display or hide gridlines: Select the chart. On the 
Layout tab, in the Axes group, click Gridlines. Select the 
horizontal or vertical gridlines and choose the gridline 
display option you want to use.

Select chart objects: Select the chart. Click the 
Layout tab or the Format tab. Select an object from 
the Chart Objects list in the Current Selection group.

Apply styles to a chart object: Select the object. 
Click the Format tab and use the buttons in the Shape Styles and 
WordArt Styles groups to format the object.

Pull out a slice in a pie chart
To draw attention to a specific data point 
in a pie chart, you can separate it from 
the rest of the pie. To do so, click the slice 
and drag it away from the pie. (The chart 
type must be Pie or Pie in 3-D.) 

Charts, continued

Freeze worksheet panes
To keep row or column labels or other data visible as you scroll 
through a worksheet, you can freeze panes.

Freeze a row or column: Select the row below the row 
to be frozen, or select the column to the right of the 
column to be frozen. Click the View tab. Click the Freeze 
Panes button and choose Freeze Panes.

Unfreeze panes: On the View tab, click the Freeze Panes
button and choose Unfreeze Panes.

Split a worksheet window into panes
You can split a worksheet into panes so that you can view up to four 
parts of the sheet at the same time. When you split a window (as op-
posed to freezing rows or columns), you can navigate in each pane.

Split a worksheet horizontally: Point to the 
split box at the top of the vertical scrollbar; 
the mouse pointer will change to this: .
Drag the split box down to where you want 
to split the window.

Split a worksheet vertically: Point to the 
split box to the right of the horizontal scroll-
bar; the mouse pointer will change to this: .
Drag the split box to the left.

Return a worksheet to a single pane: Double-click the boundary 
between panes.

Worksheet panes

Horizontal split box

Vertical split box

Create a chart
1. Select the data that you want to display as a chart. Be sure to 

select all the values you want to include in the chart and any 
labels that identify those values, as shown in the example below.

2. Click the Insert tab.

3. In the Charts group, click 
a chart type and then 
select a chart sub-type 
from the gallery.

The Chart Tools Ribbon tabs—Design, Layout, and Format—appear, 
and the chart is placed on the worksheet as an embedded chart.

Chart objects
The various parts 
of a chart are called 
objects. If you select 
the Column chart 
type, your chart will 
have the following 
objects:

Value axis:
Provides the 
scale for all data 
points in the chart, based on the values in the selected range.

Category axis: Includes the labels for all categories in the chart, 
as defined in the first row of data in the selected range.

Data point: The value from one cell in the selected range.

Data series: The values from all cells in a category.

Legend: Identifies the data series in the chart.

Chart title: A descriptive name for the chart.

Charts

Value axis Chart title Data series

Legend

Data point

Category 
axis
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Frequently Asked Questions

1. How do I get more help with Excel 2007?
Press ! to display Excel Help. You can also visit the Office Online 
Web site for further information and resources, such as spreadsheet 
templates: office.microsoft.com/excel.

2. Can I open an Excel 2007 workbook in an earlier version of 
Excel?
 If you are using a previous version of Excel and want to open an Excel 
2007 workbook, download the Compatibility Pack from 
www.microsoft.com/downloads and install it.

3. How can I check a workbook for features not supported in 
earlier versions of Excel?
To check a workbook for features not supported in earlier versions of 
Excel, run the Compatibility Checker. Click , point to Prepare, and 
choose Run Compatibility Checker. The Compatibility Checker dialog 
box will display any compatibility issues. Click OK. Change your work-
book as needed to fix the compatibility issues, and then save your file. 

4. How do I use the mouse to enter cell references in
formulas?

1. Select the cell where you want to enter the formula and press =.

2. Click the cell that you want the formula to refer to, and type the 
operator you want.

3. Repeat step 2 until you’ve completed the formula. Then, press 
e.

5. How can I format cells so that text wraps in them?
Select the cells you want to format. On the Home tab, in the Alignment 
group, click .

6. Is there a way to perform a quick calculation?
Select the cells you want to include in your calculation. The average, 
count, and sum of the selected values are displayed automatically in 
the status bar . To change the function, 
right-click the status bar and choose the desired function.

7. How can I search for and replace a formula or value in a 
large worksheet?
Here’s an efficient way to search for and replace formulas, values, or 
text in rows, columns, or an entire worksheet:

1. Select the range you want to search. If you want to search 
the entire worksheet, click any cell.

2. On the Home tab, in the Editing group, click Find & Select
and choose Replace.

3. In the Find what box, enter the value or text you want to find.

4. In the Replace with box, enter the new text or value you want to use.

5. Click Find Next to locate and select the first instance of the search 
text or value.

6. Click Replace to make the replacement in only the selected cell. Or, 
to replace all instances of the search value or text, click Replace All.

7. Repeat steps 5 and 6 as needed. Then, click Close.

8. How do I hide all zero values?
1. Click the Office Button  and then click .

2. In the left pane, click Advanced.

3. Next to “Display options for this worksheet,” select the worksheet  
where you want to hide the zero values.

4. Clear Show a zero in cells that have zero value and click OK.

9. How do I check the spelling in a range or an entire worksheet?
1. Select the range you want to check. Or, if you want to check the 

entire worksheet, select any single cell.

2. Click the Review tab and click Spelling.

3. When a word isn’t found in the dictionary, click one of the 
following buttons:

Ignore Once: To ignore the current word.

Ignore All: To ignore all occurrences of the word.

Add to Dictionary: To add the word to the dictionary.

Change: To correct the current instance of the misspelled word.

Change All: To correct all instances of the misspelled word.

4. Continue through the range or worksheet by responding to each 
suggestion. When you’re done, click OK.

10. How can I add a header or footer to a worksheet?
1. Click the Insert tab.

2. In the Text group, click Header & Footer. The worksheet will 
change to Page Layout view, and the Header & Footer Tools | 
Design tab will appear.

3. Type your header text in the box that appears, or click the buttons 
in the Header & Footer Elements group to add fields to the header.

4. In the Navigation group, click Footer.

5. Type your footer text in the box that appears, or click the buttons 
in the Header & Footer Elements group to add fields to the footer.

6. To switch back to Normal view, click a cell on the worksheet. Then, 
click the Normal button  on the status bar.

11. How can I save a custom cell style?
Select the cell whose formatting you want to save. On the Home tab, 
in the Style group, click Cell Styles and choose New Cell Style. Enter 
a name for the new style, specify which formats should be saved with 
the style, and then click OK.

NOTE: To apply the new style, select the cells you want to apply it to, click 
Cell Styles, and choose the style name.

12. How do I use Key Tips?
1. Press a to display the Key 

Tip badges. They first appear 
for all Ribbon tabs, the Quick 
Access toolbar, and the Office Button. 

2. Press the key for the desired tab to display all Key Tip badges for 
that tab’s buttons. 

3. Press the key or keys for the button you want. If the Key Tip is two 
letters, press the first key and then the second one.

13. What are some common keyboard shortcuts?

Press this… To do this…

& Check spelling in selected cells.

c+N Create a new workbook.

c+S Save the current workbook.

c+P Print the current worksheet or selection.

c+! Maximize or minimize the Ribbon.

a+e Start a new line in the same cell.


