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3Querying a Database
ACCESS 2021 & 365

One of the main goals of a database is 
to organize data so that 
information can be located and 

retrieved quickly. People in all types of 
businesses retrieve stored data and 
information daily, often at a moment’s 
notice. In this chapter, you will search 
information that is stored in tables in a 
relational database and extract records that 
meet specific criteria using a query, a 
database object used to locate records 
based on the conditions you set.

LEARNING OBJECTIVES
	■ Create, save, and run select queries

	■ Create select queries using multiple tables

	■ Use simple query criteria

	■ Use AND and OR criteria in queries

	■ Use wildcard characters in query criteria

	■ Sort query results

	■ Create and format a calculated field

CHAPTER TIMING
	■ Concepts & Practice: 01:10:00

	■ Self-Assessment: 00:15:00

	■ Total: 01:25:00

PROJECT: USING QUERIES TO GET 
ANSWERS
You have been asked to query the Winchester Web 
Design database and compile two separate 
customer lists. The lists will be used to notify all 
past clients of updates to their website contact 
forms. The first list will include only the first and 
last names of the clients and their email addresses. 
The second list will include the first and last names 
of the clients and their mailing addresses, sorted by 
ZIP code. Additionally, you have been asked to 
build queries that instantly calculate the total 
income from all the Winchester Web Design 
services and from specific areas such as blogs or 
shopping carts.
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50  FastCourse Access, Chapter 3: Querying a Database

Select Queries
A query asks a question, such as, What are the customer addresses? or How much money did the company 
make last month? The answer to the question is provided in a set of records.

All queries have common attributes:

•	They function like a saved question you ask a database.

•	They produce a subset of data from one or more tables.

•	They are dynamic objects that display up-to-date data from tables.

•	They can be used to create forms and reports with fields drawn from multiple tables.

•	When you edit data in query results, you are actually editing the data stored in the source tables.

A select query is basically a database inquiry that selects only the records you want to see or edit, from 
one or more database tables, based on criteria that you set. The easiest way to create a select query is 
with the Query Wizard.

Create→Queries→Query Wizard 

DEVELOP YOUR SKILLS: A3-D1

In this exercise, you will use the Query Wizard to create a select query that generates a customer email list.

1.	 Open A3-D1-WinDesign from your Access Chapter 3 folder and save it as: 
A3-D1-WinDesignRev

Notice in the Navigation pane that the database currently has three queries.

Note!	 When completing exercises, always choose to Enable Content.

2.	 Choose Create→Queries→Query Wizard.

The New Query dialog box appears, allowing you to select the Query Wizard you would like. The 
Wizard can help you create four types of queries, shown in the right pane of the dialog box.

3.	 Click OK to accept the Simple Query Wizard.
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Select Queries  51

4.	 Follow these steps to build the query:

A

B
C

E

D

A.	 Make sure the Customers table is chosen in the Tables/Queries list. When building a query, 
you can use multiple tables and even existing queries.

B.	 Choose the CustLastName field from the Available Fields list.

C.	 Click the Add  button to add it to the Selected Fields list.

D.	 Now add the CustFirstName and CustEmail fields, scrolling to find them as necessary, to 
the Selected Fields list.

E.	 Click Next.

If you add the wrong field, double-click the name to move it back to the Available Fields list or select it 
and use the Move Back  or Move All Back  buttons.

5.	 Type CustomersEmailList in the query title field at the top of the dialog box.

6.	 Make sure the Open the Query to View Information option is chosen and click the Finish 
button.

Notice the query results datasheet includes only the three fields you chose from the Customers list.

7.	 Click the Close button at the right of the Customers Email List tab to close the query.
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52  FastCourse Access, Chapter 3: Querying a Database

Creating a Select Query Using Query Design View
Some queries display just a few fields but report on every single record in the table. That may not be a 
problem for a small table, but, when thousands of records and multiple tables are involved, it is often 
necessary to choose only specific records by setting precise criteria. Using Query Design View, Access 
allows you to:

•	Select fields from multiple tables

•	Locate records using criteria from one or more fields

•	Perform calculations

•	Sort query results and show or hide fields in query results

Create→Queries→Query Design 

DEVELOP YOUR SKILLS: A3-D2

You have already created an email list for the Winchester Web Design customers and now need one for the 
company’s employees. In this exercise, you will create a query to select fields from the Employees table in the 
Winchester Web Design database and then rearrange the columns in the query grid.

1.	 Choose Create→Queries→Query Design to display the query design grid.

The Add Tables pane appears on the right, showing the existing tables, links, and queries in the 
database.

2.	 Select the Tables tab, choose the Employees table, and click Add Selected Tables at the 
bottom of the pane.

The Employees table appears in the design grid.

3.	 Close the Add Tables pane and close the Property Sheet if it’s open.

Next you will add fields from the Employees table to the grid.

4.	 Double-click the EmpFirstName field in the Employees table to add it to the grid.

5.	 Now add the EmpLastName, EmpPhone, and EmpEmail fields to the grid by either double-
clicking or dragging them.

Tip!	 Use the scroll bar located at the right of the table fields to access all available fields 
in the list.

6.	 Choose File→Save.

7.	 Type EmployeeContactInfo as the query name and click OK.

8.	 Choose Query Design→Results→Run .

Access runs the query and displays four columns of data (First Name, Last Name, Telephone, and 
Email) for all Employee records.
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Select Queries  53

Rearrange Query Fields
9.	 Choose Home→Views→View→Design View.

10.	 Select the EmpLastName column by placing your mouse pointer over the column heading until 
it becomes a downward-facing black arrow and then single-click.

The entire column is selected, shown by shading it in black.

11.	 Follow these steps to rearrange the EmpFirstName and EmpLastName fields:

ABC

A.	 Click the EmpLastName column heading again, this time without releasing the button. 
The button will change to a white arrow with a silhouetted box, indicating you can move the 
column.

B.	 Drag the EmpLastName column to the left of the EmpFirstName column until the thick ver-
tical bar is positioned as shown.

C.	 Release the mouse button to complete the rearrangement.

12.	 Run the query.

Last Name should now appear first in the results.

13.	 Close the query and save the changes.

Designing a Query Using Multiple Tables
Until now, the query results presented in the datasheets you have worked with have displayed data from 
only one table. There will be times when you need to view data contained in different tables within the 
same database. Multi-table queries allow you to do this.

Choosing Fields to Include in a Query
When you build a multi-table select query, you start in Query Design view. Using the Show Table dialog 
box, you can select only those tables and fields that you want to display in the query results datasheet 
and leave out those fields that have no impact on the data you want to view or that are confidential. By 
specifying only certain tables and fields in a database and displaying only the desired fields in a query, 
you can create a report or a form that presents only pertinent data.
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54  FastCourse Access, Chapter 3: Querying a Database

Multiple tables are effective in a query only if the tables are related. Using related tables allows a query 
to provide results based on all the data contained in the related table fields selected. For example, if you 
want to find the names and addresses of customers who placed orders from a specific employee, you 
would need fields from both the Customers table and the Invoices table. This is because the Customers 
table does not include any Employee fields, and the Invoices table does not include the Customer fields. 
It would be impossible to answer the question using only the Customers or Invoice tables alone.

	☁ View the video “Create a Multi-Table Select Query.”

Selecting a Field That Appears in Multiple Tables
Sometimes the same field occurs as a primary key in one table and as a foreign (or secondary) key in 
another table. If this occurs, always use the table with the primary key in your query.

Use the Customers table in the query 
because CustID is the primary key.

CustID is a foreign key 
in the Invoices table.

DEVELOP YOUR SKILLS: A3-D3

In this exercise, you will create a multi-table query using Query Design view to track the Winchester Web 
Design invoices by invoice number.

1.	 Choose Create→Queries→Query Design to display the query design grid.

2.	 Double-click the Invoices, Invoice Details, and Products tables to add them to the query.

If the Add Tables pane is not visible, choose Query Design→Query Setup→Add Tables.

3.	 Close the Add Tables pane. 

4.	 Double-click the InvNum, InvDate, and EmpID fields in the Invoices table to add those fields to 
the query grid.

5.	 Add the ProdDescription and Price fields from the Products table.

6.	 Add the Qty field from the Invoice Details table.

Your query field list should look like this:
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Using Criteria in Queries  55

7.	 Click the Sort cell for the InvNum field, click the menu button , and choose Ascending.

8.	 Choose Query Design→Results→Run to run the query.

The query results are now sorted by invoice number in the first column.

9.	 Click the Save button on the title bar; then name the query InvoicesList and click OK to 
save the query.

Using Criteria in Queries
Queries let you specify criteria, which are conditions that field values must meet. Only records meeting 
the criteria are returned when the query is run.

In this query, the EmpID criteria is set to JFW.

Only records where EmpID is JFW are returned.

Criteria are commonly used with text, numeric, currency, and date fields. Review the table for examples 
of how criteria are used:

TYPES OF CRITERIA

Field Type Criteria Examples of How Records Are Returned

Text Smith Last name is Smith

> =Smith Last names are from Smith through the end of the alphabet

Not Smith Last name is not Smith

Numeric & 
Currency

> 123

> =123

Numeric value is greater than 123

Numeric value is greater than or equal to 123

Date Date( ) Date is today’s date

< Date( ) – 30 The Date field is 30 days or more prior to today’s date

Tip!	 Search for Query Criteria in Access help for more criteria examples.
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56  FastCourse Access, Chapter 3: Querying a Database

DEVELOP YOUR SKILLS: A3-D4

In this exercise, you will add criteria to the query grid and run the query.

1.	 With the InvoicesList query open, switch to Design View.

2.	 Click the Criteria cell for the EmpID field.

3.	 Type JFW and tap [Enter].

Access will apply quotation marks indicating this is a literal value.

4.	 Choose Query Design→Results→Run to run the query.

The query results now include only records where the EmpID is equal to JFW.

5.	 Close the query and choose No when prompted to save the changes.

Saving changes to the query at this time would save the JFW criteria as part of the query. However, you 
will continue to use the query for all employees.

 

Wildcard Characters
Wildcard characters are used to locate records that have similar but not identical data. They help you 
locate records that match a pattern. For example, you might want to find all customers with last names 
that begin with the letter B or all products that begin with the word Blog.

COMMON WILDCARD CHARACTERS

Wildcard Symbol How It Is Used

Asterisk (*) Substitutes for a group of characters that appear at the 
position of the asterisk

Example: R* in the last name field will locate all last names 
beginning with R regardless of how many characters make up 
the name. In this case, Rogers, Rich, and Rodriquez would all 
appear in the results datasheet.

Question mark (?) Substitutes for a single character that might appear at the 
position of the question mark

Example: m?s will locate records containing values such as 
mrs, ms, and mbs.

Open/close brackets [ ] Matches text or individual characters placed within the 
brackets individually

Example: ca[rt] will find cat and car but not cab or cad.

Tip!	 Search for wildcard characters in Access help for more wildcard symbols and 
examples.

FastCourse Microsoft Access 2021 & 365: Level 1 © 2022 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Using Criteria in Queries  57

AND and OR Criteria
In some cases, you may need to locate records that meet multiple criteria. This can be done using AND 
and OR conditions. For example, you may want to locate all records where the employee is web certified 
AND lives in Sarasota. Or you may want to locate all employees who live in Sarasota OR Bradenton.

Create an OR condition by adding a second criterion to the Or row of a field.

Create an AND condition by adding another criterion to a different field on the Criteria row.

	☁ View the video “Create a Query with Criteria.”

DEVELOP YOUR SKILLS: A3-D5

In this exercise, you will use wildcards to locate variable data and set multiple criteria in a query to find out 
which customers have gotten blogs and which customers have added more than ten images at a time to their 
websites.

1.	 Open the InvoicesQuery query in Design View.

2.	 Follow these steps to use wildcard characters and to use AND and OR criteria:

B
A

C

A.	 In the ProdDescription Criteria cell, type Blog* and tap [Enter].

Access converts Blog* to: Like "Blog*"

B.	 In the ProdDescription Or cell, type Image* and tap [Enter].

C.	 Enter > 10 in the Qty Or cell. Be sure to type in the same row as Like "Image*" (the Or row).

These criteria will choose records where ProdDescription begins with Blog OR ProdDescription begins 
with Image AND the Qty is greater than 10.

3.	 Run the query.

Access displays the records that meet the specified criteria: either a blog or a transaction with more 
than ten images.

4.	 Close the query and save the changes.
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58  FastCourse Access, Chapter 3: Querying a Database

Date Criteria
You can set date criteria to determine age, hired date, invoice date, and so forth. Access acknowledges 
the same comparison criteria for performing date comparisons that it does for locating other types of 
data, regardless of the format used to enter dates.

DATE CRITERIA

Criterion Examples of How Records Are Returned

06/22/2021 Date is 06/22/2021

<22-Oct-2021 Dates that occur before 22/Oct/2021

>01/01/21 Dates that occur after 01/01/21

Between 01/01/21 and 06/30/21 Dates between 01/01/2021 and 06/30/2021

DEVELOP YOUR SKILLS: A3-D6

Winchester Web Design needs to track all invoices issued in 2031. In this exercise, you will query the database 
to locate customers with invoices dated from January 1, 2031, through December 31, 2031.

1.	 Choose Create→Queries→Query Design .

2.	 If necessary, open the Add Tables pane and click the Tables tab at top left of the pane.

3.	 Use double clicks to add the Customers, Invoices, InvoiceDetails, and Products tables to  
the query.

4.	 In the Invoices table double-click InvNum and InvDate to add those fields to the query grid.

5.	 From the Customers table add the CustID field.

6.	 From the Invoice Details table add the Qty field.

7.	 From the Products table add the ProdDescription and Price fields.

8.	 Hover your mouse pointer on the right edge of the InvDate column heading so a black, two-
direction arrow appears.

9.	 Click and drag the column heading to the right until the column is about three times the original 
width.

You will enter a long entry in the next step and widening the InvDate column will allow you to see the 
entire entry.
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Sorting, Showing, and Limiting Results  59

10.	 Click in the Criteria cell for the InvDate field and type: Between January 1, 2031 And 
December 31, 2031

Access formats the expression. Your query grid should now match this example. Regardless of how you 
type the dates—whether January 1, 2031; 01/01/31; or 1-1-2031—Access formats the data after you 
enter it so it appears as #1/1/2031#.

11.	 Run the query.

Notice that only records with a date in 2031 appear in the results.

12.	 Choose File→Save.

13.	 Save the query as Invoices2031 and then close it.

Sorting, Showing, and Limiting Results
The query grid contains a Sort row that lets you sort the query results. At times you may also want to 
use fields to specify criteria but may not want those fields to be displayed in the query results. This can 
be accomplished by unchecking the Show box for the desired field(s).

Limiting the Number of Results Displayed
Large databases with thousands of records often return so many records that it can be challenging to 
find what you are looking for. Limiting the number of records displayed can be beneficial, especially 
when these records are sorted.

For example, if you set up a query to sort in descending order and then limit the number of items 
displayed to ten, you would, in effect, have a list of the top ten items in the table being queried. The 
Return feature lets you set the number of records to be displayed, or returned, in the query results.

Query Design→Query Setup→Return 

DEVELOP YOUR SKILLS: A3-D7

In this exercise, you will create a query that sets a sort order and hide a field from displaying in the query 
results. You will also limit the number of records returned.

1.	 Choose Create→Queries→Query Design.

2.	 If necessary, open the Add Tables pane and click the Tables tab at top left of the pane.

3.	 Use double clicks to add the Customers, Invoices, Invoice Details, and Products tables to the 
query.
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60  FastCourse Access, Chapter 3: Querying a Database

4.	 In the Customers table double-click the CustID, CustFirstName, and CustLastName fields to 
add them to the design grid.

5.	 From the Invoices table add the InvDate field.

6.	 From the Products table add the ProdDescription field.

7.	 From the Invoice Details table add the Qty field.

8.	 Follow these steps to set a criterion and set the sort order:

B
A

A.	 In the ProdDescription Criteria cell, type Image* and tap [Enter]. Access converts Image* 
to Like "Image*". This criterion will choose only records where the product description begins 
with Image.

B.	 In the Sort cell for the Qty field, choose Descending from the list of sort options.

9.	 Run the query.

The records are now sorted in descending order (largest to smallest) by quantity.

CustID is an important key to have in the query because it is a primary key field. But it isn’t needed 
in the query results because it contains the same information that appears in the CustFirstName and 
CustLastName fields, so you will hide it from the query results.

10.	 Choose Home→Views→Design View to switch back to Design View.

11.	 Uncheck the Show box for the CustID field and Run the query.

The CustID field is still part of the query design, but it no longer shows in the query results.

12.	 Switch back to Design View and choose Query Design→Query Setup→Return menu  
button  .

13.	 Choose 5 from the list and run the query.

The query returns seven records (not five). This is because the query returns all records with the five 
largest quantities. But three records had a Qty of 14, which is the fifth highest amount, so all those 
records were returned, increasing the total to seven records.

14.	 Save the query as MostImages and then close it.

Calculated Fields
Calculated fields are fields containing formulas that perform calculations. Formulas used in calculated 
fields are often based on other fields within the query. Calculated fields are added as an additional field 
to a query and are not part of the underlying query tables. They are added to the query design grid and 
their calculated results then appear in the query results. A calculated field:

•	Creates a new field in a query that can also be used in a form or report

•	Can be used to perform mathematical operations, such as addition and multiplication

•	Has a name and can be formatted with properties just like a regular field

•	Enables you to combine values in two text fields into one field, such as LastName and FirstInitial

•	Updates and recalculates each time you run the query
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Calculated Fields  61

Identifying Parts of a Calculated Field
The structure of a calculated field includes a field name and a mathematical expression. An example of 
a calculated field in an Access query is Wage: 12.00 * 40, where Wage is the calculated field name and 
12.00 * 40 is the calculation to be performed. Another example is Total: Price * Quantity, where Total is 
the calculated field name and Price * Quantity are the calculations performed using the data in those 
query fields.

The LineTotal calculated field multiplies Price * Qty.

Each calculated field can contain the following elements:

CALCULATED FIELD ELEMENTS

Element Description

Calculated field name This is the unique name you assign to the field and is followed 
by a colon (:) to separate the field name from the expression.

Field names from 
existing tables

Field names from the query can be added to the calculated 
field expression. Access adds brackets [ ] around field names.

Arithmetic or 
comparison operators

Use +, -, *, /, ( ), ^, <, =, and > to perform mathematical 
operations or compare values.

Concatenation (i.e., 
linking together)

An ampersand (&) can be used to join text values from multiple 
fields. For example, FirstName&LastName.

Spaces can be added between fields by using quotation marks 
around a single space (" "). For example, the quotation marks in 
FirstName& " " &LastName create a space between the first and 
last names in the query results.

Calculated Field Properties
You can set field properties such as size, number format, and default values within tables. Likewise, you 
can set field properties in calculated fields. This is almost always needed in calculated fields as the query 
results need to be formatted with the correct number of decimal places, commas, currency format, and 
other formatting as needed. Field properties are set using the field Property Sheet.

Query Design→Show/Hide→Property Sheet 

The query results.
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DEVELOP YOUR SKILLS: A3-D8

In this exercise, you will create and format a calculated field.

1.	 Open the InvoicesList query and switch to Design View.

2.	 Click in the first cell of the blank column next to the Qty field.

3.	 Type the calculated field expression, taking care to include the colon between LineTotal and 
Price: LineTotal:Price * Qty

4.	 Tap [Enter] to accept the entry and allow Access to format the expression by adding brackets to 
the field names.

Access does not always format your expression by adding brackets to field names. Brackets are 
required for Access to identify the entry as a field within the query. If you want to use field data within 
a calculated field expression, you need to include the name of your calculated field within brackets. In 
this example our calculated field is named LineTotal, and it will multiply the data in the Price field by 
the data in the Qty field in each record when the query is run. Your completed field should match the 
following:

5.	 Right-click anywhere in the column of your calculated field and choose Properties.

The Property Sheet opens.

6.	 Click the Format field, then click the menu button  and choose Currency from the list.

7.	 Click the Caption field and type: Line Total

The currency format will display the calculated results with a dollar sign and two decimals. The 
caption will become the column heading for your calculated field in the query results.

8.	 Run the query, and your calculated field results will appear as shown:

9.	 Save and close the query and then close the database.

Self-Assessment
Use the Self-Assessment quiz in the Student Resource Center to check your knowledge of the key 
concepts and skills introduced in this chapter.
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