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8Customizing Reports
ACCESS 2021 & 365

Database reports summarize the data 
contained in tables or displayed in 
query results and enable you to 

provide information in a page layout 
suitable for printing. Although forms and 
reports serve different purposes within the 
context of a relational database, the 
techniques used to customize them are 
similar. In this chapter, you will import 
reports from other databases and use 
features to create custom reports.

LEARNING OBJECTIVES
	■ Import a report into a database

	■ Add a subreport to a main report

	■ Create a report from a subreport

	■ Create calculated controls on a subreport

	■ Set page breaks in reports

	■ Add a chart to a report

CHAPTER TIMING
	■ Concepts & Practice: 01:20:00

	■ Self-Assessment: 00:15:00

	■ Total: 01:35:00

PROJECT: BILLING CUSTOMERS
The company manager of Winchester Web Design, 
a small web page design company, wants you to 
improve its invoice report for customer billing. 
After reviewing invoices from several companies, 
the company manager has sketched out a design 
for the new invoice report layout. Your job is to 
create a sample of the new invoice report for the 
company’s executive team.
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140  FastCourse Access, Chapter 8: Customizing Reports

Importing a Report into a Database
Access offers a variety of ways to create reports. In addition to using the Report Wizard or starting from 
scratch in Design View, you can import reports from another database. Because most companies require 
some type of invoice to send with customer orders, locating a sample invoice report to import is not difficult.

Sometimes you have the report you want, but during its design it may have become corrupted, either 
due to inadvertent changes to the report itself or because of changes to an underlying query. That’s 
when backups are invaluable. If a report becomes corrupted, you can restore it by importing database 
objects from a backup copy of a database. The record source should already match, and there should be 
no need to edit the properties or the field names.

Identifying Report Record Sources
Reports you import retain two connections to their original database. The first is the source database 
table or query name, shown in the Record Source property, and the second are the field names, which 
appear in report text boxes. As a result, when you import a report from another database, you often 
must establish new control sources to the destination database. You can accomplish this by:

•	Editing the imported report’s Record Source property to link to a table or query in the destination 
database.

•	Editing, if necessary, the field names in the imported report’s text boxes to match those in the new 
record source table or query.

External Data→Import & Link→New Data Source→From Database→Access 

DEVELOP YOUR SKILLS: A8-D1

In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

1.	 Open A8-D1-WinDesign from your Access Chapter 8 folder and save it as: 
A8-D1-WinDesignRev

2.	 Look in the Reports section in the Navigation pane and notice the database contains three 
reports.

3.	 Choose External Data→Import & Link→New Data Source→From Database→Access.

The Get External Data – Access Database dialog box appears.

4.	 Click the Browse button and navigate to your Access Chapter 8 folder.

5.	 Choose the file A8-D1-WinDesign-Backup and click Open.

This database is a backup copy of the WinDesign database.

6.	 Leave the Import tables, queries, forms, reports storage setting selected and click OK.

Access opens the Import Objects dialog box and displays object names contained in the backup 
database in tabbed groups.

7.	 Click the Reports tab, choose CustomerInvoices, and click OK.
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Adding a Subreport to a Main Report  141

8.	 Leave the Save Import Steps box unchecked and click Close.

The CustomerInvoices report is added to the Reports section of the Navigation pane.

9.	 Double-click the CustomerInvoices report to open it in Report View.

10.	 Scroll down as necessary to see the empty space between the customer information and  
signature blocks.

This is a great spot to insert a subform/subreport that includes the invoice detail lines.
 

Adding a Subreport to a Main Report
Subreports display subsets of data in reports and are derived from related database tables, similar to sub-
forms on forms. However, a subreport can display table data by using a table, query, form, or another report 
as its source object. Forms are frequently created before reports and often already display the required report 
data. To streamline the report design and layout, it’s best to use a subform as the basis of a subreport.

This invoice report uses a subform to display invoice details.
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142  FastCourse Access, Chapter 8: Customizing Reports

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add  
a subform to a form. You can create the subreport using the Report Wizard or add an unbound subreport 
control to the report. Then you identify the database object containing the fields you  
want to display as a subreport.

	☁ View the video “Adding a Subreport Using the Wizard.”

Report Design→Controls→More→Subform/Subreport 

DEVELOP YOUR SKILLS: A8-D2

In this exercise, you will add a subreport to the CustomerInvoices report. You will use the 
InvoiceDetailsSubform as the source for the subreport.

1.	 Display the CustomerInvoices report in Design View.

2.	 Choose Design→Controls→More→Subform/Subreport (at the bottom of the controls list).

3.	 Click just below the ZIP label to insert a control and launch the SubReport Wizard.

4.	 Choose the Use an Existing Report or Form option.

5.	 Choose InvoiceDetailsSubform from the list and click Next.

6.	 Click Next again to accept the Choose from a list linking method.

7.	 Click Finish to accept InvoiceDetailsSubform as the name.

The subform is inserted in the report.

Set Properties
8.	 Display the Property Sheet, if necessary, and click the Data tab.

Notice the Source Object is set to Form.InvoiceDetails Subform.

9.	 Switch to the Format tab in the Property Sheet and set these properties:

Property Setting

Width 5.6

Height 1.5

Top 2.9

Left 0.5
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Creating a Report from a Subreport  143

10.	 Click the InvoiceDetailsSubform label, which is just below the ZIP label, and set these 
properties:

Property Setting

Caption Invoice Details

Width 1.2

Height 0.30

Top 2.5

Left 0.5

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1, Darker 50%

Switch to Report View to see your completed report.

11.	 Use the Navigation bar and the scroll bar to review the database records.

The information in both the report and the subform changes each time a new record is displayed.

12.	 Close the report, saving the changes.

Creating a Report from a Subreport
Using a subform as the record source for a subreport is convenient because the subform already 
includes the needed data. However, when a subreport uses a form as the record source, any changes 
made to the subreport layout are reflected in the source form. If you don’t want the source form to be 
changed, you can save the subreport as a separate report in the database, change the main report’s 
Record Source property to the new report object, and then edit the subreport.

Access allows you to save an existing form as a new form and an existing report as a new report. When 
a subform is used as the record source for a subreport, you can open the subreport in a separate window 
and save it as a separate report.

File→Save As→Save Object As→Save As
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144  FastCourse Access, Chapter 8: Customizing Reports

DEVELOP YOUR SKILLS: A8-D3

In this exercise, you will create and save a new report based on the subreport from the CustomerInvoices 
report. You will then edit the source object property in the main report to display the new subreport.

1.	 Open InvoiceDetailsSubform from the Forms section of the Navigation pane.

2.	 Choose File→Save As, choose Save Object As from the File Types list, and then click the Save 
As button in the right pane.

3.	 Type WWDCustomerInvoicesSubreport as the name, choose Report from the As drop-
down list, and click OK.

A new report is added to the Reports section of the Navigation pane.

4.	 Close the InvoiceDetailsSubform.

5.	 Open the new WWDCustomerInvoicesSubreport in Design View.

6.	 Display the Property Sheet, if necessary, and then click the All tab and type Customer 
Invoices Subreport as the caption.

Create a Title for the Subreport
7.	 Choose Report Design→Header/Footer→Title.

Access places a title and empty placeholder controls in the Report Header.

8.	 Type Winchester Web Design Invoice Details in the title control and tap (Enter).

9.	 Set these property values for the new title control:

Property Setting

Width 3

Height 0.25

Left 1

Font Name Arial

Font Size 12

Text Align Center

10.	 Click the Report Header section bar and set the Height property to: 0.3069

Inserting the title in the header widens the subreport, so you will now reset the width.
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Numbering Items in a Report  145

11.	 Click the report selector button and set the Width property to: 5.6

12.	 Close the subreport, saving the changes, and then open the CustomerInvoices report in 
Design View.

13.	 If necessary, display the Property Sheet and click the Data tab.

14.	 Click the subreport to select it.

15.	 Click in the Source Object property box.

A drop-down menu button appears at the far right of the 
property box.

16.	 Choose Report.WWDCustomerInvoicesSubreport 
from the drop-down menu.

17.	 Switch to Report View to see how the new subreport 
looks.

Notice the change in appearance compared to the subform 
used previously.

18.	 Scroll through the report, seeing how the subreport always shows the correct invoice details.

19.	 Close the CustomerInvoices report, saving the changes.

Numbering Items in a Report
As the number of records in a table grows, the length and number of records in a report or subreport 
also grows. You can number the records in a report to help track the items listed. If a report is grouped, 
you can set the count to restart numbering at the beginning of each group.

Setting Properties to Number Items
By adding a text box to the Detail section and setting its Control Source property to =1, you can auto-
matically number items in a report. In addition, you can set the Running Sum property to identify the 
portion of a report for which you want to count items. For example, suppose you have an invoice report 
that groups services by invoice number. You can set the Running Sum property to count the items in 
each group and then start counting again with the next group.

Numbering Subreports Separately
Access does not permit numbering items in a subreport control on a main report. However, because you 
saved the subreport as a separate report, you can add the numbering controls directly to the subreport 
by opening it in a separate window. Any edits you make when it is open as a separate item are reflected 
in the main report the next time you open it.
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146  FastCourse Access, Chapter 8: Customizing Reports

DEVELOP YOUR SKILLS: A8-D4

In this exercise, you will reposition the controls in the WWDCustomerInvoicesSubreport page header and 
add a text box control to count the number of line items.

1.	 Display the WWDCustomerInvoicesSubreport in Design View.

2.	 Right-click the Detail section bar and choose Page Header/Footer.

You will add labels to the Page Header section.

3.	 Click the Page Header section bar and change the Height property to: 0.3

4.	 Select the ProdID label in the Detail section and use (Ctrl)+(X) to cut the control.

5.	 Click in the Page Header section bar and use (Ctrl)+(V) to paste the label.

6.	 With the ProdID label still selected, set both the Width and Left properties to: 0.5

7.	 Use the procedure in steps 4–6 to move the Description, Price, Qty, and LineTotal labels one at 
a time into the Page Header section, setting the Width and Left properties as follows:

Property Width Left

Description 2 1.25

Price 0.75 3.5

Qty 0.3 4.5

LineTotal 0.75 5

8.	 If necessary, click the Description, Price, Qty, and LineTotal labels and use the up arrow (£) key 
to nudge them so they’re vertically aligned with the ProdID label.

Move and Resize Report Text Box Controls
9.	 Set these property values for the text boxes in the Detail section:

Text Box Control Width Top Left

ProdID 0.5 0.1 0.5

ProdDescription 2 0.1 1.25

Price 0.75 0.1 3.5

Qty 0.3 0.1 4.5

LineTotal 0.75 0.1 5

10.	 Click the Detail section bar and set the Height property to: 0.5

11.	 Click the Selection Type menu button  at the top of the Property Sheet and choose Report.
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Numbering Items in a Report  147

12.	 Set the Width property to: 6

13.	 Switch to Report View.

There is room for a small field to the left of the ProdID field, which is where you will insert numbering.

Add and Format a Text Box
14.	 Switch to Design View and choose Report Design→Controls→Text Box.

15.	 Click to the left of the ProdID text box in the Detail section to position the new box in that area.

The precise location is not important, as you will set the position, using specific properties, in a moment.

16.	 Click the new label control and tap (Delete) to remove it.

You may need to move your new text box if it is obscuring the label.

17.	 Click the new text box control and set these property values using the All tab in the Property Sheet:

Property Setting

Name txtCount

Width 0.3

Top 0.1

Left 0.1

Back Style Transparent

Border Style Transparent
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148  FastCourse Access, Chapter 8: Customizing Reports

Set Control Properties to Sum
18.	 Click the Data tab and set the Control Source property to =1 and the Running Sum property to 

Over Group.

19.	 Switch to Report View and scroll through the report.

Notice that the numbering continues sequentially throughout the report.

20.	 Close the WWDCustomerInvoicesSubreport, saving the changes.

21.	 Display the CustomerInvoices report in Design View.

22.	 Click the InvoiceDetailsSubform and set the Width property to: 6

23.	 Switch to Print Preview and use the navigation bar to review the various report pages.

Each invoice begins on a new page and the invoice detail line items begin at number 1 for each invoice.

24.	 Close Print Preview and then close the CustomerInvoices report, saving the changes.

Creating Calculated Controls on a Subreport
Reports summarize data in tables and queries to present useful, organized information. This means that 
a report would typically show subtotals, grand totals, and averages to summarize a specified group of 
data. You can do this by adding calculated controls.

Positioning Calculated Controls
Calculated controls are built-in reports using the Control Source property of an unbound text box con-
trol to which you add a formula. The section or group where a calculated control is placed determines 
how Access performs the calculation.

A calculated control in a Detail section 
performs a calculation for each detail line.

A calculated control in a Group Footer 
section calculates the total for the group.
A calculated control in a Page Footer 
section calculates the total for the page.

A calculated control in a Report Footer 
section calculates the total for the entire report.

DEVELOP YOUR SKILLS: A8-D5

In this exercise, you will add a calculated control to the report footer section in the 
WWDCustomerInvoicesSubreport.

1.	 Display the WWDCustomerInvoicesSubreport in Design View.

FastCourse Microsoft Access 2021 & 365: Level 2 © 2021 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Creating Calculated Controls on a Subreport  149

2.	 Click the Report Footer section bar and set the Height property to: 0.3

3.	 Choose Report Design→Controls→Text Box.

4.	 Click anywhere in the Report Footer section.

5.	 Switch to the All tab in the Property Sheet and set these properties for the new text box control:

Property Setting

Name CustomerTotal

Control Source =Sum([Price]*[Qty])  

Format Currency

Height 0.25

Top 0

Left 4.75

6.	 Click the new label control and set these property values:

Property Setting

Caption Invoice Total

Width 1.2

Height 0.25

Top 0

Left 3

Fore Color Text Dark

7.	 Close the subreport, saving the changes.

8.	 Display the CustomerInvoices report in Report View.
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150  FastCourse Access, Chapter 8: Customizing Reports

Growing and Shrinking a Subreport
When the number of records or amount of data displayed in a subreport varies, you can set the Can 
Grow and Can Shrink properties to allow the subreport space to expand or shrink so more data displays 
vertically. You can also change the orientation of the print layout to allow more horizontal space on 
each report page.

The subform without the Can Grow property enabled 
displays less vertical data, requiring a scroll bar.

The subform with the Can Grow property enabled 
is expanded to display more vertical data.

DEVELOP YOUR SKILLS: A8-D6

In this exercise, you will adjust the margins of the CustomerInvoices report and set the Can Grow and Can 
Shrink properties. These properties will adjust the size of the subreport to fit the contents.

1.	 Display the CustomerInvoices report in Design View.

2.	 Choose Page Setup→Page Size→Margins→Narrow.

3.	 Click the InvoiceDetailsSubreport.

4.	 If necessary, display the Property Sheet; on the Format tab, set the Can Grow property to No.

5.	 Switch to Report View and scroll through the report.

The subform now displays a vertical scroll bar in order to view additional records.

6.	 Switch to Design View and click the InvoiceDetailsSubreport.

7.	 Click the Format tab on the Property Sheet and, if necessary, set the Can Grow and Can Shrink 
properties to Yes.

8.	 Switch to Report View and scroll through the report.

The subreport grows and shrinks to best fit the contents.

9.	 Save the report.
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Setting Page Breaks and Customizing Controls  151

Setting Page Breaks and Customizing Controls
As you view the Winchester Web Design CustomerInvoices report in Report View, you may notice that the 
number of invoice records displayed on each screen varies depending on the number of items ordered. To 
ensure each customer invoice starts on a new page, you can add a page break control. By default, when you 
view a report in Print Preview, data for each customer/record automatically appears on a separate page; 
however, multiple records appear on the same page when the report is displayed in Report View.

To add a title or general company information to an invoice, place title controls in the Page Header 
rather than the Report Header, which prints only on the first page.

Tip!	 Add the page break at the end of the Detail section so Access knows to start a new 
page before printing the next page header.

Report Design→Controls→More→Insert Page Break 

DEVELOP YOUR SKILLS: A8-D7

In this exercise, you will modify the CustomerInvoices report by adding a title and the current date as well as 
setting up page breaks to print each invoice on a separate page.

1.	 Display the CustomerInvoices report in Design View.

To begin, you will modify the report title.

2.	 Click the Customer Invoice title control in the Page Header section and then click just in front 
of Customer to position the insertion point there.

3.	 Type Winchester Web Design and then press (Shift)+(Enter) to force Customer Invoice to a 
second line.

4.	 Click an empty area in the Page Header section and then click the title control once more to 
select it.

5.	 Set the Width property to 4 and the Left property to 2.

Add a Date Control
In the next few steps, you will insert a date that will display in the report header.

6.	 Choose Report Design→Header/Footer→Date and Time.

7.	 Choose the third date option MM/DD/YYYY format, remove the check from the Include Time 
box, and click OK.

Access places the new date control in the Report Header section. Next, you will move the date to the 
Page Header section so it appears on every page rather than just the first page of the report.

8.	 Select the date control and press (Ctrl)+(X) to cut it from the report header.

9.	 Click the Page Header section bar and press (Ctrl)+(V) to paste the date into the page header.
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152  FastCourse Access, Chapter 8: Customizing Reports

10.	 Set these properties for the date control:

Property Setting

Width 2

Height 0.2

Top 0.4

Left 5.8

Add a Page Break Control
11.	 Scroll to the bottom of the Detail section.

12.	 Choose Report Design→Controls→More→Insert Page Break.

13.	 Place the page break in the Detail section just above the Page Footer section bar.

14.	 Switch to Print Preview and use the navigation bar to browse the pages.

The date appears on each invoice because you added it in the Page Header section. Each invoice 
begins on a new page. Sometimes it’s not necessary to add a page break to a report and doing so may 
add an unneeded page. If this occurs in your report, remove the page break.

15.	 Close Print Preview and then close the report, saving the changes.

Adding Charts
Summarized and numerical data is often displayed visually using a chart. By adding a chart to a report, 
the information and relationships between report data is more easily interpreted. While you can add 
charts to reports and forms, they’re more commonly used in reports. Access offers multiple chart types, 
including column, bar, line, and pie, among others.

You can insert charts using the Chart control or the Insert Modern Chart command.

Report Design→Controls→Insert Modern Chart 

Formatting Modern Charts
You can format and modify common settings using either the Property Sheet or the Chart Settings task 
pane, which means formatting charts in Access is similar to formatting charts in other Microsoft Office 
applications, like Excel and PowerPoint.

	☁ View the video “Adding Modern Charts.”

Report Design→Tools→Chart Settings 

Before After

FastCourse Microsoft Access 2021 & 365: Level 2 © 2021 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Adding Charts  153

Refreshing Chart Data
Like many other Access objects, charts use the contents in a table or query as the data source. When the 
data source of a chart is changed, the chart may not automatically reflect those changes. The Refresh All 
command manually updates a chart to match record source data.

Home→Records→Refresh All 

DEVELOP YOUR SKILLS: A8-D8

In this exercise, you will modify Winchester’s EmployeeSales report by adding a chart. You will then format 
the chart and manually update it after making changes to the record source.

1.	 Display the EmployeeSales report in Design View.

2.	 Choose Report Design→Controls→Insert Modern Chart.

A menu appears allowing you to select the chart type.

3.	 Choose Column→Clustered Column.

Your mouse pointer changes to a chart icon with a plus sign.

4.	 Click in the upper-left corner of the Page Footer section to insert the chart control.

5.	 Close the Property Sheet and the Chart Settings pane, if necessary.

6.	 Hover your mouse pointer over the bottom right of the new 
chart control until a diagonal double-pointed arrow appears.

7.	 Resize the control by dragging to the bottom right until your 
chart is as tall as the Page Footer section and as wide as all text 
box controls in the Detail section.

Format the Chart
8.	 Choose Report Design→Tools→Chart Settings.

The Chart Settings pane appears.

9.	 Choose EmployeeSales from the Data Source drop-down list.

10.	 Choose EmpLastName for the Axis.
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154  FastCourse Access, Chapter 8: Customizing Reports

11.	 Choose ProdDescription as the Legend.

12.	 Choose LineTotal for the Values.

13.	 Open the Property Sheet and set these chart properties:

Property Setting

Has Legend Yes

Chart Title Total Sales

Category Axis Font Size 14

Primary Values Axis Format Currency

Tip!	 There are many chart properties and settings available. If you will use charts 
frequently, you may want to explore each of these settings.

14.	 Switch to Report View to see the newly created chart.

Refresh the Chart
15.	 Open the InvoiceDetails table and change the quantity for the first record to: 100

16.	 Switch to the EmployeeSales report and choose Home→Records→Refresh All.

The Home Page column for Winchester rises dramatically.

17.	 Switch to the InvoiceDetails table and change the quantity for the first record back to: 1

18.	 Switch to the EmployeeSales report and refresh the chart using the Refresh All command.

The chart data has normalized.

19.	 Close the EmployeeSales report, saving any changes, and then close the database.

Self-Assessment
Use the Self-Assessment quiz in the Student Resource Center to check your knowledge of the key 
concepts and skills introduced in this chapter.
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