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In this chapter, you will be introduced to 
database concepts and work with 
tables, the starting point of all 

databases. Have you ever wondered how 
sportscasters come up with fun and 
interesting facts about teams and players 
in a flash? Have you been taken by surprise 
when a customer service agent suddenly 
begins to recite your name, address, and a 
detailed purchase history? In most cases, 
these people have access to a powerful 
database from which they obtain the 
information.

L E A R N I N G  O B J E C T I V E S
■■ Identify database objects and the functions they 
perform

■■ Identify table features

■■ Create database tables

■■ Identify and choose data types

■■ Sort and filter table records

■■ Import a data source

■■ Establish a relationship between two database 
tables

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 15 mins

■■ Total: 2 hrs 15 mins

P R O J E C T:  C R E AT I N G  A  D ATA B A S E
Winchester Web Design is a small website 
development company. The company specializes in 
building websites for small businesses. You have 
been asked to build a database to help the company 
manage its employee, customer, and sales data. 
You’ll get started by creating a database and 
building tables and table relationships.

1 Getting Started with Tables
A C C E S S  2 0 1 6
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2  FastCourse Access 2016  Chapter 1: Getting Started with Tables

Introducing Databases
It is likely that you routinely interact with databases. If you make an online purchase, your order 
information goes into a database. The database might be used to track your order status, 
product likes and reviews, past orders, or future promotions. If you post or like something on 
your Facebook account, that information is maintained in a database. If you search for or store a 
telephone number, that information is likely kept in a database. It is quite possible you have 
been using databases without even knowing it! Here, you will be introduced to what a database 
is and gain a better understanding of related terms, explore a sample database, and finally, 
create your own!

While there are many definitions of a database, you can think of a database as an organized 
collection of related data files or tables. For example, a company might organize its information 
by both customers (external to the business) and employees (internal to the business). While 
the data relate to the same business, the types of data provided for customers and employees 
will likely differ. 

Databases are the epicenter of our digital world.

Types of Databases
Large organizations typically use large custom-designed databases specifically for that company 
or industry. When you make travel plans, you are using a database that is specific to the airline 
industry. It contains real-time data, meaning that if there is only one seat left on a plane, 
whoever selects and pays for the seat first gets the reservation. If you are a small business owner, 
you may use a database like Microsoft Access to track information about your customers, 
products, and employees. Access provides the tools needed to let small organizations create, use, 
and maintain databases.
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Introducing Databases  3

Open and Save an Access Database
Each time you start Access, the Backstage view displays options for opening an existing file, 
creating a new blank database, or selecting from a number of pre-built templates. If you’re 
creating a new database, Access will immediately prompt you to save the file in your desired 
storage location. You must save your file first because the database needs to constantly make 
updates to data as it is entered or edited.

DEVELOP YOUR SKILLS: A1-D1	

In this exercise, you will open an existing Access database and save it with a new name. 

Before You Begin: Be sure to visit the Learning Resource Center at labyrinthelab.com/lrc to retrieve the 
exercise files for this course before beginning this exercise.

	 1.	 �Click Start.

	 2.	 Type Ac and then choose Access 2016 from the list of suggestions.

	 3.	 �Browse through the list of templates and then choose Open Other Files near the lower-
left side of the window.

	 4.	 �Click the Browse button, navigate to your Access Chapter 1 folder, and double-click the 
A1-D1-WinWebDesign database file.

	 5.	 �Click Enable Content if the Security Warning bar displays.

	 6.	 �Choose File→Save As.

	 7.	 �Click Save As to accept Access Database as the file type.

	 8.	 �Add Revised to the end of the filename making it A1-D1-WinWebDesignRevised and 
click the Save button.

	 9.	 �Click Enable Content when the Security Warning bar displays again.

	10.	 �Keep Access open, as you will continue to use the database to explore the Access environment.

Database Objects and the Access Window
The Access window includes the Ribbon, Navigation pane, and work area. A database object is a 
structure used to either store or retrieve data. The four Access objects are tables, queries, forms, 
and reports. The database objects are displayed in the Navigation pane on the left side of the 
window. The work area is where you create or modify database objects.

DATABASE OBJECT TYPES

Access Object What It Does
Table Tables contain the database’s data, and they let you enter, edit, delete, or view records 

in a row and column layout that is similar to that used in an Excel worksheet.

Form Forms are used to view, edit, and add data one table record at a time.

Query Queries are used to search for specific table records using criteria and to sort and 
perform calculations on the results.

Report Reports are printable database objects that can display, group, and summarize data 
from tables and/or queries.

View the video “Working with Access Objects.”
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4  FastCourse Access 2016  Chapter 1: Getting Started with Tables

DEVELOP YOUR SKILLS: A1-D2	

In this exercise, you will open and view the four Access object types.

	 1.	 �Take a moment to explore the Access window noticing the various tables, queries, forms, 
and reports in the Navigation pane.

	 2.	 �Double-click the Customers table in the Objects list of the Navigation pane to open it in 
the work area within Datasheet View.

	 3.	 �Click in the first empty Cust ID cell at the bottom of the CustID column.

	 4.	 �Type AdamsA and tap [Tab] to complete the entry and move the insertion point to the next 
field.

	 5.	 �Type Adams in the Last Name field and tap [Tab].

	 6.	 �Enter Anthony as the First Name, 23 Pine St as the street address, and Bradenton as  
the city.

	 7.	 �Click the drop-down menu button  in the ST field and choose FL from the list of states.

	 8.	 �Complete the record as follows, making sure you tap [Tab] after entering the information.

■■ ZIP: 34210

■■ Telephone: (941) 555-3648

■■ Email: AAdams@email.com

■■ Notes: Call for delivery.

	 9.	 �Choose Home→Views→View menu button  and then choose Design View .

	10.	 �Click the View menu button  and choose Datasheet View .

	11.	 �Double-click Customers Form in the Forms section of the Navigation pane.

	12.	 �Locate the Record bar at the bottom of the form.

	13.	 �Click the Next Record   button to view the Anthony Adams record you just entered.

	14.	 �Click in the Notes box and add the phrase after 10:00 to the end of the note (that is, 
“Call for Delivery after 10:00”).

	15.	 �Click the Next Record   button again to complete the edit.

	16.	 �Double-click Customers Query in the Queries section of the Navigation pane.

	17.	 �Click the View menu button  on the Ribbon and choose Design View .
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Introducing Tables  5

	18.	 �Choose Design→Results→Run  to run the query and display only the Bradenton 
results.

	19.	 �Double-click Invoice Details Report in the Reports section.

	20.	 �Switch to Design View .

	21.	 �Switch to Report View , which is great for viewing reports.

	22.	 �Follow these steps to explore the object tabs and to close an object:

BA

A	�Switch between open objects using the tabs.

B	�Click the Close Object button to close the objects one at a time.

	23.	 �Choose File→Close to close the database.

Introducing Tables
A table is the starting point for entering, finding, and reporting useful information located in 
your database. A database can have separate tables, each tracking different types of data. A 
business might use a table to keep track of customer billing or employee contact information.

Table Features
Data are meaningful units of information such as names, numbers, dates, and descriptions 
organized for reference or analysis. The data stored in the Winchester Web Design Group 
database might include customer first and last names, business names, telephone numbers,  
and other important information.

A field is the smallest meaningful unit of information about one person, place, or item. 
Individually, each field represents a piece of data. Together the fields provide information. In 
most databases fields are displayed in columns.
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6  FastCourse Access 2016  Chapter 1: Getting Started with Tables

A record is a collection of related fields about a person, place, or item, such as a single customer 
or employee. A collection of related records makes up a table. In most databases records are 
displayed in rows.

First Name field and JeffriesD record in Customers table

Field Data Types
If you have ever filled out an online form, you might have seen instant formatting of some 
fields. When typing in currency values, the dollar sign and decimal point may appear 
automatically, and when entering a date, the slashes between month, day, and year 
spontaneously appear. This can be accomplished by assigning a data type to the field. A data 
type sets the characteristics of a particular field, identifying the type of values it may hold, such 
as alphanumeric text, or numbers, or dates, yes/no values, or even a hyperlink.

Primary Key Fields
Almost every database table should have a primary key field. A primary key is a unique identifier 
for each record in the table. Examples of fields that would make good primary keys are Social 
Security numbers, student IDs, or email addresses. Using a student ID as a primary key ensures 
that each student is uniquely identified in a student database table. Two students may have 
identical names, but they will never have identical student ID numbers.

ÍÍ Design→Tools→Primary Key 

Creating a Table in a New Database
Instead of using a database that someone else has prepared, you can design your own using a 
blank database template in Access. Tables are the starting point for databases and this shows up 
when a new blank database is first created. The new table has a single primary key field as a 
starting point for the database.

The starting point in a blank database
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Introducing Tables  7

DEVELOP YOUR SKILLS: A1-D3	

In this exercise, you will create a new blank database and add an Invoices table in Datasheet View.

	 1.	 �Choose File→New→Blank Desktop Database.

	 2.	 �Click Browse Folders  and save the database in your Access Chapter 1 folder as 
A1-D3-Datasheet.

	 3.	 �Click the Create button, and a new table will appear.

	 4.	 �Follow these steps to change the name of the ID field and set the data type for a second field:

A

C

B

A	�Double-click the ID field name and type InvNum as the new name. This will be the 
primary key field.

B	�Tap [Tab] to go to the second column and, if necessary, choose Click to Add to display 
the data type list.

C	�Choose Date & Time.

	 5.	 �Replace Field1 with the name InvDate and tap [Tab] to move to a new field.

	 6.	 �Choose Short Text as the data type for the third field and change the field name to EmpID.

	 7.	 �Tap [Tab], choose Short Text for the fourth field data type, and change the field name to 
CustID.

	 8.	 �Click in the empty InvDate field (you might have to click twice) and type 12/15/2016.

	 9.	 �Tap [Tab] and type JFW as the EmpID.

	10.	 �Tap [Tab] and type SmithW as the CustID.

	11.	 �Enter the data for these three additional records:
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8  FastCourse Access 2016  Chapter 1: Getting Started with Tables

	12.	 �Choose File→Save or click the Save button on the Quick Access toolbar and save the table 
with the name Invoices.

	13.	 �Close  the table, but leave the database open.

Creating Tables in Design View
You may find it easier to create a new table in Design View because it offers a straightforward 
layout and intuitive options for entering field names, setting data types, adding field 
descriptions, and setting field properties.

ÍÍ Create→Tables→Table 

Field Properties
Each field data type has numerous properties that can be set to assist with data entry, 
formatting of displayed data, and other useful functions. Properties are set while working in 
Design View.

DEVELOP YOUR SKILLS: A1-D4	

In this exercise, you will create a new table using Table Design View. Then, you will adjust the width of the 
table columns.

	 1.	 �Choose Create→Tables→Table Design .

	 2.	 �Type CustID in the Field Name box and tap [Tab].

	 3.	 �Tap [Tab] to accept Short Text as the Data Type.

	 4.	 �Type Customer Last Name and First Initial in the Description field and tap [Tab].

	 5.	 �Click in the CustID field and choose Design→Tools→Primary Key .

	 6.	 �Click in the empty box below the CustID field and complete the following fields as shown:
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Sorting Table Data  9

	 7.	 �Click anywhere in the CustLastName field, and the Field Properties for that field will 
display at the bottom of the window.

	 8.	 �Change the Field Size property to 25 and enter Last Name as the Caption property.

	 9.	 �Change the Field Size and Caption properties for the remaining fields as follows:

Field Name Field Size Caption
CustFirstName 25 First Name

CustStreetAddress 25 Street

CustCity 15 City

CustState 2 State

CustZIP 5 ZIP

CustPhone 15 Telephone

CustEmail Email

	10.	 �Choose File→Save or click the Save  button on the Quick Access toolbar and save the 
table as Customers.

	11.	 �Click anywhere in the CustPhone field and then click in the Input Mask property box.

	12.	 �Click the Input Mask  button on the right side of the property box to display the Input 
Mask Wizard.

	13.	 �Click Finish to complete the input mask and apply it to the CustPhone field.

	14.	 �Click the View menu button , choose Datasheet View , and choose Yes when asked 
if you want to save the table.

	15.	 �Enter the following records.

	16.	 �Choose File→Close to close the database.

Sorting Table Data
The primary purpose of any database is to locate and retrieve data quickly and efficiently. 
Sorting table records can help accomplish this goal.

When a table is created the records are automatically sorted using the primary key field. This 
can be changed by applying an ascending or descending sort to other table fields. You can even 
sort on more than one field so customers could be sorted by last name and then by first name.

ÍÍ Home→Sort & Filter→Ascending  or Descending 
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10  FastCourse Access 2016  Chapter 1: Getting Started with Tables

DEVELOP YOUR SKILLS: A1-D5	

In this exercise, you will sort and filter records in a database for a medical clinic named Raritan Clinic East.

	 1.	 �Open A1-D5-RCE from your Access Chapter 1 folder and save it as  
A1-D5-RCERevised.

	 2.	 �Double-click the Patients table in the Navigation pane to open it in Datasheet View.

	 3.	 �Click on any name in the Last Name column, and then click the Ascending  button.

	 4.	 �Choose File→Close to close the database.

Importing Data Sources
Organizations frequently have data in text files, Excel worksheets, and other formats that needs 
to be imported into a database. It’s easy to import data into Access using the Import & Link 
tools. Data is imported into tables that become part of the database. Excel workbooks are the 
most common source of imported data.

ÍÍ External Data→Import & Link→Excel 

DEVELOP YOUR SKILLS: A1-D6	

In this exercise, you will import an Excel worksheet into a new table.

	 1.	 �Open A1-D6-WinWebDesign from your Access Chapter 1 folder and save it as  
A1-D6-WinWebDesignRevised.

	 2.	 �Click the External Data Ribbon tab and notice the available Import & Link options.

	 3.	 �Choose Excel  and take a moment to examine the options in the first screen of the Get 
External Data Wizard.

	 4.	 �Click the Browse button and navigate to your Access Chapter 1 folder, choose  
A1-D6-WebContacts, and click Open.

	 5.	 �Click OK to start the import and display the second Wizard screen.

	 6.	 �Check the First Row Contains Column Headings box and click Next to specify the 
Excel column headings as the field names in the new table.

	 7.	 �Click in the Email column and click the Data Type menu button .

	 8.	 �Choose Hyperlink and click Next.

	 9.	 �Click Next again to let Access add a primary key field with autonumbering.

	10.	 �Name the table Web Contacts and click Finish.

	11.	 �Choose Close on the final Wizard screen without checking the Save Import Steps box.

	12.	 �Double-click the Web Contacts table to open it in Datasheet View.
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Relational Databases  11

	13.	 �Adjust the column widths to fit the widest entries in each column by either dragging the 
column head borders or autofitting the columns by double-clicking between two column 
heads.

	14.	 �Save the database and save changes to the table if prompted to do so.

Relational Databases
Early database programs stored data in one large, flat file similar to a worksheet. If a sales 
person sold merchandise and the same product was sold many times, these databases required 
the sales person to enter the same product description and price for every transaction. Such 
repetitive data entry is time consuming and bound to cause data errors and inconsistencies.

Relational databases like Access link tables together using primary key fields. A good example is 
linking a Sales Person table with a Sales Invoices table. One sales person might be linked to 
hundreds of sales invoices for which they receive commissions. Once a relationship between the 
Sales Person and Sales Invoices tables is created, all that’s needed to associate an invoice with a 
sales person is to choose the correct sales person when creating the invoice. This type of 
relationship is called a one-to-many relationship because one sales person is responsible for 
many invoices. The other types of database relationships are one-to-one and many-to-many, 
although they are not frequently used.

ÍÍ Database Tools→Relationships→Relationships 

Referential Integrity
Referential integrity is an option that can be chosen when creating a relationship between 
tables. It is a set of rules that prevents changes from being made to fields or records that are 
related to other fields or records. For example, if referential integrity were in effect, then a 
salesperson could not be removed from a database that has invoices assigned to that sales 
person. Referential integrity would require all of the invoices either be removed (not a good 
idea) or associated with a different sales person before the original sales person’s record could 
be deleted. Referential integrity also requires the data types of related fields to be the same or 
compatible.

Data Normalization
A properly designed database organizes tables and fields into their smallest usable units and 
then links them together using relationships. This is known as normalization. Normalization 
eliminates data duplication, decreases data entry errors and inconsistencies, reduces file size, 
and streamlines the search for necessary information. An example of reducing fields to their 
smallest usable units would be to use separate fields for first name and last name rather than a 
single name field. If a single name field were used, then the database could never be searched or 
sorted by just last name or first name.
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12  FastCourse Access 2016  Chapter 1: Getting Started with Tables

DEVELOP YOUR SKILLS: A1-D7	

In this exercise, you will open the Relationships window, add tables, create a one-to-many relationship 
between the Invoices table and the Employees table, and set referential integrity for the relationship.

	 1.	 �If necessary, open the A1-D6-WinWebDesignRevised database.

	 2.	 �Choose Database Tools→Relationships→Relationships .

	 3.	 �Click the Show Table  button.

	 4.	 �Add the Employees and Invoices tables to the Relationship window and close the Show  
Table box.

	 5.	 �Click the Close  button above the relationship and choose Yes to save the relationship.

	 6.	 �Choose File→Close to close the database and then close Access.
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Self-Assessment  13

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 Zara should use a form to display one record at a time on her screen.	 True    False

2.	 A primary key uniquely identifies each record in a table.	 True    False

3.	 A filter is used to arrange records in either ascending or descending order.	 True    False

4.	 Excel worksheets can be imported into an Access database as new tables.	 True    False

5.	 Referential integrity is a set of rules that prevents changes from being made to  
records that are related to other records.	 True    False

6.	 Which database object is used for storing data?

A.	Form

B.	 Query

C.	 Report

D.	Table

7.	 Which database object should be used to locate all customers who live in Springfield, Illinois, and to 
then sort the results in order by zip code?

A.	Form

B.	 Query

C.	 Report

D.	Table

8.	 Which table feature is shown within the Emp ID column?

A.	Field

B.	 Record

C.	 Relationship

D.	Primary key

9.	 Which database object is best for viewing and editing one record at a time?

A.	Table

B.	 Form

C.	 Query

D.	Report

(continued)
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14  FastCourse Access 2016  Chapter 1: Getting Started with Tables

10.	 What are short text, hyperlink, and numeric examples of?

A.	Primary keys

B.	 Records

C.	 Queries

D.	Data types

11.	 Which feature is used to alphabetize a list of customers?

A.	Filter

B.	 Form

C.	 Property Sheet

D.	Sort

12.	 An Access relationship occurs between which of the following?

A.	Tables

B.	 Forms

C.	 Queries

D.	Reports

13.	 Breaking the field Name into two smaller fields, Firstname and Lastname, is part of which process?

A.	Referential integrity

B.	 Establishing a relationship

C.	 Data normalization

D.	None of these options

14.	 Which field is the primary key in the following relationship?

A.	EmpID in the Employees table

B.	 EmpID in the Invoices table

C.	 EmpID in both tables

D.	There is no foreign key in this relationship

15.	 The names, addresses, and phone numbers for 5,000 customers are stored in a database as which of the 
following?

A.	5,000 fields

B.	 5,000 records

C.	 5,000 tables

D.	A single object
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In this chapter, you will create and use 
forms. If you have ever entered your 
personal information on a college 

application, filled out a loan application, or 
purchased an item from an online retailer, 
you have used a form. You also use forms to 
sign up for Facebook, Flickr, and Gmail 
accounts. A form ideally provides an 
attractive and easy-to-use interface, which 
allows a user to focus on one table record at 
a time.

L E A R N I N G  O B J E C T I V E S
■■ Create basic forms

■■ Create forms using the Forms Wizard

■■ Modify forms using Layout View

■■ Modify forms using Design View

■■ Set properties for form sections and form 
controls

■■ Set the tab order of a form

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 15 mins

■■ Total: 2 hrs 15 mins

P R O J E C T:  D E S I G N I N G  F O R M S  AT 
W I N C H E S T E R  W E B  D E S I G N
As the information technology (IT) director at 
Winchester Web Design, you are responsible for 
designing and formatting the forms and reports in  
the company database to make them more attractive, 
consistent, and user friendly. Part of your job is to 
customize forms so they better identify the company. 
To accomplish this, you plan to create a consistent 
color scheme and add the corporate name and logo to 
all the company’s forms.

2Working with Forms
A C C E S S  2 0 1 6
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16  FastCourse Access 2016  Chapter 2: Working with Forms

Creating Forms
A form is a database object used to enter, edit, or view the data for individual table records. 
Forms are a nice alternative to the row and column arrangement of table Datasheet View. Being 
able to view and focus on a single record can help ensure data accuracy.

Record Sources
Forms display data from a record source, which is typically a single table or query. However, if a 
relationship exists between two or more tables, fields from all related tables can be displayed on 
the same form. An example is an Invoice form that displays data from the Invoice, Products, 
Customers, and Employee tables.

A form with fields from the Invoice, Products, Customers, and Employee tables

Creating and Using Basic Forms
Use the Form button to instantly create a basic form for a selected table or query. This is the 
easiest way to create a form using all fields from the table or query. Only one table or query can 
be used in a basic form.

ÍÍ Create→Forms→Form 
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Creating Forms  17

DEVELOP YOUR SKILLS: A2-D1	

In this exercise, you will create a basic form and edit a record using the form.

	 1.	 �Open A2-D1-WinWebDesign from your Access Chapter 2 folder and save it as  
A2-D1-WinWebDesignRevised.

	 2.	 �Choose the Employee Spouses table in the Navigation pane by clicking the table name 
(don’t double-click).

	 3.	 �Choose Create→Forms→Form .

	 4.	 �Close any boxes that may be open, such as the Property Sheet or Field List box.

	 5.	 �Click the View menu button  and choose Form View .

	 6.	 �Use the navigation controls at the bottom of the form to browse the records from the 
underlying table.

	 7.	 �Navigate to record 2 (the Tom Franklin record) and change the last four digits of the phone 
number to 6767.

	 8.	 �Choose File→Save or click the Save  button on the Quick Access toolbar and save the 
form as Employee Spouses.

	 9.	 �Click the Close  button on the right side of the form.

Creating Forms with the Form Wizard
The Form Wizard is a great way to get started with the creation of most forms. It lets you choose 
the fields you want from one or more tables or queries (the data source) and then builds a form 
from the chosen fields. The form can then easily be modified using Layout View or Design View.

ÍÍ Create→Forms→Form Wizard 

DEVELOP YOUR SKILLS: A2-D2	

In this exercise, you will use the Form Wizard to create a form.

	 1.	 �If necessary, open the A2-D1-WinWebDesignRevised database.

	 2.	 �Choose the Customers table in the Navigation pane.

	 3.	 �Choose Create→Forms→Form Wizard .

	 4.	 �Click the Add All Fields  button and click Next.

	 5.	 �Click Next again to accept the Columnar layout format.

	 6.	 �Leave the form name as Customers and click Finish.
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18  FastCourse Access 2016  Chapter 2: Working with Forms

Changing Forms in Layout View
A typical form has a header section where tiles, logos, and decorative elements are displayed 
and a detail section with text boxes and labels where data is displayed. These objects can easily 
be sized, moved, edited, and removed in Layout View. Multiple objects can be changed together 
by holding the [Ctrl] key while selecting them with single mouse clicks.

View the video “Reorganizing Forms in Layout View.”

ÍÍ Home→Views→Layout View 

DEVELOP YOUR SKILLS: A2-D3	

In this exercise, you will size, position, and edit controls, and you’ll get extensive practice selecting multiple 
controls.

	 1.	 �If necessary, open the A2-D1-WinWebDesignRevised database and open the 
Customers form.

	 2.	 �Click the View menu button  and choose Layout View .

	 3.	 �Click on the Street Address label to select it.

	 4.	 �Click inside the selected label just to the right of Address.

	 5.	 �Use the [Backspace] key and any other keys as necessary to remove the word Address.

	 6.	 �Change the ST label to State.

	 7.	 �Change the ZIP label to Zip.

	 8.	 �Click on the large, empty Notes text box (not the label) to select it.

	 9.	 �Hover the mouse pointer over the right edge until the adjust pointer appears.

	10.	 �Drag left, reducing the box width to equal the Email text box width.

	11.	 �Reduce the width of the State text box so it is slightly wider than the two-character state 
abbreviation.

	12.	 �Click the large Notes text box.

	13.	 �Press and hold [Crtl] and click the Email text box.
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Changing Forms in Layout View  19

	14.	 �Press and hold [Ctrl] while you select all other text boxes in the column.

	15.	 �Tap the left arrow [¢] key repeatedly to move the text boxes closer to the labels.

	16.	 �Click an empty part of the form to deselect all boxes.

	17.	 �Use the mouse and [Ctrl] key to select the Telephone, Email, and Notes labels and text 
boxes.

	18.	 �Use the keyboard or drag with your mouse (when the four-headed arrow appears) to move 
the labels and text boxes up and right as shown here.

	19.	 �Make any additional adjustments to the controls you deem necessary.

	20.	 �Choose File→Save or click the Save  button on the Quick Access toolbar to save the 
changes to the form.
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20  FastCourse Access 2016  Chapter 2: Working with Forms

Changing Forms in Design View
Form Layout View is a great tool for editing, sizing, and rearranging labels and text boxes, but 
there are many form design details that can be more precisely set using Design View. In Design 
View you can precisely control any part of a form and its controls. The Property Sheet is used in 
both Layout View and Design View to specify the details for any form object.

ÍÍ Design→Views→Design View 

ÍÍ Design→Tools→Property Sheet 

Modify the Form Header Section
The Form Header and Footer appear at the top and bottom of the form. The Form Header 
typically has one or more titles and often a logo and decorative features. Form Footers are rarely 
used. The Form Header can be modified in either Layout View or Design View.

DEVELOP YOUR SKILLS: A2-D4	

In this exercise, you will format the Form Header and field labels and insert a logo to make the form look 
more professional.

	 1.	 �If necessary, open the A2-D1-WinWebDesignRevised database and open the  
Customers form.

	 2.	 �Choose Design→Views→Design View .

	 3.	 �Click inside the Customers title box in the Form Header and change the title to 
Winchester Customers.

	 4.	 �Choose Design→Tools→Property Sheet .

	 5.	 �Click in the Width box in the Property Sheet and set the Width to 5.5.

	 6.	 �Click in the Left box and set the Left position to 1.5.

	 7.	 �Set the Font Size to 30 and the Font Name to Lucida Calligraphy.

	 8.	 �Choose Home→Text Formatting→Font Color  menu button  and choose a blue 
color of your choice.
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Changing Forms in Design View  21

	 9.	 �Click the Cust ID label (not the text box) in the Detail section and notice the name CustID_
Label appears at the top of the Property Sheet.

	10.	 �Press and hold the [Ctrl] key and click all labels in the Detail section to select them all.

	11.	 �Apply the same blue font color that you just applied to the title.

	12.	 �Choose Design→Header/Footer→Logo .

	13.	 �Navigate to your Access Chapter 2 folder, choose WWD-Logo.bmp, and click OK.

	14.	 �Set both the Width and Height properties to 0.8.

	15.	 �Switch to Form View  to see the changes.

	16.	 �Switch to Design View .

	17.	 �Click the Form Header section bar and view the Property Sheet.

	18.	 �Click the Detail section bar and examine its properties.

	19.	 �Click the Selection Type menu button  in the Property Sheet, scroll through the list, 
and choose Form.

Tab Order
The most effective way to enter a record using a form is to tap the [Tab] key to move from one 
field to the next. Forms have a tab order that determines which field the insertion point moves 
to each time the [Tab] key is tapped. The tab order can be changed to allow fields to be entered in 
a different sequence. This may be necessary if fields are rearranged on a form and when fields 
from more than one table appear on the same form.

ÍÍ Design→Tools→Tab Order 

DEVELOP YOUR SKILLS: A2-D5	

In this exercise, you will change the form tab order to make the telephone number the second field in the 
tab order.

	 1.	 �Switch to Form View .

	 2.	 �Use the [Tab] key to cycle through the fields.

	 3.	 �Switch to Design View .

	 4.	 �Choose Design→Tools→Tab Order .
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22  FastCourse Access 2016  Chapter 2: Working with Forms

	 5.	 �Follow these steps to adjust the tab order:

A

B

C

A	Choose Detail to see the current tab order for fields in the Detail section.

B	Click the small selection box next to the CustPhone field.

C	Drag the CustPhone selection box up and drop it above the CustLastName field. 
CustPhone should now be second in the tab order.

	 6.	 �Click OK to complete the tab order change.

	 7.	 �Switch to Form View  and tap [Tab] repeatedly to cycle through the fields.

Themes
Themes are prepackaged groups of design elements such as background colors, font families, 
font sizes, and other properties. When themes are applied, they impact all objects in the 
database (tables, forms, queries, and reports). The Themes group on the Ribbon lets you change 
just the colors or fonts, or the overall design including both the colors and fonts.

ÍÍ Design→Themes→Themes 

DEVELOP YOUR SKILLS: A2-D6

In this exercise, you will apply a theme to your form.

	 1.	 �Switch to Design View and choose Design→Themes→Themes .

	 2.	 �Hover over each theme’s thumbnail and notice how the form changes.

	 3.	 �Choose your favorite theme and then switch to Form View to see how your finished form 
looks with the new theme.
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Creating Other Types of Forms  23

	 4.	 �If desired, switch back to Design View and choose a different theme or switch to Layout 
View to change the position and size of controls on your form.

	 5.	 �Close your form, saving the changes, if prompted to do so.

Creating Other Types of Forms
A typical large organization will have a need for many types of forms. Different departments within 
an organization may need to access the same database tables but may need to view different fields 
from within those tables. A good example would be the difference between what a customer service 
representative and a sales person might need. They will both have a need to access customer 
information, but the sales person will also want to see sales history, sales opportunities, and other 
information that a customer service representative won’t need. Large organizations typically have 
an extensive collection of forms designed to make their staff highly efficient.

Creating Multiple Item Forms
Most forms are designed to let the user focus on one record at a time. Sometimes, however, it is 
necessary to print multiple items in a table using a layout that is more appropriate for printing 
and distributing than a table datasheet. The multiple item form is used for those occasions.

Multiple item forms resemble datasheets because data appears in rows and columns. However, 
multiple item forms can be customized to enhance the appearance of the form using colors, 
graphics, and other design elements.

ÍÍ Create→Forms→More Forms→Multiple Items 

DEVELOP YOUR SKILLS: A2-D7

In this exercise, you will create a multiple item form.

	 1.	 �If necessary, open the A2-D1-WinWebDesignRevised database.

	 2.	 �Choose the Customers table in the Navigation pane.

	 3.	 �Choose Create→Forms→More Forms→Multiple Items .

	 4.	 �Choose Design→Themes→Themes  and choose a theme that has text sizes and 
formatting you like.

	 5.	 �If necessary, click on any of the customer IDs in the CustID column to select all cells in that 
column.

	 6.	 �Drag the right border of the selected cells to the left, reducing the column width.

	 7.	 �Reduce all column widths to see if you can get the form to fit on your screen.

AC16_Level1FC.indb   23 2/1/2017   1:06:31 PM

FastCourse Microsofot Access 2016   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



24  FastCourse Access 2016  Chapter 2: Working with Forms

	 8.	 �Click the Forms icon in the form header next to the Customers title and tap [Delete] to  
remove it.

	 9.	 �Close the form and save it as CustomersMultiItem.

Creating Split Forms
A split form simultaneously shows a table in Datasheet View and a form displaying a single 
record from the table. The views are synchronized so that a selected record in one view is also 
selected in the other view.

ÍÍ Create→Forms→More Forms→Split Form 

DEVELOP YOUR SKILLS: A2-D8	

In this exercise, you will create a split form.

	 1.	 �Choose the Customers table in the Navigation pane.

	 2.	 �Choose Create→Forms→More Forms→Split Form .

	 3.	 �The form is displayed in Layout View, so adjust the field widths in the form and the 
datasheet as needed.

	 4.	 �Remove the Forms icon that is next to the Customers heading.

	 5.	 �Choose File→Close to close the database and save the form as CustomersSplitForm.
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Self-Assessment  25

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 Layout View can be used to change the position and size of objects on a database form.	 True    False

2.	 Forms can display data from either tables or queries.	 True    False

3.	 Text boxes are typically positioned in the Form Header.	 True    False

4.	 Only one table or query can be chosen in the Form Wizard.	 True    False

5.	 Themes impact all objects in a database.	 True    False

6.	 The Form  tool can be used to build a form with more than one table or query.	 True    False

7.	 The Form Wizard  can be used to build a form with more than one table or query.	 True    False

8.	 The Property Sheet can be used to adjust the size of individual form controls.	 True    False

9.	 Forms have a tab order that determines which field the insertion point moves to  
each time the [Tab] key is tapped.	 True    False

10.	 Only Design View can be used to rearrange controls on a form.	 True    False

11.	 In which section of a form are a title and logo typically displayed?

A.	Form Header

B.	 Detail

C.	 Form Footer

12.	 Which form view allows you to set precise controls for any part of a form?

A.	Layout

B.	 Design

C.	 Form

13.	 Which type of form lets you view a single record in a typical form layout while simultaneously viewing 
the datasheet?

A.	Basic

B.	 Multiple item

C.	 Split

D.	None of these options

14.	 Which keystroke can be used to select multiple fields in Form Layout and Design Views?

A.	 [Enter]

B.	 [F10]

C.	 [Alt]

D.	 [Ctrl]

15.	 Which type of form resembles a datasheet?

A.	Basic

B.	 Multiple item

C.	 Split

D.	None of these options
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One of the main goals of a database 
is to organize data so that 
information can be located and 

retrieved quickly. People in all types of 
businesses retrieve stored data and 
information daily, often at a moment’s 
notice. In this chapter, you will search 
information that is stored in tables in a 
relational database and extract records that 
meet specific criteria using a query, a 
database object used to locate records 
based on the conditions you set.

L E A R N I N G  O B J E C T I V E S
■■ Create, save, and run select queries

■■ Create select queries using multiple tables

■■ Use simple query criteria

■■ Use AND and OR criteria in queries

■■ Use wildcard characters in query criteria

■■ Sort query results

■■ Create and format a calculated field

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs 45 mins

■■ Self-Assessment: 15 mins

■■ Total: 3 hrs

P R O J E C T:  U S I N G  Q U E R I E S  T O  G E T 
A N S W E R S
You have been asked to query the Winchester Web 
Design database and compile two separate customer 
lists. The lists will be used to notify all past clients of 
updates to their website contact forms. The first list 
will include only the first and last name of the 
clients and their email address. The second list will 
include the first and last name of the clients and 
their mailing addresses, sorted by ZIP code. 
Additionally, you have been asked to build queries 
that instantly calculate the total income from all the 
Winchester Web Design services, and from specific 
areas such as blogs or shopping carts.

3Querying a Database
A C C E S S  2 0 1 6
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28  FastCourse Access 2016  Chapter 3: Querying a Database

Select Queries
A select query allows you to select records from one or more database tables based on criteria 
that you set. A select query asks a question, such as, What are the customer addresses? or How much 
money did the company make last month? The answer to the question is a set of records. A select 
query is basically a database inquiry that selects only the records you want to see or edit. The 
easiest way to create a query is with the Query Wizard.

Query Features
■■ A query functions like a saved question you ask a database.

■■ A query produces a subset of data from one or more tables.

■■ When you edit data in query results, you are actually editing the data stored in the source 
tables.

■■ Queries are dynamic objects that display up-to-date data from tables.

■■ Queries can be used to create forms and reports with fields drawn from multiple tables.

ÍÍ Create→Queries→Query Wizard 

DEVELOP YOUR SKILLS: A3-D1	

In this exercise, you will use the Query Wizard to create a select query that generates a customer email list.

	 1.	 �Open A3-D1-WinWebDesign from your Access Chapter 3 folder and save it as  
A3-D1-WinWebDesignRevised.

	 2.	 �Choose Create→Queries→Query Wizard .

	 3.	 �Click OK to accept the Simple Query Wizard.
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Select Queries  29

	 4.	 �Follow these steps to build the query:

A

B
C

E

D

A	Make sure the Customers table is chosen in the Tables/Queries list. When building a 
query, you can use multiple tables and even existing queries.

B	Choose the CustLastName field from the Available Fields list.

C	Click the Add  button to add it to the Selected Fields list.

D	Now add the CustFirstName and CustEmail fields.

E	Click Next.

	 5.	 �Type Customers Email List as the query title.

	 6.	 �Make sure the Open the Query to View Information option is chosen and click the 
Finish button.

	 7.	 �Click the Close  button to the right of the Customers Email List tab to close the query.
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30  FastCourse Access 2016  Chapter 3: Querying a Database

Creating a Select Query Using Query Design View
Some queries display just a few fields but report on every single record in the table. That may not 
be a problem for a small table, but when thousands of records and multiple tables are involved, 
it is often necessary to choose only specific records by setting precise criteria. Using Query 
Design View, Access allows you to:

■■ Select fields from multiple tables

■■ Locate records using criteria from one or more fields

■■ Perform calculations

■■ Sort query results and show or hide fields in query results

View the video “Create a Multi-Table Select Query.”

ÍÍ Create→Queries→Query Design 

DEVELOP YOUR SKILLS: A3-D2	

You have already created an email list for the Winchester Web Design customers and now need one for the 
company’s employees. In this exercise, you will create a query to select fields from the Employees table in 
the Winchester Web Design database and then rearrange the columns in the query grid.

	 1.	 �Choose Create→Queries→Query Design  to display the query design grid.

	 2.	 �Choose the Employees table and click the Add button.

	 3.	 �Close the Show Table box and close the Property Sheet box if it is open.

	 4.	 �Double-click the EmpFirstName field in the Employees table to add it to the grid.

	 5.	 �Now add the EmpLastName, EmpPhone, and EmpEmail fields to the grid by either 
double-clicking or dragging them.

	 6.	 �Choose File→Save or click the Save button on the Quick Access toolbar.

	 7.	 �Type Employee Contact Info as the query name and click OK.

	 8.	 �Click the Run  button.

	 9.	 �Choose Home→Views→Design View  to switch to Design View.
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Select Queries  31

	10.	 �Follow these steps to rearrange the EmpFirstName and EmpLastName fields:

ABC

A	Click the EmpLastName column heading to select the column. The mouse pointer will 
change to a white arrow, indicating you can now move the column.

B	Drag the EmpLastName column to the left of the EmpFirstName column until the 
thick vertical bar is positioned as shown here.

C	Release the mouse button to complete the rearrangement.

	11.	 �Run  the query.

	12.	 �Close the query and save the changes.

Designing a Query Using Multiple Tables
Until now, the datasheets you have worked with have displayed data from only one table. There 
will be times when you need to view data contained in different tables within the same 
database. Queries allow you to do this.

Choosing Fields to Include in a Query
When you build a query, you select only those tables and fields that you want to display in the query 
results datasheet and leave out those fields that have no impact on the data you want to view or 
that are confidential. By specifying only certain tables and fields in a database and displaying only 
the desired fields in a query, you can create a report or a form that only presents pertinent data.

Selecting a Field That Appears in Multiple Tables
Multiple tables are only effective in a query if the tables are related. Sometimes the same ID field 
occurs as a primary key in one table and as a foreign (or secondary) key in another table. If this 
occurs, always use the table with the primary key in your query.

Use the Customers table in the query 
because CustID is the primary key.

CustID is a foreign key 
in the Invoices table.
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32  FastCourse Access 2016  Chapter 3: Querying a Database

DEVELOP YOUR SKILLS: A3-D3	

In this exercise, you will create a multitable query to track the Winchester Web Design invoices by invoice 
number using Query Design view.

	 1.	 �Choose Create→Queries→Query Design  to display the query design grid.

	 2.	 �Double-click the Invoices, Invoice Details, and Products tables to add them to the query.

	 3.	 �Close the Show Table box.

	 4.	 �Double-click the InvNum, InvDate, and EmpID fields in the Invoices table to add those 
fields to the query grid.

	 5.	 �Add the ProdDescription and Price fields from the Products table.

	 6.	 �Add the Qty field from the Invoice Details table.

	 7.	 �Click the Sort box for the InvNum field, click the menu button , and choose Ascending.

	 8.	 �Save the database and save the query as InvoicesList and click OK.

	 9.	 �Choose Design→Results→Run  to run the query.

Using Criteria in Queries
Queries let you specify criteria, which are conditions that field values must meet. Only records 
meeting the criteria are returned when the query is run.

In this query, the EmpID criteria is set to JFW.
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Using Criteria in Queries  33

Only records where EmpID is JFW are returned.

Criteria are commonly used with text, numeric, currency, and date fields. The following table 
provides a few examples of how criteria are used.

TYPES OF CRITERIA

Field Type Criteria Examples of How Records Are Returned
Text Smith Last name is Smith

> =Smith
Last names are from Smith through the end of the 
alphabet

Not Smith Last name is not Smith

Numeric & Currency > 123 Numeric value is greater than 123

> =123 Numeric value is greater than or equal to 123

Date Date( ) Date is today’s date

< Date( ) – 30 The Date field is 30 days or more prior to today’s date

View the video “Create a Query with Criteria.”

DEVELOP YOUR SKILLS: A3-D4	

In this exercise, you will add criteria to the query grid and run the query.

	 1.	 �If necessary, open the InvoicesList query and switch to Design View .

	 2.	 �Click the Criteria box for the EmpID field, type JFW, and tap [Enter]. Access will apply 
quotation marks indicating this is a literal value.

	 3.	 �Choose Design→Results→Run  to run the query.

	 4.	 �Close the query and choose No when prompted to save the changes.

Wildcard Characters
Wildcard characters are used to locate records that have similar but not identical data. They help 
you locate records that match a pattern. For example, you might want to find all customers with 
last names that begin with the letter B or all products that begin with the word Blog.
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34  FastCourse Access 2016  Chapter 3: Querying a Database

WILDCARD CHARACTERS

Common Wildcard Symbols How They Are Used
Asterisk (*) Substitutes for a group of characters that appear at the position of 

the asterisk
Example: R* in the last name field will locate all last names 
beginning with R regardless of how many characters make up the 
name. In this case, Rogers, Rich, and Rodriquez would all appear in 
the results datasheet.

Question mark (?) Substitutes for a single character that might appear at the position of 
the question mark
Example: m?s will locate records containing values such as mrs, 
ms, and mbs.

Open/close brackets [ ] Matches text or individual characters placed within the brackets 
individually
Example: ca[rt] will find cat and car but not cab or cad.

AND and OR Criteria
In some cases, you may need to locate records that meet multiple criteria. This can be done 
using AND and OR conditions. For example, you may want to locate all records where the 
employee is web certified AND lives in Sarasota. Or you may want to locate all employees who 
live in Sarasota OR Bradenton.

Create an OR condition by adding a second criterion to the Or row of a field.

Create an AND condition by adding another criterion to a different field on the Criteria row.

DEVELOP YOUR SKILLS: A3-D5	

In this exercise, you will use wildcards to locate variable data and set multiple criteria in a query to find 
out which customers have gotten blogs and which customers have added more than ten images at a time to 
their websites.

	 1.	 �Open the Invoices Query query in Design View.

AC16_Level1FC.indb   34 2/1/2017   1:06:33 PM

FastCourse Microsofot Access 2016   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Using Criteria in Queries  35

	 2.	 �Follow these steps to use wildcard characters and to use AND and OR criteria:

B
A

C

A	Click in the ProdDescription Criteria box, type Blog*, and tap [Enter].

B	Click in the ProdDescription Or box, type Image*, and tap [Enter].

C	Click in the Qty Or box and type > 10. Be sure to type in the same row as Like “Image*” 
(the Or row).

	 3.	 �Run  the query.

	 4.	 �Close the query and save the changes.

Date Criteria
You can set date criteria to determine age, hired date, invoice date, and so forth. Access 
acknowledges the same comparison criteria for performing date comparisons that it does for 
locating other types of data, regardless of the format used to enter dates.

DATE CRITERIA

Criterion Examples of How Records Are Returned
06/22/2013 Date is 06/22/2013

<22-Oct-2013 Dates that occur before 22/Oct/2013

>01/01/13 Dates that occur after 01/01/13

Between 01/01/13 and 06/30/13 Dates between 01/01/2013 and 06/30/2013

DEVELOP YOUR SKILLS: A3-D6	

Winchester Web Design needs to track all invoices issued in 2012. In this exercise, you will query the 
database to locate customers with invoices dated from January 1, 2012, through December 31, 2012.

	 1.	 �Choose Create→Queries→Query Design .

	 2.	 �Use double clicks to add the Customers, Invoices, Invoice Details, and Products tables 
to the query.

	 3.	 �Close the Show Table box.

	 4.	 �Double-click InvNum and InvDate in the Invoices table to add those fields to the  
query grid.

	 5.	 �Add the CustID field from the Customers table.

	 6.	 �Add the Qty field from the Invoice Details table.

	 7.	 �Add the ProdDescription and Price fields from the Products table.
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36  FastCourse Access 2016  Chapter 3: Querying a Database

	 8.	 �Widen the InvDate field by dragging the column heading to the right as shown here.

	 9.	 �Click in the Criteria box for the InvDate field, type Between January 1, 2012 and 
December 31, 2012, and then tap [Enter].

	10.	 �Run  the query.

	11.	 �Choose File→Save or click the Save button on the Quick Access toolbar.

	12.	 �Save the query as Invoices2012 and then close it.

Sorting and Showing Results
The query grid contains a Sort row that lets you sort the query results. At times you may also 
want to use fields to specify criteria but may not want those fields to be displayed in the query 
results. This can be accomplished by unchecking the Show box for the desired field(s).

DEVELOP YOUR SKILLS: A3-D7	

In this exercise, you will create a query that sets a sort order and you will hide a field from displaying in the 
query results. 

	 1.	 �Choose Create→Queries→Query Design .

	 2.	 �Use double clicks to add the Customers, Invoices, Invoice Details, and Products tables 
to the query.

	 3.	 �Close the Show Table box.

	 4.	 �Double-click the CustID, CustFirstName, and CustLastName fields in the Customers 
table to add them to the design grid.

	 5.	 �Add the InvDate field from the Invoices table.

	 6.	 �Add the ProdDescription field from the Products table.

	 7.	 �Add the Qty field from the Invoice Details table.
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Calculated Fields  37

	 8.	 �Follow these steps to set a criterion and set the sort order:

B

A

A	Click in the ProdDescription criteria box, type Image*, and tap [Enter]. Access 
converts Image* to Like “Image*”. This criterion will choose only records where the 
product description begins with Image.

B	Click in the Sort box for the Qty field and choose Descending from the list of sort options.

	 9.	 �Run  the query.

	10.	 �Choose Home→Views→Design View  to switch back to Design View.

	11.	 �Uncheck the Show box for the CustID field and Run  the query.

	12.	 �Save the query as Images and then close it.

Calculated Fields
Calculated fields are formulas that perform calculations on other query fields. Calculated fields 
are added to queries and are not part of the underlying query tables. They are added to the query 
design grid and their calculated results then appear in the query results. A calculated field:

■■ Creates a new field in a query that can also be used in a form or report

■■ Can be used to perform mathematical operations such as addition and multiplication

■■ Has a name and can be formatted with properties just like a regular field

■■ Enables you to combine values in two text fields into one field such as LastName and FirstInitial

■■ Updates and recalculates each time you run the query

Identifying Parts of a Calculated Field
The structure of a calculated field includes a field name and a mathematical expression. Two 
examples of calculated fields in an Access query would be Wage: Hours * Rate and Total: Price * 
Quantity, where Wage and Price are calculated field names and Hours * Rate and Price * 
Quantity are the calculations that are performed.

The LineTotal calculated field multiplies Price * Qty	 The query results
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38  FastCourse Access 2016  Chapter 3: Querying a Database

Each calculated field can contain the following elements.

CALCULATED FIELD ELEMENTS

Element Description
Calculated field name This is the unique name you assign to the field and is followed by a colon (:) 

to separate the field name from the expression.

Field names from existing 
tables

Field names from the query can be added to the calculated field expression. 
Access adds brackets [ ] around field names.

Arithmetic or comparison 
operators

Use +, -, *, /, ( ), ^, <, =, > to perform mathematical operations or compare 
values.

Concatenation (i.e., linking 
together)

An ampersand (&) can be used to join text values from multiple fields. For 
example, FirstName&LastName.
Spaces can be added between fields by using quotation marks around a single 
space (“ ”). For example, the quotation marks in FirstName& “ “ &LastName 
create a space between the first and last names in the query results.

Calculated Field Properties
You can set field properties such as size, number format, and default values within tables. 
Likewise, you can set field properties in calculated fields. This is almost always needed in 
calculated fields as the query results need to be formatted with the correct number of decimal 
places, commas, currency format, and other formatting as needed. Field properties are set using 
the field Property Sheet.

ÍÍ Design→Show/Hide→Property Sheet 

DEVELOP YOUR SKILLS: A3-D8

In this exercise, you will create and format a calculated field.

	 1.	 �Open the InvoicesList query and switch to Design View.

	 2.	 �Click in the first cell of the blank column next to the Qty field.

	 3.	 �Type the calculated field expression LineTotal:Price * Qty, making sure you include 
the colon between LineTotal and Price.

	 4.	 �Tap [Enter].

	 5.	 �Right-click anywhere in your calculated field column and choose Properties.

	 6.	 �Set the Format property to Currency and type Line Total in the Caption field.
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Calculated Fields  39

	 7.	 �Run  the query, and your calculated field results will appear as shown below.

	 8.	 �Save and close the query and then close the A3-D1-WinWebDesignRevised database.
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40  FastCourse Access 2016  Chapter 3: Querying a Database

(continued)

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 A query can use fields from more than one table.	 True    False

2.	 It is important for two tables to be related if a query uses fields from both of them.	 True    False

3.	 Entering a specific date criterion such as 06/22/2016 in a date field will only return  
records where the date is an exact match.	 True    False

4.	 The Property Sheet can be used to set properties for calculated fields.	 True    False

5.	 When data in query results is edited, the data is changed in the query  
fields, not in the underlying tables.	 True    False

6.	 Calculated fields must first be created in the underlying tables before they  
can be added to a query.	 True    False

7.	 Which field types can criteria be used with?

A.	Text

B.	 Numeric

C.	 Date

D.	All of these options

8.	 What records will the following query return?

A.	All records

B.	 Only records with a last name of Smith

C.	 Only records where the last name begins with Smith

D.	All records except for those with a last name of Smith

AC16_Level1FC.indb   40 2/1/2017   1:06:34 PM

FastCourse Microsofot Access 2016   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Self-Assessment  41

9.	 What records will the following query return?

A.	All records

B.	 Only records with customers in Sarasota

C.	 Only records with customers in both Sarasota and Bradenton

D.	Only records with customers in either Sarasota or Bradenton

10.	 Which symbol is used to separate the field name from the expression in a calculated field?

A.	[ ]

B.	 *

C.	 :

D.	→

11.	 Which of the following would work properly as a calculated field assuming the query has fields named 
Price and Quantity?

A.	Total=Price*Quantity

B.	 Price*Quantity=Totals

C.	 Total:Price*Quantity

D.	[Total]=[Price]*[Quantity]

12.	 Which criteria could be used to choose only records containing the letters HR somewhere within the 
data?

A.	HR

B.	 [HR]

C.	 *HR*

D.	HR or RH

(continued)
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42  FastCourse Access 2016  Chapter 3: Querying a Database

13.	 Which query will return the following results?

A.	

B.	

C.	

D.	

(continued)
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14.	 Which query will return records in which the invoice date occurs after January 1, 2014, the employee ID 
is JB, and all fields are shown in the query result?

A.	

B.	

C.	

D.	

15.	 Which of the following best describes the records returned by a query that has the criterion Date( ) in a 
date field:

A.	Only records with today’s date

B.	 Only records without dates

C.	 Any record with a date

D.	Criteria can’t include dates
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In this chapter, you will create reports to 
organize and summarize data into 
meaningful information. Although 

reports can summarize data from a single 
database table, they often present specific 
data from multiple tables or from queries 
based on multiple tables. Both forms and 
reports use many of the same tools and 
techniques to organize and present 
information in a readable format.

L E A R N I N G  O B J E C T I V E S
■■ Create basic reports using the Report tool

■■ Create reports with the Report Wizard

■■ Change field alignment and size in Layout View

■■ Change field properties

■■ Insert logos and dates

■■ Insert new fields

■■ Apply themes

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 15 mins

■■ Total: 2 hrs 15 mins

P R O J E C T:  T U R N I N G  D ATA  I N T O 
I N F O R M AT I O N  W I T H  R E P O R T S
Forms are great for entering data and displaying 
single records. Most businesses, however, want to 
filter and summarize data, as well as display specific 
data, such as running totals, in a readable format. 
Winchester Web Design needs a new report to 
summarize the sales for each employee and display 
sales totals. As its database manager, you have 
agreed to create a report to meet these needs.

4Using Reports to Display 
Information

A C C E S S  2 0 1 6
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46  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

Introducing Reports
Because reports are often presented in a readable format and end up as a printout, there are 
some basics that every report should include. Of course it should be well organized, look 
professional, and be visually appealing. Imagine finding a report on your desk without a date, 
without page numbers, or without a title that states what it is for. How might this affect the 
usability and readability of the data?

Most reports should have both a title and a subtitle. The title may simply be the company name. 
The subtitle should state specifically what the report is for, such as Monthly Income or Product 
List. Every report requires a date and should include the page number, even if the report is only 
one page. Once you have a good handle on the who, what, and when, you will be ready to create 
your first report.

Basic Reports
Use the Report button to instantly create a basic report for a selected table or query. This is the 
easiest way to create a report using all of the fields from the table or query. Only one table or 
query can be used in a basic report.

ÍÍ Create→Reports→Report 

DEVELOP YOUR SKILLS: A4-D1

In this exercise, you will create a basic report.

	 1.	 �Open A4-D1-WinWebDesign from your Access Chapter 4 folder and save it as 
 A4-D1-WinWebDesignRevised.

	 2.	 �Choose the Products table in the Navigation pane.

	 3.	 �Choose Create→Reports→Report .

	 4.	 �Close any boxes that may be open, such as the Property Sheet or field list pane.

	 5.	 �Choose Home→View→Report View .

	 6.	 �Choose Home→View→Print Preview  to see how your report will look when printed.

	 7.	 �Click the Close Print Preview button on the right side of the Ribbon.

	 8.	 �Switch to Design View .

	 9.	 �Take a moment to mouse over the design tools and review the ToolTips that appear.

	10.	 �Choose File→Save or click the Save button on the Quick Access toolbar and save the 
report as Products.

	11.	 �Close the report.
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Report Organization and Structure  47

Report Organization and Structure
Reports can display data from multiple tables and even from queries. Report data must often be 
grouped and sorted so it can be easily analyzed and interpreted. Effective reports turn data into 
information by displaying it in an organized and understandable manner. Queries are often the 
best data source for reports as they can receive data from multiple tables, sort the data, and even 
include calculated fields.

Sections
Sections provide the structure needed to effectively organize and present information. There are 
several types of sections, with each type used for a specific purpose.

REPORT SECTIONS

Section(s) Description
Report Header and Footer Displayed only at the top of the first page and bottom of the last 

page. Some uses include titles, subtitles, and logos.

Page Header and Footer Displayed at the top and bottom of every page. Some uses include 
descriptive labels, page numbers, and dates.

Group Header and Footer The group header shows the fields on which report data is grouped. 
For example, grouping by Sales Person might list each sales 
person and all the transactions that person is responsible for. The 
group footer displays summary information such as the total of all 
transactions for each sales person.

Detail Main part of the report where the records are displayed. The records 
are typically organized in groups. The detail sections are where field 
headings appear.

The following image shows a report in Layout View with the various sections highlighted.

The Report Header appears at the top of the report.
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48  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

The Group Footer for Employee ID MJW 
adds the group totals for invoices 29 and 30.

The Group Headers show the records 
grouped first by Employee ID and 
then by Invoice Number.

The Detail sections show headings, 
records, and a LineTotal calculated 
field from the underlying query.

The Page Footer is often used 
for page numbers and dates.

The Grand Total appears in the 
Report Footer and adds all group 
totals (some not shown here).

The Group Footers show totals 
for Invoice Numbers 29 and 30.

Grouping and Sorting
A group is a collection of records that has at least one data element or key field in common. In 
the preceding example, records are grouped first by Employee ID MJW then by Invoice 
Numbers 29 and 30. A group consists of a header, records, and a footer. Grouping helps organize 
the information in meaningful ways.

It is important that records first be sorted using the same field that is used for grouping. 
Otherwise, a new group might be created each time the data in the group changes. Sorting  
can be added in the report; however, it’s best to make the sorting occur in the underlying tables 
or queries.

The Report Wizard
The Report Wizard is a great way to get started with most reports. It lets you choose multiple 
tables or queries, group and sort data, perform calculations, and organize and present the 
information. The Wizard builds the report for you creating the necessary structure and 
organization.

ÍÍ Create→Reports→Report Wizard 
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DEVELOP YOUR SKILLS: A4-D2	

In this exercise, you will create a detailed Invoice report using the Report Wizard.

	 1.	 �Choose Invoice Details Query Q1 2013 in the Navigation pane under the Queries 
heading.

	 2.	 �Choose Create→Reports→Report Wizard .

	 3.	 �Double-click the EmpID field to add it to the Selected Fields list, or choose it and click the  
Add  button.

	 4.	 �Add the InvNum, InvDate, CustLastName, ProdID, Price, Qty, and LineTotal fields 
to the Selected Fields list.

	 5.	 �Click Next, and the Wizard will ask if you want grouping levels.

	 6.	 �With EmpID selected, click the Add  button to set EmpID as the first grouping level.

	 7.	 �Now add the InvNum field to make it the second grouping level.

	 8.	 �Click Next, and the sort order and summary information screen will appear.

	 9.	 �Click the Summary Options button in the lower part of the dialog box.

	10.	 �Check the Sum box for the LineTotal field.

	11.	 �Leave the other settings as they are and click OK.

	12.	 �Click Next since sorting isn’t needed.

	13.	 �Choose Outline as the Layout option and Landscape as the Orientation.

	14.	 �Leave the Adjust the Field Width box checked and click Next.

	15.	 �Name the report Invoice Details Report Q1 2013 and click Finish.

	16.	 �Take a moment to review the report using the page controls at the bottom of the screen 
(there should be five pages).

	17.	 �Click the Close Print Preview button on the right side of the Ribbon.
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50  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

Modifying Reports
Reports can be created from scratch using Design View but the Report Wizard is much easier to 
use and far more efficient. The Report Wizard provides a great starting point but it’s often 
necessary to add, delete, move, or resize fields and to enhance a report in other ways such as 
adding titles and a company logo. These and other enhancements can be done using Layout 
View or Design View.

View the video “Modify Reports in Layout View.”

View the video “Modify Reports in Design View.”

Controls
Controls determine where field data, titles, headings, images, and other information are 
precisely positioned within report sections. There are three types of controls used in reports.

TYPES OF CONTROLS

Control Type Description
Bound Controls that display data from the table or query

Unbound Objects that enhance the appearance of a report such as labels, titles, lines, 
and images

Calculated Controls that display calculated fields from queries or that perform 
calculations within the report itself 

The following controls are available on the Design tab of the Ribbon.

Available controls

Adding Fields to a Report
Sometimes fields need to be added to an existing report. The Existing Fields tool displays a list 
of tables and their fields. Fields are added to the report in Design View by dragging them from 
the Field List pane into report sections. Adding a field creates a text box control where the field 
data is displayed and a label control that contains the field name. The label can be changed, 
allowing you to be creative with the field names displayed on the report.

ÍÍ Design→Tools→Add Existing Fields 
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Modifying Reports  51

DEVELOP YOUR SKILLS: A4-D3	

In this exercise, you will delete unneeded controls, add controls, and rearrange and resize controls to 
produce a more attractive, well-balanced report.

	 1.	 �If necessary, open Invoice Details Report Q1 2013.

	 2.	 �Switch to Layout View .

	 3.	 �Close any boxes that may be open such as the Property Sheet or Field List pane.

	 4.	 �Follow these steps to delete and rearrange the invoice number summary controls:

DB C

A

A	Click the Summary for ‘InvNum’ control and tap [Delete] to remove it.

B	Click the Sum label then tap or hold the right arrow [¡] to move it across the report next 
to the LineTotal box.

C	With the Sum label still selected, press the [Ctrl] key and click the total box. Both 
controls should be selected.

D	Tap the up arrow [£] three times to move the controls up.
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52  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

	 5.	 �Follow these steps to repeat the preceding procedure for the EmpID field controls:

A

B C

A	Scroll down until Summary for ‘EmpID’ is visible, click to select it, and tap [Delete] to  
remove it.

B	Scroll down, click the Sum label, and tap or hold the right arrow [¡] until it is aligned 
with the Sum and Qty controls above it.

C	With the Sum label selected, press the [Ctrl] key and click the total box, then tap the up 
arrow [£] three times to move the controls up.

	 6.	 �Follow these steps to change the width and alignment of the Price controls:

B

A

A	Click any Price label and then tap the [Ctrl] key and click any price box to select all price 
labels and boxes.

B	If the Property Sheet is not visible, right-click the selected controls and choose 
Properties.

	 7.	 �Set the Width property to 0.8.

	 8.	 �Set the Left property to 6.625 and tap [Enter] so you can see the change take effect.

	 9.	 �Switch to Design View .

	10.	 �Click the =”Page” numbering control located in the Page Footer section.
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Modifying Reports  53

	11.	 �Make sure the Property Sheet box is visible, set the Width to 2, and tap [Enter] to see the 
change.

	12.	 �Follow these steps to change the report width:

B

A

A	Click the Selection Type button in the Property Sheet box and choose Report.

B	Set the Width to 9.

	13.	 �Choose Design→Tools→Add Existing Fields .

	14.	 �Follow these steps to add the ProdDescription field and to move its label:

A

C

B

A	Drag the ProdDescription field from the Field List pane and drop it between the 
ProdID and Price fields in the Detail section. It’s important to place it in the Detail 
section.

B	Right-click the new ProdDescription label (it will be hard to see) and choose Cut 
from the menu.

C	Right-click the InvNum Header and choose Paste.
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54  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

	15.	 �Follow these steps to reposition the fields:

A

B

A	Drag the Description label and drop it between the ProdID and Price labels in the 
InvNum Header.

B	Use the arrow keys to position the Description label and the ProdDescription field so 
they are left-aligned with one another and roughly centered between the ProdID and 
Price fields.

	16.	 �Close the Field List pane and switch to Layout View.

Header and Footer Objects
The Header/Footer group on the design tab lets you easily add page numbers, titles, the date and 
time, and logos while working in Design View. Logos are especially useful as they can make 
reports look more professional and visually appealing. The Report Wizard only creates one 
report title, so the Title tool is often used to add subtitles.
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DEVELOP YOUR SKILLS: A4-D4	

In this exercise, you will enhance the report header by adding a subtitle, logo, and the date and time, and 
you will format these controls.

	 1.	 �Switch to Design View .

	 2.	 �Right-click the Report Header section bar and choose Properties.

	 3.	 �Set the Height property to 0.9.

	 4.	 �Click inside the current title box, Invoice Details Report Q1 2013, and replace the text 
with Winchester Web Design.

	 5.	 �Set the properties for the title box as follows.

Property Setting
Width 3.5

Font Size 22

Text Align Center

Font Weight Bold

	 6.	 �Choose Design→Header/Footer→Title .

	 7.	 �Drag the new subtitle box so it is just below the Winchester Web Design title and aligned with 
it on the left side.

	 8.	 �Replace the text in the new title box with Invoices for Q1 2013.

	 9.	 �Set the properties for the new title as follows.

Property Setting
Width 3.5

Height 0.35

Special Effect Shadowed

Text Align Center

Font Weight Bold

	10.	 �Choose Design→Header/Footer→Logo , navigate to your Access Chapter 4 folder, 
choose WWD-Logo.bmp, and click OK.

	11.	 �Set the Left property of the logo to 4.

	12.	 �Set both the Width and Height properties to 0.8.

	13.	 �Choose Design→Header/Footer→Date and Time .

	14.	 �Choose the mm/dd/yyyy date format (the third format).

	15.	 �Uncheck the Include Time checkbox and click OK.
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56  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

	16.	 �Switch to Report View and review your Report Header.

Formatting Controls
It is important to ensure that the data values are fully displayed in a report, while at the same 
time taking care not to leave unsightly and unnecessary blank space between columns. To 
accomplish this, you must resize, reposition, and align controls. It is best to adjust controls in 
Layout View because you can see the actual field values while making the adjustments. Multiple 
controls can be formatted together by first selecting them while using the [Ctrl] key.

DEVELOP YOUR SKILLS: A4-D5	

In this exercise, you will use both Design View and Layout View to resize, reposition, and align report 
controls.

	 1.	 �Switch to Design View in the Invoice Details Report Q1 2013 report.

	 2.	 �Click the vertical ruler to the left of the InvNum label and text box in the InvNum Header 
as shown here to select both of them.

	 3.	 �Tap the up arrow [£] five times to nudge the controls up closer to the InvNum Header.

	 4.	 �Select the remaining controls in the InvNum Header section as shown here and tap the up 
arrow [£] five times to nudge them up.

	 5.	 �Position the mouse pointer on the top edge of the Detail section bar as shown here and 
drag it up until it is just below the controls you just moved.

	 6.	 �If necessary, choose Design→Tools→Property Sheet  to display the Property Sheet.
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	 7.	 �Select both of the EmpID controls in the EmpID Header section as shown here.

	 8.	 �Set the Top property for these controls to 0.

	 9.	 �Click the EmpID Header and it will turn black, indicating it is selected as shown here.

	10.	 �Set the Height property to 0.33.

	11.	 �Switch to Layout View.

	12.	 �Click one of the boxes in the Description column to select all of the fields and then drag left 
to widen the column almost to the ProdID column.

	13.	 �Select the Last Name boxes and drag left to shorten the boxes as shown here.

	14.	 �Press [Ctrl] and click the Last Name label to select the label and all the name boxes as 
shown here.

	15.	 �Tap the right arrow [¡] 8 times to nudge the boxes to the right.

	16.	 �Select the ProdID label and one of the boxes below it and then nudge the entire selection 
to the left 6 times.
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58  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

	17.	 �Scroll to the top of the report and click the InvNum box with 20 in it then drag the left 
border to the right to shorten the box as shown here.

	18.	 �Tab the left arrow [¢] enough times to position the box closer to the InvNum label as 
shown here.

	19.	 �Scroll to the bottom of the report until the Sum controls are visible.

	20.	 �Use the [Ctrl] key to select the three Sum boxes and the Grand Total box as shown here.

	21.	 �Set the Format property in the Property Sheet to Currency.

	22.	 �With the controls still selected, press [Ctrl] and click one of the currently unselected boxes in 
the column so that all line total boxes are selected as shown here.
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Modifying Reports  59

	23.	 �Now drag the right border of one of the controls to the right until the Grand Total is fully 
visible.

	24.	 �Switch to Print Preview view to see how your report will look when printed.

	25.	 �Close Print Preview and feel free to return to Design View or Layout View to make 
additional adjustments to the report.

	26.	 �Choose  File→Close to close the database, saving the changes to your report.
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60  FastCourse Access 2016  Chapter 4: Using Reports to Display Information

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 Layout View can be used to change the position and size of objects on a report.	 True    False

2.	 Reports can display data from either tables or queries.	 True    False

3.	 Report Headers are printed on every report page.	 True    False

4.	 Only one table or query can be chosen in the Report Wizard.	 True    False

5.	 All fields must be added within the Report Wizard, as fields can’t be added  
after the report has been created and saved.	 True    False

6.	 The Report  button can be used to build a report with more than one table.	 True    False

7.	 The Property Sheet can be used to adjust the size of individual report controls.	 True    False

8.	 In which section are report page numbers typically displayed?

A.	Report Header or Footer

B.	 Group Header or Footer

C.	 Page Header or Footer

D.	Detail

9.	 Which report view is shown here?

A.	Print Preview

B.	 Layout

C.	 Design

D.	Report

10.	 What important step should be taken prior to setting up a report group?

A.	Sort the records on the grouping field

B.	 Insert a date in the Report Header

C.	 Adjust column widths

D.	All of these options
(continued)
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Self-Assessment  61

11.	 Which report view is shown here?

A.	Print Preview

B.	 Layout

C.	 Design

D.	Report

12.	 Which keystroke can be used to select multiple fields in report Layout and Design Views?

A.	 [Enter]

B.	 [F10]

C.	 [Alt]

D.	 [Ctrl]

13.	 Which of the following is a more efficient way of creating a report from scratch?

A.	Layout Wizard 

B.	 Layout View

C.	 Design View

D.	Report Wizard

14.	 Which type of control within a report displays data from a table or query?

A.	Bound

B.	 Unbound

C.	 Calculated

D.	All of these options

15.	 Jasmine needs to create a report that shows all sales transactions and a transaction total for each sales 
rep. What important steps does she need to take to ensure the report produces the intended results?

A.	Sort the data by sales rep

B.	 Group the data by sales rep

C.	 Sort the data first by sales rep and then group it by sales rep

D.	A report can’t display both the transactions and a total
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Self-Assessment Answer Key
CHAPTER 1: GETTING STARTED WITH TABLES

Item Answer Page Number

1 True 3

2 True 6

3 False 9

4 True 10

5 True 11

6 D 3

7 B 3

8 A 5

9 B 3

10 D 10

11 D 9

12 A 11

13 C 11

14 A 11

15 B 6

CHAPTER 2: WORKING WITH FORMS

Item Answer Page Number

1 True 18

2 True 16

3 False 20

4 False 17

5 True 22

6 False 16

7 True 17

8 True 20

9 True 21

10 False 18

11 A 20

12 B 20

13 C 24

14 D 18

15 B 23

CHAPTER 3: QUERYING A DATABASE

Item Answer Page Number

1 True 32

2 True 32

3 True 36

4 True 39

5 False 29

6 False 38

7 D 34

8 B 34

9 D 35

10 C 39

11 C 39

12 C 35

13 C 37

14 A 35

15 A 34

CHAPTER 4: USING REPORTS TO DISPLAY INFORMATION

Item Answer Page Number

1 True 51

2 True 48

3 False 48

4 False 49

5 False 51

6 False 47

7 True 53

8 C 48

9 B 51

10 A 49

11 C 51

12 D 52

13 D 51

14 A 51

15 C 49
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Index  65

Index

Note: Index entries ending in “V” indicate that a topic is discussed in the video referenced on that page.

SYMBOLS
* (asterisk), using with queries, 34
? (question mark), using with queries, 34
[] (brackets), using with queries, 34

A
Access databases, opening and saving, 3
Access objects

opening and viewing, 4–5
working with, 3V

Access window, contents, 3
AND and OR criteria, using with  

queries, 34–35
ascending order, sorting in, 9–10
asterisk(*), using with queries, 34

B
brackets ([]), using with queries, 34

C
calculated fields, using with queries, 37–39
colors, changing with themes, 22–23
column width, adjusting, 8–9
columns, rearranging in query grid, 30–31
controls

adding to reports, 50
formatting for reports, 56–59
using in forms, 18–19

criteria. See queries

D
data normalization, 11
data sources, importing, 10–11
data types, assigning to fields, 6
databases. See also relational databases

concept, 2
creating tables, 6–8
opening and saving, 3
renaming, 3
types, 2

Datasheet View, adding Invoice table, 7–8
date and time, adding to reports, 55–56
date criteria, using with queries, 35–36
descending order, sorting in, 9–10
Design View

changing forms in, 20–23
creating tables in, 8
modifying reports, 50V

E
editing records in forms, 17
Employees table, selecting fields  

from, 30–31
Excel worksheet, importing, 10–11

F
field properties, setting, 8–9
fields

adding to reports, 50–54
choosing for queries, 31
data types, 6
explained, 5
navigating in forms, 21
selecting from Employees table, 30–31

fonts, changing with themes, 22–23
footer objects, adding to reports, 54–56
Footer section, changing in forms, 20–21
form objects, 3–5
Form Wizard, using, 17
forms

changing in Design View, 20–23
creating and using, 16–17
editing records in, 17
Header and Footer sections, 18, 20–21
with multiple items, 23–24
reorganizing in Layout View, 18V
resizing box width, 18
selecting text boxes, 19
Self-Assessment, 25–26
split form type, 24
tab order, 21–22
using controls in, 18–19

G
grouping reports, 48

H
header objects, adding to reports, 54–56
Header section, changing in forms, 20–21

I
importing data sources, 10–11
invoices

tracking by date, 35–36
tracking by number, 32

Invoices table, adding in Datasheet  
View, 7–8

L
Layout View

modifying reports, 50V
reorganizing forms, 18V

logos, adding to reports, 55–56

M
multiple item forms, creating, 23–24
multitable queries, creating to track 

invoices, 32. See also tables

N
normalization, 11

O
object types, 3–5
objects, using themes, 22–23
opening

Access databases, 3
Relationships window, 12
and viewing Access objects, 4–5

OR criteria, using with queries, 34–35

P
primary key fields

explained, 6
and relational databases, 11

projects
creating databases, 1
designing forms, 15
querying databases, 27

Q
queries

AND and OR criteria, 34–35
calculated fields, 37–39
date criteria, 35–36
Date field, 33
Numeric & Currency field, 33
Self-Assessment, 40–43
specifying criteria, 32–33V
Text field, 33
wildcard characters, 33–34

Query Design View, creating select  
queries, 30–31

query grid, Sort row, 36–37
query objects, 3–5. See also select queries
Query Wizard, using, 28–29
question mark (?), using with queries, 34
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66  FastCourse Access 2016 

R
record sources, using with forms, 16
records

entering in forms, 21–22
explained, 6
navigating to, 4

referential integrity, 11
relational databases, 11–12. See also 

databases
Relationships window, opening, 12
renaming databases, 3
Report button, using, 46
report objects, 3
Report Wizard, using, 48–49
reports

adding fields, 50–54
controls, 50
date and time, 55–56
details, 47
formatting controls, 56–59
grouping and sorting, 48
headers and footers, 47, 54–56

modifying in Design View, 50V
modifying in Layout View, 50V
sections, 47–48
Self-Assessment, 60–61
subtitles, 55–56

S
saving

Access databases, 3
relationships, 12

select queries. See also query objects; tables
multi-table, 30V
using, 28–32

Self-Assessments
forms, 25–26
queries, 40–43
reports, 60–61
tables, 13–14

Sort row, using with query grid, 36–37
sorting reports, 48
split form, creating, 24
subtitles, adding to reports, 55–56

T
tab order, changing in forms, 21–22
table columns, adjusting width of, 8–9
table data, sorting, 9–10
table objects, 3–5
tables. See also multitable queries; select 

queries
creating in databases, 6–8
creating in Design View, 8
fields, 5
linking, 11–12
records, 6
Self-Assessment, 13–14
using to design queries, 31

text boxes, selecting in forms, 19
themes, using with forms, 22–23
time and date, adding to reports, 55–56

W
wildcard characters, using with  

queries, 33–34
Winchester Web Design. See projects
worksheets, importing, 10–11
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