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Preface

T
his textbook is part of our new approach to learning for introductory computer 

courses. We’ve kept the best elements of our proven, easy-to-use instructional 

design and added interactive elements and assessments that offer enormous 

potential to engage learners in a new way. 

Why Did We Write This Content?
In today’s digital world, knowing how to use the most common software applications is critical, and 
those who don’t are left behind. Our goal is to simplify the entire learning experience and help every 
student develop the practical, real-world skills needed to be successful at work and in school. Using 
a combination of text, videos, interactive elements, and assessments, we begin with fundamental 
concepts and take learners through a systematic progression of exercises to achieve mastery.

What Key Themes Did We Follow?
We had conversations with dozens of educators at community colleges, vocational schools, and other 
learning environments in preparation for this textbook. We listened and adapted our learning solu-
tion to match the needs of a rapidly changing world, keeping the following common themes in mind:

Keep it about skills. Our content focus is on critical, job-ready topics and tasks, with a relentless focus 
on practical, real-world skills and common sense. We use step-by-step instructional design to ensure 
that learners stay engaged from the first chapter forward. We’ve retained our proven method of 
progressively moving learners through increasingly independent exercises to ensure mastery—an 
approach that has successfully developed skills for more than 25 years.

Keep it simple. Our integrated solutions create a seamless experience built on a dynamic instructional 
design that brings clarity to even the most challenging topics. We focus our content on the things 
that matter most and present it in the easiest way possible. Concise chunks of text are combined with 
visually engaging and interactive elements to increase understanding for all types of learners.

Keep it relevant. Fresh, original, and constantly evolving content helps educators keep pace with 
today’s student and work environments. We reviewed every topic for relevancy and updated it where 
needed to offer realistic examples and projects for learners.

How Do I Use This Book?
Our comprehensive learning solution consists of a print textbook, a groundbreaking interactive 
ebook, and our easy-to-use eLab course management tool featuring additional learning content, 
such as overviews and video tutorials, and assessment content. Our interactive ebook contains 
learning content delivered in ways that will engage learners.

The eLab assessment solution includes Project Grader exercises for most chapters that are automati-
cally graded by the system, in addition to clear feedback and analytics on student actions.
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Included with Your Textbook Purchase
Depending on your purchase option, some or all of the following are included with your textbook:

Interactive ebook: A dynamic, engaging, and truly interactive textbook that includes elements such as 
videos, self-assessments, slide shows, GIFs, and other interactive features. Highlighting, taking notes, 
and searching for content is easy. 

eLab Course Management System: A robust tool for accurate assessment, tracking of learner activity, 
and automated grading that includes a comprehensive set of instructor resources. eLab can be fully 
integrated with your LMS, making course management even easier.

Instructor resources: This course is also supported on the Labyrinth website with a comprehensive 
instructor support package that includes detailed lesson plans, lecture notes, PowerPoint presenta-
tions, a course syllabus, test banks, additional exercises, and more.

Student Resource Center: The exercise files that accompany this textbook can be found within eLab 
and in the Student Resource Center, which may be accessed from the ebook or online at:  
labyrinthelab.com/office19

We’re excited to share this innovative, new approach with you, and we’d love you to share your 
experience with us at: lablearning.com/share

Visual Conventions
This book uses visual and typographic cues to guide students through the lessons. Some of these cues 
are described below:

Cue Name What It Does

Type this text Text you type at the keyboard is printed in this 
typeface.

Action words The important action words in exercise steps are 
presented in boldface.

Ribbon Glossary terms are highlighted with a yellow 
background.

Note!  Tip!  Warning! Tips, notes, and warnings are called out with  
special icons.

 
Videos, WebSims, and other ebook or online 
content are indicated by this icon.

Command→Command→ 
Command→Command

Commands to execute from the Ribbon are 
presented like this: Ribbon Tab→Command  
Group→Command→Subcommand.

ÍÍ Design→Themes→Themes These notes present shortcut steps for executing 
certain tasks.

Display Settings
Multiple factors, including screen resolution, monitor size, and window size, can affect the appearance 
of the Microsoft Ribbon and its buttons. In this textbook, screen captures were taken at the native 
(recommended) screen resolutions in Office 2019 running Windows 10, with ClearType enabled. 
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The Microsoft Office Specialist Exam and This Text
This textbook has been certified and carries the ProCert Certified logo, 
distinguishing this courseware as a trusted and critical part of preparing for a 
certification exam. This solution meets all course objectives to prepare students 
to take the Microsoft Office Specialist (MOS) Core exam for this subject matter.

For more information on MOS certification, go to: certiport.pearsonvue.com/Certifications/Microsoft 
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L E A R N I N G  O B J E C T I V E S

ÝÝ Describe similarities and differences between 
Office 2019 for the desktop, Office 365, and Office 
Online

ÝÝ Identify uses of cloud storage

ÝÝ Identify parts of the Office user interface

ÝÝ Identify Office features available through 
Backstage view

ÝÝ Use the Office Clipboard

ÝÝ Format text in Office applications

ÝÝ Search for Help within Office applications

1 Introducing Microsoft 
Office and Using 
Common Features

OVERVIEW

I
n this chapter, you will be introduced 

to Microsoft Office and given an 

overview of the various versions 

of the software. Understanding what is 

offered in each will help you make the best 

decision about which version meets your 

needs. You’ll also practice using some of the 

features that are common across the Office 

suite. Once you learn how to use a feature 

in one application, you can use the same or 

similar steps in the others.
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2 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

Introduction to Microsoft Office
Microsoft Office is a software suite that enables users to create, format, revise, collaborate, and 
share files quickly across multiple devices. The Microsoft Office 2019 software suite for Windows 
includes Word, Excel, Access, PowerPoint, Outlook, OneNote, Publisher, and Skype. A software suite 
is a collection of applications generally produced by the same manufacturer and bundled together 
for a better price. Being produced by the same manufacturer also means that each application offers 
the same user interface. Examples of features shared among the different Office 2019 apps are the 
Ribbon, Quick Access toolbar, a spelling and grammar checker, and collaboration tools.

What Devices Will Microsoft Office Work With?
Microsoft Office works on desktops, laptops/notebook computers, and all-in-one PCs and Macs, as 
well as Windows, Android, and iOS smartphones and tablets (though some apps, like Publisher and 
Access, work only on PCs).

If you are writing a paper or preparing a business plan, you probably want to create it on a desktop, 
laptop, or all-in-one computer. If you want to open, read, share, or make simple changes to a Word 
document, you could select any device. This chapter assumes you will be using a desktop, laptop, or 
all-in-one computer.

To learn more about the operating systems (Windows, Android, macOS, or iOS) and types of devices 
(all-in-one computer, desktop, laptop, smartphone, or tablet) that will run Microsoft Office, do a web 
search for Microsoft Office 2019 products.

What Storage Does Microsoft Office Provide?
Microsoft OneDrive is the cloud storage location included with Microsoft Office 2019 and Office 365, 
and it provides a convenient way to save, store, and share files, photos, and videos via your computer, 
smartphone, or tablet anytime, anywhere, and on any device—provided you have an Internet 
connection or Wi-Fi access. Depending on the Microsoft Office product you use or purchase, you will 
receive anywhere from five gigabytes to five terabytes of OneDrive cloud storage.

You may want to use cloud storage as your primary saving method so you can access your files at 
home, at school, at work, or anywhere. Or you may decide to use cloud storage as a backup for your 
files located on your computer’s hard drive or your flash drive. Instead of emailing files to yourself, 
use OneDrive as a faster way to store something in the cloud. To learn more about OneDrive, do a 
web search for OneDrive.

Which Microsoft Office Should I Use?
You may have heard others talk about Microsoft Office 2019, Office 365, and Office Online and are 
not sure which one is right for you. Base your decision on the apps and features you need, in addition 
to the pricing structure.

 Ý Office Online: This version is free and requires a Microsoft account. It includes limited versions of 
Word, Excel, PowerPoint, and OneNote. No software is installed on your computer, as the apps are 
accessed and run in a web browser. The apps are not the same as the full-version apps in the other 
variations of Office and lack many features of those full versions. This version requires an Internet 
connection. Office Online is great for simple tasks, like writing a short letter or creating a basic slide 
show presentation.
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Introduction to Microsoft Office 3

 Ý Microsoft Office 2019: This version is software that is purchased once and installed on one PC. It 
does not require an Internet connection to run. It does not have all the features of Office 365, and 
you must pay for future major upgrades. Choose from a variety of plans that may include Word, 
Excel, PowerPoint, OneNote, Outlook, Publisher, Access, and Skype.

 Ý Office 365: This version requires users to pay a monthly or annual subscription fee for installing 
and using the software on one or more devices (PC/Mac and mobile devices). All upgrades are 
included, so you always have the latest-and-greatest version, and all Office 2019 apps are included. 
Microsoft says the Office 365 apps can include features not present in the Office 2019 apps, as 
Office 365 is updated more frequently than Microsoft Office.

While Microsoft Office has three distinct formats—Microsoft Office 2019, Office 365, and Office 
Online—and the examples provided in this chapter can work in each of the Office formats, this book 
assumes you are using Office 2019 on the desktop or Office 365 in a subscription-based plan, as well 
as Windows 10. Remember that Office 365 can change at any time. If you are using Office 365, keep 
in mind that your screen may not match all the illustrations in this book. Changes made to Office 365 
after publication of this title may result in additional differences between your book and the software.

What Are the Microsoft Office Apps?
In this chapter, you will learn about four of the Microsoft Office applications included in the Microsoft 
Office suite: Word, Excel, Access, and PowerPoint.

Application What It Is Used For

Word 
Word-processing software used to create, edit, format, and share 
documents, such as letters, reports, essays, and business plans.

Excel 
Spreadsheet software, arranged with rows and columns, used to perform 
calculations and analyze numerical data. Use Excel to prepare a budget 
or income statement, or to determine the amount of interest paid on a 
loan.

Access 
Database software that stores and helps you quickly retrieve data. 
In Access, you create and enter data into a table and then use forms, 
reports, and queries to display the desired results.

PowerPoint 
Presentation software used to create, edit, format, and share slides 
designed to tell a story; market a product; or explain a concept.

The Microsoft Office suite includes the following additional applications:

Application What It Is Used For

OneNote 
Note-taking software used to organize notes (handwritten or typed), 
audio recordings, screen captures, or sketches you have collected or 
created to share with others.

Outlook 
Personal information management software used to create, send, and 
receive emails, record tasks, maintain one or more calendars, schedule 
meetings and appointments, manage contacts, and take notes.

Publisher 
Desktop-publishing software used to design and lay out text and images, 
often for newsletters or brochures.

Skype 
Internet communication software used to share audio, video, text, 
messages, files, or desktop screens.
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4 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

Microsoft Accounts
A Microsoft account provides you with access to your Microsoft settings, files, contacts, and more. 
A valid Microsoft account can include Hotmail, Bing, MSN, Office, OneDrive, Outlook, Skype, Store, 
Windows, or Xbox Live. Once logged in to your computer, you can log in to your Microsoft account 
from any Office app. If you do not have a Microsoft account, you can create one for free by doing a 
web search for Microsoft account.

Common Features in Microsoft Office Apps
The Office 2019 applications share some frequently used features. They include the Ribbon, Quick 
Access toolbar, and common commands.

The Ribbon
Within each application, you will find the Ribbon displayed along the top of the window. The Ribbon 
contains tabs and commonly used buttons and other icons that are specific to the application. The 
buttons are arranged in groups within each tab. While the Ribbon changes with each application, 
some tabs, groups, and commands are common throughout the Microsoft suite. In this chapter, we 
will look at the Access Ribbon and, specifically, the File, Home, Create, External Data, Database 
Tools, and Help tabs.

View the video “Ribbon Overview.”

The Quick Access Toolbar
Each application has a one-line Quick Access toolbar located, by default, in the top-left corner of the 
application window. This helpful toolbar contains some frequently used commands to help you be 
more efficient as you work. You can customize the toolbar with the buttons you use most frequently. 
The settings for each application’s Quick Access toolbar work independently; therefore, you need to 
customize the Word, Excel, Access, PowerPoint, and Outlook Quick Access toolbars separately.

View the video “Quick Access Toolbar Overview.”

Undo/Redo
Within any application, you may type text or perform a command or action and then change your mind 
about what you did. As long as you have not exited the application, you may be able to undo the action.

Some actions, such as saving or sharing, cannot be undone.

You may want to redo an action you just undid. Sounds confusing, right? Use the Redo button to undo 
the undo, or to reapply the action. This puts the command or action you just undid back into effect.

Undo and Redo on the Quick Access toolbar

Note!
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Common Features in Microsoft Office Apps 5

The Undo and Redo commands in Access operate differently from the same commands in other 
Office applications. Because of a database’s nature, many changes made within Access, such as 
creating an object or deleting a record, cannot be undone or redone. Also, the Undo and Redo 
commands do not function the same across all object types.

In Access, the Undo and Redo commands are most often used while working with text entry and control 
design.

ÝÍ Quick Access toolbar→Undo  or Redo 

DEVELOP YOUR SKILLS: O1-D1

In this exercise, you will use the Undo button.

 1.  Log in to your computer, start Access, and tap [Enter] to accept the default template Blank 
Database.

 2.  Click the Create  button.

A new database has been created using the default name Database1 and placed in your Documents 
folder. You can delete this file after the chapter exercises if you like.

 3.  Type Hello and tap [Enter].

 4.  Type: Field

 5.  Click the Undo  button once to remove the word Field.

 6. Type Record and tap [Enter].

 7.  Click the Undo  button once to remove the word Record.

Because you tapped (Enter), the database created a new record. Using the Undo command in this 
instance would remove the entire record and not just the word Record.

 8.  Keep Access open.

Unless otherwise directed, always keep any files or programs open at the end of an exercise.
 

Common Features on the File Tab
In this section, you will learn about the features on the File tab that are used in a similar manner 
throughout multiple Microsoft applications, including Word, Excel, PowerPoint, and Access. Here you 
will use Microsoft Access to save, close, open, and print.

Backstage View
When you are working in your file and open the File tab, the Backstage view displays. Think of your 
Backstage view as your personal manager for the open file and application. Use the Backstage view 
to update file information, select account settings, view program options, open new files, save, print, 
and provide feedback to Microsoft, and recover unsaved files. These are the “big-picture” items you 
do to your file and not the specific tasks you perform using the other tabs on the Ribbon.
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6 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

Program Options
Microsoft provides preference settings that you can customize for each application (that is, Access 
or Word) so they are automatically applied each time you use the application on your device. To 
change your preferences, use the Options feature on the File tab. Some custom options include 
adding your username and initials, saving files to a default file location, and customizing the 
Ribbon.

Options include allowing you to set defaults for the file format and personalizing with username  
and initials.

ÝÍ File→Options

Saving Files
In most Office applications, you should save frequently to prevent data or information loss. Some 
people prefer to save important files every few minutes, while others save at less frequent intervals.

When an Access file is created, it is also named and saved in the location chosen by the user. A key 
feature of Access is that your file will constantly save as changes to data or objects are entered or 
updated. Because of this feature, you will not need to utilize the save settings reserved for other 
Office applications (Word, Excel, PowerPoint). However, it is still good practice to use the saving 
commands, especially when working on major design or layout changes.

The saving commands are found on the File tab, and you’ll see different options, including Save and 
Save As. In Access, these commands work to save either an individual object within the database or 
to save the entire database file.

View the video “Using Save and Save As.”

An Access database file is most likely to be saved to a shared location such as SharePoint. In a 
small organization a file may be saved to a personal device (for example, on the hard drive of a PC). 
Depending on the file size, it could possibly be saved to a flash drive or to the cloud in OneDrive.

ÝÍ File→Save or Save As
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Common Features in Microsoft Office Apps 7

DEVELOP YOUR SKILLS: O1-D2

In this exercise, you will use Save to save an open object and Save As to store an Access database file in a 
new folder.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

 1.  In your open Access database, choose File to display the Backstage view and then click Save.

Because Table1 is open, Access prompts you to save this object by opening a dialog box.

 2.  In the Save As dialog box, type New Table for the table name and then click OK.

Notice the table name has changed and is indicated in the object tab.

 3.  Choose File to display the Backstage view and then click Save As.

 4.  Verify the Save Database As option is chosen from the File Types menu on the left and the Access 
Database option is chosen to the right.

 5.  Click the Save As  button and then choose Yes to close all objects.

 6.  In the Save As dialog box, navigate to the Overview Chapter 1 folder in your file storage location.

 7.  Click the New Folder command located to the right of the Organize command, just under the 
address bar.

 8.  Type My Database for the new folder name and tap [Enter] twice.

 9.  Click in the File Name box and type: OV-D2-Database

 10.  Click the Save button.

 11.  Click File to display the Backstage view and then click Close.

Finding, Searching, and Opening Files
Files can be opened within an application by using the Open dialog box, choosing from a recently saved 
files list within the application, using File Explorer, or typing the filename in the Windows Search box. 
Within Windows 10, as well as previous versions of Windows, you can use File Explorer to locate and 
manage your files. You can click the File Explorer icon on the taskbar and then search for files located 
on your PC, flash drive, or OneDrive.

View the video “Opening Files.”
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8 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

Printing
If you are connected and have access to a printer, you should be able to print. Before printing, you 
should verify formats, ensure proper layout, and review the file to see if you have used the fewest 
possible number of pages. Use the Print Preview feature to browse the pages before printing so you 
don’t waste time or printing resources, and use the options in the Settings area to adjust elements 
such as page orientation, paper size, margins, and more. 

Keep in mind that you can print to paper or to PDF if you want to be eco-friendly.

View the video “Printing Files.”

ÝÍ File→Print

DEVELOP YOUR SKILLS: O1-D3

In this exercise, you will open an Access database file using Windows Explorer and then print an Access object.

 1.  Ensure that Access is open and then click the File tab to display the Backstage view.

 2.  Choose Open.

 3.  Open OV-D3-WinDesign from your Overview Chapter 1 folder.

 4.  Click Enable Content if the Security Warning bar displays.

The Security Warning appears whenever a database file is opened for the first time. When working 
with the files that correspond to this text, you should always click the Enable Content button that 
appears. You should never open files unless you know or trust the file sender. 

 5. Save your database in the same location as: OV-D3-WinDesignRev

 6.  Choose the CustomersMultiItem form located in the Navigation pane on the left by click-
ing the form name (don’t double-click).

 7. Click the File tab.

 8.  Choose Print from the menu and then choose Print Preview  from the list of options to the 
right.

The object opens in Print Preview.

 9.  Choose Print Preview→Zoom→Two Pages .

The form is currently set to print across two pages with only a portion of the fields printing on the 
second page.

 10.  Choose Page Layout→Landscape .

The entire form is now set to print across the length of one page.
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Common Features in Microsoft Office Apps 9

 11. Choose Print Preview→Print→Print  to open the Print dialog box.

The Print dialog box allows you to set the print range and the number of copies and select which 
printer will perform the job.

 12.  Click the Cancel button at the bottom right of the dialog box.

 13.  From the Ribbon, click Close Print Preview .

Templates
A template is a database that has created objects with preconfigured fields, relationships, and 
settings. The fonts, styles, and object and control layout settings such as orientation and size may 
already be built in. Instead of creating each object and selecting these settings when you prepare a 
blank database file, you may opt to use a template to save time.

In most Office applications including Access, you can search for online templates using the Search 
feature available when you create a new database. Templates are arranged according to categories; 
for example, by business, personal, and industry.

Most Office applications include sample templates that are stored on the hard drive of your 
computer when you install the software. Access does not include this feature because of large file 
sizes of most database templates.

ÝÍ File→New

DEVELOP YOUR SKILLS: O1-D4

In this exercise, you will open a prebuilt database template. You will need an Internet connection to 
complete this exercise.

 1.  Choose File→New and then select the Students Database template.

 2.  Name the database Students and click Create .

Explore the database. Notice the many objects available in the Navigation pane to the left. Open and 
explore a few objects of your choice by double-clicking on the object’s name.

 3.  Click File to display the Backstage view and then click Close to close the database without saving.

Common Features on the Home Tab
In this section, you will learn about the features on the Home tab that are used in a similar manner 
throughout multiple Microsoft applications, including Word, Excel, Access, and PowerPoint. You will 
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10 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

use Microsoft Access to Cut, Copy, and Paste with the Office Clipboard; format text; use the Mini 
toolbar; and find and replace text.

The Office Clipboard
Located at the far left on the Home tab, the Clipboard group contains the Cut, Copy, Paste, and 
Format Painter buttons. Selecting the Clipboard dialog box launcher opens the Clipboard pane, 
which displays at the side of your application. The Clipboard contains thumbnails (small images) of 
what you have recently cut or copied from your Microsoft Office file(s) during your Windows session, 
with the most recent item at the top of the list.

You can use the Clipboard to quickly paste text, pictures, or other images into your file. You can paste 
all items on the Clipboard into your file(s) as many times as desired, and you can clear all items from 
the Clipboard. The Cut feature in the Clipboard group allows you to cut data, and then paste it in the 
desired location. When data is cut, the original selection is removed from the source location and is 
pasted at the target location. When data is copied, the original selection remains in the source loca-
tion and a new selection is pasted at the target location.

View the video “Clipboard Overview.”

CLIPBOARD FEATURES

Feature What It Does

Cut  Cut: Removes the original selection from the source location and places 
the selection on the Office Clipboard.

Copy  Copy: Creates a duplicate of the original selection, which remains in 
the source location, and places a copy of the selection on the Office 
Clipboard.

Paste  Paste: Inserts a copy of the most recent item found on the Office 
Clipboard at the target location, or destination. Depending on the 
application, there are usually at least three paste choices: Keep Source 
Formatting, Merge Formatting, and Keep Text Only.

Keep Source Formatting: Pastes the text and the formatting (bold, 
italic, underline) of the selection from the source location to the target 
location. The selection pasted retains the original formatting from the 
source location.

Merge Formatting: Pastes the text and formatting (bold, italic, 
underline) of the selection from the source location to the target 
location and combines it with any formatting that is already at the 
target location. The selection pasted has formats from both the source 
and target locations.

Keep Text Only: Pastes the selection from the source location to the 
target location. The selection pasted takes on the formatting of the 
target location.

Format Painter Format Painter: Applies the character and paragraph formatting from 
the source selection to any characters or text selected.

Double-click the Format Painter to apply formats to multiple selections. 
Click the Format Painter button to turn it off when you are finished.

ÝÍ Home→Clipboard→Cut  | [Ctrl]+[X]

ÝÍ Home→Clipboard→Copy  | [Ctrl]+[C]

ÝÍ Home→Clipboard→Paste  | [Ctrl]+[V]
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Common Features in Microsoft Office Apps 11

DEVELOP YOUR SKILLS: O1-D5

In this exercise, you will use Access to copy data from the source destination to the target destination. You 
will also use a form control and cut data from its original location and paste it into the target location.

 1.  Ensure that Access is open and then choose File to display the Backstage view.

 2.  Choose Open.

 3.  Open OV-D3-WinDesignRev from your Overview Chapter 1 folder and save it as: 
OV-D5-WinDesignRev

 4.  Open the Customers form located in the Navigation pane on the left by double-clicking the 
form name.

The form opens in Form View. Now you will move text from one field to another using the Cut 
command.

 5.  Follow these steps to cut data from the selection and paste to the target:

D

A

B

C

A  Highlight the text Pickup at 6PM, located in the Last Name text box.

B  Choose Home→Clipboard→Cut .

C  Click the Notes text box.

D  Choose Home→Clipboard→Paste .

The note has been moved to the Notes text box and the Last Name textbox is now blank. Next you 
will use the Copy command.
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12 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

 6.  Follow these steps to copy data from the selection and paste to the target:

D

A

B

C

A  Highlight the text AndersM, located in the Cust ID text box.

B  Choose Home→Clipboard→Copy .

C  Click the Last Name text box.

D  Choose Home→Clipboard→Paste .

The data appears in both the Cust ID and the Last Name text box. Now you will make a final edit to 
the Last Name field.

 7.  Tap the (Backspace) key one time to remove the M.

Leave the form open for the next exercise.
 

Formatting Text Using Text Formatting Group Settings
To make your selection more visibly appealing and easy to read, you may want to use some or all of the 
font formats available in the Text Formatting group. To apply the formats, you must first select text.

The Format Painter applies multiple formats located in one control to another within the object. Think 
of the selected control as your paint can. You apply the formats found in your paint can, the selected 
control, to another control with the help of the paintbrush, or Format Painter. Whatever control you 
select gets the formatting. You can use Format Painter to format multiple controls by double-clicking 
the Format Painter button. To turn off the multiple-use feature and stop “painting,” tap the [Esc] key.

DEVELOP YOUR SKILLS: O1-D6

In this exercise, you will make text bold, change the font color, and use the Format Painter.

 1.  Choose Home→Views→View to switch to Layout View.

 2.  Select the First Name text box.
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Common Features in Microsoft Office Apps 13

 3.  Choose Home→Text Formatting→Bold .

 4.  Choose Home→Text Formatting→Font Color .

Text in the First Name text box is now formatted to bold and red.

 5.  Follow these steps to apply formatting taken from the selected text to the chosen target using 
Format Painter:

A

B

C

A  Double-click the Format Painter  button.

B  Click the Cust ID text box.

C  Click the Last Name text box.

The same formatting applied to the First Name text box is now applied to both Last Name and Cust 
ID text boxes.

Leave the form open for the next exercise.
 

The Mini Toolbar
The Mini toolbar is a floating toolbar that contains some of the more commonly used formatting 
buttons found on the Home tab and specific to the application. The Mini toolbar appears at various 
times in all the Office applications, giving you a convenient way to choose the most commonly used 
commands.

In Access, the Mini toolbar appears only if you are working with rich text. By default, the text properties for most 
data types is plain text so you will not likely see the Mini toolbar unless you have changed the field settings. 

The Mini toolbar in Access (left) and Excel (right)

Note!
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14 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

DEVELOP YOUR SKILLS: O1-D7

In this exercise, you will use the Mini toolbar in Access to apply formatting.

 1.  Choose Views→View to change to Form View.

 2.  Highlight the text 6PM in the Notes text box.

The Mini toolbar appears.

 3.  In the Mini toolbar, click the Bold  button and the Font Color  button to apply red 
formatting.

 4.  Click anywhere in the form to close the Mini toolbar.

 5.  Click the Close  button at the far right of the Customers tab.

 6.  Click Yes when prompted to save your changes to the Customers form.

Find and Replace
Within a database you may need to locate text quickly. You may also need to substitute data for 
something else. The Find command is used to search for characters, symbols, numbers, words, 
phrases, or any other data that meet the criteria. The Replace command first finds whatever meets 
the criteria and then replaces it with data you desire.

DEVELOP YOUR SKILLS: O1-D8

In this exercise, you will use the Find command to locate the word dogs and then replace each occurrence 
with puppy.

 1.  Open the Customers table located in the Navigation pane on the left by double-clicking the 
table name.
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Common Features in Microsoft Office Apps 15

 2.  Choose Home→Find→Find .

The Find and Replace dialog box opens.

 3.  Click the drop-down arrow for the Look In option and choose Current Document.

 4.  Click the drop-down arrow for the Match option and choose Any Part of Field.

 5.  Type dogs in the Find What box.

 6.  Click Find Next.

The word dogs is highlighted in the table.

 7.  Click the Replace tab in the Find and Replace box.

Verify that the Find What box displays dogs.

 8.  Type puppy in the Replace With box.

 9.  Click Replace All to change the one occurrence of the word dogs to puppy.

 10.  Click Yes in the Microsoft Access message box.

 11.  Close the Find and Replace box.

Help
When you are working in Microsoft Office, you may need to find out more about a topic as it relates 
to the application. Located to the right of the last tab on the Ribbon is the Tell Me What You Want to 
Do box. This box provides a quick way to access help or learn more about a feature in the applica-
tion. When you click the box, suggestions related to the application display. Use the text box to enter 
words or phrases describing what you would like to do or locate next in the application. You can use 
the Tell Me… box to research or explain the meaning of a term with Smart Lookup. To view a list of 
Help topics, tap the [F1] function key on the keyboard.
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16 Overview Chapter 1: Introducing Microsoft Office and Using Common Features

Another Help feature is the Tell Me More link that may display at the bottom of a button’s help tip. 
When you click the link, the Help window displays with more information about the specific feature. 
Using this method, you learn more about the feature without typing any search text.

Some buttons display robust ToolTips with a Tell Me More link when you point to them.

DEVELOP YOUR SKILLS: O1-D9

In this exercise, you will explore the Help and Tell Me More features.

 1.  With your Access database open, tap the (F1) key.

The Access 2019 Help window appears.

 2.  Click in the Search Help box, type Tables, and press (Enter).

Search results display numerous articles that include or relate to the topic of Tables.EVALU
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Common Features in Microsoft Office Apps 17

 3.  Close the Help window.

 4.  Follow these steps to open the Tell Me More link for the Table command:

B

A

C

A  Click the Create tab in the Ribbon.

B  In the Tables group, hover your mouse pointer over the Table command (don’t click).

C  Click the Tell Me More link at the bottom of the ToolTip.

The help window opens with topics related to the Create Table command.

 5.  Close the Help window and then Close  Access.
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L E A R N I N G  O B J E C T I V E S

ÝÝ Identify database objects and the functions they 
perform

ÝÝ Identify table features

ÝÝ Create database tables

ÝÝ Identify and choose data types

ÝÝ Sort and filter table records

ÝÝ Import a data source

ÝÝ Establish a relationship between two database 
tables

1 Getting Started with 
Tables

ACCESS

H
ave you ever wondered how 

sportscasters come up with  

fun and interesting facts about 

teams and players in a flash? Have you been 

taken by surprise when a customer service 

agent suddenly begins to recite your name, 

address, and a detailed purchase history? In 

most cases, these people have access to a 

powerful database from which they obtain  

the information. In this chapter, you will  

be introduced to database concepts and  

work with tables, the starting point of all 

databases.
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20 Access Chapter 1: Getting Started with Tables

Ý Project: Creating a Database
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You have been asked to build a database to help the company 
manage its employee, customer, and sales data. You’ll get started by creating a database and 
building tables and table relationships.

Introducing Databases
It is likely that you routinely interact with databases. If you make an online purchase, your order 
information goes into a database. The database might be used to track your order status, product 
likes and reviews, past orders, or future promotions. If you post or like something on your Facebook 
account, that information is maintained in a database. If you search for or store a telephone number, 
that information is likely kept in a database. It is quite possible you have been using databases 
without even knowing it! Here, you will be introduced to what a database is and gain a better under-
standing of related terms, explore a sample database, and, finally, create your own!

While there are many definitions of a database, you can think of a database as an organized collec-
tion of related data files or tables. For example, a company might organize its information by both 
customers (external to the business) and employees (internal to the business). While the data relate 
to the same business, the types of data provided for customers and employees will likely differ.

Databases are the epicenter of our digital world.
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Introducing Databases 21

Types of Databases
Large organizations typically use large custom-designed databases specifically for that company or 
industry. When you make travel plans, you are using a database that is specific to the airline industry. 
It contains real-time data, meaning that if there is only one seat left on a plane, whoever selects 
and pays for the seat first gets the reservation. If you are a small-business owner, you may use 
predesigned database software such as Microsoft Access to track information about your customers, 
products, and employees. Access provides the tools needed to let small organizations create, use, 
and maintain databases.

Open and Save an Access Database
Each time you start Access, the Backstage view displays options for opening an existing file, creating 
a new blank database, or selecting from a number of prebuilt templates. If you’re creating a new 
database, Access will immediately prompt you to save the file in your desired storage location. You 
must save your file first because the database will constantly update data as it is entered or edited.

DEVELOP YOUR SKILLS: A1-D1

In this exercise, you will open an existing Access database and save it with a new name.

 1.  Start Microsoft Access.

 2.  Browse through the list of templates and then choose Open Other Files near the upper-left 
side of the window.

 3.  Click the Browse  button, navigate to your Access Chapter 1 folder, and double-click 
A1-D1-WinDesign.

The database opens with the database objects shown in the Navigation pane on the left.

 4.  Click Enable Content if the Security Warning bar displays.

The Security Warning appears whenever a database file is opened for the first time. When working 
with the files that correspond to this text you should always click the Enable Content button that 
appears. You should never open files unless you know or trust the file sender.

 5.  Choose File→Save As.

Notice the Save Database As option is already selected in the File Types task pane to the left. This 
allows users to save the entire contents of a database, including any objects, relationships, and 
settings.

 6.  Click Save As to accept Access Database as the file type.

 7.  Replace the 1 at the end of the filename with Rev to make it A1-D1-WinDesignRev and then click 
the Save button.

The database is saved as a Microsoft Access Database file type. This format saves databases as Access 
2007–2019 files with the file extension of .accdb.

 8.  Click Enable Content when the Security Warning bar displays again.

Not only did you save the database with a new name, which creates another file, but you also closed 
the original database and opened the new one, so the Security Warning appears again.

 9.  Keep Access open, as you will continue to use the database to explore the Access environment.

Always leave the database file open at the end of an exercise unless instructed to close it.
 

Note!
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22 Access Chapter 1: Getting Started with Tables

Database Objects and the Access Window
The Access window includes the Ribbon, Navigation pane, and work area. The Navigation pane 
appears along the left side of the window and displays the database objects. A database object is a 
structure used to either store or retrieve data, and the four Access objects are tables, forms, queries, 
and reports. You can open and use database objects from the Navigation pane; you can also create 
new database objects using commands on the Ribbon along the top of the window. Whether you use 
the Ribbon to create a new object or double-click an existing object from within the Navigation pane, 
the object will open in the work area, where you create and modify database objects.

DATABASE OBJECT TYPES

Access Object What It Does
Table Tables contain the database’s data, and they let you enter, edit, delete, or 

view records in a row and column layout that is similar to that used in an 
Excel worksheet.

Form Forms are used to view, edit, delete, and add data to a table one record at 
a time.

Query Queries are used to search for specific table records using criteria and to 
sort and perform calculations on the results.

Report Reports are printable database objects that can display, group, and 
summarize data from tables and/or queries.

View the video “Working with Access Objects.”

DEVELOP YOUR SKILLS: A1-D2

In this exercise, you will open and view the four Access object types.

 1.  Take a moment to explore the Access window, noticing the various tables, forms, queries, and 
reports in the Navigation pane.

 2.  Double-click the Customers table from within the Navigation pane to open the table in the 
work area.

The table opens in Datasheet View by default, which appears similar to a worksheet with columns 
and rows. Datasheet View lets you view, add, and edit table records. One benefit of Datasheet View is 
it lets you see more than one record at a time.

 3.  Click in the first empty Cust ID cell at the bottom of the CustID column.

 4.  Type AdamsA and tap [Tab] to complete the entry and move the insertion point to the next 
field.

Notice the pencil icon highlighted in yellow. This indicates the current record is active and being 
created or edited.

Cust ID is known as a primary key field in this table, so each Cust ID must be unique.

 5.  Type Adams in the Last Name field and tap [Tab].
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Introducing Databases 23

 6.  Enter Anthony as the first name, 23 Pine St as the street address, and Bradenton as  
the city.

 7.  Click the drop-down menu button � in the ST field and choose FL from the list of states.

The ST field is an example that utilizes field properties to make data entry easy and accurate.

 8.  Complete the record as follows, making sure to tap [Tab] after entering the information.

Tapping [Tab] after entering data completes the record, saving it in the database. As you enter the 
telephone number, Access will automatically format the entry for you.
• ZIP: 34210
• Telephone: (941) 555-3648
• Email: AAdams@email.com
• Notes: Call for delivery.

 9.  Choose Home→Views→View menu button � and then choose Design View .

Each object type can be created or edited using Design View. Tables Design View is where fields can 
be added, removed, or edited and field properties can be set.

 10.  Click the View menu button � and choose Datasheet View .

The Anthony Adams record is now the second record in the table. It moved up because the records are 
sorted in ascending order by the data in the Cust ID field.

Explore a Form
Now you will explore a form that is based on the Customers table. Forms help facilitate effective data entry 
by displaying one record at a time.

 11.  Double-click Customers Form in the Forms section of the Navigation pane.

The form displays all fields from the Customers table, but only one record is visible.

 12.  Locate the Record bar at the bottom of the form.

 13.  Click the Next Record  button to view the Anthony Adams record you just entered.

 14.  Click in the Notes box and add the phrase after 10:00 to the end of the note (that is, “Call 
for Delivery after 10:00”).

 15.  Click the Next Record  button again to complete the edit.

This edit has now been saved in the Customers table.
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24 Access Chapter 1: Getting Started with Tables

Explore a Query
Now you will explore a query that is based on the Customers table. Queries choose specific database 
records using criteria that you specify.

 16.  Double-click Customers Query in the Queries section of the Navigation pane.

The query results look like a table displayed in Datasheet View, but the query displays only some of 
the fields from the underlying Customers table and records where the City is equal to Bradenton.

 17.  Click the View menu button � on the Ribbon and choose Design View .

The query has fields from the Customers table and the criterion Bradenton. This is an example of a 
simple query based on a single table. Queries can draw data from multiple tables and can include 
more sophisticated criteria.

 18.  Choose Query Tools→Design→Results→Run  to run the query and display only the 
Bradenton results.

Explore a Report
Now you will explore a report that uses multiple tables, including the Customers table.

 19.  Double-click Invoice Details Report in the Reports section.

Take a moment to scroll through and observe the report.

 20.  Switch to Design View .

The Report design grid may look complicated, but it’s easy to create a robust report using the Access 
Report Wizard. The design grid can then be used to make modifications once the foundation has been 
set with the Wizard.

 21.  Switch to Report View , which is great for viewing reports.

 22.  Follow these steps to display and then close an object:

BA

A  Display the Invoice report by selecting the tab at the far right.

The object type is indicated on each tab by the icon on the left of the tab.

B  Click the Close Object button at the far right to close the object.

 23.  Close the three open objects that remain.

 24.  Choose File→Close to close the database.
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Introducing Tables 25

Introducing Tables
A table is the starting point for entering, finding, and reporting useful information located in your 
database. A database can have separate tables, each tracking different types of data. A business 
might use a table to keep track of customer billing or employee contact information.

Table Features
Data are meaningful units of information such as names, numbers, dates, and descriptions organized for 
reference or analysis. The data stored in the Winchester Web Design database might include customer 
first and last names, business names, telephone numbers, and other important information.

A field is the smallest meaningful unit of information about one person, place, or item. Individually, 
each field represents a piece of data. Together the fields provide information. In most databases 
fields are displayed in columns.

A record is a collection of related fields about a person, place, or item, such as a single customer 
or employee. A collection of related records makes up a table. In most databases records are 
displayed in rows.

Field Record

CustID field and BlaserH record in Customers table

Field Data Types
If you have ever filled out an online form, you might have seen instant formatting of some fields. 
When typing in currency values, the dollar sign and decimal point may appear automatically, and 
when entering a date, the slashes between month, day, and year spontaneously appear. This can be 
accomplished by assigning a data type to the field. A data type sets the characteristics of a particular 
field, identifying the type of values it may hold, such as alphanumeric text or numbers, dates, yes/no 
values, or even a hyperlink.

Primary Key Fields
Almost every database table should have a primary key field. A primary key is a unique identifier 
for each record in the table. Examples of field data that would make good primary keys are Social 
Security numbers, student IDs, and email addresses. Using a student ID as a primary key ensures 
that each student is uniquely identified in a student database table. Two students may have identical 
names, but they will never have identical student ID numbers.

ÝÍ Table Tools→Design→Tools→Primary Key 
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26 Access Chapter 1: Getting Started with Tables

Creating a Table in a New Database
Instead of using a database that someone else has prepared, you can design your own using a blank 
database template in Access. Tables are the starting point for databases, and this shows up when a 
new blank database is first created. The new table has a single primary key field as a starting point 
for the database.

The starting point in a blank database

DEVELOP YOUR SKILLS: A1-D3

In this exercise, you will create a new blank database and add an Invoices table in Datasheet View.

 1.  Choose File→New→Blank Database.

 2. Click Browse Folders  and navigate to your Access Chapter 1 folder.

 3.  In the File Name box at the bottom of the window, enter A1-D3-Datasheet as the filename 
and then click OK.

The browsing window closes. Your new database file is now ready for creation in your chosen location 
using the filename you entered.

 4.  Click the Create button, and a new table will appear.

 5.  Follow these steps to change the name of the ID field and set the data type for a second field:

A B

C

A  Double-click the ID field name and type InvNum as the new name. This will be the primary 
key field.

B  Tap [Tab] to go to the second column and, if necessary, choose Click to Add to display the 
data type list.

C  Choose Date & Time.

Once the data type is selected, the heading for the new field becomes Field1.EVALU
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Introducing Tables 27

 6.  Replace Field1 with the name InvDate and tap [Tab] to move to a new field.

Your table currently has a primary key field and one Date/Time field.

 7.  Choose Short Text as the data type for the third field and change the field name to: EmpID

 8.  Tap [Tab], choose Short Text for the fourth field data type, and change the field name to: 
CustID

Your simple table with four fields is now set up and ready for data to be entered.

 9.  Click in the empty InvDate field directly below the InvDate header you just created (you might 
have to click twice) and type: 12/15/2019

 10.  Tap [Tab] and type JFW as the EmpID.

 11.  Tap [Tab] and type SmithW as the CustID.

 12.  Enter the data for the three additional records shown.

As you enter the records notice that the InvNum primary key field is automatically numbered because 
it has an AutoNumber property set.

You cannot enter data into a field that has an AutoNumber property set. Tap [Tab] or use your mouse 
to select the next field. Once you type data into the next field the AutoNumber field will automatically 
populate with the next available number in sequence.

 13.  Choose File→Save or click the Save  button on the Quick Access toolbar and save the table 
with the name: Invoices

 14.  Close  the table.

Creating Tables in Design View
You may find it easier to create a new table in Design View than Datasheet View because Design 
View offers a straightforward layout and intuitive options for entering field names, setting data types, 
adding field descriptions, and setting field properties.

ÝÍ Create→Tables→Table 

Field Properties
Each field data type has numerous properties that can be set to assist with data entry, formatting of 
displayed data, and other useful functions. Some properties contain drop-down menus and built-in 
wizards to help guide the user in setting the property.

Properties are set while working in Design View by using the Field Properties Pane at the bottom of 
the window.

Note!
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28 Access Chapter 1: Getting Started with Tables

The field properties available are always based on the data type for the selected field. For example, a 
field set with the Number data type will include the Decimal Places property while fields set as Short 
Text would not.

View the video “Exploring Field Properties.”

DEVELOP YOUR SKILLS: A1-D4

In this exercise, you will create a new table using Table Design View. Then you will adjust the width of the 
table columns.

 1.  Choose Create→Tables→Table Design .

Access opens an empty table in Design View.

 2.  Type CustID in the Field Name box and tap [Tab].

 3.  Tap [Tab] to accept Short Text as the Data Type.

 4.  Type Customer Last Name and First Initial in the Description field and tap [Tab].

It’s a good idea to use field descriptions when setting up tables to help keep track of the purpose and 
intent of the fields.

 5.  Click in the CustID field and choose Table Tools→Design→Tools→Primary Key .

CustID is now a required field, and each record must have a unique customer ID. Notice the key icon 
next to the CustID field name, indicating it is the primary key field.

Tip!
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 6.  Click in the empty box below the CustID field and complete the following fields as shown:

 7.  Click anywhere in the CustLastName field, and the Field Properties for that field will display at 
the bottom of the window.

 8.  Change the Field Size property to 25 and enter Last Name as the Caption property.

The field will now accept only last names of up to 25 characters in length. The Caption property will 
make Last Name the label that appears for the field when the table is displayed in Layout View and 
when the table is used in queries, forms, and reports. Good database design requires the actual field 
names follow certain guidelines such as eliminating spaces within the name. The caption lets you 
follow good design principles while having more descriptive labels for fields.

 9.  Change the Field Size and Caption properties for the remaining fields as follows:

Field Name Field Size Caption
CustFirstName 25 First Name

CustStreetAddress 25 Street

CustCity 15 City

CustState 2 State

CustZip 5 ZIP

CustPhone 15 Telephone

CustEmail Email

 10.  Choose File→Save or click Save  on the Quick Access toolbar and save the table as: 
Customers

If you ever forget to save, Access will prompt you to save when you close a table or other object.

Set an Input Mask Property
In the next few steps, you will set an input mask property for the CustPhone field. The input mask will 
automatically format telephone numbers as they are entered, adding parentheses, ( ), around the area 
code and a hyphen, -, between the digits.

 11.  Click anywhere in the CustPhone field and then click in the Input Mask property box.

 12.  Click the Input Mask  button on the right side of the property box to display the Input Mask 
Wizard.

The Input Mask Wizard has several steps that can be used to fine-tune the mask. However, the default 
settings will work just fine.
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30 Access Chapter 1: Getting Started with Tables

 13.  Click Finish to complete the input mask and apply it to the CustPhone field.

 14.  Click the View menu button �, choose Datasheet View , and choose Yes when asked if you 
want to save the table.

Notice the CustID field is still listed as CustID because you did not apply a caption in the preceding 
steps. However, all other fields now display the captions you entered previously.

Enter Records
Notice as you are entering records that the input mask you just created formats the telephone numbers, 
and the email field is automatically formatted as a hyperlink because of the field type setting you made. 
Also, feel free to widen the columns slightly by dragging the double-headed arrow that appears between 
column headings if you need more space to see all the data.

 15.  Enter the following records.

Be sure to check your data entry for accuracy.

 16.  Choose File→Close to close the database.

Sorting and Filtering Table Data
The primary purpose of any database is to locate and retrieve data quickly and efficiently. Sorting 
and filtering table records can help accomplish this goal.

When a table is created the records are automatically sorted using the primary key field. This can be 
changed by applying an ascending or descending sort to other table fields. You can even sort on more 
than one field, so customers could be sorted by last name and then by first name.

ÝÍ Home→Sort & Filter→Ascending  or Descending 

Filtering displays a subset of records. For example, in a customer table you may want to view only 
customer records for customers that live in a specific ZIP code. This is accomplished by applying a 
filter to the ZIP code field.

ÝÍ Home→Sort & Filter→Filter 

DEVELOP YOUR SKILLS: A1-D5

In this exercise, you will sort and filter records in a database for a medical clinic named Raritan Clinic East.

 1.  Open A1-D5-RCE from your Access Chapter 1 folder and save it as: A1-D5-RCERev

 2.  Double-click the Patients table in the Navigation pane to open it in Datasheet View.

The records are sorted in ascending order (smallest to largest) on the Patient ID primary key field. 
Records are always sorted on the primary key field unless a sort is applied to one or more other fields.

 3.  Click any name in the Last Name column and then choose Home→Sort & Filter→Ascending .
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Apply a Filter
 4.  Double-click the Raritan Clinic East Doctors table in the Navigation pane.

 5.  Click anywhere in the ZIP column and click the Filter  button.

 6.  Uncheck the Select All box and then check the 34205 box.

 7.  Click OK to apply the filter.

Just two records should now be visible. The remaining records are still in the table but are hidden from 
view because of the filter.

 8.  Close both tables and save the changes.

The sort and filter you applied will be active next time the tables are used.

 9.  Choose File→Close to close the database.

Importing Data Sources
Organizations frequently have data in text files, Excel worksheets, and other formats that needs to 
be imported into a database. It’s easy to import data into Access using the Import & Link tools. Data 
is imported into tables that become part of the database. Excel workbooks are the most common 
source of imported data.

ÝÍ External Data→Import & Link→Excel 

DEVELOP YOUR SKILLS: A1-D6

In this exercise, you will import an Excel worksheet into a new table.

 1.  Open A1-D6-WinDesign from your Access Chapter 1 folder and save it as: 
A1-D6-WinDesignRev

 2.  From the Ribbon, choose External Data→Import & Link→New Data Source  and then 
choose From File→Excel  from the menu.

 3.  Take a moment to examine the options in the first screen of the Get External Data Wizard.

You will leave the how and where option set to Import the Source Data into a New Table in the 
Current Database. Notice the data could also be appended (added) to an existing table if desired.

 4.  Click the Browse button, navigate to your Access Chapter 1 folder and choose A1-D6-
WebContacts, and click Open.

 5.  Click OK to start the import and display the second Wizard screen.

 6.  Check the First Row Contains Column Headings box and click Next to specify the Excel 
column headings as the field names in the new table.

The next Wizard screens let you adjust various settings, including field names and data types. In the 
next step you will change the data type for the email field, changing it to a hyperlink.

 7.  Click in the Email column and click the Data Type menu button �.

 8.  Choose Hyperlink and click Next.

The new Email field hyperlink formatting won’t show up until the import is complete.
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32 Access Chapter 1: Getting Started with Tables

 9.  Click Next again to let Access add a primary key field with autonumbering.

 10.  Name the table Web Contacts and click Finish.

 11.  Choose Close on the final Wizard screen without checking the Save Import Steps box.

The Web Contacts table appears at the bottom of the Tables list in the Navigation pane.

 12.  Double-click the Web Contacts table to open it in Datasheet View.

Notice the hyperlink format is applied to the Email field.

 13.  Adjust the column widths to fit the widest entries in each column by either dragging the column 
head borders or autofitting the columns by double-clicking between two column heads.

 14.  Click Save  on the Quick Access toolbar and close any open tables.

Relational Databases
Early database programs stored data in one large, flat file similar to a worksheet. If a salesperson 
sold merchandise and the same product was sold many times, these databases required the sales-
person to enter the same product description and price for every transaction. Such repetitive data 
entry is time-consuming and bound to cause data errors and inconsistencies.

Relational databases like Access link tables using primary key fields. A good example is linking a 
Salesperson table with a Sales Invoices table. One salesperson might be linked to hundreds of sales 
invoices for which that person received commissions. Once a relationship between the Salesperson 
and Sales Invoices tables is created, all that’s needed to associate an invoice with a salesperson is to 
choose the correct salesperson when creating the invoice. This type of relationship is called a one-
to-many relationship because one salesperson is responsible for many invoices. The other types of 
database relationships are one-to-one and many-to-many, although they are not frequently used.

ÝÍ Database Tools→Relationships→Relationships 

Referential Integrity
Referential integrity is an option that can be chosen when creating a relationship between tables. It 
is a set of rules that prevents changes from being made to fields or records that are related to other 
fields or records. For example, if referential integrity were in effect, then a salesperson could not be 
removed from a database that has invoices assigned to that salesperson. Referential integrity would 
require all the invoices either be removed (not a good idea) or associated with a different salesperson 
before the original salesperson’s record could be deleted. Referential integrity also requires the data 
types of related fields to be the same or compatible.

Data Normalization
A properly designed database organizes tables and fields into their smallest usable units and then 
links them using relationships. This is known as normalization. Normalization eliminates data duplica-
tion, decreases data entry errors and inconsistencies, reduces file size, and streamlines the search for 
necessary information. An example of reducing fields to their smallest usable units would be to use 
separate fields for first name and last name rather than a single name field. If a single name field 
were used, then the database could never be searched or sorted by just last name or first name.
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DEVELOP YOUR SKILLS: A1-D7

In this exercise, you will open the Relationships window, add tables, create a one-to-many relationship 
between the Invoices table and the Employees table, and set referential integrity for the relationship.

 1.  Choose Database Tools→Relationships→Relationships .

 2.  Click the Show Table  button.

 3.  Add the Employees and Invoices tables to the Relationships window by double-clicking them 
from the list.

 4.  Close the Show Table box.

The one-to-many relationship between the EmpID fields is automatically created because it is a 
primary key in the Employees table and a foreign (or secondary) key in the Invoices table. The line 
connecting the tables is called a join line. There’s a 1 on the Employees side of the join line because 
EmpID is the primary key in that table. EmpID is a foreign key in the Invoices table, so it has an 
infinity symbol on that side of the join line. Each employee can have an unlimited number of invoices 
associated with them.

 5.  Click Close  in the Relationships group on the Ribbon and choose Yes to save the relationship.

 6.  Choose File→Close to close the database and then close Access.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A1-R1

Create a Table in Datasheet View
In this exercise, you will create a new database and a table using Datasheet View.

 1.  Start Access and choose Blank Database from the template list.

 2.  Click the Browse Folders  button and save the database to your Access Chapter 1 folder as: 
A1-R1-K4C

 3.  Click the Create button to start a new database.

 4.  Double-click the ID heading and change the text to: StID

This will be the primary key field with autonumbering, so your records will automatically get 
numbered.

 5.  Tap [Tab], choose Short Text as the data type, and change the heading from Field1 to: 
StLName

 6.  Add the following as fields with the Short Text data type: StFName, StAdd, StCity, StST, 
StZIP, StPhone, and StAvail

 7.  Choose File→Save or click Save  on the Quick Access toolbar and save your table as: Staff

 8.  Click the first empty cell in the StLName field and enter the following records using these 
guidelines:

• Use [Tab] to complete entries.

• Enter hyphens in the phone field, as the field is not formatted with an Input Mask.

• Widen the columns as necessary.

• Strive for 100% accuracy when entering data, including spaces between characters and upper-
case and lowercase letters.

StID StLName StFName StAdd StCity StST StZIP StPhone StAvail

1 Bryant Matthew 12 Macintosh St Sarasota FL 34022 941-555-7523 Thursday

2 Earle Kevin 77 Kingfisher Ct Sarasota FL 34024 941-555-1368 Monday

 9.  Choose File→Close to close the database.

REINFORCE YOUR SKILLS: A1-R2

Create a Table in Design View
In this exercise, you will create a new table using Table Design View. Then you will adjust the width of the 
table columns.

 1.  Choose File→New and then choose Blank Database from the template list.

 2.  Click the Browse Folders  button and navigate to your Access Chapter 1 folder. Name the 
database file: A1-R2-K4C

 3.  Click the Create button and then switch to Design View .

 4.  Save the table with the name Children, and the design grid will appear.
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 5.  Replace the field name ID with ChID and tap [Tab].

Notice the key icon to the left of the Field Name indicating this is a primary key field.

 6.  Change the Data Type to Short Text and tap [Tab].

 7.  Type Last Name and First Initial and tap [Tab] to complete the description.

 8.  Enter the remaining fields using the data types and descriptions shown:

Field Name Data Type Description (Optional)

ChLName Short Text

ChFName Short Text

ChAdd Short Text

ChCity Short Text

ChST Short Text 2-char abbreviation

ChZIP Short Text 5-digit ZIP code

ChPhone Short Text Area code & number

ChBday Date/Time

 9.  Click anywhere in the ChPhone field and then click in the Input Mask property box.

 10.  Click the Input Mask  button on the right side of the Input Mask property box and choose 
Yes if asked to save the table.

 11.  Click Finish to accept the Phone Number input mask and apply it to the ChPhone field.

 12.  Switch to Datasheet View , saving the table if prompted to do so.

 13.  Enter these records, adjusting the column widths as necessary:

ChID ChLName ChFName ChAdd ChCity ChST ChZIP ChPhone ChBday

CregerK Creger Kurt 503 Hillview St Sarasota FL 34022 (941) 555-0245 10/12/2012

LangfordJ Langford James 43 Wisteria Ct Bradenton FL 34209 (941) 555-1098 8/13/2010

 14.  Choose File→Close to close the database, saving the changes if prompted.

REINFORCE YOUR SKILLS: A1-R3

Create, Import, and Sort Tables and Establish Relationships
The staff director of Kids for Change would like you to add two new tables to the database: one that stores 
various community activities and one that stores parent volunteers. You’ll create one of these tables and 
import the other.

 1.  Open A1-R3-K4C from your Access Chapter 1 folder and save it as: A1-R3-K4CRev

The first thing you’ll do is import a worksheet into a table, which will then be linked with other tables 
through relationships.

 2. Choose External Data→Import & Link→New Data Source .

 3.  From the menu that appears, choose From File→Excel .

 4.  Click the Browse button on the first Wizard screen and navigate to your Access Chapter 1 
folder.

 5.  Choose A1-R3-ActivityParticipation and click Open.

 6.  Click OK to import the worksheet into a new table and display the next Wizard screen.

 7.  Click Next again to choose ActivityParticipation as the worksheet to use.
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 8.  Check the First Row Contains Column Headings box and click Next to specify the Excel 
column headings as the field names in the new table.

 9.  Click Next again to accept the data type of the two fields as Short Text.

 10.  Click Next again to let Access add a primary key field.

 11.  Click Finish to accept ActivityParticipation as the table name and then click Close to complete 
the import.

ActivityParticipation should now be in the table list.

Sort the Imported Worksheet
 12.  Double-click the ActivityParticipation table to open it in Datasheet View.

Notice the table is sorted in ascending order by Activity ID.

 13.  Click anywhere in the Child ID column and choose Home→Sort & Filter→Ascending .

The records are now sorted by Child ID to easily see all the activities each child has participated in.

 14.  Close the table and save the changes.

Create Relationships
 15.  Choose Database Tools→Relationships→Relationships .

Notice there is currently a relationship between the Donors and Donations tables.

 16.  Click the Show Table  button.

 17.  Add the Children, ActivityParticipation, and Activities tables and then close the Show Table 
box.

 18.  Drag the Child ID primary key field from the Children table and drop it on the ChildID field in 
the Activity Participation table.

Make sure ChildID appears in both the Table/Query and Related Table/Query lists.

 19.  Check the Enforce Referential Integrity box and then click the Create button to complete the 
relationship.

 20.  Drag the ActID field from the Activities table and drop it on the ActID field in the 
ActivityParticipation table.

 21.  Choose to Enforce Referential Integrity and then click Create.

These relationships will now allow a database user to determine all the activities a particular child has 
participated in and to view the details of those activities.

 22.  Click the Close  button above the relationships and choose Yes to save the relationships.

Add a Table in Design View
 23.  Choose Create→Tables→Table .

 24.  Choose Home→Views→Design View  and save the table as: Volunteers
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 25.  Follow these guidelines to set up the table and enter a record:

• Use the field names provided in the image.

• Let VolID be the primary key field with autonumbering.

• Set the data type of all fields (except the primary key field) to Short Text.

• Enter the record shown here, including the hyphens in the phone number:

VolID VolLName VolFName VolStreet VolCity VolST VolZIP VolPhone AvailDay

1 Jones Stan 892 South St Sarasota FL 34024 941-555-8929 Tuesday

 26.  Choose File→Close when you are finished, saving the changes if prompted.
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 Apply Your Skills
APPLY YOUR SKILLS: A1-A1

Create a Database and Tables
In this exercise, you will create a new database with two tables.

 1.  Create a new database and save it to your Access Chapter 1 folder as: A1-A1-SunStateU

 2.  Create a new table named Classes using these field names, data types, and captions:

Field Name Data Type Caption

ClassID Short Text (Primary Key)

Department Short Text

ClassNumber Short Text Class Number

SectionNumber Short Text Section Number

RoomNumber Short Text Room Number

StartTime Date/Time Start Time

EndTime Date/Time End Time

CreditHours Number Credit Hours

 3.  Brainstorm and add at least two records to the table and then close the table.

 4.  Create another new table named Professors using these fields and data types and making 
ProfID the primary key field:

Field Name Data Type

ProfID Short Text

ProfLastName Short Text

ProfFirstName Short Text

ProfDept Short Text

ProfRank Short Text

 5.  Brainstorm and add at least two new records to the table and then close the table.

 6.  Choose File→Close to close the database.

APPLY YOUR SKILLS: A1-A2

Import a Table and Establish a Relationship
In this exercise, you will import an Excel worksheet and establish a relationship between the new table and 
an existing table.

 1.  Open A1-A2-Customers from your Access Chapter 1 folder and save it as: 
A1-A2-CustomersRev

 2.  Open the Customers table in Datasheet View.

 3.  Sort the records in Ascending order on the CustZIP field.
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 4.  Widen all columns to fit the widest entry in the columns.

 5.  Close the table, saving the changes.

Import a Worksheet
 6.  Follow these guidelines to import the A1-A2-Invoices workbook in your Access Chapter 1 

folder as a table into the open database:

• Leave all field names and data types as they are in the Wizard.

• Make InvNum the primary key field.

• Use Invoices as the table name.

 7.  Double-click the Invoices table to open it in Datasheet View.

 8.  Sort the table in Ascending order on the EmpID field.

 9.  Close the table, saving the changes.

Establish a Relationship
 10.  Open the Relationships window and create a relationship between the CustID fields in the 

Customers and Invoices tables, enforcing referential integrity.

 11.  Close the Relationships window and save the changes to the relationship.

 12.  Choose File→Close to close the database.

APPLY YOUR SKILLS: A1-A3

Create a Table, Import a Database, and Establish a Relationship
In this exercise, you will create a database to track the courses taught by specific teachers in a nonprofit 
organization.

 1.  Create a new database and save it to your Access Chapter 1 folder as: A1-A3-Teachers

 2.  Follow these guidelines to create the table shown:

• Use the table name, field names, and data as shown.

• Set all data types to Short Text and make TeacherID the primary key field.

• Enter this data:

TeacherID TFirstName TLastName TStatus

Amack Alex Mack Fulltime

Bsmith Brian Smith Parttime

Jjones Jack Jones Parttime

Twatts Tonya Watts Fulltime

 3.  Close the table and save it with the name: Teachers

 4.  Import the A1-A3-Courses workbook (Access Chapter 1 folder) using CourseID as the 
primary key field and naming the table: Courses

 5.  Establish a one-to-many relationship between the TeacherID fields in the Teachers and Courses 
tables and enforce referential integrity.

 6.  Close and save the Relationships window and close the database.
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  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROJECT gRADER: A1-P1

Taylor Games: Create and Import Tables
Taylor Games creates replacement parts for many different games as well as various types of dice. You’ve 
been asked to create a database to manage orders and inventory. It would like you to use the data from a 
spreadsheet that was previously created to manage inventory for various items.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A1_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A1_P1_Start from your Access Chapter 1 folder.

 2. Create a new table named Orders that contains the following fields and criteria:

Field Name Data Type Primary Key Field Size Caption
Order_ID AutoNumber Yes Order #

Order_Date Date & Time Date

SKU Number Double

Item Short Text

Quantity Number

Cost Currency

Total_Cost Currency Total Cost

 3. Import data from an Excel file into a new table using the following guidelines in the Import 
Wizard:

• Choose the A1_P1_Inventory.xlsx Excel workbook from your Access Chapter 1 folder.

• The first row should contain column headings.

• Leave all Field Options set to the default values.

• Use SKU as the primary key.

• Import to a table named: Inventory

 4. Sort the Inventory table data in Ascending order on the Quantity field; then close the table, 
saving the changes.

 5. Create a one-to-many relationship between the SKU fields in the Inventory and Orders tables, 
enforcing referential integrity. Close and save the relationship when you are finished.

 6. Save your database.

• Using eLab: Save it to your Access Chapter 1 folder as A1_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 1 folder as: A1_P1_SubmissionEVALU
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PROJECT gRADER: A1-P2

WebVision: Design a Database and Create Tables
You are the Senior Sales Rep for WebVision, a startup company providing a unique closed-circuit television 
service. You’ve been asked to create an Access database of the most recent orders taken and relate them to 
the sales reps who made the sales.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A1_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A1_P2_Start from your Access Chapter 1 folder.

 2. Create a new table named Sales Reps that contains the following fields and criteria:

Field Name Data Type Primary Key Caption
RepID Short Text Yes Rep ID

LastName Short Text Last Name

FirstName Short Text First Name

SalesTeam Short Text Sales Team

 3. Enter the following data into the Sales Rep table and then close the table, saving the changes, if 
necessary:

Rep_ID LastName FirstName SalesTeam
S101 Franks Bernie North

S102 Edmunds Sally Central

S103 Berry Amy West

S104 Lifestone Ben South

 4. Import data from an Excel file into a new table using the following guidelines in the Import 
Wizard:

• Choose the A1_P2_Orders.xlsx Excel workbook from your Access Chapter 1 folder.

• The first row should contain column headings.

• Leave all Field Options set to the default values.

• Use OrderID as the primary key.

• Import to a table named: Orders

 5. Make the following changes in the Orders table:

• Set the caption for the OrderID field to: Order Number

• Set the caption for the RepID field to: Rep ID

• Sort the data in the Date field in descending order and then close the table, saving the 
changes if necessary.

 6. Create a one-to-many relationship between the RepID fields in the Sales Reps and Orders 
tables, enforcing referential integrity. Close and save the relationship when you are finished.

 7. Save your database.

• Using eLab: Save it to your Access Chapter 1 folder as A1_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 1 folder as: A1_P2_Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A1-E1 That’s the Way I See It
You’ve volunteered to help a nonprofit organization determine how much recyclable material is 
being collected by the five recycling centers in the area. You’ve been tasked with creating a database 
with contact information for the five centers. You will also visit the five centers, gathering information 
on the recyclables they accept and the annual number of metric tons of each that they’ve collected 
each year over the past three years. The annual tonnage information needs to be in a separate table 
that is related to the Centers table. Save your completed database as: A1-E1-Recycle

A1-E2 Be Your Own Boss
Your boss, the owner of Blue Jean Landscaping, has decided to sponsor the Sarasota Service Guild, 
a nonprofit organization created to raise money to help adults with disabilities. It needs a database 
that tracks businesses that donate to the guild and the donations that are made. Create a database 
with tables and fields to track the businesses and the donations they make. Create a relationship 
that can be used to relate businesses to the donations it has made over the past five years. Populate 
your tables with information for two businesses, with each making an annual donation over the past 
five years. Include relevant information about the businesses, including their names, addresses, 
and primary contact information. Include the amount and date of the annual donations. Save your 
completed database as: A1-E2-BJL

A1-E3 Demonstrate Proficiency
Stormy BBQ wants to modernize its business. It has hired you to design and create a database 
for its BBQ restaurant. Use Access to create a database with three tables: one for staff, one for 
menu items, and one for transactions where each transaction lists the menu items on that transac-
tion including the quantity and price of each item. Relate the menu and transactions tables. Enter 
enough data to be able to view and modify the tables as needed. Save your completed database as: 
A1-E3-StormyBBQ
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L E A R N I N G  O B J E C T I V E S

ÝÝ Create basic forms

ÝÝ Create forms using the Forms Wizard

ÝÝ Modify forms using Layout View

ÝÝ Modify forms using Design View

ÝÝ Set properties for form sections and form controls

ÝÝ Set the tab order of a form

ÝÝ Create multiple item forms and split forms

2 Working with Forms

ACCESS

I
f you have ever entered your 

personal information on a college 

application, filled out a loan 

application, or purchased an item from an 

online retailer, you have used a form. You 

also use forms to sign up for social media 

and email accounts. In this chapter, you 

will create and work with Access forms that 

provide an attractive, easy-to-use interface 

that allows users to focus on one table 

record at a time.
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Ý Project: Designing Forms at Winchester Web Design
As the information technology (IT) director at Winchester Web Design, you are responsible for 
designing and formatting the forms and reports in the company database to make them more 
attractive, consistent, and user-friendly. Part of your job is to customize forms so they better 
identify the company. To accomplish this, you plan to create a consistent color scheme and add 
the corporate name and logo to all company forms.

Creating Forms
A form is a database object used to enter, edit, or view the data for individual table records. Forms 
are a nice alternative to the row and column arrangement of table Datasheet View. Being able to 
view and focus on a single record can help ensure data accuracy.

Record Sources
Forms display data from a record source, which is typically a single table or query. However, if a 
relationship exists between two or more tables, fields from all related tables can be displayed on the 
same form. An example is an Invoice form that displays fields from the Invoice, Products, Customers, 
and Employee tables.

A form with controls containing data from fields in the Invoice, Products, Customers, and Employee tables
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Creating and Using Basic Forms
The Form button instantly creates a basic form based on the table or query selected in the Naviga-
tion pane. This is the easiest way to create a form using all fields from the selected table or query. 
Only one table or query can be used in a basic form.

ÝÍ Create→Forms→Form 

DEVELOP YOUR SKILLS: A2-D1

In this exercise, you will create a basic form and edit a record using the form.

 1.  Open A2-D1-WinDesign from your Access Chapter 2 folder and save it as: 
A2-D1-WinDesignRev

When completing exercises, always choose to Enable Content.

 2.  Choose the Employee Spouses table in the Navigation pane by clicking the table name (don’t 
double-click).

 3.  Choose Create→Forms→Form .

A basic form is created based on all fields in the Employee Spouses table and is displayed in Layout 
View. Layout View is used to size and position form controls.

 4.  Click the View menu button � and choose Form View .

Form View is used for entering, editing, and viewing table records one at a time. The navigation 
controls located in the record selector at the bottom of the form are used to browse table records and 
create new records.

 5.  Navigate to record 2 (the Tom Franklin record) by clicking once on the Next Record button in 
the navigation controls.

 6.  Change the last four digits of the phone number to: 6767

 7.  Choose File→Save or click Save  on the Quick Access toolbar and save the form as: 
Employee Spouses

 8.  Click the Close  button on the right side of the form.

Creating Forms with the Form Wizard
The Form Wizard is a great way to get started with the creation of most forms. It allows you to 
build a form using the fields you choose from one or more tables or queries (record source). When 
choosing the fields your form requires, the Add and Remove buttons allow you to add or remove the 
field selected, while the Add All or Remove All buttons add or remove all fields within the record 
source with one command. You can also choose from multiple layout options—including Columnar, 
Tabular, Datasheet, and Justified—from within the Wizard. The form can then easily be modified 
using Layout View or Design View.

View the video “Working with the Form Wizard.”

ÝÍ Create→Forms→Form Wizard 
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DEVELOP YOUR SKILLS: A2-D2

In this exercise, you will use the Form Wizard to create a form.

 1.  Choose the Customers table in the Navigation pane.

 2.  Choose Create→Forms→Form Wizard .

Customers is chosen in the Tables/Queries list because you chose it before starting the Wizard.

 3.  Click the Add All Fields  button and click Next.

This adds all fields from the Customers table to the Selected Fields list. You could add fields from 
other tables and queries as well, although you won’t do that now.

 4.  Click Next again to accept the Columnar layout format option.

 5.  Leave the form name as Customers and click Finish.

The form is displayed in Form View and is ready for data entry or editing.
 

Changing Forms in Layout View
A typical form has a header section where tiles, logos, and decorative elements are displayed and a 
detail section with control labels and text boxes. In a basic form, most labels will contain the name 
of the field, while the text box displays the field data for that record.

Label

Text box
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These objects can easily be sized, moved, edited, and removed in Layout View. Multiple objects can 
be selected by holding the [Ctrl] key while clicking each desired one. Selecting multiple objects allows 
you to format or edit those objects at one time.

View the video “Reorganizing Forms in Layout View.”

ÝÍ Home→Views→Layout View 

DEVELOP YOUR SKILLS: A2-D3

In this exercise, you will size, position, and edit controls, and you’ll get extensive practice selecting multiple 
controls.

 1.  With the Customers form still open, click the View menu button � and choose Layout View .

 2.  Click the Street Address label to select it.

 3.  Click in the selected label, just to the right of Address.

 4.  Tap the [Backspace] key until the word Address has been removed.

The label should now be Street.

 5.  Click in the ST label and rename it to: State

 6.  Click in the ZIP label and change it to: Zip

Size Text Boxes
 7.  Click the large, empty Notes text box (not the label) to select it.

 8.  Hover the mouse pointer over the right edge until the adjust pointer appears.

 9.  Drag left, reducing the box width to equal the Email text box width.

 10.  Reduce the width of the State text box so it is slightly wider than the two-character state 
abbreviation.

Change the Position of Labels and Text Boxes
In the next few steps, you will move the text boxes so they are closer to their descriptive labels.

 11.  Click the large Notes text box.

 12.  Press and hold [Ctrl] and click the Email text box.

Both boxes should be selected.

 13.  Press and hold [Ctrl] while you select all other text boxes in the column.

Use Undo if you accidentally move the boxes while selecting.
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 14.  Tap the left arrow [¢] key repeatedly to move the text boxes closer to their labels.

 15.  Click any empty part of the form (white background) to deselect all boxes.

 16.  Use the mouse and [Ctrl] key to select the Telephone, Email, and Notes labels and text boxes.

 17.  Use the keyboard or drag with the mouse (when the four-headed arrow appears) to move the 
labels and text boxes up and right as shown.

 18.  Choose File→Save or click Save  on the Quick Access toolbar to save the changes to the 
form.

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Changing Forms in Design View 49

Changing Forms in Design View
Form Layout View is a great tool for controlling the visual layout of a form, including editing, sizing, 
and rearranging labels and text boxes. However, some form design details can be more precisely set 
using Design View. In Design View you can set section properties as well as which Sections to include 
in a form. The Property Sheet is used in both Layout View and Design View to specify the details for 
any form object.

ÝÍ Form Layout Tools→Design→Views→Design View 

ÝÍ Form Design Tools→Design→Tools→Property Sheet 

Modifying Form Header and Footer Sections
The Form Header and Footer sections appear at the top and bottom of the form. The Form Header is 
the typical location for decorative features such as the title and logo controls, which are available in 
the Header / Footer group on the Home tab of the Ribbon.

Form Footers are used less frequently; however, you can place static data there, such as the date 
or various contact information. Form Footers are available with the same controls offered to the 
Form Header section. The Form Header and Form Footer can be modified in either Layout View  
or Design View.

DEVELOP YOUR SKILLS: A2-D4

In this exercise, you will format the Form Header and field labels and insert a logo to make the form look 
more professional.

 1.  With the Customers form still open, choose Form Layout Tools→Design→Views→ 
Design View .

The Form Header section contains the Customers title and the text boxes, and their labels are located 
in the Detail section.

 2.  Click in the Customers title box in the form header and change the title to: Winchester 
Customers

Next you will use the Property Sheet to precisely size, position, and format the title. A
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 3.  Choose Form Design Tools→Design→Tools→Property Sheet .

The Property Sheet shows the settings for the currently selected object (the Customers title box).

 4.  Click in the Width box in the Property Sheet and then set the width to 5.5 and press (Enter).

After setting a property, press (Enter) or (Tab). Property settings don’t take effect until after the current 
property box is no longer active.

 5.  Click in the Left box and enter: 1.5

 6.  Choose Lucida Calligraphy for the Font Name setting and enter 30 for the Font Size setting.

 7.  Choose Home→Text Formatting→Font Color  menu button � and choose a blue color 
of your choice.

You can set text formats in this manner or directly in the Property Sheet, if desired.

Set Control Properties in the Detail Section
 8.  Click the Cust ID label (not the text box) in the Detail section.

The name CustID_Label appears at the top of the Property Sheet. The Property Sheet always 
indicates which control is selected.

 9.  Press and hold [Ctrl] and click all labels in the Detail section to select them all.

Properties can be set for multiple controls at the same time, provided the controls are of the same 
type (labels or text boxes). Notice in the Property Sheet that many properties, like Width and Height, 
are identical for all labels. Other properties, like Top and Left positioning, are blank because they are 
not the same for all labels.

 10.  Apply the same blue font color you just applied to the title to the selected labels.

Insert a Logo
 11.  Choose Form Design Tools→Design→Header/Footer→Logo .

 12.  Navigate to your Access Chapter 2 folder, choose WWD-Logo.bmp, and click OK.

Access places the logo in the upper-left corner of the Report Header section, but it’s a bit small. The 
logo should be selected so the Property Sheet will show the logo properties.

 13.  Set both the width and height to: 0.8

The form header will increase in height slightly to accommodate the logo.

 14.  Switch to Form View  to see the changes.

Tip!
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Explore Property Sheets for Sections and the Form
 15.  Switch to Design View .

 16.  Follow these steps to explore section and report properties :

A

D

C

B

A  Click the Form Header section bar and view the Property Sheet.

The Property Sheet should be set to FormHeader. Here you can specify the visibility of the header area 
and set formats like the background color.

B  Click the Detail section bar and examine its properties.

C  Click the Selection Type menu button � in the Property Sheet.

D  Scroll through the list and choose Form from the list.

The Form properties control the overall appearance and functionality of the form. 

Properties for the form can also be accessed by clicking the Select Form box at the top-left corner of  
the form.

 

Tab Order
The most effective way to enter a record using a form is to use [Tab] to move from one field to the 
next. Forms have a tab order that determines which field the insertion point moves to each time 
the [Tab] key is tapped. The tab order can be changed to allow fields to be entered in a different 
sequence. This may be necessary if fields are rearranged on a form and when fields from more than 
one table appear on the same form.

ÝÍ Design→Tools→Tab Order 

Tip!
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DEVELOP YOUR SKILLS: A2-D5

In this exercise, you will change the form tab order to make the telephone number the second field in the 
tab order.

 1.  Switch to Form View .

 2.  Use the [Tab] key to cycle through the fields.

The last name field is the first field in the tab order after the CustID field.

 3.  Switch to Design View .

 4.  Choose Form Design Tools→Design→Tools→Tab Order .

 5.  Follow these steps to adjust the tab order:

A

B

C

A Choose Detail from the section pane to the left to see the current tab order for fields in the 
Detail section.

B Click the small selection box next to the CustPhone field.

C Drag the CustPhone selection box up and drop it above the CustLastName field. CustPhone 
should now be second in the tab order.

 6.  Click OK to complete the tab order change.

 7.  Switch to Form View  and tap [Tab] repeatedly to cycle through the fields.

The tab order remains the same with the exception of the CustPhone field, which is now second in the order.
 

Themes
Themes are prepackaged groups of design elements such as background colors, font families, font 
sizes, and other properties. When themes are applied, they impact all objects in the database (tables, 
forms, queries, and reports). The Themes group on the Ribbon lets you change just the colors or fonts 
or the overall design, including both the colors and fonts.

ÝÍ Form Design Tools→Design→Themes→Themes 
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DEVELOP YOUR SKILLS: A2-D6

In this exercise, you will apply a theme to your form and adjust theme colors and fonts.

 1.  Switch to Design View and choose Form Design Tools→Design→Themes→Themes .

 2.  Hover over the thumbnail of the first available theme (first row, first column) in the gallery.

A ToolTip showing the theme name appears near the bottom of the mouse pointer and a live preview 
of the theme appears in the working area.

With the exception of the first theme (Office), themes in the gallery are listed in alphabetical order from 
left to right, top to bottom.

 3.  Click to choose the Office theme from the gallery.

 4.  Choose Design→Themes→Colors  menu button �.

 5.  Choose Blue Warm from the menu.

 6.  Choose Design→Themes→Fonts  menu button �and then choose Franklin Gothic from 
the menu.

 7.  Switch to Form View  to see how your finished form looks with the new theme.

Access themes are subtle, applying small, incremental changes to the form. Keep in mind that themes 
are applied to all objects in the database (tables, forms, queries, and reports). And once a theme is 
applied, it cannot be undone.

 8.  Close your form, saving the changes if prompted to do so.

Creating Other Types of Forms
The basic form may not always meet the needs of an organization. Some organizations will benefit by 
equipping staff to view multiple records or compare a form to a corresponding table within the same 
object. Different departments within an organization may need to access the same database tables 
but view different fields from within those tables. A good example would be the difference between 

Tip!
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what a customer service representative and a salesperson might need. They will both have a need 
to access customer information, but the salesperson will want to see sales history, sales opportuni-
ties, and other information that a customer service representative won’t need. For these and other 
reasons, organizations may desire a variety of forms designed to make their staff highly efficient.

Creating Multiple Item Forms
Most forms are designed to let the user focus on one record at a time. Sometimes, however, it is 
necessary to print multiple items in a table using a layout more appropriate for printing and distrib-
uting than a table datasheet. The multiple item form is used for those occasions.

Multiple item forms resemble datasheets because data appears in rows and columns. However, 
multiple item forms can be customized to enhance the appearance of the form using colors, graphics, 
and other design elements.

ÝÍ Create→Forms→More Forms→Multiple Items 

DEVELOP YOUR SKILLS: A2-D7

In this exercise, you will create a multiple item form.

 1.  Choose the Customers table in the Navigation pane.

 2.  Choose Create→Forms→More Forms→Multiple Items .

Notice the form’s datasheet-like appearance.

 3.  Choose Form Layout Tools→Design→Themes→Themes  and choose a theme that has 
text sizes and formatting you like.

 4.  If necessary, click any of the customer ID data below the CustID column header to select all 
cells in that column.

The selected cells will have faint yellow borders.

 5.  Hover the mouse pointer over the right edge until the adjust pointer appears.

 6.  Drag the right border of the selected cells to the left, reducing the column width to just accom-
modate the largest entry.

 7.  Reduce the widths of the remaining columns; see if you can get the form to fit on your screen.

 8.  Change the title to: Customers MultiForm

 9.  Click the Forms icon in the form header next to the Customers MultiForm title and tap [Delete] 
to remove it.

Your completed form is now ready to be used as an alternative to a datasheet for data entry and other uses.

 10.  Close the form, saving it as: CustomersMultiFormEVALU
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Creating Split Forms
A split form simultaneously shows a table in Datasheet View and a form displaying a single record 
from the table. The views are synchronized so that a selected record in one view is also selected in 
the other view.

ÝÍ Create→Forms→More Forms→Split Form 

DEVELOP YOUR SKILLS: A2-D8

In this exercise, you will create a split form.

 1.  Choose the Customers table in the Navigation pane.

 2.  Choose Create→Forms→More Forms→Split Form .

Click any record in the datasheet and notice that it displays in the form.

 3.  Choose Form Layout Tools→Design→Themes→Themes  and choose a theme that has 
text sizes and formatting you like.

 4.  Change the title to: Customers SplitForm

 5.  In the header, remove the Forms icon located next to the title control.

 6.  Choose File→Close to close the database, saving the form as: CustomersSplitForm

Sorting and Filtering Records by Form Field
Like tables, forms allow the user to filter or sort data using the commands provided in the Sort and 
Filter group. Ready-to-use filters are available for each data type, allowing a different filter to be 
used for each field. You can apply filters to any single field or to multiple fields—as long as those 
fields are present in Form View.

Filtering a Form
The Filter by Form command creates a blank form with a look and layout that mimics the original. 
This form allows you to filter multiple fields at one time by entering values directly in the text box or 
selecting from a drop-down list located in the field. When the filter is applied, only the records that 
match the values you entered will be displayed.

ÝÍ Home→Sort & Filter→Advanced→Filter by Form 
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DEVELOP YOUR SKILLS: A2-D9

In this exercise, you will first sort records in a form. You will also add and then remove a filter from  
the form.

 1.  Open the Customers form from the Navigation pane.

 2.  Select the Last Name text box control.

 3.  Choose Home→Sort & Filter→Descending .

The Last Name field is now sorted in descending order, making William Smith the first record in  
the form.

 4.  Choose Home→Sort & Filter→Remove Sort .

The sort is removed, and the records are now back to the order held previously.

Filter by Form
 5.  Choose Home→Sort & Filter→Advanced.

 6.  Choose Filter by Form  from the menu.

A blank form appears with two new tabs at the bottom of the form.

 7.  Follow these steps to create a filtered form:

A B

C

A  Select the City text box control.

B  Click the drop-down menu button � that appears to the right.

C  Choose Sarasota from the list.
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 8.  Choose Home→Sort & Filter→Toggle Filter  to apply the filter.

The Customers form is restored with the navigation control indicating the form is filtered to one 
record. This is the only record in our form with Sarasota in the City field.

The field drop-down menu provides a list of all data entered into the active field. This is a helpful option 
if you are not familiar with the data in a field or are unsure about keying in the values you would like to 
use in a filter.

 9.  Choose Home→Sort & Filter→Toggle Filter  to remove the filter.

 10.  Save and then close your database file.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Tip!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A2-R1

Create and Customize a Form
Kids for Change has hired you to create a new form and customize it with a new design. In this exercise, you 
will use the Form Wizard to create a form, add an image, and set several formatting properties.

 1.  Open A2-R1-K4C from your Access Chapter 2 folder and save it as: A2-R1-K4CRev

Enable the content when prompted.

 2.  Choose the Children table in the Navigation pane.

 3.  Choose Create→Forms→Form Wizard .

 4.  Add all fields from the Children table to the Selected Fields list and click Next.

 5.  Keep the Columnar layout and click Next.

 6.  Name the form Kids for Change Children Volunteers and click Finish.

Edit and Format the Title
 7.  Switch to Design View .

 8.  Click in the title box and position the insertion point just in front of the letter C in Children.

 9.  Press and hold the [Shift] key and tap [Enter] to force Children Volunteers to a new line.

 10.  If necessary, display the Property Sheet .

 11.  Set these properties for the title:

Property New Value

Width 3

Font Name Arial

Font Size 18

Text Align Center

Font Weight Semi-bold

Insert a Logo and Set Properties
 12.  Choose Form Design Tools→Design→Header/Footer→Logo .

 13.  Navigate to your Access Chapter 2 folder, choose K4C-Logo.bmp, and click OK.

 14.  Set these properties for the logo:

Property New Value

Width 0.7

Height 0.7

Left 3.3
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Format Text Boxes and Labels
 15.  Click the Child ID label in the Detail section.

 16.  Press and hold [Ctrl] while you select all other labels.

 17.  Set these properties for the labels:

Property New Value

Width 1.5

Height 0.25

Special Effect Raised

Font Name Arial

Font Weight Semi-bold

 18.  Select all text boxes in the Detail section and set these properties:

Property New Value

Height 0.25

Font Name Arial

Font Weight Semi-bold

 19.  Choose Form Design Tools→Design→Themes→Themes  and apply the Slice theme.

 20.  Switch to Form View  to see your completed form.

 21.  Choose File→Close to close the database and save the changes to your form.

REINFORCE YOUR SKILLS: A2-R2

Create a Multiple Item Form and Apply a Theme
Kids for Change has hired you to redesign its database forms and apply a consistent and attractive theme 
to both new and existing forms. In this exercise, you will create a multiple item form for entering and 
managing staff information. Then you will apply a theme to the new form.

 1.  Open A2-R2-K4C from your Access Chapter 2 folder and save it as: A2-R2-K4CRev

 2.  Choose the Staff table in the Navigation pane and choose Create→Forms→More Forms→ 
Multiple Items .

 3.  Change the title to: Kids for Change Staff

 4.  Delete the small image that is just to the left of the Kids for Change Staff title.

 5.  Choose Form Layout Tools→Design→Themes→Themes  and apply the Ion theme.

 6.  Reduce the widths of all columns to fit the widest entries in the columns.

 7.  Switch to Form View  to see your completed form.

 8.  Choose File→Close to close the database, saving the form as: Staff-MultiItem
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REINFORCE YOUR SKILLS: A2-R3

Create and Sort a Form
You have been asked to help facilitate the management of the Kids for Change Activities table. In this 
exercise, you will create a form with a title and an image. Then you will sort the form to display the 
activities by day.

 1.  Open A2-R3-K4C from your Access Chapter 2 folder and save it as: A2-R3-K4CRev

 2.  Using the Form Wizard, create a form that includes all fields in the Activities table. Choose the 
Columnar layout and save the form as: Activities Form

 3.  Switch to Layout View and change the title to: Kids for Change Activities

 4.  Widen the title box so the text doesn’t wrap inside the box.

You may need to click outside of the title box and then click on the title again before sizing it.

 5.  Reduce the widths of all labels so they are just slightly wider than the label text.

 6.  Use the form to navigate through the ten records and reduce the width of the text boxes to be 
slightly wider than the widest entries.

 7.  Move the text boxes closer to the labels.

 8.  Move the Day of Week and Meet Time labels and text boxes. Add a little extra space between 
all rows as shown here:

 9.  Choose Form Layout Tools→Design→Header/Footer→Logo .

 10.  Navigate to your Access Chapter 2 folder, choose K4C-Logo.bmp, and click OK.

 11.  Set these properties:

Property New Value

Width 0.7

Height 0.7

Left 3.6
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 12.  Reduce the height of the title box so it’s just high enough to hold the title and then move it down 
in the Form Header so it is vertically centered in the header area.

 13.  Choose Form Layout Tools→Design→Themes→Themes  and apply the theme of your 
choice.

If you apply a theme that increases the text size, you may need to go back and adjust the controls’ 
sizes again.

Apply a Sort
Now you will sort the records in order by the day of the week the activity occurs so you and others can 
easily see the weekly Kids for Change offerings.

 14.  Switch to Form View .

 15.  Select the Day of Week text box control.

 16.  Choose Sort & Filter→Ascending .

 17.  Choose File→Close to close the database, saving the changes to the form.
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 Apply Your Skills
APPLY YOUR SKILLS: A2-A1

Create and Modify a Form
Universal Corporate Events is a planner of corporate and professional events. You have been tasked with 
revamping the image of Universal Corporate Events, including everything from reports to forms. In this 
exercise, you will create a new Personnel form.

 1.  Open A2-A1-UniversalCorp from your Access Chapter 2 folder and save it as: 
A2-A1-UniversalCorpRev

 2.  Using the Form Wizard, create a form that includes all fields in the Personnel table. Choose the 
Columnar layout and save the form as: Personnel Mgmt

 3.  Switch to Layout View and display the Property Sheet.

 4.  Click in the title box and set these properties for the title:

Property New Value

Width 4

Left 1.5

Text Align Center

 5.  Edit the title, creating a two-line title with Universal Corporate Events on the first line 
and Personnel on the second.

Remember to use the [Ctrl]+[Enter] keystroke combination to push Personnel to the second line.

 6.  Insert UCE-Logo.bmp, located in your Access Chapter 2 folder.

 7.  Set both the Width and Height properties to: 0.7

Modify the Detail Section
 8.  Apply the Slice theme to the form.

 9.  Set the Width property of all labels to: 1.2

 10.  Set the Width property of the EmpID, ST, and ZIP text boxes to: 0.6

 11.  Set the Width property of the First Name, Last Name, Address, and City text boxes to: 1.5

 12.  Set the Width property of the Email Address and Salary Grade text boxes to: 2

 13.  Select all text boxes and move them closer to the labels.

 14.  Reposition the Telephone, Email Address, Date Hired, and Salary Grade labels and text 
boxes up and to the right of the other fields, creating a two-column form.

 15.  Switch to Design View and change the tab order, making EmpPhone the second field in 
sequence and leaving the rest of the tab order as it currently is.

 16.  Switch to Form View to view the database and test the tab order.

 17.  When you are finished, close the database, saving the changes you’ve made to the form.
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APPLY YOUR SKILLS: A2-A2

Edit and Format Labels and Text Boxes
In this exercise, you will create a new Personnel form.

 1.  Open A2-A2-UniversalCorp from your Access Chapter 2 folder and save it as: 
A2-A2-UniversalCorpRev

 2.  Open the Event Schedules form and switch to Layout View.

 3.  Change the Location label to: Venue

 4.  Change the Event ID label to: Event Code

 5.  Display the Property Sheet and change the properties for the Universal Corporate Events title as 
follows:

Property New Value

Width 4.5

Height 0.3

Font Name Georgia

 6.  Set these properties for the Scheduling subtitle:

Property New Value

Width 4.5

Height 0.3

Font Name Georgia

Font Weight Light

 7.  Select all the labels in the Detail section and set these properties:

Property New Value

Width 1.3

Height 0.3

Font Name Arial

Font Size 12

Font Weight Semi-bold

 8.  Select all the text boxes in the Detail section and set these properties:

Property New Value

Height 0.3

Left 1.5

Font Name Arial

Font Size 14
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 9.  Apply the Slice theme.

 10.  Switch to Form View and then make any changes needed.

 11.  Close the database, saving the changes to the form.

APPLY YOUR SKILLS: A2-A3

Create a Form with a Logo and Filter
In this exercise, you will create a new form for managing UCE’s event venue information, add and format 
a Form Header and title, and add an original company logo. You will then add a filter to the form to show 
only the events occurring in the city of Sarasota.

 1.  Open A2-A3-UniversalCorp from your Access Chapter 2 folder and save it as: 
A2-A3-UniversalCorpRev

 2.  Using the Form Wizard, create a form that includes all fields in the Venues table. Choose the 
Columnar layout and save the form as: Event Venues

 3.  Switch to Layout View and display the Property Sheet.

 4.  Click in the title box and set these properties:

Property New Value

Height 0.35

Top 0.25

Left 1.5

Font Name Georgia

 5.  Insert the UCE-Logo.bmp logo, which is located in your Access Chapter 2 folder.

 6.  Set the Width and Height properties of the logo to: 0.8

 7.  Select all the labels in the Detail section and set these properties:

Property New Value

Width 1.5

Height 0.25

Font Name Arial

Font Size 12

Font Weight Semi-bold

 8.  Select all the text boxes in the Detail section and set these properties:

Property New Value

Height 0.25

Left 1.6

Font Name Arial

Font Size 12EVALU
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 9.  Apply any theme with an alternative theme color and the theme font of your choice.

 10.  Change the tab order, making VenuWebsite the second-to-last field in sequence and leaving the 
rest of the tab order as is.

 11.  Switch to Form View to see your completed form.

Apply a Sort and Filter
Universal Corporate Events would like to add an additional event in the city of Sarasota. It wants to review 
any events that are currently scheduled there before making a selection. Now you will add a filter to show 
only events occurring in the city of Sarasota.

 12.  Sort the City field in descending order.

 13.  Use the Filter by Form command to display only the records that include the city of Sarasota.

 14.  Choose File→Close to close the database, saving any changes to your form.
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  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROjECt gRADER: A2-P1

Taylor Games: Creating Forms
Taylor Games wants to provide forms for employees to enter inventory and orders. You will first create 
a basic order form and improve readability and layout. You will also create an inventory split form and 
enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A2_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A2_P1_Start from your Access Chapter 2 folder.

 2. Create a basic form based on the Orders table.

 3. Change the Date label to: Order Date

 4. Set these properties for all label controls:

Property Value

Width 1

Height 0.3

 5. Set these properties for all text box controls:

Property Value

Width 2

Height 0.3

 6. Set the SKU text box Font Weight property to: Bold

 7. Insert a Logo control in the Form Header and set properties for it as follows:

Property Value

Picture Use Taylor Games Logo-B.png from your Access Chapter 2 folder.

Size Mode Zoom

Width 0.75

Height 0.5EVALU
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 8. Set the following properties for the Title control located in the Form Header (contains the title 
Orders):

Property Value

Width 2

Font Size 26

Text Align Center

Font Weight Bold

 9. Apply the Facet theme (the second theme in the Office category).

 10. Save the form with the name: Orders

 11. Create a new split form based on the Inventory table.

 12. Set the Width property of all label controls to: 1

 13. Set the following properties for all text box controls:

Property Value

Width 3

Height 0.25

 14. Set the SKU text box Font Weight property to: Bold

 15. Insert a Logo control in the Form Header and set properties for it as follows:

Property Value

Picture Use Taylor Games Logo-B.png from your Access Chapter 2 folder.

Size Mode Zoom

Width 0.75

Height 0.5

 16. Set the following properties for the Title control located in the Form Header (contains the title 
Inventory):

Property Value

Width 2

Font Size 26

Text Align Center

Font Weight Bold

 17. Apply the Facet theme (the second theme in the Office category)..

 18. Save the form with the name: Inventory

 19. Close all open forms and then save your database.

• Using eLab: Save it to your Access Chapter 2 folder as A2_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 2 folder as: A2_P1_Submission
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PROjECt gRADER: A2-P2

WebVision: Work with Forms
WebVision is updating a database to provide forms for employees to enter data. You will first create a 
form using the Form Wizard and modify it for employee use. You will also create a multiple item form and 
enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A2_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A2_P2_Start from your Access Chapter 2 folder.

 2. Create a new form using the Form Wizard and the following guidelines: 

• It should be based on the Orders table.

• Add all available fields.

• Use Columnar layout.

• Set the title as: Orders

 3. Change the Date label to: Order Date

 4. Set these properties for all label controls:

Property Value

Width 1.2

Height 0.25

 5. Set these properties for all text box controls:

Property Value

Width 0.75

Height 0.25

Left 1.5

Text Align Left

 6. Delete the Title control from the Form Header (contains the title Orders) then insert a new Title 
control and set these properties for it:

Property Value

Width 2

Height 0.35

Font Weight Bold

 7. Follow these guidelines to insert a Logo control in the Form Header and set properties for it:

Property Value

Picture Use WebVision Logo.jpg from your Access Chapter 2 folder.

Width 1.75
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 8. Apply the Gallery theme (the third theme in the Office category).

 9. Set the tab order from top to bottom for the fields in the Detail section as: OrderID, RepID, 
Date, Amount.

 10. Save the form.

 11. Create a new multiple item form based on the Sales Reps table.

 12. Set the Width property to 1 and the Height property to 0.25 for all controls in the Rep ID 
column:

 13. Delete the Form Icon and Title controls from the Form Header.

 14. Insert a new Logo control and set these properties for it:

Property Value

Picture Use WebVision Logo.jpg from your Access Chapter 2 folder.

Width 1.75

Height 0.35

 15. Insert a new Title control and set these properties for it:

Property Value

Width 2

Font Weight Bold

 16. Save the form with the name: Sales Reps

 17. Close all open forms and then save your database.

• Using eLab: Save it to your Access Chapter 2 folder as A2_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 2 folder as: A2_P2_Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills. You will be evaluated 
on your ability to follow directions, completeness, creativity, and the use of proper grammar and 
mechanics. Save files to your chapter folder. Submit assignments as directed.

A2-E1 That’s the Way I See It
You’ve been asked to create a sales invoice form for Blue Jean Landscaping that shows all fields 
from the Sales Invoices query. Open A2-E1-BJL and create a well-designed form that is based on 
the Sales Invoices query and that includes a title and logo (use BJL-Logo.bmp). Make sure all fields 
are appropriately positioned and sized using the largest entries in the database as a guideline for 
determining the appropriate text box sizing. Apply a theme of your choice. Apply a filter to show only 
records with the Last Name of Ford. Save your form as: Sales Invoices

A2-E2 Be Your Own Boss
Blue Jean Landscaping wants a split form that’s based on the Services table. The split form should 
include all fields from the table, a company logo, and the company name in the Form Header  
along with a Landscape Services subtitle. Begin with the file A2-E2-BJL and use the logo file  
BJL-Logo.bmp. Make sure all fields are appropriately positioned and sized using the largest entries 
in the database as a guideline for determining the appropriate text box sizing. Apply a theme of your 
choice. Sort the Equip ID field in ascending order. Save your form as: Services Split Form

A2-E3 Demonstrate Proficiency
You’ve been asked by the management of Stormy BBQ, a local BBQ restaurant, to create consistent 
forms and reports. Open the A2-E3-StormyBBQ database and examine the Merchandise form. 
Create a new form from the Restaurants table that closely matches the Merchandise form. Replicate 
the layout and formatting of fields and of the Form Header. You may not be able to create a perfect 
match but try to get the layout and formatting as close to the Merchandise form as possible. Add the 
SBQ-Logo.bmp file. Name your new form: Restaurants
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L E A R N I N G  O B J E C T I V E S

ÝÝ Create, save, and run select queries

ÝÝ Create select queries using multiple tables

ÝÝ Use simple query criteria

ÝÝ Use AND and OR criteria in queries

ÝÝ Use wildcard characters in query criteria

ÝÝ Sort query results

ÝÝ Create and format a calculated field

3 Querying a Database

ACCESS

O
ne of the main goals of a 

database is to organize data 

so that information can be 

located and retrieved quickly. People in all 

types of businesses retrieve stored data 

and information daily, often at a moment’s 

notice. In this chapter, you will search 

information that is stored in tables in a 

relational database and extract records 

that meet specific criteria using a query, 

a database object used to locate records 

based on the conditions you set.
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Ý Project: Using Queries to Get Answers
You have been asked to query the Winchester Web Design database and compile two 
separate customer lists. The lists will be used to notify all past clients of updates to their 
website contact forms. The first list will include only the first and last names of the clients and 
their email addresses. The second list will include the first and last names of the clients and 
their mailing addresses, sorted by ZIP code. Additionally, you have been asked to build queries 
that instantly calculate the total income from all the Winchester Web Design services and 
from specific areas such as blogs or shopping carts.

Select Queries
A query asks a question, such as, What are the customer addresses? or How much money did the 
company make last month? The answer to the question is provided in a set of records.

All queries have common attributes:

 Ý They function like a saved question you ask a database.

 Ý They produce a subset of data from one or more tables.

 Ý They are dynamic objects that display up-to-date data from tables.

 Ý They can be used to create forms and reports with fields drawn from multiple tables.

 Ý When you edit data in query results, you are actually editing the data stored in the source tables.

A select query is basically a database inquiry that selects only the records you want to see or edit, 
from one or more database tables, based on criteria that you set. The easiest way to create a select 
query is with the Query Wizard.

ÝÍ Create→Queries→Query Wizard 

DEVELOP YOUR SKILLS: A3-D1

In this exercise, you will use the Query Wizard to create a select query that generates a customer email list.

 1.  Open A3-D1-WinDesign from your Access Chapter 3 folder and save it as: 
A3-D1-WinDesignRev

Notice in the Navigation pane that the database currently has three queries.

When completing exercises, always choose to Enable Content.



Note!
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 2.  Choose Create→Queries→Query Wizard .

The New Query dialog box appears, allowing you to select the Query Wizard you would like. The 
Wizard can help you create four types of queries, shown in the right pane of the dialog box.

 3.  Click OK to accept the Simple Query Wizard.

 4.  Follow these steps to build the query:

A

B
C

E

D

A  Make sure the Customers table is chosen in the Tables/Queries list. When building a query, 
you can use multiple tables and even existing queries.

B  Choose the CustLastName field from the Available Fields list.

C  Click the Add  button to add it to the Selected Fields list.

D  Now add the CustFirstName and CustEmail fields, scrolling to find them as necessary, to 
the Selected Fields list.

E  Click Next.

If you add the wrong field, double-click the name to move it back to the Available Fields list or select 
it and use the Move Back  or Move All Back  buttons.
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 5.  Type Customers Email List in the query title field at the top of the dialog box.

 6.  Make sure the Open the Query to View Information option is chosen and click the Finish 
button.

Notice the query results datasheet includes only the three fields you chose from the Customers list.

 7.  Click the Close  button to the right of the Customers Email List tab to close the query.

Creating a Select Query Using Query Design View
Some queries display just a few fields but report on every single record in the table. That may not 
be a problem for a small table, but, when thousands of records and multiple tables are involved, it is 
often necessary to choose only specific records by setting precise criteria. Using Query Design View, 
Access allows you to:

 Ý Select fields from multiple tables

 Ý Locate records using criteria from one or more fields

 Ý Perform calculations

 Ý Sort query results and show or hide fields in query results

ÝÍ Create→Queries→Query Design 

DEVELOP YOUR SKILLS: A3-D2

You have already created an email list for the Winchester Web Design customers and now need one for the 
company’s employees. In this exercise, you will create a query to select fields from the Employees table in 
the Winchester Web Design database and then rearrange the columns in the query grid.

 1.  Choose Create→Queries→Query Design  to display the query design grid.

The Show Table list appears, showing the existing tables and queries in the database.

 2.  Choose the Employees table and click the Add button.

The Employees table appears in the design grid.

 3.  Close the Show Table dialog box and close the Property Sheet if it’s open.

Next you will add fields from the Employees table to the grid.

 4.  Double-click the EmpFirstName field in the Employees table to add it to the grid.
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 5.  Now add the EmpLastName, EmpPhone, and EmpEmail fields to the grid by either double-
clicking or dragging them.

Use the scroll bar located at the right of the table fields to access all available fields in the list.

 6.  Choose File→Save or click the Save button on the Quick Access toolbar.

 7.  Type Employee Contact Info as the query name and click OK.

 8.  Choose Query Tools→Design→Results→Run .

Access runs the query and displays four columns of data (First Name, Last Name, Telephone, and 
Email) for all Employee records.

Rearrange Query Fields
 9.  Choose Home→Views→View→Design View .

 10.  Select the EmpLastName column by placing your mouse pointer over the column heading until 
it becomes a downward-facing black arrow and then single-click.

The entire column is selected, shown by shading it in black.

 11.  Follow these steps to rearrange the EmpFirstName and EmpLastName fields:

ABC

A  Click the EmpLastName column heading again, this time without releasing the button. The 
button will change to a white arrow with a silhouetted box, indicating you can move the column.

B  Drag the EmpLastName column to the left of the EmpFirstName column until the thick ver-
tical bar is positioned as shown.

C  Release the mouse button to complete the rearrangement.

 12.  Run  the query.

Last Name should now appear first in the results.

 13.  Close the query and save the changes.

Tip!
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Designing a Query Using Multiple Tables
Until now, the query results presented in the datasheets you have worked with have displayed data 
from only one table. There will be times when you need to view data contained in different tables 
within the same database. Multi-table queries allow you to do this.

Choosing Fields to Include in a Query
When you build a multi-table select query, you start in Query Design view. Using the Show Table 
dialog box, you can select only those tables and fields that you want to display in the query results 
datasheet and leave out those fields that have no impact on the data you want to view or that are 
confidential. By specifying only certain tables and fields in a database and displaying only the desired 
fields in a query, you can create a report or a form that presents only pertinent data.

Multiple tables are effective in a query only if the tables are related. Using related tables allows 
a query to provide results based on all the data contained in the related table fields selected. For 
example, if you want to find the names and addresses of customers who placed orders from a specific 
employee, you would need fields from both the Customers table and the Invoices table. This is 
because the Customers table does not include any Employee fields, and the Invoices table does not 
include the Customer fields. It would be impossible to answer the question using only the Customers 
or Invoice tables alone.

View the video “Create a Multi-Table Select Query.”

Selecting a Field That Appears in Multiple Tables
Sometimes the same field occurs as a primary key in one table and as a foreign (or secondary) key in 
another table. If this occurs, always use the table with the primary key in your query.

Use the Customers table in the query 
because CustID is the primary key.

CustID is a foreign key 
in the Invoices table.

DEVELOP YOUR SKILLS: A3-D3

In this exercise, you will create a multi-table query using Query Design view to track the Winchester Web 
Design invoices by invoice number.

 1.  Choose Create→Queries→Query Design  to display the query design grid.

 2.  Double-click the Invoices, Invoice Details, and Products tables to add them to the query.

If the Show Table dialog box is not visible, choose Query Tools→Design→Query Setup→Show Table.

 3.  Close the Show Table dialog box.
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 4.  Double-click the InvNum, InvDate, and EmpID fields in the Invoices table to add those fields 
to the query grid.

 5.  Add the ProdDescription and Price fields from the Products table.

 6.  Add the Qty field from the Invoice Details table.

Your query field list should look like this.

 7.  Click the Sort cell for the InvNum field, click the menu button �, and choose Ascending.

 8.  Choose Query Tools→Design→Results→Run  to run the query.

The query results are now sorted by invoice number in the first column.

 9.  Click the Save button on the Quick Access toolbar; then name the query InvoicesList and 
click OK to save the query.

Using Criteria in Queries
Queries let you specify criteria, which are conditions that field values must meet. Only records 
meeting the criteria are returned when the query is run.

In this query, the EmpID criteria is set to JFW.

Only records where EmpID is JFW are returned.
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Criteria are commonly used with text, numeric, currency, and date fields. Review the table for 
examples of how criteria are used.

TYPES OF CRITERIA

Field Type Criteria Examples of How Records Are Returned
Text Smith Last name is Smith

> =Smith Last names are from Smith through the end of the alphabet

Not Smith Last name is not Smith

Numeric & 
Currency

> 123

> =123

Numeric value is greater than 123

Numeric value is greater than or equal to 123

Date Date( ) Date is today’s date

< Date( ) – 30 The Date field is 30 days or more prior to today’s date

Search for Query Criteria in Access help for more criteria examples.

DEVELOP YOUR SKILLS: A3-D4

In this exercise, you will add criteria to the query grid and run the query.

 1.  With the InvoicesList query open, switch to Design View .

 2.  Click the Criteria cell for the EmpID field.

 3.  Type JFW and tap [Enter].

Access will apply quotation marks indicating this is a literal value.

 4.  Choose Query Tools→Design→Results→Run  to run the query.

The query results now include only records where the EmpID is equal to JFW.

 5.  Close the query and choose No when prompted to save the changes.

Saving changes to the query at this time would save the JFW criteria as part of the query. However, 
you will continue to use the query for all employees.

 

Wildcard Characters
Wildcard characters are used to locate records that have similar but not identical data. They help 
you locate records that match a pattern. For example, you might want to find all customers with last 
names that begin with the letter B or all products that begin with the word Blog.

Tip!
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COMMON WILDCARD CHARACTERS

Wildcard Symbol How It Is Used
Asterisk (*) Substitutes for a group of characters that appear at the position of 

the asterisk

Example: R* in the last name field will locate all last names 
beginning with R regardless of how many characters make up the 
name. In this case, Rogers, Rich, and Rodriquez would all appear in the 
results datasheet.

Question mark (?) Substitutes for a single character that might appear at the position of 
the question mark

Example: m?s will locate records containing values such as mrs, ms, 
and mbs.

Open/close brackets [ ] Matches text or individual characters placed within the brackets 
individually

Example: ca[rt] will find cat and car but not cab or cad.

Search for wildcard characters in Access help for more wildcard symbols and examples.

AND and OR Criteria
In some cases, you may need to locate records that meet multiple criteria. This can be done using AND 
and OR conditions. For example, you may want to locate all records where the employee is web certified 
AND lives in Sarasota. Or you may want to locate all employees who live in Sarasota OR Bradenton.

Create an OR condition by adding a second criterion to the Or row of a field.

Create an AND condition by adding another criterion to a different field on the Criteria row.

View the video “Create a Query with Criteria.”

Tip!
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DEVELOP YOUR SKILLS: A3-D5

In this exercise, you will use wildcards to locate variable data and set multiple criteria in a query to find out 
which customers have gotten blogs and which customers have added more than ten images at a time to 
their websites.

 1.  Open the Invoices Query query in Design View.

 2.  Follow these steps to use wildcard characters and to use AND and OR criteria:

B
A

C

A  In the ProdDescription Criteria cell, type Blog* and tap [Enter].

Access converts Blog* to: Like “Blog*”

B  In the ProdDescription Or cell, type Image* and tap [Enter].

C  Enter > 10 in the Qty Or cell. Be sure to type in the same row as Like “Image*” (the Or row).

These criteria will choose records where ProdDescription begins with Blog OR ProdDescription begins 
with Image AND the Qty is greater than 10.

 3.  Run  the query.

Access displays the records that meet the specified criteria: either a blog or a transaction with more 
than ten images.

 4.  Close the query and save the changes.

Date Criteria
You can set date criteria to determine age, hired date, invoice date, and so forth. Access acknowl-
edges the same comparison criteria for performing date comparisons that it does for locating other 
types of data, regardless of the format used to enter dates.

DATE CRITERIA

Criterion Examples of How Records Are Returned
06/22/2019 Date is 06/22/2019

<22-Oct-2019 Dates that occur before 22/Oct/2019

>01/01/19 Dates that occur after 01/01/19

Between 01/01/19 and 06/30/19 Dates between 01/01/2019 and 06/30/2019

DEVELOP YOUR SKILLS: A3-D6

Winchester Web Design needs to track all invoices issued in 2018. In this exercise, you will query the 
database to locate customers with invoices dated from January 1, 2018, through December 31, 2018.

 1.  Choose Create→Queries→Query Design .

 2.  Use double clicks to add the Customers, Invoices, Invoice Details, and Products tables to  
the query.
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 3.  Close the Show Table dialog box.

 4.  In the Invoices table double-click InvNum and InvDate to add those fields to the query grid.

 5.  From the Customers table add the CustID field.

 6.  From the Invoice Details table add the Qty field.

 7.  From the Products table add the ProdDescription and Price fields.

 8.  Hover your mouse pointer on the right edge of the InvDate column heading so a black, two-
direction arrow appears.

 9.  Click and drag the column heading to the right until the column is about three times the original 
width.

You will enter a long entry in the next step and widening the InvDate column will allow you to see the 
entire entry.

 10.  Click in the Criteria cell for the InvDate field and type: Between January 1, 2018 And 
December 31, 2018

Access formats the expression. Your query grid should now match this example. Regardless of how 
you type the dates—whether January 1, 2018; 01/01/18; or 1-1-2018—Access formats the data after 
you enter it so it appears as #1/1/2018#.

 11.  Run  the query.

Notice that only records with a date in 2018 appear in the results.

 12.  Choose File→Save or click the Save button on the Quick Access toolbar.

 13.  Save the query as Invoices2018 and then close it.

Sorting, Showing, and Limiting Results
The query grid contains a Sort row that lets you sort the query results. At times you may also want 
to use fields to specify criteria but may not want those fields to be displayed in the query results. This 
can be accomplished by unchecking the Show box for the desired field(s).

Limiting the Number of Results Displayed
Large databases with thousands of records often return so many records that it can be challenging to 
find what you are looking for. Limiting the number of records displayed can be beneficial, especially 
when these records are sorted.
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For example, if you set up a query to sort in descending order and then limit the number of items 
displayed to ten, you would, in effect, have a list of the top ten items in the table being queried. The 
Return feature lets you set the number of records to be displayed, or returned, in the query results.

ÝÍ Design→Query Setup→Return 

DEVELOP YOUR SKILLS: A3-D7

In this exercise, you will create a query that sets a sort order and hide a field from displaying in the query 
results. You will also limit the number of records returned.

 1.  Choose Create→Queries→Query Design .

 2.  Use double clicks to add the Customers, Invoices, Invoice Details, and Products tables to the query.

 3.  Close the Show Table dialog box.

 4.  In the Customers table double-click the CustID, CustFirstName, and CustLastName fields to 
add them to the design grid.

 5.  From the Invoices table add the InvDate field.

 6.  From the Products table add the ProdDescription field.

 7.  From the Invoice Details table add the Qty field.

 8.  Follow these steps to set a criterion and set the sort order:

B
A

A  In the ProdDescription Criteria cell, type Image* and tap [Enter]. Access converts Image* 
to Like “Image*”. This criterion will choose only records where the product description begins 
with Image.

B  In the Sort cell for the Qty field, choose Descending from the list of sort options.

 9.  Run  the query.

The records are now sorted in descending order (largest to smallest) by quantity.

CustID is an important key to have in the query because it is a primary key field. But it isn’t needed 
in the query results because it contains the same information that appears in the CustFirstName and 
CustLastName fields, so you will hide it from the query results.

 10.  Choose Home→Views→Design View  to switch back to Design View.

 11.  Uncheck the Show box for the CustID field and Run  the query.

The CustID field is still part of the query design, but it no longer shows in the query results.

 12.  Switch back to Design View and choose Query Tools→Design→Query Setup→ 
Return  menu button �.

 13.  Choose 5 from the list and run the query.

The query returns seven records (not five). This is because the query returns all records with the five 
largest quantities. But three records had a Qty of 14, which is the fifth highest amount, so all those 
records were returned, increasing the total to seven records.

 14.  Save the query as Most Images and then close it.
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Calculated Fields
Calculated fields are fields containing formulas that perform calculations. Formulas used in calcu-
lated fields are often based on other fields within the query. Calculated fields are added as an 
additional field to a query and are not part of the underlying query tables. They are added to the 
query design grid and their calculated results then appear in the query results. A calculated field:

 Ý Creates a new field in a query that can also be used in a form or report

 Ý Can be used to perform mathematical operations, such as addition and multiplication

 Ý Has a name and can be formatted with properties just like a regular field

 Ý Enables you to combine values in two text fields into one field, such as LastName and FirstInitial

 Ý Updates and recalculates each time you run the query

Identifying Parts of a Calculated Field
The structure of a calculated field includes a field name and a mathematical expression. An example 
of a calculated field in an Access query is Wage: 12.00 * 40, where Wage is the calculated field name 
and 12.00 * 40 is the calculation to be performed. Another example is Total: Price * Quantity, where 
Total is the calculated field name and Price * Quantity are the calculations performed using the data 
in those query fields.

The LineTotal calculated field multiplies Price * Qty.

Each calculated field can contain the following elements:

CALCULATED FIELD ELEMENTS

Element Description
Calculated field name This is the unique name you assign to the field and is followed by a 

colon (:) to separate the field name from the expression.

Field names from existing 
tables

Field names from the query can be added to the calculated field 
expression. Access adds brackets [ ] around field names.

Arithmetic or comparison 
operators

Use +, -, *, /, ( ), ^, <, =, and > to perform mathematical operations 
or compare values.

Concatenation (i.e., 
linking together)

An ampersand (&) can be used to join text values from multiple 
fields. For example, FirstName&LastName.

Spaces can be added between fields by using quotation marks 
around a single space (" "). For example, the quotation marks in 
FirstName& " " &LastName create a space between the first and 
last names in the query results.

The query results.
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Calculated Field Properties
You can set field properties such as size, number format, and default values within tables. Likewise, 
you can set field properties in calculated fields. This is almost always needed in calculated fields as 
the query results need to be formatted with the correct number of decimal places, commas, currency 
format, and other formatting as needed. Field properties are set using the field Property Sheet.

ÝÍ Design→Show/Hide→Property Sheet 

DEVELOP YOUR SKILLS: A3-D8

In this exercise, you will create and format a calculated field.

 1.  Open the InvoicesList query and switch to Design View.

 2.  Click in the first cell of the blank column next to the Qty field.

 3.  Type the calculated field expression, taking care to include the colon between LineTotal and Price: 
LineTotal:Price * Qty

 4.  Tap [Enter] to accept the entry and allow Access to format the expression by adding brackets to 
the field names.

Access does not always format your expression by adding brackets to field names. Brackets are 
required for Access to identify the entry as a field within the query. If you want to use field data within 
a calculated field expression, you need to include the name of your calculated field within brackets. In 
this example our calculated field is named LineTotal, and it will multiply the data in the Price field by 
the data in the Qty field in each record when the query is run. Your completed field should match the 
following.

 5.  Right-click anywhere in the column of your calculated field and choose Properties.

The Property Sheet opens.

 6. Click the Format field, then click the menu button � and choose Currency from the list.

 7.  Click the Caption field and type: Line Total

The currency format will display the calculated results with a dollar sign and two decimals. The 
caption will become the column heading for your calculated field in the query results.EVALU
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 8.  Run  the query, and your calculated field results will appear as shown:

 9.  Save and close the query and then close the database.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A3-R1

Create Queries Using Criteria and Wildcards
Kids for Change is planning to fine-tune its database by adding queries that enable it to track activities as 
well as staff/volunteer availability. In this exercise, you will create various queries that will yield the desired 
information.

 1.  Open A3-R1-K4C from your Access Chapter 3 folder and save it as: A3-R1-K4CRev

 2.  Choose Create→Queries→Query Wizard .

 3.  Choose Simple Query Wizard and click OK.

 4.  Add the Activity, Location, Day, and MeetTime fields from the Activities table to the Selected 
Fields list and click Next.

 5.  Name the query Activities List and click Finish.

 6.  Review the query results and then close the query.

Create a Query in Design View
 7.  Choose Create→Queries→Query Design  to start a new query.

 8.  Add the Volunteers table and then close the Show Table dialog box.

 9.  Add the VolLastName, VolFirstName, VolPhone, and VolDay fields to the query design grid 
(in that order).

 10.  Run the query and take a moment to review the results.

Now you will change the field order.

 11.  Switch to Design View .

 12.  Click and drag the VolDay field, dropping it in front of the VolLastName field.

 13.  Run  the query and review the results.

You may notice the field names appear differently from those used in the query grid. Field names in 
queries retain any caption labels previously set in table properties.

 14.  Save the query as Volunteer List and then close the query.
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Create a Multi-Table Query
 15.  Create a new query in Query Design view, add the Activities and Staff tables to the query, and 

then close the Show Table dialog box.

 16.  Move the fields from the indicated tables to the query design grid:

From This Table Add These Fields

Activities • Activity

• Day

• MeetTime

Staff • StaffLastName

• StaffFirstName

• StaffPhone

 17.  Set the Sort option for the Activity field to Ascending.

 18.  Run  the query and view the results.

 19.  Save the query as Activity Staffing List and then close it.

Add Wildcard and AND/OR Criteria to a Query
 20.  Right-click the Activity Staffing List query in the Navigation pane and choose Design View.

You can open a query in Design View using this method or you can run it first and then switch to 
Design View. Remember to try right-clicks if you are having trouble finding commands.

 21.  Create a Saturday or Sunday OR condition in the Day field.

Typing the quotation marks " " isn’t necessary, as Access will add them for you.

 22.  Run the query.

Only activities for Saturday or Sunday should be displayed.

 23.  Switch to Design View and delete Sunday to remove the OR condition.

 24.  Enter 12:00 in the MeetTime Criteria field, tapping [Enter] when finished.

This creates a Saturday AND 12:00 meet-time condition. Access will format the 12:00 condition like 
this: #12:00:00 PM#

 25.  Run the query.

Because both conditions must be met, just one activity meeting (a car wash) should be returned by the 
query.

 26.  Switch to Design View and remove both the Saturday and 12:00 criteria.
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 27.  Type S* in the Criteria cell for the Day field and tap [Enter].

Access recognizes the asterisk * wildcard character and formats the condition as Like “S*”. The query 
will return all records where the name of the day begins with S (Saturday and Sunday) and should 
produce the same results as when you used the Saturday OR Sunday condition earlier in this exercise.

 28.  Run the query and take a moment to observe the results.

 29.  Save the changes and close the query.

Add Date Criteria to a New Query
Now you will create a query that returns the records of the youngest children so you can determine which 
children may need more supervision.

 30.  Create a new query in Design View, adding the Children table and the fields ChildLastName, 
ChildFirstName, and BirthDate.

 31.  Run the query and take a moment to observe the results.

Now you will add a condition.

 32.  Switch to Design View, type >January 1, 2010 in the BirthDate Criteria field, and  
tap [Enter].

Once again Access will apply formatting to the criterion.

 33.  Run the query.

Only records where the child was born after January 1, 2010, should be displayed.

 34.  Choose File→Save or click the Save button on the Quick Access toolbar and save the query as: 
Younger Children

 35.  Close the query and then close the database.

REINFORCE YOUR SKILLS: A3-R2

Limit the Records Returned and Use Calculated Fields
Kids for Change is planning to fine-tune its database further by adding queries that will produce calculated 
results. You are in charge of the IT department. In this exercise, you will generate the desired query results.

 1.  Open A3-R2-K4C from your Access Chapter 3 folder and save it as: A3-R2-K4CRev

 2.  Run (open) the Children List query.

The query returns the records of all children in the database in alphabetical order by last name.

 3.  Switch to Design View and choose Query Tools→Design→Query Setup→ 
Return  menu button �.

 4.  Choose 5 from the list.

 5.  Click in the Sort cell for the BirthDate field and choose Descending.

 6.  Run the query.

Only the records for the five youngest children should be displayed.

 7.  Close the query, saving the changes.EVALU
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Add a Calculated Field and Format the Field
As part of its community give-back policy, Kids for Change puts 10% of all donations into a scholarship 
fund. Now you will add a field that calculates 10% of each donation.

 8.  Run the Donations Query query and take a moment to observe the results.

 9.  Switch to Design View and use the scrollbar at the bottom of the grid to scroll the query grid to 
the right until the first empty column is visible.

You will enter a calculated field in this column.

 10.  Type ScholarFund:Amount*.1 in the first cell (the Field cell) of the empty column, being 
sure to include the colon between ScholarFund and Amount.

 11.  Tap [Enter] to complete the calculated field, and if necessary, widen the column so you can see 
the entire calculated field.

 12.  If the Property Sheet is not open, right-click anywhere in your calculated field column and 
choose Properties.

 13.  Click in the Format field and choose Currency from the drop-down list.

 14.  Type Scholar Fund in the Caption field.

 15.  Run the query and take a moment to ensure that the calculated field is calculating correctly and 
is formatted with the Currency format.

 16.  Close the query, saving the changes, and then close the database.

REINFORCE YOUR SKILLS: A3-R3

Create Select Queries Using Criteria and Calculated Fields
In this exercise, you will help Kids for Change further develop its database by adding queries that will 
produce calculated and formatted results based on specific search criteria.

 1.  Open A3-R3-K4C from your Access Chapter 3 folder and save it as: A3-R3-K4CRev

 2.  Use the Query Wizard to create a simple query using the Donors table and the DonorLName, 
DonorFName, DonorPhone, and DonorEmail fields.

 3.  Use Donor Contact List as the query name and finish the query.

 4.  Review the query results and then close the query.

 5.  Using Query Design, create a new query with the Staff table and the StaffLastName, 
StaffFirstName, StaffStreet, StaffCity, StaffST, and StaffZIP fields.

 6.  Save the query as: Staff Mailing List

 7.  Run the query, review the results, and then close the query.
A

C
C

E
S

S

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



90 Access Chapter 3: Querying a Database

Create a Multi-Table Query
 8.  Create a new query using Query Design view and add the Activities and Children tables to the 

design grid.

 9.  Move the fields from the indicated tables to the query design grid:

From This Table Add These Fields

Activities • Activity

• Day

• MeetTime

Children • ChildLastName

• ChildFirstName

• ChildPhone

 10.  Save the query as: Participant List

 11.  Run the query and review the results.

Add Criteria Including Wildcards and Dates
Now you will add criteria to the Participant List query to list the children signed up for 9:00 AM Saturday 
activities.

 12.  Switch to Design View.

 13.  Create an AND condition by setting Saturday as a criterion in the Day field and 9:00 as a 
criterion in the MeetTime field.

 14.  Run the query.

The only records returned are those where the day is Saturday AND the meet time is 9:00.

 15.  Close the query, saving the changes.

Now you will use a wildcard to select nearby donors so they can be invited to local activities.

 16.  Right-click the Donations Query query in the Navigation pane and choose Design View.

 17.  If necessary, scroll right through the field list until you locate the DonorZIP field.

 18.  Enter 34* in the DonorZIP Criteria field.

The asterisk is a wildcard character.

 19.  Run the query.

Only records where the ZIP code begins with 34 are returned by the query.

 20.  Switch to Design View and remove the criteria from the DonorZIP field.

 21.  Enter >01/01/2018 in the DonationDate Criteria field.

 22.  Run the query and review the results.

Sort and Limit Query Results
 23.  Switch to Design View.

 24.  Set the DonationDate field to sort in Descending order.EVALU
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 25.  Use the Query Tools→Design→Query Setup→Return  menu button � list to limit the 
records returned to 5.

 26.  Run the query and review the results.

Add a Calculated Field and Format the Field
 27.  Switch to Design View and set the Return number back to All.

 28.  Create a calculated field by entering NetAmt:Amount-ScholarFund in the first empty 
column’s Field row.

 29.  Right-click in the new calculated field column and open the Property Sheet.

 30.  Set the Format to Currency and type Net Donation as the Caption.

 31.  Run the query and review the results.

 32.  Close the query, saving the changes, and then close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A3-A1

Create Queries Using Criteria and Wildcards
The new CEO of Universal Corporate Events has asked you to refine a number of queries to be more 
selective in data output. In this exercise, you will create queries; add criteria, wildcards, and AND/OR 
conditions to a query; and add date criteria to a query.

 1.  Open A3-A1-UCE from your Access Chapter 3 folder and save it as: A3-A1-UCERev

 2.  Use the Query Wizard and this table to create a simple select query:

Table to Use Fields to Add Query Name
Personnel • PerLastName

• PerFirstName

• PerPhone

• PerEmail

Personnel Contact List

 3.  Review the results and then close the query.

 4.  Create a query in Design View that uses the tables and fields indicated:

From This Table Use These Fields

Events • EventName

Schedules • VenueID

• ContactID

• EventDate

• Guests

Menus • MenuPlan

• Chg/PP

 5.  Run the query and review the results.

 6.  Save the query as Event List and then close it.

Use Wildcards and AND/OR Criteria
UCE is planning a recruiting event in Sarasota and would like to contact employees from greater Sarasota 
(area code 941) to involve them in the planning. You will modify a query to return the records of personnel 
who live in the Sarasota area.

 7.  Open the Personnel Contact List query in Design View.

 8.  Enter the wildcard text *941* in the PerPhone Criteria field.

 9.  Run the query and verify that each telephone number in the query results contains 941 some-
where in the number.

 10.  Close the query, saving the changes.
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 11.  Create a new query in Design View from the Venues table that includes the VenueName, 
VenueCity, VenuePhone, and VenueWebSite fields.

 12.  Enter Sarasota in the VenueCity Criteria field and Tampa in the Or row of the VenueCity field.

 13.  Run the query and verify that the city is Sarasota or Tampa in each record.

 14.  Save the query as Tampa-Sarasota Venues and then close it.

Add Date Criteria
 15.  Run the Event List query and notice the range of dates.

 16.  Switch to Design View and type >May 1, 2019 in the EventDate Criteria field.

 17.  Sort the query in Ascending order on the EventDate field.

 18.  Run the query and make sure it produces the intended results.

 19.  Close the query, saving the changes, and then close the database.

APPLY YOUR SKILLS: A3-A2

Limit the Records Returned and Use Calculated Fields
You’ve been asked to improve Universal Corporate Events’ data retrieval and formatting. In this exercise, 
you will sort and limit records returned in query results and create a query using a calculated field.

 1.  Open A3-A2-UCE from your Access Chapter 3 folder and save it as: A3-A2-UCERev

 2.  Run the Event Revenue query and review the results.

 3.  Switch to Design View and set the sort order of the TotalRev calculated field to Descending.

 4.  Set the Return number to 5 to limit the number of records returned by the query to the top five.

 5.  Run the query and review the results.

 6.  Switch to Design View and change the Return value back to All.

Add a Calculated Field and Format the Field
 7.  Create a new calculated field using the name and the expression: Comm:TotalRev*.08

 8.  Open the Property Sheet for the new calculated field and set the Format to Currency and use 
Commission as the Caption.

 9.  Run the query and review the results.

 10.  Close the query, saving the changes, and then close the database.
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APPLY YOUR SKILLS: A3-A3

Create Select Queries Using Criteria and Calculated Fields
In this exercise, you will create and modify a number of queries for more precise, targeted data selection 
for Universal Corporate Events.

 1.  Open A3-A3-UCE from your Access Chapter 3 folder and save it as: A3-A3-UCERev

To begin, you will create a query to list contact information for the event venues that have an 800 
telephone number so they can be reached by phone at no charge to the caller.

 2.  Create a simple query named TollFreeVenues that uses the Venues table to generate a list 
of venue names and their corresponding phone numbers and websites.

 3.  In Design View, add the wildcard text *800* to the Criteria row to return only records for 
which the venue phone number includes 800.

 4.  Run the query and resize the columns in the query results so all data is visible.

 5.  Close the query, saving the changes.

Add Wildcard and Date Criteria and Sort the Query
Because June is the most popular month for weddings, UCE wants to pay special attention to weddings 
scheduled for June so they can hire extra part-time workers.

 6.  Using the Query Wizard, create a simple query that uses all fields from the Event List query.

 7.  Leave the Wizard’s Detail or Summary option set to Detail.

 8.  Name the query June Weddings and finish the query.

 9.  Switch to Design View.

 10.  Add the wildcard text Wed* (for Weddings) to the EventName Criteria field.

 11.  Set the sort order of the EventDate field to Ascending.

 12.  In the EventDate Criteria field, enter: Between June 1, 2019 And June 30, 2019 

 13.  Run the query and review the results.

 14.  Close the query, saving the changes.

Limit the Number of Records in Query Results
Now you will sort the Location Scheduling query by the largest number of guests and return the ten 
highest values so the company can focus extra personnel and resources to those events if the guests are 
scheduled for a full menu plan.

 15.  Display the Location Scheduling query in Design View.

 16.  Sort the query in Descending order by Guests.

 17.  Set the number of records returned to: 10

You’ll need to click in the Return cell and type 10. If Access changes the 10 to 100, delete the extra 
zero (0).

 18.  Run the query and review the results.

 19.  Close the query, saving the changes.
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Add and Format Calculated Fields
Now you will add a calculated field that subtracts the venue contact’s commission from the total revenue 
to result in a net revenue amount.

 20.  Display the Event Revenue query in Design View.

 21.  Add a calculated field named NetRev that subtracts Comm from TotalRev.

 22.  Format the new field as Currency and set the Caption as: Net Revenue

 23.  Add a criterion to the TotalRev field to choose only records where the TotalRev is greater  
than 3000.

 24.  Run the query and review the results.

 25.  Close the query, saving the changes, and then close the database.
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  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROjECT gRADER: A3-P1

Taylor Games: Creating Queries
Taylor Games wants to evaluate where levels of inventory are too high. You will use the inventory data to 
create several queries, leverage wildcard characters, and add a calculated field.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A3_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A3_P1_Start from your Access Chapter 3 folder.

 2. Use Query Design to create a simple query using the following guidelines:

• Add all fields from the Inventory table in the same sequence as they appear in the table.

• Set the criteria to include all records where (Quantity is greater than 75) AND (Total Cost is 
greater than 250).

• Save the query as Overstock and run it.

 

 3. Add criteria to the Overstock query so that the query logic now becomes (Quantity is greater 
than 75 AND Total Cost is greater than 250) OR (Item contains the word dice AND Quantity is 
greater than 75) and then run the query.

 4. Add a calculated field named Overstock Qty that subtracts 75 from the Quantity field in 
each record.

 5. Sort the query results on the Overstock Qty field in descending order.

 6. Save and close the query.

 7. Save your database.

• Using eLab: Save it to your Access Chapter 3 folder as A3_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 3 folder as: A3_P1_Submission
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PROjECT gRADER: A3-P2

WebVision: Querying a Database
WebVision would like to create a monthly query that will calculate the Sales Rep commissions for each 
order. You will use the data in multiple tables to create a select query and add a calculated field.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A3_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A3_P2_Start from your Access Chapter 3 folder.

 2. Use the Query Wizard to create a simple query using the following guidelines: 

• Add the RepID, LastName, and SalesTeam fields from the Sales Reps table in that 
sequence.

• Add the OrderID, Date, and Amount fields from the Orders table in that sequence.

• Use the Detail option.

• Name the query: June Commissions

 3. Set the Date criteria to include records between 6/1/2019 And 6/30/2019.

 4. Sort the query results on the RepID field in Ascending order.

 5. Add a calculated field named Commissions that multiplies the Amount field in each record 
by: 0.02

 6. Apply the Currency number format to the Commissions field and then run, save, and close the 
query.

 7. Save your database.

• Using eLab: Save it to your Access Chapter 3 folder as A3_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 3 folder as: A3_P2_Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A3-E1 That’s the Way I See It
Blue Jean Landscaping needs queries to better manage its customer and equipment lists and you’ve 
volunteered to assist. Open A3-E1-BJL and save it as: A3-E1-BJLRev

Create a query named 813 Area Code that uses all fields from the Customers table. The query 
should return only customers with a phone area code of 813 sorted in ascending order by city. Create 
another query named Equipment Value that uses all fields from the Equipment table. Use a 
calculated field named EquipValue to determine the total value of equipment by multiplying the 
Cost by the quantity In Stock. Sort the results with the largest Equipment Values appearing first and 
format the EquipValue field using the Currency format.

A3-E2 Be Your Own Boss
Blue Jean Landscaping wants to devise more targeted data retrieval. Open A3-E2-BJL and save it 
as: A3-E2-BJLRev

Create a query that returns a contact list for BJL’s customers sorted by last name. Create another 
query that creates a customer mailing list sorted by ZIP code. Use a wildcard to select only records 
where the ZIP code begins with 33. Add a calculated field to the Sales Invoices query that multiplies 
Cost by Qty Sold to produce a total. Format the new field as Currency and assign it a caption. Finally, 
limit the number of records returned to the largest five invoice totals, so those customers can be 
targeted for preferred customer offers.

A3-E3 Demonstrate Proficiency
You’ve been asked by the management at Stormy BBQ to query its database. Open A3-E3- 
StormyBBQ and save it as: A3-E3-StormyBBQRev

Create a query that uses data from the DailyReceipts table and determines the total revenue 
received for each item using the ItemPrice and QtySold fields. Include all fields from the table in  
the query and sort in descending order on the field that is used to perform the daily total calcula-
tions. Create another query using the Merchandise table that contains all fields from the Merchan-
dise table and a sequence of calculated fields. For each item, the calculated fields should determine 
the Stock Cost of that item (Cost * Stock), the List Price Revenue if all items were sold at list price 
(Listprice * Stock), and the Profit, which is the difference between the revenue and cost.



EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



L E A R N I N G  O B J E C T I V E S

ÝÝ Create basic reports using the Report tool

ÝÝ Create reports with the Report Wizard

ÝÝ Change field alignment and size in Layout View

ÝÝ Change field properties

ÝÝ Insert logos and dates

ÝÝ Insert new fields

4 Using Reports to 
Display Information

ACCESS

A
lthough reports can summarize 

data from a single database 

table, they often present specific 

data from multiple tables or from queries 

based on multiple tables. Both forms 

and reports use many of the same tools 

and techniques to organize and present 

information in a readable format. In this 

chapter, you will create reports to organize 

and summarize data into meaningful 

information.
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Ý Project: Turning Data into Information with Reports
Forms are great for entering data and displaying single records. Most businesses, however, 
want to filter and summarize data, as well as display specific data, such as running totals, in 
a readable format. Winchester Web Design needs a new report to summarize the sales for 
each employee and display sales totals. As its database manager, you have agreed to create a 
report to meet these needs.

Introducing Reports
Because reports are often presented in a readable format and end up as a printout, there are some 
basics that every report should include. Of course, it should be well organized, look professional, and 
be visually appealing. Imagine finding a report on your desk without a date, page numbers, or a title 
that states what it is for. How might this affect the usability and readability of the data?

Most reports should have both a title and a subtitle. The title may simply be the company name. The 
subtitle should state specifically what the report is for, such as Monthly Income or Product List. Every 
report requires a date and should include the page number, even if the report is only one page. Once 
you have a good handle on the who, what, and when, you will be ready to create your first report.

Basic Reports
Use the Report button to instantly create a basic report for a selected table or query. This is the 
easiest way to create a report using all fields from the table or query. Only one table or query can be 
used in a basic report.

ÝÍ Create→Reports→Report 

DEVELOP YOUR SKILLS: A4-D1

In this exercise, you will create and explore a basic report and then apply a multiple column format to that 
report.

 1.  Open A4-D1-WinDesign from your Access Chapter 4 folder and save it as: 
A4-D1-WinDesignRev

Click the Enable Content button, if it appears.

 2.  Choose the Products table in the Navigation pane.

 3.  Choose Create→Reports→Report .

A basic report is displayed in Layout View. In Layout View you can easily move and size report objects.

 4.  Close any boxes that may be open, such as the Property Sheet or Field List pane.

 5.  Choose Home→Views→View menu button �→Report View .

Report View is best when viewing how a report will be presented electronically.
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 6.  Choose Home→Views→View menu button �→Design View .

The report body contains sections populated with text labels and controls that display the date, time, 
and other data and that perform calculations.

 7.  Mouse over the report control tools in the Controls group of the Ribbon, reviewing the ToolTips 
that appear.

Apply Multiple Columns
 8.  Choose Home→Views→View menu button �→Print Preview  to see how your report 

will look when printed.

 9.  Choose Print Preview→Page Layout→Landscape  and then click the Columns  button.

The Page Setup dialog box appears with the Columns tab active.

 10.  Set the Number of Columns property to 2 and the Width property under Column Size to 4.5 
and then click OK.

The report is now formatted to print records into two even columns.

 11.  Click Close Print Preview  on the right side of the Ribbon.

 12.  Choose File→Save or click the Save button on the Quick Access toolbar and save the report as: 
Products

 13.  Close the report.

Report Organization and Structure
Reports can display data from multiple tables and even from queries. Report data must often be grouped 
and sorted so it can be easily analyzed and interpreted. Effective reports turn data into information by 
displaying it in an organized and understandable manner. Queries are often the best data source for 
reports as they can receive data from multiple tables, sort the data, and even include calculated fields.

Sections
Sections provide the structure needed to effectively organize and present information. There are 
several types of sections, with each type used for a specific purpose.
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REPORT SECTIONS

Section(s) Description
Report Header and Footer Displayed only at the top of the first page and bottom of the last 

page. Some uses include titles, subtitles, and logos.

Page Header and Footer Displayed at the top and bottom of every page. Some uses 
include descriptive labels, page numbers, and dates.

Group Header and Group 
Footer

The group header shows the fields on which report data is 
grouped. For example, grouping by Salesperson might list each 
salesperson and all the transactions that person is responsible for. 
The group footer displays summary information such as the total 
of all transactions for each salesperson.

Detail Main part of the report where the records are displayed. The 
records are typically organized in groups. The detail sections are 
where field headings appear.

The Report Header appears at the top of the report.

This image shows a report in Layout View with the various sections highlighted.

Group headers show the records 
grouped first by employee ID and 
then by invoice number.

Detail sections show headings, records, 
and, in this case, a LineTotal column 
calculated from the underlying query.

Group footers show 
totals for invoice 
numbers 29 and 30.

The group footer for 
employee ID MJW 
adds the group totals 
for all invoices with 
an EmpID of MJW 
(some not shown here).

The Grand Total line appears in the 
report footer and adds all group 
totals (some not shown here).EVALU
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Grouping and Sorting
A group is a collection of records that has at least one data element or key field in common. In the 
preceding example, records are grouped first by employee ID MJW and then by invoice numbers 
29 and 30. A group consists of a header, records, and a footer. Grouping helps organize the informa-
tion in meaningful ways. Groups are arranged by level. Each nested group (lower level) will appear 
indented below the group above it (higher level), so you can visualize how groups are prioritized.

Once grouping has been set, summary options become available. Summary options allow users to 
summarize a group with calculated values such as a total, average, maximum, or minimum value. 
These calculations are based on the remaining ungrouped fields whose data contains a numeric value.

It is important that records first be sorted using the same field used for grouping. Otherwise, a new 
group might be created each time the data in the group changes. Sorting can be added in the report; 
however, it’s best to make the sorting occur in the underlying tables or queries.

The Report Wizard
The Report Wizard is a great way to get started with most reports. It lets you choose multiple tables 
or queries, group and sort data, perform calculations, and organize and present the information. The 
Wizard builds the report for you, creating the necessary structure and organization.

View the video “Grouping and Sorting in the Report Wizard.”

ÝÍ Create→Reports→Report Wizard 

DEVELOP YOUR SKILLS: A4-D2

In this exercise, you will create a detailed Invoice report using the Report Wizard.

 1.  Choose the Invoice Details Query Q1 2018 query in the Navigation pane.

 2.  Choose Create→Reports→Report Wizard .

Invoice Details Query Q1 2018 is chosen in the Tables/Queries list because you chose it before starting 
the Report Wizard.

 3.  Double-click the EmpID field to add it to the Selected Fields list or choose it and click the  
Add  button.

 4.  Add the InvNum, InvDate, CustLastName, ProdID, Price, Qty, and LineTotal fields to the 
Selected Fields list.

Do not select CustFirstName and ProdDescription. If you add every field to the report, there won’t 
be enough room to display all the information. Be sure that EmpID is the first field on the list.

 5.  Click Next, and the Wizard will ask if you want to add grouping levels.

 6.  With EmpID still selected, click the Add  button to set EmpID as the first grouping level.

All invoices associated with a particular employee will be grouped together.

 7.  Click Add  once more, this time to make the InvNum field the second grouping level.

The information will first be grouped by employee ID and then within each employee group by invoice 
number.
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 8.  Click Next, and the sort order and summary information screen will appear.

This is where you can add totals and other calculations and sort the results within groups. The 
underlying query sorts the invoices in ascending order, so it isn’t necessary to add sorting in this report.

 9.  Click the Summary Options button in the lower part of the dialog box.

Price, Qty, and LineTotal are numeric fields, so they can be used to create totals as well as average, 
minimum, or maximum values.

 10.  Check the Sum box for the LineTotal field.

This will sum the invoices associated with each employee ID.

 11.  Leave the other settings as they are and click OK.

 12.  Click Next because sorting isn’t needed.

 13.  Choose Outline for the layout type and Landscape for the orientation.

 14.  Leave the Adjust the Field Width box checked and click Next.

 15.  Name the report Invoice Details Report Q1 2018 and click Finish.

Your report displays in Print Preview, showing invoice totals and summary totals for each employee.

 16.  Take a moment to review the report using the page controls at the bottom of the screen (there should 
be ten pages, including unnecessary extras resulting from the width of the summary totals control).

The Report Wizard provides a great starting point; however, the report needs some formatting and 
layout work.

 17.  Click the Close Print Preview button on the right side of the Ribbon.

The report will display in Design View.
 

Modifying Reports
Reports can be created from scratch using Design View, but the Report Wizard is much easier to use 
and far more efficient. And while the Report Wizard provides a great starting point, it’s often neces-
sary to add, delete, move, or resize fields and to enhance a report in other ways such as adding titles 
and a company logo. These and other enhancements can be done using Layout View or Design View.

Layout View allows controls to be moved and sized while viewing how the report will look when 
printed. Design View gives you a detailed view of the report to allow design changes to individual 
controls, sections, and report structure without affecting the underlying data.

View the video “Modify Reports in Layout View.”

View the video “Modify Reports in Design View.”EVALU
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Controls
Controls determine where field data, titles, headings, images, and other information are precisely 
positioned within report sections. There are three types of controls used in reports.

TYPES OF CONTROLS

Control Type Description
Bound Controls that display data from the table or query

Unbound Objects that enhance the appearance of a report, such as labels, titles, lines, 
and images

Calculated Controls that display calculated fields from queries or that perform 
calculations within the report itself 

Here are the controls available on the Design tab of the Ribbon.

Adding Fields to a Report
Sometimes fields need to be added to an existing report. The Existing Fields tool displays a list of 
tables and their fields. Fields are added to the report in Design View by dragging them from the 
Field List pane into report sections. Adding a field creates a text box control where the field data is 
displayed and a label control that contains the field name. The label can be changed, allowing you to 
be creative with the field names displayed on the report.

ÝÍ Report Design Tools→Design→Tools→Add Existing Fields 

DEVELOP YOUR SKILLS: A4-D3

In this exercise, you will delete unneeded controls, add controls, and rearrange and resize controls to 
produce a more attractive, well-balanced report.

 1.  If necessary, open Invoice Details Report Q1 2018.

 2.  Switch to Layout View .

Layout View lets you easily move controls and adjust their sizes while seeing how the report will look 
when printed.

 3.  Close any open boxes, such as the Property Sheet or Field List pane.
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 4.  Follow these steps to delete and rearrange the invoice number summary controls: 

B

A

C

D

A Click the Summary for ‘InvNum’ control and tap [Delete] to remove it.

B Click the Sum label and then tap or hold the right arrow [¡] to move it across the report 
next to the Total text box.

C With the Sum label still selected, press the [Ctrl] key and click the Total text box. Both con-
trols should be selected.

D Tap the up arrow [£] three times to move the controls up.

This section of the report should now look like this.

 5.  Follow these steps to rearrange the EmpID field controls:

B

A

C

A Scroll down to the Summary for ‘EmpID’ control, click to select it, and then tap [Delete] to 
remove it.

B Scroll down, click the Sum label, and tap the right arrow [¡] multiple times until the Sum 
label aligns with the Sum and Qty controls above it.

C With the Sum label selected, press [Ctrl], click the Total text box, and then tap the up arrow [£] 
three times to move the controls up.EVALU
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 6.  Follow these steps to change the width and alignment of the Price controls:

A

B

A Click any Price label and then press [Ctrl] and click any price text box to select all price 
labels and text boxes.

B Right-click the selected controls and choose Properties at the bottom of the menu.

 7.  Set the Width property to: 0.8

The setting won’t take effect until you tap [Enter] or click in another box.

 8.  Set the Left property to 6.625 and tap [Enter] so you can see the change take effect.

The Left property determines the position from the left side of the page. 

Change the Width of a Control and the Overall Report
Now you will work in Design View as you adjust the width of the page numbering control located in the 
Page Footer section.

 9.  Switch to Design View .

 10.  Click the ="Page" numbering control in the page footer section.

You may need to move the Property Sheet box to be able to see the control. This control determines 
how page numbers appear in the report, including their position within the page footer.

 11.  With the Property Sheet box visible, set the Width property to 2 and tap [Enter] to see the change.

Now you will change a width setting for the entire report.

 12.  Follow these steps to change the report width :

B

A

A Click the Selection Type button in the Property Sheet box and choose Report.

B Set the width to: 9

You are now viewing the properties for the report rather than for individual controls. The overall 
report width will now be 9", although this won’t be readily visible in Design View.
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Add a Control
Now you will add the Product Description control to the report and reposition it and its label.

 13.  Choose Report Design Tools→Design→Tools→Add Existing Fields .

This tool lets you add new fields to reports.

 14.  Follow these steps to add the ProdDescription field and to move its label:

A

C

B

A Drag the ProdDescription field from the Field List pane between the ProdID and Price fields 
in the Detail section.

B Select the new Description label (it will be hard to see) then right-click the selected label 
and choose Cut from the menu.

C Right-click InvNum Header and choose Paste.

This pastes the field label in the header section. You will move it in the next step.

 15.  Follow these steps to reposition the fields:

A

B

A Drag the Description label between the ProdID and Price labels in InvNum Header.

B Use the arrow keys to position the Description label and ProdDescription field so they are 
left-aligned with each other and roughly centered between the ProdID and Price fields.

 16.  Close the Field List pane and switch to Layout View.

 17.  Click the Save button on the Quick Access toolbar to save your changes.

At this point, the top part of the report should closely match this example. You will continue to 
enhance the appearance of this report.
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Header and Footer Objects
The Header/Footer group on the Design tab lets you easily add page numbers, titles, the date and 
time, and logos while working in Design View. Logos are especially useful because they can make 
reports look more professional and visually appealing. When a new report is created, a title control 
is generated based on the name of the report, so the Title tool is often used to add subtitles.

DEVELOP YOUR SKILLS: A4-D4

In this exercise, you will enhance the report header by adding a subtitle, logo, and the date and time. You 
will also format these controls.

 1.  Switch to Design View .

The first thing you will do is increase the height of the header area to accommodate a logo and 
subtitle.

 2.  Right-click the Report Header section bar and choose Properties.

 3.  Set the Height property to: 0.9

Format the Title and Subtitle
 4.  Click in the existing title control, Invoice Details Report Q1 2018, and replace the text with: 

Winchester Web Design

 5.  Set these properties for the title control:

Property Setting

Width 3.5

Font Size 22

Text Align Center

Font Weight Bold

 6.  Choose Report Design Tools→Design→Header/Footer→Title .

The report name appears in the new title control, which is placed on top of the existing title.

 7.  Drag the new subtitle control so it is left-aligned with and just below the Winchester Web Design 
title.

 8.  Replace the text in the new subtitle control with: Invoices for Q1 2018
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 9.  Set these properties for the subtitle control:

Property Setting

Width 3.5

Height 0.35

Special Effect Shadowed

Text Align Center

Font Weight Bold

Insert a Logo
 10.  Choose Report Design Tools→Design→Header/Footer→Logo .

The Insert Picture dialog box opens, prompting you to insert an image file.

 11.  Navigate to your Access Chapter 4 folder, choose WWD-Logo.bmp, and click OK.

Access places the logo in the upper-left corner of the Report Header section.

 12.  Set the Left property of the logo to: 4

The logo moves over to the 4" position.

 13.  Set both the Width and Height properties to: 0.8

Add the Date and Time and Review the Report
 14.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 15.  Follow these steps to insert a date control into the header:

A

B

C

A Choose the mm/dd/yyyy date format (the third format).

B Uncheck the Include Time checkbox.

C Click OK.

The date is inserted at the right edge of the header.

 16.  Switch to Report View and review your report header.
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Formatting Controls
It is important to ensure that the data values are fully displayed in a report, while at the same time 
taking care not to leave unsightly and unnecessary blank space between columns. To accomplish this, 
you must resize, reposition, and align controls. It is best to adjust controls in Layout View because 
you can see the actual field values while making the adjustments. Multiple controls can be formatted 
simultaneously after you select them. You will need to use the [Ctrl] key when selecting any nonadja-
cent controls.

DEVELOP YOUR SKILLS: A4-D5

In this exercise, you will use both Design View and Layout View to resize, reposition, and align report 
controls.

 1.  Switch to Design View in the Invoice Details Report Q1 2018 report.

 2.  Click the vertical ruler to the left of the InvNum label and text box in InvNum Header, as shown 
here, to select both of them.

You can also click one field and hold down [Ctrl] while clicking the other.

 3.  Tap the up arrow [£] five times to nudge the controls up closer to the InvNum Header.

 4.  Select the remaining controls in the InvNum Header section, as shown here, and tap the up 
arrow [£] five times to nudge them up.

 5.  Position the mouse pointer over the top edge of the Detail section bar until your pointer 
becomes a two-headed arrow.

 6.  Click and drag with the mouse upward until the section bar is just below the controls you moved 
previously.

 7.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 8.  Select the EmpID label and text box in the EmpID Header section.
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 9.  Set the Top property for these controls to: 0

This will move them up so they are just below the EmpID Header section bar. You can move controls 
by setting properties, using the arrow keys, or dragging. Setting properties is a way to position them 
with precision.

 10.  Click EmpID Header, and it will turn black to indicate it is selected.

 11.  Set the height to: 0.33

Access sometimes changes a precise property value that you type, so don’t worry if your Height 
property differs slightly from 0.33.

 12.  Switch to Layout View.

 13.  Click one of the text boxes in the Description column to select all the fields and then drag left to 
widen the column almost to the ProdID column.

 14.  Select the Last Name boxes and drag left to shorten the boxes as shown.

 15.  Press [Ctrl] and click the Last Name label to select the label with all the text boxes.

In the next step, you will nudge the boxes to the right. Sometimes while moving a group of controls in 
Layout View, the screen scrolls down to the end. If this occurs, just keep nudging until you are finished 
and then scroll back up to the top of the report.

 16.  Tap the right arrow [¡] eight times to nudge the text boxes to the right.

 17.  Select the ProdID label and one of the text boxes below it and then nudge the entire selection 
to the left six times.

 18.  Scroll to the top of the report, click the InvNum text box with 20 in it, and then drag the left 
border to the right to shorten the box as shown.EVALU
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 19.  Tap the left arrow [¢] enough times to position the text box closer to the InvNum label.

 20.  Scroll to the bottom of the report until the Sum controls are visible.

 21.  Use [Ctrl] to select the two Sum text boxes and the Grand Total text box.

 22.  In the Property Sheet, set the Format property to Currency.

When you apply formatting, the fields may no longer fit in the text box. When a value is too large for 
the text box, it fills the box with the # symbol.

 23.  With the controls still selected, press [Ctrl] and click one of the unselected LineTotal text boxes 
in the column so all line total boxes are selected.

 24.  Now drag the right border of one of the controls to the right until the Grand Total is fully visible.

 25.  Switch to Print Preview view to see how your report will look when printed.

 26.  Close Print Preview. Feel free to return to Design View or Layout View to make additional 
adjustments to the report.

 27.  Save the report.
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Themes
Themes in a report function identically to themes in forms, including any steps taken to apply and 
modify them. Don’t forget that when a theme is applied in any object, the applied theme impacts all 
objects in the database.

ÝÍ Report Design Tools→Design→Themes→Themes 

Backgrounds
Backgrounds are images in a report or form that add a visual element beyond applying a basic back 
color in report sections. Backgrounds appear behind form controls and include additional settings for 
size, alignment, and mode. Using the Background Image command in the Background group on the 
Ribbon allows you to select the image of your choosing to be inserted as a background image.

ÝÍ Report Design Tools→Format→Background→Background Image 

DEVELOP YOUR SKILLS: A4-D6

In this exercise, you will apply a theme and insert a background image into your report.

 1.  Switch to Design View and choose Report Design Tools→Design→Themes→Themes .

 2.  Hover over each theme’s thumbnail and take note of the ToolTips that appear to show the theme 
names, then choose Office theme to apply it to the report.

 3.  Choose Report Design Tools→Format→Background→Background Image  menu 
button �→Browse.

The Insert Picture dialog box appears.

 4.  Navigate to your Access Chapter 4 folder, select the file named WWD-Background.jpg, and 
click OK.

 5.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 6.  If necessary, click the Selection Type button in the Property Sheet box and choose Report.

 7.  Set the Picture Size Mode property to Stretch so the inserted image spans the entire report page 
background.

When setting the property for a background image, be sure to evaluate the size and format of the image 
file being inserted. Smaller images may need to be tiled or stretched to fill the report page.

 8.  Switch to Print Preview to see your finished report.

 9.  Choose File→Close to close the database, saving the changes to your report.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Tip!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A4-R1

Create and Modify a Report
The president of Kids for Change wants a report that lists financial donations the organization has received 
since its inception, grouped by donor. He also wants to list the amount that Kids for Change is depositing 
into its scholarship fund for local high-school students. In this exercise, you will create a basic donations 
report and create a more customized report. Then you will rearrange, resize, and format controls and also 
add a logo and title.

 1.  Start Access, open A4-R1-K4C from your Access Chapter 4 folder, and save it as: 
A4-R1-K4CRev

 2.  Choose the Donations table in the Navigation pane.

 3.  Choose Create→Reports→Report .

 4.  Take a moment to review the report and then close it, saving it as: Quick Donations List

Create a Report Using the Report Wizard
Now you will create a donations report that is grouped by donor IDs and includes donation totals.

 5.  Choose Donations Query in the Navigation pane and then choose Create→Reports→ 
Report Wizard .

 6.  Add DonorID, DonorLName, DonorFName, DonationDate, and Amount to the Selected 
Fields list and click Next.

The next Wizard screen asks how you want to view your data. This screen appears because the query 
uses two tables and the Wizard wants to know which table will be used for the first grouping level.

 7.  Choose By Donations and click Next.

 8.  Choose DonorID as the grouping field and add it to the grouping area.

 9.  Click Next and then click the Summary Options button.

 10.  Check the Sum box for the Amount field and click OK to add a sum calculation for that field; 
click Next.

 11.  Choose Block for the layout and Landscape for the orientation; click Next to display the final 
Wizard screen.

 12.  Enter Donations Report 2017-2018 as the title and click Finish.

 13.  Review both report pages and then close Print Preview.

You will continue to use this report.
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Add, Delete, and Edit Report Controls
 14.  In Design View, open the Property Sheet, if necessary.

In the next few steps you will select and format text boxes that display field data and the labels for 
those text boxes. The text boxes are located in the Detail section, while their labels are located in the 
Page Header section.

Labels

Text boxes

 15.  Click the DonorID text box and set the width to: 0.5

 16.  Use [Ctrl] to select the DonorLName and DonorFName text boxes and set the Width property 
to 1 and apply it to both controls.

 17.  Select the Last Name label in the Page Header section and the DonorLName text box in the 
Detail section and set their left properties to: 1.5

 18.  Select the First Name label in the Page Header section and the DonorFName text box in the 
Detail section and set their left properties to: 3

 19.  If necessary, scroll to the right of the report grid to see the other controls. Then set the left  
properties for the controls listed as indicated:

Control Location Left Property

Date label Page Header 5

DonationDate text box Detail 4.5

Amount label Page Header 6.2

 20.  Select the Amount text box in the Detail section and both =Sum(Amount) controls located in 
the DonorID footer and in the report footer.

 21.  Set the width to 1 and the left property to 6 for each of the three controls.

Add a New Field and Format It
 22.  Choose Report Design Tools→Design→Tools→Add Existing Fields  to open the Field 

List pane.

 23.  Drag ScholarFund from the Field List pane and drop it to the right of the Amount text box in the 
Detail section.

The corresponding Scholar Fund label is partly on top of the Amount text box. 

 24.  Click the Scholar Fund label and tap [Delete] to remove it.

Next you will use the Label control tool to insert a new label in the Page Header for the Scholar Fund.

 25.  Choose Report Design Tools→Design→Controls→Label .

 26.  Drag the Page Header section above the ScholarFund text box to create a rectangular label box.

 27.  Type Scholarship into the new label, adjusting the size of the label box as necessary.

 28.  Close the Field List pane and then scroll to the left in the design grid.

 29.  Click the long Summary for “ & ”‘DonorID’… control in the DonorID Footer section.
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 30.  Tap [Delete] to remove the control.

 31.  Click in the Sum label located in the DonorID Footer and replace the label text Sum with: 
Donor ID Total

 32.  Select the title in the report header section and replace it with: Kids for Change

Add a Logo and a New Title
 33.  Choose Report Design Tools→Design→Header/Footer→Logo , navigate to your Access 

Chapter 4 folder and choose K4C-Logo.bmp, and click OK.

 34.  Set the width and height of the logo to: 0.7

 35.  Drag the logo toward the right side of the header so it is positioned above the Amount fields.

 36.  Choose Report Design Tools→Design→Header/Footer→Title .

 37.  Drag the new title to the left and position it below the Kids for Change title.

 38.  Switch to Report View to see how your report looks and then, if necessary, switch back to 
Design View and make the desired adjustments to your report.

 39.  Close the database, saving the changes to your report.

REINFORCE YOUR SKILLS: A4-R2

Use Controls and Apply a Theme
In this exercise, you will size, align, and format report controls, apply a theme, and add the date to the 
Page Header.

 1.  Open A4-R2-K4C from your Access Chapter 4 folder and save it as: A4-R2-K4CRev

 2.  Double-click the Donations Report 2017-2018.

The report has some alignment problems, and the formatting of controls is inconsistent.

 3.  Switch to Design View and open the Property Sheet, if necessary.

 4.  Select the two titles in the report header section and set these property values:

Property Value

Width 4

Height 0.4

Left 2

Text Align Center

 5.  Press [Ctrl] and click the Donations Report 2017-2018 subtitle to deselect it.

 6.  Set the font size of the Kids for Change title to: 22

 7.  Set the width and height of the logo to: 0.8

 8.  Set the logo’s top property to: 0.05

Be sure to type 0.05 and not 0.5.

 9.  Click the vertical ruler to the left of the controls in the Detail section to select all the controls in 
that section.

 10.  Choose Report Design Tools→Arrange→Sizing & Ordering→Size/Space→Equal 
Horizontal  to evenly space all controls in the Detail section.
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 11.  Click the Last Name label in the page header and then press [Ctrl] and click the DonorLName 
text box in the Detail section.

 12.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Left  to left-align 
the controls.

 13.  Follow the procedures in the previous two steps to left-align the First Name controls.

 14.  Click the Date label in the page header and drag to center it above the DonationDate text box.

 15.  Select the Donor ID Total label (in the DonorID footer), the Grand Total label (in the report 
footer), and the DonationDate text box (in the Detail section).

 16.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Right  to right-
align the controls.

 17.  Select the Amount text box located in the Detail section and the two =Sum([Amount]) calcu-
lated controls located in the DonorID footer and the report footer.

 18.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Right  to right-
align the controls.

Add the Date to the Page Header
Now you will add a date control to the page header section so when viewing the report on a computer, 
readers don’t have to scroll to the very end of the report to check the date.

 19.  Click =Now( ) in the page footer section and tap [Delete] to remove it.

 20.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 21.  Choose the mm/dd/yyyy date format (the third format).

 22.  Uncheck the Include Time checkbox and click OK.

The new date control is inserted on the right-hand side of the Report Header. You may need to move 
the Property Sheet to be able to see the new date box.

 23.  Click the new date control and set these property values:

Property Value

Width 1

Top 0.875

Left 3.5

Text Align Center

 24.  Switch to Print Preview to review the completed report.

 25.  Feel free to return to Design View to make any adjustments you feel are necessary.

 26.  Close the report when you are finished, saving any changes.

Apply Themes to a Report
 27.  Display the Quick Donations List report in Design View.

 28.  Choose Report Design Tools→Design→Themes→Themes  and apply the Integral 
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 29.  Review the report in Print Preview and, if desired, switch back to Design View to choose 
another theme.

 30.  Save the report and close it when you’re finished.

REINFORCE YOUR SKILLS: A4-R3

Create Reports and Modify Controls
Kids for Change is rapidly expanding, adding new activities and staff members almost daily. To meet the 
organization’s need to match staffers with the new activities, you will create two new reports.

 1.  Open A4-R3-K4C from your Access Chapter 4 folder and save it as: A4-R3-K4CRev

 2.  Select the Activities table in the Navigation pane and then choose Create→Reports→Report .

Access generates a report of Kids for Change’s activities in Layout View. Notice the vertical dotted line 
toward the right side of the report. This is a page break line indicating the report extends beyond a 
standard 8.5" x 11" printed page.

 3.  Click an Activity text box to select the entire Activity column of text boxes.

 4.  Hover the mouse pointer over the right border of one of the text boxes until it is a resize arrow  
and then drag left to reduce the width of the boxes to fit the widest entry in the column.

 5.  Resize the remaining columns to fit the widest entries in the columns.

 6.  Switch to Design View and display the Property Sheet.

 7.  Click the =”Page” control in the page footer and set the width to 1 and the left property to: 6

 8.  Choose Report from the Selection Type list at the top of the Property Sheet box and set the 
width to: 7

Access may change the property, making it greater than 7 to account for any variations in your report. 
Setting this property to 7 adjusts the overall width of the report.

 9.  Select the =Count(*) control in the Report Footer and set the Height property to: 0.25

 10.  Switch to Print Preview.

The report should now fit nicely on one page.

 11.  Close Print Preview and then save the report as Activities Report and close it.

Create a Report Using the Report Wizard
Now you will use the Report Wizard to create a staff availability report to match staffers with specific 
activities. The report will be grouped by activity.

 12.  Click the Staff Schedule query in the Navigation pane and then choose Create→Reports→ 
Report Wizard .

 13.  Add the Activity, Day, MeetTime, StaffLastName, StaffFirstName, StaffPhone, and Hours 
fields to the Selected Fields list.

 14.  Click Next, add Activity as a group, and click Next again.

 15.  Click Next two more times, once to skip the Sort Order and Summary screen and once to accept 
Stepped as the layout.

 16.  Name the report Staff Availability Report and click Finish.
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Size, Add, Delete, and Edit Report Controls
 17.  Close Print Preview and then display the report in Layout View, opening the Property Sheet if 

necessary.

 18.  Select the Activity label and Activity text box and set the Width property to: 1.2

 19.  Set the properties for both the label and text box controls as indicated:

Label and Text Box Width Property Left Property

Day 0.9 1.5

Meet Time 0.75 2.5

Last Name 0.8 3.3

First Name 0.8 4.2

Telephone 1.1 5.1

Hours 0.4 7

 20.  Switch to Design View and then choose Report Design Tools→Design→Tools→ 
Add Existing Fields  to display the Field List pane.

 21.  Drag the HrlySal field to the right of the StaffPhone text box in the Detail section.

A label control is included with the text box. You will delete the label then add a new label in the Page 
Header section.

 22.  Click the HrlySal label control, which will be on top of the StaffPhone box, and delete it.

 23.  Close the Field List pane and open the Property Sheet.

 24.  Select the HrlySal text box and set the width to 0.55 and the left property to: 6.3

 25.  If necessary, use the arrow keys to nudge the control up or down to align it with the other con-
trols in the Detail section.

 26.  Choose Report Design Tools→Design→Controls→Label  and drag a new label between 
the Telephone and Hrs labels in the Page Header section.

 27.  Type Hrly Sal in the new label, tap [Enter], and then set the width to 0.55 and the left prop-
erty to: 6.3

 28.  If necessary, use the arrow keys to nudge the control up or down to align it with the other con-
trols in the page header section.

 29.  Switch to Print Preview to review your report.

Add a Subtitle and a Logo
 30.  Close Print Preview and switch to Design View.

 31.  Select the title in the report header and replace the text with: Kids for Change

 32.  Set these property values for the Kids for Change title:

Property Value

Width 4

Left 2

Font Size 22

Text Align Center
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 33.  Choose Report Design Tools→Design→Header/Footer→Title  to insert a new title and 
then enter these property values for it:

Property Value

Top 0.46

Width 4

Left 2

Font Size 20

Text Align Center

 34.  Choose Report Design Tools→Design→Header/Footer→Logo  and navigate to your 
Access Chapter 4 folder.

 35.  Choose the K4C-Logo.bmp and click OK to insert it.

 36.  Set the width and height of the logo to: 0.8

Add the Date to the Page Header Section
 37.  Choose =Now() in the page footer and delete it.

 38.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 39.  Choose the mm/dd/yyyy date format (the third format) and uncheck the Include Time check-
box; click OK.

The new date control is inserted on the right-hand side of the page header.

 40.  Click the new date control and tap the up arrow [£] repeatedly to move it to the top of the 
report header section.

 41.  Drag the left border of the date box to the right to the 6.5" mark on the horizontal ruler.

 42.  Review your report using Print Preview and return to Design View to make any adjustments 
you feel are necessary.

 43.  Save the changes to your report and then close it.

Finalize the Report
 44.  Display Activities Report and take a moment to review it.

 45.  Switch to Design View and choose Report Design Tools→Design→Themes→Themes .

 46.  Choose any theme.

 47.  Choose Report Design Tools→Format→Background→Background Image  and select 
Browse from the menu.

 48.  Navigate to your file storage location, select the file K4C-Background.jpg, and click OK.

 49.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 50.  If necessary, click the Selection Type button in the Property Sheet box and choose Report.

 51.  Set the property for Picture Alignment to Top Right.

 52.  Switch to Print Preview to review the report.

 53.  Close the database, saving the changes to your report.
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 Apply Your Skills
APPLY YOUR SKILLS: A4-A1

Create and Modify Reports
Universal Corporate Events is ready to add reports to its database. In this exercise, you will create two 
reports: The first is a basic report that lists contacts’ telephone numbers; the second lists the event venues 
and their contact information (address, telephone number, and website), grouped by the contact person. 
Then you will add, delete, and edit the venue report controls and also add a logo and title.

 1.  Open A4-A1-UCE from your Access Chapter 4 folder and save it as: A4-A1-UCERev

 2.  Use the Report  tool to create a report based on the Contacts table.

 3.  Save the report as Contacts List and then close it.

Use the Report Wizard and Delete and Edit Report Controls
Now you will use the Report Wizard to create a list of the event venues, including their address, phone 
number, and website, grouped by contact person.

 4.  Choose the Venues table and start the Report Wizard.

 5.  Choose all the fields except VenueID.

 6.  Leave VenueContact as the only grouping level.

 7.  Do not add a sort or change any layout options.

 8.  Name the report Venues List and finish the report.

 9.  Switch to Design View and delete the =Now() control in the page footer.

 10.  Change the VenueContact label in the page header to: Contact

 11.  Change the VenueName label in the page header to: Name of Venue

Add a New Title and a Logo
 12.  Change the Venue List title in the report header to Universal Corporate Events and 

then set these properties for it:

Property Value

Width 4

Height 0.4

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center
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 13.  Insert a new title, leaving the name set as Venue List and setting these properties:

Property Value

Width 4

Height 0.4

Top 0.45

Left 2

Font Name Arial Narrow

Font Size 20

Text Align Center

 14.  Insert UCE-Logo.bmp from your Access Chapter 4 folder into the header.

The logo should be positioned on the left side of the header.

 15.  Set the logo’s width and height properties to: 0.8

 16.  Review your report in Layout View.

The report has layout problems that are addressed in the next exercise.

 17.  Save the report, close it, and close the database.

APPLY YOUR SKILLS: A4-A2

Fine-Tune Reports
The CEO of Universal Corporate Events has sent back the first draft of the Contacts List and Venues List 
with a list of modifications he would like you to make. In this exercise, you will resize, align, and format 
controls on the Venues List report and apply a theme and background image to the Contacts List report.

 1.  Open A4-A2-UCE from your Access Chapter 4 folder and save it as: A4-A2-UCERev

 2.  Display the Venue List report in Layout View.

 3.  Modify the position and width of all columns as necessary so all data is visible.

 4.  Insert a date in the header using the mm/dd/yyyy format and omitting the time.

 5.  Save and then close the report.

Apply a Theme and Insert a Background
 6.  Display the Contacts List report in Design View.

 7.  Apply a theme of your choice to the report.

 8.  Delete the Logo control next to the title in the report header section.

 9.  Insert a background image using the image file UCE-Background.jpg and set the alignment to 
Bottom Right.

 10.  View the report in Report View and make any adjustments you feel are necessary.

 11.  Save and close the report and then close the database.
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APPLY YOUR SKILLS: A4-A3

Create and Modify Reports
Universal Corporate Events is ready to add more reports to its database. In this exercise, you will create 
two reports: a basic report using the Menus table as the record source and a report that lists personnel 
contact information grouped by last name. Then you will add, delete, and edit report controls; modify the 
captions of several labels to make them more readable; and add a logo, title, and subtitle to the venue 
report.

 1.  Open A4-A3-UCE from your Access Chapter 4 folder and save it as: A4-A3-UCERev

 2.  Use the Report  tool to create a report based on the Menus table.

 3.  Save the report as Menus List and close it.

Now you will use the Report Wizard to create a list of the company personnel and their addresses, 
phone numbers, and email addresses. The report will be grouped by last name.

 4.  Choose the Personnel table and start the Report Wizard.

 5.  Add PerLastName, PerFirstName, PerAddress, PerCity, ST, PerZIP, PerPhone, and 
PerEmail to the Selected Fields list.

 6.  Use PerLastName as the only grouping level.

 7.  Do not add a sort and leave the layout default values.

 8.  Name the report Personnel List and finish it.

Modify Controls and Add a New Title, Logo, and Date
 9.  Switch to Design View and delete the =Now() and =”Page” controls in the page footer.

 10.  Change the PerLastName label in the page header to: Last Name

 11.  Change the Personnel List title in the report header to Universal Corporate Events and 
then set these properties for it:

Property Value

Width 4

Height 0.4

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center
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 12.  Insert a new title, leaving the name set as Personnel List and setting these properties:

Property Value

Width 4

Height 0.4

Top 0.5

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center

 13.  Insert UCE-Logo.bmp from your Access Chapter 4 folder into the header.

The logo should be positioned on the left side of the header.

 14.  Set the logo’s Width and Height to: 0.8

 15.  Insert a date in the header using the mm/dd/yyyy format and do not include the time.

 16.  Move the new Date control to the top-right corner of the report header and shorten its width so 
it doesn’t overlay the title.

Review the Report and Apply a Theme
 17.  Review your report in Layout View.

Some controls, such as Telephone and Email Address, may not be wide enough to display all data. You 
will need to move some columns to the left to create space to allow for the expansion of the Telephone 
and Email Address columns. Remember that an entire column can be selected by clicking the column 
heading and using [Ctrl] to select any box in the column.

 18.  Move and widen columns as necessary so all data is visible, but make sure the Email Address field 
does not go past the vertical dotted page break line.

 19.  Save the report and close it.

 20.  Display the Menus List report in Design View.

 21.  Apply a theme of your choice to the report.

 22.  Review your report in Report View and change the theme if desired.

 23.  Save and close the report.
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  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROjECT gRADER: A4-P1

Taylor Games: Create and Modify a Basic Report
Taylor Games needs a basic inventory report. You will first create the report using the Report command, 
then modify it to improve readability and enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A4_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A4_P1_Start from your Access Chapter 4 folder.

 2. Create a basic report based on the Inventory table.

 3. Set the following properties for the Total Cost Total control located at the bottom of the report:

Property Value

Format Currency

Height 0.25

Font Weight Bold

 4. Delete the Logo, Date, and Time controls from the Report Header.

 5. Insert a Date and Time control in the report header and set properties for it as follows:

Property Value

Date Format Use the second format (DD-MM-YY).

Time Format None

Width 4

Text Align Center

 6. Format the Title control (contains the title Inventory) in the Report Header as follows:

Property Value

Width 6.25

Font Size 26

Text Align Center

Font Weight Bold
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 7. Insert a background image and set properties for it as follows:

Property Value

Picture Use Taylor Games BG.png from your Access Chapter 4 folder.

Picture Alignment Bottom Right

Picture Size Mode Stretch

Hint: Set the Property Sheet’s selection type to Report to access the needed properties.

 8. Apply the Facet theme (the second theme in the Office category).

 9. Save the report as Inventory and then close it.

 10. Save your database.

• Using eLab: Save it to your Access Chapter 4 folder as A4_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 4 folder as: A4_P1_Submission

PROjECT gRADER: A4-P2

WebVision: Work with Reports
WebVision would like a report that displays the sales orders for each sales team. You will first create the 
report using the Report Wizard and then modify it to improve readability and enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A4_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A4_P2_Start from your Access Chapter 4 folder.

 2. Create a new report using the Report Wizard and these guidelines:

• Add the SalesTeam field from the Sales Reps table.

• Add the OrderID, Date, and Amount fields from the Orders table.

• View the data by Orders.

• Add SalesTeam as the only grouping level.

• Sort by Date in descending order.

• Add summary options that include a Sum calculation on the Amount field and show Detail 
and Summary.

• Use Outline layout.

• Set the Orientation to Landscape.

• Use Orders by Region as the title.

 3. Delete the Summary for Sales Team control.
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 4. Set the following properties for the SalesTeam label:

Property Value

Caption Sales Team (add a space to the current caption)

Font Size 14

Font Weight Bold

 5. Set the Page Header section height to: 0.25

 6. Move the SalesTeam label into the Page Header section. Move only the label (not the Sales 
Team text box).

 7. Set the following properties for the SalesTeam text box:

Property Value

Width 1

Top 0

Left 0

Font Size 12

Font Weight Semi-Bold

 8. Insert the LastName field from the Sales Reps table into the SalesTeam Header section.

 9. Delete the LastName label control.

 10. Set these properties for the LastName text box:

Property Value

Top 0.2

Left 1

Border Style Transparent

Font Weight Bold

 11. Set the Date text box Width property (located in the Detail section) to 1 and the Text Align prop-
erty to Left.EVALU
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 12. Set the Date label (located in the SalesTeam Header section) Left property to: 0.5"

 13. Set the Sum label (located in the SalesTeam Footer section) Left property to 3 and the Font 
Weight property to Semi-Bold.

 14. Set the following properties for the Grand Total label (located in the Report Footer):

Property Value

Width 1

Left 2.5

Font Weight Semi-Bold

 15. Set the following properties for both the Sum of Amount text box and the Amount Grand Total 
Sum (Sum) text box:

Property Value

Border Style Transparent

Font Weight Bold

 16. Delete the Title control (Orders by Region) from the report header and insert a new Title control 
using the following properties:

Property Value

Width 2

Height 0.35

Font Weight Bold

 17. Insert WebVision Logo.jpg from your Access Chapter 4 folder and set the Width property 
to: 1.75

 18. Save and close the report.

 19. Save your database.

• Using eLab: Save it to your Access Chapter 4 folder as A4_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 4 folder as: A4_P2_Submission   
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A4-E1 That’s the Way I See It
You’ve been asked to create a sales report for Blue Jean Landscaping that shows the total amount of 
sales by equipment type, drawing the information from sales invoices. Open A4-E1-BJL and save it 
as: A4-E1-BJLRev

Create a well-designed report header with a title and logo (use BJL-Logo.bmp). Make sure all infor-
mation is visible and that the report is easy to read and understand. The date and page numbering 
should appear at either the top or bottom of the report. Save your report as: Equipment Sales

A4-E2 Be Your Own Boss
Blue Jean Landscaping has asked you to add reports to its company database that provide listings 
of its equipment, services, and customers in an attractive and useful manner. Open A4-E2-BJL and 
save it as: A4-E2-BJLRev

Use the Store Inventory query as a record source to create a report that is grouped by manufacturer 
and includes item name, price, quantity in stock, inventory amount, and a sum of the InvTot field. Use 
the default layout settings. Use the skills you learned in this chapter to size, rearrange, and format 
the report controls. Create a well-designed report header with a title and logo (use BJL-Logo.bmp). 
Name the report: Store Inventory Report

Create another report using the Service Invoices Query that includes all fields except InvNum. 
Group the results by InvDate and sum the LineTotal field. Choose the Stepped and Landscape layout 
options and use Service Invoices Report as the report name. Format the report controls 
and create the same consistent header with a logo, title, and subtitle as in the Store Inventory 
Report. Add the background image BJL-Background.jpg that is aligned bottom left to the report.

A4-E3 Demonstrate Proficiency
You’ve been asked by Stormy BBQ to prepare a Manufacturer Stock Level report that shows the 
total number of items in stock for each manufacturer. Open A4-E3-StormyBBQ and save it as: 
A4-E3-StormyBBQ-Rev

Locate the table or query in the database that will provide the data you need and use all fields from 
that table or query. Organize the report so the total stock for each manufacturer is displayed. Create 
a well-designed report header with a title and logo (SBQ-Logo.bmp). Make sure all information is 
visible and the report is easy to read and understand. The date and page numbering should appear 
at either the top or bottom of the report. Save your report as: Manufacturer Stock Levels
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ÝÝ Create and modify relationships

ÝÝ Format a table datasheet layout

ÝÝ Modify table structures

ÝÝ Set field properties

ÝÝ Use the Lookup Wizard

5 Refining Table Design

ACCESS

I
t’s important to understand 

what makes Access a relational 

database management system 

and why properly designed databases 

perform better. Well-designed databases 

reduce redundant data and create critical 

connections between the objects that help 

make them more efficient. In this chapter, 

you will develop important database table 

relationships and use tools to help speed 

data entry and ensure data accuracy.
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Ý Project: Maintaining and Formatting Databases
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You are tasked with maintaining the company’s database. After 
reviewing the objects in the database, you decide to make some changes that will make the 
database more efficient and improve data entry. You will create a lookup field to streamline 
data entry. In the process, you will add formatting to make the tables more colorful. You will 
then examine the relationships between tables to ensure they accurately define the database.

Creating and Modifying Relationships
As you build tables and other objects in a relational database, Access creates some of the relation-
ships between tables based on each table’s field structure. It’s a good idea to examine and edit these 
relationships manually. For example, you may choose to cascade updated or deleted records, that is, 
to automatically update or delete all affected records as part of a single operation.

Cascade options can be invaluable in cases in which a store pulls a product off its shelf and therefore 
needs to remove that product from its merchandise list, order list, inventory list, and advertising list. 
In most cases, you also must enforce referential integrity to ensure relationships between records in 
related tables are valid. Finally, it may be wise to create and display those relationships in a report to 
add to the database documentation.

Relationship Types
Database relationships connect data in one table to data stored in other tables. Access supports 
three different types of relationships:

 Ý A one-to-one relationship means each record in Table A can have only one matching record in 
Table B, and each record in Table B can have only one matching record in Table A. This is the least 
common relationship.

Example: A main Customers table linked to a CustPassword table (one customer has one 
password)

 Ý A one-to-many relationship means each record in Table A can have multiple matching records 
in Table B, but a record in Table B can have only one matching record in Table A. This is the most 
common relationship.

Example: One employee will have many sales, and a product will be sold many times

 Ý A many-to-many relationship occurs when two tables may each have many matches in the 
other table but they do not share key fields, so they use a third junction table to connect the two 
tables, completing the relationship. The junction table has a one-to-many relationship to each table.

Example: A Vendors table and a Products table, where one vendor provides many different products 
and one product is available from many vendors

Adding and Modifying Relationships
There are times when a database designer must add or edit a relationship. You can examine, create, 
edit, and delete relationships between tables in the Relationships window. The Show Table command 
in the Relationships window displays the Show Table window containing a list of tables and their fields. 
Tables are added to the Relationships window with a click of the Add button. Fields from one table 
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added to the Relationships window can be dragged and dropped onto a field in another table to begin 
creating a relationship between those fields. Conversely, relationships can be edited by selecting the 
join line between the relational fields and using the Edit Relationships command on the Ribbon.

ÝÍ Database Tools→Relationships→Relationships 

ÝÍ Relationship Tools→Design→Tools→Edit Relationships 

The Edit Relationships Box
The Edit Relationships dialog box displays the tables and fields involved in the relationship along with 
options for establishing referential integrity, cascade protocols, and the relationship type being created. 

Table fields to be joined

Relationship options

Type of relationship to be created

One-to-many join line

A
C

C
E

S
S

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



134 Access Chapter 5: Refining Table Design

Referential Integrity Requirements
Perhaps the most important database relationship protocol is referential integrity, which is a set of 
rules used to maintain the validity of the related data in a database. It ensures that you don’t delete 
a record or change a primary key that is related to data in a foreign table. It also requires the data 
types of the related fields (both the primary and foreign keys) to be the same or compatible.

Referential integrity is a critical part of a relational database, so let’s look at it from several views 
using real-life examples:

 Ý If the ProdID primary key in the Products table has a Number data type (Field Size property: Long 
Integer), then the ProdID foreign key in the Invoice Details table must also have the Number data 
type (Field Size property: Long Integer).

 Ý You cannot have a listing in the Invoice Details table for a product you don’t sell. This means you 
cannot have a foreign key (ProdID) in the Invoice Details table without a matching primary key 
(ProdID) in the Products table.

 Ý You cannot delete the primary key (ProdID) from the Products table when there is a corresponding 
foreign key (ProdID) in the Invoice Details table.

 Ý You cannot change the primary key value (01HP) from the Products table when there is an existing 
and corresponding foreign key value (01HP) in the Invoice Details table, unless Cascade Update is 
enabled.

Relationship Cascade Options
Two additional relationship options are available for controlling updates to related tables: Cascade 
Update and Cascade Delete. Each has a unique function for maintaining database relationships, and 
it’s important to know what they control.

RELATIONSHIP CASCADE OPTIONS

Cascade Option Description
Cascade Update Updates the value in the key field of a related table if you change the 

primary key value in the primary table. For example, if you change a 
ProdID in the Products table, the ProdID field value in the Invoice Details 
table updates for each invoice.

Cascade Delete Deletes records in a related table any time you delete related records in 
the primary table. Consider this option if you deleted an employee from 
the Employees table and want to also delete their spouse from the Spouses 
table. Take care, though, as any records associated with the deleted record 
are removed. So, if your Employees table is linked to your Invoices table, it 
would not be wise to delete all 2018 invoice records for an employee just 
because that employee retired in 2019.

View the video “Creating Relationships.”
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DEVELOP YOUR SKILLS: A5-D1

In this exercise, you will open the Relationships window, add a table, and create a relationship between 
tables with referential integrity enforced.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

 1.  Open A5-D1-WinDesign from your Access Chapter 5 folder and save it as: 
A5-D1-WinDesignRev

When completing exercises, always choose to Enable Content.

 2.  Choose Database Tools→Relationships→Relationships .

 3.  Choose Relationship Tools→Design→Relationships→Show Table .

 4.  Double-click the EmpSpouses and All_Customers tables to add them to the Relationships 
window and then close the Show Table box.

Typically, all tables will be in the Relationships window, but sometimes tables are added later.

 5.  Rearrange the tables in the Relationships window by dragging their title bars so they are 
arranged as shown.

Arranging the tables this way helps you see all the relationships, as the relationship lines are not 
overlapping.
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Manually Set Relationships
Now you will create a one-to-many relationship between the Employees table and the Invoices table so 
one employee may have many invoices.

 6.  Follow these steps to create a relationship between the Employees and Invoices tables:

A

B

A  Select the EmpID field in the Employees table and drag it to the EmpID field in the Invoices 
table.

B  When the mouse pointer is positioned as shown, release the mouse button.

The Edit Relationships dialog box opens once the mouse button is released.

 7.  Check the Enforce Referential Integrity box and click Create.

Access creates a join line and places symbols at each end. The Employees end of the join line displays a 
1, and the Invoices end displays an infinity sign (∞).

 8.  Drag the CustID field from the All_Customers table to the CustID field in the Invoices table.

In the new relationship being created, the CustID field in the All_Customers table will be the primary 
key and the CustID field in the Invoices table will be the foreign key.

 9.  Enforce referential integrity and click Create to complete the relationship.

 10.  Choose File→Save or click the Save button to save the database changes and leave the 
Relationships window open.

Unless otherwise directed, keep Access and any databases or database objects being used open at the end 
of each exercise.
 

Editing and Deleting Relationships
Deleting relationships and setting cascade options can have a ripple effect on records and data in a 
database, so it’s a good idea to back up a database before removing a relationship or setting cascade 
options and then test the settings. That way you can restore the database from the backup if the 
changes you make result in data loss.

When to Review Relationships
Any time the structure of a table changes—whether it’s through adding or removing fields, 
changing data types, or creating lookup fields—you should review and update the relationships 
among database tables.

Note!
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Deleting Relationships
To modify tables after relationships have been set, you must temporarily delete existing relationships 
so Access is free to make the revisions without violating integrity rules. For example, say you have an 
existing Short Text data type field, such as State, and you want to change it to a Lookup data type. If 
you attempt to change its data type, Access will warn you that you must first delete its relationships 
to any other tables. After you delete the relationship and change the field’s data type, you may have 
to reestablish the relationship and edit those relationship properties.

DEVELOP YOUR SKILLS: A5-D2

In this exercise, you will edit the relationship between the Employees and Invoices tables so if you change 
the Employee ID in the primary table (Employees), Access will update the Employee ID in the related 
foreign table (Invoices).

 1.  Right-click the join line between the Employees table and the Invoices table and choose Edit 
Relationships.

The mouse pointer must be right on the join line or you won’t see the Edit Relationships option on the 
right-click menu.

 2.  Check the Cascade Update Related Fields checkbox and click OK.

 3.  Right-click the join line linking the ProdID fields in the Products and InvoiceDetails tables.

Your mouse pointer must be directly on the line for the menu to appear.

 4.  Choose Delete and then click Yes to confirm the deletion.

 5.  Choose File→Save or click the Save button to save the relationship changes.

Documenting and Printing Relationships
After you have inspected the relationships, you may want to create a report to view a printable 
version of them. You can also display the database objects that make use of, or are used by, other 
objects in the database. This is done through the Object Dependencies panel.

ÝÍ Database Tools→Relationships→Relationships→Relationship Report 

ÝÍ Database Tools→Relationships→Object Dependencies 

DEVELOP YOUR SKILLS: A5-D3

In this exercise, you will create a relationship report and examine object dependencies for the Employees 
table.

 1.  Choose Relationship Tools→Design→Tools→Relationship Report .

 2.  Choose Print Preview→Page Layout→Landscape  so all tables and relationships are 
shown.

 3.  Save the report as: Relationships

The report is added to the Report group in the Navigation pane.

 4.  Close the report and then close the Relationships window.
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Display Object Dependencies
 5.  Select the Employees table in the Navigation pane 

without opening it.

 6.  Choose Database Tools→Relationships→Object 
Dependencies .

 7.  Ensure the Objects That Depend on Me option is 
selected in the Object Dependencies panel.

The objects listed below each type are dependent on the 
Employees table.

 8.  Choose the Objects That I Depend On option.

The Employees table has relationships with, or depends on, 
the EmpSpouses, Invoices, and States tables.

 9.  Close the Object Dependencies panel.

Modifying Table Structures
Database integrity and data validity are important aspects of database maintenance. Access features 
that enable you to modify table fields, control the data entered, and format the data to ensure 
consistent reporting include but are not limited to:

 Ý Renaming tables, forms, and other database objects

 Ý Adding and removing fields from tables

 Ý Changing data types

Renaming Tables and Adding, Deleting, and Editing Table 
Fields
As you create tables, you define each field by setting the data type and entering the field name. 
Access works behind the scenes and sets default properties for the field that limit the number of 
characters in a field, as well as the format and data type of characters valid for the field. You can 
accept the default properties Access sets or modify the properties. Properties available depend on 
the data type selected for the field. Take care when adding, deleting, or editing fields because of the 
impact such actions might have on the table data.

Renaming Tables
When you save a table, give it a name that describes the data it contains. You can change the name 
later without affecting its data, but note that table names are often included in other database 
objects that use the table’s data, which means renaming a table can impact other database objects. 
Access should automatically update the name of the table used in other database objects. However, 
if you rename a table, you should make sure that every form, query, or report that uses that table 
still functions the same.
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A good database design principle is to name all your tables in a similar fashion, for example, using 
the underscore between words in all tables named with more than one word (Invoice_Details). 
Traditionally, spaces are not used in table names because referencing the table in a query or 
entering the table name in an expression could be confusing. For instance, is Invoice Details two 
objects or one object? Fortunately, Access will enclose a table name like Invoice Details in [square 
brackets] when it uses it in an expression.

Adding Fields to Existing Tables
Periodically you will need to create new fields in existing database tables and then add data to these 
fields. You can add a field either in Datasheet View or in Table Design View and then move it where 
you want it to be in the layout.

Deleting Fields
When you delete a field that contains data, Access displays a warning that deleting the field will 
remove all its data. If you delete a field in Design View and have not saved the table, you can recover 
the deleted field using Undo. If, however, you save the table after deleting the field, the data is lost, 
and you have to add the field name to the Table Design and then reenter all field data in the table to 
restore the data. Fields are deleted in Design View by clicking the field header and tapping [Delete].

Editing Field Data Types
Many Access data types start with a different letter, which means you can type a letter, and the data 
type that begins with that letter will display. For example, if you want to change the data type of a 
field from Short Text to Number, you click in the field’s Data Type and type N.

Any time you change the data type of a field that contains values that fail to conform to the new 
data type, Access deletes any nonconforming data. For example, if you change a field’s data type 
from Short Text to a Number data type and someone has accidentally entered 1O (using a capital 
O) instead of 10 (using a zero), Access will warn you that you are about to delete data that did not 
conform, thus the entry made using the capital O will be removed after the change is confirmed. 
The great thing about this is that Access will allow only valid field data, which results in more 
accurate data.

The Yes/No Data Type
The Yes/No data type sets the field so only two entries are possible: Yes/No, True/False, or On/Off. 
When you set the Yes/No data type for a field, Access places a checkbox for the field in the datasheet 
and on forms where the data appears. Checking the checkbox indicates a value of Yes, True, On, etc.; 
clearing the checkbox indicates a value of No, False, or Off.

DEVELOP YOUR SKILLS: A5-D4

In this exercise, you will rename a table, delete a table field, add a table field, and modify the data type of 
a field.

 1.  Right-click the All_Customers table in the Navigation pane and choose Rename.

 2.  Type Customers and tap [Enter].

 3.  Open the Customers table and switch to Design View.
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 4.  Click the field selection box on the left edge of the Notes field to select the field.

 5.  Tap [Delete] and choose Yes to confirm.

The field and any data within it have been permanently removed from the database. However, before 
continuing, you could use Undo to restore the field and data because you made the deletion while 
working in Design View.

Add New Fields
Now you will add a Yes/No field to the Customers table.

 6.  Right-click the CustStreetAddress field selection box and choose Insert Rows.

A new row opens above the CustStreetAddress row.

 7.  Click in the empty Field Name box of your new field and type: Business

 8.  Tap [Tab] and set the data type to Yes/No.

 9.  Save the table and then switch to Datasheet View.

Your new Yes/No Business field has all boxes unchecked, which means it is set to No.

 10.  Check the Business field boxes for the records with these CustIDs: DavisP, HassanA, and 
KleinJ.

These records are now identified as having a business.

 11.  Close the Customers table.

Formatting a Table Datasheet Layout
If field values are longer than anticipated, Access displays only the portion of the data that fits within 
the column width, hiding some of the data. Or the opposite scenario may occur, in which one or two 
fields were added and you need to display all the fields on one screen, which means you may have to 
modify the width of each column to fit the screen. Alternatively, you can maximize the Access window 
or close the Navigation pane to provide more room without having to modify the width of each 
column.

Changing the Width of Columns
Access offers some useful techniques to adjust the width of each column in a datasheet to display all 
data in the column:

 Ý Drag a column border: Drag a column border to make the column on the left of the border 
wider or narrower.

 Ý Double-click a column heading border: Double-click the right border of a column to change 
the width of the column on the left to fit either the longest data entry in the column or column 
heading, whichever is wider.

 Ý Right-click a field heading and choose Field Width: Select the Field Width command from 
the context menu to open the Column Width dialog box and type the width, reset the standard 
width, or select Best Fit to automatically size the field width to the longest entry.
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Moving and Hiding Data Columns
There will be times when you want to reposition a column of data in a table layout—perhaps to display 
the email address before the telephone number. When you rearrange the columns in a datasheet, 
the table layout remains the same but the fields display in a different order in the datasheet. You may 
also want to hide some columns so you can better view other field columns. When you hide columns, 
Access temporarily removes them from display, but the data remains in the table—it’s not deleted. If 
you want to view data in hidden columns later, unhide the column.

Saving a Table Layout
Changing the layout of a table datasheet has no real effect on table data or structure; however, 
when you make changes to a table datasheet, Access recognizes the differences between the  
structure of the table and its layout and prompts you to save the changes to the layout when 
you close the table. If you abandon the changes, the next time you open the table datasheet, the 
column widths will return to their original size and any columns that were hidden will show. If you 
save the changes, the next time you open the table datasheet, Access recalls the layout and displays 
the formatting changes.

DEVELOP YOUR SKILLS: A5-D5

In this exercise, you will adjust the column width to allow for the best display of data in a datasheet. You 
will also rearrange columns and hide a column.

 1.  Display the Customers table in Datasheet View.

 2.  Position the mouse pointer over the border between the Street Address and City column headings 
so the adjust pointer appears as a double-headed arrow.

 3.  Double-click and notice that the Street Address column width adjusts to fit the widest entry in 
the column.

 4.  Position the mouse pointer on the CustID column heading and then drag 
right to select both the CustID and Last Name columns.

 5.  Position the mouse pointer between the column headings and double-click 
when the adjust pointer appears.

Both columns will be Best Fit.

 6.  Click the First Name column heading to select the column. Do not release your mouse button.

 7.  Drag the First Name column to the left of the Last Name column, releasing the mouse button 
when the black vertical bar is between the CustID and Last Name columns.

The First Name column should now be before the Last Name column.
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 8.  Click the table selection button to select all data.

 9.  Double-click the border between any of the selected column headings to Best Fit all columns.

 10.  Save the layout changes.

Enhancing a Datasheet
Changing the datasheet layout enables you to make necessary adjustments, such as widening a field 
so a longer value can be fully displayed. Enhancing the datasheet layout enables you to improve its 
readability. Some of the features you can apply to enhance a datasheet include gridlines, font size and 
color, and background color.

As you apply enhancements to the datasheet, Access formats all data and gridlines to match the 
format you choose. The Text Formatting group on the Home tab displays tools for enhancing the 
most commonly formatted features on a datasheet such as fonts, colors, fills, and alignments. It 
also contains tools for formatting alternate rows and gridlines. Finally, you can find more formatting 
options in the Datasheet Formatting dialog box (launched from the Text Formatting group).

Gridline formatting
Alternate row formatting

Dialog box launcher opens the Datasheet Formatting box

ÝÍ Home→Text Formatting

DEVELOP YOUR SKILLS: A5-D6

In this exercise, you will use the Text Formatting tools to set datasheet enhancement options for the 
Customers table.

 1.  Choose Home→Text Formatting→Alternate Row Color  menu button �.

 2.  Choose Blue, Accent 1 (the fifth color on the top row under Theme Colors).

Alternate rows in the datasheet should now be blue.

 3.  Choose Home→Text Formatting→Font menu button � and choose Arial from the list.

All table data should now be formatted with the Arial font.

 4.  Choose Home→Text Formatting→Gridlines  menu button � and choose Gridlines: 
Horizontal.

The datasheet will display only horizontal gridlines now.
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 5.  Click the dialog box launcher at Home→Text Formatting to open the Datasheet Formatting 
dialog box.

 6.  Click the Gridline Color menu button � and choose Black, Text 1 (second color on the top 
row of Theme Colors).

 7.  Click OK to apply the black gridlines.

 8.  Save the changes to the Customers table.

Setting Field Properties
Use field property settings to further define the properties of each field. The Field Properties pane 
appears in the lower portion of the Table Design View or on the Fields tab in Datasheet View. 

COMMON FIELD PROPERTIES

Field Property Description
Field Size Sets a field length for the number of characters each field can hold

Format Sets a predefined display layout for fields (that is, currency or percent)

Input Mask Identifies the format of values entered—with hyphens or without, 
alphabetic or numeric, uppercase or lowercase, etc.

Caption Sets a column heading title to describe the data content better than the 
actual field name and includes spaces where appropriate

Default Value Adds a default value for a specific field in each record, such as FL for the 
State field, abbreviated as “ST”

Validation Rule Controls actual values entered into a field, such as less than 100 or greater 
than 01/01/2017

Validation Text Provides a tip that identifies valid data entries, such as “All dates must be 
after 01/01/2017”

Required Sets the field as required to ensure a value is entered in the field

Why Set Field Properties?
Different people add data to databases—and they often enter the data using varying formats. 
For example, some people type parentheses around the area code when entering phone numbers. 
Others may separate the area code from the number using a hyphen. Both formats are accurate, but 
displaying mismatched data can be distracting. Entering parentheses or hyphens can also be time-
consuming. Setting field properties to control how data appears helps maintain data consistency 
throughout a database.

Set Field Sizes, Captions, and Default Values
Maintaining database integrity, data validity, and data format are important considerations when 
building a database. You should make every effort to ensure that data is entered consistently, 
contains the required number of characters, and falls within valid data ranges.
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Setting Field Size
Rather than using a default field size, you can set the Field Size property to limit the number of 
characters that can be entered into the field for each record. For example, you can limit data entry of 
state names to the two-character state abbreviation.

Sometimes, when you reduce an existing field size to limit data entry, Access warns that data may be 
lost due to the reduced field size. In most cases, you are familiar with the data, so you can choose Yes 
to continue. For instance, truncating Florida to FL would not create invalid data. However, if you are 
uncertain, you should choose No, check the data to ensure that it fits the new limit, and then set the 
field size.

Identifying Field Size for Number Fields
Number fields are identified by special formats in the Properties panel. In general, number fields 
should be set to define the largest value anticipated for the field. Setting the proper field size controls 
for number fields helps optimize database performance.

NUMBER FIELD FORMATS

Field Size Property Description
Byte Stores whole numbers between 0 and 255 using 1 byte and allows 

no fractions or decimal points; uses the minimal amount of memory, 
allowing for the fastest processing

Integer Stores whole numbers between –32,768 and 32,767 using 2 bytes rather 
than the standard 7 bytes normally used for high values

Long Integer Stores whole numbers between –2,147,483,648 and 2,147,483,647 using 
4 bytes rather than the standard 14 bytes normally used for high values

Single Stores positive and negative numbers to exactly seven decimal places 
using 4 bytes

Double Stores positive and negative numbers to exactly 15 decimal places 
using 8 bytes

Replication ID Identifies replication of tables, records, and other objects in Access 
2003 or earlier databases using 16 bytes

Decimal Stores positive and negative numbers to exactly 28 decimal places 
using 12 bytes

Setting Text to Uppercase or Lowercase Format
Text fields have unique field properties available for formatting data. Access provides a Format field 
that enables you to force a specific format to all characters in the field. The most common format 
characters are used to force uppercase (>) and lowercase (<). Using the Text Format property elimi-
nates the need to spend valuable time entering multiple characters in the Input Mask property.

Setting Captions
As you may have noticed, many field names contain no spaces or include an underscore, such as  
LastName or Last_Name. The Caption field property enables you to type a more descriptive name for 
a field that is more suitable for display on forms, in datasheets, and on reports—such as Last Name.EVALU
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Setting Default Field Values
Validation rules control the data you enter in table fields. Setting a default value for a field automatically 
enters the most common data value and can save time and help reduce the number of errors made 
during data entry.

For instance, all the employees at Winchester Web Design live in Florida. Consequently, it saves time 
and reduces inconsistency when the default value for the State field is set to FL. The default value 
appears whenever a new record is added. If you need to enter a different state, you simply type in the 
new state’s two-character abbreviation to replace the default value.

Making a Field Required
Whenever you create a primary key field, its properties are automatically set to be required and 
indexed, allowing no duplicates. A database index is a structure whose main function is to speed up 
database operations. An index that is set on key fields enables faster searches and retrieval of data.

A key field must have a value; by default, every other field does not require that a value be entered. 
There are times, however, when non-key fields must have values. For instance, you must include an 
employee last name and first name when entering a new record into your Employees table. The 
Required field property helps to easily accomplish this.

DEVELOP YOUR SKILLS: A5-D7

In this exercise, you will set field sizes, captions, and default values in the Customers table.

 1.  If necessary, open the Customers table and switch to Design View.

 2.  Click anywhere in the CustState field and set these field properties:
• Field Size: 2
• Format: >
• Caption: ST
• Default Value: FL

Entering > for the Format property converts entries to uppercase. Access places quotation marks 
around the Default Value field property when you click in another field property or save the table. 
Setting field sizes consistent with the data they hold helps the data display properly when it’s included 
in forms and reports.

 3.  Click anywhere in the CustLastName field and change the field size to 25 and the required 
property to Yes.
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 4.  Click anywhere in the CustPhone field and change the field size to 15 and the required property 
to Yes.

 5.  Choose File→Save. For both the Some Data May Be Lost message and the Data Integrity Rules 
Have Been Changed message, choose Yes.

 6.  Switch to Datasheet View and enter this data in a new record:

Field Data to Enter

CustID JonesK

First Name Ken

Last Name Leave this field blank.

Business Check the box to set it to Yes.

Street Address 2300 Maple Ave.

City Palmetto

ST This field already shows FL because you set FL as the default value.

ZIP 34628

Telephone Leave this field blank.

Email KJones@email.com

 7.  Tap [Tab] after entering the email address.

You are prompted to enter a value for the Customers.CustLastName field because you made it a 
required field.

 8.  Click OK, select the Last Name field, and type: Jones

 9.  Tap [Tab] through the remaining record fields. 

You are prompted to enter a value for the Customers.CustPhone field, since it is also a required field.

 10.  Click OK and then tap the left arrow [¢] to select the Telephone field; type 9415553232 and 
tap [Tab].

Access automatically applies parentheses, ( ), to the area code and a hyphen, -, after 555.
 

Custom Text and Memo Field Formats
Standard field formats in Access cannot meet the needs of every text or memo field contained in 
every database. That’s why Access provides tools for creating custom formats. Custom formats for 
Text and Memo fields can contain two sections:

 Ý Section 1 contains a symbol and is followed by a semicolon when a second section is entered.

 Ý Section 2 contains the value of the alternate value when no value is entered. This alternate is a 
null value and is enclosed in quotation marks with no space between: “”.

An example of a two-section format for a text field would look like this: @; “N/A”

The @ symbol tells Access to display the field data if a value is entered, and N/A tells Access to 
display N/A (Not Applicable) if no value is entered. The @ symbol displays all characters that will fit 
the Field Size property, and if there are fewer characters than the Field Size value, Access pads the 
rest of the field with blank spaces.EVALU
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Short Text and Long Text Field Unique Properties
Text and Memo fields are formatted to hold text characters (abc), symbols (#$%), and numbers (123) 
on which no mathematical calculations will be performed, such as FirstName, LastName, City, and 
also ZIPCode, PhoneNumber, and SocSecNumber. Because of the broad scope of data that these 
data types can contain, Access provides several field properties for controlling and formatting data 
entry in the field.

SHORT TEXT AND LONG TEXT FIELD UNIQUE PROPERTIES

Property Description
Allow Zero Length This allows data entry of zero length in a field. Data is entered as open 

and close parentheses with no character between: (). This entry shows 
that there is no value to enter. For example, if you have a field in a 
Customers table that requires a land phone number and the customer 
has no landline, enter () in the field.

Text Format This property sets the text in a Long Text field as Plain Text or Rich Text. 
Rich text fields can be formatted with different font types, sizes, and 
colors.

Text Align This positions the text on the left, center, or right side of the field box or 
column. The Distribute setting spreads out the text to fill the column or 
text box size.

Append Only This adds a series of date-stamped comments to a single Long Text field, 
making it easy to create a history log of comments added to the fields. 
These comments are stored in a separate table and accessed through 
the Append Only Long Text field.

Entering Field Properties
Access provides three basic techniques for setting field properties:

 Ý Type the value into the property box.

 Ý Choose the value from the property list. (For example, click the drop-down menu button to select a 
valid entry from the list.)

 Ý Click the Build button at the right side of a field property to open the Wizard associated with that 
property and choose the desired settings. For example, click the Build button to open the Input 
Mask Wizard to format the display of text and field dates.

DEVELOP YOUR SKILLS: A5-D8

In this exercise, you will set additional properties to require the entry of a customer’s first name.

 1.  Display the Customers table in Design View.

 2.  Click anywhere in the CustFirstName field and type @ for the Format field property.

Using the @ symbol will display all characters that fit within the field size and pad any remaining 
positions with spaces.
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 3.  Choose Yes in the Required field property and No in the Allow Zero Length field property to 
prohibit a null value from being entered.

These settings will require a CustFirstName to always be entered.

 4.  Choose File→Save and choose Yes when advised that the data integrity rules have been 
changed.

 5.  Switch to Datasheet View.

 6.  Click in the CustID field of the new, blank record at the bottom of the table and type: SmithA

 7.  Type Smith in the Last Name field and then close the Customers table.

A message informs you that you must enter a value in the CustFirstName field. This is because you set 
the Allow Zero Length property to No, which requires an entry of at least one character to be made.

 8.  Click OK to dismiss the message and then click Yes to close the database object (Customers 
table) now.

The table will close and the new record you started to enter will not be saved.
 

Formatting Data Using Input Masks
Consistency of data format is important for visual aesthetics; it also helps ensure accuracy in 
searches, queries, and sorts. You can control data formats using the field property input mask. Using 
input masks, you can set the characters you want displayed in fields, such as the parentheses in an 
area code, and Access requires the user to enter the data within that format. 

The Input Mask Wizard
The Input Mask Wizard is a valuable tool for setting the most common formats used in databases. 
You can also set input masks to require a specific number of characters in a field or to convert 
characters to capital or lowercase.

Setting input masks ensures that the data format in tables is consistent. Because the table data is 
consistent, data displayed in forms and reports will also be consistent.

Input masks can automatically format unformatted data.

The Build  button that appears at the right end of the Input Mask box when you click the box 
starts the Input Mask Wizard, which helps you build the mask.
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Input Mask Symbols
When you use the Input Mask Wizard, Access places the necessary coding into the Field Properties 
pane. Access uses several symbols to control the appearance of data.

INPUT MASK SYMBOLS

Symbol Description Example
0 Requires a numeric digit (000) 000-0000 requires an area code as 

part of the phone number.

9 Data is optional but must be a digit (999) 000-0000 requires a seven-digit 
phone number with an optional three-digit 
area code.

# Restricts data to a digit, +, -, or space #99.99 permits + or – in the position of the #.

L Requires an alphabetic character (that is, a 
letter)

LL requires the entry of two alphabetic 
characters in the State field.

? Restricts, but does not require, data to 
alphabetic characters

L????L requires two alphabetic characters, 
one on each end of the data, but permits 
four additional alphabetic characters 
between.

A Requires an alphabetic or numeric 
character

000-AAAA permits a phone number to be 
entered either as 555-1234 or 555-HOME.

a Allows, but does not require, alphabetic or 
numeric characters

(aaa) AAA-AAAA requires a seven-digit 
phone number but not the area code.

& Requires any alphanumeric character (letter 
or number) or a space

&&&& permits data entry such as a four-
character ID along the lines of 01HP, 1 HP, 
or 1234.

C Allows, but does not require, any character 
or space

CCCC could contain an entry such as 01HP, 
1 HP, HP, etc.

.,:;-/ Characters used to separate parts of 
numeric, date, time, and currency values

#,###.## permits numeric data.

99/99/00 permits date data.

99:00:00 permits time data.

< Converts characters to lowercase <aaa permits entry of three characters such 
as ABC and converts data to lowercase abc.

> Converts characters to uppercase >aa permits entry of two characters such as 
fl and converts the data to FL.

! Displays input mask characters from right 
to left

!(#) 000-0000 right-aligns the phone 
number so if only seven numbers are 
entered, the area code is left blank. This 
affects fields defined with the Number data 
type.

\ Causes characters that follow the \ to 
display as literal characters

(\A) appears as (A).

“Literal Text” Places text between the quotation marks 
into the field value at the identified position

“ID-”0000 places ID- before the numbers 
entered. A space may be enclosed in quotes 
to ensure it appears in the value.

Password Creates a password entry text box; any 
character typed in the text box is stored as 
a character but displays as an asterisk (*)

When passWord1! is typed, Access shows 
**********.
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Storing Input Mask Characters
Access provides two methods for storing the input mask with the table data—with or without the 
symbols. Storing the symbols with the data increases the size of the database file. Therefore, companies 
that store extremely large volumes of data often prefer storing the data without the input mask symbols. 
You can choose one of these methods while running the Input Mask Wizard.

Using Smart Tags
As you work in Access, you will periodically see smart tags, such as the Paste Options smart tag, 
which you may have seen in Word and other Microsoft applications. Smart tags allow you to apply 
formatting changes you make to a field in one table to the same field anywhere else it occurs in the 
database. For example, if you modify the field format properties in a table, the Property Options 
smart tag lets you apply the same format changes to the field when it appears in other forms, 
queries, and reports. This helps ensure data consistency throughout the database.

DEVELOP YOUR SKILLS: A5-D9

In this exercise, you will set the primary key, change a field size, and apply a custom input mask to a field in 
the Products table. Then you will apply a standard telephone input mask to a field in the Employees table.

 1.  Open the Products table in Datasheet View.

The ProdID field consists of two numeric characters and two alphabetic characters.

 2.  Switch to Design View and click the Primary Key  button to make ProdID the primary key field.

 3.  Click in the Input Mask field properties box and type “PROD-”00AA (use zeros and not the 
letter O for 00).

This input mask formats the ProdID field to automatically begin with PROD- followed by two 
numbers and then two letters.

 4.  Choose File→Save and the Property Update Options smart tag will appear next to the input 
mask you just entered.

 5.  Click the smart tag  and choose Update Input Mask Everywhere ProdID Is Used.

Access displays the Update Properties dialog box, which contains a list of all objects using the field. 
For this field, only one object is listed.

 6.  Click Yes to update the Products Report object and then switch to Datasheet View.

The ProdID field now has PROD- preceding each product ID.

 7.  Close the Products table.

Use the Input Mask Wizard
Now you will apply a standard input mask format to a field.

 8.  Open the Employees table in Datasheet View.

The Telephone field contains numbers without any other symbols.

 9.  Switch to Design View and click anywhere in the EmpPhone field.

 10.  Click in the Input Mask field property box and then click the Build  button on the right side 
of the box.

 11.  Choose Phone Number as the input mask and click Finish.
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 12.  Save the table and then switch to Datasheet View.

Notice the phone numbers are now formatted with parentheses and a hyphen because of the input mask.

 13.  Switch back to Design View.

Create Additional Settings
 14.  Change field properties to set the field sizes, input masks, and captions as indicated.

For the EmpLastName and EmpFirstName input masks, you’re using 24 question marks; you’re using 
14 question marks for the EmpCity input mask. These input masks use >L< to specify that the first 
character should automatically be capitalized and the next 24 or 14 question marks specify that up to 
24 or 14 alphabetic characters may be entered.

Field Field Size Input Mask Caption

EmpID 3 >LLL ID

EmpLastName 25 >L<???????????????????????? Last Name

EmpFirstName 25 >L<???????????????????????? First Name

EmpStreetAddress 30 Street Address

EmpCity 15 >L<?????????????? City

EmpST 2 >LL State

EmpZIP ZIP

EmpEmail Email

HireDate Hire Date

WebCert Web Cert

 15.  Choose File→Save and choose Yes when advised that some data may be lost.

 16.  Switch to Datasheet View.

The column headings now show captions rather than field names. The Caption property lets you use 
descriptive headings for fields, as field names cannot contain spaces.

 17.  Enter these records, using (Tab) to move between fields and only lowercase letters in the ID, Last 
Name, and First Name fields:

Field Name Field Data

ID Fdr

Last Name Roberts

First name Fred

Street Address 362 Lakeview Ave.

City Sarasota

State FL

Zip 34234

Phone 9415553981

Email FredRoberts@email.com

Hire Date 9/26/2018

Web Cert Yes (check)

Notice as you enter the data into the fields that some letters are automatically converted to uppercase 
due to the input mask rules you set.

 18.  Close the Employees table.
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Setting Validation Rules
A validation rule is a field property that enables you to limit the values entered in the field to reduce 
inaccurate data entry. You could, for example, set a validation rule to limit the value typed into an 
HoursWorked field to 50 or fewer, or the value of Pay Rate to less than $60.

Setting Appropriate Data Types for Validation Rules
For validation rules to be effective, the field for which you are setting the rule must be formatted 
appropriately for the data type to be entered. For example, if you set a validation rule requiring a 
four-digit number, the data type for the field should be set to Number. If you are requiring dates that 
occur before a specific date, the data type for the field should be Date/Time.

Validation Text Messages
When you set a validation rule for a field, it’s a good idea to set validation text, which contains 
instructions or valid data values to help guide data entry. Access displays the text as a message each 
time an invalid value is entered in the field.

Setting Different Types of Validation Rules
Validation rules are used to examine data entered into tables and forms. You can set comparison 
rules. Samples of comparison rules you can set to determine whether the value is within a valid range 
are shown in the following table:

VALIDATION RULES

Comparison Validation Rule Example Validation Text Example
Greater than >100 Enter a value greater than 100.

Less than <100 Enter a value less than 100.

Equal to =1 Or =2 Enter a value of 1 or 2.

Date after a date >#1/1/2017# Enter a date after January 1, 2017.

Greater than or equal to >=100 Enter a value of 100 or more.

Less than or equal to <=100 Enter a value of 100 or less.

Like Like “ID-0000” Enter a four-digit value starting 
with ID-.

Between Between 1 and 8 Enter a value from 1 to 8.

The same wildcards used to enter input masks are used in validation rules. For example, the question 
mark is substituted for each character that is required, such as in ID-????. The asterisk (*) can substitute 
for a group of characters that may vary, such as in ID-*.

DEVELOP YOUR SKILLS: A5-D10

In this exercise, you will set validation rules for data entered into fields in the Products table.

 1.  Display the Products table in Design View.

 2.  Click anywhere in the Price field and then click in the Validation Rule field property box.

 3.  Type >=25 as the validation rule.

 4.  Click in the Validation Text box and type: All prices must be at least $25

 5.  Choose File→Save and choose Yes to acknowledge that the date integrity rules have been 
changed.
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Test the New Validation Rules
 6.  Switch to Datasheet View.

All ProdID entries begin with PROD- because of the input mask you set earlier.

 7.  Click in the ProdID field for the new, blank record and type: 07SW

 8.  Tap [Tab], type Switchboard Page as the description, and tap [Tab] again to move to the 
Price field.

 9.  Type 20 in the Price field and tap [Tab].

The warning appears because of the validation rule you just set for the Price field. Notice the All prices 
must be at least $25 validation message you set is displayed in the alert.

 10.  Click OK to acknowledge the error message, type 30 for the price, and tap [Tab].

 11.  Close the Products table.

Setting Lookup Fields with the Lookup Wizard
All tables in a relational database are related in some way to each other, as well as to other objects 
in the database. Data from one table is often used in another table. A lookup field enables you to 
select a field value in one table by looking up values from another table; or you could select from a 
list of values entered by the database designer. The list of valid entries appears in a drop-down menu 
in the table accessing the values. 

A lookup field displays a menu arrow at the 
right end of the field during data entry.

This example shows the Products 
list displaying selectable values.

Using a lookup value also enables you to look up values from one field and return a value from a 
different field in the connected table. For example, you can look up a product number by typing the 
common product name. When a lookup field is created using values in another table, a relationship is 
also created between the lookup field and the field that contains the values.

Benefits of Lookup Tables
Adding a lookup field to a table serves three primary purposes:

 Ý It reduces the time required to enter the data repeatedly.

 Ý It reduces errors associated with data entry.

 Ý It restricts data to valid entries.
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For example, if you are processing time card data before issuing employee checks, setting a lookup 
field of valid employee IDs helps ensure only valid employees receive checks. Lookup fields also help 
reduce the number of redundant fields contained in database tables.

Performing a Lookup
Access provides the following two ways to use the Lookup feature:

 Ý Lookup Wizard: This data type launches the Lookup Wizard, which walks you through the process 
of setting up a lookup field.

View the video “Using the Lookup Wizard.”

 Ý Lookup tab: This option in the Design View Field Properties pane sets the data source containing 
the values you want to display in the field.

DEVELOP YOUR SKILLS: A5-D11

In this exercise, you will delete the relationship between two tables and create a lookup field in the 
Products table that displays a list of valid products. You will then use the lookup field to enter data into the 
Invoice Details table.

 1.  Make sure all tables are closed (you cannot make relationship changes to an open table).

 2.  Choose Database Tools→Relationships→Relationships .

 3.  Right-click the join line linking the EmpID fields in the Employees and Invoices tables.

Your mouse pointer must be directly on the line for the menu to appear.

 4.  Choose Delete and then click Yes to confirm.

 5.  Using the same procedure, delete the relationship between EmpID in the Employees table and 
EmployeeID in the EmpSpouses table.

 6.  Close the Relationships window.

 7.  Display the InvoiceDetails table in Design View.
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 8.  Click in the ProdID Data Type box and then click the drop-down menu button �.

 9.  Choose Lookup Wizard from the menu.

 10.  Click Next to accept the current setting, I Want the Lookup Field to Get the Values from Another 
Table or Query.

 11.  Choose Table: Products in the next Wizard screen and then click Next.

The Products table will contain the values to be looked up.

 12.  Move all three available fields to the Selected Fields list and click Next.

 13.  Choose ProdID as the sort field, leave the sort order as Ascending, and click Next.

The next Wizard screen lets you adjust the width of the lookup field columns, which determines how 
the columns appear when the lookup field is used.

 14.  Uncheck the Hide Key Column checkbox and then double-click the right borders of all three 
column headings to best fit the columns; click Next.

 15.  Click Next again to choose ProdID as the field that uniquely identifies the row.

 16.  In the next screen, leave the label set to ProdID, check the Enable Data Integrity box, and 
choose the Cascade Delete option.

 17.  Click Finish and then choose Yes in the two warning boxes.

Test the Lookup Field
 18.  Switch to Datasheet View.

 19.  Click in the ProdID field for the 02SP record (second record in the table).

 20.  Click the drop-down menu button � and choose the 07SW product.

This product ID replaces the 02SP for that record, so invoice 1 still has three products listed on it, but 
one of them has changed. This lookup field makes it easy for you to view a listing of products when 
adding them to invoices.

 21.  Close the InvoiceDetails table.
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Creating Lookup Fields for Multiple Values
You have already created a lookup field that enabled you to select a single item from a list. You can 
also set up lists that allow you to select multiple values to enter for each lookup field. If, for example, 
an inventory item is available from more than one supplier, you can set up the field to allow you to 
select all suppliers for an item. To create a selection list, simply check the Multiple Items option as 
you move through the Lookup Wizard screens.

DEVELOP YOUR SKILLS: A5-D12

In this exercise, you will create a lookup field in the Invoices table that allows you to assign two or more 
employees to an inventory item.

 1.  Display the Invoices table in Design View.

 2.  Click in the EmpID Data Type box, click the menu button �, and choose Lookup Wizard.

 3.  Click Next to accept the current setting, I Want the Lookup Field to Get the Values from Another 
Table or Query.

If you choose the I Will Type the Values in That I Want option, you can create your own list of items.

 4.  Choose Table: Employees and click Next.

The Employees table will contain the values to be looked up.

 5.  Move the EmpID, EmpLastName, and EmpFirstName fields to the Selected Fields list and click 
Next.

 6.  Choose EmpID as the sort field, leave the sort order as Ascending, and click Next.

 7.  Click Next to accept the default width settings for the columns.

 8.  In the final Wizard screen, check the Allow Multiple Values box, leave the label set to EmpID, 
and click Finish.

 9.  Choose Yes in the message box to confirm you want to store multiple values.

 10.  Choose Yes to save the table and choose Yes one last time to confirm that some data may be 
lost.

Test the Multiple Values Lookup Field
 11.  Switch to Datasheet View.

 12.  Click in the Emp ID field for the third record (invoice 3).

Tip!
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 13.  Click the drop-down menu button � to display the list of employees.

 14.  Check the box for Winchester (leave Mansfield checked) and click OK.

 15.  Double-click the border between the Emp ID and Cust ID columns to best fit the Emp ID 
column.

Invoice 3 now has two employees assigned to it. Notice that both employee names are visible in the 
Emp ID field.

 16.  Close the database, saving the changes to the Invoices table.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A5-R1

Create Relationships and Modify Table Structure
The president of Kids for Change, an organization that encourages young people to participate in 
community-based projects, has asked you to modify its database. In this exercise, you will create a 
relationship between tables and create a relationship report. You will rename a table and add a new field, 
delete and modify fields, and enhance the datasheet with color.

 1.  Open A5-R1-K4C from your Access Chapter 5 folder and save it as: A5-R1-K4CRev

 2.  Choose Database Tools→Relationships→Relationships  and then click Show Table .

 3.  Add the Volunteers table to the Relationships window and then close the Show Table box.

 4.  Expand the Volunteers field list by dragging down on the bottom edge of the list until all fields 
are shown.

 5.  Drag the ActID field from the Activities table and drop it on the ActID field in the Volunteers 
table.

 6.  Check the Enforce Referential Integrity checkbox and click Create to establish the 
relationship.

The join line has a 1 at the Activities table end and an infinity symbol (∞) at the Volunteers table end.

 7.  Choose Relationship Tools→Design→Tools→Relationship Report .

 8.  Close the report, saving it as Relationships and then closing the Relationships window, 
saving the changes if prompted.

Modify the Table Structure
 9.  Right-click the Staff table and choose Rename; then type PaidStaff and tap [Enter].

 10.  Display the PaidStaff table in Design View.

 11.  Right-click the row selector for the StaffStreet field and choose Insert Rows.

 12.  Click in the new Field Name box and then type Parent and tap [Tab].

 13.  Set the Data Type of the new field to Yes/No and enter Parent of K4C child in the 
Description box.

 14.  Switch to Datasheet View and save the table.

 15.  Check the Parent Yes/No boxes for parents with the last names of Lockwood, Kendall, and 
Riggs.

 16.  Close the PaidStaff table and then open the Donations table in Design View.

 17.  Click the row selector for the Acknowledgement field and tap [Delete]. Choose Yes to confirm 
and then close the Donations table, saving the changes.

Format a Table Datasheet Layout
 18.  Display the Children table in Datasheet View.

 19.  Click the First Name column heading and then hover the mouse pointer over the heading until 
the white pointer appears.
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 20.  Drag the First Name column to the left of the Last Name column.

 21.  Drag the mouse pointer over the Address, City, ST, and ZIP columns to select those columns.

 22.  Right-click one of the selected column headings and choose Hide Fields.

 23.  Double-click the right edges of the Mother and Father column headings to best fit those 
columns.

 24.  Choose Home→Text Formatting→Alternate Row Color  menu button � and choose 
any light alternate row color.

 25.  Choose Home→Text Formatting→Gridlines  menu button � and choose Gridlines: 
Horizontal.

 26.  Click the Text Formatting dialog box launcher to open the Datasheet Formatting dialog box.

 27.  Choose these settings:

• Use the Gridline Color list to choose a dark gridline color to create a nice contrast with the 
light alternate row color you chose.

• In the Border and Line Styles section, choose Column Header Underline as the border style.

• Also in the Border and Line Styles section, choose Dots as the line style.

 28.  Click OK to apply the formats and then close the database, saving the changes.

REINFORCE YOUR SKILLS: A5-R2

Set Field Properties and Create Lookup Fields
As head of Tech Development for Kids for Change, you want to set some database field properties. In this 
exercise, you will set field size, convert values to uppercase, set captions and default values, make a field 
required, and create a custom format for an ID field. You will set a predefined telephone input mask, add a 
validation rule, and set a lookup field.

 1.  Open A5-R2-K4C from your Access Chapter 5 folder and save it as: A5-R2-K4CRev

 2.  Display the Volunteers table in Design View.

 3.  Use this table to set the Field Size and Caption properties:

Field Name Field Size Caption

VolID 12

VolLastName 25 Last Name

VolFirstName 25 First Name

VolStreet 25 Street

VolCity 25 City

VolST 2 ST

VolZIP 5 ZIP Code

VolPhone 15 Telephone

ActID 6 Act/Day
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 4.  Set the Required property of the ActID field to Yes.

 5.  Select the VolST field and set the Format property to > and the Default Value to: FL

Using > as the Format property will convert lowercase values to uppercase values.

 6.  Switch to Datasheet View and choose Yes to save the table; click Yes twice to acknowledge the 
two messages that appear.

 7.  Enter this new record:

Field Name Value

VolID 10

LastName Graves

FirstName Matthew

Street 915 Beneva St

City Sarasota

ST FL

ZIPCode 34232

Telephone 9415556198

Act/Day BCSat

 8.  Close the Volunteers table.

Set an Input Mask and Validation Rules
 9.  Display the Activities table in Design View.

 10.  Set the Input Mask property of the ActID field to: "K4C-">LLL<LL

This input mask starts each ActID with the literal value K4C- followed by three uppercase (>) letters 
and two lowercase (<) letters; for example, K4C-DWTue for dog walking on Tuesday.

 11.  Switch to Datasheet View, saving the changes to the table.

 12.  Scroll to the end of the table and click in the first empty Activity ID field.

Access automatically places the new prefix in the field because of the input mask you just created.

 13.  Close the Activities table and then display the Volunteers table in Datasheet View.

Notice the Telephone field displays numbers with no formatting.

 14.  Switch to Design View, click anywhere in the VolPhone field, and then click in the Input Mask 
property box.

 15.  Click the Build  button to start the Input Mask Wizard.

 16.  Choose the Phone Number mask and click Finish.

 17.  Switch to Datasheet View, saving the changes to the table.

Notice the Telephone field is now formatted with the input mask characters.

 18.  Close the Volunteers table and then display the Children table in Design View.

 19.  Set the Validation Rule property of the BirthDate field to: >01/01/2008

 20.  Enter Only children born after January 1, 2008, may enroll in the 
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 21.  Switch to Datasheet View, choose Yes to save the table, and then choose Yes again when the 
data integrity message appears.

 22.  Enter this information into a new record:

Field Name Value

ChildID CasadoM

LastName Casado

FirstName Marty

Address 302 Waterside Ave

City Bradenton

ST FL

ZIP 34202

Telephone 9415551652

BirthDate 11/24/2007

The input mask will not allow you to enter the birth date because it is prior to 01/01/2008.

 23.  Click OK and then change the Birth Date value to: 11/24/2008

 24.  Complete the record by entering Sandy for Mother, Javier for Father, and 9415551653 for 
Emergency.

Set a Field as a Lookup Field
 25.  Switch to Design View.

 26.  Click anywhere in the ChildST field and then click the Lookup tab in the Field Properties box and 
choose Combo Box as the Display Control.

 27.  Enter these lookup properties (also shown in the preceding image):

• Row Source: States

• Column Count: 2

• Column Widths: 0.3; 1.2

• List Width: 1.5

 28.  Switch to Datasheet View and save the changes to the table.

 29.  Click in the ST field for DriverJ, which is missing the state.

 30.  Open the combo box of lookup values and choose FL.

 31.  Close the database, saving the changes.
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REINFORCE YOUR SKILLS: A5-R3

Set Relationships and Add a Lookup Field
The Kids for Change database is performing better, but you want to improve table appearance and 
facilitate data entry and validation. In this exercise, you will add a field to indicate whether a staffer has 
a master’s degree, delete an unneeded table, and rearrange fields. You will hide a field, resize columns to 
better display data, create a custom input mask with data validation, and apply a predefined input mask.

 1.  Open A5-R3-K4C from your Access Chapter 5 folder and save it as: A5-R3-K4CRev

 2.  Choose Database Tools→Relationships→Relationships .

 3.  Establish a relationship by dragging the DonorID field from the Donors table to the DonorID 
field in the Donations table.

 4.  Check the Enforce Referential Integrity checkbox and click Create.

 5.  Choose Relationship Tools→Design→Tools→Relationship Report .

 6.  Close the report, saving it as Relationships and then closing the Relationships window.

Modify the Table Structure
 7.  Display the PaidStaff table in Design View.

 8.  Right-click the ActID row selector, choose Insert Rows, and type Masters for the new field 
name.

 9.  Set the Data Type to Yes/No and enter Master’s degree or higher as the Description.

 10.  Switch to Datasheet View and save the table.

 11.  Check the Master’s checkboxes for records with the last names of Bryant, Lockwood, and 
Riggs.

 12.  Switch to Design View.

 13.  Click the field selector box for the 2ndDay field and tap [Delete] to remove it. Choose Yes to 
confirm the deletion.

 14.  Switch to Datasheet View and save the table.

Format a Table Datasheet Layout
 15.  Move the Email Address column to the left of the Master’s column.

 16.  If necessary, scroll to the right until the HrlySal column is visible. Right-click the HrlySal column 
heading and choose Hide Fields.

The hourly salary field is no longer displayed, but the data remains in the table.

 17.  If necessary, scroll to the left and then double-click the right edge of the Email Address column 
heading to Best Fit the column.

All email addresses should now be visible.

 18.  Choose Home→Text Formatting→Alternate Row Color  menu button � and choose 
any light alternate row color.

 19.  Choose Home→Text Formatting→Gridlines  menu button � and choose Gridlines: 
Horizontal.

 20.  Open the Datasheet Formatting dialog box via the dialog box launcher in the Text Formatting 
group.
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 21.  Open the Gridline Color menu, choose a dark color to complement the light row color, and 
click OK.

 22.  Close the PaidStaff table, saving the changes.

Set Field Properties
 23.  Display the Donors table in Design View.

 24.  Set these field sizes and captions:

Field Name Field Size Caption

DonorLName 25 Last Name

DonorFName 25 First Name

DonorStreet 25 Street

DonorCity 25 City

DonorST 2 ST

DonorZIP 5 ZIP

DonorPhone 15 Telephone

DonorEmail (No change) Email Address

 25.  Set the Required property of the DonorLName field to Yes and set the Allow Zero Length  
property to No.

 26.  Set the Format property of the DonorST field to > and the Default Value property to: FL

 27.  Switch to Datasheet View, saving the changes to the table, choosing Yes in the warning box, 
and choosing Yes again in the second warning box.

 28.  Enter this record, closing the Donors table when finished:

Field Name Value

DonorID (Automatically set)

LastName Castro

FirstName Lana

Street 4040 Conquistador Way

City Bradenton

ST FL

ZIP 34212

Telephone 9415556626

EmailAddress MCastro@email.com

Acknowledgement For Mina

Set Formats, Input Masks, and Allow Zero Length
 29.  Display the Donations table in Design View.

 30.  Set these field properties in the DonationType field:

• Input Mask: >L<LL

• Validation Rule: Bus Or Pvt

• Validation Text: Must be Bus or Pvt
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 31.  Switch to Datasheet View, saving the changes to the table and choosing Yes in both warning 
boxes.

 32.  Add this record to test the new input mask:

Field Name Value

DonorID 12

DonationDate 04152013

Amount 1000

DonationType Pmt

 33.  Tap [Tab] after entering the donation type.

The validation text message appears because Pmt is not an allowable DonationType entry. This is 
because the validation rule you set allows only entries of Bus or Pvt.

 34.  Click OK and then type Pvt in the DonationType field.

 35.  Close the Donations table and then display the Donors table in Design View.

 36.  Set the Format property of the Acknowledgement field to: @; No Comments

This will display the phrase No Comments when the Acknowledgement field is left blank.

 37.  Click in the DonorPhone field and then click in the Input Mask property box.

 38.  Click the Build  button to start the Input Mask Wizard, saving the table when prompted.

 39.  Choose the Phone Number mask and click Finish.

 40.  Switch to Datasheet View, saving the changes to the table.

Notice that all telephone numbers now have proper and consistent formatting. Also notice that the 
phrase No Comments appears in all records in which no Acknowledgement was entered.

 41.  Close the Donors table.

Set a Field as a Lookup Field
 42.  Display the PaidStaff table in Design View.

 43.  Click anywhere in the ActID field and then click the Lookup tab in the Field Properties box and 
choose Combo Box as the Display Control.

 44.  Enter these Lookup properties:

• Row Source: Activities

• Column Count: 2

• Column Widths: 0.5; 1.5

• List Width: 2

 45.  Switch to Datasheet View and save the changes to the table.

 46.  Right-click the Email Address column heading and choose Unhide Fields.

 47.  Check the HrlySal box and then close the Unhide Columns box.
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 48.  Test the new lookup field by adding this record:

Field Name Value

StaffID (Automatically entered)

LastName Francesco

FirstName Dominic

Parent Yes (checked)

StreetAddress 105 26th Street

City Sarasota

ST FL

ZIP 34209

Telephone 9415558287

Masters Yes (checked)

 49.  Type E in the Activity field.

Access displays the first value that begins with the letter E: EBSun.

 50.  Tap [Tab] to accept the EBSun entry.

 51.  Type 27 in the Hrly Sal field and DomFrancesco@email.com in the Email Address field.

 52.  Close the database, saving changes to any tables if prompted.
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 Apply Your Skills
APPLY YOUR SKILLS: A5-A1 

Create Relationships and Modify Table Structure
The CEO of Universal Corporate Events has asked you to make some changes to the UCE database. 
In this exercise, you will create a relationship between two tables, set referential integrity, and create 
a relationship report. You will rename and add a Yes/No field to a table as well as delete, modify, and 
rearrange fields. Finally, you will improve the appearance of the Menus table.

 1.  Open A5-A1-UCE from your Access Chapter 5 folder and save it as: A5-A1-UCERev

 2.  Establish a relationship between the VenueID fields in the Venues and Schedules tables, 
enforcing referential integrity.

 3.  Create a relationships report named: Relationships

 4.  Close the report and the Relationships window.

Modify a Table’s Structure and Column Display
 5.  Change the name of the Contacts table to: VenueLiaisons

 6.  Insert a new field in the Venues table above the VenueWebSite field with these settings:

Field Name Data Type Description

Kitchen Yes/No Does venue have a kitchen?

 7.  Switch to Datasheet View, saving the changes, and check the Yes/No Kitchen boxes for 
HyattS, ManYC, and SaraCC, SaraYC, and TmpCon.

 8.  Close the Venues table and then open the Schedules table in Design View.

 9.  Delete the VenueName field and then close the Schedules table, saving the changes.

 10.  Display the Personnel table in Datasheet View.

 11.  Move the Date Hired field to the left of the Last Name column.

 12.  Hide the Date of Birth field so it is no longer displayed.

 13.  Apply Best Fit to the Address and Email Address columns to make the widest entries in the 
columns fully visible.

 14.  Close the Personnel table, saving the changes.

Change the Formatting of a Datasheet
 15.  Display the Menus table in Datasheet View.

 16.  Apply a light alternate row color and horizontal gridlines and change the gridline color to Black.

 17.  Close the database, saving the changes to the Menus table.



EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Apply Your Skills 167

APPLY YOUR SKILLS: A5-A2

Set Field Properties, Apply Input Masks, and Create Lookup Fields
In this exercise, you will modify field properties in the UCE database tables to more accurately describe 
and limit the data. You will set field sizes and captions, convert field values, set a default value for easier 
data entry, and make a field required. You will also set a custom format for an ID field, apply a predefined 
input mask to a telephone field, add a validation rule, and set lookup fields.

 1.  Open A5-A2-UCE from your Access Chapter 5 folder and save it as: A5-A2-UCERev

 2.  Display the VenueLiaisons table in Design View and set these field sizes and captions:

Field Name Field Size Caption

LiaisonID 12

LiaisonLName 25 Last Name

LiaisonFName 25 First Name

LiaisonStreet 25 Street

LiaisonCity 25 City

LiaisonState 2 State

LiaisonZIP 5 ZIP Code

LiaisonPhone 15 Telephone

LiaisonEmail Email Address

 3.  For the LiaisonPhone field, set the Required property to Yes and the Allow Zero Length property 
to No.

 4.  Set the Default Value property of the LiaisonState field to: FL

 5.  Switch to Datasheet View, saving the changes to the table and choosing Yes in the warning 
boxes, and then add this record:

Field Name Value

LiaisonID AntonV

LastName Anton

FirstName Vera

Street 44 West Florida St.

City Bradenton

State FL

ZIP 34205

Telephone 9415554248

EmailAddress VAnton@email.com

 6.  Close the VenueLiaisons table.
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Create a Custom Field Format
 7.  Display the Personnel table in Design View.

 8.  Set these properties for the PerID field:

• Field Size: 10

• Input Mask: "UCE-"9999

• Caption: ID

Each PerID will start with the literal value UCE, followed by four numbers, such as UCE-1001.

 9.  Switch to Datasheet View, saving the changes to the table and responding Yes to the warning 
message.

 10.  Click in the empty ID field in the new record at the bottom of the table.

If your input mask is set up properly, Access will automatically add the prefix UCE to the entry.

 11.  Close the Personnel table after verifying your input mask is set up properly.

 12.  Display the VenueLiaisons table in Design View.

Set an Input Mask
 13.  Use the Input Mask Wizard to apply the Phone Number mask to the LiaisonPhone field.

 14.  Switch to Datasheet View, saving the changes to the VenueLiaisons table.

The telephone numbers should now have the input mask applied.

 15.  Close the VenueLiaisons table. Display the Schedules table in Design View.

 16.  Set these field properties for the Guests field:

Validation Rule Validation Text

>=35 At least 35 guests must be entered

Set a Field as a Lookup Field

 17.  Click anywhere in the EventID field and then click the Lookup tab in the Field Properties box 
and choose Combo Box as the Display Control.

 18.  Set these Lookup properties:

Row Source Column Count Column Widths List Width

Events 2 0.6;1.5 2.1

 19.  Click anywhere in the Menu Code field and then click the Lookup tab in the Field Properties box 
and choose Combo Box as the Display Control.

 20.  Set these Lookup properties:

Row Source Column Count Column Widths List Width

Menus 2 0.6;1.5 2.1

 21.  Switch to Datasheet View and save the changes to the table, responding Yes to any warning 
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 22.  Enter this record:

Field Name Value

ScheduleID SEMBenson

VenueID ManCtr

EventID SEMNAR

MenuCode DINBUF

EventDate 7/3/2019

Guests 30

Access displays a validation text message because the number of guests entered is less than the 
minimum of 35.

 23.  Click OK; change the number of Guests to 40 and add Miller in the Liaison field.

 24.  Close the database, saving the changes to the table if prompted.

APPLY YOUR SKILLS: A5-A3

Improve Data Readability and Validation
The CEO of Universal Corporate Events wants you to clean up the company’s database tables and improve 
data readability and validation. In this exercise, you will add, delete, and rearrange fields. You will hide 
the cost per person in the Menus table, resize columns and set field sizes, and modify a field to convert 
data. Finally, you will set captions, default values, and field requirements; create a custom input mask; and 
modify a field to look up values.

 1.  Open A5-A3-UCE from your Access Chapter 5 folder and save it as: A5-A3-UCERev

 2.  Establish a relationship by dragging the Grade field in the SalaryGrades table to the 
SalaryGrade field in the Personnel table, enforcing referential integrity.

 3.  Create a relationships report named: Relationships

 4.  Review the object dependencies and then close the Object Dependencies panel.

Modify Table Structure and Column Display
 5.  Display the SalaryGrades table in Design View.

 6.  Insert a new field in the SalaryGrades table above the Salary field with these settings:

Field Name Data Type Description

Salaried Yes/No Indicates salaried position

 7.  Switch to Datasheet View, saving the changes, and check the Yes/No boxes for each record 
with data in the Salary field.

 8.  Close the SalaryGrades table and then display the Events table in Design View.

 9.  Delete the MinGuests field and then close the Events table, saving the changes.

 10.  Display the VenueLiaisons table in Datasheet View.

 11.  Select the Telephone and Email Address columns and move both to the left of the Street 
Address column.
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 12.  Apply Best Fit to all the columns and then close the table, saving the changes.

 13.  Display the Menus table in Datasheet View.

 14.  Hide the Cost/PP field and then close the table, saving the changes.

Change the Formatting of a Datasheet and Set Field Properties
 15.  Display the Venues table in Datasheet View.

 16.  Apply a light alternate row color and horizontal gridlines and change the gridline color to Black.

 17.  Close the Venues table, saving the changes.

Set Captions, Default Values, and Field Requirements
 18.  Display the Personnel table in Design View and set these field sizes and captions:

Field Name Field Size Caption

PerLastName 25 Last Name

PerFirstName 25 First Name

PerAddr 25 Street

PerCity 25 City

PerST 2 State

PerZIP 5 ZIP Code

PerPhone 15 Telephone

SalaryGrade Salary Grade

 19.  Set the Required property of the PerLastName field to Yes.

 20.  Set the Default Value property of the PerST field to: FL

 21.  Close the table, saving the changes and choosing Yes in the warning boxes.

Set Formats, Input Masks, Allow Zero Length, and Lookup Fields
 22.  Display the Schedules table in Design View.

 23.  Enter >LLLL<?????? as the Input Mask field property for the ScheduleID field.

This mask forces 4 uppercase letters followed by from 0 to 6 lowercase letters.

 24.  Switch to Datasheet View, saving the changes.

 25.  Scroll down and type any series of 10 lowercase letters in the ScheduleID field of a new record.

Because of the input mask, Access converts the first 4 letters to uppercase.

 26.  Tap [Esc] to remove the data you just entered.

 27.  Type any series of 8 uppercase letters in the ScheduleID field.

Because of the input mask, Access converts all but the first 4 letters to lowercase.

 28.  Tap [Esc] to exit the record without saving and then close the Schedules table, choosing OK and 
Yes when prompted.

 29.  Display the Venues table in Design View.

 30.  Set the Format field property of the VenueWebSite field to: @; No Website

This will display No Website if there is no data in the VenueWebSite field.
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 31.  Set the Allow Zero Length property of the VenueLiaison field to No.

 32.  Save the Venues table, choosing Yes in the warning box.

 33.  Use the Input Mask Wizard to apply the Phone Number mask to the VenuePhone field.

 34.  Click anywhere in the VenueST field and then click the Lookup tab in the Field Properties box 
and choose Combo Box as the Display Control.

 35.  Set these Lookup properties:

Row Source Column Count Column Widths List Width

States 2 0.3;1.2 1.5

 36.  Switch to Datasheet View, saving the changes if prompted, and enter this record:

Field Name Value

VenueID BradCC

Name Bradenton Country Club

Street 2903 9th Ave

City Bradenton

ST FL

ZIP 34205

Phone 9415550031

Kitchen Yes

Website bcc.com

Liaison AntonV

 37.  Close the database, saving the changes to the Venues table and any other open tables.
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  Project Grader

PROjECT GRADER: A5-P1

Taylor Games: Designing Tables and Creating Relationships
Taylor Games is getting ready to take customer orders, but before it can begin, its database tables need to 
be refined. You will add a relationship, modify data types, create a lookup field, set a validation rule, add a 
new field, and set additional field settings.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A5_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A5_P1_Start from your Access Chapter 5 folder.

 2.  In the Order Details table, use the Lookup Wizard in the Line Item field and apply the follow-
ing Wizard settings to convert the field to a lookup field:

• Get the values from the Inventory table.

• Add SKU and then Item to the Selected Fields list.

• Do not set a sort order.

• Hide the Key Column.

• Leave the label as Line Item.

• Do not enable data integrity or allow multiple values.

 3.  In the Orders table, use these guidelines to add a new lookup field below the Order_Date field:

• Name the field Service _ Rep and initiate the Lookup Wizard.

• Get the values from the Service Reps table.

• Add Rep_ID, First_Name, and Last_Name (in that order) to the Selected Fields list.

• Sort by Last_Name in Ascending order.

• Hide the Key Column.

• Leave the label as Service_Rep.

• Do not enable data integrity or allow multiple values.

 4.  Set the Caption property of the new Service_Rep field to: Service Rep

 5.  Use these guidelines to apply formatting to the Orders table:

• Apply horizontal gridlines.

• Apply alternate row color using the Turquoise, Accent 1 theme color.
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 6.  Create a relationship using these guidelines:

• Create a One-To-Many relationship between the Order_ID field in the Orders table and the 
ID field in the Order Details table.

• Enforce referential integrity.

• Allow cascade updating of related fields.

 7.  Set these field properties in the Service Reps table:

• Make Position a required field.

• In the Hire_Date field, set the Caption to: Hire Date

• In the Hire_Date field, set this Validation Rule: >#12/31/2018#

• In the Hire_Date field, set this Validation Text: 2019 or later new hires

 8.  In the Service Reps table, follow these guidelines to create a new field:

• Position the new field below the Hire_Date field.

• Field Name: CSR_Training

• Data Type: Yes/No

• Caption: Trained?

 9.  With the Service Reps table in Datasheet View, check the boxes in the Trained? column for the 
first three service reps.

 10.  Save your database.

• Using eLab: Save it to your Access Chapter 5 folder as A5 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 5 folder as: A5 _ P1 _ Submission

PROjECT GRADER: A5-P2

WebVision: Refining Table Design
The WebVision database is growing, which requires additional settings and relationships. You will create a 
lookup field, add and delete table fields, and create relationships that connect your tables. You will then 
change the name of a table and set field properties.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A5_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A5_P2_Start from your Access Chapter 5 folder.

 2.  In the Orders table, delete the Amount field and the data in it.

 3.  Use these guidelines to create a new lookup field in the Orders table:

• Position the field below the RepID field.

• Name the field: Customer

• Use the Lookup Wizard and get the values from the Customers table.

• Add Customer ID and Company Name to the Selected Fields list.

• Do not set a sort order.

• Hide the Key Column.

• Use the label: Customer

• Do not enable data integrity or allow multiple values.
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 4.  In the Orders table, use the Customer lookup field to add customers to existing orders as shown 
here:

Order Number Rep ID Customer

1 S101 Wide World Imports

2 S102 Fourth Coffee

3 S103 Alpine Ski House

4 S104 Westwind Traders

5 S101 Coho Vineyard & Winery

 5.  In the Orders table, adjust the width of the Customer column to fit the widest entry.

 6.  Create a relationship using these guidelines:

• Create a One-To-Many relationship between the OrderID field in the Orders table and the 
Order ID field in the Order Details table.

• Enforce referential integrity.

 7.  Rename the Products and Services table as: Line Items

 8.  In the Customers table, set these field properties for the State/Province field:

• Field Size: 2

• Input Mask: >LL

 9.  In the Customers table, set these field properties for the Postal Code field:

• Field Size: 5

• Input Mask (zeros): 00000

 10.  In the Customers table, create an input mask on the Phone Number field using these guidelines:

• Use the Input Mask Wizard.

• Choose the Phone Number input mask.

• Keep the placeholder character set to the default.

• Store the data With the symbols in the mask.

 11.  Save your database.

• Using eLab: Save it to your Access Chapter 5 folder as A5 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 5 folder as: A5 _ P2 _ Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A5-E1 That’s the Way I See It
You have decided to enhance the table structure in the Blue Jean Landscaping database. Open 
and then save A5-E1-BJL as A5-E1-BJLRev and begin by creating a relationship between the 
MerchID fields in the StoreMerchandise and SalesInvoices tables. Enforce referential integrity 
and create a relationships report (call it BJL Relationships). Autofit all columns in the 
StoreMerchandise table, apply the input mask "BJL"-9999 to the MerchID field, and switch the 
order of the Manufacturer and ItemName fields. In the Customers table, make the last name 
required, display the message No Email for customers without an email address, and use the 
Input Mask Wizard to apply the Phone Number input mask to the CustTelephone field.

A5-E2 Be Your Own Boss
You want to improve how your Blue Jean Landscaping database looks and behaves. Open and save 
A5-E2-BJL as A5-E2-BJLRev and first create relationships between the CustID fields in the 
Customers and SalesInvoices tables and between the CustID fields in the Customers and ServiceInvoices 
tables. Enforce referential integrity and create a relationships report (named BJL Relationships). 
In the ServiceInvoices table, hide the ServID field, autofit all remaining columns, and make all fields 
required. In the ServiceReps table, apply the input mask "BJLRep-"9999 to the RepID field and the Phone 
Number input mask to the RepPhone field. Finally, set RepState as a combo box lookup field with the 
field properties Row Source=States, Column Count=2, Column Widths=0.5, 1.5, List Width=2.

A5-E3 Demonstrate Proficiency
Stormy BBQ is continuing to update its database as it remodels its flagship location in Key West to 
give it a more tropical look and feel. It’s also added more employees! To begin, open A5-E3-SBQ 
and save it as: A5-E3-SBQRev

Apply the techniques learned in this chapter to format and dress up the Staff table. Set appropriate 
field sizes and captions, autofit columns as needed, and display the text No Email Available for staff 
members who don't have an email address.
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ÝÝ Create a form that contains a subform

ÝÝ Add a calculated control to a form

ÝÝ Add a total row to a form

ÝÝ Disable form fields

ÝÝ Lock form fields

ÝÝ Add ScreenTips to forms

ÝÝ Create pop-up forms

6 Customizing Input 
Forms

ACCESS

R
elational database design often 

requires data from more than 

one table or query to appear 

on the same form. Customizing forms and 

their controls while applying other form 

settings gives designers more control while 

simultaneously making forms more efficient 

and easier to use. In this chapter, you will 

add a subform to a main form, which is a 

handy technique used to include data from a 

different source. You will also explore Access 

features to create calculated fields, add tips 

to form controls, and set control properties 

to protect and limit data entry.
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Ý Project: Formatting Functional Forms
Winchester Web Design has seen sales increase over recent months and wants to simplify 
data entry as a result. You’ve been asked to design advanced forms to make data entry easier 
for all team members and less prone to errors. You will create an invoice form that contains a 
subform containing invoice details. Your form will also contain a calculated field for creating 
totals, and you will use form features to enhance data entry. The database relationships will be 
critical for setting up these forms.

Subforms
Although many forms are designed to enter data into a single table, there are times when you 
may need forms that perform actions such as processing customer invoices, calculating totals, and 
locating data from multiple tables. One of the best ways to accomplish this is through a subform, 
which is a secondary form placed on a main form. Subforms work well when one-to-many relation-
ships are set, allowing the user to work with multiple tables on a single form. Subforms are simply 
subsets of data linked by parent fields on the main form to child fields on the subform.

The detail data from related tables appears in a subform.

A main form displaying customer and employee information



EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Subforms 179

Creating Subforms
The easiest way to create a subform is to use the Form Wizard, which creates a new form with an 
option to add a subform. Subforms can also be added to existing forms by placing a Subform control 
on the existing form, where you can specify the subform’s position and size. When the Subform 
control is added to the form, the Subform Wizard launches, allowing you to set subform properties.

View the Video “Creating Subforms with the Form Wizard.”

ÝÍ Create→Forms→Form Wizard 

ÝÍ Design→Controls→Subform 

DEVELOP YOUR SKILLS: A6-D1

In this exercise, you will use the Form Wizard to create an invoice form that contains an invoice details 
subform.

 1.  Open A6-D1-WinDesign from your Access Chapter 6 folder and save it as: 
A6-D1-WinDesignRev

 2.  Choose Create→Forms→Form Wizard .

 3.  Choose Table: Invoices from the Tables/Queries list and then add the InvNum and CustID 
fields to the Selected Fields list.

 4.  Add the fields indicated to the Selected Fields list, making sure to add them in the order shown:

Customers Invoices Employees InvoiceDetails Products InvoiceDetails
CustLastName InvDate EmpID ProdID ProdDescription Qty

CustFirstName EmpLastName Price

CustStreetAddress EmpFirstName

CustCity

CustState

CustZIP

CustPhone

CustEmail

 5.  Click Next and notice that the data is arranged by invoice number and the Form with 
Subform(s) option is already chosen.

The subform preview in the Wizard includes the ProdID, ProdDescription, Price, and Qty fields.

 6.  Click Next to accept the settings; click Next again to accept the Datasheet subform layout.
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 7.  In the final Wizard screen, name the form Customer Invoices and the subform 
Customer InvoiceDetails Subform and then click Finish.

The new form and subform display in Form View.

 8.  Double-click the right border of each subform column heading to autofit the columns.

 9.  Click the empty ProdID cell in the new row at the bottom of the subform.

 10.  Click the drop-down menu button � and choose 03BL.

It’s easy to populate the first three fields of the new subform record.

 11.  Enter 1 in the Qty column and tap [Tab] to complete the record.EVALU
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Modifying Subforms
When you use the Form Wizard to create a subform, Access creates the subform and a main form 
with the subform embedded within it. Both are displayed in the Navigation pane. You can then open 
and modify the subform by itself in Layout View or Design View, or you can open the main form and 
modify it and the embedded subform together.

The Customer InvoiceDetails Subform and the Customer Invoices 
main form are displayed in the Navigation pane.

Subforms and their controls have their own Property Sheets that allow you to precisely control the 
subform layout and design. And you can use the same keystroke and mouse techniques to arrange 
and size subform controls that you use with main forms.

DEVELOP YOUR SKILLS: A6-D2

In this exercise, you will modify the Customer Invoices form and subform by deleting, moving, and sizing 
controls, and adding a graphic to the form.

 1.  Switch to Layout View.

You will begin by modifying the layout and controls on the main form.

 2.  Click the ST label in the main form to select it and then click inside the label and change it to: 
State

 3.  Change the ZIP label to: Zip

 4.  Locate the EmpID label and notice the Last Name and First Name labels below it.

 5.  Change the employee Last Name label to Emp Last Name and the employee First Name 
label to: Emp First Name

 6.  If necessary, display the Property Sheet by choosing Form Layout Tools→Design→Tools→ 
Property Sheet .

As you select and move controls in the following steps, you may need to drag the Property Sheet out 
of the way or close and reopen it as needed.

You can also tap [F4] to toggle the Property Sheet open and closed.Tip!
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 7.  Select the text boxes shown here by holding [Ctrl] while clicking the boxes and then set the 
Width property to: 1

 8. Select the text boxes shown here and set the Width property to: 2

Modify, Lay Out, and Size Controls on the Subform
 9.  Select the CustomerInvoiceDetails label on the subform and tap [Delete].

 10.  Click the right border of the subform frame and drag left until the frame is slightly wider than 
the subform.
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 11.  With the subform frame still selected, use the left arrow [¢] key to nudge the subform to the left 
to align it with the main form labels.

Modify the Form Header
In the next few steps, you will modify the form title and add color and a logo to the header.

 12.  Use these guidelines to modify the form:
• Click the title box control to select it and then click just in front of Invoices and press 
[Shift]+[Enter] to move Invoices to a new line.

• Set the Width property to: 3
• Replace Customer with: Winchester Web Design
• Select both lines and choose Home→Text Formatting→Center  to center the title in  

the box.

 13.  Click to the right of the title box in an empty part of the form header.

The title box will become deselected when you select the form header.

 14.  If necessary, display the Property Sheet and click in the Back Color property box.

 15.  Click the Build  button and choose a light blue color or whatever color you feel looks best in 
the form header.

 16.  Choose Form Layout Tools→Design→Header/Footer→Logo .

 17.  Navigate to your Access Chapter 6 folder, choose WWD-Logo.bmp, and click OK.

 18.  Set the Width and Height properties to 0.8 and the Left property to: 4
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 19.  Review your completed form and then close it, saving the changes to both the form and subform.

 

Adding Calculations to Forms
There are several ways to add calculations to forms, and the easiest way is to build a form based on a 
query that already has a calculated field. If your form is based on one or more tables or is based on 
a query without a calculated field, you will need to create a calculated control by adding an unbound 
control to the form and placing a formula within the control source property.

Applying Totals to Forms in Datasheet Layout
The Form Wizard has an option for creating a form in Datasheet Layout View. A form in Datasheet 
Layout View looks just like a table in Datasheet View. The Totals feature is available for tables in 
Datasheet View and for forms in Datasheet Layout View. The Totals feature lets you easily use 
an aggregate function such as count, sum, or average to create totals for numeric fields in the 
datasheet.

ÝÍ Home→Records→Totals 
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DEVELOP YOUR SKILLS: A6-D3

In this exercise, you will create a form that uses the Totals feature to count the number of individual line 
items on customer invoices and to total the amounts of all invoices.

 1.  Choose Invoices Query in the Navigation pane and then choose Create→Forms→ 
Form Wizard .

 2.  Move all fields to the Selected Fields list and click Next.

 3.  Choose Datasheet as the layout and click Next.

 4.  Name the new form Invoices Query Form and click Finish.

The form looks like a table when displayed in Datasheet View.

 5.  Choose Home→Records→Totals .

A Total line appears at the bottom of the datasheet layout.

 6.  Click in the Qty cell on the Total row.

A menu button appears at the left end of the cell.

 7.  Click the menu button � and choose Count, then click in the LineTotal cell and choose Sum 
from the menu.

The Count function simply counts the number of rows containing a quantity while the Sum function 
adds all line totals in the column.

 8.  Scroll through the datasheet’s 125 rows and notice that the Total row remains fixed at the 
bottom of the window.

The Totals feature is an easy way to use aggregate functions and is available in forms and in tables 
and queries.

 9.  Close the Invoices Query Form, saving the changes if prompted.

Creating Calculated Controls in Forms
The Totals feature is useful when you want to create totals for all records in a datasheet. But some-
times it’s necessary to display calculations in Form View, which displays just a single record at a time. 
You can do this by inserting a calculated control. A calculated control is an unbound text box control 
placed on the form with a formula inserted in the Control Source property. Usually, the formula 
references other controls on the form that are bound to underlying database fields. For example, you 
would use the formula =Price*Qty to display the total amount of a transaction, with both the Price 
and Qty fields shown on the form. Calculated controls can also contain aggregate functions or an 
array of built-in functions and expressions made available by using the Expression Builder.

A
C

C
E

S
S

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



186 Access Chapter 6: Customizing Input Forms

The Expression Builder dialog box contains a list of available fields in the current object and a selection of 
built-in operators, functions, and expressions that can be leveraged by both novice and advanced users.

View the Video “Calculated Controls in Forms.”

DEVELOP YOUR SKILLS: A6-D4

In this exercise, you will add a calculated control to the Customer InvoiceDetails subform.

 1.  Display the Customer InvoiceDetails subform in Design View.

The first step is to insert a new control.

 2.  Position the mouse pointer on the top edge of the Form Footer section bar until the resize 
pointer appears and then drag down slightly to make room for two new text boxes.

 3.  Choose Format Design Tools→Design→Controls→Text Box .EVALU
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 4.  Click just below the Qty control text box to insert a new control.

 5.  Use the arrow keys as needed to nudge the control so it is aligned with the Qty control.

Create Formulas
 6.  If necessary, choose Format Design Tools→Design→Tools→Property Sheet to display the 

Property Sheet.

 7.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Tax

Control Source =(Price*Qty)*.07

Format Currency

Decimal Places 2

Notice that the text for Price and Qty are now surrounded by brackets, which indicates that these are 
fields.

 8.  Click the Text8 label on the subform and set these properties:

Property Value

Caption Tax

Width 0.25

Left 0.25

 9.  Choose Format Design Tools→Design→Controls→Text Box .

 10.  Click just below the Tax control text box to insert a new control.

 11.  Use the arrow keys as needed to align the control with the Tax and Qty controls above it.

 12.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Line Total

Format Currency

Decimal Places 2

 13.  Click the Control Source property and then click the Build  button to the far right.

The Expression Builder dialog box appears.

A
C

C
E

S
S

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



188 Access Chapter 6: Customizing Input Forms

 14.  Follow these steps to create a calculated control with the Expression Builder:

C

A

D

E

B

A Scroll the Expression Categories pane until the Tax control is visible.

B Double-click the Price control to enter the field into the formula.

C Tap (*) and then double-click the Qty control.

D Tap (+) and then double-click the Tax control.

E Ensure your formula matches the example and then click OK.

 15.  Click the Text10 label on the subform and set these properties:

Property Value

Caption Invoice Total

Width 1

Left 0.25

 16.  Switch to Form View to see your new calculated controls in action.

 17.  Navigate to record 16 and others for which the quantity is greater than 1 and notice that your 
calculated controls always perform the correct calculations.

 18.  Close and save the form.
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Setting Properties to Assist and Control  
Data Entry

Some properties are meant to assist with data entry, while others help control or limit it. These 
properties are easily set using the Property Sheet.

Disabling Form Fields
Sometimes a form may include data that users should not enter themselves or even access, for 
example, setting up passwords or entering Social Security numbers. Many forms also contain settings 
that enter default values, such as states, or values that correspond to data contained in another field, 
such as city and ZIP code fields. To protect a field on a form from being edited during data entry, 
you can disable the field in the Property Sheet. Disabled fields are unavailable for data entry; they’re 
still visible, but they appear grayed out and are not accessible to the user. During data entry, Access 
automatically skips a disabled field and moves directly to the next enabled and accessible field. To 
disable a field, just set the Enabled property to No.

Locking Form Fields
Another way to protect fields from being edited is to lock them. Locked fields remain available on the 
form and appear as normal; this allows users to click in the field, but they cannot change the data. 
Locked fields improve readability when a form is printed versus disabled fields, which appear grayed 
out and print faintly. To lock a field, set the Locked property to Yes.

DEVELOP YOUR SKILLS: A6-D5

In this exercise, you will disable the InvNum field in the Customer Invoices form and the LineTotal field in 
the Customer InvoiceDetails subform. In addition, you will lock the Price field in the subform so it cannot 
be edited.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box on the main form and then click the Data tab on the Property Sheet.

 3.  Disable the text box by changing the Enabled property to No.

 4.  Click anywhere on the subform to make it active and then click the ProdID text box.

 5.  Disable the ProdID text box.

 6.  Click the Price text box in the subform and set the Locked property to Yes.
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Test the Property Settings
 7.  Switch to Form View and try clicking in the disabled InvNum field.

The field is grayed out, and you can’t click in it.

 8.  Try clicking in any of the cells of the disabled ProdID field in the subform.

In the subform, only the data appears grayed out, but you still cannot click in the field.

 9.  Click in any Price field in the subform and try changing the number.

Locking allows users to select a field, but the data cannot be changed.
 

Adding Control Tips
When you create a table and define fields, you can enter field details in the Description column. 
These field descriptions appear in the status bar when the fields are active during data entry. They 
also appear in the status bar when a field appears on a form. Although forms identify most fields 
with control labels, sometimes labels for specific fields, such as State and ZIP, are removed from a 
form when the controls are grouped under a more general label such as Address.

To help data entry personnel determine what data to type in a field, you can add descriptive messages 
to display onscreen by setting the ControlTip Text property for a control. ControlTips appear when 
the user points to the control. Setting control tips helps to provide explanations for controls.

DEVELOP YOUR SKILLS: A6-D6

In this exercise, you will create control tips for the disabled and locked fields on the Customer Invoices 
form to explain why they are inaccessible.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box and then click the Other tab on the Property Sheet.

 3.  Click in the ControlTip Text property text box and type: Invoice numbers are 
assigned automatically and cannot be changed.

 4.  Enter these control tips for the subform controls:

ProdID text box Product IDs are assigned by supervisors and cannot 
be edited.

Price text box Product prices cannot be changed.

 5.  Save the changes to the form.

 6.  Switch to Form View and point to the InvNum field to display the control tip.

 7.  Point to the ProdID and Price fields in the subform and notice the control tips do not appear.

Control tips display only in Form View. The subform is currently displayed in Datasheet View, so the 
tips don’t show.

 8.  Open the Customer InvoiceDetails Subform in Form View and point to the ProdID and Price 
controls to display the control tips.

 9.  Close the Customer InvoiceDetails Subform.

Leave the Customer Invoices form open.
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Creating a Pop-Up Form
Forms and reports can be set to open in pop-up windows that stay on top of other open database 
objects. Pop-up forms can prompt a user for information or display a window containing supple-
mental data. Such forms and reports can help data entry personnel look up values while processing 
orders or looking up item prices. You can apply different formats to pop-up forms.

POP-UP WINDOW MODES

Mode Description
Modal Pop Up Displays a custom dialog box that prevents access to other database 

objects until the dialog box is closed or its required actions are taken

Example: If you choose to print a report and have the Print dialog box 
open, you cannot make changes to the report until you click OK or Cancel 
in the dialog box.

Modeless Pop Up Creates a pop-up window that sits on top of other open windows in such a 
way that users cannot work in the database while it is open

Example: When processing orders, you could set the Inventory List to 
open as a modeless pop-up form to ensure you have the correct inventory 
number.

DEVELOP YOUR SKILLS: A6-D7

In this exercise, you will create and test a pop-up form using the Winchester Web Design Products table.

 1.  Select the Pop Up Products table from the Navigation pane.

 2.  Choose Create→Forms→Form Wizard .

 3.  Add all three fields to the Selected Fields list, choose Datasheet Layout, and name the form: 
Pop Up Products List

 4.  Switch to Design View and choose Form Design Tools→Design→Tools→Property Sheet .

 5.  If necessary, choose Form from the Selection Type list and 
then click the Other tab and set the Pop Up property to Yes.

 6.  Switch to Datasheet View and double-click the right border 
of each column heading to autofit the columns.

 7.  Resize the window using the sizing handle until it just encloses 
the datasheet.

You may need to reposition the form first by dragging the title bar 
until you can see the frame borders.
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 8.  Position the pop-up form in a location where all fields in the Customer Invoices form remain 
visible.

 9.  Use the Navigation bar at the bottom of the Customer Invoices form to navigate through the 
records.

Notice the pop-up form remains available and in place.

 10.  Close the database, saving the changes to any unsaved forms.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A6-R1

Create and Modify a Form with a Subform
In this exercise, you will create a new Donors form for Kids for Change. You will delete, move, and size 
controls; modify the title; and add a logo to the form.

 1.  Open A6-R1-K4C from your Access Chapter 6 folder and save it as: A6-R1-K4CRev

 2.  Select the Donors table in the Navigation pane and choose Create→Forms→Form Wizard .

 3.  Add all fields from the Donors table to the Selected Fields list, except the first field, DonorID.

Hint: Use the Move All Fields  button and Remove  button on the DonorID field.

 4.  Click the last field in the Selected Fields list.

This ensures the fields you add in the next step are placed at the bottom of the list.

 5.  Add all four fields from the Donations table to the Selected Fields list.

 6.  Click Next and click Next again to leave the viewing options set to By Donors and a Form with 
Subform(s).

 7.  Leave the layout set to Datasheet and click Next.

 8.  On the final Wizard screen, name the form Donors Form and the subform Donations 
Subform and click Finish.

The new form and subform display in Form View.

Adjust the Subform Layout
 9.  Switch to Layout View then click the Donations label to the left of the subform and tap 

[Delete].

 10.  Double-click the right edge of each subform column heading to autofit the columns.

 11.  Size the subform by dragging its borders and then use the arrow keys to position the subform as 
shown here:
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Set Form Field Properties
 12.  Use the Navigation bar at the bottom of the main form window to move to the third record 

(McGovern).

Notice the email address text box is a bit too narrow for the email address.

 13.  Click the email address to select it and then display the Property Sheet.

 14.  Click the Format tab and then set the Width property to: 1.8

 15.  Use the Navigation bar to scroll through the database records.

The Acknowledgements text box is larger than it needs to be.

 16.  Click the Acknowledgements text box and set these properties:

Property Value

Width 2

Height 0.5

 17.  Set the widths of the State and DonorZIP text boxes to: 0.8

Modify the Form Header
 18.  Click the Donors Form title in the Form Header to select the title box and set the Width  

property to: 3.5

 19.  Click in the title box and change the title to: Kids for Change Donor Form

 20.  Choose Format Layout Tools→Design→Header/Footer→Logo .

 21.  Navigate to your Access Chapter 6 folder, choose K4C-Logo.bmp, and click OK.

 22.  Set the Width and Height properties to 0.8 and the Left property to: 4

 23.  Switch to Form View to view your completed form.

 24.  Close the database, saving the changes to both the form and subform.

REINFORCE YOUR SKILLS: A6-R2

Add a Totals Row to a Form
In this exercise, you will add a Totals row to a form that counts the number of individual donations and 
totals the amount of the donations.

 1.  Open A6-R2-K4C from your Access Chapter 6 folder and save it as: A6-R2-K4CRev

 2.  Select the Donations Query in the Navigation pane and launch the Form Wizard.

 3.  Move all fields except Acknowledgement, ScholarFund, and NetAmt to the Selected Fields list 
and click Next.

 4.  Accept the By Donations view and click Next.
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 5.  Choose the Datasheet layout and click Next.

 6.  Name the new form Total Donations and click Finish.

 7.  Click the Select All box at the top-left corner of the datasheet to select all columns.

 8.  Double-click the right edge of any column heading to autofit all columns.

 9.  Choose Home→Records→Totals .

A Total row is added to the bottom of the datasheet.

 10.  Click in the Last Name cell on the Total row.

 11.  Click the menu button � on the left and choose Count from the drop-down menu.

There are 16 individual donations.

 12.  Click in the Amount cell on the Total row and choose Sum from the menu.

 13.  Autofit the Amount column so the total is visible.

The donations total $11,150, all in even dollar amounts so decimal places aren’t needed.

 14.  Switch to Layout View and then click the Amount text box and display the Property Sheet.

 15.  On the Format tab, set the Decimal Places property to 0 and then close the Property Sheet.

 16.  Switch to Datasheet View and autofit the Amount column again.

 17.  Close the database, saving the changes to any unsaved forms.

REINFORCE YOUR SKILLS: A6-R3

Disable and Lock Fields, Calculated Controls, and Pop-Up Forms
In this exercise, you will disable and lock subform fields to prevent information from being altered by those 
without permission to do so. You will also add a calculated control to a form and create a pop-up form for 
easy access to donor information.

 1.  Open A6-R3-K4C from your Access Chapter 6 folder and save it as: A6-R3-K4CRev

 2.  Display the Donations subform in Design View and then click the DonorID text box and 
display the Property Sheet.

 3.  Click the Data tab and change the Enabled property to No.

 4.  Click the Other tab and then click in the ControlTip text box and type: Donor IDs are set 
by the administrator and cannot be edited.

 5.  Click in the Amount text box on the form and then click the Data tab and set the Locked  
property to Yes.

 6.  Click the Other tab and then click in the ControlTip Text box and type: Donor totals are 
calculated by the program and cannot be edited.

 7.  Switch to Form View and point to the DonorID and Amount controls to see the control tips you 
just created.

 8.  Close the form, saving the changes.
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Create a Calculated Control
 9.  Choose the ScholarFund Donations table in the Navigation pane and launch the Form 

Wizard.

 10.  Add all fields to the form and click Next.

 11.  Choose the Datasheet layout option and click Next.

 12.  Leave the name as ScholarFund Donations and click Finish.

 13.  Switch to Design View and then drag the top edge of the Form Footer section bar down to 
make room for a new text box.

 14.  Choose Format Design Tools→Design→Controls→Text Box  and then click just below the 
ScholarFund control to insert a new text box there.

 15.  Use the arrow keys as needed to align the control with the ScholarFund control.

 16.  Make sure the new control is still selected and, if necessary, display the Property Sheet.

 17.  Click the All tab and set these properties:

Property Value

Name Total Donation

Control Source =Amount+ScholarFund

Format Currency

Decimal Places 0

 18.  Click the text box label and set these properties:

Property Value

Caption Total Donation

Width 1

Left 0.25

 19.  Switch to Form View to see your new calculated control in action.

Notice the fields are of different widths, creating a poor form layout.

 20.  Switch back to Design View and set the Width property of all text boxes to: 1

 21.  Switch back to Form View.

The field widths are now consistent, but the left alignment of the DonationType field needs to be 
changed.

 22.  Switch back to Design View and set the Text Align property of the DonationType text box to 
Right.

 23.  Switch back to Form View to view your completed form.

Create a Pop-Up Form
 24.  Choose the Donors table in the Navigation pane and launch the Form Wizard.

 25.  Add the DonorID, DonorLName, and DonorFName fields to the Selected Fields list and click 
Next.

 26.  Choose Datasheet layout and click Next.
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 27.  Enter Donor Popup as the name, choose the option to Modify the Form’s Design, and click 
Finish.

The form displays in Design View.

 28.  Click the Other tab and set the Pop Up property to Yes.

 29.  Save the change to the form and then switch to Datasheet View.

 30.  Autofit the three columns in the pop-up form.

 31.  Adjust the height and width of the pop-up form by dragging the frame borders until the  
datasheet fits nicely within the frame.

You may need to drag the form slightly by the title bar before sizing it.

 32.  Drag the pop-up form to the right of the ScholarFund Donations fields.

 33.  Navigate through the records in the ScholarFund Donations form while the pop-up form remains 
in place, giving you access to all donor information at a glance.

 34.  Close the database, saving changes to any unsaved forms.
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 Apply Your Skills
APPLY YOUR SKILLS: A6-A1

Create a Form and Subform and Add a Totals Row
Universal Corporate Events would like you to help them track venues, employees, and their pay. In this 
exercise, you will create a form with a subform, as well as a quick form that counts salaried employees and 
totals and averages the salaries.

 1.  Open A6-A1-UCE from your Access Chapter 6 folder and save it as: A6-A1-UCERev

 2.  Select the Venues table and start the Form Wizard.

 3.  Move all fields from the Venues table to the Selected Fields list except VenueLiaison.

 4.  Choose the Schedules table in the Tables/Queries list.

 5.  Move all fields from the Schedules table to the Selected Fields list except Schedules.VenueID.

 6.  Accept viewing your data By Venues and the Form with Subform(s) option.

 7.  Choose Datasheet as the layout option.

 8.  Use Venue Events for the main form’s name and Venue Events Subform for the  
subform’s name.

 9.  Switch to Layout View and then modify the subform layout as described:

• Remove the Venue Events label.

• Widen the frame enough so all columns are visible.

• Autofit all columns.

• Reduce the frame width until it is just wide enough to contain the datasheet.

• Nudge the frame to align it with the text boxes on the main form.

 10.  Close the form, saving the changes to the form and subform.

 11.  Choose Salaried Personnel Query in the Navigation pane and start the Form Wizard.

 12.  Add all fields to the Selected Fields list, choose the Datasheet layout, and name the new form: 
Salaried Personnel Totals

 13.  Switch to Design View and then select the Salary label and the SalaryAmt text box controls.

 14.  Press [Ctrl]+[C] and then [Ctrl]+[V] to copy and paste a duplicate salary field under the existing 
label and text box.

You may need to drag the Form Footer section down slightly to make room for the salary field.

 15.  Change the name of the first Salary label to: Total Salaries

 16.  Change the name of the second Salary label to: Average Salary

 17.  Switch to Datasheet View and autofit all columns.

 18.  Add a Totals row and insert these functions:

• Count in the Salaried field

• Sum in the Total Salaries field

• Average in the Average Salary field

Notice the Count function displays the 11 records where the box in the Salaried field was checked.
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 19.  Uncheck several Salaried boxes and notice that the function updates the changes.

 20.  Close the database, saving the changes to any unsaved forms.

APPLY YOUR SKILLS: A6-A2

Add a Calculated Control to a Form and Change the Form’s Layout
In this exercise, you will add a calculated control to a main form by first copying an existing field, which 
will retain the formatting of the existing field. You will also adjust the size and position of the controls to 
change the form’s appearance.

 1.  Open A6-A2-UCE from your Access Chapter 6 folder and save it as: A6-A2-UCERev

 2.  Open the Event Pricing Entry form in Form View.

Notice that the labels have a raised effect. You will create a calculated control while retaining the 
formatting of these fields by copying and pasting an existing field.

 3.  Switch to Design View and then select the Chg/PP label and the ChgPP text box.

In the next step, you may need to drag the Form Footer bar down slightly to make room for the new 
controls.

 4.  Press [Ctrl]+[C] to copy the controls and [Ctrl]+[V] to paste them.

An identical text box and label appear below the existing text box and label.

 5.  Change the Chg/PP label text for the new label to: Total

 6.  On the Data tab of the Property Sheet, change the Control Source property of the new text box 
to: =Guests*ChgPP

 7.  Change the Width property of all eight control labels to 1 and the Left property to: 1.5

 8.  Switch to Form View and navigate through several records to verify the calculated control is 
working and the text boxes are wide enough to accommodate all records.

 9.  Close the database, saving the changes to the form.

APPLY YOUR SKILLS: A6-A3

Create a Pop-Up Form
In this exercise, you will create a pop-up form to help facilitate data entry.

 1.  Open A6-A3-UCE from your Access Chapter 6 folder and save it as: A6-A3-UCERev

 2.  Select the Events table and launch the Form Wizard.

 3.  Move both the EventID and EventName fields to the Selected Fields list, choose the Tabular 
layout, and name the form: Events Pop Up

 4.  Switch to Design View and delete the Events Pop Up title in the Form Header section.

 5.  Set the Top property to 0.1 for the Event ID label and the Event Name text box in the Form 
Header.

 6.  Set the Form Header Height property to: 0.4

 7.  Choose Form from the Selection Type drop-down list at the top of the Property Sheet.

 8.  On the Other tab, set the Pop Up property to Yes.
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 9.  Switch to Form View and display the Venue Events form in Form View.

 10.  Move the pop-up form so you can view the data in the Venue Events form and subform.

You can see what each Event ID on the Venue Events subform means by looking on the Events Pop Up 
form.

 11.  Close the database, saving the changes to the form.
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  Project Grader

PROjECt gRADER: A6-P1

Taylor Games: Creating and Customizing an Input Order Form
Taylor Games is getting ready to take customer orders, but before it can begin, its service reps need a new 
order form. In this exercise, you will create a form that contains a subform and modify the design for visual 
appeal. Then you will lock a form field and add a calculated control.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A6_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A6_P1_Start from your Access Chapter 6 folder.

 2.  Use the Form Wizard and these guidelines to create a new form and subform:

• Add all available fields from the Orders table.

• Add (in order) Line Item and Quantity from the Order Details table.

• Add the Price field from the Inventory table.

• View the data by Orders as a Form with Subform(s).

• Use the Datasheet layout.

• Use Order Form as the form title and Order Subform as the subform title.

• You will modify the form’s design in the next steps.

 3.  Set the Width property of the Order_ID text box to: 0.5

 4.  Set the Width property of the Service_Rep text box to: 1.05

 5.  Set the ControlTip Text property of the Customer_State text box to: Use two letter 
abbreviation

 6.  Set these properties for the Order Subform_Label (contains the text Order):

Property Value

Top 2.85

Left 0.25

 7.  Set these properties for the Order Subform:

Property Value

Height 2.5

Top 3.1

Left 0.25

 8.  In the Order Subform, set the Locked property of the Price control to Yes.
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 9.  In the Order Subform, insert an unbound text box control directly below the Price control.

 10.  Set these properties for the unbound text box control:

Property Value

Name LineTotal

Format Currency

 11.  Create a formula in the unbound text box control that multiplies the Quantity field by the Price 
field.

 12.  Set these properties for the Unbound label control (contains the text Text6):

Property Value

Name LineTotal

Caption Line Total

Width 1

Left 0.25

 13.  In the order form, use these guidelines to create a new Title control:

• Delete the current Title control from the Form Header (contains the title Order Form).

• Insert a new Title control.

• Set these properties for the new Title control:

Property Value

Width 2

Height 0.5

Font Size 26

Text Align Center

Font Weight Bold
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 14.  Insert a Logo control in the Form Header and set these properties for it:

Property Value

Picture Insert the Taylor Games Logo.png picture 
from your Access Chapter 6 folder.

Width 1

Height 0.6

 15.  Set the Back Color property for the FormHeader section to: Background Light Header

 16.  Save your database.

• Using eLab: Save it to your Access Chapter 6 folder as A6 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 6 folder as: A6 _ P1 _ Submission

PROjECt gRADER: A6-P2

WebVision: Create and Add a Subform
WebVision has improved its database normalization and would like to capitalize on these changes in the 
current order form. In this exercise, you will start by adding a calculated field to an existing query. Then, 
you will create a datasheet form, add a total row, and add the datasheet form as a subform to the existing 
order form. You will then disable form fields and create a pop-up form. Last, you will enter a new order 
using the form you created.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A6_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A6_P2_Start from your Access Chapter 6 folder.

 2.  In the OrderDetails Query, add a calculated field named Line Total that multiplies the 
Quantity field by the Cost field.

 3.  Create a datasheet form that is based on the OrderDetails Query.

 4.  Add a Totals row to the new form and then SUM the data in the Line Total column.

 5.  Save the form with the name: OrderDetails Subform

 6.  Insert the OrderDetails Subform into the Orders form (by dragging it from the Navigation pane 
into the detail section).

 7.  Delete the subform label (named OrderDetails Subform).
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 8.  Set the OrderDetails Subform properties using the following guidelines:

Property Value

Link Master Fields OrderID

Link Child Fields OrderID

Width 5

Height 3

Top 1.5

Left 0.25

 9.  Delete the Order ID textbox and label controls from the subform.

 10.  Disable the Cost and Line Total text box controls by setting the Enabled property to No.

 11.  In Layout View, resize the columns for each of the subform columns so all field data is 
displayed.

 12.  Set these properties in the Sales Reps form:

Property Value

Pop Up Yes

Modal No

 13.  Close all open objects, saving any changes, and then save your database.

• Using eLab: Save it to your Access Chapter 6 folder as A6 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 6 folder as: A6 _ P2 _ Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A6-E1 That’s the Way I See It
You want to create a form with a subform in the Blue Jean Landscaping database. Open A6-E1-BJL. 
Save it as A6-E1-BJLRev and start the Form Wizard. Create a Blue Jean Landscaping Customer 
Sales form with a CustSales Details subform in datasheet layout that includes: 

 Ý SalesNum and SalesDate from the MerchSales table 

 Ý CustLastName from the Customers table

 Ý ItemName, Manufacturer, and Price from the StoreMerchandise table 

 Ý QtySold from the MerchSalesDetails table

Enhance the appearance of the forms and add any features you feel will help facilitate effective data 
entry.

A6-E2 Be Your Own Boss
Blue Jean Landscaping would like you to add calculated controls to the newly created Sales Invoices 
form so it may show order totals. They have also asked that several field properties be modified to 
assist and control data entry. Open A6-E2-BJL and save it as: A6-E2-BJLRev

Open the SalesInvoices form and add a calculated control that multiplies Cost by Qty Sold to 
produce a line total. Disable the Invoice number field, lock the Cost field, and add a control tip that 
will notify the user they cannot change the cost. Enhance the appearance of the forms and add any 
features you feel will help facilitate effective data entry.

A6-E3 Demonstrate Proficiency
Stormy BBQ is continuing to update its database and now wants to have a more exact record of its 
merchandising sales. Open A6-E3-SBQ. Save it as A6-E3-SBQRev and then create a new form 
using the default form and subform names in datasheet layout that includes:

 Ý SalesID and SalesDate from the MerchSales table

 Ý SKU from the MerchSalesDetails table

 Ý Manufacturer, ItemName, and ListPrice from the Merchandise table

 Ý QtySold from the MerchSalesDetails table

In the subform, add a calculated control that multiplies ListPrice by QtySold to produce a line total. 
Create a pop-up tabular form using the Merchandise table that displays SKU, ItemName, and 
ListPrice. Enhance the appearance of the forms as desired.
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ÝÝ Create a crosstab query

ÝÝ Create a find unmatched query

ÝÝ Create a find duplicates query

ÝÝ Create and run parameter queries

ÝÝ Create and run action queries

7 Creating Complex 
Queries

ACCESS

A
s your database grows, so will 

the need to quickly retrieve and 

modify exact data. Complex 

queries help with this because they allow 

you to further refine search results and 

perform actions that modify records. In this 

chapter, you will explore queries designed 

to enhance the timeliness and accuracy of 

large relational databases. You will create 

crosstab queries and use parameter queries 

that prompt you to enter values to generate 

or modify records. You will also create 

action queries to update databases and 

automate database tasks.
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Ý Project: Handling Growing Databases
You are responsible for analyzing the data-retrieval processes for the growing Winchester 
Web Design database. You decide to develop queries to increase the efficiency of both data 
entry and updates, as well as to better analyze data. The tools you will use include crosstab 
queries for data analysis, parameter queries that will prompt the user for input, and action 
queries to update and maintain the database.

Crosstab Queries
Crosstab queries allow you to easily analyze data. A crosstab query lists the fields to be grouped 
on the left side (rows) of the datasheet, and it arranges the fields to be summarized across the top 
(columns) so you can calculate sums, averages, counts, or totals by both group and subgroup. For 
example, if you have a database that contains sales records for your employees, the description of 
each product they sell, and their total sales for each product, you could create a crosstab query to 
display the total sales by product for each employee.

The original data format is arranged by record.

Using a crosstab query, you can display the data grouped by employee with totals for the various 
products.
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Both tables and queries can be used as the basis of crosstab queries. You can create a crosstab query 
while working with an existing query in Design View using the Crosstab option; alternatively, use the 
Query Wizard.

ÝÍ Design→Query Type→Crosstab 

Watch the video “Creating Crosstab Queries.”

DEVELOP YOUR SKILLS: A7-D1

In this exercise, you will create a crosstab query that lists every employee and their total invoice amount 
generated by product.

 1.  Open A7-D1-WinDesign from your Access Chapter 7 folder and save it as: 
A7-D1-WinDesignRev

 2.  Double-click the Employee Sales query to run it and display the resulting datasheet.

The query contains line item sales data. Each employee has multiple transactions, and each 
transaction contains the product description, price, and quantity. The LineTotal field is a calculated 
field that multiplies price by quantity. You will use this query as the basis for your crosstab query.

 3.  Close the Employee Sales query.

 4.  Choose Create→Queries→Query Wizard .

 5.  Choose Crosstab Query Wizard and click OK.

 6.  Choose the Queries view option and then choose Query: Employee Sales from the query list.

 7.  Click Next to accept the Employees Sales query as the basis of your crosstab query.

 8.  Choose EmpLastName from the Available fields list and add it to the Selected Fields list.

Your crosstab query will display employee last names as row headings in the query results datasheet. 
Each employee will have a single row, with their last name displayed in the first cell of the row and 
their sales information displayed in the other row cells.

 9.  Click Next and choose ProdDescription for the column headings.

The various product descriptions (Blog, Home Page, Web Page) will appear as column headings.

The sample query at the bottom of the Wizard can be a useful guide for deciding which fields to use as 
the row and column headings.

Tip!
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 10.  Click Next, choose LineTotal from the Fields list, and then choose Sum from the Functions list.

The crosstab query will examine all transactions in the underlying Employee Sales query and sum the 
line totals for each product description. For example, a grand total of all line totals will be created 
where the product description is Blog and the employee is Kramer.

 11.  Leave the Yes, Include Row Sums option checked and click Next.

This option creates one additional column in the datasheet to hold a total for each employee. The 
total will be the sum of all cells in the crosstab query datasheet for that employee.

 12.  Leave the default query name as Employee Sales_Crosstab and click Finish.

 13.  Take a moment to examine the query results.

Complete the Query Wizard steps again, if necessary, so you fully understand how the query options 
produce the resulting datasheet.

 14.  Close the query.

Find Queries
Database tables often contain common fields that link, or relate, the tables. For example, the 
Product ID field from a Products table also appears in an Invoices table, so invoices can show only 
existing products. Thus, it’s important that records entered in one table have a matching record in the 
related table. That is, an invoice should never show a product that is not in the Products table.

Sometimes databases are poorly designed and incorrect data is allowed. For example, a user may 
enter a product that does not exist into a new invoice. Data is also sometimes imported from other 
data sources, which might result in incorrect or duplicate data. Fortunately, Access provides two 
additional Query Wizard options to help resolve these types of data conflicts.EVALU
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Find Unmatched Query
The find unmatched query locates records in one table that have no matching records in another 
table. For example, you could create a find unmatched query to ensure each record in an Invoice 
table has a corresponding record in a Customers or Products table.

Find Duplicates Query
A find duplicates query locates records containing duplicate field values in a single table or query 
datasheet. For example, you could create a find duplicates query to locate all customers with the 
same last name in a Customers table or to find all customers located in a particular state or ZIP code.

DEVELOP YOUR SKILLS: A7-D2

In this exercise, you will create a query to locate records in the Customers table that do not have a 
matching customer ID in the Invoices table. Then you will create a query to identify records with duplicate 
customer last names.

 1.  Choose Create→Queries→Query Wizard , choose Find Unmatched Query Wizard, and 
click OK.

 2.  Click Next to choose the Customers table.

When the query is created, records from the Customers table will appear in the query results.

 3.  Choose the Invoices table and click Next.

You will set up the query to find records in the Invoices table that do not have a matching customer 
record in the Customers table. Notice that the CustID fields are chosen as the matching fields in the 
Wizard screen. They’re automatically chosen because a one-to-many relationship is already set up 
between these fields in the Customers and Invoices tables.

 4.  Click Next to accept CustID as the matching field.

 5.  Add CustLastName, CustFirstName, CustPhone, and CustEmail to the Selected Fields list.

These are the fields from the Customers table that will be displayed in the query results, creating a 
contact list of customers who don’t have invoices in the system. In other words, these are customers 
who haven’t purchased anything in a while, making them potential prospects for new sales.

 6.  Click Next and then click Finish to accept the default query name Customers Without Matching 
Invoices.

Your query should produce a data set of three records only.

 7.  Close the datasheet after reviewing it.

Create a Find Duplicates Query
 8.  Choose Create→Queries→Query Wizard , choose Find Duplicates Query Wizard, and 

click OK.
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 9.  Click Next to choose the Customers table as the query to search for duplicate field values.

 10.  Add CustLastName to the Duplicate Value Fields list and click Next.

You are looking only for the records of customers who have the same last name.

 11.  Add CustFirstName and CustPhone to the Additional Query Fields list and click Next.

These fields will appear in the resulting datasheet but aren’t used in the duplicate values test. Only 
CustLastName is being checked for duplicates.

 12.  Name the query Customers with the Same Last Name and click Finish.

The query results show just two customers with the same last name (Roberts).

 13.  Close the query after reviewing the results.

Parameter Queries
A parameter query is a select query that prompts users to enter new criteria values each time the 
query is run. The query then generates results based on the value(s) entered. For example, a param-
eter query that searches for customers with a specific last name might prompt the user to enter the 
desired last name when the query is run. The query then returns only records containing the last 
name entered by the user. Parameter queries are created by enclosing the desired prompt text with 
square brackets, [ ], in the query Criteria row.

Surround the parameter 
query prompt text in 
square brackets in a 
Criteria cell.

The prompt text appears 
here when the query is run.

The user enters the desired 
parameter value here.

In this example, only records in which the customer last name is Smith are returned.
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Complex Parameter Queries
Suppose you want to see all items purchased by a particular customer and those equal to or greater 
than a particular price; for example, all items purchased by Smith with a price greater than or equal 
to $300. You can do this by creating an AND condition using parameters in the CustLastName and 
Price fields.

You can also create expressions with prompts for multiple values in the same query field or include 
logical criteria such as greater than (>), less than (<), and equal to (=). 

EXAMPLES OF PARAMETER QUERY CRITERIA FOR  
A SINGLE FIELD

Parameter Criteria Result
Between [What is the start date?] 
And [What is the end date?]

These criteria prompt the user to enter start and 
end dates. Access recognizes the Between and And 
expressions and returns dates within the range entered.

>=[Enter minimum price] This displays the prompt Enter minimum price and returns 
only records greater than or equal to the price entered.

DEVELOP YOUR SKILLS: A7-D3

In this exercise, you will use parameters to return customer records based on user input.

 1.  Display the Customer Invoice Parameter query in Design View.

 2.  Click in the CustLastName criteria field and enter the criterion: [Enter Customer Last 
Name]

 3.  Run the query, type Roberts in the parameter box that appears, and click OK.

All line items from invoices 34 and 7, where the customer last name is Roberts, are returned.

Create an AND Parameter Condition
 4.  Switch to Design View and enter this parameter in the Price criteria box: >=[Enter Minimum 

Price]
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 5.  Run the query and enter Roberts in the first parameter box and 300 in the second.

Now the record set has records only with Roberts in the Last Name field in which the price is greater 
than or equal to 300.

 6.  Close the query, saving the changes.

Action Queries
An action query performs an action that modifies a database table or a group of records in a table. 
They can modify, move, update, or delete groups of records with a single action. You can even use an 
action query to create a new table by adding various fields and data from other tables. 

An action query is run whenever it is opened, so if you create an update query designed to increase 
prices by 10% on all items in a table, Access will increase those prices every time you run the query. 
Action queries do this without opening the underlying tables being modified by the query. For this 
reason, an action query may accidentally be run more than once, inadvertently changing the under-
lying table data multiple times. It’s good practice to not save action queries after running them or to 
delete action queries if they are saved. This will help maintain the validity of the database as changes 
to the underlying data cannot easily be undone.

Action queries require that content within a database be enabled. As a result, if you did not click the 
Enable Content button found at the top of the Access window when you first opened the database, 
Access will display an error message advising you to enable content before you can create or run 
action queries.

Make Table Queries
A make table query is an action query that can create a new table using data from multiple database 
tables. It’s also a great way to move data produced from a calculated query field into a table. When 
you create a new table using a make table query, Access prompts you for a table name and even 
allows you to save the data in another database. A reason to move records to another database, 
for example, would be to archive them when they become obsolete, such as when a product is no 
longer available. When you rerun a make table query, Access will replace the table created with the 
previous running of the query. To retain the previously created table, you must first rename it; this 
way it won’t be replaced.

ÝÍ Design→Query Type→Make Table EVALU
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DEVELOP YOUR SKILLS: A7-D4

In this exercise, you will create a make table action query to save all of the 2017 invoice records in a new 
table.

 1.  Open Invoices Query in Design View.

 2.  Enter Between 1/1/2017 And 12/31/2017 as the criterion for the InvDate field.

This criterion will produce a datasheet with old invoices no longer needed in the database. You’ll then 
use the make table query feature to move the records to a new table.

 3.  Choose Query Tools→Design→Query Type→Make Table .

 4.  Enter 2017 Invoices as the table name and click OK.

 5.  Run  the query and choose Yes to paste 61 rows into a new table.

The new table named 2017 Invoices appears at the top of the Tables section in the Navigation pane.

 6.  Open the new 2017 Invoices table in Datasheet View.

Notice that all of the line items listed have a 2017 invoice date.

 7.  Close the 2017 Invoices table and then close the invoices query without saving the changes.

It’s important not to save the query because it’s used for other purposes and because you want to 
preserve the new table without risking an overwrite of it.

 8.  Open the Invoices table in Datasheet View.

The Invoices table still contains the 2017 records.

Make table queries don’t remove data from underlying tables; they simply copy the data to new tables. 

 9.  Close the Invoices table.

Append Queries
An append query adds a group of records from one or more tables to the end of one or more tables 
in the same or in another database. For example, if you want to offer a new set of products, you could 
use an append action query to add the new items from a new products table to the existing products 
table. Or you might use an append query to automatically add new customers to the Customers 
table the first time a customer places an order.

Formatting the Source and Destination Tables
In an append query, the table that records are drawn from is called the source table. The table 
receiving the records is the destination table. To successfully run an append query, the structures, 
field names, data types, and field order for both tables should be the same.

Note!
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Identifying the Source and Destination Tables
Append queries are created in the database that contains the source table. When the query is run, 
the Append dialog box prompts you to identify the destination database and table. Access identifies 
the destination table in the Append To row of the query grid.

ÝÍ Design→Query Type→Append 

DEVELOP YOUR SKILLS: A7-D5

In this exercise, you will create an action query to append records from the New Products table to the 
existing Products table.

 1.  Open the Products table and notice that it contains six records.

 2.  Open the NewProducts table to see the five records that will be appended to the Products 
table.

The tables have the same field structure, which includes field order and matching field names and field 
data types.

 3.  Close both tables and then choose Create→Queries→Query Design  to create a new 
query.

 4.  Add the New Products table to the query window and then close the Show Table dialog box.

 5.  Add all fields from the New Products table to the query grid in the same order they appear in the 
New Products list.

 6.  Choose Query Tools→Design→Query Type→Append .

 7.  Click the Table Name menu button �, choose Products, and click OK.

An Append To row is added to the query. When you run the query, it will copy all records from the 
underlying New Products table to the Products table. The tables have identical field structures, so the 
data will drop right into the existing table.

 8.  Run  the query and choose Yes to append the five rows to the Products table.

Nothing appears to happen when you run the query—but don’t run it again! You will see the changes 
only after you open the destination table to which the records were appended. If you do run the query 
again, Access will add the same records to the destination table again, creating duplicate data.

 9.  Display the Products table in Datasheet View to verify that the new records were appended.

The Products table should now contain 11 records.

 10.  Close the Products table and then close the new append query, saving it as: Append 
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Update Queries
An update query is an action query that makes global changes to a group of records in one or more 
tables. For example, you can use an update query to increase the prices for every product in a specific 
category or to update the area code for phone numbers that change when the phone company adds 
or changes an area code. To ensure the corresponding fields in related tables are updated consis-
tently, check the Cascade Update Related Fields checkbox in the Edit Relationships window.

Identifying the Query Grid Update Row
Append, update, crosstab, and delete queries all add a query-specific row to the query grid. The 
update query places an Update To row in the query grid so that you can tell Access how to update 
the desired field(s). In most cases, this will be changing one value to another by substitution, 
mathematical operation, formula, or comparison.

ÝÍ Design→Query Type→Update 

DEVELOP YOUR SKILLS: A7-D6

In this exercise, you will create an update action query that increases the prices of every item in the 
Products table by 10%.

 1.  Open the Products table in Datasheet View and notice the Home Page price is $400.

The update query will increase this and all other prices by 10%.

 2.  Close the Products table and then choose Create→Queries→Query Design .

 3.  Add the Products table to the query window and then close the Show Table dialog box.

 4.  Add all fields from the Products table to the query grid in the same order they appear in the 
Products list.

 5.  Choose Query Tools→Design→Query Type→Update .

An Update To row is added to the query grid.

 6.  Click in the Update To cell for the Price field and enter: [Price]*1.1

Be sure to include the square brackets, [ ], when entering this formula so Access will recognize Price as 
a field. Multiplying by 1.1 increases the price by 10%.

 7.  Run  the query and choose Yes when the warning prompt appears to update 11 rows.

 8.  Close the query without saving it.

Once again, it’s good practice not to save action queries, such as update queries. Running a query by 
accident can corrupt data and recovering corrupted data is often difficult or impossible to do.

 9.  Open the Products table in Datasheet View and notice the Home Page price went from $400 
to $440 (an increase of 10%).

 10.  Close the Products table.
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Delete Queries
A delete query removes a group of records from one or more tables. For example, you could create 
a delete query to remove records for a discontinued line of products or to delete records you have 
appended to another table to prevent inadvertently running an append query multiple times.

Preparing for Delete Queries
To ensure corresponding records in related tables will be deleted concurrently, check the Cascade 
Delete Related Records checkbox in the Edit Relationships window. When you set up a delete query, 
Access replaces the Sort row of the query grid with a Delete row. You can set criteria for specific 
fields in a table to identify the conditions that must be met in order to delete records, or you can set 
no criteria to remove all records from a table.

ÝÍ Design→Query Type→Delete 

DEVELOP YOUR SKILLS: A7-D7

In this exercise, you will create a delete query to remove the 2017 invoices from the Invoices table.

 1.  Open the Invoices table in Datasheet View.

The table still has invoices dated from 2017. These invoices were copied to the 2017 Invoices table 
using a make table query in a previous exercise. Because make table queries do not delete records, 
you’ll take care of this using a delete query.

 2.  Close the Invoices table and then choose Create→Queries→Query Design .

 3.  Add the Invoices table to the query window and then close the Show Table dialog box.

 4.  Add only the InvDate field to the query grid.

 5.  Enter Between 1/1/2017 And 12/31/2017 as the criterion for the InvDate field.

Access may view typing 2017 as an attempt to insert the 2017 Invoices table. To avoid adding this 
table to the criteria, tap (Spacebar) at the end of the criteria and then press (Enter).

 6.  Choose Query Tools→Design→Query Type→Delete .

A Delete row is added to the query grid.

 7.  Run  the query and choose Yes when the prompt to delete 19 rows appears.

A second warning appears, notifying you that the records cannot be deleted because there is a key 
violation. This is because the Cascade Deleted Records option is not activated for a relationship 
between the Invoices and Invoice Details table. This option must be activated for you to run delete 
queries.

 8.  Choose No in the warning message box and then choose Database Tools→Relationships→ 
Relationships .
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 9.  Right-click the join line between the Invoices and Invoice Details table and choose Edit 
Relationship.

 10.  Check the Cascade Delete Related Records box and click OK.

 11.  Close the Relationships window, saving the changes to the relationship layout if prompted.

 12.  Run  the query again, choosing Yes when the warning prompt appears.

This time, the delete query runs, removing the 2017 records from the Invoices table.

 13.  Close the query without saving it.

Remember, it’s good practice not to save action queries, especially when they are relatively easy to 
re-create, as in this example.

 14.  Open the Invoices table in Datasheet View and notice that the 2017 invoices have been 
removed.

 15.  Close the Invoices table and then close the database.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A7-R1

Create Crosstab and Find Queries
Kids for Change is fine-tuning its database. In this exercise, you will create a crosstab query to track 
donations and find queries to locate problem records.

 1.  Open the A7-R1-K4C database from your Access Chapter 7 folder and save it as: 
A7-R1-K4CRev

 2.  Choose Create→Queries→Query Wizard , choose Crosstab Query Wizard in the first 
screen, and click OK.

 3.  Choose the Queries view, choose Donations Query as the query that contains the fields you 
want in the results, and click Next.

 4.  In the next Wizard screen, move DonorLName to the Selected Fields list and click Next.

Donor last names will become your row headings and the field where the results are grouped.

 5.  In the next Wizard screen, choose only DonationDate as the field to appear in the column 
headings and click Next.

Because DonationDate is a date field, the Wizard asks you to choose an interval, such as day, month, 
or year.

 6.  Choose Month as the interval and click Next.

 7.  Choose Amount in the Fields list and Sum in the Functions list to identify the field that contains 
values and the function you want to use.

 8.  Click Next, leave the query name unchanged, and then finish the query.

The query returns the total donations for each donor, organized by month.

 9.  Close the query.

Create a Find Unmatched Records Query
 10.  Launch the Query Wizard, choose Find Unmatched Query Wizard, and click OK.

 11.  Choose the Activities table and click Next.

The Activities table will display in the query results.

 12.  Choose Volunteers as the table with related records and click Next.

 13.  Choose Day in the Activities table field list and VolDay in the Volunteers table field list and then 
click Next.

 14.  Add Activity, Day, and MeetTime to the Selected fields list and then click Next.

 15.  Click Finish to accept the default query name.

Your query should return four records of activities that do not have a matching volunteer assigned to 
them.

 16.  Close the query when you have finished viewing the results.
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Create a Find Duplicates Query
 17.  Launch the Query Wizard, choose Find Duplicates Query Wizard, and click OK.

 18.  Choose Donors as the table to check for duplicates and click Next.

 19.  Add DonorLName to the Duplicate-Value Fields list and click Next.

You are looking only for records of donors with the same last name.

 20.  Add DonorFName and DonorPhone to the Additional Query Fields list and click Next.

 21.  Accept Find Duplicates for Donors as the default query name and click Finish.

The query should return records for Clay Boltwood and Nancy Boltwood.

 22.  Close the database, saving the changes to any unsaved queries.

REINFORCE YOUR SKILLS: A7-R2

Create a Parameter Query
In this exercise, you will make a copy of an existing query. You will modify the copied query, turning it into a 
parameter query to return donor records by state.

 1.  Open the A7-R2-K4C database from your Access Chapter 7 folder and save it as: 
A7-R2-K4CRev

 2.  Click Donations Query in the Navigation pane to select it.

 3.  Press [Ctrl]+[C] to copy and [Ctrl]+[V] to paste the copy.

 4.  Enter Donations by State as the new query name and click OK.

 5.  Display the Donations by State query in Design View.

 6.  Type [Enter State Abbreviation] in the Criteria cell of the DonorST field and tap 
[Enter] to complete the entry.

 7.  Run  the query.

 8.  Type MA in the Parameter Value prompt box and click OK.

Only donations from Massachusetts donors are returned.

 9.  Close the query, saving the changes.

 10.  Choose File→Close to close the database; if you see a message regarding emptying the 
Clipboard, click Yes.
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REINFORCE YOUR SKILLS: A7-R3

Create Action Queries
Kids for Change is improving and updating its records. In this exercise, you will create a make table query 
that produces a table to archive the 2017 donation records, a query that appends new records to the 
Children table, an update query that reduces the duration of each activity by half, and a query that deletes 
old donations from the Donations table.

 1.  Open the A7-R3-K4C database from your Access Chapter 7 folder and save it as: 
A7-R3-K4CRev

Remember, you must enable a database if you will be running action queries, so click the Enable 
Content button that appears after saving the file.

To begin, you will create the make table query.

 2.  Open Donations Query and switch to Design View.

 3.  Scroll the query grid to the right and type Between 1/1/2017 And 12/31/2017 in the 
Criteria cell of the DonationDate field.

 4.  Choose Query Tools→Design→Query Type→Make Table .

 5.  Type 2017 Donations as the name of the new table and click OK.

 6.  Run  the query and choose Yes in the warning box.

 7.  Close the Donations Query without saving the changes.

Create an Append Query
 8.  Open the Children table and notice that it contains 17 records; close the table.

 9.  Choose Create→Queries→Query Design  to create a new query.

 10.  Add the NewChildren table to the query window and then close the Show Table dialog box.

 11.  Add all fields from the NewChildren table to the query grid in the same order they appear in the 
NewChildren list.

 12.  Choose Query Tools→Design→Query Type→Append .

 13.  Click the Table Name menu button �, choose Children, and click OK.

The Append To row is added to the query grid.

 14.  Run  the query and choose Yes to add the 10 rows to the Children table.

 15.  Close the query, saving it as: Append New Children

Create an Update Query
 16.  Display the Activities table in Datasheet View to see the current Hrs values (2 or 4 hours) and 

then close the table.

 17.  Choose Create→Queries→Query Design .

 18.  Add the Activities table and close the Show Table dialog box.

 19.  Add the Hours field to the query grid.

 20.  Choose Query Tools→Design→Query Type→Update .

An Update To row is added to the query.
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 21.  Type [Hours]/2 in the Update To cell of the Hours field.

It’s important to include the square brackets so that Access can perform the correct calculation. This 
calculation will divide the current activity hours value in half.

 22.  Run  the query and choose Yes to update 25 rows; close the query without saving it.

 23.  Open the Activities table and note the activities that were listed as 2 and 4 hours each are now 
1 and 2 hours; close the table.

Create a Delete Query
 24.  Open the Donations table and notice it contains donations from the year 2017; close the 

Donations table.

 25.  Choose Create→Queries→Query Design .

 26.  Add the Donations table to the query and then close the Show Table dialog box.

 27.  Double-click the DonationDate field to add it to the query grid.

 28.  Type Between 1/1/2017 And 12/31/2017 in the Criteria row for the DonationDate field.

 29.  Choose Query Tools→Design→Query Type→Delete .

A Delete row is added to the query grid.

 30.  Run  the query and choose Yes in the warning box.

 31.  Close the query without saving it and then open the Donations table and confirm that the 2017 
records have been removed.

 32.  Close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A7-A1

Create Crosstab and Find Queries
Universal Corporate Events has asked you to create queries to analyze the company’s data and identify 
unmatched and duplicate database records. In this exercise, you will respond to this request by creating 
crosstab, find unmatched records, and find duplicate records queries.

 1.  Open the A7-A1-UCE database from your Access Chapter 7 folder and save it as: 
A7-A1-UCERev

 2.  Use the Query Wizard to create a crosstab query using these parameters:

View Query: Event Revenue

Row Heading(s) VenueID

Column Heading(s) ContactID

Field(s) TotalRev

Function(s) Sum

Name Contact Revenue by Venue

 3.  Finish the query.

Seven data rows should be returned.

 4.  Close the query and then use the Query Wizard to create a find unmatched query using these 
parameters:

View Table: Venues

Related Records Table: Schedules

Fields in Venues VenueID

Fields in Schedules VenueID

Fields to see in query results VenueName, VenueStreet, VenueCity, 
VenueST, VenueZIP, VenuePhone, 
VenueWebSite

Name Venues Without Event Scheduled

 5.  Finish the query.

Three data rows should be returned.

 6.  Close the query and then use the Query Wizard to create a find duplicates query using these 
parameters:

View Query: Event List

Duplicate-Value Field EventDate

Additional Fields VenueID, ContactID, MenuPlan, Guests

Name Find Double-Booked Dates

 7.  Finish the query.

Two data rows should be returned.

 8.  Close the database.
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APPLY YOUR SKILLS: A7-A2

Create a Parameter Query
In this exercise, you will create a parameter query to return personnel records by city.

 1.  Open the A7-A2-UCE database from your Access Chapter 7 folder and save it as: 
A7-A2-UCERev

 2.  Create a new query using Query Design  and add the Personnel table to the query.

 3.  Add the PerLastName, PerFirstName, PerAddr, PerCity, PerPhone, and PerEmail fields to 
the query.

 4.  Make [Enter City] a criterion for the PerCity field.

 5.  Run the query using Sarasota as the parameter value.

The query should return five records in which the city is Sarasota.

 6.  Close the database, saving the query as: Personnel City

APPLY YOUR SKILLS: A7-A3

Create Action Queries
Universal Corporate Events is updating and consolidating its events data. In this exercise, you will create 
a make table query to archive the records for older events, an append query to add new records to the 
Schedules table, and an update query to change personnel salaries. Finally, you will create a query to 
delete older events from the main Schedules table.

 1.  Open the A7-A3-UCE database from your Access Chapter 7 folder and save it as: 
A7-A3-UCERev

You will start by creating a make table query.

 2.  Display Schedules Query in Design View and add the criterion <01/01/2019 to the 
EventDate field.

 3.  Use the Make Table query type to create a new table with the name: Older Events

 4.  Run the query.

The new table should contain six records.

 5.  Close the Schedules Query without saving the changes.

Create an Append Query
 6.  Create a new query, adding all fields from the New Schedules table.

 7.  Use the Append query type to convert the query to an append query using Schedules as the 
table name to append to.

 8.  Run the query, choosing Yes when asked if you wish to add the 30 rows to the Schedules table.

 9.  Close the query, saving it as: Append Schedules

 10.  Open the Schedules table to verify it contains 72 records; close the table.
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Create an Update Query
 11.  Create a new query using the SalaryGrades table and adding only SalaryAmt to the query 

grid.

 12.  Use the Update query type to add an Update row to the query.

 13.  Use an update criterion that multiplies the SalaryAmt field by: 1.07

This will produce a 7% increase to the numbers in the SalaryAmt field.

 14.  Run the query, choosing Yes to update 21 records.

 15.  Close the query, saving it as: Salary Updates

 16.  Close the SalaryGrades table.

Create a Delete Query
 17.  Create a new query using only the EventDate field from the Schedules table.

 18.  Use the criterion <1/1/2019 in the EventDate field.

 19.  Use the Delete query type and then run the query, choosing Yes to delete six records.

 20.  Close the new query without saving it.

 21.  Open the Schedules table to verify all records with an event date prior to 1/1/2019 have been 
deleted and then close the database.
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  Project Grader

PROjECT GRADER: A7-P1

Taylor Games: Updating Inventory
Taylor Games has new inventory it would like to add to its database. It has noticed that the selling prices 
for some of the new items are above or below the desired profit margin and need to be updated. In this 
exercise, you will start by using an append query to merge data with new inventory into the inventory table. 
Then, you will create a calculated field and a complex parameter query with criteria to identify which items 
are below and above the desired margin and make a new table using the results. Last, you will make an 
update query and modify the sales price so all items are within the desired margin.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A7_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A7_P1_Start from your Access Chapter 7 folder.

 2.  Use these guidelines to create an Append query:

• Create a new query adding all fields from the New Inventory table.

• Append to the Inventory table in the current database.

• Run the query to complete the append action, then save the query with the name:  
Inventory Append

 3.  Create a new query named Margin Parameter that uses all fields from the Inventory table.

 4.  In the Margin Parameter query, add a calculated field named Margin that calculates:  
Cost/Price

 5.  Add this parameter to the Margin Parameter query: Between [Enter Minimum Margin] 
And [Enter Maximum Margin]

 6.  In the Margin Parameter query, use the Make Table action to make a table in the current  
database with the Table Name: Items Within Margin

 7.  Run the query to create the Items Within Margin table using these minimum and maximum 
margin numbers:

• Enter Minimum Margin: 0.5

• Enter Maximum Margin: 0.75

 8.  Use these guidelines to create an Update query:

• Add only the Price field from the Inventory table to the query grid.

• Set the Update To criteria as: [cost]*1.5

• Run the query and save it as: Margin Update

 9.  Save your database.

• Using eLab: Save it to your Access Chapter 7 folder as A7 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 7 folder as: A7 _ P1 _ Submission
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PROjECT GRADER: A7-P2

WebVision: Create a Crosstab Query and Update Orders
WebVision has noticed some discrepancies in recent orders and customer records. It would also like to see 
the total sales for each sales rep for the customers they service. In this exercise, you will start by creating 
a Crosstab query. Then, you will create a Find Unmatched query to track down orders that do not contain 
any details and a Delete query to remove the incomplete orders. Last, you will create a Find Duplicates 
query to find duplicate customer records.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A7_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A7_P2_Start from your Access Chapter 7 folder.

 2.  Use these guidelines to create a Crosstab query using the Crosstab Query Wizard:

• Contains fields from the OrderDetails query.

• Use the RepID field for row headings.

• Use the Company Name field for column headings.

• Calculate each column and row intersection using the Sum function on the Line Total field.

• Name the query: Rep Sales by Customer

 3.  Make these changes to the Rep Sales by Customer query:

• Change the name of the Total of Line Total field to: Total

• Set the Format field property to Currency for both the Line Total and Total fields.

 4.  Use these guidelines to create a Find Unmatched query:

• The Orders table contains the records in the query results.

• The Order Details table contains the related records.

• Use the OrderID field in the Orders table and the Order ID field in the Order Details table 
as the matching fields.

• Show all available fields in the query results.

• Name the query: Orders Without Details

 5.  Use these guidelines to create a Delete query:

• Base the query on the Order Details table.

• Add Order ID to the query grid.

• Set Criteria to delete records where the Order ID is greater than 5.

• Run the query and click Yes when prompted.

If performed correctly, you will see a prompt notifying you that you are about to delete two rows.

• Save the query with the name: Incomplete Order Delete

 6.  Use these guidelines to create a Find Duplicates query:

• Search the Customers table for duplicate values.

• Use Billing Address, City, State/Province, and Postal Code for fields that may contain 
duplicate information.

• Add all remaining available fields to the Additional Query Fields list.

• Name the query: Duplicate Customers
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 7.  Save your database.

• Using eLab: Save it to your Access Chapter 7 folder as A7 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 7 folder as: A7 _ P2 _ Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A7-E1 That’s the Way I See It
You would like to make several enhancements to the Blue Jean Landscaping database to ensure 
more accurate data in query results. Open A7-E1-BJL and save it as: A7-E1-BJLRev

Make a copy of the Service Invoices Query, naming it Acre Rate Range, and then modify it to add a 
parameter that prompts the user to enter the rate per acre. The query should return only records 
that match the acre rate entered by the user. The second update is to the StoreMerchandise table. 
Create a New Merchandise append query that appends all records from the NewMerchandise table 
to the StoreMerchandise table. Verify that your queries function properly.

A7-E2 Be Your Own Boss
Business has picked up at Blue Jean Landscaping! You’re modifying the database to ensure efficiency 
and to cope with unexpected situations. Open A7-E2-BJL and save it as: A7-E2-BJLRev

Use the Store Inventory query as the basis for a new query named Manufacturer Item Inventory  
that prompts the user to enter a manufacturer and returns all records for that manufacturer.  
Create a 2019 Sales query that creates a new table containing all 2019 sales records from the  
Merch Sales query. Finally, create a New Customers append query that appends all records from  
the NewCustomers table to the Customers table.

A7-E3 Demonstrate Proficiency
Stormy BBQ has asked you to refine the merchandising section of its database to reflect recent price 
changes and move older records. Open A7-E3-SBQ and save it as: A7-E3-SBQRev

Create a query to copy the 2018 merchandise sales records from the MerchSales table into a new 
table and then create a delete query to remove those records from the MerchSales query. Decide 
what names to assign to the new table and to either of the two queries you choose to save. Create a 
query that increases the list prices of all items in the Merchandise table by 5%. You decide whether to 
save the query after running it (and which name to use, if you save it).
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L E A R N I N G  O B J E C T I V E S

ÝÝ Import a report into a database

ÝÝ Add a subreport to a main report

ÝÝ Create a report from a subreport

ÝÝ Create calculated controls on a subreport

ÝÝ Set page breaks in reports

ÝÝ Add a chart to a report

8 Customizing Reports

ACCESS

D
atabase reports summarize 

the data contained in tables 

or displayed in query results 

and enable you to provide information in a 

page layout suitable for printing. Although 

forms and reports serve different purposes 

within the context of a relational database, 

the techniques used to customize them 

are similar. In this chapter, you will import 

reports from other databases and use 

features to create custom reports.
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Ý Project: Billing Customers
The company manager of Winchester Web Design, a small web page design company, wants 
you to improve its invoice report for customer billing. After reviewing invoices from several 
companies, the company manager has sketched out a design for the new invoice report layout. 
Your job is to create a sample of the new invoice report for the company’s executive team.

Importing a Report into a Database
Access offers a variety of ways to create reports. In addition to using the Report Wizard or starting 
from scratch in Design View, you can import reports from another database. Because most compa-
nies require some type of invoice to send with customer orders, locating a sample invoice report to 
import is not difficult.

Sometimes you have the report you want, but during its design it may have become corrupted, either 
due to inadvertent changes to the report itself or because of changes to an underlying query. That’s 
when backups are invaluable. If a report becomes corrupted, you can restore it by importing data-
base objects from a backup copy of a database. The record source should already match, and there 
should be no need to edit the properties or the field names.

Identifying Report Record Sources
Reports you import retain two connections to their original database. The first is the source database 
table or query name, shown in the Record Source property, and the second are the field names, which 
appear in report text boxes. As a result, when you import a report from another database, you often 
must establish new control sources to the destination database. You can accomplish this by:

 Ý Editing the imported report’s Record Source property to link to a table or query in the destination 
database.

 Ý Editing, if necessary, the field names in the imported report’s text boxes to match those in the new 
record source table or query.

ÝÍ External Data→Import & Link→New Data Source→From Database→Access 

DEVELOP YOUR SKILLS: A8-D1

In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

 1.  Open A8-D1-WinDesign from your Access Chapter 8 folder and save it as: 
A8-D1-WinDesignRev

 2.  Look in the Reports section in the Navigation pane and notice the database contains three 
reports.

 3.  Choose External Data→Import & Link→New Data Source→From Database→Access .

The Get External Data – Access Database dialog box appears.

 4.  Click the Browse button and navigate to your Access Chapter 8 folder.
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 5.  Choose the file A8-D1-WinDesign-Backup and click Open.

This database is a backup copy of the WinDesign database.

 6.  Leave the Import tables, queries, forms, reports storage setting selected and click OK.

Access opens the Import Objects dialog box and displays object names contained in the backup 
database in tabbed groups.

 7.  Click the Reports tab, choose Customer Invoices, and click OK.

 8.  Leave the Save Import Steps box unchecked and click Close.

The Customer Invoices report is added to the Reports section of the Navigation pane.

 9.  Double-click the Customer Invoices report to open it in Report View.

 10.  Scroll down as necessary to see the empty space between the customer information and  
signature blocks.

This is a great spot to insert a subform/subreport that includes the invoice detail lines.
 

Adding a Subreport to a Main Report
Subreports display subsets of data in reports and are derived from related database tables, similar 
to subforms on forms. However, a subreport can display table data by using a table, query, form, or 
another report as its source object. Forms are frequently created before reports and often already 
display the required report data. To streamline the report design and layout, it’s best to use a 
subform as the basis of a subreport.
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This invoice report uses a subform to display invoice details.

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add  
a subform to a form. You can create the subreport using the Report Wizard or add an unbound 
subreport control to the report. Then you identify the database object containing the fields you  
want to display as a subreport.

View the video “Adding a Subreport Using the Wizard.”

ÝÍ Report Design Tools→Design→Controls→Subform/Subreport 

DEVELOP YOUR SKILLS: A8-D2

In this exercise, you will add a subreport to the Customer Invoices report. You will use the InvoiceDetails 
subform as the source for the subreport.

 1.  Display the Customer Invoices report in Design View.

 2.  Choose Report Design Tools→Design→Controls→Subform/Subreport  (at the bottom 
of the controls list).EVALU
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 3.  Click just below the ZIP label to insert a control and launch the SubReport Wizard.

 4.  Choose the Use an Existing Report or Form option.

 5.  Choose InvoiceDetails Subform from the list and click Next.

 6.  Click Next again to accept the Choose from a list linking method.

 7.  Click Finish to accept InvoiceDetails Subform as the name.

The subform is inserted in the report.

Set Properties
 8.  Display the Property Sheet, if necessary, and click the Data tab.

Notice the Source Object is set to Form.InvoiceDetails Subform.

 9.  Switch to the Format tab in the Property Sheet and set these properties:

Property Setting

Width 5.6

Height 1.5

Top 2.9

Left 0.5

 10.  Click the InvoiceDetails Subform label, which is just below the ZIP label, and set these 
properties:

Property Setting

Caption Invoice Details

Width 1.2

Height 0.30

Top 2.5

Property Setting

Left 0.5

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1, Darker 50%
A
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 11.  Switch to Report View to see your completed report.

 12.  Use the Navigation bar and the scroll bar to review the database records.

The information in both the report and the subform changes each time a new record is displayed.

 13.  Close the report, saving the changes.

Creating a Report from a Subreport
Using a subform as the record source for a subreport is convenient because the subform already 
includes the needed data. However, when a subreport uses a form as the record source, any changes 
made to the subreport layout are reflected in the source form. If you don’t want the source form 
to be changed, you can save the subreport as a separate report in the database, change the main 
report’s Record Source property to the new report object, and then edit the subreport.

Access allows you to save an existing form as a new form and an existing report as a new report. 
When a subform is used as the record source for a subreport, you can open the subreport in a sepa-
rate window and save it as a separate report.

ÝÍ File→Save As→Save Object As→Save As

DEVELOP YOUR SKILLS: A8-D3

In this exercise, you will create and save a new report based on the subreport from the Customer Invoices 
report. You will then edit the source object property in the main report to display the new subreport.

 1.  Open InvoiceDetails Subform from the Forms section of the Navigation pane.

 2.  Choose File→Save As, choose Save Object As from the File Types list, and then click the Save 
As button in the right pane.

 3.  Type WWD Customer Invoices Subreport as the name, choose Report from the As 
drop-down list, and click OK.

A new report is added to the Reports section of the Navigation pane.

 4.  Close the InvoiceDetails Subform.

 5.  Open the new WWD Customer Invoices Subreport in Design View.

 6.  Display the Property Sheet, if necessary, and then click the All tab and type Customer 
Invoices Subreport as the caption.

Create a Title for the Subreport
 7.  Choose Report Design Tools→Design→Header/Footer→Title.

Access places a title and empty placeholder controls in the Report Header.

 8.  Type Winchester Web Design Invoice Details in the title control and tap [Enter].EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Creating a Report from a Subreport 237

 9.  Set these property values for the new title control:

Property Setting

Width 3

Height 0.25

Left 1

Font Name Arial

Font Size 12

Text Align Center

 10.  Click the Report Header section bar and set the Height 
property to: 0.3069

Inserting the title in the header widens the subreport, so you 
will now reset the width.

 11.  Click the report selector button and set the Width prop-
erty to: 5.6

 12.  Close the subreport, saving the changes, and then open the Customer Invoices report in 
Design View.

 13.  If necessary, display the Property Sheet and click the Data tab.

 14.  Click the subreport to select it.

 15.  Click in the Source Object property box.

A drop-down menu button appears at the far 
right of the property box.

 16.  Choose Report.WWD Customer Invoices 
Subreport from the drop-down menu.

 17.  Switch to Report View to see how the new 
subreport looks.

Notice the change in appearance compared to 
the subform used previously.

 18.  Scroll through the report, seeing how the subreport always shows the correct invoice details.

 19.  Close the Customer Invoices report, saving the changes.
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Numbering Items in a Report
As the number of records in a table grows, the length and number of records in a report or subreport 
also grows. You can number the records in a report to help track the items listed. If a report is grouped, 
you can set the count to restart numbering at the beginning of each group.

Setting Properties to Number Items
By adding a text box to the Detail section and setting its Control Source property to =1, you can 
automatically number items in a report. In addition, you can set the Running Sum property to identify 
the portion of a report for which you want to count items. For example, suppose you have an invoice 
report that groups services by invoice number. You can set the Running Sum property to count the 
items in each group and then start counting again with the next group.

Numbering Subreports Separately
Access does not permit numbering items in a subreport control on a main report. However, because 
you saved the subreport as a separate report, you can add the numbering controls directly to the 
subreport by opening it in a separate window. Any edits you make when it is open as a separate item 
are reflected in the main report the next time you open it.

DEVELOP YOUR SKILLS: A8-D4

In this exercise, you will reposition the controls in the WWD Customer Invoices Subreport page header 
and add a text box control to count the number of line items.

 1.  Display the WWD Customer Invoices Subreport in Design View.

 2.  Right-click the Detail section bar and choose Page Header/Footer.

You will add labels to the Page Header section.

 3.  Click the Page Header section bar and change the Height property to: 0.3

 4.  Select the ProdID label in the Detail section and use [Ctrl]+[X] to cut the control.

 5.  Click in the Page Header section bar and use [Ctrl]+[V] to paste the label.

 6.  With the ProdID label still selected, set both the Width and Left properties to: 0.5

 7.  Use the procedure in steps 4–6 to move the Description, Price, Qty, and LineTotal labels one 
at a time into the Page Header section, setting the Width and Left properties as follows:

Property Width Left

Description 2 1.25

Price 0.75 3.5

Qty 0.3 4.5

LineTotal 0.75 5

 8.  If necessary, click the Description, Price, Qty, and LineTotal labels and use the up arrow [£] 
key to nudge them so they’re vertically aligned with the ProdID label.EVALU
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Move and Resize Report Text Box Controls
 9.  Set these property values for the text boxes in the Detail section:

Text Box Control Width Top Left

ProdID 0.5 0.1 0.5

ProdDescription 2 0.1 1.25

Price 0.75 0.1 3.5

Qty 0.3 0.1 4.5

LineTotal 0.75 0.1 5

 10.  Click the Detail section bar and set the Height property to: 0.5

 11.  Click the Selection Type menu button � at the top of the Property Sheet and choose Report.

 12. Set the Width property to: 6

 13.  Switch to Report View.

There is room for a small field to the left of the ProdID field, which is where you will insert numbering.

Add and Format a Text Box
 14.  Switch to Design View and choose Report Design Tools→Design→Controls→Text Box .

 15.  Click to the left of the ProdID text box in the Detail section to position the new box in that area.

The precise location is not important, as you will set the position, using specific properties, in a 
moment.

 16.  Click the new label control and tap [Delete] to remove it.

You may need to move your new text box if it is obscuring the label.
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 17.  Click the new text box control and set these property values using the All tab in the Property 
Sheet:

Property Setting

Name txtCount

Width 0.3

Top 0.1

Left 0.1

Back Style Transparent

Border Style Transparent

Set Control Properties to Sum
 18.  Click the Data tab and set the Control Source property to =1 and the Running Sum property to 

Over Group.

 19.  Switch to Report View and scroll through the report.

Notice that the numbering continues sequentially throughout the report.

 20.  Close the WWD Customer Invoices Subreport, saving the changes.

 21.  Display the Customer Invoices report in Design View.

 22.  Click the InvoiceDetails Subform and set the Width property to: 6

 23.  Switch to Print Preview and use the navigation bar to review the various report pages.

Each invoice begins on a new page and the invoice detail line items begin at number 1 for each invoice.

 24.  Close Print Preview and then close the Customer Invoices report, saving the changes.

Creating Calculated Controls on a Subreport
Reports summarize data in tables and queries to present useful, organized information. This means 
that a report would typically show subtotals, grand totals, and averages to summarize a specified 
group of data. You can do this by adding calculated controls.

Positioning Calculated Controls
Calculated controls are built-in reports using the Control Source property of an unbound text box 
control to which you add a formula. The section or group where a calculated control is placed deter-
mines how Access performs the calculation.
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A calculated control in a Detail section 
performs a calculation for each detail line.

A calculated control in a Group Footer 
section calculates the total for the group.

A calculated control in a Page Footer 
section calculates the total for the page.

A calculated control in a Report Footer 
section calculates the total for the entire report.

DEVELOP YOUR SKILLS: A8-D5

In this exercise, you will add a calculated control to the report footer section in the WWD Customer 
Invoices Subreport.

 1.  Display the WWD Customer Invoices Subreport in Design View.

 2.  Click the Report Footer section bar and set the Height property to: 0.3

 3.  Choose Report Design Tools→Design→Controls→Text Box 

 4.  Click anywhere in the Report Footer section.

 5.  Switch to the All tab in the Property Sheet and set these properties for the new text box control:

Property Setting

Name CustomerTotal

Control Source =Sum([Price]*[Qty])

Format Currency

Height 0.25

Top 0

Left 4.75

 6.  Click the new label control and set these property values:

Property Setting

Caption Invoice Total

Width 1.2

Height 0.25

Top 0

Left 3

Fore Color Text Dark
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 7.  Close the subreport, saving the changes.

 8.  Display the Customer Invoices report in Report View.

 

Growing and Shrinking a Subreport
When the number of records or amount of data displayed in a subreport varies, you can set the Can 
Grow and Can Shrink properties to allow the subreport space to expand or shrink so more data 
displays vertically. You can also change the orientation of the print layout to allow more horizontal 
space on each report page.

The subform without the Can Grow property enabled 
displays less vertical data, requiring a scroll bar.

The subform with the Can Grow property enabled 
is expanded to display more vertical data.

DEVELOP YOUR SKILLS: A8-D6

In this exercise, you will adjust the margins of the Customer Invoices report and set the Can Grow and Can 
Shrink properties. These properties will adjust the size of the subreport to fit the contents.

 1.  Display the Customer Invoices report in Design View.
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 2.  Choose Report Design Tools→Page Setup→Page Size→Margins→Narrow.

 3.  Click the InvoiceDetails Subreport.

 4. If necessary, display the Property Sheet; on the Format tab, set the Can Grow property to No.

 5.  Switch to Report View and scroll through the report.

The subform now displays a vertical scroll bar in order to view additional records.

 6.  Switch to Design View and click the InvoiceDetails Subreport.

 7.  Click the Format tab on the Property Sheet and, if necessary, set the Can Grow and Can Shrink 
properties to Yes.

 8.  Switch to Report View and scroll through the report.

The subreport grows and shrinks to best fit the contents.

 9.  Save the report.

Setting Page Breaks and Customizing Controls
As you view the Winchester Web Design Customer Invoices report in Report View, you may notice 
that the number of invoice records displayed on each screen varies depending on the number of items 
ordered. To ensure each customer invoice starts on a new page, you can add a page break control. 
By default, when you view a report in Print Preview, data for each customer/record automatically 
appears on a separate page; however, multiple records appear on the same page when the report is 
displayed in Report View.

To add a title or general company information to an invoice, place title controls in the Page Header 
rather than the Report Header, which prints only on the first page.

Add the page break at the end of the Detail section so Access knows to start a new page before printing 
the next page header.

ÝÍ Report Design Tools→Design→Controls→Insert Page Break 

DEVELOP YOUR SKILLS: A8-D7

In this exercise, you will modify the Customer Invoices report by adding a title and the current date as well 
as setting up page breaks to print each invoice on a separate page.

 1.  Display the Customer Invoices report in Design View.

To begin, you will modify the report title.

 2.  Click the Customer Invoice title control in the Page Header section and then click just in front 
of Customer to position the insertion point there.

 3.  Type Winchester Web Design and then press [Shift]+[Enter] to force Customer Invoice to a 
second line.

 4.  Click an empty area in the Page Header section and then click the title control once more to 
select it.

 5.  Set the Width property to 4 and the Left property to 2.

Tip!
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Add a Date Control
In the next few steps, you will insert a date that will display in the report header.

 6.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 7.  Choose the third date option MM/DD/YYYY format, remove the check from the Include Time 
box, and click OK.

Access places the new date control in the Report Header section. Next, you will move the date to the 
Page Header section so it appears on every page rather than just the first page of the report.

 8.  Select the date control and press [Ctrl]+[X] to cut it from the report header.

 9.  Click the Page Header section bar and press [Ctrl]+[V] to paste the date into the page header.

 10.  Set these properties for the date control:

Property Setting

Width 2

Height 0.2

Top 0.4

Left 5.8

Add a Page Break Control
 11.  Scroll to the bottom of the Detail section.

 12.  Choose Report Design Tools→Design→Controls→Insert Page Break .

 13.  Place the page break in the Detail section just above the Page Footer section bar.

 14.  Switch to Print Preview and use the navigation bar to browse the pages.

The date appears on each invoice because you added it in the Page Header section. Each invoice 
begins on a new page. Sometimes it’s not necessary to add a page break to a report and doing so may 
add an unneeded page. If this occurs in your report, remove the page break.

 15.  Close Print Preview and then close the report, saving the changes.

Adding Charts
Summarized and numerical data is often displayed visually using a chart. By adding a chart to a 
report, the information and relationships between report data is more easily interpreted. While you 
can add charts to reports and forms, they’re more commonly used in reports. Access offers multiple 
chart types, including column, bar, line, and pie, among others.

You can insert charts using the Chart control or the Insert Chart command.

ÝÍ Report Design Tools→Design→Controls→Insert Chart 

Before After
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Formatting Modern Charts
You can format and modify common settings using either the Property Sheet or the Chart Settings 
task pane, which means formatting charts in Access is similar to formatting charts in other Microsoft 
Office applications, like Excel and PowerPoint.

View the video “Adding Modern Charts.”

ÝÍ Report Design Tools→Design→Tools→Chart Settings 

Refreshing Chart Data
Like many other Access objects, charts use the contents in a table or query as the data source. When 
the data source of a chart is changed, the chart may not automatically reflect those changes. The 
Refresh All command manually updates a chart to match record source data.

Home→Records→Refresh All 

DEVELOP YOUR SKILLS: A8-D8

In this exercise, you will modify Winchester’s Employee Sales report by adding a chart. You will then 
format the chart and manually update it after making changes to the record source.

 1.  Display the Employee Sales report in Design View.

 2.  Choose Report Design Tools→Design→Controls→Insert Chart .

A menu appears allowing you to select the chart type.

 3.  Choose Column→Clustered Column.

Your mouse pointer changes to a chart icon with a plus sign.

 4.  Click in the upper-left corner of the Page Footer section to insert the chart control.

 5.  Close the Property Sheet and the Chart Settings pane, if necessary.

 6.  Hover your mouse pointer over the bottom right of the new 
chart control until a diagonal double-pointed arrow appears.

 7.  Resize the control by dragging to the bottom right until your 
chart is as tall as the Page Footer section and as wide as all 
text box controls in the Detail section.
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Format the Chart
 8.  Choose Report Design Tools→Design→Tools→Chart Settings .

The Chart Settings pane appears.

 9.  Choose EmployeeSales from the Data Source drop-down list.

 10.  Choose EmpLastName for the Axis.

 11.  Choose ProdDescription as the Legend.

 12.  Choose LineTotal (Sum) for the Values.

 13.  Open the Property Sheet and set these chart properties:

Property Setting

Has Legend Yes

Chart Title Total Sales

Category Axis Font Size 14

Primary Values Axis Format Currency

There are many chart properties and settings available. If you will use charts frequently, you may want 
to explore each of these settings.

 14.  Switch to Report View to see the newly created chart.

Refresh the Chart
 15.  Open the InvoiceDetails table and change the quantity for the first record to: 100

 16.  Switch to the Employee Sales report and choose Home→Records→Refresh All .

The Home Page column for Winchester rises dramatically.

 17.  Switch to the InvoiceDetails table and change the quantity for the first record back to: 1

 18.  Switch to the Employee Sales report and refresh the chart using the Refresh All command.

The chart data has normalized.

 19.  Close the Employee Sales report, saving any changes, and then close the database.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Tip!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A8-R1

Import a Report and Add a Subreport
In this exercise, you will import a report from the Kids for Change database and then add a subform with 
details on the activities provided by the staff.

 1.  Open A8-R1-K4C from your Access Chapter 8 folder and save it as: A8-R1-K4CRev

 2.  Choose External Data→Import & Link→New Data Source→From Database→Access .

 3.  Click Browse and navigate to your Access Chapter 8 folder, choose A8-R1-K4C-Backup, and 
click Open.

 4.  Leave the import storage setting chosen and click OK.

 5.  Click the Reports tab, choose Staff Report, and click OK.

 6.  Leave the Save Import Steps checkbox unchecked and click Close in the Get External Data 
dialog box.

 7.  Display the newly imported Staff Report in Report View.

The empty space between the staff records is where you will insert the subreport.

Add and Format a Subreport
 8.  Switch to Design View and choose Report Design Tools→Design→Controls→ 

Subform/Subreport  (scroll to the bottom of the controls list).

 9.  Click just below the Activity ID label in the Detail section to insert a control and launch the 
Subreport Wizard.

 10.  Choose Staffing Subform from the Use an Existing Report or Form option and click Next.

 11.  Click Next again to accept Choose from a List as the linking method.

 12.  Click Finish to accept Staffing Subform as the name.

A small green triangle in the report selector indicates a possible error. Clicking the triangle displays a 
smart tag that shows the error and possible solutions. In this case, the report is wider than the page. 
You will correct this in the next few steps.
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 13.  Click the Staffing Subform label and tap [Delete].

 14.  Click the subreport and set these properties:

Property Setting

Width 7.7

Height 0.5

Top 3

Left 0

Border Style Transparent

 15.  Click the report selector and set the Width property to: 7.8

The green smart tag indicator should be gone.

 16.  Save Staff Report and then switch to Report View.

 17.  Scroll through the report to see that the activity details now appear under the staff information.

 18.  Close the database.

REINFORCE YOUR SKILLS: A8-R2

Create a Report from a Subreport and Number Report Items
In this exercise, you will save a subreport as a separate report. You will also update a report of donations 
to Kids for Change, numbering them in order to add a count of the donations per donor.

 1.  Open A8-R2-K4C from your Access Chapter 8 folder and save it as: A8-R2-K4CRev

 2.  Open Staff Report and switch to Design View.

 3.  Right-click the subreport control and choose Subreport in New Window.

The Staffing Subform subreport opens in a separate window.
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 4.  Choose File→Save As→Save Object As→Save As.

 5.  Type K4C Staffing Subreport as the name, choose Report from the Save As drop-down 
list, and click OK.

 6.  Close the subform and the report.

 7.  Display the new K4C Staffing Subreport in Design View.

 8.  Click the Detail section bar and set the Height property to: 0.3

 9.  Right-click the Detail section bar and choose Report Header/Footer.

The Report Header section appears.

 10.  Click the Report Header section bar.

 11.  Set the Back Color property to Blue, Accent 1, Lighter 80%.

 12.  Choose Report Design Tools→Design→Controls→Label  and then click in the Report 
Header section above the ActID control and type: ID

 13.  Add six more labels: Activity, Day, Time, Venue, Street, and City

You don’t need to be precise with the label positions, as you will modify their properties in the 
next step.

 14.  Press [Ctrl] and click all seven labels to select them and then set these properties:

Property Setting

Height 0.2

Top 0

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1
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 15.  Click in an empty spot in the Report Header section to deselect the labels.

 16.  If necessary, click the individual labels and widen them so the text is fully visible and then align 
them with the text boxes in the Detail section.

 17.  Close and save K4C Staffing Subreport.

 18.  Display Staff Report in Design View and click the subreport control.

 19.  Set these properties on the All tab of the Property Sheet:

Property Value

Name Staffing Subreport

Source Object Report.K4C Staffing Subreport

 20.  Switch to Report View to see the changes and then close and save Staff Report.

Number Report Items
 21.  Display Donations Report in Design View.

 22.  Choose Report Design Tools→Design→Controls→Text Box  and click in the Detail 
section to the left of the DonorID text box.

 23.  Click the label control for the new text box (to the left of the text box—it may be difficult to see) 
and tap [Delete].
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 24.  Select the new text box control and then set these property values on the All tab of the Property Sheet:

Property Setting

Name txtCounter

Control Source =1

Width 0.3

Top 0

Property Setting

Left 0.3

Border Style Transparent

Font Name Arial

Font Weight Semi-Bold

 25.  Click the Data tab in the Property Sheet and set the Running Sum property to Over All.

 26.  Switch to Report View.

Access numbers the detail lines consecutively for each individual donation.

 27.  Close the database, saving the changes to the Donations Report.

REINFORCE YOUR SKILLS: A8-R3

Insert Calculated Fields and Page Breaks
Kids for Change wants to improve its donations reporting. In this exercise, you will add a field to calculate 
the total monthly donations for each donor. You will set the subreport to grow and shrink, and you will add 
custom controls and a page break. You will then add a column chart that shows total donations by donor 
with data labels.

 1.  Open A8-R3-K4C from your Access Chapter 8 folder and save it as: A8-R3-K4CRev

You will begin by adding a calculated field to a report.

 2.  Display K4C Donors Subreport in Design View.

 3.  Choose Report Design Tools→Design→Controls→Text Box  and click in the Page Footer 
section under the Amount text box to place a new text box there.

 4.  Click the text box label and tap [Delete].
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 5.  Click the new text box and set these properties on the All tab of the Property Sheet:

Property Setting

Name MonthTotal

Control Source =Sum([Amount])

Format Currency

Width 1.3

Height 0.2

Property Setting

Top 0

Left 5

Font Name Arial Rounded MT Bold

Text Align Right

 6.  Close and save K4C Donors Subreport.

Grow and Shrink a Subreport
 7.  Display Monthly Donations Report in Design View.

 8.  Click the subform to select it.

 9.  Click the All tab in the Property Sheet and set the Can Grow and Can Shrink properties to Yes.

 10.  Switch to Report View and scroll through the report.

Notice how the number of donations per month changes and the report shrinks and grows to 
accommodate the number of donations each month.

Modify the Title
 11.  Switch to Design View.

 12.  Click the Monthly Donations Report title control in the Page Header section and then click 
just in front of Monthly to position the insertion point.

 13.  Type Kids for Change and press [Shift]+[Enter] to force Monthly Donations Report to a 
second line.

 14.  Click a blank part of the header and then click the title control again to select it.
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 15.  Set these properties for the title control:

Property Setting

Width 4

Left 2

Text Align Center

 16.  Switch to Print Preview and scroll through the first page of the report.

More than one month appears per page.

 17.  Use the navigation bar to navigate to page 2.

The April donations spill over from the previous page. In the next steps, you will insert a page break so 
each month begins on a new page.

Insert a Page Break
 18.  Close Print Preview and then switch to Design View and choose Report Design Tools→ 

Design→Controls→Insert Page Break .

 19.  Click in the left side of the DonationDate Footer section to place the page break.

 20.  Set the Top property of the page break control to: 0

 21.  Click the DonationDate Footer section bar and set the Height property to: 0.001

This will make the DonationDate Footer section as short as possible so the page break doesn’t push 
the DonationDate header to the next page.

 22.  Switch to Print Preview and use the navigation bar to scroll through the report pages.

Now the donations for each month start on new pages.

Add a Column Chart
 23.  Close the Monthly Donations report, saving the changes, and then display the Total Donations 

Chart report in Design View.

 24.  Choose Report Design Tools→Design→Controls→Insert Chart .

 25.  Choose Column→Clustered Column.

 26.  Click in the upper-left corner of the Detail section to insert the chart control.

 27.  Choose Donations Query from the Data Source drop-down list.

 28.  Choose DonorLName for the Axis, (None) as the Legend, and NetAmt (Sum) for the Values.
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 29.  Click the Format tab at the top of the Chart Settings pane and check the box for Display Data 
Label.

 30.  Resize your control by dragging to the bottom right until your chart fills the entire Detail section.

 31.  Open the Property Sheet and set these chart properties:

Property Setting

Has Legend No

Has Title No

Primary Values Axis Format Currency

 32.  Switch to Report View and view the report; close the database, saving the changes.
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 Apply Your Skills
APPLY YOUR SKILLS: A8-A1

Work with Reports and Subreports
In this exercise, you will help Universal Corporate Events create a report that breaks down the company’s 
revenue by venue. You will add a subreport to a main report.

 1.  Open A8-A1-UCE from your Access Chapter 8 folder and save it as: A8-A1-UCERev

The first step is to import the needed report.

 2.  Choose External Data→Import & Link→New Data Source→From Database→Access .

 3.  Choose A8-A1-UCE–Backup from your Access Chapter 8 folder.

 4.  Leave the Import storage setting chosen and click OK.

 5.  Click the Reports tab, choose Venue Revenue Report, and click OK.

 6.  Choose to not save the import steps and click Close.

 7.  Display the newly imported Venue Revenue Report in Report View.

The empty space between the locations is where you will insert the subreport.

Add a Subreport
 8.  Switch to Design View and choose Report Design Tools→Design→Controls→ 

Subform/Subreport .

 9.  Click in the VenueID header section below the other controls and launch the Subreport Wizard.

 10.  Choose VenueRevenue Subform from the Use an Existing Report or Form option and click Next.

 11.  Choose the second linking option (link by VenueID) and click Next again.

 12.  Click Finish to accept VenueRevenue Subform as the name.

 13.  Delete the VenueRevenue Subform label located just above the subform.
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 14.  Select the new subform and set these properties:

Property Setting

Width 7

Height 1.5

Top 1.3

Left 0.25

Border Style Transparent

 15.  Click the VenueID Header section bar and set the Height property to: 3

 16.  Switch to Report View and scroll through the report.

Each venue now has an event data subform associated with it that contains all the revenue data for 
the events.

 17.  Close the database, saving the changes to the Venue Revenue Report.

APPLY YOUR SKILLS: A8-A2

Create a Report from a Subreport and Number Report Items
In this exercise, you will continue to help Universal Corporate Events create an effective venue revenue 
report. You will create a report from a subreport and number items on a subreport.

 1.  Open A8-A2-UCE from your Access Chapter 8 folder and save it as: A8-A2-UCERev

 2.  Display Venue Revenue Report in Design View.

 3.  Right-click the subreport and choose Subreport in New Window.

 4.  Save the object as a report named: VenueRevenue Subreport

 5.  Close VenueRevenue Subreport.

 6.  Make sure the subform/subreport is selected and the Property Sheet is displayed.

 7.  Set the Source Object property on the All tab to Report.VenueRevenue Subreport.

 8.  Save the Venue Revenue Report and then switch to Print Preview.

The subreport will be displayed.

 9.  Close Print Preview and close Venue Revenue Report.

Format the Report
Now you will resize the labels and move them from the Detail section to the Report Header section.

 10.  Display the VenueRevenue SubReport in Design View and set the Width property to: 6

This widens the subreport enough to accommodate the changes you are about to make. 
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 11.  Use [Ctrl] and the mouse to select all labels and text boxes in the Detail and Report Footer 
sections.

 12.  Click the Format tab in the Property Sheet and set the Border Style 
property to Transparent and the Fore Color property to Black, Text 1.

 13.  Click an empty part of the form to deselect all controls and then click 
each label individually and reduce the size to just fit the caption (label 
text).

 14.  Click the Report Header section bar and set the Height property to: 0.3

 15.  Click the VenueID label and press [Ctrl]+[X].

 16.  Click in the Report Header section, press [Ctrl]+[V] to paste the label, and then use the arrow 
keys to nudge it to about 0.25 in from the left edge.

 17.  Cut and paste the remaining labels from the Detail section into the Report Header and then use 
the arrow keys to align them approximately as shown:

 18.  Rearrange the Detail section text boxes by dragging them with the mouse, nudging them with 
the arrow keys, and reducing their widths to align them with the Report Header labels.

 19.  Click the Detail section bar and set the Height property to: 0.3

 20.  Use the right arrow [¡] key to right-align the calculated control in the Report Footer section 
with the Line Total label and the Detail section calculated control.
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 21.  Switch to Layout View and, if necessary, resize and reposition the controls so they are aligned 
nicely and all data is visible.

 22.  Save the subreport.

Number Report Items
 23.  Switch to Design View and insert a new text box in the Detail section to the left of the VenueID 

text box.

 24.  Delete the associated label control.

 25.  Click the new text box control and set these property values in the All tab of the Property Sheet:

Property Setting

Name txtCount

Control Source =1

Width 0.2

Top 0

Left 0

Border Style Transparent

 26.  Click the Data tab in the Property Sheet and set the Running Sum property to Over All.

 27.  Select all text boxes in the Detail section and set the Top property to: 0EVALU
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 28.  Save the VenueRevenue SubReport and then display the Venue Revenue Report in Print 
Preview.

Navigate through the report and notice that the detail lines for each venue are now numbered 
sequentially.

 29.  Close the database, saving changes to any reports.

APPLY YOUR SKILLS: A8-A3

Add a Calculated Field and a Page Break
Universal Corporate Events continues to refine its database reports. In this exercise, you will first add a 
field to calculate the total of all the venues’ revenues. You will also add a page break to another report to 
allow each month to begin on a new page.

 1.  Open A8-A3-UCE from your Access Chapter 8 folder and save it as A8-A3-UCERev

 2.  Display Venue Revenue Report in Report View.

 3.  Scroll through the report and notice that each venue is associated with Line Total calculations 
and a total of all line totals per venue.

The one thing missing is a grand total at the bottom of the report that sums all totals for the venues. 
You will add a calculated control that produces a grand total.

 4.  Switch to Design View.

 5.  Click the Report Footer section bar and set the Height property to: 0.4

 6.  Insert a text box anywhere in the Report Footer section and set these properties for the label control:

Hint: Use the Format tab on the Property Sheet.

Property Setting

Caption Grand Total for All Venues

Width 2

Top 0.1

Left 2

Font 
Weight

Semi-Bold

Fore Color Blue, Accent 1, Darker 50%
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 7.  Set these property values for the new text box:

Hint: Use the All tab on the Property Sheet.

Property Setting

Name ActivityCost

Control Source =Sum([Guests]*[ChgPP])

Format Currency

Width 1.5

Top 0.1

Property Setting

Left 5

Border Style Transparent

Font Weight Semi-Bold

Fore Color Blue, Accent 1, Darker 50%

 8.  Select the VenueRevenue Subform and set the Can Grow and Can Shrink properties on the 
Format tab of the Property Sheet to Yes.

This ensures that all venue detail lines will be displayed.

 9.  Switch to Report View and scroll to the end of the report.

Notice the Grand Total for All Venues label and the grand total calculated control.

 10.  Close Venue Revenue Report, saving the changes.

Insert a Page Break
 11.  Display the Event Revenue Report in Print Preview.

 12.  Scroll through the first page and notice that several months are included.

The page break you are about to insert will position each month on a separate page.

 13.  Close Print Preview and then switch to Design View and insert a Page Break  control on the 
left side of the EventDate Footer section, just below the Total for label.

Be sure to position the break below the label or portions of the report will be cut off.

 14.  Switch to Print Preview and notice that just one month appears on the first page.

 15.  Use the navigation bar to go to the next page, and, once again, just one month will be displayed 
because of the page break.

 16.  Close the report, saving your changes.EVALU
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Insert a Pie Chart
 17.  Display the Revenue by Venue report in Design View.

 18.  Use the Insert Chart command to create a new pie chart.

 19.  Click in the upper-left corner of the Detail section to insert the chart control and use these chart 
settings:

• Data source: Event Revenue

• Legend: (None)

• Values: TotalRev (Sum)

 20.  On the Format tab, check the box for the Display Data Label option.

 21.  Resize your chart control to fill the entire Detail section.

 22.  On the Property Sheet, set these properties for the chart:

Property Setting

Legend Position Bottom

Has Title No

Primary Values Axis Format Currency

 23.  Close the database, saving the changes to the report.
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  Project Grader

PROjECt gRADER: A8-P1

Taylor Games: Updating Inventory
Taylor Games is ready to take sales orders. Before it begins, it needs to create a printable sales receipt for 
its customers. In this exercise, you will start by adding a subreport to a main report. Next, you will add 
calculated controls to provide order subtotals, taxes, and totals. You will then set page breaks for printing 
individual receipts.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A8_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A8_P1_Start from your Access Chapter 8 folder.

 2.  Add a subreport to the Sales Receipt report using these guidelines:

• Position the subreport in the detail section below the text boxes.

• Use the OrderDetails report for the data.

• Leave all linked field options set to the default values.

• Leave the Name as OrderDetails.

 3.  Delete the OrderDetails subreport label and set the following subreport properties:

Property Value

Width 6

Height 3

Top 0.45

Left 0

Border Style Transparent

Can Shrink Yes

 4.  In the Detail section of the subreport, set the Border Style property for all text box controls to 
Transparent.

 5.  In the Report Footer section of the subreport, insert a new text box control and set these  
properties for it:

Property Value

Name Subtotal

Control Source =Sum([Line Total])

Format Currency

Top 0.10

Left 4.2

Border Style TransparentEVALU
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 6.  Set these properties for the new unbound label (contains the text Text40):

Property Value

Name Sub Total

Caption Sub Total

Width 1

Top 0.10

Left 3.5

 7.  Insert a new text box control below the Subtotal text box and set these properties for it:

Property Value

Name Taxes

Control Source =[Subtotal]*.075

Format Currency

Top 0.4

Left 4.2

Border Style Transparent

 8.  Set the following properties for the new unbound label (contains the text Text42):

Property Value

Name Tax

Caption Tax

Width 1

Top 0.4

Left 3.5

 9.  Insert a new text box control below the Taxes text box and set these properties for it:

Property Value

Name Order Total

Control Source =[Subtotal]+[Taxes]

Format Currency

Top 0.7

Left 4.2

Border Style Transparent

Font Weight Bold

 10.  Set the following properties for the new unbound label (contains the text Text44):

Property Value

Name Total

Caption Total

Width 1

Top 0.7

Left 3.5

Font Weight Bold
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 11.  Insert a page break control below the subreport and just above the Sales Receipt form’s page 
footer.

 12.  Save your database.

• Using eLab: Save it to your Access Chapter 8 folder as A8 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 8 folder as: A8 _ P1 _ Submission

PROjECt gRADER: A8-P2

WebVision: Create a Chart and Back Up the Database
WebVision would like you to make some database improvements. In this exercise, you will create a chart 
displaying the total sales for each sales rep. You will also import an invoice report, located in a backup 
database, and make a few changes to improve visual design.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A8_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A8_P2_Start from your Access Chapter 8 folder.

 2.  Use the Report Design tools to create a new report with the name: Annual Sales by Rep

 3.  Insert a date and time control using these guidelines and properties:

• Use the second date option.

• Do not include a time.

Property Value

Width 1

Text Align Center

 4.  Insert the WebVision Logo.jpg image from your Access Chapter 8 folder and set the Width 
property to: 1.25

 5.  Set the ReportHeader section Back Color property to Background Form.EVALU
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 6.  Add a pie chart to the Detail section using these chart settings:

Setting Value

Data Source Rep Sales by Customer query

Axis (Category) Last Name

Legend (Series) (None)

Values (Y axis) Total (Sum)

In the Format list Check the Display Data Label box 

 7.  Set these chart properties:

Property Value

Top 0

Left 0

Width 6.5

Height 5

Legend Position Bottom

Legend Text Font Size 14

Chart Title Annual Sales by Rep

Chart Title Font Size 20

Primary Values Axis Format Currency

 8.  Set the Report Width property to: 6.5

 9.  Use these guidelines to import a report from another database:

• Choose the A8_P2_Backup Access database located in your Access Chapter 8 folder as the 
data source.

• Choose the Invoices report as the object to import.

 10.  Save your database.

• Using eLab: Save it to your Access Chapter 8 folder as A8 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 8 folder as: A8 _ P2 _ Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A8-E1 That’s the Way I See It
You would like to modify a database report to show sales details for the Blue Jean Landscaping 
database. Open A8-E1-BJL and save it as: A8-E1-BJLRev

Import the Customer Sales Report from A8-E1-BJL-Backup. Then add the CustomerSales Subform 
to the Detail section of the Customer Sales Report.

A8-E2 Be Your Own Boss
As the owner of Blue Jean Landscaping, you pride yourself on creating organized and easy-to-use 
reports. You want to add more calculations to your report and to add page breaks for more orga-
nized viewing of the data. Open A8-E2-BJL and save it as: A8-E2-BJLRev

Open Customer Sales Report and create a new subreport from the CustomerSales Subform. Calcu-
late the line totals for each subreport line using the formula Price*QtySold. Insert a page break so 
each customer appears on a separate page when you view the report in Print Preview.

A8-E3 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant is enjoying increased sales, so you must make some 
changes to the database reports to produce more useful sales results. Open A8-E3-SBQ and save it 
as: A8-E3-SBQRev

Import the Merchandise Sales Report from A8-E3-SBQ-Backup. Insert the MerchandiseSales 
Subform into the Detail section of the Merchandise Sales Report to add individual sale line items 
(choose Show each record in Merchandise using SKU). Save the subform as a report, being sure to 
close the subform, and then open the new subreport so the changes you make are not reflected 
in the subform. Calculate each line total (ListPrice*QtySold) in the Detail section of the subreport. 
Create a new report that includes a pie chart in the Detail section. Ensure the chart uses the 
MerchandiseSalesQuery as the data source and displays the total sales by Item Name.
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ÝÝ Set Access options

ÝÝ Split a database

ÝÝ Explore switchboards and create a navigation 
form

ÝÝ Set and modify startup options

9 Customizing the 
Database Interface 
and Startup Options

ACCESS

S
hared databases can experience 

a growing number of issues that 

accompany the unpredictable 

actions of multiple users. To limit these issues, 

designers can modify interface and startup 

options to help reinforce consistent data 

entry and protect vital data. In this chapter, 

you will create a navigation form, which is an 

attractive, user-friendly interface that allows 

for quick and accurate data entry. You will 

also split a database to protect the database 

tables and their data while still allowing users 

to create and modify their own personal 

queries, forms, and reports. Finally, you will 

set and modify various Access options.
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Ý Project: Customizing—As You Like It
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You are building the company’s database, which is almost 
complete. The owner is concerned about its ease of use and future maintenance and would 
like to allow individuals to make their own customized queries and reports while maintaining a 
standard company interface and ensuring data validity and database security.

Setting Access Options
Each Microsoft Office application provides options to control the way the application performs. 
Access options can control the color of datasheets, set default fonts, create sections on the Naviga-
tion pane, add a title to the application window, customize the Quick Access toolbar, set a default 
startup form, and so on. Some options control settings for the active database, while others control 
default settings for all databases used on a particular device.

Displaying Access Options
The Access Options dialog box groups features by type. It lists the categories in a panel on the left 
side and their associated options in the panel on the right side. Some options are used frequently 
while others are rarely used.

Option sections for the selected General category show current settings.

Option 
categories
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Datasheet Effects
Users may prefer a specific font or cell style and don’t want to apply the desired changes each time 
they enter data. Options to customize how a datasheet will appear by default can be found in the 
Datasheet category of the Access Options dialog box. Examples of datasheet options that can be set 
include gridlines, cell effects, column widths, and font properties.

ÝÍ File→Options→Datasheet

DEVELOP YOUR SKILLS: A9-D1

In this exercise, you will display and explore options in the Access Options dialog box.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

 1.  Open A9-D1-WinDesign from your Access Chapter 9 folder and save it as: 
A9-D1-WinDesignRev

 2.  Choose File→Options and click the Datasheet category.

 3.  Explore the options for the current database but don’t change any.

These settings apply to any database opened using your installation of Access. Changing these settings 
will affect any database opened on this device from here out.

 4.  Click Cancel when you have finished.

Unless otherwise directed, keep Access and any databases or database objects being used open at the end 
of each exercise.
 

Setting Personal Information and Database Properties
The Access Options dialog box includes a General category that allows you to set the format in which 
databases are created and to set personal information for your copy of Microsoft Office.

Database properties are similar to other object properties, except they identify or describe an entire 
database, such as the database title and author, names of objects contained in the database, or the 
date and time it was created or last updated.

ÝÍ File→Options→General

ÝÍ File→Info

Note!
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DEVELOP YOUR SKILLS: A9-D2

In this exercise, you will you will personalize your copy of Microsoft Office and change database properties.

 1.  Choose File→Options.

The Access Options window opens with the Datasheet category selected.

 2.  Explore the general options for the database but don’t change them.

 3.  Click Cancel to close the Access Options dialog box.

Now you will set database properties.

 4.  Choose File→Info and follow these steps to set the database properties:

A

D

C

B

A Click the View and Edit Database Properties link.

B If necessary, click the Summary tab on the Properties dialog box.

C Type Jay Winchester in the Manager line.

D Type Winchester Website Design in the Company line.

 5.  Click OK.

Customizing the Navigation Pane
The Navigation pane is your tool for selecting database objects and identifying objects associated 
with each object type. You use the Navigation pane to display objects in different views. You can also 
customize it to contain additional sections to make the pane even more useful.

Navigation Pane Categories and Groups
The Navigation Options dialog box shows two list boxes: one that identifies the categories of 
objects displayed on the Navigation pane and one that shows the groups available for display  
on the pane.EVALU
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Categories 
available 
by default

Buttons for 
adding, deleting, 

and renaming 
items

Groups available 
for the selected 
category

Buttons for 
adding, deleting, 
and renaming 
groups

Working with Groups
Access prevents you from changing, deleting, or adding additional object type groups to the essential 
Tables and Related Views and Object Type categories. However, the Custom category allows you to 
rename, delete, and add groups to a category. When you add or rename groups in the Navigation 
pane, you must reassign objects to the groups so Access knows where to place them.

Customizing the Navigation pane applies the control settings to the active database only. You must 
customize the Navigation pane for any other databases. 

DEVELOP YOUR SKILLS: A9-D3

In this exercise, you will customize the Navigation pane and assign objects to new Navigation pane groups.

 1.  Choose File→Options and follow these steps to customize the Navigation pane:

A

B

C

A Choose Current Database.

B Scroll, if necessary, to the Navigation section.

C Click the Navigation Options… button.

Access displays the Navigation Options dialog box.

Note!
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 2.  Follow these steps to create a new item:

A

B

A Click Add Item.

B Type Winchester Web Design in the Custom Category 1 box and tap (Enter).

A new item named Winchester Web Design appears in the Categories list. 

 3.  Click Add Group.

A new item named Custom Group 1 appears in the Groups list.

 4.  Type Customers in the Custom Group 1 box and tap [Enter].

 5.  Click Add Group and then type Invoices and tap [Enter].

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Setting Access Options 273

 6.  Click OK to close the Navigation Options dialog box. Click OK to close the Access Options 
dialog box.

 7.  Follow these steps to display the new Winchester Web Design category:

A

B

A Click the Navigation Pane Options button.

B Choose Winchester Web Design.

All objects for the Winchester Web Design category are in the Unassigned Objects group.

 8.  In the Unassigned Objects group on the Navigation pane, right-click the Customers table 
object and choose Add to Group→Customers.

 9.  One at a time, right-click the Customers Form, the Customer Invoice Report, and the 
Customer Invoice Subreport to add them to the Customers group.

 10.  Assign these objects to the Invoice group:
• InvoiceDetails
• Invoices
• Invoice Details Query
• Invoices Query

• Invoice Form
• Invoice Details Subform
• Invoice Details Report

 11.  Click the Navigation Pane Options button and choose Object Type.

The Navigation pane returns to the more traditional view, which groups objects by type (Tables, 
Queries, Forms, and Reports).

 

Setting Up Current Database Formats
Current database settings enable you to change the way Access displays and works with the active 
database. You can, for example, change the text Access displays in the title bar when the database is 
open, show or hide the Navigation pane, enable views, or change the way Access displays open objects.

Changing Title Text in the Application Bar
Sometimes, the actual filename assigned to a database may be different from the text you want 
users to see when they open the database. You can change the text that appears in the title bar using 
the Current Database options window.

Type the text you want displayed in the 
title bar into the Application Title text box.
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Setting Object Window Format
Open database objects are set to format as tabs within the database work area. You have to click the 
tab of the object you want to see in the work area.

Tabs for opened documents are 
aligned at the top of the work area.

You can change the format so objects display as overlapping windows in the work area, or you can 
move and resize the objects for easier comparison of styles, layout, and contents.

Overlapping windows 
have individual title 
bars that “float” in 
the work area.

After changing the document window options, close and then reopen the database to view the new 
settings.

ÝÍ File→Options

Tip!
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DEVELOP YOUR SKILLS: A9-D4

In this exercise, you will change settings for the current database, editing the title and changing the 
window options.

 1.  Choose File→Options and follow these steps to change the application title text and window 
display:

A
B

C

A Choose Current Database.

B Type Winchester Web Design as the application title.

C Choose Overlapping Windows.

 2.  Explore the other options for the current database and then click OK.

You must close and then reopen the database for the settings to take effect.

 3.  Choose OK in the message dialog box and then close and reopen the database.

 4.  Display the Customers and Products tables in separate windows.

 5.  Drag the title bar of the Products table window down slightly to view the Customers table.

Move and resize the open objects so you can see both at the same time.

 6.  Choose File→Options→Current Database, set the document window preference back to 
Tabbed Documents, and click OK. Then click OK in the message box.

 7.  Close the tables and then close the database.
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Splitting a Database
Sometimes users want to edit the design and layout of queries, forms, and reports or even develop 
their own objects to meet their particular needs. If the database is shared with other users, this may 
cause problems. 

Record Locking
Multiple users can simultaneously use an Access database to add, edit, and delete data. Whenever 
an Access database is opened, Access creates a small temporary file by the same name but with the 
extension .laccdb. This file manages record locking. The initial file extension character, l, stands for 
locked, which means whenever one user edits a record, no other user can edit it until the first user 
moves to another record—essentially “unlocking” it. Record locking helps maintain consistent data 
and protects the integrity of record updates.

Reasons for Splitting Databases
Allowing users to create their own objects in a shared database can create confusion and increase 
the chance of data corruption or broken database relationships. To protect company data, many 
businesses prohibit users from creating and saving new objects. One way to protect table data when 
allowing users to create and customize objects to meet their personal needs is to split the database.

The Database Splitter
The database splitter converts a database into two files: one that contains the tables holding the 
data that support all other database objects and one that contains the database reports, forms, 
queries, and other objects that use the data. After a database is split, multiple users in a networked 
environment can access the database at the same time. As a result, each user can access, design, and 
modify their own database objects and update data from the database tables without interrupting 
other users or increasing the number of objects contained in the central database.

Split Database Terminology
Two terms are often associated with split databases:

 Ý Front end refers to the up-front portion of a split database with which users interact—the queries, 
forms, and reports they use or may create and customize. Access places a blue arrow beside each 
table name in a split database to identify objects users can view but not change.

 Ý Back end refers to the underlying database tables that support the front end. These tables are 
protected so users cannot modify their structure. Access adds _be to the end of the back-end 
portion of the database filename.
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This temporary 
file indicates 

record locking.

Blue arrows 
identify tables 

with objects 
users cannot 

change.

The filename of 
the split database’s 
back end includes _be.

When you split a database, Access links the front and back ends of the database so users can work 
with controls on forms, queries, and reports.

Backing Up a Database Prior to Splitting
Access recommends you back up a database before you split it to preserve the database in case an 
error occurs during the splitting process. One quick way to do this is to select and copy the database 
in Windows Explorer and then paste a backup copy in the desired folder.

ÝÍ Database Tools→Move Data→Access Database→Split Database

DEVELOP YOUR SKILLS: A9-D5

In this exercise, you will split the Winchester Web Design database.

 1.  Open A9-D1-WinDesignRev from your Access Chapter 9 folder.

Do not open any database objects.

 2.  Choose File→Save As→Save Database As→Save As.

 3.  Navigate to your Access Chapter 9 folder; then change the filename to  
A9-D6-WinDesign-Backup and click Save.

You back up the database so you have a copy in case errors occur when the database is split.

 4.  Close the new backup database and then reopen A9-D1-WinDesignRev but don’t open any objects.

 5.  Choose Database Tools→Move Data→Access Database .

 6.  Review the information in the Database Splitter dialog box and then click Split Database.

Access opens the Create Back-End Database dialog box and displays the same filename with _be at 
the end to identify it as the back-end file.
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 7.  Navigate to your Access Chapter 9 folder and click Split.

 8.  Click OK in the message box.

All the table names now have a blue arrow in front of them.

 9.  Right-click the Customers table in the Navigation pane and choose Design View.

Access warns you that Customers is a linked table that can’t be modified; it’s linked to the back-end 
database. You can open the table in Design View, but you can’t modify the structure or data types. To 
add, change, and delete records, you’d open the table in Datasheet View. Any changes to data in the 
front-end database are reflected in the table in the back-end database.

 10.  Read the warning message and then click No.

 11.  Right-click the Customers Form in the Navigation pane and choose Design View.

The front-end form displays in Design View.

 12.  Select the Notes label and Notes text box and tap [Delete].

 13.  Save the form and close A9-D1-WinDesignRev.

 14.  Choose File→Open and navigate to your Access Chapter 9 folder; rename A9-D1-WinDesignRev 
to A9-D6-WinDesign-Split and then open A9-D1-WinDesignRev_be.

The Winchester Web Design tables are the only objects in the back-end database.

 15.  Close the back-end database.

Customizing the Database Interface
Access offers multiple options for customizing the user interface. Switchboards and navigation forms 
can be set to automatically open when a database is opened. They provide buttons and tabs to 
perform an array of functions from displaying forms and reports to printing, saving, and even closing 
the database and exiting Access.

Database Switchboards
A switchboard is an easy-to-use interface with menus and buttons for opening database objects and 
performing common tasks such as adding records and printing reports. 

Underlying Switchboard Items table

A sample switchboard form
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The Switchboard Manager
Switchboards were common in older versions of Access. To create a switchboard, the Switchboard 
Manager command button must be on the Ribbon, which you can do via the Customize Ribbon 
group in Access Options. The Switchboard Manager button might be on the Database Tools tab if 
you open a database created in a previous version of Access or one that already contains a database 
switchboard.

Navigation Forms
An alternative to the switchboard is a navigation form, a special interface that allows you to quickly 
access forms and reports in your database. Microsoft introduced navigation forms to accommodate 
online databases published to the web because the Access Navigation pane will not display in a 
browser.

Navigation Form Features
A navigation form usually has tabs across the top to group common elements with subnavigation 
links along the left side or directly below. The navigation form opens like a regular form in the Access 
window.

Tabs can group forms and reports by subject.

Individual objects can be accessed via controls listed on the side of an active tab.

When you create a tab that matches the name of a form or report in the database, Access automatically 
assigns the form or report to the tab in the navigation form.

Navigation Form Layouts
The Winchester Web Design database includes the Employees Form, the EmployeeSpouses Form, 
and the Employee Report that you can place on the same Employees tab on a navigation form. You 
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can also add other forms and reports. Access offers six different navigation form layouts from which 
you can choose. You can also change the fonts, colors, and themes.

DEVELOP YOUR SKILLS: A9-D6

In this exercise, you will create a navigation form with tabs for the categories in the Winchester Web 
Design database. Then you will add subnavigation links for forms and reports within each tab’s category.

 1.  Choose File→Open and navigate to your Access Chapter 9 folder; rename  
A9-D6-WinDesign-Backup as A9-D7-WinDesignRev and then open that file.

 2.  Follow these steps to create a new navigation form:

C

A

B

A Click the Create tab.

B Choose Forms→Navigation.

C Choose Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View, which is the recommended view for editing.
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 3.  Follow these steps to review the new navigation form:

A

B D

C

A Notice the form icon and title in the Form Header section.

B Click to select the Vertical Navigation control.

C Click to select the Horizontal Navigation control.

D Click to select the Navigation Subform.

 4.  Double-click the Add New tab in the 
Horizontal Navigation control and then 
type Employees and tap [Enter] to 
display another Add New tab.

You can point to the right border of a tab 
until the mouse appears as a two-headed 
pointer and drag the border to the left or 
right until the tab title is best displayed.

 5.  Create additional tabs for: Customers, Invoices, and Products

Add Items to Tabs
 6.  Follow these steps to add an item to a tab:

A

C

B

A Click the Employees tab.

B Drag the Employees Form into the Vertical Navigation control.

C When the pink bar appears just above the Add New tab, drop the form.
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 7.  Drag the forms and reports to the tab indicated:

Tab Form or Report

Employees EmployeeSpouses Form

Employees Employee Report

Customers Customers Form

Customers Customer Invoice Report

Invoices Invoice Form

Invoices Invoice Details Report

Products Product Form

Products Products Report

 8.  Save the form as WWD Navigation Form and then switch to Design View.

Add a Title and Logo and Apply Formatting
 9.  Delete the Title and Logo controls in the Form Header section.

 10.  Choose Form Design Tools→Design→Controls→Label and draw a label in the Form Header 
section.

 11.  Type Welcome to Winchester Web Design as the label, tap [Enter], and then set these 
properties on the Property Sheet:

Property Value

Width 5.5

Height 0.45

Top 0.1875

Left 1.5

Font Name Georgia

Font Size 22

Text Align Center

Font Weight Semi-bold

Fore Color Blue, Accent 1, Darker 50%

 12.  Click the Form Header section bar; type 0.8 for the Height property and choose Blue, Accent 
1, Lighter 80% for the Back Color property.

 13.  Choose Form Design Tools→Design→Controls→Insert Image , navigate to your Access 
Chapter 9 folder, and choose WWD-Logo.

If the WWD-Logo is displayed in the Image Gallery, you can just click it.

 14.  Draw the new logo image in the Form Header section to the left of the title.

 15.  In the Property Sheet, make these settings:

Setting Value

Width 0.7

Height 0.7

Top 0.05

Left 0.5
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 16.  Click the Detail section bar and type Accent 1, Lighter 90% for the Back Color and 
Alternate Back Color properties.

 17.  Click the left column of the navigation form (NavigationControl5) in the Selection Type list and 
choose Transparent for the Back Style property.

 18.  Select the top navigation control row (NavigationControl0) and choose Transparent for the 
Back Style property.

 19.  Switch to Form View and click the Employees tab.

The form includes three objects listed for the Employees tab and the selected object displayed in the 
Navigation Subform.

 20.  Save the WWD Navigation Form.

Adding Custom Command Buttons
Now that you have a navigation form that opens each of the forms and reports in the database, you 
can use Design View to add command buttons that will perform functions. Then you can size and 
position the buttons and add the text that will be displayed on each button.

A button is added to the form to exit Access when work is completed.

When you use the Command Button control from the Ribbon to create an action command button 
on a form, the Command Button Wizard opens and walks you through the process. Placing command 
buttons in the Detail section will replicate the button for each entry in the form.

ÝÍ Form Design Tools→Design→Controls→Button

DEVELOP YOUR SKILLS: A9-D7

In this exercise, you will create a command button on the WWD Navigation Form. You will then add text 
and attach a command to the button.

 1.  Display the WWD Navigation Form in Design View.

 2.  Expand the Form Footer section by dragging the bottom of the form down.

 3.  Click the Form Footer section bar and type  Accent 1, Lighter 90% for the Back Color of 
the Form Footer section.
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 4.  Choose Form Design Tools→Design→Controls→Button   and draw a button in the main 
Form Footer section.

Access launches the Command Button Wizard after you draw the command button.

 5.  Follow these steps to complete the first button:

A

C

B

A Choose Application.

B Choose Quit Application.

C Click Next.
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 6.  Follow these steps to complete the button:

A B

C

A Choose the Text option.

B Type Exit Access as the text to appear on the button.

C Click Finish.

 7.  Save changes to the form and then switch to Form View.

 8.  Click the Exit Access command button on the form.

The database and Access close.
 

Setting Startup Options to Open a Form
Switchboards and navigation forms provide an interface between the user and the forms, queries, 
and reports contained in the database. In many cases, data entry personnel have no need to create 
objects or see the Navigation pane.

As a result, many businesses set startup options that display either the most commonly used form, 
such as the Invoice Form, or the database interface so it is the first thing users see when they open the 
database. Setting these startup options is also a way to protect the database from unauthorized access.

Overriding Startup Options
After you set startup options for a database, the Navigation pane and many of the underlying objects 
and database tools may be hidden. To override the startup settings, press and hold the [Shift] key as 
you open the database in Access.

ÝÍ File→Options→Current Database
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DEVELOP YOUR SKILLS: A9-D8

In this exercise, you will set the WWD Navigation Form to open automatically each time you open the 
database.

 1.  Open A9-D7-WinDesignRev from your Access Chapter 9 folder.

 2.  Choose File→Options→Current Database and follow these steps to apply startup options:

B
C

A

A Click the Display Form list button and choose WWD Navigation Form.

B Uncheck the box to Display Navigation Pane located in the Navigation section.

C Click OK.

 3.  Click OK to acknowledge the message box.

 4.  Close the database and open it again.

Access opens the database with the navigation form hidden and the WWD Navigation Form 
displayed.

 5.  Click the Exit Access command button.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).EVALU
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A9-R1

Set Options and Properties
You have been promoted to lead designer and are now responsible for all security aspects of the Kids for 
Change database. In this exercise, you will personalize Access, modify navigation options, and display 
multiple objects in an overlapping format.

 1.  Start Access, open A9-R1-K4C from your Access Chapter 9 folder, and save it as: 
A9-R1-K4CRev

Don’t forget to enable content.

 2.  Choose File→Options. In the General category, modify the username and/or initials as you feel 
necessary.

 3.  Choose Current Database, scroll to the Navigation section, and click the Navigation 
Options… button.

 4.  Click Add Item.

A new item appears in the Categories list named Custom Category 1. 

 5.  Type Kids for Change in the Custom Category 1 box and tap [Enter].

 6.  Click Add Group and type Activities for the new item that appears in the Groups List.

 7.  Add two more groups, using Children as the first name and Volunteers as the second.

 8.  Click OK twice.

 9.  Click the Navigation Pane Options button and choose Kids for Change.

Access places all objects for the Kids for Change category into the Unassigned Objects group. 

 10.  In the Unassigned Objects group on the Navigation pane, right-click the Activities table object 
and choose Add to Group→Activities.
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 11.  Right-click the Activities List query and add it to the Activities group and then add the 
Activities Form and Activity Costs Report.

 12.  Assign the Children table, Children List, Children Form, and Children Report to the Children 
group.

 13.  Assign the Volunteers table, Volunteers Subform, Volunteers Form, and Volunteers Report 
to the Volunteers group.

 14.  Click the Navigation Pane Options menu button � and choose Object Type.

The Navigation pane groups objects by type (Tables, Queries, Forms, and Reports).

Set Database Properties
 15.  Open the Access Options dialog box and choose Current Database.

 16.  Click the Application Title text box and type: Kids for Change

 17.  Choose the Overlapping Windows option and click OK.

You must close and then reopen the database for the settings to take effect.

 18.  Choose OK in the message dialog box; then close and reopen the database.

 19.  Open the Activities and Children tables to display the objects in separate overlapping windows.

You can move and resize the open objects so you can see both at the same time.

 20.  Close the database.

REINFORCE YOUR SKILLS: A9-R2

Create a Navigation Form and Set Startup Options
Kids for Change has asked you to provide a more efficient way for its data entry personnel to access forms 
and reports. In this exercise, you will create a navigation form that displays when the Kids for Change 
database is opened. 

 1.  Open A9-R2-K4C from your Access Chapter 9 folder and save it as: A9-R2-K4CRev

 2.  Choose Create→Forms→Navigation→Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View.

 3.  Double-click the Add New tab in the 
horizontal navigation control; type 
Activities as the tab name and tap 
[Enter].

 4.  Create four more tabs:

• Children

• Donors

• PaidStaff

• VolunteersEVALU
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 5.  Click the Activities tab and then drag the Activities form from the Navigation pane into the 
vertical navigation link area, placing it above the Add New tab.

 When the pink bar appears just above the Add New tab, drop the form.

 6.  Add the forms and reports to the tab indicated:

Tab Form or Report Tab Form or Report

Activities • Activity Costs Report PaidStaff • Staff Form

• Activity Staffing

• Activity Costs Report

Children • Children Form

• Children Report

Volunteers • Volunteers Form

• Volunteers Report

Donors • Donors Form

• Donations Report

• Monthly Donations Report

 7.  Save the form as K4C Navigation Form and then switch to Design View.

 8.  Delete all the controls in the Form Header section.

 9.  Choose Form Design Tools→Design→Controls→Label, draw a title label named  
Kids for Change in the Form Header section, and tap [Enter].

 10.  Enter these properties for the new title label:

Property Value

Width 4

Height 0.4

Top 0.2

Left 2

Font Name Cambria

Font Size 23

Text Align Center

Fore Color Blue, Accent 1, Darker 50%

 11.  Click the Form Header section bar; type 0.8 for the Height property and choose Dark Blue, 
Text 2, Lighter 80% for the Back Color property.

Tip!
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 12.  Choose Form Design Tools→Design→Controls→Insert Image , navigate to the Access 
Chapter 9 folder, and choose K4C-logo.bmp.

If the K4C-Logo is in the Image Gallery, you can click it there.

 13.  Draw the logo image in the Form Header section to the left of the title.

 14.  With the K4C-Logo selected, type 0.7 for the Width and Height properties, 0.05 for the Top 
property, and 0.5 for the Left property.

 15.  Switch to Form View and click each tab to verify that the objects display in the navigation 
subform; save your changes to the form.

Add a Command Button
 16.  Switch to Design View and expand the Form Footer section downward.

 17.  Choose Form Design Tools→Design→Controls→Button  and draw a button in the Form 
Footer section.

 18.  Choose Application and Quit Application, and then click Next.

 19.  Choose the Text option; type Exit Access and click Next.

 20.  Name the command button cmdExitAccess and click Finish.

 21.  Save your changes to the form.

Set Access Startup Options
 22.  Choose File→Options→Current Database.

 23.  Type Kids for Change for the application title.

 24.  Click the Display Form menu button � and choose K4C Navigation Form.

 25.  Click OK twice and then close and reopen the database.

The K4C Navigation Form opens when the database is opened and includes Kids for Change in the 
title bar and the Exit Access command button in the Form Footer.

 26.  Click the Exit Access command button to close the database and exit Access.

REINFORCE YOUR SKILLS: A9-R3

Split a Database and Hide the Navigation Pane
Kids for Change would like its table data to be protected. In this exercise, you will split the database and 
hide the Navigation pane to protect the table data from unauthorized users.

 1.  Open A9-R3-K4C from your Access Chapter 9 folder and save it as: A9-R3-K4C-Backup

 2.  Close the new backup database and reopen A9-R3-K4C, but don’t open any objects.

 3.  Choose Database Tools→Move Data→Access Database .
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 4.  Click the Split Database button and then navigate to your Access Chapter 9 folder and click 
Split.

 5.  Click OK in the message box.

Table names now have a blue arrow in front of them.

 6.  Right-click the Activities table in the Navigation pane and choose Design View.

Access informs you that Activities can’t be modified because it is linked to the back-end database. 

 7.  Click No in the message box.

 8.  Right-click the Volunteers Form in the Navigation pane and choose Design View.

 9.  Select the Available Day label and the ActID text box at the bottom of the Detail section and 
tap [Delete].

 10.  Save the form and then save the database as: A9-R3-K4CRev

Hide the Navigation Pane
 11.  Choose File→Options→Current Database.

 12.  In the Navigation section, uncheck the box next to Display Navigation Pane and then click OK.

 13.  Close and then reopen the database.

Access opens the database but does not display the Navigation pane.

 14.  Close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A9-A1

Set Options and Properties
As head of technology for Universal Corporate Events you have been tasked with fine-tuning the 
company’s database. In this exercise, you will personalize Windows settings, modify the object navigation 
options, and alter the way open objects appear on the screen.

 1.  Start Access, open A9-A1-UCE from your Access Chapter 9 folder, and save it as: 
A9-A1-UCERev

 2.  Choose File→Options. In the General category, modify the personal settings as you feel 
necessary.

 3.  Choose Current Database and open the Navigation Options dialog box.

 4.  Create a new item named: Universal Corporate Events

 5.  Create a new group named: Events

 6.  Add two more groups: Menus and Venues

 7.  Close the Navigation Options dialog box and the Access Options dialog box.

 8.  Click the Navigation Pane Options button and choose Universal Corporate Events.

Access places all objects for Universal Corporate Events into the Unassigned Objects group. 

 9.  In the Unassigned Objects group, right-click the Events table object and choose Add to 
Group→Events.

 10.  Assign these objects to their appropriate groups:

Group Object Group Object

Events • Event Revenue

• Event Pricing Entry

• Event Schedules

• EventCosts Subform

• Events Form

Venues • VenueLiaisons table

• Venues table

• Venue Events

• Venue Events Subform

• Venues Form

• Venues Report

Menus • Menus table

• Menus Form

• Event Menus Report

 11.  Click the Navigation Pane Options button and choose Object Type.

Set Database Properties
 12.  Open the Access Options dialog box and choose Current Database, if necessary.

 13.  Click the Application Title text box and type: Universal Corporate Events

 14.  Choose the Overlapping Windows option and click OK.

 15.  Choose OK in the message dialog box; then close and reopen the database. 
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 16.  Open the Personnel and Venues tables in separate overlapping windows.

You can move and resize the open objects so you can see both at the same time.

 17.  Choose File→Options→Current Database and reset the Document Window option to 
Tabbed Documents.

 18.  Close the database.

APPLY YOUR SKILLS: A9-A2

Create a Navigation Form and Set Startup Options
The president of Universal Corporate Events wants a custom navigation form. In this exercise, you will 
create a navigation form with links that open associated forms and reports as well as a command button 
that closes the database and exits Access. You will also modify the startup options.

 1.  Open A9-A2-UCE from your Access Chapter 9 folder and save it as: A9-A2-UCERev

 2.  Choose Create→Forms→Navigation→Horizontal Tabs and Vertical Tabs, Left.

The new navigation form opens in Layout View.

 3.  Double-click the Add New tab in the horizontal navigation control and then type Events and 
tap [Enter].

 4.  Create two more tabs, naming the first Menus and the second Venues.

 5.  Click the Events tab and then drag the Event Costs form from the Navigation pane into the 
vertical navigation link area.

 6.  Add these forms and reports to the tab indicated:

Tab Form or Report Tab Form or Report

Events • Events Form

• Event Pricing Entry

• Event Schedules

• Event Revenue 
Report

Venues • Venues Form

• Venue Events Form

• Venues Report

Menus • Menus Form

• Event Menus Report

 7.  Save the form as: UCE Navigation Form

 8.  Switch to Design View and delete all controls in the Form Header section.

 9.  Display the Personnel Form in Design View.
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 10.  Copy the logo and title from the Personnel Form and paste them into the Form Header of the 
UCE Navigation Form. Then close the Personnel Form.

 11.  Click the Form Header section bar; on the Property Sheet, enter 0.8 for the Height property 
and choose Blue, Accent 5, Lighter 80% for the Back Color property.

 12.  Select the pasted title control and replace Personnel Form with: Navigation Form

 13.  Type 2 for the Left property.

 14.  Select the logo and type 0.5 for the Left property.

 15.  Switch to Form View and verify that each object displays in the navigation subform.

 16.  Save your changes to the form.

Add a Command Button
 17.  Switch to Design View.

 18.  Expand the Form Footer section of the main form by dragging the bottom of the form down.

 19.  In the main Form Footer section, create a command button with the text Exit Access that 
will close the application.

Hint: Choose the Application category with the Quit Application action.

 20.  Name the command button: cmdExitAccess

 21.  Save the form. Switch to Form View and click the new command button to close the database 
and Access.

APPLY YOUR SKILLS: A9-A3

Display the Navigation Form on Startup and Split the Database
The president of Universal Corporate Events wants the navigation form to be displayed on startup. She 
also wants to protect the table data from unauthorized use. In this exercise, you will set the newly created 
navigation form to display each time someone opens the database. You will then split the database.

 1.  Open A9-A3-UCE from your Access Chapter 9 folder and save it as: A9-A3-UCERev

 2.  Choose File→Options→Current Database.

 3.  Type Universal Corporate Events for the application title.

 4.  Click the Display Form list button and choose UCE Navigation Form.

 5.  Click OK twice.

 6.  Close and then reopen the database.

Access opens the database and displays the UCE Navigation Form.

The UCE Navigation Form automatically opens in Form View when the database is opened. The form 
includes Universal Corporate Events in the title bar and the Exit Access command button in the Form 
Footer.
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Split a Database
 7.  Close any open database objects and then choose File→Save As→Save Database As→Save As.

 8.  Navigate to your Access Chapter 9 folder, change the filename to A9-A3-UCERev-Backup 
and click Save to create a backup copy, and then close the database.

 9.  Open A9-A3-UCERev, choose Database Tools→Move Data→Access Database, and click 
Split Database.

 10.  Navigate to your Access Chapter 9 folder and click Split; click OK in the message box.

All the table names now have a blue arrow in front of them.

 11.  Right-click the Personnel table in the Navigation pane and choose Design View.

Personnel is linked to the back-end database and can’t be modified.

 12.  Click No in the message dialog box.

 13.  Right-click the Personnel Form in the Navigation pane and choose Design View.

 14.  Delete the word Grade from the Salary Grade label.

 15.  Close the Personnel Form, saving the changes.

 16.  Navigate to your Access Chapter 9 folder and open A9-A3-UCERev_be.

Tables are the only objects in the back-end database.

 17.  Close the database.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A9-E1 That’s the Way I See It
You would like to create a navigation form in the Blue Jean Landscaping database. Open A9-E1-BJL 
and save it as: A9-E1-BJLRev

Use these guidelines to create horizontal tabs and a vertical left navigation form: 

 Ý Create five tabs: Customers, Equipment, Manufacturers, Merchandise, and Sales

 Ý Add all related forms and reports to the corresponding tabs.

 Ý Add a title control with the name BlueJean Landscaping Navigation Form and then 
add a logo using BLJ-Logo.bmp.

 Ý Add a command button labeled Exit Database that exits the application.

 Ý Name the form: BlueJean Landscaping Navigation Form

Enhance the appearance of the forms and add any features you feel will help facilitate effective data 
entry.

A9-E2 Be Your Own Boss
As the owner of Blue Jean Landscaping, you would like to set startup options and apply database 
properties to help streamline user performance and security in the company database. Open 
A9-E2-BJL and save it as: A9-E2-BJLRev

Set an application title using the company name. Display the Blue Jean Landscaping Navigation 
Form on startup and apply overlapping windows. Then, hide the Navigation pane. Apply any other 
Access options you feel will help facilitate effective data entry or security.

A9-E3 Demonstrate Proficiency
Stormy BBQ is concerned about lower-level staff accessing database tables and inadvertently 
introducing errors and would like the database split to ensure data accuracy. It would also like to set 
navigation options. Open A9-E3-SBQ and save it as: A9-E3-SBQRev

Create a new navigation item labeled with the company name. Add the indicated 
groups. Add as many related objects as you can to the corresponding group and then 
split the database. Finally, apply any other Access options you feel will help facilitate 
effective data entry.
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L E A R N I N G  O B J E C T I V E S

ÝÝ Convert Access 2019 files to previous Access 
formats

ÝÝ Host Access files in SharePoint

ÝÝ Attach files to database records

ÝÝ Integrate Access data with Word and Excel

ÝÝ Display Access data on the web

10 Importing and 
Exporting Data Using 
Word, Excel, and HTML

ACCESS

D
ata can be stored on all types 

of computer systems and in 

many formats. Maintaining files 

and other data so they’re easy to share 

with others can be challenging; fortunately, 

Access tools make it relatively easy to 

import, export, format, and upload files 

for sharing. In this chapter, you will share 

Access data with other Microsoft Office 

programs, as well format data for other 

systems and the web.
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Ý Project: Capturing More Data
The Winchester Web Design database stores all data related to customers, employees, 
products, and invoices. Having all the data stored in one electronic file makes it very 
convenient for sharing it within the company. Sometimes, however, data must be exported so 
it can be used offsite by someone who may not have Access on their computer. You have been 
assigned the task to experiment with file formats to make both non-sensitive and sensitive 
data available to others.

Converting Access 2019 Databases to Earlier 
Formats

Access 2019 databases carry a unique format that is incompatible with versions of Access older than 
2007. The obvious difference is the filename extension. Versions of Access prior to 2007 created files 
with an .mdb extension. Access 2007–2019 versions create files with an .accdb extension (for Access 
database). To share a database made in a more current version of Access with someone who has an 
Access version prior to 2007, you must save the database in a format that the older version recognizes.

When you try to convert some newer databases to an earlier version of Access, you may get an error 
message.

Older versions of Access do not support some of the features and formats supported in more current 
versions, such as the Long Text data type that has replaced the Memo field, the Attachment data 
type that has replaced the OLE object field, and the Custom Web App and Web App Action Bar.

Identifying the Format of an Access Database
When you open a database, Access identifies the version of the file in the title bar.

When you open a database created in Access 2007–2019, the title 
bar will reference the Access 2007–2016 file format.

When you open a file created in an older version of Access, the title 
bar will reference the Access 2002–2003 file format.

ÝÍ File→Save As→Save Database As→Access 2002–2003 Database
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DEVELOP YOUR SKILLS: A10-D1

In this exercise, you will save an Access 2019 database in the Access 2003 file format.

 1.  Open A10-D1-WinDesign from your Access Chapter 10 folder and save it as: 
A10-D1-WinDesign2019

Remember to enable content, if necessary.

 2.  Choose File→Save As→Save Database As→Access 2002–2003 Database and then click 
Save As.

The Save As dialog box opens.

 3.  Change the filename to A10-D1-WinDesign2003 and click OK.

The filename and file format information display in the title bar, indicating that the database is now 
in Access 2002–2003 file format. The filename and path might be too long to show the file format, 
however. If you click the File tab, more of the path is visible.

 4.  Close all open databases.

Attaching Files to Database Records
Older versions of Access used fields with the OLE Object data type to add images to records. For 
example, a company might want to include employee photos in their employee table. However, adding 
a single uncropped, high-resolution image taken from one of today’s smartphones or adding long and 
wordy comments to records with long text fields can significantly increase the size of the database.

A database’s size affects its speed and efficiency. Attaching files—rather than embedding the data—
can significantly reduce the size of the database.

Using the Attachment Data Type
The Attachment data type allows you to attach one or more pictures, spreadsheet files, documents, 
charts, and other file types to a specific field in the table. You can use an Attachment field to store 
multiple files of varying file types without increasing the size of the actual database file.

Attachment Limitations and Notes
• After assigning the Attachment data type to a field, you cannot change it.

• A maximum of 2 gigabytes of data can be attached to a database.

• The file size for individual attachments is limited to 256 megabytes.

• You cannot attach files to a record in Access 2003 or earlier.

Managing Attachments
Access identifies fields that contain attachments 
with a paperclip icon in the field name. A paperclip 
icon followed by a number indicates the number of 
attachments for each individual record. For instance, 
you might have a products database where you have 
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one photo of the product front and another of the product back. Or perhaps you want to store both a 
casual and a publicity dress photo for your employees.

Adding an attachment is as simple as double-clicking the paperclip icon for the record to which you 
want to attach the file. Then you navigate to the image or file you want to attach.

DEVELOP YOUR SKILLS: A10-D2

In this exercise, you will add an Attachment field to the Winchester Web Design Employees table in Design 
View and attach two photos to a table record.

 1.  Open A10-D2-WinDesign from your Access Chapter 10 folder and save it as: 
A10-D2-WinDesignRev

 2.  Display the Employees table in Design View.

 3.  Follow these steps to add a new field to the table:

A B C

A Type EmpPhoto in the first available row in the Field Name column.

B Choose Attachment from the Data Type list.

C Type Office ID Photo in the Description column.

 4.  Save the changes to the table and then switch to Datasheet View.

 5.  Follow these steps to add an attachment to the first table record:

A

B

A Scroll to the new attachment field and double-click the paperclip icon for the first record.

B Click Add.
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 6.  Navigate to your Access Chapter 10 folder, double-click JayWinchester.jpg, and click OK.

Access places the number 1 in parentheses following the attachment icon for the first record.

 7.  Double-click the paperclip icon for record 1 to open the Attachments dialog box.

 8.  Click Add and then double-click JayAndJulie.jpg; click OK to close the Attachments  
dialog box.

Now a 2 follows the paperclip icon for the first record.

 9.  Double-click the paperclip icon again, select JayWinchester.jpg, and click Open.

The photo displays in your default program used to view images.

 10.  Switch to Access and close the Attachments box; save and close the Employees table.

Integrating Access with Word
There are several ways to share data between Access and Word—the easiest being to use Copy and 
Paste. For instance, you can select all or part of an Access table or query, copy it, and then open a 
Word document and paste the copied Access selection as an unlinked object.

A variation of this is to select the desired rows or columns in an Access table or query and export 
the data as a linked source to a Word document. A linked file allows source data to be placed into 
a destination file that is automatically updated when changes are made to the source file, so if you 
were to link an Access table to a Word document on Monday and then change the Access data on 
Tuesday, those changes would be reflected in the Word document the next time the Word file is 
opened (as long as the Access file hasn’t been deleted or moved).

Another process is Mail Merge, which allows you to merge selected data fields (such as names and 
addresses) with a Word document, producing personalized letters that can be mailed to thousands of 
potential customers. You can also publish Access data into a Word document for inclusion in a report.

There are additional Export tools on 
the External Data tab of the Ribbon 
that let you connect to other Micro-
soft Office applications using various 
file formats. One is a text file, or a 
plain alphanumeric text file without 
any formatting or font information. A variation of a text file is a rich text file (RTF), which contains 
minimal formatting, such as color or bold. Both text files and rich text files are very small in size, 
relative to normal Word documents, and are compatible across virtually all hardware and software 
platforms.

Copying Data from Access to Word
You can use copy-and-paste and drag-and-drop techniques to copy Access data into a Word  
document. Note that pasted data is not linked, so editing data that has been inserted into Word  
has no effect on the data stored in Access and vice versa.
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DEVELOP YOUR SKILLS: A10-D3

In this exercise, you will copy data from an Access table into a new Word document using copy-and-paste 
and drag-and-drop techniques.

 1.  Display the Products table in Datasheet View.

 2.  Follow these steps to make a copy of all the records in the Products table:

A

B

A Click the table selector button to select all product records.

B Choose Home→Clipboard→Copy.

 3.  Start Word, choose Open Other Documents, navigate to your Access Chapter 10 folder, and 
double-click A10-D3-WWD-ProdLetter.docx.

The document, a letter to the company’s customers, opens in Microsoft Word.

 4.  Position the insertion point under the line that reads …and consider adding one of these product 
features to your current website.

EVALU
ATIO

N O
NLY

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com



Integrating Access with Word 303

 5.  Choose Home→Clipboard→Paste menu button �→Keep Source Formatting.

 6.  Close the Products table in Access.

 7.  Arrange your Word and Access windows side by side so you can view both programs 
simultaneously.

 8.  In Access, open the Employee Contact Info query.

 9.  Follow these steps to drag the Employee Contact Info query records into Word:

A

B

C

A Click the table selector button.

B Hover the mouse pointer over the left side of a field in the first column so it becomes a white 
arrow.

C Drag the records into the Word document and drop them where the insertion point is 
located.

The mouse pointer becomes a black circle with a line through it  as you drag records over the 
Access work area. When you cross onto the Word document, it becomes a white move arrow with a 
plus sign. When you copy and paste or drag data to a Word document, the name of the Access object 
(Employee Contact Info) is displayed as a title at the top of the object.

The drag-and-drop process can be challenging. You must precisely position the mouse pointer over the left 
side of a field in the first column. If you can’t get it to work, use Copy and Paste.

Note!
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 10.  Compare your Word document to this example.

If the report extends to a second page, delete any unnecessary blank lines.

 11.  Close the Employee Contact Info query.

 12.  Save the Word document as A10-D3-WWD-ProdLetterRev and then close it and exit Word. 
Maximize Access.

Publishing Data to Word
The most commonly used tools for integrating Access data with other applications appear in the Export 
group on the External Data tab, and other tools appear on the More list. These tools enable you to 
send data from a database object to Word and other applications. When you export a database object 
to Word, Access formats it in rich text format, launches Word, and opens the data in a new document. 
You can then edit and save the document in Word without affecting the data in the database.

You can use these same techniques to drag Access table data into Excel and PowerPoint.

ÝÍ External Data→Export→More→Word 

Tip!
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DEVELOP YOUR SKILLS: A10-D4

In this exercise, you will export a list of the Winchester Web Design employees to a Word document.

 1.  Open the Employees table in Datasheet View.

 2.  Choose the External Data→Export→More menu button �→Word .

The Export – RTF File dialog box opens.

 3.  Follow these steps to export the table to Word as a small, cross-platform rich text file:

B

C

A

A Click Browse, open your Access Chapter 10 folder, and save the file as: A10-D4-WWDEmp.rtf

B Click the Open the destination file after export… checkbox.

C Click OK.

Access exports the table and opens it in Word. When you export data to a Word document, there is 
no title added as there is when you copy data into Word.

 4.  Close the Export – RTF File dialog box and switch to Word.

 5.  Choose Layout→Page Setup→Margins and then choose Narrow to fit more of the data on 
the page.

 6.  Choose Layout→Page Setup→Orientation→Landscape.

 7.  Resize the columns to fit as much of the data on the page as possible.

 8.  Close the Word file, saving changes, if prompted.

 9.  Switch to Access and close the Employees table.

Merging Access Data with Word Documents
Access databases often contain valuable data that can be used in letters, mailings, and other  
documents. Retyping such data can be time-consuming and may result in inaccurate data entry.  
The Export tool is useful for merging data with Word.
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When merging data with Word, Access gives you two options:

 1.  Link to an existing Word document: This option creates a link to an existing document so 
Word can locate the database and pull the most up-to-date data into the merge document. The 
link between the Word document and the database includes a path used to locate the data each 
time you open the merge document. If the database file is moved to a different folder, Word will 
be unable to locate it and cannot complete the merge.

 2.  Create a new Word document: This option creates a new Word document and merges it 
with the data linked to an Access database table. The next time you open the Word document, 
Word automatically looks for the database containing the merge data.

ÝÍ External Data→Export→Word Merge 

DEVELOP YOUR SKILLS: A10-D5

In this exercise, you will export Access data containing customer addresses and link it to the Word 
customer letter.

 1.  Open the Customers table and choose External Data→Export→Word Merge .

The Microsoft Word Mail Merge Wizard opens.

 2.  Choose the Link Your Data to an Existing Microsoft Word Document option and click OK.

Access opens the Select Microsoft Word Document dialog box.

 3.  Navigate to your Access Chapter 10 folder and open A10-D3-WWD-ProdLetter.

Word opens your document along with the Mail Merge task pane.

 4.  Follow these steps in Word to add fields to the merge document:

A

C

B

A Click in the blank line between the phone number and the date.

B Choose Mailings→Write & Insert Fields→Insert Merge Field menu button �.

C Choose CustFirstName.
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 5.  Tap [Spacebar] to insert a space after «CustFirstName».

 6.  Choose Mailings→Write & Insert Fields→Insert Merge Field→CustLastName.

 7.  Tap [Enter] and choose CustStreetAddress from the Insert Merge Field list.

 8.  Tap [Enter] and choose CustCity from the Insert Merge Field list.

 9.  Type a comma, tap [Spacebar], and choose CustState from the Insert Merge Field list.

 10.  Tap [Spacebar] and choose CustZIP from the Insert Merge Field list.

If the field names were FirstName, LastName, City, etc., instead of CustFirstName, CustLastName, 
CustCity, you could click the Address Block icon to insert the address fields in one step.

 11.  Choose Mailings→Preview Results→Preview Results to verify the customer name and 
address display properly.

 12.  Save and close the Word document; exit Word.

 13.  Switch to Access and close the Customers table.

Integrating Access with Excel
Many people find using formulas in Excel more user-friendly and sophisticated than the calculated 
fields in Access. Luckily, you can send Access data to Excel to perform calculations. The process of 
sending data to other files or applications is called exporting data. The process of retrieving data 
from other files or applications is called importing data.
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Importing Data from Excel Files
When you import data from Excel, Access uses the Import Spreadsheet Wizard to guide you through 
the process. Imported data becomes part of the database file. Because the data is imported and not 
linked, any changes made to the Excel file after the import have no impact on the table data in Access. 

Tools on the External Data tab can be used to import and to export data.

The tool for importing from Excel 
is in the Import & Link group.

The tool for exporting to 
Excel is in the Export group.

ÝÍ External Data→Import & Link→New Data Source→From File→Excel .

DEVELOP YOUR SKILLS: A10-D6

In this exercise, you will import an Excel worksheet into your database.

 1.  Close all Access database objects and choose External Data→Import & Link→ 
New Data Source  to open the menu.

 2.  Choose From File→Excel .

Access launches the Get External Data – Excel Spreadsheet dialog box.

 3.  Choose the Import the Source Data into a New Table in the Current Database option,  
click Browse and navigate to your Access Chapter 10 folder, and double-click  
A10-D6-WebContacts.xlsx.

 4.  Click OK to launch the Import Spreadsheet Wizard.

 5.  Choose the Show Worksheets option and click Next.

 6.  Check the First Row Contains Column Headings box and click Next.

 7.  Click Next to import all worksheet fields to the new table, without changes.

 8.  Click Next to let Access create a primary key.

 9.  Type Web Contacts in the Import to Table Name box and click Finish.

 10.  Close the Get External Data window.
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View Imported Table Data
 11.  Open the new Web Contacts table.

The data imported is not linked to the Excel spreadsheet. If you update the data in Excel, it will not 
be updated in the Access file. Once this data is imported, there is no longer a connection between the 
two files.

 12.  Adjust column widths as needed and then save and close the Web Contacts table.

 13.  Close the WinWebDesign database.

 14.  Start Excel and open A10-D6-WebContacts.xlsx from your Access Chapter 10 folder.

 15.  Change the street address in cell C2 to: 888 Import Lane

 16.  Save and then close the A10-D6-WebContacts.xlsx file.

 17.  In Access, open A10-D2-WinWebDesignRev, close any open objects, and open the  
Web Contacts table.

Notice the address has not changed because the Excel worksheet was imported into Access but not 
linked to an Access table. 

 18.  Close the Web Contacts table.

Linking an Excel Worksheet to an Access Database
When you want the data in the Access database to reflect the 
most current data contained in an Excel spreadsheet, you can 
import and link the Excel spreadsheet to the Access data-
base table. When you link a spreadsheet to a database, any 
change to the spreadsheet data is reflected in Access when 
you open the linked table in Access. Access uses an Excel icon, 
with a small arrow to the left, to identify a table linked to a 
spreadsheet. 

No edits can be made to linked spreadsheets from within the 
Access table. You must open the source Excel spreadsheet to 
make changes to the data or structure.

DEVELOP YOUR SKILLS: A10-D7

In this exercise, instead of importing, you will link the WebContacts spreadsheet to the Winchester Web 
Design database.

 1.  Choose External Data→Import & Link→New Data Source→From File→Excel .

 2.  Choose the Link to the Data Source by Creating a Linked Table option, click Browse,  
navigate to your Access Chapter 10 folder, and open A10-D6-WebContacts.xlsx.

 3.  Click OK to launch the Link Spreadsheet Wizard.
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 4.  Click Next to accept Sheet1.

 5.  Check the First Row Contains Column Headings checkbox and click Next.

 6.  Type Web Contacts Linked in the Linked Table Name box and click Finish.

 7.  Click OK in the Link Spreadsheet Wizard message and locate the linked item, identified by the 
Excel icon and arrow in the Navigation pane Tables group.

 8.  Open the Web Contacts Linked table in Access and try to edit the data.

The object icon indicates that the table is linked. Access prevents data editing when the linked file is 
open in Access. 

 9.  Close the Web Contacts Linked table.

 10.  Switch to Excel and open A10-D6-WebContacts.xlsx.

 11.  Change the street address in cell C2 to: 222 Link Lane

 12.  Save and then close A10-D6-WebContacts.

 13.  Switch to Access and open the Web Contacts Linked table.

The street address for the first record is now 222 Link Lane because the table is linked to the updated 
Excel worksheet.

 14.  Close the Web Contacts Linked table.

Fixing Broken Links
When you link an Excel spreadsheet to an Access database, Access identifies the drive and folder in 
which the Excel file was located at the time you created the link. Access searches for the Excel file 
each time you open the database. If the original Excel file was moved and the path is no longer valid, 
Access is unable to connect to the linked file. 

As a result, Access contains a feature called the Linked Table Manager that aids in locating and redi-
recting the database to the correct file so you can view the data. A list of linked files along with the 
external location in which it is stored are displayed in the Linked Table Manager dialog box. Linked 
files can then be selected along with an option to tell Access you want to redirect the link to a new 
location where the file has been moved. 

ÝÍ External Data→Import & Link→Linked Table Manager 
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DEVELOP YOUR SKILLS: A10-D8

In this exercise, you will open the Linked Table Manager and update the linked table location.

 1.  Choose External Data→Import & Link→Linked Table Manager .

 2.  Follow these steps to review the information contained in the dialog box:

A

C
B

A Click the checkbox beside the linked filename and review the linked file identified.

B Check the Always Prompt for New Location checkbox.

C Click OK.

The Always Prompt for New Location option enables you to navigate to the folder containing the 
linked file if the file has been moved.

 3.  Locate the Excel file A10-D6-WebContacts.xlsx and click Open.

 4.  Click OK to acknowledge that the linked tables were successfully refreshed.

 5.  Click Close in the Linked Table Manager dialog box.

 6.  Close the A10-D2-WinDesignRev database.

Exporting Access Data to Excel
If you want to use the Excel calculations on Access data, you can export the data to create a new 
Excel file. Some fields, such as ZIP codes, which are defined as the Short Text data type, or a Yes/No 
data type, which displays values of True/False, may require additional formatting or manipulation in 
Excel. Overall, though, the steps are similar to those used to export Access data to merge with Word.

ÝÍ External Data→Export→Excel 
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DEVELOP YOUR SKILLS: A10-D9

In this exercise, you will export data from an older Winchester Web Design Invoices table to create a new 
Excel workbook.

 1.  Open A10-D9-Invoices from your Access Chapter 10 folder and save it as: 
A10-D9-InvoicesRev

 2.  Click the Invoices table in the Navigation pane to select it (but don’t open it).

 3.  Choose External Data→Export→Excel .

 4.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the first two available 
checkboxes under Specify Export Options.

 5.  Click Browse, navigate to your Access Chapter 10 folder, and save the file as:  
A10-D9-Invoices.xlsx

 6.  Click Save and then click OK in the Export – Excel Spreadsheet dialog box.

Excel opens the new workbook containing the invoice data. Resize columns as necessary.

 7.  Close the workbook, saving if prompted. Exit Excel and switch back to Access.

The Save Export Steps dialog box is displayed and indicates that Invoices was successfully exported.

 8.  Close the Export dialog box, without saving the export steps, and close the database. 

Displaying Access Data on the Web
In addition to sharing data from Access with other Microsoft Office applications, Access allows data 
to be stored on the web, either by hosting data on a SharePoint site, saving the database file directly 
to online storage, or exporting database objects in an HTML format universally available to anyone 
in the world. Additionally, there may be times when you want to add web page access to database 
objects.

Storing Data on Microsoft SharePoint
A database file can be hosted on Microsoft SharePoint. This allows any SharePoint user to access 
the data from a SharePoint list at any location with an Internet connection using a web browser. You 
can assign permission levels for each user, restricting or allowing them to complete specified actions 
such as only reading data, making changes to data, or having full control over the design. A database 
synchronized to a SharePoint site can be modified in Access offline and any changes will appear to 
the SharePoint site when reconnected.
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Alternately, you can save a database file directly to SharePoint, allowing users to access the database 
at any location with an Internet connection. Doing so requires an active SharePoint site with user 
authentication for accessing and editing the database file.

Exporting Access Objects as Web Pages
Hypertext Markup Language (HTML), the code or language in which web pages are written, allows 
files to be formatted and viewed in any web browser, anywhere in the world. Access allows you to 
save each database object separately as an HTML file and display that data online.

Updating HTML Data
When data in the database changes, HTML files do not automatically update. Consequently, many 
companies update their HTML files regularly and display a date and time to indicate when data was 
published. To create a web-based file for Access data, you use the External Data tab to export the 
object as an HTML file.

Saving HTML-Formatted Objects
When you export a database object as an HTML file, you can preserve the formatting and layout 
of what you have already designed in Access. When you click OK, Access displays the HTML Output 
Options dialog box, which enables you to choose the default or other encoding to apply to the file.

ÝÍ External Data→Export→More→HTML Document 

DEVELOP YOUR SKILLS: A10-D10

In this exercise, you will export a table in HTML format and view it in a web browser.

 1.  Open A10-D2-WinWebDesignRev and close any open objects.

 2.  Click the Products table in the Navigation pane to select it.

 3.  Choose External Data→Export→More→HTML Document .

The Export-HTML Document window appears.

 4.  Click Browse, navigate to your Access Chapter 10 folder, and click Save.

 5.  Check the first two checkboxes under Specify Export Options and click OK.

The HTML Output Options dialog box appears.
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 6.  Click OK to create the file with the default encoding.

Access creates the HTML file and opens it as a web page in your default web browser. You can now 
upload it to your website or to your network.

 7.  Close your web browser window.

 8.  Switch back to Access and close the dialog box.

Importing HTML Files
When data you want to use is in an HTML file, you can import that data to create a new table, 
append it to an existing table, or link the HTML file to the database. The steps for importing HTML 
data are similar to those used to import Excel and other types of data.

ÝÍ External Data→Import & Link→New Data Source→From File→HTML Document 

DEVELOP YOUR SKILLS: A10-D11

In this exercise, you will import a list of web resources contained in an HTML file into Access as a new table.

 1.  Close any open objects in the A10-D2-WinDesignRev database.

 2.  Choose External Data→Import & Link→New Data Source→From File→HTML Document .

 3.  Click Browse and navigate to the Access Chapter 10 folder.

 4.  Double-click A10-D11-WebResources.html and select the Import the Source Data into a 
New Table in the Current Database option.

 5.  Click OK to launch the Import HTML Wizard.

 6.  Check the First Row Contains Column Headings checkbox and click Next.

 7.  Click Next again, this time to keep the existing field names and data types and to import all 
fields into the table.

 8.  Choose the No Primary Key option and click Next.

Because the HTML document is just a short list of website addresses, there is no need to set a primary 
key to uniquely identify each site.

 9.  Type Resources for the Import to Table name and click Finish.
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 10.  Close the dialog box. Open the Resources table and resize the columns as necessary.

 11.  Review the data and then save and close the Resources table.

Adding Hyperlinks to Database Objects
Hyperlinks attached to database forms and reports are a convenient way to access other database 
objects, external files associated with the database, or websites. You can create a hyperlink to:

 Ý Open an external website.

 Ý Launch another application and open a specific file.

 Ý Add a new table field for a customer’s email address.

The Insert Hyperlink dialog box enables you to select an existing file or web page, an object in the 
active database, or an email address. Although the hyperlink text generally identifies the action of 
the hyperlink, you can also add a ScreenTip to display more descriptive text when the user points to 
the hyperlink. Typically, hyperlinks are underlined and formatted a light blue text color. When you 
point to a hyperlink, the mouse pointer appears as a pointing hand. Clicking (rather than double-
clicking) performs the action associated with the hyperlink.

Text to display for the link

Buttons to 
display the 

type of 
hyperlink

Button to set a 
descriptive ScreenTip

HTML file in the current folder

ÝÍ Form Design Tools→Design→Controls→Link 

DEVELOP YOUR SKILLS: A10-D12

In this exercise, you will add a hyperlink to Winchester’s About Us Page form.

 1.  Display the About Us Page form in Design View.
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 2.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link  to 
open the Insert Hyperlink dialog box.

 3.  Follow these steps to add a hyperlink to the company web address: 

A

C

B

D

A Choose Existing File or Web Page.

B Type Microsoft.com for the text to display.

C Type http://microsoft.com for the address.

D Click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 4.  Switch to Form View and click the hyperlink.

The Microsoft website opens in your web browser.

 5.  Close your browser window. Close all database objects, saving changes if necessary, and then 
exit Access.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A10-R1

Format Fields and Integrate with Word
As lead designer for Kids for Change, you are in charge of database maintenance. Kids for Change has 
asked you to store staff photos in the database and export data to a Word document. In this exercise, you 
will add an attachment field for staff photos, copy Access data to Word, and export a table to Word in 
rich text format.

 1.  Open A10-R1-K4C from the Access Chapter 10 folder and save it as A10-R1-K4C-Rev, 
choosing Yes when asked to close all open objects.

To begin, you will create an Attachment field.

 2.  Display the PaidStaff table in Design View.

 3.  Scroll down to the first empty row and complete the field using these guidelines: 

• Type StaffPhoto in the Field Name column.

• Choose Attachment from the Data Type list.

• Type Staff ID Photo in the Description column.

 4.  Save the PaidStaff table and switch to Datasheet View.

 5.  Double-click the paperclip icon for the first record (Matthew Bryant).

The Attachments dialog box opens.

 6.  Click Add, navigate to your Access Chapter 10 folder, and double-click MathewBryant.jpg.

Access adds the filename of the photo to the Attachments dialog box.

 7.  Click OK to close the Attachments dialog box and then close and save the PaidStaff table.

Copy Access Data to Word 
 8.  Display the K4CActivityList table in Datasheet View.

 9.  Click the table selector button and then choose Home→Clipboard→Copy .

 10.  Start Word and open A10-R1-K4C-Welcome.docx from your Access Chapter 10 folder.

 11.  Position the insertion point under the line Below are just a few of the activities we are offering this 
year and choose Home→Clipboard→Paste.

 12.  Save the Word document in your Access Chapter 10 folder as: A10-R1-K4C-WelcomeRev 

 13.  Switch back to Access and close K4CActivityList.

 14.  Position the Word and Access windows side by side and make sure the We hope that you... para-
graph is visible in the Word document.

 15.  Open the Welcome Staffers query in Access and click the table selector button to select all 
staffer records.
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 16.  Hover the pointer over the left side of the first column so it becomes a white arrow and then drag 
and drop the records below We hope that you... in the Word document.

 17.  Save and close the Word document.

Export Access Data to Word
 18.  Switch to Access and maximize the window.

 19.  Close the Welcome Staffers query and then click the Venues table to select it.

 20.  Choose External Data→Export→More→Word .

 21.  Click the Browse button, navigate to your Access Chapter 10 folder, and save the file as: 
A10-R1-K4C-Venues

 22.  Click the Open the Destination File After the Export Operation Is Complete checkbox and 
click OK.

 23.  Close the Word document, saving the changes if prompted, and then close the Export – RTF File 
dialog box in Access.

Merge Access Data into a Word Document
 24.  Open the Volunteers table and choose External Data→Export→Word Merge.

The Microsoft Word Mail Merge Wizard opens.

 25.  Choose Link Your Data to an Existing Microsoft Word Document and click OK.

 26.  Open A10-R1-K4C-WelcomeRev from your Access Chapter 10 folder; maximize the Word 
window.

 27.  Position the insertion point under the K4C logo and above Dear K4C Volunteer, and then choose 
Mailings→Write & Insert Fields→Insert Merge Field menu button �→VolFirstName.

Access inserts the table field between chevrons on the document.

 28.  Tap [Spacebar] and enter the VolLastName field.

 29.  On the next line, enter the VolStreet field.
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 30.  On the next line, enter the VolCity field, then the VolST field, and then the VolZIP field, taking 
care to include spaces between fields and a comma after the city.

 31.  Choose Mailings→Preview Results  to verify the customer name and address display properly.

 32.  Save and close the Word document and exit Word. Save and close the database.

REINFORCE YOUR SKILLS: A10-R2

Integrate Access with Excel
Kids for Change would like you to share some of the data in its database with Excel. In this exercise, you 
will add a table that is linked to an Excel spreadsheet and export a table to Excel.

 1.  Open A10-R2-K4C from your Access Chapter 10 folder and save it as: A10-R2-K4CRev

To begin, you will import unlinked Excel data into Access.

 2.  Choose External Data→Import & Link→New Data Source →From File→Excel.

Access launches the Get External Data – Excel Spreadsheet dialog box.

 3.  Choose Import the Source Data into a New Table in the Current Database, click Browse, 
and open A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder.

 4.  Click OK to launch the Import Spreadsheet Wizard and import the data using these guidelines:

• First Row Contains Column Headings.

• Import all worksheet fields to the new table, without changes.

• Let Access add the primary key.

• Type Venue Contacts for the Import to Table name.

 5.  Close the Get External Data window without saving the import steps.

 6.  Open the new Venue Contacts table and resize the columns as desired.

The table lists four fields and nineteen records. The data is not linked to the source table in Excel, so if 
you update the data in Excel, the Access file will not update.

 7.  Save and close the Venue Contacts table.

Link an Excel Spreadsheet to an Access Database
 8.  Choose External Data→Import & Link→New Data Source→From File→Excel .

 9.  Choose Link to the Data Source by Creating a Linked Table, click Browse and open  
A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder, and click OK.
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 10.  Check the First Row Contains Column Headings checkbox and click Next.

 11.  Type Venue Contacts Linked for the Linked Table name and click Finish; click OK in the 
message box.

The imported table has a different icon than the other tables in the Navigation pane. The icon has an 
arrow pointing toward the Excel icon instead of the Access table icon.

 12.  Open A10-R2-K4C-Contacts in Excel and change the contact for All Angels Church from Kevin 
Gregory to: Dina McMullen

 13.  Save and close Excel and then switch to Access and open the Venue Contacts Linked table.

The name is also changed in the table.

 14.  Close the Venue Contacts Linked table.

Use the Linked Table Manager
 15.  Choose External Data→Import & Link→Linked Table Manager .

 16.  Click the checkbox beside the linked filename and review the linked file identified.

 17.  Check the Always Prompt for New Location checkbox and click OK.

Access opens the Select New Location dialog box so you can navigate to the folder containing the 
linked file—in the event the file has been moved.

 18.  Open A10-R2-K4C-Contacts.xlsx from your Access Chapter 10 folder.

 19.  Click OK in the dialog box and then close the Linked Table Manager dialog box.

Export Access Data to Create a New Excel Workbook
 20.  Click Donations Query in the Navigation pane and then choose External Data→Export→ 

Excel .

 21.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the Export Data with 
Formatting and Layout and Open the Destination File After the Export Operation Is 
Complete checkboxes.

 22.  Save the export in your Access Chapter 10 folder as: A10-R2-K4C-Donations.xlsx 

 23.  Click OK in the dialog box. Close Excel and then close the Export – Excel Spreadsheet box.

REINFORCE YOUR SKILLS: A10-R3

Integrate Access with the Web
Kids for Change would like you to share some of the data in its database for display on the web. In this 
exercise, you will import an HTML file as a new database table, export a table to view on the web, and add 
a hyperlink from the Activities Form to the Activity Costs Report.

 1.  Open A10-R3-K4C from your Access Chapter 10 folder and save it as: A10-R3-K4CRev

You will begin by exporting an object in HTML format.

 2.  Close the navigation form and then select the Activities Query in the Navigation pane.

 3.  Choose External Data→Export→More→HTML Document .

 4.  Click Browse, navigate to your Access Chapter 10 folder, and save the file as:  
A10-R3-K4C-Activities.html

 5.  Check the Export Data with Formatting and Layout and Open the Destination File After 
the Export Operation Is Complete checkboxes.
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 6.  Click OK twice to create the file with the default encoding.

Access creates the HTML file and opens it as web page in your default web browser. You can now 
upload it to your website or to your network.

 7.  Close your web browser window; switch back to Access and close the Export – HTML Document 
dialog box.

Import an HTML File as a Database Object
 8.  Close any open objects and then choose External Data→Import & Link→New Data Source→ 

From File→HTML Document .

 9.  Click Browse and open A10-R3-K4C-Partners.html from your Access Chapter 10 folder; 
select Import the Source Data into a New Table in the Current Database and click OK.

 10.  Check the First Row Contains Column Headings checkbox and click Next.

 11.  Click Next to accept the default field names and data types, choose No Primary Key on the 
next screen, and click Next.

 12.  Type NonProfits for the Import to Table name and click Finish.

 13.  Close the Get External Data dialog box. Open the NonProfits table and size the columns so you 
can view the data.

 14.  Review the data and then save and close the NonProfits table.

Add a Hyperlink to a Form
 15.  Display the Activities Form in Design View.

 16.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link .

 17.  Choose Object in This Database, expand the Reports section, choose Activity Costs Report, 
and click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 18.  Drag the new hyperlink control to the right of the Telephone controls.

 19.  Save the changes to Activities Form, switch to Form View, and click the hyperlink.

The Activity Costs Report opens. 

 20.  Close Access, saving any changes.
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 Apply Your Skills
APPLY YOUR SKILLS: A10-A1

Change the Database Format, Create Attachments, and Integrate 
Access with Word
Universal Corporate Events needs your help adding employee photos and merging data with Word. In this 
exercise, you will add an attachment field to a table for employee photos. Then you will copy Access data 
into Word, export a table to Word, and merge Access data into a Word document.

 1.  Start Access, open A10-A1-UCE from your Access Chapter 10 folder, and save it as: 
A10-A1-UCERev

 2.  Open the Personnel table in Design View. Type PerPhoto in the first available Field Name 
record, choose the Attachment data type, and enter the description: Personnel ID Photo

 3.  Save the Personnel table and switch to Datasheet View.

 4.  Add the ReneeAllison.jpg photo from your Access Chapter 10 folder to the Renee Allison 
record.

 5.  Close the Attachments dialog box; save and close the Personnel table.

Copy and Export Access Data to Word 
 6.  Start Word and open A10-A1-UCE-Promotions.docx from your Access Chapter 10 folder.

 7.  Run the Event Organizers query in Access and then select all records in the query datasheet.

 8.  Position the Word and Access windows side by side and then drag and drop the Access query 
records into the Word document on the empty line below the paragraph that ends ...contact one 
of our Event Organizers first!

 9.  Close the Event Organizers query and then maximize the Word window.

The bottom portion of the letter includes the Event Organizers query. The name of the Access object is 
displayed as a title at the top of the object.

 10.  Save the Word document in your Access Chapter 10 folder as: 
A10-A1-UCE-PromotionsRevised

 11.  Select the Menus table and choose External Data→Export→More→Word.

 12.  Click Browse and save the file in your Access Chapter 10 folder as: A10-A1-Menus.rtf

 13.  Check the Open the Destination File After the Export Operation Is Complete checkbox 
and click OK.

 14.  Close the Word document; switch to Access, close the dialog box, and then maximize the Access 
window.

Merge Access Data into a Word Document
 15.  Open the BusinessOwners table in Datasheet View and choose External Data→Export→ 

Word Merge.

 16.  Link your data to the Word document A10-A1-UCE-PromotionsRevised in your Access 
Chapter 10 folder.
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 17.  Position the insertion point under the UCE URL and above the date and then create an address 
block as described:

• On the first line, choose First_Name from the merge fields list, tap [Spacebar), and choose 
Last_Name.

• On the second line, choose Address.

• On the third line, choose City, ST, and ZIP and add a comma and space between each field.

 18.  Choose Mailings→Preview Results→Preview Results.

 19.  Close the files in Word and Access, saving changes when prompted.

APPLY YOUR SKILLS: A10-A2

Integrate Access Data with Excel and Link Spreadsheets
The president of Universal Corporate Events wants you to integrate some of the company’s data with 
Excel. In this exercise, you will add a table that links to an Excel spreadsheet and export a table to Excel.

 1.  Open A10-A2-UCE from your Access Chapter 10 folder and save it as: A10-A2-UCERev

 2.  Choose External Data→Import & Link→New Data Source→From File→Excel.

 3.  Choose to link your data by creating a linked table and then browse to your Access Chapter 10 
folder and open A10-A2-UCE-Customers.xlsx.

 4.  Check the First Row Contains Column Headings checkbox and click Next.

 5.  Type BestCustomers-Linked for the Import to Table name and click Finish.

 6.  Click OK in the message box and then open the new BestCustomers-Linked table.

In the next few steps you will change the last name Fran to Francesca in the second record of the Excel 
spreadsheet. This change will be reflected in the Access table because they are linked. 

 7.  Close the table, saving it if prompted, and then open A10-A2-UCE-Customers.xlsx in Excel 
and change the first name in the second record from Fran to: Francesca
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 8.  Save and close the Excel workbook and then open the BestCustomers-Linked table in Access.

The first name is also changed to Francesca in the table.

 9.  Close the BestCustomers-Linked table.

 10.  Choose External Data→Import & Link→Linked Table Manager.

 11.  Mark the checkbox beside the linked filename, check the Always Prompt for New Location 
checkbox, and click OK.

 12.  Locate the A10-A2-UCE-Customers file and click Open.

 13.  Click OK in the dialog box and then close the Linked Table Manager.

Export Access Data to Create a New Excel Workbook
 14.  Select the Menus table in the Navigation pane and choose External Data→Export→Excel.

 15.  Ensure the file format is set to Excel Workbook (*.xlsx) and check the two available  
checkboxes under Specify Export Options.

 16.  Click Browse, save the file as A10-A2-UCE-Menus in your Access Chapter 10 folder, and click OK.

Excel opens and displays the workbook containing the Menus data. 

 17.  Close the Excel workbook and then switch to Access and close the Export - Excel Spreadsheet box.

 18.  Close the database, saving any changes.

APPLY YOUR SKILLS: A10-A3

Export and Import to the Web and Add Hyperlinks
In this exercise, you will export a table to make it available for viewing on the web, import an HTML file as 
a table, and add a hyperlink from the Venues Form to the Venue Revenue Report.

 1.  Open A10-A3-UCE from your Access Chapter 10 folder and save it as: A10-A3-UCERev

 2.  With the Menus table selected, choose External Data→Export→More→HTML Document.

 3.  Click Browse and save the file in your Access Chapter 10 folder as: A10-A3-UCE-Menus.html

 4.  Check the boxes for Export Data with Formatting and Layout and Open the Destination 
File After the Export Operation Is Complete; click OK.

 5.  In the HTML Output Options Dialog box, leave the option for Default Encoding selected and 
click OK.

Access creates the HTML file and opens it as a web page in your default web browser.

 6.  Close your web browser window. Switch back to Access and close the Export – HTML Document 
dialog box.

Import an HTML File as a Database Object
 7.  Close any open objects and then choose External Data→Import & Link→New Data 

Source→From File→HTML Document.

 8.  Click Browse, open A10-A3-UCE-Events.html from your Access Chapter 10 folder, and click OK.

 9.  Check the First Row Contains Column Headings checkbox and click Next.

 10.  Click Next again to accept the default field options, choose No Primary Key on the next screen, 
and click Next.
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 11.  Type AdditionalEvents for the Import to Table name and click Finish.

 12.  Close the Get External Data dialog box and then open the AdditionalEvents table and widen 
the columns as necessary.

 13.  Review the data and then save and close the AdditionalEvents table.

Add a Hyperlink to a Form
 14.  Display the Venues Form in Design View.

 15.  Click the Detail section bar and choose Form Design Tools→Design→Controls→Link.

 16.  Type Open Venue Revenue Report for the Text to Display.

 17.  Choose Object in This Database in the Insert Hyperlink dialog box.

 18.  Expand the Reports section, click Venue Revenue Report, and click OK.

Access places the hyperlink control in the top-left corner of the Detail section.

 19.  Drag the hyperlink control to the right of the Venue ID.

 20.  Save changes to the Venues Form and then switch to Form View.

When you point to the hyperlink, a ScreenTip displays the hyperlink’s destination.

 21.  Click the hyperlink to open the Venue Revenue Report in Report View.

 22.  Close all open database objects and then close the database.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A10-E1 That’s the Way I See It
To streamline customer outreach, you want to export data from the Blue Jean Landscaping database 
to Word. Open A10-E1-BJL and save it as A10-E1-BJLRev

Use the Customers table and the Mail Merge function to export the indicated 
fields into the A10-E1-BJL-Promotion document in the empty area between the 
date and body of the letter.

Open the Services table and copy the Services column header and field data, 
pasting it into empty space between the two body paragraphs. Enhance the 
appearance of the Word document using any techniques you feel will help 
improve customer outreach.

A10-E2 Be Your Own Boss
You want to export data in the Blue Jean Landscaping database to a spreadsheet so you can perform 
quick calculations. You also need to link new merchandise data from Excel. Open A10-E2-BJL and 
save it as: A10-E2-BJLRev 

Export the Merch Sales Query as an Excel spreadsheet named Merch Sales.xlsx and preserve 
the data with formatting and layout. Use A10-E2-BJL-NewMerchandise.xlsx to create a linked 
table named New Merch that contains the column headings from the sheet’s first row. Apply any 
changes to the table you feel will help improve data entry or visual appearance.

A10-E3 Demonstrate Proficiency
Stormy BBQ is concerned that sales employees cannot access merchandise data while they are 
on the road. They would like you to publish it to the web for easy access and to add a hyperlink to 
the MerchSales form. Lastly, they’ve asked you to begin adding photos of the current staff. Open 
A10-E3-SBQ and save it as: A10-E3-SBQRev 

Export the MerchSales table as an HTML document named MerchSales.html (preserve the data 
with formatting and layout). Add a hyperlink to the Merchandise table at the bottom-left corner of 
the MerchSales form using Available Merchandise as the text to display. Add an Attachment 
field to the Staff table and attach the HankGore.jpg file to the Hank Gore record. Apply any other 
changes you feel will help improve the database.



Fields to Add:

First Name

Last Name

Street Address

City

ST

ZIP
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L E A R N I N G  O B J E C T I V E S

ÝÝ Add command buttons to forms

ÝÝ Manage database objects and create macros

ÝÝ Back up, restore, analyze, compact, and repair a 
database

ÝÝ Set database security using encryption and 
passwords

11 Maintaining a 
Database

ACCESS

A
s you prepare your database for 

distribution, you will make your 

last design tweaks and confirm 

it is optimized for speed and ease of use. At 

this stage, security should be a main priority, 

as protecting a database from data loss 

and unauthorized access is critical. In this 

chapter, you will customize Access settings 

and add easy-to-use command buttons to 

a form. You will also create macros; explore 

database security features; set a database 

password; and then analyze, compact, and 

repair a database.
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Ý Project: Improving and Maintaining a Database
The prototype of the Winchester Web Design database is almost complete. After reviewing 
the database, the company’s owner is pleased with the overall design. He now wants to add 
some command buttons and macros to improve navigation and to ensure the database runs as 
efficiently as possible. A major concern is the security of the database and the data it contains. 
The owner would like to institute both security protocols and a regular backup policy.

Using Command Buttons to Improve Navigation
In addition to adding labels, text boxes, images, and other controls to database forms, you can add 
command buttons to use for record navigation, such as finding a record or going to the previous/next 
record, and report operations, such as printing a specific report or even exiting Access. To create a 
button, you draw a button shape in the desired location on the form and use the Command Button 
Wizard to walk you through the process.

ÝÍ Form Design Tools→Design→Controls→Button 

DEVELOP YOUR SKILLS: A11-D1

In this exercise, you will add command buttons to the Form Footer section of the Invoice Form to make 
navigation easier and to quickly view an invoice report.

 1.  Open A11-D1-WinDesign from your Access Chapter 11 folder and save it as: 
A11-D1-WinDesignRev

 2.  Enable content and then close the Winchester Web Design Navigation Form.

Many of the activities in this chapter require you to enable content to function properly. Enable content 
when the option appears.

 3.  Open the Invoice Form in Design View.

 4.  Click the Form Footer section bar and type 0.75 for the Height property on the Property Sheet. 
(Hint: Tap [F4] to open the Property Sheet.)

 5.  Choose Form Design Tools→Design→Controls→Button .

 6.  Draw a button in the Form Footer under the left end of the subform.

If the Command Button Wizard doesn’t open, delete the button and then choose Form Design 
Tools→Design→Controls→Use Control Wizards and draw the button again.



Note!
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 7.  Follow these steps to add a command button:

Your command button may show a different number than 33.

A

C

B

A  Choose the Record Navigation category.

B  Choose the Go To First Record action.

C  Click Next.

 8.  Click the Picture option, choose Go To First, and click Next.

 9.  Enter cmdFirst as the meaningful name and click Finish.

The command button shows the Go To First picture in the Form Footer section and is programmed to 
go to the first record when in Form View.

 10.  Repeat steps 5–9 to add commands in the order shown:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

 11.  Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action; click Next.
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 12.  Select the Invoice Details Report as the report to preview and click Next.

 13.  Choose the MS Access Report picture, if necessary, and click Next.

 14.  Enter the name cmdPreviewInvoices and click Finish.

 15.  Select the new buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

 16.  With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

 17.  Switch to Form View and test each button.

 18.  If necessary, close the Invoice Details Report and then save and close the Invoice Form.

Creating Macros to Improve Efficiency
A macro is an object that combines a series of steps into a single step so a more detailed task can be 
automated. For example, if you regularly export your data to another database, instead of choosing 
External Data→Export→Text File and then entering the filename and selecting export options, you 
could create a macro to perform all the steps with one double-click of the mouse. 

The ExportCustomers macro exports the Customers table to the default My Documents folder as 
a text file (bottom figure). If needed, a specific file path could be entered for the output file.

ÝÍ Create→Macros & Code→Macro 
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DEVELOP YOUR SKILLS: A11-D2

In this exercise, you will create a macro that will display a message box to provide basic directions on when 
and where to back up the Winchester Web Design database.

 1.  Choose Create→Macros & Code→Macro .

 2.  Choose MessageBox from the Add New Action drop-down menu.

 3.  Enter the following into the MessageBox text boxes:

Property Setting

Message Be sure to back up every Friday

Beep Yes

Type Information

Title Back-Up Policy

 4.  Save the macro as: Back-Up Policy

 5.  Choose Macro Tools→Design→Tools→Run  to test the macro.

A message box should appear with the title, message, and icon you entered.

 6.  Click OK to close the message box.

 7.  Close the Back-Up Policy macro.

Back-Up Policy is now listed in the Navigation pane under the Macros group heading.
 

Using Macros to Display Adaptable Reports
Now that you have created a simple macro to display a reminder message, you can add a command 
button to a form that will run a macro to display a report. By adding a “where” condition, you can 
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not only open the report of your choosing, you can also specify the macro to display a specific record 
within the report based on matching the criteria for a field in the current object. For example, if you 
would like to print the invoice that corresponds to the record displayed in your Orders form, you can 
set the macro to display only the record that matches the Order ID field in both the Orders form and 
the Invoices report.

DEVELOP YOUR SKILLS: A11-D3

In this exercise, you will create a macro button that will be placed on the Employees Form to display a 
report of all the sales for the specific employee selected.

 1.  Choose Create→Macros & Code→Macro .

 2.  Open the Add New Action drop-down menu, scroll the list downward, and choose 
OpenReport.

 3.  Open the Report Name drop-down menu and choose Invoice Details Report.

 4.  Complete the OpenReport text boxes as indicated:

As you start to enter in the Where Condition text box, Access will suggest field names from a  
drop-down menu, allowing you to quickly and more accurately select from the list.

Property Setting

Report Name Invoice Details Report

View Report

Where Condition [EmpID]=[Forms]![Employees Form]![EmpID]

Window Mode Normal

 5.  Save the macro as: Invoice Details Report by Employee

 6.  Display the Employees Form in Design View.

 7.  Choose Design→Controls→Button  and draw a button in the top-right corner of the 
Details section of the Employees Form.

The Command Button Wizard starts.

 8.  Choose the Miscellaneous category and the Run Macro action; click Next.

 9.  Choose Invoice Details Report by Employee and click Next.

 10.  Accept the default macro picture and click Next again.

 11.  Name the button cmdRptByEmployees and click Finish.
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 12.  Switch to Form View and navigate to Mike Waters (EmpID MJW).

 13.  Click the new Run Macro button to display all records in which the EmpID is MJW.

 14.  Close the report and form, saving the changes to the form.

Managing Database Objects
Protecting databases and the quality of data they contain is vital to the reliability and performance 
of any database. At the same time, learning efficient ways to manage database objects helps to save 
a great deal of time as you build a database. The general cleanup and maintenance of a database 
can be accomplished in a number of ways. You can create new objects from existing objects, rename 
database objects, and delete unneeded or duplicate database objects.

Creating New Objects from Existing Objects
Often, databases contain separate objects that are similar in structure and in the data they hold. 
For example, the Employees table in the Winchester Web Design database contains fields similar to 
those found in the Customers table. When you build a database that contains similar objects, you can 
copy the original object, save it using a new name, and then modify the new object to fit its specific 
needs. There are two basic ways to copy objects:

 Ý Use the Save Object As command and rename the object to create another instance of it.

 Ý Use the contextual menu Copy and Paste commands.

Renaming Database Objects
You might create a table, query, form, or report and save it with the first name that comes to mind 
and then, after working with the object for a while, you might want to change the name. When an 
object is renamed, Access automatically renames all the relationships and record sources that use 
the renamed object. For instance, if you update the Invoices table to Orders, the record source for 
the queries, forms, and reports based on the table will be updated to reflect the new name.

Deleting Database Objects
During the development of a database, there are times when it is wise to create a temporary table, 
query, form, or report for testing purposes. Once the database is completed, you should remove 
these objects so they don’t clutter the Navigation pane or confuse users. 

DEVELOP YOUR SKILLS: A11-D4

In this exercise, you will copy, rename, and delete a report. You will also save a table in the Winchester 
Web Design database as a new table and edit the field names for the new table.

 1.  Right-click the Products Report in the Navigation pane and choose Copy.

 2.  Right-click again and choose Paste, keep Copy Of Products Report as the report name, and click OK.

 3.  Right-click Copy Of Products Report and choose Rename; type Delete This Report and 
tap [Enter].
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 4.  Select the Delete This Report report in the Navigation pane.

 5.  Tap [Delete] and click Yes to confirm the deletion.

You can also right-click an object and choose Delete from the menu.

 6.  Open the Employees table and choose File→Save As→Save Object As→Save As.

 7.  Type Business Contacts in the Save ‘Employees’ To text box and click OK.

 8.  Switch to Design View.

 9.  Select and edit the Business Contacts field names, replacing each Emp prefix with a Bus prefix 
(so EmpID is BusID, EmpLastName is BusLastName, and so on).

 10.  Right-click the HireDate field, choose Delete Rows, and then click Yes to confirm.

 11.  Delete the WebCert field and then save the changes to the Business Contacts table.

 12.  Switch to Datasheet View to confirm your changes and then close the Business Contacts table.

Backing Up a Database
All databases should be safeguarded to protect their data. Most organizations have a scheduled 
procedure to back up all files on their network, including the databases.

When you back up a database using the built-in Access tools, Access automatically places the date 
of the backup in the filename so you can easily identify and retrieve each backup file. You choose 
the drive and folder in which you want to save the backup. To restore the database, simply open the 
backup.

ÝÍ File→Save As→Save Database As→Back Up Database 

DEVELOP YOUR SKILLS: A11-D5

In this exercise, you will back up your Winchester Web Design database.

 1.  Close any open objects in the Winchester Web Design database.

 2.  Choose File→Save As→Save Database As→Back Up Database  and then click Save As.

Access opens the Save As dialog box and adds the current date to the end of the filename.

 3.  Save the file in your Access Chapter 11 folder.

Access saves the backup file to the desired location, adding the date the backup occurred to the 
filename. However, the open database file is still the original Winchester Web Design database.

 4.  Close the database, navigate to your Access Chapter 11 folder, and open the backup database.

A backup is only as current as the time the backup was created. It’s important to have a policy that 
schedules and mandates a daily or weekly backup.

 5.  Close the backup database and reopen A11-D1-WinDesignRev.

Tip!
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Analyzing and Documenting Databases
Each time you change the design or content of a database, the chance that the database will become 
corrupted increases. Access includes several tools that help you protect, document, analyze, and 
even repair databases. The main tools found in the Analyze group on the Database Tools tab are:

 Ý Performance Analyzer: This tool analyzes the performance of a database to locate and identify 
potential trouble spots that affect how the database functions.

 Ý Database Documenter: This tool documents objects in the database so you can track changes 
to design and relationships. It builds an Object Definition document that provides a detailed 
description of each database object.

Reviewing and Analyzing Performance
When you run the Performance Analyzer, Access reviews each selected object in the database, looks 
at all the relationships, and identifies any problems that might affect database performance. Access 
often makes recommendations for improvements to optimize database efficiency. In some cases, 
Access identifies tables in which no primary key is set. In other cases, Access will suggest a more 
efficient data type or that you use fewer controls on a form.

Some changes recommended by the Performance Analyzer may not be necessary. For example, 
Access frequently recommends that phone numbers be formatted using the Number data type. Not 
only is this unnecessary, it may even cause problems for extensions that are commonly preceded 
by an X, such as X209. As you review the recommended changes, you will begin to identify those 
requiring your attention and those you can ignore.

There are two options for analyzing database performance. The Analyze Performance tool enables 
you to choose the database objects you want to analyze. The Analyze Table tool analyzes a table 
using the Table Analyzer Wizard.

ÝÍ Database Tools→Analyze→Analyze Performance 

Documenting a Database
As you plan a new database, you must analyze the needs of the business and the requirements of the 
database. In the process, you create a list of fields required and then organize and group those fields 
into the tables that will provide the data for forms, queries, and reports. The list identifies and defines 
each field and the tables and objects in which the fields are used within the database. When the 
database is finished, you may choose to document the database so it can be efficiently updated and 
maintained in the future.

Documentation provides insight into the structure of the entire database as well as the structure 
of each object within the database. Maintaining a database can be very time-consuming. Without 
proper documentation to identify potential impacts of changing field properties, object structures, 
and so forth, you can potentially corrupt one database object that, in turn, wreaks havoc on the entire 
database. Each time you change the structure of any database object, remove an object from, or add 
an object to the database, you should run the Database Documenter to provide up-to-date documen-
tation about the database. Such information will prove invaluable to database administration.

ÝÍ Database Tools→Analyze→Database Documenter 
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DEVELOP YOUR SKILLS: A11-D6

In this exercise, you will analyze and document your Winchester Web Design database.

 1.  Choose Database Tools→Analyze→Analyze Performance .

The Performance Analyzer opens.

 2.  Click the Tables tab and click Select All to check all the tables listed.

 3.  Click OK and view the suggestions under Analysis Notes.

The data types have been set properly, so you can ignore the suggested ideas.

 4.  Click Close.

 5.  Choose Database Tools→Analyze→Database Documenter .

The Documenter opens.

 6.  Click the Tables tab, check the InvoiceDetails, Invoices, and Products tables, and click OK.

Access produces a report about a dozen pages long that documents the tables, fields, and 
relationships of the selected tables.

 7.  Scroll through the report and examine the documentation provided.

 8.  Choose Print Preview→Data→Excel  to open the Export Excel Spreadsheet Wizard.

 9.  Check the Open the Destination File After the Export Operation Is Complete box, if 
necessary.

 10.  Click Browse, navigate to your Access Chapter 11 folder, type A11-D6-Objects as the  
filename, click Save, and then click OK.

 11.  Browse through the Excel spreadsheet and close it when finished.

 12.  Close the wizard without saving the export steps and then close the print preview.
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Compacting and Repairing a Database
When you delete a record in Access, the record is not really deleted—it’s marked for deletion. 
The process of marking a record as deleted is quicker than completely deleting and reordering or 
rewriting all the records in a table. A similar process is used when you shorten the contents of a 
record—the space that was used for the longer data is not released.

As you work with databases, they can become sluggish and the data stored in the databases can 
become fragmented. Fragmentation occurs when parts of your database file become separated by 
incidental data that has been added to the disk you are using. For example, if you saved a 10-mega-
byte database file to your hard drive and saved an Excel spreadsheet to the same hard drive shortly 
afterward, it would be written next to the 10-megabyte database file. 

Then, if a large group of new records were added to the database file, they would have to be stored 
after the Excel file and not after the original database file because the adjacent space is now occu-
pied by the spreadsheet. As you add more records and save other files, both your files and storage 
drive become fragmented and less efficient.

Consequently, over time databases can become bulky and inefficient. This issue can be resolved by 
compacting, or compressing, your database to remove wasted and unused space left from deleted 
and edited records. 

To ensure optimal performance, Access enables you to compact and repair databases as often as you 
want. Sometimes Access recognizes a problem when a database is opened and attempts to repair 
the file before you work with it. Even if there is no file corruption, the normal maintenance tasks of 
adding, deleting, and editing records, creating and running queries, and so forth, may reduce data-
base performance. You may want to compact and repair the database manually on a regular basis or 
set an option to automatically compact the database whenever you close Access.

ÝÍ Database Tools→Tools→Compact and Repair Database 

DEVELOP YOUR SKILLS: A11-D7

In this exercise, you will compact and repair your Winchester Web Design database.

 1.  Close any open database objects.

 2.  Choose Database Tools→Tools→Compact and Repair Database .

Access compacts and repairs the file. Because the database is relatively small, the compact and repair 
process takes only a moment. For larger databases, the process will take longer. 

 3.  Close A11-D1-WinDesignRev and exit Access.

Setting Database Security
Imagine your doctor stores all your medical records in a large database that could be accessed by hospi-
tals, clinics, and medical insurance companies who want to know more about the medications you take, 
conditions you might have, and doctor’s visits. Databases, by nature, often hold confidential information. 
As a result, security is imperative. Companies that maintain large database files often restrict access to 
databases at the login or server level. Splitting a database can protect the data contained in databases, 
and Access offers tools that enable you to secure a database by assigning a password.
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Opening a Database Exclusively
Most large business databases are designed to provide access to multiple users at the same time. 
As a result, the default setting for a database is as a shared file. Before you can set security for a 
database, you must ensure no one else is currently using the database. You do this by opening the file 
exclusively so Access locks the database and prevents others from accessing it at that time.

The Open dialog box contains numerous commands for opening databases after a file has been 
selected.

COMMANDS FOR OPENING DATABASES

Command Description
Open Provides full and typical access to the database and its objects 

and menus so you can create and edit

Open Read Only Opens the database so you can view and print data but does not 
allow design changes; however, you can save the database as a 
new file and edit that one 

Open Exclusive Opens the database and locks it to prevent other users in a 
shared environment from accessing it

Open Exclusive Read-Only Opens the database and locks it so other users cannot access it 
and prevents edits to data and database objects

Encrypting a Database Using a Password
Regardless of whether a backup routine is in place, valuable time can be lost reconstructing data if 
unauthorized users damage the database. Database passwords are intended to protect the database 
just as the passwords you use to access bank accounts or email accounts protect your financial and 
personal information.

Limits of Passwords
Database passwords provide limited security for databases by preventing unauthorized users from 
opening the database. You can set a password for any database you have on your personal computer, 
just as systems administrators set a password for shared databases on a network. 

Access passwords are case-sensitive, or capable of distinguishing between upper- and lowercase 
characters.

Strong Passwords
Access passwords can use a combination of upper- and lowercase characters, symbols, and numbers. 
Access allows you to use any combination of characters in passwords except “ \ [ ] : | <> + = ; , . ? and *. 
Strong passwords are at least thirteen characters long and contain at least one of each of the char-
acter types indicated. Passwords cannot start with a space.

Weak Password: webdesign

Strong Password: TooHard2Cr@ck

Setting Up Databases for Assigning Passwords
To assign a database password, the database must initially be closed. The default access setting for 
databases that appear on a network is as a shared database, accessible to anyone who has access to 
its file location. To set a password, you must open the database exclusively using the Open Exclusive 

Tip!
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command in the Open dialog box. This ensures that no one else is currently using the database and 
that, once you open it, other users are prohibited from opening it until you close it. If the file is not 
opened exclusively, you will get a warning message.

The Encrypt with Password command is a toggle. When a database has a password, the command button 
shows Decrypt Database.

ÝÍ File→Info→Encrypt with Password 

DEVELOP YOUR SKILLS: A11-D8

In this exercise, you will open the Winchester Web Design database exclusively and set a database 
password to protect the database.

 1.  Start Access, choose Open Other Files from the menu, and click Browse.

 2.  Navigate to your Access Chapter 11 folder; click A11-D1-WinDesignRev but do not open the 
database.

 3.  Click the Open menu   button and choose Open Exclusive.

 4.  Enable content and then close the WWD Navigation Form.

 5.  Choose File→Info→Encrypt with Password .

 6.  Type Labyrinth123! in the Password text box and again in the Verify text box and then click 
OK.

 7.  Click OK to acknowledge that row level locking will be ignored.

 8.  Close A11-D1-WinDesignRev and then open it again.

 If you forget your password, you won’t be able to open the database.

 9.  Type Labyrinth123! in the Enter Database Password text box and click OK.

You must open the database exclusively again if you want to change or remove the password.

 10.  Close A11-D1-WinDesignRev.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Note!

Warning!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A11-R1

Enhance and Clean Up a Database
Kids for Change would like to improve its forms by adding navigation and accessibility to other objects 
using buttons. It would also like to clean up database objects. In this exercise, you will add command 
buttons; create a macro that opens a report; and do some cleanup tasks by copying, renaming, and 
deleting objects.

 1.  Start Access; open A11-R1-K4C from your Access Chapter 11 folder, and save it as: 
A11-R1-K4CRev

Remember to enable content if the option appears. You will begin by adding command buttons to a form. 

 2.  Open the Activities Form in Design View.

 3.  Click the Form Footer section bar and set the Height property to: 0.75

 4.  Choose Form Design Tools→Design→Controls→Button  and draw a button in the form 
footer under the Telephone label.

The Command Button Wizard opens.

 5.  Choose Record Navigation as the category and Go To First Record as the action; click Next.

The wizard displays a sample button picture for each action.

 6.  Leave the options for pictures as selected, click Next, enter cmdFirst as the meaningful name, 
and click Finish.

The command button shows the Go To First image in the Form Footer section and is programmed to 
go to the first record when in Form View.

 7.  Add these buttons in the order listed:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

 8.  Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action.

 9.  Select the Activity Costs Report as the report to preview and click Next.

 10.  Choose the Preview picture and click Next; enter the name cmdPreviewCosts and click Finish.

 11.  Select the new command buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

All of the command buttons are aligned to the top.
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 12.  With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

 13.  Switch to Form View and test each of the new buttons; close the Activity Costs Report.

Create a Macro to Display Adaptable Reports
 14.  Choose Create→Macros & Code→Macro .

 15.  Choose OpenReport from the Add New Action menu.

 16.  Use this table to create the macro:

Report Name Volunteers Report

View Report

Where Condition [ActID]=[Forms]![Activity Staffing]![ActID]

 17.  Save the macro as Available Volunteers and then close it.

 18.  Display the Activity Staffing form in Design View and then choose Form Design Tools→ 
Design→Controls→Button .

 19.  Draw the new button to the right of the Meet Time controls.

 20.  Choose the Miscellaneous category and the Run Macro action, click Next, choose Available 
Volunteers, and click Next again.

 21.  Accept the default macro picture and click Next; name the button VolunteersMacro and 
click Finish.

 22.  Switch to Form View and click the new VolunteersMacro button.

The macro button displays the Volunteers Report record for the activity on the form. 

To display the Volunteers Report for another activity, close the report, navigate to the desired activity, 
and click the macro command button.

 23.  Close the Volunteers Report and then save and close the Activity Staffing form.

Rename, Delete, and Save Object as a New Object
 24.  Right-click Donations Report in the Navigation pane and choose Copy.

 25.  Right-click again, choose Paste, type Delete This Report as the report name, and click OK.

 26.  Select Delete This Report in the Navigation pane and tap [Delete]; click Yes to confirm the 
deletion.

 27.  Open the PaidStaff table and choose File→Save As→Save Object As→Save As.

 28.  Type Professional Contacts in the Save ‘PaidStaff’ To text box and click OK.

 29.  Display the new Professional Contacts table in Design View and rename the StaffID field to: 
ProfID

 30.  Right-click the Parent field and choose Delete Field; confirm the deletion.

 31.  Delete the Masters, HrlySal, and ActID fields. Click Yes to permanently delete the fields and 
to delete the ActID indexes.

 32.  Rename the Email Address field as: ProfEmail

 33.  Save and close the Professional Contacts table and then close the database.
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REINFORCE YOUR SKILLS: A11-R2

Perform Database Maintenance and Set a Password
Kids for Change would like a backup of its database. It would also like it to be optimized for speed and 
secured with a password. In this exercise, you will perform some maintenance procedures on the Kids for 
Change database, including backing up and analyzing objects. You will also add a password to protect the 
data from unauthorized users.

 1.  Start Access; open A11-R2-K4C from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-R2-K4CRev

 2.  Choose File→Save As→Save Database As→Back Up Database .

 3.  Click the Save As button, navigate to your Access Chapter 11 folder, and click Save.

Analyze and Document a Database
 4.  Choose Database Tools→Analyze→Analyze Performance .

 5.  Click the Tables tab and click Select All to check all the tables listed.

 6.  Click OK and view the Analysis Results.

Because the data types have already been set properly, you can ignore the suggested ideas.

 7.  Click Close and then choose Database Tools→Analyze→Database Documenter .

 8.  Click the Tables tab, check the Activities and PaidStaff tables, and click OK.

The report documents the tables, fields, and relationships of the selected tables.

 9.  Choose Print Preview→Data→More→Word  to export the report to a Word RTF.

RTF files contain minimal formatting, are small, and are compatible across virtually all hardware and 
software platforms. Exporting to RTF ensures wider compatibility for various users.

 10.  Browse to your Access Chapter 11 folder, type A11-R2-Tables as the filename, and click Save.

 11.  Check the Open the Destination File After the Export Operation Is Complete box and click OK.

Access creates and opens the Word document.

 12.  Page through the Word document and then close it and exit Word.

 13.  Close the dialog box without saving the export steps and then close the print preview.

Compact and Repair a Database
 14.  Choose File→Info→Compact & Repair Database .

Access has compacted and repaired the file. The K4C Navigation Form might open, depending on your 
system.

 15.  Close A11-R2-K4CRev.

Protect a Database
 16.  Choose File→Open→Browse, navigate to your Access Chapter 11 folder and click  

A11-R2-K4CRev, and then click the Open menu button  and choose Open Exclusive.

No one else will be able to use the database until you exit Access.

Because you opened the database exclusively, you can set a password to open the database.

 17.  Choose File→Info→Encrypt with Password.
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 18.  Type Labyrinth123! as the password, verify it by typing it again, and click OK.

 19.  Click OK to acknowledge the message about row-level locking.

 20.  Close A11-R2-K4CRev and then open it again.

Access displays the Password Required dialog box. 

 21.  Type Labyrinth123! in the text box and click OK.

 22.  Close the database.

REINFORCE YOUR SKILLS: A11-R3

Perform Maintenance and Back Up a Database
Kids for Change would like a reminder to back up the database regularly. It would also like to rename a 
form and save a volunteer list as a query. In this exercise, you will create a macro that reminds users to 
back up the database. You will also rename, delete, and save objects.

 1.  Open A11-R3-K4C from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-R3-K4CRev

Remember to enable content if the option appears.

Create a New Macro
 2.  Choose Create→Macros & Code→Macro .

 3.  Choose MessageBox from the Add New Action drop-down menu and use this information to 
create the macro:

Message Back up the database to SharePoint 
at the end of each day!

Beep Yes

Type Information

Title Back-up Routine

 4.  Save the macro as: Back-up Routine

 5.  Choose Macro Tools→Tools→Run .

The Back Up Routine Information message box opens.

 6.  Click OK to close the message box and then close the Back-up Routine macro.

Back-up Routine is now listed under Macros in the Navigation pane.

Manage Database Objects
 7.  Right-click Staff Form in the Navigation pane and choose Copy.

 8.  Right-click again and choose Paste; rename the pasted object to PaidStaff Form and click OK.

 9.  Select the Staff Form in the Navigation pane and tap [Delete]; click Yes to confirm the deletion.

 10.  Open the Volunteers table and choose File→Save As→Save Object As→Save As.

 11.  Type Volunteers List in the Save ‘Volunteers’ To text box.

 12.  Choose Query from the As drop-down menu and click OK.

 13.  Close the Volunteers List Query and then close the database.
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 Apply Your Skills
APPLY YOUR SKILLS: A11-A1

Enhance a Database
Universal Corporate Events has asked you to improve forms by adding navigation and accessibility to other 
objects using macros and buttons. In this exercise, you will add command buttons to the Wage and Salary 
Form and create macros to increase efficiency.

 1.  Start Access; open A11-A1-UCE from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-A1-UCERev

Remember to enable content if the option appears.

 2.  Open Wage and Salary Form in Design View.

 3.  Set the Height property for the Form Footer section to: 0.75

 4.  Draw a button in the Form Footer under the Detail section labels.

 5.  Create a Go To First Record button that uses the Go To First picture option and name it: 
cmdFirst

 6.  Add these command buttons, in the order listed, using the default picture options:

• Go To Previous Record named: cmdPrevious

• Go To Next Record named: cmdNext

• Go To Last Record named: cmdLast

• Find Record named: cmdFind

 7.  Draw a button to the right of the Find Record button using these specs:

• Category: Report Operations

• Action: Preview Report

• Report to preview: Wage and Salary Report

• Picture: Preview

• Name: cmdPreviewReport

 8.  Select all new command buttons and then top-align them and set equal horizontal space 
between them.

Hint: Go to Form Design Tools→Arrange→Sizing & Ordering.

 9.  Switch to Form View, test the buttons, and then close the Wage and Salary Report.

 10.  Save and close the Wage and Salary Form.

Create a Macro
 11.  Choose Create→Macros & Code→Macro.

You will create a macro that opens the Event Revenue Report for the Event ID shown on the form.
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 12.  Create an OpenReport macro using these guidelines:

Report Name Event Revenue Report

View Report

Where Condition [Forms]![Event Costs]![EventID]=[Event 
Revenue]![EventID]

Macro Name Event Revenue by Name

 13.  Close the macro.

 14.  Display the Event Costs form in Design View.

 15.  Create a new button under the Cost Details label using these specs:

• Category: Miscellaneous

• Action: Run Macro

• Macro: Event Revenue by Name

• Picture: default option

• Name: cmdEventRevenue

 16.  Switch to Form View and navigate to the first record with an Event ID of BUSMTG.

 17.  Click the new macro button.

The revenue report for this event type is displayed. You can display the report for other Event IDs by 
navigating to the event and running the macro.

 18.  Close the Event Revenue Report; save and close the Event Costs form.

 19.  Close the database.

APPLY YOUR SKILLS: A11-A2

Perform Database Maintenance and Set a Password
Universal Corporate Events would like a backup of its database. It would also like to fine-tune the objects 
and secure the database. In this exercise, you will perform maintenance procedures to reduce wasted 
space, defragment objects, and improve efficiency. You will also back up the database and add a password 
to protect data from unauthorized users.

 1.  Open A11-A2-UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A2-UCERev

 2.  Choose File→Save As→Save Database As→Back Up Database→Save As.

The current date is added to the end of the database filename.

 3.  Save the file in your Access Chapter 11 folder.

Analyze and Document a Database
 4.  Choose Database Tools→Analyze→Analyze Performance.

 5.  On the Tables tab, click Select All to check all the tables listed and click OK.
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 6.  Review the information presented and then close the dialog box.

 7.  Choose Database Tools→Analyze→Database Documenter.

The Documenter opens.

 8.  On the Tables tab, check Menus and Schedules, and then click OK.

Access generates a report for the tables, fields, and relationships of the selected tables.

 9.  Choose Print Preview→Data→More→Word.

 10.  Browse to your Access Chapter 11 folder, use A11-A2-MenuSched as the filename, and click 
Save.

 11.  Check the Open the Destination File After the Export Operation Is Complete box and 
click OK.

 12.  Exit Word. In Access, close the Export – RTF File dialog box without saving the export steps, 
close the preview, and close any open database objects.

Secure a Database
 13.  Choose File→Open and then navigate to your Access Chapter 11 folder and open  

A11-A2-UCERev in Exclusive mode.

 14.  Encrypt the file with the password: Labyrinth123!

 15.  Click OK to acknowledge the encrypting message.

 16.  Close and reopen A11-A2-UCERev, entering the password when prompted.

 17.  Close the database.

APPLY YOUR SKILLS: A11-A3

Maintain Database Objects and Create a Macro
Universal Corporate Events would like you to add a message to remind employees to export reports every 
Friday and to clean up database objects to ensure the database runs smoothly. In this exercise, you will 
create a macro to display a message, create a new Products table based on data in the Menus table, and 
compact and repair the database.

 1.  Open A11-A3UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A3-UCERev

 2.  Close the UCE Navigation Form.

 3.  Create a MessageBox macro, using Export all new reports on Friday! as the 
message, no beep, Information as the type, and Report Policy for the title.

 4.  Save the macro as Report Policy and then run it.

 5.  Close the information box and then close the Report Policy macro.

Maintain Database Objects
 6.  In the Navigation pane, copy and paste the Personnel Report, resulting in a new object named 

Copy of Personnel Report.

 7.  Rename the pasted object as: Staff ReportEVALU
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 8.  Delete the Staff Report, confirming the deletion when prompted.

 9.  Open the Menus table, choose File→Save As→Save Object As, and click Save As.

 10.  Save the object as a new table named Products and then display the table in Design View.

 11.  Rename the table fields as indicated:

Field Rename

MenuCode ProdCode

MenuPlan ProdPlan

ChgPP Cost

CostPP Price

 12.  Save and close the new Products table.

Last, you will compact and repair the database.

 13.  Choose Database Tools→Tools→Compact and Repair Database.

 14.  Close the database, choosing Yes to empty the Clipboard.

  Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A11-E1 That’s the Way I See It
You would like to modify a database form to provide buttons for navigation as well as opening a 
closely related report for the Blue Jean Landscaping database. Open A11-E1-BJL and save it as: 
A11-E1-BJLRev

Create a macro named Service Invoices that opens 
the Service Invoices Report in Report View for the last 
name shown on the form. In the Service Invoices form 
footer, create command buttons using the default picture 
options as indicated in the table. Then create a Run Macro 
button named cmdServiceInvoicesReport that 
opens the Service Invoices macro. Top-align the buttons 
and set equal space horizontally between all buttons. Make any other changes to the form you feel 
would improve its look and feel.

A11-E2 Be Your Own Boss
As the owner of Blue Jean Landscaping, you would like to improve performance and security. Open 
A11-E2-BJL and save it as: A11-E2-BJLRev 

Analyze the performance of all database tables. Use the Database Documenter to generate a 
report for the Services, ServiceInvoices, and ServiceInvDetails tables. Export the report to an Excel 
file (name it ServicesTables). Back up the database and then close and open A11-E2-BJLRev 
exclusively. Encrypt the file with a password of your choosing. Write the password down for your 
instructor or for future reference.

A11-E3 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant has asked you clean up unnecessary objects in its 
database and to save a table as a query for easy filtering and sorting of restaurants. Also, it would 
like the database compacted and repaired in case renaming and removing objects has affected 
efficiency. Open A11-E3-SBQ and save it as: A11-E3-SBQRev

Complete these actions:

 Ý Delete the KeyWest Staff Query.

 Ý Rename any form with the name of your choosing.

 Ý Save the Restaurants table as a query named: Restaurant List

 Ý Compact and repair the database.



Go To First Record cmdFirst

Go To Previous Record cmdPrevious

Go To Next Record cmdNext

Go To Last Record cmdLast

Find Record cmdFind
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Glossary

Access Database software that helps you quickly 
retrieve data; allows you to create and enter data into a 
table and then use forms, reports, and queries to display 
the desired results

action query Performs one of four actions on a group 
of records (delete, update, append, or create a new 
table)

aggregate function Function that performs a calcula-
tion on a set of values, returning a single value

append query Query that adds a group of records from 
one or more sources to the end of one or more tables

back end Refers to the underlying database tables that 
support the front end 

calculated control Unbound text box control with 
a formula inserted in the control source property that 
references other controls within a form or report

Cascade Delete Relationship that records in a related 
table whenever related records in the primary table are 
deleted

Cascade Update Relationship that updates the value 
in the key field of a related table when the primary key 
value in the primary table is changed

chart Graphical display of data in a visual layout; create 
charts to better interpret the relationships between 
report data (can also be used with forms)

Clipboard Location within Microsoft Office that 
contains thumbnails of what you have recently cut or 
copied from your Microsoft Office file(s) during your 
Windows session; used to quickly paste text, pictures, 
images, or charts into a file

command buttons Controls used to create action 
buttons that can be placed on a form to perform such 
actions as opening a report, moving to the next record, 
or even exiting Access

compacting Removes wasted and unused space left 
from deleted and edited records 

controls Objects placed in forms or reports that display 
data, text, checkboxes, lines, images, or buttons

Copy Creates a duplicate of the original selection, which 
remains in the source location, and places a copy of the 
selection on the Office Clipboard

crosstab query Query that lists fields to be grouped in 
rows and fields to be summarized in columns so you can 
calculate sums, averages, counts, or totals by group and 
subgroup

Cut Removes the original selection from the source 
location and places the selection on the Office 
Clipboard

data Information such as names, numbers, dates, 
descriptions, etc., organized for reference or analysis 

database A collection of data related to a subject or 
purpose, organized by records and fields; for example, 
an employee database contains information for each 
employee, such as their name, employee ID, and contact 
information

Database Documenter Documents objects in the 
database so you can track changes to database design 
and relationships; builds an Object Definition document 
that provides a detailed description of each database 
object

database splitter Converts a database into two files—
one that contains the tables holding the data and one 
that contains the objects that use the data 

Datasheet View Displays actual data values

delete query Query that deletes a group of records 
from one or more tables 

description Optional field property in Design View to 
help identify special information about a field

Design View Where form, query, and report layout are 
defined; shows field names and labels, as well as other 
objects that can be displayed

Detail section Main section of a form or report that 
contains the text boxes that display data from under-
lying database tables; detail content varies from record 
to record
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Excel Worksheet software, arranged with rows and 
columns, used to create calculations and to make 
what-if analyses; perfect for preparing a budget or 
income statement or determining the amount of interest 
paid on a loan

exporting Process of sending data to other files or 
applications

expression Combination of field names and arithmetic 
and logical operators required to perform the calcula-
tion; an Access formula

Expression Builder Feature that assists users in 
building functions via a dialog box containing a list of 
available fields in the current object and an array of 
built-in operators, functions, and expressions

field Group or category of specific information or data, 
such as last names or phone numbers; in an Access 
table, each field is displayed in a column

find duplicates query Locates records containing 
duplicate field values in a single table or query 
datasheet

find unmatched query Locates records in one table 
that have no matching records in another table

foreign (or secondary) key Field in a secondary table 
that links to the primary key field in the main table, 
which contains the detailed information for an item

form Database screen used to enter, edit, and view data 
for an individual record in a layout that is more conve-
nient and attractive than a table datasheet layout

Form Footer Bottom section of a form that appears on 
the last page of a page form; seldom used

Form Header Top section of a form that contains 
constant information, such as a title, logo, decorative 
line, or color scheme

Format Painter Applies the character and paragraph 
formatting from the source selection to any characters 
or text selected

fragmentation When parts of your database file 
become separated by incidental data that has been 
added to the storage location

Front end Refers to the up-front portion of a split 
database with which users interact

group Collection of controls or records with at least 
one feature in common; quick forms tie all automatically 
inserted text boxes and corresponding labels into one 
group, allowing you to move the entire group but not 
individual controls; or, if you want to display all vendors 
with offices in the same state, you could group on the 
State field

Group Footer displays summary information (such as 
the total of all transactions for each salesperson)

Group Header Identifies a field (such as EmpID) by 
which report data is grouped, so a summary (such as a 
total of each employee’s sales) can be displayed for the 
grouped field

Hypertext Markup Language (HTML) Code or 
language in which web pages are written 

importing Process of retrieving data from other files or 
applications

index (database) Like a book index; its main function 
is to speed up database operations; an index set on key 
fields uses one or more hidden columns in a table for 
faster data retrieval

input mask Controls data formats by setting the 
required characters to display as users enter data, such 
as slashes (/) for a date field

Keep Source Formatting Pastes the text and the 
selection with any formatting (bold, italic, underline) 
from the source location to the target location; the 
selection pasted retains the original formatting from the 
source location

Keep Text Only Pastes the selection from the source 
location to the target location; the selection pasted 
takes on the formatting of the target location

labels Part of a control that contains a caption identi-
fying the data displayed in a text box or checkbox; e.g., 
the caption Last Name is a good label for the LastName 
field

Layout View Combines the editing ability of Design 
View with the layout look of Form/Report View so you 
can better visualize and modify the form’s appearance; 
does not allow you to add, change, or delete records

linked file Allows source data to be placed in a destina-
tion file that automatically updates when changes are 
made to the source file

Linked Table Manager Aids in redirecting a database 
to the correct linked file if the file was moved, as in a 
removed thumb drive or a file moved to a different 
folder
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lookup field Enables users to select a field value in 
one table by looking up values from another table or by 
selecting values from a list they create.

macro Object that combines a series of steps into a 
single step so a more detailed task can be automated

Mail Merge Word feature used to personalize standard 
letters, envelopes, mailing labels, and other documents 
by combining a main document with a data source

make table query Query that creates a new table 
from the selected data in one or more tables

Merge Formatting Pastes the text and selection with 
any formatting (bold, italic, underline) from the source 
location to the target location and combines it with any 
formatting already at the target location; the selection 
pasted has formats from both the source and target 
locations

Microsoft account Account that gives you access to 
your Microsoft settings, files, contacts, and more, as well 
as to your computer or other devices; can include Bing, 
Hotmail, MSN, Office, OneDrive, Outlook, Skype, Stores, 
or Xbox Live

Microsoft Office 2019 Version of Microsoft Office 
that you purchase one time, for one device, similar to 
what you may have done to obtain software in the past; 
anytime there is a new version of Microsoft Office, you 
need to purchase it if you desire the most recent version 
(select Office Home & Student 2019 to install Office on 
one PC)

multiple item form A form resembling a datasheet 
with data appearing in row and column format

navigation form Form-like interface with tabs across 
the top to group common elements and sub-navigation 
links along the left side or directly below, allowing quick 
access to database forms and reports

Navigation pane Objects panel that lists existing 
database objects (specifically tables, queries, forms, and 
reports)

object A database structure used to store or reference 
data

Object Dependencies panel Allows the display of 
database objects that either use or are used by other 
objects

Office 365 Version of Microsoft Office that has a 
monthly subscription rate for one or more devices that 
offers automatic updates similar to how you make apps 
purchases on your smartphone or tablet

Office Online Version of Microsoft Office that is free 
when you are logged in to a Microsoft account; the 
online apps include Outlook.com, Word Online, Excel 
Online, PowerPoint Online, OneNote Online, and Sway; 
not all features of Office 365/2019 are available in these 
apps

OneNote Notetaking software used to organize notes 
(handwritten or keyed), audio/sound recordings, screen 
captures, or sketches you have collected or created to 
share with others

Outlook Personal information manager software 
used to create, send, and receive emails, record tasks, 
maintain one or more calendars, schedule meetings and 
appointments, manage contacts, and take notes

parameter query Query that filters records and 
returns only a subset that matches the value entered, 
delivering on-the-fly results

Paste Inserts a copy of the most recent item found on 
the Office Clipboard at the target location, or destina-
tion; there are usually at least three paste choices: Keep 
Source Formatting, Merge Formatting, and Keep Text 
Only

Performance Analyzer Analyzes database perfor-
mance to locate and identify potential trouble spots that 
affect how the database functions

PowerPoint Presentation software used to create, edit, 
revise, format, and share slides designed to tell a story, 
market a product, or explain a concept

primary key Unique ID that cannot be the same for 
any two records (e.g., a student ID)

property Field attributes that control features such as 
format, field size, font size, weight, and color; available 
properties depend on the data type

Property Sheet Panel on the right side of a design 
window used to set values for controls, such as font size, 
color, alignment, etc., depending on the type of control

Publisher Desktop publishing software used to design 
and lay out text and images, often for newsletters or 
brochures

query Object used to select, search, sort, and extract 
table data based on criteria and conditions; displays 
results in a row-and-column format

real-time data Data that is updated and shown at 
the speed at which a computer receives and processes 
information
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record Collection of details (fields) about an individual 
person, place, or thing, such as an employee record or a 
product record

record locking Helps maintain consistent data and 
protects the integrity of record updates by creating a 
small temporary file that locks a record being edited by 
another user

record source Field property that connects text boxes 
in a form, subform, or report to a field in an underlying 
table or query

referential integrity Relationship protocol that 
maintains the validity of related data; requires that the 
data types of related primary and foreign key fields are 
the same or compatible

report Database page that presents processed and 
summarized data from tables and queries as meaningful 
information in an easy-to-read format; designed to be 
printed

rich text file (RTF) Variation of a text file that contains 
minimal formatting, such as bold and color

sections The major parts of the form, such as the Form 
Header, Form Footer, Detail, Page Header, and Page 
Footer, that are separated by section bars

SharePoint Secure online location used to store, orga-
nize, collaborate, and share information from any device 
using a web browser

Skype Web communication software that utilizes the 
Internet to share audio, video, text, messages, files, 
or Desktops via a webcam on both the sending and 
receiving devices

smart tags Indicate common actions that may be taken 
if certain conditions are encountered or if a control has 
a problem; clicking a smart tag displays a list of possible 
actions

software suite Collection of applications generally 
produced by the same manufacturer and bundled 
together for a better price that provides a common user 
interface throughout each application

sort Process used to arrange data in a specific order, 
such as alphabetic, numeric, by date, or in ascending or 
descending order

source Original location of text that has been cut or 
copied

split form Two synchronized views of a table data 
in Layout/Form View and Datasheet View, shown 
simultaneously

subform A secondary (child) form placed on a main 
(parent) form, allowing the user to view and complete 
data entries for multiple tables through one form 

subreports Display subsets of data derived from 
related database tables, similar to subforms

switchboard Easy-to-use interface containing 
menus and buttons for opening database objects and 
performing common tasks such as adding records or 
printing reports

tab order Order in which Access moves among form 
fields when you press [Tab] or [Enter]

table File or collection of related records; contains the 
data used in all other database objects

target Destination location for pasted text

text boxes Controls that display the actual data stored 
in a field (e.g., Smith might be the data displayed in a 
LastName text box linked to the LastName field in an 
Employees table)

text file Small alphanumeric text file that lacks 
formatting and font information; compatible across 
virtually all hardware and software platforms

thumbnails Small images that represent an applica-
tion, file, etc.

toggle Selecting a button once to turn it on and again 
to turn it off

update query Query that makes global changes to a 
group of records in one or more tables

validation rule Field property that enables you to limit 
values entered in the field to reduce errors associated 
with data entry (e.g., limit the value typed into an Hours 
Worked field to less than 60)

validation text Contains instructions or valid data 
values to help guide the data entry personnel

wildcard characters Special characters such as an 
asterisk (*) used to represent multiple characters or a 
question mark (?) to represent any single character

Wizard Tool that walks you through the selection and 
ordering of specific fields from the tables or queries that 
contain the data you want to place onto a form, query, 
or report

Word Word-processing software for creating, editing, 
revising, formatting, and sharing documents such as 
letters, reports, essays, and business plans

work area Main part of the screen where you design 
tables, queries, forms, and reports; where you enter data 
into tables and forms
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SYMBOLS
< (input mask symbol), 149
> (input mask symbol), 149
0 (input mask symbol), 149
9 (input mask symbol), 149
* (asterisk) wildcard symbol, 79
- (input mask symbol), 149
, (input mask symbol), 149
; (input mask symbol), 149
: (input mask symbol), 149
! (input mask symbol), 149
? (input mask symbol), 149
. (input mask symbol), 149
“ “ (input mask symbol), 149
/ (input mask symbol), 149
\ (input mask symbol), 149
& (input mask symbol), 149
# (input mask symbol), 149
[ ] open/close brackets wildcard symbol

defined, 79
formatting calculated fields with, 84

? (question mark) wildcard symbol, 79
@ symbol, 146

A
.accdb file extension, 298
Access app

Access window, 22–24
backgrounds, 114
columns, 101
control properties, 50
controls, 105–108
criteria, 77–81
data normalization, 32–33
data sources, 31
dates, 110
Detail section, 50
footers, 109–110
Form Header/Footer sections, 49–51
groups, 103
headers, 109–110
images, 114
input mask properties, 29–30
labels, 47–48
Layout View, 46–48
logos in, 50
purpose of, 3
referential integrity, 32
sections, 51
tab order, 51
text boxes, 47–48

Access app (continued)
themes, 52–53
time in, 110
titles, 109
wildcard characters, 78

Access Options dialog box, 268
Datasheet category, 269
General category, 269–270

action queries, 214–219
append queries, 215–216
delete queries, 218–219
make table queries, 214–215
update queries, 217

aggregate functions, 184
a (input mask symbol), 149
A (input mask symbol), 149
Allow Zero Length property, 147
analyizing databases, 335–336
AND/OR criteria, 79–80
AND parameter condition, 213–214
Append Only property, 147
append queries, 215–216
asterisk (*) wildcard symbol, 79
Attachment data type, 299–301

B
back end, 276
backgrounds, 114
backing up before splitting databases, 

277–278
Backstage view, 5
between (validation rule), 152
bound control reports, 105
Byte format, 144

C
calculated control reports, 105
calculated controls

on subreports, creating, 240–243
positioning, 240–242

calculated fields, 83–85
identifying parts of, 83
properties of, 84–85

calculated query fields
moving data into table from, 214

calculations, adding to Access forms, 184
calculated controls, 185–188
totals, applying in Datasheet Layout 

View, 184–185
Caption field property, 144

Caption property, 143
Cascade Deleted Records option, 218
Cascade Delete option, 134
cascade options, 134–136
Cascade Update option, 134
charts reports, 246
C (input mask symbol), 149
Clipboard, 10–12
columns, 101
columns tables

moving and hiding, 141
width of, 140

Command Button control, 283
command buttons

customizing, 283–285
navigation improvement using, 328–330

compacting databases, 337
compatibility, 2
control properties, 50
controls, 105

adding, 108
aligning, 105–107
changing width of, 107
deleting, 105–107
sizing, 105–107

Control Source property, 238, 240
control tips, adding, 190
ControlTip Text property, 190
Copy feature, in Clipboard, 10
criteria, 77–81

AND/OR criteria, 79–80
date criteria, 80–81
wildcard characters, 78

crosstab queries, 208–210, 210
Current Database options window, 273
current database settings, 273–275
Cut feature, in Clipboard, 10

D
Database Documenter tool, 335
database indexes, 145
database properties, 269–270
databases

Access window, 22–24
creating tables in, 26–27
field properties, 27–30
filtering table data, 30–31
importing data sources, 31
objects in, 22–24
opening, 21
relational, 32–33
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databases (continued)
saving, 21
sorting table data, 30–31
types of, 21

data
field data, 25
table data, filtering and sorting, 30–31

data entry
adding control tips, 190
disabling form fields, 189
locking form fields, 189, 189–190
pop-up form creation, 191–192
setting properties to assist and control, 

189–192
data normalization, 32–33
datasheet effects, 269
Datasheet Layout View, applying totals to 

forms in, 184–185
data sources, 31
date after a date (validation rule), 152
date control reports, 243–244
dates, 78, 80–81, 110
Decimal format, 144
Default Value property, 143
delete queries, 218–219
deleting controls, 105–107
deleting

database objects, 333–334
fields, 139
relationships, 137

Design View, 49–53
adding fields to reports, 105
creating tables in, 27
modifying Form Footer sections, 49–51
modifying Form Header sections, 49–51
modifying reports, 104
tab order, 51
themes, 52–53

Detail section, 50, 102
device compatibility, 2
disabling form fields, 189
documenting

databases, 335–336
relationships, 137–138

Double format, 144
duplicate queries, finding, 211–212

E
Edit Relationships command, 133
Edit Relationships dialog box, 133
encrypting database, using  

passwords, 338–339
equal to (validation rule), 152
Excel

exporting data to Excel, 311–312
fixing broken links, 310–311
importing data from Excel files, 308–309
integrating Access with, 307–312
linking Excel worksheet to Access 

database, 309–310

Excel app, purpose of, 3
Existing Fields tool, 105
exporting objects as web pages, 313
Expression Builder dialog box, 186

F
field property settings tables, 143

captions, 144
default values, 145
entering, 147–148
field size for number fields, 144
formatting data using input masks, 148
memo fields, 146
reasons for setting, 143
required fields, making, 145–146
size of fields, 144
text fields, custom, 146
text fields, uppercase vs. lowercase, 144

fields
adding, 140
adding to reports, 105–108
choosing to include in queries, 76
defined, 25
editing field data types, 139
field data, 25
field properties, 27–30
filtering records by, 55–57
rearranging query fields, 75
selecting from multiple tables, 76–77
sorting records by, 55–57

Field Size property, 143
File Explorer, finding files with, 7
files

finding, 7
opening, 7
printing, 8
saving, 6–7
searching, 7

File tab, 5–9
Backstage view, 5
finding files, 7
opening files, 7
printing files, 8
program options, 6
saving files, 6–7
searching files, 7
templates, 9

filtering
applying filters, 31
Filter by Form command, 56–57
forms, 55–57
records by fields, 55–57
table data, 30–31

Find command, 14–15
find queries, 210–212

find duplicates queries, 211
find unmatched queries, 211

footers, 109–110
foreign (secondary) key tables, 76

Format Painter feature, in Clipboard
formatting multiple controls, 12
overview, 10

Format property, 143
Form Footer sections, 49–51
Form Header sections, 49–51
forms, 43–57. See also Design View

adding control tips, 190
calculated controls, 185–188
calculations, adding to, 184
changing in Layout View, 46–48
creating, 44–46, 53–55
creating multiple item forms, 54
creating split forms, 55
defined, 22
disabling form fields, 189
exploring, 23
exploring property sheets for, 51
filtering, 55–57
filtering and sorting records by  

field, 55–57
locking form fields, 189–190
pop-up form creation, 191–192
properties, setting to assist and control 

data entry, 189–192
subforms, 178–184
totals, applying in Datasheet Layout 

View, 184–185
form titles, 49–50
Form Wizard, 45–46
fragmentation, of databases, 337
front end, 276

G
greater than or equal to (validation  

rule), 152
greater than (validation rule), 152
Group header and footer section  

reports, 102
groups, 103
groups, on Navigation pane, 270–273

H
headers, 46, 109–110
headers, on Access forms,  

modifying, 183–184
Help feature, 15–17
hiding columns, in tables, 141
Home tab, 9–15

Find command, 14–15
Mini toolbar, 13
Replace command, 14–15
Text Formatting group, 12

HTML
importing HTML files, 314–315
saving HTML-formatted  

objects, 313–314
updating HTML data, 313

hyperlinks, adding to database  
object, 315–316
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I
images, 114
importing data, 31
importing reports into database, 233
input mask properties, 29–30, 143
input masks, 148–151

symbols for, 149–150
Input Mask Wizard

overview, 148
using, 150–151

Insert Hyperlink dialog box, 315
Integer format, 144
interface options, 278–286

custom command buttons, 283–285
navigation form, 279–283
startup options to open forms, 285–286
switchboard, 278–279

K
Keep Source Formatting feature, in 

Clipboard, 10
Keep Text Only feature, in Clipboard, 10
key fields, 145

L
labels, 47–48
Layout View, 46–48, 104
less than or equal to (validation rule), 152
less than (validation rule), 152
like (validation rule), 152
limiting results from queries, 81–82
linked files, 301, 306
Linked Table Manager, 310–311
L (input mask symbol), 149
locking form fields, 190
locking records, 276
logos

inserting in forms, 50
inserting in reports, 110

Long Integer format, 144
Long Text field, 147
lookup fields tables, 153–157

benefits of, 153–154
creating for multiple values, 156–157
performing lookups, 154–155
testing, 155

M
.mdb file extension, 298
macros, creating for improving efficiency, 

330–333
Mail Merge, 301
make table queries, 214–215
many-to-many relationships, 132
memo fields, 146
Merge Formatting feature, in Clipboard, 10
merging database objects, 333–334
Microsoft accounts, 4
Microsoft Office 2019, 3
Microsoft Office apps, 1–17

choosing version of, 2–3

devices compatible with, 2
Help feature in, 15–17
Microsoft accounts, 4
overview of, 2–4
Quick Access toolbar in, 4–5
Ribbon in, 4
storage provided by, 2

Mini toolbar, 13
Modal Pop Up, 191
Modeless Pop Up, 191
moving columns, in tables, 141
multiple column formats, 101
multiple item forms, 54
Multiple Items option, 156

N
naming tables, 138–139
navigation form, customizing, 279–283
navigation improvement, using command 

buttons, 328–330
Navigation pane, 22

customizing, 270–273
non-key fields, 145
normalizing data, 32–33
numbering items reports, 238–240

setting properties for, 238
subreports, numbering  

separately, 238–240
numeric & currency criteria, 78

O
objects, 22–24

defined, 22
exploring forms, 23
exploring queries, 24
exploring reports, 24
exploring tables, 22–23

Office 365, 3
Office Online, 2
OLE Object data type, 299
OneNote app, 3
one-to-many relationship, 32, 132
one-to-one relationships, 132
Open command, 338
Open Exclusive command, 338
Open Exclusive Read-Only command, 338
opening database, 21
Open Read Only command, 338
options

current database settings, 273–275
custom command buttons, 283–285
database properties, 269–270
datasheet effects, 269
interface, 278–286
navigation form, 279–283
Navigation pane, 270–273
personal information, 269–270
startup options to open forms, 285–286
switchboard, 278–279

Outlook app, 3

P
page breaks reports, 244
Page Header and Footer section reports, 102
parameter queries, 212–214
Password (input mask symbol), 149
passwords, encrypting database  

using, 338–339
Performance Analyzer tool, 335
personal information, 269–270
pop-up forms, creating, 191–192
PowerPoint app, purpose of, 3
primary key fields, 25
printing

in Office apps in general, 8
relationships, 137–138

Print Preview feature, 8, 243
program options, 6
Property Options smart tag, 150
Property Sheets, for subforms, 181
property sheets

defined, 49
for forms, 51
for sections, 51

Publisher app, 3

Q
queries, 72–85

action queries, 214–219
append queries, 215–216
as source for reports, 101
calculated fields, 83–85
crosstab queries, 208
defined, 22
delete queries, 218–219
exploring, 24
find duplicates queries, 211
find queries, 210–212
find unmatched queries, 211
limiting results from, 81–82
make table queries, 214–215
parameter queries, 212–214
rearranging fields, 75
showing results from, 81–82
sorting results from, 81–82
update queries, 217
using criteria in, 77–81

Query Design view, 74–75
question mark (?) wildcard symbol, 79
Quick Access toolbar, 4–5

R
real-time date, 21
record locking, 276
records

attaching files to, 299–301
defined, 25
entering, 30
filtering by field, 55–57
sorting by field, 55–57
sources, 44

referential integrity, 32
referential integrity requirements, 134
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relational databases, 32–33
data normalization, 32–33
referential integrity, 32

relationships
adding and modifying, 132–136
deleting, 137
Edit Relationships dialog box, 133
referential integrity requirements, 134
relationship cascade options, 134–136
reviewing, 136
types of, 132

Relationships window, 132
renaming

database objects, 333
tables, 138–139

repairing databases, 337
Replace command, 14–15
Replication ID format, 144
Report Header and Footer section  

reports, 102
reports, 100–114

adaptable, using macros to  
display, 331–333

adding background images to, 114
adding date to, 110
adding fields to, 105–108
adding subreports to, 233–236
adding time to, 110
applying multiple column formats to, 101
backgrounds for, 114
basic reports, 100–101
changing width of, 107
charts in, adding, 244–246
controls in, 105
creating from subreports, 236–237
date control, adding, 244
defined, 22
exploring, 24
formatting controls, 111–113
formatting subtitles in, 109–110
formatting titles in, 109
grouping, 103
Header/Footer objects in, 109–110
importing into database, 233
inserting logos, 110
inserting subtitles, 109–110
modifying titles in, 109
numbering items in, 238–240
organization and structure of, 101–104
overview of, 100–101
page breaks in, setting, 243–244
Report Wizard, 103–104
reviewing, 110
sections in, 101–102
setting properties for, 238
sorting, 103
subreports, numbering  

separately, 238–240
themes in, 114

Report Wizard, 104
Required field property, 143, 145

Return feature, 82
Ribbon, 4
Rich text field, 147
rich text files (RTFs), 301
Running Sum property, 238, 240

S
saving databases, 21
saving files, 6–7
saving table layout, 141–142
searching files, 7
sections, 51, 101–102
security of databases, 337–339

encrypting database using  
passwords, 338–339

opening database exclusively, 338
select queries, 72–77

choosing fields to include in, 76
creating using Query Design view, 74–75
designing using multiple tables, 76
selecting fields that appear in multiple 

tables, 76–77
SharePoint, displaying Access data  

on, 312–313
Show Table command, Relationships 

window, 132
Show Table dialog box, 76
sizing

controls, 105–107
text boxes, 47

Skype app, 3
smart tags, 150
sorting

in reports, 103
records by fields, 55–57
results from queries, 81–82
table data, 30–31

source location, of cut data, 10
split forms, 55
splitting databases, 276–278

backing up before, 277–278
database splitter, 276
reasons for, 276
terminology, 276–277

startup options
overriding, 285–286
to open forms, 285–286

storage, 2
subforms, 178–184

creating, 179–180
modifying, 181–184

subreports
creating reports from, 236–237
growing and shrinking, 242–243
numbering separately, 238–240
title for, creating, 236–237

subtitles
formatting, 109–110
inserting in reports, 109–110

summary options, for Access reports, 103
switchboard, customizing, 278–279

Switchboard Manager command button, 279
symbols for input masks, 149–150

T
tables, 19–33. See also queries

adding to, 139
benefits of lookup fields in, 153–154
captions, field property settings, 144
changing layout of, 142–143
creating for multiple values, lookup 

fields in, 156–157
creating in Design View, 27
creating in new databases, 26–27
default values, field property settings, 145
defined, 22
designing queries using multiple tables, 76
entering, field property settings, 147–148
exploring, 22–23
features of, 25
field data types, 25
field property settings, 143–153
field size for number fields, field property 

settings, 144
formatting data using input masks, field 

property settings, 148–151
lookup fields in, 153–157
memo fields, field property settings, 146
moving and hiding, columns in, 141
performing lookups, lookup fields  

in, 154–155
primary key fields, 25
reasons for setting, field property 

settings, 143
required fields, making, field property 

settings, 145–146
saving layout of, 141–142
selecting fields that appear in multiple 

tables, 76–77
size of fields, field property settings, 144
testing lookup fields in, 155
text fields, custom, field property 

settings, 146
text fields, uppercase vs. lowercase, field 

property settings, 144
validation rules, field property  

settings, 152–153
width of, columns in, 140

tab order, 51
target location, of cut data, 10
Tell Me More link, in Help, 16
Tell Me What You Want to Do box,  

in Help, 15
templates, in Office apps in general, 9
Text Align property, 147
text boxes, 46

changing position of, 47–48
sizing, 47

text boxes reports
adding and formatting, 239–240
moving and resizing controls for, 239

text criteria, 78
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text fields, custom, 146
text files, 301
Text Format property, 144, 147
Text Formatting group, 12, 142
themes, 52–53
thumbnails, in Clipboard, 10
time, 110
title bar, 273
titles, 109
Totals feature, 184–185

U
umatched queries, finding, 211
unbound control reports, 105
underscores, in table names, 139
Undo/Redo commands, 4–5
update queries, 217
Update To row, 217

V
Validation Rule property, 143
validation rules tables, 152–153
Validation Text property, 143

W
Web

adding hyperlinks to database  
object, 315–316

displaying Access data on, 312–316
exporting objects as web pages, 313
importing HTML files, 314–315
saving HTML-formatted objects, 313–314
updating HTML data, 313
using SharePoint, 312–313

wildcard characters, 78

Word
copying data from Access to  

Word, 301–304
integrating Access with, 301–307
merging data with Word  

documents, 305–307
overview, 301
publishing data to Word, 304–305

Word app, purpose of, 3
work area, 22

Y
Yes/No data type, 139–140
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