
L E A R N I N G  O B J E C T I V E S

ÝÝ Identify database objects and the functions they 
perform

ÝÝ Identify table features

ÝÝ Create database tables

ÝÝ Identify and choose data types

ÝÝ Sort and filter table records

ÝÝ Import a data source

ÝÝ Establish a relationship between two database 
tables

1 Getting Started with 
Tables

ACCESS

H
ave you ever wondered how 

sportscasters come up with  

fun and interesting facts about 

teams and players in a flash? Have you been 

taken by surprise when a customer service 

agent suddenly begins to recite your name, 

address, and a detailed purchase history? In 

most cases, these people have access to a 

powerful database from which they obtain  

the information. In this chapter, you will  

be introduced to database concepts and  

work with tables, the starting point of all 

databases.
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20 Access Chapter 1: Getting Started with Tables

Ý Project: Creating a Database
Winchester Web Design is a website development company that specializes in building 
websites for small businesses. You have been asked to build a database to help the company 
manage its employee, customer, and sales data. You’ll get started by creating a database and 
building tables and table relationships.

Introducing Databases
It is likely that you routinely interact with databases. If you make an online purchase, your order 
information goes into a database. The database might be used to track your order status, product 
likes and reviews, past orders, or future promotions. If you post or like something on your Facebook 
account, that information is maintained in a database. If you search for or store a telephone number, 
that information is likely kept in a database. It is quite possible you have been using databases 
without even knowing it! Here, you will be introduced to what a database is and gain a better under-
standing of related terms, explore a sample database, and, finally, create your own!

While there are many definitions of a database, you can think of a database as an organized collec-
tion of related data files or tables. For example, a company might organize its information by both 
customers (external to the business) and employees (internal to the business). While the data relate 
to the same business, the types of data provided for customers and employees will likely differ.

Databases are the epicenter of our digital world.
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Introducing Databases 21

Types of Databases
Large organizations typically use large custom-designed databases specifically for that company or 
industry. When you make travel plans, you are using a database that is specific to the airline industry. 
It contains real-time data, meaning that if there is only one seat left on a plane, whoever selects 
and pays for the seat first gets the reservation. If you are a small-business owner, you may use 
predesigned database software such as Microsoft Access to track information about your customers, 
products, and employees. Access provides the tools needed to let small organizations create, use, 
and maintain databases.

Open and Save an Access Database
Each time you start Access, the Backstage view displays options for opening an existing file, creating 
a new blank database, or selecting from a number of prebuilt templates. If you’re creating a new 
database, Access will immediately prompt you to save the file in your desired storage location. You 
must save your file first because the database will constantly update data as it is entered or edited.

DEVELOP YOUR SKILLS: A1-D1

In this exercise, you will open an existing Access database and save it with a new name.

 1.  Start Microsoft Access.

 2.  Browse through the list of templates and then choose Open Other Files near the upper-left 
side of the window.

 3.  Click the Browse  button, navigate to your Access Chapter 1 folder, and double-click 
A1-D1-WinDesign.

The database opens with the database objects shown in the Navigation pane on the left.

 4.  Click Enable Content if the Security Warning bar displays.

The Security Warning appears whenever a database file is opened for the first time. When working 
with the files that correspond to this text you should always click the Enable Content button that 
appears. You should never open files unless you know or trust the file sender.

 5.  Choose File→Save As.

Notice the Save Database As option is already selected in the File Types task pane to the left. This 
allows users to save the entire contents of a database, including any objects, relationships, and 
settings.

 6.  Click Save As to accept Access Database as the file type.

 7.  Replace the 1 at the end of the filename with Rev to make it A1-D1-WinDesignRev and then click 
the Save button.

The database is saved as a Microsoft Access Database file type. This format saves databases as Access 
2007–2019 files with the file extension of .accdb.

 8.  Click Enable Content when the Security Warning bar displays again.

Not only did you save the database with a new name, which creates another file, but you also closed 
the original database and opened the new one, so the Security Warning appears again.

 9.  Keep Access open, as you will continue to use the database to explore the Access environment.

Always leave the database file open at the end of an exercise unless instructed to close it.
 

Note!
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22 Access Chapter 1: Getting Started with Tables

Database Objects and the Access Window
The Access window includes the Ribbon, Navigation pane, and work area. The Navigation pane 
appears along the left side of the window and displays the database objects. A database object is a 
structure used to either store or retrieve data, and the four Access objects are tables, forms, queries, 
and reports. You can open and use database objects from the Navigation pane; you can also create 
new database objects using commands on the Ribbon along the top of the window. Whether you use 
the Ribbon to create a new object or double-click an existing object from within the Navigation pane, 
the object will open in the work area, where you create and modify database objects.

DATABASE OBJECT TYPES

Access Object What It Does
Table Tables contain the database’s data, and they let you enter, edit, delete, or 

view records in a row and column layout that is similar to that used in an 
Excel worksheet.

Form Forms are used to view, edit, delete, and add data to a table one record at 
a time.

Query Queries are used to search for specific table records using criteria and to 
sort and perform calculations on the results.

Report Reports are printable database objects that can display, group, and 
summarize data from tables and/or queries.

View the video “Working with Access Objects.”

DEVELOP YOUR SKILLS: A1-D2

In this exercise, you will open and view the four Access object types.

 1.  Take a moment to explore the Access window, noticing the various tables, forms, queries, and 
reports in the Navigation pane.

 2.  Double-click the Customers table from within the Navigation pane to open the table in the 
work area.

The table opens in Datasheet View by default, which appears similar to a worksheet with columns 
and rows. Datasheet View lets you view, add, and edit table records. One benefit of Datasheet View is 
it lets you see more than one record at a time.

 3.  Click in the first empty Cust ID cell at the bottom of the CustID column.

 4.  Type AdamsA and tap [Tab] to complete the entry and move the insertion point to the next 
field.

Notice the pencil icon highlighted in yellow. This indicates the current record is active and being 
created or edited.

Cust ID is known as a primary key field in this table, so each Cust ID must be unique.

 5.  Type Adams in the Last Name field and tap [Tab].
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Introducing Databases 23

 6.  Enter Anthony as the first name, 23 Pine St as the street address, and Bradenton as  
the city.

 7.  Click the drop-down menu button � in the ST field and choose FL from the list of states.

The ST field is an example that utilizes field properties to make data entry easy and accurate.

 8.  Complete the record as follows, making sure to tap [Tab] after entering the information.

Tapping [Tab] after entering data completes the record, saving it in the database. As you enter the 
telephone number, Access will automatically format the entry for you.
• ZIP: 34210
• Telephone: (941) 555-3648
• Email: AAdams@email.com
• Notes: Call for delivery.

 9.  Choose Home→Views→View menu button � and then choose Design View .

Each object type can be created or edited using Design View. Tables Design View is where fields can 
be added, removed, or edited and field properties can be set.

 10.  Click the View menu button � and choose Datasheet View .

The Anthony Adams record is now the second record in the table. It moved up because the records are 
sorted in ascending order by the data in the Cust ID field.

Explore a Form
Now you will explore a form that is based on the Customers table. Forms help facilitate effective data entry 
by displaying one record at a time.

 11.  Double-click Customers Form in the Forms section of the Navigation pane.

The form displays all fields from the Customers table, but only one record is visible.

 12.  Locate the Record bar at the bottom of the form.

 13.  Click the Next Record  button to view the Anthony Adams record you just entered.

 14.  Click in the Notes box and add the phrase after 10:00 to the end of the note (that is, “Call 
for Delivery after 10:00”).

 15.  Click the Next Record  button again to complete the edit.

This edit has now been saved in the Customers table.

A
C

C
E

S
S

Microsoft Access 2019 & 365: Level 1 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



24 Access Chapter 1: Getting Started with Tables

Explore a Query
Now you will explore a query that is based on the Customers table. Queries choose specific database 
records using criteria that you specify.

 16.  Double-click Customers Query in the Queries section of the Navigation pane.

The query results look like a table displayed in Datasheet View, but the query displays only some of 
the fields from the underlying Customers table and records where the City is equal to Bradenton.

 17.  Click the View menu button � on the Ribbon and choose Design View .

The query has fields from the Customers table and the criterion Bradenton. This is an example of a 
simple query based on a single table. Queries can draw data from multiple tables and can include 
more sophisticated criteria.

 18.  Choose Query Tools→Design→Results→Run  to run the query and display only the 
Bradenton results.

Explore a Report
Now you will explore a report that uses multiple tables, including the Customers table.

 19.  Double-click Invoice Details Report in the Reports section.

Take a moment to scroll through and observe the report.

 20.  Switch to Design View .

The Report design grid may look complicated, but it’s easy to create a robust report using the Access 
Report Wizard. The design grid can then be used to make modifications once the foundation has been 
set with the Wizard.

 21.  Switch to Report View , which is great for viewing reports.

 22.  Follow these steps to display and then close an object:

BA

A  Display the Invoice report by selecting the tab at the far right.

The object type is indicated on each tab by the icon on the left of the tab.

B  Click the Close Object button at the far right to close the object.

 23.  Close the three open objects that remain.

 24.  Choose File→Close to close the database.
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Introducing Tables 25

Introducing Tables
A table is the starting point for entering, finding, and reporting useful information located in your 
database. A database can have separate tables, each tracking different types of data. A business 
might use a table to keep track of customer billing or employee contact information.

Table Features
Data are meaningful units of information such as names, numbers, dates, and descriptions organized for 
reference or analysis. The data stored in the Winchester Web Design database might include customer 
first and last names, business names, telephone numbers, and other important information.

A field is the smallest meaningful unit of information about one person, place, or item. Individually, 
each field represents a piece of data. Together the fields provide information. In most databases 
fields are displayed in columns.

A record is a collection of related fields about a person, place, or item, such as a single customer 
or employee. A collection of related records makes up a table. In most databases records are 
displayed in rows.

Field Record

CustID field and BlaserH record in Customers table

Field Data Types
If you have ever filled out an online form, you might have seen instant formatting of some fields. 
When typing in currency values, the dollar sign and decimal point may appear automatically, and 
when entering a date, the slashes between month, day, and year spontaneously appear. This can be 
accomplished by assigning a data type to the field. A data type sets the characteristics of a particular 
field, identifying the type of values it may hold, such as alphanumeric text or numbers, dates, yes/no 
values, or even a hyperlink.

Primary Key Fields
Almost every database table should have a primary key field. A primary key is a unique identifier 
for each record in the table. Examples of field data that would make good primary keys are Social 
Security numbers, student IDs, and email addresses. Using a student ID as a primary key ensures 
that each student is uniquely identified in a student database table. Two students may have identical 
names, but they will never have identical student ID numbers.

ÝÍ Table Tools→Design→Tools→Primary Key 
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26 Access Chapter 1: Getting Started with Tables

Creating a Table in a New Database
Instead of using a database that someone else has prepared, you can design your own using a blank 
database template in Access. Tables are the starting point for databases, and this shows up when a 
new blank database is first created. The new table has a single primary key field as a starting point 
for the database.

The starting point in a blank database

DEVELOP YOUR SKILLS: A1-D3

In this exercise, you will create a new blank database and add an Invoices table in Datasheet View.

 1.  Choose File→New→Blank Database.

 2. Click Browse Folders  and navigate to your Access Chapter 1 folder.

 3.  In the File Name box at the bottom of the window, enter A1-D3-Datasheet as the filename 
and then click OK.

The browsing window closes. Your new database file is now ready for creation in your chosen location 
using the filename you entered.

 4.  Click the Create button, and a new table will appear.

 5.  Follow these steps to change the name of the ID field and set the data type for a second field:

A B

C

A  Double-click the ID field name and type InvNum as the new name. This will be the primary 
key field.

B  Tap [Tab] to go to the second column and, if necessary, choose Click to Add to display the 
data type list.

C  Choose Date & Time.

Once the data type is selected, the heading for the new field becomes Field1.
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Introducing Tables 27

 6.  Replace Field1 with the name InvDate and tap [Tab] to move to a new field.

Your table currently has a primary key field and one Date/Time field.

 7.  Choose Short Text as the data type for the third field and change the field name to: EmpID

 8.  Tap [Tab], choose Short Text for the fourth field data type, and change the field name to: 
CustID

Your simple table with four fields is now set up and ready for data to be entered.

 9.  Click in the empty InvDate field directly below the InvDate header you just created (you might 
have to click twice) and type: 12/15/2019

 10.  Tap [Tab] and type JFW as the EmpID.

 11.  Tap [Tab] and type SmithW as the CustID.

 12.  Enter the data for the three additional records shown.

As you enter the records notice that the InvNum primary key field is automatically numbered because 
it has an AutoNumber property set.

You cannot enter data into a field that has an AutoNumber property set. Tap [Tab] or use your mouse 
to select the next field. Once you type data into the next field the AutoNumber field will automatically 
populate with the next available number in sequence.

 13.  Choose File→Save or click the Save  button on the Quick Access toolbar and save the table 
with the name: Invoices

 14.  Close  the table.

Creating Tables in Design View
You may find it easier to create a new table in Design View than Datasheet View because Design 
View offers a straightforward layout and intuitive options for entering field names, setting data types, 
adding field descriptions, and setting field properties.

ÝÍ Create→Tables→Table 

Field Properties
Each field data type has numerous properties that can be set to assist with data entry, formatting of 
displayed data, and other useful functions. Some properties contain drop-down menus and built-in 
wizards to help guide the user in setting the property.

Properties are set while working in Design View by using the Field Properties Pane at the bottom of 
the window.

Note!
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28 Access Chapter 1: Getting Started with Tables

The field properties available are always based on the data type for the selected field. For example, a 
field set with the Number data type will include the Decimal Places property while fields set as Short 
Text would not.

View the video “Exploring Field Properties.”

DEVELOP YOUR SKILLS: A1-D4

In this exercise, you will create a new table using Table Design View. Then you will adjust the width of the 
table columns.

 1.  Choose Create→Tables→Table Design .

Access opens an empty table in Design View.

 2.  Type CustID in the Field Name box and tap [Tab].

 3.  Tap [Tab] to accept Short Text as the Data Type.

 4.  Type Customer Last Name and First Initial in the Description field and tap [Tab].

It’s a good idea to use field descriptions when setting up tables to help keep track of the purpose and 
intent of the fields.

 5.  Click in the CustID field and choose Table Tools→Design→Tools→Primary Key .

CustID is now a required field, and each record must have a unique customer ID. Notice the key icon 
next to the CustID field name, indicating it is the primary key field.

Tip!
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Introducing Tables 29

 6.  Click in the empty box below the CustID field and complete the following fields as shown:

 7.  Click anywhere in the CustLastName field, and the Field Properties for that field will display at 
the bottom of the window.

 8.  Change the Field Size property to 25 and enter Last Name as the Caption property.

The field will now accept only last names of up to 25 characters in length. The Caption property will 
make Last Name the label that appears for the field when the table is displayed in Layout View and 
when the table is used in queries, forms, and reports. Good database design requires the actual field 
names follow certain guidelines such as eliminating spaces within the name. The caption lets you 
follow good design principles while having more descriptive labels for fields.

 9.  Change the Field Size and Caption properties for the remaining fields as follows:

Field Name Field Size Caption
CustFirstName 25 First Name

CustStreetAddress 25 Street

CustCity 15 City

CustState 2 State

CustZip 5 ZIP

CustPhone 15 Telephone

CustEmail Email

 10.  Choose File→Save or click Save  on the Quick Access toolbar and save the table as: 
Customers

If you ever forget to save, Access will prompt you to save when you close a table or other object.

Set an Input Mask Property
In the next few steps, you will set an input mask property for the CustPhone field. The input mask will 
automatically format telephone numbers as they are entered, adding parentheses, ( ), around the area 
code and a hyphen, -, between the digits.

 11.  Click anywhere in the CustPhone field and then click in the Input Mask property box.

 12.  Click the Input Mask  button on the right side of the property box to display the Input Mask 
Wizard.

The Input Mask Wizard has several steps that can be used to fine-tune the mask. However, the default 
settings will work just fine.
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30 Access Chapter 1: Getting Started with Tables

 13.  Click Finish to complete the input mask and apply it to the CustPhone field.

 14.  Click the View menu button �, choose Datasheet View , and choose Yes when asked if you 
want to save the table.

Notice the CustID field is still listed as CustID because you did not apply a caption in the preceding 
steps. However, all other fields now display the captions you entered previously.

Enter Records
Notice as you are entering records that the input mask you just created formats the telephone numbers, 
and the email field is automatically formatted as a hyperlink because of the field type setting you made. 
Also, feel free to widen the columns slightly by dragging the double-headed arrow that appears between 
column headings if you need more space to see all the data.

 15.  Enter the following records.

Be sure to check your data entry for accuracy.

 16.  Choose File→Close to close the database.

Sorting and Filtering Table Data
The primary purpose of any database is to locate and retrieve data quickly and efficiently. Sorting 
and filtering table records can help accomplish this goal.

When a table is created the records are automatically sorted using the primary key field. This can be 
changed by applying an ascending or descending sort to other table fields. You can even sort on more 
than one field, so customers could be sorted by last name and then by first name.

ÝÍ Home→Sort & Filter→Ascending  or Descending 

Filtering displays a subset of records. For example, in a customer table you may want to view only 
customer records for customers that live in a specific ZIP code. This is accomplished by applying a 
filter to the ZIP code field.

ÝÍ Home→Sort & Filter→Filter 

DEVELOP YOUR SKILLS: A1-D5

In this exercise, you will sort and filter records in a database for a medical clinic named Raritan Clinic East.

 1.  Open A1-D5-RCE from your Access Chapter 1 folder and save it as: A1-D5-RCERev

 2.  Double-click the Patients table in the Navigation pane to open it in Datasheet View.

The records are sorted in ascending order (smallest to largest) on the Patient ID primary key field. 
Records are always sorted on the primary key field unless a sort is applied to one or more other fields.

 3.  Click any name in the Last Name column and then choose Home→Sort & Filter→Ascending .
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Importing Data Sources 31

Apply a Filter
 4.  Double-click the Raritan Clinic East Doctors table in the Navigation pane.

 5.  Click anywhere in the ZIP column and click the Filter  button.

 6.  Uncheck the Select All box and then check the 34205 box.

 7.  Click OK to apply the filter.

Just two records should now be visible. The remaining records are still in the table but are hidden from 
view because of the filter.

 8.  Close both tables and save the changes.

The sort and filter you applied will be active next time the tables are used.

 9.  Choose File→Close to close the database.

Importing Data Sources
Organizations frequently have data in text files, Excel worksheets, and other formats that needs to 
be imported into a database. It’s easy to import data into Access using the Import & Link tools. Data 
is imported into tables that become part of the database. Excel workbooks are the most common 
source of imported data.

ÝÍ External Data→Import & Link→Excel 

DEVELOP YOUR SKILLS: A1-D6

In this exercise, you will import an Excel worksheet into a new table.

 1.  Open A1-D6-WinDesign from your Access Chapter 1 folder and save it as: 
A1-D6-WinDesignRev

 2.  From the Ribbon, choose External Data→Import & Link→New Data Source  and then 
choose From File→Excel  from the menu.

 3.  Take a moment to examine the options in the first screen of the Get External Data Wizard.

You will leave the how and where option set to Import the Source Data into a New Table in the 
Current Database. Notice the data could also be appended (added) to an existing table if desired.

 4.  Click the Browse button, navigate to your Access Chapter 1 folder and choose A1-D6-
WebContacts, and click Open.

 5.  Click OK to start the import and display the second Wizard screen.

 6.  Check the First Row Contains Column Headings box and click Next to specify the Excel 
column headings as the field names in the new table.

The next Wizard screens let you adjust various settings, including field names and data types. In the 
next step you will change the data type for the email field, changing it to a hyperlink.

 7.  Click in the Email column and click the Data Type menu button �.

 8.  Choose Hyperlink and click Next.

The new Email field hyperlink formatting won’t show up until the import is complete.
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32 Access Chapter 1: Getting Started with Tables

 9.  Click Next again to let Access add a primary key field with autonumbering.

 10.  Name the table Web Contacts and click Finish.

 11.  Choose Close on the final Wizard screen without checking the Save Import Steps box.

The Web Contacts table appears at the bottom of the Tables list in the Navigation pane.

 12.  Double-click the Web Contacts table to open it in Datasheet View.

Notice the hyperlink format is applied to the Email field.

 13.  Adjust the column widths to fit the widest entries in each column by either dragging the column 
head borders or autofitting the columns by double-clicking between two column heads.

 14.  Click Save  on the Quick Access toolbar and close any open tables.

Relational Databases
Early database programs stored data in one large, flat file similar to a worksheet. If a salesperson 
sold merchandise and the same product was sold many times, these databases required the sales-
person to enter the same product description and price for every transaction. Such repetitive data 
entry is time-consuming and bound to cause data errors and inconsistencies.

Relational databases like Access link tables using primary key fields. A good example is linking a 
Salesperson table with a Sales Invoices table. One salesperson might be linked to hundreds of sales 
invoices for which that person received commissions. Once a relationship between the Salesperson 
and Sales Invoices tables is created, all that’s needed to associate an invoice with a salesperson is to 
choose the correct salesperson when creating the invoice. This type of relationship is called a one-
to-many relationship because one salesperson is responsible for many invoices. The other types of 
database relationships are one-to-one and many-to-many, although they are not frequently used.

ÝÍ Database Tools→Relationships→Relationships 

Referential Integrity
Referential integrity is an option that can be chosen when creating a relationship between tables. It 
is a set of rules that prevents changes from being made to fields or records that are related to other 
fields or records. For example, if referential integrity were in effect, then a salesperson could not be 
removed from a database that has invoices assigned to that salesperson. Referential integrity would 
require all the invoices either be removed (not a good idea) or associated with a different salesperson 
before the original salesperson’s record could be deleted. Referential integrity also requires the data 
types of related fields to be the same or compatible.

Data Normalization
A properly designed database organizes tables and fields into their smallest usable units and then 
links them using relationships. This is known as normalization. Normalization eliminates data duplica-
tion, decreases data entry errors and inconsistencies, reduces file size, and streamlines the search for 
necessary information. An example of reducing fields to their smallest usable units would be to use 
separate fields for first name and last name rather than a single name field. If a single name field 
were used, then the database could never be searched or sorted by just last name or first name.
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Relational Databases 33

DEVELOP YOUR SKILLS: A1-D7

In this exercise, you will open the Relationships window, add tables, create a one-to-many relationship 
between the Invoices table and the Employees table, and set referential integrity for the relationship.

 1.  Choose Database Tools→Relationships→Relationships .

 2.  Click the Show Table  button.

 3.  Add the Employees and Invoices tables to the Relationships window by double-clicking them 
from the list.

 4.  Close the Show Table box.

The one-to-many relationship between the EmpID fields is automatically created because it is a 
primary key in the Employees table and a foreign (or secondary) key in the Invoices table. The line 
connecting the tables is called a join line. There’s a 1 on the Employees side of the join line because 
EmpID is the primary key in that table. EmpID is a foreign key in the Invoices table, so it has an 
infinity symbol on that side of the join line. Each employee can have an unlimited number of invoices 
associated with them.

 5.  Click Close  in the Relationships group on the Ribbon and choose Yes to save the relationship.

 6.  Choose File→Close to close the database and then close Access.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A1-R1

Create a Table in Datasheet View
In this exercise, you will create a new database and a table using Datasheet View.

 1.  Start Access and choose Blank Database from the template list.

 2.  Click the Browse Folders  button and save the database to your Access Chapter 1 folder as: 
A1-R1-K4C

 3.  Click the Create button to start a new database.

 4.  Double-click the ID heading and change the text to: StID

This will be the primary key field with autonumbering, so your records will automatically get 
numbered.

 5.  Tap [Tab], choose Short Text as the data type, and change the heading from Field1 to: 
StLName

 6.  Add the following as fields with the Short Text data type: StFName, StAdd, StCity, StST, 
StZIP, StPhone, and StAvail

 7.  Choose File→Save or click Save  on the Quick Access toolbar and save your table as: Staff

 8.  Click the first empty cell in the StLName field and enter the following records using these 
guidelines:

• Use [Tab] to complete entries.

• Enter hyphens in the phone field, as the field is not formatted with an Input Mask.

• Widen the columns as necessary.

• Strive for 100% accuracy when entering data, including spaces between characters and upper-
case and lowercase letters.

StID StLName StFName StAdd StCity StST StZIP StPhone StAvail

1 Bryant Matthew 12 Macintosh St Sarasota FL 34022 941-555-7523 Thursday

2 Earle Kevin 77 Kingfisher Ct Sarasota FL 34024 941-555-1368 Monday

 9.  Choose File→Close to close the database.

REINFORCE YOUR SKILLS: A1-R2

Create a Table in Design View
In this exercise, you will create a new table using Table Design View. Then you will adjust the width of the 
table columns.

 1.  Choose File→New and then choose Blank Database from the template list.

 2.  Click the Browse Folders  button and navigate to your Access Chapter 1 folder. Name the 
database file: A1-R2-K4C

 3.  Click the Create button and then switch to Design View .

 4.  Save the table with the name Children, and the design grid will appear.
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Reinforce Your Skills 35

 5.  Replace the field name ID with ChID and tap [Tab].

Notice the key icon to the left of the Field Name indicating this is a primary key field.

 6.  Change the Data Type to Short Text and tap [Tab].

 7.  Type Last Name and First Initial and tap [Tab] to complete the description.

 8.  Enter the remaining fields using the data types and descriptions shown:

Field Name Data Type Description (Optional)

ChLName Short Text

ChFName Short Text

ChAdd Short Text

ChCity Short Text

ChST Short Text 2-char abbreviation

ChZIP Short Text 5-digit ZIP code

ChPhone Short Text Area code & number

ChBday Date/Time

 9.  Click anywhere in the ChPhone field and then click in the Input Mask property box.

 10.  Click the Input Mask  button on the right side of the Input Mask property box and choose 
Yes if asked to save the table.

 11.  Click Finish to accept the Phone Number input mask and apply it to the ChPhone field.

 12.  Switch to Datasheet View , saving the table if prompted to do so.

 13.  Enter these records, adjusting the column widths as necessary:

ChID ChLName ChFName ChAdd ChCity ChST ChZIP ChPhone ChBday

CregerK Creger Kurt 503 Hillview St Sarasota FL 34022 (941) 555-0245 10/12/2012

LangfordJ Langford James 43 Wisteria Ct Bradenton FL 34209 (941) 555-1098 8/13/2010

 14.  Choose File→Close to close the database, saving the changes if prompted.

REINFORCE YOUR SKILLS: A1-R3

Create, Import, and Sort Tables and Establish Relationships
The staff director of Kids for Change would like you to add two new tables to the database: one that stores 
various community activities and one that stores parent volunteers. You’ll create one of these tables and 
import the other.

 1.  Open A1-R3-K4C from your Access Chapter 1 folder and save it as: A1-R3-K4CRev

The first thing you’ll do is import a worksheet into a table, which will then be linked with other tables 
through relationships.

 2. Choose External Data→Import & Link→New Data Source .

 3.  From the menu that appears, choose From File→Excel .

 4.  Click the Browse button on the first Wizard screen and navigate to your Access Chapter 1 
folder.

 5.  Choose A1-R3-ActivityParticipation and click Open.

 6.  Click OK to import the worksheet into a new table and display the next Wizard screen.

 7.  Click Next again to choose ActivityParticipation as the worksheet to use.

A
C

C
E

S
S

Microsoft Access 2019 & 365: Level 1 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



36 Access Chapter 1: Getting Started with Tables

 8.  Check the First Row Contains Column Headings box and click Next to specify the Excel 
column headings as the field names in the new table.

 9.  Click Next again to accept the data type of the two fields as Short Text.

 10.  Click Next again to let Access add a primary key field.

 11.  Click Finish to accept ActivityParticipation as the table name and then click Close to complete 
the import.

ActivityParticipation should now be in the table list.

Sort the Imported Worksheet
 12.  Double-click the ActivityParticipation table to open it in Datasheet View.

Notice the table is sorted in ascending order by Activity ID.

 13.  Click anywhere in the Child ID column and choose Home→Sort & Filter→Ascending .

The records are now sorted by Child ID to easily see all the activities each child has participated in.

 14.  Close the table and save the changes.

Create Relationships
 15.  Choose Database Tools→Relationships→Relationships .

Notice there is currently a relationship between the Donors and Donations tables.

 16.  Click the Show Table  button.

 17.  Add the Children, ActivityParticipation, and Activities tables and then close the Show Table 
box.

 18.  Drag the Child ID primary key field from the Children table and drop it on the ChildID field in 
the Activity Participation table.

Make sure ChildID appears in both the Table/Query and Related Table/Query lists.

 19.  Check the Enforce Referential Integrity box and then click the Create button to complete the 
relationship.

 20.  Drag the ActID field from the Activities table and drop it on the ActID field in the 
ActivityParticipation table.

 21.  Choose to Enforce Referential Integrity and then click Create.

These relationships will now allow a database user to determine all the activities a particular child has 
participated in and to view the details of those activities.

 22.  Click the Close  button above the relationships and choose Yes to save the relationships.

Add a Table in Design View
 23.  Choose Create→Tables→Table .

 24.  Choose Home→Views→Design View  and save the table as: Volunteers
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Reinforce Your Skills 37

 25.  Follow these guidelines to set up the table and enter a record:

• Use the field names provided in the image.

• Let VolID be the primary key field with autonumbering.

• Set the data type of all fields (except the primary key field) to Short Text.

• Enter the record shown here, including the hyphens in the phone number:

VolID VolLName VolFName VolStreet VolCity VolST VolZIP VolPhone AvailDay

1 Jones Stan 892 South St Sarasota FL 34024 941-555-8929 Tuesday

 26.  Choose File→Close when you are finished, saving the changes if prompted.
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 Apply Your Skills
APPLY YOUR SKILLS: A1-A1

Create a Database and Tables
In this exercise, you will create a new database with two tables.

 1.  Create a new database and save it to your Access Chapter 1 folder as: A1-A1-SunStateU

 2.  Create a new table named Classes using these field names, data types, and captions:

Field Name Data Type Caption

ClassID Short Text (Primary Key)

Department Short Text

ClassNumber Short Text Class Number

SectionNumber Short Text Section Number

RoomNumber Short Text Room Number

StartTime Date/Time Start Time

EndTime Date/Time End Time

CreditHours Number Credit Hours

 3.  Brainstorm and add at least two records to the table and then close the table.

 4.  Create another new table named Professors using these fields and data types and making 
ProfID the primary key field:

Field Name Data Type

ProfID Short Text

ProfLastName Short Text

ProfFirstName Short Text

ProfDept Short Text

ProfRank Short Text

 5.  Brainstorm and add at least two new records to the table and then close the table.

 6.  Choose File→Close to close the database.

APPLY YOUR SKILLS: A1-A2

Import a Table and Establish a Relationship
In this exercise, you will import an Excel worksheet and establish a relationship between the new table and 
an existing table.

 1.  Open A1-A2-Customers from your Access Chapter 1 folder and save it as: 
A1-A2-CustomersRev

 2.  Open the Customers table in Datasheet View.

 3.  Sort the records in Ascending order on the CustZIP field.
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 4.  Widen all columns to fit the widest entry in the columns.

 5.  Close the table, saving the changes.

Import a Worksheet
 6.  Follow these guidelines to import the A1-A2-Invoices workbook in your Access Chapter 1 

folder as a table into the open database:

• Leave all field names and data types as they are in the Wizard.

• Make InvNum the primary key field.

• Use Invoices as the table name.

 7.  Double-click the Invoices table to open it in Datasheet View.

 8.  Sort the table in Ascending order on the EmpID field.

 9.  Close the table, saving the changes.

Establish a Relationship
 10.  Open the Relationships window and create a relationship between the CustID fields in the 

Customers and Invoices tables, enforcing referential integrity.

 11.  Close the Relationships window and save the changes to the relationship.

 12.  Choose File→Close to close the database.

APPLY YOUR SKILLS: A1-A3

Create a Table, Import a Database, and Establish a Relationship
In this exercise, you will create a database to track the courses taught by specific teachers in a nonprofit 
organization.

 1.  Create a new database and save it to your Access Chapter 1 folder as: A1-A3-Teachers

 2.  Follow these guidelines to create the table shown:

• Use the table name, field names, and data as shown.

• Set all data types to Short Text and make TeacherID the primary key field.

• Enter this data:

TeacherID TFirstName TLastName TStatus

Amack Alex Mack Fulltime

Bsmith Brian Smith Parttime

Jjones Jack Jones Parttime

Twatts Tonya Watts Fulltime

 3.  Close the table and save it with the name: Teachers

 4.  Import the A1-A3-Courses workbook (Access Chapter 1 folder) using CourseID as the 
primary key field and naming the table: Courses

 5.  Establish a one-to-many relationship between the TeacherID fields in the Teachers and Courses 
tables and enforce referential integrity.

 6.  Close and save the Relationships window and close the database.
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40 Access Chapter 1: Getting Started with Tables

  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROJECT gRADER: A1-P1

Taylor Games: Create and Import Tables
Taylor Games creates replacement parts for many different games as well as various types of dice. You’ve 
been asked to create a database to manage orders and inventory. It would like you to use the data from a 
spreadsheet that was previously created to manage inventory for various items.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A1_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A1_P1_Start from your Access Chapter 1 folder.

 2. Create a new table named Orders that contains the following fields and criteria:

Field Name Data Type Primary Key Field Size Caption
Order_ID AutoNumber Yes Order #

Order_Date Date & Time Date

SKU Number Double

Item Short Text

Quantity Number

Cost Currency

Total_Cost Currency Total Cost

 3. Import data from an Excel file into a new table using the following guidelines in the Import 
Wizard:

• Choose the A1_P1_Inventory.xlsx Excel workbook from your Access Chapter 1 folder.

• The first row should contain column headings.

• Leave all Field Options set to the default values.

• Use SKU as the primary key.

• Import to a table named: Inventory

 4. Sort the Inventory table data in Ascending order on the Quantity field; then close the table, 
saving the changes.

 5. Create a one-to-many relationship between the SKU fields in the Inventory and Orders tables, 
enforcing referential integrity. Close and save the relationship when you are finished.

 6. Save your database.

• Using eLab: Save it to your Access Chapter 1 folder as A1_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 1 folder as: A1_P1_Submission
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PROJECT gRADER: A1-P2

WebVision: Design a Database and Create Tables
You are the Senior Sales Rep for WebVision, a startup company providing a unique closed-circuit television 
service. You’ve been asked to create an Access database of the most recent orders taken and relate them to 
the sales reps who made the sales.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A1_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A1_P2_Start from your Access Chapter 1 folder.

 2. Create a new table named Sales Reps that contains the following fields and criteria:

Field Name Data Type Primary Key Caption
RepID Short Text Yes Rep ID

LastName Short Text Last Name

FirstName Short Text First Name

SalesTeam Short Text Sales Team

 3. Enter the following data into the Sales Rep table and then close the table, saving the changes, if 
necessary:

Rep_ID LastName FirstName SalesTeam
S101 Franks Bernie North

S102 Edmunds Sally Central

S103 Berry Amy West

S104 Lifestone Ben South

 4. Import data from an Excel file into a new table using the following guidelines in the Import 
Wizard:

• Choose the A1_P2_Orders.xlsx Excel workbook from your Access Chapter 1 folder.

• The first row should contain column headings.

• Leave all Field Options set to the default values.

• Use OrderID as the primary key.

• Import to a table named: Orders

 5. Make the following changes in the Orders table:

• Set the caption for the OrderID field to: Order Number

• Set the caption for the RepID field to: Rep ID

• Sort the data in the Date field in descending order and then close the table, saving the 
changes if necessary.

 6. Create a one-to-many relationship between the RepID fields in the Sales Reps and Orders 
tables, enforcing referential integrity. Close and save the relationship when you are finished.

 7. Save your database.

• Using eLab: Save it to your Access Chapter 1 folder as A1_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 1 folder as: A1_P2_Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A1-E1 That’s the Way I See It
You’ve volunteered to help a nonprofit organization determine how much recyclable material is 
being collected by the five recycling centers in the area. You’ve been tasked with creating a database 
with contact information for the five centers. You will also visit the five centers, gathering information 
on the recyclables they accept and the annual number of metric tons of each that they’ve collected 
each year over the past three years. The annual tonnage information needs to be in a separate table 
that is related to the Centers table. Save your completed database as: A1-E1-Recycle

A1-E2 Be Your Own Boss
Your boss, the owner of Blue Jean Landscaping, has decided to sponsor the Sarasota Service Guild, 
a nonprofit organization created to raise money to help adults with disabilities. It needs a database 
that tracks businesses that donate to the guild and the donations that are made. Create a database 
with tables and fields to track the businesses and the donations they make. Create a relationship 
that can be used to relate businesses to the donations it has made over the past five years. Populate 
your tables with information for two businesses, with each making an annual donation over the past 
five years. Include relevant information about the businesses, including their names, addresses, 
and primary contact information. Include the amount and date of the annual donations. Save your 
completed database as: A1-E2-BJL

A1-E3 Demonstrate Proficiency
Stormy BBQ wants to modernize its business. It has hired you to design and create a database 
for its BBQ restaurant. Use Access to create a database with three tables: one for staff, one for 
menu items, and one for transactions where each transaction lists the menu items on that transac-
tion including the quantity and price of each item. Relate the menu and transactions tables. Enter 
enough data to be able to view and modify the tables as needed. Save your completed database as: 
A1-E3-StormyBBQ
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