
L E A R N I N G  O B J E C T I V E S

ÝÝ Create basic reports using the Report tool

ÝÝ Create reports with the Report Wizard

ÝÝ Change field alignment and size in Layout View

ÝÝ Change field properties

ÝÝ Insert logos and dates

ÝÝ Insert new fields

4 Using Reports to 
Display Information

ACCESS

A
lthough reports can summarize 

data from a single database 

table, they often present specific 

data from multiple tables or from queries 

based on multiple tables. Both forms 

and reports use many of the same tools 

and techniques to organize and present 

information in a readable format. In this 

chapter, you will create reports to organize 

and summarize data into meaningful 

information.
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100 Access Chapter 4: Using Reports to Display Information

Ý Project: Turning Data into Information with Reports
Forms are great for entering data and displaying single records. Most businesses, however, 
want to filter and summarize data, as well as display specific data, such as running totals, in 
a readable format. Winchester Web Design needs a new report to summarize the sales for 
each employee and display sales totals. As its database manager, you have agreed to create a 
report to meet these needs.

Introducing Reports
Because reports are often presented in a readable format and end up as a printout, there are some 
basics that every report should include. Of course, it should be well organized, look professional, and 
be visually appealing. Imagine finding a report on your desk without a date, page numbers, or a title 
that states what it is for. How might this affect the usability and readability of the data?

Most reports should have both a title and a subtitle. The title may simply be the company name. The 
subtitle should state specifically what the report is for, such as Monthly Income or Product List. Every 
report requires a date and should include the page number, even if the report is only one page. Once 
you have a good handle on the who, what, and when, you will be ready to create your first report.

Basic Reports
Use the Report button to instantly create a basic report for a selected table or query. This is the 
easiest way to create a report using all fields from the table or query. Only one table or query can be 
used in a basic report.

ÝÍ Create→Reports→Report 

DEVELOP YOUR SKILLS: A4-D1

In this exercise, you will create and explore a basic report and then apply a multiple column format to that 
report.

 1.  Open A4-D1-WinDesign from your Access Chapter 4 folder and save it as: 
A4-D1-WinDesignRev

Click the Enable Content button, if it appears.

 2.  Choose the Products table in the Navigation pane.

 3.  Choose Create→Reports→Report .

A basic report is displayed in Layout View. In Layout View you can easily move and size report objects.

 4.  Close any boxes that may be open, such as the Property Sheet or Field List pane.

 5.  Choose Home→Views→View menu button �→Report View .

Report View is best when viewing how a report will be presented electronically.
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Report Organization and Structure 101

 6.  Choose Home→Views→View menu button �→Design View .

The report body contains sections populated with text labels and controls that display the date, time, 
and other data and that perform calculations.

 7.  Mouse over the report control tools in the Controls group of the Ribbon, reviewing the ToolTips 
that appear.

Apply Multiple Columns
 8.  Choose Home→Views→View menu button �→Print Preview  to see how your report 

will look when printed.

 9.  Choose Print Preview→Page Layout→Landscape  and then click the Columns  button.

The Page Setup dialog box appears with the Columns tab active.

 10.  Set the Number of Columns property to 2 and the Width property under Column Size to 4.5 
and then click OK.

The report is now formatted to print records into two even columns.

 11.  Click Close Print Preview  on the right side of the Ribbon.

 12.  Choose File→Save or click the Save button on the Quick Access toolbar and save the report as: 
Products

 13.  Close the report.

Report Organization and Structure
Reports can display data from multiple tables and even from queries. Report data must often be grouped 
and sorted so it can be easily analyzed and interpreted. Effective reports turn data into information by 
displaying it in an organized and understandable manner. Queries are often the best data source for 
reports as they can receive data from multiple tables, sort the data, and even include calculated fields.

Sections
Sections provide the structure needed to effectively organize and present information. There are 
several types of sections, with each type used for a specific purpose.
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102 Access Chapter 4: Using Reports to Display Information

REPORT SECTIONS

Section(s) Description
Report Header and Footer Displayed only at the top of the first page and bottom of the last 

page. Some uses include titles, subtitles, and logos.

Page Header and Footer Displayed at the top and bottom of every page. Some uses 
include descriptive labels, page numbers, and dates.

Group Header and Group 
Footer

The group header shows the fields on which report data is 
grouped. For example, grouping by Salesperson might list each 
salesperson and all the transactions that person is responsible for. 
The group footer displays summary information such as the total 
of all transactions for each salesperson.

Detail Main part of the report where the records are displayed. The 
records are typically organized in groups. The detail sections are 
where field headings appear.

The Report Header appears at the top of the report.

This image shows a report in Layout View with the various sections highlighted.

Group headers show the records 
grouped first by employee ID and 
then by invoice number.

Detail sections show headings, records, 
and, in this case, a LineTotal column 
calculated from the underlying query.

Group footers show 
totals for invoice 
numbers 29 and 30.

The group footer for 
employee ID MJW 
adds the group totals 
for all invoices with 
an EmpID of MJW 
(some not shown here).

The Grand Total line appears in the 
report footer and adds all group 
totals (some not shown here).
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Report Organization and Structure 103

Grouping and Sorting
A group is a collection of records that has at least one data element or key field in common. In the 
preceding example, records are grouped first by employee ID MJW and then by invoice numbers 
29 and 30. A group consists of a header, records, and a footer. Grouping helps organize the informa-
tion in meaningful ways. Groups are arranged by level. Each nested group (lower level) will appear 
indented below the group above it (higher level), so you can visualize how groups are prioritized.

Once grouping has been set, summary options become available. Summary options allow users to 
summarize a group with calculated values such as a total, average, maximum, or minimum value. 
These calculations are based on the remaining ungrouped fields whose data contains a numeric value.

It is important that records first be sorted using the same field used for grouping. Otherwise, a new 
group might be created each time the data in the group changes. Sorting can be added in the report; 
however, it’s best to make the sorting occur in the underlying tables or queries.

The Report Wizard
The Report Wizard is a great way to get started with most reports. It lets you choose multiple tables 
or queries, group and sort data, perform calculations, and organize and present the information. The 
Wizard builds the report for you, creating the necessary structure and organization.

View the video “Grouping and Sorting in the Report Wizard.”

ÝÍ Create→Reports→Report Wizard 

DEVELOP YOUR SKILLS: A4-D2

In this exercise, you will create a detailed Invoice report using the Report Wizard.

 1.  Choose the Invoice Details Query Q1 2018 query in the Navigation pane.

 2.  Choose Create→Reports→Report Wizard .

Invoice Details Query Q1 2018 is chosen in the Tables/Queries list because you chose it before starting 
the Report Wizard.

 3.  Double-click the EmpID field to add it to the Selected Fields list or choose it and click the  
Add  button.

 4.  Add the InvNum, InvDate, CustLastName, ProdID, Price, Qty, and LineTotal fields to the 
Selected Fields list.

Do not select CustFirstName and ProdDescription. If you add every field to the report, there won’t 
be enough room to display all the information. Be sure that EmpID is the first field on the list.

 5.  Click Next, and the Wizard will ask if you want to add grouping levels.

 6.  With EmpID still selected, click the Add  button to set EmpID as the first grouping level.

All invoices associated with a particular employee will be grouped together.

 7.  Click Add  once more, this time to make the InvNum field the second grouping level.

The information will first be grouped by employee ID and then within each employee group by invoice 
number.
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104 Access Chapter 4: Using Reports to Display Information

 8.  Click Next, and the sort order and summary information screen will appear.

This is where you can add totals and other calculations and sort the results within groups. The 
underlying query sorts the invoices in ascending order, so it isn’t necessary to add sorting in this report.

 9.  Click the Summary Options button in the lower part of the dialog box.

Price, Qty, and LineTotal are numeric fields, so they can be used to create totals as well as average, 
minimum, or maximum values.

 10.  Check the Sum box for the LineTotal field.

This will sum the invoices associated with each employee ID.

 11.  Leave the other settings as they are and click OK.

 12.  Click Next because sorting isn’t needed.

 13.  Choose Outline for the layout type and Landscape for the orientation.

 14.  Leave the Adjust the Field Width box checked and click Next.

 15.  Name the report Invoice Details Report Q1 2018 and click Finish.

Your report displays in Print Preview, showing invoice totals and summary totals for each employee.

 16.  Take a moment to review the report using the page controls at the bottom of the screen (there should 
be ten pages, including unnecessary extras resulting from the width of the summary totals control).

The Report Wizard provides a great starting point; however, the report needs some formatting and 
layout work.

 17.  Click the Close Print Preview button on the right side of the Ribbon.

The report will display in Design View.
 

Modifying Reports
Reports can be created from scratch using Design View, but the Report Wizard is much easier to use 
and far more efficient. And while the Report Wizard provides a great starting point, it’s often neces-
sary to add, delete, move, or resize fields and to enhance a report in other ways such as adding titles 
and a company logo. These and other enhancements can be done using Layout View or Design View.

Layout View allows controls to be moved and sized while viewing how the report will look when 
printed. Design View gives you a detailed view of the report to allow design changes to individual 
controls, sections, and report structure without affecting the underlying data.

View the video “Modify Reports in Layout View.”

View the video “Modify Reports in Design View.”
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Modifying Reports 105

Controls
Controls determine where field data, titles, headings, images, and other information are precisely 
positioned within report sections. There are three types of controls used in reports.

TYPES OF CONTROLS

Control Type Description
Bound Controls that display data from the table or query

Unbound Objects that enhance the appearance of a report, such as labels, titles, lines, 
and images

Calculated Controls that display calculated fields from queries or that perform 
calculations within the report itself 

Here are the controls available on the Design tab of the Ribbon.

Adding Fields to a Report
Sometimes fields need to be added to an existing report. The Existing Fields tool displays a list of 
tables and their fields. Fields are added to the report in Design View by dragging them from the 
Field List pane into report sections. Adding a field creates a text box control where the field data is 
displayed and a label control that contains the field name. The label can be changed, allowing you to 
be creative with the field names displayed on the report.

ÝÍ Report Design Tools→Design→Tools→Add Existing Fields 

DEVELOP YOUR SKILLS: A4-D3

In this exercise, you will delete unneeded controls, add controls, and rearrange and resize controls to 
produce a more attractive, well-balanced report.

 1.  If necessary, open Invoice Details Report Q1 2018.

 2.  Switch to Layout View .

Layout View lets you easily move controls and adjust their sizes while seeing how the report will look 
when printed.

 3.  Close any open boxes, such as the Property Sheet or Field List pane.
A
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106 Access Chapter 4: Using Reports to Display Information

 4.  Follow these steps to delete and rearrange the invoice number summary controls: 

B

A

C

D

A Click the Summary for ‘InvNum’ control and tap [Delete] to remove it.

B Click the Sum label and then tap or hold the right arrow [¡] to move it across the report 
next to the Total text box.

C With the Sum label still selected, press the [Ctrl] key and click the Total text box. Both con-
trols should be selected.

D Tap the up arrow [£] three times to move the controls up.

This section of the report should now look like this.

 5.  Follow these steps to rearrange the EmpID field controls:

B

A

C

A Scroll down to the Summary for ‘EmpID’ control, click to select it, and then tap [Delete] to 
remove it.

B Scroll down, click the Sum label, and tap the right arrow [¡] multiple times until the Sum 
label aligns with the Sum and Qty controls above it.

C With the Sum label selected, press [Ctrl], click the Total text box, and then tap the up arrow [£] 
three times to move the controls up.
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Modifying Reports 107

 6.  Follow these steps to change the width and alignment of the Price controls:

A

B

A Click any Price label and then press [Ctrl] and click any price text box to select all price 
labels and text boxes.

B Right-click the selected controls and choose Properties at the bottom of the menu.

 7.  Set the Width property to: 0.8

The setting won’t take effect until you tap [Enter] or click in another box.

 8.  Set the Left property to 6.625 and tap [Enter] so you can see the change take effect.

The Left property determines the position from the left side of the page. 

Change the Width of a Control and the Overall Report
Now you will work in Design View as you adjust the width of the page numbering control located in the 
Page Footer section.

 9.  Switch to Design View .

 10.  Click the ="Page" numbering control in the page footer section.

You may need to move the Property Sheet box to be able to see the control. This control determines 
how page numbers appear in the report, including their position within the page footer.

 11.  With the Property Sheet box visible, set the Width property to 2 and tap [Enter] to see the change.

Now you will change a width setting for the entire report.

 12.  Follow these steps to change the report width :

B

A

A Click the Selection Type button in the Property Sheet box and choose Report.

B Set the width to: 9

You are now viewing the properties for the report rather than for individual controls. The overall 
report width will now be 9", although this won’t be readily visible in Design View.
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108 Access Chapter 4: Using Reports to Display Information

Add a Control
Now you will add the Product Description control to the report and reposition it and its label.

 13.  Choose Report Design Tools→Design→Tools→Add Existing Fields .

This tool lets you add new fields to reports.

 14.  Follow these steps to add the ProdDescription field and to move its label:

A

C

B

A Drag the ProdDescription field from the Field List pane between the ProdID and Price fields 
in the Detail section.

B Select the new Description label (it will be hard to see) then right-click the selected label 
and choose Cut from the menu.

C Right-click InvNum Header and choose Paste.

This pastes the field label in the header section. You will move it in the next step.

 15.  Follow these steps to reposition the fields:

A

B

A Drag the Description label between the ProdID and Price labels in InvNum Header.

B Use the arrow keys to position the Description label and ProdDescription field so they are 
left-aligned with each other and roughly centered between the ProdID and Price fields.

 16.  Close the Field List pane and switch to Layout View.

 17.  Click the Save button on the Quick Access toolbar to save your changes.

At this point, the top part of the report should closely match this example. You will continue to 
enhance the appearance of this report.
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Modifying Reports 109

Header and Footer Objects
The Header/Footer group on the Design tab lets you easily add page numbers, titles, the date and 
time, and logos while working in Design View. Logos are especially useful because they can make 
reports look more professional and visually appealing. When a new report is created, a title control 
is generated based on the name of the report, so the Title tool is often used to add subtitles.

DEVELOP YOUR SKILLS: A4-D4

In this exercise, you will enhance the report header by adding a subtitle, logo, and the date and time. You 
will also format these controls.

 1.  Switch to Design View .

The first thing you will do is increase the height of the header area to accommodate a logo and 
subtitle.

 2.  Right-click the Report Header section bar and choose Properties.

 3.  Set the Height property to: 0.9

Format the Title and Subtitle
 4.  Click in the existing title control, Invoice Details Report Q1 2018, and replace the text with: 

Winchester Web Design

 5.  Set these properties for the title control:

Property Setting

Width 3.5

Font Size 22

Text Align Center

Font Weight Bold

 6.  Choose Report Design Tools→Design→Header/Footer→Title .

The report name appears in the new title control, which is placed on top of the existing title.

 7.  Drag the new subtitle control so it is left-aligned with and just below the Winchester Web Design 
title.

 8.  Replace the text in the new subtitle control with: Invoices for Q1 2018
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110 Access Chapter 4: Using Reports to Display Information

 9.  Set these properties for the subtitle control:

Property Setting

Width 3.5

Height 0.35

Special Effect Shadowed

Text Align Center

Font Weight Bold

Insert a Logo
 10.  Choose Report Design Tools→Design→Header/Footer→Logo .

The Insert Picture dialog box opens, prompting you to insert an image file.

 11.  Navigate to your Access Chapter 4 folder, choose WWD-Logo.bmp, and click OK.

Access places the logo in the upper-left corner of the Report Header section.

 12.  Set the Left property of the logo to: 4

The logo moves over to the 4" position.

 13.  Set both the Width and Height properties to: 0.8

Add the Date and Time and Review the Report
 14.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 15.  Follow these steps to insert a date control into the header:

A

B

C

A Choose the mm/dd/yyyy date format (the third format).

B Uncheck the Include Time checkbox.

C Click OK.

The date is inserted at the right edge of the header.

 16.  Switch to Report View and review your report header.
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Modifying Reports 111

Formatting Controls
It is important to ensure that the data values are fully displayed in a report, while at the same time 
taking care not to leave unsightly and unnecessary blank space between columns. To accomplish this, 
you must resize, reposition, and align controls. It is best to adjust controls in Layout View because 
you can see the actual field values while making the adjustments. Multiple controls can be formatted 
simultaneously after you select them. You will need to use the [Ctrl] key when selecting any nonadja-
cent controls.

DEVELOP YOUR SKILLS: A4-D5

In this exercise, you will use both Design View and Layout View to resize, reposition, and align report 
controls.

 1.  Switch to Design View in the Invoice Details Report Q1 2018 report.

 2.  Click the vertical ruler to the left of the InvNum label and text box in InvNum Header, as shown 
here, to select both of them.

You can also click one field and hold down [Ctrl] while clicking the other.

 3.  Tap the up arrow [£] five times to nudge the controls up closer to the InvNum Header.

 4.  Select the remaining controls in the InvNum Header section, as shown here, and tap the up 
arrow [£] five times to nudge them up.

 5.  Position the mouse pointer over the top edge of the Detail section bar until your pointer 
becomes a two-headed arrow.

 6.  Click and drag with the mouse upward until the section bar is just below the controls you moved 
previously.

 7.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 8.  Select the EmpID label and text box in the EmpID Header section.
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112 Access Chapter 4: Using Reports to Display Information

 9.  Set the Top property for these controls to: 0

This will move them up so they are just below the EmpID Header section bar. You can move controls 
by setting properties, using the arrow keys, or dragging. Setting properties is a way to position them 
with precision.

 10.  Click EmpID Header, and it will turn black to indicate it is selected.

 11.  Set the height to: 0.33

Access sometimes changes a precise property value that you type, so don’t worry if your Height 
property differs slightly from 0.33.

 12.  Switch to Layout View.

 13.  Click one of the text boxes in the Description column to select all the fields and then drag left to 
widen the column almost to the ProdID column.

 14.  Select the Last Name boxes and drag left to shorten the boxes as shown.

 15.  Press [Ctrl] and click the Last Name label to select the label with all the text boxes.

In the next step, you will nudge the boxes to the right. Sometimes while moving a group of controls in 
Layout View, the screen scrolls down to the end. If this occurs, just keep nudging until you are finished 
and then scroll back up to the top of the report.

 16.  Tap the right arrow [¡] eight times to nudge the text boxes to the right.

 17.  Select the ProdID label and one of the text boxes below it and then nudge the entire selection 
to the left six times.

 18.  Scroll to the top of the report, click the InvNum text box with 20 in it, and then drag the left 
border to the right to shorten the box as shown.
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Modifying Reports 113

 19.  Tap the left arrow [¢] enough times to position the text box closer to the InvNum label.

 20.  Scroll to the bottom of the report until the Sum controls are visible.

 21.  Use [Ctrl] to select the two Sum text boxes and the Grand Total text box.

 22.  In the Property Sheet, set the Format property to Currency.

When you apply formatting, the fields may no longer fit in the text box. When a value is too large for 
the text box, it fills the box with the # symbol.

 23.  With the controls still selected, press [Ctrl] and click one of the unselected LineTotal text boxes 
in the column so all line total boxes are selected.

 24.  Now drag the right border of one of the controls to the right until the Grand Total is fully visible.

 25.  Switch to Print Preview view to see how your report will look when printed.

 26.  Close Print Preview. Feel free to return to Design View or Layout View to make additional 
adjustments to the report.

 27.  Save the report.
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114 Access Chapter 4: Using Reports to Display Information

Themes
Themes in a report function identically to themes in forms, including any steps taken to apply and 
modify them. Don’t forget that when a theme is applied in any object, the applied theme impacts all 
objects in the database.

ÝÍ Report Design Tools→Design→Themes→Themes 

Backgrounds
Backgrounds are images in a report or form that add a visual element beyond applying a basic back 
color in report sections. Backgrounds appear behind form controls and include additional settings for 
size, alignment, and mode. Using the Background Image command in the Background group on the 
Ribbon allows you to select the image of your choosing to be inserted as a background image.

ÝÍ Report Design Tools→Format→Background→Background Image 

DEVELOP YOUR SKILLS: A4-D6

In this exercise, you will apply a theme and insert a background image into your report.

 1.  Switch to Design View and choose Report Design Tools→Design→Themes→Themes .

 2.  Hover over each theme’s thumbnail and take note of the ToolTips that appear to show the theme 
names, then choose Office theme to apply it to the report.

 3.  Choose Report Design Tools→Format→Background→Background Image  menu 
button �→Browse.

The Insert Picture dialog box appears.

 4.  Navigate to your Access Chapter 4 folder, select the file named WWD-Background.jpg, and 
click OK.

 5.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 6.  If necessary, click the Selection Type button in the Property Sheet box and choose Report.

 7.  Set the Picture Size Mode property to Stretch so the inserted image spans the entire report page 
background.

When setting the property for a background image, be sure to evaluate the size and format of the image 
file being inserted. Smaller images may need to be tiled or stretched to fill the report page.

 8.  Switch to Print Preview to see your finished report.

 9.  Choose File→Close to close the database, saving the changes to your report.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Tip!
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A4-R1

Create and Modify a Report
The president of Kids for Change wants a report that lists financial donations the organization has received 
since its inception, grouped by donor. He also wants to list the amount that Kids for Change is depositing 
into its scholarship fund for local high-school students. In this exercise, you will create a basic donations 
report and create a more customized report. Then you will rearrange, resize, and format controls and also 
add a logo and title.

 1.  Start Access, open A4-R1-K4C from your Access Chapter 4 folder, and save it as: 
A4-R1-K4CRev

 2.  Choose the Donations table in the Navigation pane.

 3.  Choose Create→Reports→Report .

 4.  Take a moment to review the report and then close it, saving it as: Quick Donations List

Create a Report Using the Report Wizard
Now you will create a donations report that is grouped by donor IDs and includes donation totals.

 5.  Choose Donations Query in the Navigation pane and then choose Create→Reports→ 
Report Wizard .

 6.  Add DonorID, DonorLName, DonorFName, DonationDate, and Amount to the Selected 
Fields list and click Next.

The next Wizard screen asks how you want to view your data. This screen appears because the query 
uses two tables and the Wizard wants to know which table will be used for the first grouping level.

 7.  Choose By Donations and click Next.

 8.  Choose DonorID as the grouping field and add it to the grouping area.

 9.  Click Next and then click the Summary Options button.

 10.  Check the Sum box for the Amount field and click OK to add a sum calculation for that field; 
click Next.

 11.  Choose Block for the layout and Landscape for the orientation; click Next to display the final 
Wizard screen.

 12.  Enter Donations Report 2017-2018 as the title and click Finish.

 13.  Review both report pages and then close Print Preview.

You will continue to use this report.
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116 Access Chapter 4: Using Reports to Display Information

Add, Delete, and Edit Report Controls
 14.  In Design View, open the Property Sheet, if necessary.

In the next few steps you will select and format text boxes that display field data and the labels for 
those text boxes. The text boxes are located in the Detail section, while their labels are located in the 
Page Header section.

Labels

Text boxes

 15.  Click the DonorID text box and set the width to: 0.5

 16.  Use [Ctrl] to select the DonorLName and DonorFName text boxes and set the Width property 
to 1 and apply it to both controls.

 17.  Select the Last Name label in the Page Header section and the DonorLName text box in the 
Detail section and set their left properties to: 1.5

 18.  Select the First Name label in the Page Header section and the DonorFName text box in the 
Detail section and set their left properties to: 3

 19.  If necessary, scroll to the right of the report grid to see the other controls. Then set the left  
properties for the controls listed as indicated:

Control Location Left Property

Date label Page Header 5

DonationDate text box Detail 4.5

Amount label Page Header 6.2

 20.  Select the Amount text box in the Detail section and both =Sum(Amount) controls located in 
the DonorID footer and in the report footer.

 21.  Set the width to 1 and the left property to 6 for each of the three controls.

Add a New Field and Format It
 22.  Choose Report Design Tools→Design→Tools→Add Existing Fields  to open the Field 

List pane.

 23.  Drag ScholarFund from the Field List pane and drop it to the right of the Amount text box in the 
Detail section.

The corresponding Scholar Fund label is partly on top of the Amount text box. 

 24.  Click the Scholar Fund label and tap [Delete] to remove it.

Next you will use the Label control tool to insert a new label in the Page Header for the Scholar Fund.

 25.  Choose Report Design Tools→Design→Controls→Label .

 26.  Drag the Page Header section above the ScholarFund text box to create a rectangular label box.

 27.  Type Scholarship into the new label, adjusting the size of the label box as necessary.

 28.  Close the Field List pane and then scroll to the left in the design grid.

 29.  Click the long Summary for “ & ”‘DonorID’… control in the DonorID Footer section.
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Reinforce Your Skills 117

 30.  Tap [Delete] to remove the control.

 31.  Click in the Sum label located in the DonorID Footer and replace the label text Sum with: 
Donor ID Total

 32.  Select the title in the report header section and replace it with: Kids for Change

Add a Logo and a New Title
 33.  Choose Report Design Tools→Design→Header/Footer→Logo , navigate to your Access 

Chapter 4 folder and choose K4C-Logo.bmp, and click OK.

 34.  Set the width and height of the logo to: 0.7

 35.  Drag the logo toward the right side of the header so it is positioned above the Amount fields.

 36.  Choose Report Design Tools→Design→Header/Footer→Title .

 37.  Drag the new title to the left and position it below the Kids for Change title.

 38.  Switch to Report View to see how your report looks and then, if necessary, switch back to 
Design View and make the desired adjustments to your report.

 39.  Close the database, saving the changes to your report.

REINFORCE YOUR SKILLS: A4-R2

Use Controls and Apply a Theme
In this exercise, you will size, align, and format report controls, apply a theme, and add the date to the 
Page Header.

 1.  Open A4-R2-K4C from your Access Chapter 4 folder and save it as: A4-R2-K4CRev

 2.  Double-click the Donations Report 2017-2018.

The report has some alignment problems, and the formatting of controls is inconsistent.

 3.  Switch to Design View and open the Property Sheet, if necessary.

 4.  Select the two titles in the report header section and set these property values:

Property Value

Width 4

Height 0.4

Left 2

Text Align Center

 5.  Press [Ctrl] and click the Donations Report 2017-2018 subtitle to deselect it.

 6.  Set the font size of the Kids for Change title to: 22

 7.  Set the width and height of the logo to: 0.8

 8.  Set the logo’s top property to: 0.05

Be sure to type 0.05 and not 0.5.

 9.  Click the vertical ruler to the left of the controls in the Detail section to select all the controls in 
that section.

 10.  Choose Report Design Tools→Arrange→Sizing & Ordering→Size/Space→Equal 
Horizontal  to evenly space all controls in the Detail section.
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118 Access Chapter 4: Using Reports to Display Information

 11.  Click the Last Name label in the page header and then press [Ctrl] and click the DonorLName 
text box in the Detail section.

 12.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Left  to left-align 
the controls.

 13.  Follow the procedures in the previous two steps to left-align the First Name controls.

 14.  Click the Date label in the page header and drag to center it above the DonationDate text box.

 15.  Select the Donor ID Total label (in the DonorID footer), the Grand Total label (in the report 
footer), and the DonationDate text box (in the Detail section).

 16.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Right  to right-
align the controls.

 17.  Select the Amount text box located in the Detail section and the two =Sum([Amount]) calcu-
lated controls located in the DonorID footer and the report footer.

 18.  Choose Report Design Tools→Arrange→Sizing & Ordering→Align→Right  to right-
align the controls.

Add the Date to the Page Header
Now you will add a date control to the page header section so when viewing the report on a computer, 
readers don’t have to scroll to the very end of the report to check the date.

 19.  Click =Now( ) in the page footer section and tap [Delete] to remove it.

 20.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 21.  Choose the mm/dd/yyyy date format (the third format).

 22.  Uncheck the Include Time checkbox and click OK.

The new date control is inserted on the right-hand side of the Report Header. You may need to move 
the Property Sheet to be able to see the new date box.

 23.  Click the new date control and set these property values:

Property Value

Width 1

Top 0.875

Left 3.5

Text Align Center

 24.  Switch to Print Preview to review the completed report.

 25.  Feel free to return to Design View to make any adjustments you feel are necessary.

 26.  Close the report when you are finished, saving any changes.

Apply Themes to a Report
 27.  Display the Quick Donations List report in Design View.

 28.  Choose Report Design Tools→Design→Themes→Themes  and apply the Integral 
theme.
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 29.  Review the report in Print Preview and, if desired, switch back to Design View to choose 
another theme.

 30.  Save the report and close it when you’re finished.

REINFORCE YOUR SKILLS: A4-R3

Create Reports and Modify Controls
Kids for Change is rapidly expanding, adding new activities and staff members almost daily. To meet the 
organization’s need to match staffers with the new activities, you will create two new reports.

 1.  Open A4-R3-K4C from your Access Chapter 4 folder and save it as: A4-R3-K4CRev

 2.  Select the Activities table in the Navigation pane and then choose Create→Reports→Report .

Access generates a report of Kids for Change’s activities in Layout View. Notice the vertical dotted line 
toward the right side of the report. This is a page break line indicating the report extends beyond a 
standard 8.5" x 11" printed page.

 3.  Click an Activity text box to select the entire Activity column of text boxes.

 4.  Hover the mouse pointer over the right border of one of the text boxes until it is a resize arrow  
and then drag left to reduce the width of the boxes to fit the widest entry in the column.

 5.  Resize the remaining columns to fit the widest entries in the columns.

 6.  Switch to Design View and display the Property Sheet.

 7.  Click the =”Page” control in the page footer and set the width to 1 and the left property to: 6

 8.  Choose Report from the Selection Type list at the top of the Property Sheet box and set the 
width to: 7

Access may change the property, making it greater than 7 to account for any variations in your report. 
Setting this property to 7 adjusts the overall width of the report.

 9.  Select the =Count(*) control in the Report Footer and set the Height property to: 0.25

 10.  Switch to Print Preview.

The report should now fit nicely on one page.

 11.  Close Print Preview and then save the report as Activities Report and close it.

Create a Report Using the Report Wizard
Now you will use the Report Wizard to create a staff availability report to match staffers with specific 
activities. The report will be grouped by activity.

 12.  Click the Staff Schedule query in the Navigation pane and then choose Create→Reports→ 
Report Wizard .

 13.  Add the Activity, Day, MeetTime, StaffLastName, StaffFirstName, StaffPhone, and Hours 
fields to the Selected Fields list.

 14.  Click Next, add Activity as a group, and click Next again.

 15.  Click Next two more times, once to skip the Sort Order and Summary screen and once to accept 
Stepped as the layout.

 16.  Name the report Staff Availability Report and click Finish.
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120 Access Chapter 4: Using Reports to Display Information

Size, Add, Delete, and Edit Report Controls
 17.  Close Print Preview and then display the report in Layout View, opening the Property Sheet if 

necessary.

 18.  Select the Activity label and Activity text box and set the Width property to: 1.2

 19.  Set the properties for both the label and text box controls as indicated:

Label and Text Box Width Property Left Property

Day 0.9 1.5

Meet Time 0.75 2.5

Last Name 0.8 3.3

First Name 0.8 4.2

Telephone 1.1 5.1

Hours 0.4 7

 20.  Switch to Design View and then choose Report Design Tools→Design→Tools→ 
Add Existing Fields  to display the Field List pane.

 21.  Drag the HrlySal field to the right of the StaffPhone text box in the Detail section.

A label control is included with the text box. You will delete the label then add a new label in the Page 
Header section.

 22.  Click the HrlySal label control, which will be on top of the StaffPhone box, and delete it.

 23.  Close the Field List pane and open the Property Sheet.

 24.  Select the HrlySal text box and set the width to 0.55 and the left property to: 6.3

 25.  If necessary, use the arrow keys to nudge the control up or down to align it with the other con-
trols in the Detail section.

 26.  Choose Report Design Tools→Design→Controls→Label  and drag a new label between 
the Telephone and Hrs labels in the Page Header section.

 27.  Type Hrly Sal in the new label, tap [Enter], and then set the width to 0.55 and the left prop-
erty to: 6.3

 28.  If necessary, use the arrow keys to nudge the control up or down to align it with the other con-
trols in the page header section.

 29.  Switch to Print Preview to review your report.

Add a Subtitle and a Logo
 30.  Close Print Preview and switch to Design View.

 31.  Select the title in the report header and replace the text with: Kids for Change

 32.  Set these property values for the Kids for Change title:

Property Value

Width 4

Left 2

Font Size 22

Text Align Center
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 33.  Choose Report Design Tools→Design→Header/Footer→Title  to insert a new title and 
then enter these property values for it:

Property Value

Top 0.46

Width 4

Left 2

Font Size 20

Text Align Center

 34.  Choose Report Design Tools→Design→Header/Footer→Logo  and navigate to your 
Access Chapter 4 folder.

 35.  Choose the K4C-Logo.bmp and click OK to insert it.

 36.  Set the width and height of the logo to: 0.8

Add the Date to the Page Header Section
 37.  Choose =Now() in the page footer and delete it.

 38.  Choose Report Design Tools→Design→Header/Footer→Date and Time .

 39.  Choose the mm/dd/yyyy date format (the third format) and uncheck the Include Time check-
box; click OK.

The new date control is inserted on the right-hand side of the page header.

 40.  Click the new date control and tap the up arrow [£] repeatedly to move it to the top of the 
report header section.

 41.  Drag the left border of the date box to the right to the 6.5" mark on the horizontal ruler.

 42.  Review your report using Print Preview and return to Design View to make any adjustments 
you feel are necessary.

 43.  Save the changes to your report and then close it.

Finalize the Report
 44.  Display Activities Report and take a moment to review it.

 45.  Switch to Design View and choose Report Design Tools→Design→Themes→Themes .

 46.  Choose any theme.

 47.  Choose Report Design Tools→Format→Background→Background Image  and select 
Browse from the menu.

 48.  Navigate to your file storage location, select the file K4C-Background.jpg, and click OK.

 49.  If necessary, choose Report Design Tools→Design→Tools→Property Sheet  to display 
the Property Sheet.

 50.  If necessary, click the Selection Type button in the Property Sheet box and choose Report.

 51.  Set the property for Picture Alignment to Top Right.

 52.  Switch to Print Preview to review the report.

 53.  Close the database, saving the changes to your report.
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 Apply Your Skills
APPLY YOUR SKILLS: A4-A1

Create and Modify Reports
Universal Corporate Events is ready to add reports to its database. In this exercise, you will create two 
reports: The first is a basic report that lists contacts’ telephone numbers; the second lists the event venues 
and their contact information (address, telephone number, and website), grouped by the contact person. 
Then you will add, delete, and edit the venue report controls and also add a logo and title.

 1.  Open A4-A1-UCE from your Access Chapter 4 folder and save it as: A4-A1-UCERev

 2.  Use the Report  tool to create a report based on the Contacts table.

 3.  Save the report as Contacts List and then close it.

Use the Report Wizard and Delete and Edit Report Controls
Now you will use the Report Wizard to create a list of the event venues, including their address, phone 
number, and website, grouped by contact person.

 4.  Choose the Venues table and start the Report Wizard.

 5.  Choose all the fields except VenueID.

 6.  Leave VenueContact as the only grouping level.

 7.  Do not add a sort or change any layout options.

 8.  Name the report Venues List and finish the report.

 9.  Switch to Design View and delete the =Now() control in the page footer.

 10.  Change the VenueContact label in the page header to: Contact

 11.  Change the VenueName label in the page header to: Name of Venue

Add a New Title and a Logo
 12.  Change the Venue List title in the report header to Universal Corporate Events and 

then set these properties for it:

Property Value

Width 4

Height 0.4

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center
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 13.  Insert a new title, leaving the name set as Venue List and setting these properties:

Property Value

Width 4

Height 0.4

Top 0.45

Left 2

Font Name Arial Narrow

Font Size 20

Text Align Center

 14.  Insert UCE-Logo.bmp from your Access Chapter 4 folder into the header.

The logo should be positioned on the left side of the header.

 15.  Set the logo’s width and height properties to: 0.8

 16.  Review your report in Layout View.

The report has layout problems that are addressed in the next exercise.

 17.  Save the report, close it, and close the database.

APPLY YOUR SKILLS: A4-A2

Fine-Tune Reports
The CEO of Universal Corporate Events has sent back the first draft of the Contacts List and Venues List 
with a list of modifications he would like you to make. In this exercise, you will resize, align, and format 
controls on the Venues List report and apply a theme and background image to the Contacts List report.

 1.  Open A4-A2-UCE from your Access Chapter 4 folder and save it as: A4-A2-UCERev

 2.  Display the Venue List report in Layout View.

 3.  Modify the position and width of all columns as necessary so all data is visible.

 4.  Insert a date in the header using the mm/dd/yyyy format and omitting the time.

 5.  Save and then close the report.

Apply a Theme and Insert a Background
 6.  Display the Contacts List report in Design View.

 7.  Apply a theme of your choice to the report.

 8.  Delete the Logo control next to the title in the report header section.

 9.  Insert a background image using the image file UCE-Background.jpg and set the alignment to 
Bottom Right.

 10.  View the report in Report View and make any adjustments you feel are necessary.

 11.  Save and close the report and then close the database.
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APPLY YOUR SKILLS: A4-A3

Create and Modify Reports
Universal Corporate Events is ready to add more reports to its database. In this exercise, you will create 
two reports: a basic report using the Menus table as the record source and a report that lists personnel 
contact information grouped by last name. Then you will add, delete, and edit report controls; modify the 
captions of several labels to make them more readable; and add a logo, title, and subtitle to the venue 
report.

 1.  Open A4-A3-UCE from your Access Chapter 4 folder and save it as: A4-A3-UCERev

 2.  Use the Report  tool to create a report based on the Menus table.

 3.  Save the report as Menus List and close it.

Now you will use the Report Wizard to create a list of the company personnel and their addresses, 
phone numbers, and email addresses. The report will be grouped by last name.

 4.  Choose the Personnel table and start the Report Wizard.

 5.  Add PerLastName, PerFirstName, PerAddress, PerCity, ST, PerZIP, PerPhone, and 
PerEmail to the Selected Fields list.

 6.  Use PerLastName as the only grouping level.

 7.  Do not add a sort and leave the layout default values.

 8.  Name the report Personnel List and finish it.

Modify Controls and Add a New Title, Logo, and Date
 9.  Switch to Design View and delete the =Now() and =”Page” controls in the page footer.

 10.  Change the PerLastName label in the page header to: Last Name

 11.  Change the Personnel List title in the report header to Universal Corporate Events and 
then set these properties for it:

Property Value

Width 4

Height 0.4

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center
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 12.  Insert a new title, leaving the name set as Personnel List and setting these properties:

Property Value

Width 4

Height 0.4

Top 0.5

Left 2

Font Name Arial Narrow

Font Size 22

Text Align Center

 13.  Insert UCE-Logo.bmp from your Access Chapter 4 folder into the header.

The logo should be positioned on the left side of the header.

 14.  Set the logo’s Width and Height to: 0.8

 15.  Insert a date in the header using the mm/dd/yyyy format and do not include the time.

 16.  Move the new Date control to the top-right corner of the report header and shorten its width so 
it doesn’t overlay the title.

Review the Report and Apply a Theme
 17.  Review your report in Layout View.

Some controls, such as Telephone and Email Address, may not be wide enough to display all data. You 
will need to move some columns to the left to create space to allow for the expansion of the Telephone 
and Email Address columns. Remember that an entire column can be selected by clicking the column 
heading and using [Ctrl] to select any box in the column.

 18.  Move and widen columns as necessary so all data is visible, but make sure the Email Address field 
does not go past the vertical dotted page break line.

 19.  Save the report and close it.

 20.  Display the Menus List report in Design View.

 21.  Apply a theme of your choice to the report.

 22.  Review your report in Report View and change the theme if desired.

 23.  Save and close the report.
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  Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

PROjECT gRADER: A4-P1

Taylor Games: Create and Modify a Basic Report
Taylor Games needs a basic inventory report. You will first create the report using the Report command, 
then modify it to improve readability and enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A4_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A4_P1_Start from your Access Chapter 4 folder.

 2. Create a basic report based on the Inventory table.

 3. Set the following properties for the Total Cost Total control located at the bottom of the report:

Property Value

Format Currency

Height 0.25

Font Weight Bold

 4. Delete the Logo, Date, and Time controls from the Report Header.

 5. Insert a Date and Time control in the report header and set properties for it as follows:

Property Value

Date Format Any

Time Format None

Width 4

Text Align Center

 6. Format the Title control (contains the title Inventory) in the Report Header as follows:

Property Value

Width 6.25

Font Size 26

Text Align Center

Font Weight Bold
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 7. Insert a background image and set properties for it as follows:

Property Value

Picture Use Taylor Games BG.png from your Access Chapter 4 folder.

Picture Alignment Bottom Right

Picture Size Mode Stretch

Hint: Set the Property Sheet’s selection type to Report to access the needed properties.

 8. Apply the Facet theme (the second theme in the Office category).

 9. Save the report as Inventory and then close it.

 10. Save your database.

• Using eLab: Save it to your Access Chapter 4 folder as A4_P1_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 4 folder as: A4_P1_Submission

PROjECT gRADER: A4-P2

WebVision: Work with Reports
WebVision would like a report that displays the sales orders for each sales team. You will first create the 
report using the Report Wizard and then modify it to improve readability and enhance its appearance.

 1. Download and open your Project Grader starting file.

• Using eLab: Download A4_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A4_P2_Start from your Access Chapter 4 folder.

 2. Create a new report using the Report Wizard and these guidelines:

• Add the SalesTeam field from the Sales Reps table.

• Add the OrderID, Date, and Amount fields from the Orders table.

• View the data by Orders.

• Add SalesTeam as the only grouping level.

• Sort by Date in descending order.

• Add summary options that include a Sum calculation on the Amount field and show Detail 
and Summary.

• Use Outline layout.

• Set the Orientation to Landscape.

• Use Orders by Region as the title.

 3. Delete the Summary for Sales Team control.
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 4. Set the following properties for the SalesTeam label:

Property Value

Caption Sales Team (add a space to the current caption)

Font Size 14

Font Weight Bold

 5. Set the Page Header section height to: 0.25

 6. Move the SalesTeam label into the Page Header section. Move only the label (not the Sales 
Team text box).

 7. Set the following properties for the SalesTeam text box:

Property Value

Width 1

Top 0

Left 0

Font Size 12

Font Weight Semi-Bold

 8. Insert the LastName field from the Sales Reps table into the SalesTeam Header section.

 9. Delete the LastName label control.

 10. Set these properties for the LastName text box:

Property Value

Top 0.2

Left 1

Border Style Transparent

Font Weight Bold

 11. Set the Date text box Width property (located in the Detail section) to 1 and the Text Align prop-
erty to Left.
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 12. Set the Date label Left property to: 0.5

 13. Set the Sum label Left property to 3 and Font Weight property to Semi-Bold.

 14. Set the following properties for the Grand Total label:

Property Value

Width 1

Left 2.5

Font Weight Semi-Bold

 15. Set the following properties for both the Sum of Amount text box and the Amount Grand Total 
Sum (Sum) text box:

Property Value

Border Style Transparent

Font Weight Bold

 16. Delete the Title control (Orders by Region) from the report header and insert a new Title control 
using the following properties:

Property Value

Width 2

Height 0.35

Font Weight Bold

 17. Insert WebVision Logo.jpg from your Access Chapter 4 folder and set the Width property 
to: 1.75

 18. Save and close the report.

 19. Save your database.

• Using eLab: Save it to your Access Chapter 4 folder as A4_P2_eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 4 folder as: A4_P2_Submission   
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A4-E1 That’s the Way I See It
You’ve been asked to create a sales report for Blue Jean Landscaping that shows the total amount of 
sales by equipment type, drawing the information from sales invoices. Open A4-E1-BJL and save it 
as: A4-E1-BJLRev

Create a well-designed report header with a title and logo (use BJL-Logo.bmp). Make sure all infor-
mation is visible and that the report is easy to read and understand. The date and page numbering 
should appear at either the top or bottom of the report. Save your report as: Equipment Sales

A4-E2 Be Your Own Boss
Blue Jean Landscaping has asked you to add reports to its company database that provide listings 
of its equipment, services, and customers in an attractive and useful manner. Open A4-E2-BJL and 
save it as: A4-E2-BJLRev

Use the Store Inventory query as a record source to create a report that is grouped by manufacturer 
and includes item name, price, quantity in stock, inventory amount, and a sum of the InvTot field. Use 
the default layout settings. Use the skills you learned in this chapter to size, rearrange, and format 
the report controls. Create a well-designed report header with a title and logo (use BJL-Logo.bmp). 
Name the report: Store Inventory Report

Create another report using the Service Invoices Query that includes all fields except InvNum. 
Group the results by InvDate and sum the LineTotal field. Choose the Stepped and Landscape layout 
options and use Service Invoices Report as the report name. Format the report controls 
and create the same consistent header with a logo, title, and subtitle as in the Store Inventory 
Report. Add the background image BJL-Background.jpg that is aligned bottom left to the report.

A4-E3 Demonstrate Proficiency
You’ve been asked by Stormy BBQ to prepare a Manufacturer Stock Level report that shows the 
total number of items in stock for each manufacturer. Open A4-E3-StormyBBQ and save it as: 
A4-E3-StormyBBQ-Rev

Locate the table or query in the database that will provide the data you need and use all fields from 
that table or query. Organize the report so the total stock for each manufacturer is displayed. Create 
a well-designed report header with a title and logo (SBQ-Logo.bmp). Make sure all information is 
visible and the report is easy to read and understand. The date and page numbering should appear 
at either the top or bottom of the report. Save your report as: Manufacturer Stock Levels
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