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ÝÝ Create a form that contains a subform

ÝÝ Add a calculated control to a form

ÝÝ Add a total row to a form

ÝÝ Disable form fields

ÝÝ Lock form fields

ÝÝ Add ScreenTips to forms

ÝÝ Create pop-up forms

6 Customizing Input 
Forms

ACCESS

R
elational database design often 

requires data from more than 

one table or query to appear 

on the same form. Customizing forms and 

their controls while applying other form 

settings gives designers more control while 

simultaneously making forms more efficient 

and easier to use. In this chapter, you will 

add a subform to a main form, which is a 

handy technique used to include data from a 

different source. You will also explore Access 

features to create calculated fields, add tips 

to form controls, and set control properties 

to protect and limit data entry.
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178 Access Chapter 6: Customizing Input Forms

Ý Project: Formatting Functional Forms
Winchester Web Design has seen sales increase over recent months and wants to simplify 
data entry as a result. You’ve been asked to design advanced forms to make data entry easier 
for all team members and less prone to errors. You will create an invoice form that contains a 
subform containing invoice details. Your form will also contain a calculated field for creating 
totals, and you will use form features to enhance data entry. The database relationships will be 
critical for setting up these forms.

Subforms
Although many forms are designed to enter data into a single table, there are times when you 
may need forms that perform actions such as processing customer invoices, calculating totals, and 
locating data from multiple tables. One of the best ways to accomplish this is through a subform, 
which is a secondary form placed on a main form. Subforms work well when one-to-many relation-
ships are set, allowing the user to work with multiple tables on a single form. Subforms are simply 
subsets of data linked by parent fields on the main form to child fields on the subform.

The detail data from related tables appears in a subform.

A main form displaying customer and employee information
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Creating Subforms
The easiest way to create a subform is to use the Form Wizard, which creates a new form with an 
option to add a subform. Subforms can also be added to existing forms by placing a Subform control 
on the existing form, where you can specify the subform’s position and size. When the Subform 
control is added to the form, the Subform Wizard launches, allowing you to set subform properties.

View the Video “Creating Subforms with the Form Wizard.”

ÝÍ Create→Forms→Form Wizard 

ÝÍ Design→Controls→Subform 

DEVELOP YOUR SKILLS: A6-D1

In this exercise, you will use the Form Wizard to create an invoice form that contains an invoice details 
subform.

 1.  Open A6-D1-WinDesign from your Access Chapter 6 folder and save it as: 
A6-D1-WinDesignRev

 2.  Choose Create→Forms→Form Wizard .

 3.  Choose Table: Invoices from the Tables/Queries list and then add the InvNum and CustID 
fields to the Selected Fields list.

 4.  Add the fields indicated to the Selected Fields list, making sure to add them in the order shown:

Customers Invoices Employees InvoiceDetails Products InvoiceDetails
CustLastName InvDate EmpID ProdID ProdDescription Qty

CustFirstName EmpLastName Price

CustStreetAddress EmpFirstName

CustCity

CustState

CustZIP

CustPhone

CustEmail

 5.  Click Next and notice that the data is arranged by invoice number and the Form with 
Subform(s) option is already chosen.

The subform preview in the Wizard includes the ProdID, ProdDescription, Price, and Qty fields.

 6.  Click Next to accept the settings; click Next again to accept the Datasheet subform layout.
A
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180 Access Chapter 6: Customizing Input Forms

 7.  In the final Wizard screen, name the form Customer Invoices and the subform 
Customer InvoiceDetails Subform and then click Finish.

The new form and subform display in Form View.

 8.  Double-click the right border of each subform column heading to autofit the columns.

 9.  Click the empty ProdID cell in the new row at the bottom of the subform.

 10.  Click the drop-down menu button � and choose 03BL.

It’s easy to populate the first three fields of the new subform record.

 11.  Enter 1 in the Qty column and tap [Tab] to complete the record.
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Modifying Subforms
When you use the Form Wizard to create a subform, Access creates the subform and a main form 
with the subform embedded within it. Both are displayed in the Navigation pane. You can then open 
and modify the subform by itself in Layout View or Design View, or you can open the main form and 
modify it and the embedded subform together.

The Customer InvoiceDetails Subform and the Customer Invoices 
main form are displayed in the Navigation pane.

Subforms and their controls have their own Property Sheets that allow you to precisely control the 
subform layout and design. And you can use the same keystroke and mouse techniques to arrange 
and size subform controls that you use with main forms.

DEVELOP YOUR SKILLS: A6-D2

In this exercise, you will modify the Customer Invoices form and subform by deleting, moving, and sizing 
controls, and adding a graphic to the form.

 1.  Switch to Layout View.

You will begin by modifying the layout and controls on the main form.

 2.  Click the ST label in the main form to select it and then click inside the label and change it to: 
State

 3.  Change the ZIP label to: Zip

 4.  Locate the EmpID label and notice the Last Name and First Name labels below it.

 5.  Change the employee Last Name label to Emp Last Name and the employee First Name 
label to: Emp First Name

 6.  If necessary, display the Property Sheet by choosing Form Layout Tools→Design→Tools→ 
Property Sheet .

As you select and move controls in the following steps, you may need to drag the Property Sheet out 
of the way or close and reopen it as needed.

You can also tap [F4] to toggle the Property Sheet open and closed.Tip!
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182 Access Chapter 6: Customizing Input Forms

 7.  Select the text boxes shown here by holding [Ctrl] while clicking the boxes and then set the 
Width property to: 1

 8. Select the text boxes shown here and set the Width property to: 2

Modify, Lay Out, and Size Controls on the Subform
 9.  Select the CustomerInvoiceDetails label on the subform and tap [Delete].

 10.  Click the right border of the subform frame and drag left until the frame is slightly wider than 
the subform.
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Subforms 183

 11.  With the subform frame still selected, use the left arrow [¢] key to nudge the subform to the left 
to align it with the main form labels.

Modify the Form Header
In the next few steps, you will modify the form title and add color and a logo to the header.

 12.  Use these guidelines to modify the form:
• Click the title box control to select it and then click just in front of Invoices and press 
[Shift]+[Enter] to move Invoices to a new line.

• Set the Width property to: 3
• Replace Customer with: Winchester Web Design
• Select both lines and choose Home→Text Formatting→Center  to center the title in  

the box.

 13.  Click to the right of the title box in an empty part of the form header.

The title box will become deselected when you select the form header.

 14.  If necessary, display the Property Sheet and click in the Back Color property box.

 15.  Click the Build  button and choose a light blue color or whatever color you feel looks best in 
the form header.

 16.  Choose Form Layout Tools→Design→Header/Footer→Logo .

 17.  Navigate to your Access Chapter 6 folder, choose WWD-Logo.bmp, and click OK.

 18.  Set the Width and Height properties to 0.8 and the Left property to: 4
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184 Access Chapter 6: Customizing Input Forms

 19.  Review your completed form and then close it, saving the changes to both the form and subform.

 

Adding Calculations to Forms
There are several ways to add calculations to forms, and the easiest way is to build a form based on a 
query that already has a calculated field. If your form is based on one or more tables or is based on 
a query without a calculated field, you will need to create a calculated control by adding an unbound 
control to the form and placing a formula within the control source property.

Applying Totals to Forms in Datasheet Layout
The Form Wizard has an option for creating a form in Datasheet Layout View. A form in Datasheet 
Layout View looks just like a table in Datasheet View. The Totals feature is available for tables in 
Datasheet View and for forms in Datasheet Layout View. The Totals feature lets you easily use 
an aggregate function such as count, sum, or average to create totals for numeric fields in the 
datasheet.

ÝÍ Home→Records→Totals 
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Adding Calculations to Forms 185

DEVELOP YOUR SKILLS: A6-D3

In this exercise, you will create a form that uses the Totals feature to count the number of individual line 
items on customer invoices and to total the amounts of all invoices.

 1.  Choose Invoices Query in the Navigation pane and then choose Create→Forms→ 
Form Wizard .

 2.  Move all fields to the Selected Fields list and click Next.

 3.  Choose Datasheet as the layout and click Next.

 4.  Name the new form Invoices Query Form and click Finish.

The form looks like a table when displayed in Datasheet View.

 5.  Choose Home→Records→Totals .

A Total line appears at the bottom of the datasheet layout.

 6.  Click in the Qty cell on the Total row.

A menu button appears at the left end of the cell.

 7.  Click the menu button � and choose Count, then click in the LineTotal cell and choose Sum 
from the menu.

The Count function simply counts the number of rows containing a quantity while the Sum function 
adds all line totals in the column.

 8.  Scroll through the datasheet’s 125 rows and notice that the Total row remains fixed at the 
bottom of the window.

The Totals feature is an easy way to use aggregate functions and is available in forms and in tables 
and queries.

 9.  Close the Invoices Query Form, saving the changes if prompted.

Creating Calculated Controls in Forms
The Totals feature is useful when you want to create totals for all records in a datasheet. But some-
times it’s necessary to display calculations in Form View, which displays just a single record at a time. 
You can do this by inserting a calculated control. A calculated control is an unbound text box control 
placed on the form with a formula inserted in the Control Source property. Usually, the formula 
references other controls on the form that are bound to underlying database fields. For example, you 
would use the formula =Price*Qty to display the total amount of a transaction, with both the Price 
and Qty fields shown on the form. Calculated controls can also contain aggregate functions or an 
array of built-in functions and expressions made available by using the Expression Builder.
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186 Access Chapter 6: Customizing Input Forms

The Expression Builder dialog box contains a list of available fields in the current object and a selection of 
built-in operators, functions, and expressions that can be leveraged by both novice and advanced users.

View the Video “Calculated Controls in Forms.”

DEVELOP YOUR SKILLS: A6-D4

In this exercise, you will add a calculated control to the Customer InvoiceDetails subform.

 1.  Display the Customer InvoiceDetails subform in Design View.

The first step is to insert a new control.

 2.  Position the mouse pointer on the top edge of the Form Footer section bar until the resize 
pointer appears and then drag down slightly to make room for two new text boxes.

 3.  Choose Format Design Tools→Design→Controls→Text Box .
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Adding Calculations to Forms 187

 4.  Click just below the Qty control text box to insert a new control.

 5.  Use the arrow keys as needed to nudge the control so it is aligned with the Qty control.

Create Formulas
 6.  If necessary, choose Format Design Tools→Design→Tools→Property Sheet to display the 

Property Sheet.

 7.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Tax

Control Source =(Price*Qty)*.07

Format Currency

Decimal Places 2

Notice that the text for Price and Qty are now surrounded by brackets, which indicates that these are 
fields.

 8.  Click the Text8 label on the subform and set these properties:

Property Value

Caption Tax

Width 0.25

Left 0.25

 9.  Choose Format Design Tools→Design→Controls→Text Box .

 10.  Click just below the Tax control text box to insert a new control.

 11.  Use the arrow keys as needed to align the control with the Tax and Qty controls above it.

 12.  Click the All tab in the Property Sheet box and set these properties:

Property Value

Name Line Total

Format Currency

Decimal Places 2

 13.  Click the Control Source property and then click the Build  button to the far right.

The Expression Builder dialog box appears.
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188 Access Chapter 6: Customizing Input Forms

 14.  Follow these steps to create a calculated control with the Expression Builder:

C

A

D

E

B

A Scroll the Expression Categories pane until the Tax control is visible.

B Double-click the Price control to enter the field into the formula.

C Tap (*) and then double-click the Qty control.

D Tap (+) and then double-click the Tax control.

E Ensure your formula matches the example and then click OK.

 15.  Click the Text10 label on the subform and set these properties:

Property Value

Caption Invoice Total

Width 1

Left 0.25

 16.  Switch to Form View to see your new calculated controls in action.

 17.  Navigate to record 16 and others for which the quantity is greater than 1 and notice that your 
calculated controls always perform the correct calculations.

 18.  Close and save the form.
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Setting Properties to Assist and Control Data Entry  189

Setting Properties to Assist and Control  
Data Entry

Some properties are meant to assist with data entry, while others help control or limit it. These 
properties are easily set using the Property Sheet.

Disabling Form Fields
Sometimes a form may include data that users should not enter themselves or even access, for 
example, setting up passwords or entering Social Security numbers. Many forms also contain settings 
that enter default values, such as states, or values that correspond to data contained in another field, 
such as city and ZIP code fields. To protect a field on a form from being edited during data entry, 
you can disable the field in the Property Sheet. Disabled fields are unavailable for data entry; they’re 
still visible, but they appear grayed out and are not accessible to the user. During data entry, Access 
automatically skips a disabled field and moves directly to the next enabled and accessible field. To 
disable a field, just set the Enabled property to No.

Locking Form Fields
Another way to protect fields from being edited is to lock them. Locked fields remain available on the 
form and appear as normal; this allows users to click in the field, but they cannot change the data. 
Locked fields improve readability when a form is printed versus disabled fields, which appear grayed 
out and print faintly. To lock a field, set the Locked property to Yes.

DEVELOP YOUR SKILLS: A6-D5

In this exercise, you will disable the InvNum field in the Customer Invoices form and the LineTotal field in 
the Customer InvoiceDetails subform. In addition, you will lock the Price field in the subform so it cannot 
be edited.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box on the main form and then click the Data tab on the Property Sheet.

 3.  Disable the text box by changing the Enabled property to No.

 4.  Click anywhere on the subform to make it active and then click the ProdID text box.

 5.  Disable the ProdID text box.

 6.  Click the Price text box in the subform and set the Locked property to Yes.
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Test the Property Settings
 7.  Switch to Form View and try clicking in the disabled InvNum field.

The field is grayed out, and you can’t click in it.

 8.  Try clicking in any of the cells of the disabled ProdID field in the subform.

In the subform, only the data appears grayed out, but you still cannot click in the field.

 9.  Click in any Price field in the subform and try changing the number.

Locking allows users to select a field, but the data cannot be changed.
 

Adding Control Tips
When you create a table and define fields, you can enter field details in the Description column. 
These field descriptions appear in the status bar when the fields are active during data entry. They 
also appear in the status bar when a field appears on a form. Although forms identify most fields 
with control labels, sometimes labels for specific fields, such as State and ZIP, are removed from a 
form when the controls are grouped under a more general label such as Address.

To help data entry personnel determine what data to type in a field, you can add descriptive messages 
to display onscreen by setting the ControlTip Text property for a control. ControlTips appear when 
the user points to the control. Setting control tips helps to provide explanations for controls.

DEVELOP YOUR SKILLS: A6-D6

In this exercise, you will create control tips for the disabled and locked fields on the Customer Invoices 
form to explain why they are inaccessible.

 1.  Display the Customer Invoices form in Design View.

 2.  Click the InvNum text box and then click the Other tab on the Property Sheet.

 3.  Click in the ControlTip Text property text box and type: Invoice numbers are 
assigned automatically and cannot be changed.

 4.  Enter these control tips for the subform controls:

ProdID text box Product IDs are assigned by supervisors and cannot 
be edited.

Price text box Product prices cannot be changed.

 5.  Save the changes to the form.

 6.  Switch to Form View and point to the InvNum field to display the control tip.

 7.  Point to the ProdID and Price fields in the subform and notice the control tips do not appear.

Control tips display only in Form View. The subform is currently displayed in Datasheet View, so the 
tips don’t show.

 8.  Open the Customer InvoiceDetails Subform in Form View and point to the ProdID and Price 
controls to display the control tips.

 9.  Close the Customer InvoiceDetails Subform.

Leave the Customer Invoices form open.
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Creating a Pop-Up Form
Forms and reports can be set to open in pop-up windows that stay on top of other open database 
objects. Pop-up forms can prompt a user for information or display a window containing supple-
mental data. Such forms and reports can help data entry personnel look up values while processing 
orders or looking up item prices. You can apply different formats to pop-up forms.

POP-UP WINDOW MODES

Mode Description
Modal Pop Up Displays a custom dialog box that prevents access to other database 

objects until the dialog box is closed or its required actions are taken

Example: If you choose to print a report and have the Print dialog box 
open, you cannot make changes to the report until you click OK or Cancel 
in the dialog box.

Modeless Pop Up Creates a pop-up window that sits on top of other open windows in such a 
way that users cannot work in the database while it is open

Example: When processing orders, you could set the Inventory List to 
open as a modeless pop-up form to ensure you have the correct inventory 
number.

DEVELOP YOUR SKILLS: A6-D7

In this exercise, you will create and test a pop-up form using the Winchester Web Design Products table.

 1.  Select the Pop Up Products table from the Navigation pane.

 2.  Choose Create→Forms→Form Wizard .

 3.  Add all three fields to the Selected Fields list, choose Datasheet Layout, and name the form: 
Pop Up Products List

 4.  Switch to Design View and choose Form Design Tools→Design→Tools→Property Sheet .

 5.  If necessary, choose Form from the Selection Type list and 
then click the Other tab and set the Pop Up property to Yes.

 6.  Switch to Datasheet View and double-click the right border 
of each column heading to autofit the columns.

 7.  Resize the window using the sizing handle until it just encloses 
the datasheet.

You may need to reposition the form first by dragging the title bar 
until you can see the frame borders.

A
C

C
E

S
S

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



192 Access Chapter 6: Customizing Input Forms

 8.  Position the pop-up form in a location where all fields in the Customer Invoices form remain 
visible.

 9.  Use the Navigation bar at the bottom of the Customer Invoices form to navigate through the 
records.

Notice the pop-up form remains available and in place.

 10.  Close the database, saving the changes to any unsaved forms.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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 Reinforce Your Skills
REINFORCE YOUR SKILLS: A6-R1

Create and Modify a Form with a Subform
In this exercise, you will create a new Donors form for Kids for Change. You will delete, move, and size 
controls; modify the title; and add a logo to the form.

 1.  Open A6-R1-K4C from your Access Chapter 6 folder and save it as: A6-R1-K4CRev

 2.  Select the Donors table in the Navigation pane and choose Create→Forms→Form Wizard .

 3.  Add all fields from the Donors table to the Selected Fields list, except the first field, DonorID.

Hint: Use the Move All Fields  button and Remove  button on the DonorID field.

 4.  Click the last field in the Selected Fields list.

This ensures the fields you add in the next step are placed at the bottom of the list.

 5.  Add all four fields from the Donations table to the Selected Fields list.

 6.  Click Next and click Next again to leave the viewing options set to By Donors and a Form with 
Subform(s).

 7.  Leave the layout set to Datasheet and click Next.

 8.  On the final Wizard screen, name the form Donors Form and the subform Donations 
Subform and click Finish.

The new form and subform display in Form View.

Adjust the Subform Layout
 9.  Switch to Layout View then click the Donations label to the left of the subform and tap 

[Delete].

 10.  Double-click the right edge of each subform column heading to autofit the columns.

 11.  Size the subform by dragging its borders and then use the arrow keys to position the subform as 
shown here:
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Set Form Field Properties
 12.  Use the Navigation bar at the bottom of the main form window to move to the third record 

(McGovern).

Notice the email address text box is a bit too narrow for the email address.

 13.  Click the email address to select it and then display the Property Sheet.

 14.  Click the Format tab and then set the Width property to: 1.8

 15.  Use the Navigation bar to scroll through the database records.

The Acknowledgements text box is larger than it needs to be.

 16.  Click the Acknowledgements text box and set these properties:

Property Value

Width 2

Height 0.5

 17.  Set the widths of the State and DonorZIP text boxes to: 0.8

Modify the Form Header
 18.  Click the Donors Form title in the Form Header to select the title box and set the Width  

property to: 3.5

 19.  Click in the title box and change the title to: Kids for Change Donor Form

 20.  Choose Format Layout Tools→Design→Header/Footer→Logo .

 21.  Navigate to your Access Chapter 6 folder, choose K4C-Logo.bmp, and click OK.

 22.  Set the Width and Height properties to 0.8 and the Left property to: 4

 23.  Switch to Form View to view your completed form.

 24.  Close the database, saving the changes to both the form and subform.

REINFORCE YOUR SKILLS: A6-R2

Add a Totals Row to a Form
In this exercise, you will add a Totals row to a form that counts the number of individual donations and 
totals the amount of the donations.

 1.  Open A6-R2-K4C from your Access Chapter 6 folder and save it as: A6-R2-K4CRev

 2.  Select the Donations Query in the Navigation pane and launch the Form Wizard.

 3.  Move all fields except Acknowledgement, ScholarFund, and NetAmt to the Selected Fields list 
and click Next.

 4.  Accept the By Donations view and click Next.
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 5.  Choose the Datasheet layout and click Next.

 6.  Name the new form Total Donations and click Finish.

 7.  Click the Select All box at the top-left corner of the datasheet to select all columns.

 8.  Double-click the right edge of any column heading to autofit all columns.

 9.  Choose Home→Records→Totals .

A Total row is added to the bottom of the datasheet.

 10.  Click in the Last Name cell on the Total row.

 11.  Click the menu button � on the left and choose Count from the drop-down menu.

There are 16 individual donations.

 12.  Click in the Amount cell on the Total row and choose Sum from the menu.

 13.  Autofit the Amount column so the total is visible.

The donations total $11,150, all in even dollar amounts so decimal places aren’t needed.

 14.  Switch to Layout View and then click the Amount text box and display the Property Sheet.

 15.  On the Format tab, set the Decimal Places property to 0 and then close the Property Sheet.

 16.  Switch to Datasheet View and autofit the Amount column again.

 17.  Close the database, saving the changes to any unsaved forms.

REINFORCE YOUR SKILLS: A6-R3

Disable and Lock Fields, Calculated Controls, and Pop-Up Forms
In this exercise, you will disable and lock subform fields to prevent information from being altered by those 
without permission to do so. You will also add a calculated control to a form and create a pop-up form for 
easy access to donor information.

 1.  Open A6-R3-K4C from your Access Chapter 6 folder and save it as: A6-R3-K4CRev

 2.  Display the Donations subform in Design View and then click the DonorID text box and 
display the Property Sheet.

 3.  Click the Data tab and change the Enabled property to No.

 4.  Click the Other tab and then click in the ControlTip text box and type: Donor IDs are set 
by the administrator and cannot be edited.

 5.  Click in the Amount text box on the form and then click the Data tab and set the Locked  
property to Yes.

 6.  Click the Other tab and then click in the ControlTip Text box and type: Donor totals are 
calculated by the program and cannot be edited.

 7.  Switch to Form View and point to the DonorID and Amount controls to see the control tips you 
just created.

 8.  Close the form, saving the changes.
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Create a Calculated Control
 9.  Choose the ScholarFund Donations table in the Navigation pane and launch the Form 

Wizard.

 10.  Add all fields to the form and click Next.

 11.  Choose the Datasheet layout option and click Next.

 12.  Leave the name as ScholarFund Donations and click Finish.

 13.  Switch to Design View and then drag the top edge of the Form Footer section bar down to 
make room for a new text box.

 14.  Choose Format Design Tools→Design→Controls→Text Box  and then click just below the 
ScholarFund control to insert a new text box there.

 15.  Use the arrow keys as needed to align the control with the ScholarFund control.

 16.  Make sure the new control is still selected and, if necessary, display the Property Sheet.

 17.  Click the All tab and set these properties:

Property Value

Name Total Donation

Control Source =Amount+ScholarFund

Format Currency

Decimal Places 0

 18.  Click the text box label and set these properties:

Property Value

Caption Total Donation

Width 1

Left 0.25

 19.  Switch to Form View to see your new calculated control in action.

Notice the fields are of different widths, creating a poor form layout.

 20.  Switch back to Design View and set the Width property of all text boxes to: 1

 21.  Switch back to Form View.

The field widths are now consistent, but the left alignment of the DonationType field needs to be 
changed.

 22.  Switch back to Design View and set the Text Align property of the DonationType text box to 
Right.

 23.  Switch back to Form View to view your completed form.

Create a Pop-Up Form
 24.  Choose the Donors table in the Navigation pane and launch the Form Wizard.

 25.  Add the DonorID, DonorLName, and DonorFName fields to the Selected Fields list and click 
Next.

 26.  Choose Datasheet layout and click Next.
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Reinforce Your Skills 197

 27.  Enter Donor Popup as the name, choose the option to Modify the Form’s Design, and click 
Finish.

The form displays in Design View.

 28.  Click the Other tab and set the Pop Up property to Yes.

 29.  Save the change to the form and then switch to Datasheet View.

 30.  Autofit the three columns in the pop-up form.

 31.  Adjust the height and width of the pop-up form by dragging the frame borders until the  
datasheet fits nicely within the frame.

You may need to drag the form slightly by the title bar before sizing it.

 32.  Drag the pop-up form to the right of the ScholarFund Donations fields.

 33.  Navigate through the records in the ScholarFund Donations form while the pop-up form remains 
in place, giving you access to all donor information at a glance.

 34.  Close the database, saving changes to any unsaved forms.
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 Apply Your Skills
APPLY YOUR SKILLS: A6-A1

Create a Form and Subform and Add a Totals Row
Universal Corporate Events would like you to help them track venues, employees, and their pay. In this 
exercise, you will create a form with a subform, as well as a quick form that counts salaried employees and 
totals and averages the salaries.

 1.  Open A6-A1-UCE from your Access Chapter 6 folder and save it as: A6-A1-UCERev

 2.  Select the Venues table and start the Form Wizard.

 3.  Move all fields from the Venues table to the Selected Fields list except VenueLiaison.

 4.  Choose the Schedules table in the Tables/Queries list.

 5.  Move all fields from the Schedules table to the Selected Fields list except Schedules.VenueID.

 6.  Accept viewing your data By Venues and the Form with Subform(s) option.

 7.  Choose Datasheet as the layout option.

 8.  Use Venue Events for the main form’s name and Venue Events Subform for the  
subform’s name.

 9.  Switch to Layout View and then modify the subform layout as described:

• Remove the Venue Events label.

• Widen the frame enough so all columns are visible.

• Autofit all columns.

• Reduce the frame width until it is just wide enough to contain the datasheet.

• Nudge the frame to align it with the text boxes on the main form.

 10.  Close the form, saving the changes to the form and subform.

 11.  Choose Salaried Personnel Query in the Navigation pane and start the Form Wizard.

 12.  Add all fields to the Selected Fields list, choose the Datasheet layout, and name the new form: 
Salaried Personnel Totals

 13.  Switch to Design View and then select the Salary label and the SalaryAmt text box controls.

 14.  Press [Ctrl]+[C] and then [Ctrl]+[V] to copy and paste a duplicate salary field under the existing 
label and text box.

You may need to drag the Form Footer section down slightly to make room for the salary field.

 15.  Change the name of the first Salary label to: Total Salaries

 16.  Change the name of the second Salary label to: Average Salary

 17.  Switch to Datasheet View and autofit all columns.

 18.  Add a Totals row and insert these functions:

• Count in the Salaried field

• Sum in the Total Salaries field

• Average in the Average Salary field

Notice the Count function displays the 11 records where the box in the Salaried field was checked.
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 19.  Uncheck several Salaried boxes and notice that the function updates the changes.

 20.  Close the database, saving the changes to any unsaved forms.

APPLY YOUR SKILLS: A6-A2

Add a Calculated Control to a Form and Change the Form’s Layout
In this exercise, you will add a calculated control to a main form by first copying an existing field, which 
will retain the formatting of the existing field. You will also adjust the size and position of the controls to 
change the form’s appearance.

 1.  Open A6-A2-UCE from your Access Chapter 6 folder and save it as: A6-A2-UCERev

 2.  Open the Event Pricing Entry form in Form View.

Notice that the labels have a raised effect. You will create a calculated control while retaining the 
formatting of these fields by copying and pasting an existing field.

 3.  Switch to Design View and then select the Chg/PP label and the ChgPP text box.

In the next step, you may need to drag the Form Footer bar down slightly to make room for the new 
controls.

 4.  Press [Ctrl]+[C] to copy the controls and [Ctrl]+[V] to paste them.

An identical text box and label appear below the existing text box and label.

 5.  Change the Chg/PP label text for the new label to: Total

 6.  On the Data tab of the Property Sheet, change the Control Source property of the new text box 
to: =Guests*ChgPP

 7.  Change the Width property of all eight control labels to 1 and the Left property to: 1.5

 8.  Switch to Form View and navigate through several records to verify the calculated control is 
working and the text boxes are wide enough to accommodate all records.

 9.  Close the database, saving the changes to the form.

APPLY YOUR SKILLS: A6-A3

Create a Pop-Up Form
In this exercise, you will create a pop-up form to help facilitate data entry.

 1.  Open A6-A3-UCE from your Access Chapter 6 folder and save it as: A6-A3-UCERev

 2.  Select the Events table and launch the Form Wizard.

 3.  Move both the EventID and EventName fields to the Selected Fields list, choose the Tabular 
layout, and name the form: Events Pop Up

 4.  Switch to Design View and delete the Events Pop Up title in the Form Header section.

 5.  Set the Top property to 0.1 for the Event ID label and the Event Name text box in the Form 
Header.

 6.  Set the Form Header Height property to: 0.4

 7.  Choose Form from the Selection Type drop-down list at the top of the Property Sheet.

 8.  On the Other tab, set the Pop Up property to Yes.

A
C

C
E

S
S

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



200 Access Chapter 6: Customizing Input Forms

 9.  Switch to Form View and display the Venue Events form in Form View.

 10.  Move the pop-up form so you can view the data in the Venue Events form and subform.

You can see what each Event ID on the Venue Events subform means by looking on the Events Pop Up 
form.

 11.  Close the database, saving the changes to the form.
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  Project Grader

PROjECt gRADER: A6-P1

Taylor Games: Creating and Customizing an Input Order Form
Taylor Games is getting ready to take customer orders, but before it can begin, its service reps need a new 
order form. In this exercise, you will create a form that contains a subform and modify the design for visual 
appeal. Then you will lock a form field and add a calculated control.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A6_P1_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A6_P1_Start from your Access Chapter 6 folder.

 2.  Use the Form Wizard and these guidelines to create a new form and subform:

• Add all available fields from the Orders table.

• Add (in order) Line Item and Quantity from the Order Details table.

• Add the Price field from the Inventory table.

• View the data by Orders as a Form with Subform(s).

• Use the Datasheet layout.

• Use Order Form as the form title and Order Subform as the subform title.

• You will modify the form’s design in the next steps.

 3.  Set the Width property of the Order_ID text box to: 0.5

 4.  Set the Width property of the Service_Rep text box to: 1.05

 5.  Set the ControlTip Text property of the Customer_State text box to: Use two letter 
abbreviation

 6.  Set these properties for the Order Subform_Label (contains the text Order):

Property Value

Top 2.85

Left 0.25

 7.  Set these properties for the Order Subform:

Property Value

Height 2.5

Top 3.1

Left 0.25

 8.  In the Order Subform, set the Locked property of the Price control to Yes.
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202 Access Chapter 6: Customizing Input Forms

 9.  In the Order Subform, insert an unbound text box control directly below the Price control.

 10.  Set these properties for the unbound text box control:

Property Value

Name LineTotal

Format Currency

 11.  Create a formula in the unbound text box control that multiplies the Quantity field by the Price 
field.

 12.  Set these properties for the Unbound label control (contains the text Text6):

Property Value

Name LineTotal

Caption Line Total

Width 1

Left 0.25

 13.  In the order form, use these guidelines to create a new Title control:

• Delete the current Title control from the Form Header (contains the title Order Form).

• Insert a new Title control.

• Set these properties for the new Title control:

Property Value

Width 2

Height 0.5

Font Size 26

Text Align Center

Font Weight Bold
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 14.  Insert a Logo control in the Form Header and set these properties for it:

Property Value

Picture Insert the Taylor Games Logo.png picture 
from your Access Chapter 6 folder.

Width 1

Height 0.6

 15.  Set the Back Color property for the FormHeader section to: Background Light Header

 16.  Save your database.

• Using eLab: Save it to your Access Chapter 6 folder as A6 _ P1 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 6 folder as: A6 _ P1 _ Submission

PROjECt gRADER: A6-P2

WebVision: Create and Add a Subform
WebVision has improved its database normalization and would like to capitalize on these changes in the 
current order form. In this exercise, you will start by adding a calculated field to an existing query. Then, 
you will create a datasheet form, add a total row, and add the datasheet form as a subform to the existing 
order form. You will then disable form fields and create a pop-up form. Last, you will enter a new order 
using the form you created.

 1.  Download and open your Project Grader starting file.

• Using eLab: Download A6_P2_eStart from the Assignments page. You must start with this file 
or your work cannot be automatically graded.

• Not using eLab: Open A6_P2_Start from your Access Chapter 6 folder.

 2.  In the OrderDetails Query, add a calculated field named Line Total that multiplies the 
Quantity field by the Cost field.

 3.  Create a datasheet form that is based on the OrderDetails Query.

 4.  Add a Totals row to the new form and then SUM the data in the Line Total column.

 5.  Save the form with the name: OrderDetails Subform

 6.  Insert the OrderDetails Subform into the Orders form (by dragging it from the Navigation pane 
into the detail section).

 7.  Delete the subform label (named OrderDetails Subform).
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204 Access Chapter 6: Customizing Input Forms

 8.  Set the OrderDetails Subform properties using the following guidelines:

Property Value

Link Master Fields OrderID

Link Child Fields OrderID

Width 5

Height 3

Top 1.5

Left 0.25

 9.  Delete the Order ID textbox and label controls from the subform.

 10.  Disable the Cost and Line Total text box controls by setting the Enabled property to No.

 11.  In Layout View, resize the columns for each of the subform columns so all field data is 
displayed.

 12.  Set these properties in the Sales Reps form:

Property Value

Pop Up Yes

Modal No

 13.  Close all open objects, saving any changes, and then save your database.

• Using eLab: Save it to your Access Chapter 6 folder as A6 _ P2 _ eSubmission and attach 
the file to your eLab assignment for grading.

• Not using eLab: Save it to your Access Chapter 6 folder as: A6 _ P2 _ Submission
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 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A6-E1 That’s the Way I See It
You want to create a form with a subform in the Blue Jean Landscaping database. Open A6-E1-BJL. 
Save it as A6-E1-BJLRev and start the Form Wizard. Create a Blue Jean Landscaping Customer 
Sales form with a CustSales Details subform in datasheet layout that includes: 

 Ý SalesNum and SalesDate from the MerchSales table 

 Ý CustLastName from the Customers table

 Ý ItemName, Manufacturer, and Price from the StoreMerchandise table 

 Ý QtySold from the MerchSalesDetails table

Enhance the appearance of the forms and add any features you feel will help facilitate effective data 
entry.

A6-E2 Be Your Own Boss
Blue Jean Landscaping would like you to add calculated controls to the newly created Sales Invoices 
form so it may show order totals. They have also asked that several field properties be modified to 
assist and control data entry. Open A6-E2-BJL and save it as: A6-E2-BJLRev

Open the SalesInvoices form and add a calculated control that multiplies Cost by Qty Sold to 
produce a line total. Disable the Invoice number field, lock the Cost field, and add a control tip that 
will notify the user they cannot change the cost. Enhance the appearance of the forms and add any 
features you feel will help facilitate effective data entry.

A6-E3 Demonstrate Proficiency
Stormy BBQ is continuing to update its database and now wants to have a more exact record of its 
merchandising sales. Open A6-E3-SBQ. Save it as A6-E3-SBQRev and then create a new form 
using the default form and subform names in datasheet layout that includes:

 Ý SalesID and SalesDate from the MerchSales table

 Ý SKU from the MerchSalesDetails table

 Ý Manufacturer, ItemName, and ListPrice from the Merchandise table

 Ý QtySold from the MerchSalesDetails table

In the subform, add a calculated control that multiplies ListPrice by QtySold to produce a line total. 
Create a pop-up tabular form using the Merchandise table that displays SKU, ItemName, and 
ListPrice. Enhance the appearance of the forms as desired.
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