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L E A R N I N G  O B J E C T I V E S

ÝÝ Add command buttons to forms

ÝÝ Manage database objects and create macros

ÝÝ Back up, restore, analyze, compact, and repair a 
database

ÝÝ Set database security using encryption and 
passwords

11 Maintaining a 
Database

ACCESS

A
s you prepare your database for 

distribution, you will make your 

last design tweaks and confirm 

it is optimized for speed and ease of use. At 

this stage, security should be a main priority, 

as protecting a database from data loss 

and unauthorized access is critical. In this 

chapter, you will customize Access settings 

and add easy-to-use command buttons to 

a form. You will also create macros; explore 

database security features; set a database 

password; and then analyze, compact, and 

repair a database.
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	 Project: Improving and Maintaining a Database
The prototype of the Winchester Web Design database is almost complete. After reviewing 
the database, the company’s owner is pleased with the overall design. He now wants to add 
some command buttons and macros to improve navigation and to ensure the database runs as 
efficiently as possible. A major concern is the security of the database and the data it contains. 
The owner would like to institute both security protocols and a regular backup policy.

Using Command Buttons to Improve Navigation
In addition to adding labels, text boxes, images, and other controls to database forms, you can add 
command buttons to use for record navigation, such as finding a record or going to the previous/next 
record, and report operations, such as printing a specific report or even exiting Access. To create a 
button, you draw a button shape in the desired location on the form and use the Command Button 
Wizard to walk you through the process.

ÍÍ Form Design Tools→Design→Controls→Button 

DEVELOP YOUR SKILLS: A11-D1

In this exercise, you will add command buttons to the Form Footer section of the Invoice Form to make 
navigation easier and to quickly view an invoice report.

	 1.	 �Open A11-D1-WinDesign from your Access Chapter 11 folder and save it as: 
A11-D1-WinDesignRev

	 2.	 �Enable content and then close the Winchester Web Design Navigation Form.

Many of the activities in this chapter require you to enable content to function properly. Enable content 
when the option appears.

	 3.	 �Open the Invoice Form in Design View.

	 4.	 �Click the Form Footer section bar and type 0.75 for the Height property on the Property Sheet. 
(Hint: Tap [F4] to open the Property Sheet.)

	 5.	 �Choose Form Design Tools→Design→Controls→Button .

	 6.	 �Draw a button in the Form Footer under the left end of the subform.

If the Command Button Wizard doesn’t open, delete the button and then choose Form Design 
Tools→Design→Controls→Use Control Wizards and draw the button again.



Note!
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	 7.	 �Follow these steps to add a command button:

Your command button may show a different number than 33.

A

C

B

A	�Choose the Record Navigation category.

B	�Choose the Go To First Record action.

C	�Click Next.

	 8.	 �Click the Picture option, choose Go To First, and click Next.

	 9.	 �Enter cmdFirst as the meaningful name and click Finish.

The command button shows the Go To First picture in the Form Footer section and is programmed to 
go to the first record when in Form View.

	10.	 �Repeat steps 5–9 to add commands in the order shown:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

	11.	 �Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action; click Next.
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	12.	 �Select the Invoice Details Report as the report to preview and click Next.

	13.	 �Choose the MS Access Report picture, if necessary, and click Next.

	14.	 �Enter the name cmdPreviewInvoices and click Finish.

	15.	 �Select the new buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

	16.	 �With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

	17.	 �Switch to Form View and test each button.

	18.	 �If necessary, close the Invoice Details Report and then save and close the Invoice Form.

Creating Macros to Improve Efficiency
A macro is an object that combines a series of steps into a single step so a more detailed task can be 
automated. For example, if you regularly export your data to another database, instead of choosing 
External Data→Export→Text File and then entering the filename and selecting export options, you 
could create a macro to perform all the steps with one double-click of the mouse. 

The ExportCustomers macro exports the Customers table to the default My Documents folder as 
a text file (bottom figure). If needed, a specific file path could be entered for the output file.

ÍÍ Create→Macros & Code→Macro 
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DEVELOP YOUR SKILLS: A11-D2

In this exercise, you will create a macro that will display a message box to provide basic directions on when 
and where to back up the Winchester Web Design database.

	 1.	 �Choose Create→Macros & Code→Macro .

	 2.	 �Choose MessageBox from the Add New Action drop-down menu.

	 3.	 �Enter the following into the MessageBox text boxes:

Property Setting

Message Be sure to back up every Friday

Beep Yes

Type Information

Title Back-Up Policy

	 4.	 �Save the macro as: Back-Up Policy

	 5.	 �Choose Macro Tools→Design→Tools→Run  to test the macro.

A message box should appear with the title, message, and icon you entered.

	 6.	 �Click OK to close the message box.

	 7.	 �Close the Back-Up Policy macro.

Back-Up Policy is now listed in the Navigation pane under the Macros group heading.
 

Using Macros to Display Adaptable Reports
Now that you have created a simple macro to display a reminder message, you can add a command 
button to a form that will run a macro to display a report. By adding a “where” condition, you can 
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not only open the report of your choosing, you can also specify the macro to display a specific record 
within the report based on matching the criteria for a field in the current object. For example, if you 
would like to print the invoice that corresponds to the record displayed in your Orders form, you can 
set the macro to display only the record that matches the Order ID field in both the Orders form and 
the Invoices report.

DEVELOP YOUR SKILLS: A11-D3

In this exercise, you will create a macro button that will be placed on the Employees Form to display a 
report of all the sales for the specific employee selected.

	 1.	 �Choose Create→Macros & Code→Macro .

	 2.	 �Open the Add New Action drop-down menu, scroll the list downward, and choose 
OpenReport.

	 3.	 �Open the Report Name drop-down menu and choose Invoice Details Report.

	 4.	 �Complete the OpenReport text boxes as indicated:

As you start to enter in the Where Condition text box, Access will suggest field names from a  
drop-down menu, allowing you to quickly and more accurately select from the list.

Property Setting

Report Name Invoice Details Report

View Report

Where Condition [EmpID]=[Forms]![Employees Form]![EmpID]

Window Mode Normal

	 5.	 �Save the macro as: Invoice Details Report by Employee

	 6.	 �Display the Employees Form in Design View.

	 7.	 �Choose Design→Controls→Button  and draw a button in the top-right corner of the 
Details section of the Employees Form.

The Command Button Wizard starts.

	 8.	 �Choose the Miscellaneous category and the Run Macro action; click Next.

	 9.	 �Choose Invoice Details Report by Employee and click Next.

	10.	 �Accept the default macro picture and click Next again.

	11.	 �Name the button cmdRptByEmployees and click Finish.
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	12.	 �Switch to Form View and navigate to Mike Waters (EmpID MJW).

	13.	 �Click the new Run Macro button to display all records in which the EmpID is MJW.

	14.	 �Close the report and form, saving the changes to the form.

Managing Database Objects
Protecting databases and the quality of data they contain is vital to the reliability and performance 
of any database. At the same time, learning efficient ways to manage database objects helps to save 
a great deal of time as you build a database. The general cleanup and maintenance of a database 
can be accomplished in a number of ways. You can create new objects from existing objects, rename 
database objects, and delete unneeded or duplicate database objects.

Creating New Objects from Existing Objects
Often, databases contain separate objects that are similar in structure and in the data they hold. 
For example, the Employees table in the Winchester Web Design database contains fields similar to 
those found in the Customers table. When you build a database that contains similar objects, you can 
copy the original object, save it using a new name, and then modify the new object to fit its specific 
needs. There are two basic ways to copy objects:

ÝÝ Use the Save Object As command and rename the object to create another instance of it.

ÝÝ Use the contextual menu Copy and Paste commands.

Renaming Database Objects
You might create a table, query, form, or report and save it with the first name that comes to mind 
and then, after working with the object for a while, you might want to change the name. When an 
object is renamed, Access automatically renames all the relationships and record sources that use 
the renamed object. For instance, if you update the Invoices table to Orders, the record source for 
the queries, forms, and reports based on the table will be updated to reflect the new name.

Deleting Database Objects
During the development of a database, there are times when it is wise to create a temporary table, 
query, form, or report for testing purposes. Once the database is completed, you should remove 
these objects so they don’t clutter the Navigation pane or confuse users. 

DEVELOP YOUR SKILLS: A11-D4

In this exercise, you will copy, rename, and delete a report. You will also save a table in the Winchester 
Web Design database as a new table and edit the field names for the new table.

	 1.	 �Right-click the Products Report in the Navigation pane and choose Copy.

	 2.	 �Right-click again and choose Paste, keep Copy Of Products Report as the report name, and click OK.

	 3.	 �Right-click Copy Of Products Report and choose Rename; type Delete This Report and 
tap [Enter].
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	 4.	 �Select the Delete This Report report in the Navigation pane.

	 5.	 �Tap [Delete] and click Yes to confirm the deletion.

You can also right-click an object and choose Delete from the menu.

	 6.	 �Open the Employees table and choose File→Save As→Save Object As→Save As.

	 7.	 �Type Business Contacts in the Save ‘Employees’ To text box and click OK.

	 8.	 �Switch to Design View.

	 9.	 �Select and edit the Business Contacts field names, replacing each Emp prefix with a Bus prefix 
(so EmpID is BusID, EmpLastName is BusLastName, and so on).

	10.	 �Right-click the HireDate field, choose Delete Rows, and then click Yes to confirm.

	11.	 �Delete the WebCert field and then save the changes to the Business Contacts table.

	12.	 �Switch to Datasheet View to confirm your changes and then close the Business Contacts table.

Backing Up a Database
All databases should be safeguarded to protect their data. Most organizations have a scheduled 
procedure to back up all files on their network, including the databases.

When you back up a database using the built-in Access tools, Access automatically places the date 
of the backup in the filename so you can easily identify and retrieve each backup file. You choose 
the drive and folder in which you want to save the backup. To restore the database, simply open the 
backup.

ÍÍ File→Save As→Save Database As→Back Up Database 

DEVELOP YOUR SKILLS: A11-D5

In this exercise, you will back up your Winchester Web Design database.

	 1.	 �Close any open objects in the Winchester Web Design database.

	 2.	 �Choose File→Save As→Save Database As→Back Up Database  and then click Save As.

Access opens the Save As dialog box and adds the current date to the end of the filename.

	 3.	 �Save the file in your Access Chapter 11 folder.

Access saves the backup file to the desired location, adding the date the backup occurred to the 
filename. However, the open database file is still the original Winchester Web Design database.

	 4.	 �Close the database, navigate to your Access Chapter 11 folder, and open the backup database.

A backup is only as current as the time the backup was created. It’s important to have a policy that 
schedules and mandates a daily or weekly backup.

	 5.	 �Close the backup database and reopen A11-D1-WinDesignRev.

Tip!

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Analyzing and Documenting Databases  335

Analyzing and Documenting Databases
Each time you change the design or content of a database, the chance that the database will become 
corrupted increases. Access includes several tools that help you protect, document, analyze, and 
even repair databases. The main tools found in the Analyze group on the Database Tools tab are:

ÝÝ Performance Analyzer: This tool analyzes the performance of a database to locate and identify 
potential trouble spots that affect how the database functions.

ÝÝ Database Documenter: This tool documents objects in the database so you can track changes 
to design and relationships. It builds an Object Definition document that provides a detailed 
description of each database object.

Reviewing and Analyzing Performance
When you run the Performance Analyzer, Access reviews each selected object in the database, looks 
at all the relationships, and identifies any problems that might affect database performance. Access 
often makes recommendations for improvements to optimize database efficiency. In some cases, 
Access identifies tables in which no primary key is set. In other cases, Access will suggest a more 
efficient data type or that you use fewer controls on a form.

Some changes recommended by the Performance Analyzer may not be necessary. For example, 
Access frequently recommends that phone numbers be formatted using the Number data type. Not 
only is this unnecessary, it may even cause problems for extensions that are commonly preceded 
by an X, such as X209. As you review the recommended changes, you will begin to identify those 
requiring your attention and those you can ignore.

There are two options for analyzing database performance. The Analyze Performance tool enables 
you to choose the database objects you want to analyze. The Analyze Table tool analyzes a table 
using the Table Analyzer Wizard.

ÍÍ Database Tools→Analyze→Analyze Performance 

Documenting a Database
As you plan a new database, you must analyze the needs of the business and the requirements of the 
database. In the process, you create a list of fields required and then organize and group those fields 
into the tables that will provide the data for forms, queries, and reports. The list identifies and defines 
each field and the tables and objects in which the fields are used within the database. When the 
database is finished, you may choose to document the database so it can be efficiently updated and 
maintained in the future.

Documentation provides insight into the structure of the entire database as well as the structure 
of each object within the database. Maintaining a database can be very time-consuming. Without 
proper documentation to identify potential impacts of changing field properties, object structures, 
and so forth, you can potentially corrupt one database object that, in turn, wreaks havoc on the entire 
database. Each time you change the structure of any database object, remove an object from, or add 
an object to the database, you should run the Database Documenter to provide up-to-date documen-
tation about the database. Such information will prove invaluable to database administration.

ÍÍ Database Tools→Analyze→Database Documenter 
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DEVELOP YOUR SKILLS: A11-D6

In this exercise, you will analyze and document your Winchester Web Design database.

	 1.	 �Choose Database Tools→Analyze→Analyze Performance .

The Performance Analyzer opens.

	 2.	 �Click the Tables tab and click Select All to check all the tables listed.

	 3.	 �Click OK and view the suggestions under Analysis Notes.

The data types have been set properly, so you can ignore the suggested ideas.

	 4.	 �Click Close.

	 5.	 �Choose Database Tools→Analyze→Database Documenter .

The Documenter opens.

	 6.	 �Click the Tables tab, check the InvoiceDetails, Invoices, and Products tables, and click OK.

Access produces a report about a dozen pages long that documents the tables, fields, and 
relationships of the selected tables.

	 7.	 �Scroll through the report and examine the documentation provided.

	 8.	 �Choose Print Preview→Data→Excel  to open the Export Excel Spreadsheet Wizard.

	 9.	 �Check the Open the Destination File After the Export Operation Is Complete box, if 
necessary.

	10.	 �Click Browse, navigate to your Access Chapter 11 folder, type A11-D6-Objects as the  
filename, click Save, and then click OK.

	11.	 �Browse through the Excel spreadsheet and close it when finished.

	12.	 �Close the wizard without saving the export steps and then close the print preview.
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Compacting and Repairing a Database
When you delete a record in Access, the record is not really deleted—it’s marked for deletion. 
The process of marking a record as deleted is quicker than completely deleting and reordering or 
rewriting all the records in a table. A similar process is used when you shorten the contents of a 
record—the space that was used for the longer data is not released.

As you work with databases, they can become sluggish and the data stored in the databases can 
become fragmented. Fragmentation occurs when parts of your database file become separated by 
incidental data that has been added to the disk you are using. For example, if you saved a 10-mega-
byte database file to your hard drive and saved an Excel spreadsheet to the same hard drive shortly 
afterward, it would be written next to the 10-megabyte database file. 

Then, if a large group of new records were added to the database file, they would have to be stored 
after the Excel file and not after the original database file because the adjacent space is now occu-
pied by the spreadsheet. As you add more records and save other files, both your files and storage 
drive become fragmented and less efficient.

Consequently, over time databases can become bulky and inefficient. This issue can be resolved by 
compacting, or compressing, your database to remove wasted and unused space left from deleted 
and edited records. 

To ensure optimal performance, Access enables you to compact and repair databases as often as you 
want. Sometimes Access recognizes a problem when a database is opened and attempts to repair 
the file before you work with it. Even if there is no file corruption, the normal maintenance tasks of 
adding, deleting, and editing records, creating and running queries, and so forth, may reduce data-
base performance. You may want to compact and repair the database manually on a regular basis or 
set an option to automatically compact the database whenever you close Access.

ÍÍ Database Tools→Tools→Compact and Repair Database 

DEVELOP YOUR SKILLS: A11-D7

In this exercise, you will compact and repair your Winchester Web Design database.

	 1.	 �Close any open database objects.

	 2.	 �Choose Database Tools→Tools→Compact and Repair Database .

Access compacts and repairs the file. Because the database is relatively small, the compact and repair 
process takes only a moment. For larger databases, the process will take longer. 

	 3.	 �Close A11-D1-WinDesignRev and exit Access.

Setting Database Security
Imagine your doctor stores all your medical records in a large database that could be accessed by hospi-
tals, clinics, and medical insurance companies who want to know more about the medications you take, 
conditions you might have, and doctor’s visits. Databases, by nature, often hold confidential information. 
As a result, security is imperative. Companies that maintain large database files often restrict access to 
databases at the login or server level. Splitting a database can protect the data contained in databases, 
and Access offers tools that enable you to secure a database by assigning a password.
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Opening a Database Exclusively
Most large business databases are designed to provide access to multiple users at the same time. 
As a result, the default setting for a database is as a shared file. Before you can set security for a 
database, you must ensure no one else is currently using the database. You do this by opening the file 
exclusively so Access locks the database and prevents others from accessing it at that time.

The Open dialog box contains numerous commands for opening databases after a file has been 
selected.

COMMANDS FOR OPENING DATABASES

Command Description
Open Provides full and typical access to the database and its objects 

and menus so you can create and edit

Open Read Only Opens the database so you can view and print data but does not 
allow design changes; however, you can save the database as a 
new file and edit that one 

Open Exclusive Opens the database and locks it to prevent other users in a 
shared environment from accessing it

Open Exclusive Read-Only Opens the database and locks it so other users cannot access it 
and prevents edits to data and database objects

Encrypting a Database Using a Password
Regardless of whether a backup routine is in place, valuable time can be lost reconstructing data if 
unauthorized users damage the database. Database passwords are intended to protect the database 
just as the passwords you use to access bank accounts or email accounts protect your financial and 
personal information.

Limits of Passwords
Database passwords provide limited security for databases by preventing unauthorized users from 
opening the database. You can set a password for any database you have on your personal computer, 
just as systems administrators set a password for shared databases on a network. 

Access passwords are case-sensitive, or capable of distinguishing between upper- and lowercase 
characters.

Strong Passwords
Access passwords can use a combination of upper- and lowercase characters, symbols, and numbers. 
Access allows you to use any combination of characters in passwords except “ \ [ ] : | <> + = ; , . ? and *. 
Strong passwords are at least thirteen characters long and contain at least one of each of the char-
acter types indicated. Passwords cannot start with a space.

Weak Password: webdesign

Strong Password: TooHard2Cr@ck

Setting Up Databases for Assigning Passwords
To assign a database password, the database must initially be closed. The default access setting for 
databases that appear on a network is as a shared database, accessible to anyone who has access to 
its file location. To set a password, you must open the database exclusively using the Open Exclusive 

Tip!
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command in the Open dialog box. This ensures that no one else is currently using the database and 
that, once you open it, other users are prohibited from opening it until you close it. If the file is not 
opened exclusively, you will get a warning message.

The Encrypt with Password command is a toggle. When a database has a password, the command button 
shows Decrypt Database.

ÍÍ File→Info→Encrypt with Password 

DEVELOP YOUR SKILLS: A11-D8

In this exercise, you will open the Winchester Web Design database exclusively and set a database 
password to protect the database.

	 1.	 �Start Access, choose Open Other Files from the menu, and click Browse.

	 2.	 �Navigate to your Access Chapter 11 folder; click A11-D1-WinDesignRev but do not open the 
database.

	 3.	 �Click the Open menu   button and choose Open Exclusive.

	 4.	 �Enable content and then close the WWD Navigation Form.

	 5.	 �Choose File→Info→Encrypt with Password .

	 6.	 �Type Labyrinth123! in the Password text box and again in the Verify text box and then click 
OK.

	 7.	 �Click OK to acknowledge that row level locking will be ignored.

	 8.	 �Close A11-D1-WinDesignRev and then open it again.

	 If you forget your password, you won’t be able to open the database.

	 9.	 �Type Labyrinth123! in the Enter Database Password text box and click OK.

You must open the database exclusively again if you want to change or remove the password.

	10.	 �Close A11-D1-WinDesignRev.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).

Note!

Warning!
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: A11-R1

Enhance and Clean Up a Database
Kids for Change would like to improve its forms by adding navigation and accessibility to other objects 
using buttons. It would also like to clean up database objects. In this exercise, you will add command 
buttons; create a macro that opens a report; and do some cleanup tasks by copying, renaming, and 
deleting objects.

	 1.	 �Start Access; open A11-R1-K4C from your Access Chapter 11 folder, and save it as: 
A11-R1-K4CRev

Remember to enable content if the option appears. You will begin by adding command buttons to a form. 

	 2.	 �Open the Activities Form in Design View.

	 3.	 �Click the Form Footer section bar and set the Height property to: 0.75

	 4.	 �Choose Form Design Tools→Design→Controls→Button  and draw a button in the form 
footer under the Telephone label.

The Command Button Wizard opens.

	 5.	 �Choose Record Navigation as the category and Go To First Record as the action; click Next.

The wizard displays a sample button picture for each action.

	 6.	 �Leave the options for pictures as selected, click Next, enter cmdFirst as the meaningful name, 
and click Finish.

The command button shows the Go To First image in the Form Footer section and is programmed to 
go to the first record when in Form View.

	 7.	 �Add these buttons in the order listed:

Category Action Picture Name

Record Navigation Go To Previous Record Go To Previous cmdBack

Record Navigation Go To Next Record Go To Next cmdNext

Record Navigation Go To Last Record Go To Last cmdLast

Record Navigation Find Record Binoculars (Find) cmdFind

	 8.	 �Draw a button to the right of the Find button, choosing Report Operations as the category and 
Preview Report as the action.

	 9.	 �Select the Activity Costs Report as the report to preview and click Next.

	10.	 �Choose the Preview picture and click Next; enter the name cmdPreviewCosts and click Finish.

	11.	 �Select the new command buttons and choose Form Design Tools→Arrange→Sizing & Ordering→ 
Align→Top.

All of the command buttons are aligned to the top.



Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Reinforce Your Skills  341

	12.	 �With the buttons still selected, choose Form Design Tools→Arrange→Size & Ordering→ 
Size/Space→Equal Horizontal.

	13.	 �Switch to Form View and test each of the new buttons; close the Activity Costs Report.

Create a Macro to Display Adaptable Reports
	14.	 �Choose Create→Macros & Code→Macro .

	15.	 �Choose OpenReport from the Add New Action menu.

	16.	 �Use this table to create the macro:

Report Name Volunteers Report

View Report

Where Condition [ActID]=[Forms]![Activity Staffing]![ActID]

	17.	 �Save the macro as Available Volunteers and then close it.

	18.	 �Display the Activity Staffing form in Design View and then choose Form Design Tools→ 
Design→Controls→Button .

	19.	 �Draw the new button to the right of the Meet Time controls.

	20.	 �Choose the Miscellaneous category and the Run Macro action, click Next, choose Available 
Volunteers, and click Next again.

	21.	 �Accept the default macro picture and click Next; name the button VolunteersMacro and 
click Finish.

	22.	 �Switch to Form View and click the new VolunteersMacro button.

The macro button displays the Volunteers Report record for the activity on the form. 

To display the Volunteers Report for another activity, close the report, navigate to the desired activity, 
and click the macro command button.

	23.	 �Close the Volunteers Report and then save and close the Activity Staffing form.

Rename, Delete, and Save Object as a New Object
	24.	 �Right-click Donations Report in the Navigation pane and choose Copy.

	25.	 �Right-click again, choose Paste, type Delete This Report as the report name, and click OK.

	26.	 �Select Delete This Report in the Navigation pane and tap [Delete]; click Yes to confirm the 
deletion.

	27.	 �Open the PaidStaff table and choose File→Save As→Save Object As→Save As.

	28.	 �Type Professional Contacts in the Save ‘PaidStaff’ To text box and click OK.

	29.	 �Display the new Professional Contacts table in Design View and rename the StaffID field to: 
ProfID

	30.	 �Right-click the Parent field and choose Delete Field; confirm the deletion.

	31.	 �Delete the Masters, HrlySal, and ActID fields. Click Yes to permanently delete the fields and 
to delete the ActID indexes.

	32.	 �Rename the Email Address field as: ProfEmail

	33.	 �Save and close the Professional Contacts table and then close the database.
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REINFORCE YOUR SKILLS: A11-R2

Perform Database Maintenance and Set a Password
Kids for Change would like a backup of its database. It would also like it to be optimized for speed and 
secured with a password. In this exercise, you will perform some maintenance procedures on the Kids for 
Change database, including backing up and analyzing objects. You will also add a password to protect the 
data from unauthorized users.

	 1.	 �Start Access; open A11-R2-K4C from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-R2-K4CRev

	 2.	 �Choose File→Save As→Save Database As→Back Up Database .

	 3.	 �Click the Save As button, navigate to your Access Chapter 11 folder, and click Save.

Analyze and Document a Database
	 4.	 �Choose Database Tools→Analyze→Analyze Performance .

	 5.	 �Click the Tables tab and click Select All to check all the tables listed.

	 6.	 �Click OK and view the Analysis Results.

Because the data types have already been set properly, you can ignore the suggested ideas.

	 7.	 �Click Close and then choose Database Tools→Analyze→Database Documenter .

	 8.	 �Click the Tables tab, check the Activities and PaidStaff tables, and click OK.

The report documents the tables, fields, and relationships of the selected tables.

	 9.	 �Choose Print Preview→Data→More→Word  to export the report to a Word RTF.

RTF files contain minimal formatting, are small, and are compatible across virtually all hardware and 
software platforms. Exporting to RTF ensures wider compatibility for various users.

	10.	 �Browse to your Access Chapter 11 folder, type A11-R2-Tables as the filename, and click Save.

	11.	 �Check the Open the Destination File After the Export Operation Is Complete box and click OK.

Access creates and opens the Word document.

	12.	 �Page through the Word document and then close it and exit Word.

	13.	 �Close the dialog box without saving the export steps and then close the print preview.

Compact and Repair a Database
	14.	 �Choose File→Info→Compact & Repair Database .

Access has compacted and repaired the file. The K4C Navigation Form might open, depending on your 
system.

	15.	 �Close A11-R2-K4CRev.

Protect a Database
	16.	 �Choose File→Open→Browse, navigate to your Access Chapter 11 folder and click  

A11-R2-K4CRev, and then click the Open menu button  and choose Open Exclusive.

No one else will be able to use the database until you exit Access.

Because you opened the database exclusively, you can set a password to open the database.

	17.	 �Choose File→Info→Encrypt with Password.
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	18.	 �Type Labyrinth123! as the password, verify it by typing it again, and click OK.

	19.	 �Click OK to acknowledge the message about row-level locking.

	20.	 �Close A11-R2-K4CRev and then open it again.

Access displays the Password Required dialog box. 

	21.	 �Type Labyrinth123! in the text box and click OK.

	22.	 �Close the database.

REINFORCE YOUR SKILLS: A11-R3

Perform Maintenance and Back Up a Database
Kids for Change would like a reminder to back up the database regularly. It would also like to rename a 
form and save a volunteer list as a query. In this exercise, you will create a macro that reminds users to 
back up the database. You will also rename, delete, and save objects.

	 1.	 �Open A11-R3-K4C from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-R3-K4CRev

Remember to enable content if the option appears.

Create a New Macro
	 2.	 �Choose Create→Macros & Code→Macro .

	 3.	 �Choose MessageBox from the Add New Action drop-down menu and use this information to 
create the macro:

Message Back up the database to SharePoint 
at the end of each day!

Beep Yes

Type Information

Title Back-up Routine

	 4.	 �Save the macro as: Back-up Routine

	 5.	 �Choose Macro Tools→Tools→Run .

The Back Up Routine Information message box opens.

	 6.	 �Click OK to close the message box and then close the Back-up Routine macro.

Back-up Routine is now listed under Macros in the Navigation pane.

Manage Database Objects
	 7.	 �Right-click Staff Form in the Navigation pane and choose Copy.

	 8.	 �Right-click again and choose Paste; rename the pasted object to PaidStaff Form and click OK.

	 9.	 �Select the Staff Form in the Navigation pane and tap [Delete]; click Yes to confirm the deletion.

	10.	 �Open the Volunteers table and choose File→Save As→Save Object As→Save As.

	11.	 �Type Volunteers List in the Save ‘Volunteers’ To text box.

	12.	 �Choose Query from the As drop-down menu and click OK.

	13.	 �Close the Volunteers List Query and then close the database.
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	 Apply Your Skills
APPLY YOUR SKILLS: A11-A1

Enhance a Database
Universal Corporate Events has asked you to improve forms by adding navigation and accessibility to other 
objects using macros and buttons. In this exercise, you will add command buttons to the Wage and Salary 
Form and create macros to increase efficiency.

	 1.	 �Start Access; open A11-A1-UCE from your Access Chapter 11 folder, close any open objects, 
and save the file as: A11-A1-UCERev

Remember to enable content if the option appears.

	 2.	 �Open Wage and Salary Form in Design View.

	 3.	 �Set the Height property for the Form Footer section to: 0.75

	 4.	 �Draw a button in the Form Footer under the Detail section labels.

	 5.	 �Create a Go To First Record button that uses the Go To First picture option and name it: 
cmdFirst

	 6.	 �Add these command buttons, in the order listed, using the default picture options:

•	 Go To Previous Record named: cmdPrevious

•	 Go To Next Record named: cmdNext

•	 Go To Last Record named: cmdLast

•	 Find Record named: cmdFind

	 7.	 �Draw a button to the right of the Find Record button using these specs:

•	 Category: Report Operations

•	 Action: Preview Report

•	 Report to preview: Wage and Salary Report

•	 Picture: Preview

•	 Name: cmdPreviewReport

	 8.	 �Select all new command buttons and then top-align them and set equal horizontal space 
between them.

Hint: Go to Form Design Tools→Arrange→Sizing & Ordering.

	 9.	 �Switch to Form View, test the buttons, and then close the Wage and Salary Report.

	10.	 �Save and close the Wage and Salary Form.

Create a Macro
	11.	 �Choose Create→Macros & Code→Macro.

You will create a macro that opens the Event Revenue Report for the Event ID shown on the form.


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	12.	 �Create an OpenReport macro using these guidelines:

Report Name Event Revenue Report

View Report

Where Condition [Forms]![Event Costs]![EventID]=[Event 
Revenue]![EventID]

Macro Name Event Revenue by Name

	13.	 �Close the macro.

	14.	 �Display the Event Costs form in Design View.

	15.	 �Create a new button under the Cost Details label using these specs:

•	 Category: Miscellaneous

•	 Action: Run Macro

•	 Macro: Event Revenue by Name

•	 Picture: default option

•	 Name: cmdEventRevenue

	16.	 �Switch to Form View and navigate to the first record with an Event ID of BUSMTG.

	17.	 �Click the new macro button.

The revenue report for this event type is displayed. You can display the report for other Event IDs by 
navigating to the event and running the macro.

	18.	 �Close the Event Revenue Report; save and close the Event Costs form.

	19.	 �Close the database.

APPLY YOUR SKILLS: A11-A2

Perform Database Maintenance and Set a Password
Universal Corporate Events would like a backup of its database. It would also like to fine-tune the objects 
and secure the database. In this exercise, you will perform maintenance procedures to reduce wasted 
space, defragment objects, and improve efficiency. You will also back up the database and add a password 
to protect data from unauthorized users.

	 1.	 �Open A11-A2-UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A2-UCERev

	 2.	 �Choose File→Save As→Save Database As→Back Up Database→Save As.

The current date is added to the end of the database filename.

	 3.	 �Save the file in your Access Chapter 11 folder.

Analyze and Document a Database
	 4.	 �Choose Database Tools→Analyze→Analyze Performance.

	 5.	 �On the Tables tab, click Select All to check all the tables listed and click OK.
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	 6.	 �Review the information presented and then close the dialog box.

	 7.	 �Choose Database Tools→Analyze→Database Documenter.

The Documenter opens.

	 8.	 �On the Tables tab, check Menus and Schedules, and then click OK.

Access generates a report for the tables, fields, and relationships of the selected tables.

	 9.	 �Choose Print Preview→Data→More→Word.

	10.	 �Browse to your Access Chapter 11 folder, use A11-A2-MenuSched as the filename, and click 
Save.

	11.	 �Check the Open the Destination File After the Export Operation Is Complete box and 
click OK.

	12.	 �Exit Word. In Access, close the Export – RTF File dialog box without saving the export steps, 
close the preview, and close any open database objects.

Secure a Database
	13.	 �Choose File→Open and then navigate to your Access Chapter 11 folder and open  

A11-A2-UCERev in Exclusive mode.

	14.	 �Encrypt the file with the password: Labyrinth123!

	15.	 �Click OK to acknowledge the encrypting message.

	16.	 �Close and reopen A11-A2-UCERev, entering the password when prompted.

	17.	 �Close the database.

APPLY YOUR SKILLS: A11-A3

Maintain Database Objects and Create a Macro
Universal Corporate Events would like you to add a message to remind employees to export reports every 
Friday and to clean up database objects to ensure the database runs smoothly. In this exercise, you will 
create a macro to display a message, create a new Products table based on data in the Menus table, and 
compact and repair the database.

	 1.	 �Open A11-A3UCE from your Access Chapter 11 folder, close any open objects, and save the 
file as: A11-A3-UCERev

	 2.	 �Close the UCE Navigation Form.

	 3.	 �Create a MessageBox macro, using Export all new reports on Friday! as the 
message, no beep, Information as the type, and Report Policy for the title.

	 4.	 �Save the macro as Report Policy and then run it.

	 5.	 �Close the information box and then close the Report Policy macro.

Maintain Database Objects
	 6.	 �In the Navigation pane, copy and paste the Personnel Report, resulting in a new object named 

Copy of Personnel Report.

	 7.	 �Rename the pasted object as: Staff Report
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	 8.	 �Delete the Staff Report, confirming the deletion when prompted.

	 9.	 �Open the Menus table, choose File→Save As→Save Object As, and click Save As.

	10.	 �Save the object as a new table named Products and then display the table in Design View.

	11.	 �Rename the table fields as indicated:

Field Rename

MenuCode ProdCode

MenuPlan ProdPlan

ChgPP Cost

CostPP Price

	12.	 �Save and close the new Products table.

Last, you will compact and repair the database.

	13.	 �Choose Database Tools→Tools→Compact and Repair Database.

	14.	 �Close the database, choosing Yes to empty the Clipboard.

	 	Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

A11-E1	 That’s the Way I See It
You would like to modify a database form to provide buttons for navigation as well as opening a 
closely related report for the Blue Jean Landscaping database. Open A11-E1-BJL and save it as: 
A11-E1-BJLRev

Create a macro named Service Invoices that opens 
the Service Invoices Report in Report View for the last 
name shown on the form. In the Service Invoices form 
footer, create command buttons using the default picture 
options as indicated in the table. Then create a Run Macro 
button named cmdServiceInvoicesReport that 
opens the Service Invoices macro. Top-align the buttons 
and set equal space horizontally between all buttons. Make any other changes to the form you feel 
would improve its look and feel.

A11-E2	 Be Your Own Boss
As the owner of Blue Jean Landscaping, you would like to improve performance and security. Open 
A11-E2-BJL and save it as: A11-E2-BJLRev 

Analyze the performance of all database tables. Use the Database Documenter to generate a 
report for the Services, ServiceInvoices, and ServiceInvDetails tables. Export the report to an Excel 
file (name it ServicesTables). Back up the database and then close and open A11-E2-BJLRev 
exclusively. Encrypt the file with a password of your choosing. Write the password down for your 
instructor or for future reference.

A11-E3	 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant has asked you clean up unnecessary objects in its 
database and to save a table as a query for easy filtering and sorting of restaurants. Also, it would 
like the database compacted and repaired in case renaming and removing objects has affected 
efficiency. Open A11-E3-SBQ and save it as: A11-E3-SBQRev

Complete these actions:

ÝÝ Delete the KeyWest Staff Query.

ÝÝ Rename any form with the name of your choosing.

ÝÝ Save the Restaurants table as a query named: Restaurant List

ÝÝ Compact and repair the database.



Go To First Record cmdFirst

Go To Previous Record cmdPrevious

Go To Next Record cmdNext

Go To Last Record cmdLast

Find Record cmdFind

Microsoft Access 2019 & 365 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY




