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In this chapter, you will work with 
various tools that are useful when you 
want to customize your workbook to 

suit your own specific needs. You will learn 
about ways to set up and adjust your 
worksheet to look consistent, professional, 
and presentable, as well as how to track 
information about the document.

L E A R N I N G  O B J E C T I V E S
■■ Apply and customize themes

■■ Create and use cell styles

■■ Apply cell borders and fill

■■ Create custom number formats

■■ Customize the page setup

■■ Add images to a worksheet

■■ Apply conditional formatting

■■ Use Zoom tools

■■ Edit document properties

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 20 mins

■■ Total: 2 hrs 20 mins

P R O J E C T:  P R E PA R I N G  C O M PA N Y 
D O C U M E N T S
LearnFast College is preparing the annual 
performance review to report to employees, 
management, and investors on how well the college 
did last year. You have been asked to review the 
Excel file and add appropriate formatting before it is 
distributed and presented at the annual meeting.

1Advanced Workbook 
Formatting

E X C E L  2 0 1 6
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2  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

Formatting with Themes
Themes are an easy way to personalize your workbook with a unique set of colors, fonts, and 
effects. You can apply a different theme to an existing workbook or change the theme when you 
first begin working on a new workbook. The theme is applied to the whole workbook, so all 
worksheets will look consistent.

All Office applications have a standard set of themes, and you can scroll through, preview, and select a theme from the 
gallery; the current theme is highlighted.

Customizing Themes
You can also modify an existing theme by changing each of the three elements individually: the 
colors, fonts, or effects. To modify the colors, you can choose from the list of color combinations 
available or customize even further by choosing each theme color yourself.

The Create New Theme Colors window allows you to choose the ten theme colors for text/background and accent 
colors in addition to the colors used for hyperlinks and followed hyperlinks.
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Formatting with Themes  3

To modify the theme fonts, you can again choose from the gallery of options or choose your own 
custom heading font and body font. After you have modified any part of a theme, you can save 
the theme to use again in other documents.

ÍÍ Page Layout→Themes

DEVELOP YOUR SKILLS: E1-D1	

In this exercise, you will modify the workbook’s theme and theme colors to match LearnFast College’s 
school colors.

Before You Begin: Be sure to visit the Learning Resource Center at labyrinthelab.com/lrc to retrieve the 
exercise files for this course before beginning this exercise.

	 1.	 �Start Excel, open E1-D1-PerformanceData from your Excel Chapter 1 folder, and save 
it as E1-D1-PerformanceReport.

	 2.	 �Choose Page Layout→Themes→Themes .

	 3.	 �Choose the Slice theme.

	 4.	 �Choose Home→Font→Fill Color  menu button .

	 5.	 �Choose Page Layout→Themes→Colors →Customize Colors….
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4  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

	 6.	 �Follow these steps to set the colors for Accent 4 and Accent 5:

A

B

E

C

D

A	Click the color menu button  beside Accent 4.

B	Choose Dark Purple, Accent 2, Darker 50%.

C	Click the color menu button  beside Accent 5.

D	Choose Light Turquoise, Text 2, Darker 25%.

E	Type LearnFast in the Name box for the new theme colors and click Save.

	 7.	 �Save the file.

Applying Cell Styles
Excel’s built-in cell styles can be used to give your worksheet a quick, uniform design. The Cell 
Styles option combines formatting such as font, color, fill, and alignment. New cell styles can 
also be created or existing cell styles can be modified; however, these changes would apply only 
to the current workbook.

ÍÍ Home→ Styles →Cell Styles 
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Applying Cell Styles  5

DEVELOP YOUR SKILLS: E1-D2	

In this exercise, you will create and apply cell styles to the worksheet to ensure consistent formatting.

	 1.	 �Save your file as E1-D2-PerformanceReport.

	 2.	 �Ensure you are on the 2016 sheet and select the Total for the Student Enrollments in the 
range A11:C11.

	 3.	 �Choose Home→Styles→Cell Styles .

	 4.	 �In the Titles and Headings group, select the Total style.

	 5.	 �Apply the Total style to the totals for the 3 other categories of data, in the ranges E11:G11, 
I11:K11, and M11:O11. (Hint: You can use the Format Painter if you desire.)

	 6.	 �Select the headings below Student Enrollments in the range A6:C6 and be certain to include 
the blank in cell A6.

	 7.	 �Apply the Heading 3 style to the selected range.

	 8.	 �Apply the same Heading 3 style to the ranges E6:G6, I6:K6, and M6:O6.

	 9.	 �Select cell A2, which contains the text Annual Performance Review.

	10.	 �Choose Home→Styles→Cell Styles →New Cell Style….

	11.	 �Type the new style name, LearnFast Heading, and click OK to accept all other settings.

	12.	 �Apply the LearnFast Heading style to cells A5, E5, I5,  
and M5.

	13.	 �Save the file.
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6  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

Using the Format Cells Dialog Box
Excel has many exciting features available right from the Ribbon, but there are even more 
options for formatting cells in the Format Cells dialog box. The Format Cells dialog box is useful 
when you have a cell or range that requires specific formatting adjustments.

These dialog box launchers on the Home tab offer quick, alternative ways to open the Format Cells dialog box.

The Format Cells dialog box has six tabs with additional options for formatting; the starting tab will depend on which 
method you use to open the dialog box.

ÍÍ Home→ Cells →Format →Format Cells

Cell Borders and Fill
The options for creating borders from the Ribbon are very plain (unless you use the Draw 
Borders features, which can be difficult). Another option is to select the desired cells and open 
the Format Cells dialog box, choose from a gallery of line styles, choose a color, and apply the 
border to the desired area of the selected cell or range. You also can see a preview of all of these 
various options before actually applying them to the worksheet.

Likewise, if you want a cell formatted with a fill other than a solid color, you can open the 
Format Cells dialog box to access fill options, such as gradients and patterns.

DEVELOP YOUR SKILLS: E1-D3	

In this exercise, you will use the Format Cells dialog box to create customized border and fill formatting.

	 1.	 �Save your file as E1-D3-PerformanceReport.

	 2.	 �Select cell A1, which contains the title LearnFast College.

	 3.	 �Choose Home→ Cells →Format →Format Cells.
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Using the Format Cells Dialog Box  7

	 4.	 �Follow these steps to create a unique border:

A

D
C

B

E

A	Click the Border tab.

B	Select the thick dashed line style, the 4th option in the 2nd column.

C	Click the Color menu button  and select Turquoise, Accent 5, Darker 25%.

D	Click the Bottom Border button to add a border at the bottom of the selected cell. 
(Hint: You can also click near the bottom of the preview below the word Text to apply a 
border to the bottom.)

E	Click OK to finish.

	 5.	 �Click cell A5 to select that cell and deselect cell A1, which allows you to see the border you 
just created.

	 6.	 �Select the range A4:O4, the blank row between the titles and the headings.

	 7.	 �Reopen the Format Cells dialog box by clicking the Font Settings dialog box launcher.
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8  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

	 8.	 �Follow these steps to create a pattern fill:

A

B

C

A	Click the Fill tab.

B	Click the Pattern Color menu button  and select Dark Purple, Accent 4.

C	Click the Pattern Style menu button  and select Thin Vertical Stripes.

	 9.	 �Click OK to finish.

	10.	 �Save the file.

Creating Custom Number Formats
Although Excel has many number format options to choose from, there are times that you may 
need to modify the number formatting for your own purposes. For example, you may want to 
add text or symbols to the number formatting, such as 99USD, or you may want to display a 
number with preceding zeroes, such as 000395.

Custom formatting is created in the Format Cells dialog box by using the Custom category and 
typing the desired format. The following table lists some of the common codes that can be used 
to create custom number formatting.
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Creating Custom Number Formats  9

CUSTOM NUMBER FORMATTING

Code Description Example Display
# Digit placeholder, if required ### 123

0 Digit placeholder, always displayed 0000 0123

. Decimal point #.000 1.230

, Thousands separator #,### 1,230

% Percentage #.##% 1.23%

$ - + / ( ) Characters that can be added to the displayed number +$### +$123

“abc” Displays the text inside the double quotes ###”USD” 123USD

[Red] Displays values in the color specified [Red]#,### 123

You can also specify a different format for each of the different types of values: positive values, 
negative values, zero values, and text. Each different format must be created in that specific 
order and separated by a semicolon. For example, you could format positive numbers in blue, 
negative values in red, zero values in black, and all text values in green using the code  
[Blue]General;[Red]General;[Black]General;[Green]General.

View the video “Custom Number Formatting.”

DEVELOP YOUR SKILLS: E1-D4	

In this exercise, you will create custom number formatting to enhance the data display.

	 1.	 �Save your file as E1-D4-PerformanceReport.

	 2.	 �Select the range C7:C11, which shows the change from the previous year to the current 
year.

	 3.	 �Open the Format Cells dialog box by clicking the Number Format 
dialog box launcher.

	 4.	 �Choose Custom from the bottom of the Category list.

	 5.	 �Click inside the Type box, delete General, and enter 
 +0.00%;[Red]-0.00% for the code.
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10  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

	 6.	 �Click OK to apply the new number formatting.

	 7.	 �Use the Format Painter  to apply the same number format to the other columns below 
the Change heading, in the ranges G7:G11, K7:K11, and O7:O11.

	 8.	 �Select the current year revenue data in the range J7:J11.

	 9.	 �Reopen the Format Cells dialog box.

	10.	 �On the Number tab, below Category, select Custom and insert the following code in the 
Type box: $#,###,"K". Click OK.

	11.	 �Use the Format Painter  to copy the current year revenue format to the Current Year 
Expenses in the range N7:N11.

	12.	 �Save the file.

Customizing the Page Setup
The default workbook settings are Normal margins (0.7" left and right, 0.75" top and bottom) on 
ordinary Letter size (8.5" x 11") paper with Portrait orientation. The margin is the white space 
around the edge of your printed document.

You can customize these settings as necessary. For example, you can create narrower margins to 
fit all your data onto one sheet. These page settings are not fully visible from the Normal view; to 
see how your document will look when it is printed (for example, to see the margins or 
orientation), go to the Page Layout view or the Print Preview.
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Adding Images to a Worksheet  11

Adding a Worksheet Background Image
If your worksheet is meant for display on the screen only, a worksheet background can add 
some visual interest and personality. The background will not print, so if you plan to print the 
worksheet, keep this in mind. The background picture can be inserted from your computer files, 
from an online image search using Bing, or from your OneDrive account.

ÍÍ Page Layout→Page Setup

DEVELOP YOUR SKILLS: E1-D5	

In this exercise, you will modify the page setup to fit the data onto one page and insert a background 
picture.

	 1.	 �Save your file as E1-D5-PerformanceReport.

	 2.	 �Choose View→Workbook Views→Page Layout  to switch the view.

	 3.	 �Choose Page Layout→Page Setup→Margins →Narrow.

	 4.	 �Choose Page Layout→Page Setup→Orientation →Landscape.

	 5.	 �Choose Page Layout→Page Setup→Size →Legal.

	 6.	 �Change the view back to Normal view.

	 7.	 �Insert a background by choosing Page Layout→Page Setup→Background .

	 8.	 �Beside From a File, click Browse to insert a file saved on your computer.

	 9.	 �In the dialog box, navigate to your Excel Chapter 1 folder, select the Graduate.jpg 
picture, and click Insert.

	10.	 �Save the file.

Adding Images to a Worksheet
For the most part Excel is used for text and data; however, it is also possible to add pictures and 
shapes to a worksheet. Pictures might be used to display a company logo, add information to a 
spreadsheet, or simply add a little excitement to an otherwise plain set of data. Pictures can be 
added from your computer or from an online search, and many types of shapes can be added via 
the menu button.

Adding a picture lets you access the Picture Tools features on the Ribbon, and adding a shape 
allows you to access the Drawing Tools. Both of these contextual tabs give you a great number of 
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12  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

options for changing the style, shape, color, and size and for modifying many other aspects of 
the image as well.

Allows you to add pictures 
you have already saved on 
your computer

Will insert pictures from OneDrive or 
Bing, a web search engine from Microsoft 
that lets you browse an endless supply of 
images from the Internet

Accesses the shapes library here; browse to 
find the desired shape and click to add it

Using Online Pictures to do a Bing Search for Microsoft Excel returns many variations of the Excel logo.

ÍÍ Insert→Illustrations→Pictures or Online Pictures or Shapes

ÍÍ Insert→Text→Text

ÍÍ For pictures: Picture Tools→Format | For shapes: Drawing Tools→Format

DEVELOP YOUR SKILLS: E1-D6	

	 1.	 �Save your file as E1-D6-PerformanceReport.

	 2.	 �Select cell P1 on the 2015 sheet and then choose Insert→Illustrations→ 
Online Pictures to open the dialog box.

	 3.	 �Search for graduate in the Bing Search, choose a suitable image with a graduation cap, 
and then click Insert. Because this is an online search, the results will frequently change, 
and you may not see the same images from one search to the next. 

	 4.	 �With the image selected, go to Picture Tools→Format→Size→Height , type 1 in the 
box, and then tap [Enter].
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Using Conditional Formatting  13

	 5.	 �Choose Picture Tools→Format→Adjust→Color→Dark Purple, Accent color 2 Light 
(in the Recolor group).

	 6.	 �Save the workbook.

Using Conditional Formatting
View the video “Highlighting Data with Conditional Formatting.”

Another way to better visualize your data is to use conditional formatting. Conditional formatting 
takes a set of data, applies a rule or rules, and modifies the formatting of the cells that match the 
rule. For example, you may have a large set of data containing student grades and want to quickly 
find the top three marks in the class. Or you may have sales data for a group of products and want 
to find which product sells the most and which one sells the least. Conditional formatting applies 
formatting of your choice to the cells that meet these criteria so that you can quickly find them.

Rules can be created to draw attention to the top, or bottom, or to numbers greater than or less 
than a specific number. You can also highlight a cell with a number equal to a specific amount or a 
cell that contains certain text; there are so many options!

To apply conditional formatting, the first step is always to select the entire range of data to apply 
the rule to. For conditional formatting, unlike with charts, you do not include any labels and 
generally don’t include any totals unless you set up a separate rule for total rows or columns. 
Different rule options are available from the Conditional Formatting drop-down menu, but the 
criteria and formatting can also be modified to suit your needs. After a rule has been created, you 
can Clear Rules or Manage Rules to see all existing rules for either the current selection or the 
entire worksheet.

  

After a conditional formatting rule is created, if the data changes, the formatting is 
automatically updated to reflect the new data.

ÍÍ Home→Styles→Conditional Formatting 

The worksheet before creating conditional 
formatting, with the range selected

The worksheet after the conditional formatting rule is 
applied to the range, highlighting the top five items 
with Light Red Fill and Dark Red Text
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14  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

DEVELOP YOUR SKILLS: E1-D7	

	 1.	 �Save your file as E1-D7-PerformanceReport.

	 2.	 �Select the range N7:N10 and choose Home→Styles→Conditional Formatting→ 
Highlight Cells Rules.

	 3.	 �Choose Greater Than and then, in the dialog box that opens, adjust the GREATER THAN 
value to 2000000 (that is, 2,000,000, with no commas needed). The preview shows which 
data this will apply to.

	 4.	 �Click OK to apply the format and close the dialog box.

	 5.	 �You need to see the top and bottom agents, so select the range J7:J10 and choose Home→
Styles→Conditional Formatting→Top/Bottom Rules→Top 10 Items.

	 6.	 �Change the 10 to 1, change the format to Green Fill with Dark Green Text, and click OK.

	 7.	 �With the range J7:J10 still selected, choose Home→Styles→ 
Conditional Formatting→Top/Bottom Rules→Bottom 10 Items.

	 8.	 �Change the 10 to 1, change the format to Yellow Fill with Dark Yellow Text, and click OK.

	 9.	 �Before you update the data, you realize a sale was missed in March, so select cell J7 and 
change the number from 2297777 to 3297777; this causes the formatting in that cell to 
change to show it contains the highest revenue amount. 

	10.	 �Save the workbook.
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Using Zoom Tools  15

Using Zoom Tools
While working in Excel, you may want to adjust the view to focus on one area of your 
worksheet, or you may want to get a broad view of the whole worksheet. Changing the view in 
Excel will not change how the worksheet will print. The Zoom tools allow you to increase or 
decrease the magnification of your worksheet so you can see more or less of the worksheet at 
one time. You can select a range of cells and click Zoom to Selection to focus on just that area of 
the worksheet, or you can jump back to 100% view to see your work in “real” size.

 

ÍÍ View→Zoom 

DEVELOP YOUR SKILLS: E1-D8	

In this exercise, you will use the Zoom tools to focus on different areas of the worksheet.

	 1.	 �Save your file as E1-D8-PerformanceReport.

	 2.	 �Select the student enrollments and grad job placements data in the range A5:G11.

	 3.	 �Choose View→Zoom→Zoom to Selection .

	 4.	 �Choose View→Zoom→100% .

	 5.	 �Choose View→Zoom→Zoom .

	 6.	 �In the dialog box, choose Custom, type 120 in the % box, and click OK.

	 7.	 �On the Zoom slider, click Zoom Out to reduce the 
magnification to 110%.

	 8.	 �Save the file.

The Zoom tools on the Ribbon 
allow you to customize 
magnification settings.

The Zoom slider on the status 
bar allows you to make quick 
adjustments by clicking + or –.
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16  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

Editing Document Properties
The Excel file’s document properties can tell you or anyone else who accesses the file important 
information about the document. The document properties already include information such as 
the date the file was created, the date the file was last modified, the document author (creator), 
and file size. Other information can also be added to the document properties, such as a title, 
subject, tags (keywords), or comments.

ÍÍ File→Info

DEVELOP YOUR SKILLS: E1-D9	

In this exercise, you will modify the document properties to include a title, tags, category, and subject.

	 1.	 �Save your file as E1-D9-PerformanceReport.

	 2.	 �Choose File to go to Backstage view, where the Info tab should be active by default.

	 3.	 �Click in the Add a Title box next to Title, type Final Performance Report, and tap [Tab].

	 4.	 �Enter the remaining document properties as shown below:

	 5.	 �Locate the Show All Properties link at the bottom of the Properties list.

	 6.	 �Click on Show All Properties to expand the list of properties displayed.

	 7.	 �Locate the subject, click the Specify the Subject box, and type  
2015 and 2016 Performance.

	 8.	 �Use the Back button to return to your worksheet.

	 9.	 �Save and close the file, and then exit Excel.
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Self-Assessment  17

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 You can apply a different theme to each worksheet in your workbook.	 True    False

2.	 Each cell style combines formatting such as font, color, fill, and alignment.	 True    False

3.	 You can apply a gradient color to a cell border in the Format Cells dialog box.	 True    False

4.	 After a conditional formatting rule is created, if the data changes, the formatting  
will be automatically updated to reflect the new data.	 True    False

5.	 Page settings such as margins and orientation can be seen and changed from the  
Normal worksheet view.	 True    False

6.	 Document properties are visible only to the author or creator of the file.	 True    False

7.	 A theme is made up of which three elements?

A.	Colors, fonts, and shapes

B.	 Colors, numbers, and effects

C.	 Colors, fonts, and effects

D.	Margins, orientation, and size

8.	 Alison created a new cell style, which she can use to apply the same formatting to headings in:

A.	The same worksheet

B.	 Any Excel file

C.	 Any Office document

D.	Any sheet in the current workbook

9.	 When you open the Format Cells dialog box, the active tab will be:

A.	Either Border or Fill

B.	 Any of the tabs, depending on how you open the dialog box

C.	 Border

D.	Number, Alignment, or Font

10.	 Jenny is sending a price list to a Canadian customer, and she wants to ensure the customer understands 
the prices are in U.S. Dollars by adding the text USD as well as the dollar sign to each number. The 
custom number format code Jenny should use is:

A.	“USD”00000

B.	 $,###USD

C.	 $#,###”USD”

D.	$0,000”USD”

(continued)
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18  FastCourse Excel 2016  Chapter 1: Advanced Workbook Formatting

11.	 Brian wants to impress his boss by creating a custom number format for the company’s year-end 
reports; if Brian uses the code [Blue]+0.0%;[Red]-0.0%;General, which image would represent his 
worksheet display?

A.	

B.	

C.	

D.	

12.	 You have selected the range A1:M19 and want to see only this data on your screen. You should choose:

A.	View→Zoom→Zoom to Selection

B.	 View→Zoom→200%

C.	 View→Zoom→Custom 150%

D.	View→Zoom→100%

13.	 After inserting a picture or shape on a worksheet, which aspects of the image’s appearance can you edit?

A.	 Its size and style

B.	 Its size and color

C.	 Its style and color

D.	 Its size, style, and color
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In this chapter, you will use a variety of 
methods to work with an important type 
of data in Excel: date and time 

information. You will also explore creating 
and customizing conditional formatting 
rules to gain valuable insight into the data 
in your worksheet.

L E A R N I N G  O B J E C T I V E S
■■ Identify date serial numbers

■■ Apply custom date formatting

■■ Enter times in Excel

■■ Create functions using dates

■■ Perform date and time calculations

■■ Create customized conditional formatting rules

■■ Edit rules using the conditional formatting rules 
manager

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 1 hr 30 mins

■■ Self-Assessment: 20 mins

■■ Total: 1 hr 50 mins

P R O J E C T:  P R E PA R I N G  C O M PA N Y 
D O C U M E N T S
Airspace Travel prides itself on providing top-notch 
customer service. As part of its service plan, it 
carefully tracks its customers’ travel dates and flight 
times, as well as the frequency of their trips. You 
have been given the task of reviewing and updating 
this information.

2Date Functions and 
Conditional Formatting

E X C E L  2 0 1 6
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20  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

Understanding Date Serial Numbers
In Excel, dates are stored as sequential serial numbers so they can be used in calculations. To 
understand dates in Excel, you must also know that Excel dates start with January 1, 1900. The 
serial number for January 1, 1900, is 1, and the serial numbers count up by 1 for each day after 
that date. For example, the serial number 501 represents May 15, 1901, which is exactly 500 
days after January 1, 1900.

By using serial numbers for dates, Excel can use dates in calculations and functions. For 
example, you can use a formula to find the days until a payment is due by taking the due date 
and subtracting today’s date.

The formula in cell C2 is =B2-A2.

Applying Custom Date Formatting
There are many ways to enter a date into a cell, and depending on how you enter a date into a 
cell, Excel will apply one of the default date formats, usually either 4/15/2016 or 15-Apr. You 
have the option of adjusting the date formatting using the Number Format drop-down menu or 
applying custom date formatting. The Number Format menu gives you two options, Short Date 
and Long Date; for example, 4/15/2016 and Friday, April 15, 2016, respectively.

Additional date formatting options are available from the Format Cells dialog box, either in the 
Date category or the Custom category. Each Category has many options to choose from under 
Type.

In Custom format, d represents the day, m represents the month, and y represents the year. 
Below are some examples of date formatting from both categories.
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Understanding Date Serial Numbers  21

CUSTOM DATE FORMATTING

Category Format Type Description Display for 
April 15, 2016

Date 3/14 Month/Day 4/15

3/14/12 Month/Day/Year 4/15/16

March-12 Month-Year April-16

March 14, 2012 Month Day, Year April 15, 2016

Custom d-mmm Day-Month 15-Apr

d-mmmm Day-Month 15-April

d-mmm-yy Day-Month-Year 15-Apr-16

dddd mmmm “the” d Weekday Month the Day Friday April the 15

View the video “Custom Date Formatting.”

DEVELOP YOUR SKILLS: E2-D1	

In this exercise, you will enter dates, use the dates to do a simple calculation, and then apply different 
formatting to the dates.

	 1.	 �Start Excel and open a new, blank workbook.

	 2.	 �Save the file in your Excel Chapter 2 folder as E2-D1-DaysOld.

	 3.	 �In cell A1, enter today’s date by typing it into the cell in the format mm/dd/yyyy and then  
tap [Enter].

	 4.	 �In cell A2, enter your birth date using the same format and again tap [Enter].

	 5.	 �In cell A3, enter the formula =A1-A2 and complete the entry.

	 6.	 �Select the two dates in the range A1:A2 and choose Home→ 
Number→Number Format menu button →General.

	 7.	 �With the same range selected, choose Home→ Number→ 
Number Format menu button →Long Date.

	 8.	 �In cell B3, type days old and tap [Enter].

	 9.	 �Save the file and close it.

	10.	 �Open E2-D1-Invoices from your Excel Chapter 2 folder and save it as E2-D1-Clients.

	11.	 �Select the invoice dates in the range G4:G13.

	12.	 �Open the Format Cells dialog box by clicking the Number Format 
dialog box launcher.

	13.	 �Choose Custom from the Category list.

	14.	 �In the Type box, enter the code mmm-d and click OK.

	15.	 �Select the travel dates in the range J4:J13.

	16.	 �Open the Format Cells dialog box once again and choose Custom 
from the Category list.
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22  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

	17.	 �In the Type box, enter the code ddd mmm-d and click OK.

	18.	 �Save the file.

Entering Time Information in Excel
Much like dates, times can be entered into Excel the way you want them to appear. For example, 
if you type 6:00 into a cell, Excel will recognize this as a time entry. Also, like dates, each time 
has a serial number attached to it. Because each day is 1, each hour is 1/24, or 0.041667 if 
written as a decimal. Therefore, if you enter 6:00, Excel displays the time as 6:00 but stores the 
information as 0.25 (six hours is one-quarter of the day). Combining the date and time together 
would mean that 12:00 noon on July 1, 2010 is stored with the serial number 40360.5; the date 
serial number is 40360, and the time is 0.5, halfway through the day.

Most of the time, however, you don’t have to worry about the serial number; as long as the time 
is entered correctly, Excel will apply the correct custom number formatting. You can also add the 
AM/PM designation, rather than using a 24-hour clock, but you must enter a space between the 
time and either AM/PM. You can enter 6:00 AM for the morning or 6:00 PM for the evening. If 
no designation is entered, Excel assumes you are using the 24-hour system and so 6:00 is stored 
as 6:00 AM. You can also use number formatting to customize the way the time displays on the 
worksheet.

TIME ENTRIES

Entry Display Time Stored As
6:00 6:00 6:00:00 AM or 0.25

9:00 AM 9:00 AM 9:00:00 AM or 0.375

12:00 12:00 PM 12:00:00 PM or 0.5

13:30 13:30 1:30:00 PM or 0.5625

DEVELOP YOUR SKILLS: E2-D2	

In this exercise, you will enter the times for clients’ flights into the worksheet.

	 1.	 �Save your file as E2-D2-Clients.

	 2.	 �Select the flight times in the range M5:M10.

	 3.	 �Choose Home→Number→Number Format menu button →General.

	 4.	 �Ensure only the flight times in the range M5:M10 are still selected and then open the 
Format Cells dialog box by clicking the Number Format dialog box launcher.

	 5.	 �Choose Time from the Category list.
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Using Date Functions  23

	 6.	 �Below Type, select the 3rd option, which will display hours:minutes AM/
PM, and click OK.

	 7.	 �Enter the remaining clients’ flight times into the range M11:M13.  
(Be sure to type hour:minutes AM/PM to display the correct designation  
for AM or PM.)

	 8.	 �Save the file.

Using Date Functions
As you may have noticed, Excel has many Date functions available in the Function Library. 
Dates are commonly found in Excel sheets because they provide useful information about when 
a particular event or transaction took place. Date information becomes even more useful if you 
can use those dates in formulas and functions. For example, date functions can be used to insert 
the current date or to extract information from a date such as the month or year.

Date functions are entered just like other functions, such as SUM. For example, the TODAY 
function can be used to enter today’s date by entering =TODAY(). For this function, no 
arguments are entered inside the brackets. Other examples of date functions can be found in 
the table below.

DATE FUNCTIONS

Function Description

TODAY()
No arguments are inserted inside the brackets. It displays the current date based 
on today’s serial number; the formula updates the date automatically when the 
worksheet is recalculated or reopened.

NOW()
No arguments are inserted inside the brackets. This function is similar to the 
TODAY function but also displays the time, based on your computer’s clock.

DATE(year,month,day) This function returns a specific date, based on the arguments entered. 

Example: Result:

=DATE(2020,12,20) 12/20/2020

YEAR(date)
Use this function to return the year of the specified date, which can be entered 
as a serial number or as a cell reference to a cell containing a date.

Example: Result:

=YEAR(B23) 2020
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24  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

DEVELOP YOUR SKILLS: E2-D3	

In this exercise, you will use date functions to enter date-related information into your worksheets.

	 1.	 �Save your file as E2-D3-Clients.

	 2.	 �Insert a new row above the column headings in row 3 of the worksheet.

	 3.	 �In cell D3, type Month: and tap [Tab].

	 4.	 �In cell E3, enter the formula =G5 and complete the entry.

	 5.	 �With cell E3 still selected, choose Home→Number→Number Format menu button → 
More Number Formats.

	 6.	 �Ensure the Category is Custom and then in the Type box edit the Type code to display mmmm 
only and click OK.

	 7.	 �Merge & Center the range E3:F3.

	 8.	 �Select cell H3, enter Year:, and tap [Tab].

	 9.	 �In cell I3, enter the formula =YEAR(G5) and complete the entry.

	10.	 �Merge & Center the range I3:J3.

	11.	 �Go to the Client History worksheet.

	12.	 �Insert a new row above the column headings in row 3 on the worksheet.

	13.	 �In cell A3, enter As Of: and then Merge & Center the range A3:B3.

	14.	 �In cell C3, enter the formula =TODAY() and then Merge & Center the range C3:F3.

	15.	 �Apply the Long Date number format to cell C3.

	16.	 �Save the file.

Entering Date and Time Calculations
When you understand the basic principles of dates and time in Excel, there are many useful 
ways to use this information. You can perform mathematical operations such as addition and 
subtraction to subtract two dates or add a number of days to a particular date. Likewise, you can 
take two times and find the difference or add or subtract hours or even minutes. You can also 
combine these mathematical operations with the date functions for even more applications.

For example, you could use the TODAY function to enter today’s date and enter a future date 
such as Christmas and then subtract the two to find out how many days there are until 
Christmas. Of course, in business, there are much more practical applications.

EX16_Level2FC.indb   24 12/15/2016   2:27:27 PM

FastCourse Excel  2016 Level 2   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Working with Conditional Formatting  25

DEVELOP YOUR SKILLS: E2-D4	

In this exercise, you will use date functions to enter date-related information into your worksheets.

	 1.	 �Save your file as E2-D4-Clients.

	 2.	 �Go to the Sept worksheet and select cell L5 below the Balance Due Date heading.

	 3.	 �In cell L5, enter the formula =EDATE(J5,3) and complete the entry.

	 4.	 �Copy the formula down the column for the remaining clients.

	 5.	 �Select cell N5, enter the formula =M5-(1/24*3), and then complete the entry.

	 6.	 �Copy the formula down the column for the remaining clients.

	 7.	 �Go to the Client History worksheet and insert a column to the left of column F.

	 8.	 �In cell F4, insert the heading Days Since Travelled and tap [Enter].

	 9.	 �In cell F5, enter the formula =$C$3-E5.

	10.	 �With cell F5 still selected, choose Home→Number→Number Format menu button → 
General.

	11.	 �Copy the formula down the column for the remaining clients.

	12.	 �Insert a column to the left of column E.

	13.	 �In cell E4, enter the heading Years of Loyalty and tap [Enter].

	14.	 �In cell E5, insert the formula =YEARFRAC(D5,$C$3)to find the number of years since 
each customer first became a client, represented by a fraction rather than just a calculation 
of the number of days.

	15.	 �Choose Home→Number→Comma Style  to apply the comma number format.

	16.	 �Choose Home→Number→Decrease Decimal  to reduce the decimals to 1.

	17.	 �Now copy the formula in cell E5 down the rest of the column.

	18.	 �Save the file.

Working with Conditional Formatting
The Conditional Formatting command applies formatting to the cells that meet the criteria you 
set. There are preset options for conditional formatting that can be applied to the top or bottom, 
or greater than, less than, or equal to, for example. You can create multiple rules for the same set 
of data, and the rules are applied in the order that you choose. Conditional formatting is always 
updated whenever the data in the applied range changes.

If no preset item on the Conditional Formatting menu has your desired criteria, you can create a 
new conditional formatting rule. New rules can be created using the same basic principles as the 
preset rules; however, you can customize the specific way the rules are applied. You can also 
create conditional formatting rules based on the outcome of a formula.
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26  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

Conditional Formatting with Graphics
Another option for conditional formatting is to use data bars, color scales, or icon sets. These 
options provide an alternative way of visualizing your data by breaking data into three parts: 
values that are above average, average, and below average in the selected range. There are many 
quick options to choose from in the Conditional Formatting menu, but again these graphics can 
also be added by creating a custom rule.

This data uses conditional formatting with data bars, a color scale, and an icon set to highlight trends or important 
information.

Using the Conditional Formatting Rules Manager
The Conditional Formatting Rules Manager can be used to create, edit, and delete rules or to 
rearrange the order in which they are applied. To see which rules have been created, you can 
choose to Show Formatting Rules for the current selection or the entire worksheet.

The Rules Manager allows you to add new rules and edit and delete existing rules. In this example, you see the four 
rules on the current worksheet as well as the ranges the rules apply to.

DEVELOP YOUR SKILLS: E2-D5	

In this exercise, you will create and modify conditional formatting rules to highlight important 
information about your clients.

	 1.	 �Save your file as E2-D5-Clients.

	 2.	 �Ensure you are on the Client History worksheet and, if necessary, select the data under 
Years of Loyalty in the range E5:E14.

	 3.	 �Choose Home→Styles→Conditional Formatting →Icon Sets→3 Stars (the first 
option in the Ratings group).
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Working with Conditional Formatting  27

	 4.	 �In cell A17, enter Loyalty Program, Merge & Center the range A17:B17, and apply a 
thick bottom border.

	 5.	 �Enter the qualifications for Silver and Gold status in the range 
A18:B19, as shown here.

	 6.	 �To edit the existing rule, choose Home→Styles→ 
Conditional Formatting →Manage Rules.

	 7.	 �Follow these steps to edit the rule:

A

B

D C
E

A	Select This Worksheet to show all rules on the worksheet.

B	Click Edit Rule.

C	In the Edit Formatting Rule dialog box, change the Type to Formula for both Values.

D	Click inside the box for the first value and then click cell B19 on the worksheet.

E	Click inside the box for the second value and then click cell B18 on the worksheet.

	 8.	 �Click OK to finish editing the rule and then click OK to close the Rules Manager.

	 9.	 �Go to the Sept worksheet and select the Invoice Date data in the range G5:G14.

	10.	 �Choose Home→Styles→Conditional Formatting →New Rule.
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28  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

	11.	 �Follow these steps to create the new rule:

A

C

B

A	Select Use a Formula… to determine which cells to format.

B	Enter the formula =(J5-G5)<30 to format values when this formula is true.

C	Click Format and edit the Fill by selecting Blue, Accent 5, Lighter 40% (the 9th 
column, 4th row; there is not a screen tip to display the color name).

	12.	 �Click OK  to close the Format Cells dialog box and click OK again to create and apply the  
new rule.

	13.	 �Save the file.
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Self-Assessment  29

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 The date formatting code mmm displays the first 3 letters of the month only.	 True    False

2.	 Using serial numbers for dates allows Excel to use dates to perform calculations,  
such as subtracting one date from another to find the number of days in between.	 True    False

3.	 The serial number for a day is counted as 1; therefore, 12 hours, or half a day, is  
counted as 0.5.	 True    False

4.	 If you enter the formula =TODAY() on December 16 and then reopen the Excel file  
the next day, the cell will show the date of December 17.	 True    False

5.	 Sharon wants to automatically add 8 days to her customer’s order dates to calculate  
the expected delivery date. If the order date is in cell B7, the formula will be =B7+8.	 True    False

6.	 The Conditional Formatting Rules Manager can be used to create, edit, and delete  
rules or to rearrange the order in which they are applied.	 True    False

7.	 If the serial number 1207 is a Tuesday, what day of the week would serial number 1210 be?

A.	Monday

B.	 Tuesday

C.	 Friday

D.	Saturday

8.	 The following formula will return what result, in hours and minutes?

A.	1:30

B.	 2:00

C.	 2:03

D.	2:30

9.	 The formula =DATE(2017,7,2) will return which date?

A.	July 2, 2027

B.	 February 7, 2017

C.	 February 2, 2017

D.	July 2, 2017

10.	 If you want to find the difference between 2 dates listed in years instead of days, you can use this 
function:

A.	YEAR

B.	 DATE

C.	 EDATE

D.	YEARFRAC
(continued)
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30  FastCourse Excel 2016  Chapter 2: Date Functions and Conditional Formatting

11.	 Which of the following is NOT true regarding the Conditional Formatting Rules Manager?

A.	 It allows you to create, edit, and delete rules.

B.	 It allows you to rearrange the order of rules.

C.	 Once you create a conditional rule, it cannot be changed; you must delete it and create a 
new one.

D.	 It allows you to view rules for a selection of cells or the entire worksheet.

12.	 If the actual amount of rent were to go up to 26,000 and Difference is calculated as Budget minus Actual, 
which conditional formatting graphics would change?

A.	Actual

B.	 Budget

C.	 Both Actual and Budget

D.	Both Actual and Difference

EX16_Level2FC.indb   30 12/15/2016   2:27:28 PM

FastCourse Excel  2016 Level 2   FOR EVALUATION ONLY © 2017 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



In this chapter, you will learn new 
functions that give you greater ability for 
analysis and decision making. They 

include functions that either sum or count 
values that meet certain criteria. You will 
also explore functions that can be used to 
clean up or rearrange text on your 
worksheet, as well as learn what you can 
do when you find formula errors in your 
worksheet.

L E A R N I N G  O B J E C T I V E S
■■ Use functions to format text

■■ Create conditional functions using IF and IFS 
criteria

■■ Create formulas using nested functions

■■ Find and correct errors in formulas

■■ Use 3-D cell references in formulas

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs

■■ Self-Assessment: 20 mins

■■ Total: 2 hrs 20 mins

P R O J E C T:  A N A LY Z I N G  S A L E S 
I N F O R M AT I O N
The Airspace Travel monthly sales results are in, and 
the data has been compiled for all of the company 
agents and managers in a worksheet for your review. 
Because the data was imported from different 
sources, you need to do some clean up to fix the text 
entries, and then you will use various conditional 
functions to pull out important information about 
specific performance.

3Advanced Functions for 
Text and Analysis

E X C E L  2 0 1 6
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32  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

Using Functions to Modify Text
When workbook data comes from sources other than Excel, the data can sometimes be 
formatted incorrectly. Data may also have been entered by multiple users, with different 
methods of data entry. For example, one person might enter names into a worksheet using all 
capital letters, and another person might capitalize the first letter of the name only. Then when 
the two worksheets are combined, they won’t match. Another problem can occur when data is 
either entered into too few or too many columns, such as entering First Name and Last Name 
together in one column when it is supposed to be entered in separate columns.

Although many people primarily think of Excel as working with numbers, there are quite a few 
text functions that allow you to work with text as well. Text functions can be used to fix the 
issues mentioned or to manipulate text data to be used for a different purpose. There are 
functions that let you change case, combine or separate text, remove spaces, and extract or even 
replace text.

Changing Case
PROPER, UPPER, and LOWER are three functions that allow you to change the case of the input 
text. PROPER converts the first letter of each word to uppercase (capital) and all other letters to 
lowercase. As you can probably guess, UPPER converts all letters to uppercase and LOWER 
converts all letters to lowercase.

As you can see, the function argument is simply the text to convert and can be a cell reference or the text itself.

Extracting Text
In some cases, only a part of the cell contents is needed, or there may be extra characters or 
spaces that you don’t want. The LEFT, MID, and RIGHT functions will extract a certain number 
of characters from the text string. The TRIM function removes all spaces except for a single 
space between words.
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Using Functions to Modify Text  33

The LEFT and RIGHT functions take two arguments: the text 
(which can be actual text or a cell reference) and the number 
of characters to extract.

The MID function requires three 
arguments: the text, the position of the 
first character to extract, and then the 
number of characters to extract.

The TRIM function’s only argument is 
the text from which to remove the spaces.

Combining and Separating Text
The CONCATENATE function allows you to combine two or more separate text entries into one 
cell. The Flash Fill feature is an even better option, as it can also combine multiple entries into 
one or extract text from one text string into multiple entries, in addition to having a number of 
other applications. By entering a couple of examples, Flash Fill will look for patterns and 
automatically fill in the remaining values.

For example, if you have a column with First Name and another column with Last Name, 
Concatenate can be used to combine the two names into one cell. Flash Fill could do this but 
could also do the opposite task; take one name and separate it into First and Last. You could use 
Flash Fill to extract one part of the cell only, such as the first three letters of the last name, or 
extract the area code from a phone number. Using these functions, you can also append or insert 
text, such as automatically creating email addresses from an employee list.
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34  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

The main difference is that Flash Fill will use adjacent data only, whereas CONCATENATE uses 
a cell reference so the text could be anywhere on the worksheet or even on another worksheet.

The function arguments are either cell references or actual 
text. Notice the second argument, “ “, inserts the text inside 
quotations, which is a space, between the First Name in 
cell A2 and the Last Name in cell B2.

Column C uses the CONCATENATE function to combine 
the text in column A and column B into one cell.

The original data is in column A.
The Area Code 232 was manually entered in cell B2, 
and the remaining area codes in column B were entered 
using Flash Fill (from the Data tab on the Ribbon).

The Flash Fill Options button can 
Undo or Accept the suggested entries.

Other Text Functions
Exploring some of the other text functions available in Excel can be useful in certain 
circumstances. There are text functions that allow you to replace or substitute text within a text 
string, functions for finding the text’s position, or functions to calculate text length. You can 
even insert a function that will repeat a text character a specified number of times. Some of 
these examples of additional text functions are described in the table below.
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Using Functions to Modify Text  35

TEXT FUNCTIONS

Function Description Example
REPLACE Replaces part of a text string 

with a different text string; for 
example, replacing digits in a 
credit card number to display 
8181-xxxx-xxxx-1188

Cell B1: 8181-3011-1103-1188
Formula: =REPLACE(B1,6,9,”xxxx-xxxx”)
Result: 8181-xxxx-xxxx-1188

SUBSTITUTE Looks for an exact match 
(case-sensitive) and replaces 
old text with new text if found; 
for example, replacing Mgr with 
Manager

Cell B4: Mgr
Formula: =SUBSTITUTE(B4,"Mgr","Manager")
Result: Manager

LEN Determines the number of 
characters in a cell entry

Cell B7: 2223334444
Formula: =LEN(B7)
Result: 10

REPT Repeats text, for example, 
repeating the letter A five times

Formula: =REPT("A",5)
Result: AAAAA

ÍÍ Data→Data Tools→Flash Fill

ÍÍ Formulas→Function Library→Text

DEVELOP YOUR SKILLS: E3-D1	

In this exercise, you will use text functions to clean up the text entries in the Airspace Sales Results 
worksheet.

	 1.	 �Start Excel, open E3-D1-Sales from your Excel Chapter 3 folder, and save it as  
E3-D1-SalesAnalysis.

	 2.	 �Insert a new column to the left of column A.

	 3.	 �In cell A5, enter the formula =PROPER(B5) and then fill the formula down the column 
and AutoFit the column width.

	 4.	 �With the range A5:A33 still selected, choose Home→Clipboard→Copy .

	 5.	 �Without changing the selection, choose Home→Clipboard→Paste →Values to paste 
the values only (not the formulas) into the selected range.

	 6.	 �Now delete the names from the range B5:B33.

	 7.	 �Insert a column to the left of Location in column E.

	 8.	 �In cell E5, enter the function =LEFT(D5,6) and then fill the formula down the column, 
making sure to use the Auto Fill Options to fill without formatting.

	 9.	 �With the range E5:E33 still selected, copy the formulas and then use Paste Options to 
paste the values only into column D.

	10.	 �Delete the formulas from the range E5:E33.
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36  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

	11.	 �In cell E5, enter the function =CONCATENATE(F5,” “,G5) and then fill the formula 
down the column (again fill without formatting).

	12.	 �With the range E5:E33 still selected, copy the formulas and then paste the values only into 
cell F5.

	13.	 �Delete the formulas from the range E5:E33 and the text in the range G5:G33.

	14.	 �In cell B5, enter the name Alexander and then complete the entry.

	15.	 �Now choose Data→Data Tools→Flash Fill to fill the first names down column B.

	16.	 �In cell C5, enter the name Robertson, complete the entry, and use Flash Fill to again fill 
in the rest of the last names down the column.

	17.	 �Delete column A, removing it entirely from the worksheet.

	18.	 �In cell D4, enter the heading Email.

	19.	 �In cell D5, enter the email address for Alexander, which is Alexander.Robertson@ 
airspace.com.

	20.	 �Double-click the fill handle to copy the email address down column D; in the Auto Fill 
Options, choose Flash Fill to insert the proper email addresses for all other employees in 
the column.

	21.	 �In cell F5, type Miami without a space, complete the entry, and use Flash Fill to fill the 
rest of the column.

	22.	 �Move the Location heading from cell E4 to cell F4 and delete column E.

	23.	 �Save the file.

Creating Conditional Functions Using IF 
Criteria

Conditional functions allow you to sum, count, or find the average of a range of cells if the cells 
meet your desired criteria. One criterion is entered for the IF functions and multiple criteria are 
entered for the IFS functions.

IF CRITERIA FUNCTIONS

Function Arguments [Optional]
SUMIF =SUMIF(range,criteria,[sum range])

AVERAGEIF =AVERAGEIF(range,criteria,[average range])

COUNTIF =COUNTIF(range,criteria)

SUMIFS =SUMIFS(sum range,range1,criteria1,range2,criteria2…)

AVERAGEIFS =AVERAGEIFS(average range,range1,criteria1,range2,criteria2…)

COUNTIFS =COUNTIFS(range1,criteria1,range2,criteria2…)
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Creating Conditional Functions Using IF Criteria  37

Function Syntax

IF CRITERIA FUNCTION ARGUMENTS

Arguments Description
Range These are the cells to be compared with the criteria.

Criteria They can be a comparison value or text, or an expression using a comparison 
operator such as =, >, <, >=, <=, <> (not equal to).

Sum range (Optional) This is the range to be summed, which can be different from the range 
being compared with the criteria. If Sum range is omitted, the range is summed.

Average range (Optional) Like Sum range, this is the range to be averaged.

Using the conditional functions allows you to create formulas to find out information such as:

■■ How many of your customers live in Florida?

■■ How many employees in the Human Resources division have salaries greater than $50,000?

■■ What are the total sales of product #2152?

For example, if you want to discover the total sales of product #2152 for employees in San 
Antonio, you would use the SUMIFS function because there are two criteria—the product and 
the city. The arguments would be the sum range: criteria1, range1, criteria2, range2.

The Sum Range refers to the sales, 
to be added together from column C.

Criteria_Range1 is the 
product #s in column A.

Criteria1 is the product 
number 2152; no = sign 
is needed.

Criteria_Range2 is 
the city, in column B.

Criteria2 is “San Antonio”, 
entered in quotations (or 
Excel adds quotes).

The formula in cell G3 is shown in the Formula Bar.

The preview of the 
formula result is 
shown here.

The function arguments dialog box makes it easier to enter the arguments because it can be 
difficult to keep track of the arguments when entering them directly in a cell. The dialog box 
also shows a preview of the formula result as you add more conditions. The result of the formula 
above is shown in the worksheet here.
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38  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

DEVELOP YOUR SKILLS: E3-D2	

In this exercise, you will use conditional functions to obtain information about the Miami sales team’s 
performance.

	 1.	 �Save your file as E3-D2-SalesAnalysis.

	 2.	 �In cell K5, enter Miami Employees.

	 3.	 �In cell L5, enter the formula =COUNTIF(E5:E33,"Miami").

	 4.	 �In cell K6, enter Miami Employee Commissions.

	 5.	 �In cell L6, enter the formula =SUMIF(E5:E33,"Miami",I5:I33). The range and the 
criteria are the same, but the SUMIF function also uses the sum range, which represents 
the commissions in the range I5:I33.

	 6.	 �Format cell L6 as Currency with no decimals.

	 7.	 �In cell K7, enter Miami Average Sales.

	 8.	 �In cell L7, enter the formula =AVERAGEIF(E5:E33,"Miami",H5:H33).

	 9.	 �Format cell L7 as Currency with no decimals.

	10.	 �In cell K8, enter Miami Employees – Sales >$10,000.

	11.	 �In cell L8, enter the formula =COUNTIFS(E5:E33,"Miami",H5:H33,">10000").

	12.	 �In cell K9, enter Toronto Employees – Sales >$10,000 and adjust the width of 
column K using AutoFit.

	13.	 �In cell L8, enter the formula =COUNTIFS(E5:E33,"Toronto",H5:H33,">10000").

	14.	 �In cell K10, enter Miami Mgr Comm's - Sales <$10,000.

	15.	 �In cell L10, enter the formula =SUMIFS(I5:I33,E5:E33,"Miami",F5:F33, 
"Manager",H5:H33,"<10000"). (Hint: Use the Function Arguments dialog box,  
if desired, to enter formulas with several criteria, such as this one.)

	16.	 �Format cell L10 as Currency with no decimals.

	17.	 �Save the file.
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Nested Functions  39

Nested Functions
In Excel it is possible to use functions inside of other functions. This is called Nesting functions, 
or a Nested function. Although this can be quite challenging with some functions, it can be fairly 
simple with other functions.

For example, when you use the AVERAGE function, you often get a long set of decimal places in 
the result. While you can adjust the Number Format, which will change the display of the 
number, the formula will store those decimal places for future calculations. In some cases, you 
might want to remove the decimal places altogether from the stored value, and this can be done 
by using a second function, the ROUND function. Thus, in the same cell, you could nest the 
AVERAGE function inside of the ROUND function to achieve the desired result.

This formula would use the AVERAGE function for the range F5:F52, and then the ROUND function would round the 
results to zero decimal places.

Another example would be to create an IF function within an IF function if you needed more 
than one criterion to determine the result. For example, you could use the IF function to 
determine whether an employee achieved a sales goal and then inside that function place 
another IF function to determine if the employee also achieved a minimum number of sales.

DEVELOP YOUR SKILLS: E3-D3	

In this exercise, you will use nested functions to adjust the result of one formula and to calculate an 
employee bonus in another formula.

	 1.	 �Save your file as E3-D3-SalesAnalysis.

	 2.	 �Select the Miami Average Sales Amount in cell L7.

In the first IF function, the Logical_Test 
determines IF C3>B3; are Sales greater 
than the Goal?

If Sales are greater than the goal, the Value_If_True
is another IF function, which is used to determine 
IF D3>15; does the employee have a minimum of 15 sales?

The value if this is also true is “Yes,” 
meaning each employee must have 
more than 15 sales and achieved their 
goal to return a “Yes.”

If either of these is not true, 
the Value_If_False for both is “No.”
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40  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

	 3.	 �Increase the decimal to show 3 decimal places.

	 4.	 �Now follow these steps to edit the formula:

C A B

A	In the Formula Bar, click to place the insertion point before AVERAGE and type 
ROUND(.

B	Click the right side of the Formula Bar and type ,0) at the end of the formula.

C	Click Enter on the Formula Bar to complete the changes.

	 5.	 �In cell L7, decrease the decimal to remove the decimals from the display.

	 6.	 �Select cell J4 and insert a new worksheet column.

	 7.	 �In cell J4, enter the heading Bonus.

	 8.	 �Open the Insert Function dialog box and select the IF function.

	 9.	 �Follow these steps to create a nested IF function:

A

D

B
C

A	In the Logical_Test, enter H5>G5 to determine whether sales were greater than the 
target.

B	In the Value_If_True, for employees who did meet their target, you must determine 
whether their commission was less than $1,000 by entering (IF(I5<1000,.

C	In the same box, continue by entering H5*2%,0)), which will return H5(Sales) times 
2% if this is also true and 0 if the second condition is not met.

D	In the Value_If_False field, enter 0 if the first condition is not met.

	10.	 �Click OK to enter the formula.

	11.	 �Fill the formula down the column for all other employees.

	12.	 �Save and close the file.
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Troubleshooting Formulas  41

Troubleshooting Formulas
As you can see, working with formulas can sometimes be challenging. Excel’s auditing tools can 
make sense of your worksheet when it contains a complex set of formulas. The auditing tools 
can help you identify which cells were used to create a formula or where the current cell is being 
used in other formulas, as well as locating and correcting errors in formulas.

Trace Precedents and Dependents
The Trace Precedents command displays arrows pointing to the current active cell from any cells 
that were used to produce the result. Trace Precedents work backwards from the selected cell to 
show which cells affect the current result. Because the precedent cells could also use input from 
other cells to produce their results, there can be several layers of precedents. Repeating the Trace 
Precedents command will display the next level of precedents until a warning sound indicates 
there are no more levels.

 

Although you can see which cells are used in a formula by looking at the formula in the Formula 
Bar, Tracing Precedents is much quicker and gives you an easier way to visualize the flow of data 
through the worksheet.

Adding another level to Trace Precedents 
shows that the totals use the information in 
the Goal and Sales columns.

With the current cell showing the Sales 
Above Goal, Trace Precedents is used to show 
that the Total Goal and Total Sales cells are 
used to calculate the amount of $350.
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The Trace Dependents command shows the opposite of the precedents; it shows you any cells 
that use the current cell in a formula. Like Precedents, there can be layers of dependent cells, 
which are displayed by repeating the Trace Dependents command. Changing the value in the 
current cell will therefore have an effect on all of the dependent cells.

 

Another way to think of it is to think of tracing precedents as looking backward, to see where 
the information comes from, and tracing dependents as looking forward, to see where the 
information is being used. When you no longer need the arrows, you can simply use the Remove 
Arrows command to remove them.

View the video “Tracing Formulas.”

Checking for Errors
The Error Checking tool can help you spot and correct errors in formulas. This can be 
particularly useful if you are reviewing someone else’s work, and you aren’t sure where the 
errors are located. If it is your own work, you would usually fix errors as you go along.

Errors in cells are indicated by an indicator triangle, and sometimes by an error message in the 
cell instead of the formula result.

Some of the common errors found in formulas are given in the table below.

The current cell shows Bert’s number  
of sales, and by using Trace Dependents 
you see that Bert’s sales amount is used to 
calculate total sales.

By adding another level, you see that total 
sales is then used to calculate the average 
sale.

The green error 
indicator triangle 
displays in the top 
left of an unselected cell 
that contains an error.

Selecting a cell with an error 
displays the warning sign.

Clicking on the warning sign 
displays the options for 
dealing with the error.
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COMMON EXCEL FORMULA ERRORS

Error Description
#DIV/0! Dividing by zero is not possible, so this error displays if a formula attempts 

to divide by a cell that contains zero or divides by an empty cell.

#REF! You will see this error if a formula contains an invalid cell reference; for 
example, if a formula refers to cell A1 and row 1 or column A is deleted.

#VALUE! This is another common error, which usually occurs because the formula 
is attempting to perform a mathematical operation using a cell that 
contains text.

#NAME? This error occurs when a formula contains an incorrect function name or 
an undefined name for a cell or range.

Formula Omits Adjacent Cells This error does not display in the result cell but appears as a suggested 
error when a formula refers to a column or row of data but does not 
include all adjacent numerical values.

Evaluate a Formula
When reviewing a complex formula, it can be useful to break the formula down into steps and 
watch how Excel solves the formula. This can help to discover the source of an error or explain 
why the result does not look the way you expected it to. Not all mistakes are caught by Excel 
showing an error; sometimes a valid formula is simply showing the incorrect information 
because it was not created with the correct cell references, functions, or operations.

ÍÍ Formulas→Formula Auditing

DEVELOP YOUR SKILLS: E3-D4	

In this exercise, you will use the Formula Auditing tools to analyze and correct formula errors.

	 1.	 �Open E3-D4-Sales from your Excel Chapter 3 folder and save it as  
E3-D4-SalesSummary.

	 2.	 �On the Aug Sales sheet, select cell M10.

	 3.	 �Choose Formulas→Formula Auditing→Trace Precedents .

	 4.	 �With cell M10 still selected, again choose Formulas→Formula Auditing→Trace 
Precedents .

	 5.	 �With cell M10 still selected, choose Formulas→Formula Auditing→Trace 
Dependents .

	 6.	 �Click OK to close the warning box.
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	 7.	 �Choose Formulas→Formula Auditing→Remove Arrows .

	 8.	 �Select cell M18 and again choose Formulas→Formula Auditing→Trace Precedents .

	 9.	 �Edit the formula in cell M18 to be =M16+M17.

	10.	 �With cell M18 still selected, again choose Formulas→Formula Auditing→ 
Trace Precedents  and then click the button a second time.

	11.	 �Choose Formulas→Formula Auditing→Trace Dependents .

	12.	 �Select cell A1 and choose Formulas→Formula Auditing→Error Checking .

	13.	 �Click Update Formula to Include Cells.

	14.	 �Again click Update Formula to Include Cells.

	15.	 �Click Edit in Formula Bar, delete the existing cell references, replace with the range 
J5:J33 so the formula reads =SUM(J5:J33), and then click Resume in the Error 
Checking dialog box.

	16.	 �Click Edit in Formula Bar, correct the formula by changing cell M14 to cell M15 so the 
formula is =M18/M15, and then click Resume.

	17.	 �Apply the Percent number format to cell M19.

	18.	 �With cell M19 still selected, choose Formulas→Formula Auditing→Evaluate 
Formula  .

	19.	 �Click Evaluate.
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3-D Cell References  45

	20.	 �Click Evaluate.

	21.	 �Click Evaluate once more.

	22.	 �Click Close.

	23.	 �Save the file.

3-D Cell References
Excel formulas can refer to data on other worksheets or in other workbooks; however, sometimes 
a formula is required to refer to multiple sheets at the same time. For example, if cell A5 contains 
sales information for Product #1, and this information is on a different sheet for each month, you 
might want to summarize the sales data by finding the total in cell A5 across multiple sheets. This 
can be done by adding each cell individually or by using a 3-D reference in your formula.

Compare these two formulas.

	 =SUM(January!A5+February!A5+March!A5)

	 =SUM(January:March!A5)

Similar to using a range instead of referring to each cell individually, a 3-D reference is quicker 
because you can refer to the range of sheets January to March and all sheets between and then 
use the same cell (or range) from all sheets.

If you think of columns and rows as arranged left to right and up and down on a 2-D page, then 
stacking multiple worksheets on top of each other would be a third dimension, hence the 3-D 
reference. This is also useful because if a new sheet is inserted into the worksheet range, the 
data on the new sheet will automatically be included.

DEVELOP YOUR SKILLS: E3-D5	

In this exercise, you will use 3-D cell references to create formulas that sum values from 3 worksheets.

	 1.	 �Save your file as E3-D5-SalesSummary.

	 2.	 �Go to the Q3 Sales Summary worksheet.

	 3.	 �In cell G5, begin entering your formula by typing =SUM(.
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	 4.	 �Follow these steps to finish the formula using a 3-D reference:

A

C

B

A	While editing the formula, click the Jul Sales worksheet tab.

B	On the Jul Sales worksheet, select cell G5, and the Formula Bar will display =SUM(‘Jul 
Sales’!G5.

C	Hold down the [Shift] key on the keyboard and click the Sep Sales sheet tab to select the 
range of sheets Jul Sales:Sep Sales, which includes the Aug Sales sheet.

	 5.	 �Complete the entry by clicking  on the Formula Bar, which will automatically return you 
to the Q3 Sales Summary worksheet. (Do NOT click the Q3 Sales Summary tab as this will 
change the formula!)

	 6.	 �Now select cell H5 and use the method from step 5 to create a formula to add cell H5 on 
the Jul Sales, Aug Sales, and Sep Sales sheets; your formula should be =SUM('Jul Sales:Sep 
Sales'!H5) when finished.

	 7.	 �In cell I5, create a formula to add cell I5 on the Jul Sales, Aug Sales, and Sep Sales 
sheets; your formula should be =SUM('Jul Sales:Sep Sales'!I5) when finished.

	 8.	 �Select the range G5:I5, copy the formulas down all 3 columns using the fill handle, and 
use Auto Fill Options to fill without formatting.

	 9.	 �Save your work and close the file.
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Self-Assessment  47

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 If a worksheet looks messy because it contains names in either all capitals or lowercase  
letters, you can use the UPPER function to convert all the names to all capitals.	 True    False

2.	 Flash Fill can be used like the CONCATENATE function to combine columns of data  
anywhere on a worksheet.	 True    False

3.	 To find the sum of the Miami sales employees’ commissions, the formula  
=SUMIF(E5:E33,C5:C90,"Miami",I5:I33) could be used to add all the  
commissions in the range E5:E33 that match the criteria in columns C and I.	 True    False

4.	 Conditional formulas are useful for analyzing large amounts of data; to search for  
data that matches certain criteria; and to count, add, or find an average.	 True    False

5.	 To perform more than one function, you must use more than one cell, column, or row.	 True    False

6.	 If Tracing Precedents is compared to looking backward, Tracing Dependents would  
be comparable to looking forward.	 True    False

7.	 You have created a formula using a 3-D reference that finds the sum of cell B5  
across 4 sheets. To add the sum of cell B5 on a new 5th sheet, which was inserted  
into the worksheet range, you will have to edit the formula to include the sheet.	 True    False

8.	 Geoff is having trouble with a list of product codes that need to be fixed by  
extracting the first 7 characters only and converting all letters to capitals as  
shown below. He could do this by manually retyping each code, but because  
there are hundreds of product codes, Geoff should use which two functions  
to accomplish this more quickly?

A.	PROPER and UPPER

B.	 PROPER and RIGHT

C.	 UPPER and LEFT

D.	UPPER and RIGHT

(continued)
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48  FastCourse Excel 2016  Chapter 3: Advanced Functions for Text and Analysis

9.	 You want to know how many total cars in your inventory are red. Based on the image below, the formula 
=SUMIF(B2:B6,"Red",C2:C6) would return which result?

A.	3

B.	 4

C.	 9

D.	5

10.	 After marking all of your students’ tests, you want to use a function that finds the average of each 
student’s tests (the 5 test grades are entered in the range B2:F2), returns OVER if they averaged 70% or 
higher, and returns UNDER if they averaged under 70%. Which nested formula would be your best 
choice to obtain the desired result in cell G2?

A.	=IF(AVERAGE(B2:F2)>=70%,"OVER","UNDER")

B.	 =IF(ROUND(B2:F2)>=70%,"OVER","UNDER")

C.	 =AVERAGE(IF(B2:F2)>=70%,"OVER","UNDER")

D.	=ROUND(PROPER(B2:F2)>=70%,"OVER","UNDER")

11.	 The #VALUE! Error is usually a result of a formula that attempts to perform a mathematical operation 
on a cell that:

A.	Has the wrong number format

B.	 Is empty

C.	 Contains text

D.	Has been deleted

(continued)
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Self-Assessment  49

12.	 To create a formula on the Total sheet that will add cell B3 from all of the other sheets shown below, you 
would use a 3-D reference such as:

A.	Troy:Shirley:Brita:Abed!B3

B.	 Troy:Abed!B3

C.	 Troy:Shirley!B3

D.	Troy:Total!B3
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In this chapter, you will explore functions 
used to find data, either from a large 
database or a small lookup table. You 

will also learn about the Outline feature, 
which can be used to group information or 
create subtotals. It is also a handy tool for 
data analysis.

L E A R N I N G  O B J E C T I V E S
■■ Create formulas using lookup functions

■■ Use the Outline feature

■■ Create subtotals

■■ Use the Quick Analysis tool

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 1 hr 10 mins

■■ Self-Assessment: 20 mins

■■ Total: 1 hr 30 mins

P R O J E C T:  M A N A G I N G  E M P L O Y E E 
R E C O R D S
The LearnFast College employee records are saved in 
an Excel spreadsheet and contain confidential 
information about employees, including their 
salaries. You have been asked to create a method for 
entering employees’ names to quickly find their 
extension numbers and then also to enter the tax 
rates for each employee based on salary. You will 
work with Excel to accomplish these tasks and use 
the outline tools to analyze the information further.

4Lookup Functions and 
Outlines

E X C E L  2 0 1 6
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52  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

Introducing Lookup Functions
Lookup functions are used in Excel to retrieve a piece of data from a table (usually a large table). 
By knowing one piece of information from a record, you can use it to find other information 
from that record. A phonebook is a simple example of a lookup; you know a person’s name, so 
you look for it in the first column on the left, and when you find it you look across to the column 
that contains the phone number.

The VLOOKUP and HLOOKUP Functions
The VLOOKUP function is the most commonly used lookup function because it is used 
specifically to look up information arranged in columns (the V stands for vertical; columns are 
vertical), which is the format for many databases. The HLOOKUP function has the same 
arguments but is used when the data is arranged in rows (rows are horizontal). (The LOOKUP 
function is another option, but it is primarily available because older versions of Excel did not 
have VLOOKUP and HLOOKUP.)

The VLOOKUP function arguments are =VLOOKUP(Lookup Value, Table Array, Column Index 
Number, [Range Lookup(Optional)]), and these functions are explained in the table below.

LOOKUP FUNCTION ARGUMENTS

Argument Description
Lookup_Value This is the value to be found, either in the first column 

(VLOOKUP) or row (HLOOKUP) of the table.

Table_Array This is the range of cells used to search for the lookup value 
and retrieve the result.

Column/Row Index Number  
(Col_Index_Num/Row_Index_Num)

This number indicates the column (VLOOKUP) or row 
(HLOOKUP) in the table from which the matching value will be 
retrieved; the first column/row in the Table Array is always 1.

Range_Lookup (Optional) If TRUE or omitted, this function searches for the value closest 
to but less than the lookup value; if FALSE, the function 
searches for exact matches only. If TRUE or omitted, the data 
must be sorted in ascending order.

Looking up a tax rate or discount rate is a good example of when you 
might use the VLOOKUP function. To encourage customer spending, a 
business may offer customers a discount based on their annual spending. 
The various discount levels could be contained in a table such as the one 
shown below.
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Introducing Lookup Functions  53

For each customer, you would look up the amount of money spent to date to determine the 
discount.

The formula entered in cell C3 appears here.

The Lookup_Value is in cell B3, which is the 
spending to date for Robert, totaling $28,000.

The Table_Array is the 
information found in the 
range E3:F7; it must be an 
absolute reference if the 
formula is to be copied 
(the table array does not 
include the column headings)

The value to be retrieved is 
in column 2 of the table 
and is the DISCOUNT RATE.

The Range_Lookup can be omitted because 
the Lookup Value does NOT need to be an 
exact match, and the table is sorted in 
ascending order (lowest to highest)

The result of the formula for the first customer, Robert, is 2% because he spent more than 
$20,000 but less than the $30,000 required to qualify for a 3% discount; $20,000 is the closest 
value that does not exceed the $28,000 lookup value. The rest of the customer discounts can then 
be calculated by copying the formula down the column, as shown below.
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54  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

DEVELOP YOUR SKILLS: E4-D1	

In this exercise, you will use the VLOOKUP function to both find an employee’s phone extension by typing 
in the name and look up the tax rates for all employees in a tax table.

	 1.	 �Start Excel, open E4-D1-Database from your Excel Chapter 4 folder, and save it as 
E4-D1-DataLookup.

	 2.	 �In cell B5, type the name Ed Neal.

	 3.	 �Select cell E5, type =VLOOKUP(, and then click Insert Function  in the Formula Bar.

	 4.	 �Follow these steps to create a formula using VLOOKUP:

A
B

C
D

A	For the Lookup_Value, select cell B5.

B	For the Table_Array, use the mouse to select the range A8:G20 and then use the [F4] 
key to make the range reference absolute.

C	For the Col_Index_Num, enter 3.

D	In the Range_Lookup box, type FALSE; you are looking for an exact match in this case, 
so do not leave this argument blank.

	 5.	 �Click OK to enter the formula.

	 6.	 �Select cell B5 and type Patty Mills.

	 7.	 �Select cell G8.

	 8.	 �Choose Formulas→Function Library→Lookup & Reference →VLOOKUP to insert 
the VLOOKUP function.

	 9.	 �Select cell F8 for the Lookup_Value.

	10.	 �To specify the Table_Array, choose the Tax Rate sheet, select the table without the 
headings, and press F4 to make the table reference absolute.

	11.	 �Enter 2 as the Col_Index_Num.
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Using the Outline Feature  55

	12.	 �Click OK.

	13.	 �Apply the Percent Style number format and increase the decimal to show 1 decimal place.

	14.	 �Copy the formula down the column for the other employees.

	15.	 �Save the file.

Using the Outline Feature
The Outline feature in Excel allows you to group related information together, 
which can also be useful for quickly calculating subtotals and totals. Groups 
can be created by either rows or columns. Creating an Outline means you can 
control which data to display or hide, or you can choose between a detailed 
view of data or to hide the details and view only a summary. Outlines are best 
used with normal data ranges, rather than tables.

An Outline can be created either manually or automatically using Auto Outline. To create an 
Auto Outline, you must have inserted formulas that sum or subtotal information from groups of 
rows or columns. For example, if you have created a sum below each Position category, as shown 
below in rows 6, 12, and 18, the Auto Outline command will recognize these are distinct areas of 
data and group each accordingly. Likewise, column H is a sum of the sales figures contained in 
columns F and G.

Formulas that find the sum 
of each respective group

Formula that finds the sum of ModSales and AppSales

Formula that finds the sum of the three subtotals
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56  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

The Auto Outline then adds the Outline structure along the top and left sides of the worksheet, 
which contain the outline symbols for adjusting the outline view as shown below.

Row levels will show three levels of detail, with one being 
the least and three being the greatest amount of detail, 
by collapsing or expanding all groups in that level at once.

These row buttons 
collapse individual 
groups one at a time.

Rows 13 to 17 are currently hidden; 
the expand button can be used 
to display them once again.

Column levels show or hide column details.

The collapse [−] buttons show less detail by hiding the detail contained in that particular group 
of rows or columns, and the expand [+] buttons will show the hidden group once again. An 
outline can be removed at any time using the Clear Outline command.

View the video “Creating Outlines and Subtotals.”

ÍÍ Data→Outline→Group 

ÍÍ Data→Outline→Ungroup 

DEVELOP YOUR SKILLS: E4-D2	

In this exercise, you will create an outline to group data for employees based on their positions.

	 1.	 �Save your file as E4-D2-DataLookup.

	 2.	 �Select the range E8:E15.

	 3.	 �Choose Data→Outline→Group .

	 4.	 �In the Group dialog box, ensure Rows is selected and click OK.
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Creating Subtotals  57

	 5.	 �Click the collapse button to hide rows 8:15.

	 6.	 �Choose Data→Outline→Ungroup  menu button →Clear Outline.

	 7.	 �Insert a new blank row above row 16.

	 8.	 �In the new blank row, insert the text Instructor Total in cell D16.

	 9.	 �In cell F16, choose Home→Editing→AutoSum  to calculate the combined total for 
instructor salaries.

	10.	 �In cell D22, enter Administrative Total and then use AutoSum in cell F22 to 
calculate the sum of the remaining employee salaries.

	11.	 �In cell D23, enter Grand Total, select cell F23, and choose Home→Editing→ 
AutoSum .

	12.	 �Apply Bold to the ranges D16:F16 and D22:F23.

	13.	 �If necessary, deselect the range D22:F23 and select a single cell only, anywhere on the 
worksheet.

	14.	 �Choose Data→Outline→Group  menu button →Auto Outline.

	15.	 �Click on the Level  outline symbol, as shown below, which provides the second level of 
detail; it collapses the Instructor and Administrative groups but displays both subtotals as 
well as the grand total.

	16.	 �Save your work and close the file.

Creating Subtotals
In some ways, the Subtotal command is simpler and quicker than grouping rows or using Auto 
Outline; however, there are a few more steps in the process. Deciding between the two depends 
on the existing state of your data. For example, if your data already has subtotals inserted, then 
using Auto Outline will be quick and easy for you. If your data is in one large block with no 
dividers or subtotals, then the Subtotal command will add the outline and create the subtotals by 
group all at once.
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58  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

To use the Subtotal command, you must first sort the list on the column that you will use to 
group the subtotals. For example, to create a subtotal for each city, your data must be sorted by 
city so each city is listed together. Then when you use the Subtotal command, you can group 
those cities together to perform the subtotal calculation.

A worksheet, sorted by Region, which is ready for the user to create a Subtotal to sum the sales for each region

The Subtotal Dialog Box
The Subtotal dialog box gives you a step-by-step process to simplify creating the subtotals.

The column to create groups; usually the list 
is also sorted by this column, so that for each 
different Region a subtotal will be added

The function to use in the subtotal calculation, 
such as Sum, Count, Average, Max, or Min

The column or columns where the subtotal 
will be calculated, so for each Region a Sum 
will be calculated for the ModSales, AppSales, 
and Total Sales columns
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Creating Subtotals  59

DEVELOP YOUR SKILLS: E4-D3	

In this exercise, you will rearrange the employee data to find average salaries for each location by creating 
an outline using the Subtotal command.

	 1.	 �Open E4-D3-Database from your Excel Chapter 4 folder and save it as  
E4-D3-DataLookup.

	 2.	 �Select a cell in column D below the Location heading and choose Home→Editing→ 
Sort & Filter →Sort A to Z.

	 3.	 �Choose Data→Outline→Subtotal .
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60  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

	 4.	 �Now follow these steps to create the subtotal:

A

D

C

B

A	Choose Location from the drop-down list.

B	Choose Average from the drop-down list.

C	Select Salary and deselect the Tax Rate checkbox.

D	Keep the other default settings and click OK.

	 5.	 �Save your work.

Using the Quick Analysis Tool
The Quick Analysis tool gives the user quick and easy access to several popular analysis options 
that are also available from the Ribbon. For example, you might have a list of expense data, and 
you want to quickly highlight the expenses that went over budget with conditional formatting 
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Using the Quick Analysis Tool  61

or insert a chart of all the expenses. To access the Quick Analysis tool, simply select any range of 
two or more cells that contain data.

The selected data The Quick Analysis tool button

The Quick Analysis options, which contain five categories 
and are based on the type of data selected

Each category name will display the menu of options, which include:

■■ Adding conditional formatting to your selection

■■ Creating a chart

■■ Inserting totals such as sum, average, or count, either in the row below or the column to the 
right of the selection

■■ Inserting tables, including PivotTables (depending on the data), or inserting sparklines

You can see a preview of each option by holding the mouse pointer over the option.

DEVELOP YOUR SKILLS: E4-D4	

In this exercise, you will use the Quick Analysis tool to add conditional formatting and create a chart using 
the employee salary and tax rate data.

	 1.	 �Save your file as E4-D4-DataLookup.

	 2.	 �Begin by selecting a cell in the Salary column, column F.

	 3.	 �Choose Home→Editing→Sort & Filter →Sort Smallest to Largest.

	 4.	 �Click OK to accept and remove the subtotals.

	 5.	 �Select the Salary and Tax Rate headings and data in the range F7:G20.

	 6.	 �Click the Quick Analysis tool button. (Hint: If you do not see the button, move the mouse 
near the bottom-right corner of the selection.)
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62  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

	 7.	 �Click Charts.

	 8.	 �Click the second chart option, the Clustered Column chart.

	 9.	 �Edit the chart title to be Salary and Tax Rate Comparison.

	10.	 �Move the chart to a new sheet called Comparison Chart.

	11.	 �Return to the Database sheet.

	12.	 �Select the salary info in the range F8:F20.

	13.	 �Click on Quick Analysis  and  then choose Icon Set from the list of Formatting options.

	14.	 �Select the tax rate info in the range G8:G20.

	15.	 �Click Quick Analysis  and then choose Color Scales from the list of Formatting 
options.

	16.	 �Save your work and close the file.
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Self-Assessment  63

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-Assessment. The answers to these 
questions can be found at the back of this book.

1.	 The VLOOKUP and HLOOKUP functions require three arguments, and the  
fourth argument is optional.	 True    False

2.	 The formula =VLOOKUP(2,A2:B6,2,TRUE) will return the value 7% from  
the following table.	 True    False

3.	 To create an Auto Outline, you must have already inserted formulas that sum or  
subtotal information from groups of rows or columns.	 True    False

4.	 The row level 3 in the Outline structure shows the greatest amount of detail in  
an outline.	 True    False

5.	 To use the Subtotal command, your list must be sorted by the row you will use  
to group the subtotals.	 True    False

6.	 Creating a subtotal takes 3 steps: choosing which column to create groups by,  
choosing the function to use, and choosing which columns to create subtotals for.	 True    False

7.	 The Quick Analysis tool gives the user quick and easy access to several popular  
analysis options that are not available from the Ribbon.	 True    False

8.	 If the value in cell A3 is $27,000, the result of the following formula would be:

A.	0.00%

B.	 2.00%

C.	 3.00%

D.	2.70% (continued)
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64  FastCourse Excel 2016  Chapter 4: Lookup Functions and Outlines

9.	 In the following formula, =VLOOKUP(A2,A3:H56,5,TRUE), the number 5 represents:

A.	The Lookup Value

B.	 The Table Array

C.	 The Criteria

D.	The fifth column in the table

10.	 Which button shows less detail in an outline by hiding the detail contained in that particular group of 
rows or columns?

A.	Expand button

B.	 Collapse button

C.	 Outline button

D.	Group button

11.	 To create subtotals for the following data, you should choose to add subtotals at each change in:

A.	First Name

B.	 Last Name

C.	 Team

D.	Total

12.	 The Quick Analysis tool gives you several analysis options grouped into 5 categories, such as conditional 
formatting and charts, but does NOT include:

A.	Totals

B.	 Sparklines

C.	 Tables

D.	Slicers
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Self-Assessment Answer Key
CHAPTER 1: ADVANCED WORKBOOK FORMATTING

Item Answer Page Number

1 False 2 

2 True 4 

3 False 6 

4 True 13 

5 False 10 

6 False 16 

7 C 2 

8 D 4 

9 B 6 

10 C 9 

11 D 9 

12 A 15 

13 D 12 

CHAPTER 2: DATE FUNCTIONS AND CONDITIONAL FORMATTING

Item Answer Page Number

1 True 21 

2 True 20 

3 True 22 

4 True 23 

5 True 24 

6 True 26 

7 C 20 

8 D 24 

9 D 23

10 D 25 

11 C 26

12 D 26 

CHAPTER 3: ADVANCED FUNCTIONS FOR TEXT AND ANALYSIS

Item Answer Page Number

1 True 32 

2 False 33 

3 False 37 

4 True 36 

5 False 39 

6 True 41 

7 False 45 

8 C 32 

9 D 36 

10 A 39 

11 C 43 

12 B 45 

CHAPTER 4: LOOKUP FUNCTIONS AND OUTLINES

Item Answer Page Number

1 True 52 

2 True 53 

3 True 55 

4 True 56 

5 True 58 

6 True 58 

7 False 60 

8 B 53 

9 D 52 

10 B 56 

11 C 58 

12 D 61 
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Index

Note: Index entries ending in “V” indicate that a topic is discussed in the video referenced on that page.

NUMBERS
0 code, meaning of, 9
3-D cell references, using, 45–46. See also 

cells
24-hour clock, using, 22
100% view, jumping back to, 15

SYMBOLS
#, appearance of, 9
" " argument, using with text, 34
- code, meaning of, 9
, code, meaning of, 9
. code, meaning of, 9
/ code, meaning of, 9
+ code, meaning of, 9
$ code, meaning of, 9
% code, meaning of, 9
() code, meaning of, 9

A
“abc” code, meaning of, 9
Airspace Travel company

analyzing sales information, 31
preparing company documents, 19

AM and PM, entering for time, 22
analysis options, accessing, 60–62
arrows, using with Trace  

Precedents, 41–42
Auto Outline feature, using, 55–57
Average Range argument, using with IF 

criteria, 37
AVERAGEIF function, using, 36
AVERAGEIFS function, using, 36

B
background image, adding, 11
Bing Search, using for Online Pictures, 12
borders and fill, applying to cells, 6–8

C
capitalizing text, 32
case, changing, 32
cell styles, applying, 4–5
cells. See also 3-D cell references

borders and fill, 6–8
formatting, 6–8

characters, adding to numbers, 9

clock. See time information
colors

applying to values, 9
changing for themes, 2–4

columns, looking up information  
in, 52–55

CONCATENATE function, using, 33–34
conditional formatting. See also formatting

explained, 25
with graphics, 26
Rules Manager, 26–28
using, 13V–14

conditional functions. See also functions
creating, 36–38
using, 38

COUNTIF function, using, 36
COUNTIFS function, using, 36
Criteria argument, using with IF criteria, 

37

D
data, highlighting with conditional 

formatting, 13V–14
data flow, visualizing with Trace 

Precedents, 41–42
date and time calculations,  

entering, 24–25
date formatting, customizing, 20–22, 21V
Date functions, using, 23–24
dates, serial numbers, 20–22
days, formatting, 21
decimal point, using, 9
digit placeholder, using, 9
#DIV/0! error, described, 43
document properties

editing, 16
preparing, 19

document-preparation project, 1

E
editing document properties, 16
effects, changing for themes, 2–4
employee-record management, 51
entering

date and time calculations, 24–25
time information, 22–23

Error Checking tool, using, 42–43

F
fill and borders, applying to cells, 6–8
Flash Fill feature, using, 33–35
fonts, changing for themes, 2–4
Format Cells dialog box, using, 6–10
formatting. See also conditional formatting

making consistent, 5
with themes, 2–4

Formula Auditing tools, using, 43–45
Formula Omits Adjacent Cells error, 

described, 43
formulas

comparing, 45
evaluating, 43–45
tracing, 42V
troubleshooting, 41–45

function arguments dialog box, using, 37
functions. See also conditional functions

changing case, 32
combining text, 33–34
extracting text, 32–33
LEN, 35
nesting, 39–40
REPLACE, 35
REPT, 35
separating text, 33–34
SUBSTITUTE, 35

G
graphics, using with conditional 

formatting, 26
grouping information, 55–57

H
heading styles, applying, 4–5
highlighting data with conditional 

formatting, 13V–14
HLOOKUP function, using, 52–55

I
IF criteria, using, 36–38
images

adding to worksheet backgrounds, 11
adding to worksheets, 11–13
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68  Index

L
LearnFast College project

managing employee records, 51
preparing company documents, 1

LEFT function, using, 33
LEN function, using, 35
lookup functions, using, 52–55
LOWER function, using, 32

M
m/d/yyyy formatting, 20
MID function, using, 33
months, formatting, 21

N
#NAME? error, described, 43
nesting functions, 39–40
NOW() function, using, 23
number formatting, 8, 9V, 10

O
Online Pictures, using, 12
Outline feature, using, 55–57
outlines and subtotals, creating, 56V

P
page setup, customizing, 10–11
pattern fill, creating, 8
percentage, applying, 9
pictures. See images
PM and AM, entering for time, 22
precedent cells, tracing, 41–42
PROPER function, using, 32
projects

analyzing sales information, 31
managing employee records, 51
preparing company documents, 1, 19

properties. See document properties

Q
Quick Analysis tool, using, 60–62

R
Range argument, using with IF criteria, 37
Range_Lookup argument, using with 

lookup functions, 52
#REF! error, described, 43
REPLACE function, using, 35
REPT function, using, 35
RIGHT function, using, 33
rows, looking up information in, 52–55
rules, using with conditional  

formatting, 13V–14
Rules Manager, using with conditional 

formatting, 26–28

S
sales information, analyzing, 31
Self-Assessments

conditional formatting, 29–30
date functions, 29–30
functions for text and analysis, 47–49
lookup functions and outlines, 63–64
workbook formatting, 17–18

shapes library, accessing, 12
SUBSTITUTE function, using, 35
subtotals, creating, 56V, 57–60
Sum Range argument, using with IF 

criteria, 37
SUMIF function, using, 36
SUMIFS function, using, 36

T
Table_Array argument, using with lookup 

functions, 52
text

capitalizing, 32
combining and separating, 33–34

displaying inside double quotes, 9
extracting, 32–33
LEN function, 35
modifying using functions, 32–36
REPLACE function, 35
REPT function, 35
SUBSTITUTE function, 35

text functions, using, 35–36
themes, customizing, 2–4
thousands separator, using, 9
time and date calculations,  

entering, 24–25
time information, entering, 22–23
title styles, applying, 4–5
TODAY() function, using, 23
Trace Precedents command, using, 41–42
tracing formulas, 42V
TRIM function, using, 33
troubleshooting formulas, 41–45

U
UPPER function, using, 32

V
#VALUE! error, described, 43
values, applying colors to, 9
VLOOKUP function, using, 52–55

W
worksheets, referring to multiple, 45–46

Y
YEAR() function, using, 23
years, formatting, 21

Z
Zoom tools, using, 15
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