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Preface

T
his textbook is part of our new approach to learning for introductory computer 

courses. We’ve kept the best elements of our proven, easy-to-use instructional 

design and added interactive elements and assessments that offer enormous 

potential to engage learners in a new way. 

Why Did We Write This Content?
In today’s digital world, knowing how to use the most common software applications is critical, and 
those who don’t are left behind. Our goal is to simplify the entire learning experience and help every 
student develop the practical, real-world skills needed to be successful at work and in school. Using 
a combination of text, videos, interactive elements, and assessments, we begin with fundamental 
concepts and take learners through a systematic progression of exercises to achieve mastery.

What Key Themes Did We Follow?
We had conversations with dozens of educators at community colleges, vocational schools, and other 
learning environments in preparation for this textbook. We listened and adapted our learning solu-
tion to match the needs of a rapidly changing world, keeping the following common themes in mind:

Keep it about skills. Our content focus is on critical, job-ready topics and tasks, with a relentless focus 
on practical, real-world skills and common sense. We use step-by-step instructional design to ensure 
that learners stay engaged from the first chapter forward. We’ve retained our proven method of 
progressively moving learners through increasingly independent exercises to ensure mastery—an 
approach that has successfully developed skills for more than 25 years.

Keep it simple. Our integrated solutions create a seamless experience built on a dynamic instructional 
design that brings clarity to even the most challenging topics. We focus our content on the things 
that matter most and present it in the easiest way possible. Concise chunks of text are combined with 
visually engaging and interactive elements to increase understanding for all types of learners.

Keep it relevant. Fresh, original, and constantly evolving content helps educators keep pace with 
today’s student and work environments. We reviewed every topic for relevancy and updated it where 
needed to offer realistic examples and projects for learners.

How Do I Use This Book?
Our comprehensive learning solution consists of a print textbook, a groundbreaking interactive 
ebook, and our easy-to-use eLab course management tool featuring additional learning content, 
such as overviews and video tutorials, and assessment content. Our interactive ebook contains 
learning content delivered in ways that will engage learners.

The eLab assessment solution includes Project Grader exercises for most chapters that are automati-
cally graded by the system, in addition to clear feedback and analytics on student actions.

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



vi   Preface

Included with Your Textbook Purchase
Depending on your purchase option, some or all of the following are included with your textbook:

Interactive ebook: A dynamic, engaging, and truly interactive textbook that includes elements such as 
videos, self-assessments, slide shows, GIFs, and other interactive features. Highlighting, taking notes, 
and searching for content is easy. 

eLab Course Management System: A robust tool for accurate assessment, tracking of learner activity, 
and automated grading that includes a comprehensive set of instructor resources. eLab can be fully 
integrated with your LMS, making course management even easier.

Instructor resources: This course is also supported on the Labyrinth website with a comprehensive 
instructor support package that includes detailed lesson plans, lecture notes, PowerPoint presenta-
tions, a course syllabus, test banks, additional exercises, and more.

Student Resource Center: The exercise files that accompany this textbook can be found within eLab 
and in the Student Resource Center, which may be accessed from the ebook or online at:  
labyrinthelab.com/office19

We’re excited to share this innovative, new approach with you, and we’d love you to share your 
experience with us at: lablearning.com/share

Visual Conventions
This book uses visual and typographic cues to guide students through the lessons. Some of these cues 
are described below:

Cue Name What It Does

Type this text Text you type at the keyboard is printed in this 
typeface.

Action words The important action words in exercise steps are 
presented in boldface.

Ribbon Glossary terms are highlighted with a yellow 
background.

Note!   Tip!   Warning! Tips, notes, and warnings are called out with  
special icons.

 
Videos, WebSims, and other ebook or online 
content are indicated by this icon.

Command→Command→ 
Command→Command

Commands to execute from the Ribbon are 
presented like this: Ribbon Tab→Command  
Group→Command→Subcommand.

ÍÍ Design→Themes→Themes These notes present shortcut steps for executing 
certain tasks.

Display Settings
Multiple factors, including screen resolution, monitor size, and window size, can affect the appearance 
of the Microsoft Ribbon and its buttons. In this textbook, screen captures were taken at the native 
(recommended) screen resolutions in Office 2019 running Windows 10, with ClearType enabled. 
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L E A R N I N G  O B J E C T I V E S

ÝÝ Manage data using a table

ÝÝ Create a custom filter

ÝÝ Name a table

ÝÝ Use structured references in a formula

ÝÝ Create sparklines

11 Working with Tables

EXCEL

I
n this chapter, you will explore the 

table tools available in Excel as you 

discover the advantages of creating 

and using tables. You will also create 

formulas that use structured references and 

insert sparklines for quick and simple data 

trend analysis.
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274  Excel Chapter 11: Working with Tables

	 Project: Analyzing Exam Performance
You are an instructor at LearnFast College. Your business students completed their final exams 
recently, and you are reviewing the grades. To help you assess individual exam grades and find 
the class average, you are going to create a table and use the table tools. For further analysis, 
you will create a series of formulas that use structured references to the table data and insert 
sparklines to show trends in the exam grades.

Working with Tables
Tables can be a valuable feature in Excel if they are used properly. An Excel table is comprised of a 
group of related data within a defined range. Formatting the data as a table enables the use of the 
table features.

Tables are useful, not only for managing and organizing data, but also when it comes to creating 
advanced formulas and analyzing data. In addition, table features allow you to manage the data in 
the table rows and columns independently from the data in other rows and columns on the work-
sheet. You can create a table by converting existing data into a table, or you can start by creating a 
blank table and then fill in the information later. You can even create multiple tables on the same 
worksheet.

This table of sales data displays the header row, banded rows (alternating  
colors), and a total row.

Insert and Delete Table Rows and Columns
Generally, working with a table is not very different from working with a regular data range. You can 
add rows or columns into the middle of a table just as you would with a normal range—by selecting a 
cell below the desired location of the new row, or to the right of the location of the new column, and 
using the Insert command. To delete a row or column, you use the Delete command.

The simplest way to add rows, however, is to add them at the bottom of the table, as entering new 
data in the row directly below a table will automatically expand the table to include the new row. 
Likewise, if you add new data in the column to the right, it will be included in the table as well. Table 
formatting will also be automatically applied to any new rows or columns to stay consistent with the 
rest of the table.


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Working with Tables  275

When a table is selected, the Insert and Delete menus have the additional 
table options to Insert/Delete Table Rows or Columns.

The difference between inserting a table row/column or a sheet row/column is that the Table 
commands do not affect the rest of the worksheet. For example, inserting a table row will insert 
the row into the table only, but inserting a sheet row will insert the row for the table and the entire 
worksheet.

If the table includes a total row, you can insert a new row at the bottom but above the total row by 
selecting the bottom-right table cell and pressing [Tab].

Calculated Columns
Table columns can contain text values, numerical values, or formulas. When you enter a formula into 
a table cell, it will automatically become a calculated column, which instantly copies the formula to 
all cells in the column. In the same fashion, editing a formula in one cell will update the formula for 
the entire column. This eliminates the need to use the fill handle to copy your formula, making the 
task quick and easy.

Apply a Sort or Filter
Another advantage of tables is the ability to quickly sort and filter the information contained in them. 
A sort will arrange all the information in the table according to your preference, and a filter allows 
you to decide which data to display and which to hide. Sorts and filters can be performed on both a 
normal range or a table, but a table automatically displays a filter button at the top of each column. 
Depending on the actions taken in that column, the filter button may show the down-arrow, the filter 
symbol, a sort arrow, or some combination of these.

ÍÍ Insert→Tables→Table 

ÍÍ Home→Cells→Insert  or Delete 

Tip!

E
X

C
E

L
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276  Excel Chapter 11: Working with Tables

DEVELOP YOUR SKILLS: E11-D1

In this exercise, you will create a table from existing data (the exam grades) and then edit and sort the 
students’ exam data.

Before You Begin: Download the student exercise files from your eLab course or the Student Resource 
Center (labyrinthelab.com/office19) and determine your file storage location before beginning this exercise.

	 1.	 �Start Excel, open E11-D1-Exam from your Excel Chapter 11 folder, and save it as: 
E11-D1-ExamRevised

	 2.	 �Select cell A5 and choose Insert→Tables→Table .

The Create Table dialog box suggested range is A5:J17 (as an absolute reference), which is correct. The 
My Table Has Headers box has a checkmark to indicate there are headers.

	 3.	 �Click OK to create the table.

The table is created. Notice the filter buttons beside each heading and the formatting changes. The 
Table Tools Design tab is activated on the Ribbon.

	 4.	 �Select cell D5 and choose Home→Cells→Insert  menu button �→Insert Table 
Columns to the Left.

Notice the inserted column does not affect the data in the range A20:D22.

	 5.	 �Type Date to replace Column1 in cell D5.

	 6.	 �In cell D6, enter =$A$3 to copy the date from cell A3 using an absolute reference.

After you complete the formula entry in cell D6, the formula is automatically added to all other 
cells in the table column. The results display only the #### symbols because the column needs to be 
resized.

	 7.	 �Select the range D6:D17, change the number format to Short Date, and then autofit the width 
of column D.

	 8.	 �Set the width of column I to: 6

	 9.	 �Select cell K17 and tap [Tab].

A new row is added to the bottom of the table in row 18.

	10.	 �Enter the information for another student in the new table row:

Notice that the Date and Total column formulas for Justin are automatically added for you.

	11.	 �Use the Total filter button � to sort the students by their total mark, Smallest to Largest.

	12.	 �Sort the students by program, from A to Z.

Because you already sorted by the totals first, the students are still arranged lowest to highest within 
the Applied group and Honors group.

	13.	 �Save the file.

Always leave your file open at the end of an exercise unless instructed to close it.
 

Note!
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Special Table Features  277

Special Table Features
The special features of a table include the ability to rename the table for quick reference to its data, 
the header row (used to label columns of information), and the total row (summarizes table data). 
You can also quickly adjust the formatting of a table by applying a table style, and you can modify 
table styles by adding or removing options such as banded rows, banded columns, or special first/
last column formatting. For other formatting changes, you can select a table row or column with one 
click without selecting the rest of the worksheet.

The Table Tools tab is a contextual Ribbon tab; you must have a cell within the table selected to prompt it.

Table Name
The default name for the first table in a workbook is Table1, the second is Table2, 
and so on. Although you can keep the default names, more descriptive names 
can be useful, especially if the table data will be used in formulas. You can 
change a table name by editing the name directly in the Table Tools Properties 
menu. As with defining names for a cell or range, table names cannot contain 
spaces but may include underscores.

Header Row
Most tables will contain categories of information in columns, so including a header row at the top 
of the table provides a label for each column. It’s good practice to limit each column to one piece of 
information, such as having two separate columns for first name and last name, to enable full sorting 
and filtering. Each column heading in a table should be unique.

Avoid the characters @, #, [ ], and ‘ in column headings because they have special meanings in formulas.

When scrolling through a large table, a table’s header row will remain visible across the top of the 
worksheet, eliminating the need to freeze the top row. The headings replace the normal worksheet 
column headings A, B, C, etc.

You can drag the table resize handle to add and remove columns and rows.

Table Style Options
You can add and remove table formatting using the Table Style Options checkboxes. These options 
can help make the information easier to read by differentiating certain rows and columns. Clear the 
Filter Button checkbox to hide the filter buttons in the header row.

Note!

Warning!

E
X

C
E

L
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278  Excel Chapter 11: Working with Tables

Total Row
Checking the Total Row option in the Table Style Options group will automatically add a row to 
the bottom of your table with the text Total in the left column and a sum in the far-right column. 
Although a total row is often used to sum the values in a column, there are other summary functions 
that can be used as well. The total row is formatted to match the style of the rest of the table but 
may be a different shade to stand out from the other data.

This total row adds a sum in the last column on the right, but if the last column 
contained text or dates, it would simply count the populated cells.

Selecting a cell in the total row will display a menu button � that shows a list of the available 
summary formulas. For example, rather than a sum, you may wish to display the average of the 
column data.

ÍÍ Table Tools→Design→Properties

ÍÍ Table Tools→Design→Table Style Options

DEVELOP YOUR SKILLS: E11-D2

In this exercise, you will rename the table and add a total row to calculate the average exam grades for 
the students.

	 1.	 �Save your file as: E11-D2-ExamRevised

	 2.	 �Go to Table Tools→Design→Properties and click in the Table Name box to select the existing 
name, type Exams to replace that, and tap [Enter].

The new table name is now saved as part of the table properties.

	 3.	 �Scroll down on the worksheet so row 6 is the first visible row. (You may need to use the up/down 
arrows on the scroll bar to move up/down one row at a time to get the worksheet to display 
precisely this way.)

The table headers now replace the worksheet column headers.
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Structured References  279

	 4.	 �Point to the First table header, which changes your pointer to the table column 
selector arrow.

	 5.	 �Drag one column to the right, to the Last table header, to select both table 
columns.

Notice that the selection does not include the cells below the table.

	 6.	 �Apply Bold formatting to the selection.

	 7.	 �Add a total row by going to Table Tools→Design→Table Style Options 
and clicking the Total Row checkbox.

The total row is added to the bottom of the table. The number 0 appears in the bottom-right cell 
because there is no data in the % column yet (the sum for that column is zero).

	 8.	 �Select cell A19 and replace the text Total with: Average

	 9.	 �Select the cell that contains the zero in the total row, cell K19, under the % heading.

	10.	 �Use the menu button � to select None from the drop-down list, which 
removes the 0.

	11.	 �Move one cell to the left, to cell J19 below the exam totals.

	12.	 �To find the average exam grade, click the menu button � and select 
Average from the drop-down list.

	13.	 �Decrease the decimal places to show only one decimal.

	14.	 �Go to Table Tools→Design and in the Table Style Options group, click the 
Last Column checkbox and change the table style to Blue, Table Style Medium 13.

Only certain table styles have different last column shading, Medium 13 being one of them.

	15.	 �Save your work.

Structured References
A structured reference is created when you use a formula with cell/range references to data 
contained in a table. The advantage of structured references is that they adjust formula results 
automatically when new rows or columns are added to a table. They also make it easier to identify 
the data source because the reference name includes information such as the table name and header 
name. The reference name, once used in a formula, will also update automatically if you rename the 
table or column header.

E
X

C
E

L

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



280  Excel Chapter 11: Working with Tables

The syntax for a structured reference varies depending on whether it is a reference to a cell, an entire 
column, or even an entire table.

A formula with a structured reference 
to the column Q1 in Table1

A formula with a structured reference to one 
row of data in the range from Q1:Q4 in Table1

View the video “Creating Formulas with Structured References.”

Formulas with Structured References
The best way to create structured references is to use the point-and-click method to select the table cell 
or column, which adds all the appropriate formatting/syntax based on the cell or range selected. Trying 
to type a structured reference manually is much more difficult and can lead to mistakes in your formula.

Compare the formulas in the following illustrations. The formula in the left figure was typed in, and the 
formula in the right figure was created by clicking on the cells in the Q1 and Q2 columns. In the formula 
on the right, it’s easy to see that the information from Q1 and Q2 is being added together, whereas the 
formula on the left would require finding the cells H5 and I5 first to understand the meaning.

DEVELOP YOUR SKILLS: E11-D3

In this exercise, you will create formulas that use structured references to calculate the percentage grades, 
fix the total calculation, and insert summary calculations below the table.

	 1.	 �Save your file as: E11-D3-ExamRevised

You will create a formula to find the percent each student scored by dividing the total mark by 150.

	 2.	 �Select cell K6 in the first row below the % table header.

	 3.	 �Type = and use the mouse to select cell J6, one cell to the left, below the Total table header.

The cell reference is automatically inserted as a structured reference. Due to the dark fill color in the 
column (the image shows a lighter blue for visibility), you may not be able to see the text in the cell. If 
that’s the case, check the Formula Bar.

	 4.	 �Type /150 and complete the formula entry.

The formula is calculated in cell K6, the result is 0.46, and the formula is 
automatically copied down to the rest of the column.

	 5.	 �Point to the % column header, click to select the table column, and apply Bold and the Percent 
Style number format.

You may notice the marks seem unusually low, and you may have already noticed an error in the Total 
column, which you will fix now.
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Creating Sparklines  281

	 6.	 �Select cell J6, the first cell below the Total header.

The sum formula finds the total for the range E6:H6, and the error indicates that there are adjacent cells 
omitted from the formula. Rather than edit the formula, you will reenter the SUM formula using AutoSum.

	 7.	 �Choose Home→Editing→AutoSum .

The new formula calculates the SUM using a structured reference that includes the table name Exams 
and the table column headers in the range reference @[Pt. 1]:[Pt. 5].

	 8.	 �Complete the formula entry, which again automatically updates all formulas in the column as 
well as the % grades in the next column.

	 9.	 �Select cell K19 in the total row below % and add the Average calculation for the % column.

Now you will enter some additional formulas outside of the table that use structured references to the 
table data.

	10.	 �Select cell D21 in the box beside Highest Exam Grade.

To find the highest exam grade, you will use the MAX function referring to the % table column.

	11.	 �Type =MAX( and then use the mouse to select the range K6:K18. Complete the formula while 
keeping cell D21 active.

The formula converts the range reference to Exams[%], and the formula bar displays =MAX(Exams[%]).

	12.	 �Apply the Percent Style number format.

	13.	 �In cell D22, enter the formula =COUNTIF(Exams[Program],"Honors") and then use the 
mouse to select the program information (starting in cell C6, below the heading).

The result shows there are eight Honors students.

	14.	 �In cell D23, enter this formula using the mouse to select the table ranges, program  
information, and the marks for each criteria range:  
=COUNTIFS(Exams[Program],"Honors",Exams[%],">80%")

The result shows two Honors students scored higher than 80% on the exam. Notice the criteria ranges 
and corresponding criteria are easier to understand than a regular cell reference: The program must 
be Honors and the percentage score must be greater than 80%.

	15.	 �Save the file.

Creating Sparklines
In addition to creating charts and adding conditional formatting, Excel has another tool for visualizing 
data trends. A sparkline is a miniature chart inserted as an object into an individual cell. Sparklines are 
smaller, simpler versions of charts, and any changes made to the data are immediately updated in the 
sparklines, just as with a normal chart. Each sparkline can contain data for only one column or row at 
a time.
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Sparkline types include Line, Column, or Win/Loss, and you can change the type even after the sparkline 
has been created. Formatting changes can be made with the Sparkline tools. Changes made to one 
sparkline are applied to all of the sparklines in the same group automatically.

ÍÍ Insert→Sparklines

DEVELOP YOUR SKILLS: E11-D4

In this exercise, you will insert sparklines to spot trends in the students’ exam marks.

	 1.	 �Save your file as: E11-D4-ExamRevised

	 2.	 �Select the range L6:L18 immediately to the right of the table.

	 3.	 �Choose Insert→Sparklines→Line  to open the Create Sparklines dialog box.

	 4.	 �Click in the Data Range box and then use the mouse to select the range E6:I18.

Because you already selected the desired range, the Location Range is already entered.

	 5.	 �Click OK to insert the sparklines.

The sparklines are displayed in column L and show a comparison for each student, displaying the 
trends for the marks across the five different parts of the exam.

	 6.	 �Go to Sparkline Tools→Design→Show and check the Markers option to display the markers 
on the sparklines.

	 7.	 �Select cell K20 and choose Insert→Sparklines→Column .

	 8.	 �Select the range K6:K18 as the data range, ensure K20 shows as the location, and click OK.

	 9.	 �Go to Sparkline Tools→Design→Show and check the options for High Point and Low Point.

The columns with the highest and lowest marks are indicated in red.

	10.	 �Save the file and close Excel.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: E11-R1

Work with Table Features
In this exercise, you will create a table of the Kids for Change student volunteer hours and use the table 
features to sort and clean up the data.

	 1.	 �Start Excel, open E11-R1-Hours from your Excel Chapter 11 folder, and save it as: 
E11-R1-HSHours

You will begin by inserting the table.

	 2.	 �Choose Insert→Tables→Table .

	 3.	 �Accept the suggested range, ensure My Table Has Headers is checked, and click OK.

You need to remove the data for the college and university students, keeping only the high school 
students’ data. To do this, you must first sort the data by school.

	 4.	 �Click the School filter button � and choose Sort A to Z.

	 5.	 �Select the range C15:C27and choose Home→Cells→Delete  menu button �→ 
Delete Table Rows.

There are no hours to enter for April, so you can delete this column as well.

	 6.	 �Select cell G4 and choose Home→Cells→Delete  menu button �→Delete Table 
Columns.

Notice that deleting the table columns does not affect the merged titles in rows 1 and 2 on the 
worksheet.

	 7.	 �In cell G5, use AutoSum to enter a formula that finds the sum of the Jan, Feb, and Mar hours.

The function uses structured references to the data in the Hours columns; it’s automatically copied to 
the whole column.

	 8.	 �Click the Total filter button � and choose Sort Smallest to Largest.

	 9.	 �Save your work.

REINFORCE YOUR SKILLS: E11-R2

Use Total Row and Structured References
In this exercise, you will add sparklines, averages, and other formulas to the data for the Kids for Change 
student volunteer hours.

	 1.	 �Save your file as: E11-R2-HSHours

Students receive 20% extra credit if they volunteer more than 100 total hours over the three months. 
You will create a new table column to calculate this.

	 2.	 �Enter the heading Extra Credit in cell H4 and wrap the text.

Notice the table is extended to include column H and the table formatting is applied.

	 3.	 �In cell H5, enter this formula (be sure to select the total amount in cell G5 to create  
the two structured references; type the rest of the formula):  
=IF([@Total]>100,([@Total]-100)*20%,0)


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	 4.	 �Go to Table Tools→Design→Table Style Options and click the Total Row checkbox.

The total row is added, inserting a sum for the Extra Credit column. However, you want to remove this 
and add an average for the three months.

	 5.	 �Select cell H15 and use the menu button � to select None from the drop-down list to remove 
the sum.

	 6.	 �Select cell A15 and type: Average

	 7.	 �Select cell D15 and use the menu button � to select Average from the drop-down list.

	 8.	 �Insert the Average function in the total row for the February and March hours.

	 9.	 �Use the Table Styles gallery (in Table Tools→Design) to change the style to Plum, Table Style 
Medium 9.

	10.	 �Select the range I5:I14 and choose Insert→Sparklines→Line .

	11.	 �For the data range, select the range D5:F14 and click OK.

	12.	 �Use the Style gallery (Sparkline Tools→Design) to change the sparkline style to Plum, 
Sparkline Style Accent 1, Darker 25%.

	13.	 �In cell B17, type: Most Hours in One Month:

	14.	 �Using the mouse to select the table data for all three months, enter this formula in cell D17: 
=MAX(Table1[[Jan Hours]:[Mar Hours]])

	15.	 �Use the Format Painter to copy the format from cell A15 to the range B17:F17 and then merge 
and center the range D17:F17.

	16.	 �Save your work and close the file.

REINFORCE YOUR SKILLS: E11-R3

Work with the Donor List
In this exercise, you will add a record for a new donor and insert additional analysis tools for the Donor 
List using sparklines and summary formulas.

	 1.	 �Open E11-R3-Donors from your Excel Chapter 11 folder and save it as: 
E11-R3-DonorsRevised

	 2.	 �Go to Table Tools→Design→Table Style Options and click the Total Row checkbox.

The total is calculated for lifetime donations, and you also want to add a total to the annual 
donations for this year.

	 3.	 �Select cell F20 and use the menu button � to select Sum from the drop-down list.

Now you will add a new record to the table for a new donor.

	 4.	 �Select cell G19, tap [Tab], and enter this data in the new row:

You won’t have to enter the years of support in column E, as the formula is automatically inserted, 
so once you enter the first donation date in column D, the formula will update the number for you. 
Depending on when this exercise is completed, the result may not be zero.
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	 5.	 �Sort the table by the Total Annual Donation column from Smallest to Largest.

	 6.	 �Select the range F22:G22 and choose Insert→Sparklines→Column .

	 7.	 �For the data range, select the range F5:G20 and click OK.

	 8.	 �Select any cell inside the table and modify the table name

Hint: Choose Table Tools→Design→Properties) to be: Donor_List

	 9.	 �In cell A23, insert the text: Donations This Year From Donors >15 Years 
Support

	10.	 �In cell E23, insert a SUMIF function with these arguments:

As with other formulas, be sure to use the point-and-click method to insert the Range and Sum_
Range arguments in order to create the proper structured references to the Years of Support and Total 
Annual Donations table column data.

	11.	 �Apply the Heading 3 cell style to the range A23:E23.

	12.	 �Apply the Currency number format to cell E23 and remove both decimals.

	13.	 �Save your work and close Excel.
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	 Apply Your Skills
APPLY YOUR SKILLS: E11-A1

Modify a Price List
In this exercise, you will turn the Universal Corporate Events price list of services into a table to make it 
easier to modify the list and calculate the new prices.

	 1.	 �Start Excel, open E11-A1-Prices from your Excel Chapter 11 folder, and save it as: 
E11-A1-PkgPrices

	 2.	 �Insert a table that contains all of the service descriptions, prices, and deposit amounts.

	 3.	 �Change the table style to Light Yellow, Table Style Light 19.

	 4.	 �Insert a new table row above Transportation and lodging and enter this data:

	 5.	 �In the same row, select cell C8 and enter the formula: =[@[Old Price]]*108%

	 6.	 �Sort the table by New Price, Smallest to Largest.

	 7.	 �Add a total row to the table.

	 8.	 �Change the text in cell A13 to: Complete Package Subtotal:

	 9.	 �Add a Sum formula to the New Price column.

	10.	 �Hide column B from the worksheet.

	11.	 �Change the number format for the range C5:D13 to Currency with no decimals.

	12.	 �Convert the table name to: Prices

	13.	 �Save your work.

APPLY YOUR SKILLS: E11-A2

Calculate Customer Discounts
In this exercise, you will create formulas with structured references to calculate the package discount if 
customers order all of the services in their package.

	 1.	 �Save your file as: E11-A2-PkgPrices

	 2.	 �In cell A14, enter: Complete Package Discount:

	 3.	 �In cell C14, type = and select cell C13 (in the total row below New Price), and then type: *15%

The formula should read: =Prices[[#Totals],[New Price]]*15%

Notice the syntax Prices[[#Totals],[New Price]], indicating the formula refers to the new price, in the 
total row, of the Prices table.

	 4.	 �In cell A15, enter: Complete Package Total:

	 5.	 �In cell C15, enter this formula, taking care to use the mouse to select the table data: 
=Prices[[#Totals],[New Price]]-C14



Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Apply Your Skills  287

	 6.	 �In cell A16, enter: Total Services in Package:

	 7.	 �In cell C16, enter this formula, using the mouse to select the table data: 
=COUNT(Prices[New Price])

	 8.	 �Select cell D15 and insert a Line sparkline for the data in the range C13:C15.

	 9.	 �Add markers to the sparkline and change the style to Blue, Sparkline Style Accent 1, Darker 25%.

	10.	 �Save your work and close the file.

APPLY YOUR SKILLS: E11-A3

Analyze Client Feedback
In this exercise, you will use the table tools to analyze the client feedback data and add a total row and 
sparklines.

	 1.	 �Open E11-A3-Feedback from your Excel Chapter 11 folder and save it as: 
E11-A3-FeedbackRevised

	 2.	 �Sort the table by event date from oldest to newest.

	 3.	 �Select the dates for all June events and delete those rows from the table.

	 4.	 �Change the name of the table to: Ratings

	 5.	 �Select cell H5 and modify the formula to use structured cell references.

	 6.	 �Add a total row and insert the Average function for the last four table columns.

	 7.	 �Select the range E22:H22 and apply the Number format.

	 8.	 �Edit the text in cell A22 to be: Overall Average Ratings

	 9.	 �Select the range I5:I21 and insert Column sparklines for the data in the range E5:H21.

	10.	 �Change the sparkline style to Gold, Sparkline Style Accent 4, (no dark or light).

	11.	 �Save your work and close Excel.
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	 	Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

project grader: E11-P1

Enhance Item Sales Data with Table Features
Taylor Games would like to convert its annual item sales data to be used in a table in order to take 
advantage of table features. In this exercise, you will convert the item sales data into a table so you can 
add a total row for easy calculation, apply sorting, leverage structured references, and improve readability. 
You will also add a sparkline to quickly view sales trends throughout the year.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E11_P1_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E11_P1_Start from your Excel Chapter 11 folder.

	 2.	 �Create a table using these guidelines:

•	 Use the range A6:I21 of the Item Sales worksheet as the table data.

•	 Ensure the My table has headers option is selected.

	 3.	 �Change the table name to: ItemSales

	 4.	 �Add a total row.

	 5.	 �Use AutoSum to insert a SUM function in cell H22.

	 6.	 �In cell H22, apply the Comma Style number format and decrease the decimals so that no deci-
mals display.

	 7.	 �Apply the table style Light Blue, Table Style Light 20 (the third option in the Table Styles list).

	 8.	 �Update the formula in cell H7, substituting the cell references with structured references to the 
same data. 

	 9.	 �Update the formula in cell I7, substituting the cell references with structured references to the 
same data.

	10.	 �Insert a table column to the left of the Annual Units column.

	11.	 �Change the column heading label from Column1 to: Trend

	12.	 �Use these guidelines to insert a Line sparkline:

•	 Data Range: D7:G21

•	 Location Range: H7:H21

•	 Show Markers.

	13.	 �Sort the Annual Revenue column from largest to smallest.

	14.	 �Set the width of Column J to: 20

	15.	 �Remove the Filter Button table style option.
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	16.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 11 folder as E11_P1_eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 11 folder as: E11_P1_Submission

project grader: E11-P2

Calculating Appreciation using Structured References
Classic Cars Club would like to calculate the total, yearly average, and overall average appreciation of 
each club member’s car. In this exercise, you will calculate the total and average yearly appreciation for 
each car using structured references, add a total row with average functions, and apply additional table 
style formatting.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E11_P2_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E11_P2_Start from your Excel Chapter 11 folder.

	 2.	 �Change the name of the table in the Car Values worksheet to: CarValues

	 3.	 �Insert a table column to the right of the Current Value column.

	 4.	 �In the new column, change the column heading label from Column1 to: Appreciation

	 5.	 �In cell J8, use a formula with structured references to calculate the appreciation (Current Value 
minus Original Value).

	 6.	 �Delete the formulas from cells J28, J39, and J40.

	 7.	 �Insert a table column to the right of the Appreciation column.

	 8.	 �Change the column heading label from Column1 to: AVG per Year

	 9.	 �In cell K8, use a formula with structured references to calculate the average per year 
(Appreciation divided by Age).

	10.	 �Delete the formulas from cells K28, K39, and K40.

	11.	 �Apply the table style White, Table Style Medium 1 (the fifth option in the Table Styles list).

	12.	 �Set these table style options:

•	 Use the Last Column option.

•	 Add a total row.

•	 Remove the filter button.

	13.	 �In cell J41, use an AVERAGE function for the range J8:J38.

	14.	 �Make these changes to the Total row:

•	 Remove the text in cell A41.

•	 Enter the text Average in cell G41.

•	 Use Align Right cell alignment on cell G41.

	15.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 11 folder as E11_P2_eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 11 folder as: E11_P2_Submission
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

E11-E1	 That’s the Way I See It
You are shopping for a new computer and want to make a table comparing your options. Open a new 
workbook and save it as: E11-E1-Computers

Create a table with the headers Brand, Model, Price, and My Rating. Identify at least three computer 
brands and three different models for each; go online to look up prices for each computer. Insert 
appropriate data into the table and add your own personal rating from one to ten for each computer. 
Add a total row to calculate the average price and sort the table from highest to lowest by your My 
Rating column. 

E11-E2	 Be Your Own Boss
It’s the end of the year and you are analyzing the numbers for Blue Jean Landscaping. You have 
already calculated the revenue and expenses for each month, and now you want to summarize the 
data in a table. Open E11-E2-RevandExp and save it as: E11-E2-RevandExpTable

Insert a table using the appropriate data and add a total row. Change the Total to Net Profit and 
add a sum below each month. Add a new column at the far right of the table and insert an annual 
total for the three rows. In column O, insert sparklines for the three rows of data from January to 
December. Resize the columns and adjust the worksheet formatting as appropriate. 

E11-E3	 Demonstrate Proficiency
The sales of Stormy BBQ’s three flavors of popular BBQ sauce are saved in an Excel sheet, 
and you would like to analyze the data further. Open E11-E3-SauceSales and save it as: 
E11-E3-SauceSalesAnalysis

Insert a table to include all the sales data and then insert a new column to the right to find the total 
sales for each month. Insert sparklines in the first column beside the table to show the sales trend 
for each type of sauce each month. Add a total row to the bottom and summarize with the average 
monthly sales for each sauce type. Below the table, insert one row to show the highest and another 
to show the lowest month of sales for each flavor, using structured references in the formulas. Be sure 
to include an appropriate row label for each row of the summary data. 


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ÝÝ Create PivotTables

ÝÝ Modify and format PivotTables

ÝÝ Apply a filter to a PivotTable

ÝÝ Insert a slicer to filter a PivotTable

ÝÝ Create a calculated field

ÝÝ Create PivotCharts

12 PivotTables and 
PivotCharts

EXCEL

P
ivotTables and PivotCharts 

are powerful, interactive Excel 

features that help you deal with 

large worksheets because they allow you 

to analyze your data in different ways. In 

this chapter, you will create and format 

PivotTables and PivotCharts. You will also 

filter data, add slicers, and create calculated 

fields.
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	 Project: Analyzing Sales Data
You work with Airspace Travel, which provides luxurious vacation packages to tropical 
destinations. You have been given an Excel file containing all the sales information for Airspace 
Travel’s employees for Q3 (July through September). To analyze the employees’ performance, 
you will create a variety of PivotTables and PivotCharts to highlight important details within 
the data.

Creating PivotTables
A PivotTable is a powerful and cooperative Excel tool used to summarize complex information. Pivot-
Tables make it easy to understand large amounts of information by creating a summary report of 
your data. They are created by taking existing data in a worksheet and organizing the various fields 
into columns and rows, which can then be used to display different results. The purpose of a Pivot-
Table is to take large amounts of data and to help you determine, for example, which products are 
selling the best, which employees are performing the best, which day of the week or time of day you 
need to have more staff on hand to reduce wait times for customers, etc.

To create a PivotTable, you can start with a blank table and add fields, or you can use one of the 
recommended PivotTables that Excel suggests based on your data.

View the video “Making a PivotTable.”

What Is a PivotTable?
A PivotTable combines some of the features of both tables and outlines, along with additional unique 
features that make it extremely flexible. You can arrange your data in different ways, which is where 
the term pivot (to turn or rotate) comes from, and you can quickly switch between the different views 
rather than creating a separate table each time. PivotTables are made up of rows and columns that 
contain field labels, and the value fields are then summarized within. PivotTable fields can be used to 
subtotal, compare, count, or perform other calculations on your data, as well.

The following PivotTable uses this data (only a small part of the worksheet data is shown) to compare 
the sum of product and service sales side by side for the employees, who are grouped by position:


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The Row Labels include
 position and last name.

The values for product 
and service sales are shown 
in two columns.

Rows are grouped by position,
 and each group can be collapsed

 or expanded as needed.

The Row Labels field also 
includes a filter button to 
apply a Sort or Filter to the 
rows in the PivotTable.

Arranging the Source Data
To create a PivotTable, you must know where to get the source data and what state the data has to 
be in. Because a PivotTable summarizes data, the source data should not be summarized in any way. 
You can also think of this as being the raw data.

Typically, you want the source data to have fields (column headings) listed across the top, and then 
each row in the worksheet should contain a unique list entry. For example, the source should not 
have a list of employees and then list a summary of sales for each month in the same row. Rather, the 
source should be the raw sales data with a separate row for each individual sale.

The source can be a list of data formatted as either a normal range or a table. The source should not 
contain any blank rows or columns, or duplicate values.

Remove Duplicates
When entering data or combining data from different sources, there is a chance of having the same 
information listed twice. This duplicate information can cause your information to be incorrect, which 
in turn causes incorrect evaluations, analysis, and perhaps important decisions based on flawed data. 
To check for and remove duplicates, you can use the Remove Duplicates command. For the tool to 
determine whether a record is considered a duplicate, you indicate which columns must match. In 
some cases, it requires only one or two columns to determine that a record is a duplicate; for other 
data, you may want to match all columns.

ÍÍ Data→Data Tools→Remove Duplicates
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Adding PivotTable Fields
Whether you start with a blank PivotTable or use a recommended one, you can add and remove 
fields to manipulate the table data after it’s created. The PivotTable Fields pane allows you to quickly 
add and remove fields by either clicking or dragging.

Fields added here are displayed in the 
Row Labels; note in the PivotTable on 
the right that position comes first, 
followed by last names.

Fields added here are displayed in the 
Column Labels; in this example no field 
was added to columns, so the column labels 
are the Values fields.

This area displays the Value fields added to the 
PivotTable and the function being performed.

Fields added
 here can be

 quickly filtered.

Choose from the list of 
field names to be included 

in the PivotTable; these 
are the column names 
from the source data.

ÍÍ Insert→Tables

DEVELOP YOUR SKILLS: E12-D1

In this exercise, you will check the source data for duplicates, insert a blank PivotTable, and add fields to 
the PivotTable to show a summary of sales for each location.

	 1.	 �Start Excel, open E12-D1-Sales from your Excel Chapter 12 folder, and save it as: 
E12-D1-SalesTargets

	 2.	 �Begin by quickly scrolling down through the worksheet to verify the data.

You want to ensure there are no blank rows separating the data. Note that the data ends at row 93. 
Considering there are that many rows, you likely didn’t find any duplicates visually, so you will check 
for them now.

	 3.	 �Choose Data→Data Tools→Remove Duplicates .

In some cases, you may want to match only one or two fields to remove duplicates, but in this case, 
each record could have a repeated value such as name, position, or month. If all the fields match—
including target, sales, and commissions—you know there is a true duplicate.

	 4.	 �Leave all columns checked and click OK.

You will see a dialog box telling you that four duplicates were found and 86 values remain.
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	 5.	 �Click OK to close the dialog box.

	 6.	 �Quickly navigate to the last row of data by pressing [Ctrl]+[¥] and notice the data stops at row 89.

Now you are ready to insert a PivotTable. You will start with a blank PivotTable.

	 7.	 �Choose Insert→Tables→PivotTable .

The Create PivotTable dialog box selects all adjacent data, and the PivotTable will be created on a 
new worksheet by default.

	 8.	 �Confirm the range is Sales!$A$3:$I$89 and click OK to create the PivotTable.

The next step is to add the fields to the PivotTable. You will first add the rows, then the columns, and 
finally the values.

	 9.	 �Click the Location and Position checkboxes (in that order) in the PivotTable Fields pane to add 
those fields as row labels and then drag the Month field into the Columns box.

Adding row labels can be done with a simple click, but column labels are usually added by dragging or 
right-clicking.

Note!
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	10.	 �Click the Sales checkbox (scroll down the field list as necessary) in the PivotTable Fields pane to 
add that field to the Values area.

Because the Sales field contains numerical data, it is automatically added to the Values area rather 
than the Rows area, and the default function is to find the sum of Sales values.

Your PivotTable shows a sum of the sales for each location for each month, with each location also 
showing a breakdown of sales by agents and sales by managers. A grand total is automatically added 
on the right side to sum all three months and at the bottom to sum all locations.

	11.	 �Rename the worksheet: Sum of Sales by Location

	12.	 �Save the file.

Using PivotTables for Analysis
After you have created a PivotTable, you can modify it at any time by adding or removing fields, or by 
changing the positioning and order of fields. This is done by checking/unchecking the boxes next to 
the field names or by dragging the field names in and out of the various areas. Each time you make a 
change, the PivotTable automatically reconfigures to display the new data.

Checking a box next to a field name places it in the default location, usually rows for text and values for 
numeric data. If you drag a text field into the Values area, Excel will use the COUNT function instead of 
SUM since text cannot be added!

Note!
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Changing the order of fields in either the row or column area creates different data groupings, and 
this can be done by dragging and dropping the field names into the new positioning. Or you might 
want to switch a field label from row to column or column to row—pivoting the data.

Arranging fields appropriately is perhaps the most important skill for working with PivotTables 
because each change in the data’s organization tells a new story. It is important to practice orga-
nizing your fields in a variety of ways to see how the information can be shaped to answer different 
questions.

View the video “Changing a PivotTable.”

Formatting PivotTables
Changing the PivotTable’s format can help make the information easier to read and understand. 
Similar to tables, there are a number of styles to choose from in the gallery on the Design tab. There 
are also a number of layout and style options to choose from.

Report Layout options include Compact, Outline, and Tabular. Subtotals can either be displayed at 
the top or bottom of each category or group or turned off altogether, and grand totals can also be 
turned on or off for rows and columns.

Here, product sales are grouped 
by position and then last name in 
the rows, while the columns are 
organized by region.

Now the PivotTable shows the product sales with rows 
grouped by region, then position, then last name. It’s the 
same data, it’s just organized differently.
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Number formatting does not automatically transfer from the source data, but you can quickly 
change the number format for an entire value field by selecting a value and using the Field Settings 
command or by right-clicking a value and choosing Number Format.

This PivotTable has a style and number formatting applied. The report layout is displayed 
in outline form, which takes up more space but makes it easier to see the row labels.

Changing Value Field Settings
For each value field, the settings can be changed to better suit the information you want to show. The 
field name can be customized, the number format can be modified, and a function other than Sum 
can be used to summarize values. For example, instead of showing the sum of sales for each region, 
you might want to show the average sales by region. Then, instead of Average of Product, you could 
adjust the custom name to Avg Product Sales and the number format to Currency.

DEVELOP YOUR SKILLS: E12-D2

In this exercise, you will create another PivotTable and adjust the fields and value field settings to show the 
average by position for commissions, sales, and targets.

	 1.	 �Save your file as: E12-D2-SalesTargets

	 2.	 �Go to the Sales worksheet and choose Insert→Tables→Recommended PivotTables .

The dialog box gives a list of suggested PivotTables on the left and a preview of the selected PivotTable 
on the right.
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	 3.	 �Select the third option on the left, Sum of Commissions, Sum of Sales and Sum of Target by 
Location, and click OK to insert the PivotTable.

	 4.	 �Uncheck the Location box in the PivotTable Fields pane to remove the Location field from the 
PivotTable.

	 5.	 �Now check the Position box in the Fields pane to add that field.

The PivotTable shows employees by first name and then lists their data again in a separate row with 
their positions, which does not make the information displayed very useful at the moment!

	 6.	 �Drag the Position field above the First Name field in the Rows area to change the order of the 
fields.

Now the PivotTable shows the results for each employee grouped by position, which is much more 
useful. Next you will make another change to see a different result.

	 7.	 �Check the Month box to add that field and then remove the First Name field by dragging it out 
of the Rows area and onto the worksheet (this is an alternative to removing the checkmark).

This PivotTable shows a different story by displaying the monthly results for agents and managers 
separately. Next you will apply a new PivotTable style to change the colors of the table.

	 8.	 �Choose PivotTable Tools→Design→PivotTable Styles→Dark Blue, Pivot Style Dark 20.

Now you will adjust the field name and number format for the three value fields.
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	 9.	 �In the Values area, click Sum of Commissions and choose Value Field Settings….

The full field name may be cut off from view; hover the mouse pointer over the field to see the full 
name.

	10.	 �Follow these steps to change the field settings:

A

B

C

A	�Choose Average in Summarize Value Field By.

B	�In the Custom Name box, type: Avg Comm

C	�Click Number Format and then choose Currency and click OK.

	11.	 �Click OK to close the Value Field Settings dialog box.

	12.	 �Repeat this process for the Sum of Sales and Sum of Target fields, including using the Average 
summary function and the Currency number format. Use the custom names: Avg Sales and 
Avg Target 
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	13.	 �Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline Form.

	14.	 �Rename the worksheet: Averages by Position

	15.	 �Save your work.

Filtering a PivotTable
You can filter a PivotTable to remove unnecessary data and focus on the data that is important. To 
add a filter you can use AutoFilter, add a filter field, or add a slicer. Each time you filter a PivotTable, 
the totals and subtotals instantly recalculate throughout the table.

Filtering with AutoFilter
The row labels and column labels have an AutoFilter menu button � that provides the same sorting 
and filtering options available in worksheet lists and tables.

This PivotTable has been filtered to show the Sales Account Mgr and Senior 
Account Mgr positions only, and to sort those positions alphabetically.

Filtering with a Filter Field
Adding a field to the Filters area simplifies the process of filtering the data to display one or more 
categories of data at a time. To turn on the option for showing more than one category, click the 

E
X

C
E

L

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



302  Excel Chapter 12: PivotTables and PivotCharts

Select Multiple Items checkbox in the filter menu. The filtered field and the current filter setting will 
always display directly above the PivotTable.

This PivotTable has been filtered to show only the Eastern region.

Filtering with Slicers
Slicers are menu frames placed on a worksheet that contain all filtering choices for one field. 
Selected items are highlighted in the slicer, making it easy to identify the applied criteria. To select 
multiple fields in a slicer, you can use the Multi-Select feature or use the [Ctrl] key.

Slicers are appealing because they can be moved around, resized, and styled to match the PivotTable, 
but the real benefit is that slicers can be shared with other sheets in the same workbook for other 
PivotTables that use the same source data. Changing the filtered selections in a shared slicer auto-
matically updates all connected PivotTables.

The PivotTable with a slicer used to display only the Central and Eastern region data

Adding the Region field to the Filters area displays that filter 
above the PivotTable (next figure).
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DEVELOP YOUR SKILLS: E12-D3

In this exercise, you will add filters to the existing PivotTables using two different methods.

	 1.	 �Save your file as: E12-D3-SalesTargets

Ensure the PivotTable on the Averages by Position worksheet is selected and the Fields list is visible.

	 2.	 �Drag the Location field into the Filters area.

You will now see the field name Location in cell A1. The filter in cell B1 displays (All), indicating all 
data is showing with no filter applied.

	 3.	 �Click the Location filter button � above the PivotTable, select New York to display the infor-
mation for New York only, and then click OK.

The filter now shows New York, and the data in the PivotTable show the averages for the New York 
location only.

Next you will adjust the Sum of Sales by Location PivotTable by adding a slicer for Position.

	 4.	 �Go to the Sum of Sales by Location sheet and, if necessary, select any cell in the PivotTable.

	 5.	 �Click the Position field in the Rows area and choose Remove Field.
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	 6.	 �Choose PivotTable Tools→Analyze→Filter→Insert Slicer .

	 7.	 �In the Insert Slicers dialog box, click the Position checkbox and then click OK.

The slicer window is displayed on the sheet, and the Slicer Tools are displayed on the Ribbon.

	 8.	 �Drag the slicer window directly beside the PivotTable, with the tops of both  
roughly aligned.

	 9.	 �Go to Slicer Tools→Options→Size and resize the slicer to exactly 1" high 
and 1.5" wide.

	10.	 �Apply the Light Blue, Slicer Style Dark 5 style (Slicer Tools→ 
Options→Slicer Styles) to the slicer.

	11.	 �Click Agent in the slicer window to display the sales data for agents only.

Now you will adjust the number format for sales values.

	12.	 �Right-click cell E5 and choose Number Format…, then choose Currency, 
set to zero decimals, and click OK.

Notice the entire range of values is now formatted with the Currency style.

	13.	 �Select Manager in the slicer window to display the sales data for managers only.

	14.	 �Save the file.

Creating Calculated Fields
You may want to create your own calculations and add them to your PivotTables. A calculated field 
uses a formula containing values from one or more of the existing fields. For example, you could take 
Sales values and multiply by 5% or take the Cost field from a PivotTable and subtract the Sales field.
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In this example, a calculated field is created by taking Product field 
values and multiplying them by 105% to get the expected product sales 
growth, which is 5% above the current product value.

ÍÍ PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets

Show Values As
Another option for displaying PivotTable values is to use comparison operations, which are also 
available from the Value Field Settings dialog box. There are options already created to determine 
calculations such as a percentage of a grand total, the difference between values in two fields, or a 
ranking order.

This PivotTable shows each employee’s sales in dollars and as a percentage of the grand total.

Refreshing PivotTable Data
Whenever you change the source data, you must also refresh your PivotTable to reflect the updated 
data. You can refresh only the current PivotTable or all of them at once. You can also set up an option 
to refresh the data each time the file is opened.

ÍÍ PivotTable Tools→Analyze→Data→Refresh

Referencing PivotTable Data
Extracting data from a PivotTable requires using the GETPIVOTDATA function. This function is much 
easier to use than most functions because it can be created with just a click. Using the point-and-click 
method to create a reference to data in a PivotTable inserts the function and all the required argu-
ments simultaneously.

DEVELOP YOUR SKILLS: E12-D4

In this exercise, you will create a new PivotTable that shows which employees achieved their sales targets.

	 1.	 �Save your file as: E12-D4-SalesTargets

	 2.	 �Go to the Sales sheet and create a new PivotTable using the default values.

	 3.	 �Rename the new sheet: % of Target
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	 4.	 �Add the Location, Position, and Last Name fields to the Rows area, in that order.

	 5.	 �Add Sales and Target to the Values area, in that order.

Values are automatically added to the Columns area as well.

	 6.	 �In the Values area, adjust the value field settings of each to Currency with no decimals and use 
the custom names: Total Sales and Total Target

	 7.	 �Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets →Calculated 
Field….

	 8.	 �Follow these steps to create a calculated field:

A

B

A	In the Name box, enter: % of Target

B	Delete the number 0 in the Formula box, select Sales and click Insert Field

C	Type / and then select Target and click Insert Field.

	 9.	 �Click OK to create the calculated field, which will divide sales by the target and be displayed in 
the Values quadrant.

The calculated field will only display mostly 1s until the number format is changed.

	10.	 �Right-click cell D4 and open the Value Field Settings for the calculated field, change the name 
to Total % of Target and the Number Format to Percentage with two decimal places.

Now the calculated field displays percentages above and below 100%, where 100% represents 
reaching their target.

C
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	11.	 �Click the collapse buttons for the Agent and Manager labels to display locations and positions only.

	12.	 �Change the PivotTable style to Dark Blue, Pivot Style Dark 20.

	13.	 �Now go to the Sales sheet and select cell H7.

New sales information has come in for Sarah Mckinnon for July, so you will enter the new information.

	14.	 �Enter the correct information by typing 12900 in cell H7.

	15.	 �Return to the % of Target sheet and choose PivotTable Tools→Analyze→Data→Refresh  
menu button �→Refresh All.

The data in all PivotTables is now updated to reflect the correction.

	16.	 �Save the file.

Creating PivotCharts
PivotCharts are charts based on PivotTable data. PivotCharts can be created simultaneously with the 
PivotTable or after the PivotTable has been created, but a PivotChart must have an associated PivotTable. 
The fields on the Values area of the PivotTable are displayed as data series on the chart. The row labels 
are used as the axis labels, and the column labels are used in the chart legend. The PivotChart Tools tab 
contains all of normal options for chart formatting, in addition to the Analyze options for PivotTables.

Filtering PivotCharts
A PivotChart also includes AutoFilter buttons directly in the chart for quick and easy access to filter 
options. Filtering the PivotChart also filters the associated PivotTable, and vice versa. If a slicer has 
been added to the PivotTable, filtering can also be performed with the slicer for the PivotChart.

The PivotTable Legend values 
indicate the columns being displayed.

Filter buttons can be used to filter the data; 
in this example, the filter for position displays 
the Sales and Senior Account Mgr positions 
but hides the Sales Reps.
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DEVELOP YOUR SKILLS: E12-D5

In this exercise, you will insert a PivotChart for an existing PivotTable and then build a new PivotChart 
while creating the adjoined PivotTable at the same time.

	 1.	 �Save your file as: E12-D5-SalesTargets

	 2.	 �Go to the Sum of Sales by Location sheet.

	 3.	 �Select the pivot table, if necessary, and then choose PivotTable Tools→Analyze→Tools→ 
PivotChart .

	 4.	 �Click OK to insert the clustered column chart.

	 5.	 �Drag the chart so it is directly below the PivotTable.

	 6.	 �In the slicer, click the Multi-Select  button and then click Agent to display data for both 
positions in the chart.

	 7.	 �Go to the Sales worksheet and choose Insert→Charts→PivotChart .

	 8.	 �In the Create PivotChart dialog box, click OK.

	 9.	 �In the PivotChart Fields pane, add Location to the Axis area, Month to the Legend area, and 
Commissions to the Values area.

Use whatever method you prefer to add fields, as long as they are added to the correct area.

	10.	 �In the PivotChart legend, click the Month button, click to remove the 
checkmark from Sep, and click OK.

In the PivotChart, the September data is removed and only July and August 
are displayed.

	11.	 �Rename the worksheet: Commissions by Month

	12.	 �Drag the chart so it is directly below the PivotTable.

	13.	 �Save your work and close the file.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: E12-R1

Create a PivotTable
In this exercise, you will use the data from the Kids for Change fundraising receipts to create a PivotTable 
summary to show the amounts received by Category, Type, and Date.

	 1.	 �Open E12-R1-ReceiptsData from your Excel Chapter 12 folder and save it as: 
E12-R1-ReceiptsSummary

	 2.	 �Choose Data→Data Tools→Remove Duplicates  to check for duplicates, leave all columns 
checked, and click OK.

Three duplicate values are found and removed, and 43 unique values remain.

	 3.	 �Click OK.

	 4.	 �Choose Insert→Tables→PivotTable , confirm the range is Receipts!$A$4:$F$47, and  
click OK.

	 5.	 �Click the checkboxes for Category and Type in the PivotTable Fields pane to add both fields to 
the Rows area.

	 6.	 �Add the Date field to the Column area.

Notice that Excel automatically adds a Months label to the Columns area to group the dates by 
month for January–March.

	 7.	 �Click the Amount checkbox to add that field to the Values area.

	 8.	 �Choose PivotTable Tools→Design→PivotTable Styles→Light Blue, Pivot Style Medium 9.

	 9.	 �Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline Form.

	10.	 �Choose PivotTable Tools→Analyze→Active Field→Field Settings.

	11.	 �In the Value Field Settings dialog box, change the custom name to Receipts Summary and 
change the number format to Currency with no decimals.

	12.	 �Rename the worksheet to Receipts Summary and then save the file.

REINFORCE YOUR SKILLS: E12-R2

Filter a PivotTable and Add a Calculated Field
In this exercise, you will use the Receipts Summary PivotTable to filter by employee, add a calculated field 
to estimate the Q2 receipts, and create a PivotChart.

	 1.	 �Save your file as: E12-R2-ReceiptsSummary

	 2.	 �Create a copy of the Receipts Summary worksheet, renaming it: Receipts Q2 Est.


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	 3.	 �On the Receipts Q2 Est. sheet, drag the Employee field into the Filters area.

	 4.	 �Click the Employee filter button � above the PivotTable, check the box for Select Multiple 
Items, and then clear the check from the All box to deselect all employees at once.

	 5.	 �Click to select Bowers, Burke, and Drew from the list to display the information for those 
employees and click OK.

	 6.	 �Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets→Calculated 
Field.

	 7.	 �In the Insert Calculated Field dialog box, enter Q2 Est. in the Name box.

	 8.	 �Insert the formula =Amount*1.05 and click OK.

The Q2 growth is expected to be 5%, so the calculated field adds 5% by taking the amount and 
multiplying by 1.05.

	 9.	 �Remove the Months and Date fields from the Columns area.

	10.	 �Open the Value Field Settings for the Receipts Summary field.

	11.	 �Click the Show Values As tab, select % of Grand Total from the Show Values As menu, and 
click OK.

	12.	 �Use the Employee filter to display all employees.

	13.	 �To insert a PivotChart, choose PivotTable Tools→Analyze→Tools→PivotChart .

	14.	 �Select the Combo chart and adjust the Chart Type and Secondary Axis settings as shown, click-
ing OK when finished:

	15.	 �Use the Category filter on the PivotChart to display the Corporate values only.

	16.	 �Drag the PivotChart to directly below the PivotTable.

	17.	 �Save your work and close the file.

REINFORCE YOUR SKILLS: E12-R3

Create a Volunteer Hour Summary
In this exercise, you will create a summary of the Kids for Change volunteer hours to show the average 
funds raised per hour for all volunteers.

	 1.	 �Open E12-R3-Hours from your Excel Chapter 12 folder and save it as: 
E12-R3-HoursSummary

	 2.	 �Choose Insert→Tables→Recommended PivotTables , select Sum of Hours by Name (+) 
(the fourth option on the left), and click OK.

	 3.	 �Add the Funds field to the Values area.
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	 4.	 �Choose PivotTable Tools→Design→PivotTable Styles→Dark Blue, Pivot Style Dark 2.

	 5.	 �Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline Form.

	 6.	 �Autofit the widths of columns A–D.

	 7.	 �Select a cell in the Sum of Funds column and choose PivotTable Tools→Analyze→Active 
Field→Field Settings.

	 8.	 �In the Value Field Settings dialog box, change the custom name to Total Funds and the 
number format to Currency with no decimals.

	 9.	 �Rename the worksheet: Summary

	10.	 �Insert a new calculated field named Average that uses the formula: =Funds/Hours

	11.	 �Select a cell in the Sum of Average column and edit the Value Field Settings by changing the 
custom name to Avg Per Hour and the number format to Currency with two decimals.

	12.	 �Choose PivotTable Tools→Analyze→Filter→Insert Slicer .

	13.	 �In the Insert Slicers dialog box, select Month, click OK, and then move the slicer to the right of 
the PivotTable.

	14.	 �In the Month slicer, click the Multi-Select  button and then click Jan, Feb, and Mar to 
display data for April to June only.

	15.	 �Go to the Hours sheet, insert a new row above row 29, and fill it in as follows:

	16.	 �Return to the Summary sheet, click any cell in the PivotTable, and choose PivotTable Tools→ 
Analyze→Data→Refresh.

Jessica’s sum of hours has increased from 39 to 59.

	17.	 �Choose PivotTable Tools→Analyze→Tools→PivotChart .

	18.	 �Choose the Combo chart, adjust the Chart Type and Secondary Axis settings as shown, and click 
OK when finished:

	19.	 �Drag the chart directly below the PivotTable.

	20.	 �Save your work and close the file.
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	 Apply Your Skills
APPLY YOUR SKILLS: E12-A1

Create an Event Summary
In this exercise, you will create a PivotTable to show the events sold by each of the Universal Corporate 
Events staff, for each event type.

	 1.	 �Open E12-A1-Q3Events from your Excel Chapter 12 folder and save it as: 
E12-A1-Q3EventsSummary

	 2.	 �Use the Recommended PivotTables to insert the Count of Client by Salesperson (+) and 
Event PivotTable.

	 3.	 �Rename the PivotTable sheet: Events by Salesperson

	 4.	 �Add the Fee field to the Values area and adjust its field settings to display the name Fees and 
the number format in Currency with no decimals.

	 5.	 �Adjust the Count of Client field settings to display the name: # Clients

	 6.	 �Apply Light Yellow, Pivot Style Medium 12 to the PivotTable.

	 7.	 �Show the report layout in Outline form.

	 8.	 �AutoFit the column widths.

	 9.	 �Use the Event filter button � to remove staff parties, displaying team building and training 
events only.

APPLY YOUR SKILLS: E12-A2

Compare Sales by Category with a PivotChart
In this exercise, you will create a new PivotTable to show the percentage of sales for each event type and 
create a PivotChart to display the results.

	 1.	 �Save your file as: E12-A2-Q3EventsSummary

	 2.	 �Go to the Q3 Events sheet; insert a new, blank PivotTable; and apply Light Yellow, Pivot Style 
Medium 12.

	 3.	 �Add Event to the Rows area, Salesperson to the Columns area, and Fee to the Values area.

	 4.	 �Adjust the Fee value field settings to show values as % of Grand Total.

	 5.	 �Insert a PivotChart using the default column chart option and position it directly below the 
PivotTable.

	 6.	 �With the chart area still selected, apply the shape style Moderate Effect – Gold, Accent 4. 

Hint: Go to PivotChart Tools→Format→Shape Styles.

	 7.	 �Use the PivotChart Salesperson filter to display the data for David Sutton only.

	 8.	 �Save your work and close the file.


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APPLY YOUR SKILLS: E12-A3

Summarize Client Feedback
In this exercise, you will use the feedback to create a PivotTable and PivotChart showing the average 
feedback that Universal Corporate Events received for each event type.

	 1.	 �Open E12-A3-Feedback from your Excel Chapter 12 folder and save it as: 
E12-A3-FeedbackSummary

	 2.	 �Insert a PivotChart based on the range A4:G36 into a new worksheet.

	 3.	 �Add the Event field to the Axis area and add Staff Rating, Experience Rating, and Facility 
Rating to the Values area.

	 4.	 �Adjust the three Values area fields to calculate averages, use the Number format with one 
decimal place, and edit the names to: Staff, Experience, and Facility

	 5.	 �Insert a slicer to filter by client, positioning it directly below the PivotTable.

	 6.	 �Use the slicer’s Multi-Select  button to remove Green Clean and iJams only.

	 7.	 �Format the PivotTable with Light Yellow, Pivot Style Medium 12 and the slicer with Light 
Yellow, Slicer Style Dark 4.

	 8.	 �Add the Fee field to the Values area, modifying its name to Rank by Fee and showing values 
as Rank Largest to Smallest.

	 9.	 �If necessary, move the chart to the right of the PivotTable.

	10.	 �Save your work and close Excel.
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	 	Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

project grader: E12-P1

Analyzing Quarterly Sales Data with PivotTables
Taylor Games is tracking distributor sales for the first quarter of the new year. This year, they would like 
to analyze sales data using PivotTables and PivotCharts instead of creating formulas and manipulating 
data directly in the worksheet. In this exercise, you will display first-quarter sales data for game and 
toy stores. You will first remove duplicate data and create a new PivotTable worksheet. Then, you will 
create a calculated field and add a PivotChart. Last, you will filter the data and enhance the worksheet’s 
appearance.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E12_P1_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E12_P1_Start from your Excel Chapter 12 folder.

	 2.	 �Use the default settings in the Remove Duplicates tool to remove six duplicate rows from the 
worksheet.

	 3.	 �Create a PivotTable using these guidelines:

•	 Use the range A6:H42 of the Distributor Sales Q1 worksheet as the data you want to 
analyze.

•	 Place the PivotTable in a new worksheet.

	 4.	 �Rename the PivotTable worksheet: Toy-Game Store Sales

	 5.	 �Add the Category field to the Rows area.

	 6.	 �In cell A3, change the Row Labels display name to: Category

	 7.	 �Add the January, February, and March fields to the Values area. 

	 8.	 �Make these text changes:

•	 Cell B3: January Sales

•	 Cell C3: February Sales

•	 Cell D3: March Sales

	 9.	 �Apply the Accounting number format to the range B4:D8.

	10.	 �Add a Calculated Field to the PivotTable using these guidelines:

•	 Name: Q1 Total

•	 Formula: =January+February+March

	11.	 �In cell E3, change the Sum of Q1 Total display name to: Q1 Total Sales

	12.	 �Apply the PivotTable style Light Yellow, Pivot Style Yellow 19 (the sixth option in the 
PivotTable Styles list).

	13.	 �Insert a 3-D Clustered Bar PivotChart and position it just below the PivotTable.

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Project Grader  315

	14.	 �Set the PivotChart’s height to 4.5" and its width to 10".

	15.	 �Use the PivotChart Category filter to only display chart data for the Game/Hobby Store and 
Toy Store categories.

	16.	 �Apply Chart Style 6 to the PivotChart.

	17.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 12 folder as E12_P1_eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 12 folder as: E12_P1_Submission

project grader: E12-P2

Analyzing Future Value Using a PivotTable and PivotChart
Classic Cars Club would like to estimate future car values for members. They would also like the data 
presented in a PivotTable in order to quickly filter the data. In this exercise, you will create a new 
worksheet containing a PivotTable and PivotChart that displays the estimated value 20 years from  
now of member-owned cars with a status of classic.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E12_P2_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E12_P2_Start from your Excel Chapter 12 folder.

	 2.	 �In the CarValues worksheet, insert a PivotTable using these guidelines:

•	 Use CarValues as the table/range.

•	 Place the PivotTable in a new worksheet.

	 3.	 �Rename the PivotTable worksheet as: 20 Year Estimate - Classics

	 4.	 �Add the Last Name and Car Year fields to the Rows area.

	 5.	 �In cell A3, change the Row Labels display name to: Members

	 6.	 �Add the Current Value field to the Values area.

	 7.	In cell B3, change the Sum of Current Value display name to: Current Values

	 8.	 �Apply the Accounting number format to the range B4:B61 and then decrease the decimal 
places so no decimals display.

	 9.	 �Add a calculated field to the PivotTable using these guidelines:

•	 Name: Estimated Value

•	 Formula: ='Current Value'+('AVG per Year'*20)

	10.	 �In cell C3, change the display name to: 20 Year Estimate

	11.	 �Modify the PivotTable layout as follows:

•	 Subtotals: Do not show subtotals.

•	 Report Layout: Show in tabular form.
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	12.	 �Apply the PivotTable style Light Yellow, Pivot Style Light 18 (the fifth option in the PivotTable 
Styles list).

	13.	 �Insert a slicer using these guidelines:

•	 Slicer to Insert: Status

•	 Height: 1.1"

•	 Width: 1.25"

•	 Filter by: Classic

•	 Position it below the PivotTable.

	14.	 �Insert a 3-D Area PivotChart.

	15.	 �Set the PivotChart height to 5" and the width to 10".

	16.	 �Close the PivotTable Fields pane and then position the PivotChart to the right of the PivotTable.

	17.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 12 folder as E12_P2_eSubmission and attach 
the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 12 folder as: E12_P2_Submission
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

E12-E1	 That’s the Way I See It
As a student, you’re always looking for ways to save money, so you’ve been tracking all your expenses 
for the past three months. Now you want to create a PivotTable and PivotChart to analyze your 
spending habits. Open E12-E1-PersonalExp and save it as: E12-E1-PersonalExpPT

Create a PivotTable from the data on Sheet1 and organize the fields so you can see the monthly 
spending as well as a grand total for all three months, for each expense type. Create a slicer for the 
Type field, add a PivotChart of your choice, and apply other formatting as you see fit.

E12-E2	 Be Your Own Boss
Blue Jean Landscaping keeps its revenue figures for the past six months in an Excel worksheet, and 
you want to compare the total numbers according to type and category. Open E12-E2-Revenue and 
save it as: E12-E2-RevenuePT

Create a PivotTable and set the fields as indicated. Create 
a calculated field called Forecast that will calculate a 5% 
increase in revenue and then add a slicer to filter by category. 
Apply any other formatting you feel is appropriate for a 
financial report.

E12-E3	 Demonstrate Proficiency
You are analyzing Stormy’s BBQ sauce sales data for the month of April. Open E12-E3-Sales and 
save it as: E12-E3-SalesAnalysis

Create a PivotChart based on the data on the Sales sheet, 
setting the fields as noted. Change the chart type to Pie, apply 
your choice of chart style, and modify the pie colors to match 
the company colors of red, gold, and black. Move and resize 
the chart appropriately. Finally, add a Sauce Type slicer and 
display the World Famous sauce.



Add These Fields

Rows area Type, Category

Columns area Quarter

Values area Revenue

Add These Fields

Axis area Location

Legend area Sauce Type

Values area Cases Ordered
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L E A R N I N G  O B J E C T I V E S

ÝÝ Change the macro security settings

ÝÝ Create macros to automate tasks

ÝÝ Run macros

ÝÝ Create macro buttons to run macros quickly

13 Working with Macros

EXCEL

M
any Excel workbooks you 

create will be used over and 

over and the same tasks will be 

performed repeatedly, like transferring data 

from one worksheet to another. Being able to 

automate certain tasks is more efficient and 

can reduce the risk of errors. In this chapter, 

you will change the security settings to allow 

macros in Excel that will enable you to 

automate common, repetitive tasks.
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	 Project: Creating Macros to Simplify Tasks
The sales data for Airspace Travel is used frequently and is often sorted in different ways to 
compare results. In order to make it quick and easy for any team member to use the data, you 
will create macros to do the sorting for you. You’ll also create custom buttons so a complex 
sort can be done with just one click.

Introducing Macros
A macro is a recorded set of mouse and keyboard actions that can be played back at any time. 
Essentially, a macro records the actions so a repetitive series of tasks can be completed with a single 
click of the mouse. For example, if the first thing you do when you create a new workbook is enter the 
company name in the header and the date in the footer, you can create a macro that performs these 
actions with one click, saving you valuable time.

Changing Macro Security
Macros are a way of programming Excel to take shortcuts, but they can contain viruses, so you 
should be aware of the added security features associated with using macros. You can change macro 
security settings in the Trust Center, and these settings take effect for all Excel workbooks opened on 
that computer. There are four options for macro security:

ÝÝ Disable all macros without notification

ÝÝ Disable all macros with notification

ÝÝ Disable all macros except digitally signed macros

ÝÝ Enable all macros

Choosing to enable all macros is not recommended due to potentially unsafe macros.

Disabling all macros with a notification is the default and recommended option because this gives 
you the option of allowing or disabling macros as you see fit, each time you open a macro-enabled 
workbook.

ÍÍ File→Options→Trust Center→Trust Center Settings→Macro Settings

DEVELOP YOUR SKILLS: E13-D1

In this exercise, you will verify the macro security settings and then open a workbook and enable the 
macros.

	 1.	 �Start Excel and open a new, blank workbook.

	 2.	 �Choose File→Options→Trust Center.

	 3.	 �Click the Trust Center Settings button, choose the Macro Settings category, and if necessary 
choose Disable all macros with notification.

	 4.	 �Choose the Message Bar category from the left side of the window and verify that the Show 
the Message Bar… option is selected.



Warning!
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	 5.	 �Click OK twice to close both dialog boxes.

	 6.	 �Open E13-D1-MacroTest from your Excel Chapter 13 folder.

	 7.	 �On the message bar, click the Enable Content button to enable the macros for this workbook.

	 8.	 �Save the file as: E13-D1-Macro

Note the default file type is a macro-enabled workbook 
because it was saved that way previously.

The workbook has macros in it, which enable the user 
to click a custom-made button to sort the data.

	 9.	 �Click the Sort by Leader button at the top of the worksheet.

The list is now sorted alphabetically (A–Z) by the Team Leader column.

Running a macro cannot be reversed by clicking the Undo button.

	10.	 �Save and close the file.

Recording Macros
To create a macro, you can record a series of actions that you perform in a way that’s similar to using 
a video camera. You click a button to start recording and then click again to stop recording when 
finished. You can then run the macro again and again to repeat the same series of actions, including 
keystrokes and mouse clicks.

There are several options for recording macros. One quick method is the button on the status bar.

Warning!
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There’s also a button on the Developer tab. (After the Record Macro button is clicked, the Stop 
Recording button will appear in both places.)

To view the Developer tab, right-click anywhere on the Ribbon and choose Customize the Ribbon. Under 
Customize the Ribbon (Excel Options window), click the box next to Developer and click OK.

Clicking the Record Macro button launches the Record Macro window, where you can rename the 
macro or retain the default (Macro1, Macro2, etc.) and assign a keyboard shortcut if desired. Macro 
names may not contain spaces.

Recording the Macro Steps
Most actions you perform are recorded in the macro, including mouse actions, choosing Ribbon 
commands, selecting options in dialog boxes, using arrow keys to navigate the worksheet, and typing 
text. Any mistakes or corrections made during the recording are saved as part of the macro. As long 
as the final result is correct, you can keep the recording with the mistakes and corrections, rather 
than recording a new macro; the macro will still give the proper results when you run it. That said, it’s 
a good idea to practice the steps before actually recording the macro.

Storing and Sharing Macros
The macro you record is saved only for that particular workbook, unless you assign it to the Personal 
Macro Workbook. Some macros are only useful for one specific workbook, but others may be useful 

Note!
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for any Excel file. The Personal Macro Workbook is a hidden folder, and any macros saved there are 
available to all open workbooks.

You can also copy a macro from one workbook to another. For example, you may initially create a 
macro for one workbook and then decide it would be useful in other workbooks as well. Copying a 
macro to another workbook requires opening both workbooks simultaneously and, with the Visual 
Basic editor open, dragging the macro from one to the other.

Saving a Workbook Containing Macros
To save a normal Excel file after recording and saving macros, you must use the Save As command 
and choose the Excel Macro-Enabled Workbook file type. If you use the Save command, Excel will 
display a warning message.

This is a safety feature that prevents you from accidentally losing the macros you create. Clicking No 
in the message window opens the Save As dialog box so you can change the file type. Files saved with 
the Excel Macro-Enabled Workbook file type have the extension .xlsm (the “m” is for “macro”).

DEVELOP YOUR SKILLS: E13-D2

In this exercise, you will record a macro to sort the employee list by location, position, and first name, in 
that order. You will save the workbook in the macro-enabled file format.

	 1.	 �Open E13-D2-Sales from your Excel Chapter 13 folder and save it as: 
E13-D2-SalesReport

	 2.	 �Click Record Macro  on the status bar in the bottom-left corner of the Excel window.

If the Record Macro button is not showing, right-click the status bar and select Macro Recording to 
add it to the status bar.

	 3.	 �In the Record Macro dialog box, type SortbyLocation as the macro name and click OK.

	 4.	 �Ensure cell A5 is selected and choose Home→Editing→Sort & Filter→Custom Sort.
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	 5.	 �Create this sort, using the Add Level button for each new sort type and clicking OK when finished:

	 6.	 �Click Stop Recording  on the status bar.

The data is sorted. You want to save the macro so you can perform the same sort in the future by 
simply running the macro.

	 7.	 �Click Save, which opens the warning to alert you that the macro will be lost unless you change 
the file type.

	 8.	 �Click No, change the file type to Excel Macro-Enabled Workbook, and click Save.

Running and Assigning Macros
Running a macro is easy to do from the Macro dialog box. It’s even easier if you assign a macro to 
a shortcut key, a custom button on a worksheet, or a custom button on the Quick Access toolbar. 
Running a macro then becomes as simple as clicking any other Ribbon button.

You can assign a macro to a shortcut key either when you initially create it or later by editing its 
options. Or you can insert a shape onto the worksheet and then assign a macro to that shape, 
creating a custom button.

To create a keyboard shortcut, the keys [Ctrl] or [Ctrl]+[Shift] must be part of the combination. A 
shortcut you assign will override any existing shortcut; keep this in mind when assigning shortcut keys. 
For example, if you assign [Ctrl]+[B] to a macro, you won’t be able to use that shortcut to apply bold 
formatting. As a way around this, you can use [Ctrl]+[Shift]+[B] for the macro shortcut instead.

ÍÍ View→Macros→Macros  | Developer→Code→Macros

DEVELOP YOUR SKILLS: E13-D3

In this exercise, you will run an unassigned macro, record a new macro and assign a shortcut to it, and 
then create custom buttons for the two macros.

	 1.	 �Save your file as: E13-D3-SalesReport
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	 2.	 �Select cell C5 and then choose Home→Editing→Sort & Filter→Sort A to Z.

To re-sort the data by location, you will run the macro you recorded earlier.

	 3.	 �Choose View→Macros→Macros .

	 4.	 �Ensure SortbyLocation is selected (it should be the only macro listed) and click Run.

The data is once again sorted by location, then position, then first name. Running the macro also 
closes the Macro window.

Assign a Macro to a Shortcut Key
To make it easier to run the macro, you will assign a shortcut key.

	 5.	 �Choose View→Macros→Macros .

	 6.	 �Ensure SortbyLocation is selected and choose Options.

	 7.	 �With the insertion point in the Shortcut Key box, press [Shift]+[D].

	 8.	 �Click OK to close the dialog box and then close the Macro window.

	 9.	 �Select cell G5 and then choose Home→Editing→Sort & Filter→Sort Smallest to Largest to 
sort employees by number of sales.

	10.	 �Now press [Ctrl]+[Shift]+[D] to once again sort by location, position, and first name.

Create Custom Buttons
To make it easier to remember and run the macros, you will create custom buttons using shapes.

	11.	 �Click Record Macro  on the status bar.

	12.	 �In the Record Macro dialog box, type SalesbyPosition under Macro Name and click OK.

	13.	 �Choose Home→Editing→Sort & Filter→Custom Sort.

	14.	 �Create this sort, removing a level and editing the levels as needed. 

Hint: Use the Delete Level button and note the order to sort by.

	15.	 �Click OK in the Sort dialog box then click Stop Recording  on the status bar.

The data is sorted and the macro is saved. The Sales column should be arranged from largest to 
smallest for agents and then for managers.
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	16.	 �Choose Insert→Illustrations→Shapes and select Rectangle: Rounded Corners.

	17.	 �Draw the rectangle shape from cell J3 to cell K4, approximately two rows high and two 
columns wide.

	18.	 �With the shape still selected type: Sort by Location

	19.	 �Insert another rounded rectangle shape, this time drawing the shape from cell J6 to cell K7.

	20.	 With the shape still selected, type: Sort by Sales

Your buttons need not exactly match the size and position shown here:

	21.	 �Right-click the Sort by Location shape and choose Assign Macro….

	22.	 �In the Assign Macro dialog box, select the SortbyLocation macro and click OK.

	23.	 �Right-click the Sort by Sales shape and assign the SalesbyPosition macro to it.

	24.	 �Deselect the shape by clicking any cell on the worksheet.

	25.	 �Point to the top shape and notice that the mouse pointer changes to a hand shape, then click the 
button to sort the data by location.

	26.	 �Point to the bottom shape and then click it to sort the data by sales.

	27.	 �Save the file and close Excel.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: E13-R1

Create and Use Macros
In this exercise, you will create a macro to insert today’s date and assign a bib number to a new 
participant who is entering the Kids for Change charity race.

	 1.	 �Start Excel, open E13-R1-Race from your Excel Chapter 13 folder, and save it as a macro-
enabled workbook named: E13-R1-RaceEntries

	 2.	 �Click Record Macro  on the status bar.

	 3.	 �In the Record Macro dialog box, type NewEntry as the macro name, type e as the shortcut key, 
and click OK.

	 4.	 �Right-click row 6 and select Insert to insert a new row.

	 5.	 �In cell B6, type =TODAY() and press [Enter].

	 6.	 �Now copy cell B6 and paste the contents into cell B6, but use Paste Options to only paste 
Values.

This way, running the macro will always result in the current date being entered in the cell, without the 
formula.

	 7.	 �Now select the range E7:E8 and use the fill handle to drag up one row and fill in cell E6 with a 
bib number for the new race entrant.

	 8.	 �Click Stop Recording  on the status bar.

	 9.	 �Right-click row 6 and select Delete to remove the new entry so you can test the macro.

	10.	 �Choose View→Macros→Macros , ensure NewEntry is selected, and click Run.

	11.	 �Save your work.

REINFORCE YOUR SKILLS: E13-R2

Run and Assign a Macro
In this exercise, you will insert a shape and assign a macro to it that adds new participants with a single 
click.

	 1.	 Save your file as: E13-R2-RaceEntries

	 2.	 �Press [Ctrl]+[E] to run the macro again.

You should see today’s date in cells B6 and B7 for two new entries, and bib numbers 417 and 418 in 
cells E7 and E6, respectively.

	 3.	 �To insert a button to easily run the macro, choose Insert→Illustrations→Shapes, select 
Rectangle, and draw a rectangle just smaller than the size of the range B1:B2:


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	 4.	 �With the shape still selected, type: New Entry

	 5.	 �Right-click the shape and choose Assign Macro…, select the NewEntry macro, and click OK.

	 6.	 �From the Shape Styles gallery on the Format tab, choose the Light 1 Outline, Colored Fill – 
Black, Dark 1 style.

	 7.	 �Apply bold formatting, increase the font size to 12 points, and center-align the text in the shape.

	 8.	 �Delete rows 6–7 and then click the New Entry button twice to run the macro and again insert 
new entry dates and bib numbers for two participants.

	 9.	 �Save the file.

REINFORCE YOUR SKILLS: E13-R3

Add Data to the Summary with a Macro
In this exercise, you will automate the task of copying information from one worksheet and inserting it into 
another worksheet.

	 1.	 �Open E13-R3-Receipt from your Excel Chapter 13 folder and save it as a macro-enabled 
workbook named: E13-R3-ReceiptAuto

	 2.	 �Go to the Donation Receipt worksheet and enter this placeholder information into the receipt 
fields (row 5): First, Last, 555-1234, 100

	 3.	 �Start recording a new macro (default storage location, no shortcut) named: AddReceipt

	 4.	 �While the macro is recording, complete these steps in order:

•	 Go to the Donation Summary sheet and insert a new row above row 6.

•	 Go back to the Donation Receipt sheet, select the range B5:F5, and copy the data.

•	 Go to the Donation Summary sheet and paste the values only into cell B6.

•	 Select cell G7 and use the fill handle to copy the formula up to cell G6.

•	 Select cell B6.

•	 Return to the Donation Receipt sheet, delete the entries in the range B5:E5 (don’t delete the 
date), and then select cell B5 only.

•	 Stop recording the macro.

	 5.	 �Enter your own information into the receipt fields (or make it up) and $200 for the donation 
amount.

	 6.	 �Run the macro.

	 7.	 �Go to the Donation Summary sheet to view the row with your name at the top and the new 
total calculated under Total Donations.

	 8.	 �Delete rows 6–7 with the two test entries you created and then go back to the Donation 
Receipt sheet.

	 9.	 �Insert a rectangle shape in the range E6:F7 and add the text ADD RECEIPT that is bold and 
center-aligned in the shape; apply the shape style of your choice.

	10.	 �Assign the AddReceipt macro to the shape.

	11.	 �Save your work and close Excel.
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	 Apply Your Skills
APPLY YOUR SKILLS: E13-A1

Automate the New Client Form
In this exercise, you will automate the process of copying the new client info from the Universal Corporate 
Events new client form into the client list.

	 1.	 �Start Excel, open E13-A1-Clients from your Excel Chapter 13 folder, and save it as a macro-
enabled workbook named: E13-A1-NewClients

Note the fields for the existing clients in the client list.

	 2.	 �On the Client Form worksheet in the range C4:C7, enter this sample data: ABC Co., Mike, 
555-0000, mike@abc.com

	 3.	 �Record a macro named AddClient with these steps:

•	 Copy the data from the range C4:C8.

•	 Go to the Client List sheet and select cell A4.

•	 Press [Ctrl]+[¥] to go to the bottom row of data.

	 4.	 �Choose Developer→Code→Use Relative References.

This ensures the data is always pasted at the bottom of the existing data, no matter how many clients 
are in the list.

•	 Press [¥] to go down one row to the empty row.

•	 Paste using the Transpose option. (Hint: Home→Clipboard→Paste menu button �.)

•	 Select cell E10, copy the formula for today’s date, and paste the value only into the same cell.

•	 Choose Developer→Code→Use Relative References to turn it off.

•	 Return to the Client Form sheet and delete the range C4:C7.

•	 Stop recording.

	 5.	 In the range C4:C7, enter this sample data: DEF Co., Molly, 555-0001, molly@def.com

	 6.	 �Run the macro to test it.

	 7.	 �Save your work.

APPLY YOUR SKILLS: E13-A2

Automate Sorting the Client List
In this exercise, you will record two new macros for sorting Universal Corporate Events’ client list and then 
create buttons for those macros for easy access.

	 1.	 �Save your file as: E13-A2-NewClients

You want to be able to quickly see your data in two ways: by contact name alphabetically and by date 
added, newest to oldest clients. You will create two macros to automate the sorting.

	 2.	 �On the Client List sheet, record a new macro named SortbyContact that sorts the client list 
by contact name in column B from A to Z.

	 3.	 �Record a second macro named SortbyDate that sorts the list by the date added (column E), 
newest to oldest.


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	 4.	 �Add two buttons to the right of the client list headings using the text Contact and Date and 
sizing/formatting them appropriately; assign the two macros to the buttons.

	 5.	 �Test the Contact button and then the Date button.

You should see the two new sample clients, Mike and Molly, at the top of the list.

	 6.	 �Delete the two rows with the sample data.

	 7.	 �On the Client Form sheet, insert a button with the text Add Client and format it as you did 
the buttons on the Client List sheet, position it appropriately below the form, and then assign 
the AddClient macro to it.

	 8.	 �Save your work and close the file.

APPLY YOUR SKILLS: E13-A3

Count Guest Meal Choices
Universal Corporate Events is hosting one of the Kids for Change fundraising events! In this exercise, you 
will use macros to help you count and identify the number of guests who chose each meal option.

	 1.	 �Open E13-A3-Guests from your Excel Chapter 13 folder and save it as: 
E13-A3-GuestMeals

The worksheet is already formatted to use a COUNTIF function and conditional formatting based on 
the contents of cell J6. There are also three buttons already created. You need to create the macros 
and then assign them to the correct buttons. Each button should automatically adjust the text in cell 
J6 and sort the data in column G to show the guests who chose that meal at the top.

	 2.	 �Start recording a new macro named Beef with these steps:

•	 Select cell J6 and enter: Beef

The COUNTIF function and conditional formatting are updated to reflect the count of meals for beef.

•	 Select cell G5 and perform a custom sort on the Meal Choice column to sort on cell color 
with the yellow color on top.

•	 Click the Chicken button then use [Ctrl] to select the other two buttons, Beef and Veg, and 
apply the Colored Fill – Orange, Accent 2 shape style.

•	 Deselect the shapes, click the Beef button, and change the shape style to Colored Fill - 
Gold, Accent 4.

•	 Stop recording the macro.

	 3.	 �Repeat the previous steps twice, once to create a macro for the Chicken button and once for the 
Vegetarian button, adjusting the steps as necessary for each.

	 4.	 �Assign the appropriate macro to each button and then test them to ensure they work correctly.

	 5.	 �Save your work and close Excel.

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Project Grader  331

	 	Project Grader
If your class is using eLab (labyrinthelab.com), you may upload your completed Project Grader 
assignments for automatic grading. You may complete these projects even if your class doesn’t use 
eLab, though you will not be able to upload your work.

project grader: E13-P1

Using Macros to Apply Consistent Formatting
Taylor Games wants to apply consistent title and logo formatting to all future worksheets. You’ve been 
asked to create a macro that will allow future users to format the top of new worksheets with consistent 
rows, titles, and logos. First, you will create a new macro which contains the formatting you like and can be 
executed using a shortcut key. Then, you will test the macro on a new worksheet.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E13_P1_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E13_P1_Start from your Excel Chapter 13 folder.

	 2.	 �In the Toy-Game Store Sales worksheet, record a macro using these guidelines:

•	 Macro name: TG_Header

•	 Shortcut key: [Ctrl]+[Shift]+[H]

•	 Store the macro in this workbook.

•	 Insert three new sheet rows above row 1.

•	 Reposition the Taylor Games logo to the top-left corner of the worksheet.

•	 In cell C3, apply the Calibri Light font with 18 pt. size.

•	 Apply the Title cell style to cell C3.

•	 Merge and center cells C3–E3.

•	 Stop recording.

	 3.	 �In cell C3, enter the text: Q1 Toy-Game Store Sales

	 4.	 �Switch to the Online-Club Sales worksheet and run the TG_Header macro using the assigned 
shortcut key.

	 5.	 �In cell C3, enter the text: Q1 Online-Club Sales

	 6.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 13 folder as a macro-enabled workbook named 
E13_P1_eSubmission and attach the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 13 folder as a macro-enabled workbook 
named: E13_P1_Submission
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project grader: E13-P2

Sorting and Calculating Using Macros
Classic Cars Club would like to calculate the annual dues for current members and add buttons for sorting. 
In this exercise, you will create macros that will sort the data by state and by term and create a macro 
that will calculate the dues for each member. You will then apply these macros to buttons you create and 
use an assigned shortcut key to quickly enter formulas for calculating dues.

	 1.	 �Download and open your Project Grader starting file.

•	 Using eLab: Download E13_P2_eStart from the Assignments page. You must start with this 
file or your work cannot be automatically graded.

•	 Not using eLab: Open E13_P2_Start from your Excel Chapter 13 folder.

	 2.	 �Record a macro using these guidelines:

•	 Macro name: SortbyTerm

•	 Shortcut key: Do not assign a shortcut key.

•	 Store the macro in this workbook.

•	 Recording: Sort the Membership Dues list by Term (column I) from smallest to largest.

•	 Stop recording.

	 3.	 �Create a macro button using these guidelines:

•	 Insert a rectangle shape (the first shape in the Rectangles category) above the Dues heading 
in column L.

•	 Set the rectangle height to 0.25" and the width to 1.5".

•	 Position the rectangle over cell L2.

•	 Enter the text Sort by Term in the rectangle.

•	 Apply both Center and Middle Align cell alignments to the rectangle text. 

•	 Assign the SortbyTerm macro to the rectangle.

	 4.	 �Record a macro using these guidelines:

•	 Macro name: SortbyState

•	 Shortcut key: Do not assign a shortcut key.

•	 Store the macro in this workbook.

•	 Recording: Sort the Membership Dues list by State (column L) from A to Z.

•	 Stop recording.

	 5.	 �Create a macro button using these guidelines:

•	 Insert a rectangle shape above the Dues heading in column L.

•	 Set the rectangle height to 0.25" and the width to 1.5".

•	 Position the rectangle over cell L4.

•	 Enter the text Sort by State in the rectangle. 

•	 Apply both Center and Middle Align cell alignments to the rectangle text. 

•	 Assign the macro SortbyState to the rectangle.

	 6.	 �Sort the Membership Dues list using the Sort by Term button.
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	 7.	 �In cell L7, record a macro using these guidelines:

•	 Macro name: CalculateDues

•	 Shortcut key: [Ctrl]+[Shift]+[D]

•	 Recording: In cell L7, key the formula =I7*$F$4 and complete the formula using the  
Enter  button on the Formula Bar (do not use the keyboard [Enter] key).

•	 Stop recording.

	 8.	 �In cell L8, test the CalculateDues macro by running it using the shortcut key you assigned to it.

	 9.	 �Save your workbook.

•	 Using eLab: Save it to your Excel Chapter 13 folder as a macro-enabled workbook named 
E13_P2_eSubmission and attach the file to your eLab assignment for grading.

•	 Not using eLab: Save it to your Excel Chapter 13 folder as a macro-enabled workbook 
named: E13_P2_Submission
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

E13-E1	 That’s the Way I See It
You want to create a schedule every week in Excel to organize your work, class, and extracurricular 
activities. Open a new workbook and save it as: E13-E1-Schedule

Start with a title at the top of the sheet, such as Weekly Schedule. In column A, create a series of 
times, starting with 8:00 and counting either by the hour or half hour, depending on how precise you 
want to be. Leave two rows above the times, one for the day of the week and another for the date. 
Insert a series of days of the week starting in column B, Monday to Sunday, below the title but above 
the times. Insert the list of dates for the current week below the days of the week. 

The last step is to automate updating the list of dates for the next week. Record a macro that uses a 
formula to add one day to the last date of the previous week, below Monday. Copy the formula and 
paste the values only back into the same cell, and then fill in the series of dates for the new week. 
Test the macro and then return the dates to the values for the current week. Format the worksheet 
appropriately.

E13-E2	 Be Your Own Boss
Until now, you have been manually copying information for the Blue Jean Landscaping invoices 
into the summary worksheet. Now that you have learned about macros, you want to automate the 
copying process. Open E13-E2-Invoices and save it as: E13-E2-InvoiceSummary

Review the information on the two worksheets to plan your macro, which should insert a new row 
above row 5 on the Summary sheet, copy the information from the Invoice sheet into row 5, copy the 
Total Revenue formula, and copy the correct formatting from row 6 into row 5. 

Test your macro by entering sample information on the Invoice sheet. Finally, create a button with 
suitable text and assign the macro to it.

E13-E3	 Demonstrate Proficiency
Business is booming at Stormy BBQ, and as it grows you want to ensure all of the company’s work-
books contain similar information. Open E13-E3-Sales and save it as: E13-E3-SalesSorting

Record a macro and save it in the Personal Macro Workbook (so it can be used in any Excel file). The 
macro should insert the company name in the left header section and the date in the right header 
section. You also want to be able to quickly sort the current sales worksheet by invoice number, loca-
tion, and sauce type, so record three more macros (with appropriate names) to perform these sorts. 
As an additional challenge, try changing the formatting of the column heading being sorted, as you 
record each macro. (Hint: You will have to reset formatting for all headings first and then adjust the 
formatting for the chosen column by changing font size, font color, or fill as you desire.) Finally, create 
suitable buttons and assign the macros to them.


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ÝÝ Import data from various sources

ÝÝ Consolidate data from multiple sheets into one 
sheet

ÝÝ Create a series of data using different methods

ÝÝ Chart trends and save chart templates

ÝÝ Use additional functions for lookups and logic

14 Data Management for 
Business

EXCEL

I
n this chapter, you will explore 

some of the tools businesses use 

to manage vast amounts of data 

collected on customers, transactions, 

employees, and more. While not going into 

great depth, you will be introduced to the 

terminology, concepts, and tools available 

for analyzing and managing data.
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	 Project: Working with Multiple Data Sources
You have been maintaining the quarter one (Q1) sales data for the five Airspace Travel office 
locations in individual files. Now you want to put it all in one file for better analysis and as a 
model for how data for the rest of the year should be organized. You will also be summarizing 
and analyzing the Q1 sales data to create projections for Q2.

Importing and Exporting Data
Excel is certainly useful, but companies also use many other apps for a variety of business-related 
tasks. This means that data needs to be transferable between apps that are used for different 
purposes; for example, a business might use accounting software to perform the bookkeeping tasks 
and then import the financial data from the accounting software into Excel to create financial 
forecasts.

To effectively work with data from different sources, you must understand common database termi-
nology and functionality. Databases are typically made up of numerous tables, which are made up 
of fields and records. For example, a coffee shop might have a database with tables for inventory, 
customers, and employees. The employees table would have fields for employees’ names, IDs, and 
contact information, and the information for each employee would be their record.

To work across different applications, you should save the data in one of several common formats 
that most programs understand. This allows you to import and export data in and out of various 
programs that are otherwise incompatible. Characters such as commas, spaces, and tabs can 
be used as delimiters, which are any characters used to specify a boundary between fields when 
working with data.

One of the more common file formats for importing and exporting data is CSV (.csv), which stands 
for comma separated values. Data in a CSV file typically comes from a database, where data from 
each field is separated by a comma. Text files (.txt) are also common and usually use either a tab or 
a space to separate values rather than a comma. Excel will normally recognize the character being 
used, but you can also choose which delimiter to use during the import process. You can use CSV files 
to import and export data between Word, Excel, Access, and many more programs, including most 
accounting and database software.

Importing
Importing data creates a query. A query is essentially a request for information from an external 
data source, which could be a CSV or XML file, a website, an Access table, or other various sources 
and databases. The query then creates a connection between the Excel workbook and the data 
source, and you can choose how the data is imported and managed. Sometimes you may want to 
import the data once only, and other times you may want to ensure the data is updated continuously.

After importing data with a query, you can edit the query with the Power Query Editor, enabling you 
to manipulate the data inside the query instead of on the worksheet. Since some sources contain huge 
amounts of raw data, the query can summarize the data and eliminate the need to store the infor-
mation on a worksheet to create summary tables or PivotTables, or to conduct further data analysis.


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Exporting
To export data, you can save any file as a CSV version from the Save as Type option in the Save As 
window. Saving a file as a CSV will only save the active worksheet, because the CSV format does not 
support multiple worksheets. Other formats in which to save an Excel file include PDF, for a read-
only file, and HTML, to create a web page.

Mail Merge with Microsoft Word
You might want to send a custom letter or discount offer via snail mail to a large list of customers. 
To do this, you would perform a mail merge in Microsoft Word. A mail merge has a main document 
with the same message for everyone, and then personalized information for customers using fields 
for each recipient, such as name and address. The list of recipients and fields can be created in a 
program like Excel or Access then exported by saving as a CSV, imported into Word, and used to 
perform the merge. The merge then replaces the fields for each recipient to create a unique docu-
ment for each customer.

ÍÍ File→Save As→Save as Type

ÍÍ Data→Get & Transform Data→Get Data 

 DEVELOP YOUR SKILLS: E14-D1

In this exercise, you will import the February sales data from a separate file into your Q1 workbook. Once 
you have all data for the quarter in one file, you will be able to conduct analysis on it.

	 1.	 �Start Excel, open E14-D1-Q1 from your Excel Chapter 14 folder, and save it as: 
E14-D1-Q1Summary

There is some data in the January sheet already, but notice that all information is missing for February 
and March. The February data is contained in a CSV file.

	 2.	 �Go to the Feb sheet and choose Data→Get & Transform Data→From Text/CSV .

	 3.	 �In the Import Data window, navigate to your Excel Chapter 14 folder, select the E14-D1-Q1 
feb data file, and click Import.

A new window opens, displaying the contents of the CSV file. Note the Delimiter type is Comma.

Rather than using the default settings, which would insert a new sheet in the workbook, you will 
change the load settings now.
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	 4.	 �Near the bottom of the window, click the Load menu button� 
and choose Load To….

In the Import Data window, you can see options for how and where 
the data will be inserted. Options for how to import include as a 
table, PivotTable, and PivotChart, any of which can be placed either 
on an existing or a new sheet. The other option is creating a data connection only and not actually 
pasting any information into the sheet.

	 5.	 �Leave Table selected, choose the option to put the data onto an existing worksheet, which will 
position it in cell A5 (the selected cell), and click OK to insert the data.

The data is inserted as a table, and the Queries & Connections pane opens on the right side of the 
Excel window, showing there is a query created to the E14-D1-Q1 feb data file.

In addition to the Table Tools contextual tab on the Ribbon, you will also see the Query Tools 
contextual tab, which allows you to edit, refresh, and perform other actions with the query.

	 6.	 �Save your work.

Importing Tables from Microsoft Access
Information can be shared between Excel and Access without converting to a CSV, as the programs 
are directly compatible.

External Workbook References
If the data you need exists in another Excel workbook, the data can be referenced between work-
books without importing the data. Creating an external reference creates a link to the data, so if the 
source data changes, the information in the destination workbook will be updated automatically by 

Microsoft Excel 2019 & 365: Level 3 © 2019 Labyrinth Learning – Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Importing and Exporting Data  339

default. You can modify links, open the source, break links, as well as adjust other settings from the 
Edit Links dialog box.

ÍÍ Data→Queries & Connections→Edit Links

DEVELOP YOUR SKILLS: E14-D2

In this exercise, you will import the March data from an Access table. Then you will create a link to the 
data for Vancouver’s January results, which is currently missing.

	 1.	 �Save your file as: E14-D2-Q1Summary

	 2.	 �Go to the Mar sheet and choose Data→Get & Transform Data→Get Data →From 
Database→From Microsoft Access Database.

	 3.	 �In the Import Data window, navigate to your Excel Chapter 14 folder, select E14-D2- 
March data.accdb, and click Import.

A new window opens, displaying the name of the database file, with March Results below.

	 4.	 �Click March Results to preview its contents.
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	 5.	 �Click the Load menu button � and choose Load To….

	 6.	 �In the dialog box, choose to insert the data on an existing worksheet and click OK.

The data for February and March is now complete, and you can see two items in the Queries & 
Connections pane.

The last piece of missing information is the January Vancouver data. This data is in an Excel file and 
can be referenced directly.

	 7.	 �Switch to the Jan sheet and then open E14-D2-Vancouver from your Excel Chapter 14 folder.

	 8.	 �Switch back to E14-D2-Q1Summary and select cell F6.

You can switch between open windows in several ways: [Alt]+[Tab], the taskbar, or View→Window→ 
Switch Windows . Or, to have multiple workbooks visible at the same time, you can use 
View→Window→Arrange All .

	 9.	 �Type = to begin the formula, then switch to E14-D2-Vancouver and, on the Jan sheet, click  
cell B6 and tap [Enter].

The formula in cell F6 on the Jan sheet in E14-D2-Q1Summary is:  
='[E14-D2-Vancouver.xlsx]Jan'!$B$6 

This formula includes a reference to the workbook, sheet, and cell. The result is $44,528.

References to other workbooks are absolute references by default.

	10.	 �In cell F7, repeat the process from step 9 to create a reference to the January results for 
Vancouver All Inclusive sales.

	11.	 �Edit the reference in cell F7 to make it relative. 

Hint: Click the Formula Bar to place the insertion point at the end of the reference and tap [F4] three 
times.

	12.	 �Copy the formula from cell F7 down to cell F11.

	13.	 �Close the E14-D2-Vancouver file.

The formulas and references in column F of the Q1Summary file now include the path to the 
Vancouver file’s storage location on your computer.

The data from the Vancouver file is linked and can be accessed, updated, or changed at any point via 
the Edit Links dialog box.

	14.	 �Save your work.

Tip!

Note!
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Summarizing Data
You can use PivotTables and 3D references to summarize data, but when working with different data 
sources across platforms, you may want to consider other options. In some cases, it may be neces-
sary to import the data first; in other cases, you can use some of Excel’s built-in tools or add-ons to 
get the job done:

ÝÝ Queries

ÝÝ Power Pivot

ÝÝ Data models

ÝÝ Cube functions

These require external data sources and extensive knowledge of the data you are working with. 
While a database is made up of fields and records, a data cube (like a PivotTable) summarizes the 
information across multiple groupings, such as dates, locations, and product categories. With a data 
model, such as a data cube, you can analyze data using cube functions instead of creating Pivot-
Tables. For example, CUBEMEMBER, CUBESET, and CUBEVALUE are some of the functions used to 
pull information out of the data cube.

Data Consolidation
You can also summarize data using the Consolidate command on the Data tab. If your data has 
similar labels across multiple worksheets, such as income or expenses from several different 
company offices, you can combine the data into one range in a few simple steps.

ÍÍ Data→Data Tools→Consolidate 

DEVELOP YOUR SKILLS: E14-D3

In this exercise, you will consolidate the first quarter data from the Jan, Feb, and Mar sheets into the Q1 
Summary sheet.

	 1.	 �Save your file as: E14-D3-Q1Summary

	 2.	 �Go to the Q1 Summary sheet and choose Data→Data Tools→Consolidate .
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	 3.	 �Follow these steps to consolidate the Q1 data:

E

A

B

C D

The desired function, Sum, is already selected.

A	�Click in the Reference box and then go to the Jan sheet and select the range A5:F11.

B	�Check the boxes beside Top Row and Left Column.

C	�Click Add to add the selected range to the All References box.

Selecting additional sheets will automatically use the same cell locations on those sheets.

D	�Click the Feb sheet, click Add, click the Mar sheet, and click Add.

E	�Once all three references are added, click OK.

The consolidated data remains saved as part of the current worksheet and can be reused if desired.

	 4.	 �In cell A15, enter the heading: Q1 Averages

	 5.	 �Select the range A3:G5 and then use Format Painter to copy the formatting and apply it to the 
range A15:G17.

	 6.	 �Select cell A17 and open the Consolidate tool, change the function to Average, and click OK.

	 7.	 �Select the range B18:F23 and change the number format to the Comma Style and remove the 
decimals.

	 8.	 �Save your work.
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Advanced Options for Filling a Data Series
Creating a series of values can be useful for making predictions and business decisions. You can create 
a data series based on existing data, past trends, or anticipated linear or exponential growth rates. 
For example, if a business examines costs and sees they have been increasing at a rate of 2% per 
year, they can create a set of data representing the expected costs for the next five years. Or, if they 
anticipate sales to increase from $10 million to $12 million in five years, they could create a set of 
data for that increase.

The values highlighted in yellow are created using the Fill Series command.

A linear series increases by the same number, while a growth series increases by the same 
percentage.

You can also select existing data and let Excel determine the trend for an increasing series of data. 
Or, start with a beginning value and an ending value, and let Excel fill in the missing values. There are 
many options; it all depends on how you want to use the information you do have to fill in the missing 
pieces of data.

ÝÝ A series can be created in rows or columns.

ÝÝ The series type can be linear, growth, date, or AutoFill.

ÝÝ You can choose the step value (increase amount) for the series or choose to let Excel determine the 
trend.

ÍÍ Home→Editing→Fill 

DEVELOP YOUR SKILLS: E14-D4

In this exercise, you will use information from the first-quarter sales to set sales goals for the second 
quarter.

	 1.	 �Save your file as: E14-D4-Q1Summary

	 2.	 �Go to the Q2 Projections sheet and select the range D6:G6.

After examining the Air Travel sales, you have determined a sales goal of 3% growth for the next three 
months.

	 3.	 �Choose Home→Editing→Fill →Series….
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	 4.	 �In the Series dialog box, choose Growth 
in the Type section, type 1.03 in the Step 
Value box, and click OK.

1.03 is equal to 103%, or an increase of 3%.

The goal for All Inclusive travel sales is to 
increase sales to $615,000 in June, with 
steady growth in April and May to reach 
that goal.

	 5.	 �In cell G7, enter: 615000

	 6.	 �Select the range D7:G7 and choose 
Home→Editing→Fill →Series….

	 7.	 �Leaving all settings as they are, note that 
the step value 11500 is identified and already entered and click OK.

The values 592,000 and 603,500 are entered to fill in the missing months that represent an increase 
of 11,500 per month.

Bus Tours and Excursions are seeing slower growth and unpredictable sales, so you want to be more 
conservative with these estimates.

	 8.	 �Select the range D8:G9 and fill in the two series using a Linear increase and a step value of: 3000

Based on your market research and increasing advertising efforts, you believe Hotels is going to be an 
excellent source of revenue and will continue its rapid growth for the next three months.

	 9.	 �Select the range C10:G10 (February 
and March data) and fill in the series 
using the Growth increase type and 
selecting the Trend option.

The resulting series shows values between 
210,000 and 243,000, increasing by 
roughly 7% per month.

	10.	 �Select the range C11:G11 (February and 
March data) and fill in the series using 
the Linear trend.

	11.	 �Insert the heading Total in cell H5 
and then use AutoSum to insert totals for 
each category in the range H6:H11.

	12.	 �To make the data easier to read, select the ranges B6:G6 and H6:H11 and apply the 
Accounting number format with no decimals; apply the Comma Style number format with no 
decimals to the range B7:G11.

	13.	 �Save your work.
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Additional Charts and Chart Tools
After creating sets of data, you may want to explore ways to visualize the information and make it 
easier to understand. In addition to the simpler column charts, bar charts, line charts and pie charts, 
there are many more charts to choose from.

A histogram chart can be useful for grouping large amounts of data and showing the distribution of 
the data in groups. For example, a list of a thousand or more employee salaries would not produce a 
very useful column chart; however, a histogram could group those salaries into a chart showing how 
many employees earn between $20,000 and $30,000, $30,000 and $40,000, and so on. The histo-
gram groups are called bins. In this example, the bin width is $10,000 (and can be adjusted).

Another useful chart is the Pareto chart, which shows the significance of contributions of parts rela-
tive to the whole. For example, you could identify which sales categories contribute the most to the 
company’s total revenue. The Pareto chart organizes the categories from highest to lowest, with a 
secondary axis and line indicating the increasing overall total.

The Pareto principle (also commonly known as the 80/20 rule) states that 80% of your results come 
from 20% of your efforts!

Tip!
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MORE CHART TYPES

Chart Name Description
Waterfall Displays cumulative effects of positive and negative values, such as cash 

flow

Funnel Displays progressively declining values as part of a process, such as sales 
conversions through the sales process

Sunburst Shows data proportionally across levels, displayed as rings for each level

Box and Whisker Displays variations in a data set when there are many sets of related data, 
such as tracking stock prices

Stock Similar to Box and Whisker but requires data to be organized in a specific 
way

Adding Trendlines
A trendline is an indicator of overall increases or decreases in data and can be useful to help create 
future projections; for example, this is particularly useful for predicting income or expenses for 
budget purposes. You can add trendlines using a number of methods, similar to creating a data 
series. The trendline can be linear or exponential, or it can be created as a linear forecast or moving 
average. When tracking stock prices, for example, a useful chart might include the 50-day or 
200-day moving average.

Saving a Chart as a Template
Once you have created and modified a chart to suit your specific purpose, you may want to save the 
chart as a template. Saving a chart as a template allows you to insert a new chart using the same 
chart settings but with different data. This can be a significant time saver.

DEVELOP YOUR SKILLS: E14-D5

In this exercise, you will create a Pareto chart for all sales categories and then create a column chart and 
add a trendline.

	 1.	 �Save your file as: E14-D5-Q1Summary

	 2.	 �Select the ranges A5:A11 and H5:H11. 

Hint: Use [Ctrl] to select them.
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	 3.	 �Choose Insert→Charts→Insert Statistic Chart→Pareto.

This chart shows the order of the sales categories from largest to smallest, with the line indicating the 
increasing percentage of the whole. The last category, Theme Parks, is the smallest, and adding it to all 
the other categories places the line at 100%.

	 4.	 �Drag the chart to place it below the data and delete the chart title.

	 5.	 �To create the next chart, select the range A5:G7 and insert a 2-D clustered column chart.

	 6.	 �Drag the chart and position it to the right of the data (if the Queries & Connections pane is still 
open, you can close it).

	 7.	 �To add a trendline, choose Chart Tools→Design→Chart Layouts→Add Chart Element→ 
Trendline→Linear.

	 8.	 �In the dialog box, choose All Inclusive and click OK.

	 9.	 �Format the chart with Style 14 and monochromatic colors of your choice, and then add the title: 
Projected Revenue

	10.	 �Right-click inside the chart area and choose Save As Template.

You must point to the chart area, not a chart element like a column, line, or axis, to see the Save As 
Template option. The blank space to the left or right of the chart title is the easiest place to click.

	11.	 �Save the chart template in the default location as: Linear Trend

	12.	 �For the next chart, select the ranges A5:G5 and A8:G9 and choose Insert→Charts→ 
Recommended Charts.

	13.	 �In the Insert Chart dialog box, click the All Charts tab, choose Templates on the left to display 
your saved Linear Trend template, and click OK to insert the chart.

	14.	 �Drag the chart to position it below the Projected Revenue chart and then edit the chart title to: 
Projected Revenue

	15.	 �Save your work.

Tip!
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Additional Lookup and Logical Functions
When you search for data in a large database, the VLOOKUP and HLOOKUP functions are useful, 
but they do have limitations: The data usually has to be sorted, and the functions can only look up 
values from left to right. There may be situations in which alternative methods are required.

Nesting the MATCH function inside the INDEX function allows for more flexibility in performing 
a data lookup. The INDEX function returns a value from a specified cell location, and the MATCH 
function determines what that location should be. For example, imagine you are looking for the first 
name of an employee whose ID number is 3572 (entered in cell G2) from a table where the first 
name is in column A and the ID number is in column D. The VLOOKUP function would not work 
because the ID column is to the right of the name column. However, you could use the formula 
=INDEX(A2:A9,MATCH(G2,D2:D9)).

As you can see in the Formula Bar, the MATCH function in this example looks in the range D2:D9 for 
the cell that matches the value in cell G2 and returns the matching row number; the INDEX function 
then returns the value from the range A2:A9 from that row, in this case Jack (result shown in cell G3).

Other Logical Functions
In many cases you can use the IF function to determine one of two possible outcomes, true or false, 
based on a logical test. For other situations you may need to use additional functions such as AND, 
OR, as well as NOT, either independently or combined with other functions to create even more 
possibilities.

The AND function simply checks whether all arguments are true and returns TRUE if they are and 
FALSE if they are not. The OR function, on the other hand, checks whether any of the arguments are 
true and returns TRUE if at least one is. The NOT function is used to reverse the results of a logical 
function so TRUE becomes FALSE and FALSE becomes TRUE.
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DEVELOP YOUR SKILLS: E14-D6

In this exercise, you will look up the employee name from the list and determine which employees should 
have a salary review.

	 1.	 �Save your file as: E14-D6-Q1Summary

	 2.	 �Go to the Employees sheet.

The Employee Lookup section has been completed for all fields except the Name field. Within this 
section, the formulas that return the position, location, and salary all use the ID#. You will create a 
formula to return the employee’s name.

	 3.	 �Enter this formula into cell K6: =INDEX(A5:A33,MATCH(K5,C5:C33,0))

The formula returns the name Kristen. The INDEX function returns the contents of the cell in the 
range A5:A33, in the position returned by the MATCH function; the MATCH function returns the 
correct position by finding the position of the contents of cell K5 in the range C5:C33 (the 0 argument 
means it must match exactly).

Now you want to determine if all the managers’ salaries are at least $50,000.

	 4.	 �Enter this formula into cell H5: =AND(F5="Manager",G5<50000)

This formula checks if the position is Manager and salary is less than $50,000. If both conditions are 
met, it will return TRUE. The result in cell H5 is FALSE.

	 5.	 �Copy the formula in cell H5 down the column for all employees.

Since TRUE and FALSE are not very useful, the AND function can be nested inside the IF function to 
return one result if the outcome is TRUE and another if FALSE.

	 6.	 �Modify the formula in cell H5 by nesting the AND function as follows: 
 =IF(AND(F5="Manager",G5<50000),"Review"," ")

Since the result of the first function was FALSE, the IF function returns the result for the value if false, 
which is a blank space; therefore, you will see nothing in cell H5 if the formula is entered correctly.

	 7.	 �Copy the new formula down for all employees.

	 8.	 �Use the fill handle to copy cell G4 into cell H4 and then edit the column H heading to: 
Salary Review

	 9.	 �Save the file and close Excel.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center).
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: E14-R1

Import Data and Fill Series
In this exercise, you will import fundraising data for the Kids for Change Events through six months and 
then use the data to project fundraising for the next six months.

	 1.	 �Start Excel, open E14-R1-6monthresults from your Excel Chapter 14 folder, and save it as: 
E14-R1-6MonthProjections

	 2.	 �Choose Data→Get & Transform Data→From Text/CSV .

	 3.	 �In the Import Data window, navigate to your Excel Chapter 14 folder, select E14-R1-
eventsdata, and click Import.

	 4.	 �In the next window, click Load.

The data is loaded into a table on a new sheet.

	 5.	 �Select the range A2:G2 in the table, copy the data, and then switch to the Summary sheet and 
paste the values only into cell A9.

	 6.	 �Hide Sheet1.

Now that you have the data, you are ready to create some estimates. You are projecting that 
individual donations will continue rising similar to the increase between May and June, so you will fill 
in July through December based on that trend.

	 7.	 �Select the range F5:M5, open the Series dialog box, and click OK without changing any of the 
default settings.

The individual donations increase by 110 per month up to 6,260 in December. The corporate and 
door-to-door donations are expected to increase the same from June to December as they did 
between January and June, so you will calculate the December amount first and then fill in the rest.

	 8.	 �In cell M6, enter this formula: =G6-B6+G6

The difference between June and January is added to the amount from June, resulting in expected 
donations of 4,900 in December.

	 9.	 �Copy the formula from cell M6 to cell M7, select the range G6:M7, and fill the two series 
based on the trend. 

Hint: Check the Trend box but don’t change any other settings.

Funds raised by phone and events are expected to increase by an average of 2% per month.

	10.	 �Select the range G8:M9 and fill in the series using a growth step value of: 1.02

	11.	 �Edit the subtitle in cell A2 to: Fundraising Results & Projections

	12.	 �Format the donations from individuals with the Accounting number format and no decimals and 
then format all data for July through December with the light blue fill of your choice.

	13.	 �Save your work.


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REINFORCE YOUR SKILLS: E14-R2

Create Charts
In this exercise, you will create a chart to display the projected donations for the year.

	 1.	 �Save your file as: E14-R2-6MonthProjections

	 2.	 �Enter Total into cell A10 and then apply italic formatting and right-alignment.

	 3.	 �Select the range B10:M10 and use AutoSum to insert totals.

	 4.	 �Select the range A4:M10 and insert a combo chart with the Total data series as a line chart on 
the secondary axis (for all other series use Clustered Column).

	 5.	 �Move the chart to a new sheet named Projected Annual Donations and change the 
chart title to match the sheet name.

	 6.	 �Format the chart using Style 6 and a monochromatic color of your choice.

	 7.	 �Change the color of the line to Standard Red so it stands out from the columns more. 

Hint: Right-click the line and choose the color from the Outline menu.

	 8.	 �Add a linear trendline based on the Total series and format the line color with Standard Yellow.

	 9.	 �Save the chart as a template called: Annual Trend

	10.	 �Save and close the file.

REINFORCE YOUR SKILLS: E14-R3

Insert a Histogram Chart and Functions
In this exercise, you will automate the task of copying information from one worksheet and inserting it into 
another worksheet.

	 1.	 �Open a new, blank workbook and save it as: E14-R3-StudentSummary

	 2.	 �Import the data from the E14-R3-studentdata file, located in your Excel Chapter 14 folder, 
onto the existing sheet.

	 3.	 �Replace the column headings with these: 

•	First

•	Last

•	School

•	January through December

	 4.	 �Rename the sheet: Monthly Hours

	 5.	 �In cell P1, enter the heading Total and then use AutoSum to find the sum of volunteer hours 
for 12 months for each student.

	 6.	 �Select the ranges A1:A24 and P1:P24 and insert a histogram chart.

	 7.	 �Move the chart to a new sheet, renaming the chart title: Volunteer Hours Distribution

	 8.	 �Right-click the horizontal axis and select Format Axis….
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	 9.	 �In the Axis Options settings of the Format Axis pane, choose Bin Width and enter 30 in the box.

The two largest groups are between 360 and 390, and between 450 and 480.

	10.	 �Return to the Monthly Hours sheet and enter the heading Award in cell Q1.

	11.	 �In cell Q2, enter this formula: =OR(COUNTIF(D2:O2,0)=0,SUM(D2:O2)>500)

This formula checks to see if the student either had no months with zero volunteer hours or more 
than 500 total volunteer hours for the year. If either condition is met, the result is TRUE; these are the 
students who will receive an award. 

	12.	 �Save your work and close Excel.
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	 Apply Your Skills
APPLY YOUR SKILLS: E14-A1

Consolidate Expense Data
In this exercise, you will import the expenses for two of the office locations at Universal Corporate Events 
and consolidate the data into one sheet.

	 1.	 �Start Excel, open E14-A1-HO_Expense from your Excel Chapter 14 folder, and save it as: 
E14-A1-ExpenseSummary

The expenses for four quarters are listed for the head office. You need to import the same expenses for 
the other two offices in Seattle and Chicago.

	 2.	 �Import the data from E14-A1-SEAexpdata (a CSV file), located in your Excel Chapter 14 
folder, into a new sheet using the default settings. Rename the sheet: Seattle

	 3.	 �Import the data from E14-A1-CHIexpdata (an Access database file), located in your Excel 
Chapter 14 folder, and load it into a new sheet using the default settings. Rename the sheet: 
Chicago

The next step is to consolidate the data into one sheet.

	 4.	 �Insert a new sheet, move it to the right of the Head Office sheet, and rename it: Summary

	 5.	 �Consolidate the data from the range A1:E11 on all three sheets, using the Sum function and the 
labels in the top row as well as the left column.

	 6.	 �AutoFit the width of column A and apply cell style Accent 6 to the headings in column A and 
row 1. Center the headings in row 1.

	 7.	 �Apply the Accounting style number format with no decimals to the range B2:E2, and Comma 
style with no decimals to the range B3:E11.

	 8.	 �Save your work.

APPLY YOUR SKILLS: E14-A2

Look Up Expenses
In this exercise, you will create a formula that looks up an expense for any specified expense category and 
quarter.

	 1.	 �Save your file as: E14-A2-ExpenseSummary

First you will enter labels and sample data.

	 2.	 �In the range A16:A18, enter these three labels, with the colon after each:

•	Category:

•	Quarter:

•	Amount:

	 3.	 �Use the Format Painter to copy the format from cell A11 and apply it to the range A16:A18.


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	 4.	 �Enter this data into cells B16 and B17:

•	Auto

•	Q1

Cell B18 is where you need to enter the functions to look up the expense amount for the category and 
quarter using the information entered into cells B16 and B17.

	 5.	 �In cell B18, enter a formula that uses the INDEX function with these arguments:

Hint: Use the INDEX(array, row_num, [col_num]) function arguments.

•	 The Array is the data from the range B2:E11.

•	 The Row_Num must use the MATCH function and look up the category from cell B16 with the 
category labels in the range A2:A11; the match type is zero for an exact match.

•	 The Column_Num must use the MATCH function again and look up the quarter from cell B17 
with the headings in the range B1:E1; the match type is zero for an exact match.

When complete, the result in cell B18 should show 86647. The complete function in the Formula Bar 
is: =INDEX(B2:E11,MATCH(B16,A2:A11,0),MATCH(B17,B1:E1,0))

Compare your formula to the one shown and make corrections if necessary.

	 6.	 �Apply bold formatting and the Accounting number format with no decimals to cell B18.

	 7.	 �Edit the category and quarter to look up a new expense amount for: Travel and Q3

The result shows an expense amount of $38,596.

	 8.	 �Save your work and close the file.

APPLY YOUR SKILLS: E14-A3

Forecast Revenue
In this exercise, you will use existing data about sales from the current year to forecast revenue for next 
year. You will also chart the data.

	 1.	 �Open E14-A3-Revenue from your Excel Chapter 14 folder and save it as: 
E14-A3-RevenueForecast

The data for the current year has been consolidated, and the average growth rate from quarter to 
quarter has already been calculated. Your first step is to fill in a data series for each revenue category.

	 2.	 �Begin with the Staff Party category and, one by one, fill in the data series for each category for 
Q1–Q4 in 2020. Use the Q4 revenue in column E and the growth rates in column J.

Hint: Select Growth for the type and convert the Step value to a decimal. For example, Staff Party had 
a growth rate of 1.9%, so the step value is 1.019.

	 3.	 �Insert a column to the left of column F, enter Total in cell F4, and then merge and center the 
range F4:F5.

	 4.	 �Use AutoSum to calculate the 2019 totals in column F.

	 5.	 �Select the ranges A4:A10 and F4:F10 and then insert a Pareto chart to display the totals.

	 6.	 Move the chart directly below the 2019 data and edit the chart title to: 2019

The company wants to grow sales for each category to more than $1 million annually, so the 
marketing budget will increase for any category that is still less than $1 million if it also has a growth 
rate below 3%.
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	 7.	 �In cell L4, enter: Increase Marketing Budget?

	 8.	 �Copy the format from the Growth Rate heading to cell L4 and then widen the column to roughly 
20 so the text is visible on two lines.

	 9.	 �In cell L6, create a formula using the AND function to determine if the total in cell F6 is less 
than $1,000,000 and the growth rate in cell K6 is less than 3%. Copy the formula down the 
column for all categories.

	10.	 �Save your work and close Excel.

	 	Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. Objectives from this chapter that can be accurately graded may be 
included in later chapters, if applicable.
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

E14-E1	 That’s the Way I See It
You are setting goals for yourself once you finish school, including visualizing your financial goals. 
Create a new workbook named: E14-E1-SalaryGoals

Set a goal for your annual salary starting next year; be realistic but also set the bar high! Add the year 
and the salary below that, and to the left a suitable heading. Think of at least one other financial goal, 
such as paying off a debt or saving money. Enter a heading for that goal in the next row and the first entry 
below next year. Add more goals if you choose. Use the fill handle to create the headings for the next 
five years across the top. Fill in a series for each goal for the next five years. Use at least two different Fill 
Series options (e.g., set a goal to increase your salary by 5% each year and reduce your debt from $12,000 
to zero in five years). Finally, create a chart displaying the goals and add a trendline to at least one series. 
Format the chart and worksheet appropriately, including number formatting and adding a chart title.

E14-E2	 Be Your Own Boss
Blue Jean Landscaping gives customers a discount for the hours they work on their own landscaping. 
The customer hours from the last year are saved in two CSV files, and you need to analyze and consoli-
date the information into one file. Create a new workbook named E14-E2-ClientHours and import 
E14-E2-clientdata1 and E14-E2-clientdata2 into new sheets. Rename Sheet1: Summary

Consolidate the data from both sheets into the Summary sheet, noting the labels at top and left. 
Delete the First Name and Category columns; insert a total column and calculate the total yearly 
hours for each client. Use the heading Discount Rate in a new column and use the OR function nested 
in an IF function to determine if the client worked more than 20 hours in at least three months or 
more than 200 hours total. If either condition is true, they get $17 per hour; if not, $15 per hour. (Hint: 
Build the function step by step. Start with =COUNTIF(B2:N2,">20"), determine if that result is greater 
than 2 or if N2>200, then nest that in an IF function.) Last, use the heading Discount in another 
column and multiply the rate by the total number of hours. Format the headings, client names, and 
dollar amounts so the Summary sheet looks professional.

E14-E3	 Demonstrate Proficiency
Stormy BBQ tracks sales for each flavor of BBQ sauce and now, at the end of the year, you’re 
analyzing the data. Open E14-E3-SauceSales and save it as: E14-E3-SauceSalesAnalysis

Create two Pareto charts, one for the month and monthly totals, and another for flavors and annual 
totals, to highlight the months and the flavors with the highest sales. Resize, reposition, and rename 
the charts appropriately. Create a lookup to find the number of bottles and the revenue for the flavor 
specified in cell G4. Begin by entering a flavor in cell G4 and then insert a column to the left of column 
H. In cell H4, use the MATCH function to find the position of the chosen flavor in the columns. (Hint: 
Find an exact match and use 0 for the third argument.) Insert the INDEX function in cells I4 and J4, 
the first to look up the number of bottles and the second to look up the price per bottle, which can be 
multiplied by the result in cell I4 to get revenue. (Hint: The INDEX function is looking for information 
in rows 4 and 18, so select the data for the array, then enter row 1, then use the result of the MATCH in 
cell H4 for the column argument in both.) Once the INDEX functions are entered, hide column H and 
test the formulas by entering a different flavor in cell G4.


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ÝÝ Create hyperlinks for navigation

ÝÝ Insert comments

ÝÝ Add alt text to objects

ÝÝ Inspect your workbook for issues

ÝÝ Create forms

ÝÝ Protect your workbook

15 Workbook Completion

EXCEL

I
n this chapter, you will learn how 

to put the finishing touches on 

a workbook before sharing or 

submitting your work.
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	 Project: Grade Book Submission
Now that you have finished all the grading for the Business class at LearnFast College, you 
are ready to finalize your workbook before ultimately submitting the end-of-semester grades. 
You will create hyperlinks for easy navigation, add alt text to objects to ensure all users have 
access to the content in them, and then inspect and protect the workbook to finish your work.

Inserting Hyperlinks for Navigation
Hyperlinks (or links) are often used to create links to websites or email addresses. Hyperlinks can also 
be used for navigation in Excel. You can create hyperlinks to give the user a quick link to navigate to 
a cell in another workbook, worksheet, or just a cell in another area of the same worksheet. Rather 
than using Find or Go To, which require opening a dialog box and typing or selecting the desired 
destination, the hyperlink is created right on the worksheet, and clicking the link takes you to a 
predetermined location. You can add a hyperlink to any text, shape, or picture.

Choose what to link
 to first. The other options

 change depending on
 the type of link you create.

You can link to a specific cell or to a more general 
area, such as another sheet or a defined name.

You can use the suggested link text 
to show or customize it for your needs.

You can add a ScreenTip to give more 
information about a link. ScreenTip 
text appears when a user hovers 
the mouse pointer over a link.

You always have the option to edit or remove a hyperlink you have created, and it’s as simple as 
right-clicking the cell, shape, or picture that contains the hyperlink and choosing Remove Hyperlink.

ÍÍ Insert→Links→Link 

DEVELOP YOUR SKILLS: E15-D1

In this exercise, you will insert hyperlinks to create shortcuts to each of the worksheets containing the 
different parts of each student’s grades.

	 1.	 �Start Excel, open E15-D1-Grades from your Excel Chapter 15 folder, and save it as: 
E15-D1-GradesFinal


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	 2.	 �Click in the Name box, type D5, and tap [Enter].

Cell D5 contains the heading for the overall quiz grades. You will create a hyperlink to the sheet that 
contains the individual quiz grades.

	 3.	 �Choose Insert→Links→Link .

	 4.	 �Select Place in This Document in the Link To section, select the Quizzes sheet on the right to 
create a link to that sheet, and click OK.

The text to display and cell reference can be left as they are.

Notice that the word Quizzes in cell D5 changes to a blue color with an underline to indicate the text 
is now linked.

	 5.	 �Point to cell D5 and click with the mouse.

This takes you to the Quizzes worksheet.

	 6.	 �Return to the Final Grades worksheet and select cell E5.

You may notice the word Quizzes in cell D5 has changed to a purple color. The default workbook 
theme has different settings for the font color of hyperlinks (blue) and followed hyperlinks (purple).

	 7.	 �Choose Insert→Links→Link .

	 8.	 �Ensure Place in This Document is selected in the Link To section, select the Projects sheet on 
the right to create a link to that sheet, and click OK.

	 9.	 �Repeat this process to create hyperlinks for cells F5 and G5 to the Participation sheet and 
Exam sheet, respectively.

	10.	 �Save the file.

Inserting and Viewing Comments
Before sending a workbook to someone else to view or use, you may wish to include commentary 
about the file’s contents. Comments make it easy to communicate with other people viewing the 
workbook data without cluttering up the normal view of the workbook. Comments can be shown or 
hidden individually or all at once; they can even be printed. If the workbook is large, or if you aren’t 
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sure where the comments are located, you can use the Ribbon commands to navigate to the next (or 
previous) comment.

The image at left shows the options for a cell that does not contain a comment; the image at right shows 
how options change when a cell contains a comment.

The comment feature is a useful tool for collaborating with others working on the same file. You can 
use a comment to ask questions about the worksheet data, provide additional information, or explain 
complex data and formulas.

Comments are indicated by the red triangle in the upper-right 
corner of the cell. When you hover the mouse pointer over the cell, 
the comment and its author’s name appear. You can reposition and 
resize a comment box as desired; when you do, the comment remains 
attached to the cell.

ÍÍ Review→Comments→New Comment 

DEVELOP YOUR SKILLS: E15-D2

In this exercise, you will insert comments for some of the students whose grades require additional work.

	 1.	 �Save your file as: E15-D2-GradesFinal

You need to review Project 1 with Pamela, so you want to insert a comment as a reminder to yourself.

	 2.	 �Select cell E15 and choose Review→Comments→New Comment .

Alternatively, you can insert a comment from the shortcut menu by right-clicking a cell.

	 3.	 �Type Set up a time to review Project 1 with Pamela and then click cell E15.

If you move your mouse pointer off cell E15, you may notice that the comment is no longer visible 
but the red triangle remains in the upper-right corner. Moving back to that cell displays the comment 
again.

	 4.	 �Right-click cell G13 and choose Insert Comment .

	 5.	 �Type Schedule exam retake and then click anywhere on the worksheet.

	 6.	 �Hover the mouse pointer over cell G13 to view the comment and then right-click and choose 
Edit Comment.

	 7.	 �Type for Oct. 1 to add the date to the end of the comment and then click anywhere on the 
worksheet to finish editing the comment.

	 8.	 �Save your work.
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Adding Alternative Text to Objects for Accessibility
To make your workbook accessible to individuals with visual impairments, you can add alternative 
text (or alt text) to the object properties. Alt text provides a descriptive representation of the infor-
mation contained in charts, pictures, and shapes, which is useful for people who may not be able to 
see or understand the object otherwise.

For illustrations—including pictures, shapes, and SmartArt—you can access the Alt Text pane 
through the contextual tabs on the Ribbon; for example, the Drawing Tools Format tab. For other 
objects—like charts—you can access it via the shortcut (or context) menu that appears when you 
right-click the object. In the Alt Text pane, enter a brief description of what the object is or what 
information it contains. Good alt text is clear and concise and conveys the purpose of the visual 
element for someone who can’t see it.

If a picture or shape doesn’t contain any useful or important information, it can be marked as decorative.

ÍÍ Drawing Tools→Format→Accessibility→Alt Text 

ÍÍ Picture Tools→Format→Accessibility→Alt Text 

DEVELOP YOUR SKILLS: E15-D3

In this exercise, you will add alt text to illustrations in your workbook for people with visual impairments.

	 1.	 �Save your file as: E15-D3-GradesFinal

	 2.	 �Go to the Exam sheet and select the small picture in the upper-left corner.

	 3.	 �Choose Picture Tools→Format→Accessibility→Alt Text .

In the Alt Text pane on the right, notice that alt text is already added; a title and a description of the 
picture have been included.

	 4.	 �Return to the Final Grades sheet and click in the chart area of the chart to select it.

Remember that the chart area is the empty space surrounding the title, plot area, and axes. The Alt 
Text pane is blank for this object.

Tip!
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	 5.	 �Click in the Alt Text pane box and type: Final Grade Line Chart

	 6.	 �Tap [Enter] twice and type: The line chart shows the final grades for all 
students, ranging from 74% to 91%

	 7.	 �Close the Alt Text pane and then click cell A7 to deselect the chart.

	 8.	 �Save the file.

Inspecting Your Workbook
When you are finished editing a workbook, you might want others to see or use it. It’s a good idea 
to check certain aspects of a workbook before sharing it. For example, you might want to check for 
personal information, accessibility issues, or compatibility. And if you will share your workbook with 
those in other parts of the world, you may want to set language options as well.

Inspect a Workbook for Hidden Properties or Personal 
Information
The Document Inspector searches your workbook for certain information you may not wish others to 
see. This table gives examples of data that you may include in a search, as well as items that will not 
be searched.

DOCUMENT INSPECTOR

Items Included Items Not Included
•	 Hidden worksheets, rows, columns, and names

•	 Comments, ink annotations, and invisible content

•	 Document properties and personal information

•	 Scenarios in the Scenario Manager

•	 Headers and footers

•	 Data entered in remote areas of a 
worksheet

•	 White text on a white background

•	 Data on a worksheet covered by a 
picture or shape

Before running the Document Inspector, it’s a good idea to save a copy of your workbook. The 
Document Inspector will prompt you to save the file, but it’s wise to have a backup. You also have the 
option of choosing which items to inspect and which to omit from the inspection.

After performing the inspection, the Document Inspector displays the search results. Nothing is 
removed until you choose to do so. Once you choose Remove All, however, the removal may be 
permanent. You cannot choose whether to keep or remove specific items within a category.
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Inspect a Workbook for Accessibility
Similar to how the spelling checker tells you about possible spelling errors, the Accessibility Checker can 
alert you to possible accessibility issues in your workbook. You can then fix the identified issues so someone 
with an impairment can access and understand your content. Issues are classified into two groups:

ÝÝ Errors: Content that will be very difficult for people with disabilities to understand

ÝÝ Warnings: Content that might be difficult for people with disabilities to understand

Examples of issues you might find in your workbook include pictures without alt text, text that is 
similar in color to the background, blank sheets, or merged cells.

Inspect a Workbook for Compatibility
If you’re sending a workbook to someone using an earlier version of Excel, you may want to first 
check to see whether there is content that won’t be available to that person. You can select which 
version to check or just check all versions of Excel since 1997. The summary will indicate what might 
cause issues and how many occurrences there are of each issue.

DEVELOP YOUR SKILLS: E15-D4

In this exercise, you will check the workbook for hidden properties and personal information, accessibility, 
and compatibility.

	 1.	 �Save your file as: E15-D4-GradesFinal

	 2.	 Click the File tab and click the Info tab, if necessary.

The Info tab shows the backstage options for protecting, inspecting, and managing your workbook. There 
is already a list of items below Inspect Workbook that you should be aware of, but you will inspect the 
workbook anyway to find exactly where these items or issues occur. Your screen may differ slightly.
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	 3.	 �Choose Check for Issues→Inspect Document.

	 4.	 �In the Document Inspector window, leave all options checked and click Inspect.

The report shows you any areas that might be of concern, including comments and document 
properties.

	 5.	 �Scroll through the report and notice the results show the file contains comments, document 
properties, one hidden row, and one hidden sheet.

You will ignore the comments and hidden content.

	 6.	 �Scroll back to the top and click Remove All next to Document Properties and Personal 
Information.

	 7.	 �Click Close to finish using the Document Inspector.

Check for Accessibility Issues
	 8.	 �Choose File→Info→Check for Issues→Check Accessibility.

The Accessibility Checker pane opens on the right side of the Excel window and shows a summary of 
errors and warnings for the workbook.

If necessary, click the arrows next to Errors and Warnings to expand them. There is one error for 
missing alt text and a list of warnings for several merged cells throughout the workbook. You will 
ignore the warnings but fix the error now.

	 9.	 �Click the Picture 1 (Quizzes) item below Errors.

This brings you to the Quizzes worksheet and selects the picture.

	10.	 �Right-click the picture and choose Edit Alt Text.

	11.	 �In the Alt Text pane, type: Cartoon picture of a quiz and pencil

The error is removed from the Accessibility Checker pane.

	12.	 �Close the Alt Text and Accessibility Checker panes.
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Check for Compatibility Issues
	13.	 �Choose File→Info→Check for Issues→Check Compatibility.

The Summary shows 13 occurrences that may cause minor loss of fidelity with formatting of certain 
cells for users who open the file with Excel 97–2003.

Because you won’t be sharing the file with anyone using a version of Excel older than 2007, you don’t 
need to make any changes.

	14.	 �Click OK to close the Compatibility Checker.

	15.	 �Save the file.

Configure Editing and Display Languages
When collaborating with people from different areas of the world, you may need to modify the language 
settings in Excel. Excel also has a tool that can translate selected text into another language.

The Language section in Excel Options allows you to manage language settings.
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Creating Forms
Another useful way of entering large amounts of data into Excel is through forms. You can create a 
form in Excel and then print it, complete with blank spaces for filling in data, or the user can fill it out 
directly in Excel. For example, when new clients come into the Raritan Clinic East office, they typically 
need to provide personal information. They could be given a form to fill out themselves on paper or it 
could be entered directly into the program by an assistant.

Data forms make it easier to enter information across a wide table without scrolling horizontally. 
Form tools like list boxes, checkboxes, spin buttons, and toggle buttons make data entry quick and 
easy—and less prone to error.

A data form for entering new client data.

Form controls and ActiveX controls are inserted from the Developer tab, which must be added to 
the Ribbon, and to use a data form you must add the Form command to either the Ribbon or Quick 
Access toolbar.

You can customize the Ribbon and the Quick Access toolbar by right-clicking anywhere on the Ribbon.

You can also protect your forms so users can only enter information in the appropriate places, and 
the rest of the workbook is inaccessible.

DEVELOP YOUR SKILLS: E15-D5

In this exercise, you will insert a form for adding new students into the class and create a list box to identify 
students who passed the course.

	 1.	 Save your file as: E15-D5-GradesFinal

	 2.	 �Right-click the Ribbon and choose Customize Quick Access Toolbar.

Tip!
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	 3.	 �Follow these steps to add the Form button to the Quick Access toolbar:

A

C

B

D

A	�Choose Commands Not in the Ribbon.

B	�Scroll down the list and choose Form….

C	�Click Add.

D	�Click OK to close the Excel Options window.

The Form command is now visible on the Quick Access toolbar.

	 4.	 �Go to the Final Grades sheet and ensure cell A7 is selected.

	 5.	 �Click the Form button on the Quick Access toolbar and then click New and enter this informa-
tion for a new student:

The fields for quizzes and other grades are not available because these columns contain formulas for 
calculating the grades.

	 6.	 �Click Close and see the new student’s info in row 19, with zeros filling in the formulas. (Grades 
can be entered later, and this will update the formulas.)

	 7.	 �The form controls are located on the Developer tab, so if necessary, right-click the Ribbon and 
add the Developer tab to it.

	 8.	 �Enter Pass in cell K7 and Fail in cell K8.

	 9.	 �Choose Developer→Controls→Insert→Combo Box (Form Control).

Note!
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	10.	 �Starting in the top-left corner of cell I7, drag to insert a combo box roughly the same size as the 
cell (ensure the box fits entirely inside the cell).

	11.	 �To modify the combo box options, choose Developer→Controls→Properties.

	12.	 �Click in the Input Range box, select the range K7:K8 in the worksheet, and click OK.

Hint: You may need to drag or collapse the dialog box to see the range K7:K8.

	13.	 �Hide column K and then click the form control and select Pass.

	14.	 �Right-click the form control, copy the object, and paste it into cell I8 (you may need to reposi-
tion it after pasting).

	15.	 �Copy the control again and repeat the pasting for each student.

	16.	 �Once each student has a form control in column I, select cell H19 and set the form control for 
Alex Santiago to Fail. Until his grades are entered, he does not pass the course.

	17.	 �Save your work.

Protecting Workbooks
Another option to consider is how to protect your workbook. When sending a workbook to another 
user, you may want to protect some aspects of the file from being changed, either accidentally or 
intentionally. There are many options to choose from that allow you to limit who has access to the 
file and what they can see and do with the file.

Protect Workbook Structure
To prevent structural changes from being made to the workbook, you can turn on Protect Workbook 
Structure. This prevents users from making such changes as adding, deleting, renaming, moving, or 
copying worksheets.
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There is an optional password to turn off protection. If a 
password is not set, any user can turn off the protection,  
so it’s highly recommended to use a password.

Use a password you will remember (or write it down). If you 
forget the password, there is no way to recover it and regain 
access to the protected elements of the workbook.

Be aware that protecting the workbook structure does not 
include worksheet protection, so the contents of each work-
sheet can still be edited, copied, or deleted. Protecting your data involves a separate process that you 
must perform.

Protect a Worksheet
To protect the data on your worksheets from changes, you can restrict edits using the options in the 
Restrict Access or Protect Worksheet commands. Restrict Access allows you to grant specific users 
access while removing their ability to edit, copy, or print. The simplest way to restrict edits is to use 
the Protect Sheet command. Worksheet protection must be done for each sheet you want to protect, 
one at a time. Again, setting a password is optional but highly recommended.

Additional options for worksheet protection include allowing certain actions, such as selecting 
cells or formatting cells. For example, you may want to allow users to select cells to view formulas 
without the ability to change them or prevent users from selecting cells at all. Or you might want to 
protect the worksheet data but allow format changes to be made.

By default, the options to allow users 
to select locked and unlocked cells are 
checked. To change this option, simply 
remove the check.

Lock Cells and Hide Formulas
Another option is to allow users to edit some but not all cells. For example, you may want to send a 
workbook to someone to enter input data in one range but not allow changes to the formulas you 
have already entered in another range. You can do this by first unlocking the cells you want unlocked 
and then turning on worksheet protection. By default, all cells are locked until you unlock them, 
which is done in the Format Cells dialog box.

Warning!
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To hide the formulas on a worksheet, you can mark cells as hidden. This does not hide the results—
only the formula remains hidden. (If the cell does not contain a formula, hiding it has no effect.)

Configure Formula Calculation Options
Normally you want Excel to recalculate all formulas automatically each time a value changes. This is 
the default Excel setting, but you can change this in Excel Options if necessary.

Manage Workbook Versions
It’s always a good idea to save your work periodically. However, all Office apps, including Excel, 
have AutoRecover features that make it very rare that you would actually lose any unsaved work. 
Even if you close a workbook and accidentally forget to save it, you can still recover the file; the key is 
knowing where to look and how to recover the unsaved workbook versions.

In Excel Options you can view and/or modify where and how often AutoRecover files are saved.
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To recover an unsaved workbook after closing it, reopen Excel and go to Backstage view. On the Info 
tab, choose Manage Workbook. Note that you can also view a previous version of the current file. 
This might be useful if you make changes that cannot be reversed using the Undo command, such as 
deleting a worksheet!

Mark as Final
If no more changes need to be made to a workbook, you can mark the docu-
ment as final. This is perhaps the simplest method of protection because it 
allows no changes at all to the workbook, worksheets, or cells. However, any 
user can turn off this setting. You can tell a file is marked as final when the 
Mark as Final icon is displayed on the status bar.

Encrypt with a Password
To prevent unauthorized access to your workbook, another simple method of protection is to encrypt 
the file with a password. This prevents anyone from accessing the file altogether without a password. 
Remember that passwords are not recoverable, so if you lose or forget the password, the file will be 
inaccessible even to the person who set the password!

ÍÍ File→Info→Protect Workbook | Review→Changes

DEVELOP YOUR SKILLS: E15-D6

In this exercise, you will add protection to the workbook and worksheet, unlock and hide cells, and mark 
the document as final.

	 1.	 �Save your file as: E15-D6-GradesFinal

	 2.	 �On the Final Grades worksheet, choose Review→Changes→Protect Workbook .

	 3.	 �In the Protect Structure and Windows dialog box, type abc123 for the password and click OK.

For the purposes of this book, all DYS exercise passwords are the same, simple, and easy to remember. 
Of course, for true security, you should use different passwords and make them complex.

Because the password you entered is not visible, the next step asks you to confirm what you just 
entered, before the protection is applied, to ensure you did not make a mistake when typing the 
password.

	 4.	 �Type abc123 again and click OK.

The workbook is now protected from any structural changes.

	 5.	 �Right-click the Final Grades worksheet tab.

Notice the options to insert, delete, rename, move, or copy are no longer available.

Tip!
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	 6.	 �From the context menu, choose Protect Sheet .

	 7.	 �In the Protect Sheet dialog box, type abc123 for the password.

	 8.	 �Uncheck the boxes beside Select Locked Cells and Select Unlocked Cells and click OK.

	 9.	 �Type abc123 to confirm the password and click OK.

If you click around on the worksheet, you will not be able to select any cells, meaning you cannot 
make changes to any cells. The exception is that the form controls are still accessible.

	10.	 �Choose Review→Changes→Unprotect Sheet .

	11.	 �Unprotect the worksheet using the password: abc123

Now you will unlock some of the cells so the names and ID numbers can be edited if necessary.

	12.	 �Select the range A7:C19, right-click, and choose Format Cells….

	13.	 �Click the Protection tab, uncheck Locked, and click OK.

Now you will hide the formula that calculates the final grades.

	14.	 �Select the range H7:H19, right-click, and choose Format Cells….

	15.	 �Click the box next to Hidden to add a check so the cells are both Locked and Hidden; click OK.

	16.	 �Choose Review→Changes→Protect Sheet .

	17.	 �Type abc123 for the password.

	18.	 �Check the box beside Select Locked Cells, which automatically adds a check to Select 
Unlocked Cells as well, and click OK.

	19.	 �Retype abc123 and click OK to begin protection.

Notice the Formula Bar is now blank but the results of the formulas still display in the range.

	20.	 �Type the letter a and notice the warning that pops up.
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	21.	 �Click OK to close the warning.

	22.	 �Choose File→Info→Protect Workbook→Mark as Final.

The warning box lets you know the file will be marked as final and saved.

	23.	 �Click OK. Another message box appears to provide more details about the process; click OK to 
close that message.

Notice you can no longer edit any of the workbook content, the Ribbon is collapsed, and Marked as 
Final appears above the Formula Bar.

	24.	 �Close the file without making any other changes.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment in your 
ebook or online (eLab course or Student Resource Center). E
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	 Reinforce Your Skills
REINFORCE YOUR SKILLS: E15-R1

Add Hyperlinks, Comments, and Alt Text
In this exercise, you will review the Kids for Change race summary and add a few finishing touches to the 
sheet, including hyperlinks for navigating to each of the individual result sheets.

	 1.	 �Open E15-R1-RaceSummary from your Excel Chapter 15 folder and save it as: 
E15-R1-RaceSummaryFinal

	 2.	 �Select cell B15 on the Summary sheet and choose Insert→Links→Link .

	 3.	 �Select Place in This Document in the Link To section, select the New York sheet on the right, 
and click OK.

	 4.	 �Repeat this process to insert hyperlinks in cells B16, B17, B18, and B19 to the sheets with the 
results for the corresponding city.

	 5.	 �Select cell C5 and choose Review→Comments→New Comment .

	 6.	 �Type this comment in the comment box: The goal next year is to have 7 cities

	 7.	 �Select the pie chart at the bottom of the Summary sheet.

	 8.	 �Right-click the chart area and choose Edit Alt Text.

	 9.	 �Insert this alt text: Pie chart showing the funds raised for each of  
the 5 cities

	10.	 �Close the Alt Text pane.

	11.	 �Save your work.

REINFORCE YOUR SKILLS: E15-R2

Inspect and Protect
In this exercise, you will inspect the Kids for Change results summary and then add protection to the 
worksheet.

	 1.	 �Save your file as: E15-R2-RaceSummaryFinal

	 2.	 �Choose File→Info→Check for Issues→Inspect Document.

	 3.	 �Click Inspect.

	 4.	 �Click Remove All beside Document Properties and Personal Information and then click Close.

	 5.	 �Choose File→Info→Check for Issues→Check Accessibility.

	 6.	 �Click the Picture 1 (Summary) item listed below Errors.

This brings you to the Summary worksheet and selects the picture.

	 7.	 �Right-click the picture, choose Edit Alt Text, and enter Picture of runners crossing 
a finish line for the alt text.

The error is removed from the Accessibility Checker.

	 8.	 �Without closing the Alt Text pane, copy the alt text and then click the Picture 3 (Summary) 
item in the Accessibility Checker.


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	 9.	 �Paste the copied text into the alt text box for this picture and then close the Alt Text pane and 
the Accessibility Checker.

	10.	 �Select the range C5:C12, right-click, and choose Format Cells….

	11.	 �Click the Protection tab, if necessary; check Hidden to hide the formulas in the cells; and click OK.

	12.	 �Choose Review→Changes→Protect Workbook .

	13.	 �In the Protect Structure and Windows dialog box, type abc123 for the password and click OK.

	14.	 �Type abc123 to confirm the password and click OK.

	15.	 �Save your work and close the file.

REINFORCE YOUR SKILLS: E15-R3

Finalize the Savings Summary
In this exercise, you will make the Kids for Change Savings file final by inserting hyperlinks and comments 
and then inspecting and protecting the file.

	 1.	 �Open the E15-R3-Savings file from your Excel Chapter 15 folder and save it as: 
E15-R3-SavingsFinal

	 2.	 �Choose Home→Editing→Find & Select →Go To.

In the Go To dialog box, you will see the name Company_Amt.

	 3.	 �Select Company_Amt and click OK.

You jump to the cell, which is hidden in row 5. You can see the cell contains the value 30% by looking 
in the Formula Bar.

Although it’s hidden, you can add a comment to the cell.

	 4.	 �Choose Review→Comments→New Comment  and add this comment: Look at  
cost/benefit of increasing this to 40%

	 5.	 �Select cell D16 and choose Insert→Links→Link .

The cell is blank, so you need to add the text to display in the Insert Hyperlink dialog box.

	 6.	 �Choose the Place in This Document link-to option, select the 2017 sheet, and insert the text to 
display as: 2017
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	 7.	 �Insert a hyperlink in cell E16 to the 2018 sheet with the text to display as: 2018

	 8.	 �Choose File→Info→Check for Issues→Check Accessibility.

	 9.	 �Click the Picture 1 (2019) item listed below Errors.

	10.	 �Right-click the money picture beside the title, choose Edit Alt Text, and enter this alt text: 
Picture of American money

The error is removed from the Accessibility Checker. You can ignore the warnings.

	11.	 �Close the Alt Text pane and the Accessibility Checker.

	12.	 �Choose Review→Changes→Protect Workbook .

	13.	 �In the Protect Structure and Windows dialog box, type abc123 for the password and click OK.

	14.	 �Type abc123 again and click OK.

The workbook is now protected from structural changes. However, the information for Q3 and Q4 can 
still be entered on the 2019 sheet.

	15.	 �Save your work and close the file.
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	 Apply Your Skills
APPLY YOUR SKILLS: E15-A1

Insert Hyperlinks and Comments
In this exercise, you will navigate a workbook, which contains Universal Corporate Events price listings, to 
insert comments and hyperlinks.

	 1.	 �Open E15-A1-Prices from your Excel Chapter 15 folder and save it as: 
E15-A1-PricesFinal

	 2.	 �Use Go To to navigate to the TPackage cell and insert this comment: Let’s discuss 
reducing the Package Discount to 5%

	 3.	 �Use Go To again, this time to navigate to the VIPPackage cell, and insert this comment:  
Let’s discuss increasing the VIP Package Discount to 10%

	 4.	 �On the VIP Price List sheet, insert a hyperlink in cell A3 to the Price List sheet and with the 
displayed text: Regular Price List

	 5.	 �Reduce the font size of the hyperlink to 8 points.

	 6.	 �On the Price List sheet, insert a hyperlink in cell A3 with the displayed text VIP Price List 
to the VIP Price List sheet; again, reduce the font size of the hyperlink to 8 points.

	 7.	 �Save your work.

APPLY YOUR SKILLS: E15-A2

Inspect and Mark as Final
In this exercise, you will inspect the workbook for personal information and accessibility and then protect 
the workbook by protecting the worksheets and marking it as final.

	 1.	 �Save your file as: E15-A2-PricesFinal

	 2.	 �Start the Document Inspector and use it to remove all document properties and personal infor-
mation, as well as the hidden worksheets.

	 3.	 �Leave the comments, hidden rows and columns, and any custom XML data if necessary, as they 
are and then close the Document Inspector.

	 4.	 �Open the Accessibility Checker and select 5-Point Star 1 (VIP Price List).

	 5.	 �Open the Alt Text pane and mark this shape as decorative.

	 6.	 �Close the Alt Text pane and the Accessibility Checker.

	 7.	 �Open the Compatibility Checker and review the results; close the Compatibility Checker.

	 8.	 �Protect both sheets and then protect the workbook; use abc123 as the password for all three 
passwords.

	 9.	 �As the last step, mark the workbook as final and close the file.


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APPLY YOUR SKILLS: E15-A3

Finalize the Client Feedback Results
In this exercise, you will finish up the Feedback Results workbook for Universal Corporate Events by adding 
a hyperlink to the bottom of the page, inspecting the document, and then protecting the worksheet.

	 1.	 �Open the E15-A3-Feedback file from your Excel Chapter 15 folder and save it as: 
E15-A3-FeedbackFinal

	 2.	 �Use the Name box to navigate to cell A40.

	 3.	 �Insert a hyperlink with the displayed text Back to Top to cell A4 on the same worksheet; 
edit the ScreenTip to: Cell A4

	 4.	 �Click the hyperlink you just created.

	 5.	 �Sort the Coupon Offered column from largest to smallest.

	 6.	 �Add comments to the two cells that contain the coupon values for $100 and $200; both com-
ments should read: Mailed on 9/23

	 7.	 �Inspect the workbook for accessibility issues then add this alt text to Picture 1: Company 
logo, sun rising over the name Universal Corporate Events

	 8.	 �Protect the sheet from any further changes and set the password to: abc123

	 9.	 �Save your work and close the file.

	 	Project Grader 
This chapter does not include Project Grader exercises. Project Grader content is based on the 
learning objectives for a chapter, and sometimes those learning objectives cannot be accurately 
graded by the system. 
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	 Extend Your Skills
These exercises challenge you to think critically and apply your new skills in a real-world setting. You 
will be evaluated on your ability to follow directions, completeness, creativity, and the use of proper 
grammar and mechanics. Save files to your chapter folder. Submit assignments as directed.

E15-E1	 That’s the Way I See It
Your friend Tobias has asked for your help again. He created an invoice in Excel and wants 
to allow his assistant to enter information in some of the cells while protecting any cells that 
contain formulas to calculate invoice amounts. Open E15-E1-TBPSInvoice and save it as: 
E15-E1-TBPSInvoiceFinal

Insert a comment in cell D4 that reads, You should add the date due here. Select cells A5, A7, and B7 
and unlock them. Then check the workbook for accessibility and add appropriate alt text to the logo. 
Turn on protection for the sheet, using the password: toby123

E15-E2	 Be Your Own Boss
After summarizing the annual revenue for Blue Jean Landscaping, you are now adding hyper-
links for quick navigation to the quarterly results. Open E15-E2-Revenue and save it as: 
E15-E2-RevenueFinal

In cell A3, enter a hyperlink with the text 1st Quarter to the Q1 sheet. In cells B3, C3, and D3, create 
similar hyperlinks to the Q2, Q3, and Q4 sheets. Inspect the file and remove all document properties 
and personal information. Finally, protect the workbook structure and set the password to: blue123

E15-E3	 Demonstrate Proficiency
The sales tracking for Stormy BBQ needs some work, and you also want to protect the completed 
worksheets (March Sales and April Sales) to prevent unwanted changes while allowing users to 
update the May Sales worksheet with new sales information as needed. Open E15-E3-Sales and 
save it as: E15-E3-SalesFinal

Insert a hyperlink in cell A3 of the April Sales worksheet that uses the text Prev and that links to the 
previous month’s sales results on the March Sales sheet. In cell F3, enter a similar hyperlink, with 
the text Next, to the May Sales worksheet. Then add a suitable alt text title and description for the 
picture in cell A1. Inspect the document and remove all comments as well as document properties 
and personal information. Finally, protect the March Sales and April Sales worksheets to prevent any 
changes using the password: stormy123 
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Glossary

calculated column Any column in an Excel table 
that contains a formula; typing new or editing existing 
formulas in any cell automatically updates the entire 
column

comment Note that can be attached to a cell

compatibility Determines whether files can be viewed 
in older versions of the same program

Consolidate (command) Allows you to summarize 
data from different ranges, consolidating the results into 
one output range

CSV Interchangeable file format in which values such as 
text and numbers are separated by commas

data form Type of form that makes it easy to enter 
information in a wide table without having to scroll 
across; can include list boxes, checkboxes, spin buttons, 
and toggle buttons to help ensure data accuracy

delimiter Character such as a comma, space, or tab 
used to specify a boundary between fields in a data 
table

Document Inspector Reviews workbooks for hidden 
data or personal information 

field Group or category of information or data, such as 
last names or phone numbers

form Creates a user-friendly way to enter large 
amounts of data; can be printed and filled in manually 
or completed onscreen

header row First row in a table or external data source 
with text labels that describe the data in the columns 
below

histogram Chart type that shows a distribution of large 
amounts of data into groups (“bins”), such as inventory 
sales of 0–500, 501–1,000, 1,001–1,500, etc.

hyperlink Text or graphic that, when clicked, takes the 
user to another location in the same file, a different file, 
or a web page 

Pareto Chart type that shows the significance of the 
contributions of parts to the overall whole, such as 
determining which variation of a product contributes 
most to the total sales of that product; categories are 
bars in order from highest to lowest and a line arcs to 
show the overall total

PivotChart Provides analysis based on a PivotTable; 
changes made to the PivotTable are instantly transferred 
to the PivotChart, and vice-versa

PivotTable Interactive, adaptable Excel report for 
summarizing large amounts of data in many different 
and useful ways

query Request for information from an external source

record Collection of details (fields) about an individual 
person, place, or thing, such as an employee record or a 
product record

sparkline Miniature charts in worksheet cells that 
illustrate the direction (increasing or decreasing) or data 
trend for a range of either one row or one column 

structured reference Alternative to a standard cell 
reference; indicates the location of a cell or range in a 
table using the table name and column information; 
adjusts automatically when the table is edited

syntax Proper arrangement and order of the names, 
characters, and symbols used to create references, 
formulas, and functions

table Related collection of data about a subject stored 
in records (rows) and fields (columns) that allows for 
easy sorting, filtering, formatting, and calculations using 
structured references
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Index

SYMBOLS
.txt (text files), 336

A
accessibility, 363
alt text, 361–362
AND function, 348
AutoFilter buttons, in PivotCharts, 307

C
calculated fields, in PivotTables, 304–307
cells, locking, 369–370
charts

PivotCharts, 307–308
saving as templates, 346–347
sparklines, 281–282

columns, in tables
calculated, 275
deleting, 274–275
inserting, 274–275

comments, 359–360
compatibility, between versions of Excel 

workbooks, 362–365
Consolidate command, 341–342
CSV (comma separated values) format, 337

D
data forms, 366–368
data series in Excel, filling, 343–344
delimiters, 336
Document Inspector, personal information 

findable using, 362

E
Excel

exporting data from, 337
filling data series, 343–344
importing Access tables into, 338
importing data to, 336
summarizing data in, 341–342
treadlines in, 346
using with Word’s Mail Merge, 337–338

F
filtering, in PivotTables, 301–304
filtering, in tables, 275–276
forms, 366–368
formulas

calculation options, configuring, 370
hiding, 369–370
with structured references, 280–281

functions, logical, 348–349

H
header rows, in tables, 277
hidden properties, 362
histogram charts, 345
hyperlinks, 358–359

I
IF function, 348
INDEX function, 348

L
language settings, 365
locking cells, 369–370
logical functions, 348–349

M
macros, 319–326

assigning, 324–326
custom buttons for, 325–326
recording, 321–324
running, 324–326
saving workbooks containing, 323–324
security and, 320–321
sharing, 323
storing, 322–323

MATCH function, 348

N
NOT function, 348

O
OR function, 348

P
Pareto charts, 345
passwords, 371–373
personal information, 362
PivotCharts, 307–308
PivotTables, 292–307

analysis using, 296–301
arranging source data, 293
calculated fields in, 304–307
duplicates in, removing, 293
fields, adding, 294–296
filtering, 301–304
formatting, 297–298
overview, 292
referencing data in, 305–307
refreshing data in, 305
slicers in, 302–304
value field settings, 298–301

Power Query Editor, 336

Q
queries, 336

R
recording macros, 321–324
rows, in tables

deleting, 274–275
inserting, 274–275

S
security, configuring formula calculation 

options, 370
encrypting with password, 371–373
hiding formulas, 369–370
locking cells, 369–370
macros and, 320–321
marking as final, 371
versions of workbooks, managing, 

370–371
workbook structure, 368–369

slicers in, in PivotTables, 302–304
sorting, in tables, 275–276
sparklines, 281–282
structured references, 279–281
style options, in tables, 277–279
summarizing data, 341–342
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T
tables, 273–282

columns in, 274–275
filtering info in, 275–276
header rows in, 277
names of, 277
rows in, 274–275
sorting info in, 275–276
style options, 277–279

templates
saving charts as, 346–347

text files (.txt), 336
Total Row option, 278–279
treadlines, 346

V
Value Field Settings dialog box,  

in PivotTables, 305

W
workbooks

alt text in, 361–362
comments in, 359–360
hyperlinks in, inserting, 358–359
inspecting, 362
protecting, 368–373
recovering, 371
referencing data between, 338–340
with macros, saving, 323–324
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