
Database reports summarize the data 
contained in tables or displayed in 
query results and enable you to 

provide information in a page layout suitable 
for printing. Although forms and reports serve 
two different purposes within the context of a 
relational database, the techniques used to 
customize them are similar. By now, you have 
most likely created reports using both the 
Report Wizard and Design View and have 
customized elements of a report. In this 
lesson, you will import reports from other 
databases and use additional features to 
create custom reports.

L E S S O N  O U T L I N E
Importing a Report into a Database
Adding a Subreport to a Main Report
Creating a Report from a Subreport
Numbering Items in a Report
Creating Calculated Controls on a Subreport
Setting Page Breaks and Customizing Controls
Analyzing Report Performance
Concepts Review
Reinforce Your Skills

Apply Your Skills

Extend Your Skills

Transfer Your Skills

L E A R N I N G  O B J E C T I V E S
After studying this lesson, you will be able to:

■■ Import a report into a database

■■ Add a subreport to a main report

■■ Create a report from a subreport 

■■ Create calculated controls on a subreport

■■ Set page breaks, customize controls, and analyze 
report performance

9Customizing Reports
A C C E S S  2 0 1 3
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C A S E  S T U D Y

Billing Customers
The company manager of Winchester Web Design, a small web page design 
company, wants you to improve its invoice report for customer billing. After 
reviewing invoices from several companies, the company manager has 
sketched out a design for the new invoice report layout. Your job is to create a 
sample of the new invoice report for company administrators. 
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Importing a Report into a Database
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0901

Access offers a variety of ways to create reports. In addition to using the Report Wizard or 
starting from scratch in Design View, you can also import reports from another database. 
Because most companies require some type of invoice to send with customer orders, locating a 
sample invoice report to import is not difficult.

Sometimes you have the report you want, but during design it may have become corrupted, 
either due to inadvertent changes to the report itself or changes to an underlying query. That’s 
when backups are invaluable. If a report becomes corrupted, you can restore it by importing 
database objects from a backup copy of a database. The record source should already match and 
there should be no need to edit properties and field names.

Identifying Report Record Sources
Reports that you import retain two connections to their original database: the source database 
table or query name, shown in the Record Source property, and field names, which appear in 
report text boxes. As a result, when you import a report from another database, you often must 
establish new control sources to the destination database. You can accomplish this by:

■■ Editing the imported report’s Record Source property to link to a table or query in the 
destination database. 

■■ Editing, if necessary, the field names in the imported report’s text boxes to match those 
shown in the new record source table or query.

Using Smart Tags
Many times, when Access identifies a conflict between an available data or control source and 
the one currently identified in the Record Source control, you will see smart tags attached to the 
fields affected. Smart tags indicate actions that may be taken if certain conditions are met or if a 
control has a problem. Clicking a smart tag will display a list of possible actions for that control, 
such as providing easy access to the correct Control Source property or Report Record Source 
property.

Smart tags enable you to 
change the source for the 
data if appropriate. Small green triangles 

identify the controls for 
which Access can find 
no data.

Selecting a control 
displays handles.
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DEVELOP YOUR SKILLS AC09-D01

Import a Report and Edit the Record Source
In this exercise, you will import a report from a backup copy of a database. You will rename the report and 
view data from an existing table using the imported report.

1.	 Open AC09-D01-WinWebDesign from your AC2013 Lesson 09 folder and save it as 
AC09-D01-WinWebDesign-[FirstInitialLastName].

Replace the bracketed text with your first initial and last name. For example, if your name is Bethany 
Smith, your filename would look like this: AC09-D01-WinWebDesign-BSmith.

2.	 Choose External Data→Import & Link→ .

The Get External Data dialog box opens.

3.	 Click Browse, navigate to the AC2013 Lesson 09 folder, and double-click AC09-D01-
WinWebDesign–Backup.

This database is a backup copy of the WinWebDesign database.

4.	 Choose Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database and click OK. 

Access opens the Import Objects dialog box and displays object names contained in the backup 
database.

5.	 Follow these steps to select the report to import:

A	Click the Reports tab.

B	Choose Customer 
Invoices.

C	Click OK.

6.	 Leave the Save Import Steps checkbox unchecked and click Close in the Get External Data 
dialog box.

Rename and View the Report

7.	 From the Navigation Pane, right-click the imported Customer Invoices report and choose 
Rename.

8.	 Type Customer Invoice Report and tap [Enter].
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9.	 Right-click Customer Invoice Report and choose Print Preview.

The empty area below the customer information is where you will insert the subform/subreport that 
includes the invoice detail lines.

10.	 Navigate through the pages.

11.	 Click  to close Print Preview.

Unless directed otherwise, keep Access and any databases or database objects being used open at the end 
of each exercise.

Adding a Subreport to a Main Report
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0902

Subreports display subsets of data in reports and are derived from related 
database tables, similar to subforms on forms. However, a subreport can 
display table data by using a table, query, form, or another report as its source 
object. Because forms are frequently created before reports, and they may 
already display the desired data from multiple tables, using a subform to 
create a subreport streamlines report design and layout.

FROM THE RIBBON

Arrange→Table→ 
Remove Layout to 
remove grouping
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Creating a subreport from a quick form may present challenges. When you create a quick form 
from the Create tab on the Ribbon, Access ties—or groups—all controls in the Detail section as 
one object. Because of these ties, if you resize one text box in the Detail section, all text boxes are 
resized. If you want to modify or delete individual controls, you must first remove the ties, or 
grouping.

The Remove Layout 
button removes 
control ties so you 
can edit individual 
controls.

The selection button 
selects all tied 
subreport controls.

Examining Database Objects
Invoices normally display a list of all the items ordered or services performed, in addition to the 
customer name and address. There are several tables in the WinWebDesign database that 
contain the data required for the complete invoice—the Customers table, the Products table, 
and the Invoices and InvoiceDetails tables. Fields from all these tables appear in the Winchester 
Web Design Invoices Form—and the detail fields you want to add to the report appear in the 
InvoiceDetails subform. So if you use the existing InvoiceDetails subform for the subreport, 
creating the invoice report is easier and more efficient.
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The InvoiceDetails subform 
contains the data you want 
to include on the Customer 
Invoice Report.

Adding a Subreport
The procedures used to add a subreport to a report are basically the same as those used to add a 
subform to a form. You can create the subreport using the Report Wizard or add an unbound 
subreport control to the report. Then you identify the database object containing the fields you 
want to display as a subreport.

Access might warn you that the table, query, or form specified in the report does not exist in this 
database. This is more likely to occur with imported objects, but might be due to a typing error. 
You can fix this by modifying the Record Source property, importing the missing object, or 
correcting the typo.

Error message warns that an object needed to run a report or form might be missing from the database.

To change the Record Source, click the smart tag list arrow and choose Edit the Report’s Record 
Source Property. 
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DEVELOP YOUR SKILLS AC09-D02

Add a Subreport to a Report
In this exercise, you will add a subreport to the Customer Invoice Report. You will use the InvoiceDetails 
Subform as the source for the subreport.

1.	 Display the Customer Invoice Report in Design View.

2.	 Choose Design→Controls→Subform/Subreport .

3.	 Click and draw a subreport in the Detail section just below the ZIP label.

Access opens the SubReport Wizard.

TIP

	 If the wizard doesn’t launch, the Control Wizard was likely toggled off. Choose Design→ 
Controls and choose Use Control Wizards from the drop-down menu to toggle it back on.

4.	 Follow these steps to create the subreport control:

A	Choose Use an 
Existing 
Report or 
Form.

B	Click the 
InvoiceDetails 
Subform.

C	Click Next.

5.	 Click Next to accept the default links, keep the default name InvoiceDetails Subform, and 
click Finish.

6.	 Click the Property Sheet Data tab and ensure that Form.InvoiceDetails Subform is in 
the Source Object property box.
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7.	 Click the Property Sheet Format tab and enter these property values:

Property Value

Width 5.6”

Height 1.5”

Top 2.9”

Left .5”

Border Color Blue, Accent 5, Darker 50%

8.	 Select the subform label (InvoiceDetails Subform) and enter these property values:

Property Value

Caption Invoice Details:

Width 1.2”

Height .25

Top 2.5

Left .5

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 5, Darker 50%

9.	 Click the Report selector button in the top-left corner of the report where the horizontal 
and vertical rulers meet to select the report.

10.	 Type 7.9” for the Width property.

11.	 Switch to Print Preview.
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12.	 Click the navigation buttons at the bottom of the window to display several report invoices.

13.	 Click .

14.	 Save  the Customer Invoice Report.

Creating a Report from a Subreport
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0903

Using a subform as the record source for a subreport is convenient because the subform already 
includes all needed data. However, when a subreport uses a form as the record source, any 
changes made to the subreport layout are reflected in the source form. If you don’t want the 
source form to be changed, you can save the subreport as a separate report in the database, 
change the main report’s Record Source property to the new report object, and then edit the 
subreport.

Access allows you to save an existing form as a new form, and an existing report as a new report. 
When a subform is used as the record source for a subreport, you can open the subreport in a 
separate window and save it as a separate report.

QUICK REFERENCE  SAVING A SUBREPORT AS A REPORT 

Task Procedure

Open a subreport in 
a separate window 

■■ Right-click the subreport on the report in Design View.

■■ Choose Subreport in New Window.

Save a subreport as 
a new report

■■ Open the subreport in a new window.

■■ Choose File→Save Object As.

■■ Type the name of the new report, select Report from the Save Object As list, and 
click OK.
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DEVELOP YOUR SKILLS AC09-D03

Create a New Report Using a Subreport
In this exercise, you will create and save a new report based on the subreport from the Customer Invoice 
Report and then edit the source object property in the Winchester Web Design Customer Invoice report to 
display the new report.

1.	 Display the Customer Invoice Report in Design View.

2.	 Right-click the subreport control and choose Subreport in New Window.

If you don’t see the Subreport in New Window command, click an area of the main report and then 
right-click the subreport control again, or choose Design→Tools→Subreport in New Window. 

Access opens the the InvoiceDetails Subform in a separate window.

3.	 Choose File→Save As→Save Object As→ . 

4.	 Follow these steps to save the form as a report:

A	Type WWD Customer Invoices 
Subreport.

B	Choose Report from the menu.

C	Click OK.

5.	 Close the InvoiceDetails Subform; display the WWD Customer Invoices Subreport in 
Design View.
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6.	 Click the All tab on the Property Sheet and type Customer Invoices Subreport as 
the caption.

7.	 Choose Design→Header/Footer→Title.

Access places a title and empty placeholder controls in the Report Header.

8.	 Type Winchester Web Design Invoice Details in the Title control and tap [Enter].

9.	 For the new Title control, enter these property values:

Property Value

Width 3”

Height .25”

Left 1”

Top 0”

Font Name Arial

Font Size 12

Text Align Center

10.	 Delete any empty placeholder controls in the Report Header section that were automatically 
inserted with the title, such as placeholders for a logo or date.

11.	 Click the Report Header section bar in the subreport and type .3” for the Height.

Because the empty placeholders inserted with the Title control extend the width of the report, you will 
now reset the width of the subreport back to 5.6”

12.	 Click the Report selector button and type 5.6” for the Width property.

13.	 Save and close the WWD Customer Invoices Subreport.

14.	 Return to the Customer Invoice Report in Design View.

15.	 Display the Property Sheet and then display the Data tab.

16.	 Select the subreport, click in the Source Object property line, and choose  
Report.WWD Customer Invoices Subreport from the drop-down menu.

17.	 Click the Detail section bar in the subreport.

18.	 Choose Blue, Accent 5, Lighter 80% for the Back Color property.

19.	 Choose Blue Accent 5, Lighter 60% for the Alternate Back Color.
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20.	 Switch to Print Preview and review the report and subreport.

The new subreport will appear on the main report. Notice that because the subreport is not in 
Datasheet View, it appears differently on the page and takes up far more vertical space.

21.	 Navigate through the report.

Because the new subreport is much longer than the subform, it throws off the page alignment. To fix 
this, you can set the source of the subform/subreport back to the InvoiceDetails Subform.

22.	 Close Print Preview; then save and close the Customer Invoice Report.

Numbering Items in a Report
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0904

As the number of records in a table grows, the length and number of records in a report or 
subreport also grows. You can number the records in a report to help track items listed. If a 
report is grouped, you can set the count to restart numbering at the beginning of each group.

Setting Properties to Number Items
By adding a text box to the Detail section and setting its Control Source property to =1, you can 
automatically number items in a report. In addition, you can set the Running Sum property to 
identify the portion of a report for which you want to count items. For example, suppose you 
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have an invoice report that groups services by invoice number. You can set the Running Sum 
property to count the items in each group and then start counting again with the next group.

Items are numbered 
sequentially within 
each report group.

Numbering Subreports Separately
Access does not permit numbering items in a subreport control on a main report. However, 
because you saved the subreport as a separate report, you can add the numbering controls 
directly to the subreport by opening it in a separate window. Any edits you make when it is open 
as a separate item are reflected in the main report the next time you open it.

QUICK REFERENCE  NUMBERING REPORT ITEMS 

Task Procedure

Add a text box 
control to number 
report items

■■ Display the report or subreport in Design View.

■■ Choose Design→Controls→Text Box .

■■ Click the position in the Detail section on the report or subreport to place the text 
box control.

■■ On the Property Sheet Data tab, set the Control Source to =1 and the Running 
Sum to Over Group.
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DEVELOP YOUR SKILLS AC09-D04

Number Items in a Report and Subreport
In this exercise, you will reposition controls in the Page Header of the WWD Customer Invoices Subreport 
and then add a text box control to count the number of line items.

1.	 Display the WWD Customer Invoices Subreport in Design View.

2.	 If the subreport does not show the Page Header and Page Footer section bars, right-click the 
Detail section bar and choose Page Header/Footer.

3.	 Click the Page Header section bar and change the Height to .3” on the Property Sheet.

4.	 Select the ProdID label in the Detail section and use [Ctrl]+[X] to cut the control.

5.	 Click in the Page Header section and use [Ctrl]+[V] to paste the label.

6.	 With the ProdID label still selected, type.5” for the Width and.5” for the Left property.

7.	 Add the following labels to the Page Header section; use the Width and Left property 
values shown. 

Label Width Property Left Property

Description 2” 1.25”

Price .75” 3.5”

Qty .3” 4.5”

LineTotal .75” 5”

Move and Resize Report Text Box Controls

8.	 Set these property values for the text boxes in the Detail section.

Text Box Control Width Top Left

ProdID .5” .1” .5”

ProdDescription 2” .1” 1.25”

Price .75” .1” 3.5”

Qty .3” .1” 4.5”

LineTotal .75” .1” 5”

9.	 Click the Detail section bar and type .5” for the Height.

10.	 Click the Selection Type menu button at the top of the Property Sheet and choose Report.

11.	 Type 6” for the Width property.
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12.	 Switch to Report View.

There is room for a small field to the left of the Product ID field.

Add and Format a Text Box

13.	 Switch to Design View and choose Design→Controls→Text Box .

14.	 Follow these steps to add the text box control to the Detail section:

A	Click to the left of the ProdID text 
box. The associated label appears 
behind the Unbound text box 
control.

B	Click the associated label 
control and tap [Delete].

15.	 Click the new text box control and set these property values:

Property Value

Name txtCount

Width .3”

Top .1”

Left .1”
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Set Control Properties to Sum

16.	 Follow these steps to set the data properties for the control:

A	Click the Data tab.

B	Type =1 in the Control 
Source property.

C	Set the Running Sum 
property to Over Group.

17.	 Switch to Report View and scroll to the end of the report.

Access counts each line item in the report—from 1 to 124.

18.	 Save and close the WWD Customer Invoices Subreport.

19.	 Display the Customer Invoice Report in Design View.

20.	 Choose the InvoiceDetails Subform from the Selection Type list at the top of the 
Property Sheet.

21.	 Type 6” for the Width property.

22.	 Switch to Print Preview and navigate through the report. Then display page 2.
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23.	 Close Print Preview.

24.	 Save and close the Customer Invoice Report.

Creating Calculated Controls on a 
Subreport

Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0905

Reports summarize data contained in tables and queries to present useful, organized 
information. This typically means that calculated fields must be added to a report for subtotals, 
grand totals, and averages.

Positioning Calculated Controls
Calculated controls are built on reports by using the Control Source property of an unbound text 
box control to which you add the formula for the calculation. The placement of the calculated 
control determines how Access performs the calculation.

Calculated control in a Detail section 
performs a calculation for each detail line.

Calculated control in a Group Footer 
calculates the total for the group.

Calculated control in a Page Footer 
calculates the total for the page.

Calculated control in a Report Footer 
calculates the total for the entire report.

DEVELOP YOUR SKILLS AC09-D05

Create a Calculated Control
In this exercise, you will add a calculated control to the Report Footer section of the WWD Customer 
Invoices Subreport. 

1.	 Display the WWD Customer Invoices Subreport in Design View.

2.	 Click the Report Footer section bar and type .3” for the Height property.

3.	 Choose Design→Controls→Text Box and draw a text box in the Report Footer section 
of the subreport under the Line Total text box.

4.	 Type CustomerTotal for the Name property.

5.	 Type =Sum([Price]*[Qty])for the Control Source property.
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6.	 Enter the property values shown to format the CustomerTotal calculated field:

7.	 Select the associated label for the CustomerTotal text box and enter these property values:

Property Value

Caption Invoice Total

Width 1.2”

Height .25”

Top 0”

Left 3”

Fore Color Text 1

8.	 Save and close the WWD Customer Invoices Subreport.

9.	 Display the Customer Invoice Report in Print Preview and navigate through the report. 
Then display page 2.

10.	 Save the Customer Invoice Report.
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Growing a Subreport
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0906

When the number of records or amount of data displayed in a subreport varies, you can set the 
Can Grow property setting to allow the subreport space to expand so more data displays 
vertically. You can also change the orientation of the print layout to allow more horizontal space 
on each report page. 

QUICK REFERENCE SETTING MARGINS, ORIENTATION, AND CAN GROW/CAN SHRINK PROPERTIES

Task Procedure

Set report margins ■■ From Design/Layout View: Choose Page Layout→Page Size→Margins.

■■ From Print Preview: Choose Print Preview→Page Size→Margins.

Set orientation ■■ From Design/Layout View: Choose Page Layout→Page Layout and then choose 
Portrait or Landscape.

■■ From Print Preview: Choose Print Preview→Page Layout and then choose Portrait 
or Landscape.

Set Can Grow 
property

■■ Click the subreport control.

■■ Display the Property Sheet, if necessary, and click the Format tab.

■■ Set the Can Grow property to Yes.

Set Can Shrink 
property

■■ Click the subreport control.

■■ Display the Property Sheet and click the Format tab.

■■ Set the Can Shrink property to Yes.

DEVELOP YOUR SKILLS AC09-D06

Set the Report Layout and Grow/Shrink Properties
In this exercise, you will adjust the margins of the Customer Invoice Report and set the Can Grow and Can 
Shrink properties to adjust the size of the subreport to fit the contents, which may vary in size.

1.	 Display the Customer Invoice Report in Design View.

2.	 Choose Page Setup→Page Size→Margins and choose Narrow.

3.	 Select the InvoiceDetails Subreport and click the Format tab on the Property Sheet to 
set the following properties:

■■ Set the Can Grow property to Yes, if necessary.

■■ Set the Can Shrink property to Yes.

4.	 Save the Customer Invoice Report.

5.	 Switch to Print Preview and navigate through the report.

The subreport grows and shrinks to best fit the contents.
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6.	 Display page 2.

7.	 Close Print Preview.

Setting Page Breaks and Customizing 
Controls

Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0907

As you view the Winchester Web Design Customer Invoice Report in Report View, you may 
notice that the number of invoice records displayed on each screen varies depending on the 
number of items ordered. To ensure that each customer invoice starts on a new page, you can 
add a page break control. By default, when you view a report in Print Preview, data for each 
customer/record automatically appear on a separate page; however, multiple records appear on 
the same page when the report is displayed in Report View. 

To add a title or general company information to an invoice, place title controls in the Page 
Header section rather than the Report Header, which only prints on the first page.

Positioning the Page Break Control
To ensure that each invoice record prints on a separate sheet of paper, you can set page breaks. 
When you set page breaks, add the break at the end of the Detail section so Access knows to 
start a new page before printing the next page header.

QUICK REFERENCE  ADDING PAGE BREAK CONTROLS

Task Procedure

Add a page break 
control

■■ Drag the Page Footer section bar down to provide space at the bottom of the 
Detail section.

■■ Click the bottom of the Detail section where you want the break.

■■ Choose Design→Controls→Insert Page Break .
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DEVELOP YOUR SKILLS AC09-D07

Add Logo, Title, Date, and Page Break Controls 
In this exercise, you will modify the Winchester Web Design Customer Invoice Report. You will add a title, 
insert the company logo and current date, and set page breaks to print each invoice on a separate page.

1.	 Display the Customer Invoice Report in Design View.

2.	 Select the Customer Invoice title control in the Page Header section.

3.	 Follow these steps to edit the title:

A	Click the title control to 
position the insertion point 
just before the existing text.

B	Type Winchester Web Design in 
front of Customer and press [Shift]+[Enter].

4.	 Tap [Enter]; type 4” for the Width and 2” for the Left property.

Add a Logo to the Page Header

5.	 Click the Page Header section bar, choose Design→Controls→ , navigate to the 
AC2013 Lesson 09 folder, and choose WWD-Logo.bmp.

If you choose Design→Header/Footer→Logo instead, Access inserts the image in the Report Header 
section and placeholders for title, date, and time controls. The empty placeholders are normally deleted.

6.	 Draw the logo on the far left side of the Page Header section.

7.	 Type .9” for the Width and Height properties. Type .05” for the Top property and .2” 
for the Left property.

Add a Date Control to the Report

8.	 Choose Design→Header/Footer→  and choose the MM/DD/YYYY Date 
format; do not include the time.

Access places the new date control in the Report Header section.

9.	 Select the date control and press [Ctrl]+[X] to cut the control from the Report Header.

10.	 Click the Page Header section bar and press [Ctrl]+[V] to paste the control into the Page 
Header.
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11.	 Enter these property values for the Date control:

■■ 2” for the Width property ■■ .75” for the Top property
■■ .2” for the Height property ■■ 3” for the Left property

12.	 Choose Center for the Text Align property.

13.	 Right-click the Report Header section bar and choose Report Header/Footer .Click 
Yes to delete all controls in the section.

14.	 Switch to Print Preview.

If every other page is blank, the report might be too wide or there might be a control placed beyond 
the margin. Remedy this by shortening or moving the errant control to the left and dragging the right 
edge of the report to the left.

Add a Page Break Control

15.	 Switch to Design View and scroll down to the bottom of the Detail section.

16.	 Follow these steps to position a page break:

A	Choose Design→ 
Controls→Insert 
Page Break.

B	Place the Page Break in the Detail section just above the Page Footer 
section bar.

17.	 Switch to Print Preview and page through the report.

There are times when adding a page break to a report may cause an extra page to print for each 
record. So if the page break isn’t needed, do not add it.

18.	 Save and close the Customer Invoice Report.
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Analyzing Report Performance
Video Library:	 http://labyrinthelab.com/videos  Video Number: AC13-V0908

Access tracks each database object and identifies how tables, queries, forms, and reports are 
related. Any changes you make by importing a report, editing the report structure, creating a 
subreport based on a form, and then saving the form as a report may have an impact on the 
performance of the database. 

What the Performance Analyzer Analyzes
To ensure that all objects in a database work together in an efficient manner, you can run the 
Performance Analyzer. The Performance Analyzer:

■■ Analyzes database performance by reviewing each database object, identifying potential 
errors, and recommending modifications to maintain optimum efficiency in the database. 

■■ Compares relationships between database tables and identifies data redundancy. 

■■ Identifies items such as mismatched field definitions and displays a list of these instances so 
that you can consider modifications.

■■ Locates errors that could result in inaccurate data analysis and any disconnects between 
forms/subforms and reports/subreports.

■■ Identifies fields and property settings that can slow down the running of queries and the 
generation of reports.

A sample Performance Analyzer report.

You can use the Performance Analyzer to analyze all objects in a database or selected objects. 
You can also instruct the analyzer to make corrections for you. 
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DEVELOP YOUR SKILLS AC09-D08

Analyze Report Performance
In this exercise, you will run the Performance Analyzer to analyze report performance in the Winchester 
Web Design database.

1.	 Choose Database Tools→Analyze→  to start the Performance 
Analyzer.

2.	 Follow these steps to run the Performance Analyzer on all database reports:

B	Click Select All to 
mark every checkbox.

A	Click the Reports tab.

C	Click OK.

Access runs the Performance Analyzer and displays analysis results.
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The analysis notes about each idea that appear in the bottom part of the Performance Analyzer dialog 
box indicate that the optimization will benefit the Invoice Details Report and potentially other objects 
in your database.

3.	 Close the Performance Analyzer dialog box and close the database. Exit Access.

Concepts Review
To check your knowledge of the key concepts introduced in this lesson, complete the Concepts 
Review quiz by choosing the appropriate access option below.

If you are… Then access the quiz by…

Using the Labyrinth Video Library Going to http://labyrinthelab.com/videos

Using eLab Logging in, choosing Content, and navigating to the 
Concepts Review quiz for this lesson

Not using the Labyrinth Video Library or eLab Going to the student resource center for this book
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Reinforce Your Skills
REINFORCE YOUR SKILLS AC09-R01

Work with Reports and Subreports
Kids for Change needs a report that breaks down donors and their donations by month. In this exercise, 
you will import a report that includes space for a subreport that contains donor detail information. You 
will save the subreport as a new report and then add a report control that numbers the activities that have 
available volunteers.

Import a Report

1.	 Start Access. Open AC09-R01-K4C from your AC2013 Lesson 09 folder and save it as 
AC09-R01-K4C-[FirstInitialLastName].

2.	 Choose External Data→Import & Link→ .

The Get External Data dialog box opens.

3.	 Click Browse, navigate to the AC2013 Lesson 09 folder, and double-click AC09-R01-
K4C–Backup.

This database is a backup copy of the K4C database.

4.	 Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database option, and click OK. 

Access displays object names contained in the backup database.

5.	 Click the Reports tab and choose Monthly Donations Report.

6.	 Click OK and click Close in the Get External Data dialog box.

7.	 Display the newly-imported Monthly Donations Report in Design View.

The Detail section contains no controls. This is where you will insert the subreport.

Add a Subreport

8.	 Choose Design→Controls→Subform/Subreport .

9.	 Draw a subreport control in the Detail section of the newly-imported Monthly Donations 
Report.

The SubReport Wizard starts.

10.	 Choose DonorDetail Subform from the Use an Existing Report or Form list and click 
Next.

11.	 Scroll through the list and choose Show DonorDetail Query for each record in Donations 
Query using DonationDate.

The Show items are too long to display completely in the list, but the highlighted one is shown in the 
box below the list.
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12.	 Click Next, keep the default name, and click Finish.

13.	 Click the DonorDetail Subform label and tap [Delete].

If you don’t see the subform label, it might be hidden behind the subform. If necessary, click the 
Selection Type menu button at the top of the Property Sheet, choose DonorDetail Subform label, and 
tap [Delete].

14.	 Click the subreport control and enter these properties on the Property Sheet:

Property Value

Width 6.5”

Height .5”

Top 0”

Left .5”

Border Style Transparent

15.	 Click the Detail section bar and type .5” for the Height.

16.	 Save the Monthly Donations Report and switch to Print Preview.

The report with subreport should include each detail line in subform layout.

Create a Report from a Subreport

17.	 Switch to Design View.

18.	 Right-click the left side of the subreport control and choose Subreport in New Window.

Access opens the subreport (in this case, the DonorDetail Subform) in a separate window. If you don’t 
see the Subreport in New Window choice on the shortcut menu, click an area of the main report then 
right-click the subreport control again.

19.	 Choose File→Save As→Save Object As→ .

20.	 Type K4C Donors Subreport in the Save…To box and choose Report from the As 
menu.

21.	 Click OK and close the K4C Donors Subreport.

The DonorDetail Subform is saved as a separate report so that any changes made to it are not reflected 
in the original DonorDetail Subform.

22.	 Display the Monthly Donations Report in Design View.

23.	 Display the Property Sheet and then display the Data tab.
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24.	 Select the subreport, click in the Source Object property line, and choose  
Report.K4C Donors Subreport from the drop-down menu.

25.	 Save and close the Monthly Donations Report.

Number Report Items

26.	 Display the Volunteers Report in Design View.

27.	 Choose Design→Controls→Text Box  and draw a new text box in the Detail section 
to the left of the ActID text box.

28.	 Delete the associated label control.

29.	 Click the new text box control and set these property values:

Property Value

Name txtCount

Control Source =1

Width .3”

Top 0”

Left 0”

Running Sum Over All

30.	 Switch to Report View.

Access numbers the detail lines consecutively for each activity having a volunteer.

31.	 Save and close the Volunteers Report. Close the database and exit Access.

32.	 Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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REINFORCE YOUR SKILLS AC09-R02

Add Fields and Controls, and Analyze Database 
Performance
Kids for Change wants to improve their Monthly Donations Report. In this exercise, you will add a field 
to calculate the total monthly donations for each donor. You will set the subreport to grow and shrink, 
depending on the contents, add custom controls and a page break to a report, and finally, run the 
performance analyzer on the database reports.

Add a Calculated Field to a Report

1.	 Start Access. Open AC09-R02-K4C from your AC2013 Lesson 09 folder and save it as 
AC09-R02-K4C-[FirstInitialLastName].

2.	 Display the K4C Donors Subreport in Design View.

3.	 Choose Design→Controls→Text Box and draw a new text box in the Page Footer section, 
under the Amount text box.

4.	 Select the associated label and tap [Delete].

5.	 Click the new text box and enter these values on the Property Sheet:

Property Value

Name MonthTotal

Control Source =Sum(Amount)

Format Currency

Width 1.3”

Height .2”

Top 0”

Left 5”

Font Name Arial Rounded MT Bold

Text Align Right

6.	 Save and close the K4C Donors Subreport.

Grow and Shrink a Subreport

7.	 Display the Monthly Donations Report in Design View.

8.	 Select the K4C Donors Subreport.

9.	 Choose Yes for the Can Grow property, if necessary; choose Yes for the Can Shrink property.

10.	 Save the Monthly Donations Report.

Add a Logo, Title, Date, and Page Break to a Report

11.	 Select the title control.

12.	 Click in the title control to position the insertion point just before the existing text. Type 
Kids for Change in front of Monthly Donations Report.

13.	 Press [Shift]+[Enter] to bump Monthly Donations Report to a second line.
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14.	 Tap [Enter]; type 4” for the Width, type 2” for the Left property, and choose Center for 
Text Align.

15.	 Click the Page Header section bar.

16.	 Choose Design→Header/Footer→ , navigate to the AC2013 Lesson 09 folder; choose 
All Files (*.*), and choose K4C-Logo.bmp.

17.	 Draw the logo on the far left side of the Page Header section.

18.	 Type .8” for the Width and Height properties. Type .1” for the Top property and .5” for 
the Left property.

Now you will add a Date control to the Page Header section and center it under the title.

19.	 Choose Design→Header/Footer→  and choose the MM/DD/YYYY format; 
do not include the time.

By default, Access places the new date control at the far right side of the Report Header.

20.	 Select the date control and press [Ctrl]+[X]. Then click the Page Header section bar and 
press [Ctrl]+[V].

21.	 Delete all empty placeholder controls in the Report Header section. Drag up the Page 
Header section bar to meet the Report Header section bar.

This report will not include a Report Header section because the titles are in the Page Header section so 
they will appear at the top of every report page.

22.	 Enter these property values for the Date control:

Property Value

Width 2”

Height .2”

Top .75

Left 3”

Text Align Center

23.	 Switch to Print Preview.

The date will be centered in the Page Header section.

24.	 Close Print Preview.
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25.	 In Design View, choose Design→Controls→Insert Page Break  and click in the left 
side of the DonationDate Footer section.

Access places the page break control on the report.

26.	 Type 0” for the Top property of the page break control.

27.	 Click the DonationDate Footer section bar and type .001” for the Height.

This will make the DonationDate Footer section as short as possible so that the page break doesn’t 
push down the DonationDate header on the next page.

28.	 Switch to Print Preview and navigate to the April donations.

Each month’s donations appear on a separate page.

29.	 Close Print Preview.

30.	 Save and close the Monthly Donations Report.

Analyze Report Performance

31.	 Choose Database Tools→Analyze→ .

32.	 Click the Reports tab, if necessary; click Select All, and click OK.

Access analyzes every report in the database and presents an analysis that shows relevant 
recommendations, suggestions, and ideas about data types, relationships, and design.

33.	 Click the third item in the list to see the recommendation that the analyzer has made.

The optimization will benefit the Volunteers Report and potentially other objects in your database. It 
suggests that you change the data type of the VolID field in the Volunteers table to Long Integer. No 
changes are needed because each current data type is valid.

34.	 Close the Performance Analyzer dialog box. Close the database and exit Access.

35.	 Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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REINFORCE YOUR SKILLS AC09-R03

Work with Reports and Analyze Database 
Performance
Kids for Change needs a report that presents activity staffing assignments. In this exercise, you will import 
a report that includes room for a subform containing activity detail information and save the subreport 
as a separate report. You will add a count of donations per donor and modify a report. You will set a 
subreport to accommodate its data, add custom controls and a page break to a report, and analyze report 
performance.

Import a Report

1.	 Start Access. Open AC09-R03-K4C from your AC2013 Lesson 09 folder and save it as 
AC09-R03-K4C-[FirstInitialLastName].

2.	 Choose External Data→Import & Link→ .

The Get External Data dialog box opens.

3.	 Click Browse, navigate to the AC2013 Lesson 09 folder, and double-click AC09-R03-
K4C-Backup.

This database is a backup copy of the K4C database.

4.	 Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database option, and click OK. 

Access displays object names contained in the backup database.

5.	 Click the Reports tab and choose Staff Report.

6.	 Click OK and click Close in the Get External Data dialog box.

7.	 Display the newly-imported Staff Report in Report View.

The empty space in the Detail section is where you will insert the subreport.

Add a Subreport

8.	 Switch to Design View and choose Design→Controls→Subform/Subreport .

9.	 Draw a subreport control under the existing controls in the Detail section.

10.	 Scroll down the Use an Existing Report or Form list, choose Staffing Subform, and 
click Next.
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11.	 Ensure that Choose From a List is the linking option.

12.	 Click Next, keep the default name, and click Finish.

A small green triangle in the Report selector indicates a possible error. Click the 
triangle to view the Smart tag, which lists the error and possible solutions. In 
this case, the report is wider than a page. The next few steps will eliminate the 
error.

13.	 Click the Staffing Subform label and tap [Delete].

14.	 Click the subreport and enter these properties on the Property Sheet:

Property Value

Width 7.7”

Height .5”

Top 3”

Left 0”

Border Style Transparent

15.	 Click the Report selector and type 7.8” for the Width property of the report.

The green Smart tag indicator should be gone now.

16.	 Save the Staff Report and switch to Print Preview.

The report should include the activity detail line under each staffer’s information.

Create a Report from a Subreport

17.	 Close Print Preview and switch to Design View.

18.	 Right-click the subreport control and choose Subreport in New Window.

The Staffing Subform subreport opens in a separate window. If you don’t see the Subreport in New 
Window choice, click any area of the main report then right-click the subreport again.

19.	 Choose File→Save As→Save Object As→ .

20.	 Type K4C Staffing Subreport in the Save…To box, choose Report from the As 
drop-down menu, and click OK.

21.	 Close the subform.

22.	 Display the K4C Staffing Subreport in Design View. Then click the Detail section bar 
and type .3” for the Height.

23.	 Right-click the Detail section bar and choose Report Header/Footer .

24.	 Choose Blue, Accent 1, Lighter 80% for the Back Color of the Report Header section.

25.	 Choose Design→Controls→Label  to add the seven labels to the Report Header section.
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26.	 Select all the labels and enter these properties:

Property Value

Height .2”

Top 0”

Font Name Arial Rounded MT Bold

Font Size 10

Fore Color Blue, Accent 1, Darker 50%

27.	 Save and close the K4C Staff Subreport. 

28.	 Display the Staff Report in Design View.

29.	 Select the subreport, type Staffing Subreport for the Name property, click in the 
Source Object line, and choose Report.K4C Staffing Subreport.

30.	 Save and close the Staff Report.

Number Report Items

31.	 Display the Donations Report in Design View.

32.	 Choose Design→Controls→Text Box  and draw a new text box in the Detail section 
to the left of the DonorID text box.

33.	 Delete the associated label control.

34.	 Click the new text box control and set these property values:

Property Value

Name txtCounter

Control Source =1

Width .3”

Top 0”

Left .3”

Border Style Transparent

Font Name Arial

Font Weight Semi-Bold

Running Sum Over All
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35.	 Switch to Report View.

Access numbers the detail lines consecutively for each individual donation.

36.	 Save the Donations Report.

Add a Calculated Field to a Report and Change Page Layout

37.	 Switch to Design View, click the Selection Type menu button, and choose Report.

38.	 Drag the right edge of the report to the right to the 10” mark on the horizontal ruler.

39.	 Choose Design→Controls→Text Box and draw a new text box in the Detail section, to 
the right of the Amount text box.

40.	 Select the associated label and tap [Delete].

41.	 Click the new text box and enter these values on the Property Sheet:

Property Value

Name ScholarFund

Control Source =Amount*.1

Format Currency

Width .75”

Height .25”

Top 0”

Left 7.9”

Border Style Transparent

42.	 Choose Design→Controls→Label and draw a new label control above the ScholarFund 
text box.

43.	 Type Scholar Fund in the new label.

44.	 Click the Amount label, choose Home→Clipboard→Format Painter , and click the 
new Scholar Fund label to paint the same formatting.

45.	 Select all labels in the Page Header section.

46.	 Choose Arrange→Sizing & Ordering→Align→Top.

47.	 Choose Arrange→Sizing & Ordering→Size/Space→To Shortest.
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48.	 Add a text box to the right of the ScholarFund text box, delete the associated label, and 
enter these properties for the new NetDonation text box:

Property Value

Name NetDonation

Control Source =Amount-ScholarFund

Format Currency

Width 1”

Top 0”

Left 8.8”

Border Style Transparent

49.	 Choose Design→Controls→Label. Draw a new label control above the ScholarFund text 
box named Net Donation.

50.	 Click the Amount label and paint its format on the new Net Donation label.

51.	 Align and size the Net Donation label to the other labels as above.

52.	 Choose Page Setup→Page Size→Margins →Narrow.

53.	 Choose Page Setup→Page Layout→Landscape .

54.	 Choose Report from the Selection Type list at the top of the Property Sheet and type 10” 
for the Width property.

The layout is wider and the Report Header should be centered on the report.

55.	 Select all the controls in the Report Header section and tap [¡] until the left edge of the 
titles are at the 3” mark on the horizontal ruler.

56.	 Switch to Print Preview.

The report should include the Count running down the left side and the two new currency text fields 
and labels on the right.

57.	 Save and close the Donations Report.

Now, you will modify the subreport in the Staff Report to grow and shrink depending on how many 
detail lines it contains.

58.	 Display the Staff Report in Design View.

59.	 Select the K4C Staffing Subreport and click the Format tab of the Property Sheet.

60.	 Choose Yes for the Can Grow property on the Property Sheet, if necessary; choose Yes for 
the Can Shrink property.

61.	 Save the Staff Report and leave it in Design View.

Add a Logo, Title, Date, and Page Break to a Report

62.	 Display the Volunteers Report in Design View.

63.	 Select all the controls in the Report Header section of the Volunteers Report.
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64.	 Press [Ctrl]+[C] to copy the selected controls, click the Page Header section bar of the 
Staff Report, and press [Ctrl]+[V] to paste the controls.

65.	 Tap [¥] twice to move down the pasted controls slightly.

66.	 Close the Volunteers Report.

67.	 Select the logo and type 6.5” for the Left property.

68.	 Select the two title controls and type 2” for the Left property.

69.	 Select the Date control and type 3.5” for the Left property.

70.	 Highlight the text in the Volunteers subtitle, type Staff Report, and tap [Enter].

The Page Header with the new heading controls and Staff Report as the subtitle.

71.	 Switch to Print Preview.

The report will be displayed with the new subtitle.

72.	 Switch to Design View. Choose Design→Controls→Insert Page Break  and click in 
the bottom-left side of the Detail section of the main report.

Access places the page break control on the report.

73.	 Switch to Print Preview.

The report should display each staffer on a separate page.

74.	 Close Print Preview, and save and close the Staff Report.

Analyze Report Performance

75.	 Choose Database Tools→Analyze→ .

76.	 Click the Reports tab, click Select All, and click OK.

Access provides more detail about how to optimize database performance with respect to each specific 
result. In the case above, the analyzer presents some “ideas” about changing field data types; however, 
each current data type is valid and acceptable.

77.	 Close the Performance Analyzer dialog box. Close the database and exit Access.

78.	 Submit your final file based on the guidelines provided by your instructor.
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Apply Your Skills
APPLY YOUR SKILLS AC09-A01

Work with Reports and Subreports
In this exercise, you will help Universal Corporate Events, Ltd. create a report 
that breaks down revenue by venue, including numbered detail lines for each event. You will save the 
subreport as a separate report, and add a text box to count scheduled events at each venue.

Import a Report

1.	 Start Access. Open AC09-A01-UCE from your AC2013 Lesson 09 folder and save it as 
AC09-A01-UCE-[FirstInitialLastName].

2.	 Choose External Data→Import & Link→ .

The Get External Data dialog box opens.

3.	 Click Browse, navigate to the AC2013 Lesson 09 folder, and double-click AC09-A01-
UCE-Backup.

This database is a backup copy of an older UCE, Ltd. database.

4.	 Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database option and click OK.

Access displays object names contained in the backup database.

5.	 Click the Reports tab and choose Venue Revenue Report.

6.	 Click OK then close the Get External Data dialog box.

7.	 Display the newly imported Venue Revenue Report in Design View.

The space in the VenueID Header section is where you will insert the subreport.

Add a Subreport

8.	 Draw a subreport control in the VenueID Header section under the other controls.

9.	 Choose VenueRevenue Subform and click Next.

10.	 Choose the Show Statement Linking By VenueID.

11.	 Click Next, keep the default name, and click Finish.

12.	 Delete the VenueRevenue Subform label.

13.	 Click the subreport control and enter these properties on the Property Sheet:

Property Value

Width 7”

Height 1.5”

Top 1.3”

Left .25”

Border Style Transparent
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AC09.40  Access 2013  Lesson 9: Customizing Reports

14.	 Click the VenueID Header section bar and type 3” for the Height property.

15.	 Save the Venue Revenue Report and switch to Print Preview.

v

Create a Report from a Subreport

16.	 Switch to Design View, right-click the left side of the subreport control, and choose 
Subreport in New Window.

Access opens the subreport in a separate window.

17.	 Choose File→Save As→Save Object As→Save As.

18.	 Type VenueRevenue SubReport in the Save…To box, choose Report from the As 
menu, and click OK. Close the VenueRevenue SubReport.

Access returns to the Venue Revenue Report in Design View.

19.	 With the subreport control selected, click in the Source Object line of the Property Sheet 
and choose Report.VenueRevenue SubReport.

20.	 Save the Venue Revenue Report then switch to Print Preview.

The subreport will be displayed.

21.	 Close Print Preview and close the Venue Revenue Report.

Next, you will resize the labels and move them from the Detail section into the Report Header section.

22.	 Display the VenueRevenue SubReport in Design View and drag the right edge of the 
report to the right a couple of inches.

23.	 Select all labels and text boxes, choose Transparent for the Border Style property, and 
choose Text 1 (black) for the Fore Color property.

24.	 Reduce the size of each label to just fit its caption.

25.	 Click the Report Header section bar and type .3” for the Height.

26.	 Cut each label, in order, from the Detail section and paste them into the Report Header 
section, spacing them horizontally across the section.

27.	 Click and drag each text box within the Detail section to line up horizontally under each 
label, resizing them as necessary.

Lessons from Microsoft Office 2013  FOR EVALUATION ONLY (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Apply Your Skills  AC09.41

Ac
ce

ss
 2

01
3

28.	 Right-align the Line Total label, the Detail section calculated control, and the Report 
Footer section calculated control.

29.	 Click the Detail section bar and type .3” for the Height property.

30.	 Switch to Layout View and resize and move the controls as shown.

31.	 Save the subreport.

Number Report Items

32.	 Switch to Design View, and then type 6” for the Width property of the subreport.

33.	 Select all report controls and tap [¡] to nudge them just to the right edge of the subreport.

34.	 Draw a new text box in the Detail section to the left of the VenueID text box. Delete the 
associated label control.

35.	 Click the new text box control and set these property values:

Property Value

Name txtCount

Control Source =1

Width .2”

Top 0”

Left 0”

Border Style Transparent

Running Sum Over All

36.	 Save and close the VenueRevenue SubReport.

37.	 Display the Venue Revenue Report in Print Preview.

The detail lines for each venue are counted.

38.	 Save and close the reports. Then close the database and exit Access.

39.	 Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.
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APPLY YOUR SKILLS AC09-A02

Add Fields and Controls, and Analyze Database 
Performance
Universal Corporate Events, Ltd. wants to refine their database reports and analyze report performance. 
In this exercise, you will add a field to calculate the total of all the venues’ revenues; modify a subreport 
to ensure that all venue detail lines will display; add custom Report Header controls and a page break to 
another report, and run the analyze report performance. 

Add a Calculated Field to a Report

1.	 Start Access. Open AC09-A02-UCE from your AC2013 Lesson 09 folder and save it as 
AC09-A02-UCE-[FirstInitialLastName].

2.	 Open the Venue Revenue Report in Design View.

3.	 Click the Report Footer section bar and type .4” for the Height property.

4.	 Draw a new text box in the Report Footer section, under the right end of the subreport.

5.	 Select the associated label and enter these values on the Property Sheet:

Property Value

Caption Grand Total for All Venues

Width 2”

Top .1”

Left 2”

Font Weight Semi-Bold

Fore Color Blue, Accent 1, Darker 50%

6.	 Click the new text box and enter these property values:

Property Value

Name ActivityCost

Control Source =Sum(Guests*ChgPP)

Format Currency

Width 1.5”

Top .1”

Left 5”

Border Style Transparent

Font Weight Semi-Bold

Fore Color Blue, Accent 1, Darker 50%

7.	 Switch to Print Preview and navigate through the report.

If you get an error message that says section width is greater than page width, click OK, display the 
report in Design View, and set the Width property of the report to 7.9”.

8.	 Save the Venue Revenue Report.
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Grow and Shrink a Subreport

9.	 Display the Venue Revenue Report in Design View.

10.	 Select the VenueRevenue Subform and click the Format tab on the Property Sheet.

11.	 Choose Yes for the Can Grow property, if necessary; choose Yes for the Can Shrink 
property.

This ensures that all venue detail lines will be displayed.

12.	 Save the Venue Revenue Report.

Add a Logo, Title, Date, and Page Break to a Report

13.	 Open the Event Revenue Report in Design View. Delete the title control in the Report 
Header, click the Report Header section bar, and type 0” for its Height.

14.	 Click the Page Header section bar and type .85” for its Height property

15.	 Choose Blue, Accent 1, Lighter 80% for the Back Color of the Page Header section.

16.	 Copy all the controls in the Report Header section of the Venue Revenue Report.

17.	 Paste the copied controls into the Page Header section Event Revenue Report; close the 
Venue Revenue Report.

18.	 Tap [¥] as necessary to move down the pasted controls in the Page Header.

19.	 Select the two title controls; type 4” for the Width and 2” for the Left property.

20.	 Select just the logo and type.5” for the Left property.

21.	 Select the =”Page “ control in the Page Footer section and choose Right for the Text Align 
property. Then, right-align the =”Page “ control with the Total Revenue controls.

22.	 Change the subtitle to Event Revenue Report, and tap [Enter]. 

23.	 Choose Design→Controls→Insert Page Break  and click in the left side of the 
EventDate Footer under the Total for label.

Access places the page break control on the report.

24.	 Switch to Print Preview and navigate to January 2014.

Each month’s donations appear on a separate page.

25.	 Save and close the Event Revenue Report.
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Analyze Database Performance

26.	 Choose Database Tools→Analyze→ .

27.	 Choose the Reports tab, click Select All, and click OK.

Access analyzes the reports and presents an analysis that returns several ideas.

The analyzer presents “ideas” about changing field data types; but each current data type is valid and 
acceptable.

28.	 Close the Performance Analyzer dialog box. Then close the database and exit Access.

29.	 Submit your final file based on the guidelines provided by your instructor.

To see examples of how your file or files should look at the end of this exercise, go to the student 
resource center.

APPLY YOUR SKILLS AC09-A03

Work with Reports and Analyze Database 
Performance
In this exercise, you will help Universal Corporate Events refine existing reports and analyze report 
performance. You will import a report and add a subreport that shows revenue from each venue liaison. 
You will create a separate report from the subreport, add a count of UCE’s venues, and add a field to 
calculate revenue by liaison. You will then modify a subreport to grow or shrink, add Report Header 
controls and a page break, and analyze report performance.

Import a Report

1.	 Start Access. Open AC09-A03-UCE from your AC2013 Lesson 09 folder and save it as 
AC09-A03-UCE-[FirstInitialLastName].

2.	 Choose External Data→Import & Link→ .

The Get External Data dialog box opens.

3.	 Click Browse, navigate to the AC2013 Lesson 09 folder, and double-click AC09-A03-
UCE-Backup.

4.	 Choose the Import Tables, Queries, Forms, Reports, Macros, and Modules into the 
Current Database option, and click OK.

Access displays object names contained in the backup database.

5.	 Click the Reports tab and choose Liaison Revenue Report.

6.	 Click OK then close the Get External Data dialog box.

7.	 Display the Liaison Revenue Report in Design View and open the Property Sheet.

8.	 Type Liaison Revenue Report for the Caption property.
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Add a Subreport

9.	 Draw a subreport control in the Detail section.

10.	 Choose VenueLiaison Subform as the data source.

11.	 Choose the Show VenueLiaison Query option shown:

12.	 Click Next, keep the default name, and click Finish.

13.	 Delete the VenueLiaison Subform label.

14.	 Click the subreport control and enter these properties on the Property Sheet:

Property Value

Width 7.5”

Height 2”

Top 2”

Left .1”

Border Style Transparent

15.	 Click the Detail section bar and type 4” for the Height property.

16.	 Save the Liaison Revenue Report and switch to Print Preview.

The report should list each detail line in datasheet layout. If you get a page width error message, set 
the report’s Width property to 7.9”.

17.	 Close Print Preview.

Create a Report from a Subreport

18.	 Switch to Design View, right-click the left side of the subreport control, and choose 
Subreport in New Window.

Access opens the subreport in a separate window.

19.	 Choose File→Save As→Save Object As→Save As.

20.	 Type VenueLiaison SubReport in the Save…To box, choose Report from the As 
menu, and click OK.

21.	 Close the subreport. Then, with the subreport control selected, click in the Source Object 
property line and choose Report.VenueLiaison SubReport.

22.	 Save the Liaison Revenue Report and switch to Print Preview.

23.	 Close Print Preview and close the Liaison Revenue Report.

24.	 Display the VenueLiaison SubReport in Design View.

25.	 Select all controls; choose Transparent for the Border Style and Black, Text 1 for the 
Fore Color.
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26.	 Resize and align the header controls with the detail controls.

27.	 Save the VenueLiaison SubReport.

Number Report Items

28.	 Type 7.5” for the Width property of the subreport.

Report should appear in the Selection Type box at the top of the Property Sheet.

29.	 Draw a text box in the Detail section to the left of the Liaison text box. Delete the 
associated label control.

30.	 Click the new text box control and set these property values:

Property Value

Name txtCount

Control Source =1

Width .3”

Top 0”

Left .1”

Border Style Transparent

Fore Color Text 1, Black

Running Sum Over All

31.	 Save the subreport.

Add a Calculated Field to a Report

32.	 Draw a new text box in the Detail section to the right of the Chg/PP text box. Delete the 
associated label.

33.	 Click the new text box and enter these property values:

Property Value

Name NetAmt

Control Source = Guests*ChgPP

Format Currency

Width .9”

Top 0”

Left 6.6”

Font Weight Semi-Bold

Fore Color Blue, Accent 1, Darker 50%
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34.	 Draw a new label in the Report Header section to the right of the Chg/PP label.

35.	 Type Net Amt in the new label.

36.	 Use the Format Painter to paint the formatting of the other labels onto the new label.

37.	 Type .6” for the Width and 6.9” for the Left property.

38.	 Save and close the subreport.

39.	 Display the Liaison Revenue Report in Print Preview.

A field that multiplies the number of guests by the charge per person to produce a net amount is added 
to the subreport. If necessary, switch to Layout View to adjust the size and spacing of the controls for 
better display. 

40.	 Close Print Preview.

Grow a Subreport 

41.	 Switch to Design View and click to select the VenueLiaison SubReport.

42.	 Choose Yes for the Can Grow property, if necessary; choose Yes for Can Shrink.

Setting the Can Grow and Can Shrink properties will ensure that all venue detail lines will be 
displayed, and that the spacing between the final venue total and the grand total will always 
be the same.

43.	 Save the Liaison Revenue Report.

Add a Logo, Title, Date, and Page Break to a Report

44.	 Display the Venue Revenue Report in Design View and copy all controls in the Report 
Header section. Close the report.

45.	 Display the Liaison Revenue Report in Design View, delete the existing title control, set 
the Report Header Height property to 0, and paste the copied controls into the Page Header 
section.

46.	 Tap [¥] to align the pasted controls in the Page Header.

47.	 Select the two title controls and type 2” for the Left property.

48.	 Select the logo and type.5” for the Left property.

49.	 Select the Date control and type 6.75” for the Left property.

50.	 Change the subtitle to Liaison Revenue Report.

51.	 Click the Page Header section bar and choose Blue, Accent 1, Lighter 80% for the Back 
Color property.

52.	 Save the report and switch to Print Preview.

53.	 Close Print Preview.
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54.	 Choose Design→Controls→Insert Page Break  and click in the bottom-left corner of 
the Detail section just below the subform.

Access places the page break control on the report.

55.	 Switch to Print Preview and navigate through the pages.

Each liaison’s net amount should be displayed on a separate page.

TIP

	 If every other page is blank, the report might be too wide or there might be a control placed 
beyond the margin. To fix this, move the errant control to the left and drag the right edge of 
the report to the left.

56.	 Save and close the Liaison Revenue Report.

Analyze Database Performance

57.	 Choose Database Tools→Analyze→ .

58.	 Choose the Reports tab, click Select All, and click OK.

Access analyzes the reports, presents an analysis, and suggests how to optimize performance.

59.	 Close the Performance Analyzer dialog box. Then close the database and exit Access.

60.	 Submit your final file based on the guidelines provided by your instructor.
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Extend Your Skills
In the course of working through the Extend Your Skills exercises, you will 
think critically as you use the skills taught in the lesson to complete the assigned 
projects. To evaluate your mastery and completion of the exercises, your instructor 
may use a rubric, with which more points are allotted according to performance 
characteristics. (The more you do, the more you earn!) Ask your instructor how 
your work will be evaluated.

AC09-E01	 That’s the Way I See It
Blue Jean Landscaping needs to modify its database reports. Use the database you used in 
AC08-E01 or open AC09-E01-BJL from the AC2013 Lesson 09 folder and save it as AC09-
E01-BJL-[FirstInitialLastName]. Import the Customer Sales Report from AC09-E01-
BJL-Backup in the AC2013 Lesson 09 folder. (If using your own database, import a report 
from one of your backups or create a new backup.) Add the CustomerSales Subform to the 
Customer Sales Report; save the subform as a separate report, and number the lines within the 
subreport. (If using your own database, insert a related subform in your imported report.) 
Calculate each customer line total (Price*QtySold) in the Detail section of the subreport. 
Calculate each customer’s total (=Sum(Price*QtySold)) in the Report Footer.

Add appropriate title/subtitles, date, and either the BJL logo or your own. Insert a page break to 
display each customer on a separate page and, finally, run the performance analyzer on the 
database reports.

You will be evaluated based on the inclusion of all elements, your ability to follow directions, 
your ability to apply newly learned skills to a real-world situation, your creativity, and your 
accuracy in creating objects and/or entering data. Submit your final file based on the guidelines 
provided by your instructor.

AC09-E02	 Be Your Own Boss
In this exercise, you will modify reports for Blue Jean Landscaping. To begin, open AC09-E02-
BJL from the AC2013 Lesson 09 folder and save it as AC09-E02-BJL-
[FirstInitialLastName]. 

Import the Manufacturer Sales Report from the AC09-E02-BJL-Backup database (in AC2013 
Lesson 09). Insert the ManufacturerSales Subform in the Manufacturer Sales Report and save 
the subform as a separate report. Number the line items in the subreport and main form. 
Calculate each line total (Price*QtySold) in the Detail section of the subreport.

Format titles, add the BJL-Logo and date, add a page break to display each manufacturer on a 
separate page, and analyze report performance.

You will be evaluated based on the inclusion of all elements, your ability to follow directions, 
your ability to apply newly learned skills to a real-world situation, your creativity, and your 
accuracy in creating objects and/or entering data. Submit your final file based on the guidelines 
provided by your instructor.
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Transfer Your Skills
In the course of working through the Transfer Your Skills exercises, you will use 
critical-thinking and creativity skills to complete the assigned projects using skills 
taught in the lesson. To evaluate your mastery and completion of the exercises, 
your instructor may use a rubric, with which more points are allotted according 
to performance characteristics. (The more you do, the more you earn!) Ask your 
instructor how your work will be evaluated.

AC09-T01	 Use the Web as a Learning Tool
Throughout this book, you will be provided with an opportunity to use the Internet as a learning 
tool by completing WebQuests. According to the original creators of WebQuests, as described on 
their website (WebQuest.org), a WebQuest is “an inquiry-oriented activity in which most or all 
of the information used by learners is drawn from the web.” To complete the WebQuest projects 
in this book, navigate to the student resource center and choose the WebQuest for the lesson on 
which you are currently working. The subject of each WebQuest will be relevant to the material 
found in the lesson.

WebQuest Subject: Filtering data in reports

Submit your files based on the guidelines provided by your instructor.

AC09-T02	 Demonstrate Proficiency
The Stormy BBQ Key West store and restaurant has been enjoying increased sales! You must 
make some changes to the database reports to produce more useful sales results. Open AC09-
T02-SBQ from the AC2013 Lesson 09 folder and save it as AC09-T02-SBQ-
[FirstInitialLastName]. 

Import the Merchandise Sales Report, which lists merchandise by SKU, from AC09-T02-SBQ-
Backup in the AC2013 Lesson 09 folder. Insert the MerchandiseSales Subform into the Detail 
section of the Merchandise Sales Report to add individual sale line items (Choose Show each 
record in Merchandise using SKU). Save the subform as a report. (Close the subform then open 
the subreport so the changes you make are not reflected in the subform). Number line items in 
the subreport and in the main report. Calculate each line total (ListPrice*QtySold) in the Detail 
section of the subreport. Copy the titles, logo, date, and formatting from the Merchandise 
Inventory Report into the Merchandise Sales Report, add a page break to display each SKU item 
on a separate page, and run the performance analyzer. 

Submit your final file based on the guidelines provided by your instructor.
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