Financial functions are among Excel's more complex elements. However, it’s worth taking the time to master their use, as these functions can save substantial time. Commonly used financial functions are present value (PV), future value (FV), and payment (PMT). Because of the complexity of these functions, you may find it necessary to protect some or all of a worksheet that includes them. You may also find that automating processes involving these functions with macros allows for a greater efficiency. In this chapter, you will use financial functions while creating a bond amortization schedule. You will begin by calculating different features of a bond using PV, FV, and PMT functions. You will create a bond amortization schedule for this bond and protect various worksheet elements. Last, you will create a macro to automate the completion of a bond amortization table.
City Music World

City Music World is a retail store that sells musical equipment and offers lessons for beginning and experienced musicians. The company is considering issuing bonds to fund a potential expansion of its operations. Before doing so, the company wants to review the necessary payment schedule and purchase price of bonds with different characteristics. You are creating a bond amortization schedule that can be updated for different bonds. You will protect key worksheet elements and automate as much of the schedule completion as possible.

In this chapter, you will create a bond amortization schedule using PV, FV, and PMT functions. You will also apply different levels of worksheet protection for different users. Last, you will create macros to automate populating the bond amortization schedule once key bond data has been entered.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Bond Details</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Date</td>
<td>1/1/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Face Value</td>
<td>$100,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Contract Rate</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Effective Rate</td>
<td>12%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Life (years)</td>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Payments per Year</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bond Calculations</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Present Value</td>
<td>$92,639.91</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Future Value</td>
<td>$100,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Payment</td>
<td>$5,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Date</td>
<td>Interest Payment</td>
<td>Interest Expense</td>
<td>Amortization of Bond Discount</td>
<td>Bond Discount Balance</td>
<td>Carrying Value</td>
</tr>
<tr>
<td>15</td>
<td>1/1/2012</td>
<td>$5,000.00</td>
<td>$5,558.39</td>
<td>$558.39</td>
<td>$7,360.09</td>
<td>$92,639.91</td>
</tr>
<tr>
<td>16</td>
<td>6/30/2012</td>
<td>$5,000.00</td>
<td>$5,519.90</td>
<td>$519.90</td>
<td>$6,801.69</td>
<td>$93,198.31</td>
</tr>
<tr>
<td>17</td>
<td>12/31/2012</td>
<td>$5,000.00</td>
<td>$5,627.41</td>
<td>$627.41</td>
<td>$5,582.38</td>
<td>$94,417.62</td>
</tr>
<tr>
<td>18</td>
<td>6/30/2013</td>
<td>$5,000.00</td>
<td>$5,665.06</td>
<td>$665.06</td>
<td>$4,917.32</td>
<td>$95,082.68</td>
</tr>
<tr>
<td>19</td>
<td>12/31/2013</td>
<td>$5,000.00</td>
<td>$5,704.96</td>
<td>$704.96</td>
<td>$4,212.36</td>
<td>$95,787.04</td>
</tr>
<tr>
<td>20</td>
<td>6/30/2014</td>
<td>$5,000.00</td>
<td>$5,747.26</td>
<td>$747.26</td>
<td>$3,465.11</td>
<td>$96,534.89</td>
</tr>
<tr>
<td>21</td>
<td>12/31/2014</td>
<td>$5,000.00</td>
<td>$5,792.09</td>
<td>$792.09</td>
<td>$2,673.01</td>
<td>$97,326.99</td>
</tr>
<tr>
<td>22</td>
<td>6/30/2015</td>
<td>$5,000.00</td>
<td>$5,839.62</td>
<td>$839.62</td>
<td>$1,833.39</td>
<td>$98,166.61</td>
</tr>
<tr>
<td>23</td>
<td>12/31/2015</td>
<td>$5,000.00</td>
<td>$5,890.00</td>
<td>$890.00</td>
<td>$943.40</td>
<td>$99,056.60</td>
</tr>
<tr>
<td>24</td>
<td>6/30/2016</td>
<td>$5,000.00</td>
<td>$5,943.40</td>
<td>$943.40</td>
<td>(0.00)</td>
<td>$100,000.00</td>
</tr>
<tr>
<td>25</td>
<td>12/31/2016</td>
<td>$5,000.00</td>
<td>$5,943.40</td>
<td>$943.40</td>
<td>(0.00)</td>
<td>$100,000.00</td>
</tr>
<tr>
<td>26</td>
<td>Totals</td>
<td>$50,000.00</td>
<td>$57,360.09</td>
<td>$7,360.09</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This bond amortization schedule has been fully populated through the use of a macro that automates the creation of all formulas.
When a business seeks to raise cash to fund a large expenditure, such as for the building of a new facility or the development of a new product, it will typically raise capital by issuing additional shares of stock (equity financing) or borrowing money (debt financing). One financial instrument that can be used when pursuing debt financing is a bond.

When a business issues a bond, it receives a lump payment from the bondholder to be used by the business to pursue its intended expenditure. In exchange, the bondholder receives periodic payments over the life of the bond (interest payments) and a lump-sum payment equal to the face value of the bond at the end of the bond’s life (principal payment). To determine figures such as the initial selling price of the bond and interest payments, you must understand the various bond characteristics. When using the most commonly applied effective interest method, these characteristics include the face value, life of the bond, contract interest rate, and effective interest rate.

NOTE! The effective interest method is the amortization method examined here, as it requires the completion of a bond amortization schedule. The alternative, though far less widespread, is to use straight-line amortization.

**Face Value**

The face value of a bond is the amount paid to the bondholder on the maturity date (the end of the bond’s life). If the issue price of the bond equals the face value, then the bond is being sold at its par value. However, oftentimes bonds are sold at more than their face value (sold at a premium) or less than their face value (sold at a discount).

**Life of the Bond**

The life of the bond represents the period of time over which the bond will be outstanding before it matures. A bond is often held by a single bondholder over the course of its life, but it’s also common for bonds to be sold from one bondholder to another. Periodic interest payments are made to the current bondholder throughout the life of the bond, and the face value of the bond is paid to the bondholder upon bond maturity. Note that the bond will indicate the frequency with which interest payments are made (annually, semiannually, etc.), and this schedule is followed throughout the life of the bond.

**Contract Interest Rate vs. Effective Interest Rate**

The contract interest rate is attached to the bond and used to calculate interest payments periodically made to the bondholder. Conversely, the effective interest rate (also called the market interest rate) factors in the impact of compounding on the interest payments. When completing a bond amortization table, the contract interest
rate is used to calculate actual interest payments, while the effective interest rate is used to calculate the present value of the bond.

These interest rates can be used to quickly identify whether a bond will be sold at a discount, face value, or a premium. When the contract interest rate and effective interest rate are the same, the bond sells at face value. If the contract rate is below the effective rate, then the bond can be considered less desirable than a similar bond that could be purchased elsewhere. This bond will sell at a discount from the face value. Conversely, if the contract rate is above the effective rate, then the bond is considered more attractive than a similar bond that could be purchased elsewhere and will sell at a premium above face value.

**Amortizing Bond Discount or Premium**

When a bond is issued at a discount or premium, the impact of this discount or premium within the financial records of the bond issuer is spread over the life of the bond. This **bond amortization** either increases the interest expense recorded when each bond payment is made (in the case of a discount) or reduces the interest expense (in the case of a premium). The total interest expense for each period is calculated as the interest payment plus amortized discount or minus amortized premium.

**Carrying Value**

The **carrying value** of a bond can be calculated as face value minus unamortized discount (or plus the unamortized premium). When the bond is issued, the unamortized discount or premium equals the total discount or premium for the bond. As the discount or premium is amortized, the unamortized portion of the discount or premium is gradually reduced (leading to a gradual increase in the carrying value when there is a discount or a gradual decrease when there is a premium). The result is that once the bond matures, the discount or premium will have been amortized to $0, and the bond’s carrying value will equal its face value.

### Working with Financial Functions

Excel includes a variety of financial functions that can simplify the creation of accounting-related worksheets. For example, there are basic financial functions for determining monthly payments on loans, total interest paid on loans, and the future value of investments. When examining the characteristics of a specific bond or other financial instrument, the PMT, PV, and FV functions are useful.

**PMT Function**

For the PMT function to calculate the required payment for a bond, you must specify the bond interest rate, number of payments to be made, present value, and future value of the payment at maturity.
The interest rate and number of payments must be carefully considered. The effective interest rate (not the contract interest rate) is the first argument. It’s typically expressed in annual terms, so if a bond requires an alternative payment schedule (such as semiannual instead of annual payments), the interest rate entered in the formula must be adjusted. For example, if the effective interest rate is 14% and a bond requires semiannual interest payments, then there are two interest payments every year. You divide 14% by two payments per year to arrive at an interest rate of 7%, which is what is entered as the first argument in the function.

The number of payments will often differ from the number of years in the life of the bond. If a bond with semiannual interest payments has a five-year life, then it will have a total of ten payments (five years * two payments per year).

One additional element to review is how the PMT function expresses periodic payments. By default, the result of the PMT function is displayed as a negative number. When writing the formula it is common to place a negative sign before the function. This reverses the result from a negative to a positive figure. Similar consideration is given to the individual arguments of the PMT function. Because the FV argument represents a lump payment at the end of the bond’s life, it should also be expressed as a negative number when writing the formula.

\[ \text{PMT} = -\text{PMT}(C6/C8, C7*C8, C11, -C4) \]

**PV Function and FV Function**

The PV function calculates the present value of a bond when you specify the bond interest rate, number of payments, interest payment amount, and future value of the payment at maturity. The FV function calculates the future value of a bond when you specify the bond interest rate, number of payments, interest payment amount, and present value.

\[ \text{PV} = \text{PV}(C6/C8, C7*C8, -C4*C5/C8, -C4) \]
\[ \text{FV} = \text{FV}(C6/C8, C7*C8, -C4*C5/C8, C11) \]

The PV and FV functions typically require negative symbols in their formulas.

The same considerations must be made for these functions as are made for the PMT function. Both the effective interest rate argument and the number of payments argument are entered per the earlier discussion. Additionally, the interest payment amount and future value of the payment at maturity must be expressed in negative terms. For the FV function, then, a negative sign is added before the FV at the beginning of the formula. The present value is considered to be a positive amount in Excel (since it does not represent a payment), so a negative sign is not needed before the PV at the beginning of that formula.
Financial Function Syntax

You create financial functions using actual values or cell references. Remember that using cell references offers more flexibility and is preferable.

**PMT, PV, and FV Function Syntax**

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>PMT (Payment)</td>
<td>PMT (rate, periods, present value, [future value], [type])</td>
</tr>
<tr>
<td>PV (Present Value)</td>
<td>PV (rate, periods, payment, [future value], [type])</td>
</tr>
<tr>
<td>FV (Future Value)</td>
<td>FV (rate, periods, payment, [present value], [type])</td>
</tr>
</tbody>
</table>

These financial functions can be used when the payment amount remains constant, such as with most bonds, car loans, and fixed-rate mortgages.

The *rate* argument is the interest rate for each period of the bond or loan. Although these interest rates are quoted as annual rates, payments usually are made more frequently. For monthly payments, as an example, you divide the interest rate by twelve. You can enter the result or the calculation details (such as 7%/12) in the formula.

The *periods* argument is the number of payments for the bond or loan, or the number of deposits for an investment.

The *payment* argument for a bond or loan is the required periodic interest payment. For an investment, it's the amount invested in each period. In either case, the payment is always the same for each period.

The *future value* argument is optional. It is the balance that will be owed at the bond maturity date or the amount desired at the end of an investment. This must be entered when determining the present value of, or payments for, a bond but is not required if the balance of an investment will be zero.

The *present value* argument is the value, in today's dollars, of a bond or loan. It must be entered when determining the future value of a bond. Or, it can be the starting balance of an investment (not required if the starting balance is zero). This argument is optional for the FV function.

The *type* argument indicates when payments are due. You are not required to enter the default argument 0 (zero) if payments are made at the end of the period. Enter 1 if payments are due at the beginning of the period. This is an optional argument.
Develop Your Skills EA8-D1

In this exercise, you will use financial functions to calculate the present value, future value, and payments associated with a bond. You will then create a bond amortization schedule.

Base your spreadsheet on a bond with a $100,000 face value, a five-year life, semiannual interest payments, a coupon interest rate of 10%, and an effective interest rate of 12%. The bond is issued on 1/1/2012.

1. Open a Blank Workbook and save the file in your Chapter 08 folder as: EA8-D1-Bond-[YourName]

   You will begin by preparing the worksheet for the data to be entered.

2. Set the width of column A to 0.75 and the height of row 1 to 7.2.

   This creates nice spacing that improves worksheet readability.

3. Merge and center the range B2:C2, add bold formatting, and enter Bond Details.

4. In order, type these headers in the range B3:B8: Date, Face Value, Contract Rate, Effective Rate, Life (years), and Payments per Year

5. Enter 1/1/12 in cell C3.

6. Enter 100000 in cell C4 and apply the Accounting number format.

7. Enter .1 in cell C5 and .12 in cell C6 and then select the range C5:C6 and choose Home→Number→Percent Style.

8. Select cell C7, type 5 and tap [Enter], and then type 2 and tap [Enter].

9. Center-align the contents of the range C3:C8.

10. Highlight the range B2:C8 and choose Home→Font→Borders ▼→Outside Borders; also apply an outside border around cell B2.

11. Autofit column B and set the width of column C to 12.

12. Merge and center the range B10:C10, add outside borders and bold formatting, and enter Bond Calculations.

13. In order, type these headers in the range B11:B13: Present Value, Future Value, and Payment

Enter Financial Functions

14. In cell C11, type =PV(C6/C8, but do not complete the entry.

   The effective interest rate is used for the first argument. It is divided by two because the effective rate is expressed in annual terms, but the bond pays interest semiannually.

15. Enter the next part of the formula: C7*C8,

   The second argument (number of interest payments) is calculated by multiplying the total number of years of the bond’s life by the payments per year.

16. Enter the next part of the formula: −C4*C5/C8,

   In the third argument, the contract rate of interest is multiplied by the face value of the bond to determine the periodic interest payments. Just as the effective interest rate was divided by the number of payments per year, the contract interest rate is divided by the number of payments to arrive at a prorated contract interest rate for each payment period. A negative sign is placed in front of C4 because the interest payments represent cash outflows.
17. To complete the formula, type \(-C4\) and tap [Enter].

The fourth argument represents the face value of the bond at maturity. As this is an outflow of cash, a negative sign is placed in front of C4.

18. In cell C12, type \(-\text{PV}((C6/C8, C7*C8, -C4*C5/C8, C11)}\) and tap [Enter].

The arguments in the FV function are similar to those in the PV function. Note the negative sign at the beginning of the formula.

19. With cell C13 selected, choose Formulas→Function Library→Insert Function, select the Financial category and the PMT function, and click OK.

20. Complete the Function Arguments box as shown and then click OK:

```
Rate C6/C8 = 0.06
Nper C7*C8 = 10
Pv C11 = 92639.91295
Fv -C4 = -100000
Type = number
```

21. With cell C13 still active, click between the equals sign and PMT in the Formula Bar, type a minus sign, and tap [Enter].

Just as the interest payments were preceded by a negative sign in the PV and FV functions because they represent cash outflows, the PMT function includes a negative sign here as well.

22. Apply the Accounting number format to the range C11:C13 and add an outside border to the range B10:C13.

23. Select the headers for columns D–G and use the right-click method to set the width to 15.

### Complete the Amortization Schedule

24. Starting with cell B15, highlight the range B15:G15, apply an outside border, add bold formatting, and set the Wrap Text option and Center alignment.

25. In cell B15, type Date and tap [Tab]; continue typing Interest Payment, Interest Expense, Amortization of Bond Discount, Bond Discount Balance, and Carrying Value in the remaining highlighted cells, tapping [Tab] between each entry.

Cells E15 and F15 indicate that a bond discount is being amortized. This can be verified by noting that the present value of the bond is less than its future value. If the present value had been greater than the future value, the cells would show a bond premium being amortized.


27. Highlight the range B17:B18 and then drag the fill handle at the bottom-right corner of the range through cell B26.

The bond depreciation schedule begins with the date on which the bond is issued and includes one row for every date on which an interest payment is made.

28. In cell B27, enter Totals and right-align the text.

29. Type =C12-C11 in cell F16, tap [Tab], and then type =C11 and tap [Enter].

These figures, which are based on the financial figures previously calculated, create the foundation for the remainder of the bond amortization schedule.
30. In cell C17, type =C13 and tap [F4], and then tap [Tab].
   The interest payment was previously calculated and is based on the contract interest rate. It
   remains constant for every period, so you are using absolute formatting.

31. Enter =G16*$C$6/$C$8 in cell D17.
   The total interest expense for each period is calculated by multiplying the current carrying
   value of the bond (which, as seen in cell G16, equals face value minus current balance within
   the bond discount) by the effective interest rate. As we have seen, the interest rate is divided
   by the number of payments per year.

32. Enter =D17-C17 in cell E17.
   The difference between the interest payment and the interest expense, as calculated here,
   represents the amortization of the discount for the current period.

33. Enter =F16-E17 in cell F17.
   The bond discount balance is reduced by the amortization amount each period. The bond
   discount is gradually reduced until it reaches zero at the end of the life of the bond.

34. Enter =G16+E17 in cell G17.
   Just as the bond discount balance decreases by the bond amortization amount each period, the
   carrying value of the bond (when it is issued at a discount) increases each period by the bond
   amortization amount.

35. Highlight the range C17:G17 and use the fill handle to copy the formulas through row 26.

36. Highlight the range C27:E27, choose Home→Editing→AutoSum, and then choose
   Home→Font→Borders ➤ Top and Double Bottom Border.

37. Apply the Accounting number format to the range C16:G27.

38. Save your file.
   Unless otherwise directed, always keep your file open at the end of each exercise.

---

Protecting Workbooks and Worksheets

You protect a file to prevent accidental or intentional modification. Excel offers three levels of
protection:

- **Workbook-level protection** protects the structure of the entire workbook, preventing
  changes to the way worksheets are displayed.
- **Worksheet-level protection** restricts changes to certain objects on worksheets.
- **Cell-level protection** limits access to certain cells on worksheets.

**Protecting the Workbook Structure**

Protecting a workbook prevents structural changes from being made. For example, you cannot
delete, rename, copy, or move worksheets while the structure is protected.
The Protect Workbook command displays the Protect Structure and Windows dialog box. Using an optional password allows you to control who can switch this protection on and off.

1. The Structure option protects worksheets from being reordered, copied, or deleted.
2. The Windows option is disabled in Excel 2013 and 2016 and, therefore, cannot be used.

Protecting the Worksheet Elements

You can turn on protection for individual worksheets in a workbook. The Protect Sheet command even allows you to restrict activity to specific actions, such as selecting cells, formatting rows and columns, and inserting/deleting rows and columns.

Turning Protection On and Off

Although it might appear that you would turn worksheet protection on/off using the Protect Worksheet and Contents of Locked Cells checkbox, that is not the case. That option always should have a checkmark. Clicking OK actually turns on worksheet protection.
Allowing User Changes

By default, two user options are selected in the Protect Sheet dialog box, giving users permission only to click on cells. If you remove those checkmarks, users can scroll through the worksheet but cannot select any cells. You can specify that users are allowed to change certain other items in a protected worksheet.

In a bond depreciation schedule, the user should need to change only a few input cells (including those for effective interest rate, face value, and bond life). Once entered, these figures should allow for the automatic completion of the body of the schedule. As such, it’s common for users to be given access to only those cells that require initial inputs.

Password Protection

For the highest level of protection, add a password. Users must enter the password to unprotect the worksheet and make further changes. For worksheets that are accessible by many employees but used only by a select few, including a password can help ensure that data is not improperly accessed.

**WARNING!** Keep track of your passwords! Workbook-protection passwords cannot be retrieved. If you forget your password, you must re-create the workbook.

**Develop Your Skills EA8-D2**

In this exercise, you will protect your bond amortization schedule so that users can alter only certain elements.

1. Save your file as: **EA8-D2-Bond-[YourName]**
2. Choose **Review→Changes→Protect Workbook**.
3. Follow these steps to protect the workbook:
   
   A. If necessary, click to place a checkmark in the **Structure** checkbox.
   
   B. Type **Amortization** as the password and click **OK**.
   
   C. In the **Confirm Password** dialog box, retype **Amortization** and click **OK**.
4. Double-click the Sheet1 tab.

An error message appears because protecting the workbook structure prevents the renaming of sheet tabs.

5. Click OK, choose Review→Changes→Protect Workbook, and then type the password Amortization and click OK.

The workbook is no longer protected.

6. Choose Home→Cells→Format→Protect Sheet and confirm that the boxes for these items are checked (if not, click to add checkmarks):
   • Protect Worksheet and Contents of Locked Cells
   • Select Locked Cells
   • Select Unlocked Cells

7. Click the checkbox for Format Cells, type Bond as the password, and click OK.

8. Confirm the password when prompted.

9. Right-click the column D header.

As a result of the protection you applied, some options in the pop-up menu are grayed out, or disabled.

10. Select cell C17 and then click the Insert tab on the Ribbon.

Notice that the majority of options on the Insert tab are also disabled.

11. Highlight the range B27:E27 and choose Home→Font→Bold.

You can apply the bold formatting even though the workbook protection is active because you allowed this in step 7.

12. Choose Review→Changes→Unprotect Sheet and then enter the password Bond and click OK.

13. Save your file.

---

### Protecting Individual Cells

You can protect the contents and formatting of certain cells. You can also hide formulas so they don’t display in the Formula Bar or when the Show Formulas command is used. All worksheet cells are locked by default until you unlock them. Why, then, have you been able to edit all locked cells? The cells’ locked/unlocked condition has no effect until worksheet protection is turned on.

**NOTE!** Remember that worksheet protection can be turned on through the Home or Review tab.
The Protection Tab of the Format Cells Dialog Box

You can open the Format Cells dialog box via the menu that appears when you right-click a highlighted area of a worksheet.

The Protection tab in the Format Cells dialog box allows you to change options for selected cells. There are two cell protection options you can set:

- **Locked**: Check or uncheck this option to lock/unlock the currently selected cells.
- **Hidden**: This option affects only the display of formulas. It does not hide labels, values, or formula results.

Unlocking Cells in a Protected Worksheet

When the Locked option is unchecked, selected cells are unlocked. Unlocked cells can be edited even though the overall worksheet is protected. This way, you can protect formulas and labels while still allowing data entry in other areas. The unlocked portion of the worksheet is referred to as the changes area. You must unlock the cells before protecting the worksheet.

**TIP!**
For rapid data entry into unlocked cells, tap [Tab] after entering data in each. When you reach the end of a row in the changes area and tap [Tab], the insertion point wraps to the next row.

To Lock or Not to Lock?

If your worksheet contains only a few cell ranges that users are allowed to change, unlock those cells. The rest of the worksheet will remain locked when you turn on worksheet protection. If most of the worksheet needs to be accessible for updating, you may want to use the Select All option and unlock all cells and then lock just the cells you want to protect.
Develop Your Skills EA8-D3

In this exercise, you will unlock cells that require modification to complete the bond amortization schedule. You will then protect the worksheet so only the unlocked cells can be modified.

1. Save your file as: EA8-D3-Bond-[YourName]
2. Highlight the ranges C3:C8 and B16:G27 and choose Home→Cells→Format→Lock Cell.
   As these cells were locked by default, they are now unlocked.
3. Highlight the range C11:C13, right-click, and choose Format Cells.
   The Format Cells dialog box opens.
4. Switch to the Protection tab, check the box for Hidden, and click OK.
5. Choose Review→Changes→Protect Sheet, enter Interest as the password, and click OK; confirm the password in the next dialog box.
6. Select cell C12.
   Notice that the Formula Bar is empty. This cell is in the range for which the Hidden option was selected.
7. Type any letter in cell E2.
   You did not unlock this particular cell prior to protecting the worksheet, so a warning message displays to indicate that you cannot type in this cell.
8. Click OK to close the warning message.
9. Use the right-click method to change the name of the Sheet1 tab to Bond Schedule.
   The worksheet is protected but the workbook remains unprotected; therefore, the workbook structure, including the worksheet tab names, can be modified.
10. Save your file.

Using Macros

A macro is a recorded set of mouse and keyboard actions that can be played back at any time. Macros are useful for automating routine tasks, especially lengthy tasks. Be aware that macros can contain viruses, so be cautious about opening workbooks containing macros you receive from others.

Security Levels

You change macro security in the Trust Center section of Excel Options. The setting there is in effect for all workbooks opened on your computer. The setting is not embedded in any workbooks that you save and share with others.
You can choose among four levels of security that control whether macros in an opened workbook are available or disabled:

- **Disable All Macros Without Notification**: Only macros in workbooks that you place in a trusted location of the Trust Center will run. All other digitally signed and unsigned macros are disabled.

- **Disable All Macros with Notification**: This is the default option. It displays a message allowing you to enable macros in the specified workbook if you wish or use the workbook without enabling macros.

- **Disable All Macros Except Digitally Signed Macros**: This option automatically disables unsigned macros and enables macros from publishers previously added as a trusted publisher in the Trust Center.

- **Enable All Macros**: You are not protected from potentially unsafe macros. This option is not recommended for general use.

If you have antivirus software installed, the file will be scanned for viruses before it is opened regardless of the security level set.

**NOTE!** Your network system administrator may set macro security and prevent users from changing it.

File → Options → Trust Center → Trust Center Settings → Macro Settings

### Recording Macros

Excel’s macro recording feature is similar to a video camera. You turn it on, record your actions, and then stop the recorder. You can play back the recorded keystrokes and mouse actions as many times as you want.

1. When a macro is recording, the Stop Recording button appears on the status bar.

2. After a first macro has been recorded, you can click this icon on the status bar to record subsequent macros.

View → Macros → View Macros → Record Macro

### Naming a Macro

You can add custom names for your macros or use Excel’s default names (Macro1, Macro2, etc.). Macro names cannot contain spaces but can include capital letters and underscores.
Recording Macro Steps

Most actions—including mouse actions, choosing Ribbon commands, selecting options in dialog boxes, using arrow keys to navigate, and typing text—are recorded in a macro. Any mistakes and corrections you make during recording also are saved. If the final result is correct, you can include the mistakes and their corrections in the macro; otherwise, just rerecord the macro using the proper actions.

TIP! Practice the procedure you wish to automate before recording the macro to reduce the risk of making mistakes during the recording process.

Storing Macros

Macros are available only in the workbook in which you create them unless you assign them to the Personal Macro Workbook, which is a hidden file used to make macros available to all open workbooks. Some macros are useful only in a particular workbook. For these macros, choose the This Workbook storage option. Other macros can benefit multiple workbooks, and these are the ones to assign to the Personal Macro Workbook.

Saving a Workbook Containing Macros

If you attempt to save a workbook containing macros using the normal Excel Workbook file format, Excel displays the message: “The following features cannot be saved in macro-free workbooks: VB Project.” Clicking No in the message box displays the Save As dialog box, where you should choose the Excel Macro-Enabled Workbook file format. The file is saved with the extension .xlam to indicate that it contains a macro.
Running Macros

You can run macros from the Macro dialog box, but they’re much more accessible if you assign them to shortcut keys, custom buttons or graphics on a worksheet, or buttons on the Quick Access toolbar.

View → Macros → View Macros | Alt + F8

Develop Your Skills EA8-D4

In this exercise, you will record a macro that will complete the bond amortization schedule. You will then run the macro.

1. Save your file as: EA8-D4-Bond-[YourName]
2. Choose File → Options → Trust Center → Trust Center Settings → Macro Settings, ensure that Disable All Macros with Notification is selected, and click OK twice.
3. Highlight the range C16:G27 and tap Delete.
   You will now re-create the bond amortization schedule while recording a macro, which can be saved and used later when completing subsequent schedules.
4. Choose View → Macros → Macros → Record Macro to open the Record Macro dialog box.
5. Enter Amortization Schedule as the macro name and click OK.
6. Select cell F16, type =C12-C11 and tap Tab, and then type =C11 and tap Enter.
7. Select cell C17, type =$C$13 and tap Tab, type =G16*$C$6/$C$8 and tap Tab, type =D17-C17 and tap Tab, type =F16-E17 and tap Tab, and then type =G16+E17 and tap Enter.
8. Highlight the range C17:G17 and drag the fill handle through row 26.
9. In cell C27, enter: =SUM(C17:C26)
10. Copy cell C27, paste in the range D27:E2, and tap Esc.
11. Choose View → Macros → Macros → Stop Recording.
12. Delete the contents of the range C16:G27.
   You will now run the macro to ensure that it was properly recorded. In doing so, you will repopulate the bond amortization schedule.
13. Choose View → Macros → Macros and click Run.
   The bond amortization schedule is once again complete.
14. Choose Review → Changes → Unprotect Sheet and then type Interest and tap Enter.
   You have temporarily unprotected the sheet so you can insert a text box.
15. Choose Insert → Illustrations → Shapes and click Text Box in the Basic Shapes section.
16. Click near the top-left corner of cell E2 and drag to the bottom right of cell E5 to create a text box over the range E2:E5.
17. Type Populate Schedule and format the text with bold and a 16-point font size.
What Are the Benefits of Using Excel to Create a Bond Amortization Schedule?

There are a few characteristics of a bond amortization schedule that make it ideal for completion in Excel. You have seen how financial functions can streamline bond-related calculations. More important, because the body of the schedule requires identical formulas in multiple rows, using macros is ideal. As a result, only a small number of items must be entered (effective interest rate, number of periods, etc.) before the automated portion can be completed, allowing for the use of protection throughout the majority of the worksheet.

As macros can be assigned to worksheet objects, Excel provides a simple forum for the automatic completion of a bond amortization schedule. This allows novice users to benefit from the full power of Excel without extensive knowledge of the program. Once the macro has been created, any user can easily employ it. This level of accessibility for all users is rare within accounting-related programs.

The use of workbook and/or worksheet protection also ensures that novice users do not accidentally introduce errors in a worksheet. Again, Excel is unique in its extensive ability to limit user access solely to the few elements that require modification. The result of using both macros and workbook/worksheet protection is that a relatively complex schedule, such as that for bond amortization, can be efficiently completed by users with relatively little experience in the program.
Self-Assessment

Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment here or in your eLab course.

1. The PMT, PV, and FV functions are displayed in the Financial section of the Insert Function dialog box.  
   True  False

2. In the PMT, PV, and FV functions, the interest rate argument is always expressed in annual terms.  
   True  False

3. The number 1 represents the default entry for the type argument in PMT, PV, and FV functions.  
   True  False

4. Cell references CANNOT be used with PV and FV functions.  
   True  False

5. In Excel 2016, the Windows protection option has been disabled.  
   True  False

6. The Protect Sheet command can be accessed on the Review and Home tabs.  
   True  False

7. When protecting a worksheet, you must create a password.  
   True  False

8. The [Tab] key can be used to move through unlocked cells in a worksheet.  
   True  False

9. All worksheet cells are unlocked by default.  
   True  False

10. Macro names CANNOT include spaces.  
    True  False

11. Interest rates, including the effective interest rate and contract interest rate, are typically expressed in ______ terms.
    A. weekly  
    B. monthly  
    C. semiannual  
    D. annual

12. For a bond, which formula argument represents a payment and requires the inclusion of a negative sign before the argument to reverse its sign within financial formulas?
    A. Rate  
    B. Future Value  
    C. Present Value  
    D. Periods

13. What is the optional argument for PMT, PV, and FV functions?
    A. Rate  
    B. Periods  
    C. Payment  
    D. Type

14. What is the first argument in the PV function?
    A. Type  
    B. Periods  
    C. Rate  
    D. Payment
15. Which of these is NOT an available level of protection in Excel?
   A. Excel-level protection
   B. Workbook-level protection
   C. Worksheet-level protection
   D. Cell-level protection

16. When the Hidden option on the Protection tab of the Format Cells dialog box is checked, what is NOT
    displayed in the worksheet?
   A. Formulas
   B. Labels
   C. Values
   D. Formula Results

17. Which of these is NOT an option in the Protect Sheet dialog box?
   A. Select unlocked cells
   B. Format rows
   C. Select locked sheets
   D. Insert hyperlinks

18. On what tab is the Record Macro option found?
   A. Insert
   B. Formulas
   C. Data
   D. View

19. Which of these is NOT an available level of security in Excel?
   A. Disable all macros
   B. Disable all macros except digitally signed macros
   C. Disable all macros with notification
   D. Disable all macros without notification

20. Which of these CANNOT be used to run a macro?
   A. Shortcut keys
   B. Custom buttons
   C. Quick Access toolbar
   D. Page Layout tab
In this exercise, you will complete a bond amortization schedule for Electronics Warehouse. You will calculate the bond characteristics and generate a schedule with key components. You will also protect worksheet elements and create a macro.

The bond is issued on 1/1/11 and has a $200,000 face value, a twelve-year life, semiannual interest payments, a contract interest rate of 8%, and an effective interest rate of 7%.

1. Open a Blank Workbook and save the file in your Chapter 08 folder as: EA8-R1-Bond-[YourName]
2. Prepare the worksheet as indicated:
   • Set the width of column A to 0.75 and the height of row 1 to 7.2.
   • Merge and center the range B2:C2, add bold formatting, and enter: Bond Details
   • In order, enter these headers in the range B3:B8: Date, Face Value, Contract Rate, Effective Rate, Life (years), Payments per Year
   • Apply center alignment to the range C3:C8.

Now you are ready to begin populating the worksheet with the bond data.

3. Enter this data and apply any indicated formatting:

<table>
<thead>
<tr>
<th>In this cell</th>
<th>Type this:</th>
<th>And add this formatting:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell C3</td>
<td>1/1/11</td>
<td></td>
</tr>
<tr>
<td>Cell C4</td>
<td>200000</td>
<td>Accounting number format</td>
</tr>
<tr>
<td>Cell C5</td>
<td>.08</td>
<td>Percent style</td>
</tr>
<tr>
<td>Cell C6</td>
<td>.07</td>
<td>Percent style</td>
</tr>
<tr>
<td>Cell C7</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>Cell C8</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

4. Highlight the range B2:C8 and choose Home→Font→Borders ▼→Outside Borders; apply an outside border around cell B2.
5. Autofit column B and then highlight the range C3:G3 and set the column width to 15.
6. Merge and center the range B10:C10, add bold formatting and outside borders, and enter: Bond Calculations
7. Enter this data:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell B11</td>
<td>Present Value</td>
</tr>
<tr>
<td>Cell C11</td>
<td>=PV(C6/C8, C7<em>C8, -C4</em>C5/C8, -C4)</td>
</tr>
<tr>
<td>Cell B12</td>
<td>Future Value</td>
</tr>
<tr>
<td>Cell C12</td>
<td>=-FV(C6/C8, C7<em>C8, -C4</em>C5/C8, C11)</td>
</tr>
<tr>
<td>Cell B13</td>
<td>Payment</td>
</tr>
</tbody>
</table>
8. In cell C13, choose Formulas→Function Library→Insert Function, select the Financial category and the PMT function, and click OK.

9. Fill in the Function Arguments box as indicated, clicking OK when finished:
   - Rate box: C6/C8
   - Nper box: C7*C8
   - Pv box: C11
   - Fv box: –C4

10. With cell C13 still active, click in the Formula Bar between the equals sign and PMT and type a minus sign.

11. Apply the Accounting number format to the range C11:C13 and add an outside border around the range B10:C13.

Complete the Amortization Schedule

12. In the range B15:G15, set text wrapping and center alignment, apply an outside border, and add bold formatting.

13. In order, enter these headers in the range B15:G15: Date, Interest Payment, Interest Expense, Amortization of Bond Premium, Bond Premium Balance, Carrying Value


15. Highlight the range B17:B18 and then drag the fill handle through cell B40.

16. In cell B41, type Totals and right-align the text.

17. Enter this data:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell F16</td>
<td>=C11-C12</td>
</tr>
<tr>
<td>Cell G16</td>
<td>=C11</td>
</tr>
<tr>
<td>Cell C17</td>
<td>=$C$13</td>
</tr>
<tr>
<td>Cell D17</td>
<td>=G16*$C$6/$C$8</td>
</tr>
<tr>
<td>Cell E17</td>
<td>=C17-D17</td>
</tr>
<tr>
<td>Cell F17</td>
<td>=F16-E17</td>
</tr>
<tr>
<td>Cell G17</td>
<td>=G16-E17</td>
</tr>
</tbody>
</table>

18. Copy the range C17:G17 and paste to the range C18:G40.

19. Highlight the range C41:E41 and choose Home→Editing→AutoSum; choose Home→Font→Borders ▼→Top and Double Bottom Border.

20. Apply the Accounting number format to the range C16:G41.

Protect a Workbook and a Worksheet

21. Choose Review→Changes→Protect Workbook and, if necessary, add a checkmark in the Structure checkbox.

22. Enter Protected as the password and click OK; confirm the password when prompted.

23. Choose Review→Changes→Protect Workbook, enter the password, and click OK.
24. Choose **Home**→**Cells**→**Format**→**Protect Sheet** and, as necessary, add checkmarks next to the boxes for these options and click **OK** when finished:

- Protect Worksheet and Contents of Locked Cells
- Select Locked Cells
- Select Unlocked Cells
- Format Columns

25. Use a Ribbon command to set the width of **cell C17** to **12**.

26. Choose **Review**→**Changes**→**Unprotect Sheet**.

**Protect Individual Cells**

27. Highlight the **ranges C3:C8** and **B16:G41** and choose **Home**→**Cells**→**Format**→**Lock Cell**.

28. Highlight the **range C11:C13**, right-click, and choose **Format Cells**.

29. Switch to the **Protection** tab, check the box for **Hidden**, and click **OK**.

30. Choose **Review**→**Changes**→**Protect Sheet** and add the password **Worksheet**, confirming the password when prompted.

31. In **cell G7**, type **k** and then click **OK** in the dialog box.

32. Rename the **Sheet1** tab to **Bond Schedule**.

**Record and Run a Macro**

33. Choose **File**→**Options**→**Trust Center**→**Trust Center Settings**→**Macro Settings**, ensure that **Disable All Macros with Notification** is selected, and click **OK** twice.

34. Delete the contents of the **range C16:G41**.

35. Choose **View**→**Macros**→**Macros**→**Record Macro**, enter **Amortization Schedule** as the macro name, and click **OK**.

36. Complete these actions in order for the new macro:

- Select **cell F16**, type **=C11-C12** and tap [Tab], and then type **=C11** and tap [Enter].
- Select **cell C17**, type **=$C$13** and tap [Tab], type **=G16*$C$6/$C$8** and tap [Tab], type **=C17-D17** and tap [Tab], type **=F16-E17** and tap [Tab], and then type **=G16-E17** and tap [Enter].
- Highlight the **range C17:G17** and drag the fill handle through **row 40**.
- Enter **=SUM(C17:C40)** in **cell C41**.
- Copy **cell C41** to the **range D41:E41** and tap [Esc].

37. Click the **Stop Recording** button in the status bar.

38. Delete the contents of the **range C16:G41** then choose **View**→**Macros**→**Macros** and click **Run**.

39. Choose **Review**→**Changes**→**Unprotect Sheet**, enter the password **Worksheet**, and tap [Enter].

40. Choose **Insert**→**Illustrations**→**Shapes**, click the **Text Box** shape, and draw a text box over the **range E2:E5**.

41. Type **Populate Schedule** in the text box, add italic formatting, and set the font size to **16**.
42. Right-click the text box, choose Assign Macro, click Amortization_Schedule in the list, and click OK.

43. Choose Review→Changes→Protect Sheet and enter Finalized as the password, confirming when prompted.

44. Delete the contents of the range C16:G41 and then click the text box to run the macro.

45. Save your file as a Macro-Enabled Workbook and then close it.

EA8-R2 Create a Bond Amortization Schedule for Software Developers Co.

In this exercise, you will complete a bond amortization schedule for Software Developers Co. You will calculate the bond characteristics and generate a schedule with key components. You will also protect worksheet elements and create a macro.

The bond is issued on 1/1/13 and has a $180,000 face value, a four-year life, quarterly interest payments, a contract interest rate of 9%, and an effective interest rate of 10%.

1. Open a Blank Workbook and save the file in your Chapter 08 folder as: EA8-R2-Bond-[YourName]

2. Prepare the worksheet as indicated:
   • Set the width of column A to 0.75 and the height of row 1 to 7.2.
   • Merge and center the range B2:C2, add bold formatting, and enter: Bond Details
   • In order, enter these headers in the range B3:B8: Date, Face Value, Contract Rate, Effective Rate, Life (years), Payments per Year
   • Apply center alignment to the range C3:C8.

Now you are ready to begin populating the worksheet with the bond data.

3. Enter this data and apply any indicated formatting:

<table>
<thead>
<tr>
<th>In this cell:</th>
<th>Type this:</th>
<th>And add this formatting:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell C3</td>
<td>1/1/13</td>
<td></td>
</tr>
<tr>
<td>Cell C4</td>
<td>180000</td>
<td>Accounting number format</td>
</tr>
<tr>
<td>Cell C5</td>
<td>.09</td>
<td>Percent Style</td>
</tr>
<tr>
<td>Cell C6</td>
<td>.1</td>
<td>Percent Style</td>
</tr>
<tr>
<td>Cell C7</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Cell C8</td>
<td>4</td>
<td></td>
</tr>
</tbody>
</table>

4. Highlight the range B2:C8 and choose Home→Font→Borders ▼→Outside Borders; apply an outside border around cell B2.

5. Highlight the range B3:G3 and use the Ribbon to change the column width to 15.

6. Merge and center the range B10:C10, add bold formatting and outside borders, and enter: Bond Calculations
7. Enter this data:

<table>
<thead>
<tr>
<th>Cell B11</th>
<th>Present Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell C11 =PV(C6/C8, C7<em>C8, -C4</em>C5/C8, -C4)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cell B12</th>
<th>Future Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell C12 =-FV(C6/C8, C7<em>C8, -C4</em>C5/C8, C11)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cell B13</th>
<th>Payment</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8. In cell C13, choose Formulas→Function Library→Insert Function, select the Financial category and the PMT function, and click OK.

9. Fill in the Function Arguments box as indicated, clicking OK when finished:
   - Rate box: C6/C8
   - Nper box: C7*C8
   - Pv box: C11
   - Fv box: -C4

10. With cell C13 still active, click in the Formula Bar between the equals sign and PMT and type a minus sign.

11. Apply the Accounting number format to the range C11:C13 and add outside borders to the range B10:C13.

**Complete the Amortization Schedule**

12. In the range B15:G15, set text wrapping and center alignment, apply an outside border, and add bold formatting.

13. In order, enter these headers in the range B15:G15: Date, Interest Payment, Interest Expense, Amortization of Bond Discount, Bond Discount Balance, Carrying Value


15. Highlight the range B17:B20 and then drag the fill handle through cell B32.

16. In cell B33, type Totals and right-align the text.

17. Enter this data:

<table>
<thead>
<tr>
<th>Cell F16</th>
<th>=C12-C11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell G16</td>
<td>=C11</td>
</tr>
<tr>
<td>Cell C17</td>
<td>=$C$13</td>
</tr>
<tr>
<td>Cell D17</td>
<td>=$G16*$C6/$C8</td>
</tr>
<tr>
<td>Cell E17</td>
<td>=D17-C17</td>
</tr>
<tr>
<td>Cell F17</td>
<td>=F16-E17</td>
</tr>
<tr>
<td>Cell G17</td>
<td>=G16+E17</td>
</tr>
</tbody>
</table>

18. Copy the range C17:G17 and paste to the range C18:G32.

19. Highlight the range C33:E33, choose Home→Editing→AutoSum, and choose Home→Font→Borders ▼→Top and Double Bottom Border.

20. Apply the Accounting number format to the range C16:G33.
Protect a Workbook and a Worksheet

21. Choose **Review**→**Changes**→**Protect Workbook** and, if necessary, add a checkmark in the **Structure** checkbox; click **OK**.

22. Turn off protection by choosing **Review**→**Changes**→**Protect Workbook**.

23. Choose **Home**→**Cells**→**Format**→**Protect Sheet** and, as necessary, add checkmarks in the boxes next to these options:
   - Protect Worksheet and Contents of Locked Cells
   - Select Locked Cells
   - Select Unlocked Cells
   - Format Columns

24. Enter **Accounting** as the password and click **OK**; confirm the password when prompted.

25. Use the right-click method to change the width of **column C** to **12** and then autofit **column B**.

26. Choose **Review**→**Changes**→**Unprotect Sheet**, enter the password, and click **OK**.

Protect Individual Cells

27. Highlight the **ranges C3:C8** and B16:G33 and choose **Home**→**Cells**→**Format**→**Lock Cell**.

28. Highlight the **range C11:C13**, right-click, and choose **Format Cells**.

29. Switch to the **Protection** tab, check the box for **Hidden**, and click **OK**.

30. Choose **Review**→**Changes**→**Protect Sheet** and add the password **Excel** (confirming when prompted).

31. In cell **G7**, type **w** and then click **OK** in the dialog box.

32. Rename the **Sheet1** tab to **Bond Schedule**.

Record and Run a Macro

33. Choose **File**→**Options**→**Trust Center**→**Trust Center Settings**→**Macro Settings**, ensure that **Disable All Macros with Notification** is selected, and click **OK** twice.

34. Delete the contents of the **range C16:G33**.

35. Choose **View**→**Macros**→**Record Macro**, enter **Amortization_Schedule** as the macro name, and click **OK**.

36. Complete these actions in order for the macro:
   - Select **cell F16**, type **=C12-C11** and tap **[Tab]**, and then type **=C11** and tap **[Enter]**.
   - Select **cell C17**, type **=$C$13** and tap **[Tab]**, type **=G16*$C$6/$C$8** and tap **[Tab]**, type **=D17-C17** and tap **[Tab]**, type **=F16-E17** and tap **[Tab]**, and then type **=G16+E17** and tap **[Enter]**.
   - Highlight the **range C17:G17** and drag the fill handle through **row 32**.
   - Enter **=SUM(C17:C32)** in **cell C33**.
   - Copy **cell C33** to the **range D33:E33** and tap **[Esc]**.

37. Click the **Stop Recording** button in the status bar.
38. Delete the contents of the range C16:G33 and then choose View→Macros→Macros and click Run.

39. Choose Review→Changes→Unprotect Sheet and then enter the password Excel and tap [Enter].

40. Choose Insert→Illustrations→Shapes, click the Text Box shape, and draw a text box over the range E2:E5.

41. Type Populate Schedule in the text box, add bold formatting, and set the font size to 16.

42. Right-click the text box, choose Assign Macro, click Amortization_Schedule in the list, and click OK.

43. Choose Review→Changes→Protect Sheet and enter Macro as the password, confirming when prompted.

44. Delete the contents of the range C16:G33 and then click the text box to run the macro.

45. Save your file as a Macro-Enabled Workbook and then close it.
Apply Your Skills

EA8-A1 Create a Bond Amortization Schedule for Kim’s Kitchen

In this exercise, you will complete a bond amortization schedule for Kim’s Kitchen. You will calculate the bond characteristics and generate a schedule with key components. You will also protect worksheet elements and create a macro.

The bond is issued on 1/1/10 and has a $120,000 face value, a seven-year life, semiannual interest payments, a contract interest rate of 12%, and an effective interest rate of 10%.

1. Open a Blank Workbook and save the file in your Chapter 08 folder as: EA8-A1-Bond-[YourName]
2. Change the width of column A to 0.75 and the height of row 1 to 7.2.
3. Merge and center the range B2:C2, type Bond Details in the merged cell, and bold the entry.
4. In the range B3:B8, enter the descriptions Date, Face Value, Contract Rate, Effective Rate, Life (years), and Payments per Year.
5. Enter the bond details in the range C3:C8; center these entries.
6. Apply borders to the appropriate locations in the range B2:C8.
7. Adjust the column width of columns B:G to 15.
8. Merge and center the range B10:C10, type Bond Calculations in the merged cell, and bold the entry.
9. In the range B11:B13, enter the descriptions Present Value, Future Value, and Payment.
10. In the range C11:C13, enter appropriate formulas that contain solely cell references and apply the Accounting number format.
11. Apply borders to the appropriate locations in the range B10:C13.

Complete the Amortization Schedule

12. In the range B15:G15, set text wrapping and center alignment, apply an outside border, and add bold formatting.
13. In the range B15:G15, enter the column descriptions for the bond amortization schedule.
14. In the range B16:B18, enter dates for the bond issuance and the first two interest payments.
15. Apply additional dates as appropriate in column B.
16. Type appropriate formulas in the necessary cells in rows 16–17 of the bond amortization schedule.
17. Copy the formulas in row 17 to the remaining rows in the bond amortization schedule.

18. In column B below the final populated row of the bond amortization schedule, enter Totals and right-align the text.

19. Use AutoSum in the Totals row to calculate the appropriate columns and apply the Accounting number format.

20. Add appropriate borders to the entire bond amortization schedule.

**Protect a Workbook and a Worksheet**

21. Use the Protect Workbook command and apply a password.

22. Turn off workbook protection.

23. Use the Protect Worksheet command, ensuring that all cells can be selected and all columns can be formatted while worksheet protection is on; apply a password.

24. Set the width of column C to 12 and autofit the width of column B.

25. Turn off worksheet protection.

**Protect Individual Cells**

26. Toggle off the Lock Cell command for all cells in the Bond Details and bond amortization schedule sections.

27. Hide the formulas in the Bond Calculations section.

28. Use the Protect Sheet command, ensuring that all cells can be selected while worksheet protection is on; apply a password.

29. Rename the worksheet to Bond Schedule.

**Record and Run a Macro**

30. Ensure that Disable All Macros with Notification is the active macro setting.

31. Delete all data in the bond amortization schedule except the dates and headers.

32. Record a macro that populates the bond amortization schedule, applying an appropriate name for the macro.

33. Delete all data in the bond amortization schedule except the dates and headers and then run your macro.

34. Unprotect the worksheet.

35. Insert a text box from which to run the macro in an appropriate location and add an appropriate name in bold; assign your macro to the text box.

36. Use the Protect Sheet command, ensuring that all cells can be selected while worksheet protection is on; apply a password.

37. Delete all data in the bond amortization schedule except the dates and headers and then use the text box to run your macro.

38. Save your file as a Macro-Enabled Workbook and then close it.
Create a Bond Amortization Schedule for Cubby Manufacturing

In this exercise, you will complete a bond amortization schedule for Cubby Manufacturing. You will calculate the bond characteristics and generate a schedule with key components. You will also protect worksheet elements and create a macro.

The bond is issued on 1/1/12 and has a $60,000 face value, a five-year life, quarterly interest payments, a contract interest rate of 12%, and an effective interest rate of 14%.

1. Open a Blank Workbook and save the file in your Chapter 08 folder as: EA8-A2-Bond-[YourName]
2. Change the width of column A to 0.75 and the height of row 1 to 7.2.
3. Merge and center the range B2:C2, type Bond Details in the merged cell, and bold the entry.
4. In the range B3:B8, enter the descriptions Date, Face Value, Contract Rate, Effective Rate, Life (years), and Payments per Year.
5. Enter the bond details in the range C3:C8; center these entries.
6. Apply borders to the appropriate locations in the range B2:C8.
7. Adjust the column width of columns B:G to 15.
8. Merge and center the range B10:C10, type Bond Calculations in the merged cell, and bold the entry.
9. In the range B11:B13, enter the descriptions Present Value, Future Value, and Payment.
10. In the range C11:C13, enter appropriate formulas that contain solely cell references and apply the Accounting number format.
11. Apply borders to the appropriate locations in the range B10:C13.

Complete the Amortization Schedule

12. In the range B15:G15, set text wrapping and center alignment, apply an outside border, and add bold formatting.
13. In the range B15:G15, enter the column descriptions for the bond amortization schedule.
14. In the range B16:B20, enter dates for the bond issuance and the first four interest payment dates.
15. Apply additional dates as appropriate in column B.
16. Type appropriate formulas in the necessary cells in rows 16-17 of the bond amortization schedule.
17. Copy the formulas in row 17 to the remaining rows in the bond amortization schedule.
18. In column B below the final populated row of the bond amortization schedule, enter Totals and right-align the text.
19. Use AutoSum in the Totals row to calculate the appropriate columns and apply the Accounting number format.

20. Add appropriate borders to the entire bond amortization schedule.

**Protect a Workbook and a Worksheet**

21. Use the Protect Workbook command and apply a password.

22. Turn off workbook protection.

23. Use the Protect Worksheet command, ensuring that all cells can be selected and all columns can be formatted while worksheet protection is on; apply a password.

24. Set the width of column C to 12 and autofit the width of column B.

25. Turn off worksheet protection.

**Protect Individual Cells**

26. Toggle off the Lock Cell command for all cells within the Bond Details and bond amortization schedule sections.

27. Hide the formulas in the Bond Calculations section.

28. Use the Protect Sheet command, ensuring that all cells can be selected while worksheet protection is on; apply a password.

29. Rename the worksheet to: Bond Schedule

**Record and Run a Macro**

30. Ensure that Disable All Macros with Notification is the active macro setting.

31. Delete all data in the bond amortization schedule except the dates and headers.

32. Record a macro that populates the bond amortization schedule, applying an appropriate name for the macro.

33. Delete all data in the bond amortization schedule except the dates and headers and then run your macro.

34. Unprotect the worksheet.

35. Insert a text box from which to run the macro in an appropriate location and add an appropriate name in italic; assign your macro to the text box.

36. Use the Protect Sheet command, ensuring that all cells can be selected while worksheet protection is on; apply a password.

37. Delete all data in the bond amortization schedule except the dates and headers and then run your macro.

38. Save your file as a Macro-Enabled Workbook and then close it.
Extend Your Skills

EA8-E1 Complete a Bond Amortization Schedule for
townline Construction

In this exercise, you will complete a bond amortization schedule for Townline Construction. You will calculate the bond characteristics and generate a schedule with key components. You will protect worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details for a bond with a $260,000 face value, a four-year life, semiannual interest payments, a contract interest rate of 10%, and an effective interest rate of 11%. The bond is issued on 1/1/13. (Hint: Values must be entered here so they can be used in subsequent formulas.)

Enter bond calculations for the present and future values and the payments in the range B10:C13. The future value and payment calculations will generate results that match figures given above; you complete these calculations to check your work. Create a bond amortization schedule beginning in cell B15. Use headers that are consistent with those used in this chapter. Calculate totals for the appropriate columns. Assign an appropriate name to the worksheet tab.

Record a macro that generates every formula in the worksheet after the bond details (in the range B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box in an appropriate location, add an appropriate name in the text box, and assign the macro to this text box.

Protect the workbook structure and apply a password. Modify cell protection for all cells containing formulas in column G such that formulas are hidden. Then protect the worksheet by only allowing users to select locked and unlocked cells; insert hyperlinks and apply a password.

Save your file as a Macro-Enabled Workbook.

EA8-E2 Complete a Bond Amortization Schedule for
Stationery Specialists

In this exercise, you will complete a bond amortization schedule for Stationery Specialists. You will calculate the bond characteristics and generate a schedule with key components. You will protect worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details for a bond with a $140,000 face value, a six-year life, quarterly interest payments, a contract interest rate of 8%, and an effective interest rate of 7%. The bond is issued on 1/1/11. (Hint: Values must be entered here so they can be used in subsequent formulas.)
Enter bond calculations for the present and future values and the payments in the range B10:C13. The future value and payment calculations will generate results that match figures given above; you complete these calculations to check your work. Create a bond amortization schedule beginning in cell B15. Use headers that are consistent with those used in this chapter. Calculate totals for the appropriate columns. Assign an appropriate name to the worksheet tab.

Record a macro that generates every formula in the worksheet after the bond details (in the range B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box in an appropriate location, add an appropriate name in the text box, and assign the macro to this text box.

Protect the workbook such that worksheets cannot be reordered, copied, or deleted. Modify cell protection for all cells containing formulas in column G such that the formulas are hidden. Protect the worksheet by allowing users to format only cells, columns, and rows; apply a password.

Save your file as a Macro-Enabled Workbook.

---

**EA8-E3 Complete a Bond Amortization Schedule for Dan’s Refinishing**

In this exercise, you will complete a bond amortization schedule for Dan’s Refinishing. You will calculate the bond characteristics and generate a schedule with key components. You will protect worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details for a bond with a $200,000 face value, an eight-year life, semiannual interest payments, a contract interest rate of 7%, and an effective interest rate of 9%. The bond is issued on 1/1/09. (Hint: Values must be entered here so they can be used in subsequent formulas.)

Enter bond calculations for the present and future values and the payments in the range B10:C13. The future value and payment calculations will generate results that confirm figures given above; you complete these calculations to check your work. Create a bond amortization schedule beginning in cell B15. Use headers that are consistent with those used in this chapter. Calculate totals only for the appropriate columns. Assign an appropriate name to the worksheet tab.

Record a macro that generates every formula in the worksheet after the bond details (in the range B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box in an appropriate location, add an appropriate name in the text box, and assign the macro to this text box.

Protect the workbook such that the worksheets cannot be copied, reordered, or deleted. Apply a password when protecting the workbook. Modify cell protection for all cells containing formulas in columns F:G such that the formulas are hidden. Then protect the worksheet by only allowing users to sort data.

Save your file as a Macro-Enabled Workbook.
Critical Thinking

EA8-C1 Discuss Worksheet Protection

Protection can be used at multiple levels to protect workbooks, worksheets, and individual cells. In the case of the bond amortization schedule, this protection ensures that users adjust only certain cells and cannot inadvertently alter elements that should remain static. However, a bond amortization schedule is not the only worksheet for which protection is appropriate. Depending on factors such as the frequency with which a worksheet is disseminated and the number of users with access to the file, various levels of protection can be beneficial for many of the accounting-related spreadsheets.

Write a paragraph of at least five sentences to identify four types of accounting worksheets (other than the bond amortization schedule) within which some level of protection would be appropriate. Write a second paragraph of at least eight sentences to discuss why that protection is appropriate and what level of protection you would implement for each.

EA8-C2 Discuss Macros and Worksheet Automation

Efficiency is a key goal when completing any Excel worksheet. As the size and scope of the schedule grow, taking an efficient approach to populating it becomes increasingly vital. In the case of the bond amortization schedule, you have seen how macros can be used to complete the entire body of the schedule. Macros can similarly be used in other accounting-related spreadsheets that contain repetitious and/or predictable elements.

Consider how macros can be used to increase efficiency. Write a paragraph of at least four sentences in which you identify three accounting-related spreadsheets (other than the bond amortization schedule) that can benefit from the use of macros. Write a second paragraph of at least five sentences to discuss how macros can be used in each worksheet to improve the manner in which they are populated.