
In this lesson, you will learn about Excel 
features that can help you perform 
sophisticated data analyses. These 

features include the VLOOKUP and 
HLOOKUP functions, PivotTables, and 
PivotCharts. With the VLOOKUP and 
HLOOKUP functions, you use one piece of 
information to obtain another within a list. 
PivotTables let you summarize worksheet 
data dynamically so it can be viewed in 
various ways. PivotCharts provide this 
same power and flexibility within charts. 
Additionally, since many Excel workbooks 
are used on a recurring basis, with the 
same tasks being performed repeatedly, 
you will also create macros that can 
automate repetitive tasks.

L E A R N I N G  O B J E C T I V E S
After studying this lesson, you will be able to:

■■ Create a lookup formula to locate a value or text 
in a list

■■ Create PivotTables and change their fields

■■ Create PivotCharts from PivotTable and 
worksheet data

■■ Set macro security to protect workbook data

■■ Record and run macros to automate tasks

L E S S O N  T I M I N G
■■ Concepts/Develop Your Skills: 2 hrs 00 min

■■ Concepts Review: 15 min

■■ Total: 2 hrs 15 min

C A S E  S T U D Y:  A N A LY Z I N G  D ATA 
E F F I C I E N T LY
Green Clean, a janitorial product supplier and 
cleaning service contractor, works in conjunction 
with select charitable entities to raise funds for 
environmental causes. You would like to evaluate 
the overall performance of the company’s 
fundraising team leaders. You would also like to 
examine the results of specific fundraising efforts 
that were overseen by these team leaders during the 
current year. You will use powerful data analysis 
tools—including the VLOOKUP function, 
PivotTables, and PivotCharts—to perform this 
analysis. You will also record macros to automate 
processes that will facilitate the analysis.

1Using LOOKUP Functions, 
PivotTables, and Macros

E X C E L  2 0 1 3

Book-FC3-EX2013.indb   1 11/13/2013   3:04:21 PM

FastCourse Microsoft Excel 2013 FOR  EVALUATION ONLY: LEVEL 3 of 3 (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



2 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Introducing Lookup Functions
The lookup functions VLOOKUP (Vertical Lookup) and HLOOKUP (Horizontal Lookup) are 
used to retrieve a piece of data from a lookup table located within the same worksheet, a 
separate worksheet, or a different workbook.

The same data arranged in a vertical lookup table (left) and a horizontal lookup table (right)

LOOKUP Function Syntax
The structure of the VLOOKUP and HLOOKUP functions is VLOOKUP or HLOOKUP(lookup 
value,table array,column (or row) index number,[range lookup]).

VLOOKUP FUNCTION ARGUMENTS

Argument Description

Lookup value The value in the worksheet to be looked up in the first column of the table array

Table array The cell range containing the lookup table, which may be expressed as absolute cell 
references or a defined name

Column index 
number

The column number in the table array that contains the corresponding data to be 
retrieved

Range lookup Optional; a logical value that specifies a search for an exact or approximate value in 
the table array (TRUE, the default) or an exact match only (FALSE)

How the VLOOKUP Function Works
In the formula =VLOOKUP(D5,Award_Table,2), cell D5 contains the lookup value, the defined 
name Award_Table indicates the table array in which the search takes place, and the number 2 
(the column index number) indicates that the corresponding award rate will be retrieved from 
the second column of the lookup table. The search is conducted down the first column of the 
table array until the highest value not greater than the lookup value is located.
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Introducing Lookup Functions 3

Cell E5 contains the 
VLOOKUP formula.

The Lookup Value

Excel searches the first 
column of the lookup table 
and stops at row 19 because 
the lookup value is at least 
$5,000 but not $10,000.

The award rate of 5% in the  
second column here is returned to cell E5.

When a lookup formula will be copied to other cells, the cell range of the table array should be 
expressed in the formula as a defined name or absolute cell references.

Specifying the Range Lookup Argument
In our example, Excel uses the default range lookup argument TRUE so the search is conducted 
in the first column of the table array for either an exact match of $6,810 or the closest value not 
greater than $6,810. At times, you may want to search only for an exact match of the lookup 
value. The formula =VLOOKUP(D5,Award_Table,2,FALSE) includes the FALSE range lookup 
argument. This restricts the search to an exact match. Using our example, since the first column 
of the table array ($E$16:$F$20) does not contain the exact lookup value of $6,810, Excel would 
display #N/A in the formula cell.

Sorting a Table Array
The rows in the table array must be sorted in lowest to highest (A to Z) order in the first column 
when the TRUE range lookup argument is used. This way, you can be assured that VLOOKUP 
will stop at the proper row and return the correct value. Sorting the table array is not required 
when the FALSE range lookup argument is used. 
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4 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

DEVELOP YOUR SKILLS EX01-D01

Use VLOOKUP
Before You Beegin: Navigate to the student resource center to download the student exercise files for this 
book.

1. Open EX01-D01-Awards from the EX2013 Lesson 01 
folder and save it as EX01-D01-Awards-
[FirstInitialLastName].

2. Display the December worksheet. Complete the table 
array in the range E15:G20 by entering the numbers and 
text shown.

3. Follow these steps to create the range name:

 Select the range E16:G20.

 Type Award_Table 
in the Name box.

 Tap [Enter].

4. Select cell E5 and enter the formula =VLOOKUP(D5,Award_Table,2).

5. Use AutoFill to copy the formula from cell E5 down to the range E6:E12. 

6. Select cell E7 and review the formula in the Formula Bar. 

7. Type =C5*E5 in cell F5 and use AutoFill to copy the commission formula to the range 
F6:F12.
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Introducing Lookup Functions 5

8. Select cell G5, enter the function =VLOOKUP(D5,Award_Table,3), and use AutoFill to 
copy the quota message formula to the range G6:G12.

9. Select cell F16 and change the rate to 1%.

10. Click Undo  to change the entry back to 0% in cell F16.

11. Select cell G16 and change the message to Counsel.

12. Click Undo  to change the entry back to Under Achiever. 

13. Save and then close the file.
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6 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Creating PivotTables
PivotTables are powerful data analysis tools. They let you summarize data in various ways and 
instantly change the view you use. A PivotTable not only subtotals groups of related data; it also 
compares one group to another.

Arranging the Source Data
You create PivotTables from columns or from a table in an Excel worksheet. The data should 
contain no blank rows or columns. Converting a list to a table is recommended when records 
will be added after the PivotTable is created. The additional table data are included 
automatically within the PivotTable when it is refreshed or updated. Data in a list are not 
included automatically. The following examples explain two PivotTables based on the 
worksheet list partially shown here.

The worksheet data

PivotTable Example 1
You can sort the preceding table by pledge level or sponsor category, but you cannot easily 
compare totals for the various pledge levels in each sponsor category. A PivotTable can 
summarize some or all data in any number of ways, and it creates grand totals. Each column in 
a PivotTable is a field. Examine the PivotTable and notice that the Sponsor Category field from 
the table is used for the row labels, the Pledge Level field for the column labels, and the Year 2 
field for the data area and grand totals. Each row displays the amount given by each sponsor 
group in the various pledge levels.

This PivotTable summarizes contributions by sponsor category.
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Creating PivotTables 7

PivotTable Example 2
In this example, data is summarized first by pledge level and then by sponsor category. To create 
this type of view, the PivotTable layout shown in the following illustration contains the Pledge 
Level and then Sponsor Category fields for row labels, no column labels, and the Year 2 field for 
the data area and totals.

This PivotTable layout summarizes contributions 
first by pledge level and then by sponsor category.

How PivotTables Work
Each area of a PivotTable plays a role in data organization. The PivotTable Fields task pane 
displays after you define the worksheet range to be used. The areas of the task pane are 
explained in the following illustration, which displays the settings for PivotTable Example 1.

Here you choose columns that 
will appear in the PivotTable.

Row labels are displayed here.

You can filter fields you 
have chosen by dragging 
them here.

Column labels are 
displayed here.

This area displays 
the field on which a 
calculation is performed 
within the PivotTable.
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8 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Where you place fields within the PivotTable Fields task pane determines how the PivotTable 
summarizes the data. By choosing different fields or dragging and dropping a field, you can 
quickly compare data in various ways. You may choose from several functions—such as SUM, 
COUNT, and AVERAGE—to calculate fields containing values.

DEVELOP YOUR SKILLS EX01-D02

Create PivotTables
1. Open EX01-D02-Sponsors from the EX2013 Lesson 01 folder and save it as EX01-D02-

Sponsors-[FirstInitialLastName].

2. Select cell B4 and choose Insert→Tables→PivotTable.

3. Verify that the table/range agrees with the one displayed here, and then click OK.

4. Rename Sheet1 to PivotTable by Sponsor Category, and then select cell A1. 

5. Select cell A3 to restore the task pane.

6. Follow these steps to define the PivotTable in the task pane:

 Drag the Pledge Level field to the Columns area.

 Place a checkmark 
next to Pledge Level, 
Sponsor Category, 
and Year 2.

Book-FC3-EX2013.indb   8 11/13/2013   3:04:22 PM

FastCourse Microsoft Excel 2013 FOR  EVALUATION ONLY: LEVEL 3 of 3 (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Creating PivotTables 9

7. Choose PivotTable Tools→Analyze→PivotTable→Options. 

8. Type BySponsorCategory in the PivotTable name text box and tap [Enter]. 

9. Display the Sponsors Table worksheet.

10. With any table cell selected, choose Insert→Tables→PivotTable, verify that the 
suggested range is the Sponsors_Table, and click OK. 

11. Rename the new sheet PivotTable by Pledge Level. In the PivotTable Fields task 
pane, place a checkmark next to field names in this order: Pledge Level, Sponsor 
Category, Year 2. 

12. Choose PivotTable Tools→Analyze→PivotTable→Options. 

13. Type ByPledgeLevel in the PivotTable name text box and tap [Enter]. 

14. Save the file and leave it open; you will modify it throughout this lesson.

Book-FC3-EX2013.indb   9 11/13/2013   3:04:23 PM

FastCourse Microsoft Excel 2013 FOR  EVALUATION ONLY: LEVEL 3 of 3 (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



10 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Formatting a PivotTable
Values and subtotals in a PivotTable do not automatically display the formatting from the 
original worksheet cells. You may select and format one or more specific cells in the PivotTable 
using standard Ribbon commands. Alternatively, the PivotTable Tools Design contextual tab 
contains a large selection of PivotTable styles that can be used to quickly apply color, shading, 
and gridlines. The report layout displays in Compact Form by default, but you may choose from 
two other layouts. The subtotals may be displayed at the top or bottom of each group, or can be 
hidden.

Compact form Tabular form

DEVELOP YOUR SKILLS EX01-D03

Format a PivotTable
1. Save your file as EX01-D03-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Sponsor Category worksheet, select the range B4:H4, and 
right-align the labels.

3. Choose PivotTable Tools→Design→Layout→Grand Totals. Experiment by choosing 
each option and observing its result, and then choose On for Rows and Columns.

4. Select any cell in the PivotTable.

5. Follow these steps to format the Year 2 contribution numbers:

 Choose the Number 
category.

	Set 0 in the Decimal 
Places box.

	Place a checkmark 
in the Use 1000 
Separator (,) box.

 Click OK.

 Right-click any number 
in the range B5:H19 and 
choose Number Format.

6. Display the PivotTable by Pledge Level worksheet.

7. Click in the PivotTable, choose PivotTable Tools→Design→PivotTable Styles→More , 
and choose Pivot Style Medium 9. 
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Creating PivotTables 11

8. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Outline 
Form. 

9. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Tabular 
Form. 

10. Choose PivotTable Tools→Design→Layout→Report Layout→Show in Compact 
Form to return to the original layout.

11. Save the file and leave it open.

Changing PivotTable Fields
You may add or remove fields on a PivotTable simply by adding or removing the checkmark next 
to the field name in the PivotTable Fields task pane. The PivotTable will automatically reconfigure 
to display the new data. You may also change the order of fields within the row and column areas. 
One of the most powerful ways of manipulating data is to move a field from the row area to the 
column area or vice versa. This is called pivoting the field (hence the name PivotTable). The display 
of the data field rotates to give you an entirely different view of your data, as illustrated in the two 
PivotTables you created in the previous exercise. There, you positioned the Pledge Level field to 
display as columns in the first PivotTable and as rows in the second.

Pledge Level fields displayed as columns
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12 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Pledge Level fields displayed as rows

DEVELOP YOUR SKILLS EX01-D04

Change PivotTable Fields
1. Save your file as EX01-D04-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Pledge Level worksheet.

3. Place a checkmark next to Year 1 in the task pane to add this field to the PivotTable. 

4. Right-click any cell in the Sum of Year 1 column of the PivotTable and choose Number 
Format.

5. In the Format Cells dialog box, choose the Number category, set 0 decimal places, check 
the Use 1000 Separator (,) option, and click OK.

6. Repeat steps 4–5 to format the Sum of Year 2 column.

7. Drag Sum of Year 2 below Sum of Year 1 in the Values area.
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Creating PivotTables 13

8. Place a checkmark by the Sponsor Name field in the top section of the PivotTable Fields 
task pane.

9. Remove the checkmark by the Sponsor Category and Sponsor Name fields in the 
PivotTable Fields task pane; add a checkmark next to Team Leader.

10. Drag the Team Leader field from the Rows area to the Columns area below the Values 
field.

11. Undo  the pivot.

12. Save the file and leave it open.
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14 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

Filtering a PivotTable with AutoFilter
You may set the PivotTable to filter, or include, specific items in the data summaries. The totals 
and subtotals are recalculated for the selected items. The Row Labels and Column Labels 
headings have an AutoFilter button that displays the same sorting and filtering options that are 
available on the columns of worksheet lists and tables.

The field to be 
filtered The AutoFilter 

button

Additional filtering 
commands, such as 
Begins With and Greater 
Than, are available here.

Select specific 
pledge levels here.

Filtering PivotTables with Slicers
Slicers are menu frames displayed on worksheets that contain all filtering choices in one field. 
Selected items are highlighted in slicers, making it easy to identify currently applied criteria. 
Slicer frames may be resized, moved, and formatted with styles for a consistent appearance. 
Slicers may also be shared in other worksheets of the same workbook for use with multiple 
PivotTables based on the same data set. Changing the filtering selections in a shared slicer 
causes all connected PivotTables to update automatically.

Highlighted items are 
included in the current filter.

The Clear Filter button

Dimmed items are not available in 
the current filter (Pledge Level 1 
contains no corporate grants).

DEVELOP YOUR SKILLS EX01-D05

Filter a PivotTable with Slicers
1. Save your file as EX01-D05-Sponsors-[FirstInitialLastName].

2. Display the PivotTable with Slicers worksheet.
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Creating PivotTables 15

3. Select any cell in the PivotTable and choose PivotTable Tools→Analyze→Filter→Insert 
Slicer. 

4. Place a checkmark next to Pledge Level, Team Leader, and Sponsor Category; click OK.

5. Select cell A1 to hide the PivotTable Fields task pane, if still displayed.

6. Follow these steps to move and resize the Sponsor Category slicer:

	If necessary, drag Pledge Level 
and Team Leader slicers away 
from columns D–E.

 Point at the Sponsor 
Category’s title bar and drag 
the slicer to the right of the 
PivotTable.

 Point at the lower-right 
corner handle on the slicer 
frame and drag down and right 
to display all sponsor category 
names.

7. Drag the Pledge Level and Team Leader slicers to row 19.

8. Click the Pledge Level title to display the slicer’s frame, and then hold down [Shift] and 
click the Team Leader title.

9. Choose Slicer Tools→Options→Buttons→Columns  and change the number of 
columns to 2.

10. Click the Sponsor Category title in the slicer at the right of the PivotTable, choose Slicer 
Tools→Options→Slicer Styles→More, and choose any style.

11. Apply the styles of your choice to the Pledge Level and Team Leader slicers.

12. Choose Level 2 in the Pledge Level slicer.
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16 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

13. Click the Clear Filter  button on the Pledge Level slicer.

14. Select Corporate Sponsorship in the Sponsor Category slicer, hold down [Ctrl], and select 
Individual Sponsorship.

15. Save the file and leave it open.

Editing PivotTable Calculations
You are not limited to summing values in a PivotTable, and you may create formulas within 
PivotTables when necessary.

Changing the Function for a Values Area Item
By default, the subtotals and grand totals in a PivotTable sum the values in a field. You may 
change the SUM function to a different function, such as AVERAGE, MAX, or COUNT.

If the Values area of the PivotTable Fields task pane contains only one entry, all SUM columns 
will change to the function you selected. If multiple entries exist in the Values area, you may 
change the function for one entry at a time.

Creating a Calculated Field
Some functions are not available on the Summarize Values By tab of the Value Field Settings 
dialog box. These functions may be typed in the Insert Calculated Field dialog box. A calculated 
field contains a formula using values from one or more existing fields. For example, the formula 
could subtract the value in one field from another to find the difference. 

Here, you create 
a formula for a 
calculated field.

Field names may be 
selected from this list for 
insertion in the formula.

Converting Column Data to a Calculation
The Show Values As tab of the Value Field Settings dialog box can be used to create formulas 
employing preset options. For example, you can calculate percentages of a total, the difference 
between values in two columns, a running total, or a ranked order. If you want to display the 
original column data along with the converted data, simply drag and drop the field name from 
the field list to the Values area to create a duplicate field.

Book-FC3-EX2013.indb   16 11/13/2013   3:04:24 PM

FastCourse Microsoft Excel 2013 FOR  EVALUATION ONLY: LEVEL 3 of 3 (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



Creating PivotTables 17

Refreshing PivotTable Data
PivotTables are often created with data from sources external to the Excel 
workbook containing the PivotTables. After you change the source data—
even if in a worksheet range or table within the same workbook—you must 
refresh the PivotTables manually. You may refresh just the active PivotTable 
or all PivotTables in the workbook. You may also set a PivotTable option to 
refresh data from external sources when the workbook is opened. 

DEVELOP YOUR SKILLS EX01-D06

Change PivotTable Calculations
1. Save your file as EX01-D06-Sponsors-[FirstInitialLastName].

2. Display the PivotTable by Pledge Level worksheet.

3. Select a number cell in column B of the PivotTable, and then choose PivotTable 
Tools→Analyze→Active Field→Field Settings.

4. Select Average on the Summarize Values By tab and click OK.

5. Choose PivotTable Tools→Analyze→Calculations→Fields, Items, & Sets→ 
Calculated Field.

6. Follow these steps to create a calculated field:

 Type Goal 110% Year 
2 in the Name box.

 Type an equals sign to 
begin the formula.

 Double-click Year 2 
and type *110%.

 Click Add.

 Click OK.

FROM THE RIBBON

PivotTable Tools→ 
Analyze→Data→ 
Refresh →Refresh or 
Refresh All

FROM THE KEYBOARD
[Ctrl]+[Alt]+[F5] to 
refresh all data sources
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18 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

7. Display the Sponsors Table worksheet.

8. In cell F98 change 250,000 to 200000, and then display the PivotTable by Pledge Level 
worksheet. 

9. Choose PivotTable Tools→Analyze→Data→Refresh menu →Refresh All.

10. Save the file and leave it open.

Creating PivotCharts
A PivotChart presents data from a PivotTable. There are two ways to create a PivotChart.

1. Chart an existing PivotTable by choosing a chart type from the Insert tab, as you would do for 
a normal Excel chart. 

2. Use the PivotChart command to create a PivotTable and PivotChart from the source data at 
the same time. The chart builds as you choose fields in the PivotTable Fields task pane. 

The fields in the values area of the PivotTable are displayed as data series in the chart. The row 
labels in the PivotTable are used as the axis labels in the chart; the column labels are the data 
series in the chart legend.

Filtering PivotCharts
The PivotChart may be filtered using the AutoFilter buttons on the chart, AutoFilter buttons on 
the PivotTable, or slicers added to the worksheet. The filtering is applied to the related 
PivotTable as well.

The chart columns 
depict the PivotTable 
column values.

The data may be 
filtered using the 
AutoFilter buttons.

Formatting and Printing PivotCharts
You format PivotCharts using the same Ribbon commands as you do for normal Excel charts. 
Some chart formatting, such as data labels, is not preserved after a PivotChart is refreshed.
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Changing Macro Security 19

DEVELOP YOUR SKILLS EX01-D07

Create a PivotChart
1. Save your file as EX01-D07-Sponsors-[FirstInitialLastName].

2. Display the PivotChart worksheet. 

3. Select any cell within the PivotTable, and then choose Insert→Charts→Insert Column 
Chart→2-D Column→Clustered Column.

4. Point at the chart frame and drag the chart just 
below the PivotTable.

5. Place a checkmark next to Year 2 in the PivotChart 
Fields list.

6. To filter the PivotChart, choose the Pledge Level 
AutoFilter button at the lower-left corner of the 
PivotChart, remove the checkmark next to Level 4, 
and click OK.

7. Select the chart, choose PivotChart Tools→Design→Type→Change Chart 
Type→Column→3-D Clustered Column, and click OK.

8. Save and close the file.

Changing Macro Security
A macro is a recorded set of mouse and keyboard actions that can be played back at any time. 
Macros are useful for automating routine tasks, especially if those tasks are lengthy. Macros can 
contain viruses, so be cautious about opening workbooks containing macros that you receive 
from others.

Security Levels
You change macro security in the Trust Center section within Excel Options. 
Your setting there is in effect for all Excel workbooks that you open on your 
computer. The setting is not embedded in any workbooks that you save and 
share with others. You may choose among four different levels of security in 
Excel that control whether macros in an opened workbook are available or 
disabled.

■■ Enable all macros: You are not protected from potentially unsafe macros. This option is not 
recommended for general use.

■■ Disable all macros except digitally signed macros: This option automatically disables 
unsigned macros and enables macros from publishers previously added to the trusted 
publishers list in the Trust Center.  

FROM THE RIBBON

File→Options→Trust 
Center→Trust Center 
Settings→Macro 
Settings
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20 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

■■ Disable all macros with notification: This is the default option that displays a message 
allowing you to enable macros in the specified workbook or use the workbook without 
enabling macros. 

■■ Disable all macros without notification: Only macros in workbooks that you placed in a 
trusted location of the Trust Center will run. All other digitally signed and unsigned macros 
are disabled.

If you have antivirus software installed, the file will be scanned for viruses before it is opened 
regardless of the security level set. Also, note that your network system administrator may set 
macro security and prevent users from changing it.

DEVELOP YOUR SKILLS EX01-D08

Verify Macro Security
1. Choose File→Options→Trust Center. 

2. Click the Trust Center Settings button, choose the Macro Settings category, and choose 
Disable All Macros with Notification (if necessary).

3. Choose the Message Bar category from the left side of the window. Verify that the Show 
the Message Bar… option is selected.

4. Click OK twice to close both dialog boxes.

5. Open EX01-D08-MacroTest from the EX2013 Lesson 01 folder.

6. Click Enable Editing below the Ribbon if necessary. Save the file as EX01-D08-
MacroTest-[FirstInitialLastName].

7. Click the Enable Content button , if necessary. 

8. Click the Sort by Leader button.

9. Close the file without saving changes.
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Recording Macros 21

Recording Macros
Excel’s macro recording feature is similar to a video camera. You 
turn it on, press a button to start recording, and press a button to 
stop recording when finished. You may replay the recording as 
many times as you want, during which macros play back recorded 
keystrokes and mouse actions.

Naming a Macro
You can name your macros, or use Excel’s default names (Macro1, Macro2, etc.). Macro names 
may not contain spaces but may include capital letters and underscores. 

Recording Macro Steps
Most actions you perform are recorded in a macro. These include mouse actions, choosing 
Ribbon commands, selecting options in dialog boxes, using arrow keys to navigate the 
worksheet, and typing text. Any mistakes and corrections you make during recording are also 
saved in the macro. If the final result is correct, you can choose to include mistakes and 
corrections and not bother to rerecord the macro, as there would be no benefit to doing so.

Storing Macros
Macros are available only in the workbook in which you create them unless you assign them to 
the Personal Macro Workbook. Some macros are useful only in a particular workbook. For these 
macros, you would choose the This Workbook storage option. Other macros can benefit multiple 
workbooks. So that they will be available for all workbooks, these macros are assigned to a 
Personal Macro Workbook, which is a hidden file used to make macros available to all open 
workbooks.

Saving a Workbook Containing Macros
If you attempt to save a workbook containing macros 
using the normal Excel Workbook file format, Excel 
displays the message “The following features cannot 
be saved in macro-free workbooks: VB Project.” 
Clicking No in the message box displays the Save As 
dialog box, where you should choose the Excel Macro-Enabled Workbook file format. The file is 
saved with the extension .xlsm to indicate that it contains a macro. 

DEVELOP YOUR SKILLS EX01-D09

Record a Macro
1. Open EX01-D09-Contributions from the EX2013 Lesson 01 folder and save it as EX01-

D09-Contributions-[FirstInitialLastName].

2. Click the Record Macro  button on the Status Bar at the bottom-left corner of the 
window. 

After the Record Macro 
button is clicked in the 
Status Bar, the Stop 
Recording button appears.

Book-FC3-EX2013.indb   21 11/13/2013   3:04:24 PM

FastCourse Microsoft Excel 2013 FOR  EVALUATION ONLY: LEVEL 3 of 3 (c) 2014 Labyrinth Learning - Not for Sale or Classroom Use

Labyrinth Learning  http://www.lablearning.com

EVALU
ATIO

N O
NLY



22 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

3. Follow these steps to name the macro and begin the recording process:

 Type Sort_by_Leader to 
name the macro.

 Verify that This Workbook 
displays here.

 Type this description.

 Click OK.

4. Select cell B4 in the table, and then choose Data→Sort & Filter→Sort. 

5. Follow these steps to set the sort parameters and initiate the sort:

 Click the Sort By menu button and 
choose Team Leader.

 Click Add Level.

 Choose To Date for 
the Then By options.

 Choose Largest 
to Smallest here.

 Click OK.

6. Click Stop Recording  on the Status Bar. 

7. Click Save. Click No in the dialog box, and then choose Computer→Browse if necessary.

8. Edit the filename to EX01-D09-ContsWithMacros-[FirstInitialLastName], 
choose Excel Macro-Enabled Workbook from the Save as Type list, and click Save. Keep 
the file open.
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Assigning Macros 23

Running Macros
You may run a macro from within the Macro dialog box. However, macros are 
more accessible if you assign them to shortcut keys, custom buttons or graphics 
on a worksheet, or buttons on the Quick Access toolbar. You then run a macro 
by issuing the shortcut key or clicking the object to which it is assigned. 

DEVELOP YOUR SKILLS EX01-D10

Run an Unassigned Macro
1. Save your file as EX01-D10-ContsWithMacros-[FirstInitialLastName].

2. Select cell D4 and choose Data→Sort & Filter→Sort A to Z .

3. Choose View→Macros→View Macros , choose the Sort_by_Leader macro, and click 
Run.

4. Save the file and leave it open.

Assigning Macros
Macros can be assigned to shortcut keys, or to either custom buttons or graphics within a 
worksheet.

Assigning Macros to Shortcut Keys
Excel lets you assign a macro to a shortcut key as you name the macro. You must use (Ctrl) or 
(Ctrl)+(Shift) as part of the shortcut key combination. Any shortcut you assign will override an 
existing Excel command shortcut. For example, if you assign (Ctrl)+[B] to a macro, that 
combination would no longer apply bold formatting.

DEVELOP YOUR SKILLS EX01-D11

Assign a Macro to a Shortcut Key
1. Save your file as EX01-D11-ContsWithMacros-[FirstInitialLastName].

2. Click Record Macro  on the Status Bar.

FROM THE RIBBON

View→Macros→View 
Macros

FROM THE KEYBOARD
[Alt]+[F8] to view 
macros
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24 Excel 2013 Lesson 1: Using LOOKUP Functions, PivotTables, and Macros

3. Follow these steps to name a new macro:

 Type Insert_Sponsor in 
the Macro Name box.

 Hold down [Shift] and tap 
[I] to set the shortcut as 
[Ctrl]+[Shift]+[I].

 Verify that the macro will be 
stored in This Workbook.

 Click OK.

4. Select cell A4, and then choose Home→Cells→Insert.

5. Select the range A5:G5, choose Home→Clipboard→Format Painter , and select 
cell A4 to apply the cell formatting from row 5 to the blank row 4.

6. Select cell A4 again to position the pointer for data entry.

7. Click Stop Recording . 

8. Delete the blank row 4 that you inserted while creating the macro, then use (Ctrl)+[Shift]+[I] 
to run the Insert_Sponsor macro. 

9. Add this sponsor to the table. Tap [Tab] after entering the Year 2 value to have the To Date 
value calculate automatically.

10. Run the Insert_Sponsor macro again and add this sponsor to the table.

11. Choose View→Macros→View Macros . 

12. Choose the Sort_by_Leader macro, and then click Options.

13. In the Shortcut Key text box, press [Shift], and tap [L] to set the shortcut key to 
[Ctrl]+[Shift]+[L]; click OK. 

14. Click Cancel to exit the Macro dialog box, then use [Ctrl)+[Shift]+[L] to run the macro. 

15. Save the file and leave it open.
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Concepts Review 25

Assigning Macros to Custom Buttons
A macro assigned to a custom button is run whenever the button is clicked. The easiest way to 
create a custom button is to add a shape to the worksheet. You then assign a macro to the 
button. A custom button may also contain a descriptive label to help identify its function or the 
macro that is assigned to it.

You create custom buttons using the Insert Controls tool on the Developer tab. To display this 
tab, choose File→Options, click Customize Ribbon, place a checkmark next to Developer in the 
Main Tabs list at the right, and click OK.

DEVELOP YOUR SKILLS EX01-D12

Assign Macros to Shapes
1. Save your file as EX01-D12-ContsWithMacros-[FirstInitialLastName].

2. Choose Insert→Illustrations→Shapes→Rectangles→Rectangle . 

3. Drag the mouse to draw a rectangle on cell D1. Copy and paste the button to cell E1. 

4. Select the first rectangle and type Insert Sponsor (don’t tap [Enter]), select the second 
rectangle, and type Sort by Leader.

5. Click outside the rectangle to deselect it. Then, use 
[Shift] to select both rectangles and choose Drawing 
Tools→Format→Arrange→Align Objects→ 
Align Middle.

6. Deselect the two rectangles.

7. Right-click the Insert Sponsor rectangle, choose Assign Macro, choose Insert_Sponsor, 
and click OK. 

8. Assign the Sort_by_Leader macro to its rectangle. 

9. Deselect the rectangle.

10. Click the Insert Sponsor rectangle to run the Insert_Sponsor macro. 

11. Add this sponsor to the new row:

12. Click the Sort by Leader rectangle to run the Sort_by_Leader macro. 

13. Save and then close the file. 

Concepts Review
To check your knowledge of the key concepts introduced in this lesson, complete the Concepts Review 
quiz on the student resource center.
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