
In this chapter, you will explore the table 
tools available in Excel as you discover 
the advantages of creating and using 

tables. You will also create formulas that 
use structured references and insert 
sparklines for quick and simple data trend 
analysis.

L E A R N I N G  O B J E C T I V E S
■■ Manage data using a table

■■ Create a custom filter

■■ Name a table

■■ Use structured references in a formula

■■ Create sparklines

C H A P T E R  T I M I N G
■■ Concepts/Develop Your Skills: 1 hr 10 mins

■■ Self-Assessment: 20 mins

■■ Apply Your Skills: 30 mins

■■ Total: 2 hrs 00 mins

P R O J E C T:   A N A LY Z I N G  E X A M 
P E R F O R M A N C E
You are an instructor at LearnFast College. Your 
business students completed their final exams 
recently, and you are reviewing the grades. To help 
you assess individual exam grades and find the class 
average, you are going to create a table and use the 
table tools. For further analysis, you will create a 
series of formulas that use structured references to 
the table data and insert sparklines to show trends 
in the exam grades.

11Working with Tables
E X C E L
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222  FastCourse Excel, Chapter 11: Working with Tables

Working with Tables
Tables can be a valuable feature in Excel if they are used properly. An Excel table is comprised of 
a group of related data within a defined range. Formatting the data as a table enables the use of 
the table features.

Tables are useful, not only for managing and organizing data, but also when it comes to creating 
advanced formulas and analyzing data. In addition, table features allow you to manage the data 
in the table rows and columns independently from the data in other rows and columns on the 
worksheet. You can create a table by converting existing data into a table, or you can start by 
creating a blank table and then fill in the information later. You can even create multiple tables 
on the same worksheet.

This table of sales data displays the header row, banded rows (alternating colors), and a total row.

Insert and Delete Table Rows and Columns
Generally, working with a table is not very different from working with a regular data range. You 
can add rows or columns into the middle of a table just as you would with a normal range—by 
selecting a cell below the desired location of the new row, or to the right of the location of the 
new column, and using the Insert command. To delete a row or column, you use the Delete 
command.

The simplest way to add rows, however, is to add them at the bottom of the table, as entering 
new data in the row directly below a table will automatically expand the table to include the 
new row. Likewise, if you add new data in the column to the right, it will be included in the table 
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Working with Tables  223

as well. Table formatting will also be automatically applied to any new rows or columns to stay 
consistent with the rest of the table.

When a table is selected, the Insert and Delete menus have the additional table options to Insert/Delete Table Rows or 
Columns.

The difference between inserting a table row/column or a sheet row/column is that the Table 
commands do not affect the rest of the worksheet. For example, inserting a table row will insert 
the row into the table only, but inserting a sheet row will insert the row for the table and the 
entire worksheet.

	 TIP!	 If the table includes a total row, you can insert a new row at the bottom but above the total row by 
selecting the bottom-right table cell and pressing [Tab].

Calculated Columns
Table columns can contain text values, numerical values, or formulas. When you enter a 
formula into a table cell, it will automatically become a calculated column, which instantly 
copies the formula to all cells in the column. In the same fashion, editing a formula in one cell 
will update the formula for the entire column. This eliminates the need to use the fill handle to 
copy your formula, making the task quick and easy.

Apply a Sort or Filter
Another advantage of tables is the ability to quickly sort and filter the information contained in 
them. A sort will arrange all the information in the table according to your preference, and a 
filter allows you to decide which data to display and which to hide. Sorts and filters can be 
performed on both a normal range or a table, but a table automatically displays a filter button at 
the top of each column. Depending on the actions taken in that column, the filter button may 
show the down-arrow, the filter symbol, a sort arrow, or some combination of these.

ÍÍ Insert→Tables→Table 

ÍÍ Home→Cells→Insert  or Delete 
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224  FastCourse Excel, Chapter 11: Working with Tables

DEVELOP YOUR SKILLS: E11-D1

In this exercise, you will create a table from existing data (the exam grades) and then edit and sort the 
students’ exam data.

Before You Begin: Download the student exercise files from the Student Resource Center (labyrinthelab.
com/office19) and determine your file storage location before beginning this exercise.

	 1.	 �Start Excel, open E11-D1-Exam from your Excel Chapter 11 folder, and save it as:  
E11-D1-ExamRevised

	 2.	 �Select cell A5 and choose Insert→Tables→Table .

The Create Table dialog box suggested range is A5:J17 (as an absolute reference), which is correct. The 
My Table Has Headers box has a checkmark to indicate there are headers.

	 3.	 �Click OK to create the table.

The table is created. Notice the filter buttons beside each heading and the formatting changes. The 
Table Tools Design tab is activated on the Ribbon.

	 4.	 �Select cell D5 and choose Home→Cells→Insert  menu button �→Insert Table 
Columns to the Left.

Notice the inserted column does not affect the data in the range A20:D22.

	 5.	 �Type Date to replace Column1 in cell D5.

	 6.	 �In cell D6, enter =$A$3 to copy the date from cell A3 using an absolute reference.

After you complete the formula entry in cell D6, the formula is automatically added to all other cells 
in the table column. The results display only the #### symbols because the column needs to be 
resized.

	 7.	 �Select the range D6:D17, change the number format to Short Date, and then autofit the 
width of column D.

	 8.	 �Set the width of column I to: 6

	 9.	 �Select cell K17 and tap [Tab].

A new row is added to the bottom of the table in row 18.

	10.	 �Enter the information for another student in the new table row:

Notice that the Date and Total column formulas for Justin are automatically added for you.

	11.	 �Use the Total filter button � to sort the students by their total mark, Smallest to Largest.

	12.	 �Sort the students by program, from A to Z.

Because you already sorted by the totals first, the students are still arranged lowest to highest within 
the Applied group and Honors group.

	13.	 �Save the file.

	 NOTE!	 Always leave your file open at the end of an exercise unless instructed to close it.
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Special Table Features  225

Special Table Features
The special features of a table include the ability to rename the table for quick reference to its 
data, the header row (used to label columns of information), and the total row (summarizes 
table data). You can also quickly adjust the formatting of a table by applying a table style, and 
you can modify table styles by adding or removing options such as banded rows, banded 
columns, or special first/last column formatting. For other formatting changes, you can select a 
table row or column with one click without selecting the rest of the worksheet.

	 NOTE!	 The Table Tools tab is a contextual Ribbon tab; you must have a cell within the table selected to prompt it.

Table Name
The default name for the first table in a workbook is Table1, the second is Table2, 
and so on. Although you can keep the default names, more descriptive names can 
be useful, especially if the table data will be used in formulas. You can change a 
table name by editing the name directly in the Table Tools Properties menu. As 
with defining names for a cell or range, table names cannot contain spaces but 
may include underscores.

Header Row
Most tables will contain categories of information in columns, so including a header row at the 
top of the table provides a label for each column. It’s good practice to limit each column to one 
piece of information, such as having two separate columns for first name and last name, to 
enable full sorting and filtering. Each column heading in a table should be unique.

	 WARNING!	 Avoid the characters @, #, [ ], and ‘ in column headings because they have special meanings in formulas.

When scrolling through a large table, a table’s header row will remain visible across the top of 
the worksheet, eliminating the need to freeze the top row. The headings replace the normal 
worksheet column headings A, B, C, etc.

You can drag the table resize handle to add and remove columns and rows.
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226  FastCourse Excel, Chapter 11: Working with Tables

Table Style Options
You can add and remove table formatting using the Table Style Options checkboxes. These 
options can help make the information easier to read by differentiating certain rows and 
columns. Clear the Filter Button checkbox to hide the filter buttons in the header row.

Total Row
Checking the Total Row option in the Table Style Options group will automatically add a row to 
the bottom of your table with the text Total in the left column and a sum in the far-right column. 
Although a total row is often used to sum the values in a column, there are other summary 
functions that can be used as well. The total row is formatted to match the style of the rest of the 
table but may be a different shade to stand out from the other data.

This total row adds a sum in the last column on the right, but if the last column contained text or dates, it would 
simply count the populated cells.

Selecting a cell in the total row will display a menu button � that shows a list of the available 
summary formulas. For example, rather than a sum, you may wish to display the average of the 
column data.

ÍÍ Table Tools→Design→Properties

ÍÍ Table Tools→Design→Table Style Options
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Special Table Features  227

DEVELOP YOUR SKILLS: E11-D2

In this exercise, you will rename the table and add a total row to calculate the average exam grades for the 
students.

	 1.	 �Save your file as: E11-D2-ExamRevised

	 2.	 �Go to Table Tools→Design→Properties and click in the Table Name box to select the 
existing name, type Exams to replace that, and tap [Enter].

The new table name is now saved as part of the table properties.

	 3.	 �Scroll down on the worksheet so row 6 is the first visible row. (You may need to use the up/
down arrows on the scroll bar to move up/down one row at a time to get the worksheet to 
display precisely this way.)

The table headers now replace the worksheet column headers.

	 4.	 �Point to the First table header, which changes your pointer to the table column selector 
arrow.

	 5.	 �Drag one column to the right, to the Last table header, to select both table columns.

Notice that the selection does not include the cells below the table.

	 6.	 �Apply Bold formatting to the selection.

	 7.	 �Add a total row by going to Table Tools→Design→Table Style Options and clicking the 
Total Row checkbox.

The total row is added to the bottom of the table. The number 0 appears in the bottom-right cell 
because there is no data in the % column yet (the sum for that column is zero).

	 8.	 �Select cell A19 and replace the text Total with: Average

	 9.	 �Select the cell that contains the zero in the total row, cell K19, under the % heading.
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228  FastCourse Excel, Chapter 11: Working with Tables

	10.	 �Use the menu button � to select None from the drop-down list, which removes the 0.

	11.	 �Move one cell to the left, to cell J19 below the exam totals.

	12.	 �To find the average exam grade, click the menu button � and select Average from the 
drop-down list.

	13.	 �Decrease the decimal places to show only one decimal.

	14.	 �Go to Table Tools→Design and in the Table Style Options group, click the Last Column 
checkbox and change the table style to Blue, Table Style Medium 13.

Only certain table styles have different last column shading, Medium 13 being one of them.

	15.	 �Save your work.

Structured References
A structured reference is created when you use a formula with cell/range references to data 
contained in a table. The advantage of structured references is that they adjust formula results 
automatically when new rows or columns are added to a table. They also make it easier to 
identify the data source because the reference name includes information such as the table 
name and header name. The reference name, once used in a formula, will also update 
automatically if you rename the table or column header.

The syntax for a structured reference varies depending on whether it is a reference to a cell, an 
entire column, or even an entire table.

A formula with a structured reference 
to the column Q1 in Table1

A formula with a structured reference to one 
row of data in the range from Q1:Q4 in Table1

View the video “Creating Formulas with Structured References.”

Formulas with Structured References
The best way to create structured references is to use the point-and-click method to select the 
table cell or column, which adds all the appropriate formatting/syntax based on the cell or range 
selected. Trying to type a structured reference manually is much more difficult and can lead to 
mistakes in your formula.
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Structured References  229

Compare the formulas in the following illustrations. The formula in the left figure was typed in, 
and the formula in the right figure was created by clicking on the cells in the Q1 and Q2 
columns. In the formula on the right, it’s easy to see that the information from Q1 and Q2 is 
being added together, whereas the formula on the left would require finding the cells H5 and I5 
first to understand the meaning.

DEVELOP YOUR SKILLS: E11-D3

In this exercise, you will create formulas that use structured references to calculate the percentage grades, 
fix the total calculation, and insert summary calculations below the table.

	 1.	 �Save your file as: E11-D3-ExamRevised

You will create a formula to find the percent each student scored by dividing the total mark by 150.

	 2.	 �Select cell K6 in the first row below the % table header.

	 3.	 �Type = and use the mouse to select cell J6, one cell to the left, below the Total table header.

The cell reference is automatically inserted as a structured reference. Due to the dark fill color in the 
column (the image shows a lighter blue for visibility), you may not be able to see the text in the cell. If 
that’s the case, check the Formula Bar.

	 4.	 �Type /150 and complete the formula entry.

The formula is calculated in cell K6, the result is 0.46, and the formula is automatically copied down 
to the rest of the column.

	 5.	 �Point to the % column header, click to select the table column, and apply Bold and the 
Percent Style number format.

You may notice the marks seem unusually low, and you may have already noticed an error in the 
Total column, which you will fix now.

	 6.	 �Select cell J6, the first cell below the Total header.

The sum formula finds the total for the range E6:H6, and the error indicates that there are adjacent 
cells omitted from the formula. Rather than edit the formula, you will reenter the SUM formula 
using AutoSum.

	 7.	 �Choose Home→Editing→AutoSum .

The new formula calculates the SUM using a structured reference that includes the table name 
Exams and the table column headers in the range reference @[Pt. 1]:[Pt. 5].
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230  FastCourse Excel, Chapter 11: Working with Tables

	 8.	 �Complete the formula entry, which again automatically updates all formulas in the column 
as well as the % grades in the next column.

	 9.	 �Select cell K19 in the total row below % and add the Average calculation for the % 
column.

Now you will enter some additional formulas outside of the table that use structured references to the 
table data.

	10.	 �Select cell D21 in the box beside Highest Exam Grade.

To find the highest exam grade, you will use the MAX function referring to the % table column.

	11.	 �Type =MAX( and then use the mouse to select the range K6:K18. Complete the formula 
while keeping cell D21 active.

The formula converts the range reference to Exams[%], and the formula bar displays 
=MAX(Exams[%]).

	12.	 �Apply the Percent Style number format.

	13.	 �In cell D22, enter the formula =COUNTIF(Exams[Program],"Honors") and then use 
the mouse to select the program information (starting in cell C6, below the heading).

The result shows there are eight Honors students.

	14.	 �In cell D23, enter this formula using the mouse to select the table ranges, program 
information, and the marks for each criteria range: =COUNTIFS(Exams[Program],"Ho
nors",Exams[%],">80%")

The result shows two Honors students scored higher than 80% on the exam. Notice the criteria ranges 
and corresponding criteria are easier to understand than a regular cell reference: The program must 
be Honors and the percentage score must be greater than 80%.

	15.	 �Save the file.

Creating Sparklines
In addition to creating charts and adding conditional formatting, Excel has another tool for 
visualizing data trends. A sparkline is a miniature chart inserted as an object into an individual 
cell. Sparklines are smaller, simpler versions of charts, and any changes made to the data are 
immediately updated in the sparklines, just as with a normal chart. Each sparkline can contain 
data for only one column or row at a time.
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Creating Sparklines  231

Sparkline types include Line, Column, or Win/Loss, and you can change the type even after the 
sparkline has been created. Formatting changes can be made with the Sparkline tools. Changes 
made to one sparkline are applied to all of the sparklines in the same group automatically.

ÍÍ Insert→Sparklines

DEVELOP YOUR SKILLS: E11-D4

In this exercise, you will insert sparklines to spot trends in the students’ exam marks.

	 1.	 �Save your file as: E11-D4-ExamRevised

	 2.	 �Select the range L6:L18 immediately to the right of the table.

	 3.	 �Choose Insert→Sparklines→Line  to open the Create Sparklines dialog box.

	 4.	 �Click in the Data Range box and then use the mouse to select the range E6:I18.

Because you already selected the desired range, the Location Range is already entered.

	 5.	 �Click OK to insert the sparklines.

The sparklines are displayed in column L and show a comparison for each student, displaying the 
trends for the marks across the five different parts of the exam.

	 6.	 �Go to Sparkline Tools→Design→Show and check the Markers option to display the 
markers on the sparklines.

	 7.	 �Select cell K20 and choose Insert→Sparklines→Column .

	 8.	 �Select the range K6:K18 as the data range, ensure K20 shows as the location, and click OK.

	 9.	 �Go to Sparkline Tools→Design→Show and check the options for High Point and Low 
Point.

The columns with the highest and lowest marks are indicated in red.

	10.	 �Save the file and close Excel.

Self-Assessment
Check your knowledge of this chapter’s key concepts and skills by completing the Self-
Assessment on the Student Resource Center.
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232  FastCourse Excel, Chapter 11: Working with Tables

Apply Your Skills

APPLY YOUR SKILLS: E11-A1

Modify a Price List
In this exercise, you will turn the Universal Corporate Events price list of services into a table to make it easier 
to modify the list and calculate the new prices.

	 1.	 �Start Excel, open E11-A1-Prices from your Excel Chapter 11 folder, and save it as:  
E11-A1-PkgPrices

	 2.	 �Insert a table that contains all of the service descriptions, prices, and deposit amounts.

	 3.	 �Change the table style to Light Yellow, Table Style Light 19.

	 4.	 �Insert a new table row above Transportation and lodging and enter this data:

	 5.	 �In the same row, select cell C8 and enter the formula: =[@[Old Price]]*108%

	 6.	 �Sort the table by New Price, Smallest to Largest.

	 7.	 �Add a total row to the table.

	 8.	 �Change the text in cell A13 to: Complete Package Subtotal:

	 9.	 �Add a Sum formula to the New Price column.

	10.	 �Hide column B from the worksheet.

	11.	 �Change the number format for the range C5:D13 to Currency with no decimals.

	12.	 �Convert the table name to: Prices

	13.	 �Save your work.

APPLY YOUR SKILLS: E11-A2

Calculate Customer Discounts
In this exercise, you will create formulas with structured references to calculate the package discount if 
customers order all of the services in their package.

	 1.	 �Save your file as: E11-A2-PkgPrices

	 2.	 �In cell A14, enter: Complete Package Discount:

	 3.	 �In cell C14, type = and select cell C13 (in the total row below New Price), and then type: 
*15%

The formula should read: =Prices[[#Totals],[New Price]]*15%

Notice the syntax Prices[[#Totals],[New Price]], indicating the formula refers to the new price, in 
the total row, of the Prices table.

	 4.	 �In cell A15, enter: Complete Package Total:
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Creating Sparklines  233

	 5.	 �In cell C15, enter this formula, taking care to use the mouse to select the table data: 
=Prices[[#Totals],[New Price]]-C14

	 6.	 �In cell A16, enter: Total Services in Package:

	 7.	 �In cell C16, enter this formula, using the mouse to select the table data: 
=COUNT(Prices[New Price])

	 8.	 �Select cell D15 and insert a Line sparkline for the data in the range C13:C15.

	 9.	 �Add markers to the sparkline and change the style to Blue, Sparkline Style Accent 1, 
Darker 25%.

	10.	 �Save your work and close the file.

APPLY YOUR SKILLS: E11-A3

Analyze Client Feedback
In this exercise, you will use the table tools to analyze the client feedback data and add a total row and 
sparklines.

	 1.	 �Open E11-A3-Feedback from your Excel Chapter 11 folder and save it as:  
E11-A3-FeedbackRevised

	 2.	 �Sort the table by event date from oldest to newest.

	 3.	 �Select the dates for all June events and delete those rows from the table.

	 4.	 �Change the name of the table to: Ratings

	 5.	 �Select cell H5 and modify the formula to use structured cell references.

	 6.	 �Add a total row and insert the Average function for the last four table columns.

	 7.	 �Select the range E22:H22 and apply the Number format.

	 8.	 �Edit the text in cell A22 to be: Overall Average Ratings

	 9.	 �Select the range I5:I21 and insert Column sparklines for the data in the range E5:H21.

	10.	 �Change the sparkline style to Gold, Sparkline Style Accent 4, (no dark or light).

	11.	 �Save your work and close Excel.
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