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4 Working with Vendors

QUICKBOOKS 
ONLINE

V
endors are the people and businesses 

you buy products and services from. 

In this chapter, you will build a vendor 

list. You will prepare vendor-related purchase 

and expense transactions, such as creating an 

Accounts Payable bill and recording a credit card 

and debit card purchase. You will also create 

vendor Accounts Payable and purchase-related 

management reports to assist with purchase 

history and unpaid bills.
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	 Project: Craig’s Design and Landscaping 
Services
Craig Carlson purchases supplies from a number of businesses. He would like 
to set up all these businesses as vendors in QuickBooks Online. Craig pays for 
his purchases in several different ways. He has an account with some of his 
vendors, so that he can make purchases and then receive a bill to be paid later. 
Craig also uses his credit and debit cards for many purchases.

The Vendors Center
The Vendors center is located on the Navigation bar. It provides information about your vendors 
and your transactions with them in a single place. It allows you to perform vendor-related tasks 
such as searching for vendors, adding vendors, importing vendor lists, editing and merging vendor 
information, and making vendors inactive. The Vendors center also includes tools that allow you 
to quickly perform tasks such as printing and exporting vendor lists, and adjusting list settings.

1

2

4

5
3

1 Money bar

2 New Vendor icon

3 Print, Export, and Settings icons

4 Individual vendor actions menu

5 Vendor search field
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The Money Bar
The Vendors center’s multi-colored money bar gives you a quick snapshot of Accounts Payable, 
including open, past-due, and paid bills. You can click money bar sections to access more detailed 
information about these bills.

The Vendor List
The Vendor list displays vendor names, contact information, and open balances at a glance, as 
well as detailed transaction information when you select a specific name. The Action menu lets 
you quickly create transactions for the selected vendor.

You can add vendors individually or you can import them from an Excel or CSV worksheet.

Adding Vendors
QuickBooks Online does not allow you to add 
two vendors with the exact name. You must 
include a middle initial or other distinguishing 
identifier in the Display Name As field to make 
the names different.

Tip!  Using the Vendors center is not the 
only way to add vendors. You can also add 
new vendors from within a purchase/expense 
form by typing the vendor name and adding 
details as directed.

Develop Your Skills 4-1 

In this exercise, you will add a new vendor in Craig’s Design and Landscaping Services.

Before You Begin: Access the QuickBooks Online test drive at https://qbo.intuit.com/redir/testdrive 
and leave the test drive open for the entire chapter.

Note!  Remember, the QuickBooks Online user interface is updated frequently. Some of the 
names and features in course exercises may be different from what you see on your interface.

1.	 Click Vendors on the Navigation bar.

2.	 Click the New Vendor button at the top-right corner of the browser window.

3.	 Type Morning Supplies as the company name and then tap [Tab].

4.	 The display name should fill automatically; if not, type Morning Supplies here and 
then tap [Tab] twice.

5.	 For the address, type 1458 Magnolia and tap [Tab], type Bayshore and tap [Tab], 
type CA and tap [Tab], and then type 94305 and tap [Tab] four times.

6.	 Type 650-555-8814 in the Phone field.

✔ Best Practice
As you create new vendors, enter as much 
information as possible so you can fully 
utilize the power of QuickBooks Online 
data when creating management reports. 
For example, be sure to include address 
and contact information in the Vendor list.
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7.	 Choose Net 10 in the Terms field.

8.	 Click Save.

The Display Name As field is the only required field to set up a new vendor. By completing more 
fields, you will be able to create more vendor management reports.

Importing Vendor Data from an Excel or CSV File
QuickBooks Online allows you to import vendor lists from an Excel or comma-separated values 
(CSV) worksheet. One way you can import vendor lists is by accessing the Import Data tool from 
the Gear menu.

The Import Data tool allows you to import information not only about 
vendors, but also customers, Charts of Accounts, and products and 
services. The tool includes forms and prompts to help you upload and map 
your lists to QuickBooks Online format. This feature is a great time saver 
for existing businesses that have large lists.

QuickBooks Online often provides multiple ways to do something, 
depending on where you are working within the application. Besides using 
the Import Data tool, you can also import data from within the Vendors 
center.

	 Gear  →Tools→Import Data

	 Vendors Center→New Vendor menu  →Import Vendors
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Editing, Merging, and Making Vendors Inactive
Your Vendor list is customizable. After you add a vendor, you can go back and edit the record. You 
can also merge two lists if you find that the same vendor is listed twice. Doing so will combine 
all the vendor’s transactions into a single record. Finally, to keep your Vendor list current and 
less cluttered, you can inactivate vendor records that you are no longer dealing with. As with 
customers, you can inactivate vendors but never truly delete them.

Develop Your Skills 4-2 

In this exercise, you will edit vendor data, merge two vendor records, and make one vendor inactive. 
Books by Bessie notified you that they had moved. You will start by editing the address.

1.	 Choose Books by Bessie from the Vendors list.

2.	 Click the Edit button and then type the new address as shown:

3.	 Click Save.

4.	 Return to the Vendors list. 

Merge Two Vendors
You have discovered that Lee Advertising is actually owned by Tony Rondonuwu. You will now merge 
these two records.

5.	 Choose Tony Rondonuwu from the Vendors list.

6.	 Click the Edit button and then change the display name to: Lee Advertising

7.	 Click Save and confirm the change, and then return to the Vendors list.
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Make a Vendor Inactive
Craig reviewed the Vendor list and wants to remove old or inactive vendors. Squeaky Kleen Car Wash 
closed last month, so you will make this vendor inactive.

8.	 Select Squeaky Kleen Car Wash from the Vendors list.

9.	 Click the Edit button and then click Make Inactive at the bottom of the window; confirm 
the change when prompted.

10.	 Return to the Vendors list.

11.	 To see a complete list of vendors, including inactive vendors, click the Settings icon above 
the Action menu and then click in the checkbox for Include Inactive. 

The inactive vendor is now included in the list, but it has been deleted.

Creating Vendor Transactions: Purchases 
and Expenses
Vendor transactions in QuickBooks Online are 
recorded either as an expense when you pay at 
the time of purchase, or as a bill if you make a 
purchase and pay later. Expense forms are used for 
all payments made with a debit card, credit card, 
automatic withdrawal, or wire transfer. If you have 
an account with your vendors, you will enter the bill 
on the date you made the purchase and pay the 
bill at a later time.

Remember that all QuickBooks Online forms are 
intuitive. An expense form will always credit the 
bank or credit card account chosen. A check form 
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will always credit the bank account chosen. A bill form will always credit Accounts Payable; this 
default setting cannot be changed.

Expense form

Check form

Bill form
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Customizing Expense Form Settings
Before you begin recording expense transactions, decide what information should appear on 
expense forms and then check that form settings are appropriate for your business. Although you 
can customize the content of expense forms, using the Edit icon in the Expenses folder, you cannot 
customize their appearance (as you can with customer forms such as invoices and sales receipts).

In the following figure, all of the defaults are On for Craig’s Design and Landscaping.

BEHIND THE SCENES

In accrual basis accounting, you record the expense when you have the obligation to pay. 
Remember, QuickBooks Online is a double-entry accounting system, meaning every time 
one account is affected, there is an equal and opposite effect on a corresponding account. 
QuickBooks Online handles all the accounting for you. Here is an example of what’s 
happening behind the scenes.

When entering a bill for General Supplies for $230, the Supplies Expense record increases 
with a debit and the Accounts Payable (liability) record increases with a credit.

When the bill is paid, the Checking Account record will decrease with a credit, and the 
Accounts Payable account will decrease with a debit.
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When you click the Edit  icon in the Bills and Expenses section, you can change the terms, 
markup, sales tax, and more.

	 Gear  Account and Settings→Expenses

Creating Check, Expense, and Bill Records
QuickBooks Online forms are designed to work dynamically with one another. If you link your 
Chart of Accounts and your Products and Services lists correctly as you prepare your expense 
or purchase forms, the appropriate accounting transactions will be created when you make a 
transaction.

If you write a check at the time of a purchase, you will use a check form to record your transac-
tion. If you use a credit card or debit card to pay for items at the time of purchase, you will use an 
expense form. If you purchase goods and services and pay for them later, then you will enter the 
transaction in a bill form and pay the bill at a later date.

Warning!  It’s not a good practice to record expenses on a journal entry or directly on 
a bank withdrawal form. The profit and loss report would be correct, but the purchases/
expenses would not appear on vendor reports.

Develop Your Skills 4-3   

In this exercise, you will record a check, a credit card purchase and a debit card purchase for 
purchases made on September 1, 2021. You will start by recording a purchase made by check at 
Morning Supplies.

Craig stopped by Morning Supplies to purchase some materials he needed. It was a small purchase, 
so he used a check that he happened to have in his wallet.

1.	 Choose Create →Vendors→Check.

2.	 Choose Morning Supplies as the payee field and tap [Tab].

3.	 Choose Checking as the account type, if necessary, and tap [Tab].

4.	 Type 09/01/2021 for the payment date and tap [Tab].

5.	 If necessary, enter 71 as the check number (it will likely autofill for you).

6.	 Choose Landscaping Services: Job Materials in the Account field and tap [Tab].
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7.	 Type Misc. Parts and Plant Feed in the Description field and tap [Tab].

8.	 Type 42.75 in the Amount field.

 

9.	 Choose to Save and Close the check form.

Create an Expense Form
Craig met Bill for a quick lunch at Bob’s Burger Joint on 09/01/2021. Craig paid with his debit card. 
You will now use an expense form to record the transaction.  

Tip!  When entering an expense transaction, it’s important to indicate from which account it 
was paid.

1.	 Choose Create →Vendors→Expense.

2.	 Choose Bob’s Burger Joint as the payee field and tap [Tab].

3.	 Choose Checking as the account type, if necessary, and tap [Tab].

4.	 Type 09/01/2021 for the payment date and tap [Tab] twice.

5.	 Type Debit in the Ref. No. field and tap [Tab].

6.	 Choose Meals and Entertainment in the Account field and tap [Tab].

7.	 Type Lunch with Bill in the Description field and tap [Tab].

8.	 Type 24.97 in the Amount field.

9.	 Choose Save.

Now you will view the accounting behind the scenes for this transaction.
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10.	 In the bottom tray, click the More button and then choose Transaction Journal.

In this example, Meals and Entertainment is the debit, and Checking is the credit.

Record a Credit Card Purchase
In this transaction, you will enter a credit card purchase for coffee mugs with a logo from 
Mahoney Mugs.

11.	 Choose Create →Vendors→Expense.

12.	 Complete the Expense form as noted, tapping [Tab] to navigate the fields:

•	Payee: Mahoney Mugs

•	Account: Mastercard

•	Payment Date: 09/01/2021

•	Ref No.: MC

•	Account: Office Expenses

•	Description: Mugs with Logo

•	Amount: 36.50

13.	 Choose Save and Close.
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Managing Accounts Payable
You can use QuickBooks Online to manage your Accounts Payable—that is, purchases that will 
be paid later, or on account. When vendors send you bills and you enter these bills in QuickBooks 
Online, you can keep track of the amount you owe for purchases in any given period. As you set 
up each vendor, you can specify the terms for that vendor. You can also enter the terms directly 
on the bill form.

Develop Your Skills 4-4 

Craig has ordered new computers and monitors for his office from Computers by Jenni. They will be 
delivered today, 9/1/2021, and the terms are net-15 days. In this exercise, you will enter a bill for 
purchases made today and payable in fifteen days.

1.	 Choose Create →Vendors→Bill.

2.	 Complete the Bill form as follows, using [Tab] to navigate the fields:

•	Vendor: Computers by Jenni 

•	Terms: Net 15

•	Bill Date: 09/01/2021

•	Bill No.: 2021-1515 

•	Account: Office Expenses 

•	Description: Computer and Monitor 

•	Amount: 1345.00 

3.	 Choose Save.

4.	 In the bottom tray, choose More→Transaction Journal.

Accounts Payable is the credit, which increases liabilities on the balance sheet. Office Supplies is 
the debit, which increases expenses on the profit and loss statement.



Managing Accounts Payable  89

Accounts Payable Reports 
The Reports center on the Navigation bar contains a number of vendor-related reports to help 
you manage your Accounts Payable. For example, the Manage Accounts Payable report in the 
All Reports folder lets you track what you owe and when payments are due so that you can 
manage your cash flow. The A/P Aging Summary report in the Recommended folder shows your 
unpaid bills and how long you have owed on them.

Develop Your Skills 4-5 

In this exercise, you will create reports to assist you in managing the Accounts Payable for Craig’s 
Design and Landscaping Services.

1.	 Click Reports in the Navigation bar.

2.	 In the Recommended Reports section, click A/P Aging Summary.

3.	 Type 09/30/2021 in the As Of field.

4.	 Click Run Report.

This report summarizes the vendors and the amounts due.
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5.	 To see details about various totals, click any amount. 

6.	 Review details as you like and then return to the Reports center.

7.	 Click the All Reports tab, choose Manage Accounts Payable, and then choose Vendor 
Balance Summary.

8.	 Ensure that All Dates appears in the Transaction Date field and then click Run Report.

This report gives you similar information as the A/P Aging Summary, but in a different 
format.

Craig would like to know whether any bills are overdue. The A/P Aging Detail Report will 
provide this information.

9.	 Return to the Reports center.

10.	 Choose A/P Aging Detail and notice the report lists each bill, the number of days it is past 
due, and the amount.
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Tip!  You can access similar information on the Vendors center money bar. Click the red 
Overdue section to display only overdue bills.

Other Vendor Reports
The All Reports folder includes a category called Review Expenses and Purchases. These reports 
provide summaries and/or detailed information about purchases by vendor, as well as purchases 
by Product/Service.

	 Reports center→All Reports→Review Expenses and Purchases



92  QuickBooks Online Chapter 4: Working with Vendors

Develop Your Skills 4-6 

In this exercise, you will prepare a vendor report to show Craig the transactions for each vendor last 
month.

1.	 Open the Reports center and choose All Reports→Review Expenses and 
Purchases→Transaction List by Vendor.

2.	 Choose Last Month in the Transaction Date field and click Run Report.

A partial list of the report appears here. Your dates will vary.

Paying Bills
When you pay bills in QuickBooks Online, you choose the account to make the payment from. 
When you pay with a check, the Accounts Payable (liability) decreases and the checking account 
balance (asset) decreases. You can also pay bills with a credit card.

Develop Your Skills 4-7 

In this exercise, you will pay all the bills that are past due and print checks.

1.	 Choose Create →Vendors→Pay Bills.

2.	 Choose Checking as the payment account and tap [Tab].

3.	 Type 09/01/2021 as the payment date field and tap [Tab].

4.	 The Starting Check No. field should fill in with check number 72; if not, update it 
accordingly.
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5.	 Click the checkboxes to the left of the first four vendors (payees).

Print Checks
6.	 Click Save and Print.

7.	 Choose Voucher as the check type.

8.	 Click the Yes, I’m finished with Setup button at the bottom-right corner of the browser 
window.

9.	 At the top of the Print Checks window, verify that Checking is selected as the account type.

10.	 Enter 72 in the Starting Check No. field and then click Preview and Print.

If this were a real work situation, you would now load your checks into your printer. For this 
example, you will print on plain paper or to a PDF file.

11.	 On the Print Preview screen, click Print and choose to print on blank paper or to a PDF file. 
(If printing to PDF, choose an appropriate name for the file.)

12.	 Close  the Print Preview screen.

13.	 Click Done in the next window and then Close  the Print Check window.

14.	 Return to the Vendors center.

No bills are overdue now.
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Tackle the Tasks
This is your opportunity to apply some of the skills learned in this chapter to accomplish addi-
tional tasks for Craig’s Design and Landscaping Services. To refresh your memory, refer to the 
concepts and Develop Your Skills exercises as needed.

Before You Begin: Close the current test drive file and then open a new test drive file.

Task Use This Information

Set up new vendors •	 Christina Gomez, 456 College Ave., Bayshore, CA 94301
•	 Gloria’s Garden, 8585 Main Drive, Bayshore, CA 94302
•	 KGS Tax and Accounting, PO Box 145, Bayshore, CA 94302

Create an expense Paid Gloria’s Garden for purchase of Custom Garden Art; 
Job Expenses: Job Materials account; paid $255 with check 
number 76 on 9/01/2021

Create a bill Billed $100 by Books by Bessie for accounting services (Legal 
& Professional Fees account); bill number 2021-902; dated 
9/2/2021; due in 15 days 

Create a bill Dated 9/2/2021 from Cal Telephone for purchase of a new 
speaker gadget for conference room; bill number 15188 for 
$89.23; Office Expenses account; due in 15 days 

Create an expense Paid Squeaky Kleen Car Wash $19.99 with MasterCard on 
9/3/2021; Automobile 

Pay all the bills For Books by Bessie and Cal Telephone on 9/17/2021 from the 
checking account; start with check number 77

Create a Transaction List 
by Vendor report and 
export it to Excel (XLSX)

September 1 through September 30, 2021

Your report should look like this.
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Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment quiz 
here or in your eLab course.

1.	 You can delete a vendor in QuickBooks Online.

2.	 You can have two vendors with the same name.

3.	 A vendor is a person or business you sell services or products to.

4.	 You can set up a new vendor only from the Vendors center.

5.	 You can record purchases with a credit card in QuickBooks Online.

6.	 The Accounts Payable Aging report displays the number of days a bill is past due.

7.	 You can customize the appearance of a bill form in QuickBooks Online.

8.	 You can import vendor information into QuickBooks Online.

9.	 A Vendor Balance Summary report is useful for knowing the total amount purchased from 
each vendor.

10.	 Hector is a supplier who sells you products. Which list should you add him to?

a.	 Contacts

b.	 Customer

c.	 Vendor

d.	 Chart of Accounts

11.	 To enter a transaction for a service paid for using a debit card, you would:

a.	 choose Create→Vendors→Debit Card

b.	 choose Create→Vendors→Payment 

c.	 choose Create→Vendors→Expense 

d.	 choose Create→Vendors→Bill 

12.	 How can you track Accounts Payable in QuickBooks Online?

a.	 Record an expense and then pay it.

b.	 Enter a bill and then pay it.

c.	 Write a check for the expense.

d.	 You cannot track Accounts Payable in QuickBooks Online.

13.	 To take a quick look at all past-due bills, you should:

a.	 create a Vendor Transaction report.

b.	 click the red Past Due section on the money bar in the Vendors center.

c.	 create a Chart of Accounts and check the balance in Accounts Payable.

d.	 choose Create→Vendors→Pay Bills.
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Reinforce Your Skills
For these exercises, you will work with Puppy Luv Pampered Pooch, the company account created in 
your trial subscription to QuickBooks Online.

Sadie has given you some bills that have been paid with a check, debit, or credit card. She also 
has a few bills that need to be scheduled for payment later. Recording these expenses for Puppy 
Luv Pampered Pooch is an opportunity to reinforce some of the skills learned about vendors and 
expenses.

Reinforce Your Skills 4-1 

Add and Edit Vendors
In this exercise, you will add new vendors to the Puppy Luv Pampered Pooch company file.

Before You Begin: Access your trial subscription to QuickBooks Online. Read any alerts or 
reminders that appear and close any unnecessary windows.

1.	 Open the Vendors center.

2.	 Click the New Vendor button and set up the following new vendors:

•	Sundown District Water, PO Box 1455P, Los Angeles, CA 90051

•	Silva’s Catering, 123 East Southside, Los Angeles, CA 90022; 310-555-1414

•	Steve Nguyen, 78441 Normandie Court, Los Angeles, CA 90005; 310-555-8138

3.	 Edit the Ace Groomer and Supply Company vendor with this new information:

•	1475 West Main St. 

•	Bullhead City, AZ 86426 

•	800-555-7491 

•	Hector@Ace.email.net

Reinforce Your Skills 4-2 

Review and Set Default Expense Settings
In this exercise, you will review and set the Expense form defaults for Puppy Luv Pampered Pooch.

1.	 Choose Gear→Your Company→Account and Settings.

2.	 Click Expenses in the Navigation bar.

3.	 Edit the default bill payment terms to Net 15.

4.	 Ensure that the option to use purchase orders is turned Off.


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Reinforce Your Skills 4-3 

Create Purchase and Expense Forms
The Grand Opening party for Puppy Luv Pampered Pooch was a great success. Sadie has given you 
all the receipts for the party expenses, plus a few bills that need to be scheduled for payment. In this 
exercise, you will create the purchase/expense transactions for Puppy Luv Pampered Pooch. You will 
need to add a vendor.

1.	 Choose Create→Vendors→Check and record the following: Check #10006 for $200 
to Silvia’s Catering for all food and beverages for the Grand Opening; Meals and 
Entertainment account; dated 08/01/2021.

2.	 Choose Create→Vendors→Expense and record the following: $125 paid by debit card to 
Steve Nguyen for Window Display; Marketing account; paid on 07/28/2021.

3.	 Choose Create→Vendors→Bill and record the following: Bill #2021-115 dated 
7/28/2021 for $55.50; from Bonni’s Dog Biskits, 144 Beach Road, Ventura, CA 93003; for 
some treats for the pooches; Pooch Supplies account; due in 15 days.

Reinforce Your Skills 4-4 

Create a Vendor Report
Sadie would like a report to show all of the vendor transactions to date. In this exercise, you will 
create some vendor- and expense-related reports for Sadie.

1.	 Open the Reports center.

2.	 Click the All Reports tab, choose Review Expenses and Purchases, and then choose 
Transaction List by Vendor.

3.	 Choose All Dates as the report period and then click Run Report.

Your report should look like this.
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Apply Your Skills
Now it’s time to use your new skills to prepare all the Puppy Luv Pampered Pooch purchase and 
expense transactions for the first few weeks of August. The first step in the accounting cycle is to 
analyze the transaction, determine what accounts will be affected, and then choose the appropriate 
action—in the right sequence and on the right form. The second step is to record the transaction.

In these exercises, you will perform these steps of the accounting cycle. To simulate a real-world 
accounting environment, some of the information to be entered is presented in a random fashion—
imagine a pile of bills, receipts, and notes that you have to sort through and analyze. Take your time 
and think carefully about your choices.

Apply Your Skills 4-1

Add and Edit Vendors
Sadie has been busy looking for new suppliers and networking with local dog breeder associations, 
shelters, and Chambers of Commerce. She has found a couple new vendors and received additional 
information from an existing vendor. In this exercise, you will add and edit vendors.

1.	 Add these vendors:

•	Sundown District Gas and Electric, PO Box 259RT, Los Angeles, CA 90051

•	District Party Décor, 1411 E Magnolia, Los Angeles, CA 90052

2.	 Edit the George’s Pet Media vendor with this new information:

•	310-555-7711

•	GPM@email.net

Apply Your Skills 4-2

Create Purchase and Expense Transactions
Sadie has left you some receipts for payment made and a few bills to enter. She has written notes so 
you know which account to record the transaction in. In this exercise, you will create the transactions 
for these receipts and bills. (Hint: You may need to add vendors and accounts.)

1.	 Review the list and then create the necessary transactions:

•	Debit card transaction for decorations for the Grand Opening; 7/30/2021 at District 
Party Décor; $37.88; Office Supplies

•	Debit card transaction for raffle tickets, tissue paper, and ribbons; $25.66 at Office Plus; 
7/28/2021; Office Supplies

•	Credit card purchase; 7/25/2021; Sundown District Chamber of Commerce lunch meet-
ing; $45; Meals and Entertainment

•	Credit card purchase; 7/28/2021 for $389.10 from District Party Décor for rental of 
tables and chairs, balloons, and music for the Grand Opening party; Equipment Rental 
Expense

•	Credit card purchase; 7/27/2021 to US Post Office for 100 stamps; $47.00; Postage

•	Bill dated 7/30/2021 from Sundown District Water for $16.84; for service from 
7/20/2021 to 7/28/2021; due in 15 days; Utilities


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•	Bill dated 7/30/2021 from PetEdge, PO Box 100, Beverly, MA 01915; for pooch nail clip-
pers; bill number 89774; $48.96; due in 15 days; Pooch Supplies

•	Bill dated 7/28/2021 from Designs for You, 1004 Makers Road, Los Angeles, CA 90022; 
bill number 21-8944; due in 15 days; for 1000 business cards; $108; Marketing

•	Bill dated 8/05/2021 from Sundown District Chamber of Commerce for one-year mem-
bership; $250.00; bill number PLPP 2021; due in 15 days; Dues and Subscriptions

Apply Your Skills 4-3

Prepare Report and Pay Bills
Sadie has asked you to provide a list of all unpaid bills. She will advise you about which bills to pay 
and any additional reports she would like to review. In this exercise, you will prepare a report of 
unpaid bills for Sadie.

1.	 Prepare an A/P Aging Summary report as of August 15, 2021.

2.	 Export the report to Excel, saving it in your Chapter 04 folder as: CH04 AP Aging 
8.15.21

3.	 Pay all the bills due by 8/12/2021 on 8/10/2021. The beginning check number is 10007.

4.	 Print the checks to a PDF file and then save checks 10007–10008.

5.	 Print a Vendor Balance Summary report for all dates.

The balance should be $315.80.

6.	 Export the report to Excel, saving it in your Chapter 04 folder as: CH04 Vendor 
Balance Summary

7.	 Prepare a Transaction List by Vendor report for all dates; export it to Excel, saving it in 
your Chapter 04 folder as: CH04 Transaction List By Vendor

CHECK FIGURE  Your figures should match those shown here.

Account Balance

Los Angeles City Bank $51,920.96

Accounts Payable $315.80

City Credit Union $481.10
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LEARNING OBJECTIVES

Financial functions are among Excel’s more complex elements. 

However, it’s worth taking the time to master their use, as these 

functions can save substantial time. Commonly used financial 

functions are present value (PV), future value (FV), and payment 

(PMT). Because of the complexity of these functions, you may find 

it necessary to protect some or all of a worksheet that includes 

them. You may also find that automating processes involving these 

functions with macros allows for a greater efficiency. In this chapter, 

you will use financial functions while creating a bond amortization 

schedule. You will begin by calculating different features of a bond 

using PV, FV, and PMT functions. You will create a bond amortiza-

tion schedule for this bond and protect various worksheet elements. 

Lastly, you will create a macro to automate the completion of a bond 

amortization table.

8Bond Amortization

■■ Create a bond 
amortization schedule

■■ Use the PV, FV and PMT 
functions

■■ Protect worksheet 
elements 

■■ Automate processes with 
macros
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P R O J E C T 	 City Music World
City Music World is a retail store that sells musical equipment and offers lessons for 
beginning and experienced musicians. The company is considering issuing bonds to 
fund a potential expansion of its operations. Before doing so, the company wants to 
review the necessary payment schedule and purchase price of bonds with different 
characteristics. You are creating a bond amortization schedule that can be updated for 
different bonds. You will protect key worksheet elements and automate as much of the 
schedule completion as possible.

In this chapter, you will create a bond amortization schedule using PV, FV, and PMT 
functions. You will also work apply different levels of worksheet protection for different 
users. Lastly, you will create macros to automate populating the bond amortization 
schedule once key bond data has been entered.

This bond amortization schedule has been fully populated through the use of a macro that 
automates the creation of all formulas.
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	 Bond Amortization Schedule
When a business seeks to raise cash 
to fund a large expenditure, such as 
for the building of a new facility or 
the development of a new product, it 
will typically raise capital by issuing 
additional shares of stock (equity 
financing) or borrowing money 
(debt financing). One financial 
instrument that can be used when 
pursuing debt financing is a bond.

When a business issues a bond, it 
receives a lump payment from the bondholder to be used by the business to pursue its 
intended expenditure. In exchange, the bondholder receives periodic payments over the 
life of the bond (interest payments) and a lump sum payment equal to the face value 
of the bond at the end of the bond’s life (principal payment). To determine figures such 
as the initial selling price of the bond and interest payments, you must understand the 
various bond characteristics. When using the most commonly applied effective interest 
method, these include the face value, life of the bond, contract interest rate, and 
effective interest rate.

NOTE!	 The effective interest method is the amortization method examined here, as it requires the completion 

of a bond amortization schedule. The alternative, though far less widespread, is to use straight-line 

amortization. 

Face Value

The face value of a bond is the amount paid to the bondholder on the maturity date 
(the end of the bond’s life). If the issue price of the bond equals the face value, then 
the bond is being sold at its par value. However, oftentimes bonds are sold at more than 
their face value (sold at a premium) or less than their face value (sold at a discount).

Life of the Bond

The life of the bond represents the period of time over which the bond will be 
outstanding before it matures. A bond is often held by a single bondholder over the 
course of its life, but it’s also common for bonds to be sold from one bondholder to 
another. Periodic interest payments are made to the current bondholder throughout 
the life of the bond, and the face value of the bond is paid to the bondholder upon bond 
maturity. Note that the bond will indicate the frequency with which interest payments 
are made (annually, semiannually, etc.) and this schedule is followed throughout the life 
of the bond. 

Contract Interest Rate Vs. Effective Interest Rate

The contract interest rate is attached to the bond and used to calculate interest 
payments periodically made to the bondholder. Conversely, the effective interest rate 
(also caked the market interest rate) factors in the impact of compounding on the 

(continues)
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interest payments. When completing a bond amortization table, the contract interest 
rate is used to calculate actual interest payments, while the effective interest rate is used 
to calculate the present value of the bond.

These interest rates can be used to quickly identify whether a bond will be sold at 
a discount, face value, or a premium. When the contract interest rate and effective 
interest rate are the same, the bond sells at face value. If the contract rate is below the 
effective rate, then the bond can be considered less desirable than a similar bond that 
could be purchased elsewhere. This bond will sell at a discount from the face value. 
Conversely, if the contract rate is above the effective rate, then the bond is considered 
more attractive than a similar bond that could be purchased elsewhere and will sell at a 
premium above face value.

Amortizing Bond Discount or Premium

When a bond is issued at a discount or premium, the impact of these within the 
financial records of the bond issuer is spread over the life of the bond. This bond 
amortization either increases the interest expense recorded when each bond 
payment is made (in the case of a discount) or reduces the interest expense (in the case 
of a premium). The total interest expense for each period is calculated as the interest 
payment plus amortized discount or minus amortized premium.

Carrying Value

The carrying value of a bond can be calculated as face value minus unamortized 
discount (or plus the unamortized premium). When the bond is issued, the unamor-
tized discount or premium equals the total discount or premium for the bond. As 
these are amortized, the unamortized portion of the discount or premium is gradually 
reduced (leading to a gradual increase in the carrying value when there is a discount or 
a gradual decrease when there is a premium). The result is that once the bond matures, 
the discount or premium will have been amortized to $0 and the bond’s carrying value 
will equal its face value. 

Working with Financial Functions
Excel includes a variety of financial functions that can simplify the creation of accounting-related 
worksheets. For example, there are basic financial functions for determining monthly payments on 
loans, total interest paid on loans, and the future value of investments. When examining the charac-
teristics of a specific bond or other financial instrument, the PMT, PV, and FV functions are useful. 

PMT Function
For the PMT function to calculate the required payment for a bond, you must specify the bond 
interest rate, number of payments to be made, present value, and future value of the payment at 
maturity. 
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The interest rate and number of payments must be carefully considered. The effective interest rate 
(not the contract interest rate) is the first argument. It’s typically expressed in annual terms, so if a 
bond requires an alternative payment schedule (such as semiannual instead of annual payments), 
the interest rate entered in the formula must be adjusted. For example, if the effective interest rate 
is 14% and a bond requires semiannual interest payments, then there are two interest payments 
every year. You divide 14% by 2 payments per year to arrive at an interest rate of 7%, which is what 
is entered as the first argument in the function.

The number of payments will often differ from the number of years in the life of the bond. If a 
bond with semiannual interest payments has a 5-year life, then it will have a total of 10 payments 
(5 years * 2 payments per year).

One additional element to review is how the PMT function 
expresses periodic payments. By default, the result of the PMT 
function is displayed as a negative number. When writing the formula it is common to place a 
negative sign before the function. This reverses the result from a negative to a positive figure. Similar 
consideration is given to the individual arguments of the PMT function. Because the FV argument 
represents a lump payment at the end of the bond’s life, it should also be expressed as a negative 
number when writing the formula.

	 Formulas→Function Library→Insert Function→Financial→PMT Function

PV Function and FV Function
The PV function calculates the present value of a bond when you specify the bond interest rate, 
number of payments, interest payment amount, and future value of the payment at maturity. The 
FV function calculates the future value of a bond when you specify the bond interest rate, number of 
payments, interest payment amount, and present value. 

The PV and FV functions typically require negative symbols in their formulas.

The same considerations must be made for these functions as are made for the PMT function. Both 
the effective interest rate argument and the number of payments argument are entered per the 
earlier discussion. Additionally, the interest payment amount and future value of the payment at 
maturity must be expressed in negative terms. For the FV function, then, a negative sign is added 
before the FV at the beginning of the formula. The present value is considered to be a positive 
amount in Excel (since it does not represent a payment), so a negative sign is not needed before the 
PV at the beginning of that formula.

	 Formulas→Function Library→Insert Function→Financial→PV Function 

	 Formulas→Function Library→Insert Function→Financial→FV Function

Financial Function Syntax
You create financial functions using actual values or cell references. Remember that using cell refer-
ence offers more flexibility and is preferable. 
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PMT, PV, and FV Function Syntax

Function Syntax

PMT (Payment) PMT (rate, periods, present value, [future value], [type])

PV (Present Value) PV (rate, periods, payment, [future value], [type])

FV (Future Value) FV (rate, periods, payment, [present value], [type])

These financial functions can be used when the payment amount remains constant, such as with 
most bonds, car loans, and fixed-rate mortgages. 

The rate argument is the interest rate for each period of the bond or loan. Although these are quoted 
as annual rates, payments usually are made more frequently. For monthly payments, as an example, 
you divide the interest rate by 12. You can enter the result or the calculation details (such as 7%/12) 
in the formula.

The periods argument is the number of payments for the bond or loan, or the number of deposits 
for an investment.

The payment argument for a bond or loan is the required periodic interest payment. For an invest-
ment, it’s the amount invested in each period. In either case, they payment is always the same for 
each period.

The future value argument is optional. It is the balance that will be owed at the bond maturity date 
or the amount desired at the end of an investment. This must be entered when determining the 
present value of or payments for a bond but is not required if the balance of an investment will be 
zero.

The present value argument is the value, in today’s dollars, of a bond or loan. It must be entered 
when determining the future value of a bond. Or, it can be the starting balance of an investment 
(not required if the starting balance is zero). This argument is optional for the PMT function.

The type argument indicates when payments are due. You are not required to enter the default 
argument 0 (zero) if payments are made at the end of the period. Enter 1 if payments are due at the 
beginning of the period. This is an optional argument.

Develop Your Skills EA8-D1	

In this exercise, you will use financial functions to calculate the present value, future value, and 
payments associated with a bond. You will then create a bond amortization.

Base your spreadsheet on a bond with a $100,000 face value, a 5-year life, semiannual interest 
payments, a coupon interest rate of 10%, and an effective interest rate of 12%. The bond is issued on 
1/1/2012.

1.	 Open a Blank Workbook and save the file in your Chapter 08 folder as 
EA8-D1-Bond-[YourName].

You will begin by preparing the worksheet for the data to be entered.

2.	 Set the width of column A to 0.75 and the height of row 1 to 7.2.

This creates nice spacing that improves worksheet readability.
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3.	 Merge and center the range B 2:C2, add bold formatting, and enter Bond Details.

4.	 Type these headers in the range B3:B8, in order:  Date, Face Value, Contract Rate, 
Effective Rate, Life (years), and Payments per Year.

5.	 Enter 1/1/12 in cell C3.

6.	 Enter 100000 in cell C4 and apply the Accounting number format.

7.	 Enter .1 in cell C5 and.12 in cell C6, and then select the range C5:C6 and choose 
Home→Number→Percent Style.

8.	 Select cell C7 and type 5, tap [Enter], type 2, and tap [Enter].

9.	 Center-align the contents of the range C3:C8.

10.	 Highlight the range B2:C8 and choose Home→Font→Borders menu →Outside Borders; 
also apply an outside border around cell B2.

11.	 Autofit column B and set the width of column C to 12.

12.	 Merge and center the range B10:C10, add outside borders and bold formatting, and enter 
Bond Calculations.

13.	 Type these headers in the range B11:B13, in order: Present Value, Future Value, and 
Payment.

Enter Financial Functions

14.	 In cell C11, type =PV(C6/C8, but do not complete the entry.

The effective interest rate is used for the first argument. It is divided by two because as the effective 
rate is expressed in annual terms, but the bond pays interest semiannually. 

15.	 Enter the next part of the formula: C7*C8,

The second argument (number of interest payments) is calculated by multiplying the total number of 
years of the bond’s life by the payments per year.

16.	 Enter the next part of the formula: –C4*C5/C8,

In the third argument, the contract rate of interest is multiplied by the face value of the bond to 
determine the periodic interest payments. Just as the effective interest rate was divided by the 
number of payments per year, the contract interest rate is divided by the number of payments to 
arrive at a prorated contract interest rate for each payment period. A negative sign is placed in front 
of C4 because the interest payments represent cash outflows.

17.	 To complete the formula, type –C4) and tap [Enter].

The fourth argument represents the face value of the bond at maturity. As this is an outflow of cash, 
a negative sign is placed in front of C4.

18.	 In cell C12, type =-FV(C6/C8, C7*C8, -C4*C5/C8, C11) and tap [Enter].

The arguments in the FV function are similar to those in the PV function. Note the negative sign at 
the beginning of the formula.

19.	 With cell C13 selected, choose Formulas→Function Library→Insert Function, select the 
Financial category and the PMT function, and click OK.
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20.	 Complete the Function Arguments box as shown and then click OK:

21.	 With cell C13 still active, click between the equals sign and PMT in the Formula Bar, type a 
minus sign, and tap [Enter].

Just as the interest payments were preceded by a negative sign in the PV and FV functions because 
they represent cash outflows, the PMT function includes a negative sign here as well.

22.	 Apply the Accounting number format to the range C11:C13 and add an outside border to the 
range B10:C13.

23.	 Select the headers for columns D–G and use the right-click method to set the width to 15.

Complete the Amortization Schedule

24.	 Starting with cell B15, highlight the range B15:G15, apply an outside border, add bold 
formatting, and set the Wrap Text option and Center alignment.

25.	 In cell B15, type Date and tap [Tab]; continue typing Interest Payment, Interest 
Expense, Amortization of Bond Discount, Bond Discount Balance, and 
Carrying Value, in the remaining highlighted cells, tapping [Tab] between each entry.

Cells E15 and F15 indicate that a bond discount is being amortized. This can be verified by noting 
that the present value of the bond is less than its future value. If the present value had been greater 
than the future value, the cells would show a bond premium being amortized.

26.	 Enter 1/1/2012 in cell B16, 6/30/2012 in cell B17, and 12/31/2012 in cell B18.

27.	 Highlight the range B17:B18 and then drag the fill handle at the bottom-right corner of the 
range through cell B26.

The bond depreciation schedule begins with the date on which the bond is issued and includes one 
row for every date on which an interest payment is made.

28.	 In cell B27, enter Totals and right-align the text.

29.	 Type =C12-C11 in cell F16, tap [Tab], type =C11, and tap [Enter].

These figures, which are based on the financial figures previously calculated, create the foundation 
for the remainder of the bond amortization schedule.

30.	 In cell C17, type =C13, tap [F4], and tap [Tab].

The interest payment was previously calculated and is based on the contract interest rate. It remains 
constant for every period, so you are using absolute formatting.

31.	 Enter =G16*$C$6/$C$8 in cell D17.

The total interest expense for each period is calculated by multiplying the current carrying value 
of the bond (which, as seen in cell G16, equals face value minus current balance within the bond 
discount) by the effective interest rate. As we have seen, the interest rate is divided by the number of 
payments per year.
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32.	 Enter =D17-C17 in cell E17.

The difference between the interest payment and the interest expense, as calculated here, represents 
the amortization of the discount for the current period.

33.	 Enter =F16-E17 in cell F17.

The bond discount balance is reduced by the amortization amount each period. The bond discount is 
gradually reduced until it reaches zero at the end of the life of the bond.

34.	 Enter =G16+E17 in cell G17.

Just as the bond discount balance decreases by the bond amortization amount each period, the 
carrying value of the bond (when it is issued at a discount) increases each period by the bond 
amortization amount.

35.	 Highlight the range C17:G17 and use the fill handle to copy the formulas through row 26.

36.	 Highlight the range C27:E27, choose Home→Editing→AutoSum, and then choose 
Home→Font→Borders menu →Top and Double Bottom Border.

37.	 Apply the Accounting number format to the range C16:G27. 

38.	 Save your file.

Unless otherwise directed, always keep your file open at the end of each exercise.

Protecting Workbooks and 
Worksheets

You protect a file to prevent accidental or intentional modification. Excel offers three levels of 
protection. 

•	 Workbook-level protection protects the structure of the entire workbook, preventing 
changes to the way worksheets are displayed.

•	 Worksheet-level protection restricts changes to certain objects on worksheets. 

•	 Cell-level protection limits access to certain cells on worksheets. 

Protecting the Workbook Structure
Protecting a workbook prevents structural changes from being made. For example, you cannot 
delete, rename, copy, or move worksheets while the structure is protected.
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The Protect Workbook command displays the Protect Structure and Windows dialog box. Using an 
optional password allows you to control who can switch this protection on and off. 

2

1

1.	 The Structure option protects worksheets from being reordered, copied, or deleted.

2.	 The Windows option is disabled in Excel 2013 and 2016 and, therefore, cannot be used.

	 Review→Changes→Protect Workbook

Protecting the Worksheet Elements
You can turn on protection for individual worksheets in a workbook. The Protect Sheet command 
even allows you to restrict activity to specific actions, such as selecting cells, formatting rows and 
columns, and inserting/deleting rows and columns.

Turning Protection On and Off

Although it might appear that you would turn worksheet protection on/off using the Protect 
Worksheet and Contents of Locked Cells checkbox, that is not the case. That option always should 
have a checkmark. Clicking OK actually turns on worksheet protection. 
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Allowing User Changes

By default, two user options are selected in the Protect Sheet dialog box, giving users permission 
only to click on cells. If you remove those checkmarks, users can scroll through the worksheet but 
cannot select any cells. You can specify that users are allowed to change certain other items in a 
protected worksheet. 

In a bond depreciation schedule, the user should only need to change a few input cells (including 
those for effective interest rate, face value, and bond life). Once entered, these figures should allow 
for the automatic completion of the body of the schedule. As such, it’s common for users to be given 
access to only those cells that require initial inputs.

Password Protection

For the highest level of protection, add a password. Users must enter the password to unprotect the 
worksheet and make further changes. For worksheets that are accessible by many employees but 
only used by a select few, including a password can help ensure that data is not improperly accessed.

WARNING!	Keep track of your passwords! Workbook-protection passwords cannot be retrieved. If you forget your password, you must 

re-create the workbook.

	 Review→Changes→Protect Sheet or Home→Cells→Format→Protect Sheet

Develop Your Skills EA8-D2	

In this exercise, you will protect your bond amortization schedule to that users can only alter certain 
elements. 

1.	 Save your file as EA8-D2-Bond-[YourName].

2.	 Choose Review→Changes→Protect Workbook.

3.	 Follow these steps to protect the workbook:

A

B

C

A.	 If necessary, click to place a checkmark in the Structure checkbox.

B.	 Type Amortization as the password and click OK. 

C.	 In the Confirm Password dialog box, retype Amortization and click OK.

4.	 Double-click the Sheet1 tab.

An error message appears because protecting the workbook structure prevents the renaming of sheet 
tabs. 
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5.	 Click OK; then choose Review→Changes→Protect Workbook, type the password 
Amortization, and click OK.

The workbook is no longer protected.

6.	 Choose Home→Cells→Format→Protect Sheet and confirm that the boxes for these 
items are checked (if not, click to add checkmarks):

•	 Protect Worksheet and Contents of Locked Cells 
•	 Select Locked Cells
•	 Select Unlocked Cells

7.	 Click the checkbox for Format Cells, type Bond as the password, and click OK.

8.	 Confirm the password when prompted.

9.	 Right-click the column D header.

As a result of the protection you applied, some options in the pop-up menu are grayed out, or 
disabled. 

10.	 Select cell C17 and then click the Insert tab on the Ribbon.

Notice that the majority of options on the Insert tab are also disabled. 

11.	 Highlight the range B27:E27 and choose Home→Font→Bold.

You can apply the bold formatting even though the workbook protection is active because you 
allowed this in step 7. 

12.	 Choose Review→Changes→Unprotect Sheet, enter the password Bond, and click OK.

13.	 Save your file.

Protecting Individual Cells
You can protect the contents and formatting of certain cells. You can also hide formulas so they 
don’t display in the Formula Bar or when the Show Formulas command is used. All worksheet 
cells are locked by default until you unlock them. Why, then, have you been able to edit all 
locked cells? The cells’ locked/unlocked condition has no effect until worksheet protection is 
turned on.

NOTE!	 Remember that worksheet protection can be turned on through the Home or Review tab.
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The Protection Tab of the Format Cells Dialog Box

You can open the Format Cells dialog box via the menu that appears when you right-click a high-
lighted area of a worksheet. 

The Protection tab in the Format Cells dialog box allows you to change options for selected cells. 
There are two cell protection options you can set. 

•	 �Locked: Check or uncheck this option to lock/unlock the currently selected cells. 

•	 �Hidden: This option affects only the display of formulas. It does not hide labels, values, or 
formula results.

Unlocking Cells in a Protected Worksheet 

When the Locked option is unchecked, selected cells are unlocked. Unlocked cells can be edited 
even though the overall worksheet is protected. This way, you can protect formulas and labels while 
still allowing data entry in other areas. The unlocked portion of the worksheet is referred to as the 
changes area. You must unlock the cells before protecting the worksheet. 

TIP!	 For rapid data entry into unlocked cells, tap [Tab] after entering data in each. When you reach the end of a row in the changes 

area and tap [Tab], the insertion point wraps to the next row. 

	 Home→Cells→Format→Lock Cell
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To Lock or Not to Lock

If your worksheet contains only a few cell ranges that users are allowed to change, unlock those cells. 
The rest of the worksheet will remain locked when you turn on worksheet protection. If most of the 
worksheet needs to be accessible for updating, you may want to use the Select All option and unlock 
all cells and then lock just the cells you want to protect. 

TIP!	 Use the [Ctrl] key to select multiple cell ranges and then select Unlock, Lock, or Hidden to apply the option to multiple ranges at 

once.

Develop Your Skills EA8-D3	

In this exercise, you will unlock cells that require modification to complete the bond amortization 
schedule. You will then protect the worksheet so only the unlocked cells can be modified.

1.	 Save your file as EA8-D3-Bond-[YourName].

2.	 Highlight the ranges C3:C8 and B16:G27, and choose Home→Cells→Format→Lock Cell.

As these cells were locked by default, they are now unlocked.

3.	 Highlight the range C11:C13, right-click, and choose Format Cells.

The Format Cells dialog box opens.

4.	 Switch to the Protection tab, check the box for Hidden, and click OK.

5.	 Choose Review→Changes→Protect Sheet, enter Interest as the password, and click OK; 
confirm the password in the next dialog box.

6.	 Select cell C12. 

Notice that the Formula Bar is empty. This cell is in the range for which the Hidden option was 
selected.

7.	 Type any letter in cell E2.

You did not unlock this particular cell prior to protecting the worksheet, so a warning message 
displays to indicate that you cannot type in this cell.

8.	 Click OK to close the warning message.

9.	 Use the right-click method to change the name of the Sheet1 tap to Bond Schedule.

The worksheet is protected but the workbook remains unprotected; therefore, the workbook 
structure, including the worksheet tab names, can be modified.

10.	 Save your file.

Using Macros
A macro is a recorded set of mouse and keyboard actions that can be played back at any time. Macros 
are useful for automating routine tasks, especially lengthy tasks. Be aware that macros can contain 
viruses, so be cautious about opening workbooks containing macros you receive from others.
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Security Levels

You change macro security in the Trust Center section of Excel Options. The setting there is in effect 
for all workbooks opened on your computer. The setting is not embedded in any workbooks that you 
save and share with others. 

You can choose among four levels of security that control whether macros in an opened workbook 
are available or disabled.

•	 Disable All Macros without Notification: Only macros in workbooks that you place in a 
trusted location of the Trust Center will run. All other digitally signed and unsigned macros are 
disabled.

•	 Disable All Macros with Notification: This is the default option. It displays a message 
allowing you to enable macros in the specified workbook if you wish or use the workbook 
without enabling macros. 

•	 Disable All Macros Except Digitally Signed Macros: This option automatically disables 
unsigned macros and enables macros from publishers previously added as a trusted publisher 
in the Trust Center.  

•	 Enable All Macros: You are not protected from potentially unsafe macros. This option is not 
recommended for general use.

If you have antivirus software installed, the file will be scanned for viruses before it is opened regard-
less of the security level set.

NOTE!	 Your network system administrator may set macro security and prevent users from changing it.

	 File→Options→Trust Center→Trust Center Settings→Macro Settings

Recording Macros
Excel’s macro recording feature is similar to a 
video camera. You turn it on, record your actions, 
and then stop the recorder. You can play back the 
recorded keystrokes and mouse actions as many 
times as you want.

1 2

1.	 When a macro is recording, the Stop Recording 

butto ears on the status bar.

2.	 After a first macro has been recorded, you can click 

this icon on the status bar to record subsequent macros.

	 View→Macros→View Macros menu →Record Macro
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Naming a Macro

You can add custom names for your macros or use Excel’s default names (Macro1, Macro2, etc.). 
Macro names cannot contain spaces but can include capital letters and underscores. 

Recording Macro Steps

Most actions—including mouse actions, choosing Ribbon commands, selecting options in dialog 
boxes, using arrow keys to navigate, and typing text—are recorded in a macro. Any mistakes and 
corrections you make during recording also are saved. If the final result is correct, you can include 
the mistakes and their corrections in the macro; otherwise, just rerecord the macro using the proper 
actions. 

TIP!	 Practice the procedure you wish to automate before recording the macro to reduce the risk of making mistakes during the 

recording process.

Storing Macros

Macros are available only in the workbook in which you create them unless you assign them to the 
Personal Macro Workbook, which is a hidden file used to make macros available to all open work-
books. Some macros are useful only in a particular workbook. For these macros, choose the This 
Workbook storage option. Other macros can benefit multiple workbooks, and these are the ones to 
assign to the Personal Macro Workbook.

Saving a Workbook Containing Macros

If you attempt to save a workbook containing macros using the normal Excel Workbook file format, 
Excel displays the message, “The following features cannot be saved in macro-free workbooks: VB 
Project.” Clicking No in the message box displays the Save As dialog box, where you should choose 
the Excel Macro-Enabled Workbook file format. The file is saved with the extension .xlsm to indicate 
that it contains a macro. 
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Running Macros
You can run a macro from the Macro dialog box, but they’re much more accessible if you assign 
them to shortcut keys, custom buttons or graphics on a worksheet, or buttons on the Quick Access 
toolbar.  

	 View→Macros→View Macros | [Alt]+[F8] 

Develop Your Skills EA8-D4	

In this exercise, you will record a macro that will complete the bond amortization schedule. You will then 
run the macro.

1.	 Save your file as EA8-D4-Bond-[YourName].

2.	 Choose File→Options→Trust Center→Trust Center Settings→Macro Settings, ensure 
that Disable All Macros with Notification is selected, and click OK twice.

3.	 Highlight the range C16:G27, and tap [Delete].

You will now re-create the bond amortization schedule while recording a macro, which can be saved 
and used later when completing subsequent schedules.

4.	 Choose View→Macros→Macros menu →Record Macro to open the Record Macro dialog 
box.

5.	 Enter Amortization _ Schedule as the macro name and click OK.

6.	 Select cell F16, type =C12-C11 and tap [Tab] and then type =C11 and tap [Enter].

7.	 Select cell C17, type =$C$13 and tap [Tab], type =G16*$C$6/$C$8 and tap [Tab], type 
=D17-C17 and tap [Tab], type =F16-E17 and tap [Tab], and type =G16+E17 and tap [Enter]

8.	 Highlight the range C17:G17 and drag the fill handle through row 26.

9.	 In cell C27, enter =SUM(C17:C26).

10.	 Copy cell C27 and paste in the range D27:E27.

11.	 Choose View→Macros→Macros menu →Stop Recording.

12.	 Delete the contents of the range C16:G27.

You will now run the macro to ensure that it was properly recorded. In doing so, you will repopulate 
the bond amortization schedule.

13.	 Choose View→Macros→Macros and click Run.

The bond amortization schedule is once again fully complete.

14.	 Choose Review→Changes→Unprotect Sheet, type Interest, and tap [Enter].

You have temporarily unprotected the sheet so you can insert a text box. 

15.	 Choose Insert→Illustrations→Shapes and click Text Box in the Basic Shapes section.

16.	 Click near the top-left corner of cell E2 and drag to the bottom right of cell E5 to create a text 
box over the range E2:E5.

17.	 Type Populate Schedule and format the text with bold and a 16-point font size. 
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	 What Is the Benefit of Using Excel 
to Create a Bond Amortization 
Schedule?

There are a few characteristics of a bond amortization schedule that make it ideal for comple-
tion in Excel. You have seen how financial functions can streamline bond-related calculations. 
More importantly, because the body of the schedule requires identical formulas in multiple 
rows, using macros is ideal. As a result, only a small number of items must be entered (effective 
interest rate, number of periods, etc.) before the automated portion can be completed, allowing 
for the use of protection throughout the majority of the worksheet. 

As macros can be assigned to worksheet objects, Excel provides a simple forum for the auto-
matic completion of a bond amortization schedule. This allows novice users to benefit from 
the full power of Excel without extensive knowledge of the program. Once the macro has 
been created, any user can easily employ it. This level of accessibility for all users is rare within 
accounting-related programs.

The use of workbook and/or worksheet protection 
also ensures that novice users do not accidentally 
introduce errors in a worksheet. Again, Excel is 
unique in its extensive ability to limit user access 
solely to the few elements that require modification. 
The result of using both macros and workbook/work-
sheet protection is that a relatively complex schedule, 
such as that for bond amortization, can be efficiently 
completed by users with relatively little experience in 
the program.

18.	 Right-click the text box, choose Assign Macro, click the Amortization_Schedule macro from 
the list, and click OK.

19.	 Choose Review→Changes→Protect Sheet, enter Schedule as the password, and click OK; 
confirm the password when prompted.

20.	 Delete the contents of the range C16:G27.

You will now run the macro from the object that you have entered within the spreadsheet.

21.	 Click the text box to initiate the macro.

The bond amortization schedule is once again complete.

22.	 Save a copy of your file as a Macro-Enabled Workbook then close it.

Hint: Choose File→Save As and choose Macro-Enabled Workbook from the Save as Type box.
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Self-Assessment
Check your knowledge of this chapter’s key concepts and skills using the Self-Assessment here or in your eLab course.

True/False Questions
1.	 The PMT, PV, and FV functions are displayed in the Financial section of the  

Insert Function dialog box.	 True    False

2.	 In the PMT, PV, and FV functions, interest rates are always expressed in annual terms.	 True    False

3.	 The number 1 represents the default entry for the “type” argument in PMT, PV,  
and FV functions.	 True    False

4.	 Cell references CANNOT be used with PV and FV functions.	 True    False

5.	 In Excel 2016, the Windows protection option has been disabled.	 True    False

6.	 The Protect Sheet command can be accessed on the Review and Home tabs.	 True    False

7.	 When protecting a worksheet, you must create a password.	 True    False

8.	 The [Tab] key can be used to move through unlocked cells in a worksheet. 	 True    False

9.	 All worksheet cells are unlocked by default.	 True    False

10.	 Macro names CANNOT include spaces.	 True    False

Multiple Choice Questions
11.	 Interest rates, including the effective interest rate and contract interest rate, are typically expressed in _____ 

terms.
a.	 weekly
b.	 monthly
c.	 semiannual
d.	 annual

12.	 For a bond, which formula argument represents a payment and requires the inclusion of a negative sign 
before to the argument to reverse its sign within financial formulas?
a.	 Rate
b.	 Future Value
c.	 Present Value
d.	 Periods

13.	 What is the optional argument for PMT, PV, and FV functions?
a.	 Rate
b.	 Periods
c.	 Payment
d.	 Type

(continues)
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14.	 What is the first argument in the PV present value function?
a.	 Type
b.	 Periods
c.	 Rate
d.	 Payment

15.	 Which of these IS NOT an available level of protection in Excel?
a.	 Excel-level protection
b.	 Workbook-level protection
c.	 Worksheet-level protection
d.	 Cell-level protection

16.	 When the Hidden option on the Protection tab of the Format Cells dialog box is checked, what IS NOT 
displayed in the worksheet?
a.	 Formulas
b.	 Labels
c.	 Values
d.	 Formula Results

17.	 Which of these IS NOT an option in the Protect Sheet dialog box?
a.	 Select unlocked cells
b.	 Format rows
c.	 Select locked sheets
d.	 Insert hyperlinks

18.	 On what tab is the Record Macro option found?
a.	 Insert
b.	 Formulas
c.	 Data
d.	 View

19.	 Which of these IS NOT an available level of security in Excel?
a.	 Disable all macros
b.	 Disable all macros except digitally signed macros
c.	 Disable all macros with notification
d.	 Disable all macros without notification

20.	 Which of these CANNOT be used to run a macro?
a.	 Shortcut keys
b.	 Custom buttons
c.	 Quick Access toolbar
d.	 Page Layout tab
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Reinforce Your Skills

EA8-R1  Create a Bond Amortization Schedule for Electronics 
Warehouse

In this exercise, you will complete a bond amortization schedule for Electronics Warehouse. You will 
calculate the bond characteristics and generate a schedule with key components. You will also protect 
worksheet elements and create a macro.

The bond is issued on 1/1/11, has a $200,000 face value, a 12-year life, semiannual interest payments, 
a contract interest rate of 8%, and an effective interest rate of 7%.

1.	 Open a Blank Workbook and save the file in your Chapter 08 folder as 
EA8-R1-Bond-[YourName].

2.	 Prepare the worksheet as indicated:

•	 Set the width of column A to 0.75 and the height of row 1 to 7.2.
•	 Merge and center the range B2:C2, add bold formatting, and enter Bond Details.
•	 In order, enter these headers in the range B3:B8: Date, Face Value, Contract 
Rate, Effective Rate, Life (years), Payments per Year.

•	 Apply center alignment to the range C3:C8.

Now you are ready to begin populating the worksheet with the bond data.

3.	 Enter this data and apply any indicated formatting:

In this cell: Type this: And add this formatting:

Cell C3 1/1/11

Cell C4 200000 Accounting number format

Cell C5 .08 Percent Style

Cell C6 .07 Percent Style

Cell C7 12

Cell C8 2

4.	 Highlight the range B2:C8 and choose Home→Font→Borders menu →Outside Borders; 
apply an outside border around cell B2.

5.	 Autofit column B then highlight the range C3:G3 and set the column width to 15.

6.	 Merge and center the range B10:C10, add bold formatting and outside borders, and enter 
Bond Calculations.

7.	 Enter this data:

Cell B11 Present Value

Cell C11 =PV(C6/C8, C7*C8, –C4*C5/C8, –C4)

Cell B12 Future Value

Cell C12 =-FV(C6/C8, C7*C8, -C4*C5/C8, C11)

Cell B13 Payment
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8.	 In cell C13, choose Formulas→Function Library→Insert Function, select the Financial 
category and the PMT function, and click OK.

9.	 Fill in the Function Arguments box as indicated, clicking OK when finished:

•	 Rate box: C6/C8
•	 Nper box: C7*C8 
•	 Pv box: C11 
•	 Fv box: –C4

10.	 With cell C13 still active, click in the Formula Bar between the equals sign and PMT and type a 
minus sign.

11.	 Apply the Accounting number format to the range C11:C13 and add an outside border 
around the range B10:C13.

Complete the Amortization Schedule

12.	 In the range B15:G15, set text wrapping and center alignment, apply an outside border, and 
add bold formatting.

13.	 In order, enter these headers in the range B15:G15: Date, Interest Payment, 
Interest Expense, Amortization of Bond Premium, Bond Premium 
Balance, Carrying Value.

14.	 Type 1/1/2011 in cell B16, 6/30/2011 in cell B17, and 12/31/2011 in cell B18.

15.	 Highlight the range B17:B18 and then drag the fill handle through cell B40.

16.	 In cell B41, type Totals and right-align the text.

17.	 Enter this data:

Cell F16 =C11-C12

Cell G16 =C11

Cell C17 =$C$13

Cell D17 =G16*$C$6/$C$8

Cell E17 =C17-D17

Cell F17 =F16-E17

Cell G17 =G16-E17

18.	 Copy the range C17:G17 and paste to the range C18:G40.

19.	 Highlight the range C41:E41 and choose Home→Editing→AutoSum, and then choose 
Home→Font→Borders menu →Top and Double Bottom Border.

20.	 Apply the Accounting number format to the range C16:G41. 

Protect a Workbook and a Worksheet

21.	 Choose Review→Changes→Protect Workbook and, if necessary, add a checkmark in the 
Structure checkbox.

22.	 Enter Protected as the password and click OK; confirm the password when prompted.

23.	 Choose Review→Changes→Protect Workbook, enter the password, and click OK.
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24.	 Choose Home→Cells→Format→Protect Sheet and, as necessary, add checkmarks next to 
the boxes for these options and click OK when finished:

•	 Protect Worksheet and Contents of Locked Cells 
•	 Select Locked Cells 
•	 Select Unlocked Cells
•	 Format Columns

25.	 Use a Ribbon command to set the width of cell C17 to 12.

26.	 Choose Review→Changes→Unprotect Sheet.

Protect Individual Cells

27.	 Highlight the ranges C3:C8 and B16:G41, and choose Home→Cells→Format→Lock Cell.

28.	 Highlight the range C11:C13, right-click, and choose Format Cells.

29.	 Switch to the Protection tab, check the box for Hidden, and click OK.

30.	 Choose Review→Changes→Protect Sheet and add the password Worksheet, confirming 
the password when prompted.

31.	 In cell G7, type k then click OK in the dialog box. 

32.	 Rename the Sheet1 tab to Bond Schedule.

Record and Run a Macro

33.	 Choose File→Options→Trust Center→Trust Center Settings→Macro Settings, ensure 
that Disable All Macros with Notification is selected, and click OK twice.

34.	 Delete the contents of the range C16:G41.

35.	 Choose View→Macros→Macros menu →Record Macro, enter Amortization _
Schedule as the macro name, and click OK.

36.	 Complete these actions in order for the new macro:

•	 Select cell F16, type =C11-C12, tap [Tab], type =C11, and tap [Enter].
•	 Select cell C17, type =$C$13, tap [Tab], type =G16*$C$6/$C$8, tap [Tab], type 
=D17-C17, tap [Tab], type =F16-E17, tap [Tab], type =G16+E17, and tap [Enter].

•	 Highlight the range C17:G17 and drag the fill handle through row 40.
•	 Enter =SUM(C17:C28) in cell C41.
•	 Copy cell C41 to the range D41:E41.

37.	 Click the Stop Recording button in the status bar.

38.	 Delete the contents of the range C16:G41 then choose View→Macros→Macros and click 
Run.

39.	 Choose Review→Changes→Unprotect Sheet, enter the password Worksheet, and tap 
[Enter].

40.	 Choose Insert→Illustrations→Shapes, click the Text Box shape, and draw a text box over 
the range E2:E5.

41.	 Type Populate Schedule in the text box, add italic formatting format, and set the font 
size to 16.
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42.	 Right-click the text box, choose Assign Macro, click Amortization_Schedule in the list, and 
click OK.

43.	 Choose Review→Changes→Protect Sheet and enter Finalized as the password, 
confirming when prompted.

44.	 Delete the contents of the range C16:G41 and then click the text box to run the macro.

45.	 Save your file as a Macro-Enabled Workbook and then close it.

EA8-R2  Create a Bond Amortization Schedule for Software 
Developers Co.

In this exercise, you will complete a bond amortization schedule for Software Developers Co. You will 
calculate the bond characteristics and generate a schedule with key components. You will also protect 
worksheet elements and create a macro.

The bond is issued on 1/1/13, has a $180,000 face value, a 4-year life, quarterly interest payments, a 
contract interest rate of 9%, and an effective interest rate of 10%.

1.	 Open a Blank Workbook and save the file in your Chapter 08 folder as 
EA8-R2-Bond-[YourName].

2.	 Prepare the worksheet as indicated:

•	 Set the width of column A to 0.75 and the height of row 1 to 7.2.
•	 Merge and center the range B2:C2, add bold formatting, and enter Bond Details.
•	 In order, enter these headers in the range B3:B8: Date, Face Value, Contract 
Rate, Effective Rate, Life (years), Payments per Year.

•	 Apply center alignment to the range C3:C8.
Now you are ready to begin populating the worksheet with the bond data.

3.	 Enter this data and apply any indicated formatting:

In this cell: Type this: And add this formatting:

Cell C3 1/1/13

Cell C4 180000 Accounting number format

Cell C5 .09 Percent Style

Cell C6 .1 Percent Style

Cell C7 4

Cell C8 4

4.	 Highlight the range B2:C8 and choose Home→Font→Borders menu →Outside Borders; 
apply an outside border around cell B2.

5.	 Highlight the range B3:G3 and use the Ribbon to change the column width to 15.

6.	 Merge and center the range B10:C10, add bold formatting and outside borders, and enter 
Bond Calculations.
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7.	 Enter this data:

Cell B11 Present Value

Cell C11 =PV(C6/C8, C7*C8, –C4*C5/C8, –C4)

Cell B12 Future Value

Cell C12 =-FV(C6/C8, C7*C8, -C4*C5/C8, C11)

Cell B13 Payment

8.	 In cell C13, choose Formulas→Function Library→Insert Function, select the Financial 
category and the PMT function, and click OK.

9.	 Fill in the Function Arguments box as indicated, clicking OK when finished:

•	 Rate box: C6/C8
•	 Nper box: C7*C8 
•	 Pv box: C11 
•	 Fv box: –C4

10.	 With cell C13 still active, click in the Formula Bar between the minus sign and PMT and type a 
minus sign.

11.	 Apply the Accounting number format to the range C11:C13 and add outside borders to the 
range B10:C13.

Complete the Amortization Schedule

12.	 In the range B15:G15, set text wrapping and center alignment, apply an outside border, and 
add bold formatting.

13.	 In order, enter these headers in the range B15:G15: Date, Interest Payment, 
Interest Expense, Amortization of Bond Discount, Bond Discount 
Balance, Carrying Value.

14.	 Type 1/1/2013 in cell B16, 3/31/2013 in cell B17, 6/30/2013 in cell B18, 9/30/2013 in 
cell B19, and 12/31/2013 in cell B20.

15.	 Highlight the range B17:B20 and then drag the fill handle through cell B32.

16.	 In cell B33, type Totals and right-align the text.

17.	 Enter this data:

Cell F16 =C12-C11

Cell G16 =C11

Cell C17 =$C$13

Cell D17 =G16*$C$6/$C$8

Cell E17 =D17-C17

Cell F17 =F16-E17

Cell G17 =G16+E17

18.	 Copy the range C17:G17 and paste to the range C18:G32.

19.	 Highlight the range C33:E33 and choose Home→Editing→AutoSum, and choose 
Home→Font→Borders menu →Top and Double Bottom Border.

20.	 Apply the Accounting number format to the range C16:G33. 
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Protect a Workbook and a Worksheet

21.	 Choose Review→Changes→Protect Workbook and, if necessary, add a checkmark in the 
Structure checkbox; click OK.

22.	 Turn off protection by choosing Review→Changes→Protect Workbook.

23.	 Choose Home→Cells→Format→Protect Sheet and, as necessary, add checkmarks in the 
boxes next to these options:

•	 Protect Worksheet and Contents of Locked Cells 
•	 Select Locked Cells 
•	 Select Unlocked Cells
•	 Format Columns

24.	 Enter Accounting as the password and click OK; confirm the password when prompted.

25.	 Use the right-click method to change the width of column C to 12; autofit column B.

26.	 Choose Review→Changes→Unprotect Sheet, enter the password, and click OK.

Protect Individual Cells

27.	 Highlight the ranges C3:C8 and B16:G33, and choose Home→Cells→Format→Lock Cell.

28.	 Highlight the range C11:C13, right-click, and choose Format Cells.

29.	 Switch to the Protection tab, check the box for Hidden, and click OK.

30.	 Choose Review→Changes→Protect Sheet and add the password Excel, confirming when 
prompted.

31.	 In cell G7, type w then click OK in the dialog box. 

32.	 Rename the Sheet1 tab to Bond Schedule.

Record and Run a Macro

33.	 Choose File→Options→Trust Center→Trust Center Settings→Macro Settings, ensure 
that Disable All Macros with Notification is selected, and click OK twice.

34.	 Delete the contents of the range C16:G33.

35.	 Choose View→Macros→Macros menu →Record Macro, enter Amortization _
Schedule as the macro name, and click OK.

36.	 Complete these actions in order for the macro:

•	 Select cell F16, type =C12-C11, tap [Tab], type =C11, and tap [Enter].
•	 Select cell C17, type =$C$13, tap [Tab], type =G16*$C$6/$C$8, tap [Tab], type 
=D17-C17, tap [Tab], type =F16-E17, tap [Tab], type =G16+E17, and tap [Enter].

•	 Highlight the range C17:G17 and drag the fill handle through row 32.
•	 Enter =SUM(C17:C32) in cell C33.
•	 Copy cell C33 to the range D33:E33.

37.	 Click the Stop Recording button in the status bar.

38.	 Delete the contents of the range C16:G33 and then choose View→Macros→Macros and 
click Run.
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39.	 Choose Review→Changes→Unprotect Sheet, enter the password Excel, and tap [Enter].

40.	 Choose Insert→Illustrations→Shapes, click the Text Box shape, and draw a text box over 
the range E2:E5.

41.	 Type Populate Schedule in the text box, add bold formatting, and set the font size to 16.

42.	 Right-click the text box, choose Assign Macro, click Amortization_Schedule in the list, and 
click OK.

43.	 Choose Review→Changes→Protect Sheet and enter Macro as the password, confirming 
when prompted.

44.	 Delete the contents of the range C16:G33 and then click the text box to run the macro. 

45.	 Save your file as a Macro-Enabled Workbook and then close it.
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Apply Your Skills

EA8-A1  Create a Bond Amortization Schedule for Kim’s Kitchen

In this exercise, you will complete a bond amortization schedule for Kim’s Kitchen. You will calculate 
the bond characteristics and generate a schedule with key components. You will also protect worksheet 
elements and create a macro.

The bond is issued on 1/1/10, has a $120,000 face value, a 7-year life, semiannual interest payments, a 
contract interest rate of 12%, and an effective interest rate of 10%.

1.	 Open a Blank Workbook and save the file in your Chapter 08 folder as 
EA8-A1-Bond-[YourName].

2.	 Change the width of column A to 0.75 and the height of row 1 to 7.2.

3.	 Merge and center the range B2:C2 and type Bond Details in the merged cell.

4.	 In the range B3:B8, enter the descriptions Date, Face Value, Contract Rate, 
Effective Rate, Life (years), and Payments per Year.

5.	 Enter the bond details in the range C3:C8; center these entries.

6.	 Apply borders to the appropriate locations in the range B2:C8.

7.	 Adjust the column width of columns B–G to 15.

8.	 Merge and center the range B10:C10 and type Bond Calculations in the merged cell.

9.	 In the range B11:B13, enter the descriptions Present Value, Future Value, and 
Payment.

10.	 In the range C11:C13, enter appropriate formulas that solely contain cell references and apply 
the Accounting number format.

11.	 Apply borders to the appropriate locations in the range B10:C13.

Complete the Amortization Schedule

12.	 In the range B15:G15, set text wrapping and center alignment, apply an outside border, and 
add bold formatting.

13.	 In the range B15:G15, enter the column descriptions for the bond amortization schedule.

14.	 In the range B16:B18, enter dates for the bond issuance and the first two interest payments.

15.	 Apply additional dates as appropriate in column B.

16.	 Type appropriate formulas in the necessary cells in rows 16–17 of the bond amortization 
schedule.

17.	 Copy the formulas in row 17 to the remaining rows in the bond amortization schedule.

18.	 In column B below the final populated row of the bond amortization schedule, enter Totals 
and right-align the text.

19.	 Use AutoSum in the Totals row to calculate the appropriate columns and apply the 
Accounting number format.

20.	 Add appropriate borders to the entire bond amortization schedule.  
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Protect a Workbook and a Worksheet

21.	 Use the Protect Workbook command and apply a password.

22.	 Turn off workbook protection.

23.	 Use the Protect Worksheet command, ensure that all cells can be selected and all columns can 
be formatted while worksheet protection is on; apply a password.

24.	 Set the width of column C to 12 and autofit the width of column B.

25.	 Turn off worksheet protection.

Protect Individual Cells

26.	 Toggle off the Lock Cell command for all cells in the Bond Details and bond amortization 
schedule sections.

27.	 Hide the formulas in the Bond Calculations section.

28.	 Use the Protect Worksheet command, ensure that all cells can be selected while worksheet 
protection is on; apply a password. 

29.	 Rename the worksheet to Bond Schedule.

Record and Run a Macro

30.	 Ensure that Disable All Macros with Notification is the active macro setting.

31.	 Delete all data in the bond amortization schedule except the dates and headers.

32.	 Record a macro that populates the bond amortization schedule, applying an appropriate name 
for the macro. 

33.	 Delete all data in the bond amortization schedule except the dates and headers then run your 
macro.

34.	 Unprotect the worksheet.

35.	 Insert a text box from which to run the macro in an appropriate location and add an appro-
priate name in bold; assign your macro to the text box.

36.	 Use the Protect Worksheet command, ensure that all cells can be selected while worksheet 
protection is on; apply a password. 

37.	 Delete all data in the bond amortization schedule except the dates and headers then use the 
text box to run your macro.

38.	 Save your file as a Macro-Enabled Workbook then close it.
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EA8-A2  Create a Bond Amortization Schedule for Cubby 
Manufacturing

In this exercise, you will complete a bond amortization schedule for Cubby Manufacturing. You will 
calculate the bond characteristics and generate a schedule with key components. You will also protect 
worksheet elements and create a macro.

The bond is issued on 1/1/12, has a $60,000 face value, a 5-year life, quarterly interest payments, a 
contract interest rate of 12%, and an effective interest rate of 14%.

1.	 Open a Blank Workbook and save the file in your Chapter 08 folder as 
EA8-A2-Bond-[YourName].

2.	 Change the width of column A to 0.75, and the height of row 1 to 7.2.

3.	 Merge and center the range B2:C2 and type Bond Details in the merged cell.

4.	 In the range B3:B8, enter the descriptions Date, Face Value, Contract Rate, 
Effective Rate, Life (years), and Payments per Year.

5.	 Enter the bond details in the range C3:C8; center these entries.

6.	 Apply border to the appropriate locations in the range B2:C8.

7.	 Adjust the column width of columns B–G to 15.

8.	 Merge and center the range B10:C10 and type Bond Calculations in the merged cell.

9.	 In the range B11:B13, enter the descriptions Present Value, Future Value, and 
Payment.

10.	 In the range C11:C13, enter appropriate formulas that solely contain cell references and apply 
the Accounting number format.

11.	 Apply borders to the appropriate locations in the range B10:C13.

Complete the Amortization Schedule

12.	 In the range B15:G15, set text wrapping and center alignment, apply an outside border, and 
add bold formatting.

13.	 In the range B15:G15, enter the column descriptions for the bond amortization schedule. 

14.	 In the range B16:B18, enter dates for the bond issuance and the first two interest payment 
dates.

15.	 Apply additional dates as appropriate in column B.

16.	 Type appropriate formulas in the necessary cells in row 16–17 of the bond amortization 
schedule.

17.	 Copy the formulas in row 17 to the remaining rows in the bond amortization schedule.

18.	 In column B below the final populated row of the bond amortization schedule, enter Totals 
and right-align the text.

19.	 Use AutoSum in the Totals row to calculate the appropriate columns and apply the 
Accounting number format.

20.	 Add appropriate borders to the entire bond amortization schedule.  
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Protect a Workbook and a Worksheet

21.	 Use the Protect Workbook command and apply a password.

22.	 Turn off workbook protection.

23.	 Use the Protect Worksheet command, ensure that all cells can be selected and all columns can 
be formatted while worksheet protection is on; apply a password.

24.	 Set the width of column C to 12 and autofit the width of column B.

25.	 Turn off worksheet protection.

Protect Individual Cells

26.	 Toggle off the Lock Cell command for all cells within the Bond Details and bond amortization 
schedule sections.

27.	 Hide the formulas in the Bond Calculations section.

28.	 Use the Protect Worksheet command, ensure that all cells can be selected while worksheet 
protection is on; apply a password.

29.	 Rename the worksheet to Bond Schedule.

Record and Run a Macro

30.	 Ensure that Disable All Macros with Notification is the active macro setting.

31.	 Delete all data in the bond amortization schedule except the dates and headers.

32.	 Record a macro that populates the bond amortization schedule, applying an appropriate name 
for the macro. 

33.	 Delete all data in the bond amortization 
schedule except the dates and headers then run your macro.

34.	 Unprotect the worksheet.

35.	 Insert a text box from which to run the macro in an appropriate location and add an appro-
priate name in italic; assign your macro to the text box.

36.	 Use the Protect Worksheet command, ensure that all cells can be selected while worksheet 
protection is on; and apply a password.

37.	 Delete all data in the bond amortization schedule except the dates and headers then run your 
macro.

38.	 Save your file as a Macro-Enabled Workbook then close it.



114  Excel for Accounting  Chapter 8: Bond Amortization

Extend Your Skills

EA8-E1  Complete a Bond Amortization Schedule for Townline 
Construction

In this exercise, you will complete a bond amortization schedule for Townline Construction. You will 
calculate the bond characteristics and generate a schedule with key components. You will protect 
worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the 
bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details 
for a bond with a $260,000 face value, a 4-year life, semiannual interest payments, a contract 
interest rate of 10%, and an effective interest rate of 11%. The bond is issued on 1/1/13. (Hint: 
Values must be entered here so they can be used in subsequent formulas.)

Enter bond calculations for the present and future values and the payments in the range B10:C13. 
The future value and payment calculations will generate results that match figures given above; you 
complete these calculations to check your work. Create a bond amortization schedule beginning 
in cell B15. Use headers that are consistent with those used in this chapter. Calculate totals for the 
appropriate columns.

Protect the workbook structure and apply a password. Modify cell protection for all cells containing 
formulas in column G such that formulas are hidden. Then protect the worksheet by only allowing 
users to select locked and unlocked cells, and insert hyperlinks; apply a password.

Record a macro that generates every formula in the worksheet after the bond details (in the range 
B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box 
in an appropriate location, add an appropriate name in the text box, and assign the macro to this 
text box. Save your file as a Macro-Enabled Workbook.

EA8-E2  Complete a Bond Amortization Schedule for Stationary 
Specialists

In this exercise, you will complete a bond amortization schedule for Stationary Specialists. You will 
calculate the bond characteristics and generate a schedule with key components. You will protect 
worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the 
bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details 
for a bond with a $140,000 face value, a 6-year life, quarterly interest payments, a contract interest 
rate of 8%, and an effective interest rate of 7%. The bond is issued on 1/1/11. (Hint: Values must be 
entered here so they can be used in subsequent formulas.)

Enter bond calculations for the present and future values and the payments in the range B10:C13. 
The future value and payment calculations will generate results that match figures given above; you 
complete these calculations to check your work. Create a bond amortization schedule beginning 
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in cell B15. Use headers that are consistent with those used in this chapter. Calculate totals for the 
appropriate columns.

Protect the workbook such that worksheets cannot be reordered, copied, or deleted. Modify cell 
protection for all cells containing formulas in column G such that the formulas are hidden. Protect 
the worksheet by only allowing users to format cells, columns, and rows; apply a password.

Record a macro that generates every formula in the worksheet after the bond details (in the range 
B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box 
in an appropriate location, add an appropriate name in the text box, and assign the macro to this 
text box. Save your file as a Macro-Enabled Workbook.

EA8-E3  Complete a Bond Amortization Schedule for Dan’s 
Refinishing

In this exercise, you will complete a bond amortization schedule for Dan’s Refinishing. You will 
calculate the bond characteristics and generate a schedule with key components. You will protect 
worksheet elements and create a macro.

Start a new file. Reduce the width of column A to 0.75 and the height of row 1 to 7.20. Enter the 
bond details in the range B2:C8. Include a centered header and appropriate titles. Enter the details 
for a bond with a $200,000 face value, a 8-year life, semiannual interest payments, a contract 
interest rate of 7%, and an effective interest rate of 9%. The bond is issued on 1/1/09. (Hint: Values 
must be entered here so they can be used in subsequent formulas.)

Enter bond calculations for the present and future values and the payments in the range B10:C13. 
The future value and payment calculations will generate results that confirm figures given above; you 
complete these calculations to check your work. Create a bond amortization schedule beginning in 
cell B15. Use headers that are consistent with those used in this chapter. Calculate totals only for the 
appropriate columns.

Protect the workbook such that the worksheets cannot be copied, reordered, or deleted. Apply a 
password when protecting the workbook. Modify cell protection for all cells containing formulas in 
columns F–G such that the formulas are hidden. Then protect the worksheet by only allowing users 
to sort data.

Record a macro that generates every formula in the worksheet after the bond details (in the range 
B2:C8) and dates have been entered. Run the macro to ensure it operates properly. Insert a text box 
in an appropriate location, add an appropriate name in the text box, and assign the macro to this 
text box. Save your file as a Macro-Enabled Workbook.
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Critical Thinking

EA8-C1  Discuss Worksheet Protection

Protection can be used at multiple levels to protect workbooks, worksheets, and individual cells. In 
the case of the bond amortization schedule, this protection ensures that users only adjust certain 
cells and cannot inadvertently alter elements that should remain static. However, a bond amor-
tization schedule is not the only worksheet for which protection is appropriate. Depending on 
factors such as the frequency with which a worksheet is disseminated and the number of users with 
access to the file, various levels of protection can be beneficial for many of the accounting-related 
spreadsheets.

Write a paragraph of at least five sentences to identify four types of accounting worksheets (other 
than the bond amortization schedule) within which some level of protection would be appropriate. 
Write a second paragraph of at least eight sentences to discuss why that protection is appropriate 
and what level of protection you would implement for each.

EA8-C2  Discuss Macros and Worksheet Automation 

Efficiency is a key goal when completing any Excel worksheet. As the size and scope of the schedule 
grows, taking an efficient approach to populating it becomes increasingly vital. In the case of the 
bond amortization schedule, you have seen how macros can be used to complete the entire body of 
the schedule. Macros can similarly be used in other accounting-related spreadsheets that contain 
repetitious and/or predictable elements.

Consider how macros can be used to increase efficiency. Write a paragraph of at least four sentences 
in which you identify three accounting-related spreadsheets (other than the bond amortiza-
tion schedule) that can benefit from the use of macros. Write a second paragraph of at least five 
sentences to discuss how macros can be used in each worksheet to improve the manner in which 
they are populated.
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